%%LocalItemTitle%%

XML Einrichten Version 1.2
Elements
Element | Description
DesadvMessage | Mesage: Delivery note (DESADV)
InvoiceMessage | Mesage: Invoice (INVOIC)
InvrptMessage | Mesage: Inventory (INVRPT)
OrdchgMessage | Mesage: Order Change (ORDCHG)
OrderMessage | Mesage: Order (ORDERS)
OrdrspMessage | Message: Order Resopons (ORDRSP)
OstrptMessage | Mesage: Order status report (OSTRPT)
RecadvMessage | Mesage: Receiving advice(RECADV)
RemadvMessage | Mesage: Remittance advise (REMADV)
Complex Types
Complex Type | Description
AccountingPeriodDate | Start or end date of the accounting period
ActualDeliveryDate | Actual delivery date
AdditionalLineReferences | Enter subsequent additional information related to a position
Adjustment | Berichtigung Correction
AdvisedDeliveryDate | Advised Delivery date/time
BorderCrossing | Border Crossing Number
BordercrossingDate | Date of Border Crossing
CashDiscount | Cash Discount defined by Date percentage and/or amount
ClassOfGoods | Categorization of a product by categorization schema type, feature and option
CNDF | Segment for conditions for the complete document
CNDL | Segment for conditions for a single position
CODL | Handling instructions for a position
ConfirmedDeliveryDate | Confirmed delivery date
Contact | Group for contact information
ContactCommunication | Group for communication data of a contact person
CurrencyValue | Amount defined by decimal value and currency
DELTIMES | Segment for delivery times
DespatchAdviceDate | Date of the delivery note
DespatchAdviceLine | Position within the delivery note
DespatchAdviceNumberRef | reference to the dispatch advise number
DespatchDate | Goods issue date
DespatchNumberRef | Referenc to the dispatch number
DiscountsConditionsTotal | Total amount for all conditions on head or line level
DocumentFoot | Foot section of the message
DocumentHead | Head of the document
DocumentLineReference | reference to a position of another document
DocumentLineReferenceQualified | Reference to other documents variable defined by qualifier
DocumentPaci
Information about the packaging pieces
Hint for the ORDRSP:
Pieces which contain more than one article position are defined below the first article position within the piece
DocumentPaciLine | Link between LINE and PACI (n..m)
DocumentReference
Reference to another document or process
How to transfer for example ExcalibuR Idents?
DocRefNumber = GeoID or ConfigID
DocDate = Date of transfer from XCR
DocumentReferenceQualified | Reference to other documents variable defined by qualifier
DueDate | Due date
Duration
Duration
Code list:
803 = Weeks
804 = Days
805 = Hours
806 = Mminutes
EDIDate | variable definition of a date format by format code
EDIDateQualified
format description for a date info
102 = "CCYYMMDD"
203 = "CCYYMMDDHHMM"
616 = "CCYYWW"
EndConsumer | Information about the end-consumer
EndCustomerOrderLine | Position within the order of the end-consumer
FII | Group for financial information
GrossLineAmount | Attention - Do not use anymore. will be cancelled in further versions
GrossUnitPrice | Gross price
HTXT | Segment for textual information within the head of the message
InvoiceAmount | Total amount if the invoice including all taxes from all tax rates
InvoiceDate | Date of the invoice
InvoiceListDate | date of the consolidated invoice list
LastChangeDate | Last possible date for change of the order
LineAmount | not on detail defined position amount)
LineAmountQualified | by code defined position amount)
LTXT | Segment for textual information for a position
MEA | Group for measurement information
MessageVersion | Format Version and handling
MULH | Segment for multimedia information for the document
MULL | Segment for multimeda information for a single position
MVMT | Inventory movements
NAD | Segment for address information
NetItemAmount | sum of all net position amounts
NetLineAmount | Net amount of a position (Net price*Quantity)
NetUnitPrice | Net price of an unit
OpeningPeriod
Opening Hours, period during which a contact is available
DTM+306 = Working period
Qualifier 720 = THHMMTHHMM T=1=Monday
OPT | Segment for information about features and options for a single position
Option | Subsequent to a feature information
OrderLine | Line within an order
OrderLineNumberEndCustomer | Line within an order of an end-consumer
OrderNumber | Number of an order
OrderResponseDate | Date of the an order response
OrderResponseLine | Line within an order response
OrderResponseNumberRef | reference to the number of the order response
OriginalOrder | Reference to the original order
PaymentDate | Date of payment
PickUpDate | Pick up date
PreCustomerOrder | Number of the customer order in a previous system
PreCustomerOrderLine | Number of position within the customer order in a previous system
PrevInvoice | Number of the previous invoice
PrevOrderResponse | Number of the previous order response
Price | Price information
PriceQualified | Price information with a defined price type by a qualifier
ProcessingStates
Processig stat within serveral processing types
-----------------------------------------------
Mapping für Bahag
Category=2,Code=002:STS+1+5 = (MUSS)Bestellung erhalten
Category=2,Code=102:STS+1+275 = (MUSS)Stornoanfrage des Kunden bestätigt
Category=2,Code=103:STS+1+71 = (MUSS)Storno durch Kunde nicht mehr möglich
Category=2,Code=104:STS+1+56 = (MUSS)Storno durch Lieferant
Category=1,Code=201:STS+1+24 = (MUSS)Ware versendet
Category=1,Code=202:STS+1+21 = (MUSS)Ware mit Spedition versendet
Category=1,Code=301:STS+1+64 = (MUSS)Abholauftrag für Retoure erhalten
Category=1,Code=302:STS+1+82 = (MUSS)Retoure: Ware vor Ort
Category=1,Code=303:STS+1+13 = (KANN)Endkunde: Abholtermin bestätigt
Category=1,Code=401:STS+1+216 = (KANN)Endkunde nicht erreicht - schriftliche Benachrichtigung zur Terminavisierung
Category=1,Code=402:STS+1+243 = (KANN)Endkunde: Terminavisierung nicht möglich
Category=1,Code=403:STS+1+209 = (KANN)Endkunde: Liefertermin bestätig
Category=1,Code=404:STS+1+212 = (KANN)Endkunde: Liefertermin geändert
Category=1,Code=405:STS+1+210 = (KANN)Endkunde: Nicht angetroffen - zweite Lieferung avisiert
Category=1,Code=406:STS+1+325 = (KANN)Endkunde: Annahme der Lieferung verweigert
Category=1,Code=407:STS+1+73 = (KANN)Endkunde: Lieferung unvollständig - Nachlieferung avisiert
Category=3,Code=501:STS+1+80 = (MUSS)Retoure: Prüfung wurde bestanden
Category=3,Code=502:STS+1+81 = (MUSS)Retoure: Prüfung wurde nicht bestanden
Category=3,Code=503:STS+1+218 = (KANN)Endkunde:Ware beschädigt
Category=5,Code=601:FTX+ZZZ:1 = (MUSS)Kunde wünscht Gutschrift
Category=5,Code=602:FTX+ZZZ:2 = (MUSS)Kunde wünscht Ersatzlieferung
-----------------------------------------------
Mapping für Otto
Auftrag
Category=1,Code=201: SENT
Category=2,Code=101: CANCELED_BY_OTTO
Category=2,Code=104, Reason=001: CANCELED_TIMEOUT
Category=2,Code=104, Reason=101: CANCELED_NOT_AVAILABLE
Retoure
Category=1,Code=302: ARRIVED
Category=3,Code=501: ACCEPTED
Category=3,Code=502: REJECTED
ProductIdentifier | Identification information for an article
Quantity | Quantity
QuantityQualified | Qualified quantity
ReceivingPaci | Informationen zum gebuchten Wareneingang Information about the received packages
RequestedDeliveryDate | Requested delivery date
ShippingDate | goods issue date/time
Textinformation | Qualified text information
Times | Zeitenangaben in den Lieferzeiten Times within the delivery times section
TotalAmount | Total amount
TotalAmountQualified | Qualified total amount
TotalLineAmount | Total amountof a position
UnitValue | Unit value
ValueDate | Value date
Vat | Group to describe a tax
VatTotal | Sum of all tax amounts
Weight | Weight
Simple Types
Simple Type | Description
Availability
Availabilty of the products
71 = Available
72 = Not Available
BarcodeNumber | Unique barcode for this document
BatchNumber | Batch Number
BusinessCustomerNumber | Internal number of the buyer at the manufacturer
CatalogID | Catalogue Ident for the catalogue from which the order has been produced
ClassOfGoodsFeature | Feature
ClassOfGoodsType
classification schema
HS = customs tariff number
NB = Batch Number
STQ = eCl@ss
ClassOfGoodsValue
value within a classification
1. Ident within a classification (ClassofGoodsFeature stays empty)
2. option value for the specified feature (ClassofGoodsFeature is defined)
Commission | Name (number) of the commission
CorrectionReason
Resaon for the correction
Grund für die Berichtigung
Code list:
1 = Vereinbarte Regulierung
7 = Akontozahlung
8 = Inklusive Gebühr für Mehrwegverpackung
17 = Transportschaden
19 = Handelsrabatt
21 = Werbekostenzuschuss
38 = Bonus
40 = Abzugsfähige Frachtkosten
15E = Delkredere
16E = Skonto
36E = Ständer- oder Regalauffüllservice
37E = Außerordentlicher Werbeservice
38E = Unterschiede im Steuersatz
Currency | currency coded. for example EUR
DeliveryCondition
Delivery Conditions. Use the following code list
04E = Cash on delivery
DespatchAdviceNumber | despatch advise number
DespatchNumber | Dispatch number
DirectionOfMovement
Movement of inventory
Code list:
1 = from stock
2 = to stock
DischargingTime | Discharging Time
DischargingTimeMeasureUnit | DTime unit for the discharging Time
DocumentFunctionSymbol
Document functional symbol
Code list:
DocumentNumber | Number of this document
DocumentReferenceQualifier
Qualified reference to another content
Code list:
ABO = Reference to to the commission
DQ = Reference to the despatch advise number
IV = Reference to the Invoice
LI = Reference to the position
ON = Reference to the order
POR = Reference to the order response
XCG = Reference to the GeoID(XcalibuR)
XCC = Reference to the ConfigID(XcalibuR)
FCID = Reference to the FurncloudID(furnplan)
FSC = Reference to the FSC Certificate
PEFC = Reference to the PEFC Certificate
DocumentType
Type of the document
Code liste
35 = Inventory report
163 = Receiving advice
220 = Order
22E = Order generated by manufacturer
230 = Order response change
231 = Order Response
256 = Delivery Time report
348 = Order Status Report
351 = Dispatch advise
380 = Invoice
381 = Credit note
481 = Remittance advise
610 = Forwarding order
73E = Sales report
EDIDateFormatCode
Code for the description of an date format
Code list:
102 = CCYYMMDD
201 = YYMMDDHHMM
615 = YYWW
616 = CCYYWW
720 = THHMMTHHMM
804 = Number of dayse
Example <DocumentDate FormatCode="102">20160331</DocumentDate>
EDIDateQualifier
Code for the type of adate
Code list:
2 = Recommended delivery date
3 = Invoice date
4 = Order date
11 = Delivery datum
18 = date of assembly installation
35 = real delivery date
48 = Duration
63 = Latest delivery data
64 = Earliest delivery date
69 = Promised delivery date
76 = Confirmed delivery date
79 = Goods issue date
137 = date of the document
138 = Payment date
157 = Information valid from
171 = Reference date
209 = Value date
743 = Latest possible order changing date
EmployeeID | Employee ID of the salesman
ExchangeRate | Exchange Rate
GoodsCountry | Country of origin
GoodsReceiptNumber | Number of the goods receipt document
IndicatorForDocumentLine
InstructionsConsumer | Instruction for the end consumer
InventoryMethod
Method of inventory rating
Code list:
1 = booked inventory
2 = counted inventory
InventoryQuantityUnit | Quantity unit of invetory
InventoryType
Type of inventory
Code list:
1 = Accepted inventory
2 = damaged inventory
3 = Customs inventory
4 = reserved Inventory
InvoiceListNumber | Number of the invoice summary list
InvoiceNumber | Number of the invoice
LicencePlateTrailer | Plate of the trailer
LicencePlateTruck | Plate of the truck
Liefermeldungsnummer | Number of the dispatch advise
LineAmountQualifier
Amount of the position
Code list:
66 = Net value = Gross price*Quantity - Conditions
203 = Gross value = Gross price*Quantity Remark: No Tax included
131 = Sum of all discounts and allowances
LineItemNumber | Number of position in a document
LoadingTackle | Loading Tackle
LocationOfGoods | Location of goods
NumberOfPackages | Number of packing pieces
NumberOfTheLeadWireSeal | Seal identifier
Orderability
Is it possible to order the product
71 = yes
72 = No
OrderResponseLineItemNumber | Number of position in an order response
OrderResponseNumber | Number of the order response
OrderType
Type of the order
Code ist:
FURN000 = Standard order for stock delivery
FURN050 = Standard order in commission
FURN100 = Promotional goods
FURN200 = Basic equipment
FURN210 = Sample
FURN250 = new opening
FURN300 = Spare parts delivery free of charge
FURN350 = Spare parts delivery free with charge
FURN400 = Complaint order
PackingPieceNumber | Number of the packing piece
PartialDelivery
Restrictions on partial delivery
Code list:
X2 = Partial delivery with subsequent delivery allowed
X1 = Partial delivery without subsequent delivery allowed
144 = KPartial delivery disallowed
PaymentType | Type of payment
PaymentWay | Way of payment
PointOfSale | Point of Sale (Identification by GLN possible)
PositionFunctionSymbol
Flag how to process the Position especially in the ORDCHG - Please refer to the Anwendungsempfehlung
Head = 1: Cancellation of the total order - all positions are canceled
Head = 4: Message contains changed information on header or positions - All positions or only positions with changes could be transmitted
Head = 5: Replacement. All positions will be transmitted. Accurate image of the new order
Head = 20: Change in Head: Changes only in delivery date or delivery location
Use the following codes for the Position Function Symbol
1 = Position added (valid if HEAD = 4)
2 = Position canceled (valid if HEAD = 1,4)
3 = Position modified (valid if HEAD = 4,5)
11 = Position unmodified (valid if HEAD = 4,20)
PrepaidAmountOfLine | Prepaid amount on position
PriceQualifier
Codes for definition of pricetypes
Code list:
AAA = Net price
AAB = Gross price
INF = Imformation only. not billed
PromotionalGoodsNumber
PromotionNumber | Identification of the promotion
QTYVar
Information whether a product is variable in quantity
Code list:
VQ = yes
= no
QuantityQualifier
Code for definition of the type of a quantity
Code list:
12 = Delivered quantity
21 = ordered quantity
35 = Price calculation quantity
47 = Billed quantity
53 = Minimum order quantity
54 = Maximum order quantity
131 = confirmed order quantity
129 = Units per unit price
131 = Delivered quantity
182 = canceled quantity
RemittanceAdviceNumber | Number of the remittance advise
SerialNumber | Serial Number
ShippingMark | Mark in the shipped package
StackType | Type of stack
TaxId | Tax Identification number
TechnicalReceiver | Technical partner of the document (GLN)
TerminalNumber | Number of the Cash register
TotalAmountQualifier
Code for deinition of a total document amount
Code list:
22 = Cash on delivery amount
44 = Delivery value
77 = Total Invoice amount = 125+124
79 = Sum of all Net Line Amounts = (Type 66)
86 = Total document amount = 125+124-113
131 = Sum of all charges and allowances
125 = Taxable amount = 79 - 131
124 = Sum of all taxes
113 = Sum of all prepayments
TourNumber | Number of the (delivery) tour
TypeOfPackaging
Type of packaging
GS1: http://www.gs1.se/eancom_2002/ean02s4/user/part3/dc8m.htm
Code list:
09= Pallet that must be returned
201= Euro pallet
CT=carton
PK=Package generaln
TypeOfProduct
type of product
Code list:
BA = Basic product doe variant definition
TU = Trading unit
NO = Nor order product, Packaging, Service
PR1 = Bonus Pack - not ordered but delivered and not billed
NDU = No delivery unit
FMD = Article of another manufacturer
SER = Service
TypeOfQuantityDeviation | type and reason for a quantity deviation
TypeOfShippingMark
Type of shipping mark SSCC
Code list:
BJ = NVE
TypeOfTransportCondition
Conditions fpr transport
Code list:
5 = Standard
12 = Special agreements
TypeOfTransportNature
type of the goods in transport
Codeliste:
12 = Standard
11 = Dangerous goods
TypeOfTransportService
Transport Services
Code list:
5 = Standard: The cargo has to be delivered as instructed
20 = Retrieval
37 = assembly service
59 = 2 Men Handling
?? = 4 Men Handling
TypeOfTransportVelocity
Transport Geschwindigkeit
Codeliste:
1 = Express
2 = High Speed
3 = Standard
4 = according to contract with the carrier
Unit | Unit
VATId | Sales tax identification number
VatPercentage | Tax rate
WorkflowDestination
workflow instructions referencing to the starting point: order message
D = Drop Shipping to an endconsumer. Delivery address in NAD + UC
L = Lagerauftrag. Delivery to a stock. Delivery address in NAD + DP
CD= Crossdocking. Delivery to a crossdocing stock. Delivery address in NAD + DP
ZRNumber | Number at Zentralregulierer

© 2023 IWOfurn Service GmbH. All Rights Reserved.

Senden Sie uns hier Ihre Kommentare und Verbesserungsvorschläge


DesadvMessage Element
XML Einrichten Version 1.2 : DesadvMessage Element
Description
Mesage: Delivery note (DESADV)
Namespace (none)
Diagram
DESADV Element Sequence DesadvMessage Element
Overview
DesadvMessage
Mesage: Delivery note (DESADV)
Sequence
DESADV 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the delivery note (DESADV)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Commission optional Commission Simple Type
OrderResponseRef optional OrderResponseNumber Simple Type
BorderCrossingRef optional BorderCrossing Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DespatchDate optional DespatchDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ShippingDate optional ShippingDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
UnloadingDuration optional Duration Complex Type
Unit optional Unit Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
Weight optional MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Volume optional MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
LicencePlateTruck optional LicencePlateTruck Simple Type
LicencePlateTrailer optional LicencePlateTrailer Simple Type
LeadWireSealNumber optional NumberOfTheLeadWireSeal Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
PACI 0..∞ DocumentPaci Complex Type
Description of the pachaging pieces within the delivery note (DESADV)
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
LINE 1..∞
Description of the articles within the delivery note (DESADV)
Sequence
LineItemNumber LineItemNumber Simple Type
Commission optional Commission Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
BatchNumber optional BatchNumber Simple Type
GoodsCountry optional GoodsCountry Simple Type
ClassOfGoods optional ClassOfGoods Complex Type
Sequence
ClassOfGoodsType ClassOfGoodsType Simple Type
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
ClassOfGoodsValue ClassOfGoodsValue Simple Type
MinimumDurabilityDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
FinalOrderResponseLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
OrderedQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
OrderResponseQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
QuantityExclusiveOfEvaluation optional Quantity Complex Type
Unit optional Unit Simple Type
DespatchAdviceQuantity Quantity Complex Type
Unit optional Unit Simple Type
QuantityDeviation optional QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
QuantityDeviationType optional TypeOfQuantityDeviation Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
PACILINE 0..∞ DocumentPaciLine Complex Type
Description of the relation bewteen articles and packagign pieces within the delivery note (DESADV)
Sequence
LineItemNumber LineItemNumber Simple Type
reference to a position defined in LINE
PaciNumber PackingPieceNumber Simple Type
Reference to a position defined in PACi
Quantity optional Quantity Complex Type
Number of units from LINE in PACI
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Footer of the delivery note (DESADV)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DesadvMessage" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <b>Nachricht: Lieferschein (DESADV) </b>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <b>Mesage: Delivery note (DESADV) </b>
    </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DESADV" minOccurs="1" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Kopfteil des Lieferscheins (DESADV)  </xs:documentation>
                <xs:documentation xml:lang="en">Head of the delivery note (DESADV) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentHead">
                    <xs:sequence>
                      <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
                      <xs:element name="Commission" type="Commission" minOccurs="0" />
                      <xs:element name="OrderResponseRef" type="OrderResponseNumber" minOccurs="0" />
                      <xs:element name="BorderCrossingRef" type="BorderCrossing" minOccurs="0" />
                      <xs:element name="DespatchDate" type="DespatchDate" minOccurs="0" />
                      <xs:element name="ShippingDate" type="ShippingDate" minOccurs="0" />
                      <xs:element name="UnloadingDuration" type="Duration" minOccurs="0" />
                      <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
                      <xs:element name="Weight" type="MEA" minOccurs="0" />
                      <xs:element name="Volume" type="MEA" minOccurs="0" />
                      <xs:element name="LicencePlateTruck" type="LicencePlateTruck" minOccurs="0" />
                      <xs:element name="LicencePlateTrailer" type="LicencePlateTrailer" minOccurs="0" />
                      <xs:element name="LeadWireSealNumber" type="NumberOfTheLeadWireSeal" minOccurs="0" />
                      <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
                      <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" />
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Beschreibung der Packstücke im Lieferschein (DESADV)  </xs:documentation>
                <xs:documentation xml:lang="en">Description of the pachaging pieces within the delivery note (DESADV) </xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Beschreibung der Artikel im Lieferschein (DESADV)  </xs:documentation>
                <xs:documentation xml:lang="en">Description of the articles within the delivery note (DESADV) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
                  <xs:element name="Commission" type="Commission" minOccurs="0" />
                  <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" />
                  <xs:element name="GoodsCountry" type="GoodsCountry" minOccurs="0" />
                  <xs:element name="ClassOfGoods" type="ClassOfGoods" minOccurs="0" />
                  <xs:element name="MinimumDurabilityDate" type="EDIDate" minOccurs="0" />
                  <xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" />
                  <xs:element name="FinalOrderResponseLineRef" type="DocumentLineReference" minOccurs="0" />
                  <xs:element name="OrderedQuantity" type="Quantity" minOccurs="0" />
                  <xs:element name="OrderResponseQuantity" type="Quantity" minOccurs="0" />
                  <xs:element name="QuantityExclusiveOfEvaluation" type="Quantity" minOccurs="0" />
                  <xs:element name="DespatchAdviceQuantity" type="Quantity" minOccurs="1" />
                  <xs:element name="QuantityDeviation" type="QuantityQualified" minOccurs="0" />
                  <xs:element name="QuantityDeviationType" type="TypeOfQuantityDeviation" minOccurs="0" />
                  <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
                  <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
                  <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
                  <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
                  <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
                  <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PACILINE" type="DocumentPaciLine" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Beschreibung der Zugeörigkeit von Artikeln zur Packstücken im Lieferrschein(DESADV)  </xs:documentation>
                <xs:documentation xml:lang="en">Description of the relation bewteen articles and packagign pieces within the delivery note (DESADV) </xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Abschluss des Lieferscheins (DESADV)  </xs:documentation>
                <xs:documentation xml:lang="en">Footer of the delivery note (DESADV) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentFoot" />
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
XML Einrichten Version 1.2


DESADV Element
XML Einrichten Version 1.2 > DesadvMessage Element : DESADV Element
Namespace (none)
Diagram
FOOT Element Quantity Element PaciNumber Element LineItemNumber Element Sequence PACILINE Element LINE Element MEA Element ConsumerInstructions Element ShippingMark Element TypeOfShippingMark Element LoadingTackle Element TypeOfPackaging Element NumberOfPackages Element ParentPaciNumber Element PaciNumber Element Sequence PACI Element HEAD Element Sequence DESADV Element
Overview
DESADV 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the delivery note (DESADV)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Commission optional Commission Simple Type
OrderResponseRef optional OrderResponseNumber Simple Type
BorderCrossingRef optional BorderCrossing Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DespatchDate optional DespatchDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ShippingDate optional ShippingDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
UnloadingDuration optional Duration Complex Type
Unit optional Unit Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
Weight optional MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Volume optional MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
LicencePlateTruck optional LicencePlateTruck Simple Type
LicencePlateTrailer optional LicencePlateTrailer Simple Type
LeadWireSealNumber optional NumberOfTheLeadWireSeal Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
PACI 0..∞ DocumentPaci Complex Type
Description of the pachaging pieces within the delivery note (DESADV)
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
LINE 1..∞
Description of the articles within the delivery note (DESADV)
Sequence
LineItemNumber LineItemNumber Simple Type
Commission optional Commission Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
BatchNumber optional BatchNumber Simple Type
GoodsCountry optional GoodsCountry Simple Type
ClassOfGoods optional ClassOfGoods Complex Type
Sequence
ClassOfGoodsType ClassOfGoodsType Simple Type
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
ClassOfGoodsValue ClassOfGoodsValue Simple Type
MinimumDurabilityDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
FinalOrderResponseLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
OrderedQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
OrderResponseQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
QuantityExclusiveOfEvaluation optional Quantity Complex Type
Unit optional Unit Simple Type
DespatchAdviceQuantity Quantity Complex Type
Unit optional Unit Simple Type
QuantityDeviation optional QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
QuantityDeviationType optional TypeOfQuantityDeviation Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
PACILINE 0..∞ DocumentPaciLine Complex Type
Description of the relation bewteen articles and packagign pieces within the delivery note (DESADV)
Sequence
LineItemNumber LineItemNumber Simple Type
reference to a position defined in LINE
PaciNumber PackingPieceNumber Simple Type
Reference to a position defined in PACi
Quantity optional Quantity Complex Type
Number of units from LINE in PACI
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Footer of the delivery note (DESADV)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DESADV" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Kopfteil des Lieferscheins (DESADV)  </xs:documentation>
          <xs:documentation xml:lang="en">Head of the delivery note (DESADV) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentHead">
              <xs:sequence>
                <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
                <xs:element name="Commission" type="Commission" minOccurs="0" />
                <xs:element name="OrderResponseRef" type="OrderResponseNumber" minOccurs="0" />
                <xs:element name="BorderCrossingRef" type="BorderCrossing" minOccurs="0" />
                <xs:element name="DespatchDate" type="DespatchDate" minOccurs="0" />
                <xs:element name="ShippingDate" type="ShippingDate" minOccurs="0" />
                <xs:element name="UnloadingDuration" type="Duration" minOccurs="0" />
                <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
                <xs:element name="Weight" type="MEA" minOccurs="0" />
                <xs:element name="Volume" type="MEA" minOccurs="0" />
                <xs:element name="LicencePlateTruck" type="LicencePlateTruck" minOccurs="0" />
                <xs:element name="LicencePlateTrailer" type="LicencePlateTrailer" minOccurs="0" />
                <xs:element name="LeadWireSealNumber" type="NumberOfTheLeadWireSeal" minOccurs="0" />
                <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
                <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" />
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Beschreibung der Packstücke im Lieferschein (DESADV)  </xs:documentation>
          <xs:documentation xml:lang="en">Description of the pachaging pieces within the delivery note (DESADV) </xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Beschreibung der Artikel im Lieferschein (DESADV)  </xs:documentation>
          <xs:documentation xml:lang="en">Description of the articles within the delivery note (DESADV) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
            <xs:element name="Commission" type="Commission" minOccurs="0" />
            <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" />
            <xs:element name="GoodsCountry" type="GoodsCountry" minOccurs="0" />
            <xs:element name="ClassOfGoods" type="ClassOfGoods" minOccurs="0" />
            <xs:element name="MinimumDurabilityDate" type="EDIDate" minOccurs="0" />
            <xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" />
            <xs:element name="FinalOrderResponseLineRef" type="DocumentLineReference" minOccurs="0" />
            <xs:element name="OrderedQuantity" type="Quantity" minOccurs="0" />
            <xs:element name="OrderResponseQuantity" type="Quantity" minOccurs="0" />
            <xs:element name="QuantityExclusiveOfEvaluation" type="Quantity" minOccurs="0" />
            <xs:element name="DespatchAdviceQuantity" type="Quantity" minOccurs="1" />
            <xs:element name="QuantityDeviation" type="QuantityQualified" minOccurs="0" />
            <xs:element name="QuantityDeviationType" type="TypeOfQuantityDeviation" minOccurs="0" />
            <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
            <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
            <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
            <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
            <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
            <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PACILINE" type="DocumentPaciLine" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Beschreibung der Zugeörigkeit von Artikeln zur Packstücken im Lieferrschein(DESADV)  </xs:documentation>
          <xs:documentation xml:lang="en">Description of the relation bewteen articles and packagign pieces within the delivery note (DESADV) </xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Abschluss des Lieferscheins (DESADV)  </xs:documentation>
          <xs:documentation xml:lang="en">Footer of the delivery note (DESADV) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentFoot" />
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
DesadvMessage Element | XML Einrichten Version 1.2


FOOT Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element : FOOT Element
Description
Footer of the delivery note (DESADV)
Namespace (none)
Type
Extension of DocumentFoot Complex Type
Diagram
SendingDate Element Sequence FOOT Element
Overview
FOOT Extension of DocumentFoot Complex Type
Footer of the delivery note (DESADV)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="FOOT" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Abschluss des Lieferscheins (DESADV)  </xs:documentation>
    <xs:documentation xml:lang="en">Footer of the delivery note (DESADV) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentFoot" />
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


SendingDate Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > FOOT Element : SendingDate Element
Description
Sending date of this message
Namespace (none)
Type
EDIDate Complex Type
Diagram
SendingDate Element
Overview
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="SendingDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Versanddatum der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Sending date of this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FOOT Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


HEAD Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element : HEAD Element
Description
Head of the delivery note (DESADV)
Namespace (none)
Type
Extension of DocumentHead Complex Type
Diagram
AppTargetIdentification Element AppSourceIdentification Element ObjectContent Element Source Element RemoteType Element FunctionType Element ObjectType Element ObjectDescription Element FileName Element Sequence MULH Element FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element LeadWireSealNumber Element LicencePlateTrailer Element LicencePlateTruck Element Volume Element Weight Element NumberOfPackages Element UnloadingDuration Element ShippingDate Element DespatchDate Element DocDate Element DocRefNumber Element Sequence BorderCrossingRef Element OrderResponseRef Element Commission Element DocDate Element DocRefNumber Element Sequence OrderNumberRef Element TechnicalReceiverCopy Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element AdditionalDate Element TechnicalSender Element TechnicalReceiver Element DocumentDate Element DocumentNumber Element DocumentFunctionSymbol Element DocumentType Element WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element Sequence HEAD Element
Overview
HEAD Extension of DocumentHead Complex Type
Head of the delivery note (DESADV)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Commission optional Commission Simple Type
OrderResponseRef optional OrderResponseNumber Simple Type
BorderCrossingRef optional BorderCrossing Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DespatchDate optional DespatchDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ShippingDate optional ShippingDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
UnloadingDuration optional Duration Complex Type
Unit optional Unit Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
Weight optional MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Volume optional MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
LicencePlateTruck optional LicencePlateTruck Simple Type
LicencePlateTrailer optional LicencePlateTrailer Simple Type
LeadWireSealNumber optional NumberOfTheLeadWireSeal Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
Source
<xs:element name="HEAD" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kopfteil des Lieferscheins (DESADV)  </xs:documentation>
    <xs:documentation xml:lang="en">Head of the delivery note (DESADV) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentHead">
        <xs:sequence>
          <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
          <xs:element name="Commission" type="Commission" minOccurs="0" />
          <xs:element name="OrderResponseRef" type="OrderResponseNumber" minOccurs="0" />
          <xs:element name="BorderCrossingRef" type="BorderCrossing" minOccurs="0" />
          <xs:element name="DespatchDate" type="DespatchDate" minOccurs="0" />
          <xs:element name="ShippingDate" type="ShippingDate" minOccurs="0" />
          <xs:element name="UnloadingDuration" type="Duration" minOccurs="0" />
          <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
          <xs:element name="Weight" type="MEA" minOccurs="0" />
          <xs:element name="Volume" type="MEA" minOccurs="0" />
          <xs:element name="LicencePlateTruck" type="LicencePlateTruck" minOccurs="0" />
          <xs:element name="LicencePlateTrailer" type="LicencePlateTrailer" minOccurs="0" />
          <xs:element name="LeadWireSealNumber" type="NumberOfTheLeadWireSeal" minOccurs="0" />
          <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
          <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" />
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


AdditionalReference Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : AdditionalReference Element
Namespace (none)
Type
DocumentReferenceQualified Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence AdditionalReference Element
Overview
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalReference" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


BorderCrossingRef Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : BorderCrossingRef Element
Namespace (none)
Type
BorderCrossing Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence BorderCrossingRef Element
Overview
BorderCrossingRef optional BorderCrossing Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="BorderCrossingRef" type="BorderCrossing" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


Commission Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : Commission Element
Namespace (none)
Type
Commission Simple Type
Diagram
Commission Element
Overview
Commission optional Commission Simple Type
Source
<xs:element name="Commission" type="Commission" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


DespatchDate Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : DespatchDate Element
Namespace (none)
Type
DespatchDate Complex Type
Diagram
DespatchDate Element
Overview
DespatchDate optional DespatchDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DespatchDate" type="DespatchDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


DocumentDate Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : DocumentDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocumentDate Element
Overview
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocumentDate" type="EDIDate" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


DocumentFunctionSymbol Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : DocumentFunctionSymbol Element
Namespace (none)
Type
DocumentFunctionSymbol Simple Type
Diagram
DocumentFunctionSymbol Element
Overview
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
Source
<xs:element name="DocumentFunctionSymbol" type="DocumentFunctionSymbol" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


DocumentNumber Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : DocumentNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocumentNumber Element
Overview
DocumentNumber DocumentNumber Simple Type
Source
<xs:element name="DocumentNumber" type="DocumentNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


DocumentType Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : DocumentType Element
Namespace (none)
Type
DocumentType Simple Type
Diagram
DocumentType Element
Overview
DocumentType DocumentType Simple Type
Source
<xs:element name="DocumentType" type="DocumentType" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


LeadWireSealNumber Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : LeadWireSealNumber Element
Namespace (none)
Type
NumberOfTheLeadWireSeal Simple Type
Diagram
LeadWireSealNumber Element
Overview
LeadWireSealNumber optional NumberOfTheLeadWireSeal Simple Type
Source
<xs:element name="LeadWireSealNumber" type="NumberOfTheLeadWireSeal" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


LicencePlateTrailer Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : LicencePlateTrailer Element
Namespace (none)
Type
LicencePlateTrailer Simple Type
Diagram
LicencePlateTrailer Element
Overview
LicencePlateTrailer optional LicencePlateTrailer Simple Type
Source
<xs:element name="LicencePlateTrailer" type="LicencePlateTrailer" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


LicencePlateTruck Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : LicencePlateTruck Element
Namespace (none)
Type
LicencePlateTruck Simple Type
Diagram
LicencePlateTruck Element
Overview
LicencePlateTruck optional LicencePlateTruck Simple Type
Source
<xs:element name="LicencePlateTruck" type="LicencePlateTruck" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


MULH Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : MULH Element
Namespace (none)
Type
MULH Complex Type
Diagram
AppTargetIdentification Element AppSourceIdentification Element ObjectContent Element Source Element RemoteType Element FunctionType Element ObjectType Element ObjectDescription Element FileName Element Sequence MULH Element
Overview
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
Source
<xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


NAD Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : NAD Element
Namespace (none)
Type
NAD Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element
Overview
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


NumberOfPackages Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : NumberOfPackages Element
Namespace (none)
Type
NumberOfPackages Simple Type
Diagram
NumberOfPackages Element
Overview
NumberOfPackages optional NumberOfPackages Simple Type
Source
<xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


OrderNumberRef Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : OrderNumberRef Element
Namespace (none)
Type
OrderNumber Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence OrderNumberRef Element
Overview
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


OrderResponseRef Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : OrderResponseRef Element
Namespace (none)
Type
OrderResponseNumber Simple Type
Diagram
OrderResponseRef Element
Overview
OrderResponseRef optional OrderResponseNumber Simple Type
Source
<xs:element name="OrderResponseRef" type="OrderResponseNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


ShippingDate Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : ShippingDate Element
Namespace (none)
Type
ShippingDate Complex Type
Diagram
ShippingDate Element
Overview
ShippingDate optional ShippingDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="ShippingDate" type="ShippingDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


TechnicalReceiver Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : TechnicalReceiver Element
Description
technical, physical recipient of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiver Element
Overview
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
Source
<xs:element name="TechnicalReceiver" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Empfänger der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical recipient of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


TechnicalReceiverCopy Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : TechnicalReceiverCopy Element
Description
Physical receiver for a copy from this message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiverCopy Element
Overview
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Source
<xs:element name="TechnicalReceiverCopy" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Physischer Empfänger einer Kopie dieser Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Physical receiver for a copy from this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


TechnicalSender Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : TechnicalSender Element
Description
technical, physical sender of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalSender Element
Overview
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
Source
<xs:element name="TechnicalSender" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Versender der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical sender of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


UnloadingDuration Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : UnloadingDuration Element
Namespace (none)
Type
Duration Complex Type
Diagram
UnloadingDuration Element
Overview
UnloadingDuration optional Duration Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="UnloadingDuration" type="Duration" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


VersionNumber Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : VersionNumber Element
Namespace (none)
Type
MessageVersion Complex Type
Diagram
WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element
Overview
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
Source
<xs:element name="VersionNumber" type="MessageVersion" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


Volume Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : Volume Element
Namespace (none)
Type
MEA Complex Type
Diagram
Volume Element
Overview
Volume optional MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="Volume" type="MEA" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


Weight Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > HEAD Element : Weight Element
Namespace (none)
Type
MEA Complex Type
Diagram
Weight Element
Overview
Weight optional MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="Weight" type="MEA" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


LINE Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element : LINE Element
Description
Description of the articles within the delivery note (DESADV)
Namespace (none)
Diagram
NumericValue Element TextValue Element OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element LineText Element Sequence LTXT Element MEA Element AdditionalDate Element AdditionalQuantity Element Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence AdditionalPrice Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element Sequence AdditionalLineReferences Element Currency Element Value Element Sequence NetLineAmount Element Currency Element Value Element Sequence GrossLineAmount Element NumberOfPackages Element QuantityDeviationType Element QuantityDeviation Element DespatchAdviceQuantity Element QuantityExclusiveOfEvaluation Element OrderResponseQuantity Element OrderedQuantity Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence FinalOrderResponseLineRef Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence OrderLineRef Element MinimumDurabilityDate Element ClassOfGoodsValue Element ClassOfGoodsFeature Element ClassOfGoodsType Element Sequence ClassOfGoods Element GoodsCountry Element BatchNumber Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element Commission Element LineItemNumber Element Sequence LINE Element
Overview
LINE 1..∞
Description of the articles within the delivery note (DESADV)
Sequence
LineItemNumber LineItemNumber Simple Type
Commission optional Commission Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
BatchNumber optional BatchNumber Simple Type
GoodsCountry optional GoodsCountry Simple Type
ClassOfGoods optional ClassOfGoods Complex Type
Sequence
ClassOfGoodsType ClassOfGoodsType Simple Type
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
ClassOfGoodsValue ClassOfGoodsValue Simple Type
MinimumDurabilityDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
FinalOrderResponseLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
OrderedQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
OrderResponseQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
QuantityExclusiveOfEvaluation optional Quantity Complex Type
Unit optional Unit Simple Type
DespatchAdviceQuantity Quantity Complex Type
Unit optional Unit Simple Type
QuantityDeviation optional QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
QuantityDeviationType optional TypeOfQuantityDeviation Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="LINE" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Beschreibung der Artikel im Lieferschein (DESADV)  </xs:documentation>
    <xs:documentation xml:lang="en">Description of the articles within the delivery note (DESADV) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
      <xs:element name="Commission" type="Commission" minOccurs="0" />
      <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" />
      <xs:element name="GoodsCountry" type="GoodsCountry" minOccurs="0" />
      <xs:element name="ClassOfGoods" type="ClassOfGoods" minOccurs="0" />
      <xs:element name="MinimumDurabilityDate" type="EDIDate" minOccurs="0" />
      <xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" />
      <xs:element name="FinalOrderResponseLineRef" type="DocumentLineReference" minOccurs="0" />
      <xs:element name="OrderedQuantity" type="Quantity" minOccurs="0" />
      <xs:element name="OrderResponseQuantity" type="Quantity" minOccurs="0" />
      <xs:element name="QuantityExclusiveOfEvaluation" type="Quantity" minOccurs="0" />
      <xs:element name="DespatchAdviceQuantity" type="Quantity" minOccurs="1" />
      <xs:element name="QuantityDeviation" type="QuantityQualified" minOccurs="0" />
      <xs:element name="QuantityDeviationType" type="TypeOfQuantityDeviation" minOccurs="0" />
      <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
      <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
      <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
      <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
      <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
      <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


AdditionalLineReferences Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : AdditionalLineReferences Element
Namespace (none)
Type
AdditionalLineReferences Complex Type
Diagram
AdditionalDate Element AdditionalQuantity Element Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence AdditionalPrice Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element Sequence AdditionalLineReferences Element
Overview
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


BatchNumber Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : BatchNumber Element
Namespace (none)
Type
BatchNumber Simple Type
Diagram
BatchNumber Element
Overview
BatchNumber optional BatchNumber Simple Type
Source
<xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


ClassOfGoods Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : ClassOfGoods Element
Namespace (none)
Type
ClassOfGoods Complex Type
Diagram
ClassOfGoodsValue Element ClassOfGoodsFeature Element ClassOfGoodsType Element Sequence ClassOfGoods Element
Overview
ClassOfGoods optional ClassOfGoods Complex Type
Sequence
ClassOfGoodsType ClassOfGoodsType Simple Type
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
ClassOfGoodsValue ClassOfGoodsValue Simple Type
Source
<xs:element name="ClassOfGoods" type="ClassOfGoods" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


Commission Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : Commission Element
Namespace (none)
Type
Commission Simple Type
Diagram
Commission Element
Overview
Commission optional Commission Simple Type
Source
<xs:element name="Commission" type="Commission" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


DespatchAdviceQuantity Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : DespatchAdviceQuantity Element
Namespace (none)
Type
Quantity Complex Type
Diagram
DespatchAdviceQuantity Element
Overview
DespatchAdviceQuantity Quantity Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="DespatchAdviceQuantity" type="Quantity" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


FinalOrderResponseLineRef Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : FinalOrderResponseLineRef Element
Namespace (none)
Type
DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence FinalOrderResponseLineRef Element
Overview
FinalOrderResponseLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="FinalOrderResponseLineRef" type="DocumentLineReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


GoodsCountry Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : GoodsCountry Element
Namespace (none)
Type
GoodsCountry Simple Type
Diagram
GoodsCountry Element
Overview
GoodsCountry optional GoodsCountry Simple Type
Source
<xs:element name="GoodsCountry" type="GoodsCountry" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


GrossLineAmount Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : GrossLineAmount Element
Namespace (none)
Type
GrossLineAmount Complex Type
Diagram
Currency Element Value Element Sequence GrossLineAmount Element
Overview
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


LineItemNumber Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : LineItemNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
LineItemNumber Element
Overview
LineItemNumber LineItemNumber Simple Type
Source
<xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


LTXT Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : LTXT Element
Namespace (none)
Type
LTXT Complex Type
Diagram
LineText Element Sequence LTXT Element
Overview
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


MEA Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : MEA Element
Namespace (none)
Type
MEA Complex Type
Diagram
MEA Element
Overview
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


MinimumDurabilityDate Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : MinimumDurabilityDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
MinimumDurabilityDate Element
Overview
MinimumDurabilityDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="MinimumDurabilityDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


NetLineAmount Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : NetLineAmount Element
Namespace (none)
Type
NetLineAmount Complex Type
Diagram
Currency Element Value Element Sequence NetLineAmount Element
Overview
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


NumberOfPackages Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : NumberOfPackages Element
Namespace (none)
Type
NumberOfPackages Simple Type
Diagram
NumberOfPackages Element
Overview
NumberOfPackages optional NumberOfPackages Simple Type
Source
<xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


OPT Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : OPT Element
Namespace (none)
Type
OPT Complex Type
Diagram
NumericValue Element TextValue Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element
Overview
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


OrderedQuantity Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : OrderedQuantity Element
Namespace (none)
Type
Quantity Complex Type
Diagram
OrderedQuantity Element
Overview
OrderedQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OrderedQuantity" type="Quantity" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


OrderLineRef Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : OrderLineRef Element
Namespace (none)
Type
DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence OrderLineRef Element
Overview
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


OrderResponseQuantity Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : OrderResponseQuantity Element
Namespace (none)
Type
Quantity Complex Type
Diagram
OrderResponseQuantity Element
Overview
OrderResponseQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OrderResponseQuantity" type="Quantity" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


ProductID Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : ProductID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element
Overview
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


QuantityDeviation Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : QuantityDeviation Element
Namespace (none)
Type
QuantityQualified Complex Type
Diagram
QuantityDeviation Element
Overview
QuantityDeviation optional QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
Source
<xs:element name="QuantityDeviation" type="QuantityQualified" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


QuantityDeviationType Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : QuantityDeviationType Element
Namespace (none)
Type
TypeOfQuantityDeviation Simple Type
Diagram
QuantityDeviationType Element
Overview
QuantityDeviationType optional TypeOfQuantityDeviation Simple Type
Source
<xs:element name="QuantityDeviationType" type="TypeOfQuantityDeviation" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


QuantityExclusiveOfEvaluation Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : QuantityExclusiveOfEvaluation Element
Namespace (none)
Type
Quantity Complex Type
Diagram
QuantityExclusiveOfEvaluation Element
Overview
QuantityExclusiveOfEvaluation optional Quantity Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="QuantityExclusiveOfEvaluation" type="Quantity" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


SeriesID Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element > LINE Element : SeriesID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element
Overview
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


PACI Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element : PACI Element
Description
Description of the pachaging pieces within the delivery note (DESADV)
Namespace (none)
Type
DocumentPaci Complex Type
Diagram
MEA Element ConsumerInstructions Element ShippingMark Element TypeOfShippingMark Element LoadingTackle Element TypeOfPackaging Element NumberOfPackages Element ParentPaciNumber Element PaciNumber Element Sequence PACI Element
Overview
PACI 0..∞ DocumentPaci Complex Type
Description of the pachaging pieces within the delivery note (DESADV)
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Beschreibung der Packstücke im Lieferschein (DESADV)  </xs:documentation>
    <xs:documentation xml:lang="en">Description of the pachaging pieces within the delivery note (DESADV) </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


PACILINE Element
XML Einrichten Version 1.2 > DesadvMessage Element > DESADV Element : PACILINE Element
Description
Description of the relation bewteen articles and packagign pieces within the delivery note (DESADV)
Namespace (none)
Type
DocumentPaciLine Complex Type
Diagram
Quantity Element PaciNumber Element LineItemNumber Element Sequence PACILINE Element
Overview
PACILINE 0..∞ DocumentPaciLine Complex Type
Description of the relation bewteen articles and packagign pieces within the delivery note (DESADV)
Sequence
LineItemNumber LineItemNumber Simple Type
reference to a position defined in LINE
PaciNumber PackingPieceNumber Simple Type
Reference to a position defined in PACi
Quantity optional Quantity Complex Type
Number of units from LINE in PACI
Unit optional Unit Simple Type
Source
<xs:element name="PACILINE" type="DocumentPaciLine" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Beschreibung der Zugeörigkeit von Artikeln zur Packstücken im Lieferrschein(DESADV)  </xs:documentation>
    <xs:documentation xml:lang="en">Description of the relation bewteen articles and packagign pieces within the delivery note (DESADV) </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DESADV Element | DesadvMessage Element | XML Einrichten Version 1.2


InvoiceMessage Element
XML Einrichten Version 1.2 : InvoiceMessage Element
Description
Mesage: Invoice (INVOIC)
Namespace (none)
Diagram
INVOICE Element Sequence InvoiceMessage Element
Overview
InvoiceMessage
Mesage: Invoice (INVOIC)
Sequence
INVOICE 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the invoice (INVOIC)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
OrderType optional OrderType Simple Type
Commission optional Commission Simple Type
DespatchAdviceNumberRef optional DespatchAdviceNumber Simple Type
OrderResponseRef optional OrderResponseNumber Simple Type
PrevInvoiceRef optional PrevInvoice Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ActuallyDeliveryDate optional ActualDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ValueDate optional ValueDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DueDate optional DueDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
CashDiscount 0..5 CashDiscount Complex Type
Sequence
CashDiscountDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
CashDiscountPercentage optional xs:decimal
CashDiscountAmount optional TotalAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
BarcodeNumber optional BarcodeNumber Simple Type
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
NAD 1..99999 NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
LINE 1..∞
Posiitions of the invoice (INVOIC)
Sequence
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
BatchNumber optional BatchNumber Simple Type
TypeOfProduct optional TypeOfProduct Simple Type
GoodsCountry optional GoodsCountry Simple Type
ClassOfGoods optional ClassOfGoods Complex Type
Sequence
ClassOfGoodsType ClassOfGoodsType Simple Type
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
ClassOfGoodsValue ClassOfGoodsValue Simple Type
Commission optional Commission Simple Type
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
DespatchAdviceLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
OrderResponseLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
MEA 0..20 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
InvoiceQuantity Quantity Complex Type
Unit optional Unit Simple Type
GrossUnitPrice optional GrossUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
NetUnitPrice optional NetUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal optional DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
LineVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LTXT 0..300 LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
CNDL 0..∞ CNDL Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:string
Condition level
TypeOfCondition Restriction of xs:string
Type of condition
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
InvoiceAmount InvoiceAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
VatTotal 0..5 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
CNDF 0..∞ CNDF Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:decimal
TypeOfCondition Restriction of xs:string
Type of conditiont
DI = Rebate
FC = Freight Cost
IN = Insurance
PC = Handling costs
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Source
<xs:element name="InvoiceMessage" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <b>Nachricht: Rechnung (INVOIC) </b>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <b>Mesage: Invoice (INVOIC) </b>
    </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="INVOICE" minOccurs="1" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Kopfteil der Rechnung (INVOIC)  </xs:documentation>
                <xs:documentation xml:lang="en">Head of the invoice (INVOIC) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentHead">
                    <xs:sequence>
                      <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
                      <xs:element name="OrderType" type="OrderType" minOccurs="0" />
                      <xs:element name="Commission" type="Commission" minOccurs="0" />
                      <xs:element name="DespatchAdviceNumberRef" type="DespatchAdviceNumber" minOccurs="0" />
                      <xs:element name="OrderResponseRef" type="OrderResponseNumber" minOccurs="0" />
                      <xs:element name="PrevInvoiceRef" type="PrevInvoice" minOccurs="0" />
                      <xs:element name="ActuallyDeliveryDate" type="ActualDeliveryDate" minOccurs="0" />
                      <xs:element name="ValueDate" type="ValueDate" minOccurs="0" />
                      <xs:element name="DueDate" type="DueDate" minOccurs="0" />
                      <xs:element name="CashDiscount" type="CashDiscount" minOccurs="0" maxOccurs="5" />
                      <xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" />
                      <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" />
                      <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="99999" />
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Positionen der Rechnung (INVOIC) </xs:documentation>
                <xs:documentation xml:lang="en">Posiitions of the invoice (INVOIC)  </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
                  <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
                  <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" />
                  <xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" />
                  <xs:element name="GoodsCountry" type="GoodsCountry" minOccurs="0" />
                  <xs:element name="ClassOfGoods" type="ClassOfGoods" minOccurs="0" />
                  <xs:element name="Commission" type="Commission" minOccurs="0" />
                  <xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" />
                  <xs:element name="DespatchAdviceLineRef" type="DocumentLineReference" minOccurs="0" />
                  <xs:element name="OrderResponseLineRef" type="DocumentLineReference" minOccurs="0" />
                  <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
                  <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
                  <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="20" />
                  <xs:element name="InvoiceQuantity" type="Quantity" />
                  <xs:element name="GrossUnitPrice" type="GrossUnitPrice" minOccurs="0" />
                  <xs:element name="NetUnitPrice" type="NetUnitPrice" minOccurs="0" />
                  <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
                  <xs:element name="DiscountsConditionsTotal" type="DiscountsConditionsTotal" minOccurs="0" />
                  <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" maxOccurs="1" />
                  <xs:element name="LineVat" type="Vat" minOccurs="0" />
                  <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
                  <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="300" />
                  <xs:element name="CNDL" type="CNDL" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentFoot">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">Abschluss der Rechnung (INVOIC)</xs:documentation>
                      <xs:documentation xml:lang="en">Footer of the invoice (INVOIC) </xs:documentation>
                    </xs:annotation>
                    <xs:sequence>
                      <xs:element name="InvoiceAmount" type="InvoiceAmount" minOccurs="1" maxOccurs="1" />
                      <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="5" />
                      <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
                      <xs:element name="CNDF" type="CNDF" minOccurs="0" maxOccurs="unbounded" />
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
XML Einrichten Version 1.2


INVOICE Element
XML Einrichten Version 1.2 > InvoiceMessage Element : INVOICE Element
Namespace (none)
Diagram
FOOT Element LINE Element HEAD Element Sequence INVOICE Element
Overview
INVOICE 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the invoice (INVOIC)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
OrderType optional OrderType Simple Type
Commission optional Commission Simple Type
DespatchAdviceNumberRef optional DespatchAdviceNumber Simple Type
OrderResponseRef optional OrderResponseNumber Simple Type
PrevInvoiceRef optional PrevInvoice Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ActuallyDeliveryDate optional ActualDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ValueDate optional ValueDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DueDate optional DueDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
CashDiscount 0..5 CashDiscount Complex Type
Sequence
CashDiscountDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
CashDiscountPercentage optional xs:decimal
CashDiscountAmount optional TotalAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
BarcodeNumber optional BarcodeNumber Simple Type
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
NAD 1..99999 NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
LINE 1..∞
Posiitions of the invoice (INVOIC)
Sequence
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
BatchNumber optional BatchNumber Simple Type
TypeOfProduct optional TypeOfProduct Simple Type
GoodsCountry optional GoodsCountry Simple Type
ClassOfGoods optional ClassOfGoods Complex Type
Sequence
ClassOfGoodsType ClassOfGoodsType Simple Type
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
ClassOfGoodsValue ClassOfGoodsValue Simple Type
Commission optional Commission Simple Type
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
DespatchAdviceLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
OrderResponseLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
MEA 0..20 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
InvoiceQuantity Quantity Complex Type
Unit optional Unit Simple Type
GrossUnitPrice optional GrossUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
NetUnitPrice optional NetUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal optional DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
LineVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LTXT 0..300 LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
CNDL 0..∞ CNDL Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:string
Condition level
TypeOfCondition Restriction of xs:string
Type of condition
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
InvoiceAmount InvoiceAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
VatTotal 0..5 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
CNDF 0..∞ CNDF Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:decimal
TypeOfCondition Restriction of xs:string
Type of conditiont
DI = Rebate
FC = Freight Cost
IN = Insurance
PC = Handling costs
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Source
<xs:element name="INVOICE" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Kopfteil der Rechnung (INVOIC)  </xs:documentation>
          <xs:documentation xml:lang="en">Head of the invoice (INVOIC) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentHead">
              <xs:sequence>
                <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
                <xs:element name="OrderType" type="OrderType" minOccurs="0" />
                <xs:element name="Commission" type="Commission" minOccurs="0" />
                <xs:element name="DespatchAdviceNumberRef" type="DespatchAdviceNumber" minOccurs="0" />
                <xs:element name="OrderResponseRef" type="OrderResponseNumber" minOccurs="0" />
                <xs:element name="PrevInvoiceRef" type="PrevInvoice" minOccurs="0" />
                <xs:element name="ActuallyDeliveryDate" type="ActualDeliveryDate" minOccurs="0" />
                <xs:element name="ValueDate" type="ValueDate" minOccurs="0" />
                <xs:element name="DueDate" type="DueDate" minOccurs="0" />
                <xs:element name="CashDiscount" type="CashDiscount" minOccurs="0" maxOccurs="5" />
                <xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" />
                <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" />
                <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="99999" />
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Positionen der Rechnung (INVOIC) </xs:documentation>
          <xs:documentation xml:lang="en">Posiitions of the invoice (INVOIC)  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
            <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
            <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" />
            <xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" />
            <xs:element name="GoodsCountry" type="GoodsCountry" minOccurs="0" />
            <xs:element name="ClassOfGoods" type="ClassOfGoods" minOccurs="0" />
            <xs:element name="Commission" type="Commission" minOccurs="0" />
            <xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" />
            <xs:element name="DespatchAdviceLineRef" type="DocumentLineReference" minOccurs="0" />
            <xs:element name="OrderResponseLineRef" type="DocumentLineReference" minOccurs="0" />
            <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
            <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
            <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="20" />
            <xs:element name="InvoiceQuantity" type="Quantity" />
            <xs:element name="GrossUnitPrice" type="GrossUnitPrice" minOccurs="0" />
            <xs:element name="NetUnitPrice" type="NetUnitPrice" minOccurs="0" />
            <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
            <xs:element name="DiscountsConditionsTotal" type="DiscountsConditionsTotal" minOccurs="0" />
            <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" maxOccurs="1" />
            <xs:element name="LineVat" type="Vat" minOccurs="0" />
            <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
            <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="300" />
            <xs:element name="CNDL" type="CNDL" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentFoot">
              <xs:annotation>
                <xs:documentation xml:lang="de">Abschluss der Rechnung (INVOIC)</xs:documentation>
                <xs:documentation xml:lang="en">Footer of the invoice (INVOIC) </xs:documentation>
              </xs:annotation>
              <xs:sequence>
                <xs:element name="InvoiceAmount" type="InvoiceAmount" minOccurs="1" maxOccurs="1" />
                <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="5" />
                <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
                <xs:element name="CNDF" type="CNDF" minOccurs="0" maxOccurs="unbounded" />
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
InvoiceMessage Element | XML Einrichten Version 1.2


FOOT Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element : FOOT Element
Namespace (none)
Type
Extension of DocumentFoot Complex Type
Diagram
VatPercentageOfCondition Element AmountOfCondition Element PercentageRateOfCondition Element DscOfConditionType Element TypeOfCondition Element ConditionLevel Element ConditionIndicator Element Sequence CNDF Element Qualifier Element Currency Element Value Element Sequence AdditionalAmounts Element Currency Element Value Element Sequence DiscountsConditionsTotal Element Currency Element Value Element Sequence NetItemAmount Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence VatTotal Element Currency Element Value Element Sequence InvoiceAmount Element SendingDate Element Sequence FOOT Element
Overview
FOOT Extension of DocumentFoot Complex Type
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
InvoiceAmount InvoiceAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
VatTotal 0..5 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
CNDF 0..∞ CNDF Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:decimal
TypeOfCondition Restriction of xs:string
Type of conditiont
DI = Rebate
FC = Freight Cost
IN = Insurance
PC = Handling costs
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Source
<xs:element name="FOOT" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentFoot">
        <xs:annotation>
          <xs:documentation xml:lang="de">Abschluss der Rechnung (INVOIC)</xs:documentation>
          <xs:documentation xml:lang="en">Footer of the invoice (INVOIC) </xs:documentation>
        </xs:annotation>
        <xs:sequence>
          <xs:element name="InvoiceAmount" type="InvoiceAmount" minOccurs="1" maxOccurs="1" />
          <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="5" />
          <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
          <xs:element name="CNDF" type="CNDF" minOccurs="0" maxOccurs="unbounded" />
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


AdditionalAmounts Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > FOOT Element : AdditionalAmounts Element
Namespace (none)
Type
TotalAmountQualified Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence AdditionalAmounts Element
Overview
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
Source
<xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FOOT Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


CNDF Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > FOOT Element : CNDF Element
Namespace (none)
Type
CNDF Complex Type
Diagram
VatPercentageOfCondition Element AmountOfCondition Element PercentageRateOfCondition Element DscOfConditionType Element TypeOfCondition Element ConditionLevel Element ConditionIndicator Element Sequence CNDF Element
Overview
CNDF 0..∞ CNDF Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:decimal
TypeOfCondition Restriction of xs:string
Type of conditiont
DI = Rebate
FC = Freight Cost
IN = Insurance
PC = Handling costs
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Source
<xs:element name="CNDF" type="CNDF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FOOT Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


InvoiceAmount Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > FOOT Element : InvoiceAmount Element
Namespace (none)
Type
InvoiceAmount Complex Type
Diagram
Currency Element Value Element Sequence InvoiceAmount Element
Overview
InvoiceAmount InvoiceAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="InvoiceAmount" type="InvoiceAmount" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FOOT Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


SendingDate Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > FOOT Element : SendingDate Element
Description
Sending date of this message
Namespace (none)
Type
EDIDate Complex Type
Diagram
SendingDate Element
Overview
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="SendingDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Versanddatum der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Sending date of this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FOOT Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


VatTotal Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > FOOT Element : VatTotal Element
Namespace (none)
Type
VatTotal Complex Type
Diagram
Currency Element Value Element Sequence DiscountsConditionsTotal Element Currency Element Value Element Sequence NetItemAmount Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence VatTotal Element
Overview
VatTotal 0..5 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="5" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FOOT Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


HEAD Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element : HEAD Element
Description
Head of the invoice (INVOIC)
Namespace (none)
Type
Extension of DocumentHead Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element HeadText Element Sequence HTXT Element BarcodeNumber Element Currency Element Value Element Sequence CashDiscountAmount Element CashDiscountPercentage Element CashDiscountDate Element Sequence CashDiscount Element DueDate Element ValueDate Element ActuallyDeliveryDate Element DocDate Element DocRefNumber Element Sequence PrevInvoiceRef Element OrderResponseRef Element DespatchAdviceNumberRef Element Commission Element OrderType Element DocDate Element DocRefNumber Element Sequence OrderNumberRef Element TechnicalReceiverCopy Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element AdditionalDate Element TechnicalSender Element TechnicalReceiver Element DocumentDate Element DocumentNumber Element DocumentFunctionSymbol Element DocumentType Element WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element Sequence HEAD Element
Overview
HEAD Extension of DocumentHead Complex Type
Head of the invoice (INVOIC)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
OrderType optional OrderType Simple Type
Commission optional Commission Simple Type
DespatchAdviceNumberRef optional DespatchAdviceNumber Simple Type
OrderResponseRef optional OrderResponseNumber Simple Type
PrevInvoiceRef optional PrevInvoice Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ActuallyDeliveryDate optional ActualDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ValueDate optional ValueDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DueDate optional DueDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
CashDiscount 0..5 CashDiscount Complex Type
Sequence
CashDiscountDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
CashDiscountPercentage optional xs:decimal
CashDiscountAmount optional TotalAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
BarcodeNumber optional BarcodeNumber Simple Type
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
NAD 1..99999 NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="HEAD" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kopfteil der Rechnung (INVOIC)  </xs:documentation>
    <xs:documentation xml:lang="en">Head of the invoice (INVOIC) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentHead">
        <xs:sequence>
          <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
          <xs:element name="OrderType" type="OrderType" minOccurs="0" />
          <xs:element name="Commission" type="Commission" minOccurs="0" />
          <xs:element name="DespatchAdviceNumberRef" type="DespatchAdviceNumber" minOccurs="0" />
          <xs:element name="OrderResponseRef" type="OrderResponseNumber" minOccurs="0" />
          <xs:element name="PrevInvoiceRef" type="PrevInvoice" minOccurs="0" />
          <xs:element name="ActuallyDeliveryDate" type="ActualDeliveryDate" minOccurs="0" />
          <xs:element name="ValueDate" type="ValueDate" minOccurs="0" />
          <xs:element name="DueDate" type="DueDate" minOccurs="0" />
          <xs:element name="CashDiscount" type="CashDiscount" minOccurs="0" maxOccurs="5" />
          <xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" />
          <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" />
          <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="99999" />
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


ActuallyDeliveryDate Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : ActuallyDeliveryDate Element
Namespace (none)
Type
ActualDeliveryDate Complex Type
Diagram
ActuallyDeliveryDate Element
Overview
ActuallyDeliveryDate optional ActualDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="ActuallyDeliveryDate" type="ActualDeliveryDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


AdditionalReference Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : AdditionalReference Element
Namespace (none)
Type
DocumentReferenceQualified Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence AdditionalReference Element
Overview
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalReference" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


BarcodeNumber Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : BarcodeNumber Element
Namespace (none)
Type
BarcodeNumber Simple Type
Diagram
BarcodeNumber Element
Overview
BarcodeNumber optional BarcodeNumber Simple Type
Source
<xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


CashDiscount Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : CashDiscount Element
Namespace (none)
Type
CashDiscount Complex Type
Diagram
Currency Element Value Element Sequence CashDiscountAmount Element CashDiscountPercentage Element CashDiscountDate Element Sequence CashDiscount Element
Overview
CashDiscount 0..5 CashDiscount Complex Type
Sequence
CashDiscountDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
CashDiscountPercentage optional xs:decimal
CashDiscountAmount optional TotalAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="CashDiscount" type="CashDiscount" minOccurs="0" maxOccurs="5" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


Commission Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : Commission Element
Namespace (none)
Type
Commission Simple Type
Diagram
Commission Element
Overview
Commission optional Commission Simple Type
Source
<xs:element name="Commission" type="Commission" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


DespatchAdviceNumberRef Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : DespatchAdviceNumberRef Element
Namespace (none)
Type
DespatchAdviceNumber Simple Type
Diagram
DespatchAdviceNumberRef Element
Overview
DespatchAdviceNumberRef optional DespatchAdviceNumber Simple Type
Source
<xs:element name="DespatchAdviceNumberRef" type="DespatchAdviceNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


DocumentDate Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : DocumentDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocumentDate Element
Overview
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocumentDate" type="EDIDate" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


DocumentFunctionSymbol Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : DocumentFunctionSymbol Element
Namespace (none)
Type
DocumentFunctionSymbol Simple Type
Diagram
DocumentFunctionSymbol Element
Overview
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
Source
<xs:element name="DocumentFunctionSymbol" type="DocumentFunctionSymbol" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


DocumentNumber Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : DocumentNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocumentNumber Element
Overview
DocumentNumber DocumentNumber Simple Type
Source
<xs:element name="DocumentNumber" type="DocumentNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


DocumentType Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : DocumentType Element
Namespace (none)
Type
DocumentType Simple Type
Diagram
DocumentType Element
Overview
DocumentType DocumentType Simple Type
Source
<xs:element name="DocumentType" type="DocumentType" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


DueDate Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : DueDate Element
Namespace (none)
Type
DueDate Complex Type
Diagram
DueDate Element
Overview
DueDate optional DueDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DueDate" type="DueDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


HTXT Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : HTXT Element
Namespace (none)
Type
HTXT Complex Type
Diagram
HeadText Element Sequence HTXT Element
Overview
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


NAD Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : NAD Element
Namespace (none)
Type
NAD Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element
Overview
NAD 1..99999 NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="99999" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


OrderNumberRef Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : OrderNumberRef Element
Namespace (none)
Type
OrderNumber Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence OrderNumberRef Element
Overview
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


OrderResponseRef Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : OrderResponseRef Element
Namespace (none)
Type
OrderResponseNumber Simple Type
Diagram
OrderResponseRef Element
Overview
OrderResponseRef optional OrderResponseNumber Simple Type
Source
<xs:element name="OrderResponseRef" type="OrderResponseNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


OrderType Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : OrderType Element
Namespace (none)
Type
OrderType Simple Type
Diagram
OrderType Element
Overview
OrderType optional OrderType Simple Type
Source
<xs:element name="OrderType" type="OrderType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


PrevInvoiceRef Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : PrevInvoiceRef Element
Namespace (none)
Type
PrevInvoice Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence PrevInvoiceRef Element
Overview
PrevInvoiceRef optional PrevInvoice Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="PrevInvoiceRef" type="PrevInvoice" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


TechnicalReceiver Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : TechnicalReceiver Element
Description
technical, physical recipient of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiver Element
Overview
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
Source
<xs:element name="TechnicalReceiver" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Empfänger der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical recipient of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


TechnicalReceiverCopy Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : TechnicalReceiverCopy Element
Description
Physical receiver for a copy from this message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiverCopy Element
Overview
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Source
<xs:element name="TechnicalReceiverCopy" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Physischer Empfänger einer Kopie dieser Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Physical receiver for a copy from this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


TechnicalSender Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : TechnicalSender Element
Description
technical, physical sender of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalSender Element
Overview
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
Source
<xs:element name="TechnicalSender" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Versender der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical sender of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


ValueDate Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : ValueDate Element
Namespace (none)
Type
ValueDate Complex Type
Diagram
ValueDate Element
Overview
ValueDate optional ValueDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="ValueDate" type="ValueDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


VersionNumber Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > HEAD Element : VersionNumber Element
Namespace (none)
Type
MessageVersion Complex Type
Diagram
WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element
Overview
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
Source
<xs:element name="VersionNumber" type="MessageVersion" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


LINE Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element : LINE Element
Description
Posiitions of the invoice (INVOIC)
Namespace (none)
Diagram
NumericValue Element TextValue Element OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element VatPercentageOfCondition Element AmountOfCondition Element PercentageRateOfCondition Element DscOfConditionType Element TypeOfCondition Element ConditionLevel Element ConditionIndicator Element Sequence CNDL Element LineText Element Sequence LTXT Element AdditionalDate Element AdditionalQuantity Element Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence AdditionalPrice Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element Sequence AdditionalLineReferences Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence LineVat Element Currency Element Value Element Sequence NetLineAmount Element Currency Element Value Element Sequence DiscountsConditionsTotal Element Currency Element Value Element Sequence GrossLineAmount Element PriceQuantity Element Currency Element Value Element Sequence NetUnitPrice Element PriceQuantity Element Currency Element Value Element Sequence GrossUnitPrice Element InvoiceQuantity Element MEA Element NumberOfPackages Element TypeOfPackaging Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence OrderResponseLineRef Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence DespatchAdviceLineRef Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence OrderLineRef Element Commission Element ClassOfGoodsValue Element ClassOfGoodsFeature Element ClassOfGoodsType Element Sequence ClassOfGoods Element GoodsCountry Element TypeOfProduct Element BatchNumber Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element ParentLineItemNumber Element LineItemNumber Element Sequence LINE Element
Overview
LINE 1..∞
Posiitions of the invoice (INVOIC)
Sequence
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
BatchNumber optional BatchNumber Simple Type
TypeOfProduct optional TypeOfProduct Simple Type
GoodsCountry optional GoodsCountry Simple Type
ClassOfGoods optional ClassOfGoods Complex Type
Sequence
ClassOfGoodsType ClassOfGoodsType Simple Type
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
ClassOfGoodsValue ClassOfGoodsValue Simple Type
Commission optional Commission Simple Type
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
DespatchAdviceLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
OrderResponseLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
MEA 0..20 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
InvoiceQuantity Quantity Complex Type
Unit optional Unit Simple Type
GrossUnitPrice optional GrossUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
NetUnitPrice optional NetUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal optional DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
LineVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LTXT 0..300 LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
CNDL 0..∞ CNDL Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:string
Condition level
TypeOfCondition Restriction of xs:string
Type of condition
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="LINE" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Positionen der Rechnung (INVOIC) </xs:documentation>
    <xs:documentation xml:lang="en">Posiitions of the invoice (INVOIC)  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
      <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
      <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" />
      <xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" />
      <xs:element name="GoodsCountry" type="GoodsCountry" minOccurs="0" />
      <xs:element name="ClassOfGoods" type="ClassOfGoods" minOccurs="0" />
      <xs:element name="Commission" type="Commission" minOccurs="0" />
      <xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" />
      <xs:element name="DespatchAdviceLineRef" type="DocumentLineReference" minOccurs="0" />
      <xs:element name="OrderResponseLineRef" type="DocumentLineReference" minOccurs="0" />
      <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
      <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
      <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="20" />
      <xs:element name="InvoiceQuantity" type="Quantity" />
      <xs:element name="GrossUnitPrice" type="GrossUnitPrice" minOccurs="0" />
      <xs:element name="NetUnitPrice" type="NetUnitPrice" minOccurs="0" />
      <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
      <xs:element name="DiscountsConditionsTotal" type="DiscountsConditionsTotal" minOccurs="0" />
      <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" maxOccurs="1" />
      <xs:element name="LineVat" type="Vat" minOccurs="0" />
      <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
      <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="300" />
      <xs:element name="CNDL" type="CNDL" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


AdditionalLineReferences Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : AdditionalLineReferences Element
Namespace (none)
Type
AdditionalLineReferences Complex Type
Diagram
AdditionalDate Element AdditionalQuantity Element Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence AdditionalPrice Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element Sequence AdditionalLineReferences Element
Overview
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


BatchNumber Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : BatchNumber Element
Namespace (none)
Type
BatchNumber Simple Type
Diagram
BatchNumber Element
Overview
BatchNumber optional BatchNumber Simple Type
Source
<xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


ClassOfGoods Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : ClassOfGoods Element
Namespace (none)
Type
ClassOfGoods Complex Type
Diagram
ClassOfGoodsValue Element ClassOfGoodsFeature Element ClassOfGoodsType Element Sequence ClassOfGoods Element
Overview
ClassOfGoods optional ClassOfGoods Complex Type
Sequence
ClassOfGoodsType ClassOfGoodsType Simple Type
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
ClassOfGoodsValue ClassOfGoodsValue Simple Type
Source
<xs:element name="ClassOfGoods" type="ClassOfGoods" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


CNDL Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : CNDL Element
Namespace (none)
Type
CNDL Complex Type
Diagram
VatPercentageOfCondition Element AmountOfCondition Element PercentageRateOfCondition Element DscOfConditionType Element TypeOfCondition Element ConditionLevel Element ConditionIndicator Element Sequence CNDL Element
Overview
CNDL 0..∞ CNDL Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:string
Condition level
TypeOfCondition Restriction of xs:string
Type of condition
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Source
<xs:element name="CNDL" type="CNDL" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


Commission Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : Commission Element
Namespace (none)
Type
Commission Simple Type
Diagram
Commission Element
Overview
Commission optional Commission Simple Type
Source
<xs:element name="Commission" type="Commission" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


DespatchAdviceLineRef Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : DespatchAdviceLineRef Element
Namespace (none)
Type
DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence DespatchAdviceLineRef Element
Overview
DespatchAdviceLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="DespatchAdviceLineRef" type="DocumentLineReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


DiscountsConditionsTotal Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : DiscountsConditionsTotal Element
Namespace (none)
Type
DiscountsConditionsTotal Complex Type
Diagram
Currency Element Value Element Sequence DiscountsConditionsTotal Element
Overview
DiscountsConditionsTotal optional DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="DiscountsConditionsTotal" type="DiscountsConditionsTotal" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


GoodsCountry Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : GoodsCountry Element
Namespace (none)
Type
GoodsCountry Simple Type
Diagram
GoodsCountry Element
Overview
GoodsCountry optional GoodsCountry Simple Type
Source
<xs:element name="GoodsCountry" type="GoodsCountry" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


GrossLineAmount Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : GrossLineAmount Element
Namespace (none)
Type
GrossLineAmount Complex Type
Diagram
Currency Element Value Element Sequence GrossLineAmount Element
Overview
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


GrossUnitPrice Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : GrossUnitPrice Element
Namespace (none)
Type
GrossUnitPrice Complex Type
Diagram
PriceQuantity Element Currency Element Value Element Sequence GrossUnitPrice Element
Overview
GrossUnitPrice optional GrossUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Source
<xs:element name="GrossUnitPrice" type="GrossUnitPrice" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


InvoiceQuantity Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : InvoiceQuantity Element
Namespace (none)
Type
Quantity Complex Type
Diagram
InvoiceQuantity Element
Overview
InvoiceQuantity Quantity Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="InvoiceQuantity" type="Quantity" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


LineItemNumber Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : LineItemNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
LineItemNumber Element
Overview
LineItemNumber LineItemNumber Simple Type
Source
<xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


LineVat Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : LineVat Element
Namespace (none)
Type
Vat Complex Type
Diagram
Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence LineVat Element
Overview
LineVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="LineVat" type="Vat" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


LTXT Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : LTXT Element
Namespace (none)
Type
LTXT Complex Type
Diagram
LineText Element Sequence LTXT Element
Overview
LTXT 0..300 LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="300" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


MEA Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : MEA Element
Namespace (none)
Type
MEA Complex Type
Diagram
MEA Element
Overview
MEA 0..20 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="20" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


NetLineAmount Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : NetLineAmount Element
Namespace (none)
Type
NetLineAmount Complex Type
Diagram
Currency Element Value Element Sequence NetLineAmount Element
Overview
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


NetUnitPrice Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : NetUnitPrice Element
Namespace (none)
Type
NetUnitPrice Complex Type
Diagram
PriceQuantity Element Currency Element Value Element Sequence NetUnitPrice Element
Overview
NetUnitPrice optional NetUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Source
<xs:element name="NetUnitPrice" type="NetUnitPrice" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


NumberOfPackages Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : NumberOfPackages Element
Namespace (none)
Type
NumberOfPackages Simple Type
Diagram
NumberOfPackages Element
Overview
NumberOfPackages optional NumberOfPackages Simple Type
Source
<xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


OPT Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : OPT Element
Namespace (none)
Type
OPT Complex Type
Diagram
NumericValue Element TextValue Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element
Overview
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


OrderLineRef Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : OrderLineRef Element
Namespace (none)
Type
DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence OrderLineRef Element
Overview
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


OrderResponseLineRef Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : OrderResponseLineRef Element
Namespace (none)
Type
DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence OrderResponseLineRef Element
Overview
OrderResponseLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="OrderResponseLineRef" type="DocumentLineReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


ParentLineItemNumber Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : ParentLineItemNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
ParentLineItemNumber Element
Overview
ParentLineItemNumber optional LineItemNumber Simple Type
Source
<xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


ProductID Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : ProductID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element
Overview
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


SeriesID Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : SeriesID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element
Overview
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


TypeOfPackaging Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : TypeOfPackaging Element
Namespace (none)
Type
TypeOfPackaging Simple Type
Diagram
TypeOfPackaging Element
Overview
TypeOfPackaging optional TypeOfPackaging Simple Type
Source
<xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


TypeOfProduct Element
XML Einrichten Version 1.2 > InvoiceMessage Element > INVOICE Element > LINE Element : TypeOfProduct Element
Namespace (none)
Type
TypeOfProduct Simple Type
Diagram
TypeOfProduct Element
Overview
TypeOfProduct optional TypeOfProduct Simple Type
Source
<xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVOICE Element | InvoiceMessage Element | XML Einrichten Version 1.2


InvrptMessage Element
XML Einrichten Version 1.2 : InvrptMessage Element
Description
Mesage: Inventory (INVRPT)
Namespace (none)
Diagram
INVRPT Element Sequence InvrptMessage Element
Overview
InvrptMessage
Mesage: Inventory (INVRPT)
Sequence
INVRPT 1..∞
Head of the inventory report (INVRPT)
Sequence
HEAD Extension of DocumentHead Complex Type
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
LINE 1..∞
Posiitions of the inventory report (INVRPT)
Sequence
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Orderability optional Orderability Simple Type
Availability optional Availability Simple Type
LeadTimeIfNotAvailable optional Duration Complex Type
Unit optional Unit Simple Type
MVMT MVMT Complex Type
Sequence
DirectionOfMovement optional DirectionOfMovement Simple Type
InventoryType optional InventoryType Simple Type
InventoryMethod optional InventoryMethod Simple Type
InventoryQuantity Quantity Complex Type
Unit optional Unit Simple Type
LocationOfGoods optional LocationOfGoods Simple Type
DateOfInventoryReport optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ExpirationDateStart optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ExpirationDateEnd optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PromotionNumber optional PromotionNumber Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Footer of the inventory report (INVRPT)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="InvrptMessage" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <b>Nachricht: Lagerbestand (INVRPT) </b>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <b>Mesage: Inventory (INVRPT) </b>
    </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="INVRPT" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Kopfteil des Lagerbestandsberichts(INVRPT)  </xs:documentation>
          <xs:documentation xml:lang="en">Head of the inventory report (INVRPT)  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentHead">
                    <xs:sequence>
                      <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Positionen des Lagerbestandsberichts(INVRPT)  </xs:documentation>
                <xs:documentation xml:lang="en">Posiitions of the inventory report (INVRPT)  </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="Orderability" type="Orderability" minOccurs="0" />
                  <xs:element name="Availability" type="Availability" minOccurs="0" />
                  <xs:element name="LeadTimeIfNotAvailable" type="Duration" minOccurs="0" />
                  <xs:element name="MVMT" type="MVMT" minOccurs="1" maxOccurs="1" />
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Abschluss der Bestellung (ORDERdes Lagerbestandsberichts(INVRPT) </xs:documentation>
                <xs:documentation xml:lang="en">Footer of the inventory report (INVRPT)  </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentFoot">
                    <xs:sequence />
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
XML Einrichten Version 1.2


INVRPT Element
XML Einrichten Version 1.2 > InvrptMessage Element : INVRPT Element
Description
Head of the inventory report (INVRPT)
Namespace (none)
Diagram
FOOT Element LINE Element HEAD Element Sequence INVRPT Element
Overview
INVRPT 1..∞
Head of the inventory report (INVRPT)
Sequence
HEAD Extension of DocumentHead Complex Type
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
LINE 1..∞
Posiitions of the inventory report (INVRPT)
Sequence
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Orderability optional Orderability Simple Type
Availability optional Availability Simple Type
LeadTimeIfNotAvailable optional Duration Complex Type
Unit optional Unit Simple Type
MVMT MVMT Complex Type
Sequence
DirectionOfMovement optional DirectionOfMovement Simple Type
InventoryType optional InventoryType Simple Type
InventoryMethod optional InventoryMethod Simple Type
InventoryQuantity Quantity Complex Type
Unit optional Unit Simple Type
LocationOfGoods optional LocationOfGoods Simple Type
DateOfInventoryReport optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ExpirationDateStart optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ExpirationDateEnd optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PromotionNumber optional PromotionNumber Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Footer of the inventory report (INVRPT)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="INVRPT" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kopfteil des Lagerbestandsberichts(INVRPT)  </xs:documentation>
    <xs:documentation xml:lang="en">Head of the inventory report (INVRPT)  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentHead">
              <xs:sequence>
                <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Positionen des Lagerbestandsberichts(INVRPT)  </xs:documentation>
          <xs:documentation xml:lang="en">Posiitions of the inventory report (INVRPT)  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="Orderability" type="Orderability" minOccurs="0" />
            <xs:element name="Availability" type="Availability" minOccurs="0" />
            <xs:element name="LeadTimeIfNotAvailable" type="Duration" minOccurs="0" />
            <xs:element name="MVMT" type="MVMT" minOccurs="1" maxOccurs="1" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Abschluss der Bestellung (ORDERdes Lagerbestandsberichts(INVRPT) </xs:documentation>
          <xs:documentation xml:lang="en">Footer of the inventory report (INVRPT)  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentFoot">
              <xs:sequence />
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
InvrptMessage Element | XML Einrichten Version 1.2


FOOT Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element : FOOT Element
Description
Footer of the inventory report (INVRPT)
Namespace (none)
Type
Extension of DocumentFoot Complex Type
Diagram
SendingDate Element Sequence FOOT Element
Overview
FOOT Extension of DocumentFoot Complex Type
Footer of the inventory report (INVRPT)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="FOOT" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Abschluss der Bestellung (ORDERdes Lagerbestandsberichts(INVRPT) </xs:documentation>
    <xs:documentation xml:lang="en">Footer of the inventory report (INVRPT)  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentFoot">
        <xs:sequence />
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


SendingDate Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > FOOT Element : SendingDate Element
Description
Sending date of this message
Namespace (none)
Type
EDIDate Complex Type
Diagram
SendingDate Element
Overview
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="SendingDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Versanddatum der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Sending date of this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FOOT Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


HEAD Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element : HEAD Element
Namespace (none)
Type
Extension of DocumentHead Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element TechnicalReceiverCopy Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element AdditionalDate Element TechnicalSender Element TechnicalReceiver Element DocumentDate Element DocumentNumber Element DocumentFunctionSymbol Element DocumentType Element WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element Sequence HEAD Element
Overview
HEAD Extension of DocumentHead Complex Type
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="HEAD" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentHead">
        <xs:sequence>
          <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > HEAD Element : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


AdditionalReference Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > HEAD Element : AdditionalReference Element
Namespace (none)
Type
DocumentReferenceQualified Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence AdditionalReference Element
Overview
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalReference" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


DocumentDate Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > HEAD Element : DocumentDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocumentDate Element
Overview
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocumentDate" type="EDIDate" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


DocumentFunctionSymbol Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > HEAD Element : DocumentFunctionSymbol Element
Namespace (none)
Type
DocumentFunctionSymbol Simple Type
Diagram
DocumentFunctionSymbol Element
Overview
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
Source
<xs:element name="DocumentFunctionSymbol" type="DocumentFunctionSymbol" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


DocumentNumber Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > HEAD Element : DocumentNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocumentNumber Element
Overview
DocumentNumber DocumentNumber Simple Type
Source
<xs:element name="DocumentNumber" type="DocumentNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


DocumentType Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > HEAD Element : DocumentType Element
Namespace (none)
Type
DocumentType Simple Type
Diagram
DocumentType Element
Overview
DocumentType DocumentType Simple Type
Source
<xs:element name="DocumentType" type="DocumentType" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


NAD Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > HEAD Element : NAD Element
Namespace (none)
Type
NAD Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element
Overview
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


TechnicalReceiver Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > HEAD Element : TechnicalReceiver Element
Description
technical, physical recipient of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiver Element
Overview
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
Source
<xs:element name="TechnicalReceiver" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Empfänger der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical recipient of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


TechnicalReceiverCopy Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > HEAD Element : TechnicalReceiverCopy Element
Description
Physical receiver for a copy from this message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiverCopy Element
Overview
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Source
<xs:element name="TechnicalReceiverCopy" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Physischer Empfänger einer Kopie dieser Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Physical receiver for a copy from this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


TechnicalSender Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > HEAD Element : TechnicalSender Element
Description
technical, physical sender of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalSender Element
Overview
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
Source
<xs:element name="TechnicalSender" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Versender der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical sender of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


VersionNumber Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > HEAD Element : VersionNumber Element
Namespace (none)
Type
MessageVersion Complex Type
Diagram
WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element
Overview
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
Source
<xs:element name="VersionNumber" type="MessageVersion" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


LINE Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element : LINE Element
Description
Posiitions of the inventory report (INVRPT)
Namespace (none)
Diagram
AdditionalQuantity Element AdditionalDate Element PromotionNumber Element ExpirationDateEnd Element ExpirationDateStart Element DateOfInventoryReport Element LocationOfGoods Element InventoryQuantity Element InventoryMethod Element InventoryType Element DirectionOfMovement Element Sequence MVMT Element LeadTimeIfNotAvailable Element Availability Element Orderability Element NumericValue Element TextValue Element OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element Sequence LINE Element
Overview
LINE 1..∞
Posiitions of the inventory report (INVRPT)
Sequence
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Orderability optional Orderability Simple Type
Availability optional Availability Simple Type
LeadTimeIfNotAvailable optional Duration Complex Type
Unit optional Unit Simple Type
MVMT MVMT Complex Type
Sequence
DirectionOfMovement optional DirectionOfMovement Simple Type
InventoryType optional InventoryType Simple Type
InventoryMethod optional InventoryMethod Simple Type
InventoryQuantity Quantity Complex Type
Unit optional Unit Simple Type
LocationOfGoods optional LocationOfGoods Simple Type
DateOfInventoryReport optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ExpirationDateStart optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ExpirationDateEnd optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PromotionNumber optional PromotionNumber Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
Source
<xs:element name="LINE" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Positionen des Lagerbestandsberichts(INVRPT)  </xs:documentation>
    <xs:documentation xml:lang="en">Posiitions of the inventory report (INVRPT)  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="Orderability" type="Orderability" minOccurs="0" />
      <xs:element name="Availability" type="Availability" minOccurs="0" />
      <xs:element name="LeadTimeIfNotAvailable" type="Duration" minOccurs="0" />
      <xs:element name="MVMT" type="MVMT" minOccurs="1" maxOccurs="1" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


Availability Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > LINE Element : Availability Element
Namespace (none)
Type
Availability Simple Type
Diagram
Availability Element
Overview
Availability optional Availability Simple Type
Source
<xs:element name="Availability" type="Availability" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


LeadTimeIfNotAvailable Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > LINE Element : LeadTimeIfNotAvailable Element
Namespace (none)
Type
Duration Complex Type
Diagram
LeadTimeIfNotAvailable Element
Overview
LeadTimeIfNotAvailable optional Duration Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="LeadTimeIfNotAvailable" type="Duration" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


MVMT Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > LINE Element : MVMT Element
Namespace (none)
Type
MVMT Complex Type
Diagram
AdditionalQuantity Element AdditionalDate Element PromotionNumber Element ExpirationDateEnd Element ExpirationDateStart Element DateOfInventoryReport Element LocationOfGoods Element InventoryQuantity Element InventoryMethod Element InventoryType Element DirectionOfMovement Element Sequence MVMT Element
Overview
MVMT MVMT Complex Type
Sequence
DirectionOfMovement optional DirectionOfMovement Simple Type
InventoryType optional InventoryType Simple Type
InventoryMethod optional InventoryMethod Simple Type
InventoryQuantity Quantity Complex Type
Unit optional Unit Simple Type
LocationOfGoods optional LocationOfGoods Simple Type
DateOfInventoryReport optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ExpirationDateStart optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ExpirationDateEnd optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PromotionNumber optional PromotionNumber Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
Source
<xs:element name="MVMT" type="MVMT" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


OPT Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > LINE Element : OPT Element
Namespace (none)
Type
OPT Complex Type
Diagram
NumericValue Element TextValue Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element
Overview
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


Orderability Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > LINE Element : Orderability Element
Namespace (none)
Type
Orderability Simple Type
Diagram
Orderability Element
Overview
Orderability optional Orderability Simple Type
Source
<xs:element name="Orderability" type="Orderability" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


ProductID Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > LINE Element : ProductID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element
Overview
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


SeriesID Element
XML Einrichten Version 1.2 > InvrptMessage Element > INVRPT Element > LINE Element : SeriesID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element
Overview
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | INVRPT Element | InvrptMessage Element | XML Einrichten Version 1.2


OrdchgMessage Element
XML Einrichten Version 1.2 : OrdchgMessage Element
Description
Mesage: Order Change (ORDCHG)
Namespace (none)
Diagram
ORDCHG Element Sequence OrdchgMessage Element
Overview
OrdchgMessage
Mesage: Order Change (ORDCHG)
Sequence
ORDCHG 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the order change (ORDCGF)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Commission optional Commission Simple Type
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PartialDelivery optional PartialDelivery Simple Type
OrderType optional OrderType Simple Type
OriginalOrderRef optional OriginalOrder Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
BarcodeNumber optional BarcodeNumber Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
LINE 1..∞
Posiitions of the order change(ORDCHG)
Sequence
PositionFunctionSymbol PositionFunctionSymbol Simple Type
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
Commission optional Commission Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
CatalogID optional CatalogID Simple Type
TypeOfProduct optional TypeOfProduct Simple Type
OrderQuantity Quantity Complex Type
Unit optional Unit Simple Type
QTYVar optional QTYVar Simple Type
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
BuyingPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
SalesPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
LineVAT optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
MEA 0..10 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
PACI 0..∞ DocumentPaci Complex Type
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
CODL 0..∞ CODL Complex Type
Sequence
CommandGroup Restriction of xs:string
Command Group
CommandCode optional Restriction of xs:string
Instruction by the client
002 = Assembly
003 = Connection
004 = Adding the goods by the carrier
MULL 0..10 MULL Complex Type
Sequence
FileName Restriction of xs:string
Filename
ObjectID optional Restriction of xs:string
ID of the object within the file
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Footer of the Order change (ORDVHG)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
VatTotal 0..3 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
Source
<xs:element name="OrdchgMessage" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <b>Nachricht: Bestelländerung (ORDCHG) </b>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <b>Mesage: Order  Change (ORDCHG) </b>
    </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ORDCHG" minOccurs="1" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Kopfteil der Bestelländerung (ORCHG)  </xs:documentation>
                <xs:documentation xml:lang="en">Head of the order change (ORDCGF) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentHead">
                    <xs:sequence>
                      <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
                      <xs:element name="Commission" type="Commission" minOccurs="0" />
                      <xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" />
                      <xs:element name="PartialDelivery" type="PartialDelivery" minOccurs="0" />
                      <xs:element name="OrderType" type="OrderType" minOccurs="0" />
                      <xs:element name="OriginalOrderRef" type="OriginalOrder" minOccurs="0" />
                      <xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" />
                      <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
                      <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" />
                      <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" />
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Positionen der Bestelländerung (ORDCHG) </xs:documentation>
                <xs:documentation xml:lang="en">Posiitions of the order change(ORDCHG)  </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PositionFunctionSymbol" type="PositionFunctionSymbol" minOccurs="1" />
                  <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
                  <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
                  <xs:element name="Commission" type="Commission" minOccurs="0" />
                  <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="CatalogID" type="CatalogID" minOccurs="0" />
                  <xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" />
                  <xs:element name="OrderQuantity" type="Quantity" />
                  <xs:element name="QTYVar" type="QTYVar" minOccurs="0" />
                  <xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" />
                  <xs:element name="BuyingPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" />
                  <xs:element name="SalesPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" />
                  <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
                  <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
                  <xs:element name="LineVAT" type="Vat" minOccurs="0" />
                  <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="10" />
                  <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
                  <xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
                  <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
                  <xs:element name="CODL" type="CODL" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="MULL" type="MULL" minOccurs="0" maxOccurs="10" />
                  <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Abschluss der Bestelländeurng (ORDCHG)</xs:documentation>
                <xs:documentation xml:lang="en">Footer of the Order change (ORDVHG) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentFoot">
                    <xs:sequence>
                      <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="3" />
                      <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
XML Einrichten Version 1.2


ORDCHG Element
XML Einrichten Version 1.2 > OrdchgMessage Element : ORDCHG Element
Namespace (none)
Diagram
FOOT Element LINE Element HEAD Element Sequence ORDCHG Element
Overview
ORDCHG 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the order change (ORDCGF)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Commission optional Commission Simple Type
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PartialDelivery optional PartialDelivery Simple Type
OrderType optional OrderType Simple Type
OriginalOrderRef optional OriginalOrder Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
BarcodeNumber optional BarcodeNumber Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
LINE 1..∞
Posiitions of the order change(ORDCHG)
Sequence
PositionFunctionSymbol PositionFunctionSymbol Simple Type
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
Commission optional Commission Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
CatalogID optional CatalogID Simple Type
TypeOfProduct optional TypeOfProduct Simple Type
OrderQuantity Quantity Complex Type
Unit optional Unit Simple Type
QTYVar optional QTYVar Simple Type
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
BuyingPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
SalesPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
LineVAT optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
MEA 0..10 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
PACI 0..∞ DocumentPaci Complex Type
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
CODL 0..∞ CODL Complex Type
Sequence
CommandGroup Restriction of xs:string
Command Group
CommandCode optional Restriction of xs:string
Instruction by the client
002 = Assembly
003 = Connection
004 = Adding the goods by the carrier
MULL 0..10 MULL Complex Type
Sequence
FileName Restriction of xs:string
Filename
ObjectID optional Restriction of xs:string
ID of the object within the file
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Footer of the Order change (ORDVHG)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
VatTotal 0..3 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
Source
<xs:element name="ORDCHG" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Kopfteil der Bestelländerung (ORCHG)  </xs:documentation>
          <xs:documentation xml:lang="en">Head of the order change (ORDCGF) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentHead">
              <xs:sequence>
                <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
                <xs:element name="Commission" type="Commission" minOccurs="0" />
                <xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" />
                <xs:element name="PartialDelivery" type="PartialDelivery" minOccurs="0" />
                <xs:element name="OrderType" type="OrderType" minOccurs="0" />
                <xs:element name="OriginalOrderRef" type="OriginalOrder" minOccurs="0" />
                <xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" />
                <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
                <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" />
                <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" />
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Positionen der Bestelländerung (ORDCHG) </xs:documentation>
          <xs:documentation xml:lang="en">Posiitions of the order change(ORDCHG)  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PositionFunctionSymbol" type="PositionFunctionSymbol" minOccurs="1" />
            <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
            <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
            <xs:element name="Commission" type="Commission" minOccurs="0" />
            <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="CatalogID" type="CatalogID" minOccurs="0" />
            <xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" />
            <xs:element name="OrderQuantity" type="Quantity" />
            <xs:element name="QTYVar" type="QTYVar" minOccurs="0" />
            <xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" />
            <xs:element name="BuyingPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" />
            <xs:element name="SalesPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" />
            <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
            <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
            <xs:element name="LineVAT" type="Vat" minOccurs="0" />
            <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="10" />
            <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
            <xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
            <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
            <xs:element name="CODL" type="CODL" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="MULL" type="MULL" minOccurs="0" maxOccurs="10" />
            <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Abschluss der Bestelländeurng (ORDCHG)</xs:documentation>
          <xs:documentation xml:lang="en">Footer of the Order change (ORDVHG) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentFoot">
              <xs:sequence>
                <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="3" />
                <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
OrdchgMessage Element | XML Einrichten Version 1.2


FOOT Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element : FOOT Element
Description
Footer of the Order change (ORDVHG)
Namespace (none)
Type
Extension of DocumentFoot Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence AdditionalAmounts Element Currency Element Value Element Sequence DiscountsConditionsTotal Element Currency Element Value Element Sequence NetItemAmount Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence VatTotal Element SendingDate Element Sequence FOOT Element
Overview
FOOT Extension of DocumentFoot Complex Type
Footer of the Order change (ORDVHG)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
VatTotal 0..3 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
Source
<xs:element name="FOOT" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Abschluss der Bestelländeurng (ORDCHG)</xs:documentation>
    <xs:documentation xml:lang="en">Footer of the Order change (ORDVHG) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentFoot">
        <xs:sequence>
          <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="3" />
          <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


AdditionalAmounts Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > FOOT Element : AdditionalAmounts Element
Namespace (none)
Type
TotalAmountQualified Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence AdditionalAmounts Element
Overview
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
Source
<xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FOOT Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


SendingDate Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > FOOT Element : SendingDate Element
Description
Sending date of this message
Namespace (none)
Type
EDIDate Complex Type
Diagram
SendingDate Element
Overview
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="SendingDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Versanddatum der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Sending date of this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FOOT Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


VatTotal Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > FOOT Element : VatTotal Element
Namespace (none)
Type
VatTotal Complex Type
Diagram
Currency Element Value Element Sequence DiscountsConditionsTotal Element Currency Element Value Element Sequence NetItemAmount Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence VatTotal Element
Overview
VatTotal 0..3 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FOOT Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


HEAD Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element : HEAD Element
Description
Head of the order change (ORDCGF)
Namespace (none)
Type
Extension of DocumentHead Complex Type
Diagram
AppTargetIdentification Element AppSourceIdentification Element ObjectContent Element Source Element RemoteType Element FunctionType Element ObjectType Element ObjectDescription Element FileName Element Sequence MULH Element HeadText Element Sequence HTXT Element FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element BarcodeNumber Element DocDate Element DocRefNumber Element Sequence OriginalOrderRef Element OrderType Element PartialDelivery Element RequestedDeliveryDate Element Commission Element DocDate Element DocRefNumber Element Sequence OrderNumberRef Element TechnicalReceiverCopy Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element AdditionalDate Element TechnicalSender Element TechnicalReceiver Element DocumentDate Element DocumentNumber Element DocumentFunctionSymbol Element DocumentType Element WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element Sequence HEAD Element
Overview
HEAD Extension of DocumentHead Complex Type
Head of the order change (ORDCGF)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Commission optional Commission Simple Type
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PartialDelivery optional PartialDelivery Simple Type
OrderType optional OrderType Simple Type
OriginalOrderRef optional OriginalOrder Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
BarcodeNumber optional BarcodeNumber Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
Source
<xs:element name="HEAD" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kopfteil der Bestelländerung (ORCHG)  </xs:documentation>
    <xs:documentation xml:lang="en">Head of the order change (ORDCGF) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentHead">
        <xs:sequence>
          <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
          <xs:element name="Commission" type="Commission" minOccurs="0" />
          <xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" />
          <xs:element name="PartialDelivery" type="PartialDelivery" minOccurs="0" />
          <xs:element name="OrderType" type="OrderType" minOccurs="0" />
          <xs:element name="OriginalOrderRef" type="OriginalOrder" minOccurs="0" />
          <xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" />
          <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
          <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" />
          <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" />
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


AdditionalReference Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : AdditionalReference Element
Namespace (none)
Type
DocumentReferenceQualified Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence AdditionalReference Element
Overview
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalReference" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


BarcodeNumber Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : BarcodeNumber Element
Namespace (none)
Type
BarcodeNumber Simple Type
Diagram
BarcodeNumber Element
Overview
BarcodeNumber optional BarcodeNumber Simple Type
Source
<xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


Commission Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : Commission Element
Namespace (none)
Type
Commission Simple Type
Diagram
Commission Element
Overview
Commission optional Commission Simple Type
Source
<xs:element name="Commission" type="Commission" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


DocumentDate Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : DocumentDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocumentDate Element
Overview
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocumentDate" type="EDIDate" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


DocumentFunctionSymbol Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : DocumentFunctionSymbol Element
Namespace (none)
Type
DocumentFunctionSymbol Simple Type
Diagram
DocumentFunctionSymbol Element
Overview
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
Source
<xs:element name="DocumentFunctionSymbol" type="DocumentFunctionSymbol" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


DocumentNumber Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : DocumentNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocumentNumber Element
Overview
DocumentNumber DocumentNumber Simple Type
Source
<xs:element name="DocumentNumber" type="DocumentNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


DocumentType Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : DocumentType Element
Namespace (none)
Type
DocumentType Simple Type
Diagram
DocumentType Element
Overview
DocumentType DocumentType Simple Type
Source
<xs:element name="DocumentType" type="DocumentType" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


HTXT Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : HTXT Element
Namespace (none)
Type
HTXT Complex Type
Diagram
HeadText Element Sequence HTXT Element
Overview
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


MULH Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : MULH Element
Namespace (none)
Type
MULH Complex Type
Diagram
AppTargetIdentification Element AppSourceIdentification Element ObjectContent Element Source Element RemoteType Element FunctionType Element ObjectType Element ObjectDescription Element FileName Element Sequence MULH Element
Overview
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
Source
<xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


NAD Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : NAD Element
Namespace (none)
Type
NAD Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element
Overview
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


OrderNumberRef Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : OrderNumberRef Element
Namespace (none)
Type
OrderNumber Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence OrderNumberRef Element
Overview
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


OrderType Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : OrderType Element
Namespace (none)
Type
OrderType Simple Type
Diagram
OrderType Element
Overview
OrderType optional OrderType Simple Type
Source
<xs:element name="OrderType" type="OrderType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


OriginalOrderRef Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : OriginalOrderRef Element
Namespace (none)
Type
OriginalOrder Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence OriginalOrderRef Element
Overview
OriginalOrderRef optional OriginalOrder Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OriginalOrderRef" type="OriginalOrder" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


PartialDelivery Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : PartialDelivery Element
Namespace (none)
Type
PartialDelivery Simple Type
Diagram
PartialDelivery Element
Overview
PartialDelivery optional PartialDelivery Simple Type
Source
<xs:element name="PartialDelivery" type="PartialDelivery" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


RequestedDeliveryDate Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : RequestedDeliveryDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
RequestedDeliveryDate Element
Overview
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


TechnicalReceiver Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : TechnicalReceiver Element
Description
technical, physical recipient of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiver Element
Overview
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
Source
<xs:element name="TechnicalReceiver" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Empfänger der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical recipient of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


TechnicalReceiverCopy Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : TechnicalReceiverCopy Element
Description
Physical receiver for a copy from this message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiverCopy Element
Overview
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Source
<xs:element name="TechnicalReceiverCopy" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Physischer Empfänger einer Kopie dieser Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Physical receiver for a copy from this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


TechnicalSender Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : TechnicalSender Element
Description
technical, physical sender of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalSender Element
Overview
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
Source
<xs:element name="TechnicalSender" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Versender der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical sender of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


VersionNumber Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > HEAD Element : VersionNumber Element
Namespace (none)
Type
MessageVersion Complex Type
Diagram
WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element
Overview
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
Source
<xs:element name="VersionNumber" type="MessageVersion" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


LINE Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element : LINE Element
Description
Posiitions of the order change(ORDCHG)
Namespace (none)
Diagram
NumericValue Element TextValue Element OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element ObjectID Element FileName Element Sequence MULL Element CommandCode Element CommandGroup Element Sequence CODL Element LineText Element Sequence LTXT Element AdditionalDate Element AdditionalQuantity Element Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence AdditionalPrice Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element Sequence AdditionalLineReferences Element MEA Element ConsumerInstructions Element ShippingMark Element TypeOfShippingMark Element LoadingTackle Element TypeOfPackaging Element NumberOfPackages Element ParentPaciNumber Element PaciNumber Element Sequence PACI Element TypeOfPackaging Element MEA Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence LineVAT Element Currency Element Value Element Sequence NetLineAmount Element Currency Element Value Element Sequence GrossLineAmount Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence SalesPrice Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence BuyingPrice Element RequestedDeliveryDate Element QTYVar Element OrderQuantity Element TypeOfProduct Element CatalogID Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element Commission Element ParentLineItemNumber Element LineItemNumber Element PositionFunctionSymbol Element Sequence LINE Element
Overview
LINE 1..∞
Posiitions of the order change(ORDCHG)
Sequence
PositionFunctionSymbol PositionFunctionSymbol Simple Type
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
Commission optional Commission Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
CatalogID optional CatalogID Simple Type
TypeOfProduct optional TypeOfProduct Simple Type
OrderQuantity Quantity Complex Type
Unit optional Unit Simple Type
QTYVar optional QTYVar Simple Type
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
BuyingPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
SalesPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
LineVAT optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
MEA 0..10 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
PACI 0..∞ DocumentPaci Complex Type
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
CODL 0..∞ CODL Complex Type
Sequence
CommandGroup Restriction of xs:string
Command Group
CommandCode optional Restriction of xs:string
Instruction by the client
002 = Assembly
003 = Connection
004 = Adding the goods by the carrier
MULL 0..10 MULL Complex Type
Sequence
FileName Restriction of xs:string
Filename
ObjectID optional Restriction of xs:string
ID of the object within the file
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="LINE" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Positionen der Bestelländerung (ORDCHG) </xs:documentation>
    <xs:documentation xml:lang="en">Posiitions of the order change(ORDCHG)  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PositionFunctionSymbol" type="PositionFunctionSymbol" minOccurs="1" />
      <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
      <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
      <xs:element name="Commission" type="Commission" minOccurs="0" />
      <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="CatalogID" type="CatalogID" minOccurs="0" />
      <xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" />
      <xs:element name="OrderQuantity" type="Quantity" />
      <xs:element name="QTYVar" type="QTYVar" minOccurs="0" />
      <xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" />
      <xs:element name="BuyingPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" />
      <xs:element name="SalesPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" />
      <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
      <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
      <xs:element name="LineVAT" type="Vat" minOccurs="0" />
      <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="10" />
      <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
      <xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
      <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
      <xs:element name="CODL" type="CODL" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="MULL" type="MULL" minOccurs="0" maxOccurs="10" />
      <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


AdditionalLineReferences Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : AdditionalLineReferences Element
Namespace (none)
Type
AdditionalLineReferences Complex Type
Diagram
AdditionalDate Element AdditionalQuantity Element Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence AdditionalPrice Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element Sequence AdditionalLineReferences Element
Overview
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


BuyingPrice Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : BuyingPrice Element
Namespace (none)
Type
PriceQualified Complex Type
Diagram
Qualifier Element PriceQuantity Element Currency Element Value Element Sequence BuyingPrice Element
Overview
BuyingPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
Source
<xs:element name="BuyingPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


CatalogID Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : CatalogID Element
Namespace (none)
Type
CatalogID Simple Type
Diagram
CatalogID Element
Overview
CatalogID optional CatalogID Simple Type
Source
<xs:element name="CatalogID" type="CatalogID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


CODL Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : CODL Element
Namespace (none)
Type
CODL Complex Type
Diagram
CommandCode Element CommandGroup Element Sequence CODL Element
Overview
CODL 0..∞ CODL Complex Type
Sequence
CommandGroup Restriction of xs:string
Command Group
CommandCode optional Restriction of xs:string
Instruction by the client
002 = Assembly
003 = Connection
004 = Adding the goods by the carrier
Source
<xs:element name="CODL" type="CODL" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


Commission Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : Commission Element
Namespace (none)
Type
Commission Simple Type
Diagram
Commission Element
Overview
Commission optional Commission Simple Type
Source
<xs:element name="Commission" type="Commission" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


GrossLineAmount Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : GrossLineAmount Element
Namespace (none)
Type
GrossLineAmount Complex Type
Diagram
Currency Element Value Element Sequence GrossLineAmount Element
Overview
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


LineItemNumber Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : LineItemNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
LineItemNumber Element
Overview
LineItemNumber LineItemNumber Simple Type
Source
<xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


LineVAT Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : LineVAT Element
Namespace (none)
Type
Vat Complex Type
Diagram
Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence LineVAT Element
Overview
LineVAT optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="LineVAT" type="Vat" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


LTXT Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : LTXT Element
Namespace (none)
Type
LTXT Complex Type
Diagram
LineText Element Sequence LTXT Element
Overview
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


MEA Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : MEA Element
Namespace (none)
Type
MEA Complex Type
Diagram
MEA Element
Overview
MEA 0..10 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="10" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


MULL Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : MULL Element
Namespace (none)
Type
MULL Complex Type
Diagram
ObjectID Element FileName Element Sequence MULL Element
Overview
MULL 0..10 MULL Complex Type
Sequence
FileName Restriction of xs:string
Filename
ObjectID optional Restriction of xs:string
ID of the object within the file
Source
<xs:element name="MULL" type="MULL" minOccurs="0" maxOccurs="10" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


NetLineAmount Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : NetLineAmount Element
Namespace (none)
Type
NetLineAmount Complex Type
Diagram
Currency Element Value Element Sequence NetLineAmount Element
Overview
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


OPT Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : OPT Element
Namespace (none)
Type
OPT Complex Type
Diagram
NumericValue Element TextValue Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element
Overview
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


OrderQuantity Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : OrderQuantity Element
Namespace (none)
Type
Quantity Complex Type
Diagram
OrderQuantity Element
Overview
OrderQuantity Quantity Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OrderQuantity" type="Quantity" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


PACI Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : PACI Element
Namespace (none)
Type
DocumentPaci Complex Type
Diagram
MEA Element ConsumerInstructions Element ShippingMark Element TypeOfShippingMark Element LoadingTackle Element TypeOfPackaging Element NumberOfPackages Element ParentPaciNumber Element PaciNumber Element Sequence PACI Element
Overview
PACI 0..∞ DocumentPaci Complex Type
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


ParentLineItemNumber Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : ParentLineItemNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
ParentLineItemNumber Element
Overview
ParentLineItemNumber optional LineItemNumber Simple Type
Source
<xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


PositionFunctionSymbol Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : PositionFunctionSymbol Element
Namespace (none)
Type
PositionFunctionSymbol Simple Type
Diagram
PositionFunctionSymbol Element
Overview
PositionFunctionSymbol PositionFunctionSymbol Simple Type
Source
<xs:element name="PositionFunctionSymbol" type="PositionFunctionSymbol" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


ProductID Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : ProductID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element
Overview
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


QTYVar Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : QTYVar Element
Namespace (none)
Type
QTYVar Simple Type
Diagram
QTYVar Element
Overview
QTYVar optional QTYVar Simple Type
Source
<xs:element name="QTYVar" type="QTYVar" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


RequestedDeliveryDate Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : RequestedDeliveryDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
RequestedDeliveryDate Element
Overview
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


SalesPrice Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : SalesPrice Element
Namespace (none)
Type
PriceQualified Complex Type
Diagram
Qualifier Element PriceQuantity Element Currency Element Value Element Sequence SalesPrice Element
Overview
SalesPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
Source
<xs:element name="SalesPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


SeriesID Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : SeriesID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element
Overview
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


TypeOfPackaging Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : TypeOfPackaging Element
Namespace (none)
Type
TypeOfPackaging Simple Type
Diagram
TypeOfPackaging Element
Overview
TypeOfPackaging optional TypeOfPackaging Simple Type
Source
<xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


TypeOfProduct Element
XML Einrichten Version 1.2 > OrdchgMessage Element > ORDCHG Element > LINE Element : TypeOfProduct Element
Namespace (none)
Type
TypeOfProduct Simple Type
Diagram
TypeOfProduct Element
Overview
TypeOfProduct optional TypeOfProduct Simple Type
Source
<xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDCHG Element | OrdchgMessage Element | XML Einrichten Version 1.2


OrderMessage Element
XML Einrichten Version 1.2 : OrderMessage Element
Description
Mesage: Order (ORDERS)
Namespace (none)
Diagram
ORDER Element Sequence OrderMessage Element
Overview
OrderMessage
Mesage: Order (ORDERS)
Sequence
ORDER 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the order (ORDER)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Commission optional Commission Simple Type
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PartialDelivery optional PartialDelivery Simple Type
OrderType optional OrderType Simple Type
OriginalOrderRef optional OriginalOrder Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
BarcodeNumber optional BarcodeNumber Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
LINE 1..∞
Posiitions of the order (ORDER)
Sequence
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
Commission optional Commission Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
CatalogID optional CatalogID Simple Type
TypeOfProduct optional TypeOfProduct Simple Type
OrderQuantity Quantity Complex Type
Unit optional Unit Simple Type
QTYVar optional QTYVar Simple Type
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
BuyingPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
SalesPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
LineVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
MEA 0..10 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
PACI 0..∞ DocumentPaci Complex Type
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
CODL 0..∞ CODL Complex Type
Sequence
CommandGroup Restriction of xs:string
Command Group
CommandCode optional Restriction of xs:string
Instruction by the client
002 = Assembly
003 = Connection
004 = Adding the goods by the carrier
MULL 0..10 MULL Complex Type
Sequence
FileName Restriction of xs:string
Filename
ObjectID optional Restriction of xs:string
ID of the object within the file
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Footer of the Order (ORDER)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
VatTotal 0..5 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
Source
<xs:element name="OrderMessage" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <b>Nachricht: Bestellung (ORDERS) </b>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <b>Mesage: Order (ORDERS) </b>
    </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ORDER" minOccurs="1" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Kopfteil der Bestellung (ORDER)  </xs:documentation>
                <xs:documentation xml:lang="en">Head of the order (ORDER) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentHead">
                    <xs:sequence>
                      <xs:element name="Commission" type="Commission" minOccurs="0" />
                      <xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" />
                      <xs:element name="PartialDelivery" type="PartialDelivery" minOccurs="0" />
                      <xs:element name="OrderType" type="OrderType" minOccurs="0" />
                      <xs:element name="OriginalOrderRef" type="OriginalOrder" minOccurs="0" />
                      <xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" />
                      <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
                      <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" />
                      <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" />
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Positionen der Bestellung (ORDER) </xs:documentation>
                <xs:documentation xml:lang="en">Posiitions of the order (ORDER)  </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
                  <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
                  <xs:element name="Commission" type="Commission" minOccurs="0" />
                  <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="CatalogID" type="CatalogID" minOccurs="0" />
                  <xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" />
                  <xs:element name="OrderQuantity" type="Quantity" />
                  <xs:element name="QTYVar" type="QTYVar" minOccurs="0" />
                  <xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" />
                  <xs:element name="BuyingPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" />
                  <xs:element name="SalesPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" />
                  <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
                  <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
                  <xs:element name="LineVat" type="Vat" minOccurs="0" />
                  <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="10" />
                  <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
                  <xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
                  <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
                  <xs:element name="CODL" type="CODL" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="MULL" type="MULL" minOccurs="0" maxOccurs="10" />
                  <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Abschluss der Bestellung (ORDER)</xs:documentation>
                <xs:documentation xml:lang="en">Footer of the Order (ORDER) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentFoot">
                    <xs:sequence>
                      <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="5" />
                      <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
XML Einrichten Version 1.2


ORDER Element
XML Einrichten Version 1.2 > OrderMessage Element : ORDER Element
Namespace (none)
Diagram
FOOT Element LINE Element HEAD Element Sequence ORDER Element
Overview
ORDER 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the order (ORDER)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Commission optional Commission Simple Type
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PartialDelivery optional PartialDelivery Simple Type
OrderType optional OrderType Simple Type
OriginalOrderRef optional OriginalOrder Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
BarcodeNumber optional BarcodeNumber Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
LINE 1..∞
Posiitions of the order (ORDER)
Sequence
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
Commission optional Commission Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
CatalogID optional CatalogID Simple Type
TypeOfProduct optional TypeOfProduct Simple Type
OrderQuantity Quantity Complex Type
Unit optional Unit Simple Type
QTYVar optional QTYVar Simple Type
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
BuyingPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
SalesPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
LineVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
MEA 0..10 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
PACI 0..∞ DocumentPaci Complex Type
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
CODL 0..∞ CODL Complex Type
Sequence
CommandGroup Restriction of xs:string
Command Group
CommandCode optional Restriction of xs:string
Instruction by the client
002 = Assembly
003 = Connection
004 = Adding the goods by the carrier
MULL 0..10 MULL Complex Type
Sequence
FileName Restriction of xs:string
Filename
ObjectID optional Restriction of xs:string
ID of the object within the file
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Footer of the Order (ORDER)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
VatTotal 0..5 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
Source
<xs:element name="ORDER" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Kopfteil der Bestellung (ORDER)  </xs:documentation>
          <xs:documentation xml:lang="en">Head of the order (ORDER) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentHead">
              <xs:sequence>
                <xs:element name="Commission" type="Commission" minOccurs="0" />
                <xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" />
                <xs:element name="PartialDelivery" type="PartialDelivery" minOccurs="0" />
                <xs:element name="OrderType" type="OrderType" minOccurs="0" />
                <xs:element name="OriginalOrderRef" type="OriginalOrder" minOccurs="0" />
                <xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" />
                <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
                <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" />
                <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" />
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Positionen der Bestellung (ORDER) </xs:documentation>
          <xs:documentation xml:lang="en">Posiitions of the order (ORDER)  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
            <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
            <xs:element name="Commission" type="Commission" minOccurs="0" />
            <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="CatalogID" type="CatalogID" minOccurs="0" />
            <xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" />
            <xs:element name="OrderQuantity" type="Quantity" />
            <xs:element name="QTYVar" type="QTYVar" minOccurs="0" />
            <xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" />
            <xs:element name="BuyingPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" />
            <xs:element name="SalesPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" />
            <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
            <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
            <xs:element name="LineVat" type="Vat" minOccurs="0" />
            <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="10" />
            <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
            <xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
            <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
            <xs:element name="CODL" type="CODL" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="MULL" type="MULL" minOccurs="0" maxOccurs="10" />
            <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Abschluss der Bestellung (ORDER)</xs:documentation>
          <xs:documentation xml:lang="en">Footer of the Order (ORDER) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentFoot">
              <xs:sequence>
                <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="5" />
                <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
OrderMessage Element | XML Einrichten Version 1.2


FOOT Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element : FOOT Element
Description
Footer of the Order (ORDER)
Namespace (none)
Type
Extension of DocumentFoot Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence AdditionalAmounts Element Currency Element Value Element Sequence DiscountsConditionsTotal Element Currency Element Value Element Sequence NetItemAmount Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence VatTotal Element SendingDate Element Sequence FOOT Element
Overview
FOOT Extension of DocumentFoot Complex Type
Footer of the Order (ORDER)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
VatTotal 0..5 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
Source
<xs:element name="FOOT" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Abschluss der Bestellung (ORDER)</xs:documentation>
    <xs:documentation xml:lang="en">Footer of the Order (ORDER) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentFoot">
        <xs:sequence>
          <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="5" />
          <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


AdditionalAmounts Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > FOOT Element : AdditionalAmounts Element
Namespace (none)
Type
TotalAmountQualified Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence AdditionalAmounts Element
Overview
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
Source
<xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FOOT Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


SendingDate Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > FOOT Element : SendingDate Element
Description
Sending date of this message
Namespace (none)
Type
EDIDate Complex Type
Diagram
SendingDate Element
Overview
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="SendingDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Versanddatum der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Sending date of this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FOOT Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


VatTotal Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > FOOT Element : VatTotal Element
Namespace (none)
Type
VatTotal Complex Type
Diagram
Currency Element Value Element Sequence DiscountsConditionsTotal Element Currency Element Value Element Sequence NetItemAmount Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence VatTotal Element
Overview
VatTotal 0..5 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="5" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FOOT Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


HEAD Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element : HEAD Element
Description
Head of the order (ORDER)
Namespace (none)
Type
Extension of DocumentHead Complex Type
Diagram
AppTargetIdentification Element AppSourceIdentification Element ObjectContent Element Source Element RemoteType Element FunctionType Element ObjectType Element ObjectDescription Element FileName Element Sequence MULH Element HeadText Element Sequence HTXT Element FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element BarcodeNumber Element DocDate Element DocRefNumber Element Sequence OriginalOrderRef Element OrderType Element PartialDelivery Element RequestedDeliveryDate Element Commission Element TechnicalReceiverCopy Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element AdditionalDate Element TechnicalSender Element TechnicalReceiver Element DocumentDate Element DocumentNumber Element DocumentFunctionSymbol Element DocumentType Element WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element Sequence HEAD Element
Overview
HEAD Extension of DocumentHead Complex Type
Head of the order (ORDER)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Commission optional Commission Simple Type
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PartialDelivery optional PartialDelivery Simple Type
OrderType optional OrderType Simple Type
OriginalOrderRef optional OriginalOrder Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
BarcodeNumber optional BarcodeNumber Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
Source
<xs:element name="HEAD" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kopfteil der Bestellung (ORDER)  </xs:documentation>
    <xs:documentation xml:lang="en">Head of the order (ORDER) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentHead">
        <xs:sequence>
          <xs:element name="Commission" type="Commission" minOccurs="0" />
          <xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" />
          <xs:element name="PartialDelivery" type="PartialDelivery" minOccurs="0" />
          <xs:element name="OrderType" type="OrderType" minOccurs="0" />
          <xs:element name="OriginalOrderRef" type="OriginalOrder" minOccurs="0" />
          <xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" />
          <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
          <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" />
          <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" />
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


AdditionalReference Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : AdditionalReference Element
Namespace (none)
Type
DocumentReferenceQualified Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence AdditionalReference Element
Overview
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalReference" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


BarcodeNumber Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : BarcodeNumber Element
Namespace (none)
Type
BarcodeNumber Simple Type
Diagram
BarcodeNumber Element
Overview
BarcodeNumber optional BarcodeNumber Simple Type
Source
<xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


Commission Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : Commission Element
Namespace (none)
Type
Commission Simple Type
Diagram
Commission Element
Overview
Commission optional Commission Simple Type
Source
<xs:element name="Commission" type="Commission" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


DocumentDate Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : DocumentDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocumentDate Element
Overview
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocumentDate" type="EDIDate" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


DocumentFunctionSymbol Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : DocumentFunctionSymbol Element
Namespace (none)
Type
DocumentFunctionSymbol Simple Type
Diagram
DocumentFunctionSymbol Element
Overview
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
Source
<xs:element name="DocumentFunctionSymbol" type="DocumentFunctionSymbol" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


DocumentNumber Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : DocumentNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocumentNumber Element
Overview
DocumentNumber DocumentNumber Simple Type
Source
<xs:element name="DocumentNumber" type="DocumentNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


DocumentType Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : DocumentType Element
Namespace (none)
Type
DocumentType Simple Type
Diagram
DocumentType Element
Overview
DocumentType DocumentType Simple Type
Source
<xs:element name="DocumentType" type="DocumentType" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


HTXT Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : HTXT Element
Namespace (none)
Type
HTXT Complex Type
Diagram
HeadText Element Sequence HTXT Element
Overview
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


MULH Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : MULH Element
Namespace (none)
Type
MULH Complex Type
Diagram
AppTargetIdentification Element AppSourceIdentification Element ObjectContent Element Source Element RemoteType Element FunctionType Element ObjectType Element ObjectDescription Element FileName Element Sequence MULH Element
Overview
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
Source
<xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


NAD Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : NAD Element
Namespace (none)
Type
NAD Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element
Overview
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


OrderType Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : OrderType Element
Namespace (none)
Type
OrderType Simple Type
Diagram
OrderType Element
Overview
OrderType optional OrderType Simple Type
Source
<xs:element name="OrderType" type="OrderType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


OriginalOrderRef Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : OriginalOrderRef Element
Namespace (none)
Type
OriginalOrder Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence OriginalOrderRef Element
Overview
OriginalOrderRef optional OriginalOrder Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OriginalOrderRef" type="OriginalOrder" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


PartialDelivery Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : PartialDelivery Element
Namespace (none)
Type
PartialDelivery Simple Type
Diagram
PartialDelivery Element
Overview
PartialDelivery optional PartialDelivery Simple Type
Source
<xs:element name="PartialDelivery" type="PartialDelivery" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


RequestedDeliveryDate Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : RequestedDeliveryDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
RequestedDeliveryDate Element
Overview
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


TechnicalReceiver Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : TechnicalReceiver Element
Description
technical, physical recipient of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiver Element
Overview
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
Source
<xs:element name="TechnicalReceiver" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Empfänger der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical recipient of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


TechnicalReceiverCopy Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : TechnicalReceiverCopy Element
Description
Physical receiver for a copy from this message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiverCopy Element
Overview
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Source
<xs:element name="TechnicalReceiverCopy" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Physischer Empfänger einer Kopie dieser Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Physical receiver for a copy from this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


TechnicalSender Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : TechnicalSender Element
Description
technical, physical sender of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalSender Element
Overview
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
Source
<xs:element name="TechnicalSender" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Versender der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical sender of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


VersionNumber Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > HEAD Element : VersionNumber Element
Namespace (none)
Type
MessageVersion Complex Type
Diagram
WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element
Overview
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
Source
<xs:element name="VersionNumber" type="MessageVersion" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


LINE Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element : LINE Element
Description
Posiitions of the order (ORDER)
Namespace (none)
Diagram
NumericValue Element TextValue Element OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element ObjectID Element FileName Element Sequence MULL Element CommandCode Element CommandGroup Element Sequence CODL Element LineText Element Sequence LTXT Element AdditionalDate Element AdditionalQuantity Element Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence AdditionalPrice Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element Sequence AdditionalLineReferences Element MEA Element ConsumerInstructions Element ShippingMark Element TypeOfShippingMark Element LoadingTackle Element TypeOfPackaging Element NumberOfPackages Element ParentPaciNumber Element PaciNumber Element Sequence PACI Element TypeOfPackaging Element MEA Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence LineVat Element Currency Element Value Element Sequence NetLineAmount Element Currency Element Value Element Sequence GrossLineAmount Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence SalesPrice Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence BuyingPrice Element RequestedDeliveryDate Element QTYVar Element OrderQuantity Element TypeOfProduct Element CatalogID Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element Commission Element ParentLineItemNumber Element LineItemNumber Element Sequence LINE Element
Overview
LINE 1..∞
Posiitions of the order (ORDER)
Sequence
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
Commission optional Commission Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
CatalogID optional CatalogID Simple Type
TypeOfProduct optional TypeOfProduct Simple Type
OrderQuantity Quantity Complex Type
Unit optional Unit Simple Type
QTYVar optional QTYVar Simple Type
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
BuyingPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
SalesPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
LineVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
MEA 0..10 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
PACI 0..∞ DocumentPaci Complex Type
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
CODL 0..∞ CODL Complex Type
Sequence
CommandGroup Restriction of xs:string
Command Group
CommandCode optional Restriction of xs:string
Instruction by the client
002 = Assembly
003 = Connection
004 = Adding the goods by the carrier
MULL 0..10 MULL Complex Type
Sequence
FileName Restriction of xs:string
Filename
ObjectID optional Restriction of xs:string
ID of the object within the file
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="LINE" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Positionen der Bestellung (ORDER) </xs:documentation>
    <xs:documentation xml:lang="en">Posiitions of the order (ORDER)  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
      <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
      <xs:element name="Commission" type="Commission" minOccurs="0" />
      <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="CatalogID" type="CatalogID" minOccurs="0" />
      <xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" />
      <xs:element name="OrderQuantity" type="Quantity" />
      <xs:element name="QTYVar" type="QTYVar" minOccurs="0" />
      <xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" />
      <xs:element name="BuyingPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" />
      <xs:element name="SalesPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" />
      <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
      <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
      <xs:element name="LineVat" type="Vat" minOccurs="0" />
      <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="10" />
      <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
      <xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
      <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
      <xs:element name="CODL" type="CODL" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="MULL" type="MULL" minOccurs="0" maxOccurs="10" />
      <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


AdditionalLineReferences Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : AdditionalLineReferences Element
Namespace (none)
Type
AdditionalLineReferences Complex Type
Diagram
AdditionalDate Element AdditionalQuantity Element Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence AdditionalPrice Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element Sequence AdditionalLineReferences Element
Overview
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


BuyingPrice Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : BuyingPrice Element
Namespace (none)
Type
PriceQualified Complex Type
Diagram
Qualifier Element PriceQuantity Element Currency Element Value Element Sequence BuyingPrice Element
Overview
BuyingPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
Source
<xs:element name="BuyingPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


CatalogID Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : CatalogID Element
Namespace (none)
Type
CatalogID Simple Type
Diagram
CatalogID Element
Overview
CatalogID optional CatalogID Simple Type
Source
<xs:element name="CatalogID" type="CatalogID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


CODL Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : CODL Element
Namespace (none)
Type
CODL Complex Type
Diagram
CommandCode Element CommandGroup Element Sequence CODL Element
Overview
CODL 0..∞ CODL Complex Type
Sequence
CommandGroup Restriction of xs:string
Command Group
CommandCode optional Restriction of xs:string
Instruction by the client
002 = Assembly
003 = Connection
004 = Adding the goods by the carrier
Source
<xs:element name="CODL" type="CODL" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


Commission Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : Commission Element
Namespace (none)
Type
Commission Simple Type
Diagram
Commission Element
Overview
Commission optional Commission Simple Type
Source
<xs:element name="Commission" type="Commission" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


GrossLineAmount Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : GrossLineAmount Element
Namespace (none)
Type
GrossLineAmount Complex Type
Diagram
Currency Element Value Element Sequence GrossLineAmount Element
Overview
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


LineItemNumber Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : LineItemNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
LineItemNumber Element
Overview
LineItemNumber LineItemNumber Simple Type
Source
<xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


LineVat Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : LineVat Element
Namespace (none)
Type
Vat Complex Type
Diagram
Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence LineVat Element
Overview
LineVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="LineVat" type="Vat" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


LTXT Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : LTXT Element
Namespace (none)
Type
LTXT Complex Type
Diagram
LineText Element Sequence LTXT Element
Overview
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


MEA Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : MEA Element
Namespace (none)
Type
MEA Complex Type
Diagram
MEA Element
Overview
MEA 0..10 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="10" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


MULL Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : MULL Element
Namespace (none)
Type
MULL Complex Type
Diagram
ObjectID Element FileName Element Sequence MULL Element
Overview
MULL 0..10 MULL Complex Type
Sequence
FileName Restriction of xs:string
Filename
ObjectID optional Restriction of xs:string
ID of the object within the file
Source
<xs:element name="MULL" type="MULL" minOccurs="0" maxOccurs="10" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


NetLineAmount Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : NetLineAmount Element
Namespace (none)
Type
NetLineAmount Complex Type
Diagram
Currency Element Value Element Sequence NetLineAmount Element
Overview
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


OPT Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : OPT Element
Namespace (none)
Type
OPT Complex Type
Diagram
NumericValue Element TextValue Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element
Overview
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


OrderQuantity Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : OrderQuantity Element
Namespace (none)
Type
Quantity Complex Type
Diagram
OrderQuantity Element
Overview
OrderQuantity Quantity Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OrderQuantity" type="Quantity" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


PACI Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : PACI Element
Namespace (none)
Type
DocumentPaci Complex Type
Diagram
MEA Element ConsumerInstructions Element ShippingMark Element TypeOfShippingMark Element LoadingTackle Element TypeOfPackaging Element NumberOfPackages Element ParentPaciNumber Element PaciNumber Element Sequence PACI Element
Overview
PACI 0..∞ DocumentPaci Complex Type
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


ParentLineItemNumber Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : ParentLineItemNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
ParentLineItemNumber Element
Overview
ParentLineItemNumber optional LineItemNumber Simple Type
Source
<xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


ProductID Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : ProductID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element
Overview
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


QTYVar Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : QTYVar Element
Namespace (none)
Type
QTYVar Simple Type
Diagram
QTYVar Element
Overview
QTYVar optional QTYVar Simple Type
Source
<xs:element name="QTYVar" type="QTYVar" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


RequestedDeliveryDate Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : RequestedDeliveryDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
RequestedDeliveryDate Element
Overview
RequestedDeliveryDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="RequestedDeliveryDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


SalesPrice Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : SalesPrice Element
Namespace (none)
Type
PriceQualified Complex Type
Diagram
Qualifier Element PriceQuantity Element Currency Element Value Element Sequence SalesPrice Element
Overview
SalesPrice 0..2 PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
Source
<xs:element name="SalesPrice" type="PriceQualified" minOccurs="0" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


SeriesID Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : SeriesID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element
Overview
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


TypeOfPackaging Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : TypeOfPackaging Element
Namespace (none)
Type
TypeOfPackaging Simple Type
Diagram
TypeOfPackaging Element
Overview
TypeOfPackaging optional TypeOfPackaging Simple Type
Source
<xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


TypeOfProduct Element
XML Einrichten Version 1.2 > OrderMessage Element > ORDER Element > LINE Element : TypeOfProduct Element
Namespace (none)
Type
TypeOfProduct Simple Type
Diagram
TypeOfProduct Element
Overview
TypeOfProduct optional TypeOfProduct Simple Type
Source
<xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDER Element | OrderMessage Element | XML Einrichten Version 1.2


OrdrspMessage Element
XML Einrichten Version 1.2 : OrdrspMessage Element
Description
Message: Order Resopons (ORDRSP)
Namespace (none)
Diagram
ORDRSP Element Sequence OrdrspMessage Element
Overview
OrdrspMessage
Message: Order Resopons (ORDRSP)
Sequence
ORDRSP 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the order response (ORDRSP)
Positions of an order can be confirmed as single position.
Head information are valid for all positions without for any contrary are laid down.
Recommendation: Send all information on the positions, too.
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
OrderType optional OrderType Simple Type
Commission optional Commission Simple Type
RequestedDeliveryDate optional RequestedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ConfirmedDeliveryDate optional ConfirmedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AdvisedDeliveryDate optional AdvisedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PartialDelivery optional PartialDelivery Simple Type
BarcodeNumber optional BarcodeNumber Simple Type
LastChangeDate optional LastChangeDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
LINE 1..∞
Posiitions of the order response (ORDRSP)
Sequence
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Commission optional Commission Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TypeOfProduct optional TypeOfProduct Simple Type
GoodsCountry optional GoodsCountry Simple Type
ClassOfGoods optional ClassOfGoods Complex Type
Sequence
ClassOfGoodsType ClassOfGoodsType Simple Type
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
ClassOfGoodsValue ClassOfGoodsValue Simple Type
BatchNumber optional BatchNumber Simple Type
RequestedDeliveryDate optional RequestedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ConfirmedDeliveryDate optional ConfirmedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AdvisedDeliveryDate optional AdvisedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
MEA 0..10 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
PACI 0..∞ DocumentPaci Complex Type
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
OrderResponseQuantity Quantity Complex Type
Unit optional Unit Simple Type
QuantityDeviation optional QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
QuantityDeviationType optional TypeOfQuantityDeviation Simple Type
GrossUnitPrice optional GrossUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
NetUnitPrice optional NetUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal optional DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
LineVAT optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULL 0..10 MULL Complex Type
Sequence
FileName Restriction of xs:string
Filename
ObjectID optional Restriction of xs:string
ID of the object within the file
CNDL 0..∞ CNDL Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:string
Condition level
TypeOfCondition Restriction of xs:string
Type of condition
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Footer of the order response (ORDRSP)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
VatTotal 0..3 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
CNDF 0..∞ CNDF Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:decimal
TypeOfCondition Restriction of xs:string
Type of conditiont
DI = Rebate
FC = Freight Cost
IN = Insurance
PC = Handling costs
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Source
<xs:element name="OrdrspMessage" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <b>Nachricht: Bestellbestätigung (ORDRSP) </b>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <b>Message: Order Resopons (ORDRSP)</b>
    </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ORDRSP" minOccurs="1" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">
                  <dl>
                    <dt>Kopfteil der Bestellbestätigung (ORDRSP)  </dt>
                    <dt>Positionen eines Auftrags können einzeln bestätigt werden.</dt>
                    <dt>Kopfinformationen gelten für alle Positionen, für die keine abweichenden Inhalte festgelegt sind.</dt>
                    <dt>Empfehlung: alle Informationen auch auf den Positionen senden.</dt>
                  </dl>
                </xs:documentation>
                <xs:documentation xml:lang="en">
                  <dl>
                    <dt>Head of the order response (ORDRSP)  </dt>
                    <dt>Positions of an order can be confirmed as single position. </dt>
                    <dt>Head information are valid for all positions without for any contrary are laid down.</dt>
                    <dt>Recommendation: Send all information on the positions, too.</dt>
                  </dl>
                </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentHead">
                    <xs:sequence>
                      <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
                      <xs:element name="OrderType" type="OrderType" minOccurs="0" />
                      <xs:element name="Commission" type="Commission" minOccurs="0" />
                      <xs:element name="RequestedDeliveryDate" type="RequestedDeliveryDate" minOccurs="0" />
                      <xs:element name="ConfirmedDeliveryDate" type="ConfirmedDeliveryDate" minOccurs="0" />
                      <xs:element name="AdvisedDeliveryDate" type="AdvisedDeliveryDate" minOccurs="0" maxOccurs="1" />
                      <xs:element name="PartialDelivery" type="PartialDelivery" minOccurs="0" />
                      <xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" />
                      <xs:element name="LastChangeDate" type="LastChangeDate" minOccurs="0" />
                      <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
                      <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" />
                      <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
                      <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" />
                      <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" />
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Positionen der Bestellbestätigung (ORDRSP) </xs:documentation>
                <xs:documentation xml:lang="en">Posiitions of the order response (ORDRSP)   </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
                  <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
                  <xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" />
                  <xs:element name="Commission" type="Commission" minOccurs="0" />
                  <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" />
                  <xs:element name="GoodsCountry" type="GoodsCountry" minOccurs="0" />
                  <xs:element name="ClassOfGoods" type="ClassOfGoods" minOccurs="0" />
                  <xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" />
                  <xs:element name="RequestedDeliveryDate" type="RequestedDeliveryDate" minOccurs="0" />
                  <xs:element name="ConfirmedDeliveryDate" type="ConfirmedDeliveryDate" minOccurs="0" />
                  <xs:element name="AdvisedDeliveryDate" type="AdvisedDeliveryDate" minOccurs="0" maxOccurs="1" />
                  <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="10" />
                  <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
                  <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
                  <xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="OrderResponseQuantity" type="Quantity" minOccurs="1" maxOccurs="1" />
                  <xs:element name="QuantityDeviation" type="QuantityQualified" minOccurs="0" />
                  <xs:element name="QuantityDeviationType" type="TypeOfQuantityDeviation" minOccurs="0" />
                  <xs:element name="GrossUnitPrice" type="GrossUnitPrice" minOccurs="0" />
                  <xs:element name="NetUnitPrice" type="NetUnitPrice" minOccurs="0" />
                  <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
                  <xs:element name="DiscountsConditionsTotal" type="DiscountsConditionsTotal" minOccurs="0" />
                  <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
                  <xs:element name="LineVAT" type="Vat" minOccurs="0" />
                  <xs:element name="AdditionalLineAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
                  <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
                  <xs:element name="MULL" type="MULL" minOccurs="0" maxOccurs="10" />
                  <xs:element name="CNDL" type="CNDL" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Abschluss der Bestellbestätigung (ORDRSP)</xs:documentation>
                <xs:documentation xml:lang="en">Footer of the order response (ORDRSP)  </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentFoot">
                    <xs:sequence>
                      <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="3" />
                      <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
                      <xs:element name="CNDF" type="CNDF" minOccurs="0" maxOccurs="unbounded" />
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
XML Einrichten Version 1.2


ORDRSP Element
XML Einrichten Version 1.2 > OrdrspMessage Element : ORDRSP Element
Namespace (none)
Diagram
FOOT Element LINE Element HEAD Element Sequence ORDRSP Element
Overview
ORDRSP 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the order response (ORDRSP)
Positions of an order can be confirmed as single position.
Head information are valid for all positions without for any contrary are laid down.
Recommendation: Send all information on the positions, too.
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
OrderType optional OrderType Simple Type
Commission optional Commission Simple Type
RequestedDeliveryDate optional RequestedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ConfirmedDeliveryDate optional ConfirmedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AdvisedDeliveryDate optional AdvisedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PartialDelivery optional PartialDelivery Simple Type
BarcodeNumber optional BarcodeNumber Simple Type
LastChangeDate optional LastChangeDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
LINE 1..∞
Posiitions of the order response (ORDRSP)
Sequence
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Commission optional Commission Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TypeOfProduct optional TypeOfProduct Simple Type
GoodsCountry optional GoodsCountry Simple Type
ClassOfGoods optional ClassOfGoods Complex Type
Sequence
ClassOfGoodsType ClassOfGoodsType Simple Type
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
ClassOfGoodsValue ClassOfGoodsValue Simple Type
BatchNumber optional BatchNumber Simple Type
RequestedDeliveryDate optional RequestedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ConfirmedDeliveryDate optional ConfirmedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AdvisedDeliveryDate optional AdvisedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
MEA 0..10 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
PACI 0..∞ DocumentPaci Complex Type
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
OrderResponseQuantity Quantity Complex Type
Unit optional Unit Simple Type
QuantityDeviation optional QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
QuantityDeviationType optional TypeOfQuantityDeviation Simple Type
GrossUnitPrice optional GrossUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
NetUnitPrice optional NetUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal optional DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
LineVAT optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULL 0..10 MULL Complex Type
Sequence
FileName Restriction of xs:string
Filename
ObjectID optional Restriction of xs:string
ID of the object within the file
CNDL 0..∞ CNDL Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:string
Condition level
TypeOfCondition Restriction of xs:string
Type of condition
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Footer of the order response (ORDRSP)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
VatTotal 0..3 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
CNDF 0..∞ CNDF Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:decimal
TypeOfCondition Restriction of xs:string
Type of conditiont
DI = Rebate
FC = Freight Cost
IN = Insurance
PC = Handling costs
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Source
<xs:element name="ORDRSP" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">
            <dl>
              <dt>Kopfteil der Bestellbestätigung (ORDRSP)  </dt>
              <dt>Positionen eines Auftrags können einzeln bestätigt werden.</dt>
              <dt>Kopfinformationen gelten für alle Positionen, für die keine abweichenden Inhalte festgelegt sind.</dt>
              <dt>Empfehlung: alle Informationen auch auf den Positionen senden.</dt>
            </dl>
          </xs:documentation>
          <xs:documentation xml:lang="en">
            <dl>
              <dt>Head of the order response (ORDRSP)  </dt>
              <dt>Positions of an order can be confirmed as single position. </dt>
              <dt>Head information are valid for all positions without for any contrary are laid down.</dt>
              <dt>Recommendation: Send all information on the positions, too.</dt>
            </dl>
          </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentHead">
              <xs:sequence>
                <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
                <xs:element name="OrderType" type="OrderType" minOccurs="0" />
                <xs:element name="Commission" type="Commission" minOccurs="0" />
                <xs:element name="RequestedDeliveryDate" type="RequestedDeliveryDate" minOccurs="0" />
                <xs:element name="ConfirmedDeliveryDate" type="ConfirmedDeliveryDate" minOccurs="0" />
                <xs:element name="AdvisedDeliveryDate" type="AdvisedDeliveryDate" minOccurs="0" maxOccurs="1" />
                <xs:element name="PartialDelivery" type="PartialDelivery" minOccurs="0" />
                <xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" />
                <xs:element name="LastChangeDate" type="LastChangeDate" minOccurs="0" />
                <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
                <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" />
                <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
                <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" />
                <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" />
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Positionen der Bestellbestätigung (ORDRSP) </xs:documentation>
          <xs:documentation xml:lang="en">Posiitions of the order response (ORDRSP)   </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
            <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
            <xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" />
            <xs:element name="Commission" type="Commission" minOccurs="0" />
            <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" />
            <xs:element name="GoodsCountry" type="GoodsCountry" minOccurs="0" />
            <xs:element name="ClassOfGoods" type="ClassOfGoods" minOccurs="0" />
            <xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" />
            <xs:element name="RequestedDeliveryDate" type="RequestedDeliveryDate" minOccurs="0" />
            <xs:element name="ConfirmedDeliveryDate" type="ConfirmedDeliveryDate" minOccurs="0" />
            <xs:element name="AdvisedDeliveryDate" type="AdvisedDeliveryDate" minOccurs="0" maxOccurs="1" />
            <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="10" />
            <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
            <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
            <xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="OrderResponseQuantity" type="Quantity" minOccurs="1" maxOccurs="1" />
            <xs:element name="QuantityDeviation" type="QuantityQualified" minOccurs="0" />
            <xs:element name="QuantityDeviationType" type="TypeOfQuantityDeviation" minOccurs="0" />
            <xs:element name="GrossUnitPrice" type="GrossUnitPrice" minOccurs="0" />
            <xs:element name="NetUnitPrice" type="NetUnitPrice" minOccurs="0" />
            <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
            <xs:element name="DiscountsConditionsTotal" type="DiscountsConditionsTotal" minOccurs="0" />
            <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
            <xs:element name="LineVAT" type="Vat" minOccurs="0" />
            <xs:element name="AdditionalLineAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
            <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
            <xs:element name="MULL" type="MULL" minOccurs="0" maxOccurs="10" />
            <xs:element name="CNDL" type="CNDL" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Abschluss der Bestellbestätigung (ORDRSP)</xs:documentation>
          <xs:documentation xml:lang="en">Footer of the order response (ORDRSP)  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentFoot">
              <xs:sequence>
                <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="3" />
                <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
                <xs:element name="CNDF" type="CNDF" minOccurs="0" maxOccurs="unbounded" />
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
OrdrspMessage Element | XML Einrichten Version 1.2


FOOT Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element : FOOT Element
Description
Footer of the order response (ORDRSP)
Namespace (none)
Type
Extension of DocumentFoot Complex Type
Diagram
VatPercentageOfCondition Element AmountOfCondition Element PercentageRateOfCondition Element DscOfConditionType Element TypeOfCondition Element ConditionLevel Element ConditionIndicator Element Sequence CNDF Element Qualifier Element Currency Element Value Element Sequence AdditionalAmounts Element Currency Element Value Element Sequence DiscountsConditionsTotal Element Currency Element Value Element Sequence NetItemAmount Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence VatTotal Element SendingDate Element Sequence FOOT Element
Overview
FOOT Extension of DocumentFoot Complex Type
Footer of the order response (ORDRSP)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
VatTotal 0..3 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
CNDF 0..∞ CNDF Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:decimal
TypeOfCondition Restriction of xs:string
Type of conditiont
DI = Rebate
FC = Freight Cost
IN = Insurance
PC = Handling costs
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Source
<xs:element name="FOOT" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Abschluss der Bestellbestätigung (ORDRSP)</xs:documentation>
    <xs:documentation xml:lang="en">Footer of the order response (ORDRSP)  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentFoot">
        <xs:sequence>
          <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="3" />
          <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
          <xs:element name="CNDF" type="CNDF" minOccurs="0" maxOccurs="unbounded" />
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


AdditionalAmounts Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > FOOT Element : AdditionalAmounts Element
Namespace (none)
Type
TotalAmountQualified Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence AdditionalAmounts Element
Overview
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
Source
<xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FOOT Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


CNDF Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > FOOT Element : CNDF Element
Namespace (none)
Type
CNDF Complex Type
Diagram
VatPercentageOfCondition Element AmountOfCondition Element PercentageRateOfCondition Element DscOfConditionType Element TypeOfCondition Element ConditionLevel Element ConditionIndicator Element Sequence CNDF Element
Overview
CNDF 0..∞ CNDF Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:decimal
TypeOfCondition Restriction of xs:string
Type of conditiont
DI = Rebate
FC = Freight Cost
IN = Insurance
PC = Handling costs
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Source
<xs:element name="CNDF" type="CNDF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FOOT Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


SendingDate Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > FOOT Element : SendingDate Element
Description
Sending date of this message
Namespace (none)
Type
EDIDate Complex Type
Diagram
SendingDate Element
Overview
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="SendingDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Versanddatum der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Sending date of this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FOOT Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


VatTotal Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > FOOT Element : VatTotal Element
Namespace (none)
Type
VatTotal Complex Type
Diagram
Currency Element Value Element Sequence DiscountsConditionsTotal Element Currency Element Value Element Sequence NetItemAmount Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence VatTotal Element
Overview
VatTotal 0..3 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FOOT Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


HEAD Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element : HEAD Element
Description
Head of the order response (ORDRSP)
Positions of an order can be confirmed as single position.
Head information are valid for all positions without for any contrary are laid down.
Recommendation: Send all information on the positions, too.
Namespace (none)
Type
Extension of DocumentHead Complex Type
Diagram
AppTargetIdentification Element AppSourceIdentification Element ObjectContent Element Source Element RemoteType Element FunctionType Element ObjectType Element ObjectDescription Element FileName Element Sequence MULH Element HeadText Element Sequence HTXT Element FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element MEA Element NumberOfPackages Element LastChangeDate Element BarcodeNumber Element PartialDelivery Element AdvisedDeliveryDate Element ConfirmedDeliveryDate Element RequestedDeliveryDate Element Commission Element OrderType Element DocDate Element DocRefNumber Element Sequence OrderNumberRef Element TechnicalReceiverCopy Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element AdditionalDate Element TechnicalSender Element TechnicalReceiver Element DocumentDate Element DocumentNumber Element DocumentFunctionSymbol Element DocumentType Element WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element Sequence HEAD Element
Overview
HEAD Extension of DocumentHead Complex Type
Head of the order response (ORDRSP)
Positions of an order can be confirmed as single position.
Head information are valid for all positions without for any contrary are laid down.
Recommendation: Send all information on the positions, too.
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
OrderType optional OrderType Simple Type
Commission optional Commission Simple Type
RequestedDeliveryDate optional RequestedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ConfirmedDeliveryDate optional ConfirmedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AdvisedDeliveryDate optional AdvisedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PartialDelivery optional PartialDelivery Simple Type
BarcodeNumber optional BarcodeNumber Simple Type
LastChangeDate optional LastChangeDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
Source
<xs:element name="HEAD" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Kopfteil der Bestellbestätigung (ORDRSP)  </dt>
        <dt>Positionen eines Auftrags können einzeln bestätigt werden.</dt>
        <dt>Kopfinformationen gelten für alle Positionen, für die keine abweichenden Inhalte festgelegt sind.</dt>
        <dt>Empfehlung: alle Informationen auch auf den Positionen senden.</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Head of the order response (ORDRSP)  </dt>
        <dt>Positions of an order can be confirmed as single position. </dt>
        <dt>Head information are valid for all positions without for any contrary are laid down.</dt>
        <dt>Recommendation: Send all information on the positions, too.</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentHead">
        <xs:sequence>
          <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
          <xs:element name="OrderType" type="OrderType" minOccurs="0" />
          <xs:element name="Commission" type="Commission" minOccurs="0" />
          <xs:element name="RequestedDeliveryDate" type="RequestedDeliveryDate" minOccurs="0" />
          <xs:element name="ConfirmedDeliveryDate" type="ConfirmedDeliveryDate" minOccurs="0" />
          <xs:element name="AdvisedDeliveryDate" type="AdvisedDeliveryDate" minOccurs="0" maxOccurs="1" />
          <xs:element name="PartialDelivery" type="PartialDelivery" minOccurs="0" />
          <xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" />
          <xs:element name="LastChangeDate" type="LastChangeDate" minOccurs="0" />
          <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
          <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" />
          <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
          <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" />
          <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" />
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


AdditionalReference Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : AdditionalReference Element
Namespace (none)
Type
DocumentReferenceQualified Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence AdditionalReference Element
Overview
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalReference" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


AdvisedDeliveryDate Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : AdvisedDeliveryDate Element
Namespace (none)
Type
AdvisedDeliveryDate Complex Type
Diagram
AdvisedDeliveryDate Element
Overview
AdvisedDeliveryDate optional AdvisedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdvisedDeliveryDate" type="AdvisedDeliveryDate" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


BarcodeNumber Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : BarcodeNumber Element
Namespace (none)
Type
BarcodeNumber Simple Type
Diagram
BarcodeNumber Element
Overview
BarcodeNumber optional BarcodeNumber Simple Type
Source
<xs:element name="BarcodeNumber" type="BarcodeNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


Commission Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : Commission Element
Namespace (none)
Type
Commission Simple Type
Diagram
Commission Element
Overview
Commission optional Commission Simple Type
Source
<xs:element name="Commission" type="Commission" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


ConfirmedDeliveryDate Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : ConfirmedDeliveryDate Element
Namespace (none)
Type
ConfirmedDeliveryDate Complex Type
Diagram
ConfirmedDeliveryDate Element
Overview
ConfirmedDeliveryDate optional ConfirmedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="ConfirmedDeliveryDate" type="ConfirmedDeliveryDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


DocumentDate Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : DocumentDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocumentDate Element
Overview
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocumentDate" type="EDIDate" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


DocumentFunctionSymbol Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : DocumentFunctionSymbol Element
Namespace (none)
Type
DocumentFunctionSymbol Simple Type
Diagram
DocumentFunctionSymbol Element
Overview
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
Source
<xs:element name="DocumentFunctionSymbol" type="DocumentFunctionSymbol" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


DocumentNumber Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : DocumentNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocumentNumber Element
Overview
DocumentNumber DocumentNumber Simple Type
Source
<xs:element name="DocumentNumber" type="DocumentNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


DocumentType Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : DocumentType Element
Namespace (none)
Type
DocumentType Simple Type
Diagram
DocumentType Element
Overview
DocumentType DocumentType Simple Type
Source
<xs:element name="DocumentType" type="DocumentType" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


HTXT Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : HTXT Element
Namespace (none)
Type
HTXT Complex Type
Diagram
HeadText Element Sequence HTXT Element
Overview
HTXT optional HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


LastChangeDate Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : LastChangeDate Element
Namespace (none)
Type
LastChangeDate Complex Type
Diagram
LastChangeDate Element
Overview
LastChangeDate optional LastChangeDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="LastChangeDate" type="LastChangeDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


MEA Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : MEA Element
Namespace (none)
Type
MEA Complex Type
Diagram
MEA Element
Overview
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


MULH Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : MULH Element
Namespace (none)
Type
MULH Complex Type
Diagram
AppTargetIdentification Element AppSourceIdentification Element ObjectContent Element Source Element RemoteType Element FunctionType Element ObjectType Element ObjectDescription Element FileName Element Sequence MULH Element
Overview
MULH 0..10 MULH Complex Type
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
Source
<xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


NAD Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : NAD Element
Namespace (none)
Type
NAD Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element
Overview
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


NumberOfPackages Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : NumberOfPackages Element
Namespace (none)
Type
NumberOfPackages Simple Type
Diagram
NumberOfPackages Element
Overview
NumberOfPackages optional NumberOfPackages Simple Type
Source
<xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


OrderNumberRef Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : OrderNumberRef Element
Namespace (none)
Type
OrderNumber Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence OrderNumberRef Element
Overview
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


OrderType Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : OrderType Element
Namespace (none)
Type
OrderType Simple Type
Diagram
OrderType Element
Overview
OrderType optional OrderType Simple Type
Source
<xs:element name="OrderType" type="OrderType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


PartialDelivery Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : PartialDelivery Element
Namespace (none)
Type
PartialDelivery Simple Type
Diagram
PartialDelivery Element
Overview
PartialDelivery optional PartialDelivery Simple Type
Source
<xs:element name="PartialDelivery" type="PartialDelivery" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


RequestedDeliveryDate Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : RequestedDeliveryDate Element
Namespace (none)
Type
RequestedDeliveryDate Complex Type
Diagram
RequestedDeliveryDate Element
Overview
RequestedDeliveryDate optional RequestedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="RequestedDeliveryDate" type="RequestedDeliveryDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


TechnicalReceiver Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : TechnicalReceiver Element
Description
technical, physical recipient of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiver Element
Overview
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
Source
<xs:element name="TechnicalReceiver" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Empfänger der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical recipient of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


TechnicalReceiverCopy Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : TechnicalReceiverCopy Element
Description
Physical receiver for a copy from this message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiverCopy Element
Overview
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Source
<xs:element name="TechnicalReceiverCopy" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Physischer Empfänger einer Kopie dieser Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Physical receiver for a copy from this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


TechnicalSender Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : TechnicalSender Element
Description
technical, physical sender of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalSender Element
Overview
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
Source
<xs:element name="TechnicalSender" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Versender der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical sender of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


VersionNumber Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > HEAD Element : VersionNumber Element
Namespace (none)
Type
MessageVersion Complex Type
Diagram
WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element
Overview
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
Source
<xs:element name="VersionNumber" type="MessageVersion" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


LINE Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element : LINE Element
Description
Posiitions of the order response (ORDRSP)
Namespace (none)
Diagram
NumericValue Element TextValue Element OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element VatPercentageOfCondition Element AmountOfCondition Element PercentageRateOfCondition Element DscOfConditionType Element TypeOfCondition Element ConditionLevel Element ConditionIndicator Element Sequence CNDL Element ObjectID Element FileName Element Sequence MULL Element LineText Element Sequence LTXT Element AdditionalDate Element AdditionalQuantity Element Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence AdditionalPrice Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element Sequence AdditionalLineReferences Element Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence LineVAT Element Currency Element Value Element Sequence NetLineAmount Element Currency Element Value Element Sequence DiscountsConditionsTotal Element Currency Element Value Element Sequence GrossLineAmount Element PriceQuantity Element Currency Element Value Element Sequence NetUnitPrice Element PriceQuantity Element Currency Element Value Element Sequence GrossUnitPrice Element QuantityDeviationType Element QuantityDeviation Element OrderResponseQuantity Element MEA Element ConsumerInstructions Element ShippingMark Element TypeOfShippingMark Element LoadingTackle Element TypeOfPackaging Element NumberOfPackages Element ParentPaciNumber Element PaciNumber Element Sequence PACI Element NumberOfPackages Element TypeOfPackaging Element MEA Element AdvisedDeliveryDate Element ConfirmedDeliveryDate Element RequestedDeliveryDate Element BatchNumber Element ClassOfGoodsValue Element ClassOfGoodsFeature Element ClassOfGoodsType Element Sequence ClassOfGoods Element GoodsCountry Element TypeOfProduct Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element Commission Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence OrderLineRef Element ParentLineItemNumber Element LineItemNumber Element Sequence LINE Element
Overview
LINE 1..∞
Posiitions of the order response (ORDRSP)
Sequence
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Commission optional Commission Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TypeOfProduct optional TypeOfProduct Simple Type
GoodsCountry optional GoodsCountry Simple Type
ClassOfGoods optional ClassOfGoods Complex Type
Sequence
ClassOfGoodsType ClassOfGoodsType Simple Type
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
ClassOfGoodsValue ClassOfGoodsValue Simple Type
BatchNumber optional BatchNumber Simple Type
RequestedDeliveryDate optional RequestedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ConfirmedDeliveryDate optional ConfirmedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AdvisedDeliveryDate optional AdvisedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
MEA 0..10 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
PACI 0..∞ DocumentPaci Complex Type
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
OrderResponseQuantity Quantity Complex Type
Unit optional Unit Simple Type
QuantityDeviation optional QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
QuantityDeviationType optional TypeOfQuantityDeviation Simple Type
GrossUnitPrice optional GrossUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
NetUnitPrice optional NetUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal optional DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
LineVAT optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULL 0..10 MULL Complex Type
Sequence
FileName Restriction of xs:string
Filename
ObjectID optional Restriction of xs:string
ID of the object within the file
CNDL 0..∞ CNDL Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:string
Condition level
TypeOfCondition Restriction of xs:string
Type of condition
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="LINE" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Positionen der Bestellbestätigung (ORDRSP) </xs:documentation>
    <xs:documentation xml:lang="en">Posiitions of the order response (ORDRSP)   </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
      <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
      <xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" />
      <xs:element name="Commission" type="Commission" minOccurs="0" />
      <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" />
      <xs:element name="GoodsCountry" type="GoodsCountry" minOccurs="0" />
      <xs:element name="ClassOfGoods" type="ClassOfGoods" minOccurs="0" />
      <xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" />
      <xs:element name="RequestedDeliveryDate" type="RequestedDeliveryDate" minOccurs="0" />
      <xs:element name="ConfirmedDeliveryDate" type="ConfirmedDeliveryDate" minOccurs="0" />
      <xs:element name="AdvisedDeliveryDate" type="AdvisedDeliveryDate" minOccurs="0" maxOccurs="1" />
      <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="10" />
      <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
      <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
      <xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="OrderResponseQuantity" type="Quantity" minOccurs="1" maxOccurs="1" />
      <xs:element name="QuantityDeviation" type="QuantityQualified" minOccurs="0" />
      <xs:element name="QuantityDeviationType" type="TypeOfQuantityDeviation" minOccurs="0" />
      <xs:element name="GrossUnitPrice" type="GrossUnitPrice" minOccurs="0" />
      <xs:element name="NetUnitPrice" type="NetUnitPrice" minOccurs="0" />
      <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
      <xs:element name="DiscountsConditionsTotal" type="DiscountsConditionsTotal" minOccurs="0" />
      <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
      <xs:element name="LineVAT" type="Vat" minOccurs="0" />
      <xs:element name="AdditionalLineAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" />
      <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
      <xs:element name="MULL" type="MULL" minOccurs="0" maxOccurs="10" />
      <xs:element name="CNDL" type="CNDL" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


AdditionalLineAmount Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : AdditionalLineAmount Element
Namespace (none)
Type
LineAmountQualified Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element
Overview
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
Source
<xs:element name="AdditionalLineAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


AdditionalLineReferences Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : AdditionalLineReferences Element
Namespace (none)
Type
AdditionalLineReferences Complex Type
Diagram
AdditionalDate Element AdditionalQuantity Element Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence AdditionalPrice Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element Sequence AdditionalLineReferences Element
Overview
AdditionalLineReferences optional AdditionalLineReferences Complex Type
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalLineReferences" type="AdditionalLineReferences" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


AdvisedDeliveryDate Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : AdvisedDeliveryDate Element
Namespace (none)
Type
AdvisedDeliveryDate Complex Type
Diagram
AdvisedDeliveryDate Element
Overview
AdvisedDeliveryDate optional AdvisedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdvisedDeliveryDate" type="AdvisedDeliveryDate" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


BatchNumber Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : BatchNumber Element
Namespace (none)
Type
BatchNumber Simple Type
Diagram
BatchNumber Element
Overview
BatchNumber optional BatchNumber Simple Type
Source
<xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


ClassOfGoods Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : ClassOfGoods Element
Namespace (none)
Type
ClassOfGoods Complex Type
Diagram
ClassOfGoodsValue Element ClassOfGoodsFeature Element ClassOfGoodsType Element Sequence ClassOfGoods Element
Overview
ClassOfGoods optional ClassOfGoods Complex Type
Sequence
ClassOfGoodsType ClassOfGoodsType Simple Type
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
ClassOfGoodsValue ClassOfGoodsValue Simple Type
Source
<xs:element name="ClassOfGoods" type="ClassOfGoods" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


CNDL Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : CNDL Element
Namespace (none)
Type
CNDL Complex Type
Diagram
VatPercentageOfCondition Element AmountOfCondition Element PercentageRateOfCondition Element DscOfConditionType Element TypeOfCondition Element ConditionLevel Element ConditionIndicator Element Sequence CNDL Element
Overview
CNDL 0..∞ CNDL Complex Type
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:string
Condition level
TypeOfCondition Restriction of xs:string
Type of condition
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Source
<xs:element name="CNDL" type="CNDL" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


Commission Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : Commission Element
Namespace (none)
Type
Commission Simple Type
Diagram
Commission Element
Overview
Commission optional Commission Simple Type
Source
<xs:element name="Commission" type="Commission" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


ConfirmedDeliveryDate Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : ConfirmedDeliveryDate Element
Namespace (none)
Type
ConfirmedDeliveryDate Complex Type
Diagram
ConfirmedDeliveryDate Element
Overview
ConfirmedDeliveryDate optional ConfirmedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="ConfirmedDeliveryDate" type="ConfirmedDeliveryDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


DiscountsConditionsTotal Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : DiscountsConditionsTotal Element
Namespace (none)
Type
DiscountsConditionsTotal Complex Type
Diagram
Currency Element Value Element Sequence DiscountsConditionsTotal Element
Overview
DiscountsConditionsTotal optional DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="DiscountsConditionsTotal" type="DiscountsConditionsTotal" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


GoodsCountry Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : GoodsCountry Element
Namespace (none)
Type
GoodsCountry Simple Type
Diagram
GoodsCountry Element
Overview
GoodsCountry optional GoodsCountry Simple Type
Source
<xs:element name="GoodsCountry" type="GoodsCountry" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


GrossLineAmount Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : GrossLineAmount Element
Namespace (none)
Type
GrossLineAmount Complex Type
Diagram
Currency Element Value Element Sequence GrossLineAmount Element
Overview
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


GrossUnitPrice Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : GrossUnitPrice Element
Namespace (none)
Type
GrossUnitPrice Complex Type
Diagram
PriceQuantity Element Currency Element Value Element Sequence GrossUnitPrice Element
Overview
GrossUnitPrice optional GrossUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Source
<xs:element name="GrossUnitPrice" type="GrossUnitPrice" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


LineItemNumber Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : LineItemNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
LineItemNumber Element
Overview
LineItemNumber LineItemNumber Simple Type
Source
<xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


LineVAT Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : LineVAT Element
Namespace (none)
Type
Vat Complex Type
Diagram
Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence LineVAT Element
Overview
LineVAT optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="LineVAT" type="Vat" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


LTXT Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : LTXT Element
Namespace (none)
Type
LTXT Complex Type
Diagram
LineText Element Sequence LTXT Element
Overview
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


MEA Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : MEA Element
Namespace (none)
Type
MEA Complex Type
Diagram
MEA Element
Overview
MEA 0..10 MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="10" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


MULL Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : MULL Element
Namespace (none)
Type
MULL Complex Type
Diagram
ObjectID Element FileName Element Sequence MULL Element
Overview
MULL 0..10 MULL Complex Type
Sequence
FileName Restriction of xs:string
Filename
ObjectID optional Restriction of xs:string
ID of the object within the file
Source
<xs:element name="MULL" type="MULL" minOccurs="0" maxOccurs="10" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


NetLineAmount Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : NetLineAmount Element
Namespace (none)
Type
NetLineAmount Complex Type
Diagram
Currency Element Value Element Sequence NetLineAmount Element
Overview
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


NetUnitPrice Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : NetUnitPrice Element
Namespace (none)
Type
NetUnitPrice Complex Type
Diagram
PriceQuantity Element Currency Element Value Element Sequence NetUnitPrice Element
Overview
NetUnitPrice optional NetUnitPrice Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Source
<xs:element name="NetUnitPrice" type="NetUnitPrice" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


NumberOfPackages Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : NumberOfPackages Element
Namespace (none)
Type
NumberOfPackages Simple Type
Diagram
NumberOfPackages Element
Overview
NumberOfPackages optional NumberOfPackages Simple Type
Source
<xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


OPT Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : OPT Element
Namespace (none)
Type
OPT Complex Type
Diagram
NumericValue Element TextValue Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element
Overview
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


OrderLineRef Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : OrderLineRef Element
Namespace (none)
Type
DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence OrderLineRef Element
Overview
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


OrderResponseQuantity Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : OrderResponseQuantity Element
Namespace (none)
Type
Quantity Complex Type
Diagram
OrderResponseQuantity Element
Overview
OrderResponseQuantity Quantity Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OrderResponseQuantity" type="Quantity" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


PACI Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : PACI Element
Namespace (none)
Type
DocumentPaci Complex Type
Diagram
MEA Element ConsumerInstructions Element ShippingMark Element TypeOfShippingMark Element LoadingTackle Element TypeOfPackaging Element NumberOfPackages Element ParentPaciNumber Element PaciNumber Element Sequence PACI Element
Overview
PACI 0..∞ DocumentPaci Complex Type
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


ParentLineItemNumber Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : ParentLineItemNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
ParentLineItemNumber Element
Overview
ParentLineItemNumber optional LineItemNumber Simple Type
Source
<xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


ProductID Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : ProductID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element
Overview
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


QuantityDeviation Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : QuantityDeviation Element
Namespace (none)
Type
QuantityQualified Complex Type
Diagram
QuantityDeviation Element
Overview
QuantityDeviation optional QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
Source
<xs:element name="QuantityDeviation" type="QuantityQualified" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


QuantityDeviationType Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : QuantityDeviationType Element
Namespace (none)
Type
TypeOfQuantityDeviation Simple Type
Diagram
QuantityDeviationType Element
Overview
QuantityDeviationType optional TypeOfQuantityDeviation Simple Type
Source
<xs:element name="QuantityDeviationType" type="TypeOfQuantityDeviation" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


RequestedDeliveryDate Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : RequestedDeliveryDate Element
Namespace (none)
Type
RequestedDeliveryDate Complex Type
Diagram
RequestedDeliveryDate Element
Overview
RequestedDeliveryDate optional RequestedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="RequestedDeliveryDate" type="RequestedDeliveryDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


SeriesID Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : SeriesID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element
Overview
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


TypeOfPackaging Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : TypeOfPackaging Element
Namespace (none)
Type
TypeOfPackaging Simple Type
Diagram
TypeOfPackaging Element
Overview
TypeOfPackaging optional TypeOfPackaging Simple Type
Source
<xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


TypeOfProduct Element
XML Einrichten Version 1.2 > OrdrspMessage Element > ORDRSP Element > LINE Element : TypeOfProduct Element
Namespace (none)
Type
TypeOfProduct Simple Type
Diagram
TypeOfProduct Element
Overview
TypeOfProduct optional TypeOfProduct Simple Type
Source
<xs:element name="TypeOfProduct" type="TypeOfProduct" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | ORDRSP Element | OrdrspMessage Element | XML Einrichten Version 1.2


OstrptMessage Element
XML Einrichten Version 1.2 : OstrptMessage Element
Description
Mesage: Order status report (OSTRPT)
Namespace (none)
Diagram
OSTRPT Element Sequence OstrptMessage Element
Overview
OstrptMessage
Mesage: Order status report (OSTRPT)
Sequence
OSTRPT 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the order status report (OSTRPT)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef optional DocumentReference Complex Type
Reference to the order number referred in this status repoort
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocumentNumberRef optional DocumentReferenceQualified Complex Type
Reference to the document responsible for the status - if not the order
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Commission optional Commission Simple Type
Commission reference out of the order
ProcessingStates optional ProcessingStates Complex Type
status information on HEAD Level
Sequence
ProcessingStateCategory Restriction of xs:string
Type of process status
1 = Transport
2 = Order managament
3 = Control result
4 = Publication
5 = Legal regulation
ProcessingStateCode Restriction of xs:string
ProcessingStateReasonCode optional Restriction of xs:string
Reason for the processing state
001 = Timed out
002 = Content difference
101 = Inventory difference
ProcessingStateDescription optional Restriction of xs:string
Description of the status
NAD 1..∞ NAD Complex Type
Information about the involved parties
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
HTXT optional HTXT Complex Type
Additional information on HEAD Level
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULH 0..10 MULH Complex Type
Attached documents
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
LINE 0..∞
Position number within this status report (OSTRPT)
Sequence
LineItemNumber LineItemNumber Simple Type
Number of the position within the report
OrderPositionRef optional LineItemNumber Simple Type
Reference to the order position referred ot responsible for this status
DocumentLineReference optional DocumentLineReferenceQualified Complex Type
Reference to the document position resopnsible for the status
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
SeriesID optional ProductIdentifier Complex Type
Identification of the series related to the referred article
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Identification of the article within the referred position
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProcessingStates ProcessingStates Complex Type
status information to the referred position
Sequence
ProcessingStateCategory Restriction of xs:string
Type of process status
1 = Transport
2 = Order managament
3 = Control result
4 = Publication
5 = Legal regulation
ProcessingStateCode Restriction of xs:string
ProcessingStateReasonCode optional Restriction of xs:string
Reason for the processing state
001 = Timed out
002 = Content difference
101 = Inventory difference
ProcessingStateDescription optional Restriction of xs:string
Description of the status
FOOT Extension of DocumentFoot Complex Type
Footer of the order status report (OSTRPT))
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OstrptMessage" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <b>Nachricht: Bestellstatus (OSTRPT) </b>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <b>Mesage: Order status report (OSTRPT) </b>
    </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OSTRPT" minOccurs="1" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Kopfteil des Bestellstatus (OSTRPT)  </xs:documentation>
                <xs:documentation xml:lang="en">Head of the order status report (OSTRPT) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentHead">
                    <xs:sequence>
                      <xs:element name="OrderNumberRef" type="DocumentReference" minOccurs="0" maxOccurs="1">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">Referenz zu der Bestellung auf die sich der Status bezieht</xs:documentation>
                          <xs:documentation xml:lang="en">Reference to the order number referred in this status repoort</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="DocumentNumberRef" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="1">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">Referenz zu dem Dokument auf das sich der Status beziegt, falls nicht die Bestellung ist</xs:documentation>
                          <xs:documentation xml:lang="en">Reference to the document responsible for the status - if not the order</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="Commission" type="Commission" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">Kommmission Ident aus der Bestellung</xs:documentation>
                          <xs:documentation xml:lang="en">Commission reference out of the order</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="ProcessingStates" type="ProcessingStates" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">Statusinformationen auf Kopf Ebene</xs:documentation>
                          <xs:documentation xml:lang="en">status information on HEAD Level</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">Informationen zu den beteiligten Parteien</xs:documentation>
                          <xs:documentation xml:lang="en">Information about the involved parties</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">Zusatzinformationen Kopf Ebene</xs:documentation>
                          <xs:documentation xml:lang="en">Additional information on HEAD Level</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">Angehängte Dokumente</xs:documentation>
                          <xs:documentation xml:lang="en">Attached documents</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="LINE" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Positionnummer innerhalb des Status Reports (OSTRPT)  </xs:documentation>
                <xs:documentation xml:lang="en">Position number within this status report (OSTRPT) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" maxOccurs="1 ">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">Nummer der Position im Report</xs:documentation>
                      <xs:documentation xml:lang="en">Number of the position within the report </xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OrderPositionRef" type="LineItemNumber" minOccurs="0" maxOccurs="1">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">Referenz zu der Bestellposition, auf die sich dieser Status bezieht</xs:documentation>
                      <xs:documentation xml:lang="en">Reference to the order position referred ot responsible  for this status </xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="DocumentLineReference" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="1">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">Referenz zu der Dokumentenposition, die zu dem Status führt</xs:documentation>
                      <xs:documentation xml:lang="en">Reference to the document position resopnsible for the status </xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" maxOccurs="1 ">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">Identifikation der Serie des Artikels in der benannten Position</xs:documentation>
                      <xs:documentation xml:lang="en">Identification of the series related to the referred article </xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" maxOccurs="1 ">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">Identifikation  des Artikels in der benannten Position</xs:documentation>
                      <xs:documentation xml:lang="en">Identification of the article within the referred position </xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="ProcessingStates" type="ProcessingStates" minOccurs="1" maxOccurs="1">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">Statusinformationen zu dieser Position</xs:documentation>
                      <xs:documentation xml:lang="en">status information to the referred position</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Abschluss des Bestellstatus (OSTRPT)</xs:documentation>
                <xs:documentation xml:lang="en">Footer of the order status report (OSTRPT)) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentFoot"></xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
XML Einrichten Version 1.2


OSTRPT Element
XML Einrichten Version 1.2 > OstrptMessage Element : OSTRPT Element
Namespace (none)
Diagram
FOOT Element LINE Element HEAD Element Sequence OSTRPT Element
Overview
OSTRPT 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the order status report (OSTRPT)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef optional DocumentReference Complex Type
Reference to the order number referred in this status repoort
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocumentNumberRef optional DocumentReferenceQualified Complex Type
Reference to the document responsible for the status - if not the order
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Commission optional Commission Simple Type
Commission reference out of the order
ProcessingStates optional ProcessingStates Complex Type
status information on HEAD Level
Sequence
ProcessingStateCategory Restriction of xs:string
Type of process status
1 = Transport
2 = Order managament
3 = Control result
4 = Publication
5 = Legal regulation
ProcessingStateCode Restriction of xs:string
ProcessingStateReasonCode optional Restriction of xs:string
Reason for the processing state
001 = Timed out
002 = Content difference
101 = Inventory difference
ProcessingStateDescription optional Restriction of xs:string
Description of the status
NAD 1..∞ NAD Complex Type
Information about the involved parties
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
HTXT optional HTXT Complex Type
Additional information on HEAD Level
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULH 0..10 MULH Complex Type
Attached documents
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
LINE 0..∞
Position number within this status report (OSTRPT)
Sequence
LineItemNumber LineItemNumber Simple Type
Number of the position within the report
OrderPositionRef optional LineItemNumber Simple Type
Reference to the order position referred ot responsible for this status
DocumentLineReference optional DocumentLineReferenceQualified Complex Type
Reference to the document position resopnsible for the status
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
SeriesID optional ProductIdentifier Complex Type
Identification of the series related to the referred article
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Identification of the article within the referred position
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProcessingStates ProcessingStates Complex Type
status information to the referred position
Sequence
ProcessingStateCategory Restriction of xs:string
Type of process status
1 = Transport
2 = Order managament
3 = Control result
4 = Publication
5 = Legal regulation
ProcessingStateCode Restriction of xs:string
ProcessingStateReasonCode optional Restriction of xs:string
Reason for the processing state
001 = Timed out
002 = Content difference
101 = Inventory difference
ProcessingStateDescription optional Restriction of xs:string
Description of the status
FOOT Extension of DocumentFoot Complex Type
Footer of the order status report (OSTRPT))
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OSTRPT" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Kopfteil des Bestellstatus (OSTRPT)  </xs:documentation>
          <xs:documentation xml:lang="en">Head of the order status report (OSTRPT) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentHead">
              <xs:sequence>
                <xs:element name="OrderNumberRef" type="DocumentReference" minOccurs="0" maxOccurs="1">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">Referenz zu der Bestellung auf die sich der Status bezieht</xs:documentation>
                    <xs:documentation xml:lang="en">Reference to the order number referred in this status repoort</xs:documentation>
                  </xs:annotation>
                </xs:element>
                <xs:element name="DocumentNumberRef" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="1">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">Referenz zu dem Dokument auf das sich der Status beziegt, falls nicht die Bestellung ist</xs:documentation>
                    <xs:documentation xml:lang="en">Reference to the document responsible for the status - if not the order</xs:documentation>
                  </xs:annotation>
                </xs:element>
                <xs:element name="Commission" type="Commission" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">Kommmission Ident aus der Bestellung</xs:documentation>
                    <xs:documentation xml:lang="en">Commission reference out of the order</xs:documentation>
                  </xs:annotation>
                </xs:element>
                <xs:element name="ProcessingStates" type="ProcessingStates" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">Statusinformationen auf Kopf Ebene</xs:documentation>
                    <xs:documentation xml:lang="en">status information on HEAD Level</xs:documentation>
                  </xs:annotation>
                </xs:element>
                <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">Informationen zu den beteiligten Parteien</xs:documentation>
                    <xs:documentation xml:lang="en">Information about the involved parties</xs:documentation>
                  </xs:annotation>
                </xs:element>
                <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">Zusatzinformationen Kopf Ebene</xs:documentation>
                    <xs:documentation xml:lang="en">Additional information on HEAD Level</xs:documentation>
                  </xs:annotation>
                </xs:element>
                <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">Angehängte Dokumente</xs:documentation>
                    <xs:documentation xml:lang="en">Attached documents</xs:documentation>
                  </xs:annotation>
                </xs:element>
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="LINE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Positionnummer innerhalb des Status Reports (OSTRPT)  </xs:documentation>
          <xs:documentation xml:lang="en">Position number within this status report (OSTRPT) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" maxOccurs="1 ">
              <xs:annotation>
                <xs:documentation xml:lang="de">Nummer der Position im Report</xs:documentation>
                <xs:documentation xml:lang="en">Number of the position within the report </xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OrderPositionRef" type="LineItemNumber" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Referenz zu der Bestellposition, auf die sich dieser Status bezieht</xs:documentation>
                <xs:documentation xml:lang="en">Reference to the order position referred ot responsible  for this status </xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="DocumentLineReference" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Referenz zu der Dokumentenposition, die zu dem Status führt</xs:documentation>
                <xs:documentation xml:lang="en">Reference to the document position resopnsible for the status </xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" maxOccurs="1 ">
              <xs:annotation>
                <xs:documentation xml:lang="de">Identifikation der Serie des Artikels in der benannten Position</xs:documentation>
                <xs:documentation xml:lang="en">Identification of the series related to the referred article </xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" maxOccurs="1 ">
              <xs:annotation>
                <xs:documentation xml:lang="de">Identifikation  des Artikels in der benannten Position</xs:documentation>
                <xs:documentation xml:lang="en">Identification of the article within the referred position </xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="ProcessingStates" type="ProcessingStates" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Statusinformationen zu dieser Position</xs:documentation>
                <xs:documentation xml:lang="en">status information to the referred position</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Abschluss des Bestellstatus (OSTRPT)</xs:documentation>
          <xs:documentation xml:lang="en">Footer of the order status report (OSTRPT)) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentFoot"></xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
OstrptMessage Element | XML Einrichten Version 1.2


FOOT Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element : FOOT Element
Description
Footer of the order status report (OSTRPT))
Namespace (none)
Type
Extension of DocumentFoot Complex Type
Diagram
SendingDate Element Sequence FOOT Element
Overview
FOOT Extension of DocumentFoot Complex Type
Footer of the order status report (OSTRPT))
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="FOOT" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Abschluss des Bestellstatus (OSTRPT)</xs:documentation>
    <xs:documentation xml:lang="en">Footer of the order status report (OSTRPT)) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentFoot"></xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


SendingDate Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > FOOT Element : SendingDate Element
Description
Sending date of this message
Namespace (none)
Type
EDIDate Complex Type
Diagram
SendingDate Element
Overview
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="SendingDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Versanddatum der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Sending date of this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FOOT Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


HEAD Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element : HEAD Element
Description
Head of the order status report (OSTRPT)
Namespace (none)
Type
Extension of DocumentHead Complex Type
Diagram
AppTargetIdentification Element AppSourceIdentification Element ObjectContent Element Source Element RemoteType Element FunctionType Element ObjectType Element ObjectDescription Element FileName Element Sequence MULH Element HeadText Element Sequence HTXT Element FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element ProcessingStateDescription Element ProcessingStateReasonCode Element ProcessingStateCode Element ProcessingStateCategory Element Sequence ProcessingStates Element Commission Element DocDate Element DocRefNumber Element Sequence DocumentNumberRef Element DocDate Element DocRefNumber Element Sequence OrderNumberRef Element TechnicalReceiverCopy Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element AdditionalDate Element TechnicalSender Element TechnicalReceiver Element DocumentDate Element DocumentNumber Element DocumentFunctionSymbol Element DocumentType Element WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element Sequence HEAD Element
Overview
HEAD Extension of DocumentHead Complex Type
Head of the order status report (OSTRPT)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
OrderNumberRef optional DocumentReference Complex Type
Reference to the order number referred in this status repoort
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocumentNumberRef optional DocumentReferenceQualified Complex Type
Reference to the document responsible for the status - if not the order
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Commission optional Commission Simple Type
Commission reference out of the order
ProcessingStates optional ProcessingStates Complex Type
status information on HEAD Level
Sequence
ProcessingStateCategory Restriction of xs:string
Type of process status
1 = Transport
2 = Order managament
3 = Control result
4 = Publication
5 = Legal regulation
ProcessingStateCode Restriction of xs:string
ProcessingStateReasonCode optional Restriction of xs:string
Reason for the processing state
001 = Timed out
002 = Content difference
101 = Inventory difference
ProcessingStateDescription optional Restriction of xs:string
Description of the status
NAD 1..∞ NAD Complex Type
Information about the involved parties
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
HTXT optional HTXT Complex Type
Additional information on HEAD Level
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
MULH 0..10 MULH Complex Type
Attached documents
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
Source
<xs:element name="HEAD" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kopfteil des Bestellstatus (OSTRPT)  </xs:documentation>
    <xs:documentation xml:lang="en">Head of the order status report (OSTRPT) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentHead">
        <xs:sequence>
          <xs:element name="OrderNumberRef" type="DocumentReference" minOccurs="0" maxOccurs="1">
            <xs:annotation>
              <xs:documentation xml:lang="de">Referenz zu der Bestellung auf die sich der Status bezieht</xs:documentation>
              <xs:documentation xml:lang="en">Reference to the order number referred in this status repoort</xs:documentation>
            </xs:annotation>
          </xs:element>
          <xs:element name="DocumentNumberRef" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="1">
            <xs:annotation>
              <xs:documentation xml:lang="de">Referenz zu dem Dokument auf das sich der Status beziegt, falls nicht die Bestellung ist</xs:documentation>
              <xs:documentation xml:lang="en">Reference to the document responsible for the status - if not the order</xs:documentation>
            </xs:annotation>
          </xs:element>
          <xs:element name="Commission" type="Commission" minOccurs="0">
            <xs:annotation>
              <xs:documentation xml:lang="de">Kommmission Ident aus der Bestellung</xs:documentation>
              <xs:documentation xml:lang="en">Commission reference out of the order</xs:documentation>
            </xs:annotation>
          </xs:element>
          <xs:element name="ProcessingStates" type="ProcessingStates" minOccurs="0">
            <xs:annotation>
              <xs:documentation xml:lang="de">Statusinformationen auf Kopf Ebene</xs:documentation>
              <xs:documentation xml:lang="en">status information on HEAD Level</xs:documentation>
            </xs:annotation>
          </xs:element>
          <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded">
            <xs:annotation>
              <xs:documentation xml:lang="de">Informationen zu den beteiligten Parteien</xs:documentation>
              <xs:documentation xml:lang="en">Information about the involved parties</xs:documentation>
            </xs:annotation>
          </xs:element>
          <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1">
            <xs:annotation>
              <xs:documentation xml:lang="de">Zusatzinformationen Kopf Ebene</xs:documentation>
              <xs:documentation xml:lang="en">Additional information on HEAD Level</xs:documentation>
            </xs:annotation>
          </xs:element>
          <xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10">
            <xs:annotation>
              <xs:documentation xml:lang="de">Angehängte Dokumente</xs:documentation>
              <xs:documentation xml:lang="en">Attached documents</xs:documentation>
            </xs:annotation>
          </xs:element>
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


AdditionalReference Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : AdditionalReference Element
Namespace (none)
Type
DocumentReferenceQualified Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence AdditionalReference Element
Overview
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalReference" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


Commission Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : Commission Element
Description
Commission reference out of the order
Namespace (none)
Type
Commission Simple Type
Diagram
Commission Element
Overview
Commission optional Commission Simple Type
Commission reference out of the order
Source
<xs:element name="Commission" type="Commission" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kommmission Ident aus der Bestellung</xs:documentation>
    <xs:documentation xml:lang="en">Commission reference out of the order</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


DocumentDate Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : DocumentDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocumentDate Element
Overview
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocumentDate" type="EDIDate" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


DocumentFunctionSymbol Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : DocumentFunctionSymbol Element
Namespace (none)
Type
DocumentFunctionSymbol Simple Type
Diagram
DocumentFunctionSymbol Element
Overview
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
Source
<xs:element name="DocumentFunctionSymbol" type="DocumentFunctionSymbol" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


DocumentNumber Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : DocumentNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocumentNumber Element
Overview
DocumentNumber DocumentNumber Simple Type
Source
<xs:element name="DocumentNumber" type="DocumentNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


DocumentNumberRef Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : DocumentNumberRef Element
Description
Reference to the document responsible for the status - if not the order
Namespace (none)
Type
DocumentReferenceQualified Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence DocumentNumberRef Element
Overview
DocumentNumberRef optional DocumentReferenceQualified Complex Type
Reference to the document responsible for the status - if not the order
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocumentNumberRef" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Referenz zu dem Dokument auf das sich der Status beziegt, falls nicht die Bestellung ist</xs:documentation>
    <xs:documentation xml:lang="en">Reference to the document responsible for the status - if not the order</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


DocumentType Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : DocumentType Element
Namespace (none)
Type
DocumentType Simple Type
Diagram
DocumentType Element
Overview
DocumentType DocumentType Simple Type
Source
<xs:element name="DocumentType" type="DocumentType" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


HTXT Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : HTXT Element
Description
Additional information on HEAD Level
Namespace (none)
Type
HTXT Complex Type
Diagram
HeadText Element Sequence HTXT Element
Overview
HTXT optional HTXT Complex Type
Additional information on HEAD Level
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Zusatzinformationen Kopf Ebene</xs:documentation>
    <xs:documentation xml:lang="en">Additional information on HEAD Level</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


MULH Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : MULH Element
Description
Attached documents
Namespace (none)
Type
MULH Complex Type
Diagram
AppTargetIdentification Element AppSourceIdentification Element ObjectContent Element Source Element RemoteType Element FunctionType Element ObjectType Element ObjectDescription Element FileName Element Sequence MULH Element
Overview
MULH 0..10 MULH Complex Type
Attached documents
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
Source
<xs:element name="MULH" type="MULH" minOccurs="0" maxOccurs="10" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Angehängte Dokumente</xs:documentation>
    <xs:documentation xml:lang="en">Attached documents</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


NAD Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : NAD Element
Description
Information about the involved parties
Namespace (none)
Type
NAD Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element
Overview
NAD 1..∞ NAD Complex Type
Information about the involved parties
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Informationen zu den beteiligten Parteien</xs:documentation>
    <xs:documentation xml:lang="en">Information about the involved parties</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


OrderNumberRef Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : OrderNumberRef Element
Description
Reference to the order number referred in this status repoort
Namespace (none)
Type
DocumentReference Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence OrderNumberRef Element
Overview
OrderNumberRef optional DocumentReference Complex Type
Reference to the order number referred in this status repoort
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OrderNumberRef" type="DocumentReference" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Referenz zu der Bestellung auf die sich der Status bezieht</xs:documentation>
    <xs:documentation xml:lang="en">Reference to the order number referred in this status repoort</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


ProcessingStates Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : ProcessingStates Element
Description
status information on HEAD Level
Namespace (none)
Type
ProcessingStates Complex Type
Diagram
ProcessingStateDescription Element ProcessingStateReasonCode Element ProcessingStateCode Element ProcessingStateCategory Element Sequence ProcessingStates Element
Overview
ProcessingStates optional ProcessingStates Complex Type
status information on HEAD Level
Sequence
ProcessingStateCategory Restriction of xs:string
Type of process status
1 = Transport
2 = Order managament
3 = Control result
4 = Publication
5 = Legal regulation
ProcessingStateCode Restriction of xs:string
ProcessingStateReasonCode optional Restriction of xs:string
Reason for the processing state
001 = Timed out
002 = Content difference
101 = Inventory difference
ProcessingStateDescription optional Restriction of xs:string
Description of the status
Source
<xs:element name="ProcessingStates" type="ProcessingStates" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Statusinformationen auf Kopf Ebene</xs:documentation>
    <xs:documentation xml:lang="en">status information on HEAD Level</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


TechnicalReceiver Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : TechnicalReceiver Element
Description
technical, physical recipient of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiver Element
Overview
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
Source
<xs:element name="TechnicalReceiver" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Empfänger der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical recipient of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


TechnicalReceiverCopy Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : TechnicalReceiverCopy Element
Description
Physical receiver for a copy from this message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiverCopy Element
Overview
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Source
<xs:element name="TechnicalReceiverCopy" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Physischer Empfänger einer Kopie dieser Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Physical receiver for a copy from this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


TechnicalSender Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : TechnicalSender Element
Description
technical, physical sender of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalSender Element
Overview
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
Source
<xs:element name="TechnicalSender" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Versender der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical sender of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


VersionNumber Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > HEAD Element : VersionNumber Element
Namespace (none)
Type
MessageVersion Complex Type
Diagram
WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element
Overview
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
Source
<xs:element name="VersionNumber" type="MessageVersion" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


LINE Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element : LINE Element
Description
Position number within this status report (OSTRPT)
Namespace (none)
Diagram
ProcessingStateDescription Element ProcessingStateReasonCode Element ProcessingStateCode Element ProcessingStateCategory Element Sequence ProcessingStates Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence DocumentLineReference Element OrderPositionRef Element LineItemNumber Element Sequence LINE Element
Overview
LINE 0..∞
Position number within this status report (OSTRPT)
Sequence
LineItemNumber LineItemNumber Simple Type
Number of the position within the report
OrderPositionRef optional LineItemNumber Simple Type
Reference to the order position referred ot responsible for this status
DocumentLineReference optional DocumentLineReferenceQualified Complex Type
Reference to the document position resopnsible for the status
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
SeriesID optional ProductIdentifier Complex Type
Identification of the series related to the referred article
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Identification of the article within the referred position
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProcessingStates ProcessingStates Complex Type
status information to the referred position
Sequence
ProcessingStateCategory Restriction of xs:string
Type of process status
1 = Transport
2 = Order managament
3 = Control result
4 = Publication
5 = Legal regulation
ProcessingStateCode Restriction of xs:string
ProcessingStateReasonCode optional Restriction of xs:string
Reason for the processing state
001 = Timed out
002 = Content difference
101 = Inventory difference
ProcessingStateDescription optional Restriction of xs:string
Description of the status
Source
<xs:element name="LINE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Positionnummer innerhalb des Status Reports (OSTRPT)  </xs:documentation>
    <xs:documentation xml:lang="en">Position number within this status report (OSTRPT) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" maxOccurs="1 ">
        <xs:annotation>
          <xs:documentation xml:lang="de">Nummer der Position im Report</xs:documentation>
          <xs:documentation xml:lang="en">Number of the position within the report </xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OrderPositionRef" type="LineItemNumber" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Referenz zu der Bestellposition, auf die sich dieser Status bezieht</xs:documentation>
          <xs:documentation xml:lang="en">Reference to the order position referred ot responsible  for this status </xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="DocumentLineReference" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Referenz zu der Dokumentenposition, die zu dem Status führt</xs:documentation>
          <xs:documentation xml:lang="en">Reference to the document position resopnsible for the status </xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" maxOccurs="1 ">
        <xs:annotation>
          <xs:documentation xml:lang="de">Identifikation der Serie des Artikels in der benannten Position</xs:documentation>
          <xs:documentation xml:lang="en">Identification of the series related to the referred article </xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" maxOccurs="1 ">
        <xs:annotation>
          <xs:documentation xml:lang="de">Identifikation  des Artikels in der benannten Position</xs:documentation>
          <xs:documentation xml:lang="en">Identification of the article within the referred position </xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="ProcessingStates" type="ProcessingStates" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Statusinformationen zu dieser Position</xs:documentation>
          <xs:documentation xml:lang="en">status information to the referred position</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


DocumentLineReference Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > LINE Element : DocumentLineReference Element
Description
Reference to the document position resopnsible for the status
Namespace (none)
Type
DocumentLineReferenceQualified Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence DocumentLineReference Element
Overview
DocumentLineReference optional DocumentLineReferenceQualified Complex Type
Reference to the document position resopnsible for the status
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="DocumentLineReference" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Referenz zu der Dokumentenposition, die zu dem Status führt</xs:documentation>
    <xs:documentation xml:lang="en">Reference to the document position resopnsible for the status </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
LINE Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


LineItemNumber Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > LINE Element : LineItemNumber Element
Description
Number of the position within the report
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
LineItemNumber Element
Overview
LineItemNumber LineItemNumber Simple Type
Number of the position within the report
Source
<xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" maxOccurs="1 " xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer der Position im Report</xs:documentation>
    <xs:documentation xml:lang="en">Number of the position within the report </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
LINE Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


OrderPositionRef Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > LINE Element : OrderPositionRef Element
Description
Reference to the order position referred ot responsible for this status
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
OrderPositionRef Element
Overview
OrderPositionRef optional LineItemNumber Simple Type
Reference to the order position referred ot responsible for this status
Source
<xs:element name="OrderPositionRef" type="LineItemNumber" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Referenz zu der Bestellposition, auf die sich dieser Status bezieht</xs:documentation>
    <xs:documentation xml:lang="en">Reference to the order position referred ot responsible  for this status </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
LINE Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


ProcessingStates Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > LINE Element : ProcessingStates Element
Description
status information to the referred position
Namespace (none)
Type
ProcessingStates Complex Type
Diagram
ProcessingStateDescription Element ProcessingStateReasonCode Element ProcessingStateCode Element ProcessingStateCategory Element Sequence ProcessingStates Element
Overview
ProcessingStates ProcessingStates Complex Type
status information to the referred position
Sequence
ProcessingStateCategory Restriction of xs:string
Type of process status
1 = Transport
2 = Order managament
3 = Control result
4 = Publication
5 = Legal regulation
ProcessingStateCode Restriction of xs:string
ProcessingStateReasonCode optional Restriction of xs:string
Reason for the processing state
001 = Timed out
002 = Content difference
101 = Inventory difference
ProcessingStateDescription optional Restriction of xs:string
Description of the status
Source
<xs:element name="ProcessingStates" type="ProcessingStates" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Statusinformationen zu dieser Position</xs:documentation>
    <xs:documentation xml:lang="en">status information to the referred position</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
LINE Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


ProductID Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > LINE Element : ProductID Element
Description
Identification of the article within the referred position
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element
Overview
ProductID optional ProductIdentifier Complex Type
Identification of the article within the referred position
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" maxOccurs="1 " xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Identifikation  des Artikels in der benannten Position</xs:documentation>
    <xs:documentation xml:lang="en">Identification of the article within the referred position </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
LINE Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


SeriesID Element
XML Einrichten Version 1.2 > OstrptMessage Element > OSTRPT Element > LINE Element : SeriesID Element
Description
Identification of the series related to the referred article
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element
Overview
SeriesID optional ProductIdentifier Complex Type
Identification of the series related to the referred article
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" maxOccurs="1 " xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Identifikation der Serie des Artikels in der benannten Position</xs:documentation>
    <xs:documentation xml:lang="en">Identification of the series related to the referred article </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
LINE Element | OSTRPT Element | OstrptMessage Element | XML Einrichten Version 1.2


RecadvMessage Element
XML Einrichten Version 1.2 : RecadvMessage Element
Description
Mesage: Receiving advice(RECADV)
Namespace (none)
Diagram
RECADV Element Sequence RecadvMessage Element
Overview
RecadvMessage
Mesage: Receiving advice(RECADV)
Sequence
RECADV 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the receiving advice(RECADV)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
VATId optional VATId Simple Type
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
RequestedDeliveryDate optional RequestedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Commission optional Commission Simple Type
OrderResponseRef optional OrderResponseNumberRef Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DespatchAdviceRef DespatchAdviceNumberRef Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TourNumber TourNumber Simple Type
DespatchNumber optional DespatchNumberRef Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
UnloadingDuration optional Duration Complex Type
Unit optional Unit Simple Type
LeadWireSealNumber optional NumberOfTheLeadWireSeal Simple Type
GoodsReceiptNumber optional GoodsReceiptNumber Simple Type
PickUpDate optional PickUpDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
HTXT 0..∞ HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
PACI 0..∞ DocumentPaci Complex Type
Description of the pachaging pieces within the receiving advice(RECADV)
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
LINE 1..∞
Description of the articles within the receiving advice(RECADV)
Sequence
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
BlanketOrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Commission optional Commission Simple Type
PackagingType optional TypeOfPackaging Simple Type
BatchNumber optional BatchNumber Simple Type
SerialNumber optional SerialNumber Simple Type
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
OrderedQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
OrderResponseQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
ReceivingAdviceQuantity Quantity Complex Type
Unit optional Unit Simple Type
QuantityExclusiveOfEvaluation optional Quantity Complex Type
Unit optional Unit Simple Type
QuantityDeviation optional QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
QuantityDeviationType optional TypeOfQuantityDeviation Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
DespatchDate optional DespatchDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
PACILINE 0..∞ DocumentPaciLine Complex Type
Description of the relation bewteen articles and packagign pieces within the receiving advice(RECADV)
Sequence
LineItemNumber LineItemNumber Simple Type
reference to a position defined in LINE
PaciNumber PackingPieceNumber Simple Type
Reference to a position defined in PACi
Quantity optional Quantity Complex Type
Number of units from LINE in PACI
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Footer of the receiving advice(RECADV)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="RecadvMessage" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <b>Nachricht: Wareiengangsmeldung (RECADV) </b>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <b>Mesage: Receiving advice(RECADV) </b>
    </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RECADV" minOccurs="1" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Kopfteil der Wareiengangsmeldung (RECADV) </xs:documentation>
                <xs:documentation xml:lang="en">Head of the receiving advice(RECADV) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentHead">
                    <xs:sequence>
                      <xs:element name="VATId" type="VATId" minOccurs="0" />
                      <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
                      <xs:element name="RequestedDeliveryDate" type="RequestedDeliveryDate" minOccurs="0" />
                      <xs:element name="Commission" type="Commission" minOccurs="0" />
                      <xs:element name="OrderResponseRef" type="OrderResponseNumberRef" minOccurs="0" />
                      <xs:element name="DespatchAdviceRef" type="DespatchAdviceNumberRef" minOccurs="1" />
                      <xs:element name="TourNumber" type="TourNumber" minOccurs="1" />
                      <xs:element name="DespatchNumber" type="DespatchNumberRef" minOccurs="0" />
                      <xs:element name="UnloadingDuration" type="Duration" minOccurs="0" />
                      <xs:element name="LeadWireSealNumber" type="NumberOfTheLeadWireSeal" minOccurs="0" />
                      <xs:element name="GoodsReceiptNumber" type="GoodsReceiptNumber" minOccurs="0" />
                      <xs:element name="PickUpDate" type="PickUpDate" minOccurs="0" />
                      <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="unbounded" />
                      <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Beschreibung der Packstücke in der Wareiengangsmeldung (RECADV)  </xs:documentation>
                <xs:documentation xml:lang="en">Description of the pachaging pieces within the receiving advice(RECADV) </xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Beschreibung der Artikel in der Wareiengangsmeldung (RECADV) </xs:documentation>
                <xs:documentation xml:lang="en">Description of the articles within the receiving advice(RECADV) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
                  <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
                  <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" />
                  <xs:element name="BlanketOrderLineRef" type="DocumentLineReference" minOccurs="0" />
                  <xs:element name="Commission" type="Commission" minOccurs="0" />
                  <xs:element name="PackagingType" type="TypeOfPackaging" minOccurs="0" />
                  <xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" />
                  <xs:element name="SerialNumber" type="SerialNumber" minOccurs="0" />
                  <xs:element name="AdditionalLineRef" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="OrderedQuantity" type="Quantity" minOccurs="0" />
                  <xs:element name="OrderResponseQuantity" type="Quantity" minOccurs="0" />
                  <xs:element name="ReceivingAdviceQuantity" type="Quantity" minOccurs="1" />
                  <xs:element name="QuantityExclusiveOfEvaluation" type="Quantity" minOccurs="0" />
                  <xs:element name="QuantityDeviation" type="QuantityQualified" minOccurs="0" />
                  <xs:element name="QuantityDeviationType" type="TypeOfQuantityDeviation" minOccurs="0" />
                  <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
                  <xs:element name="DespatchDate" type="DespatchDate" minOccurs="0" />
                  <xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="AdditionalQuantity" type="QuantityQualified" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
                  <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PACILINE" type="DocumentPaciLine" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Beschreibung der Zugeörigkeit von Artikeln zur Packstücken in der Wareiengangsmeldung (RECADV) </xs:documentation>
                <xs:documentation xml:lang="en">Description of the relation bewteen articles and packagign pieces within the receiving advice(RECADV)</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Abschluss der Wareiengangsmeldung (RECADV)</xs:documentation>
                <xs:documentation xml:lang="en">Footer of the receiving advice(RECADV) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentFoot" />
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
XML Einrichten Version 1.2


RECADV Element
XML Einrichten Version 1.2 > RecadvMessage Element : RECADV Element
Namespace (none)
Diagram
FOOT Element Quantity Element PaciNumber Element LineItemNumber Element Sequence PACILINE Element LINE Element MEA Element ConsumerInstructions Element ShippingMark Element TypeOfShippingMark Element LoadingTackle Element TypeOfPackaging Element NumberOfPackages Element ParentPaciNumber Element PaciNumber Element Sequence PACI Element HEAD Element Sequence RECADV Element
Overview
RECADV 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the receiving advice(RECADV)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
VATId optional VATId Simple Type
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
RequestedDeliveryDate optional RequestedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Commission optional Commission Simple Type
OrderResponseRef optional OrderResponseNumberRef Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DespatchAdviceRef DespatchAdviceNumberRef Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TourNumber TourNumber Simple Type
DespatchNumber optional DespatchNumberRef Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
UnloadingDuration optional Duration Complex Type
Unit optional Unit Simple Type
LeadWireSealNumber optional NumberOfTheLeadWireSeal Simple Type
GoodsReceiptNumber optional GoodsReceiptNumber Simple Type
PickUpDate optional PickUpDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
HTXT 0..∞ HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
PACI 0..∞ DocumentPaci Complex Type
Description of the pachaging pieces within the receiving advice(RECADV)
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
LINE 1..∞
Description of the articles within the receiving advice(RECADV)
Sequence
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
BlanketOrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Commission optional Commission Simple Type
PackagingType optional TypeOfPackaging Simple Type
BatchNumber optional BatchNumber Simple Type
SerialNumber optional SerialNumber Simple Type
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
OrderedQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
OrderResponseQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
ReceivingAdviceQuantity Quantity Complex Type
Unit optional Unit Simple Type
QuantityExclusiveOfEvaluation optional Quantity Complex Type
Unit optional Unit Simple Type
QuantityDeviation optional QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
QuantityDeviationType optional TypeOfQuantityDeviation Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
DespatchDate optional DespatchDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
PACILINE 0..∞ DocumentPaciLine Complex Type
Description of the relation bewteen articles and packagign pieces within the receiving advice(RECADV)
Sequence
LineItemNumber LineItemNumber Simple Type
reference to a position defined in LINE
PaciNumber PackingPieceNumber Simple Type
Reference to a position defined in PACi
Quantity optional Quantity Complex Type
Number of units from LINE in PACI
Unit optional Unit Simple Type
FOOT Extension of DocumentFoot Complex Type
Footer of the receiving advice(RECADV)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="RECADV" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Kopfteil der Wareiengangsmeldung (RECADV) </xs:documentation>
          <xs:documentation xml:lang="en">Head of the receiving advice(RECADV) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentHead">
              <xs:sequence>
                <xs:element name="VATId" type="VATId" minOccurs="0" />
                <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
                <xs:element name="RequestedDeliveryDate" type="RequestedDeliveryDate" minOccurs="0" />
                <xs:element name="Commission" type="Commission" minOccurs="0" />
                <xs:element name="OrderResponseRef" type="OrderResponseNumberRef" minOccurs="0" />
                <xs:element name="DespatchAdviceRef" type="DespatchAdviceNumberRef" minOccurs="1" />
                <xs:element name="TourNumber" type="TourNumber" minOccurs="1" />
                <xs:element name="DespatchNumber" type="DespatchNumberRef" minOccurs="0" />
                <xs:element name="UnloadingDuration" type="Duration" minOccurs="0" />
                <xs:element name="LeadWireSealNumber" type="NumberOfTheLeadWireSeal" minOccurs="0" />
                <xs:element name="GoodsReceiptNumber" type="GoodsReceiptNumber" minOccurs="0" />
                <xs:element name="PickUpDate" type="PickUpDate" minOccurs="0" />
                <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="unbounded" />
                <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Beschreibung der Packstücke in der Wareiengangsmeldung (RECADV)  </xs:documentation>
          <xs:documentation xml:lang="en">Description of the pachaging pieces within the receiving advice(RECADV) </xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="LINE" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Beschreibung der Artikel in der Wareiengangsmeldung (RECADV) </xs:documentation>
          <xs:documentation xml:lang="en">Description of the articles within the receiving advice(RECADV) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
            <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
            <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" />
            <xs:element name="BlanketOrderLineRef" type="DocumentLineReference" minOccurs="0" />
            <xs:element name="Commission" type="Commission" minOccurs="0" />
            <xs:element name="PackagingType" type="TypeOfPackaging" minOccurs="0" />
            <xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" />
            <xs:element name="SerialNumber" type="SerialNumber" minOccurs="0" />
            <xs:element name="AdditionalLineRef" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="OrderedQuantity" type="Quantity" minOccurs="0" />
            <xs:element name="OrderResponseQuantity" type="Quantity" minOccurs="0" />
            <xs:element name="ReceivingAdviceQuantity" type="Quantity" minOccurs="1" />
            <xs:element name="QuantityExclusiveOfEvaluation" type="Quantity" minOccurs="0" />
            <xs:element name="QuantityDeviation" type="QuantityQualified" minOccurs="0" />
            <xs:element name="QuantityDeviationType" type="TypeOfQuantityDeviation" minOccurs="0" />
            <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
            <xs:element name="DespatchDate" type="DespatchDate" minOccurs="0" />
            <xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="AdditionalQuantity" type="QuantityQualified" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
            <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PACILINE" type="DocumentPaciLine" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Beschreibung der Zugeörigkeit von Artikeln zur Packstücken in der Wareiengangsmeldung (RECADV) </xs:documentation>
          <xs:documentation xml:lang="en">Description of the relation bewteen articles and packagign pieces within the receiving advice(RECADV)</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Abschluss der Wareiengangsmeldung (RECADV)</xs:documentation>
          <xs:documentation xml:lang="en">Footer of the receiving advice(RECADV) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentFoot" />
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
RecadvMessage Element | XML Einrichten Version 1.2


FOOT Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element : FOOT Element
Description
Footer of the receiving advice(RECADV)
Namespace (none)
Type
Extension of DocumentFoot Complex Type
Diagram
SendingDate Element Sequence FOOT Element
Overview
FOOT Extension of DocumentFoot Complex Type
Footer of the receiving advice(RECADV)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="FOOT" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Abschluss der Wareiengangsmeldung (RECADV)</xs:documentation>
    <xs:documentation xml:lang="en">Footer of the receiving advice(RECADV) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentFoot" />
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


SendingDate Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > FOOT Element : SendingDate Element
Description
Sending date of this message
Namespace (none)
Type
EDIDate Complex Type
Diagram
SendingDate Element
Overview
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="SendingDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Versanddatum der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Sending date of this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FOOT Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


HEAD Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element : HEAD Element
Description
Head of the receiving advice(RECADV)
Namespace (none)
Type
Extension of DocumentHead Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element HeadText Element Sequence HTXT Element PickUpDate Element GoodsReceiptNumber Element LeadWireSealNumber Element UnloadingDuration Element DocDate Element DocRefNumber Element Sequence DespatchNumber Element TourNumber Element DocDate Element DocRefNumber Element Sequence DespatchAdviceRef Element DocDate Element DocRefNumber Element Sequence OrderResponseRef Element Commission Element RequestedDeliveryDate Element DocDate Element DocRefNumber Element Sequence OrderNumberRef Element VATId Element TechnicalReceiverCopy Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element AdditionalDate Element TechnicalSender Element TechnicalReceiver Element DocumentDate Element DocumentNumber Element DocumentFunctionSymbol Element DocumentType Element WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element Sequence HEAD Element
Overview
HEAD Extension of DocumentHead Complex Type
Head of the receiving advice(RECADV)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
VATId optional VATId Simple Type
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
RequestedDeliveryDate optional RequestedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Commission optional Commission Simple Type
OrderResponseRef optional OrderResponseNumberRef Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DespatchAdviceRef DespatchAdviceNumberRef Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TourNumber TourNumber Simple Type
DespatchNumber optional DespatchNumberRef Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
UnloadingDuration optional Duration Complex Type
Unit optional Unit Simple Type
LeadWireSealNumber optional NumberOfTheLeadWireSeal Simple Type
GoodsReceiptNumber optional GoodsReceiptNumber Simple Type
PickUpDate optional PickUpDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
HTXT 0..∞ HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="HEAD" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kopfteil der Wareiengangsmeldung (RECADV) </xs:documentation>
    <xs:documentation xml:lang="en">Head of the receiving advice(RECADV) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentHead">
        <xs:sequence>
          <xs:element name="VATId" type="VATId" minOccurs="0" />
          <xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" />
          <xs:element name="RequestedDeliveryDate" type="RequestedDeliveryDate" minOccurs="0" />
          <xs:element name="Commission" type="Commission" minOccurs="0" />
          <xs:element name="OrderResponseRef" type="OrderResponseNumberRef" minOccurs="0" />
          <xs:element name="DespatchAdviceRef" type="DespatchAdviceNumberRef" minOccurs="1" />
          <xs:element name="TourNumber" type="TourNumber" minOccurs="1" />
          <xs:element name="DespatchNumber" type="DespatchNumberRef" minOccurs="0" />
          <xs:element name="UnloadingDuration" type="Duration" minOccurs="0" />
          <xs:element name="LeadWireSealNumber" type="NumberOfTheLeadWireSeal" minOccurs="0" />
          <xs:element name="GoodsReceiptNumber" type="GoodsReceiptNumber" minOccurs="0" />
          <xs:element name="PickUpDate" type="PickUpDate" minOccurs="0" />
          <xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="unbounded" />
          <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


AdditionalReference Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : AdditionalReference Element
Namespace (none)
Type
DocumentReferenceQualified Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence AdditionalReference Element
Overview
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalReference" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


Commission Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : Commission Element
Namespace (none)
Type
Commission Simple Type
Diagram
Commission Element
Overview
Commission optional Commission Simple Type
Source
<xs:element name="Commission" type="Commission" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


DespatchAdviceRef Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : DespatchAdviceRef Element
Namespace (none)
Type
DespatchAdviceNumberRef Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence DespatchAdviceRef Element
Overview
DespatchAdviceRef DespatchAdviceNumberRef Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DespatchAdviceRef" type="DespatchAdviceNumberRef" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


DespatchNumber Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : DespatchNumber Element
Namespace (none)
Type
DespatchNumberRef Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence DespatchNumber Element
Overview
DespatchNumber optional DespatchNumberRef Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DespatchNumber" type="DespatchNumberRef" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


DocumentDate Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : DocumentDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocumentDate Element
Overview
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocumentDate" type="EDIDate" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


DocumentFunctionSymbol Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : DocumentFunctionSymbol Element
Namespace (none)
Type
DocumentFunctionSymbol Simple Type
Diagram
DocumentFunctionSymbol Element
Overview
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
Source
<xs:element name="DocumentFunctionSymbol" type="DocumentFunctionSymbol" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


DocumentNumber Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : DocumentNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocumentNumber Element
Overview
DocumentNumber DocumentNumber Simple Type
Source
<xs:element name="DocumentNumber" type="DocumentNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


DocumentType Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : DocumentType Element
Namespace (none)
Type
DocumentType Simple Type
Diagram
DocumentType Element
Overview
DocumentType DocumentType Simple Type
Source
<xs:element name="DocumentType" type="DocumentType" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


GoodsReceiptNumber Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : GoodsReceiptNumber Element
Namespace (none)
Type
GoodsReceiptNumber Simple Type
Diagram
GoodsReceiptNumber Element
Overview
GoodsReceiptNumber optional GoodsReceiptNumber Simple Type
Source
<xs:element name="GoodsReceiptNumber" type="GoodsReceiptNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


HTXT Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : HTXT Element
Namespace (none)
Type
HTXT Complex Type
Diagram
HeadText Element Sequence HTXT Element
Overview
HTXT 0..∞ HTXT Complex Type
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="HTXT" type="HTXT" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


LeadWireSealNumber Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : LeadWireSealNumber Element
Namespace (none)
Type
NumberOfTheLeadWireSeal Simple Type
Diagram
LeadWireSealNumber Element
Overview
LeadWireSealNumber optional NumberOfTheLeadWireSeal Simple Type
Source
<xs:element name="LeadWireSealNumber" type="NumberOfTheLeadWireSeal" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


NAD Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : NAD Element
Namespace (none)
Type
NAD Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element
Overview
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


OrderNumberRef Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : OrderNumberRef Element
Namespace (none)
Type
OrderNumber Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence OrderNumberRef Element
Overview
OrderNumberRef OrderNumber Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OrderNumberRef" type="OrderNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


OrderResponseRef Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : OrderResponseRef Element
Namespace (none)
Type
OrderResponseNumberRef Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence OrderResponseRef Element
Overview
OrderResponseRef optional OrderResponseNumberRef Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OrderResponseRef" type="OrderResponseNumberRef" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


PickUpDate Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : PickUpDate Element
Namespace (none)
Type
PickUpDate Complex Type
Diagram
PickUpDate Element
Overview
PickUpDate optional PickUpDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="PickUpDate" type="PickUpDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


RequestedDeliveryDate Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : RequestedDeliveryDate Element
Namespace (none)
Type
RequestedDeliveryDate Complex Type
Diagram
RequestedDeliveryDate Element
Overview
RequestedDeliveryDate optional RequestedDeliveryDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="RequestedDeliveryDate" type="RequestedDeliveryDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


TechnicalReceiver Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : TechnicalReceiver Element
Description
technical, physical recipient of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiver Element
Overview
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
Source
<xs:element name="TechnicalReceiver" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Empfänger der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical recipient of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


TechnicalReceiverCopy Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : TechnicalReceiverCopy Element
Description
Physical receiver for a copy from this message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiverCopy Element
Overview
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Source
<xs:element name="TechnicalReceiverCopy" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Physischer Empfänger einer Kopie dieser Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Physical receiver for a copy from this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


TechnicalSender Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : TechnicalSender Element
Description
technical, physical sender of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalSender Element
Overview
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
Source
<xs:element name="TechnicalSender" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Versender der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical sender of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


TourNumber Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : TourNumber Element
Namespace (none)
Type
TourNumber Simple Type
Diagram
TourNumber Element
Overview
TourNumber TourNumber Simple Type
Source
<xs:element name="TourNumber" type="TourNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


UnloadingDuration Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : UnloadingDuration Element
Namespace (none)
Type
Duration Complex Type
Diagram
UnloadingDuration Element
Overview
UnloadingDuration optional Duration Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="UnloadingDuration" type="Duration" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


VATId Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : VATId Element
Namespace (none)
Type
VATId Simple Type
Diagram
VATId Element
Overview
VATId optional VATId Simple Type
Source
<xs:element name="VATId" type="VATId" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


VersionNumber Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > HEAD Element : VersionNumber Element
Namespace (none)
Type
MessageVersion Complex Type
Diagram
WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element
Overview
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
Source
<xs:element name="VersionNumber" type="MessageVersion" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


LINE Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element : LINE Element
Description
Description of the articles within the receiving advice(RECADV)
Namespace (none)
Diagram
NumericValue Element TextValue Element OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element LineText Element Sequence LTXT Element MEA Element AdditionalQuantity Element AdditionalDate Element DespatchDate Element NumberOfPackages Element QuantityDeviationType Element QuantityDeviation Element QuantityExclusiveOfEvaluation Element ReceivingAdviceQuantity Element OrderResponseQuantity Element OrderedQuantity Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element SerialNumber Element BatchNumber Element PackagingType Element Commission Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence BlanketOrderLineRef Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence OrderLineRef Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element ParentLineItemNumber Element LineItemNumber Element Sequence LINE Element
Overview
LINE 1..∞
Description of the articles within the receiving advice(RECADV)
Sequence
LineItemNumber LineItemNumber Simple Type
ParentLineItemNumber optional LineItemNumber Simple Type
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
BlanketOrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Commission optional Commission Simple Type
PackagingType optional TypeOfPackaging Simple Type
BatchNumber optional BatchNumber Simple Type
SerialNumber optional SerialNumber Simple Type
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
OrderedQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
OrderResponseQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
ReceivingAdviceQuantity Quantity Complex Type
Unit optional Unit Simple Type
QuantityExclusiveOfEvaluation optional Quantity Complex Type
Unit optional Unit Simple Type
QuantityDeviation optional QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
QuantityDeviationType optional TypeOfQuantityDeviation Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
DespatchDate optional DespatchDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="LINE" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Beschreibung der Artikel in der Wareiengangsmeldung (RECADV) </xs:documentation>
    <xs:documentation xml:lang="en">Description of the articles within the receiving advice(RECADV) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" />
      <xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" />
      <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" />
      <xs:element name="BlanketOrderLineRef" type="DocumentLineReference" minOccurs="0" />
      <xs:element name="Commission" type="Commission" minOccurs="0" />
      <xs:element name="PackagingType" type="TypeOfPackaging" minOccurs="0" />
      <xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" />
      <xs:element name="SerialNumber" type="SerialNumber" minOccurs="0" />
      <xs:element name="AdditionalLineRef" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="OrderedQuantity" type="Quantity" minOccurs="0" />
      <xs:element name="OrderResponseQuantity" type="Quantity" minOccurs="0" />
      <xs:element name="ReceivingAdviceQuantity" type="Quantity" minOccurs="1" />
      <xs:element name="QuantityExclusiveOfEvaluation" type="Quantity" minOccurs="0" />
      <xs:element name="QuantityDeviation" type="QuantityQualified" minOccurs="0" />
      <xs:element name="QuantityDeviationType" type="TypeOfQuantityDeviation" minOccurs="0" />
      <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
      <xs:element name="DespatchDate" type="DespatchDate" minOccurs="0" />
      <xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="AdditionalQuantity" type="QuantityQualified" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" />
      <xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


AdditionalLineRef Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : AdditionalLineRef Element
Namespace (none)
Type
DocumentLineReferenceQualified Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element
Overview
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="AdditionalLineRef" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


AdditionalQuantity Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : AdditionalQuantity Element
Namespace (none)
Type
QuantityQualified Complex Type
Diagram
AdditionalQuantity Element
Overview
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
Source
<xs:element name="AdditionalQuantity" type="QuantityQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


BatchNumber Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : BatchNumber Element
Namespace (none)
Type
BatchNumber Simple Type
Diagram
BatchNumber Element
Overview
BatchNumber optional BatchNumber Simple Type
Source
<xs:element name="BatchNumber" type="BatchNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


BlanketOrderLineRef Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : BlanketOrderLineRef Element
Namespace (none)
Type
DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence BlanketOrderLineRef Element
Overview
BlanketOrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="BlanketOrderLineRef" type="DocumentLineReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


Commission Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : Commission Element
Namespace (none)
Type
Commission Simple Type
Diagram
Commission Element
Overview
Commission optional Commission Simple Type
Source
<xs:element name="Commission" type="Commission" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


DespatchDate Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : DespatchDate Element
Namespace (none)
Type
DespatchDate Complex Type
Diagram
DespatchDate Element
Overview
DespatchDate optional DespatchDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DespatchDate" type="DespatchDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


LineItemNumber Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : LineItemNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
LineItemNumber Element
Overview
LineItemNumber LineItemNumber Simple Type
Source
<xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


LTXT Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : LTXT Element
Namespace (none)
Type
LTXT Complex Type
Diagram
LineText Element Sequence LTXT Element
Overview
LTXT optional LTXT Complex Type
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="LTXT" type="LTXT" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


MEA Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : MEA Element
Namespace (none)
Type
MEA Complex Type
Diagram
MEA Element
Overview
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


NumberOfPackages Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : NumberOfPackages Element
Namespace (none)
Type
NumberOfPackages Simple Type
Diagram
NumberOfPackages Element
Overview
NumberOfPackages optional NumberOfPackages Simple Type
Source
<xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


OPT Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : OPT Element
Namespace (none)
Type
OPT Complex Type
Diagram
NumericValue Element TextValue Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Element
Overview
OPT 0..∞ OPT Complex Type
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OPT" type="OPT" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


OrderedQuantity Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : OrderedQuantity Element
Namespace (none)
Type
Quantity Complex Type
Diagram
OrderedQuantity Element
Overview
OrderedQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OrderedQuantity" type="Quantity" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


OrderLineRef Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : OrderLineRef Element
Namespace (none)
Type
DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence OrderLineRef Element
Overview
OrderLineRef optional DocumentLineReference Complex Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="OrderLineRef" type="DocumentLineReference" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


OrderResponseQuantity Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : OrderResponseQuantity Element
Namespace (none)
Type
Quantity Complex Type
Diagram
OrderResponseQuantity Element
Overview
OrderResponseQuantity optional Quantity Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="OrderResponseQuantity" type="Quantity" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


PackagingType Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : PackagingType Element
Namespace (none)
Type
TypeOfPackaging Simple Type
Diagram
PackagingType Element
Overview
PackagingType optional TypeOfPackaging Simple Type
Source
<xs:element name="PackagingType" type="TypeOfPackaging" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


ParentLineItemNumber Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : ParentLineItemNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
ParentLineItemNumber Element
Overview
ParentLineItemNumber optional LineItemNumber Simple Type
Source
<xs:element name="ParentLineItemNumber" type="LineItemNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


ProductID Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : ProductID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element
Overview
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


QuantityDeviation Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : QuantityDeviation Element
Namespace (none)
Type
QuantityQualified Complex Type
Diagram
QuantityDeviation Element
Overview
QuantityDeviation optional QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
Source
<xs:element name="QuantityDeviation" type="QuantityQualified" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


QuantityDeviationType Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : QuantityDeviationType Element
Namespace (none)
Type
TypeOfQuantityDeviation Simple Type
Diagram
QuantityDeviationType Element
Overview
QuantityDeviationType optional TypeOfQuantityDeviation Simple Type
Source
<xs:element name="QuantityDeviationType" type="TypeOfQuantityDeviation" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


QuantityExclusiveOfEvaluation Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : QuantityExclusiveOfEvaluation Element
Namespace (none)
Type
Quantity Complex Type
Diagram
QuantityExclusiveOfEvaluation Element
Overview
QuantityExclusiveOfEvaluation optional Quantity Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="QuantityExclusiveOfEvaluation" type="Quantity" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


ReceivingAdviceQuantity Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : ReceivingAdviceQuantity Element
Namespace (none)
Type
Quantity Complex Type
Diagram
ReceivingAdviceQuantity Element
Overview
ReceivingAdviceQuantity Quantity Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="ReceivingAdviceQuantity" type="Quantity" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


SerialNumber Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : SerialNumber Element
Namespace (none)
Type
SerialNumber Simple Type
Diagram
SerialNumber Element
Overview
SerialNumber optional SerialNumber Simple Type
Source
<xs:element name="SerialNumber" type="SerialNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


SeriesID Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element > LINE Element : SeriesID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element
Overview
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LINE Element | RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


PACI Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element : PACI Element
Description
Description of the pachaging pieces within the receiving advice(RECADV)
Namespace (none)
Type
DocumentPaci Complex Type
Diagram
MEA Element ConsumerInstructions Element ShippingMark Element TypeOfShippingMark Element LoadingTackle Element TypeOfPackaging Element NumberOfPackages Element ParentPaciNumber Element PaciNumber Element Sequence PACI Element
Overview
PACI 0..∞ DocumentPaci Complex Type
Description of the pachaging pieces within the receiving advice(RECADV)
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="PACI" type="DocumentPaci" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Beschreibung der Packstücke in der Wareiengangsmeldung (RECADV)  </xs:documentation>
    <xs:documentation xml:lang="en">Description of the pachaging pieces within the receiving advice(RECADV) </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


PACILINE Element
XML Einrichten Version 1.2 > RecadvMessage Element > RECADV Element : PACILINE Element
Description
Description of the relation bewteen articles and packagign pieces within the receiving advice(RECADV)
Namespace (none)
Type
DocumentPaciLine Complex Type
Diagram
Quantity Element PaciNumber Element LineItemNumber Element Sequence PACILINE Element
Overview
PACILINE 0..∞ DocumentPaciLine Complex Type
Description of the relation bewteen articles and packagign pieces within the receiving advice(RECADV)
Sequence
LineItemNumber LineItemNumber Simple Type
reference to a position defined in LINE
PaciNumber PackingPieceNumber Simple Type
Reference to a position defined in PACi
Quantity optional Quantity Complex Type
Number of units from LINE in PACI
Unit optional Unit Simple Type
Source
<xs:element name="PACILINE" type="DocumentPaciLine" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Beschreibung der Zugeörigkeit von Artikeln zur Packstücken in der Wareiengangsmeldung (RECADV) </xs:documentation>
    <xs:documentation xml:lang="en">Description of the relation bewteen articles and packagign pieces within the receiving advice(RECADV)</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RECADV Element | RecadvMessage Element | XML Einrichten Version 1.2


RemadvMessage Element
XML Einrichten Version 1.2 : RemadvMessage Element
Description
Mesage: Remittance advise (REMADV)
Namespace (none)
Diagram
REMADV Element Sequence RemadvMessage Element
Overview
RemadvMessage
Mesage: Remittance advise (REMADV)
Sequence
REMADV 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the remittance advise (REMADV)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
PaymentType optional PaymentType Simple Type
PaymentWay optional PaymentWay Simple Type
PaymentDate optional PaymentDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AccountingPeriodStartDate optional AccountingPeriodDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AccountingPeriodEndDate optional AccountingPeriodDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
FinancialInformation optional FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
Currency optional Currency Simple Type
ExchangeRate optional ExchangeRate Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
MessageADV 1..∞
Sequence
DocumentType DocumentType Simple Type
PreviousDocumentNumber DocumentNumber Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
MAJT 1..∞ Adjustment Complex Type
Sequence
CorrectionReason optional CorrectionReason Simple Type
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
CorrectionVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
ProductADV
Sequence
IndicatorForDocumentLine optional IndicatorForDocumentLine Simple Type
LineItemNumber optional LineItemNumber Simple Type
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LAJT 1..∞ Adjustment Complex Type
Sequence
CorrectionReason optional CorrectionReason Simple Type
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
CorrectionVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
FOOT Extension of DocumentFoot Complex Type
Footer of the remittance advise (REMADV)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
VatTotal 0..3 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="RemadvMessage" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <b>Nachricht: Zahlungsavise (REMADV) </b>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <b>Mesage: Remittance advise (REMADV) </b>
    </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="REMADV" minOccurs="1" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Kopfteil der Zahlungsavise (REMADV)  </xs:documentation>
                <xs:documentation xml:lang="en">Head of the remittance advise (REMADV) </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentHead">
                    <xs:sequence>
                      <xs:element name="PaymentType" type="PaymentType" minOccurs="0" />
                      <xs:element name="PaymentWay" type="PaymentWay" minOccurs="0" />
                      <xs:element name="PaymentDate" type="PaymentDate" minOccurs="0" />
                      <xs:element name="AccountingPeriodStartDate" type="AccountingPeriodDate" minOccurs="0" />
                      <xs:element name="AccountingPeriodEndDate" type="AccountingPeriodDate" minOccurs="0" />
                      <xs:element name="FinancialInformation" type="FII" minOccurs="0" />
                      <xs:element name="Currency" type="Currency" minOccurs="0" />
                      <xs:element name="ExchangeRate" type="ExchangeRate" minOccurs="0" />
                      <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="MessageADV" minOccurs="1" maxOccurs="unbounded">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DocumentType" type="DocumentType" />
                  <xs:element name="PreviousDocumentNumber" type="DocumentNumber" />
                  <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
                  <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
                  <xs:element name="AdditionalAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" />
                  <xs:element name="AdditionalReference" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="MAJT" type="Adjustment" minOccurs="1" maxOccurs="unbounded" />
                  <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
                  <xs:element name="ProductADV">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="IndicatorForDocumentLine" type="IndicatorForDocumentLine" minOccurs="0" />
                        <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="0" />
                        <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
                        <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
                        <xs:element name="AdditionalAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" />
                        <xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" />
                        <xs:element name="LAJT" type="Adjustment" minOccurs="1" maxOccurs="unbounded" />
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
              <xs:annotation>
                <xs:documentation xml:lang="de">Abschluss der Zahlungsavise (REMADV)</xs:documentation>
                <xs:documentation xml:lang="en">Footer of the remittance advise (REMADV)  </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:complexContent>
                  <xs:extension base="DocumentFoot">
                    <xs:sequence>
                      <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
                      <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="3" />
                    </xs:sequence>
                  </xs:extension>
                </xs:complexContent>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
XML Einrichten Version 1.2


REMADV Element
XML Einrichten Version 1.2 > RemadvMessage Element : REMADV Element
Namespace (none)
Diagram
FOOT Element MessageADV Element HEAD Element Sequence REMADV Element
Overview
REMADV 1..∞
Sequence
HEAD Extension of DocumentHead Complex Type
Head of the remittance advise (REMADV)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
PaymentType optional PaymentType Simple Type
PaymentWay optional PaymentWay Simple Type
PaymentDate optional PaymentDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AccountingPeriodStartDate optional AccountingPeriodDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AccountingPeriodEndDate optional AccountingPeriodDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
FinancialInformation optional FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
Currency optional Currency Simple Type
ExchangeRate optional ExchangeRate Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
MessageADV 1..∞
Sequence
DocumentType DocumentType Simple Type
PreviousDocumentNumber DocumentNumber Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
MAJT 1..∞ Adjustment Complex Type
Sequence
CorrectionReason optional CorrectionReason Simple Type
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
CorrectionVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
ProductADV
Sequence
IndicatorForDocumentLine optional IndicatorForDocumentLine Simple Type
LineItemNumber optional LineItemNumber Simple Type
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LAJT 1..∞ Adjustment Complex Type
Sequence
CorrectionReason optional CorrectionReason Simple Type
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
CorrectionVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
FOOT Extension of DocumentFoot Complex Type
Footer of the remittance advise (REMADV)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
VatTotal 0..3 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="REMADV" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="HEAD" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Kopfteil der Zahlungsavise (REMADV)  </xs:documentation>
          <xs:documentation xml:lang="en">Head of the remittance advise (REMADV) </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentHead">
              <xs:sequence>
                <xs:element name="PaymentType" type="PaymentType" minOccurs="0" />
                <xs:element name="PaymentWay" type="PaymentWay" minOccurs="0" />
                <xs:element name="PaymentDate" type="PaymentDate" minOccurs="0" />
                <xs:element name="AccountingPeriodStartDate" type="AccountingPeriodDate" minOccurs="0" />
                <xs:element name="AccountingPeriodEndDate" type="AccountingPeriodDate" minOccurs="0" />
                <xs:element name="FinancialInformation" type="FII" minOccurs="0" />
                <xs:element name="Currency" type="Currency" minOccurs="0" />
                <xs:element name="ExchangeRate" type="ExchangeRate" minOccurs="0" />
                <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="MessageADV" minOccurs="1" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DocumentType" type="DocumentType" />
            <xs:element name="PreviousDocumentNumber" type="DocumentNumber" />
            <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
            <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
            <xs:element name="AdditionalAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" />
            <xs:element name="AdditionalReference" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="MAJT" type="Adjustment" minOccurs="1" maxOccurs="unbounded" />
            <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
            <xs:element name="ProductADV">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="IndicatorForDocumentLine" type="IndicatorForDocumentLine" minOccurs="0" />
                  <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="0" />
                  <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
                  <xs:element name="AdditionalAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" />
                  <xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" />
                  <xs:element name="LAJT" type="Adjustment" minOccurs="1" maxOccurs="unbounded" />
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FOOT" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="de">Abschluss der Zahlungsavise (REMADV)</xs:documentation>
          <xs:documentation xml:lang="en">Footer of the remittance advise (REMADV)  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:complexContent>
            <xs:extension base="DocumentFoot">
              <xs:sequence>
                <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
                <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="3" />
              </xs:sequence>
            </xs:extension>
          </xs:complexContent>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
RemadvMessage Element | XML Einrichten Version 1.2


FOOT Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element : FOOT Element
Description
Footer of the remittance advise (REMADV)
Namespace (none)
Type
Extension of DocumentFoot Complex Type
Diagram
Currency Element Value Element Sequence DiscountsConditionsTotal Element Currency Element Value Element Sequence NetItemAmount Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence VatTotal Element Qualifier Element Currency Element Value Element Sequence AdditionalAmounts Element SendingDate Element Sequence FOOT Element
Overview
FOOT Extension of DocumentFoot Complex Type
Footer of the remittance advise (REMADV)
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
VatTotal 0..3 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="FOOT" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Abschluss der Zahlungsavise (REMADV)</xs:documentation>
    <xs:documentation xml:lang="en">Footer of the remittance advise (REMADV)  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentFoot">
        <xs:sequence>
          <xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" />
          <xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="3" />
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


AdditionalAmounts Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > FOOT Element : AdditionalAmounts Element
Namespace (none)
Type
TotalAmountQualified Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence AdditionalAmounts Element
Overview
AdditionalAmounts 0..∞ TotalAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
Source
<xs:element name="AdditionalAmounts" type="TotalAmountQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FOOT Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


SendingDate Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > FOOT Element : SendingDate Element
Description
Sending date of this message
Namespace (none)
Type
EDIDate Complex Type
Diagram
SendingDate Element
Overview
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="SendingDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Versanddatum der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Sending date of this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FOOT Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


VatTotal Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > FOOT Element : VatTotal Element
Namespace (none)
Type
VatTotal Complex Type
Diagram
Currency Element Value Element Sequence DiscountsConditionsTotal Element Currency Element Value Element Sequence NetItemAmount Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence VatTotal Element
Overview
VatTotal 0..3 VatTotal Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="VatTotal" type="VatTotal" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
FOOT Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


HEAD Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element : HEAD Element
Description
Head of the remittance advise (REMADV)
Namespace (none)
Type
Extension of DocumentHead Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element ExchangeRate Element Currency Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence FinancialInformation Element AccountingPeriodEndDate Element AccountingPeriodStartDate Element PaymentDate Element PaymentWay Element PaymentType Element TechnicalReceiverCopy Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element AdditionalDate Element TechnicalSender Element TechnicalReceiver Element DocumentDate Element DocumentNumber Element DocumentFunctionSymbol Element DocumentType Element WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element Sequence HEAD Element
Overview
HEAD Extension of DocumentHead Complex Type
Head of the remittance advise (REMADV)
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
PaymentType optional PaymentType Simple Type
PaymentWay optional PaymentWay Simple Type
PaymentDate optional PaymentDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AccountingPeriodStartDate optional AccountingPeriodDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
AccountingPeriodEndDate optional AccountingPeriodDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
FinancialInformation optional FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
Currency optional Currency Simple Type
ExchangeRate optional ExchangeRate Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="HEAD" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kopfteil der Zahlungsavise (REMADV)  </xs:documentation>
    <xs:documentation xml:lang="en">Head of the remittance advise (REMADV) </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:complexContent>
      <xs:extension base="DocumentHead">
        <xs:sequence>
          <xs:element name="PaymentType" type="PaymentType" minOccurs="0" />
          <xs:element name="PaymentWay" type="PaymentWay" minOccurs="0" />
          <xs:element name="PaymentDate" type="PaymentDate" minOccurs="0" />
          <xs:element name="AccountingPeriodStartDate" type="AccountingPeriodDate" minOccurs="0" />
          <xs:element name="AccountingPeriodEndDate" type="AccountingPeriodDate" minOccurs="0" />
          <xs:element name="FinancialInformation" type="FII" minOccurs="0" />
          <xs:element name="Currency" type="Currency" minOccurs="0" />
          <xs:element name="ExchangeRate" type="ExchangeRate" minOccurs="0" />
          <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
See Also
REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


AccountingPeriodEndDate Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : AccountingPeriodEndDate Element
Namespace (none)
Type
AccountingPeriodDate Complex Type
Diagram
AccountingPeriodEndDate Element
Overview
AccountingPeriodEndDate optional AccountingPeriodDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AccountingPeriodEndDate" type="AccountingPeriodDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


AccountingPeriodStartDate Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : AccountingPeriodStartDate Element
Namespace (none)
Type
AccountingPeriodDate Complex Type
Diagram
AccountingPeriodStartDate Element
Overview
AccountingPeriodStartDate optional AccountingPeriodDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AccountingPeriodStartDate" type="AccountingPeriodDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


AdditionalReference Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : AdditionalReference Element
Namespace (none)
Type
DocumentReferenceQualified Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence AdditionalReference Element
Overview
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalReference" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency optional Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


DocumentDate Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : DocumentDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocumentDate Element
Overview
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocumentDate" type="EDIDate" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


DocumentFunctionSymbol Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : DocumentFunctionSymbol Element
Namespace (none)
Type
DocumentFunctionSymbol Simple Type
Diagram
DocumentFunctionSymbol Element
Overview
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
Source
<xs:element name="DocumentFunctionSymbol" type="DocumentFunctionSymbol" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


DocumentNumber Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : DocumentNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocumentNumber Element
Overview
DocumentNumber DocumentNumber Simple Type
Source
<xs:element name="DocumentNumber" type="DocumentNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


DocumentType Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : DocumentType Element
Namespace (none)
Type
DocumentType Simple Type
Diagram
DocumentType Element
Overview
DocumentType DocumentType Simple Type
Source
<xs:element name="DocumentType" type="DocumentType" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


ExchangeRate Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : ExchangeRate Element
Namespace (none)
Type
ExchangeRate Simple Type
Diagram
ExchangeRate Element
Overview
ExchangeRate optional ExchangeRate Simple Type
Source
<xs:element name="ExchangeRate" type="ExchangeRate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


FinancialInformation Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : FinancialInformation Element
Namespace (none)
Type
FII Complex Type
Diagram
IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence FinancialInformation Element
Overview
FinancialInformation optional FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
Source
<xs:element name="FinancialInformation" type="FII" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


NAD Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : NAD Element
Namespace (none)
Type
NAD Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element
Overview
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


PaymentDate Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : PaymentDate Element
Namespace (none)
Type
PaymentDate Complex Type
Diagram
PaymentDate Element
Overview
PaymentDate optional PaymentDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="PaymentDate" type="PaymentDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


PaymentType Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : PaymentType Element
Namespace (none)
Type
PaymentType Simple Type
Diagram
PaymentType Element
Overview
PaymentType optional PaymentType Simple Type
Source
<xs:element name="PaymentType" type="PaymentType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


PaymentWay Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : PaymentWay Element
Namespace (none)
Type
PaymentWay Simple Type
Diagram
PaymentWay Element
Overview
PaymentWay optional PaymentWay Simple Type
Source
<xs:element name="PaymentWay" type="PaymentWay" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


TechnicalReceiver Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : TechnicalReceiver Element
Description
technical, physical recipient of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiver Element
Overview
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
Source
<xs:element name="TechnicalReceiver" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Empfänger der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical recipient of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


TechnicalReceiverCopy Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : TechnicalReceiverCopy Element
Description
Physical receiver for a copy from this message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiverCopy Element
Overview
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Source
<xs:element name="TechnicalReceiverCopy" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Physischer Empfänger einer Kopie dieser Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Physical receiver for a copy from this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


TechnicalSender Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : TechnicalSender Element
Description
technical, physical sender of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalSender Element
Overview
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
Source
<xs:element name="TechnicalSender" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Versender der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical sender of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


VersionNumber Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > HEAD Element : VersionNumber Element
Namespace (none)
Type
MessageVersion Complex Type
Diagram
WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element
Overview
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
Source
<xs:element name="VersionNumber" type="MessageVersion" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
HEAD Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


MessageADV Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element : MessageADV Element
Namespace (none)
Diagram
ProductADV Element FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element VatBase Element VatPercentage Element VatValue Element Sequence CorrectionVat Element Qualifier Element Currency Element Value Element Sequence AdditionalAmount Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element CorrectionReason Element Sequence MAJT Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element AdditionalDate Element Qualifier Element Currency Element Value Element Sequence AdditionalAmount Element Currency Element Value Element Sequence NetLineAmount Element Currency Element Value Element Sequence GrossLineAmount Element PreviousDocumentNumber Element DocumentType Element Sequence MessageADV Element
Overview
MessageADV 1..∞
Sequence
DocumentType DocumentType Simple Type
PreviousDocumentNumber DocumentNumber Simple Type
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
MAJT 1..∞ Adjustment Complex Type
Sequence
CorrectionReason optional CorrectionReason Simple Type
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
CorrectionVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
ProductADV
Sequence
IndicatorForDocumentLine optional IndicatorForDocumentLine Simple Type
LineItemNumber optional LineItemNumber Simple Type
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LAJT 1..∞ Adjustment Complex Type
Sequence
CorrectionReason optional CorrectionReason Simple Type
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
CorrectionVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="MessageADV" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DocumentType" type="DocumentType" />
      <xs:element name="PreviousDocumentNumber" type="DocumentNumber" />
      <xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" />
      <xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" />
      <xs:element name="AdditionalAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" />
      <xs:element name="AdditionalReference" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="MAJT" type="Adjustment" minOccurs="1" maxOccurs="unbounded" />
      <xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" />
      <xs:element name="ProductADV">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="IndicatorForDocumentLine" type="IndicatorForDocumentLine" minOccurs="0" />
            <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="0" />
            <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
            <xs:element name="AdditionalAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" />
            <xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" />
            <xs:element name="LAJT" type="Adjustment" minOccurs="1" maxOccurs="unbounded" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


AdditionalAmount Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element : AdditionalAmount Element
Namespace (none)
Type
LineAmountQualified Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence AdditionalAmount Element
Overview
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
Source
<xs:element name="AdditionalAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


AdditionalReference Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element : AdditionalReference Element
Namespace (none)
Type
DocumentLineReferenceQualified Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element
Overview
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="AdditionalReference" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


DocumentType Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element : DocumentType Element
Namespace (none)
Type
DocumentType Simple Type
Diagram
DocumentType Element
Overview
DocumentType DocumentType Simple Type
Source
<xs:element name="DocumentType" type="DocumentType" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


GrossLineAmount Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element : GrossLineAmount Element
Namespace (none)
Type
GrossLineAmount Complex Type
Diagram
Currency Element Value Element Sequence GrossLineAmount Element
Overview
GrossLineAmount optional GrossLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="GrossLineAmount" type="GrossLineAmount" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


MAJT Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element : MAJT Element
Namespace (none)
Type
Adjustment Complex Type
Diagram
Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence CorrectionVat Element Qualifier Element Currency Element Value Element Sequence AdditionalAmount Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element CorrectionReason Element Sequence MAJT Element
Overview
MAJT 1..∞ Adjustment Complex Type
Sequence
CorrectionReason optional CorrectionReason Simple Type
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
CorrectionVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="MAJT" type="Adjustment" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


NAD Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element : NAD Element
Namespace (none)
Type
NAD Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element
Overview
NAD 1..∞ NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="NAD" type="NAD" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


NetLineAmount Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element : NetLineAmount Element
Namespace (none)
Type
NetLineAmount Complex Type
Diagram
Currency Element Value Element Sequence NetLineAmount Element
Overview
NetLineAmount optional NetLineAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="NetLineAmount" type="NetLineAmount" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


PreviousDocumentNumber Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element : PreviousDocumentNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
PreviousDocumentNumber Element
Overview
PreviousDocumentNumber DocumentNumber Simple Type
Source
<xs:element name="PreviousDocumentNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


ProductADV Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element : ProductADV Element
Namespace (none)
Diagram
VatBase Element VatPercentage Element VatValue Element Sequence CorrectionVat Element Qualifier Element Currency Element Value Element Sequence AdditionalAmount Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element CorrectionReason Element Sequence LAJT Element AdditionalDate Element Qualifier Element Currency Element Value Element Sequence AdditionalAmount Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element LineItemNumber Element IndicatorForDocumentLine Element Sequence ProductADV Element
Overview
ProductADV
Sequence
IndicatorForDocumentLine optional IndicatorForDocumentLine Simple Type
LineItemNumber optional LineItemNumber Simple Type
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
LAJT 1..∞ Adjustment Complex Type
Sequence
CorrectionReason optional CorrectionReason Simple Type
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
CorrectionVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="ProductADV" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="IndicatorForDocumentLine" type="IndicatorForDocumentLine" minOccurs="0" />
      <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="0" />
      <xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" />
      <xs:element name="AdditionalAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" />
      <xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" />
      <xs:element name="LAJT" type="Adjustment" minOccurs="1" maxOccurs="unbounded" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


AdditionalAmount Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element > ProductADV Element : AdditionalAmount Element
Namespace (none)
Type
LineAmountQualified Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence AdditionalAmount Element
Overview
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
Source
<xs:element name="AdditionalAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductADV Element | MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element > ProductADV Element : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductADV Element | MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


IndicatorForDocumentLine Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element > ProductADV Element : IndicatorForDocumentLine Element
Namespace (none)
Type
IndicatorForDocumentLine Simple Type
Diagram
IndicatorForDocumentLine Element
Overview
IndicatorForDocumentLine optional IndicatorForDocumentLine Simple Type
Source
<xs:element name="IndicatorForDocumentLine" type="IndicatorForDocumentLine" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductADV Element | MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


LAJT Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element > ProductADV Element : LAJT Element
Namespace (none)
Type
Adjustment Complex Type
Diagram
Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence CorrectionVat Element Qualifier Element Currency Element Value Element Sequence AdditionalAmount Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element CorrectionReason Element Sequence LAJT Element
Overview
LAJT 1..∞ Adjustment Complex Type
Sequence
CorrectionReason optional CorrectionReason Simple Type
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
CorrectionVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="LAJT" type="Adjustment" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductADV Element | MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


LineItemNumber Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element > ProductADV Element : LineItemNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
LineItemNumber Element
Overview
LineItemNumber optional LineItemNumber Simple Type
Source
<xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductADV Element | MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


ProductID Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element > ProductADV Element : ProductID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductID Element
Overview
ProductID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="ProductID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductADV Element | MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


SeriesID Element
XML Einrichten Version 1.2 > RemadvMessage Element > REMADV Element > MessageADV Element > ProductADV Element : SeriesID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence SeriesID Element
Overview
SeriesID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="SeriesID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ProductADV Element | MessageADV Element | REMADV Element | RemadvMessage Element | XML Einrichten Version 1.2


AccountingPeriodDate Complex Type
XML Einrichten Version 1.2 : AccountingPeriodDate Complex Type
Description
Start or end date of the accounting period
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
AccountingPeriodDate Complex Type
Overview
AccountingPeriodDate Restriction of EDIDate Complex Type
Start or end date of the accounting period
FormatCode optional EDIDateFormatCode Simple Type
Used By
AccountingPeriodStartDate Element
AccountingPeriodEndDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="AccountingPeriodDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Start oder Endedatum des Abrechungszeitraums </xs:documentation>
    <xs:documentation xml:lang="en">Start or end date of the accounting period </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


ActualDeliveryDate Complex Type
XML Einrichten Version 1.2 : ActualDeliveryDate Complex Type
Description
Actual delivery date
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
ActualDeliveryDate Complex Type
Overview
ActualDeliveryDate Restriction of EDIDate Complex Type
Actual delivery date
FormatCode optional EDIDateFormatCode Simple Type
Used By
ActuallyDeliveryDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="ActualDeliveryDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Tatsächliches Lieferdatum </xs:documentation>
    <xs:documentation xml:lang="en">Actual delivery date </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


AdditionalLineReferences Complex Type
XML Einrichten Version 1.2 : AdditionalLineReferences Complex Type
Description
Enter subsequent additional information related to a position
Namespace (none)
Diagram
AdditionalDate Element AdditionalQuantity Element Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element Qualifier Element PriceQuantity Element Currency Element Value Element Sequence AdditionalPrice Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element Sequence AdditionalLineReferences Complex Type
Overview
AdditionalLineReferences
Enter subsequent additional information related to a position
Sequence
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Used By
AdditionalLineReferences Element
AdditionalLineReferences Element
AdditionalLineReferences Element
AdditionalLineReferences Element
AdditionalLineReferences Element
Source
<xs:complexType name="AdditionalLineReferences" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Geben Sie hier über den Standard hinausgehende Informationen zur Position ein </xs:documentation>
    <xs:documentation xml:lang="en">Enter subsequent additional information related to a position </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="AdditionalLineRef" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="unbounded" />
    <xs:element name="AdditionalPrice" type="PriceQualified" minOccurs="0" maxOccurs="unbounded" />
    <xs:element name="AdditionalLineAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" />
    <xs:element name="AdditionalQuantity" type="QuantityQualified" minOccurs="0" maxOccurs="unbounded" />
    <xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > AdditionalLineReferences Complex Type : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AdditionalLineReferences Complex Type | XML Einrichten Version 1.2


AdditionalLineAmount Element
XML Einrichten Version 1.2 > AdditionalLineReferences Complex Type : AdditionalLineAmount Element
Namespace (none)
Type
LineAmountQualified Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence AdditionalLineAmount Element
Overview
AdditionalLineAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
Source
<xs:element name="AdditionalLineAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AdditionalLineReferences Complex Type | XML Einrichten Version 1.2


AdditionalLineRef Element
XML Einrichten Version 1.2 > AdditionalLineReferences Complex Type : AdditionalLineRef Element
Namespace (none)
Type
DocumentLineReferenceQualified Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalLineRef Element
Overview
AdditionalLineRef 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="AdditionalLineRef" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AdditionalLineReferences Complex Type | XML Einrichten Version 1.2


AdditionalPrice Element
XML Einrichten Version 1.2 > AdditionalLineReferences Complex Type : AdditionalPrice Element
Namespace (none)
Type
PriceQualified Complex Type
Diagram
Qualifier Element PriceQuantity Element Currency Element Value Element Sequence AdditionalPrice Element
Overview
AdditionalPrice 0..∞ PriceQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
Source
<xs:element name="AdditionalPrice" type="PriceQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AdditionalLineReferences Complex Type | XML Einrichten Version 1.2


AdditionalQuantity Element
XML Einrichten Version 1.2 > AdditionalLineReferences Complex Type : AdditionalQuantity Element
Namespace (none)
Type
QuantityQualified Complex Type
Diagram
AdditionalQuantity Element
Overview
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
Source
<xs:element name="AdditionalQuantity" type="QuantityQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
AdditionalLineReferences Complex Type | XML Einrichten Version 1.2


Adjustment Complex Type
XML Einrichten Version 1.2 : Adjustment Complex Type
Description
Berichtigung Correction
Namespace (none)
Diagram
Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence CorrectionVat Element Qualifier Element Currency Element Value Element Sequence AdditionalAmount Element DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element CorrectionReason Element Sequence Adjustment Complex Type
Overview
Adjustment
Berichtigung Correction
Sequence
CorrectionReason optional CorrectionReason Simple Type
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
CorrectionVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
Used By
MAJT Element
LAJT Element
Source
<xs:complexType name="Adjustment" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>
      <xs:documentation xml:lang="de">Berichtigung </xs:documentation>
      <xs:documentation xml:lang="en">Correction </xs:documentation>
    </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="CorrectionReason" type="CorrectionReason" minOccurs="0" />
    <xs:element name="AdditionalReference" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="unbounded" />
    <xs:element name="AdditionalAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" />
    <xs:element name="CorrectionVat" type="Vat" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


AdditionalAmount Element
XML Einrichten Version 1.2 > Adjustment Complex Type : AdditionalAmount Element
Namespace (none)
Type
LineAmountQualified Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence AdditionalAmount Element
Overview
AdditionalAmount 0..∞ LineAmountQualified Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
Source
<xs:element name="AdditionalAmount" type="LineAmountQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Adjustment Complex Type | XML Einrichten Version 1.2


AdditionalReference Element
XML Einrichten Version 1.2 > Adjustment Complex Type : AdditionalReference Element
Namespace (none)
Type
DocumentLineReferenceQualified Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element
Overview
AdditionalReference 0..∞ DocumentLineReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="AdditionalReference" type="DocumentLineReferenceQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Adjustment Complex Type | XML Einrichten Version 1.2


CorrectionReason Element
XML Einrichten Version 1.2 > Adjustment Complex Type : CorrectionReason Element
Namespace (none)
Type
CorrectionReason Simple Type
Diagram
CorrectionReason Element
Overview
CorrectionReason optional CorrectionReason Simple Type
Source
<xs:element name="CorrectionReason" type="CorrectionReason" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Adjustment Complex Type | XML Einrichten Version 1.2


CorrectionVat Element
XML Einrichten Version 1.2 > Adjustment Complex Type : CorrectionVat Element
Namespace (none)
Type
Vat Complex Type
Diagram
Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence CorrectionVat Element
Overview
CorrectionVat optional Vat Complex Type
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="CorrectionVat" type="Vat" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Adjustment Complex Type | XML Einrichten Version 1.2


AdvisedDeliveryDate Complex Type
XML Einrichten Version 1.2 : AdvisedDeliveryDate Complex Type
Description
Advised Delivery date/time
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
AdvisedDeliveryDate Complex Type
Overview
AdvisedDeliveryDate Restriction of EDIDate Complex Type
Advised Delivery date/time
FormatCode optional EDIDateFormatCode Simple Type
Used By
AdvisedDeliveryDate Element
AdvisedDeliveryDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="AdvisedDeliveryDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Avisiertes Lieferdatum / Uhrzeit </xs:documentation>
    <xs:documentation xml:lang="en">Advised Delivery date/time </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


BorderCrossing Complex Type
XML Einrichten Version 1.2 : BorderCrossing Complex Type
Description
Border Crossing Number
Namespace (none)
Base Type
Extension of DocumentReference Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence BorderCrossing Complex Type
Overview
BorderCrossing Extension of DocumentReference Complex Type
Border Crossing Number
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Used By
BorderCrossingRef Element
Source
<xs:complexType name="BorderCrossing" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Nummer des Grezübergangs</xs:documentation>
    <xs:documentation xml:lang="en"> Border Crossing Number </xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


BordercrossingDate Complex Type
XML Einrichten Version 1.2 : BordercrossingDate Complex Type
Description
Date of Border Crossing
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
BordercrossingDate Complex Type
Overview
BordercrossingDate Restriction of EDIDate Complex Type
Date of Border Crossing
FormatCode optional EDIDateFormatCode Simple Type
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="BordercrossingDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Datum des Grezübergangs</xs:documentation>
    <xs:documentation xml:lang="en"> Date of Border Crossing </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


CashDiscount Complex Type
XML Einrichten Version 1.2 : CashDiscount Complex Type
Description
Cash Discount defined by Date percentage and/or amount
Namespace (none)
Diagram
Currency Element Value Element Sequence CashDiscountAmount Element CashDiscountPercentage Element CashDiscountDate Element Sequence CashDiscount Complex Type
Overview
CashDiscount
Cash Discount defined by Date percentage and/or amount
Sequence
CashDiscountDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
CashDiscountPercentage optional xs:decimal
CashDiscountAmount optional TotalAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Used By
CashDiscount Element
Source
<xs:complexType name="CashDiscount" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Preisnachlass festgelegt über Datum , Prozensatz und/oder Betrag</xs:documentation>
    <xs:documentation xml:lang="en">Cash Discount defined by Date percentage and/or amount </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="CashDiscountDate" type="EDIDate" minOccurs="1" />
    <xs:element name="CashDiscountPercentage" type="xs:decimal" minOccurs="0" />
    <xs:element name="CashDiscountAmount" type="TotalAmount" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


CashDiscountAmount Element
XML Einrichten Version 1.2 > CashDiscount Complex Type : CashDiscountAmount Element
Namespace (none)
Type
TotalAmount Complex Type
Diagram
Currency Element Value Element Sequence CashDiscountAmount Element
Overview
CashDiscountAmount optional TotalAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="CashDiscountAmount" type="TotalAmount" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CashDiscount Complex Type | XML Einrichten Version 1.2


CashDiscountDate Element
XML Einrichten Version 1.2 > CashDiscount Complex Type : CashDiscountDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
CashDiscountDate Element
Overview
CashDiscountDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="CashDiscountDate" type="EDIDate" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CashDiscount Complex Type | XML Einrichten Version 1.2


CashDiscountPercentage Element
XML Einrichten Version 1.2 > CashDiscount Complex Type : CashDiscountPercentage Element
Namespace (none)
Type
xs:decimal
Diagram
CashDiscountPercentage Element
Overview
CashDiscountPercentage optional xs:decimal
Source
<xs:element name="CashDiscountPercentage" type="xs:decimal" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CashDiscount Complex Type | XML Einrichten Version 1.2


ClassOfGoods Complex Type
XML Einrichten Version 1.2 : ClassOfGoods Complex Type
Description
Categorization of a product by categorization schema type, feature and option
Namespace (none)
Diagram
ClassOfGoodsValue Element ClassOfGoodsFeature Element ClassOfGoodsType Element Sequence ClassOfGoods Complex Type
Overview
ClassOfGoods
Categorization of a product by categorization schema type, feature and option
Sequence
ClassOfGoodsType ClassOfGoodsType Simple Type
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
ClassOfGoodsValue ClassOfGoodsValue Simple Type
Used By
ClassOfGoods Element
ClassOfGoods Element
ClassOfGoods Element
Source
<xs:complexType name="ClassOfGoods" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Katageorisierung für ein Produkt über Klassikationsschema, Merkmal und Merkmalswert</xs:documentation>
    <xs:documentation xml:lang="en">Categorization of a product by categorization schema type, feature and option</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="ClassOfGoodsType" type="ClassOfGoodsType" minOccurs="1" />
    <xs:element name="ClassOfGoodsFeature" type="ClassOfGoodsFeature" minOccurs="0" />
    <xs:element name="ClassOfGoodsValue" type="ClassOfGoodsValue" minOccurs="1" />
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


ClassOfGoodsFeature Element
XML Einrichten Version 1.2 > ClassOfGoods Complex Type : ClassOfGoodsFeature Element
Namespace (none)
Type
ClassOfGoodsFeature Simple Type
Diagram
ClassOfGoodsFeature Element
Overview
ClassOfGoodsFeature optional ClassOfGoodsFeature Simple Type
Source
<xs:element name="ClassOfGoodsFeature" type="ClassOfGoodsFeature" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ClassOfGoods Complex Type | XML Einrichten Version 1.2


ClassOfGoodsType Element
XML Einrichten Version 1.2 > ClassOfGoods Complex Type : ClassOfGoodsType Element
Namespace (none)
Type
ClassOfGoodsType Simple Type
Diagram
ClassOfGoodsType Element
Overview
ClassOfGoodsType ClassOfGoodsType Simple Type
Source
<xs:element name="ClassOfGoodsType" type="ClassOfGoodsType" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ClassOfGoods Complex Type | XML Einrichten Version 1.2


ClassOfGoodsValue Element
XML Einrichten Version 1.2 > ClassOfGoods Complex Type : ClassOfGoodsValue Element
Namespace (none)
Type
ClassOfGoodsValue Simple Type
Diagram
ClassOfGoodsValue Element
Overview
ClassOfGoodsValue ClassOfGoodsValue Simple Type
Source
<xs:element name="ClassOfGoodsValue" type="ClassOfGoodsValue" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ClassOfGoods Complex Type | XML Einrichten Version 1.2


CNDF Complex Type
XML Einrichten Version 1.2 : CNDF Complex Type
Description
Segment for conditions for the complete document
Namespace (none)
Diagram
VatPercentageOfCondition Element AmountOfCondition Element PercentageRateOfCondition Element DscOfConditionType Element TypeOfCondition Element ConditionLevel Element ConditionIndicator Element Sequence CNDF Complex Type
Overview
CNDF
Segment for conditions for the complete document
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:decimal
TypeOfCondition Restriction of xs:string
Type of conditiont
DI = Rebate
FC = Freight Cost
IN = Insurance
PC = Handling costs
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Used By
CNDF Element
CNDF Element
Source
<xs:complexType name="CNDF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Segment für Konditionen zu einem Beleg </xs:documentation>
    <xs:documentation xml:lang="en">Segment for conditions for the complete document </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="ConditionIndicator" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Konditionskennzeichen</dt>
            <dt>A = Abschlag</dt>
            <dt>C = ZUschlag</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>Condition Indicator</dt>
            <dt>A = Allowence</dt>
            <dt>C = Charge</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ConditionLevel">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Konditionsstufe</dt>
            <dt>Reihenfolge in der die Konditionen angewendet werden</dt>
            <dt>1 = Anwendung auf den Basisbetrag</dt>
            <dt>2 = Awendung auf den durch 1 veränderten Basisbetrag</dt>
            <dt>3 = Awendung auf den durch 2 veränderten Betrag</dt>
            <dt>etc.</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Condition levele</dt>
            <dt>Sequence of calculation</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:totalDigits value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="TypeOfCondition">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Konditionsart</dt>
            <dt>DI = Rabattt</dt>
            <dt>FC = Frachtkosten</dt>
            <dt>IN = Versicherung</dt>
            <dt>PC = Verpacken, Handlingskosten</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>Type of conditiont</dt>
            <dt>DI = Rebate</dt>
            <dt>FC = Freight Cost</dt>
            <dt>IN = Insurance</dt>
            <dt>PC = Handling costs</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="DscOfConditionType" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Textliche Beschreibun der Kondition </xs:documentation>
        <xs:documentation xml:lang="en">Description of the condition </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="PercentageRateOfCondition" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Prozentsatz der Kondition </xs:documentation>
        <xs:documentation xml:lang="en">Percentage value of the condition </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:totalDigits value="10" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="AmountOfCondition" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Betrag der Kondition </xs:documentation>
        <xs:documentation xml:lang="en">Amount value of the condition </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:totalDigits value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="VatPercentageOfCondition" type="VatPercentage" minOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Steuersatz der Kondition  </xs:documentation>
        <xs:documentation xml:lang="en">Vat of the condition </xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


AmountOfCondition Element
XML Einrichten Version 1.2 > CNDF Complex Type : AmountOfCondition Element
Description
Amount value of the condition
Namespace (none)
Type
Restriction of xs:decimal
Diagram
AmountOfCondition Element
Overview
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
Source
<xs:element name="AmountOfCondition" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Betrag der Kondition </xs:documentation>
    <xs:documentation xml:lang="en">Amount value of the condition </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:decimal">
      <xs:totalDigits value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CNDF Complex Type | XML Einrichten Version 1.2


ConditionIndicator Element
XML Einrichten Version 1.2 > CNDF Complex Type : ConditionIndicator Element
Description
Condition Indicator
A = Allowence
C = Charge
Namespace (none)
Type
Restriction of xs:string
Diagram
ConditionIndicator Element
Overview
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
Source
<xs:element name="ConditionIndicator" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Konditionskennzeichen</dt>
        <dt>A = Abschlag</dt>
        <dt>C = ZUschlag</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Condition Indicator</dt>
        <dt>A = Allowence</dt>
        <dt>C = Charge</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CNDF Complex Type | XML Einrichten Version 1.2


ConditionLevel Element
XML Einrichten Version 1.2 > CNDF Complex Type : ConditionLevel Element
Namespace (none)
Type
Restriction of xs:decimal
Diagram
ConditionLevel Element
Overview
ConditionLevel Restriction of xs:decimal
Source
<xs:element name="ConditionLevel" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Konditionsstufe</dt>
        <dt>Reihenfolge in der die Konditionen angewendet werden</dt>
        <dt>1 = Anwendung auf den Basisbetrag</dt>
        <dt>2 = Awendung auf den durch 1 veränderten Basisbetrag</dt>
        <dt>3 = Awendung auf den durch 2 veränderten Betrag</dt>
        <dt>etc.</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Condition levele</dt>
        <dt>Sequence of calculation</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:decimal">
      <xs:totalDigits value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CNDF Complex Type | XML Einrichten Version 1.2


DscOfConditionType Element
XML Einrichten Version 1.2 > CNDF Complex Type : DscOfConditionType Element
Description
Description of the condition
Namespace (none)
Type
Restriction of xs:string
Diagram
DscOfConditionType Element
Overview
DscOfConditionType optional Restriction of xs:string
Description of the condition
Source
<xs:element name="DscOfConditionType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Textliche Beschreibun der Kondition </xs:documentation>
    <xs:documentation xml:lang="en">Description of the condition </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CNDF Complex Type | XML Einrichten Version 1.2


PercentageRateOfCondition Element
XML Einrichten Version 1.2 > CNDF Complex Type : PercentageRateOfCondition Element
Description
Percentage value of the condition
Namespace (none)
Type
Restriction of xs:decimal
Diagram
PercentageRateOfCondition Element
Overview
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
Source
<xs:element name="PercentageRateOfCondition" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Prozentsatz der Kondition </xs:documentation>
    <xs:documentation xml:lang="en">Percentage value of the condition </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:decimal">
      <xs:totalDigits value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CNDF Complex Type | XML Einrichten Version 1.2


TypeOfCondition Element
XML Einrichten Version 1.2 > CNDF Complex Type : TypeOfCondition Element
Description
Type of conditiont
DI = Rebate
FC = Freight Cost
IN = Insurance
PC = Handling costs
Namespace (none)
Type
Restriction of xs:string
Diagram
TypeOfCondition Element
Overview
TypeOfCondition Restriction of xs:string
Type of conditiont
DI = Rebate
FC = Freight Cost
IN = Insurance
PC = Handling costs
Source
<xs:element name="TypeOfCondition" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Konditionsart</dt>
        <dt>DI = Rabattt</dt>
        <dt>FC = Frachtkosten</dt>
        <dt>IN = Versicherung</dt>
        <dt>PC = Verpacken, Handlingskosten</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Type of conditiont</dt>
        <dt>DI = Rebate</dt>
        <dt>FC = Freight Cost</dt>
        <dt>IN = Insurance</dt>
        <dt>PC = Handling costs</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CNDF Complex Type | XML Einrichten Version 1.2


VatPercentageOfCondition Element
XML Einrichten Version 1.2 > CNDF Complex Type : VatPercentageOfCondition Element
Description
Vat of the condition
Namespace (none)
Type
VatPercentage Simple Type
Diagram
VatPercentageOfCondition Element
Overview
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Source
<xs:element name="VatPercentageOfCondition" type="VatPercentage" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Steuersatz der Kondition  </xs:documentation>
    <xs:documentation xml:lang="en">Vat of the condition </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CNDF Complex Type | XML Einrichten Version 1.2


CNDL Complex Type
XML Einrichten Version 1.2 : CNDL Complex Type
Description
Segment for conditions for a single position
Namespace (none)
Diagram
VatPercentageOfCondition Element AmountOfCondition Element PercentageRateOfCondition Element DscOfConditionType Element TypeOfCondition Element ConditionLevel Element ConditionIndicator Element Sequence CNDL Complex Type
Overview
CNDL
Segment for conditions for a single position
Sequence
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
ConditionLevel Restriction of xs:string
Condition level
TypeOfCondition Restriction of xs:string
Type of condition
DscOfConditionType optional Restriction of xs:string
Description of the condition
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Used By
CNDL Element
CNDL Element
Source
<xs:complexType name="CNDL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Segment für Konditionen zu einer Position </xs:documentation>
    <xs:documentation xml:lang="en">Segment for conditions for a single position </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="ConditionIndicator" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Konditionskennzeichen</dt>
            <dt>A = Abschlag</dt>
            <dt>C = ZUschlag</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>Condition Indicator</dt>
            <dt>A = Allowence</dt>
            <dt>C = Charge</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ConditionLevel">
      <xs:annotation>
        <xs:documentation xml:lang="de">Konditionsstufe </xs:documentation>
        <xs:documentation xml:lang="en">Condition level </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="TypeOfCondition">
      <xs:annotation>
        <xs:documentation xml:lang="de">Art der Kondition </xs:documentation>
        <xs:documentation xml:lang="en">Type of condition </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="DscOfConditionType" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Textliche Beschreibun der Kondition </xs:documentation>
        <xs:documentation xml:lang="en">Description of the condition </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="PercentageRateOfCondition" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Prozentsatz der Kondition </xs:documentation>
        <xs:documentation xml:lang="en">Percentage value of the condition </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:totalDigits value="10" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="AmountOfCondition" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Betrag der Kondition </xs:documentation>
        <xs:documentation xml:lang="en">Amount value of the condition </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:totalDigits value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="VatPercentageOfCondition" type="VatPercentage" minOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Steuersatz der Kondition  </xs:documentation>
        <xs:documentation xml:lang="en">Vat of the condition </xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


AmountOfCondition Element
XML Einrichten Version 1.2 > CNDL Complex Type : AmountOfCondition Element
Description
Amount value of the condition
Namespace (none)
Type
Restriction of xs:decimal
Diagram
AmountOfCondition Element
Overview
AmountOfCondition optional Restriction of xs:decimal
Amount value of the condition
Source
<xs:element name="AmountOfCondition" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Betrag der Kondition </xs:documentation>
    <xs:documentation xml:lang="en">Amount value of the condition </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:decimal">
      <xs:totalDigits value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CNDL Complex Type | XML Einrichten Version 1.2


ConditionIndicator Element
XML Einrichten Version 1.2 > CNDL Complex Type : ConditionIndicator Element
Description
Condition Indicator
A = Allowence
C = Charge
Namespace (none)
Type
Restriction of xs:string
Diagram
ConditionIndicator Element
Overview
ConditionIndicator optional Restriction of xs:string
Condition Indicator
A = Allowence
C = Charge
Source
<xs:element name="ConditionIndicator" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Konditionskennzeichen</dt>
        <dt>A = Abschlag</dt>
        <dt>C = ZUschlag</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Condition Indicator</dt>
        <dt>A = Allowence</dt>
        <dt>C = Charge</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CNDL Complex Type | XML Einrichten Version 1.2


ConditionLevel Element
XML Einrichten Version 1.2 > CNDL Complex Type : ConditionLevel Element
Description
Condition level
Namespace (none)
Type
Restriction of xs:string
Diagram
ConditionLevel Element
Overview
ConditionLevel Restriction of xs:string
Condition level
Source
<xs:element name="ConditionLevel" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Konditionsstufe </xs:documentation>
    <xs:documentation xml:lang="en">Condition level </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CNDL Complex Type | XML Einrichten Version 1.2


DscOfConditionType Element
XML Einrichten Version 1.2 > CNDL Complex Type : DscOfConditionType Element
Description
Description of the condition
Namespace (none)
Type
Restriction of xs:string
Diagram
DscOfConditionType Element
Overview
DscOfConditionType optional Restriction of xs:string
Description of the condition
Source
<xs:element name="DscOfConditionType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Textliche Beschreibun der Kondition </xs:documentation>
    <xs:documentation xml:lang="en">Description of the condition </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CNDL Complex Type | XML Einrichten Version 1.2


PercentageRateOfCondition Element
XML Einrichten Version 1.2 > CNDL Complex Type : PercentageRateOfCondition Element
Description
Percentage value of the condition
Namespace (none)
Type
Restriction of xs:decimal
Diagram
PercentageRateOfCondition Element
Overview
PercentageRateOfCondition optional Restriction of xs:decimal
Percentage value of the condition
Source
<xs:element name="PercentageRateOfCondition" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Prozentsatz der Kondition </xs:documentation>
    <xs:documentation xml:lang="en">Percentage value of the condition </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:decimal">
      <xs:totalDigits value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CNDL Complex Type | XML Einrichten Version 1.2


TypeOfCondition Element
XML Einrichten Version 1.2 > CNDL Complex Type : TypeOfCondition Element
Description
Type of condition
Namespace (none)
Type
Restriction of xs:string
Diagram
TypeOfCondition Element
Overview
TypeOfCondition Restriction of xs:string
Type of condition
Source
<xs:element name="TypeOfCondition" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Art der Kondition </xs:documentation>
    <xs:documentation xml:lang="en">Type of condition </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CNDL Complex Type | XML Einrichten Version 1.2


VatPercentageOfCondition Element
XML Einrichten Version 1.2 > CNDL Complex Type : VatPercentageOfCondition Element
Description
Vat of the condition
Namespace (none)
Type
VatPercentage Simple Type
Diagram
VatPercentageOfCondition Element
Overview
VatPercentageOfCondition VatPercentage Simple Type
Vat of the condition
Source
<xs:element name="VatPercentageOfCondition" type="VatPercentage" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Steuersatz der Kondition  </xs:documentation>
    <xs:documentation xml:lang="en">Vat of the condition </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CNDL Complex Type | XML Einrichten Version 1.2


CODL Complex Type
XML Einrichten Version 1.2 : CODL Complex Type
Description
Handling instructions for a position
Namespace (none)
Diagram
CommandCode Element CommandGroup Element Sequence CODL Complex Type
Overview
CODL
Handling instructions for a position
Sequence
CommandGroup Restriction of xs:string
Command Group
CommandCode optional Restriction of xs:string
Instruction by the client
002 = Assembly
003 = Connection
004 = Adding the goods by the carrier
Used By
CODL Element
CODL Element
Source
<xs:complexType name="CODL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Handhabungshinweise für eine Position  </xs:documentation>
    <xs:documentation xml:lang="en">Handling instructions for a position</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="CommandGroup">
      <xs:annotation>
        <xs:documentation xml:lang="de">Anweisungs Gruppe </xs:documentation>
        <xs:documentation xml:lang="en">Command Group</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="17" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="CommandCode" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>DE: Anweisungs-Code vom Auftraggeber</dt>
            <dt>002  = Aufbau</dt>
            <dt>003  = Anschluss</dt>
            <dt>004 = Zusteuerung der Ware durch Spediteur</dt>
            <dt></dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>Instruction by the client</dt>
            <dt>002  = Assembly</dt>
            <dt>003  = Connection</dt>
            <dt>004 = Adding the goods by the carrier</dt>
            <dt></dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


CommandCode Element
XML Einrichten Version 1.2 > CODL Complex Type : CommandCode Element
Description
Instruction by the client
002 = Assembly
003 = Connection
004 = Adding the goods by the carrier
Namespace (none)
Type
Restriction of xs:string
Diagram
CommandCode Element
Overview
CommandCode optional Restriction of xs:string
Instruction by the client
002 = Assembly
003 = Connection
004 = Adding the goods by the carrier
Source
<xs:element name="CommandCode" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>DE: Anweisungs-Code vom Auftraggeber</dt>
        <dt>002  = Aufbau</dt>
        <dt>003  = Anschluss</dt>
        <dt>004 = Zusteuerung der Ware durch Spediteur</dt>
        <dt></dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Instruction by the client</dt>
        <dt>002  = Assembly</dt>
        <dt>003  = Connection</dt>
        <dt>004 = Adding the goods by the carrier</dt>
        <dt></dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CODL Complex Type | XML Einrichten Version 1.2


CommandGroup Element
XML Einrichten Version 1.2 > CODL Complex Type : CommandGroup Element
Description
Command Group
Namespace (none)
Type
Restriction of xs:string
Diagram
CommandGroup Element
Overview
CommandGroup Restriction of xs:string
Command Group
Source
<xs:element name="CommandGroup" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Anweisungs Gruppe </xs:documentation>
    <xs:documentation xml:lang="en">Command Group</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="17" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CODL Complex Type | XML Einrichten Version 1.2


ConfirmedDeliveryDate Complex Type
XML Einrichten Version 1.2 : ConfirmedDeliveryDate Complex Type
Description
Confirmed delivery date
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
ConfirmedDeliveryDate Complex Type
Overview
ConfirmedDeliveryDate Restriction of EDIDate Complex Type
Confirmed delivery date
FormatCode optional EDIDateFormatCode Simple Type
Used By
ConfirmedDeliveryDate Element
ConfirmedDeliveryDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="ConfirmedDeliveryDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Bestätigtes Lieferdatum </xs:documentation>
    <xs:documentation xml:lang="en">Confirmed delivery date </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Contact Complex Type
XML Einrichten Version 1.2 : Contact Complex Type
Description
Group for contact information
Namespace (none)
Diagram
CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence Contact Complex Type
Overview
Contact
Group for contact information
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
Used By
ContactPerson Element
Source
<xs:complexType name="Contact" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Segment für Kontaktinormationen</xs:documentation>
    <xs:documentation xml:lang="en">Group for contact information</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="ContactSurName" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Nachname der Kontaktperson</xs:documentation>
        <xs:documentation xml:lang="en">Surname of the contact</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ContactFirstName" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Vorname der Kontaktperson</xs:documentation>
        <xs:documentation xml:lang="en">First name of the contact</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ContactCode" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Kurzzeichen der Kontaktperson</xs:documentation>
        <xs:documentation xml:lang="en">Ident of the contact</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ContactCommunication" type="ContactCommunication" minOccurs="0" maxOccurs="9">
      <xs:annotation>
        <xs:documentation xml:lang="de">Block für die Kommunikationsdaten</xs:documentation>
        <xs:documentation xml:lang="en">Group for the communication data</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


ContactCommunication Complex Type
XML Einrichten Version 1.2 : ContactCommunication Complex Type
Description
Group for communication data of a contact person
Namespace (none)
Diagram
CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Complex Type
Overview
ContactCommunication
Group for communication data of a contact person
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
Used By
ContactCommunication Element
Source
<xs:complexType name="ContactCommunication" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Block für Kommunikationsdaten einer Kontaktperson</xs:documentation>
    <xs:documentation xml:lang="en">Group for communication data of a contact person</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="CommunicationCode" minOccurs="1" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Typ der Kommunikationsadresse</dt>
            <dt>Codeliste:  </dt>
            <dt>EM = eMail</dt>
            <dt>FX = Fax</dt>
            <dt>TE = Telefon</dt>
            <dt>AL = MobilTelefon</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>TCommunication Type</dt>
            <dt>Code list:  </dt>
            <dt>EM = eMail</dt>
            <dt>FX = Fax</dt>
            <dt>TE = Phone</dt>
            <dt>AL = Mobile phone</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
          <xs:enumeration value="AL" />
          <xs:enumeration value="EM" />
          <xs:enumeration value="FX" />
          <xs:enumeration value="TE" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="CommunicationAdress" minOccurs="1" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Kommunikationsadresse zum davor festgelegten Kommunikationstyp </xs:documentation>
        <xs:documentation xml:lang="en">Communication address related to the previous defined communication type </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="512" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


CommunicationAdress Element
XML Einrichten Version 1.2 > ContactCommunication Complex Type : CommunicationAdress Element
Description
Communication address related to the previous defined communication type
Namespace (none)
Type
Restriction of xs:string
Diagram
CommunicationAdress Element
Overview
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
Source
<xs:element name="CommunicationAdress" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kommunikationsadresse zum davor festgelegten Kommunikationstyp </xs:documentation>
    <xs:documentation xml:lang="en">Communication address related to the previous defined communication type </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="512" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ContactCommunication Complex Type | XML Einrichten Version 1.2


CommunicationCode Element
XML Einrichten Version 1.2 > ContactCommunication Complex Type : CommunicationCode Element
Namespace (none)
Type
Restriction of xs:string
Diagram
CommunicationCode Element
Overview
CommunicationCode Restriction of xs:string
Source
<xs:element name="CommunicationCode" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Typ der Kommunikationsadresse</dt>
        <dt>Codeliste:  </dt>
        <dt>EM = eMail</dt>
        <dt>FX = Fax</dt>
        <dt>TE = Telefon</dt>
        <dt>AL = MobilTelefon</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>TCommunication Type</dt>
        <dt>Code list:  </dt>
        <dt>EM = eMail</dt>
        <dt>FX = Fax</dt>
        <dt>TE = Phone</dt>
        <dt>AL = Mobile phone</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
      <xs:enumeration value="AL" />
      <xs:enumeration value="EM" />
      <xs:enumeration value="FX" />
      <xs:enumeration value="TE" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ContactCommunication Complex Type | XML Einrichten Version 1.2


CurrencyValue Complex Type
XML Einrichten Version 1.2 : CurrencyValue Complex Type
Description
Amount defined by decimal value and currency
Namespace (none)
Diagram
Currency Element Value Element Sequence CurrencyValue Complex Type
Overview
CurrencyValue
Amount defined by decimal value and currency
Sequence
Value xs:decimal
Currency Currency Simple Type
Used By
VatValue Element
VatBase Element
VatValue Element
VatBase Element
Source
<xs:complexType name="CurrencyValue" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Betrag, festgelegt über Dezimalwert und Währung</xs:documentation>
    <xs:documentation xml:lang="en">Amount defined by decimal value and currency</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" />
    <xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" />
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > CurrencyValue Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CurrencyValue Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > CurrencyValue Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CurrencyValue Complex Type | XML Einrichten Version 1.2


DELTIMES Complex Type
XML Einrichten Version 1.2 : DELTIMES Complex Type
Description
Segment for delivery times
Namespace (none)
Diagram
DeliveryDateUntil Element OrderDateUntil Element DeliveryTime Element TargetMarket Element FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element Sequence DELTIMES Complex Type
Overview
DELTIMES
Segment for delivery times
Sequence
NAD optional NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
TargetMarket optional WorkflowDestination Simple Type
DeliveryTime optional Duration Complex Type
Unit optional Unit Simple Type
OrderDateUntil optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DeliveryDateUntil optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:complexType name="DELTIMES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Segment für Lieferzeiten </xs:documentation>
    <xs:documentation xml:lang="en">Segment for delivery times </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="NAD" type="NAD" minOccurs="0" maxOccurs="1" />
    <xs:element name="TargetMarket" type="WorkflowDestination" minOccurs="0" maxOccurs="1" />
    <xs:element name="DeliveryTime" type="Duration" minOccurs="0" maxOccurs="1" />
    <xs:element name="OrderDateUntil" type="EDIDate" minOccurs="0" maxOccurs="1" />
    <xs:element name="DeliveryDateUntil" type="EDIDate" minOccurs="0" maxOccurs="1" />
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DeliveryDateUntil Element
XML Einrichten Version 1.2 > DELTIMES Complex Type : DeliveryDateUntil Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DeliveryDateUntil Element
Overview
DeliveryDateUntil optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DeliveryDateUntil" type="EDIDate" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DELTIMES Complex Type | XML Einrichten Version 1.2


DeliveryTime Element
XML Einrichten Version 1.2 > DELTIMES Complex Type : DeliveryTime Element
Namespace (none)
Type
Duration Complex Type
Diagram
DeliveryTime Element
Overview
DeliveryTime optional Duration Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="DeliveryTime" type="Duration" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DELTIMES Complex Type | XML Einrichten Version 1.2


NAD Element
XML Einrichten Version 1.2 > DELTIMES Complex Type : NAD Element
Namespace (none)
Type
NAD Complex Type
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Element
Overview
NAD optional NAD Complex Type
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="NAD" type="NAD" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DELTIMES Complex Type | XML Einrichten Version 1.2


OrderDateUntil Element
XML Einrichten Version 1.2 > DELTIMES Complex Type : OrderDateUntil Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
OrderDateUntil Element
Overview
OrderDateUntil optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OrderDateUntil" type="EDIDate" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DELTIMES Complex Type | XML Einrichten Version 1.2


TargetMarket Element
XML Einrichten Version 1.2 > DELTIMES Complex Type : TargetMarket Element
Namespace (none)
Type
WorkflowDestination Simple Type
Diagram
TargetMarket Element
Overview
TargetMarket optional WorkflowDestination Simple Type
Source
<xs:element name="TargetMarket" type="WorkflowDestination" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DELTIMES Complex Type | XML Einrichten Version 1.2


DespatchAdviceDate Complex Type
XML Einrichten Version 1.2 : DespatchAdviceDate Complex Type
Description
Date of the delivery note
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
DespatchAdviceDate Complex Type
Overview
DespatchAdviceDate Restriction of EDIDate Complex Type
Date of the delivery note
FormatCode optional EDIDateFormatCode Simple Type
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="DespatchAdviceDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Datum des Lieferscheins</xs:documentation>
    <xs:documentation xml:lang="en">Date of the delivery note</xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DespatchAdviceLine Complex Type
XML Einrichten Version 1.2 : DespatchAdviceLine Complex Type
Description
Position within the delivery note
Namespace (none)
Base Type
Extension of DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence DespatchAdviceLine Complex Type
Overview
DespatchAdviceLine Extension of DocumentLineReference Complex Type
Position within the delivery note
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:complexType name="DespatchAdviceLine" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Position auf dem Lieferschein</xs:documentation>
    <xs:documentation xml:lang="en">Position within the delivery note</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentLineReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > DespatchAdviceLine Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DespatchAdviceLine Complex Type | XML Einrichten Version 1.2


DocRefLineNumber Element
XML Einrichten Version 1.2 > DespatchAdviceLine Complex Type : DocRefLineNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
DocRefLineNumber Element
Overview
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="DocRefLineNumber" type="LineItemNumber" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DespatchAdviceLine Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > DespatchAdviceLine Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DespatchAdviceLine Complex Type | XML Einrichten Version 1.2


DespatchAdviceNumberRef Complex Type
XML Einrichten Version 1.2 : DespatchAdviceNumberRef Complex Type
Description
reference to the dispatch advise number
Namespace (none)
Base Type
Extension of DocumentReference Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence DespatchAdviceNumberRef Complex Type
Overview
DespatchAdviceNumberRef Extension of DocumentReference Complex Type
reference to the dispatch advise number
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Used By
DespatchAdviceRef Element
Source
<xs:complexType name="DespatchAdviceNumberRef" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Referenz auf die Lieferscheinnummer </xs:documentation>
    <xs:documentation xml:lang="en">reference to the dispatch advise number</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > DespatchAdviceNumberRef Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DespatchAdviceNumberRef Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > DespatchAdviceNumberRef Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DespatchAdviceNumberRef Complex Type | XML Einrichten Version 1.2


DespatchDate Complex Type
XML Einrichten Version 1.2 : DespatchDate Complex Type
Description
Goods issue date
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
DespatchDate Complex Type
Overview
DespatchDate Restriction of EDIDate Complex Type
Goods issue date
FormatCode optional EDIDateFormatCode Simple Type
Used By
DespatchDate Element
DespatchDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="DespatchDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Warenausgagsdatum</xs:documentation>
    <xs:documentation xml:lang="en">Goods issue date</xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DespatchNumberRef Complex Type
XML Einrichten Version 1.2 : DespatchNumberRef Complex Type
Description
Referenc to the dispatch number
Namespace (none)
Base Type
Extension of DocumentReference Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence DespatchNumberRef Complex Type
Overview
DespatchNumberRef Extension of DocumentReference Complex Type
Referenc to the dispatch number
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Used By
DespatchNumber Element
Source
<xs:complexType name="DespatchNumberRef" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Referenz auf die Versendenummer</xs:documentation>
    <xs:documentation xml:lang="en">Referenc to the dispatch number </xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > DespatchNumberRef Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DespatchNumberRef Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > DespatchNumberRef Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DespatchNumberRef Complex Type | XML Einrichten Version 1.2


DiscountsConditionsTotal Complex Type
XML Einrichten Version 1.2 : DiscountsConditionsTotal Complex Type
Description
Total amount for all conditions on head or line level
Namespace (none)
Base Type
Extension of CurrencyValue Complex Type
Diagram
Currency Element Value Element Sequence DiscountsConditionsTotal Complex Type
Overview
DiscountsConditionsTotal Extension of CurrencyValue Complex Type
Total amount for all conditions on head or line level
Sequence
Value xs:decimal
Currency Currency Simple Type
Used By
DiscountsConditionsTotal Element
DiscountsConditionsTotal Element
DiscountsConditionsTotal Element
Source
<xs:complexType name="DiscountsConditionsTotal" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Gesamtwert aller Rabatte auf Kopf oder Position</xs:documentation>
    <xs:documentation xml:lang="en">Total amount for all conditions on head or line level</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="CurrencyValue" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > DiscountsConditionsTotal Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DiscountsConditionsTotal Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > DiscountsConditionsTotal Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DiscountsConditionsTotal Complex Type | XML Einrichten Version 1.2


DocumentFoot Complex Type
XML Einrichten Version 1.2 : DocumentFoot Complex Type
Description
Foot section of the message
Namespace (none)
Diagram
SendingDate Element Sequence DocumentFoot Complex Type
Overview
DocumentFoot
Foot section of the message
Sequence
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:complexType name="DocumentFoot" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Abschluss der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Foot section of the message</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="SendingDate" type="EDIDate" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Versanddatum der Nachricht </xs:documentation>
        <xs:documentation xml:lang="en">Sending date of this message</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


SendingDate Element
XML Einrichten Version 1.2 > DocumentFoot Complex Type : SendingDate Element
Description
Sending date of this message
Namespace (none)
Type
EDIDate Complex Type
Diagram
SendingDate Element
Overview
SendingDate optional EDIDate Complex Type
Sending date of this message
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="SendingDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Versanddatum der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Sending date of this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DocumentFoot Complex Type | XML Einrichten Version 1.2


DocumentHead Complex Type
XML Einrichten Version 1.2 : DocumentHead Complex Type
Description
Head of the document
Namespace (none)
Diagram
TechnicalReceiverCopy Element DocDate Element DocRefNumber Element Sequence AdditionalReference Element AdditionalDate Element TechnicalSender Element TechnicalReceiver Element DocumentDate Element DocumentNumber Element DocumentFunctionSymbol Element DocumentType Element WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element Sequence DocumentHead Complex Type
Overview
DocumentHead
Head of the document
Sequence
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
DocumentType DocumentType Simple Type
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
DocumentNumber DocumentNumber Simple Type
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Source
<xs:complexType name="DocumentHead" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kopf des Belegs </xs:documentation>
    <xs:documentation xml:lang="en">Head of the document</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="VersionNumber" type="MessageVersion" minOccurs="1" />
    <xs:element name="DocumentType" type="DocumentType" minOccurs="1" />
    <xs:element name="DocumentFunctionSymbol" type="DocumentFunctionSymbol" minOccurs="1" />
    <xs:element name="DocumentNumber" type="DocumentNumber" minOccurs="1" />
    <xs:element name="DocumentDate" type="EDIDate" minOccurs="1" />
    <xs:element name="TechnicalReceiver" type="TechnicalReceiver" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Technischer, physischer Empfänger der Nachricht </xs:documentation>
        <xs:documentation xml:lang="en">technical, physical recipient of the message</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="TechnicalSender" type="TechnicalReceiver" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Technischer, physischer Versender der Nachricht </xs:documentation>
        <xs:documentation xml:lang="en">technical, physical sender of the message</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" />
    <xs:element name="AdditionalReference" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="99" />
    <xs:element name="TechnicalReceiverCopy" type="TechnicalReceiver" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Physischer Empfänger einer Kopie dieser Nachricht </xs:documentation>
        <xs:documentation xml:lang="en">Physical receiver for a copy from this message</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > DocumentHead Complex Type : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..99 EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentHead Complex Type | XML Einrichten Version 1.2


AdditionalReference Element
XML Einrichten Version 1.2 > DocumentHead Complex Type : AdditionalReference Element
Namespace (none)
Type
DocumentReferenceQualified Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence AdditionalReference Element
Overview
AdditionalReference 0..99 DocumentReferenceQualified Complex Type
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalReference" type="DocumentReferenceQualified" minOccurs="0" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentHead Complex Type | XML Einrichten Version 1.2


DocumentDate Element
XML Einrichten Version 1.2 > DocumentHead Complex Type : DocumentDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocumentDate Element
Overview
DocumentDate EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocumentDate" type="EDIDate" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentHead Complex Type | XML Einrichten Version 1.2


DocumentFunctionSymbol Element
XML Einrichten Version 1.2 > DocumentHead Complex Type : DocumentFunctionSymbol Element
Namespace (none)
Type
DocumentFunctionSymbol Simple Type
Diagram
DocumentFunctionSymbol Element
Overview
DocumentFunctionSymbol DocumentFunctionSymbol Simple Type
Source
<xs:element name="DocumentFunctionSymbol" type="DocumentFunctionSymbol" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentHead Complex Type | XML Einrichten Version 1.2


DocumentNumber Element
XML Einrichten Version 1.2 > DocumentHead Complex Type : DocumentNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocumentNumber Element
Overview
DocumentNumber DocumentNumber Simple Type
Source
<xs:element name="DocumentNumber" type="DocumentNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentHead Complex Type | XML Einrichten Version 1.2


DocumentType Element
XML Einrichten Version 1.2 > DocumentHead Complex Type : DocumentType Element
Namespace (none)
Type
DocumentType Simple Type
Diagram
DocumentType Element
Overview
DocumentType DocumentType Simple Type
Source
<xs:element name="DocumentType" type="DocumentType" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentHead Complex Type | XML Einrichten Version 1.2


TechnicalReceiver Element
XML Einrichten Version 1.2 > DocumentHead Complex Type : TechnicalReceiver Element
Description
technical, physical recipient of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiver Element
Overview
TechnicalReceiver optional TechnicalReceiver Simple Type
technical, physical recipient of the message
Source
<xs:element name="TechnicalReceiver" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Empfänger der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical recipient of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DocumentHead Complex Type | XML Einrichten Version 1.2


TechnicalReceiverCopy Element
XML Einrichten Version 1.2 > DocumentHead Complex Type : TechnicalReceiverCopy Element
Description
Physical receiver for a copy from this message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalReceiverCopy Element
Overview
TechnicalReceiverCopy optional TechnicalReceiver Simple Type
Physical receiver for a copy from this message
Source
<xs:element name="TechnicalReceiverCopy" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Physischer Empfänger einer Kopie dieser Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">Physical receiver for a copy from this message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DocumentHead Complex Type | XML Einrichten Version 1.2


TechnicalSender Element
XML Einrichten Version 1.2 > DocumentHead Complex Type : TechnicalSender Element
Description
technical, physical sender of the message
Namespace (none)
Type
TechnicalReceiver Simple Type
Diagram
TechnicalSender Element
Overview
TechnicalSender optional TechnicalReceiver Simple Type
technical, physical sender of the message
Source
<xs:element name="TechnicalSender" type="TechnicalReceiver" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Technischer, physischer Versender der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">technical, physical sender of the message</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DocumentHead Complex Type | XML Einrichten Version 1.2


VersionNumber Element
XML Einrichten Version 1.2 > DocumentHead Complex Type : VersionNumber Element
Namespace (none)
Type
MessageVersion Complex Type
Diagram
WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence VersionNumber Element
Overview
VersionNumber MessageVersion Complex Type
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
Source
<xs:element name="VersionNumber" type="MessageVersion" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentHead Complex Type | XML Einrichten Version 1.2


DocumentLineReference Complex Type
XML Einrichten Version 1.2 : DocumentLineReference Complex Type
Description
reference to a position of another document
Namespace (none)
Base Type
Extension of DocumentReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence DocumentLineReference Complex Type
Overview
DocumentLineReference Extension of DocumentReference Complex Type
reference to a position of another document
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Used By
OrderLineRef Element
OrderLineRef Element
FinalOrderResponseLineRef Element
OrderLineRef Element
BlanketOrderLineRef Element
OrderLineRef Element
DespatchAdviceLineRef Element
OrderResponseLineRef Element
Source
<xs:complexType name="DocumentLineReference" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Referenz auf die Position aus einem anderen Dokument</dt>
        <dt>Wie überträgt man ExcalibuR Kennungen:</dt>
        <dt>DocRefNumber = GeoID oder ConfigID</dt>
        <dt>DocDate = Datum der Übernahme aus XCR</dt>
        <dt>DocRefLineNumber = Positionsnummer in XCR, falls es so etwas gibt. Ansonsten leer lassen.</dt>
        <dt>Reference auf die FurnCloudid ebenfalls ohne Positionsangabe</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">reference to a position of another document</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentReference">
      <xs:sequence>
        <xs:element name="DocRefLineNumber" type="LineItemNumber" minOccurs="0" maxOccurs="1" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocumentLineReferenceQualified Complex Type
XML Einrichten Version 1.2 : DocumentLineReferenceQualified Complex Type
Description
Reference to other documents variable defined by qualifier
Namespace (none)
Base Type
Extension of DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence DocumentLineReferenceQualified Complex Type
Overview
DocumentLineReferenceQualified Extension of DocumentLineReference Complex Type
Reference to other documents variable defined by qualifier
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Used By
AdditionalLineRef Element
AdditionalReference Element
AdditionalLineRef Element
AdditionalReference Element
DocumentLineReference Element
Attributes
Name | Type | Use | Default | Fixed | Description
Qualifier | DocumentReferenceQualifier Simple Type | optional |  |  |
Source
<xs:complexType name="DocumentLineReferenceQualified" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Referenz auf andere Belege variabel über Qualifier  </xs:documentation>
    <xs:documentation xml:lang="en"> Reference to other documents variable defined by qualifier</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentLineReference">
      <xs:attribute name="Qualifier" type="DocumentReferenceQualifier" />
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > DocumentLineReferenceQualified Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentLineReferenceQualified Complex Type | XML Einrichten Version 1.2


DocRefLineNumber Element
XML Einrichten Version 1.2 > DocumentLineReferenceQualified Complex Type : DocRefLineNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
DocRefLineNumber Element
Overview
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="DocRefLineNumber" type="LineItemNumber" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentLineReferenceQualified Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > DocumentLineReferenceQualified Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentLineReferenceQualified Complex Type | XML Einrichten Version 1.2


DocumentPaci Complex Type
XML Einrichten Version 1.2 : DocumentPaci Complex Type
Description
Information about the packaging pieces
Hint for the ORDRSP:
Pieces which contain more than one article position are defined below the first article position within the piece
Namespace (none)
Diagram
MEA Element ConsumerInstructions Element ShippingMark Element TypeOfShippingMark Element LoadingTackle Element TypeOfPackaging Element NumberOfPackages Element ParentPaciNumber Element PaciNumber Element Sequence DocumentPaci Complex Type
Overview
DocumentPaci
Information about the packaging pieces
Hint for the ORDRSP:
Pieces which contain more than one article position are defined below the first article position within the piece
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Used By
PACI Element
PACI Element
PACI Element
PACI Element
PACI Element
Source
<xs:complexType name="DocumentPaci" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Informationen zu den Packstücken</dt>
        <dt>Hinweise für ORDRSP:</dt>
        <dt>Packstücke, die mehrere Artikelpositionen beinhalten werden unter der ersten Artikelposition beschrieben, die enthalten ist</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Information about the packaging pieces</dt>
        <dt>Hint for the ORDRSP:</dt>
        <dt>Pieces which contain more than one article position are defined below the first article position within the piece</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="PaciNumber" type="PackingPieceNumber" minOccurs="1" />
    <xs:element name="ParentPaciNumber" type="PackingPieceNumber" minOccurs="0" />
    <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
    <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
    <xs:element name="LoadingTackle" type="LoadingTackle" minOccurs="0" />
    <xs:element name="TypeOfShippingMark" type="TypeOfShippingMark" minOccurs="0" />
    <xs:element name="ShippingMark" type="ShippingMark" minOccurs="0" />
    <xs:element name="ConsumerInstructions" type="InstructionsConsumer" minOccurs="0" />
    <xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocumentPaciLine Complex Type
XML Einrichten Version 1.2 : DocumentPaciLine Complex Type
Description
Link between LINE and PACI (n..m)
Namespace (none)
Diagram
Quantity Element PaciNumber Element LineItemNumber Element Sequence DocumentPaciLine Complex Type
Overview
DocumentPaciLine
Link between LINE and PACI (n..m)
Sequence
LineItemNumber LineItemNumber Simple Type
reference to a position defined in LINE
PaciNumber PackingPieceNumber Simple Type
Reference to a position defined in PACi
Quantity optional Quantity Complex Type
Number of units from LINE in PACI
Unit optional Unit Simple Type
Used By
PACILINE Element
PACILINE Element
Source
<xs:complexType name="DocumentPaciLine" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Verknüpfung zwischen den Struktrem LINE und PACI (n:m) </xs:documentation>
    <xs:documentation xml:lang="en"> Link between LINE and PACI (n..m)</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de"> Referenz auf eine Positionsnummer aus LINE</xs:documentation>
        <xs:documentation xml:lang="en"> reference to a position defined in LINE</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="PaciNumber" type="PackingPieceNumber" minOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de"> Referenz auf eine in PACI definierte Packstückposition</xs:documentation>
        <xs:documentation xml:lang="en"> Reference to a position defined in PACi</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Quantity" type="Quantity" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de"> Anzahl der Einheiten von LINE in PACI</xs:documentation>
        <xs:documentation xml:lang="en"> Number of units from LINE in PACI</xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


LineItemNumber Element
XML Einrichten Version 1.2 > DocumentPaciLine Complex Type : LineItemNumber Element
Description
reference to a position defined in LINE
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
LineItemNumber Element
Overview
LineItemNumber LineItemNumber Simple Type
reference to a position defined in LINE
Source
<xs:element name="LineItemNumber" type="LineItemNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Referenz auf eine Positionsnummer aus LINE</xs:documentation>
    <xs:documentation xml:lang="en"> reference to a position defined in LINE</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DocumentPaciLine Complex Type | XML Einrichten Version 1.2


PaciNumber Element
XML Einrichten Version 1.2 > DocumentPaciLine Complex Type : PaciNumber Element
Description
Reference to a position defined in PACi
Namespace (none)
Type
PackingPieceNumber Simple Type
Diagram
PaciNumber Element
Overview
PaciNumber PackingPieceNumber Simple Type
Reference to a position defined in PACi
Source
<xs:element name="PaciNumber" type="PackingPieceNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Referenz auf eine in PACI definierte Packstückposition</xs:documentation>
    <xs:documentation xml:lang="en"> Reference to a position defined in PACi</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DocumentPaciLine Complex Type | XML Einrichten Version 1.2


Quantity Element
XML Einrichten Version 1.2 > DocumentPaciLine Complex Type : Quantity Element
Description
Number of units from LINE in PACI
Namespace (none)
Type
Quantity Complex Type
Diagram
Quantity Element
Overview
Quantity optional Quantity Complex Type
Number of units from LINE in PACI
Unit optional Unit Simple Type
Source
<xs:element name="Quantity" type="Quantity" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Anzahl der Einheiten von LINE in PACI</xs:documentation>
    <xs:documentation xml:lang="en"> Number of units from LINE in PACI</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DocumentPaciLine Complex Type | XML Einrichten Version 1.2


DocumentReference Complex Type
XML Einrichten Version 1.2 : DocumentReference Complex Type
Description
Reference to another document or process
How to transfer for example ExcalibuR Idents?
DocRefNumber = GeoID or ConfigID
DocDate = Date of transfer from XCR
Namespace (none)
Diagram
DocDate Element DocRefNumber Element Sequence DocumentReference Complex Type
Overview
DocumentReference
Reference to another document or process
How to transfer for example ExcalibuR Idents?
DocRefNumber = GeoID or ConfigID
DocDate = Date of transfer from XCR
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Used By
OrderNumberRef Element
Source
<xs:complexType name="DocumentReference" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Referenz auf einen anderen Beleg oder Vorgang</dt>
        <dt>Wie überträgt man z.B. ExcalibuR Kennungen?</dt>
        <dt>DocRefNumber = GeoID oder ConfigID</dt>
        <dt>DocDate = Datum der Übernahme aus XCR</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Reference to another document or process</dt>
        <dt>How to transfer for example ExcalibuR Idents?</dt>
        <dt>DocRefNumber = GeoID or ConfigID</dt>
        <dt>DocDate = Date of transfer from XCR</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="DocRefNumber" type="DocumentNumber" />
    <xs:element name="DocDate" type="EDIDate" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocumentReferenceQualified Complex Type
XML Einrichten Version 1.2 : DocumentReferenceQualified Complex Type
Description
Reference to other documents variable defined by qualifier
Namespace (none)
Base Type
Extension of DocumentReference Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence DocumentReferenceQualified Complex Type
Overview
DocumentReferenceQualified Extension of DocumentReference Complex Type
Reference to other documents variable defined by qualifier
Qualifier optional DocumentReferenceQualifier Simple Type
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Used By
AdditionalReference Element
AdditionalReference Element
AdditionalReference Element
AdditionalReference Element
AdditionalReference Element
AdditionalReference Element
AdditionalReference Element
AdditionalReference Element
AdditionalReference Element
AdditionalReference Element
DocumentNumberRef Element
Attributes
Name | Type | Use | Default | Fixed | Description
Qualifier | DocumentReferenceQualifier Simple Type | optional |  |  |
Source
<xs:complexType name="DocumentReferenceQualified" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Referenz auf andere Belege variabel über Qualifier  </xs:documentation>
    <xs:documentation xml:lang="en"> Reference to other documents variable defined by qualifier</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentReference">
      <xs:attribute name="Qualifier" type="DocumentReferenceQualifier" />
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > DocumentReferenceQualified Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentReferenceQualified Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > DocumentReferenceQualified Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentReferenceQualified Complex Type | XML Einrichten Version 1.2


DueDate Complex Type
XML Einrichten Version 1.2 : DueDate Complex Type
Description
Due date
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
DueDate Complex Type
Overview
DueDate Restriction of EDIDate Complex Type
Due date
FormatCode optional EDIDateFormatCode Simple Type
Used By
DueDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="DueDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Fälligkeitsdatum</xs:documentation>
    <xs:documentation xml:lang="en">Due date</xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Duration Complex Type
XML Einrichten Version 1.2 : Duration Complex Type
Description
Duration
Code list:
803 = Weeks
804 = Days
805 = Hours
806 = Mminutes
Namespace (none)
Base Type
Extension of UnitValue Complex Type
Diagram
Duration Complex Type
Overview
Duration Extension of UnitValue Complex Type
Duration
Code list:
803 = Weeks
804 = Days
805 = Hours
806 = Mminutes
Unit optional Unit Simple Type
Used By
DeliveryTime Element
DeliveryTime Element
UnloadingDuration Element
UnloadingDuration Element
LeadTimeIfNotAvailable Element
Attributes
Name | Type | Use | Default | Fixed | Description
Unit | Unit Simple Type | optional |  |  |
Source
<xs:complexType name="Duration" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Dauer</dt>
        <dt>Codeliste: </dt>
        <dt>803 = Wochen </dt>
        <dt>804 = Tage </dt>
        <dt>805 = Stunden </dt>
        <dt>806 = Minuten </dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Duration</dt>
        <dt>Code list: </dt>
        <dt>803 = Weeks </dt>
        <dt>804 = Days </dt>
        <dt>805 = Hours </dt>
        <dt>806 = Mminutes </dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:extension base="UnitValue" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


EDIDate Complex Type
XML Einrichten Version 1.2 : EDIDate Complex Type
Description
variable definition of a date format by format code
Namespace (none)
Base Type
Extension of xs:string
Diagram
EDIDate Complex Type
Overview
EDIDate Extension of xs:string
variable definition of a date format by format code
FormatCode optional EDIDateFormatCode Simple Type
Used By
DocDate Element
CashDiscountDate Element
DocDate Element
SendingDate Element
DocumentDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
DocDate Element
OrderDateUntil Element
DateOfInventoryReport Element
ExpirationDateStart Element
ExpirationDateEnd Element
OrderDateUntil Element
DeliveryDateUntil Element
DocumentDate Element
RequestedDeliveryDate Element
RequestedDeliveryDate Element
SendingDate Element
DocumentDate Element
RequestedDeliveryDate Element
RequestedDeliveryDate Element
SendingDate Element
DocumentDate Element
SendingDate Element
DocumentDate Element
MinimumDurabilityDate Element
SendingDate Element
DocumentDate Element
SendingDate Element
DocumentDate Element
SendingDate Element
DocumentDate Element
SendingDate Element
DocumentDate Element
SendingDate Element
DocumentDate Element
SendingDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="EDIDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Variable Angabe eines Datusmformats über Format Codes</xs:documentation>
    <xs:documentation xml:lang="en">variable definition of a date format by format code</xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:extension base="xs:string">
      <xs:attribute name="FormatCode" form="unqualified" type="EDIDateFormatCode" />
    </xs:extension>
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


EDIDateQualified Complex Type
XML Einrichten Version 1.2 : EDIDateQualified Complex Type
Description
format description for a date info
102 = "CCYYMMDD"
203 = "CCYYMMDDHHMM"
616 = "CCYYWW"
Namespace (none)
Base Type
Extension of EDIDate Complex Type
Diagram
EDIDateQualified Complex Type
Overview
EDIDateQualified Extension of EDIDate Complex Type
format description for a date info
102 = "CCYYMMDD"
203 = "CCYYMMDDHHMM"
616 = "CCYYWW"
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Used By
AdditionalDate Element
AdditionalDate Element
AdditionalDate Element
AdditionalDate Element
AdditionalDate Element
AdditionalDate Element
AdditionalDate Element
AdditionalDate Element
AdditionalDate Element
AdditionalDate Element
AdditionalDate Element
AdditionalDate Element
AdditionalDate Element
AdditionalDate Element
AdditionalDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
Qualifier | EDIDateQualifier Simple Type | optional |  |  |
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="EDIDateQualified" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Datumsformatangabe</dt>
        <dt>102 = "CCYYMMDD"</dt>
        <dt>203 = "CCYYMMDDHHMM"</dt>
        <dt>616 = "CCYYWW"</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>format description for a date info</dt>
        <dt>102 = "CCYYMMDD"</dt>
        <dt>203 = "CCYYMMDDHHMM"</dt>
        <dt>616 = "CCYYWW"</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:extension base="EDIDate">
      <xs:attribute name="Qualifier" type="EDIDateQualifier" />
    </xs:extension>
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


EndConsumer Complex Type
XML Einrichten Version 1.2 : EndConsumer Complex Type
Description
Information about the end-consumer
Namespace (none)
Diagram
CustomerEmail Element CustomerMobile Element CustomerPhone Element ISOCountryCode Element City Element PostalCode Element Street2 Element Street1 Element SurName Element FirstName Element CompanyName Element CustomerID Element QualifierType Element Sequence EndConsumer Complex Type
Overview
EndConsumer
Information about the end-consumer
Sequence
QualifierType Restriction of xs:string
Type of address for the endconsumer
Code list:
UD = Invoice address
UC = Delivery address
CustomerID optional Restriction of xs:string
Customer ID of the end-consumer
CompanyName optional Restriction of xs:string
Company name of the end-consumer
FirstName optional Restriction of xs:string
First name of the end-consumer
SurName optional Restriction of xs:string
Surname of the end-consumer
Street1 optional Restriction of xs:string
Stree Row 1
Street2 optional Restriction of xs:string
Stree Row 2
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
CustomerPhone optional Restriction of xs:string
Phone number of the end-consumer
CustomerMobile optional Restriction of xs:string
Mobile phone number of the end-consumer
CustomerEmail optional Restriction of xs:string
E-Mail of the end-consumer
Source
<xs:complexType name="EndConsumer" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Information zum Endkunden</xs:documentation>
    <xs:documentation xml:lang="en">Information about the end-consumer</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="QualifierType">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Adressart des Endkunden</dt>
            <dt>Codeliste: </dt>
            <dt>UD = Rechnungsadresse</dt>
            <dt>UC = Lieferadresse</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>Type of address for the endconsumer </dt>
            <dt>Code list: </dt>
            <dt>UD = Invoice address</dt>
            <dt>UC = Delivery address</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
          <xs:enumeration value="UD" />
          <xs:enumeration value="UC" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="CustomerID" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Kundennummer des Endkunden</xs:documentation>
        <xs:documentation xml:lang="en">Customer ID of the end-consumer</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="CompanyName" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Firmenname des Endkunden</xs:documentation>
        <xs:documentation xml:lang="en">Company name of the end-consumer</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="FirstName" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Vorname des Endkunden</xs:documentation>
        <xs:documentation xml:lang="en">First name of the end-consumer</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="SurName" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Nachname des Endkunden</xs:documentation>
        <xs:documentation xml:lang="en">Surname of the end-consumer</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="Street1" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Strasse Zeile 1</xs:documentation>
        <xs:documentation xml:lang="en">Stree Row 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="Street2" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Strasse Zeile 2</xs:documentation>
        <xs:documentation xml:lang="en">Stree Row 2</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="PostalCode" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Postleitzahl</xs:documentation>
        <xs:documentation xml:lang="en">Zip Code</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="9" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="City" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Ort</xs:documentation>
        <xs:documentation xml:lang="en">City</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ISOCountryCode" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">ISO Länderkennzeichen</xs:documentation>
        <xs:documentation xml:lang="en">ISO Country Code</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:length value="2" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="CustomerPhone" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Telefonnummer des Endkunden</xs:documentation>
        <xs:documentation xml:lang="en">Phone number of the end-consumer</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="70" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="CustomerMobile" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Mobilnummer des Endkunden</xs:documentation>
        <xs:documentation xml:lang="en">Mobile phone number of the end-consumer</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="70" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="CustomerEmail" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">E-Mail des Endkunden</xs:documentation>
        <xs:documentation xml:lang="en">E-Mail of the end-consumer</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="70" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


City Element
XML Einrichten Version 1.2 > EndConsumer Complex Type : City Element
Description
City
Namespace (none)
Type
Restriction of xs:string
Diagram
City Element
Overview
City optional Restriction of xs:string
City
Source
<xs:element name="City" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Ort</xs:documentation>
    <xs:documentation xml:lang="en">City</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EndConsumer Complex Type | XML Einrichten Version 1.2


CompanyName Element
XML Einrichten Version 1.2 > EndConsumer Complex Type : CompanyName Element
Description
Company name of the end-consumer
Namespace (none)
Type
Restriction of xs:string
Diagram
CompanyName Element
Overview
CompanyName optional Restriction of xs:string
Company name of the end-consumer
Source
<xs:element name="CompanyName" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Firmenname des Endkunden</xs:documentation>
    <xs:documentation xml:lang="en">Company name of the end-consumer</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EndConsumer Complex Type | XML Einrichten Version 1.2


CustomerEmail Element
XML Einrichten Version 1.2 > EndConsumer Complex Type : CustomerEmail Element
Description
E-Mail of the end-consumer
Namespace (none)
Type
Restriction of xs:string
Diagram
CustomerEmail Element
Overview
CustomerEmail optional Restriction of xs:string
E-Mail of the end-consumer
Source
<xs:element name="CustomerEmail" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">E-Mail des Endkunden</xs:documentation>
    <xs:documentation xml:lang="en">E-Mail of the end-consumer</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="70" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EndConsumer Complex Type | XML Einrichten Version 1.2


CustomerID Element
XML Einrichten Version 1.2 > EndConsumer Complex Type : CustomerID Element
Description
Customer ID of the end-consumer
Namespace (none)
Type
Restriction of xs:string
Diagram
CustomerID Element
Overview
CustomerID optional Restriction of xs:string
Customer ID of the end-consumer
Source
<xs:element name="CustomerID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kundennummer des Endkunden</xs:documentation>
    <xs:documentation xml:lang="en">Customer ID of the end-consumer</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EndConsumer Complex Type | XML Einrichten Version 1.2


CustomerMobile Element
XML Einrichten Version 1.2 > EndConsumer Complex Type : CustomerMobile Element
Description
Mobile phone number of the end-consumer
Namespace (none)
Type
Restriction of xs:string
Diagram
CustomerMobile Element
Overview
CustomerMobile optional Restriction of xs:string
Mobile phone number of the end-consumer
Source
<xs:element name="CustomerMobile" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Mobilnummer des Endkunden</xs:documentation>
    <xs:documentation xml:lang="en">Mobile phone number of the end-consumer</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="70" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EndConsumer Complex Type | XML Einrichten Version 1.2


CustomerPhone Element
XML Einrichten Version 1.2 > EndConsumer Complex Type : CustomerPhone Element
Description
Phone number of the end-consumer
Namespace (none)
Type
Restriction of xs:string
Diagram
CustomerPhone Element
Overview
CustomerPhone optional Restriction of xs:string
Phone number of the end-consumer
Source
<xs:element name="CustomerPhone" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Telefonnummer des Endkunden</xs:documentation>
    <xs:documentation xml:lang="en">Phone number of the end-consumer</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="70" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EndConsumer Complex Type | XML Einrichten Version 1.2


FirstName Element
XML Einrichten Version 1.2 > EndConsumer Complex Type : FirstName Element
Description
First name of the end-consumer
Namespace (none)
Type
Restriction of xs:string
Diagram
FirstName Element
Overview
FirstName optional Restriction of xs:string
First name of the end-consumer
Source
<xs:element name="FirstName" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Vorname des Endkunden</xs:documentation>
    <xs:documentation xml:lang="en">First name of the end-consumer</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EndConsumer Complex Type | XML Einrichten Version 1.2


ISOCountryCode Element
XML Einrichten Version 1.2 > EndConsumer Complex Type : ISOCountryCode Element
Description
ISO Country Code
Namespace (none)
Type
Restriction of xs:string
Diagram
ISOCountryCode Element
Overview
ISOCountryCode optional Restriction of xs:string
ISO Country Code
Source
<xs:element name="ISOCountryCode" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">ISO Länderkennzeichen</xs:documentation>
    <xs:documentation xml:lang="en">ISO Country Code</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:length value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EndConsumer Complex Type | XML Einrichten Version 1.2


PostalCode Element
XML Einrichten Version 1.2 > EndConsumer Complex Type : PostalCode Element
Description
Zip Code
Namespace (none)
Type
Restriction of xs:string
Diagram
PostalCode Element
Overview
PostalCode optional Restriction of xs:string
Zip Code
Source
<xs:element name="PostalCode" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Postleitzahl</xs:documentation>
    <xs:documentation xml:lang="en">Zip Code</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="9" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EndConsumer Complex Type | XML Einrichten Version 1.2


QualifierType Element
XML Einrichten Version 1.2 > EndConsumer Complex Type : QualifierType Element
Description
Type of address for the endconsumer
Code list:
UD = Invoice address
UC = Delivery address
Namespace (none)
Type
Restriction of xs:string
Diagram
QualifierType Element
Overview
QualifierType Restriction of xs:string
Type of address for the endconsumer
Code list:
UD = Invoice address
UC = Delivery address
Source
<xs:element name="QualifierType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Adressart des Endkunden</dt>
        <dt>Codeliste: </dt>
        <dt>UD = Rechnungsadresse</dt>
        <dt>UC = Lieferadresse</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Type of address for the endconsumer </dt>
        <dt>Code list: </dt>
        <dt>UD = Invoice address</dt>
        <dt>UC = Delivery address</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
      <xs:enumeration value="UD" />
      <xs:enumeration value="UC" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EndConsumer Complex Type | XML Einrichten Version 1.2


Street1 Element
XML Einrichten Version 1.2 > EndConsumer Complex Type : Street1 Element
Description
Stree Row 1
Namespace (none)
Type
Restriction of xs:string
Diagram
Street1 Element
Overview
Street1 optional Restriction of xs:string
Stree Row 1
Source
<xs:element name="Street1" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Strasse Zeile 1</xs:documentation>
    <xs:documentation xml:lang="en">Stree Row 1</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EndConsumer Complex Type | XML Einrichten Version 1.2


Street2 Element
XML Einrichten Version 1.2 > EndConsumer Complex Type : Street2 Element
Description
Stree Row 2
Namespace (none)
Type
Restriction of xs:string
Diagram
Street2 Element
Overview
Street2 optional Restriction of xs:string
Stree Row 2
Source
<xs:element name="Street2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Strasse Zeile 2</xs:documentation>
    <xs:documentation xml:lang="en">Stree Row 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EndConsumer Complex Type | XML Einrichten Version 1.2


SurName Element
XML Einrichten Version 1.2 > EndConsumer Complex Type : SurName Element
Description
Surname of the end-consumer
Namespace (none)
Type
Restriction of xs:string
Diagram
SurName Element
Overview
SurName optional Restriction of xs:string
Surname of the end-consumer
Source
<xs:element name="SurName" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nachname des Endkunden</xs:documentation>
    <xs:documentation xml:lang="en">Surname of the end-consumer</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EndConsumer Complex Type | XML Einrichten Version 1.2


EndCustomerOrderLine Complex Type
XML Einrichten Version 1.2 : EndCustomerOrderLine Complex Type
Description
Position within the order of the end-consumer
Namespace (none)
Base Type
Extension of DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence EndCustomerOrderLine Complex Type
Overview
EndCustomerOrderLine Extension of DocumentLineReference Complex Type
Position within the order of the end-consumer
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:complexType name="EndCustomerOrderLine" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Auftragsposition in der Endkundenbestelllung</xs:documentation>
    <xs:documentation xml:lang="en">Position within the order of the end-consumer</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentLineReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > EndCustomerOrderLine Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
EndCustomerOrderLine Complex Type | XML Einrichten Version 1.2


DocRefLineNumber Element
XML Einrichten Version 1.2 > EndCustomerOrderLine Complex Type : DocRefLineNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
DocRefLineNumber Element
Overview
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="DocRefLineNumber" type="LineItemNumber" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
EndCustomerOrderLine Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > EndCustomerOrderLine Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
EndCustomerOrderLine Complex Type | XML Einrichten Version 1.2


FII Complex Type
XML Einrichten Version 1.2 : FII Complex Type
Description
Group for financial information
Namespace (none)
Diagram
IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence FII Complex Type
Overview
FII
Group for financial information
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
Used By
Accounting Element
FinancialInformation Element
Source
<xs:complexType name="FII" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Block für Finanzinformationen</xs:documentation>
    <xs:documentation xml:lang="en">Group for financial information</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="AccountNumber" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Kontonummer </xs:documentation>
        <xs:documentation xml:lang="en">Account Number </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="AccountHolder1" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Konto Inhaber Zeile 1 </xs:documentation>
        <xs:documentation xml:lang="en">Account holder Line 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="AccountHolder2" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Konto Inhaber Zeile 2 </xs:documentation>
        <xs:documentation xml:lang="en">Account holder Line 2</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="InstitutionBranch" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Niederlassung der Bank</xs:documentation>
        <xs:documentation xml:lang="en">Branch of the bank</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="17" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="InstitutionName" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Name der Bank </xs:documentation>
        <xs:documentation xml:lang="en">Name of the bank</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="70" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="InstitutionBranchLocation" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Ort der Bankfiliale </xs:documentation>
        <xs:documentation xml:lang="en">City of the bank branch</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="70" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="Country" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Land der Bank </xs:documentation>
        <xs:documentation xml:lang="en">City of the bank</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="2" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="BICNumber" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">BIC Code </xs:documentation>
        <xs:documentation xml:lang="en">BIC Code</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="17" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="IBANNumber" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">IBAN</xs:documentation>
        <xs:documentation xml:lang="en">IBAN</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


AccountHolder1 Element
XML Einrichten Version 1.2 > FII Complex Type : AccountHolder1 Element
Description
Account holder Line 1
Namespace (none)
Type
Restriction of xs:string
Diagram
AccountHolder1 Element
Overview
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
Source
<xs:element name="AccountHolder1" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Konto Inhaber Zeile 1 </xs:documentation>
    <xs:documentation xml:lang="en">Account holder Line 1</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FII Complex Type | XML Einrichten Version 1.2


AccountHolder2 Element
XML Einrichten Version 1.2 > FII Complex Type : AccountHolder2 Element
Description
Account holder Line 2
Namespace (none)
Type
Restriction of xs:string
Diagram
AccountHolder2 Element
Overview
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
Source
<xs:element name="AccountHolder2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Konto Inhaber Zeile 2 </xs:documentation>
    <xs:documentation xml:lang="en">Account holder Line 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FII Complex Type | XML Einrichten Version 1.2


AccountNumber Element
XML Einrichten Version 1.2 > FII Complex Type : AccountNumber Element
Description
Account Number
Namespace (none)
Type
Restriction of xs:string
Diagram
AccountNumber Element
Overview
AccountNumber optional Restriction of xs:string
Account Number
Source
<xs:element name="AccountNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kontonummer </xs:documentation>
    <xs:documentation xml:lang="en">Account Number </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FII Complex Type | XML Einrichten Version 1.2


BICNumber Element
XML Einrichten Version 1.2 > FII Complex Type : BICNumber Element
Description
BIC Code
Namespace (none)
Type
Restriction of xs:string
Diagram
BICNumber Element
Overview
BICNumber optional Restriction of xs:string
BIC Code
Source
<xs:element name="BICNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">BIC Code </xs:documentation>
    <xs:documentation xml:lang="en">BIC Code</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="17" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FII Complex Type | XML Einrichten Version 1.2


Country Element
XML Einrichten Version 1.2 > FII Complex Type : Country Element
Description
City of the bank
Namespace (none)
Type
Restriction of xs:string
Diagram
Country Element
Overview
Country optional Restriction of xs:string
City of the bank
Source
<xs:element name="Country" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Land der Bank </xs:documentation>
    <xs:documentation xml:lang="en">City of the bank</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FII Complex Type | XML Einrichten Version 1.2


IBANNumber Element
XML Einrichten Version 1.2 > FII Complex Type : IBANNumber Element
Description
IBAN
Namespace (none)
Type
Restriction of xs:string
Diagram
IBANNumber Element
Overview
IBANNumber optional Restriction of xs:string
IBAN
Source
<xs:element name="IBANNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">IBAN</xs:documentation>
    <xs:documentation xml:lang="en">IBAN</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FII Complex Type | XML Einrichten Version 1.2


InstitutionBranch Element
XML Einrichten Version 1.2 > FII Complex Type : InstitutionBranch Element
Description
Branch of the bank
Namespace (none)
Type
Restriction of xs:string
Diagram
InstitutionBranch Element
Overview
InstitutionBranch optional Restriction of xs:string
Branch of the bank
Source
<xs:element name="InstitutionBranch" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Niederlassung der Bank</xs:documentation>
    <xs:documentation xml:lang="en">Branch of the bank</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="17" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FII Complex Type | XML Einrichten Version 1.2


InstitutionBranchLocation Element
XML Einrichten Version 1.2 > FII Complex Type : InstitutionBranchLocation Element
Description
City of the bank branch
Namespace (none)
Type
Restriction of xs:string
Diagram
InstitutionBranchLocation Element
Overview
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Source
<xs:element name="InstitutionBranchLocation" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Ort der Bankfiliale </xs:documentation>
    <xs:documentation xml:lang="en">City of the bank branch</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="70" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FII Complex Type | XML Einrichten Version 1.2


InstitutionName Element
XML Einrichten Version 1.2 > FII Complex Type : InstitutionName Element
Description
Name of the bank
Namespace (none)
Type
Restriction of xs:string
Diagram
InstitutionName Element
Overview
InstitutionName optional Restriction of xs:string
Name of the bank
Source
<xs:element name="InstitutionName" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Name der Bank </xs:documentation>
    <xs:documentation xml:lang="en">Name of the bank</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="70" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FII Complex Type | XML Einrichten Version 1.2


GrossLineAmount Complex Type
XML Einrichten Version 1.2 : GrossLineAmount Complex Type
Description
Attention - Do not use anymore. will be cancelled in further versions
Namespace (none)
Base Type
Extension of CurrencyValue Complex Type
Diagram
Currency Element Value Element Sequence GrossLineAmount Complex Type
Overview
GrossLineAmount Extension of CurrencyValue Complex Type
Attention - Do not use anymore. will be cancelled in further versions
Sequence
Value xs:decimal
Currency Currency Simple Type
Used By
GrossLineAmount Element
GrossLineAmount Element
GrossLineAmount Element
GrossLineAmount Element
GrossLineAmount Element
GrossLineAmount Element
Source
<xs:complexType name="GrossLineAmount" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Achtung - nicht mehr verwenden. Dieses Feld ist für kommene Versionen zur Streichung vorgesehen.  </xs:documentation>
    <xs:documentation xml:lang="en">Attention - Do not use anymore. will be cancelled in further versions </xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="CurrencyValue" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > GrossLineAmount Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
GrossLineAmount Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > GrossLineAmount Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
GrossLineAmount Complex Type | XML Einrichten Version 1.2


GrossUnitPrice Complex Type
XML Einrichten Version 1.2 : GrossUnitPrice Complex Type
Description
Gross price
Namespace (none)
Base Type
Extension of Price Complex Type
Diagram
PriceQuantity Element Currency Element Value Element Sequence GrossUnitPrice Complex Type
Overview
GrossUnitPrice Extension of Price Complex Type
Gross price
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Used By
GrossUnitPrice Element
GrossUnitPrice Element
Source
<xs:complexType name="GrossUnitPrice" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Brutto Preis</xs:documentation>
    <xs:documentation xml:lang="en">Gross price</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="Price" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > GrossUnitPrice Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
GrossUnitPrice Complex Type | XML Einrichten Version 1.2


PriceQuantity Element
XML Einrichten Version 1.2 > GrossUnitPrice Complex Type : PriceQuantity Element
Description
Quantity related to the price information
Namespace (none)
Type
Quantity Complex Type
Diagram
PriceQuantity Element
Overview
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Source
<xs:element name="PriceQuantity" type="Quantity" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Preisberechnungsmenge</xs:documentation>
    <xs:documentation xml:lang="en">Quantity related to the price information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
GrossUnitPrice Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > GrossUnitPrice Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
GrossUnitPrice Complex Type | XML Einrichten Version 1.2


HTXT Complex Type
XML Einrichten Version 1.2 : HTXT Complex Type
Description
Segment for textual information within the head of the message
Namespace (none)
Diagram
HeadText Element Sequence HTXT Complex Type
Overview
HTXT
Segment for textual information within the head of the message
Sequence
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Used By
HTXT Element
HTXT Element
HTXT Element
HTXT Element
HTXT Element
HTXT Element
Source
<xs:complexType name="HTXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Segment für Textinformationen zum Nachrichtenkof </xs:documentation>
    <xs:documentation xml:lang="en">Segment for textual information within the head of the message </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="HeadText" type="Textinformation" minOccurs="1" maxOccurs="999">
      <xs:annotation>
        <xs:documentation xml:lang="de">Informationszeile zum Kopf der Nachricht </xs:documentation>
        <xs:documentation xml:lang="en">One line of text information according to the head information </xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


HeadText Element
XML Einrichten Version 1.2 > HTXT Complex Type : HeadText Element
Description
One line of text information according to the head information
Namespace (none)
Type
Textinformation Complex Type
Diagram
HeadText Element
Overview
HeadText 1..999 Textinformation Complex Type
One line of text information according to the head information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="HeadText" type="Textinformation" minOccurs="1" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Informationszeile zum Kopf der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">One line of text information according to the head information </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
HTXT Complex Type | XML Einrichten Version 1.2


InvoiceAmount Complex Type
XML Einrichten Version 1.2 : InvoiceAmount Complex Type
Description
Total amount if the invoice including all taxes from all tax rates
Namespace (none)
Base Type
Extension of CurrencyValue Complex Type
Diagram
Currency Element Value Element Sequence InvoiceAmount Complex Type
Overview
InvoiceAmount Extension of CurrencyValue Complex Type
Total amount if the invoice including all taxes from all tax rates
Sequence
Value xs:decimal
Currency Currency Simple Type
Used By
InvoiceAmount Element
Source
<xs:complexType name="InvoiceAmount" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Gesamtbetrag einer Rechnung inklusive alle Steuerbeträge aus allen Steuersätzen</xs:documentation>
    <xs:documentation xml:lang="en">Total amount if the invoice including all taxes from all tax rates</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="CurrencyValue" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > InvoiceAmount Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
InvoiceAmount Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > InvoiceAmount Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
InvoiceAmount Complex Type | XML Einrichten Version 1.2


InvoiceDate Complex Type
XML Einrichten Version 1.2 : InvoiceDate Complex Type
Description
Date of the invoice
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
InvoiceDate Complex Type
Overview
InvoiceDate Restriction of EDIDate Complex Type
Date of the invoice
FormatCode optional EDIDateFormatCode Simple Type
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="InvoiceDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Rechnungsdatum</xs:documentation>
    <xs:documentation xml:lang="en">Date of the invoice</xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


InvoiceListDate Complex Type
XML Einrichten Version 1.2 : InvoiceListDate Complex Type
Description
date of the consolidated invoice list
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
InvoiceListDate Complex Type
Overview
InvoiceListDate Restriction of EDIDate Complex Type
date of the consolidated invoice list
FormatCode optional EDIDateFormatCode Simple Type
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="InvoiceListDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Datum der Rechnungsliste</xs:documentation>
    <xs:documentation xml:lang="en">date of the consolidated invoice list</xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


LastChangeDate Complex Type
XML Einrichten Version 1.2 : LastChangeDate Complex Type
Description
Last possible date for change of the order
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
LastChangeDate Complex Type
Overview
LastChangeDate Restriction of EDIDate Complex Type
Last possible date for change of the order
FormatCode optional EDIDateFormatCode Simple Type
Used By
LastChangeDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="LastChangeDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Letztmögliches Änderungsdatum der Bestellung</xs:documentation>
    <xs:documentation xml:lang="en">Last possible date for change of the order </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


LineAmount Complex Type
XML Einrichten Version 1.2 : LineAmount Complex Type
Description
not on detail defined position amount)
Namespace (none)
Base Type
Extension of CurrencyValue Complex Type
Diagram
Currency Element Value Element Sequence LineAmount Complex Type
Overview
LineAmount Extension of CurrencyValue Complex Type
not on detail defined position amount)
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:complexType name="LineAmount" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nicht näger spezifizierter Positionsbetrag </xs:documentation>
    <xs:documentation xml:lang="en">not on detail defined position amount)</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="CurrencyValue" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


LineAmountQualified Complex Type
XML Einrichten Version 1.2 : LineAmountQualified Complex Type
Description
by code defined position amount)
Namespace (none)
Base Type
Extension of CurrencyValue Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence LineAmountQualified Complex Type
Overview
LineAmountQualified Extension of CurrencyValue Complex Type
by code defined position amount)
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier LineAmountQualifier Simple Type
Used By
AdditionalLineAmount Element
AdditionalAmount Element
AdditionalLineAmount Element
AdditionalAmount Element
AdditionalAmount Element
Source
<xs:complexType name="LineAmountQualified" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Über einen Code spezifizierter Positionsbetrag </xs:documentation>
    <xs:documentation xml:lang="en">by code defined position amount)</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="CurrencyValue">
      <xs:sequence>
        <xs:element name="Qualifier" type="LineAmountQualifier" minOccurs="1" maxOccurs="1" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > LineAmountQualified Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LineAmountQualified Complex Type | XML Einrichten Version 1.2


Qualifier Element
XML Einrichten Version 1.2 > LineAmountQualified Complex Type : Qualifier Element
Namespace (none)
Type
LineAmountQualifier Simple Type
Diagram
Qualifier Element
Overview
Qualifier LineAmountQualifier Simple Type
Source
<xs:element name="Qualifier" type="LineAmountQualifier" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LineAmountQualified Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > LineAmountQualified Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LineAmountQualified Complex Type | XML Einrichten Version 1.2


LTXT Complex Type
XML Einrichten Version 1.2 : LTXT Complex Type
Description
Segment for textual information for a position
Namespace (none)
Diagram
LineText Element Sequence LTXT Complex Type
Overview
LTXT
Segment for textual information for a position
Sequence
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Used By
LTXT Element
LTXT Element
LTXT Element
LTXT Element
LTXT Element
LTXT Element
Source
<xs:complexType name="LTXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Segment für Textinformatioen zu einer Position </xs:documentation>
    <xs:documentation xml:lang="en">Segment for textual information for a position</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LineText" type="Textinformation" minOccurs="1" maxOccurs="999">
      <xs:annotation>
        <xs:documentation xml:lang="de">Informationszeile Position der Nachricht </xs:documentation>
        <xs:documentation xml:lang="en">One line of text information according to the line information </xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


LineText Element
XML Einrichten Version 1.2 > LTXT Complex Type : LineText Element
Description
One line of text information according to the line information
Namespace (none)
Type
Textinformation Complex Type
Diagram
LineText Element
Overview
LineText 1..999 Textinformation Complex Type
One line of text information according to the line information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:element name="LineText" type="Textinformation" minOccurs="1" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Informationszeile Position der Nachricht </xs:documentation>
    <xs:documentation xml:lang="en">One line of text information according to the line information </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
LTXT Complex Type | XML Einrichten Version 1.2


MEA Complex Type
XML Einrichten Version 1.2 : MEA Complex Type
Description
Group for measurement information
Namespace (none)
Base Type
Extension of UnitValue Complex Type
Diagram
MEA Complex Type
Overview
MEA Extension of UnitValue Complex Type
Group for measurement information
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Used By
MEA Element
MEA Element
MEA Element
MEA Element
MEA Element
Weight Element
Volume Element
MEA Element
MEA Element
MEA Element
Attributes
Name | Type | Use | Default | Fixed | Description
Type Restriction of xs:string optional
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension Restriction of xs:string optional
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit | Unit Simple Type | optional
Source
<xs:complexType name="MEA" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Block für Maßangabe </xs:documentation>
    <xs:documentation xml:lang="en">Group for measurement information</xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:extension base="UnitValue">
      <xs:attribute name="Type">
        <xs:annotation>
          <xs:documentation xml:lang="de">
            <dl>
              <dt>Art der Maßangabe</dt>
              <dt>Codeliste (für Artikel wie für Packstücke):</dt>
              <dt>AAE = Gewicht oder Volumen allgemein </dt>
              <dt>PD = Abmessungen</dt>
              <dt>Verwenden Sie folgende Codes für Artikel Spezialangaben: </dt>
              <dt>ABL = Innenmaß</dt>
              <dt>ABK = Außenmaß</dt>
              <dt>Y2E = Maximalmaß z.B. durch Auszug</dt>
              <dt>Y3E = Minimalmaß z.B. Klappstuhl eingeklappt</dt>
              <dt>Y4E = Liegemaß</dt>
              <dt>Y5E = Sitzmaß</dt>
            </dl>
          </xs:documentation>
          <xs:documentation xml:lang="en">
            <dl>
              <dt>Type if measurement</dt>
              <dt>Code list (for articles and packaging):</dt>
              <dt>AAE = Weight or Volumen </dt>
              <dt>PD = Dimension</dt>
              <dt>Use the following codes for special article measurements: </dt>
              <dt>ABK = Outside dimension</dt>
              <dt>ABL = Inside dimension</dt>
              <dt>Y2E = Maximum dimension </dt>
              <dt>Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt</dt>
              <dt>Y4E = Lying dimension</dt>
              <dt>Y5E = Sitting dimension</dt>
            </dl>
          </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:maxLength value="3" />
            <xs:enumeration value="AAE" />
            <xs:enumeration value="ABK" />
            <xs:enumeration value="ABL" />
            <xs:enumeration value="Y2E" />
            <xs:enumeration value="Y3E" />
            <xs:enumeration value="Y4E" />
            <xs:enumeration value="Y5E" />
            <xs:enumeration value="PD" />
          </xs:restriction>
        </xs:simpleType>
      </xs:attribute>
      <xs:attribute name="Dimension">
        <xs:annotation>
          <xs:documentation xml:ang="de">
            <dl>
              <dt>Gemessene Dimension</dt>
              <dt>Verwenden Sie folgende Codes für Artikel und Packstücke:</dt>
              <dt>DP  = Tiefe</dt>
              <dt>HT  = Höhe</dt>
              <dt>LN  = Länge</dt>
              <dt>WD  = Breite</dt>
              <dt>DI  = Durchmesser</dt>
              <dt>AAA = Netto Gewicht Ware inkl. Endkundenverpackung</dt>
              <dt>AAB = Brutto Gewicht Ware inkl. Transportverpackung</dt>
              <dt>AAF = Netto  Gewicht Ware ohne jede Verpackung</dt>
              <dt>ABJ = Volumen</dt>
            </dl>
          </xs:documentation>
          <xs:documentation xml:ang="en">
            <dl>
              <dt>Mesaured dimension </dt>
              <dt>use this codes for articles and packaging:</dt>
              <dt>DP  = Depth</dt>
              <dt>HT  = Height</dt>
              <dt>LN  = Length</dt>
              <dt>WD  = Width</dt>
              <dt>DI  = Diameter</dt>
              <dt>AAA = Net weight goods incl. end-consumer packaging</dt>
              <dt>AAB = Gross weight goods incl. packaging for transporz</dt>
              <dt>AAF = Net weight goods without any packaging</dt>
              <dt>ABJ = Volume</dt>
            </dl>
          </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:maxLength value="3" />
            <xs:enumeration value="DP" />
            <xs:enumeration value="HT" />
            <xs:enumeration value="LN" />
            <xs:enumeration value="WD" />
            <xs:enumeration value="DI" />
            <xs:enumeration value="AAA" />
            <xs:enumeration value="AAB" />
            <xs:enumeration value="AAF" />
            <xs:enumeration value="ABJ" />
          </xs:restriction>
        </xs:simpleType>
      </xs:attribute>
    </xs:extension>
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


MessageVersion Complex Type
XML Einrichten Version 1.2 : MessageVersion Complex Type
Description
Format Version and handling
Namespace (none)
Diagram
WorkflowAdditonalDocs Element WorkflowDestination Element WorkflowType Element VersionNo Element VersionName Element Sequence MessageVersion Complex Type
Overview
MessageVersion
Format Version and handling
Sequence
VersionName Restriction of xs:string
format name
VersionNo Restriction of xs:string
format Version number
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
WorkflowAdditonalDocs optional Restriction of xs:string
Used By
VersionNumber Element
VersionNumber Element
VersionNumber Element
VersionNumber Element
VersionNumber Element
VersionNumber Element
VersionNumber Element
VersionNumber Element
VersionNumber Element
VersionNumber Element
Source
<xs:complexType name="MessageVersion" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Format Version und Handling </xs:documentation>
    <xs:documentation xml:lang="en">Format Version and handling</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="VersionName" minOccurs="1" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Format Name </xs:documentation>
        <xs:documentation xml:lang="en">format name</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="VersionNo" minOccurs="1" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Format Versionsnummer </xs:documentation>
        <xs:documentation xml:lang="en">format Version number</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="10" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="WorkflowType" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Hinweise zum Prozess basierend auf derBestellnachricht</dt>
            <dt>Codeliste: </dt>
            <dt>""  = Standard</dt>
            <dt>P   = Planungsauftrag</dt>
            <dt>K   = Küchenauftrag</dt>
            <dt>E   = Auftrag ausschließlich mit GTIN (EAN) Nummern</dt>
            <dt>T   = Textauftrag ohne eindeutige Artikelidents</dt>
            <dt>XCR  = Variantenauftrag aus XcalibuR</dt>
            <dt>XCRK= Kopie eines Variantenauftrag aus XcalibuR - nur an die Plattform übertragen</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>Remarks to the process based on the order message</dt>
            <dt>Code list: </dt>
            <dt>""  = Standard order</dt>
            <dt>P   = Planning order</dt>
            <dt>K   = Kitchen order </dt>
            <dt>E   = Order with GTIN (EAN)in each position</dt>
            <dt>T   = Order with text and without unigue article identifier</dt>
            <dt>XCR  = Variant order from XcalibuR</dt>
            <dt>XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="10" />
          <xs:enumeration value=" " />
          <xs:enumeration value="P" />
          <xs:enumeration value="K" />
          <xs:enumeration value="E" />
          <xs:enumeration value="T" />
          <xs:enumeration value="XCR" />
          <xs:enumeration value="XCRK" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="WorkflowDestination" type="WorkflowDestination" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Hinweise zum Prozess basierend dem Lieferprozess</dt>
            <dt>Codeliste: </dt>
            <dt>L   = Lager</dt>
            <dt>CD   = Cross docking</dt>
            <dt>D   = Dropshipping</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>Remarks to the process based on the delivery process</dt>
            <dt>Code list: </dt>
            <dt>L   = Lager</dt>
            <dt>CD   = Cross docking</dt>
            <dt>D   = Dropshipping</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="WorkflowAdditonalDocs" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Welche Dokumente müssen aus dem Ausgangsbeleg zusätzlich erzeugt werden</dt>
            <dt>Codeliste: </dt>
            <dt>R = Rechnung</dt>
            <dt>L = Lieferschein</dt>
            <dt>A = Adressaufkleber</dt>
            <dt>#..# = Alle Kombinationen aus oben möglich</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Which documents have to be generated additionally</dt>
            <dt>Code list: </dt>
            <dt>R = Invoice</dt>
            <dt>L = delivery note</dt>
            <dt>A = labels</dt>
            <dt>#..# = all combinations of above</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="10" />
          <xs:enumeration value="R" />
          <xs:enumeration value="L" />
          <xs:enumeration value="A" />
          <xs:enumeration value="#..#" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


VersionName Element
XML Einrichten Version 1.2 > MessageVersion Complex Type : VersionName Element
Description
format name
Namespace (none)
Type
Restriction of xs:string
Diagram
VersionName Element
Overview
VersionName Restriction of xs:string
format name
Source
<xs:element name="VersionName" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Format Name </xs:documentation>
    <xs:documentation xml:lang="en">format name</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MessageVersion Complex Type | XML Einrichten Version 1.2


VersionNo Element
XML Einrichten Version 1.2 > MessageVersion Complex Type : VersionNo Element
Description
format Version number
Namespace (none)
Type
Restriction of xs:string
Diagram
VersionNo Element
Overview
VersionNo Restriction of xs:string
format Version number
Source
<xs:element name="VersionNo" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Format Versionsnummer </xs:documentation>
    <xs:documentation xml:lang="en">format Version number</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MessageVersion Complex Type | XML Einrichten Version 1.2


WorkflowAdditonalDocs Element
XML Einrichten Version 1.2 > MessageVersion Complex Type : WorkflowAdditonalDocs Element
Namespace (none)
Type
Restriction of xs:string
Diagram
WorkflowAdditonalDocs Element
Overview
WorkflowAdditonalDocs optional Restriction of xs:string
Source
<xs:element name="WorkflowAdditonalDocs" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Welche Dokumente müssen aus dem Ausgangsbeleg zusätzlich erzeugt werden</dt>
        <dt>Codeliste: </dt>
        <dt>R = Rechnung</dt>
        <dt>L = Lieferschein</dt>
        <dt>A = Adressaufkleber</dt>
        <dt>#..# = Alle Kombinationen aus oben möglich</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Which documents have to be generated additionally</dt>
        <dt>Code list: </dt>
        <dt>R = Invoice</dt>
        <dt>L = delivery note</dt>
        <dt>A = labels</dt>
        <dt>#..# = all combinations of above</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="10" />
      <xs:enumeration value="R" />
      <xs:enumeration value="L" />
      <xs:enumeration value="A" />
      <xs:enumeration value="#..#" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MessageVersion Complex Type | XML Einrichten Version 1.2


WorkflowDestination Element
XML Einrichten Version 1.2 > MessageVersion Complex Type : WorkflowDestination Element
Description
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
Namespace (none)
Type
WorkflowDestination Simple Type
Diagram
WorkflowDestination Element
Overview
WorkflowDestination optional WorkflowDestination Simple Type
Remarks to the process based on the delivery process
Code list:
L = Lager
CD = Cross docking
D = Dropshipping
Source
<xs:element name="WorkflowDestination" type="WorkflowDestination" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Hinweise zum Prozess basierend dem Lieferprozess</dt>
        <dt>Codeliste: </dt>
        <dt>L   = Lager</dt>
        <dt>CD   = Cross docking</dt>
        <dt>D   = Dropshipping</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Remarks to the process based on the delivery process</dt>
        <dt>Code list: </dt>
        <dt>L   = Lager</dt>
        <dt>CD   = Cross docking</dt>
        <dt>D   = Dropshipping</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
MessageVersion Complex Type | XML Einrichten Version 1.2


WorkflowType Element
XML Einrichten Version 1.2 > MessageVersion Complex Type : WorkflowType Element
Description
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
Namespace (none)
Type
Restriction of xs:string
Diagram
WorkflowType Element
Overview
WorkflowType optional Restriction of xs:string
Remarks to the process based on the order message
Code list:
"" = Standard order
P = Planning order
K = Kitchen order
E = Order with GTIN (EAN)in each position
T = Order with text and without unigue article identifier
XCR = Variant order from XcalibuR
XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform
Source
<xs:element name="WorkflowType" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Hinweise zum Prozess basierend auf derBestellnachricht</dt>
        <dt>Codeliste: </dt>
        <dt>""  = Standard</dt>
        <dt>P   = Planungsauftrag</dt>
        <dt>K   = Küchenauftrag</dt>
        <dt>E   = Auftrag ausschließlich mit GTIN (EAN) Nummern</dt>
        <dt>T   = Textauftrag ohne eindeutige Artikelidents</dt>
        <dt>XCR  = Variantenauftrag aus XcalibuR</dt>
        <dt>XCRK= Kopie eines Variantenauftrag aus XcalibuR - nur an die Plattform übertragen</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Remarks to the process based on the order message</dt>
        <dt>Code list: </dt>
        <dt>""  = Standard order</dt>
        <dt>P   = Planning order</dt>
        <dt>K   = Kitchen order </dt>
        <dt>E   = Order with GTIN (EAN)in each position</dt>
        <dt>T   = Order with text and without unigue article identifier</dt>
        <dt>XCR  = Variant order from XcalibuR</dt>
        <dt>XCRK= Copy of a variant order from XcalibuR - only for transport to IWOfurn Platform</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="10" />
      <xs:enumeration value=" " />
      <xs:enumeration value="P" />
      <xs:enumeration value="K" />
      <xs:enumeration value="E" />
      <xs:enumeration value="T" />
      <xs:enumeration value="XCR" />
      <xs:enumeration value="XCRK" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MessageVersion Complex Type | XML Einrichten Version 1.2


MULH Complex Type
XML Einrichten Version 1.2 : MULH Complex Type
Description
Segment for multimedia information for the document
Namespace (none)
Diagram
AppTargetIdentification Element AppSourceIdentification Element ObjectContent Element Source Element RemoteType Element FunctionType Element ObjectType Element ObjectDescription Element FileName Element Sequence MULH Complex Type
Overview
MULH
Segment for multimedia information for the document
Sequence
FileName Restriction of xs:string
file name without path prefix
ObjectDescription optional Restriction of xs:string
Describes the content of the file
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
FunctionType Restriction of xs:string
RemoteType optional Restriction of xs:string
Source optional Restriction of xs:string
File path
ObjectContent optional xs:string
content base64 coded
AppSourceIdentification optional Restriction of xs:string
Source application
AppTargetIdentification optional Restriction of xs:string
Target program for the object
Used By
MULH Element
MULH Element
MULH Element
MULH Element
MULH Element
Source
<xs:complexType name="MULH" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Segment für Multimedia Informationen zum Beleg </xs:documentation>
    <xs:documentation xml:lang="en">Segment for multimedia information for the document</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="FileName" minOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Name der Datei ohne Pfadangabe</xs:documentation>
        <xs:documentation xml:lang="en">file name without path prefix </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="256" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ObjectDescription" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Beschreibt den Inhat der Datei</xs:documentation>
        <xs:documentation xml:lang="en">Describes the content of the file </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="256" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ObjectType" minOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Objekttyp (Inhalt der Datei)</dt>
            <dt>PCT = Bild</dt>
            <dt>TXT = Text</dt>
            <dt>OTH = Andere Formate</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>Object type classifeid</dt>
            <dt>PCT = Picture</dt>
            <dt>TXT = Text</dt>
            <dt>OTH = Others</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="FunctionType" minOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Wozu wird die Datei benutzt</dt>
            <dt>SKE = Skizze</dt>
            <dt>...</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Use case of the file</dt>
            <dt>SKE = Sketch</dt>
            <dt>...</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="RemoteType" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Wo befindet sich das Objekt</dt>
            <dt>IA = external see Source</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>where is the object located</dt>
            <dt>IA = external see Source</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="Source" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Pfad zur Datei</xs:documentation>
        <xs:documentation xml:lang="en">File path</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="512" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ObjectContent" type="xs:string" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Inhalte base64 dociert </xs:documentation>
        <xs:documentation xml:lang="en">content base64 coded</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="AppSourceIdentification" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Quellprogramm </xs:documentation>
        <xs:documentation xml:lang="en">Source application</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="70" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="AppTargetIdentification" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Zielporgramm für das Objekt </xs:documentation>
        <xs:documentation xml:lang="en">Target program for the object</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="70" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


AppSourceIdentification Element
XML Einrichten Version 1.2 > MULH Complex Type : AppSourceIdentification Element
Description
Source application
Namespace (none)
Type
Restriction of xs:string
Diagram
AppSourceIdentification Element
Overview
AppSourceIdentification optional Restriction of xs:string
Source application
Source
<xs:element name="AppSourceIdentification" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Quellprogramm </xs:documentation>
    <xs:documentation xml:lang="en">Source application</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="70" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MULH Complex Type | XML Einrichten Version 1.2


AppTargetIdentification Element
XML Einrichten Version 1.2 > MULH Complex Type : AppTargetIdentification Element
Description
Target program for the object
Namespace (none)
Type
Restriction of xs:string
Diagram
AppTargetIdentification Element
Overview
AppTargetIdentification optional Restriction of xs:string
Target program for the object
Source
<xs:element name="AppTargetIdentification" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Zielporgramm für das Objekt </xs:documentation>
    <xs:documentation xml:lang="en">Target program for the object</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="70" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MULH Complex Type | XML Einrichten Version 1.2


FileName Element
XML Einrichten Version 1.2 > MULH Complex Type : FileName Element
Description
file name without path prefix
Namespace (none)
Type
Restriction of xs:string
Diagram
FileName Element
Overview
FileName Restriction of xs:string
file name without path prefix
Source
<xs:element name="FileName" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Name der Datei ohne Pfadangabe</xs:documentation>
    <xs:documentation xml:lang="en">file name without path prefix </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="256" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MULH Complex Type | XML Einrichten Version 1.2


FunctionType Element
XML Einrichten Version 1.2 > MULH Complex Type : FunctionType Element
Namespace (none)
Type
Restriction of xs:string
Diagram
FunctionType Element
Overview
FunctionType Restriction of xs:string
Source
<xs:element name="FunctionType" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Wozu wird die Datei benutzt</dt>
        <dt>SKE = Skizze</dt>
        <dt>...</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Use case of the file</dt>
        <dt>SKE = Sketch</dt>
        <dt>...</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MULH Complex Type | XML Einrichten Version 1.2


ObjectContent Element
XML Einrichten Version 1.2 > MULH Complex Type : ObjectContent Element
Description
content base64 coded
Namespace (none)
Type
xs:string
Diagram
ObjectContent Element
Overview
ObjectContent optional xs:string
content base64 coded
Source
<xs:element name="ObjectContent" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Inhalte base64 dociert </xs:documentation>
    <xs:documentation xml:lang="en">content base64 coded</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
MULH Complex Type | XML Einrichten Version 1.2


ObjectDescription Element
XML Einrichten Version 1.2 > MULH Complex Type : ObjectDescription Element
Description
Describes the content of the file
Namespace (none)
Type
Restriction of xs:string
Diagram
ObjectDescription Element
Overview
ObjectDescription optional Restriction of xs:string
Describes the content of the file
Source
<xs:element name="ObjectDescription" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Beschreibt den Inhat der Datei</xs:documentation>
    <xs:documentation xml:lang="en">Describes the content of the file </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="256" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MULH Complex Type | XML Einrichten Version 1.2


ObjectType Element
XML Einrichten Version 1.2 > MULH Complex Type : ObjectType Element
Description
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
Namespace (none)
Type
Restriction of xs:string
Diagram
ObjectType Element
Overview
ObjectType Restriction of xs:string
Object type classifeid
PCT = Picture
TXT = Text
OTH = Others
Source
<xs:element name="ObjectType" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Objekttyp (Inhalt der Datei)</dt>
        <dt>PCT = Bild</dt>
        <dt>TXT = Text</dt>
        <dt>OTH = Andere Formate</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Object type classifeid</dt>
        <dt>PCT = Picture</dt>
        <dt>TXT = Text</dt>
        <dt>OTH = Others</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MULH Complex Type | XML Einrichten Version 1.2


RemoteType Element
XML Einrichten Version 1.2 > MULH Complex Type : RemoteType Element
Namespace (none)
Type
Restriction of xs:string
Diagram
RemoteType Element
Overview
RemoteType optional Restriction of xs:string
Source
<xs:element name="RemoteType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Wo befindet sich das Objekt</dt>
        <dt>IA = external see Source</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>where is the object located</dt>
        <dt>IA = external see Source</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MULH Complex Type | XML Einrichten Version 1.2


Source Element
XML Einrichten Version 1.2 > MULH Complex Type : Source Element
Description
File path
Namespace (none)
Type
Restriction of xs:string
Diagram
Source Element
Overview
Source optional Restriction of xs:string
File path
Source
<xs:element name="Source" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Pfad zur Datei</xs:documentation>
    <xs:documentation xml:lang="en">File path</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="512" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MULH Complex Type | XML Einrichten Version 1.2


MULL Complex Type
XML Einrichten Version 1.2 : MULL Complex Type
Description
Segment for multimeda information for a single position
Namespace (none)
Diagram
ObjectID Element FileName Element Sequence MULL Complex Type
Overview
MULL
Segment for multimeda information for a single position
Sequence
FileName Restriction of xs:string
Filename
ObjectID optional Restriction of xs:string
ID of the object within the file
Used By
MULL Element
MULL Element
MULL Element
Source
<xs:complexType name="MULL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Segment für Multimedia Informationen zu einer Position </xs:documentation>
    <xs:documentation xml:lang="en">Segment for multimeda information for a single position </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="FileName">
      <xs:annotation>
        <xs:documentation xml:lang="de">Datename </xs:documentation>
        <xs:documentation xml:lang="en">Filename </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="256" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ObjectID" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Kennung des Objetkes in der Datei </xs:documentation>
        <xs:documentation xml:lang="en">ID of the object within the file</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="70" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


FileName Element
XML Einrichten Version 1.2 > MULL Complex Type : FileName Element
Description
Filename
Namespace (none)
Type
Restriction of xs:string
Diagram
FileName Element
Overview
FileName Restriction of xs:string
Filename
Source
<xs:element name="FileName" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Datename </xs:documentation>
    <xs:documentation xml:lang="en">Filename </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="256" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MULL Complex Type | XML Einrichten Version 1.2


ObjectID Element
XML Einrichten Version 1.2 > MULL Complex Type : ObjectID Element
Description
ID of the object within the file
Namespace (none)
Type
Restriction of xs:string
Diagram
ObjectID Element
Overview
ObjectID optional Restriction of xs:string
ID of the object within the file
Source
<xs:element name="ObjectID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kennung des Objetkes in der Datei </xs:documentation>
    <xs:documentation xml:lang="en">ID of the object within the file</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="70" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MULL Complex Type | XML Einrichten Version 1.2


MVMT Complex Type
XML Einrichten Version 1.2 : MVMT Complex Type
Description
Inventory movements
Namespace (none)
Diagram
AdditionalQuantity Element AdditionalDate Element PromotionNumber Element ExpirationDateEnd Element ExpirationDateStart Element DateOfInventoryReport Element LocationOfGoods Element InventoryQuantity Element InventoryMethod Element InventoryType Element DirectionOfMovement Element Sequence MVMT Complex Type
Overview
MVMT
Inventory movements
Sequence
DirectionOfMovement optional DirectionOfMovement Simple Type
InventoryType optional InventoryType Simple Type
InventoryMethod optional InventoryMethod Simple Type
InventoryQuantity Quantity Complex Type
Unit optional Unit Simple Type
LocationOfGoods optional LocationOfGoods Simple Type
DateOfInventoryReport optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ExpirationDateStart optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ExpirationDateEnd optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
PromotionNumber optional PromotionNumber Simple Type
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
Used By
MVMT Element
Source
<xs:complexType name="MVMT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Bestandsbewegungen </xs:documentation>
    <xs:documentation xml:lang="en">Inventory movements </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="DirectionOfMovement" type="DirectionOfMovement" minOccurs="0" />
    <xs:element name="InventoryType" type="InventoryType" minOccurs="0" />
    <xs:element name="InventoryMethod" type="InventoryMethod" minOccurs="0" />
    <xs:element name="InventoryQuantity" type="Quantity" minOccurs="1" />
    <xs:element name="LocationOfGoods" type="LocationOfGoods" minOccurs="0" />
    <xs:element name="DateOfInventoryReport" type="EDIDate" minOccurs="0" />
    <xs:element name="ExpirationDateStart" type="EDIDate" minOccurs="0" />
    <xs:element name="ExpirationDateEnd" type="EDIDate" minOccurs="0" />
    <xs:element name="PromotionNumber" type="PromotionNumber" minOccurs="0" />
    <xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="unbounded" />
    <xs:element name="AdditionalQuantity" type="QuantityQualified" minOccurs="0" maxOccurs="unbounded" />
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


AdditionalDate Element
XML Einrichten Version 1.2 > MVMT Complex Type : AdditionalDate Element
Namespace (none)
Type
EDIDateQualified Complex Type
Diagram
AdditionalDate Element
Overview
AdditionalDate 0..∞ EDIDateQualified Complex Type
Qualifier optional EDIDateQualifier Simple Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="AdditionalDate" type="EDIDateQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MVMT Complex Type | XML Einrichten Version 1.2


AdditionalQuantity Element
XML Einrichten Version 1.2 > MVMT Complex Type : AdditionalQuantity Element
Namespace (none)
Type
QuantityQualified Complex Type
Diagram
AdditionalQuantity Element
Overview
AdditionalQuantity 0..∞ QuantityQualified Complex Type
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
Source
<xs:element name="AdditionalQuantity" type="QuantityQualified" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MVMT Complex Type | XML Einrichten Version 1.2


DateOfInventoryReport Element
XML Einrichten Version 1.2 > MVMT Complex Type : DateOfInventoryReport Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DateOfInventoryReport Element
Overview
DateOfInventoryReport optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DateOfInventoryReport" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MVMT Complex Type | XML Einrichten Version 1.2


DirectionOfMovement Element
XML Einrichten Version 1.2 > MVMT Complex Type : DirectionOfMovement Element
Namespace (none)
Type
DirectionOfMovement Simple Type
Diagram
DirectionOfMovement Element
Overview
DirectionOfMovement optional DirectionOfMovement Simple Type
Source
<xs:element name="DirectionOfMovement" type="DirectionOfMovement" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MVMT Complex Type | XML Einrichten Version 1.2


ExpirationDateEnd Element
XML Einrichten Version 1.2 > MVMT Complex Type : ExpirationDateEnd Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
ExpirationDateEnd Element
Overview
ExpirationDateEnd optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="ExpirationDateEnd" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MVMT Complex Type | XML Einrichten Version 1.2


ExpirationDateStart Element
XML Einrichten Version 1.2 > MVMT Complex Type : ExpirationDateStart Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
ExpirationDateStart Element
Overview
ExpirationDateStart optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="ExpirationDateStart" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MVMT Complex Type | XML Einrichten Version 1.2


InventoryMethod Element
XML Einrichten Version 1.2 > MVMT Complex Type : InventoryMethod Element
Namespace (none)
Type
InventoryMethod Simple Type
Diagram
InventoryMethod Element
Overview
InventoryMethod optional InventoryMethod Simple Type
Source
<xs:element name="InventoryMethod" type="InventoryMethod" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MVMT Complex Type | XML Einrichten Version 1.2


InventoryQuantity Element
XML Einrichten Version 1.2 > MVMT Complex Type : InventoryQuantity Element
Namespace (none)
Type
Quantity Complex Type
Diagram
InventoryQuantity Element
Overview
InventoryQuantity Quantity Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="InventoryQuantity" type="Quantity" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MVMT Complex Type | XML Einrichten Version 1.2


InventoryType Element
XML Einrichten Version 1.2 > MVMT Complex Type : InventoryType Element
Namespace (none)
Type
InventoryType Simple Type
Diagram
InventoryType Element
Overview
InventoryType optional InventoryType Simple Type
Source
<xs:element name="InventoryType" type="InventoryType" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MVMT Complex Type | XML Einrichten Version 1.2


LocationOfGoods Element
XML Einrichten Version 1.2 > MVMT Complex Type : LocationOfGoods Element
Namespace (none)
Type
LocationOfGoods Simple Type
Diagram
LocationOfGoods Element
Overview
LocationOfGoods optional LocationOfGoods Simple Type
Source
<xs:element name="LocationOfGoods" type="LocationOfGoods" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MVMT Complex Type | XML Einrichten Version 1.2


PromotionNumber Element
XML Einrichten Version 1.2 > MVMT Complex Type : PromotionNumber Element
Namespace (none)
Type
PromotionNumber Simple Type
Diagram
PromotionNumber Element
Overview
PromotionNumber optional PromotionNumber Simple Type
Source
<xs:element name="PromotionNumber" type="PromotionNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MVMT Complex Type | XML Einrichten Version 1.2


NAD Complex Type
XML Einrichten Version 1.2 : NAD Complex Type
Description
Segment for address information
Namespace (none)
Diagram
FurtherReferences Element IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element DeliveryConditions Element BusinessCustomerNumber Element ZRNumber Element ContractNumber Element OpeningHours Element CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element TaxId Element VATId Element ISOCountryCode Element City Element PostalCode Element StreetAddition Element Street1 Element Name4 Element Name3 Element Name2 Element Name1 Element AdressGLN Element FlagOfParty Element Sequence NAD Complex Type
Overview
NAD
Segment for address information
Sequence
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
AdressGLN optional
GLN Code of the address
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Street1 optional Restriction of xs:string
Street
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
PostalCode optional Restriction of xs:string
Zip Code
City optional Restriction of xs:string
City
ISOCountryCode optional Restriction of xs:string
ISO Country Code
VATId optional VATId Simple Type
TaxId optional TaxId Simple Type
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
ContractNumber optional Restriction of xs:string
Contract number
ZRNumber optional ZRNumber Simple Type
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
DeliveryConditions 0..10 DeliveryCondition Simple Type
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
FurtherReferences optional Restriction of xs:string
e.g. depot number
Used By
NAD Element
NAD Element
NAD Element
NAD Element
NAD Element
NAD Element
NAD Element
NAD Element
NAD Element
NAD Element
NAD Element
Source
<xs:complexType name="NAD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Segment für Adressinformationen </xs:documentation>
    <xs:documentation xml:lang="en">Segment for address information </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="FlagOfParty" minOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Adress Typ</dt>
            <dt>Codeliste:</dt>
            <dt>SU = Lieferant</dt>
            <dt>BY = Käufer</dt>
            <dt>DP = Lieferadresse</dt>
            <dt>UC = Lieferadresse Endkunde</dt>
            <dt>IV = Rechnungsempfänger der Warenrechnung</dt>
            <dt>UD = Rechnungsadresse Endkunde, falls abweichend von UC</dt>
            <dt>PL = Zentralregulierer</dt>
            <dt>MA = fMontageadresse</dt>
            <dt>MF = Hersteller - nur für die Kimmunikation mit OTTO</dt>
            <dt>----- Transport -----</dt>
            <dt>PO = Auftraggeber des Transportauftrags</dt>
            <dt>PW = Abholadresse, Übergabeort</dt>
            <dt>PF = Empfänger der Frachtrechnung</dt>
            <dt>FW = Ausgewähltes Transportunternehmen</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>Adress Typ</dt>
            <dt>Code list:</dt>
            <dt>SU = Suppler address</dt>
            <dt>BY = Buyers address</dt>
            <dt>DP = Delivery address</dt>
            <dt>UC = Delivery address end-consumer</dt>
            <dt>IV = Invoice Recipient</dt>
            <dt>UD = invoice recipient end-consumer</dt>
            <dt>PL = Faktorer</dt>
            <dt>MA = Assembly address</dt>
            <dt>MF = Manufacturer- used for OTTO only</dt>
            <dt>----- Transport -----</dt>
            <dt>PO = Client of the transport orders</dt>
            <dt>PW = Pick-Up address, delivery point</dt>
            <dt>PF = Recipient of the freight invoice</dt>
            <dt>FW = Selected carrier</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
          <xs:enumeration value="BY" />
          <xs:enumeration value="DP" />
          <xs:enumeration value="FW" />
          <xs:enumeration value="IV" />
          <xs:enumeration value="MA" />
          <xs:enumeration value="PF" />
          <xs:enumeration value="PL" />
          <xs:enumeration value="PO" />
          <xs:enumeration value="PW" />
          <xs:enumeration value="SU" />
          <xs:enumeration value="UC" />
          <xs:enumeration value="UD" />
          <xs:enumeration value="MF" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="AdressGLN" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">GLN Nummer der Adresse </xs:documentation>
        <xs:documentation xml:lang="en">GLN Code of the address </xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Name1" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Bei Firmen:         Firmierung</dt>
            <dt>Bei Privatpersonen: Vorname Nachname</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>in case of Companies: Companyname</dt>
            <dt>in case of Endusers:  Firstname surname</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="Name2" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Bei Firmen:         Fortsetzung der Firmierung</dt>
            <dt>Bei Privatpersonen: leer</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>in case of Companies: Continuation of the Companyname</dt>
            <dt>in case of Endusers:  empty</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="Name3" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Bei Firmen:         Leer</dt>
            <dt>Bei Privatpersonen: Vorname</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>in case of Companies: Empty</dt>
            <dt>in case of Endusers:  First name</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="Name4" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Bei Firmen:         Leer</dt>
            <dt>Bei Privatpersonen: Nachname</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>in case of Companies: Empty</dt>
            <dt>in case of Endusers:  Surname</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="Street1" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Strasse</xs:documentation>
        <xs:documentation xml:lang="en">Street </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="StreetAddition" minOccurs="0" maxOccurs="3">
      <xs:annotation>
        <xs:documentation xml:lang="de">Zusatzinformationen zur Strasse</xs:documentation>
        <xs:documentation xml:lang="en">Additional information to the Street </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="PostalCode" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Postleiztahl</xs:documentation>
        <xs:documentation xml:lang="en">Zip Code </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="17" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="City" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Ort</xs:documentation>
        <xs:documentation xml:lang="en">City </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ISOCountryCode" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">ISO Länderkennzeichen</xs:documentation>
        <xs:documentation xml:lang="en">ISO Country Code </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:length value="2" />
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="VATId" type="VATId" minOccurs="0" />
    <xs:element name="TaxId" type="TaxId" minOccurs="0" />
    <xs:element name="ContactPerson" type="Contact" minOccurs="0" maxOccurs="1" />
    <xs:element name="OpeningHours" type="OpeningPeriod" minOccurs="0" maxOccurs="9" />
    <xs:element name="ContractNumber" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Abkommensnummer </xs:documentation>
        <xs:documentation xml:lang="en">Contract number </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ZRNumber" type="ZRNumber" minOccurs="0" />
    <xs:element name="BusinessCustomerNumber" type="BusinessCustomerNumber" minOccurs="0" />
    <xs:element name="DeliveryConditions" type="DeliveryCondition" minOccurs="0" maxOccurs="10" />
    <xs:element name="Accounting" type="FII" minOccurs="0" maxOccurs="5" />
    <xs:element name="FurtherReferences" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">z.B. Depotnummer/Abladestelle </xs:documentation>
        <xs:documentation xml:lang="en">e.g. depot number </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="35" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Accounting Element
XML Einrichten Version 1.2 > NAD Complex Type : Accounting Element
Namespace (none)
Type
FII Complex Type
Diagram
IBANNumber Element BICNumber Element Country Element InstitutionBranchLocation Element InstitutionName Element InstitutionBranch Element AccountHolder2 Element AccountHolder1 Element AccountNumber Element Sequence Accounting Element
Overview
Accounting 0..5 FII Complex Type
Sequence
AccountNumber optional Restriction of xs:string
Account Number
AccountHolder1 optional Restriction of xs:string
Account holder Line 1
AccountHolder2 optional Restriction of xs:string
Account holder Line 2
InstitutionBranch optional Restriction of xs:string
Branch of the bank
InstitutionName optional Restriction of xs:string
Name of the bank
InstitutionBranchLocation optional Restriction of xs:string
City of the bank branch
Country optional Restriction of xs:string
City of the bank
BICNumber optional Restriction of xs:string
BIC Code
IBANNumber optional Restriction of xs:string
IBAN
Source
<xs:element name="Accounting" type="FII" minOccurs="0" maxOccurs="5" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NAD Complex Type | XML Einrichten Version 1.2


AdressGLN Element
XML Einrichten Version 1.2 > NAD Complex Type : AdressGLN Element
Description
GLN Code of the address
Namespace (none)
Diagram
AdressGLN Element
Overview
AdressGLN optional
GLN Code of the address
Source
<xs:element name="AdressGLN" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">GLN Nummer der Adresse </xs:documentation>
    <xs:documentation xml:lang="en">GLN Code of the address </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
NAD Complex Type | XML Einrichten Version 1.2


BusinessCustomerNumber Element
XML Einrichten Version 1.2 > NAD Complex Type : BusinessCustomerNumber Element
Namespace (none)
Type
BusinessCustomerNumber Simple Type
Diagram
BusinessCustomerNumber Element
Overview
BusinessCustomerNumber optional BusinessCustomerNumber Simple Type
Source
<xs:element name="BusinessCustomerNumber" type="BusinessCustomerNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NAD Complex Type | XML Einrichten Version 1.2


City Element
XML Einrichten Version 1.2 > NAD Complex Type : City Element
Description
City
Namespace (none)
Type
Restriction of xs:string
Diagram
City Element
Overview
City optional Restriction of xs:string
City
Source
<xs:element name="City" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Ort</xs:documentation>
    <xs:documentation xml:lang="en">City </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
NAD Complex Type | XML Einrichten Version 1.2


ContactPerson Element
XML Einrichten Version 1.2 > NAD Complex Type : ContactPerson Element
Namespace (none)
Type
Contact Complex Type
Diagram
CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element ContactCode Element ContactFirstName Element ContactSurName Element Sequence ContactPerson Element
Overview
ContactPerson optional Contact Complex Type
Sequence
ContactSurName optional Restriction of xs:string
Surname of the contact
ContactFirstName optional Restriction of xs:string
First name of the contact
ContactCode optional Restriction of xs:string
Ident of the contact
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
Source
<xs:element name="ContactPerson" type="Contact" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NAD Complex Type | XML Einrichten Version 1.2


ContractNumber Element
XML Einrichten Version 1.2 > NAD Complex Type : ContractNumber Element
Description
Contract number
Namespace (none)
Type
Restriction of xs:string
Diagram
ContractNumber Element
Overview
ContractNumber optional Restriction of xs:string
Contract number
Source
<xs:element name="ContractNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Abkommensnummer </xs:documentation>
    <xs:documentation xml:lang="en">Contract number </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
NAD Complex Type | XML Einrichten Version 1.2


DeliveryConditions Element
XML Einrichten Version 1.2 > NAD Complex Type : DeliveryConditions Element
Namespace (none)
Type
DeliveryCondition Simple Type
Diagram
DeliveryConditions Element
Overview
DeliveryConditions 0..10 DeliveryCondition Simple Type
Source
<xs:element name="DeliveryConditions" type="DeliveryCondition" minOccurs="0" maxOccurs="10" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NAD Complex Type | XML Einrichten Version 1.2


FlagOfParty Element
XML Einrichten Version 1.2 > NAD Complex Type : FlagOfParty Element
Description
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
Namespace (none)
Type
Restriction of xs:string
Diagram
FlagOfParty Element
Overview
FlagOfParty Restriction of xs:string
Adress Typ
Code list:
SU = Suppler address
BY = Buyers address
DP = Delivery address
UC = Delivery address end-consumer
IV = Invoice Recipient
UD = invoice recipient end-consumer
PL = Faktorer
MA = Assembly address
MF = Manufacturer- used for OTTO only
----- Transport -----
PO = Client of the transport orders
PW = Pick-Up address, delivery point
PF = Recipient of the freight invoice
FW = Selected carrier
Source
<xs:element name="FlagOfParty" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Adress Typ</dt>
        <dt>Codeliste:</dt>
        <dt>SU = Lieferant</dt>
        <dt>BY = Käufer</dt>
        <dt>DP = Lieferadresse</dt>
        <dt>UC = Lieferadresse Endkunde</dt>
        <dt>IV = Rechnungsempfänger der Warenrechnung</dt>
        <dt>UD = Rechnungsadresse Endkunde, falls abweichend von UC</dt>
        <dt>PL = Zentralregulierer</dt>
        <dt>MA = fMontageadresse</dt>
        <dt>MF = Hersteller - nur für die Kimmunikation mit OTTO</dt>
        <dt>----- Transport -----</dt>
        <dt>PO = Auftraggeber des Transportauftrags</dt>
        <dt>PW = Abholadresse, Übergabeort</dt>
        <dt>PF = Empfänger der Frachtrechnung</dt>
        <dt>FW = Ausgewähltes Transportunternehmen</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Adress Typ</dt>
        <dt>Code list:</dt>
        <dt>SU = Suppler address</dt>
        <dt>BY = Buyers address</dt>
        <dt>DP = Delivery address</dt>
        <dt>UC = Delivery address end-consumer</dt>
        <dt>IV = Invoice Recipient</dt>
        <dt>UD = invoice recipient end-consumer</dt>
        <dt>PL = Faktorer</dt>
        <dt>MA = Assembly address</dt>
        <dt>MF = Manufacturer- used for OTTO only</dt>
        <dt>----- Transport -----</dt>
        <dt>PO = Client of the transport orders</dt>
        <dt>PW = Pick-Up address, delivery point</dt>
        <dt>PF = Recipient of the freight invoice</dt>
        <dt>FW = Selected carrier</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
      <xs:enumeration value="BY" />
      <xs:enumeration value="DP" />
      <xs:enumeration value="FW" />
      <xs:enumeration value="IV" />
      <xs:enumeration value="MA" />
      <xs:enumeration value="PF" />
      <xs:enumeration value="PL" />
      <xs:enumeration value="PO" />
      <xs:enumeration value="PW" />
      <xs:enumeration value="SU" />
      <xs:enumeration value="UC" />
      <xs:enumeration value="UD" />
      <xs:enumeration value="MF" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
NAD Complex Type | XML Einrichten Version 1.2


FurtherReferences Element
XML Einrichten Version 1.2 > NAD Complex Type : FurtherReferences Element
Description
e.g. depot number
Namespace (none)
Type
Restriction of xs:string
Diagram
FurtherReferences Element
Overview
FurtherReferences optional Restriction of xs:string
e.g. depot number
Source
<xs:element name="FurtherReferences" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">z.B. Depotnummer/Abladestelle </xs:documentation>
    <xs:documentation xml:lang="en">e.g. depot number </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
NAD Complex Type | XML Einrichten Version 1.2


ISOCountryCode Element
XML Einrichten Version 1.2 > NAD Complex Type : ISOCountryCode Element
Description
ISO Country Code
Namespace (none)
Type
Restriction of xs:string
Diagram
ISOCountryCode Element
Overview
ISOCountryCode optional Restriction of xs:string
ISO Country Code
Source
<xs:element name="ISOCountryCode" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">ISO Länderkennzeichen</xs:documentation>
    <xs:documentation xml:lang="en">ISO Country Code </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:length value="2" />
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
NAD Complex Type | XML Einrichten Version 1.2


Name1 Element
XML Einrichten Version 1.2 > NAD Complex Type : Name1 Element
Description
in case of Companies: Companyname
in case of Endusers: Firstname surname
Namespace (none)
Type
Restriction of xs:string
Diagram
Name1 Element
Overview
Name1 optional Restriction of xs:string
in case of Companies: Companyname
in case of Endusers: Firstname surname
Source
<xs:element name="Name1" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Bei Firmen:         Firmierung</dt>
        <dt>Bei Privatpersonen: Vorname Nachname</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>in case of Companies: Companyname</dt>
        <dt>in case of Endusers:  Firstname surname</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
NAD Complex Type | XML Einrichten Version 1.2


Name2 Element
XML Einrichten Version 1.2 > NAD Complex Type : Name2 Element
Description
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Namespace (none)
Type
Restriction of xs:string
Diagram
Name2 Element
Overview
Name2 optional Restriction of xs:string
in case of Companies: Continuation of the Companyname
in case of Endusers: empty
Source
<xs:element name="Name2" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Bei Firmen:         Fortsetzung der Firmierung</dt>
        <dt>Bei Privatpersonen: leer</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>in case of Companies: Continuation of the Companyname</dt>
        <dt>in case of Endusers:  empty</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
NAD Complex Type | XML Einrichten Version 1.2


Name3 Element
XML Einrichten Version 1.2 > NAD Complex Type : Name3 Element
Description
in case of Companies: Empty
in case of Endusers: First name
Namespace (none)
Type
Restriction of xs:string
Diagram
Name3 Element
Overview
Name3 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: First name
Source
<xs:element name="Name3" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Bei Firmen:         Leer</dt>
        <dt>Bei Privatpersonen: Vorname</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>in case of Companies: Empty</dt>
        <dt>in case of Endusers:  First name</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
NAD Complex Type | XML Einrichten Version 1.2


Name4 Element
XML Einrichten Version 1.2 > NAD Complex Type : Name4 Element
Description
in case of Companies: Empty
in case of Endusers: Surname
Namespace (none)
Type
Restriction of xs:string
Diagram
Name4 Element
Overview
Name4 optional Restriction of xs:string
in case of Companies: Empty
in case of Endusers: Surname
Source
<xs:element name="Name4" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Bei Firmen:         Leer</dt>
        <dt>Bei Privatpersonen: Nachname</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>in case of Companies: Empty</dt>
        <dt>in case of Endusers:  Surname</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
NAD Complex Type | XML Einrichten Version 1.2


OpeningHours Element
XML Einrichten Version 1.2 > NAD Complex Type : OpeningHours Element
Namespace (none)
Type
OpeningPeriod Complex Type
Diagram
OpeningHours Element
Overview
OpeningHours 0..9 OpeningPeriod Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OpeningHours" type="OpeningPeriod" minOccurs="0" maxOccurs="9" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NAD Complex Type | XML Einrichten Version 1.2


PostalCode Element
XML Einrichten Version 1.2 > NAD Complex Type : PostalCode Element
Description
Zip Code
Namespace (none)
Type
Restriction of xs:string
Diagram
PostalCode Element
Overview
PostalCode optional Restriction of xs:string
Zip Code
Source
<xs:element name="PostalCode" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Postleiztahl</xs:documentation>
    <xs:documentation xml:lang="en">Zip Code </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="17" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
NAD Complex Type | XML Einrichten Version 1.2


Street1 Element
XML Einrichten Version 1.2 > NAD Complex Type : Street1 Element
Description
Street
Namespace (none)
Type
Restriction of xs:string
Diagram
Street1 Element
Overview
Street1 optional Restriction of xs:string
Street
Source
<xs:element name="Street1" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Strasse</xs:documentation>
    <xs:documentation xml:lang="en">Street </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
NAD Complex Type | XML Einrichten Version 1.2


StreetAddition Element
XML Einrichten Version 1.2 > NAD Complex Type : StreetAddition Element
Description
Additional information to the Street
Namespace (none)
Type
Restriction of xs:string
Diagram
StreetAddition Element
Overview
StreetAddition 0..3 Restriction of xs:string
Additional information to the Street
Source
<xs:element name="StreetAddition" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Zusatzinformationen zur Strasse</xs:documentation>
    <xs:documentation xml:lang="en">Additional information to the Street </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
NAD Complex Type | XML Einrichten Version 1.2


TaxId Element
XML Einrichten Version 1.2 > NAD Complex Type : TaxId Element
Namespace (none)
Type
TaxId Simple Type
Diagram
TaxId Element
Overview
TaxId optional TaxId Simple Type
Source
<xs:element name="TaxId" type="TaxId" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NAD Complex Type | XML Einrichten Version 1.2


VATId Element
XML Einrichten Version 1.2 > NAD Complex Type : VATId Element
Namespace (none)
Type
VATId Simple Type
Diagram
VATId Element
Overview
VATId optional VATId Simple Type
Source
<xs:element name="VATId" type="VATId" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NAD Complex Type | XML Einrichten Version 1.2


ZRNumber Element
XML Einrichten Version 1.2 > NAD Complex Type : ZRNumber Element
Namespace (none)
Type
ZRNumber Simple Type
Diagram
ZRNumber Element
Overview
ZRNumber optional ZRNumber Simple Type
Source
<xs:element name="ZRNumber" type="ZRNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NAD Complex Type | XML Einrichten Version 1.2


NetItemAmount Complex Type
XML Einrichten Version 1.2 : NetItemAmount Complex Type
Description
sum of all net position amounts
Namespace (none)
Base Type
Extension of CurrencyValue Complex Type
Diagram
Currency Element Value Element Sequence NetItemAmount Complex Type
Overview
NetItemAmount Extension of CurrencyValue Complex Type
sum of all net position amounts
Sequence
Value xs:decimal
Currency Currency Simple Type
Used By
NetItemAmount Element
Source
<xs:complexType name="NetItemAmount" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Summe aller Netto Positionseträge</xs:documentation>
    <xs:documentation xml:lang="en">sum of all net position amounts</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="CurrencyValue" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > NetItemAmount Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NetItemAmount Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > NetItemAmount Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NetItemAmount Complex Type | XML Einrichten Version 1.2


NetLineAmount Complex Type
XML Einrichten Version 1.2 : NetLineAmount Complex Type
Description
Net amount of a position (Net price*Quantity)
Namespace (none)
Base Type
Extension of CurrencyValue Complex Type
Diagram
Currency Element Value Element Sequence NetLineAmount Complex Type
Overview
NetLineAmount Extension of CurrencyValue Complex Type
Net amount of a position (Net price*Quantity)
Sequence
Value xs:decimal
Currency Currency Simple Type
Used By
NetLineAmount Element
NetLineAmount Element
NetLineAmount Element
NetLineAmount Element
NetLineAmount Element
NetLineAmount Element
Source
<xs:complexType name="NetLineAmount" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Netto Positionsbetrag (Nettoopreis*Menge </xs:documentation>
    <xs:documentation xml:lang="en">Net amount of a position (Net price*Quantity)</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="CurrencyValue" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > NetLineAmount Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NetLineAmount Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > NetLineAmount Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NetLineAmount Complex Type | XML Einrichten Version 1.2


NetUnitPrice Complex Type
XML Einrichten Version 1.2 : NetUnitPrice Complex Type
Description
Net price of an unit
Namespace (none)
Base Type
Extension of Price Complex Type
Diagram
PriceQuantity Element Currency Element Value Element Sequence NetUnitPrice Complex Type
Overview
NetUnitPrice Extension of Price Complex Type
Net price of an unit
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Used By
NetUnitPrice Element
NetUnitPrice Element
Source
<xs:complexType name="NetUnitPrice" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Netto Preis einer bestimmten Einheit </xs:documentation>
    <xs:documentation xml:lang="en">Net price of an unit</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="Price" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > NetUnitPrice Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NetUnitPrice Complex Type | XML Einrichten Version 1.2


PriceQuantity Element
XML Einrichten Version 1.2 > NetUnitPrice Complex Type : PriceQuantity Element
Description
Quantity related to the price information
Namespace (none)
Type
Quantity Complex Type
Diagram
PriceQuantity Element
Overview
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Source
<xs:element name="PriceQuantity" type="Quantity" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Preisberechnungsmenge</xs:documentation>
    <xs:documentation xml:lang="en">Quantity related to the price information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
NetUnitPrice Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > NetUnitPrice Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
NetUnitPrice Complex Type | XML Einrichten Version 1.2


OpeningPeriod Complex Type
XML Einrichten Version 1.2 : OpeningPeriod Complex Type
Description
Opening Hours, period during which a contact is available
DTM+306 = Working period
Qualifier 720 = THHMMTHHMM T=1=Monday
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
OpeningPeriod Complex Type
Overview
OpeningPeriod Restriction of EDIDate Complex Type
Opening Hours, period during which a contact is available
DTM+306 = Working period
Qualifier 720 = THHMMTHHMM T=1=Monday
FormatCode optional EDIDateFormatCode Simple Type
Used By
OpeningHours Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="OpeningPeriod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Öffnungszeit, Anlieferungszeit</dt>
        <dt>DTM+306 = Arbeitsperiode</dt>
        <dt>Qualifier 720 = THHMMTHHMM T=1=Montag</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Opening Hours, period during which a contact is available</dt>
        <dt>DTM+306 = Working period</dt>
        <dt>Qualifier 720 = THHMMTHHMM T=1=Monday</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


OPT Complex Type
XML Einrichten Version 1.2 : OPT Complex Type
Description
Segment for information about features and options for a single position
Namespace (none)
Diagram
NumericValue Element TextValue Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence OptionID Element Sequence Option Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element ParentFeatureLineNumber Element FeatureLineNumber Element Sequence OPT Complex Type
Overview
OPT
Segment for information about features and options for a single position
Sequence
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Used By
OPT Element
OPT Element
OPT Element
OPT Element
OPT Element
OPT Element
OPT Element
Source
<xs:complexType name="OPT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Segment für Varianteninformationen zu einer Position </xs:documentation>
    <xs:documentation xml:lang="en">Segment for information about features and options for a single position </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="FeatureLineNumber" minOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Fortlaufende nummereriung der Feature innerhalb einer Position </xs:documentation>
        <xs:documentation xml:lang="en">Sequential number of the feature within a line  </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:int">
          <xs:totalDigits value="6" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ParentFeatureLineNumber" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Referenz auf ein übergeordnetes Feature </xs:documentation>
        <xs:documentation xml:lang="en">reference to a superior feature </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:totalDigits value="6" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="FeatureID" type="ProductIdentifier" minOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Identifktaionen zu einem Feature </xs:documentation>
        <xs:documentation xml:lang="en">identification elements for a feature </xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="Option" type="Option" minOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Beschreibung der Option zu einem Feature </xs:documentation>
        <xs:documentation xml:lang="en">Description of the option according to the feature </xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Option Complex Type
XML Einrichten Version 1.2 : Option Complex Type
Description
Subsequent to a feature information
Namespace (none)
Diagram
NumericValue Element TextValue Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence OptionID Element Sequence Option Complex Type
Overview
Option
Subsequent to a feature information
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Used By
Option Element
Source
<xs:complexType name="Option" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Antwort auf eine Featureangabe </xs:documentation>
    <xs:documentation xml:lang="en">Subsequent to a feature information</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="OptionID" type="ProductIdentifier" minOccurs="0" />
    <xs:element name="TextValue" minOccurs="0" />
    <xs:element name="NumericValue" type="UnitValue" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


NumericValue Element
XML Einrichten Version 1.2 > Option Complex Type : NumericValue Element
Namespace (none)
Type
UnitValue Complex Type
Diagram
NumericValue Element
Overview
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="NumericValue" type="UnitValue" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Option Complex Type | XML Einrichten Version 1.2


OptionID Element
XML Einrichten Version 1.2 > Option Complex Type : OptionID Element
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence OptionID Element
Overview
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="OptionID" type="ProductIdentifier" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Option Complex Type | XML Einrichten Version 1.2


TextValue Element
XML Einrichten Version 1.2 > Option Complex Type : TextValue Element
Namespace (none)
Diagram
TextValue Element
Overview
TextValue optional
Source
<xs:element name="TextValue" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Option Complex Type | XML Einrichten Version 1.2


OrderLine Complex Type
XML Einrichten Version 1.2 : OrderLine Complex Type
Description
Line within an order
Namespace (none)
Base Type
Extension of DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence OrderLine Complex Type
Overview
OrderLine Extension of DocumentLineReference Complex Type
Line within an order
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:complexType name="OrderLine" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Position in einer Bestellung </xs:documentation>
    <xs:documentation xml:lang="en">Line within an order</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentLineReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


OrderLineNumberEndCustomer Complex Type
XML Einrichten Version 1.2 : OrderLineNumberEndCustomer Complex Type
Description
Line within an order of an end-consumer
Namespace (none)
Base Type
Extension of DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence OrderLineNumberEndCustomer Complex Type
Overview
OrderLineNumberEndCustomer Extension of DocumentLineReference Complex Type
Line within an order of an end-consumer
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:complexType name="OrderLineNumberEndCustomer" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Position in einer Bestellung eines Endkunden </xs:documentation>
    <xs:documentation xml:lang="en">Line within an order of an end-consumer</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentLineReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > OrderLineNumberEndCustomer Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OrderLineNumberEndCustomer Complex Type | XML Einrichten Version 1.2


DocRefLineNumber Element
XML Einrichten Version 1.2 > OrderLineNumberEndCustomer Complex Type : DocRefLineNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
DocRefLineNumber Element
Overview
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="DocRefLineNumber" type="LineItemNumber" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OrderLineNumberEndCustomer Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > OrderLineNumberEndCustomer Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OrderLineNumberEndCustomer Complex Type | XML Einrichten Version 1.2


OrderNumber Complex Type
XML Einrichten Version 1.2 : OrderNumber Complex Type
Description
Number of an order
Namespace (none)
Base Type
Extension of DocumentReference Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence OrderNumber Complex Type
Overview
OrderNumber Extension of DocumentReference Complex Type
Number of an order
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Used By
OrderNumberRef Element
OrderNumberRef Element
OrderNumberRef Element
OrderNumberRef Element
OrderNumberRef Element
Source
<xs:complexType name="OrderNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Bestellnummer </xs:documentation>
    <xs:documentation xml:lang="en">Number of an order</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > OrderNumber Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OrderNumber Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > OrderNumber Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OrderNumber Complex Type | XML Einrichten Version 1.2


OrderResponseDate Complex Type
XML Einrichten Version 1.2 : OrderResponseDate Complex Type
Description
Date of the an order response
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
OrderResponseDate Complex Type
Overview
OrderResponseDate Restriction of EDIDate Complex Type
Date of the an order response
FormatCode optional EDIDateFormatCode Simple Type
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="OrderResponseDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Datum der Bestellbestätigung </xs:documentation>
    <xs:documentation xml:lang="en">Date of the an order response</xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


OrderResponseLine Complex Type
XML Einrichten Version 1.2 : OrderResponseLine Complex Type
Description
Line within an order response
Namespace (none)
Base Type
Extension of DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence OrderResponseLine Complex Type
Overview
OrderResponseLine Extension of DocumentLineReference Complex Type
Line within an order response
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:complexType name="OrderResponseLine" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Position in einer Bestellbestätigung </xs:documentation>
    <xs:documentation xml:lang="en">Line within an order response</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentLineReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > OrderResponseLine Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OrderResponseLine Complex Type | XML Einrichten Version 1.2


DocRefLineNumber Element
XML Einrichten Version 1.2 > OrderResponseLine Complex Type : DocRefLineNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
DocRefLineNumber Element
Overview
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="DocRefLineNumber" type="LineItemNumber" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OrderResponseLine Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > OrderResponseLine Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OrderResponseLine Complex Type | XML Einrichten Version 1.2


OrderResponseNumberRef Complex Type
XML Einrichten Version 1.2 : OrderResponseNumberRef Complex Type
Description
reference to the number of the order response
Namespace (none)
Base Type
Extension of DocumentReference Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence OrderResponseNumberRef Complex Type
Overview
OrderResponseNumberRef Extension of DocumentReference Complex Type
reference to the number of the order response
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Used By
OrderResponseRef Element
Source
<xs:complexType name="OrderResponseNumberRef" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Referenz auf die Nummer der Auftragsbestätigung</xs:documentation>
    <xs:documentation xml:lang="en">reference to the number of the order response </xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > OrderResponseNumberRef Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OrderResponseNumberRef Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > OrderResponseNumberRef Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OrderResponseNumberRef Complex Type | XML Einrichten Version 1.2


OriginalOrder Complex Type
XML Einrichten Version 1.2 : OriginalOrder Complex Type
Description
Reference to the original order
Namespace (none)
Base Type
Extension of DocumentReference Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence OriginalOrder Complex Type
Overview
OriginalOrder Extension of DocumentReference Complex Type
Reference to the original order
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Used By
OriginalOrderRef Element
OriginalOrderRef Element
Source
<xs:complexType name="OriginalOrder" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Referenz auf die ursprüngliche Bestellung</xs:documentation>
    <xs:documentation xml:lang="en">Reference to the original order</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > OriginalOrder Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OriginalOrder Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > OriginalOrder Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OriginalOrder Complex Type | XML Einrichten Version 1.2


PaymentDate Complex Type
XML Einrichten Version 1.2 : PaymentDate Complex Type
Description
Date of payment
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
PaymentDate Complex Type
Overview
PaymentDate Restriction of EDIDate Complex Type
Date of payment
FormatCode optional EDIDateFormatCode Simple Type
Used By
PaymentDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="PaymentDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Bezahldatum </xs:documentation>
    <xs:documentation xml:lang="en">Date of payment </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


PickUpDate Complex Type
XML Einrichten Version 1.2 : PickUpDate Complex Type
Description
Pick up date
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
PickUpDate Complex Type
Overview
PickUpDate Restriction of EDIDate Complex Type
Pick up date
FormatCode optional EDIDateFormatCode Simple Type
Used By
PickUpDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="PickUpDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Pick up date </xs:documentation>
    <xs:documentation xml:lang="en">Pick up date </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


PreCustomerOrder Complex Type
XML Einrichten Version 1.2 : PreCustomerOrder Complex Type
Description
Number of the customer order in a previous system
Namespace (none)
Base Type
Extension of DocumentReference Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence PreCustomerOrder Complex Type
Overview
PreCustomerOrder Extension of DocumentReference Complex Type
Number of the customer order in a previous system
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:complexType name="PreCustomerOrder" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="en">Number of the customer order in a previous system </xs:documentation>
    <xs:documentation xml:lang="de">Nummer der Endkundenbestellung in einem vorgelagerten system</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


PreCustomerOrderLine Complex Type
XML Einrichten Version 1.2 : PreCustomerOrderLine Complex Type
Description
Number of position within the customer order in a previous system
Namespace (none)
Base Type
Extension of DocumentLineReference Complex Type
Diagram
DocRefLineNumber Element DocDate Element DocRefNumber Element Sequence PreCustomerOrderLine Complex Type
Overview
PreCustomerOrderLine Extension of DocumentLineReference Complex Type
Number of position within the customer order in a previous system
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:complexType name="PreCustomerOrderLine" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="en">Number of position within the customer order in a previous system </xs:documentation>
    <xs:documentation xml:lang="de">Nummer der Position einer Endkundenbestellung in einem vorgelagerten system</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentLineReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > PreCustomerOrderLine Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PreCustomerOrderLine Complex Type | XML Einrichten Version 1.2


DocRefLineNumber Element
XML Einrichten Version 1.2 > PreCustomerOrderLine Complex Type : DocRefLineNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
DocRefLineNumber Element
Overview
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="DocRefLineNumber" type="LineItemNumber" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PreCustomerOrderLine Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > PreCustomerOrderLine Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PreCustomerOrderLine Complex Type | XML Einrichten Version 1.2


PrevInvoice Complex Type
XML Einrichten Version 1.2 : PrevInvoice Complex Type
Description
Number of the previous invoice
Namespace (none)
Base Type
Extension of DocumentReference Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence PrevInvoice Complex Type
Overview
PrevInvoice Extension of DocumentReference Complex Type
Number of the previous invoice
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Used By
PrevInvoiceRef Element
Source
<xs:complexType name="PrevInvoice" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer der vroausgegangenen Rechnung </xs:documentation>
    <xs:documentation xml:lang="en">Number of the previous invoice</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > PrevInvoice Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PrevInvoice Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > PrevInvoice Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PrevInvoice Complex Type | XML Einrichten Version 1.2


PrevOrderResponse Complex Type
XML Einrichten Version 1.2 : PrevOrderResponse Complex Type
Description
Number of the previous order response
Namespace (none)
Base Type
Extension of DocumentReference Complex Type
Diagram
DocDate Element DocRefNumber Element Sequence PrevOrderResponse Complex Type
Overview
PrevOrderResponse Extension of DocumentReference Complex Type
Number of the previous order response
Sequence
DocRefNumber DocumentNumber Simple Type
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:complexType name="PrevOrderResponse" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer der vorausgegangenen Bestellbestätigung </xs:documentation>
    <xs:documentation xml:lang="en">Number of the previous order response</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="DocumentReference" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > PrevOrderResponse Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PrevOrderResponse Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > PrevOrderResponse Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PrevOrderResponse Complex Type | XML Einrichten Version 1.2


Price Complex Type
XML Einrichten Version 1.2 : Price Complex Type
Description
Price information
Namespace (none)
Base Type
Extension of CurrencyValue Complex Type
Diagram
PriceQuantity Element Currency Element Value Element Sequence Price Complex Type
Overview
Price Extension of CurrencyValue Complex Type
Price information
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Source
<xs:complexType name="Price" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Preisangabe </xs:documentation>
    <xs:documentation xml:lang="en">Price information</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="CurrencyValue">
      <xs:sequence>
        <xs:element name="PriceQuantity" type="Quantity" minOccurs="1" maxOccurs="1">
          <xs:annotation>
            <xs:documentation xml:lang="de">Preisberechnungsmenge</xs:documentation>
            <xs:documentation xml:lang="en">Quantity related to the price information</xs:documentation>
          </xs:annotation>
        </xs:element>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


PriceQualified Complex Type
XML Einrichten Version 1.2 : PriceQualified Complex Type
Description
Price information with a defined price type by a qualifier
Namespace (none)
Base Type
Extension of Price Complex Type
Diagram
Qualifier Element PriceQuantity Element Currency Element Value Element Sequence PriceQualified Complex Type
Overview
PriceQualified Extension of Price Complex Type
Price information with a defined price type by a qualifier
Sequence
Value xs:decimal
Currency Currency Simple Type
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Qualifier PriceQualifier Simple Type
Used By
AdditionalPrice Element
BuyingPrice Element
SalesPrice Element
BuyingPrice Element
SalesPrice Element
Source
<xs:complexType name="PriceQualified" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Preisangabe mit definierten Preistyp über einen Qualifer</xs:documentation>
    <xs:documentation xml:lang="en">Price information with a defined price type by a qualifier</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="Price">
      <xs:sequence>
        <xs:element name="Qualifier" type="PriceQualifier" minOccurs="1" maxOccurs="1" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > PriceQualified Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PriceQualified Complex Type | XML Einrichten Version 1.2


PriceQuantity Element
XML Einrichten Version 1.2 > PriceQualified Complex Type : PriceQuantity Element
Description
Quantity related to the price information
Namespace (none)
Type
Quantity Complex Type
Diagram
PriceQuantity Element
Overview
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Source
<xs:element name="PriceQuantity" type="Quantity" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Preisberechnungsmenge</xs:documentation>
    <xs:documentation xml:lang="en">Quantity related to the price information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PriceQualified Complex Type | XML Einrichten Version 1.2


Qualifier Element
XML Einrichten Version 1.2 > PriceQualified Complex Type : Qualifier Element
Namespace (none)
Type
PriceQualifier Simple Type
Diagram
Qualifier Element
Overview
Qualifier PriceQualifier Simple Type
Source
<xs:element name="Qualifier" type="PriceQualifier" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PriceQualified Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > PriceQualified Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PriceQualified Complex Type | XML Einrichten Version 1.2


ProcessingStates Complex Type
XML Einrichten Version 1.2 : ProcessingStates Complex Type
Description
Processig stat within serveral processing types
-----------------------------------------------
Mapping für Bahag
Category=2,Code=002:STS+1+5 = (MUSS)Bestellung erhalten
Category=2,Code=102:STS+1+275 = (MUSS)Stornoanfrage des Kunden bestätigt
Category=2,Code=103:STS+1+71 = (MUSS)Storno durch Kunde nicht mehr möglich
Category=2,Code=104:STS+1+56 = (MUSS)Storno durch Lieferant
Category=1,Code=201:STS+1+24 = (MUSS)Ware versendet
Category=1,Code=202:STS+1+21 = (MUSS)Ware mit Spedition versendet
Category=1,Code=301:STS+1+64 = (MUSS)Abholauftrag für Retoure erhalten
Category=1,Code=302:STS+1+82 = (MUSS)Retoure: Ware vor Ort
Category=1,Code=303:STS+1+13 = (KANN)Endkunde: Abholtermin bestätigt
Category=1,Code=401:STS+1+216 = (KANN)Endkunde nicht erreicht - schriftliche Benachrichtigung zur Terminavisierung
Category=1,Code=402:STS+1+243 = (KANN)Endkunde: Terminavisierung nicht möglich
Category=1,Code=403:STS+1+209 = (KANN)Endkunde: Liefertermin bestätig
Category=1,Code=404:STS+1+212 = (KANN)Endkunde: Liefertermin geändert
Category=1,Code=405:STS+1+210 = (KANN)Endkunde: Nicht angetroffen - zweite Lieferung avisiert
Category=1,Code=406:STS+1+325 = (KANN)Endkunde: Annahme der Lieferung verweigert
Category=1,Code=407:STS+1+73 = (KANN)Endkunde: Lieferung unvollständig - Nachlieferung avisiert
Category=3,Code=501:STS+1+80 = (MUSS)Retoure: Prüfung wurde bestanden
Category=3,Code=502:STS+1+81 = (MUSS)Retoure: Prüfung wurde nicht bestanden
Category=3,Code=503:STS+1+218 = (KANN)Endkunde:Ware beschädigt
Category=5,Code=601:FTX+ZZZ:1 = (MUSS)Kunde wünscht Gutschrift
Category=5,Code=602:FTX+ZZZ:2 = (MUSS)Kunde wünscht Ersatzlieferung
-----------------------------------------------
Mapping für Otto
Auftrag
Category=1,Code=201: SENT
Category=2,Code=101: CANCELED_BY_OTTO
Category=2,Code=104, Reason=001: CANCELED_TIMEOUT
Category=2,Code=104, Reason=101: CANCELED_NOT_AVAILABLE
Retoure
Category=1,Code=302: ARRIVED
Category=3,Code=501: ACCEPTED
Category=3,Code=502: REJECTED
Namespace (none)
Diagram
ProcessingStateDescription Element ProcessingStateReasonCode Element ProcessingStateCode Element ProcessingStateCategory Element Sequence ProcessingStates Complex Type
Overview
ProcessingStates
Processig stat within serveral processing types
-----------------------------------------------
Mapping für Bahag
Category=2,Code=002:STS+1+5 = (MUSS)Bestellung erhalten
Category=2,Code=102:STS+1+275 = (MUSS)Stornoanfrage des Kunden bestätigt
Category=2,Code=103:STS+1+71 = (MUSS)Storno durch Kunde nicht mehr möglich
Category=2,Code=104:STS+1+56 = (MUSS)Storno durch Lieferant
Category=1,Code=201:STS+1+24 = (MUSS)Ware versendet
Category=1,Code=202:STS+1+21 = (MUSS)Ware mit Spedition versendet
Category=1,Code=301:STS+1+64 = (MUSS)Abholauftrag für Retoure erhalten
Category=1,Code=302:STS+1+82 = (MUSS)Retoure: Ware vor Ort
Category=1,Code=303:STS+1+13 = (KANN)Endkunde: Abholtermin bestätigt
Category=1,Code=401:STS+1+216 = (KANN)Endkunde nicht erreicht - schriftliche Benachrichtigung zur Terminavisierung
Category=1,Code=402:STS+1+243 = (KANN)Endkunde: Terminavisierung nicht möglich
Category=1,Code=403:STS+1+209 = (KANN)Endkunde: Liefertermin bestätig
Category=1,Code=404:STS+1+212 = (KANN)Endkunde: Liefertermin geändert
Category=1,Code=405:STS+1+210 = (KANN)Endkunde: Nicht angetroffen - zweite Lieferung avisiert
Category=1,Code=406:STS+1+325 = (KANN)Endkunde: Annahme der Lieferung verweigert
Category=1,Code=407:STS+1+73 = (KANN)Endkunde: Lieferung unvollständig - Nachlieferung avisiert
Category=3,Code=501:STS+1+80 = (MUSS)Retoure: Prüfung wurde bestanden
Category=3,Code=502:STS+1+81 = (MUSS)Retoure: Prüfung wurde nicht bestanden
Category=3,Code=503:STS+1+218 = (KANN)Endkunde:Ware beschädigt
Category=5,Code=601:FTX+ZZZ:1 = (MUSS)Kunde wünscht Gutschrift
Category=5,Code=602:FTX+ZZZ:2 = (MUSS)Kunde wünscht Ersatzlieferung
-----------------------------------------------
Mapping für Otto
Auftrag
Category=1,Code=201: SENT
Category=2,Code=101: CANCELED_BY_OTTO
Category=2,Code=104, Reason=001: CANCELED_TIMEOUT
Category=2,Code=104, Reason=101: CANCELED_NOT_AVAILABLE
Retoure
Category=1,Code=302: ARRIVED
Category=3,Code=501: ACCEPTED
Category=3,Code=502: REJECTED
Sequence
ProcessingStateCategory Restriction of xs:string
Type of process status
1 = Transport
2 = Order managament
3 = Control result
4 = Publication
5 = Legal regulation
ProcessingStateCode Restriction of xs:string
ProcessingStateReasonCode optional Restriction of xs:string
Reason for the processing state
001 = Timed out
002 = Content difference
101 = Inventory difference
ProcessingStateDescription optional Restriction of xs:string
Description of the status
Used By
ProcessingStates Element
ProcessingStates Element
Source
<xs:complexType name="ProcessingStates" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Prozess Status in der jeweiligen Prozess Kategorie</dt>
        <dt>-----------------------------------------------</dt>
        <dt>Mapping für Bahag</dt>
        <dt>Category=2,Code=002:STS+1+5   = (MUSS)Bestellung erhalten</dt>
        <dt>Category=2,Code=102:STS+1+275 = (MUSS)Stornoanfrage des Kunden bestätigt</dt>
        <dt>Category=2,Code=103:STS+1+71  = (MUSS)Storno durch Kunde nicht mehr möglich</dt>
        <dt>Category=2,Code=104:STS+1+56  = (MUSS)Storno durch Lieferant</dt>
        <dt>Category=1,Code=201:STS+1+24  = (MUSS)Ware versendet</dt>
        <dt>Category=1,Code=202:STS+1+21  = (MUSS)Ware mit Spedition versendet</dt>
        <dt>Category=1,Code=301:STS+1+64  = (MUSS)Abholauftrag für Retoure erhalten</dt>
        <dt>Category=1,Code=302:STS+1+82  = (MUSS)Retoure: Ware vor Ort</dt>
        <dt>Category=1,Code=303:STS+1+13  = (KANN)Endkunde: Abholtermin bestätigt</dt>
        <dt>Category=1,Code=401:STS+1+216 = (KANN)Endkunde nicht erreicht - schriftliche Benachrichtigung zur Terminavisierung</dt>
        <dt>Category=1,Code=402:STS+1+243 = (KANN)Endkunde: Terminavisierung nicht möglich</dt>
        <dt>Category=1,Code=403:STS+1+209 = (KANN)Endkunde: Liefertermin bestätig</dt>
        <dt>Category=1,Code=404:STS+1+212 = (KANN)Endkunde: Liefertermin geändert</dt>
        <dt>Category=1,Code=405:STS+1+210 = (KANN)Endkunde: Nicht angetroffen - zweite Lieferung avisiert</dt>
        <dt>Category=1,Code=406:STS+1+325 = (KANN)Endkunde: Annahme der Lieferung verweigert</dt>
        <dt>Category=1,Code=407:STS+1+73  = (KANN)Endkunde: Lieferung unvollständig - Nachlieferung avisiert</dt>
        <dt>Category=3,Code=501:STS+1+80  = (MUSS)Retoure: Prüfung wurde bestanden</dt>
        <dt>Category=3,Code=502:STS+1+81  = (MUSS)Retoure: Prüfung wurde nicht bestanden</dt>
        <dt>Category=3,Code=503:STS+1+218 = (KANN)Endkunde:Ware beschädigt</dt>
        <dt>Category=5,Code=601:FTX+ZZZ:1 = (MUSS)Kunde wünscht Gutschrift</dt>
        <dt>Category=5,Code=602:FTX+ZZZ:2 = (MUSS)Kunde wünscht Ersatzlieferung</dt>
        <dt>-----------------------------------------------</dt>
        <dt>Mapping für Otto</dt>
        <dt>Auftrag</dt>
        <dt>Category=1,Code=201:          <OrderState>SENT</OrderState></dt>
        <dt>Auftragsstatus</dt>
        <dt>Category=2,Code=101:         <OrderState>CANCELED_BY_OTTO</OrderState></dt>
        <dt>Category=2,Code=104, Reason=001:   <OrderState>CANCELED_TIMEOUT</OrderState></dt>
        <dt>Category=2,Code=104, Reason=101:   <OrderState>CANCELED_NOT_AVAILABLE</OrderState></dt>
        <dt>Retoure</dt>
        <dt>Category=1,Code=302:        <OrderReturnStatus>ARRIVED</OrderReturnStatus></dt>
        <dt>Category=3,Code=501:        <OrderReturnStatus>ACCEPTED</OrderReturnStatus></dt>
        <dt>Category=3,Code=502:        <OrderReturnStatus>REJECTED</OrderReturnStatus></dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Processig stat within serveral processing types</dt>
        <dt>-----------------------------------------------</dt>
        <dt>Mapping für Bahag</dt>
        <dt>Category=2,Code=002:STS+1+5   = (MUSS)Bestellung erhalten</dt>
        <dt>Category=2,Code=102:STS+1+275 = (MUSS)Stornoanfrage des Kunden bestätigt</dt>
        <dt>Category=2,Code=103:STS+1+71  = (MUSS)Storno durch Kunde nicht mehr möglich</dt>
        <dt>Category=2,Code=104:STS+1+56  = (MUSS)Storno durch Lieferant</dt>
        <dt>Category=1,Code=201:STS+1+24  = (MUSS)Ware versendet</dt>
        <dt>Category=1,Code=202:STS+1+21  = (MUSS)Ware mit Spedition versendet</dt>
        <dt>Category=1,Code=301:STS+1+64  = (MUSS)Abholauftrag für Retoure erhalten</dt>
        <dt>Category=1,Code=302:STS+1+82  = (MUSS)Retoure: Ware vor Ort</dt>
        <dt>Category=1,Code=303:STS+1+13  = (KANN)Endkunde: Abholtermin bestätigt</dt>
        <dt>Category=1,Code=401:STS+1+216 = (KANN)Endkunde nicht erreicht - schriftliche Benachrichtigung zur Terminavisierung</dt>
        <dt>Category=1,Code=402:STS+1+243 = (KANN)Endkunde: Terminavisierung nicht möglich</dt>
        <dt>Category=1,Code=403:STS+1+209 = (KANN)Endkunde: Liefertermin bestätig</dt>
        <dt>Category=1,Code=404:STS+1+212 = (KANN)Endkunde: Liefertermin geändert</dt>
        <dt>Category=1,Code=405:STS+1+210 = (KANN)Endkunde: Nicht angetroffen - zweite Lieferung avisiert</dt>
        <dt>Category=1,Code=406:STS+1+325 = (KANN)Endkunde: Annahme der Lieferung verweigert</dt>
        <dt>Category=1,Code=407:STS+1+73  = (KANN)Endkunde: Lieferung unvollständig - Nachlieferung avisiert</dt>
        <dt>Category=3,Code=501:STS+1+80  = (MUSS)Retoure: Prüfung wurde bestanden</dt>
        <dt>Category=3,Code=502:STS+1+81  = (MUSS)Retoure: Prüfung wurde nicht bestanden</dt>
        <dt>Category=3,Code=503:STS+1+218 = (KANN)Endkunde:Ware beschädigt</dt>
        <dt>Category=5,Code=601:FTX+ZZZ:1 = (MUSS)Kunde wünscht Gutschrift</dt>
        <dt>Category=5,Code=602:FTX+ZZZ:2 = (MUSS)Kunde wünscht Ersatzlieferung</dt>
        <dt>-----------------------------------------------</dt>
        <dt>Mapping für Otto</dt>
        <dt></dt>
        <dt>Auftrag</dt>
        <dt>Category=1,Code=201:    <OrderState>SENT</OrderState></dt>
        <dt>Category=2,Code=101:    <OrderState>CANCELED_BY_OTTO</OrderState></dt>
        <dt>Category=2,Code=104,    Reason=001: <OrderState>CANCELED_TIMEOUT</OrderState></dt>
        <dt>Category=2,Code=104,    Reason=101: <OrderState>CANCELED_NOT_AVAILABLE</OrderState></dt>
        <dt>Retoure</dt>
        <dt>Category=1,Code=302:  <OrderReturnStatus>ARRIVED</OrderReturnStatus></dt>
        <dt>Category=3,Code=501:  <OrderReturnStatus>ACCEPTED</OrderReturnStatus></dt>
        <dt>Category=3,Code=502:  <OrderReturnStatus>REJECTED</OrderReturnStatus></dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="ProcessingStateCategory" minOccurs="1" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Art des Prozessstatus</dt>
            <dt></dt>
            <dt>1 = Transport</dt>
            <dt>2 = Auftragsabwicklung</dt>
            <dt>3 = Kontrollergebnis</dt>
            <dt>4 = Veröffentlichung</dt>
            <dt>5 = Gesetzesvorschrift</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>Type of process status</dt>
            <dt></dt>
            <dt>1 = Transport</dt>
            <dt>2 = Order managament</dt>
            <dt>3 = Control result</dt>
            <dt>4 = Publication</dt>
            <dt>5 = Legal regulation</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ProcessingStateCode" minOccurs="1" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Verarbeitungsstatus der Nachricht</dt>
            <dt>Codes für den Status: Auftragsabwicklung(ProcessingStateCategory: 2): </dt>
            <dt>Auftragsabwicklung(ProcessingStateCategory: 2): </dt>
            <dt>001 = An Kunde:    Bestellung Empfangen</dt>
            <dt>002 = An Kunde:    Bestellung Verarbeitet</dt>
            <dt>101 = An Lieferant:Storno durch Kunde</dt>
            <dt>102 = An Kunde:    Storno durch Kunde, vom Lieferant bestätigt</dt>
            <dt>103 = An Kunde:    Storno durch Kunde nicht mehr möglich</dt>
            <dt>104 = An Kunde:    Storno durch Lieferant</dt>
            <dt>105 = An Absender: Beleg verarbeitet</dt>
            <dt>106 = An Absender: Beleg abgelehnt</dt>
            <dt></dt>
            <dt>Transportabwicklung: (ProcessingStateCategory: 1)</dt>
            <dt>199 = An Kunde:    Neue Sendung erfasst (NEW)</dt>
            <dt>200 = An Kunde:    Sendung elektronisch übermittelt (EDI)</dt>
            <dt>201 = An Kunde:    Übergabe an den Paketversand (In Depot)</dt>
            <dt>202 = An Kunde:    Übergabe an den Spediteur</dt>
            <dt>203 = An Kunde:    Sendung hat das Depot verlassen (Out Depot)</dt>
            <dt>204 = An Kunde:    Sendung wird zum Empfänger transportiert (Load for Delivery)</dt>
            <dt>210 = An Kunde:    Sendung erfolgreich zugestellt (Delivered)</dt>
            <dt>301 = An Kunde:    Abholauftrag für Retoure erhalten</dt>
            <dt>302 = An Kunde:    Abholauftrag für Retoure ausgefühführt: Ware vor Ort</dt>
            <dt>303 = An Kunde:    Endkunde: Abholtermin bestätigt</dt>
            <dt>401 = An Kunde:    Endkunde nicht erreicht - schriftliche Benachrichtigung zur Terminavisierung</dt>
            <dt>402 = An Kunde:    Endkunde: Terminavisierung nicht möglich</dt>
            <dt>403 = An Kunde:    Endkunde: Liefertermin bestätig</dt>
            <dt>404 = An Kunde:    Endkunde: Liefertermin geändert</dt>
            <dt>405 = An Kunde:    Endkunde: Nicht angetroffen - zweite Lieferung avisiert</dt>
            <dt>406 = An Kunde:    Endkunde: Annahme der Lieferung verweigert</dt>
            <dt>407 = An Kunde:    Endkunde: Lieferung unvollständig - Nachlieferung avisiert</dt>
            <dt>411 = An Kunde:    Sendung konnte nicht zugestellt werden (Error)</dt>
            <dt>415 = An Kunde:    Allgemeine Information (Info)</dt>
            <dt>416 = An Kunde:    Die Zustellung verzögert sich (Warning)</dt>
            <dt>450 = An Kunde:    Endkunde: Lieferung vollständig erfolgt und vom Kunden bestätigt</dt>
            <dt></dt>
            <dt>Kontrollergebnis: (ProcessingStateCategory: 3)</dt>
            <dt>501 = An Kunde:    Retouren Prüfung bestanden</dt>
            <dt>502 = An Kunde:    Retouren Prüfung nicht bestanden</dt>
            <dt>503 = An Kunde:    Endkunde: Ware beschädigt</dt>
            <dt></dt>
            <dt>Rechtliche Abwicklung: (ProcessingStateCategory: 5)</dt>
            <dt>601 = An Kunde:    Kunde wünscht Gutschrift</dt>
            <dt>602 = An Kunde:    Kunde wünscht Ersatzlieferung</dt>
            <dt></dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ProcessingStateReasonCode" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Grund für den Prozessstatus</dt>
            <dt></dt>
            <dt>001 = Zeitüberschreitung</dt>
            <dt>002 = Inhaltliche Differenz</dt>
            <dt>101 = Lagerdifferenz</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>Reason for the processing state</dt>
            <dt></dt>
            <dt>001 = Timed out</dt>
            <dt>002 = Content difference</dt>
            <dt>101 = Inventory difference</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="ProcessingStateDescription" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Beschreibung des Prozessstatus</xs:documentation>
        <xs:documentation xml:lang="en">Description of the status </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="512" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


ProcessingStateCategory Element
XML Einrichten Version 1.2 > ProcessingStates Complex Type : ProcessingStateCategory Element
Description
Type of process status
1 = Transport
2 = Order managament
3 = Control result
4 = Publication
5 = Legal regulation
Namespace (none)
Type
Restriction of xs:string
Diagram
ProcessingStateCategory Element
Overview
ProcessingStateCategory Restriction of xs:string
Type of process status
1 = Transport
2 = Order managament
3 = Control result
4 = Publication
5 = Legal regulation
Source
<xs:element name="ProcessingStateCategory" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Art des Prozessstatus</dt>
        <dt></dt>
        <dt>1 = Transport</dt>
        <dt>2 = Auftragsabwicklung</dt>
        <dt>3 = Kontrollergebnis</dt>
        <dt>4 = Veröffentlichung</dt>
        <dt>5 = Gesetzesvorschrift</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Type of process status</dt>
        <dt></dt>
        <dt>1 = Transport</dt>
        <dt>2 = Order managament</dt>
        <dt>3 = Control result</dt>
        <dt>4 = Publication</dt>
        <dt>5 = Legal regulation</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ProcessingStates Complex Type | XML Einrichten Version 1.2


ProcessingStateCode Element
XML Einrichten Version 1.2 > ProcessingStates Complex Type : ProcessingStateCode Element
Namespace (none)
Type
Restriction of xs:string
Diagram
ProcessingStateCode Element
Overview
ProcessingStateCode Restriction of xs:string
Source
<xs:element name="ProcessingStateCode" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Verarbeitungsstatus der Nachricht</dt>
        <dt>Codes für den Status: Auftragsabwicklung(ProcessingStateCategory: 2): </dt>
        <dt>Auftragsabwicklung(ProcessingStateCategory: 2): </dt>
        <dt>001 = An Kunde:    Bestellung Empfangen</dt>
        <dt>002 = An Kunde:    Bestellung Verarbeitet</dt>
        <dt>101 = An Lieferant:Storno durch Kunde</dt>
        <dt>102 = An Kunde:    Storno durch Kunde, vom Lieferant bestätigt</dt>
        <dt>103 = An Kunde:    Storno durch Kunde nicht mehr möglich</dt>
        <dt>104 = An Kunde:    Storno durch Lieferant</dt>
        <dt>105 = An Absender: Beleg verarbeitet</dt>
        <dt>106 = An Absender: Beleg abgelehnt</dt>
        <dt></dt>
        <dt>Transportabwicklung: (ProcessingStateCategory: 1)</dt>
        <dt>199 = An Kunde:    Neue Sendung erfasst (NEW)</dt>
        <dt>200 = An Kunde:    Sendung elektronisch übermittelt (EDI)</dt>
        <dt>201 = An Kunde:    Übergabe an den Paketversand (In Depot)</dt>
        <dt>202 = An Kunde:    Übergabe an den Spediteur</dt>
        <dt>203 = An Kunde:    Sendung hat das Depot verlassen (Out Depot)</dt>
        <dt>204 = An Kunde:    Sendung wird zum Empfänger transportiert (Load for Delivery)</dt>
        <dt>210 = An Kunde:    Sendung erfolgreich zugestellt (Delivered)</dt>
        <dt>301 = An Kunde:    Abholauftrag für Retoure erhalten</dt>
        <dt>302 = An Kunde:    Abholauftrag für Retoure ausgefühführt: Ware vor Ort</dt>
        <dt>303 = An Kunde:    Endkunde: Abholtermin bestätigt</dt>
        <dt>401 = An Kunde:    Endkunde nicht erreicht - schriftliche Benachrichtigung zur Terminavisierung</dt>
        <dt>402 = An Kunde:    Endkunde: Terminavisierung nicht möglich</dt>
        <dt>403 = An Kunde:    Endkunde: Liefertermin bestätig</dt>
        <dt>404 = An Kunde:    Endkunde: Liefertermin geändert</dt>
        <dt>405 = An Kunde:    Endkunde: Nicht angetroffen - zweite Lieferung avisiert</dt>
        <dt>406 = An Kunde:    Endkunde: Annahme der Lieferung verweigert</dt>
        <dt>407 = An Kunde:    Endkunde: Lieferung unvollständig - Nachlieferung avisiert</dt>
        <dt>411 = An Kunde:    Sendung konnte nicht zugestellt werden (Error)</dt>
        <dt>415 = An Kunde:    Allgemeine Information (Info)</dt>
        <dt>416 = An Kunde:    Die Zustellung verzögert sich (Warning)</dt>
        <dt>450 = An Kunde:    Endkunde: Lieferung vollständig erfolgt und vom Kunden bestätigt</dt>
        <dt></dt>
        <dt>Kontrollergebnis: (ProcessingStateCategory: 3)</dt>
        <dt>501 = An Kunde:    Retouren Prüfung bestanden</dt>
        <dt>502 = An Kunde:    Retouren Prüfung nicht bestanden</dt>
        <dt>503 = An Kunde:    Endkunde: Ware beschädigt</dt>
        <dt></dt>
        <dt>Rechtliche Abwicklung: (ProcessingStateCategory: 5)</dt>
        <dt>601 = An Kunde:    Kunde wünscht Gutschrift</dt>
        <dt>602 = An Kunde:    Kunde wünscht Ersatzlieferung</dt>
        <dt></dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ProcessingStates Complex Type | XML Einrichten Version 1.2


ProcessingStateDescription Element
XML Einrichten Version 1.2 > ProcessingStates Complex Type : ProcessingStateDescription Element
Description
Description of the status
Namespace (none)
Type
Restriction of xs:string
Diagram
ProcessingStateDescription Element
Overview
ProcessingStateDescription optional Restriction of xs:string
Description of the status
Source
<xs:element name="ProcessingStateDescription" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Beschreibung des Prozessstatus</xs:documentation>
    <xs:documentation xml:lang="en">Description of the status </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="512" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ProcessingStates Complex Type | XML Einrichten Version 1.2


ProcessingStateReasonCode Element
XML Einrichten Version 1.2 > ProcessingStates Complex Type : ProcessingStateReasonCode Element
Description
Reason for the processing state
001 = Timed out
002 = Content difference
101 = Inventory difference
Namespace (none)
Type
Restriction of xs:string
Diagram
ProcessingStateReasonCode Element
Overview
ProcessingStateReasonCode optional Restriction of xs:string
Reason for the processing state
001 = Timed out
002 = Content difference
101 = Inventory difference
Source
<xs:element name="ProcessingStateReasonCode" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Grund für den Prozessstatus</dt>
        <dt></dt>
        <dt>001 = Zeitüberschreitung</dt>
        <dt>002 = Inhaltliche Differenz</dt>
        <dt>101 = Lagerdifferenz</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Reason for the processing state</dt>
        <dt></dt>
        <dt>001 = Timed out</dt>
        <dt>002 = Content difference</dt>
        <dt>101 = Inventory difference</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ProcessingStates Complex Type | XML Einrichten Version 1.2


ProductIdentifier Complex Type
XML Einrichten Version 1.2 : ProductIdentifier Complex Type
Description
Identification information for an article
Namespace (none)
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence ProductIdentifier Complex Type
Overview
ProductIdentifier
Identification information for an article
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Used By
OptionID Element
FeatureID Element
SeriesID Element
ProductID Element
SeriesID Element
ProductID Element
SeriesID Element
ProductID Element
SeriesID Element
ProductID Element
SeriesID Element
ProductID Element
SeriesID Element
ProductID Element
ProductID Element
SeriesID Element
SeriesID Element
ProductID Element
SeriesID Element
ProductID Element
Source
<xs:complexType name="ProductIdentifier" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Identifikationsangaben zu  eines Artkels </xs:documentation>
    <xs:documentation xml:lang="en">Identification information for an article</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="GTIN" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de"> = EAN Code </xs:documentation>
        <xs:documentation xml:lang="en"> = EAN Code </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:totalDigits value="14" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="Number" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Hersteller Nummer </xs:documentation>
        <xs:documentation xml:lang="en">Internal number defined by the manufacturer</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="70" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="Name" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Name </xs:documentation>
        <xs:documentation xml:lang="en">Name</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="70" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="CustomerNumber" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Nummer beim Kunden</xs:documentation>
        <xs:documentation xml:lang="en">Number at customers site</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="70" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
    <xs:element name="CustomerName" minOccurs="0">
      <xs:annotation>
        <xs:documentation xml:lang="de">Name beim Kunden </xs:documentation>
        <xs:documentation xml:lang="en">Name at customers site</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="70" />
        </xs:restriction>
      </xs:simpleType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


CustomerName Element
XML Einrichten Version 1.2 > ProductIdentifier Complex Type : CustomerName Element
Description
Name at customers site
Namespace (none)
Type
Restriction of xs:string
Diagram
CustomerName Element
Overview
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="CustomerName" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Name beim Kunden </xs:documentation>
    <xs:documentation xml:lang="en">Name at customers site</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="70" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ProductIdentifier Complex Type | XML Einrichten Version 1.2


CustomerNumber Element
XML Einrichten Version 1.2 > ProductIdentifier Complex Type : CustomerNumber Element
Description
Number at customers site
Namespace (none)
Type
Restriction of xs:string
Diagram
CustomerNumber Element
Overview
CustomerNumber optional Restriction of xs:string
Number at customers site
Source
<xs:element name="CustomerNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer beim Kunden</xs:documentation>
    <xs:documentation xml:lang="en">Number at customers site</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="70" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ProductIdentifier Complex Type | XML Einrichten Version 1.2


GTIN Element
XML Einrichten Version 1.2 > ProductIdentifier Complex Type : GTIN Element
Description
= EAN Code
Namespace (none)
Type
Restriction of xs:decimal
Diagram
GTIN Element
Overview
GTIN optional Restriction of xs:decimal
= EAN Code
Source
<xs:element name="GTIN" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> = EAN Code </xs:documentation>
    <xs:documentation xml:lang="en"> = EAN Code </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:decimal">
      <xs:totalDigits value="14" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ProductIdentifier Complex Type | XML Einrichten Version 1.2


Name Element
XML Einrichten Version 1.2 > ProductIdentifier Complex Type : Name Element
Description
Name
Namespace (none)
Type
Restriction of xs:string
Diagram
Name Element
Overview
Name optional Restriction of xs:string
Name
Source
<xs:element name="Name" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Name </xs:documentation>
    <xs:documentation xml:lang="en">Name</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="70" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ProductIdentifier Complex Type | XML Einrichten Version 1.2


Number Element
XML Einrichten Version 1.2 > ProductIdentifier Complex Type : Number Element
Description
Internal number defined by the manufacturer
Namespace (none)
Type
Restriction of xs:string
Diagram
Number Element
Overview
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Source
<xs:element name="Number" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Hersteller Nummer </xs:documentation>
    <xs:documentation xml:lang="en">Internal number defined by the manufacturer</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="70" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ProductIdentifier Complex Type | XML Einrichten Version 1.2


Quantity Complex Type
XML Einrichten Version 1.2 : Quantity Complex Type
Description
Quantity
Namespace (none)
Base Type
Extension of UnitValue Complex Type
Diagram
Quantity Complex Type
Overview
Quantity Extension of UnitValue Complex Type
Quantity
Unit optional Unit Simple Type
Used By
Quantity Element
PriceQuantity Element
PriceQuantity Element
PriceQuantity Element
PriceQuantity Element
InventoryQuantity Element
OrderQuantity Element
OrderQuantity Element
OrderResponseQuantity Element
OrderedQuantity Element
OrderResponseQuantity Element
QuantityExclusiveOfEvaluation Element
DespatchAdviceQuantity Element
OrderedQuantity Element
OrderResponseQuantity Element
ReceivingAdviceQuantity Element
QuantityExclusiveOfEvaluation Element
InvoiceQuantity Element
Attributes
Name | Type | Use | Default | Fixed | Description
Unit | Unit Simple Type | optional |  |  |
Source
<xs:complexType name="Quantity" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Menge </xs:documentation>
    <xs:documentation xml:lang="en">Quantity </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:extension base="UnitValue"></xs:extension>
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


QuantityQualified Complex Type
XML Einrichten Version 1.2 : QuantityQualified Complex Type
Description
Qualified quantity
Namespace (none)
Base Type
Extension of Quantity Complex Type
Diagram
QuantityQualified Complex Type
Overview
QuantityQualified Extension of Quantity Complex Type
Qualified quantity
Qualifier optional QuantityQualifier Simple Type
Unit optional Unit Simple Type
Used By
AdditionalQuantity Element
AdditionalQuantity Element
QuantityDeviation Element
QuantityDeviation Element
QuantityDeviation Element
AdditionalQuantity Element
Attributes
Name | Type | Use | Default | Fixed | Description
Qualifier | QuantityQualifier Simple Type | optional |  |  |
Unit | Unit Simple Type | optional |  |  |
Source
<xs:complexType name="QuantityQualified" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Qualifizierte Mengenangabe </xs:documentation>
    <xs:documentation xml:lang="en">Qualified quantity </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:extension base="Quantity">
      <xs:attribute name="Qualifier" type="QuantityQualifier" />
    </xs:extension>
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


ReceivingPaci Complex Type
XML Einrichten Version 1.2 : ReceivingPaci Complex Type
Description
Informationen zum gebuchten Wareneingang Information about the received packages
Namespace (none)
Diagram
ConsumerInstructions Element ShippingMark Element TypeOfShippingMark Element LoadingTackle Element TypeOfPackaging Element NumberOfPackages Element ParentPaciNumber Element PaciNumber Element Sequence ReceivingPaci Complex Type
Overview
ReceivingPaci
Informationen zum gebuchten Wareneingang Information about the received packages
Sequence
PaciNumber PackingPieceNumber Simple Type
ParentPaciNumber optional PackingPieceNumber Simple Type
NumberOfPackages optional NumberOfPackages Simple Type
TypeOfPackaging optional TypeOfPackaging Simple Type
LoadingTackle optional LoadingTackle Simple Type
TypeOfShippingMark optional TypeOfShippingMark Simple Type
ShippingMark optional ShippingMark Simple Type
ConsumerInstructions optional InstructionsConsumer Simple Type
Source
<xs:complexType name="ReceivingPaci" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>
      <xs:documentation xml:lang="de"> Informationen zum gebuchten  Wareneingang</xs:documentation>
      <xs:documentation xml:lang="en"> Information about the received packages</xs:documentation>
    </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="PaciNumber" type="PackingPieceNumber" minOccurs="1" />
    <xs:element name="ParentPaciNumber" type="PackingPieceNumber" minOccurs="0" />
    <xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" />
    <xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" />
    <xs:element name="LoadingTackle" type="LoadingTackle" minOccurs="0" />
    <xs:element name="TypeOfShippingMark" type="TypeOfShippingMark" minOccurs="0" />
    <xs:element name="ShippingMark" type="ShippingMark" minOccurs="0" />
    <xs:element name="ConsumerInstructions" type="InstructionsConsumer" minOccurs="0" />
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


ConsumerInstructions Element
XML Einrichten Version 1.2 > ReceivingPaci Complex Type : ConsumerInstructions Element
Namespace (none)
Type
InstructionsConsumer Simple Type
Diagram
ConsumerInstructions Element
Overview
ConsumerInstructions optional InstructionsConsumer Simple Type
Source
<xs:element name="ConsumerInstructions" type="InstructionsConsumer" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ReceivingPaci Complex Type | XML Einrichten Version 1.2


LoadingTackle Element
XML Einrichten Version 1.2 > ReceivingPaci Complex Type : LoadingTackle Element
Namespace (none)
Type
LoadingTackle Simple Type
Diagram
LoadingTackle Element
Overview
LoadingTackle optional LoadingTackle Simple Type
Source
<xs:element name="LoadingTackle" type="LoadingTackle" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ReceivingPaci Complex Type | XML Einrichten Version 1.2


NumberOfPackages Element
XML Einrichten Version 1.2 > ReceivingPaci Complex Type : NumberOfPackages Element
Namespace (none)
Type
NumberOfPackages Simple Type
Diagram
NumberOfPackages Element
Overview
NumberOfPackages optional NumberOfPackages Simple Type
Source
<xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ReceivingPaci Complex Type | XML Einrichten Version 1.2


PaciNumber Element
XML Einrichten Version 1.2 > ReceivingPaci Complex Type : PaciNumber Element
Namespace (none)
Type
PackingPieceNumber Simple Type
Diagram
PaciNumber Element
Overview
PaciNumber PackingPieceNumber Simple Type
Source
<xs:element name="PaciNumber" type="PackingPieceNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ReceivingPaci Complex Type | XML Einrichten Version 1.2


ParentPaciNumber Element
XML Einrichten Version 1.2 > ReceivingPaci Complex Type : ParentPaciNumber Element
Namespace (none)
Type
PackingPieceNumber Simple Type
Diagram
ParentPaciNumber Element
Overview
ParentPaciNumber optional PackingPieceNumber Simple Type
Source
<xs:element name="ParentPaciNumber" type="PackingPieceNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ReceivingPaci Complex Type | XML Einrichten Version 1.2


ShippingMark Element
XML Einrichten Version 1.2 > ReceivingPaci Complex Type : ShippingMark Element
Namespace (none)
Type
ShippingMark Simple Type
Diagram
ShippingMark Element
Overview
ShippingMark optional ShippingMark Simple Type
Source
<xs:element name="ShippingMark" type="ShippingMark" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ReceivingPaci Complex Type | XML Einrichten Version 1.2


TypeOfPackaging Element
XML Einrichten Version 1.2 > ReceivingPaci Complex Type : TypeOfPackaging Element
Namespace (none)
Type
TypeOfPackaging Simple Type
Diagram
TypeOfPackaging Element
Overview
TypeOfPackaging optional TypeOfPackaging Simple Type
Source
<xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ReceivingPaci Complex Type | XML Einrichten Version 1.2


TypeOfShippingMark Element
XML Einrichten Version 1.2 > ReceivingPaci Complex Type : TypeOfShippingMark Element
Namespace (none)
Type
TypeOfShippingMark Simple Type
Diagram
TypeOfShippingMark Element
Overview
TypeOfShippingMark optional TypeOfShippingMark Simple Type
Source
<xs:element name="TypeOfShippingMark" type="TypeOfShippingMark" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
ReceivingPaci Complex Type | XML Einrichten Version 1.2


RequestedDeliveryDate Complex Type
XML Einrichten Version 1.2 : RequestedDeliveryDate Complex Type
Description
Requested delivery date
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
RequestedDeliveryDate Complex Type
Overview
RequestedDeliveryDate Restriction of EDIDate Complex Type
Requested delivery date
FormatCode optional EDIDateFormatCode Simple Type
Used By
RequestedDeliveryDate Element
RequestedDeliveryDate Element
RequestedDeliveryDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="RequestedDeliveryDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Gewünschtes Lieferdatum </xs:documentation>
    <xs:documentation xml:lang="en">Requested delivery date </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


ShippingDate Complex Type
XML Einrichten Version 1.2 : ShippingDate Complex Type
Description
goods issue date/time
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
ShippingDate Complex Type
Overview
ShippingDate Restriction of EDIDate Complex Type
goods issue date/time
FormatCode optional EDIDateFormatCode Simple Type
Used By
ShippingDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="ShippingDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Warenausgagsdatum /-zeit </xs:documentation>
    <xs:documentation xml:lang="en">goods issue date/time</xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Textinformation Complex Type
XML Einrichten Version 1.2 : Textinformation Complex Type
Description
Qualified text information
Namespace (none)
Base Type
Extension of xs:string
Diagram
Textinformation Complex Type
Overview
Textinformation Extension of xs:string
Qualified text information
Type required Restriction of xs:string
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Used By
HeadText Element
LineText Element
Attributes
Name Type Use Default Fixed Description
Type Restriction of xs:string required
Freitext
Codeliste für Rechnungen
SUR = Text zur Entgeltminderung
REG = Text zur innergeimeischaftlichen Lieferung
AAB = Zahlungsbedingungen
AAI = Allgemeine Geschäftsbedingungen
AAR = Lieferbedingungen
-----------------------
Codeliste allgemein
TDT = Transportbemerkungen
ZZZ = Beidseitig vereinbart
Free text
Code list for invoice
SUR = Text about payment reduction
REG = Text about Intra-European delivery
AAB = Payment conditions
AAI = Terms of Service
AAR = Delivery conditions
-----------------------
Code list common
TDT = Remarks about delivery
ZZZ = bilateral agreed
Source
<xs:complexType name="Textinformation" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Qualifizierte Textinformation </xs:documentation>
    <xs:documentation xml:lang="en">Qualified text information</xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:extension base="xs:string">
      <xs:attribute name="Type" use="required">
        <xs:annotation>
          <xs:documentation xmlns:lang="de">
            <dl>
              <dt>Freitext</dt>
              <dt>Codeliste für Rechnungen</dt>
              <dt>SUR = Text zur Entgeltminderung</dt>
              <dt>REG = Text zur innergeimeischaftlichen Lieferung</dt>
              <dt>AAB = Zahlungsbedingungen</dt>
              <dt>AAI = Allgemeine Geschäftsbedingungen</dt>
              <dt>AAR = Lieferbedingungen</dt>
              <dt>-----------------------</dt>
              <dt>Codeliste allgemein</dt>
              <dt>TDT = Transportbemerkungen</dt>
              <dt>ZZZ = Beidseitig vereinbart</dt>
            </dl>
          </xs:documentation>
          <xs:documentation xmlns:lang="en">
            <dl>
              <dt>Free text</dt>
              <dt>Code list for invoice </dt>
              <dt>SUR = Text about payment reduction</dt>
              <dt>REG = Text about Intra-European delivery </dt>
              <dt>AAB = Payment conditions</dt>
              <dt>AAI = Terms of Service</dt>
              <dt>AAR = Delivery conditions</dt>
              <dt>-----------------------</dt>
              <dt>Code list common</dt>
              <dt>TDT = Remarks about delivery</dt>
              <dt>ZZZ = bilateral agreed</dt>
            </dl>
          </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:maxLength value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:attribute>
    </xs:extension>
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Times Complex Type
XML Einrichten Version 1.2 : Times Complex Type
Description
Zeitenangaben in den Lieferzeiten Times within the delivery times section
Namespace (none)
Diagram
DeliveryTime Element OrderDateUntil Element Sequence Times Complex Type
Overview
Times
Zeitenangaben in den Lieferzeiten Times within the delivery times section
Sequence
OrderDateUntil optional EDIDate Complex Type
For oders unti this date the subsequent delivery time is valid.
FormatCode optional EDIDateFormatCode Simple Type
DeliveryTime optional Duration Complex Type
Unit optional Unit Simple Type
Source
<xs:complexType name="Times" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>
      <xs:documentation xml:lang="de">Zeitenangaben in den Lieferzeiten</xs:documentation>
      <xs:documentation xml:lang="en">Times within the delivery times section</xs:documentation>
    </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="OrderDateUntil" type="EDIDate" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de"> Bei Bestellung bis zu diesem Datum gilt nachfolgende Lieferzeit.</xs:documentation>
        <xs:documentation xml:lang="en"> For oders unti this date the subsequent delivery time is valid.</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="DeliveryTime" type="Duration" minOccurs="0" maxOccurs="1" />
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DeliveryTime Element
XML Einrichten Version 1.2 > Times Complex Type : DeliveryTime Element
Namespace (none)
Type
Duration Complex Type
Diagram
DeliveryTime Element
Overview
DeliveryTime optional Duration Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="DeliveryTime" type="Duration" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Times Complex Type | XML Einrichten Version 1.2


OrderDateUntil Element
XML Einrichten Version 1.2 > Times Complex Type : OrderDateUntil Element
Description
For oders unti this date the subsequent delivery time is valid.
Namespace (none)
Type
EDIDate Complex Type
Diagram
OrderDateUntil Element
Overview
OrderDateUntil optional EDIDate Complex Type
For oders unti this date the subsequent delivery time is valid.
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="OrderDateUntil" type="EDIDate" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Bei Bestellung bis zu diesem Datum gilt nachfolgende Lieferzeit.</xs:documentation>
    <xs:documentation xml:lang="en"> For oders unti this date the subsequent delivery time is valid.</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
Times Complex Type | XML Einrichten Version 1.2


TotalAmount Complex Type
XML Einrichten Version 1.2 : TotalAmount Complex Type
Description
Total amount
Namespace (none)
Base Type
Extension of CurrencyValue Complex Type
Diagram
Currency Element Value Element Sequence TotalAmount Complex Type
Overview
TotalAmount Extension of CurrencyValue Complex Type
Total amount
Sequence
Value xs:decimal
Currency Currency Simple Type
Used By
CashDiscountAmount Element
Source
<xs:complexType name="TotalAmount" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Gesamtbetrag </xs:documentation>
    <xs:documentation xml:lang="en">Total amount</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="CurrencyValue" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


TotalAmountQualified Complex Type
XML Einrichten Version 1.2 : TotalAmountQualified Complex Type
Description
Qualified total amount
Namespace (none)
Base Type
Extension of TotalAmount Complex Type
Diagram
Qualifier Element Currency Element Value Element Sequence TotalAmountQualified Complex Type
Overview
TotalAmountQualified Extension of TotalAmount Complex Type
Qualified total amount
Sequence
Value xs:decimal
Currency Currency Simple Type
Qualifier TotalAmountQualifier Simple Type
Used By
AdditionalAmounts Element
AdditionalAmounts Element
AdditionalAmounts Element
AdditionalAmounts Element
AdditionalAmounts Element
Source
<xs:complexType name="TotalAmountQualified" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Gesamtbetrag qualifiziert</xs:documentation>
    <xs:documentation xml:lang="en">Qualified total amount</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="TotalAmount">
      <xs:sequence>
        <xs:element name="Qualifier" type="TotalAmountQualifier" minOccurs="1" maxOccurs="1" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > TotalAmountQualified Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
TotalAmountQualified Complex Type | XML Einrichten Version 1.2


Qualifier Element
XML Einrichten Version 1.2 > TotalAmountQualified Complex Type : Qualifier Element
Namespace (none)
Type
TotalAmountQualifier Simple Type
Diagram
Qualifier Element
Overview
Qualifier TotalAmountQualifier Simple Type
Source
<xs:element name="Qualifier" type="TotalAmountQualifier" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
TotalAmountQualified Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > TotalAmountQualified Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
TotalAmountQualified Complex Type | XML Einrichten Version 1.2


TotalLineAmount Complex Type
XML Einrichten Version 1.2 : TotalLineAmount Complex Type
Description
Total amountof a position
Namespace (none)
Base Type
Extension of TotalAmount Complex Type
Diagram
Currency Element Value Element Sequence TotalLineAmount Complex Type
Overview
TotalLineAmount Extension of TotalAmount Complex Type
Total amountof a position
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:complexType name="TotalLineAmount" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Gesamtbetrag einer POsition</xs:documentation>
    <xs:documentation xml:lang="en">Total amountof a position</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="TotalAmount" />
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > TotalLineAmount Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
TotalLineAmount Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > TotalLineAmount Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
TotalLineAmount Complex Type | XML Einrichten Version 1.2


UnitValue Complex Type
XML Einrichten Version 1.2 : UnitValue Complex Type
Description
Unit value
Namespace (none)
Base Type
Extension of xs:decimal
Diagram
UnitValue Complex Type
Overview
UnitValue Extension of xs:decimal
Unit value
Unit optional Unit Simple Type
Used By
NumericValue Element
Attributes
Name | Type | Use | Default | Fixed | Description
Unit | Unit Simple Type | optional |  |  |
Source
<xs:complexType name="UnitValue" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Wert in einer Einheit</xs:documentation>
    <xs:documentation xml:lang="en">Unit value</xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:extension base="xs:decimal">
      <xs:attribute name="Unit" form="unqualified" type="Unit" />
    </xs:extension>
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


ValueDate Complex Type
XML Einrichten Version 1.2 : ValueDate Complex Type
Description
Value date
Namespace (none)
Base Type
Restriction of EDIDate Complex Type
Diagram
ValueDate Complex Type
Overview
ValueDate Restriction of EDIDate Complex Type
Value date
FormatCode optional EDIDateFormatCode Simple Type
Used By
ValueDate Element
Attributes
Name | Type | Use | Default | Fixed | Description
FormatCode | EDIDateFormatCode Simple Type | optional |  |  |
Source
<xs:complexType name="ValueDate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Valuta Datum </xs:documentation>
    <xs:documentation xml:lang="en">Value date </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:restriction base="EDIDate" />
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Vat Complex Type
XML Einrichten Version 1.2 : Vat Complex Type
Description
Group to describe a tax
Namespace (none)
Diagram
Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence Vat Complex Type
Overview
Vat
Group to describe a tax
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
Used By
CorrectionVat Element
LineVat Element
LineVAT Element
LineVAT Element
LineVat Element
Source
<xs:complexType name="Vat" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Block zur Beschreibung einer Steuer </xs:documentation>
    <xs:documentation xml:lang="en">Group to describe a tax </xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="VatValue" type="CurrencyValue" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Betrag der Steuer </xs:documentation>
        <xs:documentation xml:lang="en">Tax Amount</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="VatPercentage" type="VatPercentage" minOccurs="1" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">Steuersatz </xs:documentation>
        <xs:documentation xml:lang="en">Tax rate</xs:documentation>
      </xs:annotation>
    </xs:element>
    <xs:element name="VatBase" type="CurrencyValue" minOccurs="0" maxOccurs="1">
      <xs:annotation>
        <xs:documentation xml:lang="de">
          <dl>
            <dt>Steuerpflichtiger Betrag zum jeweiligen Steuersatz</dt>
            <dt>Berechnung: Summer aller Netto Positionswerte - alle Rabatte</dt>
          </dl>
        </xs:documentation>
        <xs:documentation xml:lang="en">
          <dl>
            <dt>Vat base amount for a dedicated tax rate</dt>
            <dt>Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal</dt>
          </dl>
        </xs:documentation>
      </xs:annotation>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
XML Einrichten Version 1.2


VatTotal Complex Type
XML Einrichten Version 1.2 : VatTotal Complex Type
Description
Sum of all tax amounts
Namespace (none)
Base Type
Extension of Vat Complex Type
Diagram
Currency Element Value Element Sequence DiscountsConditionsTotal Element Currency Element Value Element Sequence NetItemAmount Element Currency Element Value Element Sequence VatBase Element VatPercentage Element Currency Element Value Element Sequence VatValue Element Sequence VatTotal Complex Type
Overview
VatTotal Extension of Vat Complex Type
Sum of all tax amounts
Sequence
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
VatPercentage VatPercentage Simple Type
Tax rate
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Used By
VatTotal Element
VatTotal Element
VatTotal Element
VatTotal Element
VatTotal Element
Source
<xs:complexType name="VatTotal" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Summe aller Steuerbeträge </xs:documentation>
    <xs:documentation xml:lang="en">Sum of all tax amounts</xs:documentation>
  </xs:annotation>
  <xs:complexContent>
    <xs:extension base="Vat">
      <xs:sequence>
        <xs:element name="NetItemAmount" type="NetItemAmount" minOccurs="1" maxOccurs="1" />
        <xs:element name="DiscountsConditionsTotal" type="DiscountsConditionsTotal" minOccurs="1" maxOccurs="1" />
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


DiscountsConditionsTotal Element
XML Einrichten Version 1.2 > VatTotal Complex Type : DiscountsConditionsTotal Element
Namespace (none)
Type
DiscountsConditionsTotal Complex Type
Diagram
Currency Element Value Element Sequence DiscountsConditionsTotal Element
Overview
DiscountsConditionsTotal DiscountsConditionsTotal Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="DiscountsConditionsTotal" type="DiscountsConditionsTotal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
VatTotal Complex Type | XML Einrichten Version 1.2


NetItemAmount Element
XML Einrichten Version 1.2 > VatTotal Complex Type : NetItemAmount Element
Namespace (none)
Type
NetItemAmount Complex Type
Diagram
Currency Element Value Element Sequence NetItemAmount Element
Overview
NetItemAmount NetItemAmount Complex Type
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="NetItemAmount" type="NetItemAmount" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
VatTotal Complex Type | XML Einrichten Version 1.2


VatBase Element
XML Einrichten Version 1.2 > VatTotal Complex Type : VatBase Element
Description
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Namespace (none)
Type
CurrencyValue Complex Type
Diagram
Currency Element Value Element Sequence VatBase Element
Overview
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="VatBase" type="CurrencyValue" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Steuerpflichtiger Betrag zum jeweiligen Steuersatz</dt>
        <dt>Berechnung: Summer aller Netto Positionswerte - alle Rabatte</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Vat base amount for a dedicated tax rate</dt>
        <dt>Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
VatTotal Complex Type | XML Einrichten Version 1.2


VatPercentage Element
XML Einrichten Version 1.2 > VatTotal Complex Type : VatPercentage Element
Description
Tax rate
Namespace (none)
Type
VatPercentage Simple Type
Diagram
VatPercentage Element
Overview
VatPercentage VatPercentage Simple Type
Tax rate
Source
<xs:element name="VatPercentage" type="VatPercentage" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Steuersatz </xs:documentation>
    <xs:documentation xml:lang="en">Tax rate</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
VatTotal Complex Type | XML Einrichten Version 1.2


VatValue Element
XML Einrichten Version 1.2 > VatTotal Complex Type : VatValue Element
Description
Tax Amount
Namespace (none)
Type
CurrencyValue Complex Type
Diagram
Currency Element Value Element Sequence VatValue Element
Overview
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="VatValue" type="CurrencyValue" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Betrag der Steuer </xs:documentation>
    <xs:documentation xml:lang="en">Tax Amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
VatTotal Complex Type | XML Einrichten Version 1.2


Weight Complex Type
XML Einrichten Version 1.2 : Weight Complex Type
Description
Weight
Namespace (none)
Base Type
Extension of UnitValue Complex Type
Diagram
Weight Complex Type
Overview
Weight Extension of UnitValue Complex Type
Weight
Unit optional Unit Simple Type
Attributes
Name | Type | Use | Default | Fixed | Description
Unit | Unit Simple Type | optional |  |  |
Source
<xs:complexType name="Weight" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Gewicht </xs:documentation>
    <xs:documentation xml:lang="en">Weight </xs:documentation>
  </xs:annotation>
  <xs:simpleContent>
    <xs:extension base="UnitValue"></xs:extension>
  </xs:simpleContent>
</xs:complexType>
See Also
XML Einrichten Version 1.2


Availability Simple Type
XML Einrichten Version 1.2 : Availability Simple Type
Description
Availabilty of the products
71 = Available
72 = Not Available
Namespace (none)
Type
Restriction of xs:string
Diagram
Availability Simple Type
Overview
Availability Restriction of xs:string
Availabilty of the products
71 = Available
72 = Not Available
Facets
MaxLength | 2
Enumeration | 71
Enumeration | 72
Source
<xs:simpleType name="Availability" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Verfügbarkeit des Artikels</dt>
        <dt>71 = Verfügbar</dt>
        <dt>72 = Nicht verfügbar</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Availabilty of the products</dt>
        <dt>71 = Available</dt>
        <dt>72 = Not Available</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="2" />
    <xs:enumeration value="71" />
    <xs:enumeration value="72" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


BarcodeNumber Simple Type
XML Einrichten Version 1.2 : BarcodeNumber Simple Type
Description
Unique barcode for this document
Namespace (none)
Type
Restriction of xs:string
Diagram
BarcodeNumber Simple Type
Overview
BarcodeNumber Restriction of xs:string
Unique barcode for this document
Facets
MaxLength 10
Source
<xs:simpleType name="BarcodeNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Eindeutige Barcodenummer für diesen Beleg</xs:documentation>
    <xs:documentation xml:lang="en"> Unique barcode for this document</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="10" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


BatchNumber Simple Type
XML Einrichten Version 1.2 : BatchNumber Simple Type
Description
Batch Number
Namespace (none)
Type
Restriction of xs:string
Diagram
BatchNumber Simple Type
Overview
BatchNumber Restriction of xs:string
Batch Number
Facets
MaxLength 35
Source
<xs:simpleType name="BatchNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Chargennummer </xs:documentation>
    <xs:documentation xml:lang="en"> Batch Number</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


BusinessCustomerNumber Simple Type
XML Einrichten Version 1.2 : BusinessCustomerNumber Simple Type
Description
Internal number of the buyer at the manufacturer
Namespace (none)
Type
Restriction of xs:string
Diagram
BusinessCustomerNumber Simple Type
Overview
BusinessCustomerNumber Restriction of xs:string
Internal number of the buyer at the manufacturer
Facets
MaxLength 17
Source
<xs:simpleType name="BusinessCustomerNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Interne Nummer des Köufers beim Hersteller</xs:documentation>
    <xs:documentation xml:lang="en"> Internal number of the buyer at the manufacturer</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="17" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


CatalogID Simple Type
XML Einrichten Version 1.2 : CatalogID Simple Type
Description
Catalogue Ident for the catalogue from which the order has been produced
Namespace (none)
Type
Restriction of xs:string
Diagram
CatalogID Simple Type
Overview
CatalogID Restriction of xs:string
Catalogue Ident for the catalogue from which the order has been produced
Source
<xs:simpleType name="CatalogID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Katalog Ident des IDM Katalogs aus dem die Konfiguration stammt</xs:documentation>
    <xs:documentation xml:lang="en">Catalogue Ident for the catalogue from which the order has been produced</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string" />
</xs:simpleType>
See Also
XML Einrichten Version 1.2


ClassOfGoodsFeature Simple Type
XML Einrichten Version 1.2 : ClassOfGoodsFeature Simple Type
Description
Feature
Namespace (none)
Type
Restriction of xs:string
Diagram
ClassOfGoodsFeature Simple Type
Overview
ClassOfGoodsFeature Restriction of xs:string
Feature
Facets
MaxLength 35
Source
<xs:simpleType name="ClassOfGoodsFeature" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Merkmal </xs:documentation>
    <xs:documentation xml:lang="en">Feature </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


ClassOfGoodsType Simple Type
XML Einrichten Version 1.2 : ClassOfGoodsType Simple Type
Description
classification schema
HS = customs tariff number
NB = Batch Number
STQ = eCl@ss
Namespace (none)
Type
Restriction of xs:string
Diagram
ClassOfGoodsType Simple Type
Overview
ClassOfGoodsType Restriction of xs:string
classification schema
HS = customs tariff number
NB = Batch Number
STQ = eCl@ss
Facets
MaxLength 15
Source
<xs:simpleType name="ClassOfGoodsType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Klassifikationsschema</dt>
        <dt>HS  = Zolltarifsystem</dt>
        <dt>NB  = Chargennummer</dt>
        <dt>STQ = eCl@ss</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>classification schema</dt>
        <dt>HS  = customs tariff number</dt>
        <dt>NB  = Batch Number</dt>
        <dt>STQ = eCl@ss</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="15" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


ClassOfGoodsValue Simple Type
XML Einrichten Version 1.2 : ClassOfGoodsValue Simple Type
Description
value within a classification
1. Ident within a classification (ClassofGoodsFeature stays empty)
2. option value for the specified feature (ClassofGoodsFeature is defined)
Namespace (none)
Type
Restriction of xs:string
Diagram
ClassOfGoodsValue Simple Type
Overview
ClassOfGoodsValue Restriction of xs:string
value within a classification
1. Ident within a classification (ClassofGoodsFeature stays empty)
2. option value for the specified feature (ClassofGoodsFeature is defined)
Facets
MaxLength 35
Source
<xs:simpleType name="ClassOfGoodsValue" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Klassifikationswert</dt>
        <dt>1. Ident innerhalb der Klassifikation (ClassofGoodsFeature bleit leer)</dt>
        <dt>2. Merkmalswert zu einem feature (ClassofGoodsFeature ist definiert)</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>value within a classification</dt>
        <dt>1. Ident within a classification (ClassofGoodsFeature stays empty)</dt>
        <dt>2. option value for the specified feature (ClassofGoodsFeature is defined)</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


Commission Simple Type
XML Einrichten Version 1.2 : Commission Simple Type
Description
Name (number) of the commission
Namespace (none)
Type
Restriction of xs:string
Diagram
Commission Simple Type
Overview
Commission Restriction of xs:string
Name (number) of the commission
Facets
MaxLength 35
Source
<xs:simpleType name="Commission" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Name / Nummer  der Kommsssion </xs:documentation>
    <xs:documentation xml:lang="en">Name (number) of the commission </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


CorrectionReason Simple Type
XML Einrichten Version 1.2 : CorrectionReason Simple Type
Description
Resaon for the correction
Grund für die Berichtigung
Code list:
1 = Vereinbarte Regulierung
7 = Akontozahlung
8 = Inklusive Gebühr für Mehrwegverpackung
17 = Transportschaden
19 = Handelsrabatt
21 = Werbekostenzuschuss
38 = Bonus
40 = Abzugsfähige Frachtkosten
15E = Delkredere
16E = Skonto
36E = Ständer- oder Regalauffüllservice
37E = Außerordentlicher Werbeservice
38E = Unterschiede im Steuersatz
Namespace (none)
Type
Restriction of xs:string
Diagram
CorrectionReason Simple Type
Overview
CorrectionReason Restriction of xs:string
Resaon for the correction
Grund für die Berichtigung
Code list:
1 = Vereinbarte Regulierung
7 = Akontozahlung
8 = Inklusive Gebühr für Mehrwegverpackung
17 = Transportschaden
19 = Handelsrabatt
21 = Werbekostenzuschuss
38 = Bonus
40 = Abzugsfähige Frachtkosten
15E = Delkredere
16E = Skonto
36E = Ständer- oder Regalauffüllservice
37E = Außerordentlicher Werbeservice
38E = Unterschiede im Steuersatz
Facets
MaxLength | 3
Enumeration | 1
Enumeration | 7
Enumeration | 8
Enumeration | 17
Enumeration | 19
Enumeration | 21
Enumeration | 38
Enumeration | 40
Enumeration | 15E
Enumeration | 16E
Enumeration | 36E
Enumeration | 37E
Enumeration | 38E
Source
<xs:simpleType name="CorrectionReason" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Grund für die Berichtigung</dt>
        <dt>Codeliste:</dt>
        <dt>  1 = Vereinbarte Regulierung</dt>
        <dt>  7 = Akontozahlung</dt>
        <dt>  8 = Inklusive Gebühr für Mehrwegverpackung</dt>
        <dt> 17 = Transportschaden</dt>
        <dt> 19 = Handelsrabatt</dt>
        <dt> 21 = Werbekostenzuschuss</dt>
        <dt> 38 = Bonus</dt>
        <dt> 40 = Abzugsfähige Frachtkosten</dt>
        <dt>15E = Delkredere</dt>
        <dt>16E = Skonto</dt>
        <dt>36E = Ständer- oder Regalauffüllservice</dt>
        <dt>37E = Außerordentlicher Werbeservice</dt>
        <dt>38E = Unterschiede im Steuersatz</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Resaon for the correction</dt>
        <dt>Grund für die Berichtigung</dt>
        <dt>Code list:</dt>
        <dt>  1 = Vereinbarte Regulierung</dt>
        <dt>  7 = Akontozahlung</dt>
        <dt>  8 = Inklusive Gebühr für Mehrwegverpackung</dt>
        <dt> 17 = Transportschaden</dt>
        <dt> 19 = Handelsrabatt</dt>
        <dt> 21 = Werbekostenzuschuss</dt>
        <dt> 38 = Bonus</dt>
        <dt> 40 = Abzugsfähige Frachtkosten</dt>
        <dt>15E = Delkredere</dt>
        <dt>16E = Skonto</dt>
        <dt>36E = Ständer- oder Regalauffüllservice</dt>
        <dt>37E = Außerordentlicher Werbeservice</dt>
        <dt>38E = Unterschiede im Steuersatz</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
    <xs:enumeration value="1" />
    <xs:enumeration value="7" />
    <xs:enumeration value="8" />
    <xs:enumeration value="17" />
    <xs:enumeration value="19" />
    <xs:enumeration value="21" />
    <xs:enumeration value="38" />
    <xs:enumeration value="40" />
    <xs:enumeration value="15E" />
    <xs:enumeration value="16E" />
    <xs:enumeration value="36E" />
    <xs:enumeration value="37E" />
    <xs:enumeration value="38E" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


Currency Simple Type
XML Einrichten Version 1.2 : Currency Simple Type
Description
currency coded. for example EUR
Namespace (none)
Type
Restriction of xs:string
Diagram
Currency Simple Type
Overview
Currency Restriction of xs:string
currency coded. for example EUR
Facets
MaxLength | 3
MinLength | 1
Source
<xs:simpleType name="Currency" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Währung kodiert z.B. EUR </xs:documentation>
    <xs:documentation xml:lang="en">currency coded. for example EUR </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
    <xs:minLength value="1" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


DeliveryCondition Simple Type
XML Einrichten Version 1.2 : DeliveryCondition Simple Type
Description
Delivery Conditions. Use the following code list
04E = Cash on delivery
Namespace (none)
Type
Restriction of xs:string
Diagram
DeliveryCondition Simple Type
Overview
DeliveryCondition Restriction of xs:string
Delivery Conditions. Use the following code list
04E = Cash on delivery
Facets
MaxLength | 3
Enumeration | 04E
Source
<xs:simpleType name="DeliveryCondition" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Liederbedingungen. Folgende Codes verwenden </dt>
        <dt>04E = Nachnahme</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Delivery Conditions. Use the following code list </dt>
        <dt>04E = Cash on delivery</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
    <xs:enumeration value="04E" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


DespatchAdviceNumber Simple Type
XML Einrichten Version 1.2 : DespatchAdviceNumber Simple Type
Description
despatch advise number
Namespace (none)
Type
Restriction of DocumentNumber Simple Type
Diagram
DespatchAdviceNumber Simple Type
Overview
DespatchAdviceNumber Restriction of DocumentNumber Simple Type
despatch advise number
Source
<xs:simpleType name="DespatchAdviceNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer des Lieferscheins </xs:documentation>
    <xs:documentation xml:lang="en">despatch advise number </xs:documentation>
  </xs:annotation>
  <xs:restriction base="DocumentNumber" />
</xs:simpleType>
See Also
XML Einrichten Version 1.2


DespatchNumber Simple Type
XML Einrichten Version 1.2 : DespatchNumber Simple Type
Description
Dispatch number
Namespace (none)
Type
Restriction of xs:string
Diagram
DespatchNumber Simple Type
Overview
DespatchNumber Restriction of xs:string
Dispatch number
Facets
MaxLength 35
Source
<xs:simpleType name="DespatchNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Versendenummer</xs:documentation>
    <xs:documentation xml:lang="en">Dispatch number </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


DirectionOfMovement Simple Type
XML Einrichten Version 1.2 : DirectionOfMovement Simple Type
Description
Movement of inventory
Code list:
1 = from stock
2 = to stock
Namespace (none)
Type
Restriction of xs:string
Diagram
DirectionOfMovement Simple Type
Overview
DirectionOfMovement Restriction of xs:string
Movement of inventory
Code list:
1 = from stock
2 = to stock
Facets
MaxLength | 1
Enumeration | 1
Enumeration | 2
Source
<xs:simpleType name="DirectionOfMovement" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Richtung der Bestandsbewegung</dt>
        <dl>Codeliste:</dl>
        <dt>1 = Lagerabgang</dt>
        <dt>2 = Lagerzugang</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Movement of inventory</dt>
        <dl>Code list:</dl>
        <dt>1 = from stock</dt>
        <dt>2 = to stock</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="1" />
    <xs:enumeration value="1" />
    <xs:enumeration value="2" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


DischargingTime Simple Type
XML Einrichten Version 1.2 : DischargingTime Simple Type
Description
Discharging Time
Namespace (none)
Type
Restriction of xs:decimal
Diagram
DischargingTime Simple Type
Overview
DischargingTime Restriction of xs:decimal
Discharging Time
Facets
TotalDigits 7
Source
<xs:simpleType name="DischargingTime" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Entladedauer</xs:documentation>
    <xs:documentation xml:lang="en">Discharging Time </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:decimal">
    <xs:totalDigits value="7" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


DischargingTimeMeasureUnit Simple Type
XML Einrichten Version 1.2 : DischargingTimeMeasureUnit Simple Type
Description
DTime unit for the discharging Time
Namespace (none)
Type
Restriction of xs:string
Diagram
DischargingTimeMeasureUnit Simple Type
Overview
DischargingTimeMeasureUnit Restriction of xs:string
DTime unit for the discharging Time
Facets
MaxLength 3
Source
<xs:simpleType name="DischargingTimeMeasureUnit" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Zeiteinheit der Entladedauer</xs:documentation>
    <xs:documentation xml:lang="en">DTime unit for the discharging Time </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


DocumentFunctionSymbol Simple Type
XML Einrichten Version 1.2 : DocumentFunctionSymbol Simple Type
Description
Document functional symbol
Code list:
Namespace (none)
Type
Restriction of xs:string
Diagram
DocumentFunctionSymbol Simple Type
Overview
DocumentFunctionSymbol Restriction of xs:string
Document functional symbol
Code list:
Facets
MaxLength | 3
Enumeration | 9
Enumeration | 2
Enumeration | 22
Enumeration | 29
Enumeration | 45
Enumeration | 1
Enumeration | 4
Enumeration | 5
Enumeration | 20
Source
<xs:simpleType name="DocumentFunctionSymbol" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Dokumentensteuerungskennzeichen</dt>
        <dt>Codeliste:</dt>
        <dt> 9 = Für alle Nachrichtenarten: Original</dt>
        <dt>ORDRSP</dt>
        <dt> 2 = ORDRSP AVIS:    Ergänzende Auftragsbestätigung. Ergänzende Informationen zu Verpackung und /oder Liefertermin. Keine Änderungen der Menge erlaubt</dt>
        <dt> 9 = ORDRSP Confirm: Bestätigung ohne weitere Angabe</dt>
        <dt>22 = ORDRSP FINAL:   Letzte Auftragsbestätigung. Ab jetzt kann der Auftrag nicht mehr geändert werden</dt>
        <dt>29 = ORDRSP Confirm: Auftrag ohne Änderungen bestätigt</dt>
        <dt>45 = ORDRSP Confirm: Auftrag mit Änderungen bestätigt (Menge, Liefertermin)</dt>
        <dt> ------------------</dt>
        <dt>ORDCHG</dt>
        <dt> 1 = ORDCHG Stornierung des Gesamtauftrags - alle Positionen werden storniert</dt>
        <dt> 4 = ORDCHG Änderung: Nachricht enthält geänderte Informationen auf Kopf oder auf Position. Es können alle Positionen oder auch nur Positionen mit Änderungen übertragen werden.</dt>
        <dt> 5 = ORDCHG Ersetzung: Dieser Auftrag ersetzt komplett den vorherigen Auftrag (Kopf und Positionen)</dt>
        <dt>20 = ORDCHG Ersetzung von Kopfinformationen, ORDCHG - Kopfänderung: Änderungen nur im Liefertermin oder Anlieferort erlaubt</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Document functional symbol</dt>
        <dt>Code list:</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
    <xs:enumeration value="9" />
    <xs:enumeration value="2" />
    <xs:enumeration value="22" />
    <xs:enumeration value="29" />
    <xs:enumeration value="45" />
    <xs:enumeration value="1" />
    <xs:enumeration value="4" />
    <xs:enumeration value="5" />
    <xs:enumeration value="20" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


DocumentNumber Simple Type
XML Einrichten Version 1.2 : DocumentNumber Simple Type
Description
Number of this document
Namespace (none)
Type
Restriction of xs:string
Diagram
DocumentNumber Simple Type
Overview
DocumentNumber Restriction of xs:string
Number of this document
Facets
MaxLength 35
Source
<xs:simpleType name="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer des Belegs</xs:documentation>
    <xs:documentation xml:lang="en">Number of this document </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


DocumentReferenceQualifier Simple Type
XML Einrichten Version 1.2 : DocumentReferenceQualifier Simple Type
Description
Qualified reference to another content
Code list:
ABO = Reference to to the commission
DQ = Reference to the despatch advise number
IV = Reference to the Invoice
LI = Reference to the position
ON = Reference to the order
POR = Reference to the order response
XCG = Reference to the GeoID(XcalibuR)
XCC = Reference to the ConfigID(XcalibuR)
FCID = Reference to the FurncloudID(furnplan)
FSC = Reference to the FSC Certificate
PEFC = Reference to the PEFC Certificate
Namespace (none)
Type
Restriction of xs:string
Diagram
DocumentReferenceQualifier Simple Type
Overview
DocumentReferenceQualifier Restriction of xs:string
Qualified reference to another content
Code list:
ABO = Reference to to the commission
DQ = Reference to the despatch advise number
IV = Reference to the Invoice
LI = Reference to the position
ON = Reference to the order
POR = Reference to the order response
XCG = Reference to the GeoID(XcalibuR)
XCC = Reference to the ConfigID(XcalibuR)
FCID = Reference to the FurncloudID(furnplan)
FSC = Reference to the FSC Certificate
PEFC = Reference to the PEFC Certificate
Facets
MaxLength 3
Source
<xs:simpleType name="DocumentReferenceQualifier" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Qualifizerte Referenzauf einen anderen Inhalt</dt>
        <dt>Codeliste: </dt>
        <dt>ABO  = Referenz auf die Kommission</dt>
        <dt>DQ   = Referenz auf die Lieferscheinnummer</dt>
        <dt>IV   = Referenz auf die Rechnung</dt>
        <dt>LI   = Referenz auf die Position</dt>
        <dt>ON   = Referenz auf den Auftrag</dt>
        <dt>POR  = Referenz auf die Auftragsbestätigung</dt>
        <dt>XCG  = Referenz auf die GeoID (XcalibuR)</dt>
        <dt>XCC  = Referenz auf die ConfigID (XcalibuR</dt>
        <dt>FCID = Referenz auf die FurncloudID (furnplan)</dt>
        <dt>FSC  = Referenz auf eine FSC Zertifikatsnummer</dt>
        <dt>PEFC = Referenz auf eine PEFC Zertifikatsnummer</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Qualified reference to another content</dt>
        <dt>Code list: </dt>
        <dt>ABO  = Reference to to the commission</dt>
        <dt>DQ   = Reference to the despatch advise number</dt>
        <dt>IV   = Reference to the Invoice</dt>
        <dt>LI   = Reference to the position</dt>
        <dt>ON   = Reference to the order</dt>
        <dt>POR  = Reference to the order response</dt>
        <dt>XCG  = Reference to the GeoID(XcalibuR)</dt>
        <dt>XCC  = Reference to the ConfigID(XcalibuR)</dt>
        <dt>FCID = Reference to the FurncloudID(furnplan)</dt>
        <dt>FSC  = Reference to the FSC Certificate</dt>
        <dt>PEFC = Reference to the PEFC Certificate</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


DocumentType Simple Type
XML Einrichten Version 1.2 : DocumentType Simple Type
Description
Type of the document
Code liste
35 = Inventory report
163 = Receiving advice
220 = Order
22E = Order generated by manufacturer
230 = Order response change
231 = Order Response
256 = Delivery Time report
348 = Order Status Report
351 = Dispatch advise
380 = Invoice
381 = Credit note
481 = Remittance advise
610 = Forwarding order
73E = Sales report
Namespace (none)
Type
Restriction of xs:string
Diagram
DocumentType Simple Type
Overview
DocumentType Restriction of xs:string
Type of the document
Code liste
35 = Inventory report
163 = Receiving advice
220 = Order
22E = Order generated by manufacturer
230 = Order response change
231 = Order Response
256 = Delivery Time report
348 = Order Status Report
351 = Dispatch advise
380 = Invoice
381 = Credit note
481 = Remittance advise
610 = Forwarding order
73E = Sales report
Facets
MaxLength | 3
Enumeration | 35
Enumeration | 163
Enumeration | 220
Enumeration | 221
Enumeration | 224
Enumeration | 226
Enumeration | 230
Enumeration | 256
Enumeration | 22E
Enumeration | 237
Enumeration | 380
Enumeration | 393
Enumeration | 381
Enumeration | 67
Enumeration | 83
Enumeration | 84
Enumeration | 384
Enumeration | 386
Enumeration | 73E
Enumeration | 231
Enumeration | 351
Enumeration | 481
Enumeration | 610
Enumeration | 325
Source
<xs:simpleType name="DocumentType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Belegart</dt>
        <dt>Codeliste </dt>
        <dt> 35 = Lagerbestandsbericht</dt>
        <dt>163 = Wareneingangsmeldung</dt>
        <dt>220 = Bestellung</dt>
        <dt>22E = Vom Hersteller erstellte Bestellung</dt>
        <dt>230 = Änderungsbestellung</dt>
        <dt>231 = Auftragsbestätigung</dt>
        <dt>256 = Lieferzeitenliste</dt>
        <dt>348 = Bestellstatusbericht</dt>
        <dt>351 = Lieferavis</dt>
        <dt>380 = Rechnung</dt>
        <dt>381 = Gutschrift</dt>
        <dt>481 = Zahlungsavis</dt>
        <dt>610 = Speditionsauftrag</dt>
        <dt>73E = Verkaufsbericht</dt>
        <dt>-------------------------</dt>
        <dt>Bislang ungenutzte Codes: </dt>
        <dt> 67 = Handelsunstimmigkeit (Reklamation)</dt>
        <dt> 83 = Wertgutschrift</dt>
        <dt> 84 = Wertbelastung</dt>
        <dt>221 = Rahmenauftrag</dt>
        <dt>224 = Eilauftrag</dt>
        <dt>226 = Abrufauftrag</dt>
        <dt>237 = Cross docking Bestellung</dt>
        <dt>325 = Proforma Rechnung</dt>
        <dt>386 = Vorauszahlungsrechnung</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Type of the document</dt>
        <dt>Code liste </dt>
        <dt> 35 = Inventory report</dt>
        <dt>163 = Receiving advice</dt>
        <dt>220 = Order</dt>
        <dt>22E = Order generated by manufacturer</dt>
        <dt>230 = Order response change</dt>
        <dt>231 = Order Response</dt>
        <dt>256 = Delivery Time report</dt>
        <dt>348 = Order Status Report</dt>
        <dt>351 = Dispatch advise</dt>
        <dt>380 = Invoice   </dt>
        <dt>381 = Credit note</dt>
        <dt>481 = Remittance advise</dt>
        <dt>610 = Forwarding order</dt>
        <dt>73E = Sales report</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
    <xs:enumeration value="35" />
    <xs:enumeration value="163" />
    <xs:enumeration value="220" />
    <xs:enumeration value="221" />
    <xs:enumeration value="224" />
    <xs:enumeration value="226" />
    <xs:enumeration value="230" />
    <xs:enumeration value="256" />
    <xs:enumeration value="22E" />
    <xs:enumeration value="237" />
    <xs:enumeration value="380" />
    <xs:enumeration value="393" />
    <xs:enumeration value="381" />
    <xs:enumeration value="67" />
    <xs:enumeration value="83" />
    <xs:enumeration value="84" />
    <xs:enumeration value="384" />
    <xs:enumeration value="386" />
    <xs:enumeration value="73E" />
    <xs:enumeration value="231" />
    <xs:enumeration value="351" />
    <xs:enumeration value="481" />
    <xs:enumeration value="610" />
    <xs:enumeration value="325" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


EDIDateFormatCode Simple Type
XML Einrichten Version 1.2 : EDIDateFormatCode Simple Type
Description
Code for the description of an date format
Code list:
102 = CCYYMMDD
201 = YYMMDDHHMM
615 = YYWW
616 = CCYYWW
720 = THHMMTHHMM
804 = Number of dayse
Example <DocumentDate FormatCode="102">20160331</DocumentDate>
Namespace (none)
Type
Restriction of xs:string
Diagram
EDIDateFormatCode Simple Type
Overview
EDIDateFormatCode Restriction of xs:string
Code for the description of an date format
Code list:
102 = CCYYMMDD
201 = YYMMDDHHMM
615 = YYWW
616 = CCYYWW
720 = THHMMTHHMM
804 = Number of dayse
Example <DocumentDate FormatCode="102">20160331</DocumentDate>
Facets
MaxLength 3
Source
<xs:simpleType name="EDIDateFormatCode" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Code zur Beschreibung des Datumsformats</dt>
        <dt>Codeliste: </dt>
        <dt>102 = CCYYMMDD</dt>
        <dt>201 = YYMMDDHHMM</dt>
        <dt>615 = YYWW</dt>
        <dt>616 = CCYYWW</dt>
        <dt>720 = THHMMTHHMM</dt>
        <dt>804 = Anzahl Tage</dt>
        <dt>Beispiel: &lt;DocumentDate FormatCode="102"&gt;20160331&lt;/DocumentDate&gt;</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Code for the description of an date format</dt>
        <dt>Code list: </dt>
        <dt>102 = CCYYMMDD</dt>
        <dt>201 = YYMMDDHHMM</dt>
        <dt>615 = YYWW</dt>
        <dt>616 = CCYYWW</dt>
        <dt>720 = THHMMTHHMM</dt>
        <dt>804 = Number of dayse</dt>
        <dt>Example &lt;DocumentDate FormatCode="102"&gt;20160331&lt;/DocumentDate&gt;</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


EDIDateQualifier Simple Type
XML Einrichten Version 1.2 : EDIDateQualifier Simple Type
Description
Code for the type of adate
Code list:
2 = Recommended delivery date
3 = Invoice date
4 = Order date
11 = Delivery datum
18 = date of assembly installation
35 = real delivery date
48 = Duration
63 = Latest delivery data
64 = Earliest delivery date
69 = Promised delivery date
76 = Confirmed delivery date
79 = Goods issue date
137 = date of the document
138 = Payment date
157 = Information valid from
171 = Reference date
209 = Value date
743 = Latest possible order changing date
Namespace (none)
Type
Restriction of xs:string
Diagram
EDIDateQualifier Simple Type
Overview
EDIDateQualifier Restriction of xs:string
Code for the type of adate
Code list:
2 = Recommended delivery date
3 = Invoice date
4 = Order date
11 = Delivery datum
18 = date of assembly installation
35 = real delivery date
48 = Duration
63 = Latest delivery data
64 = Earliest delivery date
69 = Promised delivery date
76 = Confirmed delivery date
79 = Goods issue date
137 = date of the document
138 = Payment date
157 = Information valid from
171 = Reference date
209 = Value date
743 = Latest possible order changing date
Facets
MaxLength 3
Source
<xs:simpleType name="EDIDateQualifier" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Code für den Datumstyp</dt>
        <dt>Codeliste: </dt>
        <dt>  2 = Gewünschtes Lieferdatum</dt>
        <dt>  3 = Rechnungsdatum</dt>
        <dt>  4 = Bestelldatum</dt>
        <dt> 11 = Warenlieferdatum</dt>
        <dt> 18 = Montagedatum, Installationsdatum</dt>
        <dt> 35 = Tatsächliches Lieferdatum</dt>
        <dt> 48 = Dauer</dt>
        <dt> 63 = Spätestes Lieferdatum</dt>
        <dt> 64 = Frühestes Lieferdatum</dt>
        <dt> 69 = Versprochenes Lieferdatum</dt>
        <dt> 76 = Bestätigter Liefertermin</dt>
        <dt> 79 = Warenausgangsdatum</dt>
        <dt>137 = Dokumentendatum</dt>
        <dt>138 = Bezahldatum</dt>
        <dt>157 = Information gültig ab</dt>
        <dt>171 = Referenzdatum</dt>
        <dt>209 = Valutadatum</dt>
        <dt>743 = Letztmögliches Änderungsdatum</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Code for the type of adate</dt>
        <dt>Code list: </dt>
        <dt>  2 = Recommended delivery date</dt>
        <dt>  3 = Invoice date</dt>
        <dt>  4 = Order date</dt>
        <dt> 11 = Delivery datum</dt>
        <dt> 18 = date of assembly installation</dt>
        <dt> 35 = real delivery date</dt>
        <dt> 48 = Duration</dt>
        <dt> 63 = Latest delivery data</dt>
        <dt> 64 = Earliest delivery date</dt>
        <dt> 69 = Promised delivery date</dt>
        <dt> 76 = Confirmed delivery date</dt>
        <dt> 79 = Goods issue date</dt>
        <dt>137 = date of the document</dt>
        <dt>138 = Payment date</dt>
        <dt>157 = Information valid from</dt>
        <dt>171 = Reference date</dt>
        <dt>209 = Value date</dt>
        <dt>743 = Latest possible order changing date</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


EmployeeID Simple Type
XML Einrichten Version 1.2 : EmployeeID Simple Type
Description
Employee ID of the salesman
Namespace (none)
Type
Restriction of xs:string
Diagram
EmployeeID Simple Type
Overview
EmployeeID Restriction of xs:string
Employee ID of the salesman
Facets
MaxLength 35
Source
<xs:simpleType name="EmployeeID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Personalnummer des Verkäufers</xs:documentation>
    <xs:documentation xml:lang="en">Employee ID of the salesman </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


ExchangeRate Simple Type
XML Einrichten Version 1.2 : ExchangeRate Simple Type
Description
Exchange Rate
Namespace (none)
Type
Restriction of xs:decimal
Diagram
ExchangeRate Simple Type
Overview
ExchangeRate Restriction of xs:decimal
Exchange Rate
Facets
TotalDigits | 12
FractionDigits | 6
Source
<xs:simpleType name="ExchangeRate" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Umrechnungskurs</xs:documentation>
    <xs:documentation xml:lang="en"> Exchange Rate</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:decimal">
    <xs:totalDigits value="12" />
    <xs:fractionDigits value="6" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


GoodsCountry Simple Type
XML Einrichten Version 1.2 : GoodsCountry Simple Type
Description
Country of origin
Namespace (none)
Type
Restriction of xs:string
Diagram
GoodsCountry Simple Type
Overview
GoodsCountry Restriction of xs:string
Country of origin
Facets
MaxLength 3
Source
<xs:simpleType name="GoodsCountry" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"> Herkunftsland</xs:documentation>
    <xs:documentation xml:lang="en"> Country of origin</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


GoodsReceiptNumber Simple Type
XML Einrichten Version 1.2 : GoodsReceiptNumber Simple Type
Description
Number of the goods receipt document
Namespace (none)
Type
Restriction of xs:string
Diagram
GoodsReceiptNumber Simple Type
Overview
GoodsReceiptNumber Restriction of xs:string
Number of the goods receipt document
Facets
MaxLength 35
Source
<xs:simpleType name="GoodsReceiptNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer des Wareneingangsbelegs</xs:documentation>
    <xs:documentation xml:lang="en">Number of the goods receipt document </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


IndicatorForDocumentLine Simple Type
XML Einrichten Version 1.2 : IndicatorForDocumentLine Simple Type
Namespace (none)
Type
Restriction of xs:string
Diagram
IndicatorForDocumentLine Simple Type
Overview
IndicatorForDocumentLine Restriction of xs:string
Facets
MaxLength 3
Source
<xs:simpleType name="IndicatorForDocumentLine" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"></xs:documentation>
    <xs:documentation xml:lang="en"></xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


InstructionsConsumer Simple Type
XML Einrichten Version 1.2 : InstructionsConsumer Simple Type
Description
Instruction for the end consumer
Namespace (none)
Type
Restriction of xs:string
Diagram
InstructionsConsumer Simple Type
Overview
InstructionsConsumer Restriction of xs:string
Instruction for the end consumer
Facets
MaxLength 70
Source
<xs:simpleType name="InstructionsConsumer" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nutzungsempfehlung fpr den Endkunde</xs:documentation>
    <xs:documentation xml:lang="en">Instruction for the end consumer </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="70" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


InventoryMethod Simple Type
XML Einrichten Version 1.2 : InventoryMethod Simple Type
Description
Method of inventory rating
Code list:
1 = booked inventory
2 = counted inventory
Namespace (none)
Type
Restriction of xs:string
Diagram
InventoryMethod Simple Type
Overview
InventoryMethod Restriction of xs:string
Method of inventory rating
Code list:
1 = booked inventory
2 = counted inventory
Facets
MaxLength | 1
Enumeration | 1
Enumeration | 2
Source
<xs:simpleType name="InventoryMethod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Methode der Bestandsbewertung</dt>
        <dt>Codeliste: </dt>
        <dt>1 = Buchbestand</dt>
        <dt>2 = Tatsächlicher Bestand</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Method of inventory rating</dt>
        <dt>Code list: </dt>
        <dt>1 = booked inventory </dt>
        <dt>2 = counted inventory </dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="1" />
    <xs:enumeration value="1" />
    <xs:enumeration value="2" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


InventoryQuantityUnit Simple Type
XML Einrichten Version 1.2 : InventoryQuantityUnit Simple Type
Description
Quantity unit of invetory
Namespace (none)
Type
Restriction of xs:string
Diagram
InventoryQuantityUnit Simple Type
Overview
InventoryQuantityUnit Restriction of xs:string
Quantity unit of invetory
Facets
MaxLength 35
Source
<xs:simpleType name="InventoryQuantityUnit" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Mengeneinheit des Bestands</xs:documentation>
    <xs:documentation xml:lang="en">Quantity unit of invetory </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


InventoryType Simple Type
XML Einrichten Version 1.2 : InventoryType Simple Type
Description
Type of inventory
Code list:
1 = Accepted inventory
2 = damaged inventory
3 = Customs inventory
4 = reserved Inventory
Namespace (none)
Type
Restriction of xs:string
Diagram
InventoryType Simple Type
Overview
InventoryType Restriction of xs:string
Type of inventory
Code list:
1 = Accepted inventory
2 = damaged inventory
3 = Customs inventory
4 = reserved Inventory
Facets
MaxLength | 1
Enumeration | 1
Enumeration | 2
Enumeration | 3
Enumeration | 4
Source
<xs:simpleType name="InventoryType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Bestandsart</dt>
        <dt>Codeliste: </dt>
        <dt>1 = Akzeptierter Warenbestand</dt>
        <dt>2 = Beschädigter Warenbestand</dt>
        <dt>3 = Zollbestand</dt>
        <dt>4 = Reservierter Bestand</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Type of inventory</dt>
        <dt>Code list: </dt>
        <dt>1 = Accepted inventory</dt>
        <dt>2 = damaged inventory</dt>
        <dt>3 = Customs inventory</dt>
        <dt>4 = reserved Inventory</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="1" />
    <xs:enumeration value="1" />
    <xs:enumeration value="2" />
    <xs:enumeration value="3" />
    <xs:enumeration value="4" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


InvoiceListNumber Simple Type
XML Einrichten Version 1.2 : InvoiceListNumber Simple Type
Description
Number of the invoice summary list
Namespace (none)
Type
Restriction of xs:string
Diagram
InvoiceListNumber Simple Type
Overview
InvoiceListNumber Restriction of xs:string
Number of the invoice summary list
Facets
MaxLength 35
Source
<xs:simpleType name="InvoiceListNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer der zusammenfassenden Rechnungsliste</xs:documentation>
    <xs:documentation xml:lang="en">Number of the invoice summary list </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


InvoiceNumber Simple Type
XML Einrichten Version 1.2 : InvoiceNumber Simple Type
Description
Number of the invoice
Namespace (none)
Type
Restriction of DocumentNumber Simple Type
Diagram
InvoiceNumber Simple Type
Overview
InvoiceNumber Restriction of DocumentNumber Simple Type
Number of the invoice
Source
<xs:simpleType name="InvoiceNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Rechnungsnummer</xs:documentation>
    <xs:documentation xml:lang="en">Number of the invoice </xs:documentation>
  </xs:annotation>
  <xs:restriction base="DocumentNumber" />
</xs:simpleType>
See Also
XML Einrichten Version 1.2


LicencePlateTrailer Simple Type
XML Einrichten Version 1.2 : LicencePlateTrailer Simple Type
Description
Plate of the trailer
Namespace (none)
Type
Restriction of xs:string
Diagram
LicencePlateTrailer Simple Type
Overview
LicencePlateTrailer Restriction of xs:string
Plate of the trailer
Facets
MaxLength 35
Source
<xs:simpleType name="LicencePlateTrailer" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kennzeichen des Anhängersr</xs:documentation>
    <xs:documentation xml:lang="en">Plate of the trailer </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


LicencePlateTruck Simple Type
XML Einrichten Version 1.2 : LicencePlateTruck Simple Type
Description
Plate of the truck
Namespace (none)
Type
Restriction of xs:string
Diagram
LicencePlateTruck Simple Type
Overview
LicencePlateTruck Restriction of xs:string
Plate of the truck
Facets
MaxLength 35
Source
<xs:simpleType name="LicencePlateTruck" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kennzeichen des Trucks</xs:documentation>
    <xs:documentation xml:lang="en">Plate of the truck </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


Liefermeldungsnummer Simple Type
XML Einrichten Version 1.2 : Liefermeldungsnummer Simple Type
Description
Number of the dispatch advise
Namespace (none)
Type
Restriction of xs:decimal
Diagram
Liefermeldungsnummer Simple Type
Overview
Liefermeldungsnummer Restriction of xs:decimal
Number of the dispatch advise
Facets
TotalDigits 35
Source
<xs:simpleType name="Liefermeldungsnummer" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer des Lieferscheins</xs:documentation>
    <xs:documentation xml:lang="en">Number of the dispatch advise </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:decimal">
    <xs:totalDigits value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


LineAmountQualifier Simple Type
XML Einrichten Version 1.2 : LineAmountQualifier Simple Type
Description
Amount of the position
Code list:
66 = Net value = Gross price*Quantity - Conditions
203 = Gross value = Gross price*Quantity Remark: No Tax included
131 = Sum of all discounts and allowances
Namespace (none)
Type
Restriction of xs:string
Diagram
LineAmountQualifier Simple Type
Overview
LineAmountQualifier Restriction of xs:string
Amount of the position
Code list:
66 = Net value = Gross price*Quantity - Conditions
203 = Gross value = Gross price*Quantity Remark: No Tax included
131 = Sum of all discounts and allowances
Facets
MaxLength | 3
MinLength | 1
Enumeration | 66
Enumeration | 203
Enumeration | 131
Source
<xs:simpleType name="LineAmountQualifier" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Positionsbetrag</dt>
        <dt>Codeliste:</dt>
        <dt> 66 = Netto Wert  = Brutto Preis*Menge - Konditionen (CNDL)</dt>
        <dt>203 = Brutto Wert = Brutto Preis*Menge  Hinweis: Immer ohne Steuer</dt>
        <dt>131 = Summe aller zu-/Abschläge  auf Positionsebene(CNDL)</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Amount of the position</dt>
        <dt>Code list:</dt>
        <dt> 66 = Net value   = Gross price*Quantity - Conditions</dt>
        <dt>203 = Gross value = Gross price*Quantity  Remark: No Tax included</dt>
        <dt>131 = Sum of all discounts and allowances</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
    <xs:minLength value="1" />
    <xs:enumeration value="66" />
    <xs:enumeration value="203" />
    <xs:enumeration value="131" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


LineItemNumber Simple Type
XML Einrichten Version 1.2 : LineItemNumber Simple Type
Description
Number of position in a document
Namespace (none)
Type
Restriction of xs:int
Diagram
LineItemNumber Simple Type
Overview
LineItemNumber Restriction of xs:int
Number of position in a document
Facets
TotalDigits 6
Source
<xs:simpleType name="LineItemNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer des Belegopsition</xs:documentation>
    <xs:documentation xml:lang="en">Number of position in a document </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:int">
    <xs:totalDigits value="6" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


LoadingTackle Simple Type
XML Einrichten Version 1.2 : LoadingTackle Simple Type
Description
Loading Tackle
Namespace (none)
Type
Restriction of xs:string
Diagram
LoadingTackle Simple Type
Overview
LoadingTackle Restriction of xs:string
Loading Tackle
Facets
MaxLength 3
Source
<xs:simpleType name="LoadingTackle" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Lademittel</xs:documentation>
    <xs:documentation xml:lang="en">Loading Tackle</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


LocationOfGoods Simple Type
XML Einrichten Version 1.2 : LocationOfGoods Simple Type
Description
Location of goods
Namespace (none)
Type
Restriction of xs:string
Diagram
LocationOfGoods Simple Type
Overview
LocationOfGoods Restriction of xs:string
Location of goods
Facets
MaxLength 35
Source
<xs:simpleType name="LocationOfGoods" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Wo befindet sich die Ware</xs:documentation>
    <xs:documentation xml:lang="en">Location of goods </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


NumberOfPackages Simple Type
XML Einrichten Version 1.2 : NumberOfPackages Simple Type
Description
Number of packing pieces
Namespace (none)
Type
Restriction of xs:int
Diagram
NumberOfPackages Simple Type
Overview
NumberOfPackages Restriction of xs:int
Number of packing pieces
Facets
TotalDigits 8
Source
<xs:simpleType name="NumberOfPackages" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Anzahl der Packstücke</xs:documentation>
    <xs:documentation xml:lang="en">Number of packing pieces </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:int">
    <xs:totalDigits value="8" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


NumberOfTheLeadWireSeal Simple Type
XML Einrichten Version 1.2 : NumberOfTheLeadWireSeal Simple Type
Description
Seal identifier
Namespace (none)
Type
Restriction of xs:string
Diagram
NumberOfTheLeadWireSeal Simple Type
Overview
NumberOfTheLeadWireSeal Restriction of xs:string
Seal identifier
Facets
MaxLength 35
Source
<xs:simpleType name="NumberOfTheLeadWireSeal" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer des Plombendrahts</xs:documentation>
    <xs:documentation xml:lang="en">Seal identifier </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


Orderability Simple Type
XML Einrichten Version 1.2 : Orderability Simple Type
Description
Is it possible to order the product
71 = yes
72 = No
Namespace (none)
Type
Restriction of xs:string
Diagram
Orderability Simple Type
Overview
Orderability Restriction of xs:string
Is it possible to order the product
71 = yes
72 = No
Facets
MaxLength | 2
Enumeration | 71
Enumeration | 72
Source
<xs:simpleType name="Orderability" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Kann der Artikel bestellt werden?</dt>
        <dt>71 = Bestellbar</dt>
        <dt>72 = Nicht bestellbar</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Is it possible to order the product</dt>
        <dt>71 = yes</dt>
        <dt>72 = No</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="2" />
    <xs:enumeration value="71" />
    <xs:enumeration value="72" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


OrderResponseLineItemNumber Simple Type
XML Einrichten Version 1.2 : OrderResponseLineItemNumber Simple Type
Description
Number of position in an order response
Namespace (none)
Type
Restriction of xs:decimal
Diagram
OrderResponseLineItemNumber Simple Type
Overview
OrderResponseLineItemNumber Restriction of xs:decimal
Number of position in an order response
Facets
TotalDigits 6
Source
<xs:simpleType name="OrderResponseLineItemNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer des Position in der Auftragsbestätigung</xs:documentation>
    <xs:documentation xml:lang="en">Number of position in an order response</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:decimal">
    <xs:totalDigits value="6" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


OrderResponseNumber Simple Type
XML Einrichten Version 1.2 : OrderResponseNumber Simple Type
Description
Number of the order response
Namespace (none)
Type
Restriction of DocumentNumber Simple Type
Diagram
OrderResponseNumber Simple Type
Overview
OrderResponseNumber Restriction of DocumentNumber Simple Type
Number of the order response
Source
<xs:simpleType name="OrderResponseNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer der Auftragbestätigung</xs:documentation>
    <xs:documentation xml:lang="en">Number of the order response </xs:documentation>
  </xs:annotation>
  <xs:restriction base="DocumentNumber" />
</xs:simpleType>
See Also
XML Einrichten Version 1.2


OrderType Simple Type
XML Einrichten Version 1.2 : OrderType Simple Type
Description
Type of the order
Code ist:
FURN000 = Standard order for stock delivery
FURN050 = Standard order in commission
FURN100 = Promotional goods
FURN200 = Basic equipment
FURN210 = Sample
FURN250 = new opening
FURN300 = Spare parts delivery free of charge
FURN350 = Spare parts delivery free with charge
FURN400 = Complaint order
Namespace (none)
Type
Restriction of xs:string
Diagram
OrderType Simple Type
Overview
OrderType Restriction of xs:string
Type of the order
Code ist:
FURN000 = Standard order for stock delivery
FURN050 = Standard order in commission
FURN100 = Promotional goods
FURN200 = Basic equipment
FURN210 = Sample
FURN250 = new opening
FURN300 = Spare parts delivery free of charge
FURN350 = Spare parts delivery free with charge
FURN400 = Complaint order
Facets
MaxLength | 7
Enumeration | FURN000
Enumeration | FURN050
Enumeration | FURN100
Enumeration | FURN200
Enumeration | FURN250
Enumeration | FURN300
Enumeration | FURN350
Enumeration | FURN400
Source
<xs:simpleType name="OrderType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Auftragsart</dt>
        <dt>Codeliste:</dt>
        <dt>FURN000 = Standard Lagerauftrag</dt>
        <dt>FURN050 = Standard Kommissionsauftrag</dt>
        <dt>FURN100 = Werbeware</dt>
        <dt>FURN200 = Erstausstattung</dt>
        <dt>FURN210 = Muster, Ausstellung, Platzierung</dt>
        <dt>FURN250 = Neueröffnung</dt>
        <dt>FURN300 = Ersatzteillieferung ohne Berechnung</dt>
        <dt>FURN350 = Ersatzteillieferung mit Berechnung</dt>
        <dt>FURN400 = Reklamationbestellung</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Type of the order</dt>
        <dt>Code ist:</dt>
        <dt>FURN000 = Standard order for stock delivery</dt>
        <dt>FURN050 = Standard order in commission</dt>
        <dt>FURN100 = Promotional goods</dt>
        <dt>FURN200 = Basic equipment</dt>
        <dt>FURN210 = Sample</dt>
        <dt>FURN250 = new opening</dt>
        <dt>FURN300 = Spare parts delivery free of charge</dt>
        <dt>FURN350 = Spare parts delivery free with charge</dt>
        <dt>FURN400 = Complaint order</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="7" />
    <xs:enumeration value="FURN000" />
    <xs:enumeration value="FURN050" />
    <xs:enumeration value="FURN100" />
    <xs:enumeration value="FURN200" />
    <xs:enumeration value="FURN250" />
    <xs:enumeration value="FURN300" />
    <xs:enumeration value="FURN350" />
    <xs:enumeration value="FURN400" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


PackingPieceNumber Simple Type
XML Einrichten Version 1.2 : PackingPieceNumber Simple Type
Description
Number of the packing piece
Namespace (none)
Type
Restriction of xs:string
Diagram
PackingPieceNumber Simple Type
Overview
PackingPieceNumber Restriction of xs:string
Number of the packing piece
Facets
MaxLength 12
Source
<xs:simpleType name="PackingPieceNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer des Packstücks</xs:documentation>
    <xs:documentation xml:lang="en">Number of the packing piece </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="12" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


PartialDelivery Simple Type
XML Einrichten Version 1.2 : PartialDelivery Simple Type
Description
Restrictions on partial delivery
Code list:
X2 = Partial delivery with subsequent delivery allowed
X1 = Partial delivery without subsequent delivery allowed
144 = KPartial delivery disallowed
Namespace (none)
Type
Restriction of xs:string
Diagram
PartialDelivery Simple Type
Overview
PartialDelivery Restriction of xs:string
Restrictions on partial delivery
Code list:
X2 = Partial delivery with subsequent delivery allowed
X1 = Partial delivery without subsequent delivery allowed
144 = KPartial delivery disallowed
Facets
MaxLength | 2
Enumeration | X2
Enumeration | X1
Source
<xs:simpleType name="PartialDelivery" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Einschänkungen zur Teillieferung</dt>
        <dt>Codeliste: </dt>
        <dt> X2 = Teillieferung mit Nachliefeerung erlaub</dt>
        <dt> X1 = Teillieferung ohne Nachliefeerung erlaubt</dt>
        <dt>144 = Keine Teillieferung erlaubt</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Restrictions on partial delivery</dt>
        <dt>Code list: </dt>
        <dt> X2 = Partial delivery  with subsequent delivery allowed</dt>
        <dt> X1 = Partial delivery  without subsequent delivery allowed</dt>
        <dt>144 = KPartial delivery  disallowed</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="2" />
    <xs:enumeration value="X2" />
    <xs:enumeration value="X1" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


PaymentType Simple Type
XML Einrichten Version 1.2 : PaymentType Simple Type
Description
Type of payment
Namespace (none)
Type
Restriction of xs:string
Diagram
PaymentType Simple Type
Overview
PaymentType Restriction of xs:string
Type of payment
Facets
MaxLength 3
Source
<xs:simpleType name="PaymentType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Bezahlungsmethode</xs:documentation>
    <xs:documentation xml:lang="en">Type of payment </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


PaymentWay Simple Type
XML Einrichten Version 1.2 : PaymentWay Simple Type
Description
Way of payment
Namespace (none)
Type
Restriction of xs:string
Diagram
PaymentWay Simple Type
Overview
PaymentWay Restriction of xs:string
Way of payment
Facets
MaxLength 3
Source
<xs:simpleType name="PaymentWay" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">?</xs:documentation>
    <xs:documentation xml:lang="en">Way of payment </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


PointOfSale Simple Type
XML Einrichten Version 1.2 : PointOfSale Simple Type
Description
Point of Sale (Identification by GLN possible)
Namespace (none)
Type
Restriction of xs:string
Diagram
PointOfSale Simple Type
Overview
PointOfSale Restriction of xs:string
Point of Sale (Identification by GLN possible)
Facets
MaxLength 17
Source
<xs:simpleType name="PointOfSale" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Adresse der Verkaufstelle (GLN möglich)</xs:documentation>
    <xs:documentation xml:lang="en">Point of Sale (Identification by GLN possible) </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="17" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


PositionFunctionSymbol Simple Type
XML Einrichten Version 1.2 : PositionFunctionSymbol Simple Type
Description
Flag how to process the Position especially in the ORDCHG - Please refer to the Anwendungsempfehlung
Head = 1: Cancellation of the total order - all positions are canceled
Head = 4: Message contains changed information on header or positions - All positions or only positions with changes could be transmitted
Head = 5: Replacement. All positions will be transmitted. Accurate image of the new order
Head = 20: Change in Head: Changes only in delivery date or delivery location
Use the following codes for the Position Function Symbol
1 = Position added (valid if HEAD = 4)
2 = Position canceled (valid if HEAD = 1,4)
3 = Position modified (valid if HEAD = 4,5)
11 = Position unmodified (valid if HEAD = 4,20)
Namespace (none)
Type
Restriction of xs:string
Diagram
PositionFunctionSymbol Simple Type
Overview
PositionFunctionSymbol Restriction of xs:string
Flag how to process the Position especially in the ORDCHG - Please refer to the Anwendungsempfehlung
Head = 1: Cancellation of the total order - all positions are canceled
Head = 4: Message contains changed information on header or positions - All positions or only positions with changes could be transmitted
Head = 5: Replacement. All positions will be transmitted. Accurate image of the new order
Head = 20: Change in Head: Changes only in delivery date or delivery location
Use the following codes for the Position Function Symbol
1 = Position added (valid if HEAD = 4)
2 = Position canceled (valid if HEAD = 1,4)
3 = Position modified (valid if HEAD = 4,5)
11 = Position unmodified (valid if HEAD = 4,20)
Facets
MaxLength | 3
Enumeration | 1
Enumeration | 2
Enumeration | 3
Enumeration | 11
Source
<xs:simpleType name="PositionFunctionSymbol" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Kennzeichen, relevant zur Steuerung der Positionsverarbeitung in der ORDCHG - Details siehe Anwendungsempfehlung</dt>
        <dt>Kopf =  1: Stornierung des Gesamtauftrags - alle Positionen werden storniert</dt>
        <dt>Kopf =  4: Nachricht enthält geänderte Informationen auf Kopf oder auf Position. Es können alle Positionen oder auch nur Positionen mit Änderungen übertragen werden.</dt>
        <dt>Kopf =  5: Ersetzung: Dieser Auftrag ersetzt komplett den vorherigen Auftrag (Kopf und Positionen)</dt>
        <dt>Kopf = 20: Kopfänderung: Änderungen nur im Liefertermin oder Anlieferort erlaubt</dt>
        <dt>--------------------------------------------------------------------------------</dt>
        <dt>Codeliste: </dt>
        <dt> 1 = Position hinzugefügt   (gültig wenn Kopf   = 4)</dt>
        <dt> 2 = Position storniert   (gültig wenn Kopf   = 1,4)</dt>
        <dt> 3 = Position geändert     (gültig wenn Kopf   = 4,5)</dt>
        <dt>11 = Position unverändert  (gültig wenn Kopf   = 4,20)</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Flag how to process the Position especially in the ORDCHG - Please refer to the Anwendungsempfehlung</dt>
        <dt>Head = 1: Cancellation of the total order - all positions are canceled</dt>
        <dt>Head = 4: Message contains changed information on header or positions - All positions or only positions with changes could be transmitted</dt>
        <dt>Head = 5: Replacement. All positions will be transmitted. Accurate image of the new order</dt>
        <dt>Head = 20: Change in Head: Changes only in delivery date or delivery location</dt>
        <dt></dt>
        <dt>Use the following codes for the Position Function Symbol</dt>
        <dt> 1 = Position added       (valid if HEAD   = 4)</dt>
        <dt> 2 = Position canceled    (valid if HEAD  = 1,4)</dt>
        <dt> 3 = Position modified    (valid if HEAD   = 4,5)</dt>
        <dt>11 = Position unmodified  (valid if HEAD   = 4,20)</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
    <xs:enumeration value="1" />
    <xs:enumeration value="2" />
    <xs:enumeration value="3" />
    <xs:enumeration value="11" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


PrepaidAmountOfLine Simple Type
XML Einrichten Version 1.2 : PrepaidAmountOfLine Simple Type
Description
Prepaid amount on position
Namespace (none)
Type
Restriction of xs:decimal
Diagram
PrepaidAmountOfLine Simple Type
Overview
PrepaidAmountOfLine Restriction of xs:decimal
Prepaid amount on position
Facets
TotalDigits | 15
FractionDigits | 3
Source
<xs:simpleType name="PrepaidAmountOfLine" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Vorauszahlungsbetrag auf der Positions</xs:documentation>
    <xs:documentation xml:lang="en">Prepaid amount on position</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:decimal">
    <xs:totalDigits value="15" />
    <xs:fractionDigits value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


PriceQualifier Simple Type
XML Einrichten Version 1.2 : PriceQualifier Simple Type
Description
Codes for definition of pricetypes
Code list:
AAA = Net price
AAB = Gross price
INF = Imformation only. not billed
Namespace (none)
Type
Restriction of xs:string
Diagram
PriceQualifier Simple Type
Overview
PriceQualifier Restriction of xs:string
Codes for definition of pricetypes
Code list:
AAA = Net price
AAB = Gross price
INF = Imformation only. not billed
Facets
MaxLength | 3
Enumeration | AAA
Enumeration | AAB
Enumeration | INF
Source
<xs:simpleType name="PriceQualifier" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Codes zu Preisangabe</dt>
        <dt>Codeliste: </dt>
        <dt>AAA = Netto Preis</dt>
        <dt>AAB = Brutto Preis</dt>
        <dt>INF = Preisnformation. Nicht berechneter Preis</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Codes for definition of pricetypes</dt>
        <dt>Code list: </dt>
        <dt>AAA = Net price</dt>
        <dt>AAB = Gross price</dt>
        <dt>INF = Imformation only. not billed</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
    <xs:enumeration value="AAA" />
    <xs:enumeration value="AAB" />
    <xs:enumeration value="INF" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


PromotionalGoodsNumber Simple Type
XML Einrichten Version 1.2 : PromotionalGoodsNumber Simple Type
Namespace (none)
Type
Restriction of xs:string
Diagram
PromotionalGoodsNumber Simple Type
Overview
PromotionalGoodsNumber Restriction of xs:string
Facets
MaxLength 35
Source
<xs:simpleType name="PromotionalGoodsNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de"></xs:documentation>
    <xs:documentation xml:lang="en"></xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


PromotionNumber Simple Type
XML Einrichten Version 1.2 : PromotionNumber Simple Type
Description
Identification of the promotion
Namespace (none)
Type
Restriction of xs:string
Diagram
PromotionNumber Simple Type
Overview
PromotionNumber Restriction of xs:string
Identification of the promotion
Facets
MaxLength 35
Source
<xs:simpleType name="PromotionNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kennung der Werbeaktion</xs:documentation>
    <xs:documentation xml:lang="en">Identification of the promotion</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


QTYVar Simple Type
XML Einrichten Version 1.2 : QTYVar Simple Type
Description
Information whether a product is variable in quantity
Code list:
VQ = yes
= no
Namespace (none)
Type
Restriction of xs:string
Diagram
QTYVar Simple Type
Overview
QTYVar Restriction of xs:string
Information whether a product is variable in quantity
Code list:
VQ = yes
= no
Facets
MaxLength | 2
Enumeration | VQ
Enumeration |
Source
<xs:simpleType name="QTYVar" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Angabe, ob der Artikel mengenvariabel ist</dt>
        <dt>Codeliset: </dt>
        <dt>VQ  = mengenvariabel</dt>
        <dt>    = nicht mengenvariabel</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Information whether a product is variable in quantity</dt>
        <dt>Code list: </dt>
        <dt>VQ  = yes</dt>
        <dt>    = no</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="2" />
    <xs:enumeration value="VQ" />
    <xs:enumeration value="" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


QuantityQualifier Simple Type
XML Einrichten Version 1.2 : QuantityQualifier Simple Type
Description
Code for definition of the type of a quantity
Code list:
12 = Delivered quantity
21 = ordered quantity
35 = Price calculation quantity
47 = Billed quantity
53 = Minimum order quantity
54 = Maximum order quantity
131 = confirmed order quantity
129 = Units per unit price
131 = Delivered quantity
182 = canceled quantity
Namespace (none)
Type
Restriction of xs:string
Diagram
QuantityQualifier Simple Type
Overview
QuantityQualifier Restriction of xs:string
Code for definition of the type of a quantity
Code list:
12 = Delivered quantity
21 = ordered quantity
35 = Price calculation quantity
47 = Billed quantity
53 = Minimum order quantity
54 = Maximum order quantity
131 = confirmed order quantity
129 = Units per unit price
131 = Delivered quantity
182 = canceled quantity
Facets
MaxLength 3
Source
<xs:simpleType name="QuantityQualifier" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Code zur Festlegung der Types einer Mengenangabe</dt>
        <dt>Codeliste:</dt>
        <dt> 12 = Gelieferte Menge</dt>
        <dt> 21 = Bestellte Menge</dt>
        <dt> 35 = Preisberechnungsmenge</dt>
        <dt> 47 = Rechnungsmenge</dt>
        <dt> 53 = Mindestbestellmenge</dt>
        <dt> 54 = Maximum der Bestellmenge</dt>
        <dt>129 = Einheiten pro Stückpreis</dt>
        <dt>131 = Bestätigte Menge</dt>
        <dt>131 = Liefermenge</dt>
        <dt>182 = Stornierte Menge</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Code for definition of the type of a quantity</dt>
        <dt>Code list:</dt>
        <dt> 12 = Delivered quantity</dt>
        <dt> 21 = ordered quantity</dt>
        <dt> 35 = Price calculation quantity</dt>
        <dt> 47 = Billed quantity</dt>
        <dt> 53 = Minimum order quantity</dt>
        <dt> 54 = Maximum order quantity</dt>
        <dt>131 = confirmed order quantity</dt>
        <dt>129 = Units per unit price</dt>
        <dt>131 = Delivered quantity</dt>
        <dt>182 = canceled quantity</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


RemittanceAdviceNumber Simple Type
XML Einrichten Version 1.2 : RemittanceAdviceNumber Simple Type
Description
Number of the remittance advise
Namespace (none)
Type
Restriction of xs:string
Diagram
RemittanceAdviceNumber Simple Type
Overview
RemittanceAdviceNumber Restriction of xs:string
Number of the remittance advise
Facets
MaxLength 35
Source
<xs:simpleType name="RemittanceAdviceNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer des Zahlungsavis</xs:documentation>
    <xs:documentation xml:lang="en">Number of the remittance advise </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


SerialNumber Simple Type
XML Einrichten Version 1.2 : SerialNumber Simple Type
Description
Serial Number
Namespace (none)
Type
Restriction of xs:string
Diagram
SerialNumber Simple Type
Overview
SerialNumber Restriction of xs:string
Serial Number
Facets
MaxLength 35
Source
<xs:simpleType name="SerialNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Seriennummer </xs:documentation>
    <xs:documentation xml:lang="en">Serial Number </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


ShippingMark Simple Type
XML Einrichten Version 1.2 : ShippingMark Simple Type
Description
Mark in the shipped package
Namespace (none)
Type
Restriction of xs:string
Diagram
ShippingMark Simple Type
Overview
ShippingMark Restriction of xs:string
Mark in the shipped package
Facets
MaxLength 35
Source
<xs:simpleType name="ShippingMark" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Identifikatoin des Packstücks </xs:documentation>
    <xs:documentation xml:lang="en">Mark in the shipped package </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


StackType Simple Type
XML Einrichten Version 1.2 : StackType Simple Type
Description
Type of stack
Namespace (none)
Type
Restriction of xs:string
Diagram
StackType Simple Type
Overview
StackType Restriction of xs:string
Type of stack
Facets
MaxLength 3
Source
<xs:simpleType name="StackType" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Art der Stapelung </xs:documentation>
    <xs:documentation xml:lang="en">Type of stack </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


TaxId Simple Type
XML Einrichten Version 1.2 : TaxId Simple Type
Description
Tax Identification number
Namespace (none)
Type
Restriction of xs:string
Diagram
TaxId Simple Type
Overview
TaxId Restriction of xs:string
Tax Identification number
Facets
MaxLength 35
Source
<xs:simpleType name="TaxId" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Steuer nummer </xs:documentation>
    <xs:documentation xml:lang="en">Tax Identification number </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


TechnicalReceiver Simple Type
XML Einrichten Version 1.2 : TechnicalReceiver Simple Type
Description
Technical partner of the document (GLN)
Namespace (none)
Type
Restriction of xs:string
Diagram
TechnicalReceiver Simple Type
Overview
TechnicalReceiver Restriction of xs:string
Technical partner of the document (GLN)
Facets
MaxLength 35
Source
<xs:simpleType name="TechnicalReceiver" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">TechnischerPartner des Dokumentes (GLN) </xs:documentation>
    <xs:documentation xml:lang="en">Technical partner of the document (GLN) </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


TerminalNumber Simple Type
XML Einrichten Version 1.2 : TerminalNumber Simple Type
Description
Number of the Cash register
Namespace (none)
Type
Restriction of xs:string
Diagram
TerminalNumber Simple Type
Overview
TerminalNumber Restriction of xs:string
Number of the Cash register
Facets
MaxLength 35
Source
<xs:simpleType name="TerminalNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer der Kasse</xs:documentation>
    <xs:documentation xml:lang="en">Number of the Cash register </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


TotalAmountQualifier Simple Type
XML Einrichten Version 1.2 : TotalAmountQualifier Simple Type
Description
Code for deinition of a total document amount
Code list:
22 = Cash on delivery amount
44 = Delivery value
77 = Total Invoice amount = 125+124
79 = Sum of all Net Line Amounts = (Type 66)
86 = Total document amount = 125+124-113
131 = Sum of all charges and allowances
125 = Taxable amount = 79 - 131
124 = Sum of all taxes
113 = Sum of all prepayments
Namespace (none)
Type
Restriction of xs:string
Diagram
TotalAmountQualifier Simple Type
Overview
TotalAmountQualifier Restriction of xs:string
Code for deinition of a total document amount
Code list:
22 = Cash on delivery amount
44 = Delivery value
77 = Total Invoice amount = 125+124
79 = Sum of all Net Line Amounts = (Type 66)
86 = Total document amount = 125+124-113
131 = Sum of all charges and allowances
125 = Taxable amount = 79 - 131
124 = Sum of all taxes
113 = Sum of all prepayments
Facets
MaxLength | 3
MinLength | 1
Enumeration | 22
Enumeration | 44
Enumeration | 79
Enumeration | 131
Enumeration | 125
Enumeration | 124
Enumeration | 113
Enumeration | 86
Enumeration | 77
Source
<xs:simpleType name="TotalAmountQualifier" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Code zur Identification eines Gesamtbetrags</dt>
        <dt>Codeliste: </dt>
        <dt> 22 = Nachnahme Betrag</dt>
        <dt> 44 = Wert der Lieferung</dt>
        <dt> 77 = Beleg Gesamtbetrag Rechnung                           = 125+124</dt>
        <dt> 79 = Netto Positionswerte Gesamt (Summe aller LineAoumnts) Typ 66)</dt>
        <dt> 86 = Beleg Gesamtbetrag                                    = 125+124-113</dt>
        <dt>131 = Summe aller Beleg Zu- und Abschläge </dt>
        <dt>125 = Steuerpflichtiger Betrag:                             = 79 - 131</dt>
        <dt>124 = Summe aller Steuerbeträge</dt>
        <dt>113 = Summe aller Vorauszahlungen</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Code for deinition of a total document amount</dt>
        <dt>Code list: </dt>
        <dt> 22 = Cash on delivery amount</dt>
        <dt> 44 = Delivery value</dt>
        <dt> 77 = Total Invoice amount              = 125+124</dt>
        <dt> 79 = Sum of all Net Line Amounts       = (Type 66)</dt>
        <dt> 86 = Total document amount             = 125+124-113</dt>
        <dt>131 = Sum of all charges and allowances</dt>
        <dt>125 = Taxable amount                    = 79 - 131</dt>
        <dt>124 = Sum of all taxes</dt>
        <dt>113 = Sum of all prepayments</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
    <xs:minLength value="1" />
    <xs:enumeration value="22" />
    <xs:enumeration value="44" />
    <xs:enumeration value="79" />
    <xs:enumeration value="131" />
    <xs:enumeration value="125" />
    <xs:enumeration value="124" />
    <xs:enumeration value="113" />
    <xs:enumeration value="86" />
    <xs:enumeration value="77" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


TourNumber Simple Type
XML Einrichten Version 1.2 : TourNumber Simple Type
Description
Number of the (delivery) tour
Namespace (none)
Type
Restriction of xs:string
Diagram
TourNumber Simple Type
Overview
TourNumber Restriction of xs:string
Number of the (delivery) tour
Facets
MaxLength 35
Source
<xs:simpleType name="TourNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer der (Auslieferungs) Tour</xs:documentation>
    <xs:documentation xml:lang="en">Number of the (delivery) tour </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


TypeOfPackaging Simple Type
XML Einrichten Version 1.2 : TypeOfPackaging Simple Type
Description
Type of packaging
GS1: http://www.gs1.se/eancom_2002/ean02s4/user/part3/dc8m.htm
Code list:
09= Pallet that must be returned
201= Euro pallet
CT=carton
PK=Package generaln
Namespace (none)
Type
Restriction of xs:string
Diagram
TypeOfPackaging Simple Type
Overview
TypeOfPackaging Restriction of xs:string
Type of packaging
GS1: http://www.gs1.se/eancom_2002/ean02s4/user/part3/dc8m.htm
Code list:
09= Pallet that must be returned
201= Euro pallet
CT=carton
PK=Package generaln
Facets
MaxLength 3
Source
<xs:simpleType name="TypeOfPackaging" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Verpackungsart</dt>
        <dt>GS1: http://www.gs1.se/eancom_2002/ean02s4/user/part3/dc8m.htm</dt>
        <dt>Codeliste: </dt>
        <dt> 09=Palette die zurück gegeben werden muss</dt>
        <dt>201=Europalette</dt>
        <dt> CT=Karton</dt>
        <dt> PK=Paket allgemein</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Type of packaging</dt>
        <dt>GS1: http://www.gs1.se/eancom_2002/ean02s4/user/part3/dc8m.htm</dt>
        <dt>Code list: </dt>
        <dt> 09= Pallet that must be returned</dt>
        <dt>201= Euro pallet</dt>
        <dt> CT=carton</dt>
        <dt> PK=Package generaln</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


TypeOfProduct Simple Type
XML Einrichten Version 1.2 : TypeOfProduct Simple Type
Description
type of product
Code list:
BA = Basic product doe variant definition
TU = Trading unit
NO = Nor order product, Packaging, Service
PR1 = Bonus Pack - not ordered but delivered and not billed
NDU = No delivery unit
FMD = Article of another manufacturer
SER = Service
Namespace (none)
Type
Restriction of xs:string
Diagram
TypeOfProduct Simple Type
Overview
TypeOfProduct Restriction of xs:string
type of product
Code list:
BA = Basic product doe variant definition
TU = Trading unit
NO = Nor order product, Packaging, Service
PR1 = Bonus Pack - not ordered but delivered and not billed
NDU = No delivery unit
FMD = Article of another manufacturer
SER = Service
Facets
MaxLength | 3
Enumeration | BA
Enumeration | TU
Enumeration | PR1
Enumeration | NDU
Enumeration | FMD
Source
<xs:simpleType name="TypeOfProduct" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Art des Artikels</dt>
        <dt>Codeliste: </dt>
        <dt>BA  = Basis Produkt</dt>
        <dt>TU  = Handelseinheit</dt>
        <dt>NO  = Nicht bestellter Artikel, Packung, Service</dt>
        <dt>PR1 = Bonus Pack -  Wurde nicht bestellt wird aber als nicht fakturierbarer Artikel mitgeliefert. In diesem Fall wird die Referenz zur Auftragsposition (OrderItemNumber) entweder mit 0 oder mit einer Auftragsposition gefüllt zu der dieses Bonus Pack gehört</dt>
        <dt>NDU = Keine Liefereinheit</dt>
        <dt>FMD = Fremdartikel</dt>
        <dt>SER = Service</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>type of product</dt>
        <dt>Code list: </dt>
        <dt> BA = Basic product doe variant definition</dt>
        <dt> TU = Trading unit</dt>
        <dt> NO = Nor order product, Packaging, Service</dt>
        <dt>PR1 = Bonus Pack -  not ordered but delivered and not billed</dt>
        <dt>NDU = No delivery unit</dt>
        <dt>FMD = Article of another manufacturer</dt>
        <dt>SER = Service</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
    <xs:enumeration value="BA" />
    <xs:enumeration value="TU" />
    <xs:enumeration value="PR1" />
    <xs:enumeration value="NDU" />
    <xs:enumeration value="FMD" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


TypeOfQuantityDeviation Simple Type
XML Einrichten Version 1.2 : TypeOfQuantityDeviation Simple Type
Description
type and reason for a quantity deviation
Namespace (none)
Type
Restriction of xs:string
Diagram
TypeOfQuantityDeviation Simple Type
Overview
TypeOfQuantityDeviation Restriction of xs:string
type and reason for a quantity deviation
Facets
MaxLength 3
Source
<xs:simpleType name="TypeOfQuantityDeviation" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Art und Ursache einer Mengenabweichung</xs:documentation>
    <xs:documentation xml:lang="en">type and reason for a quantity deviation </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


TypeOfShippingMark Simple Type
XML Einrichten Version 1.2 : TypeOfShippingMark Simple Type
Description
Type of shipping mark SSCC
Code list:
BJ = NVE
Namespace (none)
Type
Restriction of xs:string
Diagram
TypeOfShippingMark Simple Type
Overview
TypeOfShippingMark Restriction of xs:string
Type of shipping mark SSCC
Code list:
BJ = NVE
Facets
MaxLength 3
Source
<xs:simpleType name="TypeOfShippingMark" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Art der Versandmarkierung</dt>
        <dt>Codeliste: </dt>
        <dt>BJ = NVE</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Type of shipping mark SSCC</dt>
        <dt>Code list: </dt>
        <dt>BJ = NVE</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


TypeOfTransportCondition Simple Type
XML Einrichten Version 1.2 : TypeOfTransportCondition Simple Type
Description
Conditions fpr transport
Code list:
5 = Standard
12 = Special agreements
Namespace (none)
Type
Restriction of xs:string
Diagram
TypeOfTransportCondition Simple Type
Overview
TypeOfTransportCondition Restriction of xs:string
Conditions fpr transport
Code list:
5 = Standard
12 = Special agreements
Facets
MaxLength 3
Source
<xs:simpleType name="TypeOfTransportCondition" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Transport Konditionen</dt>
        <dt>Codeliste: </dt>
        <dt> 5 = Standard</dt>
        <dt>12 = Spezielle Vereinbarungen</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Conditions fpr transport</dt>
        <dt>Code list: </dt>
        <dt> 5 = Standard</dt>
        <dt>12 = Special agreements</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


TypeOfTransportNature Simple Type
XML Einrichten Version 1.2 : TypeOfTransportNature Simple Type
Description
type of the goods in transport
Codeliste:
12 = Standard
11 = Dangerous goods
Namespace (none)
Type
Restriction of xs:string
Diagram
TypeOfTransportNature Simple Type
Overview
TypeOfTransportNature Restriction of xs:string
type of the goods in transport
Codeliste:
12 = Standard
11 = Dangerous goods
Facets
MaxLength 3
Source
<xs:simpleType name="TypeOfTransportNature" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Beschaffenheit der Ware</dt>
        <dt>Codeliste: </dt>
        <dt>12 = Standard</dt>
        <dt>11 = Gefahrgut</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>type of the goods in transport</dt>
        <dt>Codeliste: </dt>
        <dt>12 = Standard</dt>
        <dt>11 = Dangerous goods</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


TypeOfTransportService Simple Type
XML Einrichten Version 1.2 : TypeOfTransportService Simple Type
Description
Transport Services
Code list:
5 = Standard: The cargo has to be delivered as instructed
20 = Retrieval
37 = assembly service
59 = 2 Men Handling
?? = 4 Men Handling
Namespace (none)
Type
Restriction of xs:string
Diagram
TypeOfTransportService Simple Type
Overview
TypeOfTransportService Restriction of xs:string
Transport Services
Code list:
5 = Standard: The cargo has to be delivered as instructed
20 = Retrieval
37 = assembly service
59 = 2 Men Handling
?? = 4 Men Handling
Facets
MaxLength 3
Source
<xs:simpleType name="TypeOfTransportService" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Transport Services</dt>
        <dt>Codeliste: </dt>
        <dt> 5 = Standard: Das Frachtgut ist wie angewiesen zu liefern</dt>
        <dt>20 = Rückholung</dt>
        <dt>37 = AufbauService</dt>
        <dt>59 = 2 Mann Handling</dt>
        <dt>?? = 4 Mann Handling</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Transport Services</dt>
        <dt>Code list: </dt>
        <dt> 5 = Standard: The cargo has to be delivered as instructed</dt>
        <dt>20 = Retrieval</dt>
        <dt>37 = assembly service</dt>
        <dt>59 = 2 Men Handling</dt>
        <dt>?? = 4 Men Handling</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


TypeOfTransportVelocity Simple Type
XML Einrichten Version 1.2 : TypeOfTransportVelocity Simple Type
Description
Transport Geschwindigkeit
Codeliste:
1 = Express
2 = High Speed
3 = Standard
4 = according to contract with the carrier
Namespace (none)
Type
Restriction of xs:string
Diagram
TypeOfTransportVelocity Simple Type
Overview
TypeOfTransportVelocity Restriction of xs:string
Transport Geschwindigkeit
Codeliste:
1 = Express
2 = High Speed
3 = Standard
4 = according to contract with the carrier
Facets
MaxLength 3
Source
<xs:simpleType name="TypeOfTransportVelocity" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Transport Geschwindigkeit</dt>
        <dt>Codeliste: </dt>
        <dt>1 = Express</dt>
        <dt>2 = High Speed</dt>
        <dt>3 = Standard</dt>
        <dt>4 = gem. Vertrag mit z.B. der Post</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Transport Geschwindigkeit</dt>
        <dt>Codeliste: </dt>
        <dt>1 = Express</dt>
        <dt>2 = High Speed</dt>
        <dt>3 = Standard</dt>
        <dt>4 = according to contract with the carrier</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


Unit Simple Type
XML Einrichten Version 1.2 : Unit Simple Type
Description
Unit
Namespace (none)
Type
Restriction of xs:string
Diagram
Unit Simple Type
Overview
Unit Restriction of xs:string
Unit
Facets
MaxLength | 3
MinLength | 1
Source
<xs:simpleType name="Unit" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Einheit</xs:documentation>
    <xs:documentation xml:lang="en">Unit </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="3" />
    <xs:minLength value="1" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


VATId Simple Type
XML Einrichten Version 1.2 : VATId Simple Type
Description
Sales tax identification number
Namespace (none)
Type
Restriction of xs:string
Diagram
VATId Simple Type
Overview
VATId Restriction of xs:string
Sales tax identification number
Facets
MaxLength 35
Source
<xs:simpleType name="VATId" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Umsatzsteuer Identnummer</xs:documentation>
    <xs:documentation xml:lang="en">Sales tax identification number </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="35" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


VatPercentage Simple Type
XML Einrichten Version 1.2 : VatPercentage Simple Type
Description
Tax rate
Namespace (none)
Type
Restriction of xs:decimal
Diagram
VatPercentage Simple Type
Overview
VatPercentage Restriction of xs:decimal
Tax rate
Facets
TotalDigits | 15
FractionDigits | 3
Source
<xs:simpleType name="VatPercentage" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Steuersatz</xs:documentation>
    <xs:documentation xml:lang="en">Tax rate </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:decimal">
    <xs:totalDigits value="15" />
    <xs:fractionDigits value="3" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


WorkflowDestination Simple Type
XML Einrichten Version 1.2 : WorkflowDestination Simple Type
Description
workflow instructions referencing to the starting point: order message
D = Drop Shipping to an endconsumer. Delivery address in NAD + UC
L = Lagerauftrag. Delivery to a stock. Delivery address in NAD + DP
CD= Crossdocking. Delivery to a crossdocing stock. Delivery address in NAD + DP
Namespace (none)
Type
Restriction of xs:string
Diagram
WorkflowDestination Simple Type
Overview
WorkflowDestination Restriction of xs:string
workflow instructions referencing to the starting point: order message
D = Drop Shipping to an endconsumer. Delivery address in NAD + UC
L = Lagerauftrag. Delivery to a stock. Delivery address in NAD + DP
CD= Crossdocking. Delivery to a crossdocing stock. Delivery address in NAD + DP
Facets
MaxLength | 10
Enumeration | CD
Enumeration | D
Enumeration | L
Source
<xs:simpleType name="WorkflowDestination" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Hinweise zum Workflow ausgehend von der Bestellnachricht</dt>
        <dt>D = Direktbelieferung an den Endkunde. Lieferadresse im NAD + UC</dt>
        <dt>L = Lagerauftrag. Lieferung an einen Lagerort</dt>
        <dt>CD= Crossdocking. Lieferung an ein Umschlaglager. Lieferadresse im NAD + DP</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dt>workflow instructions referencing to the starting point: order message</dt>
      <dt>D = Drop Shipping to an endconsumer.               Delivery address in NAD + UC</dt>
      <dt>L = Lagerauftrag. Delivery to a stock.             Delivery address in NAD + DP</dt>
      <dt>CD= Crossdocking. Delivery to a crossdocing stock. Delivery address in NAD + DP</dt>
    </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="10" />
    <xs:enumeration value="CD" />
    <xs:enumeration value="D" />
    <xs:enumeration value="L" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


ZRNumber Simple Type
XML Einrichten Version 1.2 : ZRNumber Simple Type
Description
Number at Zentralregulierer
Namespace (none)
Type
Restriction of xs:string
Diagram
ZRNumber Simple Type
Overview
ZRNumber Restriction of xs:string
Number at Zentralregulierer
Facets
MaxLength 17
Source
<xs:simpleType name="ZRNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nummer beim Zentralregulierer</xs:documentation>
    <xs:documentation xml:lang="en">Number at Zentralregulierer </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="17" />
  </xs:restriction>
</xs:simpleType>
See Also
XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > BorderCrossing Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BorderCrossing Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > BorderCrossing Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
BorderCrossing Complex Type | XML Einrichten Version 1.2


ContactCode Element
XML Einrichten Version 1.2 > Contact Complex Type : ContactCode Element
Description
Ident of the contact
Namespace (none)
Type
Restriction of xs:string
Diagram
ContactCode Element
Overview
ContactCode optional Restriction of xs:string
Ident of the contact
Source
<xs:element name="ContactCode" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Kurzzeichen der Kontaktperson</xs:documentation>
    <xs:documentation xml:lang="en">Ident of the contact</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
Contact Complex Type | XML Einrichten Version 1.2


ContactCommunication Element
XML Einrichten Version 1.2 > Contact Complex Type : ContactCommunication Element
Description
Group for the communication data
Namespace (none)
Type
ContactCommunication Complex Type
Diagram
CommunicationAdress Element CommunicationCode Element Sequence ContactCommunication Element
Overview
ContactCommunication 0..9 ContactCommunication Complex Type
Group for the communication data
Sequence
CommunicationCode Restriction of xs:string
CommunicationAdress Restriction of xs:string
Communication address related to the previous defined communication type
Source
<xs:element name="ContactCommunication" type="ContactCommunication" minOccurs="0" maxOccurs="9" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Block für die Kommunikationsdaten</xs:documentation>
    <xs:documentation xml:lang="en">Group for the communication data</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
Contact Complex Type | XML Einrichten Version 1.2


ContactFirstName Element
XML Einrichten Version 1.2 > Contact Complex Type : ContactFirstName Element
Description
First name of the contact
Namespace (none)
Type
Restriction of xs:string
Diagram
ContactFirstName Element
Overview
ContactFirstName optional Restriction of xs:string
First name of the contact
Source
<xs:element name="ContactFirstName" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Vorname der Kontaktperson</xs:documentation>
    <xs:documentation xml:lang="en">First name of the contact</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
Contact Complex Type | XML Einrichten Version 1.2


ContactSurName Element
XML Einrichten Version 1.2 > Contact Complex Type : ContactSurName Element
Description
Surname of the contact
Namespace (none)
Type
Restriction of xs:string
Diagram
ContactSurName Element
Overview
ContactSurName optional Restriction of xs:string
Surname of the contact
Source
<xs:element name="ContactSurName" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Nachname der Kontaktperson</xs:documentation>
    <xs:documentation xml:lang="en">Surname of the contact</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="35" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
Contact Complex Type | XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > DocumentLineReference Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentLineReference Complex Type | XML Einrichten Version 1.2


DocRefLineNumber Element
XML Einrichten Version 1.2 > DocumentLineReference Complex Type : DocRefLineNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
DocRefLineNumber Element
Overview
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="DocRefLineNumber" type="LineItemNumber" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentLineReference Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > DocumentLineReference Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentLineReference Complex Type | XML Einrichten Version 1.2


ConsumerInstructions Element
XML Einrichten Version 1.2 > DocumentPaci Complex Type : ConsumerInstructions Element
Namespace (none)
Type
InstructionsConsumer Simple Type
Diagram
ConsumerInstructions Element
Overview
ConsumerInstructions optional InstructionsConsumer Simple Type
Source
<xs:element name="ConsumerInstructions" type="InstructionsConsumer" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentPaci Complex Type | XML Einrichten Version 1.2


LoadingTackle Element
XML Einrichten Version 1.2 > DocumentPaci Complex Type : LoadingTackle Element
Namespace (none)
Type
LoadingTackle Simple Type
Diagram
LoadingTackle Element
Overview
LoadingTackle optional LoadingTackle Simple Type
Source
<xs:element name="LoadingTackle" type="LoadingTackle" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentPaci Complex Type | XML Einrichten Version 1.2


MEA Element
XML Einrichten Version 1.2 > DocumentPaci Complex Type : MEA Element
Namespace (none)
Type
MEA Complex Type
Diagram
MEA Element
Overview
MEA 0..∞ MEA Complex Type
Type optional Restriction of xs:string
Type if measurement
Code list (for articles and packaging):
AAE = Weight or Volumen
PD = Dimension
Use the following codes for special article measurements:
ABK = Outside dimension
ABL = Inside dimension
Y2E = Maximum dimension
Y3E = Minimum dimensionMinimalmaß z.B. Klappstuhl eingeklappt
Y4E = Lying dimension
Y5E = Sitting dimension
Dimension optional Restriction of xs:string
Gemessene Dimension
Verwenden Sie folgende Codes für Artikel und Packstücke:
DP = Tiefe
HT = Höhe
LN = Länge
WD = Breite
DI = Durchmesser
AAA = Netto Gewicht Ware inkl. Endkundenverpackung
AAB = Brutto Gewicht Ware inkl. Transportverpackung
AAF = Netto Gewicht Ware ohne jede Verpackung
ABJ = Volumen
Mesaured dimension
use this codes for articles and packaging:
DP = Depth
HT = Height
LN = Length
WD = Width
DI = Diameter
AAA = Net weight goods incl. end-consumer packaging
AAB = Gross weight goods incl. packaging for transporz
AAF = Net weight goods without any packaging
ABJ = Volume
Unit optional Unit Simple Type
Source
<xs:element name="MEA" type="MEA" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentPaci Complex Type | XML Einrichten Version 1.2


NumberOfPackages Element
XML Einrichten Version 1.2 > DocumentPaci Complex Type : NumberOfPackages Element
Namespace (none)
Type
NumberOfPackages Simple Type
Diagram
NumberOfPackages Element
Overview
NumberOfPackages optional NumberOfPackages Simple Type
Source
<xs:element name="NumberOfPackages" type="NumberOfPackages" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentPaci Complex Type | XML Einrichten Version 1.2


PaciNumber Element
XML Einrichten Version 1.2 > DocumentPaci Complex Type : PaciNumber Element
Namespace (none)
Type
PackingPieceNumber Simple Type
Diagram
PaciNumber Element
Overview
PaciNumber PackingPieceNumber Simple Type
Source
<xs:element name="PaciNumber" type="PackingPieceNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentPaci Complex Type | XML Einrichten Version 1.2


ParentPaciNumber Element
XML Einrichten Version 1.2 > DocumentPaci Complex Type : ParentPaciNumber Element
Namespace (none)
Type
PackingPieceNumber Simple Type
Diagram
ParentPaciNumber Element
Overview
ParentPaciNumber optional PackingPieceNumber Simple Type
Source
<xs:element name="ParentPaciNumber" type="PackingPieceNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentPaci Complex Type | XML Einrichten Version 1.2


ShippingMark Element
XML Einrichten Version 1.2 > DocumentPaci Complex Type : ShippingMark Element
Namespace (none)
Type
ShippingMark Simple Type
Diagram
ShippingMark Element
Overview
ShippingMark optional ShippingMark Simple Type
Source
<xs:element name="ShippingMark" type="ShippingMark" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentPaci Complex Type | XML Einrichten Version 1.2


TypeOfPackaging Element
XML Einrichten Version 1.2 > DocumentPaci Complex Type : TypeOfPackaging Element
Namespace (none)
Type
TypeOfPackaging Simple Type
Diagram
TypeOfPackaging Element
Overview
TypeOfPackaging optional TypeOfPackaging Simple Type
Source
<xs:element name="TypeOfPackaging" type="TypeOfPackaging" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentPaci Complex Type | XML Einrichten Version 1.2


TypeOfShippingMark Element
XML Einrichten Version 1.2 > DocumentPaci Complex Type : TypeOfShippingMark Element
Namespace (none)
Type
TypeOfShippingMark Simple Type
Diagram
TypeOfShippingMark Element
Overview
TypeOfShippingMark optional TypeOfShippingMark Simple Type
Source
<xs:element name="TypeOfShippingMark" type="TypeOfShippingMark" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentPaci Complex Type | XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > DocumentReference Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentReference Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > DocumentReference Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
DocumentReference Complex Type | XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > LineAmount Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LineAmount Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > LineAmount Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LineAmount Complex Type | XML Einrichten Version 1.2


FeatureID Element
XML Einrichten Version 1.2 > OPT Complex Type : FeatureID Element
Description
identification elements for a feature
Namespace (none)
Type
ProductIdentifier Complex Type
Diagram
CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence FeatureID Element
Overview
FeatureID ProductIdentifier Complex Type
identification elements for a feature
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
Source
<xs:element name="FeatureID" type="ProductIdentifier" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Identifktaionen zu einem Feature </xs:documentation>
    <xs:documentation xml:lang="en">identification elements for a feature </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPT Complex Type | XML Einrichten Version 1.2


FeatureLineNumber Element
XML Einrichten Version 1.2 > OPT Complex Type : FeatureLineNumber Element
Description
Sequential number of the feature within a line
Namespace (none)
Type
Restriction of xs:int
Diagram
FeatureLineNumber Element
Overview
FeatureLineNumber Restriction of xs:int
Sequential number of the feature within a line
Source
<xs:element name="FeatureLineNumber" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Fortlaufende nummereriung der Feature innerhalb einer Position </xs:documentation>
    <xs:documentation xml:lang="en">Sequential number of the feature within a line  </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:int">
      <xs:totalDigits value="6" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
OPT Complex Type | XML Einrichten Version 1.2


Option Element
XML Einrichten Version 1.2 > OPT Complex Type : Option Element
Description
Description of the option according to the feature
Namespace (none)
Type
Option Complex Type
Diagram
NumericValue Element TextValue Element CustomerName Element CustomerNumber Element Name Element Number Element GTIN Element Sequence OptionID Element Sequence Option Element
Overview
Option Option Complex Type
Description of the option according to the feature
Sequence
OptionID optional ProductIdentifier Complex Type
Sequence
GTIN optional Restriction of xs:decimal
= EAN Code
Number optional Restriction of xs:string
Internal number defined by the manufacturer
Name optional Restriction of xs:string
Name
CustomerNumber optional Restriction of xs:string
Number at customers site
CustomerName optional Restriction of xs:string
Name at customers site
TextValue optional
NumericValue optional UnitValue Complex Type
Unit optional Unit Simple Type
Source
<xs:element name="Option" type="Option" minOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Beschreibung der Option zu einem Feature </xs:documentation>
    <xs:documentation xml:lang="en">Description of the option according to the feature </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPT Complex Type | XML Einrichten Version 1.2


ParentFeatureLineNumber Element
XML Einrichten Version 1.2 > OPT Complex Type : ParentFeatureLineNumber Element
Description
reference to a superior feature
Namespace (none)
Type
Restriction of xs:decimal
Diagram
ParentFeatureLineNumber Element
Overview
ParentFeatureLineNumber optional Restriction of xs:decimal
reference to a superior feature
Source
<xs:element name="ParentFeatureLineNumber" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Referenz auf ein übergeordnetes Feature </xs:documentation>
    <xs:documentation xml:lang="en">reference to a superior feature </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:decimal">
      <xs:totalDigits value="6" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
OPT Complex Type | XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > OrderLine Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OrderLine Complex Type | XML Einrichten Version 1.2


DocRefLineNumber Element
XML Einrichten Version 1.2 > OrderLine Complex Type : DocRefLineNumber Element
Namespace (none)
Type
LineItemNumber Simple Type
Diagram
DocRefLineNumber Element
Overview
DocRefLineNumber optional LineItemNumber Simple Type
Source
<xs:element name="DocRefLineNumber" type="LineItemNumber" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OrderLine Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > OrderLine Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
OrderLine Complex Type | XML Einrichten Version 1.2


DocDate Element
XML Einrichten Version 1.2 > PreCustomerOrder Complex Type : DocDate Element
Namespace (none)
Type
EDIDate Complex Type
Diagram
DocDate Element
Overview
DocDate optional EDIDate Complex Type
FormatCode optional EDIDateFormatCode Simple Type
Source
<xs:element name="DocDate" type="EDIDate" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PreCustomerOrder Complex Type | XML Einrichten Version 1.2


DocRefNumber Element
XML Einrichten Version 1.2 > PreCustomerOrder Complex Type : DocRefNumber Element
Namespace (none)
Type
DocumentNumber Simple Type
Diagram
DocRefNumber Element
Overview
DocRefNumber DocumentNumber Simple Type
Source
<xs:element name="DocRefNumber" type="DocumentNumber" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PreCustomerOrder Complex Type | XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > Price Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Price Complex Type | XML Einrichten Version 1.2


PriceQuantity Element
XML Einrichten Version 1.2 > Price Complex Type : PriceQuantity Element
Description
Quantity related to the price information
Namespace (none)
Type
Quantity Complex Type
Diagram
PriceQuantity Element
Overview
PriceQuantity Quantity Complex Type
Quantity related to the price information
Unit optional Unit Simple Type
Source
<xs:element name="PriceQuantity" type="Quantity" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Preisberechnungsmenge</xs:documentation>
    <xs:documentation xml:lang="en">Quantity related to the price information</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
Price Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > Price Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Price Complex Type | XML Einrichten Version 1.2


Currency Element
XML Einrichten Version 1.2 > TotalAmount Complex Type : Currency Element
Namespace (none)
Type
Currency Simple Type
Diagram
Currency Element
Overview
Currency Currency Simple Type
Source
<xs:element name="Currency" type="Currency" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
TotalAmount Complex Type | XML Einrichten Version 1.2


Value Element
XML Einrichten Version 1.2 > TotalAmount Complex Type : Value Element
Namespace (none)
Type
xs:decimal
Diagram
Value Element
Overview
Value xs:decimal
Source
<xs:element name="Value" type="xs:decimal" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
TotalAmount Complex Type | XML Einrichten Version 1.2


VatBase Element
XML Einrichten Version 1.2 > Vat Complex Type : VatBase Element
Description
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Namespace (none)
Type
CurrencyValue Complex Type
Diagram
Currency Element Value Element Sequence VatBase Element
Overview
VatBase optional CurrencyValue Complex Type
Vat base amount for a dedicated tax rate
Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="VatBase" type="CurrencyValue" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">
      <dl>
        <dt>Steuerpflichtiger Betrag zum jeweiligen Steuersatz</dt>
        <dt>Berechnung: Summer aller Netto Positionswerte - alle Rabatte</dt>
      </dl>
    </xs:documentation>
    <xs:documentation xml:lang="en">
      <dl>
        <dt>Vat base amount for a dedicated tax rate</dt>
        <dt>Calculation: Sum of all Net Line Amounts - DiscountsConditionsTotal</dt>
      </dl>
    </xs:documentation>
  </xs:annotation>
</xs:element>
See Also
Vat Complex Type | XML Einrichten Version 1.2


VatPercentage Element
XML Einrichten Version 1.2 > Vat Complex Type : VatPercentage Element
Description
Tax rate
Namespace (none)
Type
VatPercentage Simple Type
Diagram
VatPercentage Element
Overview
VatPercentage VatPercentage Simple Type
Tax rate
Source
<xs:element name="VatPercentage" type="VatPercentage" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Steuersatz </xs:documentation>
    <xs:documentation xml:lang="en">Tax rate</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
Vat Complex Type | XML Einrichten Version 1.2


VatValue Element
XML Einrichten Version 1.2 > Vat Complex Type : VatValue Element
Description
Tax Amount
Namespace (none)
Type
CurrencyValue Complex Type
Diagram
Currency Element Value Element Sequence VatValue Element
Overview
VatValue optional CurrencyValue Complex Type
Tax Amount
Sequence
Value xs:decimal
Currency Currency Simple Type
Source
<xs:element name="VatValue" type="CurrencyValue" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Betrag der Steuer </xs:documentation>
    <xs:documentation xml:lang="en">Tax Amount</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
Vat Complex Type | XML Einrichten Version 1.2