%%ItemTitle%%

IDMW 2.0 XML schema documentation
Introduction

IDMW 2.0.0 XML schema

Documentation

Last revised 01 November 2019

Documented XML schema:

IDMW_2_0_0.xsd

Contact

DCC e. V.
Dr.-Ing. Olaf Plümer
E-Mail pluemer@vhk-herford.de
Telephone +49 (0) 52 21/12 65-37


%%ItemTitle%%

IDMW 2.0 XML schema documentation
The basic structure of the IDM schema
Introduction > The basic structure of the IDM schema

The basic structure of the IDM schema

The main element T_NEW_CATALOG defines that a new and complete multi-manufacturer catalogue data pool is made available.

The IDM schema is subdivided in data ranges that are specified in the subsequent child-elements (see figure 1) in T_NEW_CATALOG.

Figure 1 - child elements in T_NEW_CATALOG

The data ranges are not used in isolation from each other. In some data ranges, data is initially created and used from other data ranges via referencing.

Description of the data ranges

CATALOG

CATALOG is used to store administrative information concerning the data pool. E.g. the version of the data format, release date or the unique identification of the data pool.

SUPPLIER

SUPPLIER is used to store administrative information concerning the manufacturer. Example: specification of contact data, EDI communication parameters or the manufacturer's country of origin.

GLOBAL_DEFINITION

The GLOBAL_DEFINITION data range is a kind of data pool for information used in the other data ranges. As an example, standard handle positions or information about series are specified here.

SERIES

SERIES is used to store the data for the description of the items. Items are combined into product groups, such as base units or shelf units.

PART_LISTS

PARTS_LISTS is used to assemble dynamic piece lists, with the sub-positions assigned to rules (DECISIONS) that determine depending on the option in which quantity the respective position exists in the piece list.

FEATURE_DEFINITION

The feature information is specified in FEATURE_DEFINITION. Example: Data for feature classes (FEATURE_CLASS), features (FEATURE), the associated options (OPTION_DEFINITION) or assessment methods (RESTRICTION) are specified.

PRICE_DEFINITION

The price information is specified in PRICE_DEFINITION. Example: Data for price characteristics groups (PRICE_FEATURE_GROUP), VAT (VALUE_ADDED_TAXES), product categories (MERCHANDISE_GROUP) or price types (PRICE_TYPE) are specified.

See Also
T_NEW_CATALOG Element


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Elements of the catalogue structure
Introduction > Elements of the catalogue structure

Creating elements of the catalogue structure

Creating series information

Series are defined in the following element:

T_NEW_CATALOG/SERIES/SERIE

All child elements are used to describe the properties of the series.Options are assigned to series via assessment procedures (RESTRICTION_REF).

Creating options

Example: creating options

1. Definition of the feature properties/feature classes

The feature properties are defined in the following element:

FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

</OPTION_DEFINITION>

This element is used to define the properties of colours, materials, shape versions and dimensions.

2. Creating the options

The options are created in the following element:

FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_KEY="L"

</OPTION>

<OPTION OPTION_KEY="S"

</OPTION>

</OPTIONS>

</FEATURE>

Features are defined via feature type numbers, e.g. 1. The option is unequivocally identified by the combination of FEATURE_NO in FEATURE_DEFINITION/FEATURES/FEATURE and OPTION_KEY in FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION identified unequivocally.

Creating item information

Item information is specified in the following element:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The element ITEM has a multitude of elements used to describe the properties of items. An item is identified via the attribute TYPE_NO.

Please note that depending on the series, an item may have different properties. Consequently, an item and its properties can only be unequivocally identified in combination with the series.

Series-specific item information

Depending on the series, items may have different properties. Items are automatically assigned to a series because the element ITEM is a child element of the SERIE element.

Creating feature information

Feature information is created in the IDM schema as described in the following:

- Creation of variations for the options

- Assignment of variation and feature

Creating variations

The variations for the options are defined as a data pool in the element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION.

Figure 2 - The element OPTION_DEFINITION

The OPTION_DEFINITION element contains elements in which the respective variations are specified:

MATERIAL | This element is used to define the properties of materials using colours and textures. These elements are referenced from features.
FORM | This element is used to define the numbers for form variations (FORM_NO). In the current version of the IDM schema, no further characteristic features are specified in this element other than FORM_NO.
OPTION_MEASURE | This element is used to specify the values of options that are expressed in a dimension (e.g. sitting height (feature 35)).

Example: variations for colours

<OPTION_DEFINITION>

<MATERIAL>

<COLOR COLOR_NO="1">

<RGB_RED>255</RGB_RED>

<RGB_GREEN>0</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="2">

<RGB_RED>133</RGB_RED>

<RGB_GREEN>273</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="3">

<RGB_RED>0</RGB_RED>

<RGB_GREEN>89</RGB_GREEN>

<RGB_BLUE>89</RGB_BLUE>

</COLOR>

</MATERIAL>

</OPTION_DEFINITION>

The above elements define three colours that are identified by numbers (COLOR_NO) 1-3.

Assignment of variation and feature

To use the colours defined in the example above, features must be assigned, which results in options.

The assignment of features (FEATURE) and variations (OPTION) to options is done in the element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE. An option is formed and identified by the combination of FEATURE and OPTION. The following XML elements define 2 feed heights (feature 15).

Example: assembly of options from feature and variations

<FEATURE FEATURE_NO="15">

<OPTIONS>

<OPTION OPTION_KEY="10">

<OPTION_TEXT>

</OPTION_TEXT>

</OPTION>

<OPTION OPTION_KEY="30">

<OPTION_TEXT>

</OPTION_TEXT>

</OPTION>

</OPTIONS>

<FEATURE_TEXT>

</FEATURE_TEXT>

<HEADER_POS_VARIATION_TYPE>K</HEADER_POS_VARIATION_TYPE>

</FEATURE>

The child elements of FEATURE describe the properties of the feature, the child elements of OPTION describe the properties of the option. Analogous to this principle, which applies for essentially all elements in the IDM schema, the OPTION_TEXT defines a text that designates the option. The element FEATURE_TEXT defines a text that designates the feature.

If the data is supposed to reference an option, the combination of FEATURE_NO and OPTION_KEY must always be specified as a reference key.


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Arranging the catalogue structure
Introduction > Arranging the catalogue structure

Arranging the catalogue structure

Assigning series to options

Options are assigned to all series in the following element:

SERIES/DECISIONS/DECISION_REF

The option is assigned to the series by referencing a rule that defines the option as a valid combination in the SERIES/SERIE/DECISIONS/DECISION_REF element.

Assigning items, series and options

Item-series assignment

Items are automatically assigned to series because the ITEM element is a child element of the SERIES element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Item-specific rules can be defined via SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISIONS_REF.

Example: Rule for options assignment

Element: FEATURE_DEFINITION/DECISIONS/DECISION

<DECISIONS>
<DECISIONVALIDATION_TYPE="0"DECISION_NO="1">
<DECISION_NAME_TEXT>
<LANGUAGEISO_LANGUAGE_ID="EN">
<TEXT_LINESEQUENCE_NO="1">
<TEXT>item numbers</TEXT>
</TEXT_LINE>
</LANGUAGE>
</DECISION_NAME_TEXT>
<OPTION_COMBINATIONSEQUENCE="1">
<FEATURE_REFFEATURE_NO="1">
<OPTION_REF_OPOPTION_KEY="1"OPERATOR="eq"/>
</FEATURE_REF>
<FEATURE_REFFEATURE_NO="201">
<OPTION_REF_OPOPTION_KEY="0"OPERATOR="eq"/>
</FEATURE_REF>
<FEATURE_REFFEATURE_NO="202">
<OPTION_REF_OPOPTION_KEY="00"OPERATOR="eq"/>
</FEATURE_REF>
<ACTIONS>
<SET_FEATURE_FIXEDFEATURE_NO="204">
<OPTION_REFOPTION_KEY="1000"/>
</SET_FEATURE_FIXED>
</ACTIONS>
</OPTION_COMBINATION>
</DECISION>
</DECISIONS>


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Catalogue structure
Introduction > Catalogue structure

Catalogue and element structure

The catalogue structure in the IDM schema is mapped by the following element hierarchy:

Figure 1 - Element hierarchy in the IDM schema

The SERIE element is used to define the properties of a series.Product groups (PRODUCT_GROUPS) in which items (ITEMS) with similar features are combined are defined within the series. The items are automatically assigned to a series because they are child elements of the SERIE element. The DECISIONS elements are used to cross-series assign options to a series, product group or item via rules. It is also possible to assign actions (ACTIONS) to the rules defined in DECISIONS.


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Referencing
Introduction > Referencing

Referencing of elements

The IDM schema establishes relationships between elements and defines information at a central point which are used on multiple occasions in another position. The reuse of the information and the structure of element relationships takes place via referencing. The type of referencing used in the IDM schema is described in the following.

Definition of terms

The IDM schema uses the following terms for the referencing of elements:

Key element | An XML element referenced by other elements.
Ref element | An XML element referencing other elements

Referencing procedure

The key element has attributes that allow for its unequivocal identification. The ref element has at least the key attributes of the key element. The reference in which the attribute values of the ref element are identical to those of the key element is established between the elements.

Example: Referencing the rule across multiple series, from the series, the product group and the item

The following example shows how a rule (DECISION) is referenced from an item (ITEM). Only some of the XML elements are explained.

Key element

T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS

<DECISIONS>

<DECISION DECISION_NO="1"/> … </DECISION>

<DECISION DECISION_NO="2"/> … </DECISION>

<DECISION DECISION_NO="3"/> … </DECISION>

. . .

</DECISIONS>

Ref element

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

<ITEMS>

<ITEM TYPE_NO="1111">

<DECISIONS>

<DECISION_REF DECISION_NO="1"> …</DECISION_REF>

. . .

</ITEMS>

Example: referencing of an option

The following example shows how to reference an option from an assessment procedure.

Key element

T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="15"> <!-- foot height-->

<OPTIONS>

<OPTION OPTION_KEY="100"> …</OPTION>

<OPTION OPTION_KEY="120"> …</OPTION>

<OPTION OPTION_KEY="30"> …</OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="17"> <!-- Footshape-->

<OPTIONS>

<OPTION OPTION_KEY="F00"> …</OPTION>

<OPTION OPTION_KEY="F3Z"> …</OPTION>

<OPTIONOPTION_KEY="F70"> …</OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

For feature 15, the XML elements define three options (OPTION) with codes 100,120,30. For feature 17, three options with codes F00, F3Z, F70 are defined. An option is identified via the combination of FEATURE_NO and OPTION_KEY.


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Assessment procedure

Definition and assignment of assessment methods

Assessment methods can be cross-series, series-specific or item specific. The deeper within the Series -> Item hierarchy an assessment method is assigned, the higher its priority. An assessment method on item level would, e.g., override an assessment method assigned on series level. An overriding assessment method can however only define additional restrictions. It is, e.g., not possible to reactivate options that have already been excluded by a series-specific assessment method by using an item-specific assessment method.

Assessment methods are initially created irrespective of their regular assignment and then assigned to series or items.

Creation of assessment methods

Assessment methods are specified in the following element:

FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

The RESTRICTION element is used to reference features for which the assisting method is to be created for their combinations. The options for which the combinations are to be assessed or referenced in the OPTION_REf element. Only options for which the features have been referenced in the RESTRICTION element may be referenced within the features. The TEST_ID element defines whether the specified feature combination is allowed or prohibited.

Example: definition of assessment methods

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="10017" FEATURE_1_NO="17" FEATURE_2_NO="18" VALDATION_TYPE="0" >

<OPTION_COMBINATION>

<OPTION_REF OPTION_KEY="F50"FEATURE_NO="17"/>#Timber foot

<OPTION_REF OPTION_KEY="P44"FEATURE_NO="18"/>#colour maple

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_KEY="F50"FEATURE_NO="17"/>#Timber foot

<OPTION_REF OPTION_KEY="P51"FEATURE_NO="18"/>#colour cherry

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_KEY="F91"FEATURE_NO="17"/>#metal foot

<OPTION_REF OPTION_KEY="P20"FEATURE_NO="18"/>#silver

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

The above example shows the definition of an assessment method that defines the options of features for "foot shape" (no. 17) and "foot colour" (no. 18). In the above assessment method, the combinations timber foot-colour maple, timber foot-colour cheery in metal foot are allowed (TEST_ID = 1). When listing the feature combinations (OPTION_REF), the order as determined by the attributes of RESTRICTION (FEATURE_1_NO, FEATURE_2_NO) must be observed.

The assessment method is identified by being allocated an unequivocal number (RESTRICTION_NO).

Assignment of assessment methods

Cross-series assignment

The following element is used to assign assessment methods across series:

SERIES/RESTRICTIONS/RESTRICTION_REF

The element RESTRICTION_REF is a child element of the SERIES/RESTRICTIONS element, and assigns the assessment methods referenced in RESTRICTION_RF to all series that are defined in SERIES/SERIE.

Example: cross-series assignment of assessment methods

<SERIES>

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1"RESTRICTION_NO="523"/>

<RESTRICTION_REF SEQUENCE="2"RESTRICTION_NO="678"/>

</RESTRICTIONS>

</SERIES>

The above example shows assessment methods 523 and 678 reference and thereby being assigned to all series.

Series-specific assignment

The series-specific assignment of assessment methods follows the same rules as the cross-series assignment. The following element is used for the series-specific assignment:

SERIES/SERIE/RESTRICTIONS/RESTRICTION_REF

The assessment methods referenced in RESTRICTIONS_REF are assigned to the series in which the reference was placed.

Example: series-specific assignment of assessment methods

<SERIES>

<SERIE SERIE_NO="2">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1"RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2"RESTRICTION_NO="67"/>

</RESTRICTIONS>

</SERIE>

<SERIE SERIE_NO="7">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1"RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2"RESTRICTION_NO="123"/>

</RESTRICTIONS>

</SERIE>

</SERIES>

The above example shows how series "2" was assigned assessment methods 45 and 67, in series "7" was assigned assessment methods 45 and 123.

Item-specific assignment

The following element is used for article-specific assignments of assessment methods:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

The assignment of assessment method follows the same rules as the series-specific assignment.

If no assignment methods are assigned to an item, the item is available for delivery with all options.

Product group-specific assignment

The following element is used for product group-specific assignments of assessment methods:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/RESTRICTIONS/RESTRICTION_REF

The assignment of assessment method follows the same rules as the series-specific assignment.

Rules

In addition to RESTRICTIONS, there are now the DECISIONS.

The rules/assessment procedures are assigned to serious or items by references from the corresponding elements. In total, all assessment procedures defined in this element must be referenced from either series or items.

Rules that are referenced by items take priority over rules referenced by series.

DECISIONS have 3 types of rules (identified by TEST_ID).

Depending on the TEST_ID element, different rules can be specified.

If the value in TEST_ID is 1, the rule is a "preparation rule".

This allows for the definition of valid options in OPTION_COMBINATION. These are used to determine the valid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

The conditions are supplemented with operators. The special data type operator was defined for this purpose. It may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

The individual OPTION_COMBINATIONs must be considered as ELSE branches. This means that as soon as a condition line (OPTION_COMBINATIONS) receives a hit, the others will not be executed anymore.

If the value in TEST_ID is 2, the rule is a an action rule. It allows for the definition of actions in addition to the conditions.

If all conditions within an „OPTION_COMBINATION“ are satisfied, all signed actions (ACTIONS) then can set values or make features (FEATURES) invisible depending on conditions. If an OPTION_COMBINATION is satisfied, the other conditions are not processed.

Actions (ACTIONS) are instructions that are executed if a condition is met. The following actions can be executed:

  • The setting of options (SET_FEATURE_FIXED) with the following options:

§Direct, e.g. main fabric = "blue" (OPTION)

§the setting of feature values from another feature (FEATURE), e.g. ledge fabric = main fabric

§the calculation of options (e.g. sitting height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

  • Setting default features (SET_FEATURE_DEFAULT):
    These can be filled if no value has been entered yet. The same options as above apply.
  • The visibility of features (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) and disabling of rules (DISABLE_DECISION, ENABLE_DECISION):
    Example: for wooden feet, a potentially existing feature for a shade can be displayed and made invisible if a metal foot is selected.

Action rules are usually used in the configurator if an option value (an option) changes. If, for example, the foot option is changed from stainless steel to wood, a feature for the shade can be displayed.


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Data types
Introduction > Data types

Data types and value ranges

The IDM schema uses the data types defined in the standard XML schema 1.0 second edition (28 October 2004).

IDMP version 2.4 uses the following data types:

boolean | This data type maps the logical values "true" or "false". In accordance with the W3C recommendation for XML schemas, the values that can be used in the IDM are true/false or 1/0.
date | In the IDMP, the data type date is used in conformity with the XML schemas as follows: YYYY-MM-DD Y = year, M = month, D = day
integer | Numbers can be positive and negative integers.
nonNegativeInteger | Value is a positive integer, including 0
positiveInteger | Value is a positive integer, excluding 0
decimal | The data type is used in the IDMP for floating-point values. Floating-point values for this data type are, as recommended by the W3C, stored as 126.56 or -45.98000 or +27.0.
string | A limited number of alphanumeric characters and special characters.
anyURI | The data type is used in the IDMP for URLs.anyURI represents a Uniform Resource Identifier (URI). The lexical part of anyURI is an indefinite sequence of characters that correspond to a legal URI. An anyURI value can be absolute or relative and may contain fragment codes (e.g. an URI reference).
language | The data type is used in the IDMP for the mapping of valid language keys.language represents codes for natural languages Tags for the Identification of Languagesas defined in the Thevaluerangeof language is the quantum of all character sequences that represent a valid code of a natural language. For ISO languages, the format consists of a sequence of 2-3 lower case letters optionally followed by a hyphen and a country code consisting of 2 upper case letters, e.g. en-US.

Additionally, there is also a user-defined data type:

operator

Thy data type is used for rules in the IDMP. This simple, self-defined data type defines an operator for comparisons. The comparison operator is a string of 1 to 4 characters length and may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

The value ranges of the above data types are usually restricted for the elements in the IDMP. The "restrictions" in the data type definition contains restrictions for minimum and maximum values, permitted characters (pattern) and value lists.

In the documentation of the XML schema of the IDM, the value ranges are specified by the information coming after M and P.


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Notes to the documentation
Introduction > Notes to the documentation

Notes to the IDM documentation

Notes to the IDM documentation schema are stored in this section.

Explanation of the element properties

Each element is documented on the basis of a description and its properties. The following shows an example for an element description:

EXCHANGE_ID_NO Attribute

Description
This attribute identifies a swap-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

The element properties are documented on the right side. They have the following meaning:

D | The data type of the element is documented here. If this position is left blank, the element does not contain any reference data but additional child-elements.
P | The entries made in P and M document the value range of an element. A regular expression that defines the permitted values must be entered in P.
M | The minimum and maximum permitted values must be entered in M. In the case of a string data type, P defines the permitted characters and M the minimum and maximum character length. In the case of a numeric data type, the permitted minimum and maximum value is defined.


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Features
Introduction > Features

Features

The following features have been defined:

Feature | Feature text | Variation | Remark
1 | Range | A | Program as feature
100 | Front version | A |
101 | Front colour 1 | F | Infill with smooth front panel = full surface
102 | Front colour 2 | F | Frame
103 | Front colour 3 | F | Pilaster strips
104 | Edge colour front | F |
105 | Front combination | K | If only one key is specified for multiple front information.
106 | Front panel group | A | Overwrites the FRONT_GROUP_NO in FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
110 | Front version trim 1 | A |
111 | Front colour 1 trim 1 | F | Infill with smooth front panel = full surface
112 | Front colour 2 trim 1 | F | Frame
113 | Front colour 3 trim 1 | F | Pilaster strips
114 | Front edge colour 1 | F |
115 | Front combination trim 1 | K | May contain options 111 to 114
120 | Front version trim 2 | A |
121 | Front colour 1 trim 2 | F | Infill with smooth front panel = full surface
122 | Front colour 2 trim 2 | F | Frame
123 | Front colour 3 trim 2 | F | Pilaster strips
124 | Front edge colour 2 | F |
125 | Front combination trim 2 | K | May contain options 121 to 124
150 | Glass finish | A |
151 | Glass colour | F |
152 | Bar version | A |
153 | Bar colour | F |
154 | Finish glass door frame | A |
155 | Colour glass door frame | F |
160 | Roller shutter finish | A |
161 | Colour of roller shutter | F |
170 | Scoop finish | A |
171 | Scoop colour | F |
200 | Carcase finish | A |
201 | Carcase combination | K | If only one key is available for multiple carcase colours - inside/outside.
202 | Carcase colour outside | F |
203 | Carcase colour inside | F |
204 | Edge finish carcase | A |
205 | Edge colour carcase | F |
206 | Finish visible sides | A |
207 | Colour visible sides | F |
208 | Carcase colour inside for glass | F | Glass cabinets and open cupboards, that are not shelving units
209 | Carcase design inside for glass | A | Glass cabinets and open cupboards, that are not shelving units
300 | Handle finish | A |
301 | Handle colour 1 | F | Handle, UNKNOWN TERM and/or main colour
302 | Handle colour 2 | F | UNKNOWN TERMS
303 | Handle combination | K | If only one key is specified for multiple handle conditions.
304 | Handle positions |  |
400 | Plinth finish | A |
401 | Plinth colour | F |
402 | Plinth height | A |
410 | Plinth base type | A |
411 | Plinth base colour | F |
500 | Finish shelf units | A |
501 | Colour shelf units | F |
502 | Cornice finish | A | Includes shape and material
503 | Colour cornice | F |
504 | Light baffle finish | A | Includes shape and material
505 | Light pelmet colour | F |
506 | Finish ceiling infill panel | A |
507 | Colour ceiling infill panel | F |
508 | Finish bottom cupboard skirting board | A | Bottom cupboard skirting board
509 | Colour bottom cupboard skirting board | F | Bottom cupboard skirting board
510 | Finish top shelf | A |
511 | Colour top shelf | F |
512 | Top panel edge finish | A |
513 | Top panel edge colour | F |
514 | Shelf finish | A |
515 | Colour shelf | F |
516 | UNKNOWN TERM finish | A |
517 | UNKNOWN TERM colour | F |
520 | Finish modular panels/bar | A |
521 | Colour modular panes/bars | F |
522 | Finish panel edge | A |
523 | Colour panel edge | F |
524 | Bottom panel finish | A |
525 | Bottom panel colour | F |
526 | Bottom panel edge finish | A |
527 | Bottom panel edge colour | F |
550 | Niche design | A |
551 | Niche colour | F |
560 | Version of accessories for niches | A |
561 | Colour of accessories for niches | F |
562 | Finish pilaster | A |
563 | Colour pilaster | F |
564 | UNKNOWN TERM finish | A |
565 | UNKNOWN TERM colour | F |
570 | Profiled board finish | A |
571 | Profiled board colour | F |
600 | Worktop finish | A |
601 | Worktop colour | F |
602 | Worktop edge finish | A |
603 | Worktop edge colour | F |
604 | Bar top finish | A |
605 | Bar top colour | F |
606 | Bar top edge finish | A |
607 | Bar top edge colour | F |
620 | Finish top cover | A |
621 | Colour top cover | F |
622 | Top cover edge finish | A |
623 | Top cover edge colour | F |
624 | Table attachment finish | A |
625 | Table attachment colour | F |
626 | Table attachment edge finish | A |
627 | Table attachment edge colour | F |
650 | Sealer strip finish | A | Upstand
651 | Colour of sealer strip | F | Upstand
700 | Drawer finish | A | Interior fittings
701 | Drawer colour | F | Interior fittings
702 | Deep drawer type | A | Interior fittings
703 | Pull-out colour | F | Interior fittings
750 | Worktop shape | S |
751 | Cornice form | S |
752 | Form of light baffle | S |
753 | Plinth form | S |
754 | Wall joint shape | S |
755 | Cover panel shape | S |
756 | Bar top shape | S |
800 | Electrical appliances finish | A |
801 | Electrical appliances colour | F |
802 | Eectrical appliance accessories colour | F |
850 | Sinks finish | A |
851 | Sinks colour | F |
852 | Sink accessories colour | F |
853 | Mixer tabs colour | F |
854 | Mixer tabs finish | A |
900 | Finish of general accessories | A |
901 | Colour of general accessories | F |
930 | additional visually-relevant finish 1 | A | the software houses must be informed separately
931 | additional visually-relevant colour 1 | F | the software houses must be informed separately
932 | additional visually-relevant finish 2 | A | the software houses must be informed separately
933 | additional visually-relevant colour 2 | F | the software houses must be informed separately
934 | additional visually-relevant finish 3 | A | the software houses must be informed separately
935 | additional visually-relevant colour 3 | F | the software houses must be informed separately
936 | additional visually-relevant finish 4 | A | the software houses must be informed separately
937 | additional visually-relevant colour 4 | F | the software houses must be informed separately
938 | additional visually-relevant finish 5 | A | the software houses must be informed separately
939 | additional visually-relevant colour 5 | F | the software houses must be informed separately
940 | additional finishes and colours | F | the software houses must be informed separately
941 | additional finishes and colours | F | the software houses must be informed separately
942 | additional finishes and colours | F | the software houses must be informed separately
943 | additional finishes and colours | F | the software houses must be informed separately
944 | additional finishes and colours | F | the software houses must be informed separately
945 | additional finishes and colours | F | the software houses must be informed separately
946 | additional finishes and colours | F | the software houses must be informed separately
947 | additional finishes and colours | F | the software houses must be informed separately
948 | additional finishes and colours | F | the software houses must be informed separately
949 | additional finishes and colours | F | the software houses must be informed separately
950 | additional finishes and colours | F | the software houses must be informed separately
951 | additional finishes and colours | F | the software houses must be informed separately
952 | additional finishes and colours | F | the software houses must be informed separately
953 | additional finishes and colours | F | the software houses must be informed separately
954 | additional finishes and colours | F | the software houses must be informed separately
955 | additional finishes and colours | F | the software houses must be informed separately
956 | additional finishes and colours | F | the software houses must be informed separately
957 | additional finishes and colours | F | the software houses must be informed separately
958 | additional finishes and colours | F | the software houses must be informed separately
959 | additional finishes and colours | F | the software houses must be informed separately
960 | additional finishes and colours | F | the software houses must be informed separately
961 | additional finishes and colours | F | the software houses must be informed separately
962 | additional finishes and colours | F | the software houses must be informed separately
963 | additional finishes and colours | F | the software houses must be informed separately
964 | additional finishes and colours | F | the software houses must be informed separately
965 | additional finishes and colours | F | the software houses must be informed separately
966 | additional finishes and colours | F | the software houses must be informed separately
967 | additional finishes and colours | F | the software houses must be informed separately
968 | additional finishes and colours | F | the software houses must be informed separately
969 | additional finishes and colours | F | the software houses must be informed separately
970 | additional finishes and colours | F | the software houses must be informed separately
971 | additional finishes and colours | F | the software houses must be informed separately
972 | additional finishes and colours | F | the software houses must be informed separately
973 | additional finishes and colours | F | the software houses must be informed separately
974 | additional finishes and colours | F | the software houses must be informed separately
975 | additional finishes and colours | F | the software houses must be informed separately
976 | additional finishes and colours | F | the software houses must be informed separately
977 | additional finishes and colours | F | the software houses must be informed separately
978 | additional finishes and colours | F | the software houses must be informed separately
979 | additional finishes and colours | F | the software houses must be informed separately
980 | additional finishes and colours | F | the software houses must be informed separately
981 | additional finishes and colours | F | the software houses must be informed separately
982 | additional finishes and colours | F | the software houses must be informed separately
983 | additional finishes and colours | F | the software houses must be informed separately
984 | additional finishes and colours | F | the software houses must be informed separately
985 | additional finishes and colours | F | the software houses must be informed separately
986 | additional finishes and colours | F | the software houses must be informed separately
987 | additional finishes and colours | F | the software houses must be informed separately
988 | additional finishes and colours | F | the software houses must be informed separately
989 | additional finishes and colours | F | the software houses must be informed separately
990 | additional finishes and colours | F | the software houses must be informed separately
991 | additional finishes and colours | F | the software houses must be informed separately
992 | additional finishes and colours | F | the software houses must be informed separately
993 | additional finishes and colours | F | the software houses must be informed separately
994 | additional finishes and colours | F | the software houses must be informed separately
995 | additional finishes and colours | F | the software houses must be informed separately
996 | additional finishes and colours | F | the software houses must be informed separately
997 | additional finishes and colours | F | the software houses must be informed separately
998 | additional finishes and colours | F | the software houses must be informed separately
999 | additional finishes and colours | F | the software houses must be informed separately
1001 | Reference type | A |
1002 | Main reference type | A |
1003 | Main reference colour | F |
1004 | UNKNOWN TERM | A |
1005 | UNKNOWN TERM | F |
1006 | UNKNOWN TERM | A |
1007 | UNKNOWN TERM | F |
1008 | UNKNOWN TERM | A | UNKNOWN TERM
1009 | Seat cushion type | A |
1010 | Seat cushion colour | F |
1011 | Decorative cushion type | A | soft, firm, round, rectangular, ...
1012 | Decorative cushion colour | F |
1013 | Contrast stitching type / variation | A |
1014 | Contrast stitching colour | F |
1015 | Foot height | A |
1016 | Foot material | A | Metal, timber, plastic, beech,. ..
1017 | Foot shape | A | UNKNOWN TERM
1018 | Foot colour | F |
1019 | UNKNOWN TERM | A |
1020 | UNKNOWN TERM | F |
1021 | UNKNOWN TERM | A |
1022 | UNKNOWN TERM | F |
1023 | UNKNOWN TERM | A |
1024 | UNKNOWN TERM | F |
1025 | Side pocket type | A |
1026 | Side pocket colour | F |
1027 | UNKNOWN TERM | A |
1028 | UNKNOWN TERM | F |
1029 | UNKNOWN TERM | A |
1030 | UNKNOWN TERM | F |
1031 | Zipper type | A |
1032 | Zipper colour | F |
1033 | Seat hardness, quality | A | with/without spring core, ...
1034 | Drive type | A | Nozzle, manual, gas pressure spring, motor plug-in, motor battery, do
1035 | Seat height | A |
1036 | Seat depth | A |
1037 | Seat width | A |
1038 | Back height | A |
1039 | Back cushion height | A |
1040 | Back cushion type | A |
1041 | Armrests/side element configuration | A | without, left, right, both sides, ...
1042 | Armrests/side element type | A |
1043 | Side element adjustment | A |
1044 | Headrest finish | A | movable, fixed, neck rest, ...
1045 | Headrest colour | F |
1046 | UNKNOWN TERM | A | floor level, floor-free
1047 | Fabric combination | K |
1048 | Fire / flame retardant | A |
1049 | Resting area type | A |
1050 | Resting area colour | F |
1051 | Country version | A |
1052 | Crossways sleepers | A |
1053 | Seat angle adjustment | A |
1054 | Seat depth adjustment | A | mechanical, electric motor, gas pressure spring, ...
1055 | Backrest adjustment | A | mechanical, electric motor, gas pressure spring, ...
1056 | Footrest adjustment | A | mechanical, electric motor, gas pressure spring, ...
1057 | Massage function | A |
1058 | Seat heating | A |
1059 | Lumbar support | A |
1060 | Swivel base | A |
1061 | Stand-up aid | A | mechanical, electric motor, gas pressure spring, ...
1062 | Folding table | A |
1063 | UNKNOWN TERM | A |
1064 | Pull-out table | A |
1065 | Cupholder | A |
1066 | Headboard | A | Shape 1, shape 2 etc., headboard shortening at a surcharge, without K
1067 | Headboard fabric | A |
1068 | Throw-over | A | short, half-length, full length, shroud
1069 | Day cover fabric | A |
1070 | Lying surface | A | 160x200, 180x200, 200x200 etc., other lengths at a surcharge
1071 | Bedding box | A | standard, inserting mechanism, highline etc.
1072 | Bedding box upholstery | A |
1073 | Slatted base | A | Standard or alternatives against additional charge, additional sheet if necessary
1074 | Mattress | A | Standard or alternatives at a surcharge >> firmness level H2
1075 | Handles (for bedside tables) | F |
1076 | Bedside tables | A | Drawer with plastic or metal rails
1077 | Lamp colour and finish | A |
1078 | Knob cover | F |
1079 | Slatted base adjustment | A | mechanical, electric motor, gas pressure spring, combination ...
1080 | Function/adjustment in general | A |
1089 | Connection type L | P | ID of the connection vector in the SVG: AVL
1090 | Connection type R | P | ID of the connection vector in the SVG: AVR
1091 | Connection type custom 1 | P | ID of the connection vector in the SVG: AVC1
1092 | Connection type custom 2 | P | ID of the connection vector in the SVG: AVC2
1093 | Connection type custom 3 | P | ID of the connection vector in the SVG: AVC3
1094 | Connection type custom 4 | P | ID of the connection vector in the SVG: AVC4
1095 | Planning width | P | Item width
1096 | Planning depth | P | Item depth
1097 | Planning height | P | Item height
1098 | Drive position | A |
1099 | Table colour | F |
1100 | Head-section adjustment | A |
1101 | Relax function | A |
1102 | Vitalising function | A |
1103 | Power source/motor | A |
1104 | Accessories | A |
1105 | Top table | A |
1106 | Back holder | A |
1107 | Slot-in back | A |
1108 | Intermediate table | A |
1109 | Newspaper rack | A |
1110 | Swivel function | A |
1111 | Reading lamp | A |
1112 | Decorative item | A |
1500-1999 | freely defined feature | F |
2000 | Model number | A |
2001 | Hinge | A |
2010 | Front colour 4 | F | Front interior colour
2011 | Front height | A |
2012 | Front width | A |
2100 | Back panel finish | A |
2101 | Back panel colour | F |
2102 | Carcase finish back side for room divider | A | for room divider
2103 | Carcase colour back side for room divider | F | for room divider
2110 | Garment rail finish | A |
2111 | Garment rail colour | F |
2140 | Tabletop finish | A | for tables
2141 | Tabletop colour | F | for tables
2142 | Table edge finish | A | for tables
2143 | Table edge colour | F | for tables
2144 | Table frame finish | A | for tables
2145 | Table frame colour | F | for tables
2146 | Baseplate finish | A | for tables
2147 | Baseplate colour | F | for tables
2148 | Height adjustment | A | for tables
2149 | Pull-outs | A | for tables
2150 | Inserts | A | for tables
2151 | Insert finish | A | for tables
2152 | Insert colour | F | for tables
2153 | maximum length extending shelf | A | for tables
2160 | Bed frame finish | A |
2161 | Bed frame colour | F |
2162 | Bed frame finish | A |
2163 | Bed frame colour | F |
2164 | Head board finish | A |
2165 | Head board colour | F |
2166 | Head board fabric | A |
2167 | Head board fabric colour | F |
2168 | Foot board finish | A |
2169 | Foot board colour | F |
2170 | Foot board fabric | A |
2171 | Foot board fabric colour | F |
2200 | Handle 2 finish | A |
2201 | Handle 2 colour 1 | F | Handle, UNKNOWN TERM and/or main colour
2202 | Handle 2 colour 2 | F | UNKNOWN TERMS
2203 | Handle 2 combination | K | If only one key is specified for multiple handle conditions.
2204 | Handle 2 position | A | See handle position, pages 5-23
2205 | Handle 3 finish | A |
2206 | Handle 3 colour 1 | F | Handle, UNKNOWN TERM and/or main colour
2207 | Handle 3 colour 2 | F | UNKNOWN TERMS
2208 | Handle 3 combination | K | If only one key is specified for multiple handle conditions.
2209 | Handle 3 position | A | See handle position, pages 5-23
2300 | Front version | A |
2301 | Front colour 1 | F | Infill with smooth front panel = full surface
2302 | Front colour 2 | F | Frame
2303 | Front colour 3 | F | Pilaster strips
2304 | Edge colour front | F |
2305 | Front combination | K | If only one key is specified for multiple front information.
2306 | Front version | A |
2307 | Front colour 1 | F | Infill with smooth front panel = full surface
2308 | Front colour 2 | F | Frame
2309 | Front colour 3 | F | Pilaster strips
2310 | Edge colour front | F |
2311 | Front combination | K | If only one key is specified for multiple front information.
2312 | Front version | A |
2313 | Front colour 1 | F | Infill with smooth front panel = full surface
2314 | Front colour 2 | F | Frame
2315 | Front colour 3 | F | Pilaster strips
2316 | Edge colour front | F |
2317 | Front combination | K | If only one key is specified for multiple front information.
2318 | Front version | A |
2319 | Front colour 1 | F | Infill with smooth front panel = full surface
2320 | Front colour 2 | F | Frame
2321 | Front colour 3 | F | Pilaster strips
2322 | Edge colour front | F |
2323 | Front combination | K | If only one key is specified for multiple front information.
2324 | Front version | A |
2325 | Front colour 1 | F | Infill with smooth front panel = full surface
2326 | Front colour 2 | F | Frame
2327 | Front colour 3 | F | Pilaster strips
2328 | Edge colour front | F |
2329 | Front combination | K | If only one key is specified for multiple front information.
2330 | Front version | A |
2331 | Front colour 1 | F | Infill with smooth front panel = full surface
2332 | Front colour 2 | F | Frame
2333 | Front colour 3 | F | Pilaster strips
2334 | Edge colour front | F |
2335 | Front combination | K | If only one key is specified for multiple front information.
2336 | Front version | A |
2337 | Front colour 1 | F | Infill with smooth front panel = full surface
2338 | Front colour 2 | F | Frame
2339 | Front colour 3 | F | Pilaster strips
2340 | Edge colour front | F |
2341 | Front combination | K | If only one key is specified for multiple front information.
2342 | Front version | A |
2343 | Front colour 1 | F | Infill with smooth front panel = full surface
2344 | Front colour 2 | F | Frame
2345 | Front colour 3 | F | Pilaster strips
2346 | Edge colour front | F |
2347 | Front combination | K | If only one key is specified for multiple front information.
2348 | Front version | A |
2349 | Front colour 1 | F | Infill with smooth front panel = full surface
2350 | Front colour 2 | F | Frame
2351 | Front colour 3 | F | Pilaster strips
2352 | Edge colour front | F |
2353 | Front combination | K | If only one key is specified for multiple front information.
2354 | Front version | A |
2355 | Front colour 1 | F | Infill with smooth front panel = full surface
2356 | Front colour 2 | F | Frame
2357 | Front colour 3 | F | Pilaster strips
2358 | Edge colour front | F |
2359 | Front combination | K | If only one key is specified for multiple front information.
2360 | Front version | A |
2361 | Front colour 1 | F | Infill with smooth front panel = full surface
2362 | Front colour 2 | F | Frame
2363 | Front colour 3 | F | Pilaster strips
2364 | Edge colour front | F |
2365 | Front combination | K | If only one key is specified for multiple front information.
2366 | Front version | A |
2367 | Front colour 1 | F | Infill with smooth front panel = full surface
2368 | Front colour 2 | F | Frame
2369 | Front colour 3 | F | Pilaster strips
2370 | Edge colour front | F |
2371 | Front combination | K | If only one key is specified for multiple front information.
2372 | Front version | A |
2373 | Front colour 1 | F | Infill with smooth front panel = full surface
2374 | Front colour 2 | F | Frame
2375 | Front colour 3 | F | Pilaster strips
2376 | Edge colour front | F |
2377 | Front combination | K | If only one key is specified for multiple front information.
2378 | Front version | A |
2379 | Front colour 1 | F | Infill with smooth front panel = full surface
2380 | Front colour 2 | F | Frame
2381 | Front colour 3 | F | Pilaster strips
2382 | Edge colour front | F |
2383 | Front combination | K | If only one key is specified for multiple front information.
2384 | Front version | A |
2385 | Front colour 1 | F | Infill with smooth front panel = full surface
2386 | Front colour 2 | F | Frame
2387 | Front colour 3 | F | Pilaster strips
2388 | Edge colour front | F |
2389 | Front combination | K | If only one key is specified for multiple front information.
2390 | Front version | A |
2391 | Front colour 1 | F | Infill with smooth front panel = full surface
2392 | Front colour 2 | F | Frame
2393 | Front colour 3 | F | Pilaster strips
2394 | Edge colour front | F |
2395 | Front combination | K | If only one key is specified for multiple front information.
2396 | Front version | A |
2397 | Front colour 1 | F | Infill with smooth front panel = full surface
2398 | Front colour 2 | F | Frame
2399 | Front colour 3 | F | Pilaster strips
2400 | Edge colour front | F |
2401 | Front combination | K | If only one key is specified for multiple front information.
2402 | Front version | A |
2403 | Front colour 1 | F | Infill with smooth front panel = full surface
2404 | Front colour 2 | F | Frame
2405 | Front colour 3 | F | Pilaster strips
2406 | Edge colour front | F |
2407 | Front combination | K | If only one key is specified for multiple front information.
2408 | Front version | A |
2409 | Front colour 1 | F | Infill with smooth front panel = full surface
2410 | Front colour 2 | F | Frame
2411 | Front colour 3 | F | Pilaster strips
2412 | Edge colour front | F |
2413 | Front combination | K | If only one key is specified for multiple front information.
2414 | Front version | A |
2415 | Front colour 1 | F | Infill with smooth front panel = full surface
2416 | Front colour 2 | F | Frame
2417 | Front colour 3 | F | Pilaster strips
2418 | Edge colour front | F |
2419 | Front combination | K | If only one key is specified for multiple front information.
2420 | Front version | A |
2421 | Front colour 1 | F | Infill with smooth front panel = full surface
2422 | Front colour 2 | F | Frame
2423 | Front colour 3 | F | Pilaster strips
2424 | Edge colour front | F |
2425 | Front combination | K | If only one key is specified for multiple front information.
2426 | Front version | A |
2427 | Front colour 1 | F | Infill with smooth front panel = full surface
2428 | Front colour 2 | F | Frame
2429 | Front colour 3 | F | Pilaster strips
2430 | Edge colour front | F |
2431 | Front combination | K | If only one key is specified for multiple front information.
2432 | Front version | A |
2433 | Front colour 1 | F | Infill with smooth front panel = full surface
2434 | Front colour 2 | F | Frame
2435 | Front colour 3 | F | Pilaster strips
2436 | Edge colour front | F |
2437 | Front combination | K | If only one key is specified for multiple front information.
2438 | Front version | A |
2439 | Front colour 1 | F | Infill with smooth front panel = full surface
2440 | Front colour 2 | F | Frame
2441 | Front colour 3 | F | Pilaster strips
2442 | Edge colour front | F |
2443 | Front combination | K | If only one key is specified for multiple front information.
2444 | Front version | A |
2445 | Front colour 1 | F | Infill with smooth front panel = full surface
2446 | Front colour 2 | F | Frame
2447 | Front colour 3 | F | Pilaster strips
2448 | Edge colour front | F |
2449 | Front combination | K | If only one key is specified for multiple front information.
2500-2699 | freely defined feature | F | commercial
2700-2999 | freely defined feature | F | graphic

Freely defined features are available from 2500 to 2999.

Type: A = finish

F = colour

K = Combination

S = shape

P = planning


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Model code
Introduction > Model code

Model code

This element is used to specify the model code:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE

The following model codes have been defined:

No. | Type
1010 | Carcase element
1020 | Cabinet
1030 | Display cabinet
1040 | Shelf
1050 | Highboard/sideboard/dressers/buffets/lowboard
1060 | TV, audio, media furniture
1070 | Front
1080 | Shelving system element
1090 | Bedside table/side table/chest of drawers/powder room table
1100 | Coffee table/occasional table
1110 | Dining table
1120 | Writing desk/computer desk
1130 | Bureau
1140 | Chair
1150 | Stool/bar stool
1160 | Corner bench/bench
1170 | Children/play furniture/nappy change table/nappy change unit
1180 | Bed
1190 | Mattress/slatted frame/set
1200 | Bedside table/chest of drawers/cupboard/cabinet
1210 | Castor containers/upside containers
1220 | Bar counter equipment/home bar furniture
1230 | Wardrobe/hall furniture
1240 | Shoe cupboard
1250 | Chests
1260 | Mirror
1270 | Panel
1280 | Plinth/pedestal
1290 | Cover panel
1300 | Cornice/cornice profile/passe-partout
1310 | Lighting
1320 | Combination/set
1330 | Fixed panel/filler piece
1340 | Accessories
1350 | Other


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Model code types
Introduction > Model code types

No. | Type | Assignment
000 | All |
100 | Hinged door | 1010;1020;1030;1050;1060;1070;1090;1230;1240
110 | Folding door/angled door | 1010;1020;1030;1050;1060;1070;1090;1230;1240
120 | Sliding door | 1010;1020;1030;1050;1060;1070;1090;1230;1240
130 | Drawer | 1010;1020;1030;1050;1060;1070;1090;1230;1240
140 | Flap door | 1010;1020;1030;1050;1060;1070;1090;1230;1240
150 | Pull-out | 1010;1020;1030;1050;1060;1070;1090;1230;1240
160 | Combination front | 1010;1020;1030;1050;1060;1070;1090;1230;1240
170 | Shutter/roller shutter/slats | 1010;1020;1030;1050;1060;1070;1090;1230;1240
200 | Inside drawer | 1340
210 | Inside shelf | 1340
220 | Interior partitioning | 1340
230 | Wardrobe accessories (clothes rail, laundry basket ...) | 1340
240 | Speakers/receivers | 1340
250 | TV support | 1340
260 | Miscellaneous | 1340
300 | Modular parts/line pedals/stiles | 1080
310 | Stiles/cupboard/hook-ins/light/shelf | 1080
320 | Plinth base | 1080
330 | Rack/push-fit shelf | 1080:1340
340 | Rear panel | 1080;1120;1340
400 | Tabletop | 1100;1110;1120;1340
410 | Table frames | 1100;1110;1120;1340
420 | Plug-in panel/insert | 1100;1110;1120;1340
430 | 4-legged table/frame | 1100;1110;1120;1340
440 | Pedestal tables/frame | 1100;1110;1120;1340
450 | C-pedestal | 1120;1340
460 | A-pedestal | 1100;1110;1120;1340
470 | T-pedestal | 1100;1110;1120;1340
500 | Dining chair/stackable chair | 1140
510 | Castor chairs, chair with wheels | 1140
520 | Child's chair | 1140;1170
600 | Bed frame/head board/foot board | 1180
610 | Loft bed/mid bed/bunk bed/cave bed | 1170;1180
620 | Child bed/cot | 1170;1180
630 | Box spring bed | 1180
640 | Bed sofa/guest bed/foldable recliner | 1180
650 | Wall, foldaway bed | 1180
660 | Water bed | 1180
670 | Upholstered bed | 1180
700 | Bench cushion | 1340
710 | Handles | 1340
720 | Small hardware items | 1340
800 | Preferred combination | 1320
810 | Suggested combination | 1320


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Variation code
Introduction > Variation code

No. | Finish
00 | All
10 | Single element
20 | Basic element
30 | Add-on element
40 | Corner element
50 | Filler element
60 | Dresser element
70 | Hanging element
80 | Base element


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Information key
Introduction > Information key

Property no.

Designation

Description

Unit of measure

Value

Information for washing machines

100

RATED_CAPACITY

Nominal capacity in kg cotton for the standard program "Cotton 60°C" or the standard program

"Cotton 40°C", respectively with full load, with the lower of the two values being authoritative

kg

numerical

101

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 1

A+++ … D

102

WEIGHTED_ANNUAL_ENERGY_CONSUMPTION

weighted annual energy consumption (AE C) in KWh/a, rounded to the next integer. This value must be specified as: Energy consumption of "X" kWh/a on the basis of 220 standard washing cycles at 60°C and 40°C cotton programs with full load and partial load, as well as consumption of operating modes with low power consumption. The actual energy consumption depends on the actual use of the appliance.

kWh per year

numerical

103

ENERGY_CONSUMPTION

Energy consumption (E t,60 , E t,60½ , E t,40½ ) of the standard program "Cotton 60°C" with full load and partial load, as well as the "Cotton 40°C" standard program with partial load.

kWh

numerical

104

WEIGHTED_POWER_CONSUMPTION_OFF

weighted power consumption when switched off

W

numerical

105

WEIGHTED_POWER_CONSUMPTION_ON

weighted power consumption when switched on

W

numerical

106

WEIGHTED_ANNUAL_WATER_CONSUMPTION

weighted annual water consumption (AW C) in liters/a, rounded to the next integer. This value must be specified as: Water consumption of "X" litres/a on the basis of 220 standard washing cycles at 60°C and 40°C cotton programs with full load and partial load. The actual water consumption depends on the actual use of the appliance.

litres per year

numerical

107

SPIN_DRYING_EFFICIENCY_CLASS

spinning efficiency class, determined using table 2 and expressed as spinning efficiency class "X" on a scale from G (lowest efficiency) to A (highest efficiency). A different design can be used as long as it is made clear that the scale ranges from G (lowest efficiency) to A (highest efficiency).

A … G

108

MAX_SPIN_SPEED

maximum spinning speed for standard program "Cotton 60°C" with full load or for standard program "Cotton 40°C" with partial load, with the lower value being authoritative, as well as residual humidity for standard program "Cotton 60°C" with full load or for standard program "Cotton 40°C" with partial load, with the higher value being authoritative

revolutions per minute

numerical

109

INDICATION_STANDARD

information about the fact that the standard programs "Cotton 60°C" and "Cotton 40°C" are the standard washing programs to which the information on the label and data sheet refer, that these programs are suitable for washing averagely dirty cotton fabrics and the most efficient ones with respect to the combined energy and water consumption

Character sequence ST or blank

110

PROGRAMME_TIME

Program duration of the standard program "Cotton 60°C" with full load and partial load, as well as the "Cotton 40°C" standard program with partial load in minutes, rounded to the next minute

min

numerical

111

DURATION_LEFT_ON_MODE

Time appliance is in switched on mode (T I ) if the household washing machine is equipped with power control

min

numerical

112

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Airborne acoustical emissions in db(A) re 1 pW, rounded to the next integer, during washing and spinning in the standard program "Cotton 60°C" with full load.

dB

numerical

Information for dishwashers

120

RATED_CAPACITY

Nominal capacity in standard place settings for the standard cleaning mode

Quantity

numerical

121

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 3

A+++ … D

122

ANNUAL_ENERGY_CONSUMPTION

annual energy consumption (AE C ) in KWh/a, rounded to the next integer. This value must be stated as energy consumption "X" kWh/a on the basis of 280 standard cleaning cycles with cold water and the consumption incurred in the operating modes with the lowest power consumption. The actual energy consumption depends on the actual use of the appliance.

kWh per year

numerical

123

ENERGY_CONSUMPTION

Energy consumption (E t ) of the standard cleaning cycle

kWh

numerical

124

POWER_CONSUMPTION_OFF

weighted power consumption when switched off

W

numerical

125

POWER_CONSUMPTION_ON

weighted power consumption when switched on

W

numerical

126

WEIGHTED_ANNUAL_WATER_CONSUMPTION

weighted annual water consumption (AW C ) in liters/a, rounded to the next integer. This must be stated as: water consumption "X" litres/a based on 280 standard dishwashing cycles. The actual water consumption depends on the actual use of the appliance.

litres per year

numerical

127

DRYING_EFFICIENCY_CLASS

Drying efficiency class, determined in accordance with table 4 and expressed as the drying efficiency class "X" on a scale from G (lowest efficiency) to A (highest efficiency). A different design may be used if data is displayed in a table, provided it is made clear that the scale ranges from G (lowest efficiency) to A (highest efficiency).

A … G

128

INDICATION_STANDARD

Information about the fact that the "standard program" is the cleaning cycle to which the information on the label and data sheet refer, that this program is suitable for washing averagely dirty dishes and the most efficient one with respect to the combined energy and water consumption

Character sequence ST or blank

129

PROGRAMME_TIME

Program duration of the standard cleaning cycle in minutes, rounded to the next integer

min

numerical

130

DURATION_LEFT_ON_MODE

Time appliance is in switched on mode (T I ) if the household dishwasher is equipped with power control

min

numerical

131

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Airborne acoustical emissions in db(A) re 1 pW, rounded to the next integer

dB

numerical

Information for tumble dryers

140

RATED_CAPACITY

Nominal capacity in kg cotton clothing for the standard cotton program with full load

kg

numerical

141

TUMBLE_KIND

whether the household tumble dryer is an exhaust air, condensation or gas-heated household tumble dryer

Code A, C or G

142

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 5

A+++ … D

143

WEIGHTED_ANNUAL_ENERGY_CONSUMPTION

for electrically heated household tumble dryers:

weighted annual energy consumption (AE c ) in KWh/a, rounded to one decimal space. This value must be specified as: Energy consumption of "X" kWh/a on the basis of 160 drying cycles for the standard cotton program with full load and partial load, as well as consumption of operating modes with low power consumption. The actual energy consumption per cycle depends on the actual use of the appliance.

for gas-heated household tumble dryers:

weighted annual energy consumption (AE c (gas) ) in KWh/a, rounded to one decimal space. This value must be specified as: Energy consumption of "X" gas kWh/a on the basis of 160 drying cycles for the standard cotton program with full load and partial load. The actual energy consumption per cycle depends on the actual use of the appliance.

and

weighted annual energy consumption (AE C (gas)el ), rounded to one decimal space. This value must be specified as: Energy consumption of "X" kWh/a on the basis of 160 drying cycles for the standard cotton program with full load and partial load, as well as consumption of operating modes with low power consumption. The actual energy consumption per cycle depends on the actual use of the appliance.

kWh per year

numerical

144

AUTOMATIC

whether the household tumble dryer is a tumble dryer with automatic controls or a tumble dryer without automatic controls

1=true
0=false

145

ENERGY_CONSUMPTION

Energy consumption (E dry , E dry½ , Eg dry , Eg dry½ , Eg dry,a , Eg dry½,a ) of the standard cotton program with full load and partial load

kWh

numerical

146

POWER_CONSUMPTION_OFF

Power consumption when switched off (P o ) for the standard cotton program with full load

W

numerical

147

POWER_CONSUMPTION_ON

Power consumption when switched on (P I ) for the standard cotton program with full load

W

numerical

148

DURATION_LEFT_ON_MODE

Time appliance is in switched on mode if the household tumble dryer is equipped with power control

min

numerical

149

INDICATION_STANDARD

Information about the fact that the "standard cotton program" with full and partial load is the standard drying program to which the information on the label and data sheet refers, that this program is suitable for drying normally wet cotton clothes and the most efficient one for cotton with respect to the energy consumption

Character sequence ST or blank

150

WEIGHTED_PROGRAMME_TIME

weighted program duration (T t ) of the "standard cotton program with full and partial load" in minutes, rounded to the next full minute

min

numerical

151

WEIGHTED_PROGRAMME_TIME

Program duration of the "standard cotton program" with full load (T dry ) in minutes, rounded to the next full minute

min

numerical

152

WEIGHTED_PROGRAMME_TIME

Program duration of the "standard cotton program" with partial load (T dry½ ) in minutes, rounded to the next full minute

min

numerical

153

CONDENSATION_EFFICIENCY

if the household tumble dryer is a condensation dryer, the condensation efficiency class as stated in table 6 expressed as "condensation efficiency class 'X' on a scale from G (lowest efficiency) to A (highest efficiency); a different design can be used provided it is made clear that the scale ranges from G (lowest efficiency) to A (highest efficiency)

A … G

154

AVERAGE_CONDENSATION_EFFICIENCY

if the household tumble dryer is a condensation dryer, the average condensation efficiency C dry and C dry½ of the standard cotton program with full load and partial load and the weighted condensation efficiency (C t ) for the standard cotton program with full and partial load expressed as a percentage number rounded to the next full percent

%

numerical

155

SOUND_POWER_LEVEL

Sound power level (weighted average value - L WA ) in db, rounded to the next integer, for the standard cotton program with full load

dB

numerical

Information for combo washer dryers

160

ENERGY_EFFICIENCY_CLASS

Energy efficiency class of the model as per table 7, expressed as "energy efficiency class". . . on a scale from A (low energy consumption) to G (high energy consumption)". A different design may be used if data is displayed in a table, provided it is made clear that the scale ranges from G (lowest efficiency) to A (highest efficiency).

A … G

161

ENERGY_CONSUMPTION

Energy consumption in kWh per completed operating cycle (washing, spinning, drying)

kWh

numerical

162

ENERGY_CONSUMPTION_W_D_ONLY

Energy consumption in kWh for the washing and spinning program only

kWh

numerical

163

WASHING_PERFORMANCE

Washing performance class as per table 8, expressed as "washing performance class . on a scale from A (better) to G (poor)". A different design can be used as long as it is made clear that the scale ranges from A (better) to G (poor).

A … G

164

WATER_EXTRACTION_EFFICIENCY

Spinning performance for the standard program "Cotton 60°C", expressed as "residual humidity after spinning ...% (percentage of the dry weight of the load)"

%

numerical

165

MAX_SPIN_SPEED

maximum spinning speed for the standard program "Cotton 60°C"

revolutions per minute

numerical

166

WASH_CAPACITY

Load capacity (washing) of the appliance for the standard program "Cotton 60°C"

kg

numerical

167

DRY_CAPACITY

Load capacity (drying) of the appliance for the standard program "Cotton shelf-dry"

kg

numerical

168

WATER_CONSUMPTION

Water consumption in 1 per completed operating cycle (washing, spinning and drying)

litres

numerical

169

WATER_CONSUMPTION_W_D_ONLY

Water consumption in 1 for washing and spinning only for the standard program "Cotton 60°C"

litres

numerical

170

WASHING_DRYING_TIME

Washing and drying time: duration until operating cycle (washing, spinning and drying) is completed in the standard program "Cotton 60°C" and the drying program "Cotton shelf-dry" with nominal capacity load

min

numerical

171

ENERGY_WATER_CONSUMPTION

Energy and water consumption based on 200 standard cycles, expressed as the estimated annual consumption of a 4-person household that always uses the combo washer dryer for drying (200 programs)

kWh

numerical

172

NOISE_EMISSION

Noise emissions during washing, spinning and drying in the standard program "Cotton 60°C" and "Cotton, shelf-dry",

dB

numerical

Information for refrigerators

180

CATEGORY

Household refrigerator category as per tables 9 and 10

numerical

1 … 10

181

ENERGY_EFFICIENCY_CLASS

Energy efficiency class of the model as per table 11

A+++ … G

182

ANNUAL_ENERGY_CONSUMPTION

annual energy consumption (AE C ) in KWh/a in accordance with no. 3 (2) of Annex VIII, rounded to the next integer. To be stated as: Energy consumption 'XYZ' kWh/a based on results of standard testing over 24 hours. The actual consumption depends on the use and location of the appliance.

kWh per year

numerical

183

STORAGE_VOLUMNE

Capacity of each compartment and, if applicable, star rating in accordance with the total capacity of all freezer compartments that have a star rating (i.e. with an operating temperature ≤ – 6 °C), rounded to the next integer, and star rating of the compartment with the highest share in the total; if the household refrigerator does not have freezer compartments, the supplier will specify "- L" instead of a value and leave the position for the star ranking blank

litres

numerical

184

DESIGN_TEMPERATURE

Design temperature "other compartments" in the meaning of Annex I letter n. For wine chilling compartments, the lowest chilling temperature that is preset for the compartment, or that can be set by the consumer in accordance with the manufacturer's instructions, and that can be maintained permanently

°C

numerical

185

FROST_FREE

Information "Frost-free" for the relevant compartment(s) other than wine chilling compartments and intended for storage of certain foods with a temperature higher than + 14 °C

Compartment, counted from the bottom up

numerical

186

TEMPERATURE_RISE_TIME

"Storage time during malfunction 'X' h" defines the "temperature rise time"

h

numerical

187

FREEZING_CAPACITY

"Freezing capacity" in kg/24h

kg/24 h

numerical

188

CLIMATE_CLASS

"Climate class" as per table 12, expressed as: climate class: W [climate class]. This appliance is designed for operation in ambient temperatures between 'X' [lowest temperature] °C and 'X' [highest temperature] °C.

SN, N, ST or T

189

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Airborne acoustical emissions in db(A) re 1 pW, rounded to the next integer

dB

numerical

190

WINE_ONLY

the following must be stated for wine chillers: "This appliance is intended for the storage of wine only." This does not apply to household refrigerators that are not specifically designed for wine chilling but can be used for this purpose and not to household refrigerators that have a wine chilling compartment that is combined with another type of compartment.

1=true

0=false

Information for ovens

200

NUMBER_CAVITY

number of cooking chambers

Quantity

numerical

201

ENERGY_EFFICIENCY_INDEX

the energy efficiency index (EEIcavity) for the first cooking chamber of the model, rounded to one decimal space

numerical

202

ENERGY_EFFICIENCY_CLASS

the energy efficiency class of the model for the first cooking chamber as per table 13

A+++ … D

203

ENERGY_CONSUMPTION

the energy consumption per cycle for the first cooking chamber in conventional cooking mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

204

ENERGY_CONSUMPTION

the energy consumption per cycle for the first cooking chamber in fan-forced mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

205

HEAT_SOURCE_CAVITY

the heat source for the first cooking chamber

E or G

206

VOLUMNE_ CAVITY

the volume of the first cooking chamber

litres

numerical

207

ENERGY_EFFICIENCY_INDEX

the energy efficiency index (EEIcavity) for the second cooking chamber of the model, rounded to one decimal space

208

ENERGY_EFFICIENCY_CLASS

the energy efficiency class of the model for the second cooking chamber as per table 13

A+++ … D

209

ENERGY_CONSUMPTION

the energy consumption per cycle for the second cooking chamber in conventional cooking mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

210

ENERGY_CONSUMPTION

the energy consumption per cycle for the second cooking chamber in fan-forced mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

211

HEAT_SOURCE_CAVITY

the heat source for the second cooking chamber

E or G

212

VOLUMNE_ CAVITY

the volume of the second cooking chamber

litres

numerical

213

ENERGY_EFFICIENCY_INDEX

the energy efficiency index (EEIcavity) for the third cooking chamber of the model, rounded to one decimal space

numerical

214

ENERGY_EFFICIENCY_CLASS

the energy efficiency class of the model for the third cooking chamber as per table 13

A+++ … D

215

ENERGY_CONSUMPTION

the energy consumption per cycle for the third cooking chamber in conventional cooking mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

216

ENERGY_CONSUMPTION

the energy consumption per cycle for the third cooking chamber in fan-forced mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

217

HEAT_SOURCE_CAVITY

the heat source for the third cooking chamber

E or G

218

VOLUMNE_ CAVITY

the volume of the third cooking chamber

litres

numerical

Information for cooker hoods

220

ANNUAL_ENERGY_CONSUMPTION

the annual energy consumption (AEC hood) in kWh/a, rounded to one decimal space

kWh per year

numerical

221

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 14

A+++ … G

222

FLUID_DYNAMIC_EFFICIENCY

The calculated fluid-dynamic efficiency (FDE hood), rounded to one decimal space

numerical

223

FLUID_DYNAMIC_EFFICIENCY_CLASS

The fluid-dynamic efficiency clause as per table 15

A … G

224

LIGHTING_EFFICIENCY

the calculated lighting efficiency (LE hood) in lx/W, rounded to one decimal space

numerical

225

LIGHTING _EFFICIENCY_CLASS

The lighting efficiency class as per table 16, the specified class must not be higher than the class stated in the technical documentation

A … G

226

GREASE_FILTERING_EFFICIENCY

the calculated grease filtering degree in percent, rounded to one decimal space. The stated value must not be higher than the value stated in the technical documentation.

%

numerical

227

GREASE_FILTERING _EFFICIENCY_CLASS

the class for level of grease separation as per table 17

A … G

228

AIR_FLOW

the air flow (in m 3 /h, rounded to the next integer) at maximum and minimum speed in normal mode; intensive mode and fast mode are excluded

m³/h

numerical

229

AIR_FLOW_INTENSIVE

if applicable, the air flow (in m 3 /h, rounded to the next integer) in intensive mode and fast mode

m³/h

numerical

230

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

the A-rated airborne critical noise emissions (in dB, rounded to the next integer) at minimum and maximum available speed in normal mode

dB

numerical

231

AIRBORNE_ACOUSTICAL_NOISE_EMISSION_INT

if applicable, the A-rated airborne acoustical noise emissions (in dB, rounded to the next integer) in intensive mode and fast mode

dB

numerical

232

POWER_CONSUMPTION_OFF

if applicable, the power consumption while switched off (P o ) in Watt, rounded to two decimal spaces

W

numerical

231

POWER_CONSUMPTION_ON

if applicable, the power consumption in standby mode (P o ) in Watt, rounded to two decimal spaces

W

numerical

Information for electrical lamps and lights

240

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 18

A++ … E

241

WEIGHTED_ENERGY_CONSUMPTION

weighted energy consumption (EC) in KWh/1000h, rounded to the next integer.

kWh per 1000 hours

numerical

242

ENERGY_EFFICIENCY_CLASS_COMPATIBILITY

The energy efficiency classes of lights that can be exchanged by the user and with which the light is compatible in accordance with state-of-the-art compatibility requirements

A++ … E

243

ENERGY_EFFICIENCY_CLASS_N_COMPATIBILITY

The energy efficiency classes of lights with which the lamp is incompatible in accordance with state-of-the-art compatibility requirements

A++ … E

244

ENERGY_EFFICIENCY_CLASS_LED

The energy efficiency classes for LED modules not intended for removal by the consumer

A++ … E

245

ENERGY_EFFICIENCY_CLASS_INCLUDED

The energy efficiency classes for lamps operated with the lights that can be exchanged by the consumer and that are included in the lamp's packaging

A++ … E

Information for TVs

260

ENERGY_EFFICIENCY_CLASS

Energy efficiency class of the model as per table 19

A+++ … G

261

SCREEN_DIAGONAL_CM

visible screen size in centimetres

cm

numerical

262

SCREEN_DIAGONAL_INCH

visible screen size in inches

inch

numerical

263

POWER_CONSUMPTION_ON

Power consumption while switched on

W

numerical

264

ANNUAL_ENERGY_CONSUMPTION

The calculated annual energy consumption in kWh/a, rounded to the next integer. This value is to be stated as: energy consumption XYZ kWh/a based on four hours of daily operation of the TV on 365 days. The actual energy consumption depends on the actual use of the TV.

kWh per year

numerical

265

POWER_CONSUMPTION_OFF

Power consumption while switched off

W

numerical

266

POWER_CONSUMPTION_STANDBY

Power consumption in standby mode

W

numerical

267

SCREEN_RESOLUTION_HORIZONTAL

Screen resolution, measured in the physical horizontal number of pixels.

pt

numerical

268

SCREEN_RESOLUTION_VERTICAL

Screen resolution, measured in the physical vertical number of pixels.

pt

numerical

Information for heating appliances: 280-300

Information for air-conditioners: 300-320

Information for single room heating appliances: 320-340

Information for vacuum cleaners: 340-360

Information for commercial refrigeration cabinets: 360-380

Information for residential ventilation appliances: 380-400

Information for solid fuel boilers and composite systems including solar installations: 400-420

The required numerical data must not be negative numbers. No decimal comma is used for numbers in the thousand range. Decimal spaces are preceded by a dot.

Properties can be freely assigned to the values 800-999.

1. ENERGY EFFICIENCY CLASSES for washing machines

The energy efficiency class of a household washing machine is determined on the basis of its energy efficiency index (EEI) as per table 1.

The energy efficiency index (EEI) of a household washing machine is determined as per table 1.

2. SPINNING EFFICIENCY CLASSES for washing machines

The spinning efficiency class of a household washing machine is determined on the basis of the residual humidity (D) as per table 2.

3. ENERGY EFFICIENCY CLASSES for dishwashers

The energy efficiency class of a household dishwasher is determined on the basis of its energy efficiency index (EEI)

as per table 3.

4. DRYING EFFICIENCY CLASSES for dishwashers

table 4

5. ENERGY EFFICIENCY CLASSES for tumble dryers

The energy efficiency class of a household tumble dryer is determined on the basis of its energy efficiency index (EEI) as per table 5.

table 5

6. CONDENSATION EFFICIENCY CLASSES

The condensation efficiency class of a household condensation tumble dryer is determined on the basis of the weighted condensation efficiency (C t ) as per table 6.

table 6

7. EFFICIENCY CLASSES for combo washer dryers

table 7: efficiency classes

Table 8: washing performance classes

8. CLASSIFICATION OF HOUSEHOLD REFRIGERATORS

The household refrigerators are classified in categories in accordance with table 9.

Each category is determined by a certain composition of compartments in accordance with table 10 and independent from the number of doors and/or drawers.

table 9

Household refrigerators that cannot be assigned to category 1 to 9 due to their compartment temperatures must be assigned to category 10.

Table 10

Household refrigerator classification and compartment composition

9. EFFICIENCY CLASSES for refrigeration appliances

The energy efficiency class of a household tumble dryer is determined on the basis of its energy efficiency index (EEI) as per table 5.

table 11

table 12

10. ENERGY EFFICIENCY CLASSES for ovens

The energy efficiency classes for household ovens are determined for each cooking chamber in accordance with the values in table 13.

11. EFFICIENCY CLASSES for cooker hoods

The energy efficiency classes ofcooker hoodsare determined in accordance with the values in table 14.

The classes for the fluid-dynamic efficiency of a household cooker hood are determined on the basis of their fluid-dynamic efficiency (FDE hood) in accordance with the following table 15.

The classes for the illumination efficiency of a household cooker hood are determined on the basis of their illumination efficiency (LE hood) in accordance with the following table 16.

The classes for the level of grease separation of a household cooker hood are determined on the basis of their grease separation level (GFE hood) in accordance with the following table 17

12. ENERGY EFFICIENCY CLASSES for lamps

table 18: energy efficiency classes

13. ENERGY EFFICIENCY CLASSES for TVs

table 19: energy efficiency classes for TVs

The official EU journals pertaining to the relevant directives and regulations can be found at the following links:

http://www.newenergylabel.com/index.php/start/

http://ec.europa.eu/energy/sites/ener/files/documents/list_of_enegy_labelling_measures.pdf

Links to the individual product groups are available in multiple languages.


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Language key
Introduction > Language key

Language key | Language name
AA | Afar
AB | Abkhasian
AE | Avestan
AF | Afrikaans
AM | Amharic
AN | Aragonese
AR | Arabic
AS | Assam
AY | Aymara
AZ | Azerbaijanian
BA | Baschkirian
BE | Byelorussian
BG | Bulgarian
BH | Biharic
BI | Bislamic
BM | Bambara
BN | Bengal
BO | Tibetan
BR | Breton
BS | Bosnian
CA | Catalan
CE | Circassian
CH | Chamorro
CO | Corsican
CS | Czech
CU | Old slavish
CV | Chuvash
CY | Welsh
DA | Danish
DE | German
DV | Dhivehi
DZ | Dzongkha
DV | Dhivehi
EE | Estonian
EL | Greek
EN | English
EO | Esperanto
ES | Spanish
ET | Estonian
EU | Basque
FA | Persian
FF | Fulfulde
FI | Finno-Ugric
FJ | Fiji
FO | Faroese
FR | French
FY | Frisian
GA | Irish
GD | Gaelic
GL | Galician
GN | Guarani
GU | Gujaratic
GV | Manx, Manx-Gaelic
HA | Hausa
HE | Hebrew
HI | Hindi
HO | Hiri Motu
HR | Croatian
HT | Haitian
HU | Hungarian
HY | Armenian
HZ | Herero
IA | Interlingua
ID | Indonesian
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiak
IN | former Indonesian
IO | Ido
IS | Icelandic
IT | Italian
IU | Inuit
JA | Japanese
JV | Javanese
KA | Georgian
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kazakh
KL | Kalaallisut (Greenland)
KM | Cambodian
KN | Canadian
KO | Korean
KR | Kanuri
KS | Kashmirian
KU | Kurdish
KV | Komi
KW | Cornish
KY | Kirghiz
LA | Latin
LB | Luxembourgish
LG | Luganda
LI | Limburg
LN | Lingala
LO | Laotian
LT | Lithuanian
LU | Kiluba
LV | Lett
MG | Malagasy
MH | Marshallese
MI | Maori
MK | Macedonian
ML | Malay
MN | Mongolian
MO | Moldovan
MR | Marathi
MS | Malayan
MT | Maltese
MY | Burmese
NA | Nauruan
NB | Norwegian Bokmål
ND | North Ndebele
NE | Nepalese
NG | Ndonga
NL | Dutch
NN | Norwegian Nynorsk
NO | Norwegian
NR | South Ndebele
NV | Navajo
NY | Chichewa
OC | Occitan
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Punjab
PI | Pali
PL | Polish
PS | Paschtu
PT | Portugese
QU | Quechua
RM | Rhaeto-Romanic
RN | Kirundisch
RO | Romanian
RU | Russian
RW | Kijarwanda
SA | Sanskrit
SC | Sardinian
SD | Sinto
SE | North Sami
SG | Sango
SI | Sinhalese
SK | Slovakian
SL | Slovenian
SM | Samoan
SN | Shonian
SO | Somali
SQ | Albanian
SR | Serbian
SS | Swazi
ST | Sesothisch
SU | Sudanese
SV | Swedish
SW | Swahili
TA | Tamil
TE | Tegulu
TG | Tajik
TH | Thai
TI | Tigrinja
TK | Turkmenian
TL | Tagalog
TN | Sezuan
TO | Tongan
TR | Turkish
TS | Tongan
TT | Tartary
TW | Twi
TY | Thai
UG | Uighur
UK | Ukranian
UR | Urdu
UZ | Uzbek
VI | Vietnamese
VO | Volapük
WA | Walloon
WO | Wolof
XH | Xhosa
YI | Yiddish
YO | Joruba
ZA | Zhuang
ZH | Chinese
ZU | Zulu

</</


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Country code
Introduction > Country code

country code | country (German) | country (English)
AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Types of detailed information
Introduction > Types of detailed information

The following info types can be used to describe the type of detail information:

1 = Milieu photo
2 = Item pictogram (type/item overview)
3 = Magnetic planner drawing (SVGs in top view)
4 = Option photo
5 = Front option (front texture, ...)
6 = Manufacturer logo/product brand
7 = Colour consultancy (the options are defined in an assessment procedure)
8 = Material pass (PDF attached to the fronts)
9 = Model description sheets (PDF below series)
10 = Installation instructions
11 = Marketing
12 = Miscellaneous
13 = Colour consultancy wall
14 = Colour consultancy floor
15 = Item pictogram view


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Notes to the documentation


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Element reference


%%LocalItemTitle%%

IDMW 2.0 XML-Schema Dokumentation
T_NEW_CATALOG Element
IDMW 2.0 XML-Schema Dokumentation : T_NEW_CATALOG Element
Description
This element is used to specify all information and data for the provisioning of a complete catalogue/data pool.
Namespace (none)
Diagram
PRICE_DEFINITION Element FEATURE_DEFINITION Element PART_LISTS Element SERIES Element GLOBAL_DEFINITION Element SUPPLIER Element CATALOG Element Sequence T_NEW_CATALOG Element
Overview
T_NEW_CATALOG
This element is used to specify all information and data for the provisioning of a complete catalogue/data pool.
MAJOR required List of xs:positiveInteger
The version number "MAJOR" specifies the format version the data pool is delivered. The major version number will only change in the case of a fundamental revision of the entire format.
The complete information about the format version in which a data pool is delivered consists of MAJOR, MINOR and REVISION. 		D positiveInteger
P
M [2:2]
MINOR required Restriction of xs:nonNegativeInteger
The sub-version number "MINOR" usually changes every year. If the main version MAJOR is modified, the subversion is reset to 0.
 D nonNegativeInteger
P
M [0:0]
REVISION required Restriction of xs:nonNegativeInteger
The revision number "REVISION" highlights changes during the year resultant from individual working groups. The revisions are not published if they are not concerned with necessary corrections. Revision is reset to 0 with each new MINOR sub-version number.
 D nonNegativeInteger
P
M [0:0]
FORMAT required Restriction of xs:string

This element is used to specify the manufacturer's industry code. The following industry codes are currently defined:

A = worktop manufacturers
B = bathroom furniture manufacturers
G = appliance manufacturers
K = kitchen furniture manufacturers
O = office furniture manufacturers
P = upholstered furniture manufacturers
S = sanitary products manufacturers
W = living room furniture manufacturers
Z = accessories manufacturers

The identifier W is the only value permitted for this element.

 D string
P [W]
M [1:1]
Sequence
CATALOG
This element is used to store administrative information concerning the catalogue/data pool.
Sequence
CATALOG_IDENTIFICATION
This element is used to specify the catalogue's identifying characteristics.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data must be identical.
Sequence
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used. D language
P [A-Za-z]{1,3}
M [1:3]
CURRENCY_KEY Restriction of xs:string
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
CATALOG_NUMBER Restriction of xs:string
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
CATALOG_NAME languagetext30 Complex Type
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names that include the year are permitted.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
The data version (DATA_VERSION) defines the date until which catalogue data, supplements and error corrections published by the manufacturer was included in the data pool. D date
P
M
VALID_FROM_DATE Restriction of xs:date
The element is used to specify the validity period date of the catalogue and thereby of the current data pool. D date
P
M
VALID_UNTIL_DATE Restriction of xs:date
The element is used to specify the validity period date of the catalogue and thereby of the current data pool. D date
P
M
FILE_ID Restriction of xs:boolean
This element is used to specify whether the data pool contains test data or released data.

0/false = test data
1/true = released data 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
This element is used to specify whether the provisions data are

B = block data with prices
K = catalogue data
V = block data without prices (fictional prices must be specified)
F = correction update.

 D string
P [BKVF]
M [1:1]
CATALOG_MERGE_TYPE optional xs:boolean

This element CATALOG_MERGE_TYPE is optional and contains boolean data with the following values:

0: The value if the element is not present; it means that this catalogue does not have to be part of a multi-manufacturer catalogue.

1: This catalogue is always part of a multi-manufacturer catalogue.

 D boolean
P
M
CATALOG_DATA_VERSION optional Restriction of xs:date
This element must be filled if the CATALOG_MARK element (catalogue identifier) contains the value F for correction update.

This element is used to enter the date of the base file (element DATA_VERSION) to which the correction update relates. 		D date
P
M
CATALOG_INFO optional languagetext Complex Type
This element is used to store the information texts.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
CATALOG_ID Restriction of xs:string

The manufacturer can enter a unique ID (e.g. GUID) that unequivocally identifies the catalogue here.

It must be observed that a manufacturer catalogue must always have the same ID for the same dealership.

 D string
P
M [1:64]
CATALOG_VERSION Restriction of xs:positiveInteger
The manufacturer can assign a version number for the catalogue in this field D positiveInteger
P
M [1:999999999]
FALL_BACK_LANGUAGE Restriction of xs:language
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The 2-digit ISO Language code must be used. D language
P [A-Z]{2}
M [2:2]
DETAIL_INFOS 0..∞
This element serves to specify images on catalogue level, e.g. a manufacturer or catalogue logo.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
SUPPLIER
This element is used to specify the manufacturer's data, e.g. communication and contact information.
Sequence
EDI_INFO 0..∞
This element is used to inform the partners of the available EDI communications. One element is created fir each EDI message in EDI format.
Sequence
EDI_FORMAT optional Restriction of xs:string
The supported EDI format is specified here (e.g. EDIData) D string
P
M [1:20]
EDI_FORMAT_VERSION optional Restriction of xs:string
The supported version of the EDI format specified in the EDI-FORMAT element is specified here. D string
P
M [1:10]
EDI_MESSAGE optional Restriction of xs:string
The messages in EDI format supported by the manufacturer are stored here (e.g. order, order response). D string
P
M [1:20]
EDI_COMMUNICATION optional Restriction of xs:string
This is used to specify the method for EDI communications (e.g. X400, Telebox, email). D string
P
M [1:20]
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
The address for the specified communication method is specified here ( e.g. X400 address, email address, or as discussed) D string
P
M [1:40]
EDI_CONTACT optional Restriction of xs:string
The contact person available at the manufacturer for details concerning EDI processing is specified here. The specification of contact information is optional, i.e. necessary information, e.g. name, telephone number or email address, can be specified up to the maximum field length. D string
P
M [1:60]
ISO_COUNTRY_ID Restriction of xs:string
This element is used to specify the manufacturer's country in accordance with the ISO standard. D string
P [A-Z]{2}
M [2:2]
GLN_NO Restriction of xs:string
This element is used to enter a unique global location number (GLN). The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data.
If a company has multiple GLN values, the root GLN must be specified. 		D string
P [0-9]{13}
M
WEEE_NO optional Restriction of xs:string
This element is used to enter the WEEE registration number. A WEEE registration number is mandatory for everyone classified as a manufacturer or importer of electrical appliances in accordance with the "Electrical and Electronic Equipment Act (ElektroG)".
In Germany, WEEE numbers look as follows: "DE12345678".
Dealers can verify the validity of WEEE numbers on the website of the register for Waste Electrical Appliances (http://www.stiftung-ear.de). 		D string
P
M
CONTACT_PERSON 1..2
This element is used to specify the information of a contact person
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
This element is used to specify the priorities of methods for making contact with the contact person. (1=1st Contact, 2=2nd contact) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
This element is used to specify the role of the newly created contact. The role designation certified by the manufacturer (e.g. substitute, person responsible for EDI). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
This element is used to specify the last name of the direct contact person for the software house. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
This element is used to specify the first name of the direct contact person. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
This element is used to specify the salutation for the direct contact person.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
This element is, if present, used to specify the department of the direct contact person. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
This element is used to specify the telephone number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
This element is used to specify the fax number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
This element is used to specify the email address. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
STREET optional Restriction of xs:string
This element as you specify the street of the manufacturer's business address. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
This element is used to specify the postcode of the manufacturer's business address. D string
P
M [1:8]
CITY optional Restriction of xs:string
This element is used to specify the manufacturer's place registered office. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
This element is used to specify the manufacturer's country in accordance with the ISO standard is to be specified. D string
P [A-Z]{2}
M [2:2]
CONTACT_SUPPLIER
This element is used to specify the manufacturer's contact data
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
This element is used to specify the first line of the company name. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
If activated, this element is used to store the second line of the company name. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
This element is used to specify the official email address for the dealership or consumer. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
INTERNET_ADDRESS optional Restriction of xs:string
This element, if present, is used to specify the official URL (e.g. http://www.company.com) for dealerships or consumers. D string
P
M
STREET Restriction of xs:string
This element as you specify the street of the manufacturer's business address. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
This element is used to specify the postcode of the manufacturer's business address. D string
P
M [1:8]
CITY Restriction of xs:string
This element is used to specify the manufacturer's place registered office. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
This element is used to specify the manufacturer's country in accordance with the ISO standard is to be specified. D string
P [A-Z]{2}
M [2:2]
ZIPCODE_POSTBOX optional Restriction of xs:string
This element is, if present, used to specify the postcode associated with the PO Box. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
This element is, if present, used to specify the PO Box line of the manufacturer's address. The word "PO Box" must be omitted. D string
P [0-9a-zA-Z]{0,10}
M [00:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
This element is used to specify the telephone number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
This element is here to specify the fax number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
GLOBAL_DEFINITION optional
This element is used to specify data that is valid for the entire catalogue/data pool (global information).
Sequence
DETAIL_INFOS optional
This element is used to specify detailed information.
Sequence
DETAIL_INFO 1..∞
This element is used to specify URLs to detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute identifies a detailed information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
This element is used to classify detailed information.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
This element is here to describe the type of detailed information.

The values that can be assigned to the information types can be found in the corresponding table in the introduction. 		D positiveInteger
P
M [1:15]
EXTERNAL_NAME optional languagetext Complex Type
This element contains the display name of the link (e.g. "sketch 4711").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
INTERNAL_NAME optional languagetext40 Complex Type
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

This element contains the text for a link note.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
URL
This element specifies the URL to the detailed information.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

This element is used to place add-on items, e.g. headrests.

This element is only allowed for SVG files.

Within the outline type of a SVG, the following applies:

There is no overlapping of any areas designated by our clients within the same layer.

The following values apply to the element:

10 Carpet

20 Sofa/furniture/table (default value)

30 Cushion

40 Decorative cushion

50 Headrest

60 Plate/ throw

 D positiveInteger
P [1-6]0
M [10:60]
MESSAGES optional

The possible warnings and information are stored under this element.

The possible warnings and information notices with the corresponding text, the level and the unique identifier are stored under this element.

Sequence
MESSAGE 1..99999
This element is used to store a message.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify the message. D nonNegativeInteger
P
M [0:99999]
LEVEL optional Restriction of xs:nonNegativeInteger

The message level is specified here:
0 Notice/information
1 Warning

 D nonNegativeInteger
P
M [0:1]
Sequence
MESSAGE_TEXT languagetext Complex Type
This element is used to store the message text.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PROPERTIES optional

This element is used to include additional information and characteristics, e.g. energy label, efficiency classes and similar data. Only the characteristics needed for correctly mapping the catalogue are defined.

The keys can be found in the corresponding table (information keys).

Sequence
PROPERTY 1..∞

This element is used to define a feature.

The key, text and measurement unit can be found in the corresponding table (information keys).

PROPERTY_NO required Restriction of xs:nonNegativeInteger

This attribute is used to identify the feature.

Its number can be found in the table with the information keys.

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetext Complex Type
This element contains texts for characteristic features/properties.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PROPERTY_UNIT optional languagetext30 Complex Type
This element is used to specify the unit of measure for the respective characteristic features like property.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
SERIES

This element is used to specify all series of the catalogue/data with the properties and elements assigned to them, e.g. product groups or items.

A series usually corresponds to a model.

Sequence
SERIE 1..1000000
This element is used to define the series. A series usually corresponds to a model.
An item from series 0 is valid in all other series, which means that items of series 0 must not exist with the same type designation (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in any other series. Items of other series (other than 0) may however exist in multiple series with identical type designation.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the series. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO required xs:positiveInteger
This attribute allows for the specification of series with a freely-defined sorting order.
If a SEQUENCE_NO is specified for one series, a SEQUENCE_NO must be specified for all series. 		D positiveInteger
P
M
Sequence
SERIES_NAME
This element is used to specify the series name.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Za-z]{1,3}
M [1:3]
Sequence
TEXT_LINE
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Sequence
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
PURCHASE_RETAIL_ID Restriction of xs:nonNegativeInteger

This element assigns an identifier for series-specific purchasing/sales prices:

EK_VK_ID
0 = purchasing price including VAT (or list price)
1 = sales price including VAT ( recommended sales price)
2 = purchasing price excluding VAT
3 = purchasing price excl. VAT/VAT

The price is defined as a function of the price-ID (Element PRICE_ID (path 1)) as follows:

Price ID = 1 (price), the value from the ITEM_PRICE (path 2) element will be used.

Price ID = 2 (ID number), the price from the IDENT_NUMBER/PRICE (path 3)element, the ITEM_PRICE/PRICE_MINIMUM_BASIC (path 2) element or the ADDITIONAL_PRICE (element 5) is used.

Price ID = 3 (offsetting point), the value from the ITEM_PRICE (path 2) element or the PRICE_MINIMUM_BASIC Element multiplied by the settlement factor from the PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR is used.

Due to the key, only one price (combination of the elements VAT (path 4) and PURCHASE_RETAIL_ID ) can be specified within the same series.
If a file contains both purchasing and retail prices, models with purchasing prices must not be assigned the same calculation groups (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) as models with retail prices.
This element is very important for pricing. If the purchasing prices are used, this must be the dealership's purchasing price, not the manufacturer purchasing price.

Element paths
Path 1: CATALOG/CATALOG_IDENTIFICATION/
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/
Path 3: PRICE_DEFINITION/IDENT_NUMBERS
Path 4: CATALOG/CATALOG_IDENTIFICATION/
Path 5 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

 D nonNegativeInteger
P
M [0:3]
DECISIONS optional
This element is used to collect series specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a series.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D nonNegativeInteger
P
M [1:9999999999]
PRODUCT_GROUPS
This element is used to define product groups. Articles with identical features are grouped together in product groups.
Sequence
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups. "Identical" product groups must therefore not be captured.
Sequence
PRODUCT_GROUP_TEXT languagetext60 Complex Type
This element contains the designation of a product group.
Sequence
LANGUAGE 1..∞
FEATURE_CLASS_REF optional
This element is used to assign a feature class to the product group. A feature class referenced in the FEATURE_DEFINITION/FEATURE_CLASSES element is defined here.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute is used to identify the referenced feature class (FEATURE_CLASS). D positiveInteger
P
M [1:9999999999]
ITEMS
This element is used to define all items of a product group.
Sequence
ITEM 1..∞
This element is used to define items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes.

The characteristic features/properties, or a reference via ITEM_REF to another series (SERIE_NO) and the item number of valid for the other series, are stored for each item. If the ITEM_REF element contains a value, the item is a reference item belonging to another series, otherwise the item belongs to the series in which it is specified at this position.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
DECISIONS optional
This element is used to combine product group-specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a product group.
COLOR_CONSULTANCIES optional

This element is used to define colour consultancies.

Each colour consultancy COLOR_CONSULTANCY contains any number of references to combinations of detailed information and assessments FEATURE_DETAIL_INFO_REF, which are sorted by SEQUENCE_NO. The applied assessments must contain colour variations.

Sequence
COLOR_CONSULTANCY 1..∞
This element is used to directly assign assessments to image layers.
The applied assessments must contain colour variations.
COLOR_CONSULTANCY_NO required Restriction of xs:nonNegativeInteger
This attribute defines the colour consultancy number. D nonNegativeInteger
P
M [0:9999]
Sequence
FEATURE_DETAIL_INFO_REF 1..∞
This element allows for the assignment of precisely one assessment or rule to the image layers.
The assessment and/or rule must contain a colour feature. The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO. Either an assessment (RESTRICTION) or rule (DECISION) can be assigned.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of the colour consultancy. D positiveInteger
P
M
DECISION_NO optional Restriction of xs:positiveInteger
This attribute references a rule. D positiveInteger
P
M [1:9999999999]
DETAIL_INFOS 0..∞
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the series becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
DECISIONS optional
This element is used to collect cross-series rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a cross-series rule.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
SERIE_GROUPS optional
This element can be used to combine different series in groups (model groups).
Sequence
SERIE_GROUP 1..∞
A model group (combination of multiple series) is defined here.
SERIE_GROUP_KEY required Restriction of xs:string

This attribute assigns unique identifiers to series groups/model groups.

 D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger

This attribute allows for the specification of series groups with a freely-defined sorting order.

 D nonNegativeInteger
P
M
Sequence
SERIE_REF 1..∞
This element is used to reference series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a series. D nonNegativInteger
P
M [0:999999]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute defines the order of the series within a series group. D nonNegativeInteger
P
M
SERIE_GROUP_TEXT languagetext60 Complex Type
This element is used to specify the designation of the series group/model group.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS 0..∞
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
PART_LISTS optional

This element is used to assemble dynamic piece lists, with the sub-positions assigned to rules that determine depending on the option in which quantity the respective position exists in the piece list.

Only items in a corresponding series or items of series 0 are contained.

A contained item may however contain a piece list.

The item that contains a piece list passes on its options (OPTIONS) to the sub positions if these have identical features (FEATURES) in the feature class associated with the respective sub-position.

Sequence
PART_LIST 1..∞
This version is used to define a piece list.
PART_LIST_KEY required Restriction of xs:string
This attribute is used to reference a piece list. D string
P
M [1:30]
Sequence
PART_LIST_POS 1..∞
This element is used to describe the piece list positions.
Sequence
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This attribute allows for the specification of piece lists with a freely-defined sorting order. D positiveInteger
P
M
ITEM_REF
This element is used to reference an item.
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:99999]
DECISIONS optional

The rules for the corresponding piece list position are collected in this element. It thereby influences the options and dimensions available for this position.

A rule with a quantity factor must not be specified here.Thisrule is referenced via DECISION_POS_COUNT.

Sequence
DECISION_REF 1..∞

This element references a rule corresponding to the piece list position and thereby influences the dimensions and options available for this position. A rule with a quantity factor must not be specified here.The rule is referenced via DECISION_POS_COUNT.

DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
This element is used to specify the quantity of the item in the piece list. D nonNegativeInteger
P
M [0:999999999]
DECISION_POS_COUNT optional

This element is used to specify a rule that sets the quantity factor.The maximum number is one for each position.This rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations.

Sequence
DECISION_REF

This element references a rulethat determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations.

DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule that determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations. D positiveInteger
P
M [1:9999999999]
POS_INVISIBILITY Restriction of xs:integer

This element is an identifier that the item must be contained in the order, the position should not be displayed in the configurator. The invisibility only applies to the specific position, not to a potentially existing sub-tree. This means that invisibility must in this case be specified at each sub-position.

0 = completely visible

1 = fully invisible

2 = only visible in EDI order if them is generated via a rule

D integer
P
M [0:2]
FEATURE_DEFINITION
This element is used to specify option-specific information.
Sequence
FEATURE_CLASSES

This element is used to combine features in families. These feature classes can be used to carry out plausibility and completeness checks with respect to the valid features.

The defined feature classes (path 1) can be assigned to series or product groups via FEATURE_CLASS_REF in SERIE and PRODUCT_GROUP. There is no relationship with respect to a priority between feature classes on series and item level. The number of features that are valid for an item results from the total number of features declared in the items product group.

All features that are referenced via the elements in PRICE_FEATURE_GROUP (path 3), PRICE_FEATURE_BASE_PRICE_GROUP_REF (path 4) and FINISH (path 5) must be contained in the feature class of the item.

The features used via the elements RESTRICTION_REF (path 6) and RESTRICTION_REF (path 8) must also be contained in the item's feature class.

Element paths
Path 1 : FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS
Path 2 : FEATURE_DEFINITION/FEATURES
Path 3 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 5 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Path 6: SERIES/RESTRICTIONS/RESTRICTION_REF
Path 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS

Sequence
FEATURE_CLASS 1..∞
This element is used to define a feature class.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute is used to identify a feature class. D positiveInteger
P
M [1:9999999999]
Sequence
FEATURE_REF 1..∞
This feature refers to the FEATURE (path 1) element.
Only helpful options must be referenced in the feature class of an item. Example: the feature class vacation must not contain any features for feet shapes.

Element paths
Path 1 : FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:9999]
INVISIBLE optional xs:boolean
If the value of this attribute is set to true (or 1), it specifies that the corresponding feature is invisible. D boolean
P
M
.
FEATURES

This element is used to define the features (FEATURE) and the associated options. Only the features needed for correctly mapping the catalogue are defined.

The combination of finish and colour is used for some features.

If this is the case, features must always be created in pairs. The corresponding colour feature exists for the respective finish option types; a corresponding finish feature exists for the colour feature.

Features declared as invisible features are not be referenced in a feature class.

All features in the FEATURES (path 3) element that are not declared as invisible head feature must be referenced in at least one feature class.

Further information about features can be found in the Introduction in section "features"
Element paths
Path 1 : FEATURE_DEFINITION/FEATURES
Path 2: FEATURE_DEFINITION/FEATURES/FEATURE
Path 3: FEATURE_DEFINITION

Sequence
FEATURE 1..∞
This element is used to define a feature.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a feature. D nonNegativeInteger
P
M [0:9999]
Sequence
OPTIONS optional
It is a container element in which the possible variations of a feature are stored.
The element is omitted for resulting features (HEADER_POS_VARIATION_TYPE=V).
Sequence
OPTION 1..∞
This element is used to define the options for feature.All options necessary in the data pool are stored here. If the option to be created is a feature (introduction: table features identified by type A), no colour values or texture must be specified. The gloss and opaqueness can optionally be assigned to a feature and have priority over corresponding colour variations.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute allows for the specification of a freely-defined sorting order. D nonNegativeInteger
P
M
Sequence
Choice optional
MATERIAL_REF
This element is used to reference a material.
FORM_REF
This element is used to reference a shape.

OPTION_MEASURE_REF
This attribute is used to reference a dimensional variation of a feature.
OPTION_TEXT languagetext60 Complex Type
This element is used to define an option text.
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements:
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.It is possible to assign a number of detail information to one option, and each image of the option can then be assigned to specific series or items. The respective image/media will then only be displayed for the corresponding series or item.
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
This element contains texts for features.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element is used to specify a manufacturer-specific sorting for the features.
The order is a recommendation by the manufacturer. The dealership will, if necessary, work with a different sorting. The sorting is, for example, used for: display in on-screen forms, order of the options during the ordering process, or forms.
The sorting must be specified unequivocally for all data records.
The element is left blank for invisible head options (HEADER_POS_VARIATION_TYPE = U (path 1)).

Element paths
Path 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
This element is an identifier that specifies whether a feature is an
I = implicit feature,
K = head option, or
P = position feature.

It serves the purpose of controlling the processing method on head or position level, features designated with a "P" must, according to the manufacturer, not be processed on head level.

Features designated with an "I" are visible and result implicitly from other features. 		D string
P [IKP]
M [1:1]
FEATURE_TYPE
This element is used to identify the feature corresponding to the option. A feature can be assigned dimensional variations (value of FEATURE_T "M"), colour variations (value of FEATURE_T "C") or other features (value of FEATURE_T "O").
FEATURE_T optional Restriction of xs:string

This attribute is used to define the options assigned to the feature.

M = dimensional versions

C = colour versions

O = other options

 D string
P [MCO]
M [1:1]
Sequence
MEASURE optional

If the options assigned to the feature are dimensional versions, the dimensional information is entered in this element.

They consist of a dimensional parameter, the unit of measure and can then, for example, be used in the formulas of the rules (DECISIONS).

Sequence
MEASURE_UNIT xs:string
This element is used to specify the unit of measure. D string
P
M
MEASURE_PARAMETER optional Restriction of xs:string

This element is used to specify the parameters for defining a formula, e.g. planning width = 2 * st +sb, with st expressing the side part width and sb expressing the seat width.

 D string
P
M
OPTION_DEFINITION optional
This element is used to define the properties of colours, materials and dimensions.
Sequence
MATERIAL 0..∞
This element is used to define a material.

If the option to be created is a feature (identified by A), no colour values (COLOR) or texture (TEXTURE) must be specified.

Features are defined via T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION.
MATERIAL_NO required Restriction of xs:string
This attribute is used to identify a material. D string
P
M [1:5]
Sequence
COLOR
This element is used to define colours.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
OPTION_MEASURE 0..∞
This element is used to specify the values of options that are expressed in a dimension (e.g. backrest or cushion height).
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
This attribute identifies a dimensional variation. D positiveInteger
P
M [1:99999]
Sequence
MEASURE_VALUE Restriction of xs:nonNegativeInteger
This element is used to specify the dimensions. D nonNegativeInteger
P
M [0:999999999]
MEASURE_UNIT xs:string
This element is used to specify the unit of measure. D string
P
M
DECISIONS optional
This element is used to specify rules for options and features.
Sequence
DECISION 1..99999

This element is used to define and describe a rule that maps technically feasible configurations.
The rules are assigned to series or items by references from the corresponding elements. In total, all rules defined in this element must be referenced from either series or items.

Depending on the DECISION_TYPE attribute, different rules can be specified.

If the value in DECISION_TYPE is 0 or 1, the rule is a "preparation rule".

This allows for the definition of invalid and/or valid options in OPTION_COMBINATION. These are used to determine the valid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

The conditions are supplemented with operators. The special data type operator was defined for this purpose. It may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

The individual OPTION_COMBINATIONs must be considered as ELSE branches. This means that as soon as a condition line (OPTION_COMBINATION) receives a hit, the others will not be executed anymore.

If the value in DECISION_TYPE is 2, the rule is an action rule. It allows for the definition of actions depending on the conditions.

If all conditions within an „OPTION_COMBINATION“ are satisfied, all signed actions (ACTIONS) then can set values or make features (FEATURES) invisible depending on conditions. If an OPTION_COMBINATION is satisfied, the other conditions are not processed.

Actions (ACTIONS)

are instructions that are executed if a condition is met. The following actions can be executed:

    The setting of options ( SET_FEATURE_FIXED ) with the following options:

      - Direct, e.g. main fabric = "blue" (OPTION)

      - the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

      - the calculation of options (e.g. sitting height + 5 cm).
      This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
      This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
      The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

        The setting of standard versions ( SET_FEATURE_DEFAULT , SET_FEATURE_DEFAULT_NULL ):
        These can be filled if no value has been entered yet. The same options as above apply.

            The visibility of features ( SET_FEATURE_VISIBLE , SET_FEATURE_INVISIBLE ) and/or the deactivation of rules ( DISABLE_DECISION , ENABLE_DECISION ):
            Example: for wooden feet, a potentially existing feature for a shade can be displayed and made invisible if a metal foot is selected.

              Action rules are usually used in the configurator if an option value (an option) changes. If, for example, the foot option is changed from stainless steel to wood, a feature for the shade can be displayed.

              If the value in DECISION_TYPE is 3, the rule is an action rule for piece lists. Depending on the conditions, the quantity can be defined in the piece list here.

              DECISION_NO required Restriction of xs:positiveInteger
              This attribute is used to identify the rule. D positiveInteger
              P
              M [1:9999999999]
              DECISION_TYPE required Restriction of xs:int

              This attribute is used to specify the rule type.

              0 = excluding preparation rule

              This allows for the definition of invalid options in OPTION_COMBINATION/FEATURE_REF. These are used to determine the invalid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

              1 = Preparation rule

              This allows for the definition of valid options in OPTION_COMBINATION/FEATURE_REF. These are used to determine the valid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

              2 = Action rule
              It allows for the definition of actions in addition to the conditions.
              The rules are analysed before an option is entered for an item.
              Once a value has been selected, the action rules apply and then set values or make features invisible.
              For action rules, it is always the first line (OPTIONS_SET_REF) that applies. In this case, all associated ACTIONS are executed.

              3 = Action rule for quantity in piece lists (PositionCounter Rule)

              The quantity in the piece list can be defined here depending on the conditions via the action SET_POS_COUNT_VALUE.

                       D int
              P
              M [0-3]
              Sequence
              DECISION_NAME_TEXT languagetext60 Complex Type
              This element is used to specify the designation of a rule.
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              This attribute is used to specify the ISO code of the language in which the text is stored. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
              P [\S ]{1,60}
              M [1:60]
              OPTION_COMBINATION 1..∞

              This element is used to form a feature combination that is linked to certain conditions.

              If the value of DECISION_TYPE is 2 or 3, actions (ACTIONS) can also be assigned to the feature combination.

              SEQUENCE required Restriction of xs:nonNegativeInteger
              This element is used to specify the sequence in which the assigned assessment procedures will be executed. D nonNegativeInteger
              P
              M [1:99999]
              Sequence
              OPTIONS_SET_REF 0..∞

              This element is used to reference a feature and define a rule for its feature classes. The rules may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

              The simple data type operator was defined for this purpose and may contain the following values:

              eq (equal)

              ne (not equal)

              in (is contained in a quantity)

              nin (is not contained in a quantity)

              gt (greater)

              lt (less)

              ge (greater than or equal)

              le (less than or equal)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              REF_LEVEL optional Restriction of xs:nonNegativeInteger
              In piece lists, sub-positions can query features of the main position (PARENT), the uppermost position (ROOT) and the item itself (SELF) via the REF_LEVEL and depending on them trigger an action or integrate the action in a condition.

              1 = ROOT

              2 = PARENT

              3 = SELF (default is SELF if no REF level is specified)               		D nonNegativeInteger
              P
              M [1:3]
              Choice
              OPTION_INTERVAL
              This element is used to evaluate whether an option falls within or outside of an interval.
              OPTION_LIST
              This element is used to evaluate whether an option corresponds to a value in a list.
              OPTION_GROUP_REF_OP
              This element is used to evaluate whether an option falls within a feature group.
              OPTION_REF_OP

              This element is used to define a comparison with an option.

              The comparison operator may contain the following values:

              eq (equal)

              ne (not equal)

              gt (greater)

              lt (less)

              ge (greater than or equal)

              le (less than or equal)

              FEATURE_REF_OP

              This element is used to directly compare the feature.

              The comparison operator may contain the following values:

              eq (equal)

              ne (not equal)

              MEASURE_VALUE_OP
              This element is used to check the dimension of an option using another dimension.
              MEASURE_INTERVAL
              This element is used to evaluate whether an option's dimension falls within or outside of an interval.
              ACTIONS optional

              This element is used to determine actions that are executed under certain conditions.

              Actions (ACTIONS) are instructions that are executed if a condition is met. The following actions can be executed:

              • The setting of options (SET_FEATURE_FIXED) with the following options:

              §Direct, e.g. main fabric = "blue" (OPTION)

              §the setting of feature values from another feature (FEATURE), e.g. ledge fabric = main fabric

              §the calculation of options (e.g. sitting height + 5 cm).
              This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
              This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
              The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

              • The setting of standard options (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
                These can be filled if no value has been entered yet. The same options as above apply.

              • The visibility of features (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) and disabling of rules (DISABLE_DECISION, ENABLE_DECISION):
                Example: for wooden feet, a potentially existing feature for a shade can be displayed and made invisible if a metal foot is selected.

              Choice 1..∞
              SET_FEATURE_DEFAULT

              This action is used to set standard options.

              These can be filled if no value has been entered yet.

              • The following options are available for the setting of options:

              - Direct , e.g. main fabric = "blue" (OPTION)

              - the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

              - the calculation of options. (e.g. seat height + 5 cm).
              This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
              This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
              The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

              SET_FEATURE_FIXED

              This action is used to set options.

              The following options are available for the setting of options:

              - Direct , e.g. main fabric = "blue" (OPTION)

              - the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

              - the calculation of options. (e.g. seat height + 5 cm).
              This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
              This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
              The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

              ENABLE_DECISION

              This action activates rules.

              DISABLE_DECISION

              This action deactivates rules.

              SET_FEATURE_VISIBLE
              This action makes features visible.
              SET_FEATURE_INVISIBLE
              This action makes features invisible.
              SET_FEATURE
              This action sets a value for an option of a feature. Contrary to „SET_FEATURE FIXED“, this value can be modified if permitted by the conditions. This value rule also applies if the corresponding field was previously set to default or manual.
              SET_FEATURE_DEFAULT_NULL

              This action is used to set standard options.

              The default value only applies if the relevant feature field was previously blank.

              SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
              This version is used to set a quantity in the piece list.
              This action must only be specified for rules with DECISION_TYPE = 3.               		D nonNegativeInteger
              P
              M [0:9999]
              SET_MESSAGE
              This element is used to set a message for the purpose of triggering warnings or notices for certain feature combinations.
              VALID_FROM optional Restriction of xs:date
              This element is used to specify the date from which date onwards a rule is valid.
              Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date.               		D date
              P
              M
              VALID_UNTIL optional Restriction of xs:date
              This element specifies the date until which a rule is valid.
              Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.               		D date
              P
              M
              FEATURE_REF 0..∞
              This element is used to reference a feature.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              PRIO Restriction of xs:positiveInteger
              This element is used to specify a value for the priority of a rule.
              A low value means a high priority. This means that the rule takes a lower priority the higher this value is.               		D positiveInteger
              P
              M [1:999999999]
              OPTION_GROUPS optional
              This element is used to group quantities of options. They can be referenced in the assessment below OPTION_COMBINATION/FEATURE_REF in DECISIONS. These options are to be considered an independent pool and have no connection to any feature.
              Sequence
              OPTION_GROUP 1..∞

              This element is used to specify a feature group.

              It can be referenced in assessments below OPTION_COMBINATION/FEATURE_REF in the DECISIONS . These options are to be considered an independent pool and have no connection to any feature.

              OPTION_GROUP_KEY required Restriction of xs:string
              This attribute is used to identify a feature group. D string
              P
              M [1:30]
              Sequence
              OPTION 1..∞
              This element is used to reference an option.
              OPTION_KEY required Restriction of xs:string
              This attribute is used to reference an option. D string
              P
              M [1:30]
              SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
              This attribute defines the order of the options in a feature group. D nonNegativeInteger
              P
              M
              OPTION_GROUP_TEXT languagetext60 Complex Type
              This element contains texts for feature groups.
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              This attribute is used to specify the ISO code of the language in which the text is stored. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
              P [\S ]{1,60}
              M [1:60]
              FORMULAS optional
              This element is used for the calculation of options (e.g. sitting height + 5 cm). The function is however only permitted for dimensional versions with a feature that contains the value "M", the unit of measure can be entered in MEASURE_UNIT, the parameter (e.g. sh for sitting height) in MEASURE_PARAMETER. The calculation is carried out via a formula string that may contain parameters and values.
              Sequence
              FORMULA 1..∞
              The element serves the purpose of defining a formula.The attribute FORMULA_KEY contains the identifier, the FORMULA_STRING contains the actual formula.
              FORMULA_KEY required Restriction of xs:string
              This attribute is used to define the key for the formula. D string
              P
              M [1:30]
              Sequence
              FORMULA_STRING Restriction of xs:string
              This element is used to specify a formula. D string
              P [+\-*/()A-Za-z. ]{0,}
              M
              PRICE_DEFINITION
              This element is used to specify information for the catalogue modification that is necessary for the price calculation, such as price tables and design ranges.
              Sequence
              PRICE_FEATURE_GROUPS
              This element is used to define feature groups (PRICE_FEATURE_GROUPS).
              Sequence
              PRICE_FEATURE_GROUP 1..∞

              This element is used to specify price control information. The PRICE_FEATURE_GROUP is used to control the conditions under which a price (e.g. feature combinations) applies.

              A PRICE_FEATURE_GROUP is referenced by the item. The specific prices are also specified in the item.

              The following rules apply to PRICE_FEATURE_GROUP and/or items:
              - Price group-neutral items can have options that are price-neutral. Their price must not be stated in price field 1, and they must only have one FINISHED element for the price field information. Price field-independent items for which only one FINISH element, in which the price is specified, exists in the PRICE_FEATURE_GROUP are only permitted to have one assigned price in accordance with the FINISH element specified in the price field.

              - Variation-dependent items have one or a number of features.
              - An item must reference precisely one base price group (ADDITIONAL_PRICE=0).

              The creation of multiple PRICE_FEATURE_GROUPs with the same combination of features are permitted.

              PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
              This attribute is used to unequivocally identify a PRICE_FEATURE_GROUP. D postiveInteger
              P
              M [1:99999]
              ADDITIONAL_PRICE required Restriction of xs:boolean
              Identifier whether the specified price is a base price or a surcharge. (0 = base price, 1 = additional price).
                       D boolean
              P
              M
              Sequence
              PRICE_FEATURE_GROUP_TEXT languagetext60 Complex Type
              This element contains texts for variation groups.
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              This attribute is used to specify the ISO code of the language in which the text is stored. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
              P [\S ]{1,60}
              M [1:60]
              Choice
              FINISH 0..∞
              This element is used to assign price fields (PRICE_FIELD) and a manufacturer price group to valid feature combinations.
              SEQUENCE required Restriction of xs:nonNegativeInteger
              This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The price group is determined by the first matching feature combination. D nonNegativeInteger
              P
              M [1:99999]
              Sequence
              OPTIONS_SET_REF 0..∞

              This element is used to reference a feature and define a price group for its feature classes. The price groups may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

              The simple data type operator was defined for this purpose and may contain the following values:

              eq (equal)
              ne (not equal)
              in (is contained in a quantity)
              nin (is not contained in a quantity)
              gt (greater)
              lt (less)
              ge (greater than or equal)
              le (less than or equal)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              Choice
              OPTION_INTERVAL

              This element is used to evaluate whether an option falls within or outside of an interval. 

              Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

              OPTION_LIST
              This element is used to evaluate whether an option corresponds to a value in a list.
              OPTION_GROUP_REF_OP
              This element is used to evaluate whether an option falls within a feature group.
              OPTION_REF_OP

              This element is used to define a comparison with an option.

              The comparison operator may contain the following values:

              eq (equal)
              ne (not equal)
              gt (greater)
              lt (less)
              ge (greater than or equal)
              le (less than or equal)

              MEASURE_VALUE_OP
              This element is used to check the dimension of an option using another dimension.
              MEASURE_INTERVAL
              This element is used to evaluate whether an option's dimension falls within or outside of an interval.
              PRICE_FIELD Restriction of xs:positiveInteger

              These element specifies the price field in which the price of an item in this variation is specified. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1 or path 2).

              In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

              Element paths
              Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

              Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

                       D positiveInteger
              P
              M [1:9999]
              SUPPLIER_PRICE_GROUP Restriction of xs:string
              This catalogue is used to specify the manufacturer's price group.
                       D string
              P
              M [1:10]
              VALID_FROM optional Restriction of xs:date
              This element is used to specify the date from which date onwards a price field is valid. D date
              P
              M
              VALID_UNTIL optional Restriction of xs:date
              This element is used to specify the date until which a price field is valid. D date
              P
              M
              PERCENTAGE_SURCHARGE 0..∞
              To allow for percentage surcharges, the element FINISH supplemented below PRICE_FEATURE_GROUP by the element PERCENTAGE_SURCHARGE consisting of OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM and VALID_UNTIL.
              This element must only be used for PRICE_FEATURE_GROUP's for which the attribute ADDITIONAL_PRICE is set to 1 (1=surcharge).
              The percentage surcharge may refer to different PRICE_FEATURE_GROUPs:

              Case 1

              Base price 500.00

              Surcharge headrest 50.00

              Surcharge function 66.00

              Surcharge seat heating 10% of base price --> factor 0.1 * 500 = 50

              Surcharge rapport base price 10% of base price + headrest --> factor 0.1 * (500+50) = 55

              Surcharge XY 20% on everything --> factor 0.2 * (500+50+66+50+55) = 144.20

              Position value = 865.20

              Case 2

              Base price 500.00

              Surcharge seat heating 10% of base price --> factor 0.1 * 500 = 50

              Position value = 550.00

              Case 3

              Base price 500.00

              Surcharge headrest 50.00

              Surcharge function 66.00

              Surcharge XY 20% of base price + headrest + function --> factor 0.2 * (500+50+66)=123.20

              Position value = 739.20

              Case 4

              Base price 500.00

              Surcharge headrest 50.00

              Surcharge function 66.00

              Surcharge XY 20% of ( base price + headrest + function ) --> factor 0.2 * (500+50+66)=123.20

              Surcharge ZZ -10% of ( base price + function ) --> factor 0.1 * (500+66)=56.60

              Position value = 682.60

              Case 5

              Base price 500.00

              Surcharge headrest 50.00

              Surcharge function 66.00

              Condition value 616.00

              Surcharge Global1 10% on everything --> factor 0.1 * 616 results in condition value = 61.60

              Surcharge Global2 20% on everything --> factor 0.2 * 616 results in condition value = 123.20

              Position value = 800.80

              The factor value must be specified in the PRICE_FACTOR element.

              The price groups to which the percentage surcharge relates are specified under PRICE_FEATURE_GROUP_REF.

              The validity is specified in the VALID_FROM and VALID_UNTIL elements.

              Position value = 800.80
              SEQUENCE required Restriction of xs:nonNegativeInteger
              This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The percentage surcharge is determined by the first matching feature combination. D nonNegativeInteger
              P
              M [1:99999]
              Sequence
              OPTIONS_SET_REF 0..∞

              This element is used to reference a feature and defines a percentage surcharge for its feature classes. The percentage surcharges may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

              The simple data type operator was defined for this purpose and may contain the following values:

              eq (equal)
              ne (not equal)
              in (is contained in a quantity)
              nin (is not contained in a quantity)
              gt (greater)
              lt (less)
              ge (greater than or equal)
              le (less than or equal)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              Choice
              OPTION_INTERVAL

              This element is used to evaluate whether an option falls within or outside of an interval.

              Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

              OPTION_LIST
              This element is used to evaluate whether an option corresponds to a value in a list.
              OPTION_GROUP_REF_OP
              This element is used to evaluate whether an option falls within a feature group.
              OPTION_REF_OP

              This element is used to define a comparison with an option.

              The comparison operator may contain the following values:

              eq (equal)

              ne (not equal)

              gt (greater)

              lt (less)

              ge (greater than or equal)

              le (less than or equal)

              MEASURE_VALUE_OP
              This element is used to check the dimension of an option using another dimension.
              MEASURE_INTERVAL
              This element is used to evaluate whether an option's dimension falls within or outside of an interval.
              PRICE_FACTOR Restriction of xs:int

              This element specifies a percentage surcharge. It is specified as a factor with five decimal places.

              A value of 1050000 corresponds to a surcharge of 10.5%.

              A value of -1000000 corresponds to a surcharge of -10%.

                       D int
              P
              M [-9999999:99999999]
              PRICE_FEATURE_GROUP_REF 0..∞
              This element is used to reference a price group irrespective of the feature and/or calculation method (PRICE_FEATURE_GROUP).
              PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
              This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
              P
              M [1:99999]
              VALID_FROM optional Restriction of xs:date
              This element is used to specify the date from which date onwards a percentage surcharge is valid. D date
              P
              M
              VALID_UNTIL optional Restriction of xs:date
              This element is used to specify the date until a percentage surcharge is valid. D date
              P
              M
              PRICE_TYPES
              This element is used to define the price types for piece or dimension-variable calculation of variation-neutral or variation-dependent items.
              The child elements WIDTH_X, DEPTH_Y, HEIGHT_Z specify whether the price calculated for an item with this price type depends on the width, height, depth, surface area or volume.
              If no dimension is specified as "1", the price does not depend on dimensions and is calculated on a per piece basis (e.g. for a sitting element). The values in BASIC_UNIT and ROUNDING_UNIT are then set to 0.
              If "1" is set for a dimension, the price calculation will be based on this dimension (e.g. fabrics).
              If exactly two dimensions are set to "1", the price is based on the surface area (e.g. carpets).
              If exactly three dimensions are set to "1", the price is based on the volume (e.g. lounge sections).
              Sequence 1..∞
              PRICE_TYPE
              This version is used to define a price type.
              PRICE_TYPE_NO required Restriction of xs:positiveInteger
              This attribute unequivocally identifies a defined price type. D positiveInteger
              P
              M [1:250]
              Sequence
              WIDTH_X Restriction of xs:boolean
              If the price that is to be calculated depends on the dimension width, this element is set to 1, otherwise it is set to 0. D boolean
              P
              M
              DEPTH_Y Restriction of xs:boolean
              If the price that is to be calculated depends on the dimension depth, this element is set to 1, otherwise it is set to 0. D boolean
              P
              M
              HEIGHT_Z Restriction of xs:boolean
              If the price that is to be calculated depends on the dimension height , this element is set to 1, otherwise it is set to 0. D boolean
              P
              M
              BASIC_UNIT Restriction of xs:nonNegativeInteger
              The base unit (BASIC_UNIT) specifies on which dimension the prices in the ITEM_PRICE (P1) and ADDITIONAL_PRICE (P2) elements relate.
              The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one meter, the value in this element must be entered as "1000". In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³]. If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0".

              P1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
              P2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/               		D nonNegativeInteger
              P
              M [0:999999999999]
              ROUNDING_UNIT Restriction of xs:nonNegativeInteger
              The rounding unit (ROUNDING_UNIT) is used to specify the upward rounding for the length, the surface area and/or the volume. The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one centimetre, the value in this element must be entered as "10". If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0". D nonNegativeInteger
              P
              M [0:999999999999]
              ROUNDING_TYPE Restriction of xs:positiveInteger

              To specify the different types of the rounding, the ROUNDING_UNIT element is supplemented with the element ROUNDING_TYPE, with possible values being 1, 2 and 3, that identifies commercial rounding (up and down).

              The values have the following meaning:

              1 rounding up

              2 rounding down

              3 commercial rounding

                       D positiveInteger
              P
              M [1:3]
              BASIC_PRICE_DEPENDENT Restriction of xs:boolean

              If the element is set to 1, the price will be calculated
              on the basis of the base price and a base price unit. If the value is 0,
              the price calculation is independent from a base price.

              The element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC Izzy is to specify the
              items base price applicable for the calculation and in .../ITEM/
              PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT the
              .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT element. The base price unit is used
              as a base value and/or starting point for the dimension-variable calculation.

              The element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE
              is used to specify the price that serves as a basis for the calculation of the filler price
              that corresponds to the basic unit defined in the BASIC_UNIT element.
              The base price is always a piece price. An item that is assigned a base price calculation
              cannot be assigned a minimum price. The final price
              of the item consists of the base price + the
              calculated filler price in consideration of the logic defined in the element.
              Base prices can only be assigned to items for which at least
              one-dimensional is used for calculation purposes.

              The effective item prices are calculated as follows:
              The dimensions of the base price unit must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions.
              To calculate the price for the infill dimensions, the logic from the PRICE_TYPE element in conjunction with the
              price from element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE is used.
              If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

                       D boolean
              P
              M
              PRICE_TYPE_FORMULA optional Restriction of xs:string
              Price calculation formulas can be specified when defining price types (PRICE_TYPE). Formulas must not be specified for standard price types, such as a calculation that relies squares or cubic metres.
              The following rules apply for the definition of price type formulas:
              - the parameters b, h and t can be used in formulas. Parameters b, h, t correspond to the parameters b, h and t of the carcase basic shape. Depending on the b, h, t parameters used, the corresponding element WIDTH_Y (P1) (b), DEPTH_Y (P1) (t) or HEIGHT_Z (P1) (h) must be set to "true".
              - the basic calculation methods addition (+), subtraction (-), multiplication (*) and division (/) can be used;
              - arithmetic brackets can be used;
              - +/minus signs must not be used;
              - only the final result is rounded;
              - elements BASIC_UNIT (P1), ROUNDING_UNIT (P1) and BASIC_PRICE_DEPENDENT (P1) also apply in conjunction with the price type formula;

              [SSS_elementpaths_SSS]element paths[EEE_elementpaths_EEE]
              P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/               		D string
              P [\+\-\*/\(\)bhtBHT]{0,}
              M [1:100]
              PRICE_TYPE_NAME optional languagetext60 Complex Type
              This element is used to specify a designation for the defined price type.
              The designation simplifies data collection and communication. The designation is not analysed by the planning software.
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              This attribute is used to specify the ISO code of the language in which the text is stored. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
              P [\S ]{1,60}
              M [1:60]
              PRICE_TYPE_RULES optional
              This element is used to define rules for determining the price type.
              Sequence
              PRICE_TYPE_RULE 1..100
              This element is used to define rules for determining the price type.
              RULE_NO required Restriction of xs:nonNegativeInteger
              This element is used to specify the rule number. D nonNegativeInteger
              P
              M [0:9999]
              Sequence
              RULE xs:string
              This element is used to define the rule. D string
              P
              M
              Attributes
              Name Type Use Default Fixed Description
              MAJOR List of xs:positiveInteger required 1
              The version number "MAJOR" specifies the format version the data pool is delivered. The major version number will only change in the case of a fundamental revision of the entire format.
              The complete information about the format version in which a data pool is delivered consists of MAJOR, MINOR and REVISION.               		D positiveInteger
              P
              M [2:2]
              MINOR Restriction of xs:nonNegativeInteger required
              The sub-version number "MINOR" usually changes every year. If the main version MAJOR is modified, the subversion is reset to 0.
                       D nonNegativeInteger
              P
              M [0:0]
              REVISION Restriction of xs:nonNegativeInteger required
              The revision number "REVISION" highlights changes during the year resultant from individual working groups. The revisions are not published if they are not concerned with necessary corrections. Revision is reset to 0 with each new MINOR sub-version number.
                       D nonNegativeInteger
              P
              M [0:0]
              FORMAT Restriction of xs:string required

              This element is used to specify the manufacturer's industry code. The following industry codes are currently defined:

              A = worktop manufacturers
              B = bathroom furniture manufacturers
              G = appliance manufacturers
              K = kitchen furniture manufacturers
              O = office furniture manufacturers
              P = upholstered furniture manufacturers
              S = sanitary products manufacturers
              W = living room furniture manufacturers
              Z = accessories manufacturers

              The identifier W is the only value permitted for this element.

                       D string
              P [W]
              M [1:1]
              Remarks

              Source
              <xs:element name="T_NEW_CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version 2.3 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CATALOG_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:language">
                        <xs:pattern value="[A-Z]{1,2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CURRENCY_KEY">
                    <xs:annotation>
                      <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{1,3}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CATALOG_NUMBER">
              <xs:annotation>
                <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_NAME" type="languagetext30">
              <xs:annotation>
                <xs:documentation>100--10--Katalog_Name</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="DATA_VERSION">
              <xs:annotation>
                <xs:documentation>100--11--Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_FROM_DATE">
              <xs:annotation>
                <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL_DATE">
              <xs:annotation>
                <xs:documentation>100--12--Gueltig_bis_Datum Neu Build 9</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILE_ID">
              <xs:annotation>
                <xs:documentation>100--14--Datei_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MARK">
              <xs:annotation>
                <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BKVF]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MERGE_TYPE" type="xs:boolean" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Kennzeichen, ob Teil eines Multiherstellerkataloges</xs:documentation>
                <xs:documentation>1: immer Teil eines Multiherstellerkataloges</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_DATA_VERSION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_INFO" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>110--3--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_ID">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Katalog_ID
/Hermann Balke 9.06.2013
neu in 2.3
hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="64" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_VERSION">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Katalog_Version
/Hermann Balke 16.07.2013
neu in 2.3
hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FALL_BACK_LANGUAGE">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
                <xs:documentation>K. Richter 15.08.2017</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
                <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW  </xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW </xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SUPPLIER">
        <xs:annotation>
          <xs:documentation>100--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EDI_INFO" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>105--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EDI_FORMAT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--2--EDI_Format</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_FORMAT_VERSION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="10" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_MESSAGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_COMMUNICATION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="40" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_CONTACT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="60" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="ISO_COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="GLN_NO">
              <xs:annotation>
                <xs:documentation>100--45--GLN_Nr
30.05.2012/Bur</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9]{13}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="WEEE_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--47--WEEE_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_PERSON" maxOccurs="2">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CONTACT_PERSON_NO">
                    <xs:annotation>
                      <xs:documentation>100--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_ROLE">
                    <xs:annotation>
                      <xs:documentation>100--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="60" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_NAME">
                    <xs:annotation>
                      <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FIRST_NAME">
                    <xs:annotation>
                      <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FORM_OF_ADDRESS">
                    <xs:annotation>
                      <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DEPARTMENT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE">
                    <xs:annotation>
                      <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CONTACT_SUPPLIER">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_NAME_1">
                    <xs:annotation>
                      <xs:documentation>100--16--Herstellername_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--17--Herstellername_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INTERNET_ADDRESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--19--Internet_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET">
                    <xs:annotation>
                      <xs:documentation>100--20--Strasse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET">
                    <xs:annotation>
                      <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY">
                    <xs:annotation>
                      <xs:documentation>100--22--Ort</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--24--Postfach</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="GLOBAL_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLASSIFICATION">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="INFO_TYPE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Front(Fronttextur, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Materialpass (PDF an den Fronten)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Artikelpictogramm Ansicht
12.02.2013/Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:maxInclusive value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="URL">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT" type="xs:anyURI">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="HASH_VALUE">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="32" />
                                          <xs:maxLength value="32" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="LAYER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-6]0" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="MESSAGES" minOccurs="0" maxOccurs="1">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MESSAGE" maxOccurs="99999">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MESSAGE_TEXT" type="languagetext" />
                      </xs:sequence>
                      <xs:attribute name="MESSAGE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="LEVEL">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PROPERTIES" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>120--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PROPERTY" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>120--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PROPERTY_TEXT" type="languagetext" minOccurs="1" maxOccurs="1" />
                        <xs:element name="PROPERTY_UNIT" type="languagetext30" minOccurs="0" maxOccurs="1" />
                      </xs:sequence>
                      <xs:attribute name="PROPERTY_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIES">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE" maxOccurs="1000000">
              <xs:annotation>
                <xs:documentation>200--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIES_NAME">
                    <xs:annotation>
                      <xs:documentation>200--3--Serienname</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>200--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>200--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Za-z]{1,3}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PURCHASE_RETAIL_ID">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Version 2.3 Polster
Hermann Balke 01.07.2013
EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto</xs:documentation>
                      <xs:documentation />
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DECISIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DECISION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DECISION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRODUCT_GROUPS">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRODUCT_GROUP_TEXT" type="languagetext60">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_CLASS_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                                      <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEMS">
                                <xs:annotation>
                                  <xs:documentation>400--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:choice>
                                            <xs:sequence>
                                              <xs:element name="ITEM_REF">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="TYPE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>401--0--NEW</xs:documentation>
                                                      <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:minLength value="1" />
                                                        <xs:maxLength value="30" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="SERIE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>200--1--Satzart</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="0" />
                                                        <xs:maxInclusive value="999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:sequence>
                                              <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                                <xs:annotation>
                                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence minOccurs="0">
                                                    <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>450/470--1--Satzart</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="PRICE_FIELD">
                                                            <xs:annotation>
                                                              <xs:documentation>450--4--Preisfeld</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="9999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="PRICE">
                                                            <xs:annotation>
                                                              <xs:documentation>450--5--Preis</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:integer">
                                                                <xs:minInclusive value="-99999999" />
                                                                <xs:maxInclusive value="999999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>470--4--Preis</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:integer">
                                                                <xs:minInclusive value="-99999999" />
                                                                <xs:maxInclusive value="999999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="VALID_FROM" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                                              <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:date" />
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="VALID_UNTIL" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                                              <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:date" />
                                                            </xs:simpleType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="99999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="PRICE_TYPE_REF">
                                                <xs:annotation>
                                                  <xs:documentation>400/407--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>400/407--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="PRICE_FEATURE_GROUP_REF">
                                                      <xs:annotation>
                                                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                                            <xs:annotation>
                                                              <xs:documentation>460--1--Satzart</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:sequence>
                                                                <xs:element name="PRICE_FIELD">
                                                                  <xs:annotation>
                                                                    <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:positiveInteger">
                                                                      <xs:minInclusive value="1" />
                                                                      <xs:maxInclusive value="9999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:element>
                                                                <xs:element name="PRICE">
                                                                  <xs:annotation>
                                                                    <xs:documentation>460--5--Preis</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:integer">
                                                                      <xs:minInclusive value="-99999999" />
                                                                      <xs:maxInclusive value="999999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:element>
                                                              </xs:sequence>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                        <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="99999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                    <xs:element name="PRICE_TYPE_REF">
                                                      <xs:annotation>
                                                        <xs:documentation>407--5--Preisart</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>407--5--Preisart</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="DECISIONS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>291--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="DECISION_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>291--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="9999999999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>406--1--Satzart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                                            <xs:annotation>
                                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                                              <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:sequence>
                                                                <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                                                                  <xs:annotation>
                                                                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                </xs:element>
                                                                <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:complexType>
                                                                    <xs:attribute name="SERIE_NO" use="required">
                                                                      <xs:annotation>
                                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                                        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                                          <xs:minInclusive value="0" />
                                                                          <xs:maxInclusive value="999999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                    <xs:attribute name="TYPE_NO" use="required">
                                                                      <xs:annotation>
                                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                                        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:string">
                                                                          <xs:minLength value="1" />
                                                                          <xs:maxLength value="30" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                    <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                                      <xs:annotation>
                                                                        <xs:documentation>406--7--Anzahl</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                                          <xs:minInclusive value="1" />
                                                                          <xs:maxInclusive value="999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                  </xs:complexType>
                                                                </xs:element>
                                                              </xs:sequence>
                                                              <xs:attribute name="SET_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:positiveInteger">
                                                                    <xs:minInclusive value="1" />
                                                                    <xs:maxInclusive value="9" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                              <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                    <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:sequence>
                                                                <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:complexType>
                                                                    <xs:attribute name="SERIE_NO" use="required">
                                                                      <xs:annotation>
                                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                                          <xs:minInclusive value="0" />
                                                                          <xs:maxInclusive value="999999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                    <xs:attribute name="TYPE_NO" use="required">
                                                                      <xs:annotation>
                                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:string">
                                                                          <xs:minLength value="1" />
                                                                          <xs:maxLength value="30" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                    <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                                      <xs:annotation>
                                                                        <xs:documentation>406--7--Anzahl</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                                          <xs:minInclusive value="1" />
                                                                          <xs:maxInclusive value="999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                  </xs:complexType>
                                                                </xs:element>
                                                              </xs:sequence>
                                                              <xs:attribute name="SET_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:positiveInteger">
                                                                    <xs:minInclusive value="1" />
                                                                    <xs:maxInclusive value="9" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="EDP_NUMBER" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="EAN_NUMBER" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="ITEM_IDENTIFICATION">
                                                <xs:annotation>
                                                  <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="[BEKSMZVP12]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="CATALOG_PAGE" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="7" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="VALID_FROM" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:date" />
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:date" />
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="WEIGHT_NETTO" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="VOLUME" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--21--Volumen</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="BASIC_PROFILE" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:choice>
                                                      <xs:element name="CARCASE_BASIC_SHAPE">
                                                        <xs:annotation>
                                                          <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>400--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType mixed="true">
                                                                <xs:sequence>
                                                                  <xs:element name="OPTION_REF">
                                                                    <xs:annotation>
                                                                      <xs:documentation>430--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:complexType>
                                                                      <xs:attribute name="FEATURE_NO" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>430--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="9999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="OPTION_KEY" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>430--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:string">
                                                                            <xs:minLength value="1" />
                                                                            <xs:maxLength value="30" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                    </xs:complexType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                                <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>400--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:pattern value="[\S ]{1,5}" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                            <xs:element name="BASIC_SHAPE_PARAMETERS">
                                                              <xs:annotation>
                                                                <xs:documentation>500--1--Satzart</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:complexType>
                                                                      <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--0--Parameter</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:string">
                                                                            <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--5--Nennwert</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="BASIC_SHAPE_FROM">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--6--Von</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="BASIC_SHAPE_TO">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--7--Bis</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                    </xs:complexType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                                        <xs:annotation>
                                                          <xs:documentation>400--32--Massbild</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:minLength value="1" />
                                                                  <xs:maxLength value="240" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="DIMENSIONAL_PARAMETERS">
                                                              <xs:annotation>
                                                                <xs:documentation>500--1--Satzart</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:complexType>
                                                                      <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:string">
                                                                            <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="DIMENSIONAL_FROM">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="DIMENSIONAL_TO">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                    </xs:complexType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>400--32--Massbild</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="20" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:choice>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="ITEM_TEXT">
                                                <xs:annotation>
                                                  <xs:documentation>410--1--Satzart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="SHORT_TEXT">
                                                      <xs:annotation>
                                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:sequence>
                                                                <xs:element name="TEXT_LINE" maxOccurs="3">
                                                                  <xs:annotation>
                                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:complexType>
                                                                    <xs:sequence>
                                                                      <xs:element name="TEXT">
                                                                        <xs:annotation>
                                                                          <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:string">
                                                                            <xs:pattern value="[\S ]{1,30}" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:element>
                                                                    </xs:sequence>
                                                                    <xs:attribute name="SEQUENCE_NO" use="required">
                                                                      <xs:annotation>
                                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:positiveInteger" />
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                  </xs:complexType>
                                                                </xs:element>
                                                              </xs:sequence>
                                                              <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:language">
                                                                    <xs:pattern value="[A-Za-z]{1,3}" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                    <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:element>
                                                    <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="TYPE_KEY">
                                                <xs:annotation>
                                                  <xs:documentation>445--1--Satzart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                                                      <xs:annotation>
                                                        <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:maxInclusive value="2000" />
                                                          <xs:minInclusive value="1000" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="TK_CLASS" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="TK_INFO" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:pattern value="[0-8]0" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="ECLASS">
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="ECLASS_NO">
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:totalDigits value="8" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:maxInclusive value="999999999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="DECISION_NO" use="optional">
                                                          <xs:annotation>
                                                            <xs:documentation>291--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="9999999999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="SALES_NUMBER" minOccurs="0">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PART_LIST_REF" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>401--1--Satzart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="PART_LIST_KEY" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>--0--NEW</xs:documentation>
                                                      <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:maxLength value="30" />
                                                        <xs:minLength value="1" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:boolean" />
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PROPERTIES" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="PROPERTY_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="0" />
                                                              <xs:maxInclusive value="999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="VALUE" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:string">
                                                              <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="ECO_MOBILIER" minOccurs="0">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="[0-9]{11}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>250--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                          </xs:element>
                                                          <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>250--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                          </xs:element>
                                                          <xs:element name="WIDTH">
                                                            <xs:annotation>
                                                              <xs:documentation>400--20--Gewicht</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="9999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="DEPTH">
                                                            <xs:annotation>
                                                              <xs:documentation>400--20--Gewicht</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="9999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="HEIGHT">
                                                            <xs:annotation>
                                                              <xs:documentation>400--20--Gewicht</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="9999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="WEIGHT" type="xs:decimal">
                                                            <xs:annotation>
                                                              <xs:documentation>400--20--Gewicht</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                            </xs:annotation>
                                                          </xs:element>
                                                          <xs:element name="EAN_NUMBER" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="DECISIONS" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>291--0--NEW</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:sequence>
                                                                <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                                                  <xs:annotation>
                                                                    <xs:documentation>291--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:complexType>
                                                                    <xs:attribute name="DECISION_NO" use="required">
                                                                      <xs:annotation>
                                                                        <xs:documentation>291--0--NEW</xs:documentation>
                                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:positiveInteger">
                                                                          <xs:minInclusive value="1" />
                                                                          <xs:maxInclusive value="9999999999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                  </xs:complexType>
                                                                </xs:element>
                                                              </xs:sequence>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger" />
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:choice>
                                        </xs:sequence>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE_NO">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="DECISIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>291--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>291--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DECISION_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>291--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="COLOR_CONSULTANCIES" minOccurs="0">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="COLOR_CONSULTANCY" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke
                              </xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FEATURE_DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>255--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
                                          30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>270--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="DECISION_NO" use="optional">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="COLOR_CONSULTANCY_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO" type="xs:positiveInteger" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">IDM 2.5 Sortierung der Modelle</xs:documentation>
                    <xs:documentation>K. Richter 26.02.2015</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DECISIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SERIE_GROUPS" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">IDM 2.5
Möglichkeit Serien zu gruppieren und auch ein Bild zu hinterlegen</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIE_GROUP" maxOccurs="unbounded">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SERIE_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>200--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SERIE_GROUP_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SERIE_GROUP_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          <xs:documentation>geändert auf SERIE_GROUP_KEY, K.Richter 23.11.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PART_LISTS" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PART_LIST" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation> K. Richter 12.02.2015</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PART_LIST_POS" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation />
                      <xs:documentation />
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SEQUENCE_NO">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">IDM-2.5
laufende Nummer der Position
bei Planungsvorschlägen sollte diese von links nach rechts gemäß der Planungsvariante geordnet sein</xs:documentation>
                            <xs:documentation xml:lang="DE" />
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DECISIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>291--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DECISION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="POS_COUNT_VALUE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Anzahl der Positionen gemäß der Einheit an den Stammdaten</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DECISION_POS_COUNT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">IDM 2.5
Entscheidungstabellen, die die Anzahl steuern.
Hier dürfen nur Decisions verwendet werden, die im Action_part die Anzahl steuern (set_pos_count).</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DECISION_REF">
                                <xs:annotation>
                                  <xs:documentation />
                                  <xs:documentation />
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DECISION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="POS_INVISIBILITY">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">IDM 2.5 neu
0 = sichtbar komplett
1 = gar nicht sichtbar
2= nur in EDI-Bestellung sichtbar, wenn über Decisions gezogen wird</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:integer">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="2" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PART_LIST_KEY" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:maxLength value="30" />
                      <xs:minLength value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_DEFINITION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_CLASSES">
              <xs:annotation>
                <xs:documentation>255--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_CLASS" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>255--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FEATURE_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>255--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>255--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="INVISIBLE" type="xs:boolean">
                              <xs:annotation>
                                <xs:documentation xml:lang="de">neu 2.4 BA/07.03.2014
unsichtbare Variantenart.
Wird nicht im Konfigurator angezeigt.
</xs:documentation>
                              </xs:annotation>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_CLASS_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>255--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                          <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURES">
              <xs:annotation>
                <xs:documentation>250--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:choice minOccurs="0">
                                      <xs:element name="MATERIAL_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="MATERIAL_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="5" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="FORM_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="FORM_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="5" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_MEASURE_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_MEASURE_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:choice>
                                    <xs:element name="OPTION_TEXT" type="languagetext60">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="DETAIL_INFOS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="30" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                  <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_FREETEXT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:boolean" />
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE_NO">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FEATURE_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>250--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="SEQUENCE_NO">
                          <xs:annotation>
                            <xs:documentation>250--4--Sortierung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HEADER_POS_VARIATION_TYPE">
                          <xs:annotation>
                            <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[IKP]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FEATURE_TYPE">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="MEASURE" minOccurs="0">
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="MEASURE_UNIT" type="xs:string">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="MEASURE_PARAMETER" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:maxLength value="20" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="FEATURE_T">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:length value="1" />
                                  <xs:pattern value="[MCO]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_DEFINITION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="COLOR">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="RGB_RED">
                                <xs:annotation>
                                  <xs:documentation>260--11--RGB_Rot</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="255" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="RGB_GREEN">
                                <xs:annotation>
                                  <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="255" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="RGB_BLUE">
                                <xs:annotation>
                                  <xs:documentation>260--13--RGB_Blau</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="255" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="MATERIAL_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MEASURE_VALUE">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MEASURE_UNIT" type="xs:string">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="OPTION_MEASURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DECISIONS" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>270/271--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>nicht zwingend anzugeben, K. Richter, 23.05.2014</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION" maxOccurs="99999">
                    <xs:annotation>
                      <xs:documentation>270/271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DECISION_NAME_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>270--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:complexType>
                                  <xs:choice>
                                    <xs:element name="OPTION_INTERVAL">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="in|nin" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY_MIN" use="required">
                                          <xs:annotation>
                                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY_MAX" use="required">
                                          <xs:annotation>
                                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_LIST">
                                      <xs:complexType>
                                        <xs:sequence maxOccurs="unbounded">
                                          <xs:element name="OPTION_REF">
                                            <xs:complexType>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="in|nin" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_GROUP_REF_OP">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>271--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="in|nin" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF_OP">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>271--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FEATURE_REF_OP">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
                                        <xs:documentation />
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>271--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="eq|ne" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="MEASURE_VALUE_OP">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                          </xs:annotation>
                                        </xs:attribute>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="MEASURE_INTERVAL">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="in|nin" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                          <xs:annotation>
                                            <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                          </xs:annotation>
                                        </xs:attribute>
                                        <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                          <xs:annotation>
                                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                          </xs:annotation>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="REF_LEVEL" use="optional">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">1 = ROOT
2 = PARENT
3 = SELF
Standardfall ist SELF, wenn kein REF-Level angegeben ist</xs:documentation>
                                      <xs:documentation xml:lang="DE">12.02.2015 K. Richter</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:maxInclusive value="3" />
                                        <xs:minInclusive value="1" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ACTIONS" minOccurs="0">
                                <xs:complexType>
                                  <xs:choice maxOccurs="unbounded">
                                    <xs:element name="SET_FEATURE_DEFAULT">
                                      <xs:complexType>
                                        <xs:choice>
                                          <xs:element name="FEATURE_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPTION_REF">
                                            <xs:complexType>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FORMULA_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FORMULA_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:choice>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="SET_FEATURE_FIXED">
                                      <xs:complexType>
                                        <xs:choice>
                                          <xs:element name="FEATURE_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPTION_REF">
                                            <xs:complexType>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FORMULA_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FORMULA_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:choice>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ENABLE_DECISION">
                                      <xs:complexType>
                                        <xs:attribute name="DECISION_NO">
                                          <xs:annotation>
                                            <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="DISABLE_DECISION">
                                      <xs:complexType>
                                        <xs:attribute name="DECISION_NO">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="SET_FEATURE_VISIBLE">
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="SET_FEATURE_INVISIBLE">
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="SET_FEATURE">
                                      <xs:complexType>
                                        <xs:choice>
                                          <xs:element name="FEATURE_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPTION_REF">
                                            <xs:complexType>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FORMULA_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FORMULA_KEY">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:choice>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="SET_FEATURE_DEFAULT_NULL">
                                      <xs:complexType>
                                        <xs:choice>
                                          <xs:element name="FEATURE_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPTION_REF">
                                            <xs:complexType>
                                              <xs:attribute name="OPTION_KEY">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FORMULA_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FORMULA_KEY">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:choice>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="SET_POS_COUNT_VALUE">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                        <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                                        <xs:documentation>setzt Anzahl</xs:documentation>
                                        <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="SET_MESSAGE">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                        <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                                        <xs:documentation>setzt Anzahl</xs:documentation>
                                        <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="MESSAGE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                            <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                            <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FEATURE_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Entscheidungstabellen wieder entfernt, nur Angabe FEATURE_NO, 02.05.2014</xs:documentation>
                            <xs:documentation xml:lang="de">Version Beta 2.0 Build 12</xs:documentation>
                            <xs:documentation xml:lang="de">minimale Kardinalität auf 0 geändert K.Richter 18.07.2014</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRIO">
                          <xs:annotation>
                            <xs:documentation xml:lang="de">neu IDM 2.4
Priorität von Prüfungen

Am Artikel können nur Decisions mit niedriger Priorität hinzu bzw. ausgeschaltet werden
Mehrere DECISIONS können auf einem gleichen Priolevel liegen

</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="DECISION_TYPE" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">IDM 2.4 Build 14 H.Balke 05.2014
0 = ausschließende (nicht erlaubende) Preparation
1 = Preparation
2 = action Rules
3 = action Rule mit SET_POS_COUNT_VALUE (setzt die Anzahl in der die Position in der Stückliste erscheint)

Restriktions werden vor Eingabe einer Variante am Artikel ausgewertet.
Wenn dann ein Wert ausgewählt wurde, greifen die action Rules, welche dann Werte setzen oder Variantenarten ausblenden können.
Bei Action Rules greift immer die erste Zeile (option combination), die zutrifft. In dem Fall werden alle zugehörigen Actions ausgeführt.
</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:int">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="3" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_GROUPS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_GROUP" maxOccurs="unbounded">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_GROUP_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="OPTION_GROUP_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FORMULAS" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="de">Formeln dürfen nur angewendet werden auf Maßvarianten </xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FORMULA" maxOccurs="unbounded">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FORMULA_STRING">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Formeln dürfen nur Parameter enthalten, die an der Variantenart definiert wurden.</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[+\-*/()A-Za-z0-9. ]*" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FORMULA_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_DEFINITION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>300--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:choice>
                          <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                                    <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:choice>
                                      <xs:element name="OPTION_INTERVAL">
                                        <xs:annotation>
                                          <xs:documentation>271--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPTION_KEY_MIN" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPTION_KEY_MAX" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_LIST">
                                        <xs:complexType>
                                          <xs:sequence maxOccurs="unbounded">
                                            <xs:element name="OPTION_REF">
                                              <xs:complexType>
                                                <xs:attribute name="OPTION_KEY" use="required">
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="30" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_GROUP_REF_OP">
                                        <xs:annotation>
                                          <xs:documentation>271--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                            <xs:annotation>
                                              <xs:documentation>271--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_REF_OP">
                                        <xs:annotation>
                                          <xs:documentation>271--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_KEY" use="required">
                                            <xs:annotation>
                                              <xs:documentation>271--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MEASURE_VALUE_OP">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MEASURE_INTERVAL">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                          <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:choice>
                                    <xs:attribute name="FEATURE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="PRICE_FIELD">
                                  <xs:annotation>
                                    <xs:documentation>311--5--Preisfeld</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="SUPPLIER_PRICE_GROUP">
                                  <xs:annotation>
                                    <xs:documentation>311--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:minLength value="1" />
                                      <xs:maxLength value="10" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="VALID_FROM" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:date" />
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="VALID_UNTIL" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:date" />
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="SEQUENCE" use="required">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="PERCENTAGE_SURCHARGE" minOccurs="0" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>geändert K.Richter 23.11.2015</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                                    <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:choice>
                                      <xs:element name="OPTION_INTERVAL">
                                        <xs:annotation>
                                          <xs:documentation>271--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPTION_KEY_MIN" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPTION_KEY_MAX" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_LIST">
                                        <xs:complexType>
                                          <xs:sequence maxOccurs="unbounded">
                                            <xs:element name="OPTION_REF">
                                              <xs:complexType>
                                                <xs:attribute name="OPTION_KEY" use="required">
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="30" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_GROUP_REF_OP">
                                        <xs:annotation>
                                          <xs:documentation>271--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                            <xs:annotation>
                                              <xs:documentation>271--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_REF_OP">
                                        <xs:annotation>
                                          <xs:documentation>271--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_KEY" use="required">
                                            <xs:annotation>
                                              <xs:documentation>271--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MEASURE_VALUE_OP">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MEASURE_INTERVAL">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                          <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:choice>
                                    <xs:attribute name="FEATURE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="PRICE_FACTOR">
                                  <xs:annotation>
                                    <xs:documentation>311--5--Preisfeld</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:int">
                                      <xs:maxInclusive value="99999999" />
                                      <xs:minInclusive value="-9999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="PRICE_FEATURE_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>311--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="VALID_FROM" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:date" />
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="VALID_UNTIL" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:date" />
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="SEQUENCE" use="required">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                      </xs:sequence>
                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="ADDITIONAL_PRICE" use="required">
                        <xs:annotation>
                          <xs:documentation>300--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:boolean" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_TYPES">
              <xs:annotation>
                <xs:documentation>150--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence maxOccurs="unbounded">
                  <xs:element name="PRICE_TYPE">
                    <xs:annotation>
                      <xs:documentation>150--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="WIDTH_X">
                          <xs:annotation>
                            <xs:documentation>150--3--Breite_X</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DEPTH_Y">
                          <xs:annotation>
                            <xs:documentation>150--4--Tiefe_Y</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HEIGHT_Z">
                          <xs:annotation>
                            <xs:documentation>150--5--Hoehe_Z</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_UNIT">
                          <xs:annotation>
                            <xs:documentation>150--6--Basis_Einheit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ROUNDING_UNIT">
                          <xs:annotation>
                            <xs:documentation>150--7--Rundungseinheit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ROUNDING_TYPE">
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="3" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_PRICE_DEPENDENT">
                          <xs:annotation>
                            <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>150--9--Preisart_Formel</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="100" />
                              <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_NAME" type="languagetext60" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_RULES" minOccurs="0" maxOccurs="1">
                          <xs:annotation>
                            <xs:documentation>360--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRICE_TYPE_RULE" maxOccurs="100">
                                <xs:annotation>
                                  <xs:documentation>Polster
Regeln zur ermittelung der Preisart
z.B. if Preisgruppe A &gt; Preisgruppe B dann nimm Preisgruppe A </xs:documentation>
                                  <xs:documentation xml:lang="DE">Version 2.1 Build 7</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="RULE" type="xs:string">
                                      <xs:annotation>
                                        <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
                                        <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="RULE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>360--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>150--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MAJOR" fixed="1" use="required">
      <xs:annotation>
        <xs:documentation>100--3--Versionsnummer</xs:documentation>
        <xs:documentation>Verlegung der Versionierung</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:list itemType="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MINOR" use="required">
      <xs:annotation>
        <xs:documentation>100--4--Sub_Versions_Nr</xs:documentation>
        <xs:documentation />
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="0" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="REVISION" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="0" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FORMAT" use="required">
      <xs:annotation>
        <xs:documentation>100--8--Branchen_ID</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[ABGKOPSWZ]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
              See Also
              IDMW 2.0 XML-Schema Dokumentation

              © 2019 All Rights Reserved.

              Send comments on this topic.


%%LocalItemTitle%%

CATALOG Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : CATALOG Element
Description
This element is used to store administrative information concerning the catalogue/data pool.
Namespace (none)
Diagram
DETAIL_INFOS Element FALL_BACK_LANGUAGE Element CATALOG_VERSION Element CATALOG_ID Element LANGUAGE Element Sequence CATALOG_INFO Element CATALOG_DATA_VERSION Element CATALOG_MERGE_TYPE Element CATALOG_MARK Element FILE_ID Element VALID_UNTIL_DATE Element VALID_FROM_DATE Element DATA_VERSION Element LANGUAGE Element Sequence CATALOG_NAME Element CATALOG_NUMBER Element CATALOG_IDENTIFICATION Element Sequence CATALOG Element
Overview
CATALOG
This element is used to store administrative information concerning the catalogue/data pool.
Sequence
CATALOG_IDENTIFICATION
This element is used to specify the catalogue's identifying characteristics.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data must be identical.
Sequence
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used. D language
P [A-Za-z]{1,3}
M [1:3]
CURRENCY_KEY Restriction of xs:string
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
CATALOG_NUMBER Restriction of xs:string
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
CATALOG_NAME languagetext30 Complex Type
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names that include the year are permitted.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
The data version (DATA_VERSION) defines the date until which catalogue data, supplements and error corrections published by the manufacturer was included in the data pool. D date
P
M
VALID_FROM_DATE Restriction of xs:date
The element is used to specify the validity period date of the catalogue and thereby of the current data pool. D date
P
M
VALID_UNTIL_DATE Restriction of xs:date
The element is used to specify the validity period date of the catalogue and thereby of the current data pool. D date
P
M
FILE_ID Restriction of xs:boolean
This element is used to specify whether the data pool contains test data or released data.

0/false = test data
1/true = released data 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
This element is used to specify whether the provisions data are

B = block data with prices
K = catalogue data
V = block data without prices (fictional prices must be specified)
F = correction update.

 D string
P [BKVF]
M [1:1]
CATALOG_MERGE_TYPE optional xs:boolean

This element CATALOG_MERGE_TYPE is optional and contains boolean data with the following values:

0: The value if the element is not present; it means that this catalogue does not have to be part of a multi-manufacturer catalogue.

1: This catalogue is always part of a multi-manufacturer catalogue.

 D boolean
P
M
CATALOG_DATA_VERSION optional Restriction of xs:date
This element must be filled if the CATALOG_MARK element (catalogue identifier) contains the value F for correction update.

This element is used to enter the date of the base file (element DATA_VERSION) to which the correction update relates. 		D date
P
M
CATALOG_INFO optional languagetext Complex Type
This element is used to store the information texts.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
CATALOG_ID Restriction of xs:string

The manufacturer can enter a unique ID (e.g. GUID) that unequivocally identifies the catalogue here.

It must be observed that a manufacturer catalogue must always have the same ID for the same dealership.

 D string
P
M [1:64]
CATALOG_VERSION Restriction of xs:positiveInteger
The manufacturer can assign a version number for the catalogue in this field D positiveInteger
P
M [1:999999999]
FALL_BACK_LANGUAGE Restriction of xs:language
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The 2-digit ISO Language code must be used. D language
P [A-Z]{2}
M [2:2]
DETAIL_INFOS 0..∞
This element serves to specify images on catalogue level, e.g. a manufacturer or catalogue logo.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Remarks

Source
<xs:element name="CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version 2.3 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{1,2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CURRENCY_KEY">
              <xs:annotation>
                <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{1,3}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG_NUMBER">
        <xs:annotation>
          <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_NAME" type="languagetext30">
        <xs:annotation>
          <xs:documentation>100--10--Katalog_Name</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="DATA_VERSION">
        <xs:annotation>
          <xs:documentation>100--11--Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_FROM_DATE">
        <xs:annotation>
          <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL_DATE">
        <xs:annotation>
          <xs:documentation>100--12--Gueltig_bis_Datum Neu Build 9</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILE_ID">
        <xs:annotation>
          <xs:documentation>100--14--Datei_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MARK">
        <xs:annotation>
          <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BKVF]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MERGE_TYPE" type="xs:boolean" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Kennzeichen, ob Teil eines Multiherstellerkataloges</xs:documentation>
          <xs:documentation>1: immer Teil eines Multiherstellerkataloges</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_DATA_VERSION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_INFO" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>110--3--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_ID">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Katalog_ID
/Hermann Balke 9.06.2013
neu in 2.3
hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="64" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_VERSION">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Katalog_Version
/Hermann Balke 16.07.2013
neu in 2.3
hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FALL_BACK_LANGUAGE">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
          <xs:documentation>K. Richter 15.08.2017</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
          <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW  </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW </xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_IDENTIFICATION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_IDENTIFICATION Element
Description
This element is used to specify the catalogue's identifying characteristics.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data must be identical.
Namespace (none)
Diagram
CURRENCY_KEY Element ISO_LANGUAGE_ID Element Sequence CATALOG_IDENTIFICATION Element
Overview
CATALOG_IDENTIFICATION
This element is used to specify the catalogue's identifying characteristics.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data must be identical.
Sequence
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used. D language
P [A-Za-z]{1,3}
M [1:3]
CURRENCY_KEY Restriction of xs:string
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
Remarks

Source
<xs:element name="CATALOG_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{1,2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CURRENCY_KEY">
        <xs:annotation>
          <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{1,3}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ISO_LANGUAGE_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ISO_LANGUAGE_ID Element
Description
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used. D language
P [A-Za-z]{1,3}
M [1:3]
Namespace (none)
Type
Restriction of xs:language
Diagram
ISO_LANGUAGE_ID Element
Overview
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used. D language
P [A-Za-z]{1,3}
M [1:3]
Remarks

Source
<xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{1,2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CURRENCY_KEY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CURRENCY_KEY Element
Description
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
Namespace (none)
Type
Restriction of xs:string
Diagram
CURRENCY_KEY Element
Overview
CURRENCY_KEY Restriction of xs:string
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
Remarks

Source
<xs:element name="CURRENCY_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{1,3}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_NUMBER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_NUMBER Element
Description
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_NUMBER Element
Overview
CATALOG_NUMBER Restriction of xs:string
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
Remarks

Source
<xs:element name="CATALOG_NUMBER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_NAME Element
Description
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names that include the year are permitted.
Namespace (none)
Type
languagetext30 Complex Type
Diagram
LANGUAGE Element Sequence CATALOG_NAME Element
Overview
CATALOG_NAME languagetext30 Complex Type
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names that include the year are permitted.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Remarks

Source
<xs:element name="CATALOG_NAME" type="languagetext30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--10--Katalog_Name</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > languagetext30 Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetext30 Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > languagetext30 Complex Type > LANGUAGE Element : TEXT Element
Description
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetext30 Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DATA_VERSION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : DATA_VERSION Element
Description
The data version (DATA_VERSION) defines the date until which catalogue data, supplements and error corrections published by the manufacturer was included in the data pool. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
DATA_VERSION Element
Overview
DATA_VERSION Restriction of xs:date
The data version (DATA_VERSION) defines the date until which catalogue data, supplements and error corrections published by the manufacturer was included in the data pool. D date
P
M
Remarks

Source
<xs:element name="DATA_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--11--Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM_DATE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : VALID_FROM_DATE Element
Description
The element is used to specify the validity period date of the catalogue and thereby of the current data pool. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM_DATE Element
Overview
VALID_FROM_DATE Restriction of xs:date
The element is used to specify the validity period date of the catalogue and thereby of the current data pool. D date
P
M
Remarks

Source
<xs:element name="VALID_FROM_DATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL_DATE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : VALID_UNTIL_DATE Element
Description
The element is used to specify the validity period date of the catalogue and thereby of the current data pool. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL_DATE Element
Overview
VALID_UNTIL_DATE Restriction of xs:date
The element is used to specify the validity period date of the catalogue and thereby of the current data pool. D date
P
M
Remarks

Source
<xs:element name="VALID_UNTIL_DATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--12--Gueltig_bis_Datum Neu Build 9</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FILE_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : FILE_ID Element
Description
This element is used to specify whether the data pool contains test data or released data.

0/false = test data
1/true = released data 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
FILE_ID Element
Overview
FILE_ID Restriction of xs:boolean
This element is used to specify whether the data pool contains test data or released data.

0/false = test data
1/true = released data 		D boolean
P
M
Remarks

Source
<xs:element name="FILE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--14--Datei_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_MARK Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_MARK Element
Description
This element is used to specify whether the provisions data are

B = block data with prices
K = catalogue data
V = block data without prices (fictional prices must be specified)
F = correction update.

 D string
P [BKVF]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_MARK Element
Overview
CATALOG_MARK Restriction of xs:string
This element is used to specify whether the provisions data are

B = block data with prices
K = catalogue data
V = block data without prices (fictional prices must be specified)
F = correction update.

 D string
P [BKVF]
M [1:1]
Remarks

Source
<xs:element name="CATALOG_MARK" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BKVF]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_MERGE_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_MERGE_TYPE Element
Description

This element CATALOG_MERGE_TYPE is optional and contains boolean data with the following values:

0: The value if the element is not present; it means that this catalogue does not have to be part of a multi-manufacturer catalogue.

1: This catalogue is always part of a multi-manufacturer catalogue.

 D boolean
P
M
Namespace (none)
Type
xs:boolean
Diagram
CATALOG_MERGE_TYPE Element
Overview
CATALOG_MERGE_TYPE optional xs:boolean

This element CATALOG_MERGE_TYPE is optional and contains boolean data with the following values:

0: The value if the element is not present; it means that this catalogue does not have to be part of a multi-manufacturer catalogue.

1: This catalogue is always part of a multi-manufacturer catalogue.

 D boolean
P
M
Source
<xs:element name="CATALOG_MERGE_TYPE" type="xs:boolean" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Kennzeichen, ob Teil eines Multiherstellerkataloges</xs:documentation>
    <xs:documentation>1: immer Teil eines Multiherstellerkataloges</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_DATA_VERSION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_DATA_VERSION Element
Description
This element must be filled if the CATALOG_MARK element (catalogue identifier) contains the value F for correction update.

This element is used to enter the date of the base file (element DATA_VERSION) to which the correction update relates. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
CATALOG_DATA_VERSION Element
Overview
CATALOG_DATA_VERSION optional Restriction of xs:date
This element must be filled if the CATALOG_MARK element (catalogue identifier) contains the value F for correction update.

This element is used to enter the date of the base file (element DATA_VERSION) to which the correction update relates. 		D date
P
M
Remarks

Source
<xs:element name="CATALOG_DATA_VERSION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_INFO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_INFO Element
Description
This element is used to store the information texts.
Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence CATALOG_INFO Element
Overview
CATALOG_INFO optional languagetext Complex Type
This element is used to store the information texts.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="CATALOG_INFO" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>110--3--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > languagetext Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:string" />
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetext Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > languagetext Complex Type > LANGUAGE Element : TEXT Element
Description
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Namespace (none)
Type
xs:string
Diagram
TEXT Element
Overview
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="TEXT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LANGUAGE Element | languagetext Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_ID Element
Description

The manufacturer can enter a unique ID (e.g. GUID) that unequivocally identifies the catalogue here.

It must be observed that a manufacturer catalogue must always have the same ID for the same dealership.

 D string
P
M [1:64]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_ID Element
Overview
CATALOG_ID Restriction of xs:string

The manufacturer can enter a unique ID (e.g. GUID) that unequivocally identifies the catalogue here.

It must be observed that a manufacturer catalogue must always have the same ID for the same dealership.

 D string
P
M [1:64]
Remarks

Source
<xs:element name="CATALOG_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Katalog_ID
/Hermann Balke 9.06.2013
neu in 2.3
hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="64" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_VERSION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_VERSION Element
Description
The manufacturer can assign a version number for the catalogue in this field D positiveInteger
P
M [1:999999999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
CATALOG_VERSION Element
Overview
CATALOG_VERSION Restriction of xs:positiveInteger
The manufacturer can assign a version number for the catalogue in this field D positiveInteger
P
M [1:999999999]
Remarks

Source
<xs:element name="CATALOG_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Katalog_Version
/Hermann Balke 16.07.2013
neu in 2.3
hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FALL_BACK_LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : FALL_BACK_LANGUAGE Element
Description
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The 2-digit ISO Language code must be used. D language
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:language
Diagram
FALL_BACK_LANGUAGE Element
Overview
FALL_BACK_LANGUAGE Restriction of xs:language
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The 2-digit ISO Language code must be used. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="FALL_BACK_LANGUAGE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFOS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : DETAIL_INFOS Element
Description
This element serves to specify images on catalogue level, e.g. a manufacturer or catalogue logo.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS 0..∞
This element serves to specify images on catalogue level, e.g. a manufacturer or catalogue logo.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
    <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW </xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description
This element is used to reference the detailed information.
Namespace (none)
Diagram
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SUPPLIER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : SUPPLIER Element
Description
This element is used to specify the manufacturer's data, e.g. communication and contact information.
Namespace (none)
Diagram
CONTACT_SUPPLIER Element CONTACT_PERSON Element WEEE_NO Element GLN_NO Element ISO_COUNTRY_ID Element EDI_INFO Element Sequence SUPPLIER Element
Overview
SUPPLIER
This element is used to specify the manufacturer's data, e.g. communication and contact information.
Sequence
EDI_INFO 0..∞
This element is used to inform the partners of the available EDI communications. One element is created fir each EDI message in EDI format.
Sequence
EDI_FORMAT optional Restriction of xs:string
The supported EDI format is specified here (e.g. EDIData) D string
P
M [1:20]
EDI_FORMAT_VERSION optional Restriction of xs:string
The supported version of the EDI format specified in the EDI-FORMAT element is specified here. D string
P
M [1:10]
EDI_MESSAGE optional Restriction of xs:string
The messages in EDI format supported by the manufacturer are stored here (e.g. order, order response). D string
P
M [1:20]
EDI_COMMUNICATION optional Restriction of xs:string
This is used to specify the method for EDI communications (e.g. X400, Telebox, email). D string
P
M [1:20]
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
The address for the specified communication method is specified here ( e.g. X400 address, email address, or as discussed) D string
P
M [1:40]
EDI_CONTACT optional Restriction of xs:string
The contact person available at the manufacturer for details concerning EDI processing is specified here. The specification of contact information is optional, i.e. necessary information, e.g. name, telephone number or email address, can be specified up to the maximum field length. D string
P
M [1:60]
ISO_COUNTRY_ID Restriction of xs:string
This element is used to specify the manufacturer's country in accordance with the ISO standard. D string
P [A-Z]{2}
M [2:2]
GLN_NO Restriction of xs:string
This element is used to enter a unique global location number (GLN). The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data.
If a company has multiple GLN values, the root GLN must be specified. 		D string
P [0-9]{13}
M
WEEE_NO optional Restriction of xs:string
This element is used to enter the WEEE registration number. A WEEE registration number is mandatory for everyone classified as a manufacturer or importer of electrical appliances in accordance with the "Electrical and Electronic Equipment Act (ElektroG)".
In Germany, WEEE numbers look as follows: "DE12345678".
Dealers can verify the validity of WEEE numbers on the website of the register for Waste Electrical Appliances (http://www.stiftung-ear.de). 		D string
P
M
CONTACT_PERSON 1..2
This element is used to specify the information of a contact person
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
This element is used to specify the priorities of methods for making contact with the contact person. (1=1st Contact, 2=2nd contact) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
This element is used to specify the role of the newly created contact. The role designation certified by the manufacturer (e.g. substitute, person responsible for EDI). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
This element is used to specify the last name of the direct contact person for the software house. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
This element is used to specify the first name of the direct contact person. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
This element is used to specify the salutation for the direct contact person.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
This element is, if present, used to specify the department of the direct contact person. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
This element is used to specify the telephone number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
This element is used to specify the fax number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
This element is used to specify the email address. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
STREET optional Restriction of xs:string
This element as you specify the street of the manufacturer's business address. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
This element is used to specify the postcode of the manufacturer's business address. D string
P
M [1:8]
CITY optional Restriction of xs:string
This element is used to specify the manufacturer's place registered office. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
This element is used to specify the manufacturer's country in accordance with the ISO standard is to be specified. D string
P [A-Z]{2}
M [2:2]
CONTACT_SUPPLIER
This element is used to specify the manufacturer's contact data
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
This element is used to specify the first line of the company name. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
If activated, this element is used to store the second line of the company name. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
This element is used to specify the official email address for the dealership or consumer. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
INTERNET_ADDRESS optional Restriction of xs:string
This element, if present, is used to specify the official URL (e.g. http://www.company.com) for dealerships or consumers. D string
P
M
STREET Restriction of xs:string
This element as you specify the street of the manufacturer's business address. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
This element is used to specify the postcode of the manufacturer's business address. D string
P
M [1:8]
CITY Restriction of xs:string
This element is used to specify the manufacturer's place registered office. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
This element is used to specify the manufacturer's country in accordance with the ISO standard is to be specified. D string
P [A-Z]{2}
M [2:2]
ZIPCODE_POSTBOX optional Restriction of xs:string
This element is, if present, used to specify the postcode associated with the PO Box. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
This element is, if present, used to specify the PO Box line of the manufacturer's address. The word "PO Box" must be omitted. D string
P [0-9a-zA-Z]{0,10}
M [00:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
This element is used to specify the telephone number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
This element is here to specify the fax number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
Remarks

Source
<xs:element name="SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EDI_INFO" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>105--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EDI_FORMAT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--2--EDI_Format</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_FORMAT_VERSION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_MESSAGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_COMMUNICATION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="40" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_CONTACT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="60" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="ISO_COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="GLN_NO">
        <xs:annotation>
          <xs:documentation>100--45--GLN_Nr
30.05.2012/Bur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9]{13}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="WEEE_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--47--WEEE_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_PERSON" maxOccurs="2">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CONTACT_PERSON_NO">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_ROLE">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="60" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_NAME">
              <xs:annotation>
                <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FIRST_NAME">
              <xs:annotation>
                <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FORM_OF_ADDRESS">
              <xs:annotation>
                <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DEPARTMENT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE">
              <xs:annotation>
                <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CONTACT_SUPPLIER">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_NAME_1">
              <xs:annotation>
                <xs:documentation>100--16--Herstellername_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--17--Herstellername_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INTERNET_ADDRESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--19--Internet_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET">
              <xs:annotation>
                <xs:documentation>100--20--Strasse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET">
              <xs:annotation>
                <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY">
              <xs:annotation>
                <xs:documentation>100--22--Ort</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--24--Postfach</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_INFO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element : EDI_INFO Element
Description
This element is used to inform the partners of the available EDI communications. One element is created fir each EDI message in EDI format.
Namespace (none)
Diagram
EDI_CONTACT Element EDI_COMMUNICATION_ADDRESS Element EDI_COMMUNICATION Element EDI_MESSAGE Element EDI_FORMAT_VERSION Element EDI_FORMAT Element Sequence EDI_INFO Element
Overview
EDI_INFO 0..∞
This element is used to inform the partners of the available EDI communications. One element is created fir each EDI message in EDI format.
Sequence
EDI_FORMAT optional Restriction of xs:string
The supported EDI format is specified here (e.g. EDIData) D string
P
M [1:20]
EDI_FORMAT_VERSION optional Restriction of xs:string
The supported version of the EDI format specified in the EDI-FORMAT element is specified here. D string
P
M [1:10]
EDI_MESSAGE optional Restriction of xs:string
The messages in EDI format supported by the manufacturer are stored here (e.g. order, order response). D string
P
M [1:20]
EDI_COMMUNICATION optional Restriction of xs:string
This is used to specify the method for EDI communications (e.g. X400, Telebox, email). D string
P
M [1:20]
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
The address for the specified communication method is specified here ( e.g. X400 address, email address, or as discussed) D string
P
M [1:40]
EDI_CONTACT optional Restriction of xs:string
The contact person available at the manufacturer for details concerning EDI processing is specified here. The specification of contact information is optional, i.e. necessary information, e.g. name, telephone number or email address, can be specified up to the maximum field length. D string
P
M [1:60]
Remarks

Source
<xs:element name="EDI_INFO" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EDI_FORMAT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--2--EDI_Format</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_FORMAT_VERSION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_MESSAGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_COMMUNICATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="40" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_CONTACT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="60" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_FORMAT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_FORMAT Element
Description
The supported EDI format is specified here (e.g. EDIData) D string
P
M [1:20]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDI_FORMAT Element
Overview
EDI_FORMAT optional Restriction of xs:string
The supported EDI format is specified here (e.g. EDIData) D string
P
M [1:20]
Remarks

Source
<xs:element name="EDI_FORMAT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--2--EDI_Format</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_FORMAT_VERSION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_FORMAT_VERSION Element
Description
The supported version of the EDI format specified in the EDI-FORMAT element is specified here. D string
P
M [1:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDI_FORMAT_VERSION Element
Overview
EDI_FORMAT_VERSION optional Restriction of xs:string
The supported version of the EDI format specified in the EDI-FORMAT element is specified here. D string
P
M [1:10]
Remarks

Source
<xs:element name="EDI_FORMAT_VERSION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_MESSAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_MESSAGE Element
Description
The messages in EDI format supported by the manufacturer are stored here (e.g. order, order response). D string
P
M [1:20]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDI_MESSAGE Element
Overview
EDI_MESSAGE optional Restriction of xs:string
The messages in EDI format supported by the manufacturer are stored here (e.g. order, order response). D string
P
M [1:20]
Remarks

Source
<xs:element name="EDI_MESSAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_COMMUNICATION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_COMMUNICATION Element
Description
This is used to specify the method for EDI communications (e.g. X400, Telebox, email). D string
P
M [1:20]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDI_COMMUNICATION Element
Overview
EDI_COMMUNICATION optional Restriction of xs:string
This is used to specify the method for EDI communications (e.g. X400, Telebox, email). D string
P
M [1:20]
Remarks

Source
<xs:element name="EDI_COMMUNICATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_COMMUNICATION_ADDRESS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_COMMUNICATION_ADDRESS Element
Description
The address for the specified communication method is specified here ( e.g. X400 address, email address, or as discussed) D string
P
M [1:40]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDI_COMMUNICATION_ADDRESS Element
Overview
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
The address for the specified communication method is specified here ( e.g. X400 address, email address, or as discussed) D string
P
M [1:40]
Remarks

Source
<xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="40" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_CONTACT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_CONTACT Element
Description
The contact person available at the manufacturer for details concerning EDI processing is specified here. The specification of contact information is optional, i.e. necessary information, e.g. name, telephone number or email address, can be specified up to the maximum field length. D string
P
M [1:60]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDI_CONTACT Element
Overview
EDI_CONTACT optional Restriction of xs:string
The contact person available at the manufacturer for details concerning EDI processing is specified here. The specification of contact information is optional, i.e. necessary information, e.g. name, telephone number or email address, can be specified up to the maximum field length. D string
P
M [1:60]
Remarks

Source
<xs:element name="EDI_CONTACT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="60" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ISO_COUNTRY_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element : ISO_COUNTRY_ID Element
Description
This element is used to specify the manufacturer's country in accordance with the ISO standard. D string
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:string
Diagram
ISO_COUNTRY_ID Element
Overview
ISO_COUNTRY_ID Restriction of xs:string
This element is used to specify the manufacturer's country in accordance with the ISO standard. D string
P [A-Z]{2}
M [2:2]
Remarks

Source
<xs:element name="ISO_COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

GLN_NO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element : GLN_NO Element
Description
This element is used to enter a unique global location number (GLN). The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data.
If a company has multiple GLN values, the root GLN must be specified. 		D string
P [0-9]{13}
M
Namespace (none)
Type
Restriction of xs:string
Diagram
GLN_NO Element
Overview
GLN_NO Restriction of xs:string
This element is used to enter a unique global location number (GLN). The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data.
If a company has multiple GLN values, the root GLN must be specified. 		D string
P [0-9]{13}
M
Remarks

Source
<xs:element name="GLN_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--45--GLN_Nr
30.05.2012/Bur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9]{13}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

WEEE_NO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element : WEEE_NO Element
Description
This element is used to enter the WEEE registration number. A WEEE registration number is mandatory for everyone classified as a manufacturer or importer of electrical appliances in accordance with the "Electrical and Electronic Equipment Act (ElektroG)".
In Germany, WEEE numbers look as follows: "DE12345678".
Dealers can verify the validity of WEEE numbers on the website of the register for Waste Electrical Appliances (http://www.stiftung-ear.de). 		D string
P
M
Namespace (none)
Type
Restriction of xs:string
Diagram
WEEE_NO Element
Overview
WEEE_NO optional Restriction of xs:string
This element is used to enter the WEEE registration number. A WEEE registration number is mandatory for everyone classified as a manufacturer or importer of electrical appliances in accordance with the "Electrical and Electronic Equipment Act (ElektroG)".
In Germany, WEEE numbers look as follows: "DE12345678".
Dealers can verify the validity of WEEE numbers on the website of the register for Waste Electrical Appliances (http://www.stiftung-ear.de). 		D string
P
M
Remarks

Source
<xs:element name="WEEE_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--47--WEEE_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CONTACT_PERSON Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element : CONTACT_PERSON Element
Description
This element is used to specify the information of a contact person
Namespace (none)
Diagram
ISO_COUNTRY_ID Element CITY Element ZIPCODE_STREET Element STREET Element EMAIL Element FAX Element TELEPHONE Element DEPARTMENT Element FORM_OF_ADDRESS Element FIRST_NAME Element CONTACT_NAME Element CONTACT_ROLE Element CONTACT_PERSON_NO Element Sequence CONTACT_PERSON Element
Overview
CONTACT_PERSON 1..2
This element is used to specify the information of a contact person
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
This element is used to specify the priorities of methods for making contact with the contact person. (1=1st Contact, 2=2nd contact) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
This element is used to specify the role of the newly created contact. The role designation certified by the manufacturer (e.g. substitute, person responsible for EDI). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
This element is used to specify the last name of the direct contact person for the software house. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
This element is used to specify the first name of the direct contact person. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
This element is used to specify the salutation for the direct contact person.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
This element is, if present, used to specify the department of the direct contact person. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
This element is used to specify the telephone number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
This element is used to specify the fax number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
This element is used to specify the email address. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
STREET optional Restriction of xs:string
This element as you specify the street of the manufacturer's business address. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
This element is used to specify the postcode of the manufacturer's business address. D string
P
M [1:8]
CITY optional Restriction of xs:string
This element is used to specify the manufacturer's place registered office. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
This element is used to specify the manufacturer's country in accordance with the ISO standard is to be specified. D string
P [A-Z]{2}
M [2:2]
Remarks

Source
<xs:element name="CONTACT_PERSON" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CONTACT_PERSON_NO">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_ROLE">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="60" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_NAME">
        <xs:annotation>
          <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FIRST_NAME">
        <xs:annotation>
          <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FORM_OF_ADDRESS">
        <xs:annotation>
          <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DEPARTMENT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE">
        <xs:annotation>
          <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CONTACT_PERSON_NO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_PERSON_NO Element
Description
This element is used to specify the priorities of methods for making contact with the contact person. (1=1st Contact, 2=2nd contact) D positiveInteger
P
M [1:2]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
CONTACT_PERSON_NO Element
Overview
CONTACT_PERSON_NO Restriction of xs:positiveInteger
This element is used to specify the priorities of methods for making contact with the contact person. (1=1st Contact, 2=2nd contact) D positiveInteger
P
M [1:2]
Remarks

Source
<xs:element name="CONTACT_PERSON_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CONTACT_ROLE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_ROLE Element
Description
This element is used to specify the role of the newly created contact. The role designation certified by the manufacturer (e.g. substitute, person responsible for EDI). D string
P
M [1:60]
Namespace (none)
Type
Restriction of xs:string
Diagram
CONTACT_ROLE Element
Overview
CONTACT_ROLE Restriction of xs:string
This element is used to specify the role of the newly created contact. The role designation certified by the manufacturer (e.g. substitute, person responsible for EDI). D string
P
M [1:60]
Remarks

Source
<xs:element name="CONTACT_ROLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="60" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CONTACT_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_NAME Element
Description
This element is used to specify the last name of the direct contact person for the software house. D string
P
M [1:20]
Namespace (none)
Type
Restriction of xs:string
Diagram
CONTACT_NAME Element
Overview
CONTACT_NAME Restriction of xs:string
This element is used to specify the last name of the direct contact person for the software house. D string
P
M [1:20]
Remarks

Source
<xs:element name="CONTACT_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FIRST_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : FIRST_NAME Element
Description
This element is used to specify the first name of the direct contact person. D string
P
M [1:20]
Namespace (none)
Type
Restriction of xs:string
Diagram
FIRST_NAME Element
Overview
FIRST_NAME Restriction of xs:string
This element is used to specify the first name of the direct contact person. D string
P
M [1:20]
Source
<xs:element name="FIRST_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORM_OF_ADDRESS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : FORM_OF_ADDRESS Element
Description
This element is used to specify the salutation for the direct contact person.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
FORM_OF_ADDRESS Element
Overview
FORM_OF_ADDRESS Restriction of xs:positiveInteger
This element is used to specify the salutation for the direct contact person.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
Remarks

Source
<xs:element name="FORM_OF_ADDRESS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DEPARTMENT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : DEPARTMENT Element
Description
This element is, if present, used to specify the department of the direct contact person. D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
DEPARTMENT Element
Overview
DEPARTMENT optional Restriction of xs:string
This element is, if present, used to specify the department of the direct contact person. D string
P
M [1:15]
Remarks

Source
<xs:element name="DEPARTMENT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TELEPHONE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : TELEPHONE Element
Description
This element is used to specify the telephone number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
Namespace (none)
Type
Restriction of xs:string
Diagram
TELEPHONE Element
Overview
TELEPHONE Restriction of xs:string
This element is used to specify the telephone number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
Remarks

Source
<xs:element name="TELEPHONE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FAX Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : FAX Element
Description
This element is used to specify the fax number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(5251)60-3284. D string
P
M [1:18]
Namespace (none)
Type
Restriction of xs:string
Diagram
FAX Element
Overview
FAX optional Restriction of xs:string
This element is used to specify the fax number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(5251)60-3284. D string
P
M [1:18]
Remarks

Source
<xs:element name="FAX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EMAIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : EMAIL Element
Description
This element is used to specify the email address. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
Namespace (none)
Type
Restriction of xs:string
Diagram
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
This element is used to specify the email address. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
Remarks

Source
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

STREET Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : STREET Element
Description
This element as you specify the street of the manufacturer's business address. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
STREET Element
Overview
STREET optional Restriction of xs:string
This element as you specify the street of the manufacturer's business address. D string
P
M [1:30]
Remarks

Source
<xs:element name="STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ZIPCODE_STREET Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : ZIPCODE_STREET Element
Description
This element is used to specify the postcode of the manufacturer's business address. D string
P
M [1:8]
Namespace (none)
Type
Restriction of xs:string
Diagram
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET optional Restriction of xs:string
This element is used to specify the postcode of the manufacturer's business address. D string
P
M [1:8]
Remarks

Source
<xs:element name="ZIPCODE_STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CITY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CITY Element
Description
This element is used to specify the manufacturer's place registered office. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
CITY Element
Overview
CITY optional Restriction of xs:string
This element is used to specify the manufacturer's place registered office. D string
P
M [1:30]
Remarks

Source
<xs:element name="CITY" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ISO_COUNTRY_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : ISO_COUNTRY_ID Element
Description
This element is used to specify the manufacturer's country in accordance with the ISO standard is to be specified. D string
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:string
Diagram
ISO_COUNTRY_ID Element
Overview
ISO_COUNTRY_ID Restriction of xs:string
This element is used to specify the manufacturer's country in accordance with the ISO standard is to be specified. D string
P [A-Z]{2}
M [2:2]
Source
<xs:element name="ISO_COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CONTACT_SUPPLIER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element : CONTACT_SUPPLIER Element
Description
This element is used to specify the manufacturer's contact data
Namespace (none)
Diagram
FAX_SWITCHBOARD Element TELEPHONE_SWITCHBOARD Element POSTBOX Element ZIPCODE_POSTBOX Element ISO_COUNTRY_ID Element CITY Element ZIPCODE_STREET Element STREET Element INTERNET_ADDRESS Element EMAIL Element MANUFACTURER_NAME_2 Element MANUFACTURER_NAME_1 Element Sequence CONTACT_SUPPLIER Element
Overview
CONTACT_SUPPLIER
This element is used to specify the manufacturer's contact data
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
This element is used to specify the first line of the company name. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
If activated, this element is used to store the second line of the company name. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
This element is used to specify the official email address for the dealership or consumer. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
INTERNET_ADDRESS optional Restriction of xs:string
This element, if present, is used to specify the official URL (e.g. http://www.company.com) for dealerships or consumers. D string
P
M
STREET Restriction of xs:string
This element as you specify the street of the manufacturer's business address. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
This element is used to specify the postcode of the manufacturer's business address. D string
P
M [1:8]
CITY Restriction of xs:string
This element is used to specify the manufacturer's place registered office. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
This element is used to specify the manufacturer's country in accordance with the ISO standard is to be specified. D string
P [A-Z]{2}
M [2:2]
ZIPCODE_POSTBOX optional Restriction of xs:string
This element is, if present, used to specify the postcode associated with the PO Box. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
This element is, if present, used to specify the PO Box line of the manufacturer's address. The word "PO Box" must be omitted. D string
P [0-9a-zA-Z]{0,10}
M [00:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
This element is used to specify the telephone number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
This element is here to specify the fax number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
Remarks

Source
<xs:element name="CONTACT_SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_NAME_1">
        <xs:annotation>
          <xs:documentation>100--16--Herstellername_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--17--Herstellername_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INTERNET_ADDRESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--19--Internet_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET">
        <xs:annotation>
          <xs:documentation>100--20--Strasse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET">
        <xs:annotation>
          <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY">
        <xs:annotation>
          <xs:documentation>100--22--Ort</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--24--Postfach</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9a-zA-Z]{0,10}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MANUFACTURER_NAME_1 Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_1 Element
Description
This element is used to specify the first line of the company name. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
MANUFACTURER_NAME_1 Element
Overview
MANUFACTURER_NAME_1 Restriction of xs:string
This element is used to specify the first line of the company name. D string
P
M [1:30]
Remarks

Source
<xs:element name="MANUFACTURER_NAME_1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--16--Herstellername_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MANUFACTURER_NAME_2 Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_2 Element
Description
If activated, this element is used to store the second line of the company name. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
MANUFACTURER_NAME_2 Element
Overview
MANUFACTURER_NAME_2 optional Restriction of xs:string
If activated, this element is used to store the second line of the company name. D string
P
M [1:30]
Remarks

Source
<xs:element name="MANUFACTURER_NAME_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--17--Herstellername_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EMAIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : EMAIL Element
Description
This element is used to specify the official email address for the dealership or consumer. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
Namespace (none)
Type
Restriction of xs:string
Diagram
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
This element is used to specify the official email address for the dealership or consumer. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
Remarks

Source
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

INTERNET_ADDRESS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : INTERNET_ADDRESS Element
Description
This element, if present, is used to specify the official URL (e.g. http://www.company.com) for dealerships or consumers. D string
P
M
Namespace (none)
Type
Restriction of xs:string
Diagram
INTERNET_ADDRESS Element
Overview
INTERNET_ADDRESS optional Restriction of xs:string
This element, if present, is used to specify the official URL (e.g. http://www.company.com) for dealerships or consumers. D string
P
M
Remarks

Source
<xs:element name="INTERNET_ADDRESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--19--Internet_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

STREET Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : STREET Element
Description
This element as you specify the street of the manufacturer's business address. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
STREET Element
Overview
STREET Restriction of xs:string
This element as you specify the street of the manufacturer's business address. D string
P
M [1:30]
Remarks

Source
<xs:element name="STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--20--Strasse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ZIPCODE_STREET Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_STREET Element
Description
This element is used to specify the postcode of the manufacturer's business address. D string
P
M [1:8]
Namespace (none)
Type
Restriction of xs:string
Diagram
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET Restriction of xs:string
This element is used to specify the postcode of the manufacturer's business address. D string
P
M [1:8]
Remarks

Source
<xs:element name="ZIPCODE_STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CITY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : CITY Element
Description
This element is used to specify the manufacturer's place registered office. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
CITY Element
Overview
CITY Restriction of xs:string
This element is used to specify the manufacturer's place registered office. D string
P
M [1:30]
Remarks

Source
<xs:element name="CITY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--22--Ort</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ISO_COUNTRY_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ISO_COUNTRY_ID Element
Description
This element is used to specify the manufacturer's country in accordance with the ISO standard is to be specified. D string
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:string
Diagram
ISO_COUNTRY_ID Element
Overview
ISO_COUNTRY_ID Restriction of xs:string
This element is used to specify the manufacturer's country in accordance with the ISO standard is to be specified. D string
P [A-Z]{2}
M [2:2]
Source
<xs:element name="ISO_COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ZIPCODE_POSTBOX Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_POSTBOX Element
Description
This element is, if present, used to specify the postcode associated with the PO Box. D string
P
M [1:8]
Namespace (none)
Type
Restriction of xs:string
Diagram
ZIPCODE_POSTBOX Element
Overview
ZIPCODE_POSTBOX optional Restriction of xs:string
This element is, if present, used to specify the postcode associated with the PO Box. D string
P
M [1:8]
Remarks

Source
<xs:element name="ZIPCODE_POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

POSTBOX Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : POSTBOX Element
Description
This element is, if present, used to specify the PO Box line of the manufacturer's address. The word "PO Box" must be omitted. D string
P [0-9a-zA-Z]{0,10}
M [00:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
POSTBOX Element
Overview
POSTBOX optional Restriction of xs:string
This element is, if present, used to specify the PO Box line of the manufacturer's address. The word "PO Box" must be omitted. D string
P [0-9a-zA-Z]{0,10}
M [00:10]
Remarks

Source
<xs:element name="POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--24--Postfach</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9a-zA-Z]{0,10}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TELEPHONE_SWITCHBOARD Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : TELEPHONE_SWITCHBOARD Element
Description
This element is used to specify the telephone number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
Namespace (none)
Type
Restriction of xs:string
Diagram
TELEPHONE_SWITCHBOARD Element
Overview
TELEPHONE_SWITCHBOARD Restriction of xs:string
This element is used to specify the telephone number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
Remarks

Source
<xs:element name="TELEPHONE_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FAX_SWITCHBOARD Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : FAX_SWITCHBOARD Element
Description
This element is here to specify the fax number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
Namespace (none)
Type
Restriction of xs:string
Diagram
FAX_SWITCHBOARD Element
Overview
FAX_SWITCHBOARD Restriction of xs:string
This element is here to specify the fax number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890. D string
P
M [1:18]
Remarks

Source
<xs:element name="FAX_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

GLOBAL_DEFINITION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : GLOBAL_DEFINITION Element
Description
This element is used to specify data that is valid for the entire catalogue/data pool (global information).
Namespace (none)
Diagram
PROPERTIES Element MESSAGES Element DETAIL_INFOS Element Sequence GLOBAL_DEFINITION Element
Overview
GLOBAL_DEFINITION optional
This element is used to specify data that is valid for the entire catalogue/data pool (global information).
Sequence
DETAIL_INFOS optional
This element is used to specify detailed information.
Sequence
DETAIL_INFO 1..∞
This element is used to specify URLs to detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute identifies a detailed information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
This element is used to classify detailed information.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
This element is here to describe the type of detailed information.

The values that can be assigned to the information types can be found in the corresponding table in the introduction. 		D positiveInteger
P
M [1:15]
EXTERNAL_NAME optional languagetext Complex Type
This element contains the display name of the link (e.g. "sketch 4711").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
INTERNAL_NAME optional languagetext40 Complex Type
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

This element contains the text for a link note.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
URL
This element specifies the URL to the detailed information.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

This element is used to place add-on items, e.g. headrests.

This element is only allowed for SVG files.

Within the outline type of a SVG, the following applies:

There is no overlapping of any areas designated by our clients within the same layer.

The following values apply to the element:

10 Carpet

20 Sofa/furniture/table (default value)

30 Cushion

40 Decorative cushion

50 Headrest

60 Plate/ throw

 D positiveInteger
P [1-6]0
M [10:60]
MESSAGES optional

The possible warnings and information are stored under this element.

The possible warnings and information notices with the corresponding text, the level and the unique identifier are stored under this element.

Sequence
MESSAGE 1..99999
This element is used to store a message.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify the message. D nonNegativeInteger
P
M [0:99999]
LEVEL optional Restriction of xs:nonNegativeInteger

The message level is specified here:
0 Notice/information
1 Warning

 D nonNegativeInteger
P
M [0:1]
Sequence
MESSAGE_TEXT languagetext Complex Type
This element is used to store the message text.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PROPERTIES optional

This element is used to include additional information and characteristics, e.g. energy label, efficiency classes and similar data. Only the characteristics needed for correctly mapping the catalogue are defined.

The keys can be found in the corresponding table (information keys).

Sequence
PROPERTY 1..∞

This element is used to define a feature.

The key, text and measurement unit can be found in the corresponding table (information keys).

PROPERTY_NO required Restriction of xs:nonNegativeInteger

This attribute is used to identify the feature.

Its number can be found in the table with the information keys.

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetext Complex Type
This element contains texts for characteristic features/properties.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PROPERTY_UNIT optional languagetext30 Complex Type
This element is used to specify the unit of measure for the respective characteristic features like property.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Remarks

Source
<xs:element name="GLOBAL_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLASSIFICATION">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INFO_TYPE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Front(Fronttextur, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Materialpass (PDF an den Fronten)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Artikelpictogramm Ansicht
12.02.2013/Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="URL">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT" type="xs:anyURI">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="HASH_VALUE">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="32" />
                                    <xs:maxLength value="32" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="LAYER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-6]0" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MESSAGES" minOccurs="0" maxOccurs="1">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MESSAGE" maxOccurs="99999">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MESSAGE_TEXT" type="languagetext" />
                </xs:sequence>
                <xs:attribute name="MESSAGE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="LEVEL">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PROPERTIES" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>120--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PROPERTY" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>120--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PROPERTY_TEXT" type="languagetext" minOccurs="1" maxOccurs="1" />
                  <xs:element name="PROPERTY_UNIT" type="languagetext30" minOccurs="0" maxOccurs="1" />
                </xs:sequence>
                <xs:attribute name="PROPERTY_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFOS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : DETAIL_INFOS Element
Description
This element is used to specify detailed information.
Namespace (none)
Diagram
DETAIL_INFO Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
This element is used to specify detailed information.
Sequence
DETAIL_INFO 1..∞
This element is used to specify URLs to detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute identifies a detailed information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
This element is used to classify detailed information.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
This element is here to describe the type of detailed information.

The values that can be assigned to the information types can be found in the corresponding table in the introduction. 		D positiveInteger
P
M [1:15]
EXTERNAL_NAME optional languagetext Complex Type
This element contains the display name of the link (e.g. "sketch 4711").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
INTERNAL_NAME optional languagetext40 Complex Type
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

This element contains the text for a link note.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
URL
This element specifies the URL to the detailed information.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

This element is used to place add-on items, e.g. headrests.

This element is only allowed for SVG files.

Within the outline type of a SVG, the following applies:

There is no overlapping of any areas designated by our clients within the same layer.

The following values apply to the element:

10 Carpet

20 Sofa/furniture/table (default value)

30 Cushion

40 Decorative cushion

50 Headrest

60 Plate/ throw

 D positiveInteger
P [1-6]0
M [10:60]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLASSIFICATION">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="INFO_TYPE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Front(Fronttextur, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Materialpass (PDF an den Fronten)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Artikelpictogramm Ansicht
12.02.2013/Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="URL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT" type="xs:anyURI">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="HASH_VALUE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="32" />
                              <xs:maxLength value="32" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="LAYER" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-6]0" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element : DETAIL_INFO Element
Description
This element is used to specify URLs to detailed information.
Namespace (none)
Diagram
LAYER Element URL Element LANGUAGE Element Sequence TOOL_TIP Element LANGUAGE Element Sequence INTERNAL_NAME Element LANGUAGE Element Sequence EXTERNAL_NAME Element INFO_TYPE Element CLASSIFICATION Element Sequence DETAIL_INFO Element
Overview
DETAIL_INFO 1..∞
This element is used to specify URLs to detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute identifies a detailed information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
This element is used to classify detailed information.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
This element is here to describe the type of detailed information.

The values that can be assigned to the information types can be found in the corresponding table in the introduction. 		D positiveInteger
P
M [1:15]
EXTERNAL_NAME optional languagetext Complex Type
This element contains the display name of the link (e.g. "sketch 4711").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
INTERNAL_NAME optional languagetext40 Complex Type
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

This element contains the text for a link note.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
URL
This element specifies the URL to the detailed information.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

This element is used to place add-on items, e.g. headrests.

This element is only allowed for SVG files.

Within the outline type of a SVG, the following applies:

There is no overlapping of any areas designated by our clients within the same layer.

The following values apply to the element:

10 Carpet

20 Sofa/furniture/table (default value)

30 Cushion

40 Decorative cushion

50 Headrest

60 Plate/ throw

 D positiveInteger
P [1-6]0
M [10:60]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute identifies a detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLASSIFICATION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="INFO_TYPE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Front(Fronttextur, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Materialpass (PDF an den Fronten)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Artikelpictogramm Ansicht
12.02.2013/Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="URL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT" type="xs:anyURI">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="HASH_VALUE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="32" />
                        <xs:maxLength value="32" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="LAYER" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-6]0" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CLASSIFICATION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : CLASSIFICATION Element
Description
This element is used to classify detailed information.

 D string
P
M
Namespace (none)
Type
Restriction of xs:string
Diagram
CLASSIFICATION Element
Overview
CLASSIFICATION Restriction of xs:string
This element is used to classify detailed information.

 D string
P
M
Source
<xs:element name="CLASSIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

INFO_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INFO_TYPE Element
Description
This element is here to describe the type of detailed information.

The values that can be assigned to the information types can be found in the corresponding table in the introduction. 		D positiveInteger
P
M [1:15]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
INFO_TYPE Element
Overview
INFO_TYPE Restriction of xs:positiveInteger
This element is here to describe the type of detailed information.

The values that can be assigned to the information types can be found in the corresponding table in the introduction. 		D positiveInteger
P
M [1:15]
Source
<xs:element name="INFO_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Front(Fronttextur, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Materialpass (PDF an den Fronten)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Artikelpictogramm Ansicht
12.02.2013/Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EXTERNAL_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : EXTERNAL_NAME Element
Description
This element contains the display name of the link (e.g. "sketch 4711").
Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence EXTERNAL_NAME Element
Overview
EXTERNAL_NAME optional languagetext Complex Type
This element contains the display name of the link (e.g. "sketch 4711").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

INTERNAL_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INTERNAL_NAME Element
Description
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.
Namespace (none)
Type
languagetext40 Complex Type
Diagram
LANGUAGE Element Sequence INTERNAL_NAME Element
Overview
INTERNAL_NAME optional languagetext40 Complex Type
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
Source
<xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TOOL_TIP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : TOOL_TIP Element
Description

This element contains the text for a link note.

Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence TOOL_TIP Element
Overview
TOOL_TIP optional languagetext Complex Type

This element contains the text for a link note.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="TOOL_TIP" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

URL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : URL Element
Description
This element specifies the URL to the detailed information.
Namespace (none)
Diagram
LANGUAGE Element Sequence URL Element
Overview
URL
This element specifies the URL to the detailed information.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
Source
<xs:element name="URL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT" type="xs:anyURI">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="HASH_VALUE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="32" />
                  <xs:maxLength value="32" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element : LANGUAGE Element
Description
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
Namespace (none)
Diagram
HASH_VALUE Element TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:anyURI">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="HASH_VALUE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="32" />
            <xs:maxLength value="32" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : TEXT Element
Description
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
Namespace (none)
Type
xs:anyURI
Diagram
TEXT Element
Overview
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
Source
<xs:element name="TEXT" type="xs:anyURI" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

HASH_VALUE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : HASH_VALUE Element
Description
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
Namespace (none)
Type
Restriction of xs:string
Diagram
HASH_VALUE Element
Overview
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
Source
<xs:element name="HASH_VALUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="32" />
      <xs:maxLength value="32" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LAYER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : LAYER Element
Description

This element is used to place add-on items, e.g. headrests.

This element is only allowed for SVG files.

Within the outline type of a SVG, the following applies:

There is no overlapping of any areas designated by our clients within the same layer.

The following values apply to the element:

10 Carpet

20 Sofa/furniture/table (default value)

30 Cushion

40 Decorative cushion

50 Headrest

60 Plate/ throw

 D positiveInteger
P [1-6]0
M [10:60]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
LAYER Element
Overview
LAYER optional Restriction of xs:positiveInteger

This element is used to place add-on items, e.g. headrests.

This element is only allowed for SVG files.

Within the outline type of a SVG, the following applies:

There is no overlapping of any areas designated by our clients within the same layer.

The following values apply to the element:

10 Carpet

20 Sofa/furniture/table (default value)

30 Cushion

40 Decorative cushion

50 Headrest

60 Plate/ throw

 D positiveInteger
P [1-6]0
M [10:60]
Source
<xs:element name="LAYER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-6]0" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MESSAGES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : MESSAGES Element
Description

The possible warnings and information are stored under this element.

The possible warnings and information notices with the corresponding text, the level and the unique identifier are stored under this element.

Namespace (none)
Diagram
MESSAGE Element Sequence MESSAGES Element
Overview
MESSAGES optional

The possible warnings and information are stored under this element.

The possible warnings and information notices with the corresponding text, the level and the unique identifier are stored under this element.

Sequence
MESSAGE 1..99999
This element is used to store a message.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify the message. D nonNegativeInteger
P
M [0:99999]
LEVEL optional Restriction of xs:nonNegativeInteger

The message level is specified here:
0 Notice/information
1 Warning

 D nonNegativeInteger
P
M [0:1]
Sequence
MESSAGE_TEXT languagetext Complex Type
This element is used to store the message text.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="MESSAGES" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MESSAGE" maxOccurs="99999">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MESSAGE_TEXT" type="languagetext" />
          </xs:sequence>
          <xs:attribute name="MESSAGE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="LEVEL">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MESSAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > MESSAGES Element : MESSAGE Element
Description
This element is used to store a message.
Namespace (none)
Diagram
LANGUAGE Element Sequence MESSAGE_TEXT Element Sequence MESSAGE Element
Overview
MESSAGE 1..99999
This element is used to store a message.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify the message. D nonNegativeInteger
P
M [0:99999]
LEVEL optional Restriction of xs:nonNegativeInteger

The message level is specified here:
0 Notice/information
1 Warning

 D nonNegativeInteger
P
M [0:1]
Sequence
MESSAGE_TEXT languagetext Complex Type
This element is used to store the message text.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
MESSAGE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to identify the message. D nonNegativeInteger
P
M [0:99999]
LEVEL Restriction of xs:nonNegativeInteger optional

The message level is specified here:
0 Notice/information
1 Warning

 D nonNegativeInteger
P
M [0:1]
Source
<xs:element name="MESSAGE" maxOccurs="99999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MESSAGE_TEXT" type="languagetext" />
    </xs:sequence>
    <xs:attribute name="MESSAGE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="LEVEL">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
MESSAGES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MESSAGE_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > MESSAGES Element > MESSAGE Element : MESSAGE_TEXT Element
Description
This element is used to store the message text.
Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence MESSAGE_TEXT Element
Overview
MESSAGE_TEXT languagetext Complex Type
This element is used to store the message text.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="MESSAGE_TEXT" type="languagetext" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
MESSAGE Element | MESSAGES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PROPERTIES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : PROPERTIES Element
Description

This element is used to include additional information and characteristics, e.g. energy label, efficiency classes and similar data. Only the characteristics needed for correctly mapping the catalogue are defined.

The keys can be found in the corresponding table (information keys).

Namespace (none)
Diagram
PROPERTY Element Sequence PROPERTIES Element
Overview
PROPERTIES optional

This element is used to include additional information and characteristics, e.g. energy label, efficiency classes and similar data. Only the characteristics needed for correctly mapping the catalogue are defined.

The keys can be found in the corresponding table (information keys).

Sequence
PROPERTY 1..∞

This element is used to define a feature.

The key, text and measurement unit can be found in the corresponding table (information keys).

PROPERTY_NO required Restriction of xs:nonNegativeInteger

This attribute is used to identify the feature.

Its number can be found in the table with the information keys.

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetext Complex Type
This element contains texts for characteristic features/properties.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PROPERTY_UNIT optional languagetext30 Complex Type
This element is used to specify the unit of measure for the respective characteristic features like property.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="PROPERTIES" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROPERTY" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>120--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PROPERTY_TEXT" type="languagetext" minOccurs="1" maxOccurs="1" />
            <xs:element name="PROPERTY_UNIT" type="languagetext30" minOccurs="0" maxOccurs="1" />
          </xs:sequence>
          <xs:attribute name="PROPERTY_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PROPERTY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > PROPERTIES Element : PROPERTY Element
Description

This element is used to define a feature.

The key, text and measurement unit can be found in the corresponding table (information keys).

Namespace (none)
Diagram
LANGUAGE Element Sequence PROPERTY_UNIT Element LANGUAGE Element Sequence PROPERTY_TEXT Element Sequence PROPERTY Element
Overview
PROPERTY 1..∞

This element is used to define a feature.

The key, text and measurement unit can be found in the corresponding table (information keys).

PROPERTY_NO required Restriction of xs:nonNegativeInteger

This attribute is used to identify the feature.

Its number can be found in the table with the information keys.

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetext Complex Type
This element contains texts for characteristic features/properties.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PROPERTY_UNIT optional languagetext30 Complex Type
This element is used to specify the unit of measure for the respective characteristic features like property.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Attributes
Name Type Use Default Fixed Description
PROPERTY_NO Restriction of xs:nonNegativeInteger required

This attribute is used to identify the feature.

Its number can be found in the table with the information keys.

 D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="PROPERTY" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROPERTY_TEXT" type="languagetext" minOccurs="1" maxOccurs="1" />
      <xs:element name="PROPERTY_UNIT" type="languagetext30" minOccurs="0" maxOccurs="1" />
    </xs:sequence>
    <xs:attribute name="PROPERTY_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PROPERTIES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PROPERTY_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > PROPERTIES Element > PROPERTY Element : PROPERTY_TEXT Element
Description
This element contains texts for characteristic features/properties.
Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence PROPERTY_TEXT Element
Overview
PROPERTY_TEXT languagetext Complex Type
This element contains texts for characteristic features/properties.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="PROPERTY_TEXT" type="languagetext" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PROPERTY Element | PROPERTIES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PROPERTY_UNIT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > PROPERTIES Element > PROPERTY Element : PROPERTY_UNIT Element
Description
This element is used to specify the unit of measure for the respective characteristic features like property.
Namespace (none)
Type
languagetext30 Complex Type
Diagram
LANGUAGE Element Sequence PROPERTY_UNIT Element
Overview
PROPERTY_UNIT optional languagetext30 Complex Type
This element is used to specify the unit of measure for the respective characteristic features like property.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="PROPERTY_UNIT" type="languagetext30" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PROPERTY Element | PROPERTIES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : SERIES Element
Description

This element is used to specify all series of the catalogue/data with the properties and elements assigned to them, e.g. product groups or items.

A series usually corresponds to a model.

Namespace (none)
Diagram
SERIE_GROUPS Element DECISIONS Element SERIE Element Sequence SERIES Element
Overview
SERIES

This element is used to specify all series of the catalogue/data with the properties and elements assigned to them, e.g. product groups or items.

A series usually corresponds to a model.

Sequence
SERIE 1..1000000
This element is used to define the series. A series usually corresponds to a model.
An item from series 0 is valid in all other series, which means that items of series 0 must not exist with the same type designation (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in any other series. Items of other series (other than 0) may however exist in multiple series with identical type designation.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the series. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO required xs:positiveInteger
This attribute allows for the specification of series with a freely-defined sorting order.
If a SEQUENCE_NO is specified for one series, a SEQUENCE_NO must be specified for all series. 		D positiveInteger
P
M
Sequence
SERIES_NAME
This element is used to specify the series name.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Za-z]{1,3}
M [1:3]
Sequence
TEXT_LINE
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Sequence
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
PURCHASE_RETAIL_ID Restriction of xs:nonNegativeInteger

This element assigns an identifier for series-specific purchasing/sales prices:

EK_VK_ID
0 = purchasing price including VAT (or list price)
1 = sales price including VAT ( recommended sales price)
2 = purchasing price excluding VAT
3 = purchasing price excl. VAT/VAT

The price is defined as a function of the price-ID (Element PRICE_ID (path 1)) as follows:

Price ID = 1 (price), the value from the ITEM_PRICE (path 2) element will be used.

Price ID = 2 (ID number), the price from the IDENT_NUMBER/PRICE (path 3)element, the ITEM_PRICE/PRICE_MINIMUM_BASIC (path 2) element or the ADDITIONAL_PRICE (element 5) is used.

Price ID = 3 (offsetting point), the value from the ITEM_PRICE (path 2) element or the PRICE_MINIMUM_BASIC Element multiplied by the settlement factor from the PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR is used.

Due to the key, only one price (combination of the elements VAT (path 4) and PURCHASE_RETAIL_ID ) can be specified within the same series.
If a file contains both purchasing and retail prices, models with purchasing prices must not be assigned the same calculation groups (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) as models with retail prices.
This element is very important for pricing. If the purchasing prices are used, this must be the dealership's purchasing price, not the manufacturer purchasing price.

Element paths
Path 1: CATALOG/CATALOG_IDENTIFICATION/
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/
Path 3: PRICE_DEFINITION/IDENT_NUMBERS
Path 4: CATALOG/CATALOG_IDENTIFICATION/
Path 5 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

 D nonNegativeInteger
P
M [0:3]
DECISIONS optional
This element is used to collect series specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a series.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D nonNegativeInteger
P
M [1:9999999999]
PRODUCT_GROUPS
This element is used to define product groups. Articles with identical features are grouped together in product groups.
Sequence
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups. "Identical" product groups must therefore not be captured.
Sequence
PRODUCT_GROUP_TEXT languagetext60 Complex Type
This element contains the designation of a product group.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
This element is used to assign a feature class to the product group. A feature class referenced in the FEATURE_DEFINITION/FEATURE_CLASSES element is defined here.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute is used to identify the referenced feature class (FEATURE_CLASS). D positiveInteger
P
M [1:9999999999]
ITEMS
This element is used to define all items of a product group.
Sequence
ITEM 1..∞
This element is used to define items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes.

The characteristic features/properties, or a reference via ITEM_REF to another series (SERIE_NO) and the item number of valid for the other series, are stored for each item. If the ITEM_REF element contains a value, the item is a reference item belonging to another series, otherwise the item belongs to the series in which it is specified at this position.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
TYPE_NO required Restriction of xs:string
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Sequence
Choice
Sequence
ITEM_REF
This element is used to reference an item.
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element is used to reference a base price group. A base Price group is a PRICE_FEATURE_GROUP (path 1) where the ADDITIONAL_PRICE element has a value of 0.

An item must be assigned to precisely one base price group. Additional price groups are assigned via the ADDITIONAL_PRICE_GROUP element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
ADDITIONAL_PRICE_GROUP 0..∞
This element is used to reference PRICE_FEATURE_GROUPS with additional price groups. The base price group that must be referenced precisely 1x by an item is specified in the PRICE_FEATURE_GROUP_BASE_PRICE_REF element.

All items that reference the identical PRICE_FEATURE_GROUP must also reference the same calculation group (CALC_GROUP_REF) and exchange ID (EXCHANGE_ID_REF).

The following combinations are permitted when assigning different price types to items and surcharges for the same item:

Item | Surcharge
Unit price | Unit price
length-dependent | length-dependent
length-dependent | Unit price

The following combination is not permitted:

Item | Surcharge
Unit price | length-dependent
DECISIONS optional
This element is used to combine product item-specific rules.
ADDITIONAL_ITEMS optional
This element is used to assign additional items. It defines quantities of optional and/or necessary additional items, from which the additional items will be selected during planning.
EDP_NUMBER optional Restriction of xs:string
This element is used to enter the (internal) item EDP number of the manufacturer.
If the EDP_NUMBER is used, it must be unique within a series and created for all items. 		D string
P
M [1:30]
EAN_NUMBER optional Restriction of xs:string
If existing, the EAN number of the item must be entered in this element. D string
P
M [1:15]
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article:
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
V = Settlement block
P = Settlement position
1 = Planning proposal
2 = Preferred combination

The following applies for the planning proposal (1):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations:
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

D string
P [BEKSMZVP12]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
This element should be used to specify the item's catalogue page. This information helps to quickly find an item within the printed catalogue.
Items may feature on multiple catalogue pages. In this case, the number of the page on which the item appears first should be used. In the case of accessories, it makes sense to use the page that contains a full description of the item. This is often done in the section/register "accessories". 		D string
P
M [1:7]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item gross weight (100 g), i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item net weight (100 g), i.e. including packaging material, i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
This element is used to specify the item volume [dm³] including packaging material. (e.g. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element is used to specify the minimum delivery time in weeks.
The minimum delivery time is for information, the planning software does not interfere with the order controlling (e.g. postponement of the order, partial delivery) 		D nonNegativeInteger
P
M [0:999]
BASIC_PROFILE optional
This element is used to specify the basic shapes assigned to an item.
ITEM_TEXT
This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. At least one item text must be specified for each item.

The following text combinations are permitted:
- Short text;
- Short text + recommended text;
- Short text + recommended text + long text;
- Short text + long text (only if no recommended text is been stored).

The short text may consist of three lines.
TYPE_KEY
This element is used to define the item's model code.

The values for model codes can be found in a table in the introduction, section Model code

The model code is specified precisely once for each item.
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
SALES_NUMBER optional Restriction of xs:string
If existing, the sale number of the item must be entered in this element. D string
P
M [1:30]
PART_LIST_REF optional

This element references a piece list contained in an item.

The item passes on its options (OPTIONS) to the sub positions if these have identical features (FEATURES) in the feature class associated with the respective sub-position.

The sub-positions can have rules that determine whether a sub-position is displayed. The sub-position is then specified with the corresponding piece quantity.

Items that are only permitted as sub-positions are marked separately (element PARTS_LIST_EXCLUSIVE).

If the item is a catalogue item (ITEM_IDENTIFICATION 'K'), prices may be assigned to the item.The total price of the catalogue item results from the price assigned to it and the prices of the components from the piece list.

The following applies for the planning proposal (ITEM_IDENTIFICATION '1'):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations (ITEM_IDENTIFICATION '2'):
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
This element is used to identify whether the item is only permitted as a sub position within a piece list (value set to 1 (true)).
The value 0 (false) has the same meaning as no value at all. 		D boolean
P
M
PROPERTIES optional
This element is used to combine item-specific characteristic features/properties.
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

D string P [0-9]{11} M [11:11]

Information can be found at the following link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

PACKAGE_LIST optional

This element is used to specify the packaged pieces per item. An optimisation of packaged items for purchases is not possible.

The width, depth and height must be specified for each packaged item in full mm figures. The weight is specified in decimal kg.

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

DECISIONS optional
This element is used to combine product group-specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a product group.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
COLOR_CONSULTANCIES optional

This element is used to define colour consultancies.

Each colour consultancy COLOR_CONSULTANCY contains any number of references to combinations of detailed information and assessments FEATURE_DETAIL_INFO_REF, which are sorted by SEQUENCE_NO. The applied assessments must contain colour variations.

Sequence
COLOR_CONSULTANCY 1..∞
This element is used to directly assign assessments to image layers.
The applied assessments must contain colour variations.
COLOR_CONSULTANCY_NO required Restriction of xs:nonNegativeInteger
This attribute defines the colour consultancy number. D nonNegativeInteger
P
M [0:9999]
Sequence
FEATURE_DETAIL_INFO_REF 1..∞
This element allows for the assignment of precisely one assessment or rule to the image layers.
The assessment and/or rule must contain a colour feature. The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO. Either an assessment (RESTRICTION) or rule (DECISION) can be assigned.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of the colour consultancy. D positiveInteger
P
M
DECISION_NO optional Restriction of xs:positiveInteger
This attribute references a rule. D positiveInteger
P
M [1:9999999999]
DETAIL_INFOS 0..∞
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the series becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
DECISIONS optional
This element is used to collect cross-series rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a cross-series rule.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
SERIE_GROUPS optional
This element can be used to combine different series in groups (model groups).
Sequence
SERIE_GROUP 1..∞
A model group (combination of multiple series) is defined here.
SERIE_GROUP_KEY required Restriction of xs:string

This attribute assigns unique identifiers to series groups/model groups.

 D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger

This attribute allows for the specification of series groups with a freely-defined sorting order.

 D nonNegativeInteger
P
M
Sequence
SERIE_REF 1..∞
This element is used to reference series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a series. D nonNegativInteger
P
M [0:999999]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute defines the order of the series within a series group. D nonNegativeInteger
P
M
SERIE_GROUP_TEXT languagetext60 Complex Type
This element is used to specify the designation of the series group/model group.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS 0..∞
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
Remarks

Source
<xs:element name="SERIES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE" maxOccurs="1000000">
        <xs:annotation>
          <xs:documentation>200--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIES_NAME">
              <xs:annotation>
                <xs:documentation>200--3--Serienname</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>200--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Za-z]{1,3}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PURCHASE_RETAIL_ID">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Version 2.3 Polster
Hermann Balke 01.07.2013
EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DECISIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRODUCT_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_CLASS_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                                <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEMS">
                          <xs:annotation>
                            <xs:documentation>400--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:choice>
                                      <xs:sequence>
                                        <xs:element name="ITEM_REF">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="TYPE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>401--0--NEW</xs:documentation>
                                                <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:minLength value="1" />
                                                  <xs:maxLength value="30" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="SERIE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>200--1--Satzart</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="0" />
                                                  <xs:maxInclusive value="999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:sequence>
                                        <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                          <xs:annotation>
                                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence minOccurs="0">
                                              <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>450/470--1--Satzart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="PRICE_FIELD">
                                                      <xs:annotation>
                                                        <xs:documentation>450--4--Preisfeld</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="9999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="PRICE">
                                                      <xs:annotation>
                                                        <xs:documentation>450--5--Preis</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:integer">
                                                          <xs:minInclusive value="-99999999" />
                                                          <xs:maxInclusive value="999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>470--4--Preis</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:integer">
                                                          <xs:minInclusive value="-99999999" />
                                                          <xs:maxInclusive value="999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="VALID_FROM" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                                        <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:date" />
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                                        <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:date" />
                                                      </xs:simpleType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="99999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="PRICE_TYPE_REF">
                                          <xs:annotation>
                                            <xs:documentation>400/407--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="PRICE_TYPE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>400/407--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="PRICE_FEATURE_GROUP_REF">
                                                <xs:annotation>
                                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>460--1--Satzart</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="PRICE_FIELD">
                                                            <xs:annotation>
                                                              <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="9999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="PRICE">
                                                            <xs:annotation>
                                                              <xs:documentation>460--5--Preis</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:integer">
                                                                <xs:minInclusive value="-99999999" />
                                                                <xs:maxInclusive value="999999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="99999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="PRICE_TYPE_REF">
                                                <xs:annotation>
                                                  <xs:documentation>407--5--Preisart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>407--5--Preisart</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="DECISIONS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>291--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="DECISION_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>291--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="9999999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>406--1--Satzart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                                        <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                          </xs:element>
                                                          <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:attribute name="SERIE_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                                  <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                                    <xs:minInclusive value="0" />
                                                                    <xs:maxInclusive value="999999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                              <xs:attribute name="TYPE_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                                  <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:string">
                                                                    <xs:minLength value="1" />
                                                                    <xs:maxLength value="30" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                              <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--7--Anzahl</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                                    <xs:minInclusive value="1" />
                                                                    <xs:maxInclusive value="999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                        <xs:attribute name="SET_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="9" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:attribute name="SERIE_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                                    <xs:minInclusive value="0" />
                                                                    <xs:maxInclusive value="999999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                              <xs:attribute name="TYPE_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:string">
                                                                    <xs:minLength value="1" />
                                                                    <xs:maxLength value="30" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                              <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--7--Anzahl</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                                    <xs:minInclusive value="1" />
                                                                    <xs:maxInclusive value="999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                        <xs:attribute name="SET_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>406--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="9" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="EDP_NUMBER" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="EAN_NUMBER" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="ITEM_IDENTIFICATION">
                                          <xs:annotation>
                                            <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="[BEKSMZVP12]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="CATALOG_PAGE" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="7" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="VALID_FROM" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:date" />
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="VALID_UNTIL" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:date" />
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--20--Gewicht</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="WEIGHT_NETTO" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--20--Gewicht</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="VOLUME" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--21--Volumen</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="BASIC_PROFILE" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:choice>
                                                <xs:element name="CARCASE_BASIC_SHAPE">
                                                  <xs:annotation>
                                                    <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>400--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType mixed="true">
                                                          <xs:sequence>
                                                            <xs:element name="OPTION_REF">
                                                              <xs:annotation>
                                                                <xs:documentation>430--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="FEATURE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>430--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="9999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="OPTION_KEY" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>430--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:minLength value="1" />
                                                                      <xs:maxLength value="30" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>400--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:pattern value="[\S ]{1,5}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="BASIC_SHAPE_PARAMETERS">
                                                        <xs:annotation>
                                                          <xs:documentation>500--1--Satzart</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--0--Parameter</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--5--Nennwert</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="BASIC_SHAPE_FROM">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--6--Von</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="BASIC_SHAPE_TO">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--7--Bis</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                                  <xs:annotation>
                                                    <xs:documentation>400--32--Massbild</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:minLength value="1" />
                                                            <xs:maxLength value="240" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="DIMENSIONAL_PARAMETERS">
                                                        <xs:annotation>
                                                          <xs:documentation>500--1--Satzart</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="DIMENSIONAL_FROM">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="DIMENSIONAL_TO">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>400--32--Massbild</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="20" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:choice>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="ITEM_TEXT">
                                          <xs:annotation>
                                            <xs:documentation>410--1--Satzart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="SHORT_TEXT">
                                                <xs:annotation>
                                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="TEXT_LINE" maxOccurs="3">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:sequence>
                                                                <xs:element name="TEXT">
                                                                  <xs:annotation>
                                                                    <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:pattern value="[\S ]{1,30}" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:element>
                                                              </xs:sequence>
                                                              <xs:attribute name="SEQUENCE_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:positiveInteger" />
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>410--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:language">
                                                              <xs:pattern value="[A-Za-z]{1,3}" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                                </xs:annotation>
                                              </xs:element>
                                              <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="TYPE_KEY">
                                          <xs:annotation>
                                            <xs:documentation>445--1--Satzart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:maxInclusive value="2000" />
                                                    <xs:minInclusive value="1000" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="TK_CLASS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="TK_INFO" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[0-8]0" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="ECLASS">
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="ECLASS_NO">
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:totalDigits value="8" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:maxInclusive value="999999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="DECISION_NO" use="optional">
                                                    <xs:annotation>
                                                      <xs:documentation>291--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="9999999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="SALES_NUMBER" minOccurs="0">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PART_LIST_REF" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>401--1--Satzart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="PART_LIST_KEY" use="required">
                                              <xs:annotation>
                                                <xs:documentation>--0--NEW</xs:documentation>
                                                <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:maxLength value="30" />
                                                  <xs:minLength value="1" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:boolean" />
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PROPERTIES" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="PROPERTY_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="0" />
                                                        <xs:maxInclusive value="999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="VALUE" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="ECO_MOBILIER" minOccurs="0">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="[0-9]{11}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>250--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:element>
                                                    <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>250--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:element>
                                                    <xs:element name="WIDTH">
                                                      <xs:annotation>
                                                        <xs:documentation>400--20--Gewicht</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="9999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="DEPTH">
                                                      <xs:annotation>
                                                        <xs:documentation>400--20--Gewicht</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="9999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="HEIGHT">
                                                      <xs:annotation>
                                                        <xs:documentation>400--20--Gewicht</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="9999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="WEIGHT" type="xs:decimal">
                                                      <xs:annotation>
                                                        <xs:documentation>400--20--Gewicht</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:element>
                                                    <xs:element name="EAN_NUMBER" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="DECISIONS" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>291--0--NEW</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                                            <xs:annotation>
                                                              <xs:documentation>291--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:attribute name="DECISION_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>291--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:positiveInteger">
                                                                    <xs:minInclusive value="1" />
                                                                    <xs:maxInclusive value="9999999999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger" />
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:choice>
                                  </xs:sequence>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE_NO">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DECISIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>291--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DECISION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="COLOR_CONSULTANCIES" minOccurs="0">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="COLOR_CONSULTANCY" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke
                              </xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FEATURE_DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>255--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                          30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>270--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="DECISION_NO" use="optional">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="COLOR_CONSULTANCY_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO" type="xs:positiveInteger" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">IDM 2.5 Sortierung der Modelle</xs:documentation>
              <xs:documentation>K. Richter 26.02.2015</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DECISIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIE_GROUPS" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM 2.5
Möglichkeit Serien zu gruppieren und auch ein Bild zu hinterlegen</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE_GROUP" maxOccurs="unbounded">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIE_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>200--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SERIE_GROUP_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_GROUP_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                    <xs:documentation>geändert auf SERIE_GROUP_KEY, K.Richter 23.11.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element : SERIE Element
Description
This element is used to define the series. A series usually corresponds to a model.
An item from series 0 is valid in all other series, which means that items of series 0 must not exist with the same type designation (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in any other series. Items of other series (other than 0) may however exist in multiple series with identical type designation.
Namespace (none)
Diagram
VALID_UNTIL Element VALID_FROM Element DETAIL_INFOS Element COLOR_CONSULTANCIES Element PRODUCT_GROUPS Element DECISIONS Element PURCHASE_RETAIL_ID Element SERIES_NAME Element Sequence SERIE Element
Overview
SERIE 1..1000000
This element is used to define the series. A series usually corresponds to a model.
An item from series 0 is valid in all other series, which means that items of series 0 must not exist with the same type designation (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in any other series. Items of other series (other than 0) may however exist in multiple series with identical type designation.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the series. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO required xs:positiveInteger
This attribute allows for the specification of series with a freely-defined sorting order.
If a SEQUENCE_NO is specified for one series, a SEQUENCE_NO must be specified for all series. 		D positiveInteger
P
M
Sequence
SERIES_NAME
This element is used to specify the series name.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Za-z]{1,3}
M [1:3]
Sequence
TEXT_LINE
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Sequence
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
PURCHASE_RETAIL_ID Restriction of xs:nonNegativeInteger

This element assigns an identifier for series-specific purchasing/sales prices:

EK_VK_ID
0 = purchasing price including VAT (or list price)
1 = sales price including VAT ( recommended sales price)
2 = purchasing price excluding VAT
3 = purchasing price excl. VAT/VAT

The price is defined as a function of the price-ID (Element PRICE_ID (path 1)) as follows:

Price ID = 1 (price), the value from the ITEM_PRICE (path 2) element will be used.

Price ID = 2 (ID number), the price from the IDENT_NUMBER/PRICE (path 3)element, the ITEM_PRICE/PRICE_MINIMUM_BASIC (path 2) element or the ADDITIONAL_PRICE (element 5) is used.

Price ID = 3 (offsetting point), the value from the ITEM_PRICE (path 2) element or the PRICE_MINIMUM_BASIC Element multiplied by the settlement factor from the PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR is used.

Due to the key, only one price (combination of the elements VAT (path 4) and PURCHASE_RETAIL_ID ) can be specified within the same series.
If a file contains both purchasing and retail prices, models with purchasing prices must not be assigned the same calculation groups (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) as models with retail prices.
This element is very important for pricing. If the purchasing prices are used, this must be the dealership's purchasing price, not the manufacturer purchasing price.

Element paths
Path 1: CATALOG/CATALOG_IDENTIFICATION/
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/
Path 3: PRICE_DEFINITION/IDENT_NUMBERS
Path 4: CATALOG/CATALOG_IDENTIFICATION/
Path 5 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

 D nonNegativeInteger
P
M [0:3]
DECISIONS optional
This element is used to collect series specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a series.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D nonNegativeInteger
P
M [1:9999999999]
PRODUCT_GROUPS
This element is used to define product groups. Articles with identical features are grouped together in product groups.
Sequence
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups. "Identical" product groups must therefore not be captured.
Sequence
PRODUCT_GROUP_TEXT languagetext60 Complex Type
This element contains the designation of a product group.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
This element is used to assign a feature class to the product group. A feature class referenced in the FEATURE_DEFINITION/FEATURE_CLASSES element is defined here.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute is used to identify the referenced feature class (FEATURE_CLASS). D positiveInteger
P
M [1:9999999999]
ITEMS
This element is used to define all items of a product group.
Sequence
ITEM 1..∞
This element is used to define items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes.

The characteristic features/properties, or a reference via ITEM_REF to another series (SERIE_NO) and the item number of valid for the other series, are stored for each item. If the ITEM_REF element contains a value, the item is a reference item belonging to another series, otherwise the item belongs to the series in which it is specified at this position.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
TYPE_NO required Restriction of xs:string
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Sequence
Choice
Sequence
ITEM_REF
This element is used to reference an item.
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:99999]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element is used to reference a base price group. A base Price group is a PRICE_FEATURE_GROUP (path 1) where the ADDITIONAL_PRICE element has a value of 0.

An item must be assigned to precisely one base price group. Additional price groups are assigned via the ADDITIONAL_PRICE_GROUP element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
This element is used to specify the item price and additional price data.
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
ADDITIONAL_PRICE_GROUP 0..∞
This element is used to reference PRICE_FEATURE_GROUPS with additional price groups. The base price group that must be referenced precisely 1x by an item is specified in the PRICE_FEATURE_GROUP_BASE_PRICE_REF element.

All items that reference the identical PRICE_FEATURE_GROUP must also reference the same calculation group (CALC_GROUP_REF) and exchange ID (EXCHANGE_ID_REF).

The following combinations are permitted when assigning different price types to items and surcharges for the same item:

Item | Surcharge
Unit price | Unit price
length-dependent | length-dependent
length-dependent | Unit price

The following combination is not permitted:

Item | Surcharge
Unit price | length-dependent
Sequence
PRICE_FEATURE_GROUP_REF
This element is used to reference a surcharge group. Surcharge groups referenced here must not be used as design ranges.
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
DECISIONS optional
This element is used to combine product item-specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to an item.
ADDITIONAL_ITEMS optional
This element is used to assign additional items. It defines quantities of optional and/or necessary additional items, from which the additional items will be selected during planning.
Sequence
OPTIONAL_ITEMS optional
This element is used to reference optional additional items. Multiple items may be selected from the available optional additional items.
MANDATORY_ITEMS optional
This element is used to assign necessary additional items to an item. Only one additional item may be selected from the available additional items. An item may however be assigned multiple quantities of necessary additional items.
If only one additional item is assigned to a quantity, the item will be selected automatically.
EDP_NUMBER optional Restriction of xs:string
This element is used to enter the (internal) item EDP number of the manufacturer.
If the EDP_NUMBER is used, it must be unique within a series and created for all items. 		D string
P
M [1:30]
EAN_NUMBER optional Restriction of xs:string
If existing, the EAN number of the item must be entered in this element. D string
P
M [1:15]
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article:
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
V = Settlement block
P = Settlement position
1 = Planning proposal
2 = Preferred combination

The following applies for the planning proposal (1):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations:
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

D string
P [BEKSMZVP12]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
This element should be used to specify the item's catalogue page. This information helps to quickly find an item within the printed catalogue.
Items may feature on multiple catalogue pages. In this case, the number of the page on which the item appears first should be used. In the case of accessories, it makes sense to use the page that contains a full description of the item. This is often done in the section/register "accessories". 		D string
P
M [1:7]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item gross weight (100 g), i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item net weight (100 g), i.e. including packaging material, i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
This element is used to specify the item volume [dm³] including packaging material. (e.g. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element is used to specify the minimum delivery time in weeks.
The minimum delivery time is for information, the planning software does not interfere with the order controlling (e.g. postponement of the order, partial delivery) 		D nonNegativeInteger
P
M [0:999]
BASIC_PROFILE optional
This element is used to specify the basic shapes assigned to an item.
Sequence
Choice
CARCASE_BASIC_SHAPE
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation. If there are no parameter values for items with basic shape = 0, parameters must be filled with a value of 0.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
997 = items for which neither a basic shape nor a real visual presentation are delivered. This requires the elementsSUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO to be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.
This element must be filled if the BASIC_PROFILE_SHAPE is empty.
ITEM_DIMENSIONAL_DRAWING
This element is used to specify a dimensional drawing for which the parameters are specified in the DIMENSIONAL_PARAMETERS element. The dimensional drawing describes additional items.
The element must not be created if the BASIC_PROFILE_SHAPE already exists.
ITEM_TEXT
This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. At least one item text must be specified for each item.

The following text combinations are permitted:
- Short text;
- Short text + recommended text;
- Short text + recommended text + long text;
- Short text + long text (only if no recommended text is been stored).

The short text may consist of three lines.
Sequence
SHORT_TEXT
This element contains short texts.
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
TYPE_KEY
This element is used to define the item's model code.

The values for model codes can be found in a table in the introduction, section Model code

The model code is specified precisely once for each item.
Sequence
TK_TYPE Restriction of xs:positiveInteger
A value from the column no. intable "model code" in the introduction is entered here. D poisitiveInteger
P
M [1000:2000]
TK_CLASS optional Restriction of xs:nonNegativeInteger
A value from colum type in table "model codes" is entered here. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
TK_INFO optional Restriction of xs:nonNegativeInteger
A value from colum no. in table " Variation code" is entered here. D nonNegativeInteger
P [0-8]0
M [00-80]
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

SALES_NUMBER optional Restriction of xs:string
If existing, the sale number of the item must be entered in this element. D string
P
M [1:30]
PART_LIST_REF optional

This element references a piece list contained in an item.

The item passes on its options (OPTIONS) to the sub positions if these have identical features (FEATURES) in the feature class associated with the respective sub-position.

The sub-positions can have rules that determine whether a sub-position is displayed. The sub-position is then specified with the corresponding piece quantity.

Items that are only permitted as sub-positions are marked separately (element PARTS_LIST_EXCLUSIVE).

If the item is a catalogue item (ITEM_IDENTIFICATION 'K'), prices may be assigned to the item.The total price of the catalogue item results from the price assigned to it and the prices of the components from the piece list.

The following applies for the planning proposal (ITEM_IDENTIFICATION '1'):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations (ITEM_IDENTIFICATION '2'):
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

PART_LIST_KEY required Restriction of xs:string
This attribute is used to specify the piece list key. D string
P
M [1:30]
PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
This element is used to identify whether the item is only permitted as a sub position within a piece list (value set to 1 (true)).
The value 0 (false) has the same meaning as no value at all. 		D boolean
P
M
PROPERTIES optional
This element is used to combine item-specific characteristic features/properties.
Sequence
PROPERTY_REF 1..∞
This element is used to reference a characteristic feature defined under GLOBAL_DEFINITION/PROPERTIES
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

D string P [0-9]{11} M [11:11]

Information can be found at the following link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

PACKAGE_LIST optional

This element is used to specify the packaged pieces per item. An optimisation of packaged items for purchases is not possible.

The width, depth and height must be specified for each packaged item in full mm figures. The weight is specified in decimal kg.

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

Sequence
PACKAGE_LIST_POS 1..∞
The properties of a packaged item on the list are specified here.
DECISIONS optional
This element is used to combine product group-specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a product group.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
COLOR_CONSULTANCIES optional

This element is used to define colour consultancies.

Each colour consultancy COLOR_CONSULTANCY contains any number of references to combinations of detailed information and assessments FEATURE_DETAIL_INFO_REF, which are sorted by SEQUENCE_NO. The applied assessments must contain colour variations.

Sequence
COLOR_CONSULTANCY 1..∞
This element is used to directly assign assessments to image layers.
The applied assessments must contain colour variations.
COLOR_CONSULTANCY_NO required Restriction of xs:nonNegativeInteger
This attribute defines the colour consultancy number. D nonNegativeInteger
P
M [0:9999]
Sequence
FEATURE_DETAIL_INFO_REF 1..∞
This element allows for the assignment of precisely one assessment or rule to the image layers.
The assessment and/or rule must contain a colour feature. The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO. Either an assessment (RESTRICTION) or rule (DECISION) can be assigned.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of the colour consultancy. D positiveInteger
P
M
DECISION_NO optional Restriction of xs:positiveInteger
This attribute references a rule. D positiveInteger
P
M [1:9999999999]
DETAIL_INFOS 0..∞
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the series becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify the serial number of the series. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO xs:positiveInteger required
This attribute allows for the specification of series with a freely-defined sorting order.
If a SEQUENCE_NO is specified for one series, a SEQUENCE_NO must be specified for all series. 		D positiveInteger
P
M
Remarks

Source
<xs:element name="SERIE" maxOccurs="1000000" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIES_NAME">
        <xs:annotation>
          <xs:documentation>200--3--Serienname</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>200--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Za-z]{1,3}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PURCHASE_RETAIL_ID">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Version 2.3 Polster
Hermann Balke 01.07.2013
EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DECISIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRODUCT_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_CLASS_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                          <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEMS">
                    <xs:annotation>
                      <xs:documentation>400--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:choice>
                                <xs:sequence>
                                  <xs:element name="ITEM_REF">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="TYPE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>401--0--NEW</xs:documentation>
                                          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:minLength value="1" />
                                            <xs:maxLength value="30" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="SERIE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>200--1--Satzart</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:sequence>
                                  <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                    <xs:annotation>
                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence minOccurs="0">
                                        <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>450/470--1--Satzart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="PRICE_FIELD">
                                                <xs:annotation>
                                                  <xs:documentation>450--4--Preisfeld</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PRICE">
                                                <xs:annotation>
                                                  <xs:documentation>450--5--Preis</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:integer">
                                                    <xs:minInclusive value="-99999999" />
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>470--4--Preis</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:integer">
                                                    <xs:minInclusive value="-99999999" />
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="VALID_FROM" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                                  <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:date" />
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                                  <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:date" />
                                                </xs:simpleType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="99999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="PRICE_TYPE_REF">
                                    <xs:annotation>
                                      <xs:documentation>400/407--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>400/407--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="PRICE_FEATURE_GROUP_REF">
                                          <xs:annotation>
                                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>460--1--Satzart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="PRICE_FIELD">
                                                      <xs:annotation>
                                                        <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="9999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="PRICE">
                                                      <xs:annotation>
                                                        <xs:documentation>460--5--Preis</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:integer">
                                                          <xs:minInclusive value="-99999999" />
                                                          <xs:maxInclusive value="999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="99999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="PRICE_TYPE_REF">
                                          <xs:annotation>
                                            <xs:documentation>407--5--Preisart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="PRICE_TYPE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>407--5--Preisart</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="DECISIONS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>291--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="DECISION_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>291--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="9999999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>406--1--Satzart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                  <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:element>
                                                    <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="SERIE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>406--0--NEW</xs:documentation>
                                                            <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="0" />
                                                              <xs:maxInclusive value="999999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="TYPE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>406--0--NEW</xs:documentation>
                                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:string">
                                                              <xs:minLength value="1" />
                                                              <xs:maxLength value="30" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                          <xs:annotation>
                                                            <xs:documentation>406--7--Anzahl</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="SET_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="9" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="SERIE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>406--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="0" />
                                                              <xs:maxInclusive value="999999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="TYPE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>406--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:string">
                                                              <xs:minLength value="1" />
                                                              <xs:maxLength value="30" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                          <xs:annotation>
                                                            <xs:documentation>406--7--Anzahl</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="SET_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>406--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="9" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="EDP_NUMBER" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="EAN_NUMBER" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="ITEM_IDENTIFICATION">
                                    <xs:annotation>
                                      <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[BEKSMZVP12]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="CATALOG_PAGE" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="7" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="VALID_FROM" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:date" />
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="VALID_UNTIL" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:date" />
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--20--Gewicht</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="WEIGHT_NETTO" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--20--Gewicht</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="VOLUME" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--21--Volumen</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="BASIC_PROFILE" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:choice>
                                          <xs:element name="CARCASE_BASIC_SHAPE">
                                            <xs:annotation>
                                              <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>400--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType mixed="true">
                                                    <xs:sequence>
                                                      <xs:element name="OPTION_REF">
                                                        <xs:annotation>
                                                          <xs:documentation>430--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="FEATURE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>430--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="9999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="OPTION_KEY" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>430--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="30" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>400--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:pattern value="[\S ]{1,5}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="BASIC_SHAPE_PARAMETERS">
                                                  <xs:annotation>
                                                    <xs:documentation>500--1--Satzart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>500--0--Parameter</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>500--5--Nennwert</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="BASIC_SHAPE_FROM">
                                                            <xs:annotation>
                                                              <xs:documentation>500--6--Von</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="BASIC_SHAPE_TO">
                                                            <xs:annotation>
                                                              <xs:documentation>500--7--Bis</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                            <xs:annotation>
                                                              <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                            <xs:annotation>
                                              <xs:documentation>400--32--Massbild</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="240" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="DIMENSIONAL_PARAMETERS">
                                                  <xs:annotation>
                                                    <xs:documentation>500--1--Satzart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>500--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>500--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="DIMENSIONAL_FROM">
                                                            <xs:annotation>
                                                              <xs:documentation>500--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="DIMENSIONAL_TO">
                                                            <xs:annotation>
                                                              <xs:documentation>500--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                            <xs:annotation>
                                                              <xs:documentation>500--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--32--Massbild</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="20" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:choice>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="ITEM_TEXT">
                                    <xs:annotation>
                                      <xs:documentation>410--1--Satzart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="SHORT_TEXT">
                                          <xs:annotation>
                                            <xs:documentation>410--5--Texttype</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="TEXT_LINE" maxOccurs="3">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="TEXT">
                                                            <xs:annotation>
                                                              <xs:documentation>410--6--Textzeile</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:pattern value="[\S ]{1,30}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>410--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger" />
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>410--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:language">
                                                        <xs:pattern value="[A-Za-z]{1,3}" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>410--5--Texttype</xs:documentation>
                                          </xs:annotation>
                                        </xs:element>
                                        <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>410--5--Texttype</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="TYPE_KEY">
                                    <xs:annotation>
                                      <xs:documentation>445--1--Satzart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:maxInclusive value="2000" />
                                              <xs:minInclusive value="1000" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="TK_CLASS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="TK_INFO" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[0-8]0" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="ECLASS">
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="ECLASS_NO">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:totalDigits value="8" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:maxInclusive value="999999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="DECISION_NO" use="optional">
                                              <xs:annotation>
                                                <xs:documentation>291--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="9999999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="SALES_NUMBER" minOccurs="0">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PART_LIST_REF" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>401--1--Satzart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="PART_LIST_KEY" use="required">
                                        <xs:annotation>
                                          <xs:documentation>--0--NEW</xs:documentation>
                                          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:maxLength value="30" />
                                            <xs:minLength value="1" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:boolean" />
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PROPERTIES" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="PROPERTY_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="0" />
                                                  <xs:maxInclusive value="999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="VALUE" use="required">
                                              <xs:annotation>
                                                <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="ECO_MOBILIER" minOccurs="0">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[0-9]{11}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>250--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                              </xs:element>
                                              <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>250--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                              </xs:element>
                                              <xs:element name="WIDTH">
                                                <xs:annotation>
                                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="DEPTH">
                                                <xs:annotation>
                                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="HEIGHT">
                                                <xs:annotation>
                                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="WEIGHT" type="xs:decimal">
                                                <xs:annotation>
                                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                </xs:annotation>
                                              </xs:element>
                                              <xs:element name="EAN_NUMBER" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="DECISIONS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>291--0--NEW</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>291--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="DECISION_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>291--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="9999999999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="SEQUENCE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger" />
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:choice>
                            </xs:sequence>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DECISIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DECISION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DECISION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="COLOR_CONSULTANCIES" minOccurs="0">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="COLOR_CONSULTANCY" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke
                              </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>255--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                          30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="DECISION_NO" use="optional">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="COLOR_CONSULTANCY_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO" type="xs:positiveInteger" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">IDM 2.5 Sortierung der Modelle</xs:documentation>
        <xs:documentation>K. Richter 26.02.2015</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIES_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : SERIES_NAME Element
Description
This element is used to specify the series name.
Namespace (none)
Diagram
LANGUAGE Element Sequence SERIES_NAME Element
Overview
SERIES_NAME
This element is used to specify the series name.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Za-z]{1,3}
M [1:3]
Sequence
TEXT_LINE
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Sequence
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Remarks

Source
<xs:element name="SERIES_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--3--Serienname</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>200--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Za-z]{1,3}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element : LANGUAGE Element
Description
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
Namespace (none)
Diagram
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Za-z]{1,3}
M [1:3]
Sequence
TEXT_LINE
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Sequence
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute specifies the ISO code of the stored text's language. D language
P [A-Za-z]{1,3}
M [1:3]
Remarks

Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>200--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Za-z]{1,3}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT_LINE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element : TEXT_LINE Element
Description
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Namespace (none)
Diagram
FULL_TEXT Element TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Sequence
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Remarks

Source
<xs:element name="TEXT_LINE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Description
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Remarks

Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FULL_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : FULL_TEXT Element
Description
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Namespace (none)
Type
xs:string
Diagram
FULL_TEXT Element
Overview
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Source
<xs:element name="FULL_TEXT" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PURCHASE_RETAIL_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : PURCHASE_RETAIL_ID Element
Description

This element assigns an identifier for series-specific purchasing/sales prices:

EK_VK_ID
0 = purchasing price including VAT (or list price)
1 = sales price including VAT ( recommended sales price)
2 = purchasing price excluding VAT
3 = purchasing price excl. VAT/VAT

The price is defined as a function of the price-ID (Element PRICE_ID (path 1)) as follows:

Price ID = 1 (price), the value from the ITEM_PRICE (path 2) element will be used.

Price ID = 2 (ID number), the price from the IDENT_NUMBER/PRICE (path 3)element, the ITEM_PRICE/PRICE_MINIMUM_BASIC (path 2) element or the ADDITIONAL_PRICE (element 5) is used.

Price ID = 3 (offsetting point), the value from the ITEM_PRICE (path 2) element or the PRICE_MINIMUM_BASIC Element multiplied by the settlement factor from the PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR is used.

Due to the key, only one price (combination of the elements VAT (path 4) and PURCHASE_RETAIL_ID ) can be specified within the same series.
If a file contains both purchasing and retail prices, models with purchasing prices must not be assigned the same calculation groups (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) as models with retail prices.
This element is very important for pricing. If the purchasing prices are used, this must be the dealership's purchasing price, not the manufacturer purchasing price.

Element paths
Path 1: CATALOG/CATALOG_IDENTIFICATION/
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/
Path 3: PRICE_DEFINITION/IDENT_NUMBERS
Path 4: CATALOG/CATALOG_IDENTIFICATION/
Path 5 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

 D nonNegativeInteger
P
M [0:3]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
PURCHASE_RETAIL_ID Element
Overview
PURCHASE_RETAIL_ID Restriction of xs:nonNegativeInteger

This element assigns an identifier for series-specific purchasing/sales prices:

EK_VK_ID
0 = purchasing price including VAT (or list price)
1 = sales price including VAT ( recommended sales price)
2 = purchasing price excluding VAT
3 = purchasing price excl. VAT/VAT

The price is defined as a function of the price-ID (Element PRICE_ID (path 1)) as follows:

Price ID = 1 (price), the value from the ITEM_PRICE (path 2) element will be used.

Price ID = 2 (ID number), the price from the IDENT_NUMBER/PRICE (path 3)element, the ITEM_PRICE/PRICE_MINIMUM_BASIC (path 2) element or the ADDITIONAL_PRICE (element 5) is used.

Price ID = 3 (offsetting point), the value from the ITEM_PRICE (path 2) element or the PRICE_MINIMUM_BASIC Element multiplied by the settlement factor from the PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR is used.

Due to the key, only one price (combination of the elements VAT (path 4) and PURCHASE_RETAIL_ID ) can be specified within the same series.
If a file contains both purchasing and retail prices, models with purchasing prices must not be assigned the same calculation groups (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) as models with retail prices.
This element is very important for pricing. If the purchasing prices are used, this must be the dealership's purchasing price, not the manufacturer purchasing price.

Element paths
Path 1: CATALOG/CATALOG_IDENTIFICATION/
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/
Path 3: PRICE_DEFINITION/IDENT_NUMBERS
Path 4: CATALOG/CATALOG_IDENTIFICATION/
Path 5 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

 D nonNegativeInteger
P
M [0:3]
Remarks

Source
<xs:element name="PURCHASE_RETAIL_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Version 2.3 Polster
Hermann Balke 01.07.2013
EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : DECISIONS Element
Description
This element is used to collect series specific rules.
Namespace (none)
Diagram
DECISION_REF Element Sequence DECISIONS Element
Overview
DECISIONS optional
This element is used to collect series specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a series.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D nonNegativeInteger
P
M [1:9999999999]
Source
<xs:element name="DECISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DECISIONS Element : DECISION_REF Element
Description
This element is used to reference a rule assigned to a series.
Namespace (none)
Diagram
DECISION_REF Element
Overview
DECISION_REF 1..∞
This element is used to reference a rule assigned to a series.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D nonNegativeInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
DECISION_NO Restriction of xs:positiveInteger required
This attribute is used to reference a rule. D nonNegativeInteger
P
M [1:9999999999]
Source
<xs:element name="DECISION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DECISIONS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRODUCT_GROUPS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : PRODUCT_GROUPS Element
Description
This element is used to define product groups. Articles with identical features are grouped together in product groups.
Namespace (none)
Diagram
PRODUCT_GROUP Element Sequence PRODUCT_GROUPS Element
Overview
PRODUCT_GROUPS
This element is used to define product groups. Articles with identical features are grouped together in product groups.
Sequence
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups. "Identical" product groups must therefore not be captured.
Sequence
PRODUCT_GROUP_TEXT languagetext60 Complex Type
This element contains the designation of a product group.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
This element is used to assign a feature class to the product group. A feature class referenced in the FEATURE_DEFINITION/FEATURE_CLASSES element is defined here.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute is used to identify the referenced feature class (FEATURE_CLASS). D positiveInteger
P
M [1:9999999999]
ITEMS
This element is used to define all items of a product group.
Sequence
ITEM 1..∞
This element is used to define items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes.

The characteristic features/properties, or a reference via ITEM_REF to another series (SERIE_NO) and the item number of valid for the other series, are stored for each item. If the ITEM_REF element contains a value, the item is a reference item belonging to another series, otherwise the item belongs to the series in which it is specified at this position.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
TYPE_NO required Restriction of xs:string
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Sequence
Choice
Sequence
ITEM_REF
This element is used to reference an item.
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:99999]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element is used to reference a base price group. A base Price group is a PRICE_FEATURE_GROUP (path 1) where the ADDITIONAL_PRICE element has a value of 0.

An item must be assigned to precisely one base price group. Additional price groups are assigned via the ADDITIONAL_PRICE_GROUP element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
This element is used to specify the item price and additional price data.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
The prices according to their price groups (price field, element PRICE_FIELD) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: EUR -9.00 corresponds to -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_BASE_PRICE_REF of the item does not contain an element for the corresponding price group. 		D integer
P
M [-99999999:999999999]
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used to enter minimum prices or base prices. The prices are entered in accordance with their price groups (price field, PRICE_FIELD).

If the price type referenced by the item is not base price-dependent, the minimum price is entered, otherwise a base price. If a price of 0 is entered, the item does not have a minimum or base price, but is also not free of charge.

The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). = 30000 Cent). Identification numbers are entered without decimal places. Settlement points are entered with exactly 2 decimal places (excluding the decimal point itself).

If an item within a price group is unavailable, no data record of the corresponding price group is specified.

The base price is always a piece price. If an item is assigned a base price calculation, the same item cannot be assigned a minimum price.
The end price of the item generally consists of the base price plus the calculated infill price in consideration of the logic defined by the price type (path 3/ PRICE_TYPE_REF). Base prices can only be assigned to items for which at least one dimension is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit (path 5/ BASIC_PRICE_UNIT) must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions. To calculate the price for the infill dimensions, the logic from the price type in conjunction with the item price (path 5/ PRICE) is used. If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

This element must be specified for an item if the item's price type (Path 3/PRICE_TYPE_REF) is base price-dependent.

Element paths:
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: GLOBAL_DEFINITION
Path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_EF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (path 1/ PRICE_TYPE_REF) is defined as base price-dependent, the dimensions for the base price unit must be specified here. The base price unit depends on the number of dimensions specified as "1 or true" in the price type.

If, for example, the base price of a length-dependent item relates to 1.5 m, the value of 1500 bees is entered in this element. In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³].
If they are piece prices, i.e. no dimension was specified as ?1?, the value 0 must be entered in this element.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_SINCE must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
ADDITIONAL_PRICE_GROUP 0..∞
This element is used to reference PRICE_FEATURE_GROUPS with additional price groups. The base price group that must be referenced precisely 1x by an item is specified in the PRICE_FEATURE_GROUP_BASE_PRICE_REF element.

All items that reference the identical PRICE_FEATURE_GROUP must also reference the same calculation group (CALC_GROUP_REF) and exchange ID (EXCHANGE_ID_REF).

The following combinations are permitted when assigning different price types to items and surcharges for the same item:

Item | Surcharge
Unit price | Unit price
length-dependent | length-dependent
length-dependent | Unit price

The following combination is not permitted:

Item | Surcharge
Unit price | length-dependent
Sequence
PRICE_FEATURE_GROUP_REF
This element is used to reference a surcharge group. Surcharge groups referenced here must not be used as design ranges.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
This element is used to specify the item price.
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
DECISIONS optional
This element is used to combine product item-specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to an item.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
ADDITIONAL_ITEMS optional
This element is used to assign additional items. It defines quantities of optional and/or necessary additional items, from which the additional items will be selected during planning.
Sequence
OPTIONAL_ITEMS optional
This element is used to reference optional additional items. Multiple items may be selected from the available optional additional items.
Sequence
OPTIONAL_ITEM_GROUP 1..9
This element is used to form a group of optional items.
MANDATORY_ITEMS optional
This element is used to assign necessary additional items to an item. Only one additional item may be selected from the available additional items. An item may however be assigned multiple quantities of necessary additional items.
If only one additional item is assigned to a quantity, the item will be selected automatically.
Sequence
MANDATORY_ITEM_GROUP 1..9
This element is used to form a group of necessary items. Precisely one item must be selected from this group.
EDP_NUMBER optional Restriction of xs:string
This element is used to enter the (internal) item EDP number of the manufacturer.
If the EDP_NUMBER is used, it must be unique within a series and created for all items. 		D string
P
M [1:30]
EAN_NUMBER optional Restriction of xs:string
If existing, the EAN number of the item must be entered in this element. D string
P
M [1:15]
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article:
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
V = Settlement block
P = Settlement position
1 = Planning proposal
2 = Preferred combination

The following applies for the planning proposal (1):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations:
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

D string
P [BEKSMZVP12]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
This element should be used to specify the item's catalogue page. This information helps to quickly find an item within the printed catalogue.
Items may feature on multiple catalogue pages. In this case, the number of the page on which the item appears first should be used. In the case of accessories, it makes sense to use the page that contains a full description of the item. This is often done in the section/register "accessories". 		D string
P
M [1:7]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item gross weight (100 g), i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item net weight (100 g), i.e. including packaging material, i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
This element is used to specify the item volume [dm³] including packaging material. (e.g. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element is used to specify the minimum delivery time in weeks.
The minimum delivery time is for information, the planning software does not interfere with the order controlling (e.g. postponement of the order, partial delivery) 		D nonNegativeInteger
P
M [0:999]
BASIC_PROFILE optional
This element is used to specify the basic shapes assigned to an item.
Sequence
Choice
CARCASE_BASIC_SHAPE
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation. If there are no parameter values for items with basic shape = 0, parameters must be filled with a value of 0.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
997 = items for which neither a basic shape nor a real visual presentation are delivered. This requires the elementsSUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO to be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.
This element must be filled if the BASIC_PROFILE_SHAPE is empty.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
999 = items that are relevant for visual presentation, but for which no basic shape exists and that are visualised by a graphic model (also see elementMODELING_GRAPHIC_ID). The parameters for width, height and depth must also be specified when using real visual presentations. Additionally, the elementsSERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO can be used to store information for this item.
998 = items for which there is no basic shape or real visual presentation.
997 = items for which neither a basic shape nor a real visual presentation are delivered. For this, the SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO must be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.

This element must be filled if the BASIC_PROFILE_SHAPE is empty. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Here, a basic shape that describes the profile geometry is referenced. The dimensions of the profile must be specified in accordance with the parameters specified in the basic shape.
BASIC_SHAPE_PARAMETERS
This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

For items with a basic shape number = 0 that do not have any dimensions, such as calculation positions (e.g. surcharge for feet shape), the parameters must be filled with 0.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
ITEM_DIMENSIONAL_DRAWING
This element is used to specify a dimensional drawing for which the parameters are specified in the DIMENSIONAL_PARAMETERS element. The dimensional drawing describes additional items.
The element must not be created if the BASIC_PROFILE_SHAPE already exists.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
This element is used to specify a dimensional drawing for which the parameters are specified in the PARAMETERS element. The dimensional drawing describes additional items.
Even if this element is not specified, at least the dimensions of the bounding box (b, h, t) must be specified in the BASIC_PROFILES/PARAMETERS element.
The element must not be created if the BASIC_PROFILE_SHAPE already exists. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
The name of a document or a reference to a document is specified in this field.

The documents may e.g. contain additional technical information about the installation or templates for cutouts and drilling.
If only the document name is specified, the document must be delivered with the data. A document reference is specified for an URI/URL.

If a document reference is specified in this element, the NAME element must be set to 23. The value of 23 stands for document reference (see value tables). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS

This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements DIMENSIONAL_NOMINAL_VALUE (path 1), DIMENSIONAL_FROM (path 1) and DIMENSIONAL_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

If the created item is an electrical appliance, the dimensions B, H and T of that appliance must be specified.

Width, height and depth must also be specified, the planning systems use the term length (depending on the model key) for T=depth.

If absolutely necessary (e.g. for diagonal corner infill pieces), the values for basic shapes 21, 24 and 25 may be specified in 1/10 mm. Example: 27.33 mm => element volume: 0027,3

This element can only be omitted from an item if the item has basic shape number 0 assigned to it and no dimensions, such as for calculation positions (e.g. surcharge for handle).

Path1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

ITEM_TEXT
This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. At least one item text must be specified for each item.

The following text combinations are permitted:
- Short text;
- Short text + recommended text;
- Short text + recommended text + long text;
- Short text + long text (only if no recommended text is been stored).

The short text may consist of three lines.
Sequence
SHORT_TEXT
This element contains short texts.
Sequence
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
TYPE_KEY
This element is used to define the item's model code.

The values for model codes can be found in a table in the introduction, section Model code

The model code is specified precisely once for each item.
Sequence
TK_TYPE Restriction of xs:positiveInteger
A value from the column no. intable "model code" in the introduction is entered here. D poisitiveInteger
P
M [1000:2000]
TK_CLASS optional Restriction of xs:nonNegativeInteger
A value from colum type in table "model codes" is entered here. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
TK_INFO optional Restriction of xs:nonNegativeInteger
A value from colum no. in table " Variation code" is entered here. D nonNegativeInteger
P [0-8]0
M [00-80]
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) must be specified within a preparation rule, there must not be any simultaneous referencing to an assessment (no value for RESTRICTION_NO). 		D positiveInteger
P
M [1:9999999999]
SALES_NUMBER optional Restriction of xs:string
If existing, the sale number of the item must be entered in this element. D string
P
M [1:30]
PART_LIST_REF optional

This element references a piece list contained in an item.

The item passes on its options (OPTIONS) to the sub positions if these have identical features (FEATURES) in the feature class associated with the respective sub-position.

The sub-positions can have rules that determine whether a sub-position is displayed. The sub-position is then specified with the corresponding piece quantity.

Items that are only permitted as sub-positions are marked separately (element PARTS_LIST_EXCLUSIVE).

If the item is a catalogue item (ITEM_IDENTIFICATION 'K'), prices may be assigned to the item.The total price of the catalogue item results from the price assigned to it and the prices of the components from the piece list.

The following applies for the planning proposal (ITEM_IDENTIFICATION '1'):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations (ITEM_IDENTIFICATION '2'):
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

PART_LIST_KEY required Restriction of xs:string
This attribute is used to specify the piece list key. D string
P
M [1:30]
PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
This element is used to identify whether the item is only permitted as a sub position within a piece list (value set to 1 (true)).
The value 0 (false) has the same meaning as no value at all. 		D boolean
P
M
PROPERTIES optional
This element is used to combine item-specific characteristic features/properties.
Sequence
PROPERTY_REF 1..∞
This element is used to reference a characteristic feature defined under GLOBAL_DEFINITION/PROPERTIES
PROPERTY_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a characteristic feature. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

This attribute is used to specify the value of the characteristic feature.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

D string P [0-9]{11} M [11:11]

Information can be found at the following link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

PACKAGE_LIST optional

This element is used to specify the packaged pieces per item. An optimisation of packaged items for purchases is not possible.

The width, depth and height must be specified for each packaged item in full mm figures. The weight is specified in decimal kg.

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

Sequence
PACKAGE_LIST_POS 1..∞
The properties of a packaged item on the list are specified here.
SEQUENCE_NO required Restriction of xs:positiveInteger
This element serves the purpose of an assigning unique number within the list. D positiveInteger
P
M
Sequence
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
This element contains the names on the packaged items list.
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
The description of the list of packaged items is entered here.
WIDTH Restriction of xs:nonNegativeInteger

The width is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
DEPTH Restriction of xs:nonNegativeInteger

The depth is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
HEIGHT Restriction of xs:nonNegativeInteger

The height is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
WEIGHT xs:decimal

The weight is specified in this element.

 D decimal
P
M
EAN_NUMBER optional Restriction of xs:string

The EAN number is specified in this element.

 D string
P
M [1:15]
MATERIAL_NUMBER optional Restriction of xs:string

The material number is specified in this element.

 D string
P
M [1:15]
DECISIONS optional

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

This element is used to reference rules.

DECISIONS optional
This element is used to combine product group-specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a product group.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Remarks

Source
<xs:element name="PRODUCT_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_CLASS_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                    <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEMS">
              <xs:annotation>
                <xs:documentation>400--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:choice>
                          <xs:sequence>
                            <xs:element name="ITEM_REF">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="TYPE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>401--0--NEW</xs:documentation>
                                    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:minLength value="1" />
                                      <xs:maxLength value="30" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="SERIE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>200--1--Satzart</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:sequence>
                            <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                              <xs:annotation>
                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence minOccurs="0">
                                  <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>450/470--1--Satzart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="PRICE_FIELD">
                                          <xs:annotation>
                                            <xs:documentation>450--4--Preisfeld</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PRICE">
                                          <xs:annotation>
                                            <xs:documentation>450--5--Preis</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:integer">
                                              <xs:minInclusive value="-99999999" />
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>470--4--Preis</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:integer">
                                              <xs:minInclusive value="-99999999" />
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="VALID_FROM" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                            <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:date" />
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="VALID_UNTIL" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                            <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:date" />
                                          </xs:simpleType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="99999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="PRICE_TYPE_REF">
                              <xs:annotation>
                                <xs:documentation>400/407--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="PRICE_TYPE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>400/407--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="PRICE_FEATURE_GROUP_REF">
                                    <xs:annotation>
                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>460--1--Satzart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="PRICE_FIELD">
                                                <xs:annotation>
                                                  <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PRICE">
                                                <xs:annotation>
                                                  <xs:documentation>460--5--Preis</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:integer">
                                                    <xs:minInclusive value="-99999999" />
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="99999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="PRICE_TYPE_REF">
                                    <xs:annotation>
                                      <xs:documentation>407--5--Preisart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>407--5--Preisart</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="DECISIONS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="DECISION_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>291--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9999999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>406--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                              </xs:element>
                                              <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="SERIE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>406--0--NEW</xs:documentation>
                                                      <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="0" />
                                                        <xs:maxInclusive value="999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="TYPE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>406--0--NEW</xs:documentation>
                                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:minLength value="1" />
                                                        <xs:maxLength value="30" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                    <xs:annotation>
                                                      <xs:documentation>406--7--Anzahl</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="SET_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="9" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="SERIE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>406--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="0" />
                                                        <xs:maxInclusive value="999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="TYPE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>406--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:minLength value="1" />
                                                        <xs:maxLength value="30" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                    <xs:annotation>
                                                      <xs:documentation>406--7--Anzahl</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="SET_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="9" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="EDP_NUMBER" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="EAN_NUMBER" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="ITEM_IDENTIFICATION">
                              <xs:annotation>
                                <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:pattern value="[BEKSMZVP12]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="CATALOG_PAGE" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="7" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="VALID_FROM" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:date" />
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="VALID_UNTIL" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:date" />
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--20--Gewicht</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="WEIGHT_NETTO" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--20--Gewicht</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="VOLUME" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--21--Volumen</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="BASIC_PROFILE" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:choice>
                                    <xs:element name="CARCASE_BASIC_SHAPE">
                                      <xs:annotation>
                                        <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType mixed="true">
                                              <xs:sequence>
                                                <xs:element name="OPTION_REF">
                                                  <xs:annotation>
                                                    <xs:documentation>430--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="FEATURE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>430--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="9999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="OPTION_KEY" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>430--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="30" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="[\S ]{1,5}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="BASIC_SHAPE_PARAMETERS">
                                            <xs:annotation>
                                              <xs:documentation>500--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>500--0--Parameter</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>500--5--Nennwert</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="BASIC_SHAPE_FROM">
                                                      <xs:annotation>
                                                        <xs:documentation>500--6--Von</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="BASIC_SHAPE_TO">
                                                      <xs:annotation>
                                                        <xs:documentation>500--7--Bis</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                      <xs:annotation>
                                                        <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                      <xs:annotation>
                                        <xs:documentation>400--32--Massbild</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="240" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="DIMENSIONAL_PARAMETERS">
                                            <xs:annotation>
                                              <xs:documentation>500--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>500--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>500--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="DIMENSIONAL_FROM">
                                                      <xs:annotation>
                                                        <xs:documentation>500--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="DIMENSIONAL_TO">
                                                      <xs:annotation>
                                                        <xs:documentation>500--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                      <xs:annotation>
                                                        <xs:documentation>500--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--32--Massbild</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="20" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="ITEM_TEXT">
                              <xs:annotation>
                                <xs:documentation>410--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="SHORT_TEXT">
                                    <xs:annotation>
                                      <xs:documentation>410--5--Texttype</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="TEXT_LINE" maxOccurs="3">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="TEXT">
                                                      <xs:annotation>
                                                        <xs:documentation>410--6--Textzeile</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:pattern value="[\S ]{1,30}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>410--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger" />
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                              <xs:annotation>
                                                <xs:documentation>410--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:language">
                                                  <xs:pattern value="[A-Za-z]{1,3}" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>410--5--Texttype</xs:documentation>
                                    </xs:annotation>
                                  </xs:element>
                                  <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>410--5--Texttype</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="TYPE_KEY">
                              <xs:annotation>
                                <xs:documentation>445--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="2000" />
                                        <xs:minInclusive value="1000" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="TK_CLASS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="TK_INFO" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[0-8]0" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="CLASSIFICATIONS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="ECLASS">
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="ECLASS_NO">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:totalDigits value="8" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="DETAIL_INFOS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:maxInclusive value="999999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="DECISION_NO" use="optional">
                                        <xs:annotation>
                                          <xs:documentation>291--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9999999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="SALES_NUMBER" minOccurs="0">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PART_LIST_REF" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>401--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="PART_LIST_KEY" use="required">
                                  <xs:annotation>
                                    <xs:documentation>--0--NEW</xs:documentation>
                                    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:maxLength value="30" />
                                      <xs:minLength value="1" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:boolean" />
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PROPERTIES" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="PROPERTY_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="VALUE" use="required">
                                        <xs:annotation>
                                          <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="ECO_MOBILIER" minOccurs="0">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:pattern value="[0-9]{11}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>250--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                        </xs:element>
                                        <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>250--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                        </xs:element>
                                        <xs:element name="WIDTH">
                                          <xs:annotation>
                                            <xs:documentation>400--20--Gewicht</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="DEPTH">
                                          <xs:annotation>
                                            <xs:documentation>400--20--Gewicht</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="HEIGHT">
                                          <xs:annotation>
                                            <xs:documentation>400--20--Gewicht</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="WEIGHT" type="xs:decimal">
                                          <xs:annotation>
                                            <xs:documentation>400--20--Gewicht</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                          </xs:annotation>
                                        </xs:element>
                                        <xs:element name="EAN_NUMBER" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="DECISIONS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>291--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>291--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="DECISION_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>291--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="9999999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="SEQUENCE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger" />
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:choice>
                      </xs:sequence>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DECISIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRODUCT_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element : PRODUCT_GROUP Element
Description
This element is used to create modified items that are combined in product groups. "Identical" product groups must therefore not be captured.
Namespace (none)
Diagram
DECISIONS Element ITEMS Element FEATURE_CLASS_REF Element LANGUAGE Element Sequence PRODUCT_GROUP_TEXT Element Sequence PRODUCT_GROUP Element
Overview
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups. "Identical" product groups must therefore not be captured.
Sequence
PRODUCT_GROUP_TEXT languagetext60 Complex Type
This element contains the designation of a product group.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
This element is used to assign a feature class to the product group. A feature class referenced in the FEATURE_DEFINITION/FEATURE_CLASSES element is defined here.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute is used to identify the referenced feature class (FEATURE_CLASS). D positiveInteger
P
M [1:9999999999]
ITEMS
This element is used to define all items of a product group.
Sequence
ITEM 1..∞
This element is used to define items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes.

The characteristic features/properties, or a reference via ITEM_REF to another series (SERIE_NO) and the item number of valid for the other series, are stored for each item. If the ITEM_REF element contains a value, the item is a reference item belonging to another series, otherwise the item belongs to the series in which it is specified at this position.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
TYPE_NO required Restriction of xs:string
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Sequence
Choice
Sequence
ITEM_REF
This element is used to reference an item.
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:99999]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element is used to reference a base price group. A base Price group is a PRICE_FEATURE_GROUP (path 1) where the ADDITIONAL_PRICE element has a value of 0.

An item must be assigned to precisely one base price group. Additional price groups are assigned via the ADDITIONAL_PRICE_GROUP element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
This element is used to specify the item price and additional price data.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
The prices according to their price groups (price field, element PRICE_FIELD) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: EUR -9.00 corresponds to -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_BASE_PRICE_REF of the item does not contain an element for the corresponding price group. 		D integer
P
M [-99999999:999999999]
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used to enter minimum prices or base prices. The prices are entered in accordance with their price groups (price field, PRICE_FIELD).

If the price type referenced by the item is not base price-dependent, the minimum price is entered, otherwise a base price. If a price of 0 is entered, the item does not have a minimum or base price, but is also not free of charge.

The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). = 30000 Cent). Identification numbers are entered without decimal places. Settlement points are entered with exactly 2 decimal places (excluding the decimal point itself).

If an item within a price group is unavailable, no data record of the corresponding price group is specified.

The base price is always a piece price. If an item is assigned a base price calculation, the same item cannot be assigned a minimum price.
The end price of the item generally consists of the base price plus the calculated infill price in consideration of the logic defined by the price type (path 3/ PRICE_TYPE_REF). Base prices can only be assigned to items for which at least one dimension is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit (path 5/ BASIC_PRICE_UNIT) must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions. To calculate the price for the infill dimensions, the logic from the price type in conjunction with the item price (path 5/ PRICE) is used. If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

This element must be specified for an item if the item's price type (Path 3/PRICE_TYPE_REF) is base price-dependent.

Element paths:
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: GLOBAL_DEFINITION
Path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_EF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (path 1/ PRICE_TYPE_REF) is defined as base price-dependent, the dimensions for the base price unit must be specified here. The base price unit depends on the number of dimensions specified as "1 or true" in the price type.

If, for example, the base price of a length-dependent item relates to 1.5 m, the value of 1500 bees is entered in this element. In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³].
If they are piece prices, i.e. no dimension was specified as ?1?, the value 0 must be entered in this element.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_SINCE must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
ADDITIONAL_PRICE_GROUP 0..∞
This element is used to reference PRICE_FEATURE_GROUPS with additional price groups. The base price group that must be referenced precisely 1x by an item is specified in the PRICE_FEATURE_GROUP_BASE_PRICE_REF element.

All items that reference the identical PRICE_FEATURE_GROUP must also reference the same calculation group (CALC_GROUP_REF) and exchange ID (EXCHANGE_ID_REF).

The following combinations are permitted when assigning different price types to items and surcharges for the same item:

Item | Surcharge
Unit price | Unit price
length-dependent | length-dependent
length-dependent | Unit price

The following combination is not permitted:

Item | Surcharge
Unit price | length-dependent
Sequence
PRICE_FEATURE_GROUP_REF
This element is used to reference a surcharge group. Surcharge groups referenced here must not be used as design ranges.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
This element is used to specify the item price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of minus EUR 9.00 is entered as -900) 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
DECISIONS optional
This element is used to combine product item-specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to an item.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
ADDITIONAL_ITEMS optional
This element is used to assign additional items. It defines quantities of optional and/or necessary additional items, from which the additional items will be selected during planning.
Sequence
OPTIONAL_ITEMS optional
This element is used to reference optional additional items. Multiple items may be selected from the available optional additional items.
Sequence
OPTIONAL_ITEM_GROUP 1..9
This element is used to form a group of optional items.
SET_NO required Restriction of xs:positiveInteger
A quantity of optional additional items can be defined for each item. Multiple additional items may be selected from the available optional additional items if MULTIPLE_CHOICE = true. If only one item is defined within a quantity of optional additional items, the item will be selected automatically.

1-9= status for defining the quantities of optional additional items. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
This attribute specifies whether multiple selections within the group are permitted.

true = multiple selection permitted 		D boolean
P
M
Sequence
GROUP_TITLE optional languagetext60 Complex Type
This element is used to designate the group of optional items.
ITEM_REF 1..∞
This element is used to reference an optional additional item.
MANDATORY_ITEMS optional
This element is used to assign necessary additional items to an item. Only one additional item may be selected from the available additional items. An item may however be assigned multiple quantities of necessary additional items.
If only one additional item is assigned to a quantity, the item will be selected automatically.
Sequence
MANDATORY_ITEM_GROUP 1..9
This element is used to form a group of necessary items. Precisely one item must be selected from this group.
SET_NO required Restriction of xs:positiveInteger
For each item, a quantity of optional additional items and nine quantities
of mandatory additional items can be defined.
Multiple additional items may be selected from the available optional additional items.
For each quantity, only one item may be selected from the quantities
of mandatory additional items.
If only one item is defined within a quantity of mandatory additional items,
the item will be selected automatically.

1-9= status for defining the quantities of mandatory additional items.

This element is not necessary, but is retained in IDM 2.0 for reasons of compatibility to ISM 1.7. 		D positiveInteger
P
M [1:9]
Sequence
ITEM_REF 1..∞
This element references an item.
EDP_NUMBER optional Restriction of xs:string
This element is used to enter the (internal) item EDP number of the manufacturer.
If the EDP_NUMBER is used, it must be unique within a series and created for all items. 		D string
P
M [1:30]
EAN_NUMBER optional Restriction of xs:string
If existing, the EAN number of the item must be entered in this element. D string
P
M [1:15]
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article:
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
V = Settlement block
P = Settlement position
1 = Planning proposal
2 = Preferred combination

The following applies for the planning proposal (1):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations:
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

D string
P [BEKSMZVP12]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
This element should be used to specify the item's catalogue page. This information helps to quickly find an item within the printed catalogue.
Items may feature on multiple catalogue pages. In this case, the number of the page on which the item appears first should be used. In the case of accessories, it makes sense to use the page that contains a full description of the item. This is often done in the section/register "accessories". 		D string
P
M [1:7]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item gross weight (100 g), i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item net weight (100 g), i.e. including packaging material, i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
This element is used to specify the item volume [dm³] including packaging material. (e.g. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element is used to specify the minimum delivery time in weeks.
The minimum delivery time is for information, the planning software does not interfere with the order controlling (e.g. postponement of the order, partial delivery) 		D nonNegativeInteger
P
M [0:999]
BASIC_PROFILE optional
This element is used to specify the basic shapes assigned to an item.
Sequence
Choice
CARCASE_BASIC_SHAPE
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation. If there are no parameter values for items with basic shape = 0, parameters must be filled with a value of 0.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
997 = items for which neither a basic shape nor a real visual presentation are delivered. This requires the elementsSUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO to be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.
This element must be filled if the BASIC_PROFILE_SHAPE is empty.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
999 = items that are relevant for visual presentation, but for which no basic shape exists and that are visualised by a graphic model (also see elementMODELING_GRAPHIC_ID). The parameters for width, height and depth must also be specified when using real visual presentations. Additionally, the elementsSERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO can be used to store information for this item.
998 = items for which there is no basic shape or real visual presentation.
997 = items for which neither a basic shape nor a real visual presentation are delivered. For this, the SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO must be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.

This element must be filled if the BASIC_PROFILE_SHAPE is empty. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Here, a basic shape that describes the profile geometry is referenced. The dimensions of the profile must be specified in accordance with the parameters specified in the basic shape.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
This element is used to specify the number of the basic profile shape. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
The feature and option code for the profile shape option are specified here.
BASIC_SHAPE_PARAMETERS
This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

For items with a basic shape number = 0 that do not have any dimensions, such as calculation positions (e.g. surcharge for feet shape), the parameters must be filled with 0.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.

If an item that is not relevant for visual presentation is created and the item does not have any parameters, then the superordinate node BASIC_PROFILE BASIC_PROFILE can be omitted instead of filling the parameters with 0.
ITEM_DIMENSIONAL_DRAWING
This element is used to specify a dimensional drawing for which the parameters are specified in the DIMENSIONAL_PARAMETERS element. The dimensional drawing describes additional items.
The element must not be created if the BASIC_PROFILE_SHAPE already exists.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
This element is used to specify a dimensional drawing for which the parameters are specified in the PARAMETERS element. The dimensional drawing describes additional items.
Even if this element is not specified, at least the dimensions of the bounding box (b, h, t) must be specified in the BASIC_PROFILES/PARAMETERS element.
The element must not be created if the BASIC_PROFILE_SHAPE already exists. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
The name of a document or a reference to a document is specified in this field.

The documents may e.g. contain additional technical information about the installation or templates for cutouts and drilling.
If only the document name is specified, the document must be delivered with the data. A document reference is specified for an URI/URL.

If a document reference is specified in this element, the NAME element must be set to 23. The value of 23 stands for document reference (see value tables). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS

This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements DIMENSIONAL_NOMINAL_VALUE (path 1), DIMENSIONAL_FROM (path 1) and DIMENSIONAL_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

If the created item is an electrical appliance, the dimensions B, H and T of that appliance must be specified.

Width, height and depth must also be specified, the planning systems use the term length (depending on the model key) for T=depth.

If absolutely necessary (e.g. for diagonal corner infill pieces), the values for basic shapes 21, 24 and 25 may be specified in 1/10 mm. Example: 27.33 mm => element volume: 0027,3

This element can only be omitted from an item if the item has basic shape number 0 assigned to it and no dimensions, such as for calculation positions (e.g. surcharge for handle).

Path1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Sequence
DIMENSIONAL_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.
ITEM_TEXT
This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. At least one item text must be specified for each item.

The following text combinations are permitted:
- Short text;
- Short text + recommended text;
- Short text + recommended text + long text;
- Short text + long text (only if no recommended text is been stored).

The short text may consist of three lines.
Sequence
SHORT_TEXT
This element contains short texts.
Sequence
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2
ISO_LANGUAGE_ID required Restriction of xs:language
410--0--NEW Version Beta 2.0 Build 2, K. Richter 26.03.2014
Sequence
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
This element is used to define the item's model code.

The values for model codes can be found in a table in the introduction, section Model code

The model code is specified precisely once for each item.
Sequence
TK_TYPE Restriction of xs:positiveInteger
A value from the column no. intable "model code" in the introduction is entered here. D poisitiveInteger
P
M [1000:2000]
TK_CLASS optional Restriction of xs:nonNegativeInteger
A value from colum type in table "model codes" is entered here. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
TK_INFO optional Restriction of xs:nonNegativeInteger
A value from colum no. in table " Variation code" is entered here. D nonNegativeInteger
P [0-8]0
M [00-80]
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) must be specified within a preparation rule, there must not be any simultaneous referencing to an assessment (no value for RESTRICTION_NO). 		D positiveInteger
P
M [1:9999999999]
SALES_NUMBER optional Restriction of xs:string
If existing, the sale number of the item must be entered in this element. D string
P
M [1:30]
PART_LIST_REF optional

This element references a piece list contained in an item.

The item passes on its options (OPTIONS) to the sub positions if these have identical features (FEATURES) in the feature class associated with the respective sub-position.

The sub-positions can have rules that determine whether a sub-position is displayed. The sub-position is then specified with the corresponding piece quantity.

Items that are only permitted as sub-positions are marked separately (element PARTS_LIST_EXCLUSIVE).

If the item is a catalogue item (ITEM_IDENTIFICATION 'K'), prices may be assigned to the item.The total price of the catalogue item results from the price assigned to it and the prices of the components from the piece list.

The following applies for the planning proposal (ITEM_IDENTIFICATION '1'):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations (ITEM_IDENTIFICATION '2'):
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

PART_LIST_KEY required Restriction of xs:string
This attribute is used to specify the piece list key. D string
P
M [1:30]
PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
This element is used to identify whether the item is only permitted as a sub position within a piece list (value set to 1 (true)).
The value 0 (false) has the same meaning as no value at all. 		D boolean
P
M
PROPERTIES optional
This element is used to combine item-specific characteristic features/properties.
Sequence
PROPERTY_REF 1..∞
This element is used to reference a characteristic feature defined under GLOBAL_DEFINITION/PROPERTIES
PROPERTY_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a characteristic feature. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

This attribute is used to specify the value of the characteristic feature.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

D string P [0-9]{11} M [11:11]

Information can be found at the following link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

PACKAGE_LIST optional

This element is used to specify the packaged pieces per item. An optimisation of packaged items for purchases is not possible.

The width, depth and height must be specified for each packaged item in full mm figures. The weight is specified in decimal kg.

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

Sequence
PACKAGE_LIST_POS 1..∞
The properties of a packaged item on the list are specified here.
SEQUENCE_NO required Restriction of xs:positiveInteger
This element serves the purpose of an assigning unique number within the list. D positiveInteger
P
M
Sequence
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
This element contains the names on the packaged items list.
Sequence
LANGUAGE 1..∞
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
The description of the list of packaged items is entered here.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
WIDTH Restriction of xs:nonNegativeInteger

The width is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
DEPTH Restriction of xs:nonNegativeInteger

The depth is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
HEIGHT Restriction of xs:nonNegativeInteger

The height is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
WEIGHT xs:decimal

The weight is specified in this element.

 D decimal
P
M
EAN_NUMBER optional Restriction of xs:string

The EAN number is specified in this element.

 D string
P
M [1:15]
MATERIAL_NUMBER optional Restriction of xs:string

The material number is specified in this element.

 D string
P
M [1:15]
DECISIONS optional

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

This element is used to reference rules.

Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a list of packaged items.
DECISIONS optional
This element is used to combine product group-specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a product group.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Remarks

Source
<xs:element name="PRODUCT_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_CLASS_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
              <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEMS">
        <xs:annotation>
          <xs:documentation>400--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:choice>
                    <xs:sequence>
                      <xs:element name="ITEM_REF">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="TYPE_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>401--0--NEW</xs:documentation>
                              <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:minLength value="1" />
                                <xs:maxLength value="30" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                          <xs:attribute name="SERIE_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>200--1--Satzart</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                    <xs:sequence>
                      <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                        <xs:annotation>
                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence minOccurs="0">
                            <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>450/470--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="PRICE_FIELD">
                                    <xs:annotation>
                                      <xs:documentation>450--4--Preisfeld</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PRICE">
                                    <xs:annotation>
                                      <xs:documentation>450--5--Preis</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:integer">
                                        <xs:minInclusive value="-99999999" />
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>470--4--Preis</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:integer">
                                        <xs:minInclusive value="-99999999" />
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="VALID_FROM" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                      <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:date" />
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="VALID_UNTIL" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                      <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:date" />
                                    </xs:simpleType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="99999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="PRICE_TYPE_REF">
                        <xs:annotation>
                          <xs:documentation>400/407--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="PRICE_TYPE_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>400/407--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="PRICE_FEATURE_GROUP_REF">
                              <xs:annotation>
                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>460--1--Satzart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="PRICE_FIELD">
                                          <xs:annotation>
                                            <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PRICE">
                                          <xs:annotation>
                                            <xs:documentation>460--5--Preis</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:integer">
                                              <xs:minInclusive value="-99999999" />
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="99999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="PRICE_TYPE_REF">
                              <xs:annotation>
                                <xs:documentation>407--5--Preisart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="PRICE_TYPE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>407--5--Preisart</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="DECISIONS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="DECISION_REF" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="DECISION_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>291--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9999999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>406--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                        </xs:element>
                                        <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="SERIE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="0" />
                                                  <xs:maxInclusive value="999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="TYPE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:minLength value="1" />
                                                  <xs:maxLength value="30" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                              <xs:annotation>
                                                <xs:documentation>406--7--Anzahl</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="SET_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="SERIE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="0" />
                                                  <xs:maxInclusive value="999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="TYPE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:minLength value="1" />
                                                  <xs:maxLength value="30" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                              <xs:annotation>
                                                <xs:documentation>406--7--Anzahl</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="SET_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>406--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="EDP_NUMBER" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="EAN_NUMBER" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="ITEM_IDENTIFICATION">
                        <xs:annotation>
                          <xs:documentation>400--14--Artikelkennung</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:pattern value="[BEKSMZVP12]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="CATALOG_PAGE" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="7" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="VALID_FROM" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:date" />
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="VALID_UNTIL" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:date" />
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--20--Gewicht</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="WEIGHT_NETTO" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--20--Gewicht</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="VOLUME" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--21--Volumen</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="BASIC_PROFILE" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:choice>
                              <xs:element name="CARCASE_BASIC_SHAPE">
                                <xs:annotation>
                                  <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType mixed="true">
                                        <xs:sequence>
                                          <xs:element name="OPTION_REF">
                                            <xs:annotation>
                                              <xs:documentation>430--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>430--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>430--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="[\S ]{1,5}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="BASIC_SHAPE_PARAMETERS">
                                      <xs:annotation>
                                        <xs:documentation>500--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>500--0--Parameter</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>500--5--Nennwert</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="BASIC_SHAPE_FROM">
                                                <xs:annotation>
                                                  <xs:documentation>500--6--Von</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="BASIC_SHAPE_TO">
                                                <xs:annotation>
                                                  <xs:documentation>500--7--Bis</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                <xs:annotation>
                                                  <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                <xs:annotation>
                                  <xs:documentation>400--32--Massbild</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="240" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="DIMENSIONAL_PARAMETERS">
                                      <xs:annotation>
                                        <xs:documentation>500--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="DIMENSIONAL_FROM">
                                                <xs:annotation>
                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="DIMENSIONAL_TO">
                                                <xs:annotation>
                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                <xs:annotation>
                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--32--Massbild</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="20" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="ITEM_TEXT">
                        <xs:annotation>
                          <xs:documentation>410--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="SHORT_TEXT">
                              <xs:annotation>
                                <xs:documentation>410--5--Texttype</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="TEXT_LINE" maxOccurs="3">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="TEXT">
                                                <xs:annotation>
                                                  <xs:documentation>410--6--Textzeile</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="[\S ]{1,30}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="SEQUENCE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>410--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger" />
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                        <xs:annotation>
                                          <xs:documentation>410--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:language">
                                            <xs:pattern value="[A-Za-z]{1,3}" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>410--5--Texttype</xs:documentation>
                              </xs:annotation>
                            </xs:element>
                            <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>410--5--Texttype</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="TYPE_KEY">
                        <xs:annotation>
                          <xs:documentation>445--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="2000" />
                                  <xs:minInclusive value="1000" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="TK_CLASS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="TK_INFO" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-8]0" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="CLASSIFICATIONS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="ECLASS">
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="ECLASS_NO">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:totalDigits value="8" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="DETAIL_INFOS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="DETAIL_INFO_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:maxInclusive value="999999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="DECISION_NO" use="optional">
                                  <xs:annotation>
                                    <xs:documentation>291--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9999999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="SALES_NUMBER" minOccurs="0">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="PART_LIST_REF" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>401--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="PART_LIST_KEY" use="required">
                            <xs:annotation>
                              <xs:documentation>--0--NEW</xs:documentation>
                              <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:maxLength value="30" />
                                <xs:minLength value="1" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:boolean" />
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="PROPERTIES" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="PROPERTY_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="VALUE" use="required">
                                  <xs:annotation>
                                    <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="ECO_MOBILIER" minOccurs="0">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:pattern value="[0-9]{11}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>250--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                  </xs:element>
                                  <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>250--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                  </xs:element>
                                  <xs:element name="WIDTH">
                                    <xs:annotation>
                                      <xs:documentation>400--20--Gewicht</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="DEPTH">
                                    <xs:annotation>
                                      <xs:documentation>400--20--Gewicht</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="HEIGHT">
                                    <xs:annotation>
                                      <xs:documentation>400--20--Gewicht</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="WEIGHT" type="xs:decimal">
                                    <xs:annotation>
                                      <xs:documentation>400--20--Gewicht</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                    </xs:annotation>
                                  </xs:element>
                                  <xs:element name="EAN_NUMBER" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="DECISIONS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>291--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="DECISION_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>291--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="9999999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="SEQUENCE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger" />
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:choice>
                </xs:sequence>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DECISIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRODUCT_GROUP_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : PRODUCT_GROUP_TEXT Element
Description
This element contains the designation of a product group.
Namespace (none)
Type
languagetext60 Complex Type
Diagram
LANGUAGE Element Sequence PRODUCT_GROUP_TEXT Element
Overview
PRODUCT_GROUP_TEXT languagetext60 Complex Type
This element contains the designation of a product group.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="PRODUCT_GROUP_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > languagetext60 Complex Type : LANGUAGE Element
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetext60 Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > languagetext60 Complex Type > LANGUAGE Element : TEXT Element
Description
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetext60 Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_CLASS_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : FEATURE_CLASS_REF Element
Description
This element is used to assign a feature class to the product group. A feature class referenced in the FEATURE_DEFINITION/FEATURE_CLASSES element is defined here.
Namespace (none)
Diagram
FEATURE_CLASS_REF Element
Overview
FEATURE_CLASS_REF optional
This element is used to assign a feature class to the product group. A feature class referenced in the FEATURE_DEFINITION/FEATURE_CLASSES element is defined here.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute is used to identify the referenced feature class (FEATURE_CLASS). D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
FEATURE_CLASS_NO Restriction of xs:positiveInteger required
This attribute is used to identify the referenced feature class (FEATURE_CLASS). D positiveInteger
P
M [1:9999999999]
Remarks

Source
<xs:element name="FEATURE_CLASS_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_CLASS_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
        <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEMS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : ITEMS Element
Description
This element is used to define all items of a product group.
Namespace (none)
Diagram
ITEM Element Sequence ITEMS Element
Overview
ITEMS
This element is used to define all items of a product group.
Sequence
ITEM 1..∞
This element is used to define items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes.

The characteristic features/properties, or a reference via ITEM_REF to another series (SERIE_NO) and the item number of valid for the other series, are stored for each item. If the ITEM_REF element contains a value, the item is a reference item belonging to another series, otherwise the item belongs to the series in which it is specified at this position.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
TYPE_NO required Restriction of xs:string
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Sequence
Choice
Sequence
ITEM_REF
This element is used to reference an item.
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:99999]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element is used to reference a base price group. A base Price group is a PRICE_FEATURE_GROUP (path 1) where the ADDITIONAL_PRICE element has a value of 0.

An item must be assigned to precisely one base price group. Additional price groups are assigned via the ADDITIONAL_PRICE_GROUP element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
This element is used to specify the item price and additional price data.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
The prices according to their price groups (price field, element PRICE_FIELD) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: EUR -9.00 corresponds to -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_BASE_PRICE_REF of the item does not contain an element for the corresponding price group. 		D integer
P
M [-99999999:999999999]
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used to enter minimum prices or base prices. The prices are entered in accordance with their price groups (price field, PRICE_FIELD).

If the price type referenced by the item is not base price-dependent, the minimum price is entered, otherwise a base price. If a price of 0 is entered, the item does not have a minimum or base price, but is also not free of charge.

The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). = 30000 Cent). Identification numbers are entered without decimal places. Settlement points are entered with exactly 2 decimal places (excluding the decimal point itself).

If an item within a price group is unavailable, no data record of the corresponding price group is specified.

The base price is always a piece price. If an item is assigned a base price calculation, the same item cannot be assigned a minimum price.
The end price of the item generally consists of the base price plus the calculated infill price in consideration of the logic defined by the price type (path 3/ PRICE_TYPE_REF). Base prices can only be assigned to items for which at least one dimension is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit (path 5/ BASIC_PRICE_UNIT) must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions. To calculate the price for the infill dimensions, the logic from the price type in conjunction with the item price (path 5/ PRICE) is used. If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

This element must be specified for an item if the item's price type (Path 3/PRICE_TYPE_REF) is base price-dependent.

Element paths:
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: GLOBAL_DEFINITION
Path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_EF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (path 1/ PRICE_TYPE_REF) is defined as base price-dependent, the dimensions for the base price unit must be specified here. The base price unit depends on the number of dimensions specified as "1 or true" in the price type.

If, for example, the base price of a length-dependent item relates to 1.5 m, the value of 1500 bees is entered in this element. In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³].
If they are piece prices, i.e. no dimension was specified as ?1?, the value 0 must be entered in this element.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_SINCE must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
ADDITIONAL_PRICE_GROUP 0..∞
This element is used to reference PRICE_FEATURE_GROUPS with additional price groups. The base price group that must be referenced precisely 1x by an item is specified in the PRICE_FEATURE_GROUP_BASE_PRICE_REF element.

All items that reference the identical PRICE_FEATURE_GROUP must also reference the same calculation group (CALC_GROUP_REF) and exchange ID (EXCHANGE_ID_REF).

The following combinations are permitted when assigning different price types to items and surcharges for the same item:

Item | Surcharge
Unit price | Unit price
length-dependent | length-dependent
length-dependent | Unit price

The following combination is not permitted:

Item | Surcharge
Unit price | length-dependent
Sequence
PRICE_FEATURE_GROUP_REF
This element is used to reference a surcharge group. Surcharge groups referenced here must not be used as design ranges.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
This element is used to specify the item price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of minus EUR 9.00 is entered as -900) 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
DECISIONS optional
This element is used to combine product item-specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to an item.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
ADDITIONAL_ITEMS optional
This element is used to assign additional items. It defines quantities of optional and/or necessary additional items, from which the additional items will be selected during planning.
Sequence
OPTIONAL_ITEMS optional
This element is used to reference optional additional items. Multiple items may be selected from the available optional additional items.
Sequence
OPTIONAL_ITEM_GROUP 1..9
This element is used to form a group of optional items.
SET_NO required Restriction of xs:positiveInteger
A quantity of optional additional items can be defined for each item. Multiple additional items may be selected from the available optional additional items if MULTIPLE_CHOICE = true. If only one item is defined within a quantity of optional additional items, the item will be selected automatically.

1-9= status for defining the quantities of optional additional items. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
This attribute specifies whether multiple selections within the group are permitted.

true = multiple selection permitted 		D boolean
P
M
Sequence
GROUP_TITLE optional languagetext60 Complex Type
This element is used to designate the group of optional items.
Sequence
LANGUAGE 1..∞
ITEM_REF 1..∞
This element is used to reference an optional additional item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. (e.g. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY optional Restriction of xs:nonNegativeInteger
Quantity of additional items. Suggested value for planning systems. The quantity is a non-binding suggestion for optional additional items; for mandatory items, the quantity is binding during planning. D nonNegativeInteger
P
M [1:999]
MANDATORY_ITEMS optional
This element is used to assign necessary additional items to an item. Only one additional item may be selected from the available additional items. An item may however be assigned multiple quantities of necessary additional items.
If only one additional item is assigned to a quantity, the item will be selected automatically.
Sequence
MANDATORY_ITEM_GROUP 1..9
This element is used to form a group of necessary items. Precisely one item must be selected from this group.
SET_NO required Restriction of xs:positiveInteger
For each item, a quantity of optional additional items and nine quantities
of mandatory additional items can be defined.
Multiple additional items may be selected from the available optional additional items.
For each quantity, only one item may be selected from the quantities
of mandatory additional items.
If only one item is defined within a quantity of mandatory additional items,
the item will be selected automatically.

1-9= status for defining the quantities of mandatory additional items.

This element is not necessary, but is retained in IDM 2.0 for reasons of compatibility to ISM 1.7. 		D positiveInteger
P
M [1:9]
Sequence
ITEM_REF 1..∞
This element references an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. D string
P
M [1:30]
MANDATORY_QUANTITY optional Restriction of xs:nonNegativeInteger
Quantity of additional items. Suggested value for planning systems. D nonNegativeInteger
P
M [1:999]
EDP_NUMBER optional Restriction of xs:string
This element is used to enter the (internal) item EDP number of the manufacturer.
If the EDP_NUMBER is used, it must be unique within a series and created for all items. 		D string
P
M [1:30]
EAN_NUMBER optional Restriction of xs:string
If existing, the EAN number of the item must be entered in this element. D string
P
M [1:15]
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article:
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
V = Settlement block
P = Settlement position
1 = Planning proposal
2 = Preferred combination

The following applies for the planning proposal (1):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations:
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

D string
P [BEKSMZVP12]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
This element should be used to specify the item's catalogue page. This information helps to quickly find an item within the printed catalogue.
Items may feature on multiple catalogue pages. In this case, the number of the page on which the item appears first should be used. In the case of accessories, it makes sense to use the page that contains a full description of the item. This is often done in the section/register "accessories". 		D string
P
M [1:7]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item gross weight (100 g), i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item net weight (100 g), i.e. including packaging material, i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
This element is used to specify the item volume [dm³] including packaging material. (e.g. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element is used to specify the minimum delivery time in weeks.
The minimum delivery time is for information, the planning software does not interfere with the order controlling (e.g. postponement of the order, partial delivery) 		D nonNegativeInteger
P
M [0:999]
BASIC_PROFILE optional
This element is used to specify the basic shapes assigned to an item.
Sequence
Choice
CARCASE_BASIC_SHAPE
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation. If there are no parameter values for items with basic shape = 0, parameters must be filled with a value of 0.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
997 = items for which neither a basic shape nor a real visual presentation are delivered. This requires the elementsSUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO to be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.
This element must be filled if the BASIC_PROFILE_SHAPE is empty.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
999 = items that are relevant for visual presentation, but for which no basic shape exists and that are visualised by a graphic model (also see elementMODELING_GRAPHIC_ID). The parameters for width, height and depth must also be specified when using real visual presentations. Additionally, the elementsSERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO can be used to store information for this item.
998 = items for which there is no basic shape or real visual presentation.
997 = items for which neither a basic shape nor a real visual presentation are delivered. For this, the SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO must be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.

This element must be filled if the BASIC_PROFILE_SHAPE is empty. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Here, a basic shape that describes the profile geometry is referenced. The dimensions of the profile must be specified in accordance with the parameters specified in the basic shape.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
This element is used to specify the number of the basic profile shape. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
The feature and option code for the profile shape option are specified here.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify a feature. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option that is to be assigned to a basic profile shape. D string
P
M [1:30]
BASIC_SHAPE_PARAMETERS
This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

For items with a basic shape number = 0 that do not have any dimensions, such as calculation positions (e.g. surcharge for feet shape), the parameters must be filled with 0.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.

If an item that is not relevant for visual presentation is created and the item does not have any parameters, then the superordinate node BASIC_PROFILE BASIC_PROFILE can be omitted instead of filling the parameters with 0.
BASIC_SHAPE_NAME required Restriction of xs:string
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
ITEM_DIMENSIONAL_DRAWING
This element is used to specify a dimensional drawing for which the parameters are specified in the DIMENSIONAL_PARAMETERS element. The dimensional drawing describes additional items.
The element must not be created if the BASIC_PROFILE_SHAPE already exists.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
This element is used to specify a dimensional drawing for which the parameters are specified in the PARAMETERS element. The dimensional drawing describes additional items.
Even if this element is not specified, at least the dimensions of the bounding box (b, h, t) must be specified in the BASIC_PROFILES/PARAMETERS element.
The element must not be created if the BASIC_PROFILE_SHAPE already exists. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
The name of a document or a reference to a document is specified in this field.

The documents may e.g. contain additional technical information about the installation or templates for cutouts and drilling.
If only the document name is specified, the document must be delivered with the data. A document reference is specified for an URI/URL.

If a document reference is specified in this element, the NAME element must be set to 23. The value of 23 stands for document reference (see value tables). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS

This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements DIMENSIONAL_NOMINAL_VALUE (path 1), DIMENSIONAL_FROM (path 1) and DIMENSIONAL_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

If the created item is an electrical appliance, the dimensions B, H and T of that appliance must be specified.

Width, height and depth must also be specified, the planning systems use the term length (depending on the model key) for T=depth.

If absolutely necessary (e.g. for diagonal corner infill pieces), the values for basic shapes 21, 24 and 25 may be specified in 1/10 mm. Example: 27.33 mm => element volume: 0027,3

This element can only be omitted from an item if the item has basic shape number 0 assigned to it and no dimensions, such as for calculation positions (e.g. surcharge for handle).

Path1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Sequence
DIMENSIONAL_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.
DIMENSIONAL_NAME required Restriction of xs:string
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
ITEM_TEXT
This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. At least one item text must be specified for each item.

The following text combinations are permitted:
- Short text;
- Short text + recommended text;
- Short text + recommended text + long text;
- Short text + long text (only if no recommended text is been stored).

The short text may consist of three lines.
Sequence
SHORT_TEXT
This element contains short texts.
Sequence
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2
ISO_LANGUAGE_ID required Restriction of xs:language
410--0--NEW Version Beta 2.0 Build 2, K. Richter 26.03.2014
Sequence
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5
SEQUENCE_NO required Restriction of xs:positiveInteger
410--0--NEW Version Beta 2.0 Build 5
Sequence
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
This element is used to define the item's model code.

The values for model codes can be found in a table in the introduction, section Model code

The model code is specified precisely once for each item.
Sequence
TK_TYPE Restriction of xs:positiveInteger
A value from the column no. intable "model code" in the introduction is entered here. D poisitiveInteger
P
M [1000:2000]
TK_CLASS optional Restriction of xs:nonNegativeInteger
A value from colum type in table "model codes" is entered here. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
TK_INFO optional Restriction of xs:nonNegativeInteger
A value from colum no. in table " Variation code" is entered here. D nonNegativeInteger
P [0-8]0
M [00-80]
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) must be specified within a preparation rule, there must not be any simultaneous referencing to an assessment (no value for RESTRICTION_NO). 		D positiveInteger
P
M [1:9999999999]
SALES_NUMBER optional Restriction of xs:string
If existing, the sale number of the item must be entered in this element. D string
P
M [1:30]
PART_LIST_REF optional

This element references a piece list contained in an item.

The item passes on its options (OPTIONS) to the sub positions if these have identical features (FEATURES) in the feature class associated with the respective sub-position.

The sub-positions can have rules that determine whether a sub-position is displayed. The sub-position is then specified with the corresponding piece quantity.

Items that are only permitted as sub-positions are marked separately (element PARTS_LIST_EXCLUSIVE).

If the item is a catalogue item (ITEM_IDENTIFICATION 'K'), prices may be assigned to the item.The total price of the catalogue item results from the price assigned to it and the prices of the components from the piece list.

The following applies for the planning proposal (ITEM_IDENTIFICATION '1'):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations (ITEM_IDENTIFICATION '2'):
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

PART_LIST_KEY required Restriction of xs:string
This attribute is used to specify the piece list key. D string
P
M [1:30]
PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
This element is used to identify whether the item is only permitted as a sub position within a piece list (value set to 1 (true)).
The value 0 (false) has the same meaning as no value at all. 		D boolean
P
M
PROPERTIES optional
This element is used to combine item-specific characteristic features/properties.
Sequence
PROPERTY_REF 1..∞
This element is used to reference a characteristic feature defined under GLOBAL_DEFINITION/PROPERTIES
PROPERTY_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a characteristic feature. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

This attribute is used to specify the value of the characteristic feature.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

D string P [0-9]{11} M [11:11]

Information can be found at the following link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

PACKAGE_LIST optional

This element is used to specify the packaged pieces per item. An optimisation of packaged items for purchases is not possible.

The width, depth and height must be specified for each packaged item in full mm figures. The weight is specified in decimal kg.

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

Sequence
PACKAGE_LIST_POS 1..∞
The properties of a packaged item on the list are specified here.
SEQUENCE_NO required Restriction of xs:positiveInteger
This element serves the purpose of an assigning unique number within the list. D positiveInteger
P
M
Sequence
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
This element contains the names on the packaged items list.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
The description of the list of packaged items is entered here.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
WIDTH Restriction of xs:nonNegativeInteger

The width is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
DEPTH Restriction of xs:nonNegativeInteger

The depth is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
HEIGHT Restriction of xs:nonNegativeInteger

The height is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
WEIGHT xs:decimal

The weight is specified in this element.

 D decimal
P
M
EAN_NUMBER optional Restriction of xs:string

The EAN number is specified in this element.

 D string
P
M [1:15]
MATERIAL_NUMBER optional Restriction of xs:string

The material number is specified in this element.

 D string
P
M [1:15]
DECISIONS optional

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

This element is used to reference rules.

Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a list of packaged items.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Remarks

Source
<xs:element name="ITEMS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:choice>
              <xs:sequence>
                <xs:element name="ITEM_REF">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="TYPE_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>401--0--NEW</xs:documentation>
                        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:minLength value="1" />
                          <xs:maxLength value="30" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                    <xs:attribute name="SERIE_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>200--1--Satzart</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
              <xs:sequence>
                <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                  <xs:annotation>
                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence minOccurs="0">
                      <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>450/470--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="PRICE_FIELD">
                              <xs:annotation>
                                <xs:documentation>450--4--Preisfeld</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PRICE">
                              <xs:annotation>
                                <xs:documentation>450--5--Preis</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:integer">
                                  <xs:minInclusive value="-99999999" />
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>470--4--Preis</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:integer">
                                  <xs:minInclusive value="-99999999" />
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="VALID_FROM" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:date" />
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="VALID_UNTIL" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:date" />
                              </xs:simpleType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="99999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
                <xs:element name="PRICE_TYPE_REF">
                  <xs:annotation>
                    <xs:documentation>400/407--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="PRICE_TYPE_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>400/407--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
                <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="PRICE_FEATURE_GROUP_REF">
                        <xs:annotation>
                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>460--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="PRICE_FIELD">
                                    <xs:annotation>
                                      <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PRICE">
                                    <xs:annotation>
                                      <xs:documentation>460--5--Preis</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:integer">
                                        <xs:minInclusive value="-99999999" />
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="99999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="PRICE_TYPE_REF">
                        <xs:annotation>
                          <xs:documentation>407--5--Preisart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="PRICE_TYPE_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>407--5--Preisart</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="DECISIONS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="DECISION_REF" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="DECISION_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>291--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9999999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>406--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                  </xs:element>
                                  <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="SERIE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>406--0--NEW</xs:documentation>
                                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="TYPE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>406--0--NEW</xs:documentation>
                                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:minLength value="1" />
                                            <xs:maxLength value="30" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                        <xs:annotation>
                                          <xs:documentation>406--7--Anzahl</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="SET_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="SERIE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>406--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="TYPE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>406--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:minLength value="1" />
                                            <xs:maxLength value="30" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                        <xs:annotation>
                                          <xs:documentation>406--7--Anzahl</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="SET_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>406--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="EDP_NUMBER" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="EAN_NUMBER" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="ITEM_IDENTIFICATION">
                  <xs:annotation>
                    <xs:documentation>400--14--Artikelkennung</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[BEKSMZVP12]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="CATALOG_PAGE" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="7" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="VALID_FROM" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:date" />
                  </xs:simpleType>
                </xs:element>
                <xs:element name="VALID_UNTIL" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:date" />
                  </xs:simpleType>
                </xs:element>
                <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--20--Gewicht</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="WEIGHT_NETTO" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--20--Gewicht</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="VOLUME" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--21--Volumen</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="BASIC_PROFILE" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:choice>
                        <xs:element name="CARCASE_BASIC_SHAPE">
                          <xs:annotation>
                            <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType mixed="true">
                                  <xs:sequence>
                                    <xs:element name="OPTION_REF">
                                      <xs:annotation>
                                        <xs:documentation>430--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>430--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>430--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[\S ]{1,5}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="BASIC_SHAPE_PARAMETERS">
                                <xs:annotation>
                                  <xs:documentation>500--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                          <xs:annotation>
                                            <xs:documentation>500--0--Parameter</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>500--5--Nennwert</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="BASIC_SHAPE_FROM">
                                          <xs:annotation>
                                            <xs:documentation>500--6--Von</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="BASIC_SHAPE_TO">
                                          <xs:annotation>
                                            <xs:documentation>500--7--Bis</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                          <xs:annotation>
                                            <xs:documentation>500--8--Schrittweite</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                          <xs:annotation>
                            <xs:documentation>400--32--Massbild</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="240" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="DIMENSIONAL_PARAMETERS">
                                <xs:annotation>
                                  <xs:documentation>500--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                          <xs:annotation>
                                            <xs:documentation>500--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>500--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="DIMENSIONAL_FROM">
                                          <xs:annotation>
                                            <xs:documentation>500--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="DIMENSIONAL_TO">
                                          <xs:annotation>
                                            <xs:documentation>500--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                          <xs:annotation>
                                            <xs:documentation>500--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--32--Massbild</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="20" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="ITEM_TEXT">
                  <xs:annotation>
                    <xs:documentation>410--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="SHORT_TEXT">
                        <xs:annotation>
                          <xs:documentation>410--5--Texttype</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="LANGUAGE" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="TEXT_LINE" maxOccurs="3">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="TEXT">
                                          <xs:annotation>
                                            <xs:documentation>410--6--Textzeile</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="[\S ]{1,30}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="SEQUENCE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>410--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger" />
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                  <xs:annotation>
                                    <xs:documentation>410--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:language">
                                      <xs:pattern value="[A-Za-z]{1,3}" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>410--5--Texttype</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>410--5--Texttype</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="TYPE_KEY">
                  <xs:annotation>
                    <xs:documentation>445--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="2000" />
                            <xs:minInclusive value="1000" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="TK_CLASS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="TK_INFO" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-8]0" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="CLASSIFICATIONS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="ECLASS">
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="ECLASS_NO">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:totalDigits value="8" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="DETAIL_INFOS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="DETAIL_INFO_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:maxInclusive value="999999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                          <xs:attribute name="DECISION_NO" use="optional">
                            <xs:annotation>
                              <xs:documentation>291--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9999999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="SALES_NUMBER" minOccurs="0">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="PART_LIST_REF" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>401--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="PART_LIST_KEY" use="required">
                      <xs:annotation>
                        <xs:documentation>--0--NEW</xs:documentation>
                        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:maxLength value="30" />
                          <xs:minLength value="1" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
                <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:boolean" />
                  </xs:simpleType>
                </xs:element>
                <xs:element name="PROPERTIES" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="PROPERTY_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                          <xs:attribute name="VALUE" use="required">
                            <xs:annotation>
                              <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="ECO_MOBILIER" minOccurs="0">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[0-9]{11}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>250--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                            </xs:element>
                            <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>250--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                            </xs:element>
                            <xs:element name="WIDTH">
                              <xs:annotation>
                                <xs:documentation>400--20--Gewicht</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="DEPTH">
                              <xs:annotation>
                                <xs:documentation>400--20--Gewicht</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="HEIGHT">
                              <xs:annotation>
                                <xs:documentation>400--20--Gewicht</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="WEIGHT" type="xs:decimal">
                              <xs:annotation>
                                <xs:documentation>400--20--Gewicht</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                              </xs:annotation>
                            </xs:element>
                            <xs:element name="EAN_NUMBER" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="DECISIONS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="DECISION_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>291--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9999999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:attribute name="SEQUENCE_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger" />
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:choice>
          </xs:sequence>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element : ITEM Element
Description
This element is used to define items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes.

The characteristic features/properties, or a reference via ITEM_REF to another series (SERIE_NO) and the item number of valid for the other series, are stored for each item. If the ITEM_REF element contains a value, the item is a reference item belonging to another series, otherwise the item belongs to the series in which it is specified at this position.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
Namespace (none)
Diagram
PACKAGE_LIST Element ECO_MOBILIER Element PROPERTIES Element PART_LIST_EXCLUSIVE Element PART_LIST_REF Element SALES_NUMBER Element DETAIL_INFOS Element CLASSIFICATIONS Element TYPE_KEY Element ITEM_TEXT Element BASIC_PROFILE Element MINIMUM_DELIVERY_TIME Element VOLUME Element WEIGHT_NETTO Element WEIGHT_BRUTTO Element VALID_UNTIL Element VALID_FROM Element CATALOG_PAGE Element ITEM_IDENTIFICATION Element EAN_NUMBER Element EDP_NUMBER Element ADDITIONAL_ITEMS Element DECISIONS Element ADDITIONAL_PRICE_GROUP Element PRICE_TYPE_REF Element PRICE_FEATURE_GROUP_BASE_PRICE_REF Element Sequence ITEM_REF Element Sequence Choice Sequence ITEM Element
Overview
ITEM 1..∞
This element is used to define items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes.

The characteristic features/properties, or a reference via ITEM_REF to another series (SERIE_NO) and the item number of valid for the other series, are stored for each item. If the ITEM_REF element contains a value, the item is a reference item belonging to another series, otherwise the item belongs to the series in which it is specified at this position.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
TYPE_NO required Restriction of xs:string
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Sequence
Choice
Sequence
ITEM_REF
This element is used to reference an item.
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:99999]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element is used to reference a base price group. A base Price group is a PRICE_FEATURE_GROUP (path 1) where the ADDITIONAL_PRICE element has a value of 0.

An item must be assigned to precisely one base price group. Additional price groups are assigned via the ADDITIONAL_PRICE_GROUP element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
This element is used to specify the item price and additional price data.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
The prices according to their price groups (price field, element PRICE_FIELD) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: EUR -9.00 corresponds to -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_BASE_PRICE_REF of the item does not contain an element for the corresponding price group. 		D integer
P
M [-99999999:999999999]
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used to enter minimum prices or base prices. The prices are entered in accordance with their price groups (price field, PRICE_FIELD).

If the price type referenced by the item is not base price-dependent, the minimum price is entered, otherwise a base price. If a price of 0 is entered, the item does not have a minimum or base price, but is also not free of charge.

The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). = 30000 Cent). Identification numbers are entered without decimal places. Settlement points are entered with exactly 2 decimal places (excluding the decimal point itself).

If an item within a price group is unavailable, no data record of the corresponding price group is specified.

The base price is always a piece price. If an item is assigned a base price calculation, the same item cannot be assigned a minimum price.
The end price of the item generally consists of the base price plus the calculated infill price in consideration of the logic defined by the price type (path 3/ PRICE_TYPE_REF). Base prices can only be assigned to items for which at least one dimension is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit (path 5/ BASIC_PRICE_UNIT) must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions. To calculate the price for the infill dimensions, the logic from the price type in conjunction with the item price (path 5/ PRICE) is used. If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

This element must be specified for an item if the item's price type (Path 3/PRICE_TYPE_REF) is base price-dependent.

Element paths:
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: GLOBAL_DEFINITION
Path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_EF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (path 1/ PRICE_TYPE_REF) is defined as base price-dependent, the dimensions for the base price unit must be specified here. The base price unit depends on the number of dimensions specified as "1 or true" in the price type.

If, for example, the base price of a length-dependent item relates to 1.5 m, the value of 1500 bees is entered in this element. In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³].
If they are piece prices, i.e. no dimension was specified as ?1?, the value 0 must be entered in this element.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_SINCE must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
ADDITIONAL_PRICE_GROUP 0..∞
This element is used to reference PRICE_FEATURE_GROUPS with additional price groups. The base price group that must be referenced precisely 1x by an item is specified in the PRICE_FEATURE_GROUP_BASE_PRICE_REF element.

All items that reference the identical PRICE_FEATURE_GROUP must also reference the same calculation group (CALC_GROUP_REF) and exchange ID (EXCHANGE_ID_REF).

The following combinations are permitted when assigning different price types to items and surcharges for the same item:

Item | Surcharge
Unit price | Unit price
length-dependent | length-dependent
length-dependent | Unit price

The following combination is not permitted:

Item | Surcharge
Unit price | length-dependent
Sequence
PRICE_FEATURE_GROUP_REF
This element is used to reference a surcharge group. Surcharge groups referenced here must not be used as design ranges.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
This element is used to specify the item price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of minus EUR 9.00 is entered as -900) 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
DECISIONS optional
This element is used to combine product item-specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to an item.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
ADDITIONAL_ITEMS optional
This element is used to assign additional items. It defines quantities of optional and/or necessary additional items, from which the additional items will be selected during planning.
Sequence
OPTIONAL_ITEMS optional
This element is used to reference optional additional items. Multiple items may be selected from the available optional additional items.
Sequence
OPTIONAL_ITEM_GROUP 1..9
This element is used to form a group of optional items.
SET_NO required Restriction of xs:positiveInteger
A quantity of optional additional items can be defined for each item. Multiple additional items may be selected from the available optional additional items if MULTIPLE_CHOICE = true. If only one item is defined within a quantity of optional additional items, the item will be selected automatically.

1-9= status for defining the quantities of optional additional items. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
This attribute specifies whether multiple selections within the group are permitted.

true = multiple selection permitted 		D boolean
P
M
Sequence
GROUP_TITLE optional languagetext60 Complex Type
This element is used to designate the group of optional items.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
ITEM_REF 1..∞
This element is used to reference an optional additional item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. (e.g. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY optional Restriction of xs:nonNegativeInteger
Quantity of additional items. Suggested value for planning systems. The quantity is a non-binding suggestion for optional additional items; for mandatory items, the quantity is binding during planning. D nonNegativeInteger
P
M [1:999]
MANDATORY_ITEMS optional
This element is used to assign necessary additional items to an item. Only one additional item may be selected from the available additional items. An item may however be assigned multiple quantities of necessary additional items.
If only one additional item is assigned to a quantity, the item will be selected automatically.
Sequence
MANDATORY_ITEM_GROUP 1..9
This element is used to form a group of necessary items. Precisely one item must be selected from this group.
SET_NO required Restriction of xs:positiveInteger
For each item, a quantity of optional additional items and nine quantities
of mandatory additional items can be defined.
Multiple additional items may be selected from the available optional additional items.
For each quantity, only one item may be selected from the quantities
of mandatory additional items.
If only one item is defined within a quantity of mandatory additional items,
the item will be selected automatically.

1-9= status for defining the quantities of mandatory additional items.

This element is not necessary, but is retained in IDM 2.0 for reasons of compatibility to ISM 1.7. 		D positiveInteger
P
M [1:9]
Sequence
ITEM_REF 1..∞
This element references an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. D string
P
M [1:30]
MANDATORY_QUANTITY optional Restriction of xs:nonNegativeInteger
Quantity of additional items. Suggested value for planning systems. D nonNegativeInteger
P
M [1:999]
EDP_NUMBER optional Restriction of xs:string
This element is used to enter the (internal) item EDP number of the manufacturer.
If the EDP_NUMBER is used, it must be unique within a series and created for all items. 		D string
P
M [1:30]
EAN_NUMBER optional Restriction of xs:string
If existing, the EAN number of the item must be entered in this element. D string
P
M [1:15]
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article:
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
V = Settlement block
P = Settlement position
1 = Planning proposal
2 = Preferred combination

The following applies for the planning proposal (1):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations:
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

D string
P [BEKSMZVP12]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
This element should be used to specify the item's catalogue page. This information helps to quickly find an item within the printed catalogue.
Items may feature on multiple catalogue pages. In this case, the number of the page on which the item appears first should be used. In the case of accessories, it makes sense to use the page that contains a full description of the item. This is often done in the section/register "accessories". 		D string
P
M [1:7]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item gross weight (100 g), i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item net weight (100 g), i.e. including packaging material, i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
This element is used to specify the item volume [dm³] including packaging material. (e.g. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element is used to specify the minimum delivery time in weeks.
The minimum delivery time is for information, the planning software does not interfere with the order controlling (e.g. postponement of the order, partial delivery) 		D nonNegativeInteger
P
M [0:999]
BASIC_PROFILE optional
This element is used to specify the basic shapes assigned to an item.
Sequence
Choice
CARCASE_BASIC_SHAPE
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation. If there are no parameter values for items with basic shape = 0, parameters must be filled with a value of 0.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
997 = items for which neither a basic shape nor a real visual presentation are delivered. This requires the elementsSUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO to be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.
This element must be filled if the BASIC_PROFILE_SHAPE is empty.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
999 = items that are relevant for visual presentation, but for which no basic shape exists and that are visualised by a graphic model (also see elementMODELING_GRAPHIC_ID). The parameters for width, height and depth must also be specified when using real visual presentations. Additionally, the elementsSERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO can be used to store information for this item.
998 = items for which there is no basic shape or real visual presentation.
997 = items for which neither a basic shape nor a real visual presentation are delivered. For this, the SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO must be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.

This element must be filled if the BASIC_PROFILE_SHAPE is empty. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Here, a basic shape that describes the profile geometry is referenced. The dimensions of the profile must be specified in accordance with the parameters specified in the basic shape.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
This element is used to specify the number of the basic profile shape. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
The feature and option code for the profile shape option are specified here.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify a feature. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option that is to be assigned to a basic profile shape. D string
P
M [1:30]
BASIC_SHAPE_PARAMETERS
This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

For items with a basic shape number = 0 that do not have any dimensions, such as calculation positions (e.g. surcharge for feet shape), the parameters must be filled with 0.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.

If an item that is not relevant for visual presentation is created and the item does not have any parameters, then the superordinate node BASIC_PROFILE BASIC_PROFILE can be omitted instead of filling the parameters with 0.
BASIC_SHAPE_NAME required Restriction of xs:string
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
ITEM_DIMENSIONAL_DRAWING
This element is used to specify a dimensional drawing for which the parameters are specified in the DIMENSIONAL_PARAMETERS element. The dimensional drawing describes additional items.
The element must not be created if the BASIC_PROFILE_SHAPE already exists.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
This element is used to specify a dimensional drawing for which the parameters are specified in the PARAMETERS element. The dimensional drawing describes additional items.
Even if this element is not specified, at least the dimensions of the bounding box (b, h, t) must be specified in the BASIC_PROFILES/PARAMETERS element.
The element must not be created if the BASIC_PROFILE_SHAPE already exists. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
The name of a document or a reference to a document is specified in this field.

The documents may e.g. contain additional technical information about the installation or templates for cutouts and drilling.
If only the document name is specified, the document must be delivered with the data. A document reference is specified for an URI/URL.

If a document reference is specified in this element, the NAME element must be set to 23. The value of 23 stands for document reference (see value tables). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS

This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements DIMENSIONAL_NOMINAL_VALUE (path 1), DIMENSIONAL_FROM (path 1) and DIMENSIONAL_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

If the created item is an electrical appliance, the dimensions B, H and T of that appliance must be specified.

Width, height and depth must also be specified, the planning systems use the term length (depending on the model key) for T=depth.

If absolutely necessary (e.g. for diagonal corner infill pieces), the values for basic shapes 21, 24 and 25 may be specified in 1/10 mm. Example: 27.33 mm => element volume: 0027,3

This element can only be omitted from an item if the item has basic shape number 0 assigned to it and no dimensions, such as for calculation positions (e.g. surcharge for handle).

Path1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Sequence
DIMENSIONAL_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.
DIMENSIONAL_NAME required Restriction of xs:string
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
ITEM_TEXT
This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. At least one item text must be specified for each item.

The following text combinations are permitted:
- Short text;
- Short text + recommended text;
- Short text + recommended text + long text;
- Short text + long text (only if no recommended text is been stored).

The short text may consist of three lines.
Sequence
SHORT_TEXT
This element contains short texts.
Sequence
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2
ISO_LANGUAGE_ID required Restriction of xs:language
410--0--NEW Version Beta 2.0 Build 2, K. Richter 26.03.2014
Sequence
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5
SEQUENCE_NO required Restriction of xs:positiveInteger
410--0--NEW Version Beta 2.0 Build 5
Sequence
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
This element is used to define the item's model code.

The values for model codes can be found in a table in the introduction, section Model code

The model code is specified precisely once for each item.
Sequence
TK_TYPE Restriction of xs:positiveInteger
A value from the column no. intable "model code" in the introduction is entered here. D poisitiveInteger
P
M [1000:2000]
TK_CLASS optional Restriction of xs:nonNegativeInteger
A value from colum type in table "model codes" is entered here. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
TK_INFO optional Restriction of xs:nonNegativeInteger
A value from colum no. in table " Variation code" is entered here. D nonNegativeInteger
P [0-8]0
M [00-80]
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) must be specified within a preparation rule, there must not be any simultaneous referencing to an assessment (no value for RESTRICTION_NO). 		D positiveInteger
P
M [1:9999999999]
SALES_NUMBER optional Restriction of xs:string
If existing, the sale number of the item must be entered in this element. D string
P
M [1:30]
PART_LIST_REF optional

This element references a piece list contained in an item.

The item passes on its options (OPTIONS) to the sub positions if these have identical features (FEATURES) in the feature class associated with the respective sub-position.

The sub-positions can have rules that determine whether a sub-position is displayed. The sub-position is then specified with the corresponding piece quantity.

Items that are only permitted as sub-positions are marked separately (element PARTS_LIST_EXCLUSIVE).

If the item is a catalogue item (ITEM_IDENTIFICATION 'K'), prices may be assigned to the item.The total price of the catalogue item results from the price assigned to it and the prices of the components from the piece list.

The following applies for the planning proposal (ITEM_IDENTIFICATION '1'):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations (ITEM_IDENTIFICATION '2'):
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

PART_LIST_KEY required Restriction of xs:string
This attribute is used to specify the piece list key. D string
P
M [1:30]
PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
This element is used to identify whether the item is only permitted as a sub position within a piece list (value set to 1 (true)).
The value 0 (false) has the same meaning as no value at all. 		D boolean
P
M
PROPERTIES optional
This element is used to combine item-specific characteristic features/properties.
Sequence
PROPERTY_REF 1..∞
This element is used to reference a characteristic feature defined under GLOBAL_DEFINITION/PROPERTIES
PROPERTY_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a characteristic feature. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

This attribute is used to specify the value of the characteristic feature.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

D string P [0-9]{11} M [11:11]

Information can be found at the following link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

PACKAGE_LIST optional

This element is used to specify the packaged pieces per item. An optimisation of packaged items for purchases is not possible.

The width, depth and height must be specified for each packaged item in full mm figures. The weight is specified in decimal kg.

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

Sequence
PACKAGE_LIST_POS 1..∞
The properties of a packaged item on the list are specified here.
SEQUENCE_NO required Restriction of xs:positiveInteger
This element serves the purpose of an assigning unique number within the list. D positiveInteger
P
M
Sequence
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
This element contains the names on the packaged items list.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
The description of the list of packaged items is entered here.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
WIDTH Restriction of xs:nonNegativeInteger

The width is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
DEPTH Restriction of xs:nonNegativeInteger

The depth is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
HEIGHT Restriction of xs:nonNegativeInteger

The height is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
WEIGHT xs:decimal

The weight is specified in this element.

 D decimal
P
M
EAN_NUMBER optional Restriction of xs:string

The EAN number is specified in this element.

 D string
P
M [1:15]
MATERIAL_NUMBER optional Restriction of xs:string

The material number is specified in this element.

 D string
P
M [1:15]
DECISIONS optional

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

This element is used to reference rules.

Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a list of packaged items.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
TYPE_NO Restriction of xs:string required
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO Restriction of xs:positiveInteger optional

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Remarks

Source
<xs:element name="ITEM" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:choice>
        <xs:sequence>
          <xs:element name="ITEM_REF">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:attribute name="TYPE_NO" use="required">
                <xs:annotation>
                  <xs:documentation>401--0--NEW</xs:documentation>
                  <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:minLength value="1" />
                    <xs:maxLength value="30" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:attribute>
              <xs:attribute name="SERIE_NO" use="required">
                <xs:annotation>
                  <xs:documentation>200--1--Satzart</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
        </xs:sequence>
        <xs:sequence>
          <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
            <xs:annotation>
              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence minOccurs="0">
                <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                  <xs:annotation>
                    <xs:documentation>450/470--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="PRICE_FIELD">
                        <xs:annotation>
                          <xs:documentation>450--4--Preisfeld</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="PRICE">
                        <xs:annotation>
                          <xs:documentation>450--5--Preis</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:integer">
                            <xs:minInclusive value="-99999999" />
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>470--4--Preis</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:integer">
                            <xs:minInclusive value="-99999999" />
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="VALID_FROM" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:date" />
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="VALID_UNTIL" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:date" />
                        </xs:simpleType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
              <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                <xs:annotation>
                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="99999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
          <xs:element name="PRICE_TYPE_REF">
            <xs:annotation>
              <xs:documentation>400/407--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:attribute name="PRICE_TYPE_NO" use="required">
                <xs:annotation>
                  <xs:documentation>400/407--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
          <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="PRICE_FEATURE_GROUP_REF">
                  <xs:annotation>
                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>460--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="PRICE_FIELD">
                              <xs:annotation>
                                <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PRICE">
                              <xs:annotation>
                                <xs:documentation>460--5--Preis</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:integer">
                                  <xs:minInclusive value="-99999999" />
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="99999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
                <xs:element name="PRICE_TYPE_REF">
                  <xs:annotation>
                    <xs:documentation>407--5--Preisart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="PRICE_TYPE_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>407--5--Preisart</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="DECISIONS" minOccurs="0">
            <xs:annotation>
              <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="DECISION_REF" maxOccurs="unbounded">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="DECISION_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>291--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="9999999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
            <xs:annotation>
              <xs:documentation>406--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                            </xs:element>
                            <xs:element name="ITEM_REF" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="SERIE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>406--0--NEW</xs:documentation>
                                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="TYPE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>406--0--NEW</xs:documentation>
                                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:minLength value="1" />
                                      <xs:maxLength value="30" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                  <xs:annotation>
                                    <xs:documentation>406--7--Anzahl</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:attribute name="SET_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                          <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="ITEM_REF" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="SERIE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>406--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="TYPE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>406--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:minLength value="1" />
                                      <xs:maxLength value="30" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                  <xs:annotation>
                                    <xs:documentation>406--7--Anzahl</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:attribute name="SET_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>406--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="EDP_NUMBER" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--10--EDV_Nummer</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="EAN_NUMBER" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--11--EAN_Nummer</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="ITEM_IDENTIFICATION">
            <xs:annotation>
              <xs:documentation>400--14--Artikelkennung</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[BEKSMZVP12]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="CATALOG_PAGE" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--15--Katalog_Seite</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="7" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="VALID_FROM" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:date" />
            </xs:simpleType>
          </xs:element>
          <xs:element name="VALID_UNTIL" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:date" />
            </xs:simpleType>
          </xs:element>
          <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--20--Gewicht</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="WEIGHT_NETTO" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--20--Gewicht</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="VOLUME" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--21--Volumen</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="BASIC_PROFILE" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:choice>
                  <xs:element name="CARCASE_BASIC_SHAPE">
                    <xs:annotation>
                      <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType mixed="true">
                            <xs:sequence>
                              <xs:element name="OPTION_REF">
                                <xs:annotation>
                                  <xs:documentation>430--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>430--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>430--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:pattern value="[\S ]{1,5}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="BASIC_SHAPE_PARAMETERS">
                          <xs:annotation>
                            <xs:documentation>500--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                    <xs:annotation>
                                      <xs:documentation>500--0--Parameter</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>500--5--Nennwert</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="BASIC_SHAPE_FROM">
                                    <xs:annotation>
                                      <xs:documentation>500--6--Von</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="BASIC_SHAPE_TO">
                                    <xs:annotation>
                                      <xs:documentation>500--7--Bis</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                    <xs:annotation>
                                      <xs:documentation>500--8--Schrittweite</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                    <xs:annotation>
                      <xs:documentation>400--32--Massbild</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="240" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DIMENSIONAL_PARAMETERS">
                          <xs:annotation>
                            <xs:documentation>500--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                    <xs:annotation>
                                      <xs:documentation>500--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>500--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="DIMENSIONAL_FROM">
                                    <xs:annotation>
                                      <xs:documentation>500--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="DIMENSIONAL_TO">
                                    <xs:annotation>
                                      <xs:documentation>500--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                    <xs:annotation>
                                      <xs:documentation>500--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--32--Massbild</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="20" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="ITEM_TEXT">
            <xs:annotation>
              <xs:documentation>410--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="SHORT_TEXT">
                  <xs:annotation>
                    <xs:documentation>410--5--Texttype</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="LANGUAGE" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="TEXT_LINE" maxOccurs="3">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="TEXT">
                                    <xs:annotation>
                                      <xs:documentation>410--6--Textzeile</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[\S ]{1,30}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="SEQUENCE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>410--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger" />
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                            <xs:annotation>
                              <xs:documentation>410--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:language">
                                <xs:pattern value="[A-Za-z]{1,3}" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>410--5--Texttype</xs:documentation>
                  </xs:annotation>
                </xs:element>
                <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>410--5--Texttype</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="TYPE_KEY">
            <xs:annotation>
              <xs:documentation>445--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="2000" />
                      <xs:minInclusive value="1000" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="TK_CLASS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="TK_INFO" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-8]0" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="CLASSIFICATIONS" minOccurs="0">
            <xs:annotation>
              <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="ECLASS">
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="ECLASS_NO">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:totalDigits value="8" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="DETAIL_INFOS" minOccurs="0">
            <xs:annotation>
              <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="DETAIL_INFO_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:maxInclusive value="999999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                    <xs:attribute name="DECISION_NO" use="optional">
                      <xs:annotation>
                        <xs:documentation>291--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="9999999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="SALES_NUMBER" minOccurs="0">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="PART_LIST_REF" minOccurs="0">
            <xs:annotation>
              <xs:documentation>401--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:attribute name="PART_LIST_KEY" use="required">
                <xs:annotation>
                  <xs:documentation>--0--NEW</xs:documentation>
                  <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:maxLength value="30" />
                    <xs:minLength value="1" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
          <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
            <xs:annotation>
              <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:boolean" />
            </xs:simpleType>
          </xs:element>
          <xs:element name="PROPERTIES" minOccurs="0">
            <xs:annotation>
              <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                  <xs:annotation>
                    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="PROPERTY_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                    <xs:attribute name="VALUE" use="required">
                      <xs:annotation>
                        <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="ECO_MOBILIER" minOccurs="0">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[0-9]{11}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
            <xs:annotation>
              <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="WIDTH">
                        <xs:annotation>
                          <xs:documentation>400--20--Gewicht</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="DEPTH">
                        <xs:annotation>
                          <xs:documentation>400--20--Gewicht</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="HEIGHT">
                        <xs:annotation>
                          <xs:documentation>400--20--Gewicht</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="WEIGHT" type="xs:decimal">
                        <xs:annotation>
                          <xs:documentation>400--20--Gewicht</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="EAN_NUMBER" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="DECISIONS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="DECISION_REF" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="DECISION_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>291--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9999999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                    <xs:attribute name="SEQUENCE_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger" />
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
        </xs:sequence>
      </xs:choice>
    </xs:sequence>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_REF Element
Description
This element is used to reference an item.
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF
This element is used to reference an item.
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:99999]
Attributes
Name Type Use Default Fixed Description
TYPE_NO Restriction of xs:string required
This attribute is used to reference an item with an item number. D string
P
M [1:30]
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:99999]
Source
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
Description
This element is used to reference a base price group. A base Price group is a PRICE_FEATURE_GROUP (path 1) where the ADDITIONAL_PRICE element has a value of 0.

An item must be assigned to precisely one base price group. Additional price groups are assigned via the ADDITIONAL_PRICE_GROUP element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
Namespace (none)
Diagram
ITEM_PRICE Element Sequence PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
Overview
PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element is used to reference a base price group. A base Price group is a PRICE_FEATURE_GROUP (path 1) where the ADDITIONAL_PRICE element has a value of 0.

An item must be assigned to precisely one base price group. Additional price groups are assigned via the ADDITIONAL_PRICE_GROUP element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
This element is used to specify the item price and additional price data.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
The prices according to their price groups (price field, element PRICE_FIELD) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: EUR -9.00 corresponds to -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_BASE_PRICE_REF of the item does not contain an element for the corresponding price group. 		D integer
P
M [-99999999:999999999]
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used to enter minimum prices or base prices. The prices are entered in accordance with their price groups (price field, PRICE_FIELD).

If the price type referenced by the item is not base price-dependent, the minimum price is entered, otherwise a base price. If a price of 0 is entered, the item does not have a minimum or base price, but is also not free of charge.

The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). = 30000 Cent). Identification numbers are entered without decimal places. Settlement points are entered with exactly 2 decimal places (excluding the decimal point itself).

If an item within a price group is unavailable, no data record of the corresponding price group is specified.

The base price is always a piece price. If an item is assigned a base price calculation, the same item cannot be assigned a minimum price.
The end price of the item generally consists of the base price plus the calculated infill price in consideration of the logic defined by the price type (path 3/ PRICE_TYPE_REF). Base prices can only be assigned to items for which at least one dimension is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit (path 5/ BASIC_PRICE_UNIT) must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions. To calculate the price for the infill dimensions, the logic from the price type in conjunction with the item price (path 5/ PRICE) is used. If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

This element must be specified for an item if the item's price type (Path 3/PRICE_TYPE_REF) is base price-dependent.

Element paths:
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: GLOBAL_DEFINITION
Path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_EF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (path 1/ PRICE_TYPE_REF) is defined as base price-dependent, the dimensions for the base price unit must be specified here. The base price unit depends on the number of dimensions specified as "1 or true" in the price type.

If, for example, the base price of a length-dependent item relates to 1.5 m, the value of 1500 bees is entered in this element. In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³].
If they are piece prices, i.e. no dimension was specified as ?1?, the value 0 must be entered in this element.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_SINCE must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Attributes
Name Type Use Default Fixed Description
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
This attribute is used to reference a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Source
<xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence minOccurs="0">
      <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>450/470--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>450--4--Preisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE">
              <xs:annotation>
                <xs:documentation>450--5--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
              <xs:annotation>
                <xs:documentation>470--4--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_PRICE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element : ITEM_PRICE Element
Description
This element is used to specify the item price and additional price data.
Namespace (none)
Diagram
VALID_UNTIL Element VALID_FROM Element BASIC_PRICE_UNIT Element PRICE_MINIMUM_BASIC Element PRICE Element PRICE_FIELD Element Sequence ITEM_PRICE Element
Overview
ITEM_PRICE 0..∞
This element is used to specify the item price and additional price data.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
The prices according to their price groups (price field, element PRICE_FIELD) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: EUR -9.00 corresponds to -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_BASE_PRICE_REF of the item does not contain an element for the corresponding price group. 		D integer
P
M [-99999999:999999999]
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used to enter minimum prices or base prices. The prices are entered in accordance with their price groups (price field, PRICE_FIELD).

If the price type referenced by the item is not base price-dependent, the minimum price is entered, otherwise a base price. If a price of 0 is entered, the item does not have a minimum or base price, but is also not free of charge.

The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). = 30000 Cent). Identification numbers are entered without decimal places. Settlement points are entered with exactly 2 decimal places (excluding the decimal point itself).

If an item within a price group is unavailable, no data record of the corresponding price group is specified.

The base price is always a piece price. If an item is assigned a base price calculation, the same item cannot be assigned a minimum price.
The end price of the item generally consists of the base price plus the calculated infill price in consideration of the logic defined by the price type (path 3/ PRICE_TYPE_REF). Base prices can only be assigned to items for which at least one dimension is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit (path 5/ BASIC_PRICE_UNIT) must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions. To calculate the price for the infill dimensions, the logic from the price type in conjunction with the item price (path 5/ PRICE) is used. If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

This element must be specified for an item if the item's price type (Path 3/PRICE_TYPE_REF) is base price-dependent.

Element paths:
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: GLOBAL_DEFINITION
Path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_EF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (path 1/ PRICE_TYPE_REF) is defined as base price-dependent, the dimensions for the base price unit must be specified here. The base price unit depends on the number of dimensions specified as "1 or true" in the price type.

If, for example, the base price of a length-dependent item relates to 1.5 m, the value of 1500 bees is entered in this element. In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³].
If they are piece prices, i.e. no dimension was specified as ?1?, the value 0 must be entered in this element.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_SINCE must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Source
<xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450/470--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>450--4--Preisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE">
        <xs:annotation>
          <xs:documentation>450--5--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
        <xs:annotation>
          <xs:documentation>470--4--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FIELD Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE_FIELD Element
Description
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
Source
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--4--Preisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE Element
Description
The prices according to their price groups (price field, element PRICE_FIELD) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: EUR -9.00 corresponds to -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_BASE_PRICE_REF of the item does not contain an element for the corresponding price group. 		D integer
P
M [-99999999:999999999]
Namespace (none)
Type
Restriction of xs:integer
Diagram
PRICE Element
Overview
PRICE Restriction of xs:integer
The prices according to their price groups (price field, element PRICE_FIELD) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: EUR -9.00 corresponds to -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_BASE_PRICE_REF of the item does not contain an element for the corresponding price group. 		D integer
P
M [-99999999:999999999]
Source
<xs:element name="PRICE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--5--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_MINIMUM_BASIC Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE_MINIMUM_BASIC Element
Description
This element is used to enter minimum prices or base prices. The prices are entered in accordance with their price groups (price field, PRICE_FIELD).

If the price type referenced by the item is not base price-dependent, the minimum price is entered, otherwise a base price. If a price of 0 is entered, the item does not have a minimum or base price, but is also not free of charge.

The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). = 30000 Cent). Identification numbers are entered without decimal places. Settlement points are entered with exactly 2 decimal places (excluding the decimal point itself).

If an item within a price group is unavailable, no data record of the corresponding price group is specified.

The base price is always a piece price. If an item is assigned a base price calculation, the same item cannot be assigned a minimum price.
The end price of the item generally consists of the base price plus the calculated infill price in consideration of the logic defined by the price type (path 3/ PRICE_TYPE_REF). Base prices can only be assigned to items for which at least one dimension is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit (path 5/ BASIC_PRICE_UNIT) must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions. To calculate the price for the infill dimensions, the logic from the price type in conjunction with the item price (path 5/ PRICE) is used. If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

This element must be specified for an item if the item's price type (Path 3/PRICE_TYPE_REF) is base price-dependent.

Element paths:
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: GLOBAL_DEFINITION
Path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_EF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
Namespace (none)
Type
Restriction of xs:integer
Diagram
PRICE_MINIMUM_BASIC Element
Overview
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used to enter minimum prices or base prices. The prices are entered in accordance with their price groups (price field, PRICE_FIELD).

If the price type referenced by the item is not base price-dependent, the minimum price is entered, otherwise a base price. If a price of 0 is entered, the item does not have a minimum or base price, but is also not free of charge.

The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). = 30000 Cent). Identification numbers are entered without decimal places. Settlement points are entered with exactly 2 decimal places (excluding the decimal point itself).

If an item within a price group is unavailable, no data record of the corresponding price group is specified.

The base price is always a piece price. If an item is assigned a base price calculation, the same item cannot be assigned a minimum price.
The end price of the item generally consists of the base price plus the calculated infill price in consideration of the logic defined by the price type (path 3/ PRICE_TYPE_REF). Base prices can only be assigned to items for which at least one dimension is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit (path 5/ BASIC_PRICE_UNIT) must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions. To calculate the price for the infill dimensions, the logic from the price type in conjunction with the item price (path 5/ PRICE) is used. If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

This element must be specified for an item if the item's price type (Path 3/PRICE_TYPE_REF) is base price-dependent.

Element paths:
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: GLOBAL_DEFINITION
Path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_EF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
Source
<xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>470--4--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_PRICE_UNIT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : BASIC_PRICE_UNIT Element
Description
If a price type (path 1/ PRICE_TYPE_REF) is defined as base price-dependent, the dimensions for the base price unit must be specified here. The base price unit depends on the number of dimensions specified as "1 or true" in the price type.

If, for example, the base price of a length-dependent item relates to 1.5 m, the value of 1500 bees is entered in this element. In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³].
If they are piece prices, i.e. no dimension was specified as ?1?, the value 0 must be entered in this element.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BASIC_PRICE_UNIT Element
Overview
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (path 1/ PRICE_TYPE_REF) is defined as base price-dependent, the dimensions for the base price unit must be specified here. The base price unit depends on the number of dimensions specified as "1 or true" in the price type.

If, for example, the base price of a length-dependent item relates to 1.5 m, the value of 1500 bees is entered in this element. In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³].
If they are piece prices, i.e. no dimension was specified as ?1?, the value 0 must be entered in this element.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
Source
<xs:element name="BASIC_PRICE_UNIT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : VALID_FROM Element
Description
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_SINCE must not contain a date prior to the catalogue start date. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_SINCE must not contain a date prior to the catalogue start date. 		D date
P
M
Source
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : VALID_UNTIL Element
Description
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Source
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PRICE_TYPE_REF Element
Description
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
Namespace (none)
Diagram
PRICE_TYPE_REF Element
Overview
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
PRICE_TYPE_NO Restriction of xs:positiveInteger required
This attribute identifies a price type. D positiveInteger
P
M [1:999]
Source
<xs:element name="PRICE_TYPE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400/407--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400/407--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ADDITIONAL_PRICE_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ADDITIONAL_PRICE_GROUP Element
Description
This element is used to reference PRICE_FEATURE_GROUPS with additional price groups. The base price group that must be referenced precisely 1x by an item is specified in the PRICE_FEATURE_GROUP_BASE_PRICE_REF element.

All items that reference the identical PRICE_FEATURE_GROUP must also reference the same calculation group (CALC_GROUP_REF) and exchange ID (EXCHANGE_ID_REF).

The following combinations are permitted when assigning different price types to items and surcharges for the same item:

Item | Surcharge
Unit price | Unit price
length-dependent | length-dependent
length-dependent | Unit price

The following combination is not permitted:

Item | Surcharge
Unit price | length-dependent
Namespace (none)
Diagram
PRICE_TYPE_REF Element PRICE_FEATURE_GROUP_REF Element Sequence ADDITIONAL_PRICE_GROUP Element
Overview
ADDITIONAL_PRICE_GROUP 0..∞
This element is used to reference PRICE_FEATURE_GROUPS with additional price groups. The base price group that must be referenced precisely 1x by an item is specified in the PRICE_FEATURE_GROUP_BASE_PRICE_REF element.

All items that reference the identical PRICE_FEATURE_GROUP must also reference the same calculation group (CALC_GROUP_REF) and exchange ID (EXCHANGE_ID_REF).

The following combinations are permitted when assigning different price types to items and surcharges for the same item:

Item | Surcharge
Unit price | Unit price
length-dependent | length-dependent
length-dependent | Unit price

The following combination is not permitted:

Item | Surcharge
Unit price | length-dependent
Sequence
PRICE_FEATURE_GROUP_REF
This element is used to reference a surcharge group. Surcharge groups referenced here must not be used as design ranges.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
This element is used to specify the item price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of minus EUR 9.00 is entered as -900) 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
Source
<xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP_REF">
        <xs:annotation>
          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>460--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FIELD">
                    <xs:annotation>
                      <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE">
                    <xs:annotation>
                      <xs:documentation>460--5--Preis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="-99999999" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_TYPE_REF">
        <xs:annotation>
          <xs:documentation>407--5--Preisart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PRICE_TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>407--5--Preisart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element : PRICE_FEATURE_GROUP_REF Element
Description
This element is used to reference a surcharge group. Surcharge groups referenced here must not be used as design ranges.
Namespace (none)
Diagram
ITEM_PRICE Element Sequence PRICE_FEATURE_GROUP_REF Element
Overview
PRICE_FEATURE_GROUP_REF
This element is used to reference a surcharge group. Surcharge groups referenced here must not be used as design ranges.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
This element is used to specify the item price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of minus EUR 9.00 is entered as -900) 		D integer
P
M [-99999999:999999999]
Attributes
Name Type Use Default Fixed Description
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
Source
<xs:element name="PRICE_FEATURE_GROUP_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>460--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE">
              <xs:annotation>
                <xs:documentation>460--5--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_PRICE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element > PRICE_FEATURE_GROUP_REF Element : ITEM_PRICE Element
Description
This element is used to specify the item price.
Namespace (none)
Diagram
PRICE Element PRICE_FIELD Element Sequence ITEM_PRICE Element
Overview
ITEM_PRICE 1..∞
This element is used to specify the item price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of minus EUR 9.00 is entered as -900) 		D integer
P
M [-99999999:999999999]
Source
<xs:element name="ITEM_PRICE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>460--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE">
        <xs:annotation>
          <xs:documentation>460--5--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_FEATURE_GROUP_REF Element | ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FIELD Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element > PRICE_FEATURE_GROUP_REF Element > ITEM_PRICE Element : PRICE_FIELD Element
Description
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger
This element is used to specify the price field for the price. D positiveInteger
P
M [1:9999]
Source
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_REF Element | ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element > PRICE_FEATURE_GROUP_REF Element > ITEM_PRICE Element : PRICE Element
Description
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of minus EUR 9.00 is entered as -900) 		D integer
P
M [-99999999:999999999]
Namespace (none)
Type
Restriction of xs:integer
Diagram
PRICE Element
Overview
PRICE Restriction of xs:integer
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of minus EUR 9.00 is entered as -900) 		D integer
P
M [-99999999:999999999]
Source
<xs:element name="PRICE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>460--5--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_REF Element | ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element : PRICE_TYPE_REF Element
Description
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
Namespace (none)
Diagram
PRICE_TYPE_REF Element
Overview
PRICE_TYPE_REF
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
PRICE_TYPE_NO Restriction of xs:positiveInteger required
This attribute identifies a price type. D positiveInteger
P
M [1:999]
Source
<xs:element name="PRICE_TYPE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>407--5--Preisart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>407--5--Preisart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : DECISIONS Element
Description
This element is used to combine product item-specific rules.
Namespace (none)
Diagram
DECISION_REF Element Sequence DECISIONS Element
Overview
DECISIONS optional
This element is used to combine product item-specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to an item.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DECISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > DECISIONS Element : DECISION_REF Element
Description
This element is used to reference a rule assigned to an item.
Namespace (none)
Diagram
DECISION_REF Element
Overview
DECISION_REF 1..∞
This element is used to reference a rule assigned to an item.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
DECISION_NO Restriction of xs:positiveInteger required
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DECISION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DECISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ADDITIONAL_ITEMS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ADDITIONAL_ITEMS Element
Description
This element is used to assign additional items. It defines quantities of optional and/or necessary additional items, from which the additional items will be selected during planning.
Namespace (none)
Diagram
MANDATORY_ITEMS Element OPTIONAL_ITEMS Element Sequence ADDITIONAL_ITEMS Element
Overview
ADDITIONAL_ITEMS optional
This element is used to assign additional items. It defines quantities of optional and/or necessary additional items, from which the additional items will be selected during planning.
Sequence
OPTIONAL_ITEMS optional
This element is used to reference optional additional items. Multiple items may be selected from the available optional additional items.
Sequence
OPTIONAL_ITEM_GROUP 1..9
This element is used to form a group of optional items.
SET_NO required Restriction of xs:positiveInteger
A quantity of optional additional items can be defined for each item. Multiple additional items may be selected from the available optional additional items if MULTIPLE_CHOICE = true. If only one item is defined within a quantity of optional additional items, the item will be selected automatically.

1-9= status for defining the quantities of optional additional items. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
This attribute specifies whether multiple selections within the group are permitted.

true = multiple selection permitted 		D boolean
P
M
Sequence
GROUP_TITLE optional languagetext60 Complex Type
This element is used to designate the group of optional items.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
ITEM_REF 1..∞
This element is used to reference an optional additional item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. (e.g. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY optional Restriction of xs:nonNegativeInteger
Quantity of additional items. Suggested value for planning systems. The quantity is a non-binding suggestion for optional additional items; for mandatory items, the quantity is binding during planning. D nonNegativeInteger
P
M [1:999]
MANDATORY_ITEMS optional
This element is used to assign necessary additional items to an item. Only one additional item may be selected from the available additional items. An item may however be assigned multiple quantities of necessary additional items.
If only one additional item is assigned to a quantity, the item will be selected automatically.
Sequence
MANDATORY_ITEM_GROUP 1..9
This element is used to form a group of necessary items. Precisely one item must be selected from this group.
SET_NO required Restriction of xs:positiveInteger
For each item, a quantity of optional additional items and nine quantities
of mandatory additional items can be defined.
Multiple additional items may be selected from the available optional additional items.
For each quantity, only one item may be selected from the quantities
of mandatory additional items.
If only one item is defined within a quantity of mandatory additional items,
the item will be selected automatically.

1-9= status for defining the quantities of mandatory additional items.

This element is not necessary, but is retained in IDM 2.0 for reasons of compatibility to ISM 1.7. 		D positiveInteger
P
M [1:9]
Sequence
ITEM_REF 1..∞
This element references an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. D string
P
M [1:30]
MANDATORY_QUANTITY optional Restriction of xs:nonNegativeInteger
Quantity of additional items. Suggested value for planning systems. D nonNegativeInteger
P
M [1:999]
Source
<xs:element name="ADDITIONAL_ITEMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="ITEM_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                        <xs:annotation>
                          <xs:documentation>406--7--Anzahl</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SET_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MANDATORY_ITEMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                        <xs:annotation>
                          <xs:documentation>406--7--Anzahl</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SET_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTIONAL_ITEMS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element : OPTIONAL_ITEMS Element
Description
This element is used to reference optional additional items. Multiple items may be selected from the available optional additional items.
Namespace (none)
Diagram
OPTIONAL_ITEM_GROUP Element Sequence OPTIONAL_ITEMS Element
Overview
OPTIONAL_ITEMS optional
This element is used to reference optional additional items. Multiple items may be selected from the available optional additional items.
Sequence
OPTIONAL_ITEM_GROUP 1..9
This element is used to form a group of optional items.
SET_NO required Restriction of xs:positiveInteger
A quantity of optional additional items can be defined for each item. Multiple additional items may be selected from the available optional additional items if MULTIPLE_CHOICE = true. If only one item is defined within a quantity of optional additional items, the item will be selected automatically.

1-9= status for defining the quantities of optional additional items. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
This attribute specifies whether multiple selections within the group are permitted.

true = multiple selection permitted 		D boolean
P
M
Sequence
GROUP_TITLE optional languagetext60 Complex Type
This element is used to designate the group of optional items.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
ITEM_REF 1..∞
This element is used to reference an optional additional item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. (e.g. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY optional Restriction of xs:nonNegativeInteger
Quantity of additional items. Suggested value for planning systems. The quantity is a non-binding suggestion for optional additional items; for mandatory items, the quantity is binding during planning. D nonNegativeInteger
P
M [1:999]
Source
<xs:element name="OPTIONAL_ITEMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="ITEM_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                  <xs:annotation>
                    <xs:documentation>406--7--Anzahl</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SET_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTIONAL_ITEM_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPTIONAL_ITEMS Element : OPTIONAL_ITEM_GROUP Element
Description
This element is used to form a group of optional items.
Namespace (none)
Diagram
ITEM_REF Element LANGUAGE Element Sequence GROUP_TITLE Element Sequence OPTIONAL_ITEM_GROUP Element
Overview
OPTIONAL_ITEM_GROUP 1..9
This element is used to form a group of optional items.
SET_NO required Restriction of xs:positiveInteger
A quantity of optional additional items can be defined for each item. Multiple additional items may be selected from the available optional additional items if MULTIPLE_CHOICE = true. If only one item is defined within a quantity of optional additional items, the item will be selected automatically.

1-9= status for defining the quantities of optional additional items. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
This attribute specifies whether multiple selections within the group are permitted.

true = multiple selection permitted 		D boolean
P
M
Sequence
GROUP_TITLE optional languagetext60 Complex Type
This element is used to designate the group of optional items.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
ITEM_REF 1..∞
This element is used to reference an optional additional item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. (e.g. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY optional Restriction of xs:nonNegativeInteger
Quantity of additional items. Suggested value for planning systems. The quantity is a non-binding suggestion for optional additional items; for mandatory items, the quantity is binding during planning. D nonNegativeInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
SET_NO Restriction of xs:positiveInteger required
A quantity of optional additional items can be defined for each item. Multiple additional items may be selected from the available optional additional items if MULTIPLE_CHOICE = true. If only one item is defined within a quantity of optional additional items, the item will be selected automatically.

1-9= status for defining the quantities of optional additional items. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE xs:boolean required
This attribute specifies whether multiple selections within the group are permitted.

true = multiple selection permitted 		D boolean
P
M
Source
<xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="ITEM_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
            <xs:annotation>
              <xs:documentation>406--7--Anzahl</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SET_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
  </xs:complexType>
</xs:element>
See Also
OPTIONAL_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

GROUP_TITLE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPTIONAL_ITEMS Element > OPTIONAL_ITEM_GROUP Element : GROUP_TITLE Element
Description
This element is used to designate the group of optional items.
Namespace (none)
Type
languagetext60 Complex Type
Diagram
LANGUAGE Element Sequence GROUP_TITLE Element
Overview
GROUP_TITLE optional languagetext60 Complex Type
This element is used to designate the group of optional items.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPTIONAL_ITEM_GROUP Element | OPTIONAL_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPTIONAL_ITEMS Element > OPTIONAL_ITEM_GROUP Element : ITEM_REF Element
Description
This element is used to reference an optional additional item.
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF 1..∞
This element is used to reference an optional additional item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. (e.g. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY optional Restriction of xs:nonNegativeInteger
Quantity of additional items. Suggested value for planning systems. The quantity is a non-binding suggestion for optional additional items; for mandatory items, the quantity is binding during planning. D nonNegativeInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO Restriction of xs:string required
This element is used to enter the item code. (e.g. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY Restriction of xs:nonNegativeInteger optional
Quantity of additional items. Suggested value for planning systems. The quantity is a non-binding suggestion for optional additional items; for mandatory items, the quantity is binding during planning. D nonNegativeInteger
P
M [1:999]
Source
<xs:element name="ITEM_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
      <xs:annotation>
        <xs:documentation>406--7--Anzahl</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONAL_ITEM_GROUP Element | OPTIONAL_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MANDATORY_ITEMS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element : MANDATORY_ITEMS Element
Description
This element is used to assign necessary additional items to an item. Only one additional item may be selected from the available additional items. An item may however be assigned multiple quantities of necessary additional items.
If only one additional item is assigned to a quantity, the item will be selected automatically.
Namespace (none)
Diagram
MANDATORY_ITEM_GROUP Element Sequence MANDATORY_ITEMS Element
Overview
MANDATORY_ITEMS optional
This element is used to assign necessary additional items to an item. Only one additional item may be selected from the available additional items. An item may however be assigned multiple quantities of necessary additional items.
If only one additional item is assigned to a quantity, the item will be selected automatically.
Sequence
MANDATORY_ITEM_GROUP 1..9
This element is used to form a group of necessary items. Precisely one item must be selected from this group.
SET_NO required Restriction of xs:positiveInteger
For each item, a quantity of optional additional items and nine quantities
of mandatory additional items can be defined.
Multiple additional items may be selected from the available optional additional items.
For each quantity, only one item may be selected from the quantities
of mandatory additional items.
If only one item is defined within a quantity of mandatory additional items,
the item will be selected automatically.

1-9= status for defining the quantities of mandatory additional items.

This element is not necessary, but is retained in IDM 2.0 for reasons of compatibility to ISM 1.7. 		D positiveInteger
P
M [1:9]
Sequence
ITEM_REF 1..∞
This element references an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. D string
P
M [1:30]
MANDATORY_QUANTITY optional Restriction of xs:nonNegativeInteger
Quantity of additional items. Suggested value for planning systems. D nonNegativeInteger
P
M [1:999]
Source
<xs:element name="MANDATORY_ITEMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                  <xs:annotation>
                    <xs:documentation>406--7--Anzahl</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SET_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MANDATORY_ITEM_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > MANDATORY_ITEMS Element : MANDATORY_ITEM_GROUP Element
Description
This element is used to form a group of necessary items. Precisely one item must be selected from this group.
Namespace (none)
Diagram
ITEM_REF Element Sequence MANDATORY_ITEM_GROUP Element
Overview
MANDATORY_ITEM_GROUP 1..9
This element is used to form a group of necessary items. Precisely one item must be selected from this group.
SET_NO required Restriction of xs:positiveInteger
For each item, a quantity of optional additional items and nine quantities
of mandatory additional items can be defined.
Multiple additional items may be selected from the available optional additional items.
For each quantity, only one item may be selected from the quantities
of mandatory additional items.
If only one item is defined within a quantity of mandatory additional items,
the item will be selected automatically.

1-9= status for defining the quantities of mandatory additional items.

This element is not necessary, but is retained in IDM 2.0 for reasons of compatibility to ISM 1.7. 		D positiveInteger
P
M [1:9]
Sequence
ITEM_REF 1..∞
This element references an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. D string
P
M [1:30]
MANDATORY_QUANTITY optional Restriction of xs:nonNegativeInteger
Quantity of additional items. Suggested value for planning systems. D nonNegativeInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
SET_NO Restriction of xs:positiveInteger required
For each item, a quantity of optional additional items and nine quantities
of mandatory additional items can be defined.
Multiple additional items may be selected from the available optional additional items.
For each quantity, only one item may be selected from the quantities
of mandatory additional items.
If only one item is defined within a quantity of mandatory additional items,
the item will be selected automatically.

1-9= status for defining the quantities of mandatory additional items.

This element is not necessary, but is retained in IDM 2.0 for reasons of compatibility to ISM 1.7. 		D positiveInteger
P
M [1:9]
Source
<xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MANDATORY_QUANTITY" use="optional">
            <xs:annotation>
              <xs:documentation>406--7--Anzahl</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SET_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
MANDATORY_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > MANDATORY_ITEMS Element > MANDATORY_ITEM_GROUP Element : ITEM_REF Element
Description
This element references an item.
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF 1..∞
This element references an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. D string
P
M [1:30]
MANDATORY_QUANTITY optional Restriction of xs:nonNegativeInteger
Quantity of additional items. Suggested value for planning systems. D nonNegativeInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:999999]
TYPE_NO Restriction of xs:string required
This element is used to enter the item code. D string
P
M [1:30]
MANDATORY_QUANTITY Restriction of xs:nonNegativeInteger optional
Quantity of additional items. Suggested value for planning systems. D nonNegativeInteger
P
M [1:999]
Source
<xs:element name="ITEM_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MANDATORY_QUANTITY" use="optional">
      <xs:annotation>
        <xs:documentation>406--7--Anzahl</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
MANDATORY_ITEM_GROUP Element | MANDATORY_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDP_NUMBER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EDP_NUMBER Element
Description
This element is used to enter the (internal) item EDP number of the manufacturer.
If the EDP_NUMBER is used, it must be unique within a series and created for all items. 		D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDP_NUMBER Element
Overview
EDP_NUMBER optional Restriction of xs:string
This element is used to enter the (internal) item EDP number of the manufacturer.
If the EDP_NUMBER is used, it must be unique within a series and created for all items. 		D string
P
M [1:30]
Source
<xs:element name="EDP_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--10--EDV_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EAN_NUMBER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EAN_NUMBER Element
Description
If existing, the EAN number of the item must be entered in this element. D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
EAN_NUMBER Element
Overview
EAN_NUMBER optional Restriction of xs:string
If existing, the EAN number of the item must be entered in this element. D string
P
M [1:15]
Source
<xs:element name="EAN_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--11--EAN_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_IDENTIFICATION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_IDENTIFICATION Element
Description

This element is used to assign an identifier to the article:
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
V = Settlement block
P = Settlement position
1 = Planning proposal
2 = Preferred combination

The following applies for the planning proposal (1):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations:
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

D string
P [BEKSMZVP12]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
ITEM_IDENTIFICATION Element
Overview
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article:
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
V = Settlement block
P = Settlement position
1 = Planning proposal
2 = Preferred combination

The following applies for the planning proposal (1):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations:
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

D string
P [BEKSMZVP12]
M [1:1]
Source
<xs:element name="ITEM_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--14--Artikelkennung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BEKSMZVP12]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_PAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CATALOG_PAGE Element
Description
This element should be used to specify the item's catalogue page. This information helps to quickly find an item within the printed catalogue.
Items may feature on multiple catalogue pages. In this case, the number of the page on which the item appears first should be used. In the case of accessories, it makes sense to use the page that contains a full description of the item. This is often done in the section/register "accessories". 		D string
P
M [1:7]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_PAGE Element
Overview
CATALOG_PAGE optional Restriction of xs:string
This element should be used to specify the item's catalogue page. This information helps to quickly find an item within the printed catalogue.
Items may feature on multiple catalogue pages. In this case, the number of the page on which the item appears first should be used. In the case of accessories, it makes sense to use the page that contains a full description of the item. This is often done in the section/register "accessories". 		D string
P
M [1:7]
Source
<xs:element name="CATALOG_PAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--15--Katalog_Seite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="7" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_FROM Element
Description
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
Source
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TK_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_TYPE Element
Description
A value from the column no. intable "model code" in the introduction is entered here. D poisitiveInteger
P
M [1000:2000]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
TK_TYPE Element
Overview
TK_TYPE Restriction of xs:positiveInteger
A value from the column no. intable "model code" in the introduction is entered here. D poisitiveInteger
P
M [1000:2000]
Source
<xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="2000" />
      <xs:minInclusive value="1000" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_UNTIL Element
Description
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Source
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

WEIGHT_BRUTTO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : WEIGHT_BRUTTO Element
Description
This element is used to specify the item gross weight (100 g), i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
WEIGHT_BRUTTO Element
Overview
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item gross weight (100 g), i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="WEIGHT_BRUTTO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

WEIGHT_NETTO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : WEIGHT_NETTO Element
Description
This element is used to specify the item net weight (100 g), i.e. including packaging material, i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
WEIGHT_NETTO Element
Overview
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
This element is used to specify the item net weight (100 g), i.e. including packaging material, i.e. exclusive of packaging materials. (e.g. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="WEIGHT_NETTO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VOLUME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VOLUME Element
Description
This element is used to specify the item volume [dm³] including packaging material. (e.g. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
VOLUME Element
Overview
VOLUME optional Restriction of xs:nonNegativeInteger
This element is used to specify the item volume [dm³] including packaging material. (e.g. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="VOLUME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--21--Volumen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MINIMUM_DELIVERY_TIME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MINIMUM_DELIVERY_TIME Element
Description
This element is used to specify the minimum delivery time in weeks.
The minimum delivery time is for information, the planning software does not interfere with the order controlling (e.g. postponement of the order, partial delivery) 		D nonNegativeInteger
P
M [0:999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MINIMUM_DELIVERY_TIME Element
Overview
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element is used to specify the minimum delivery time in weeks.
The minimum delivery time is for information, the planning software does not interfere with the order controlling (e.g. postponement of the order, partial delivery) 		D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_PROFILE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : BASIC_PROFILE Element
Description
This element is used to specify the basic shapes assigned to an item.
Namespace (none)
Diagram
ITEM_DIMENSIONAL_DRAWING Element CARCASE_BASIC_SHAPE Element Choice Sequence BASIC_PROFILE Element
Overview
BASIC_PROFILE optional
This element is used to specify the basic shapes assigned to an item.
Sequence
Choice
CARCASE_BASIC_SHAPE
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation. If there are no parameter values for items with basic shape = 0, parameters must be filled with a value of 0.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
997 = items for which neither a basic shape nor a real visual presentation are delivered. This requires the elementsSUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO to be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.
This element must be filled if the BASIC_PROFILE_SHAPE is empty.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
999 = items that are relevant for visual presentation, but for which no basic shape exists and that are visualised by a graphic model (also see elementMODELING_GRAPHIC_ID). The parameters for width, height and depth must also be specified when using real visual presentations. Additionally, the elementsSERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO can be used to store information for this item.
998 = items for which there is no basic shape or real visual presentation.
997 = items for which neither a basic shape nor a real visual presentation are delivered. For this, the SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO must be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.

This element must be filled if the BASIC_PROFILE_SHAPE is empty. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Here, a basic shape that describes the profile geometry is referenced. The dimensions of the profile must be specified in accordance with the parameters specified in the basic shape.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
This element is used to specify the number of the basic profile shape. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
The feature and option code for the profile shape option are specified here.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify a feature. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option that is to be assigned to a basic profile shape. D string
P
M [1:30]
BASIC_SHAPE_PARAMETERS
This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

For items with a basic shape number = 0 that do not have any dimensions, such as calculation positions (e.g. surcharge for feet shape), the parameters must be filled with 0.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.

If an item that is not relevant for visual presentation is created and the item does not have any parameters, then the superordinate node BASIC_PROFILE BASIC_PROFILE can be omitted instead of filling the parameters with 0.
BASIC_SHAPE_NAME required Restriction of xs:string
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
ITEM_DIMENSIONAL_DRAWING
This element is used to specify a dimensional drawing for which the parameters are specified in the DIMENSIONAL_PARAMETERS element. The dimensional drawing describes additional items.
The element must not be created if the BASIC_PROFILE_SHAPE already exists.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
This element is used to specify a dimensional drawing for which the parameters are specified in the PARAMETERS element. The dimensional drawing describes additional items.
Even if this element is not specified, at least the dimensions of the bounding box (b, h, t) must be specified in the BASIC_PROFILES/PARAMETERS element.
The element must not be created if the BASIC_PROFILE_SHAPE already exists. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
The name of a document or a reference to a document is specified in this field.

The documents may e.g. contain additional technical information about the installation or templates for cutouts and drilling.
If only the document name is specified, the document must be delivered with the data. A document reference is specified for an URI/URL.

If a document reference is specified in this element, the NAME element must be set to 23. The value of 23 stands for document reference (see value tables). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS

This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements DIMENSIONAL_NOMINAL_VALUE (path 1), DIMENSIONAL_FROM (path 1) and DIMENSIONAL_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

If the created item is an electrical appliance, the dimensions B, H and T of that appliance must be specified.

Width, height and depth must also be specified, the planning systems use the term length (depending on the model key) for T=depth.

If absolutely necessary (e.g. for diagonal corner infill pieces), the values for basic shapes 21, 24 and 25 may be specified in 1/10 mm. Example: 27.33 mm => element volume: 0027,3

This element can only be omitted from an item if the item has basic shape number 0 assigned to it and no dimensions, such as for calculation positions (e.g. surcharge for handle).

Path1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Sequence
DIMENSIONAL_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.
DIMENSIONAL_NAME required Restriction of xs:string
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
Source
<xs:element name="BASIC_PROFILE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:choice>
        <xs:element name="CARCASE_BASIC_SHAPE">
          <xs:annotation>
            <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>400--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                </xs:annotation>
                <xs:complexType mixed="true">
                  <xs:sequence>
                    <xs:element name="OPTION_REF">
                      <xs:annotation>
                        <xs:documentation>430--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="FEATURE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>430--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPTION_KEY" use="required">
                          <xs:annotation>
                            <xs:documentation>430--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,5}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="BASIC_SHAPE_PARAMETERS">
                <xs:annotation>
                  <xs:documentation>500--1--Satzart</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>500--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                          <xs:annotation>
                            <xs:documentation>500--0--Parameter</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>500--5--Nennwert</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_FROM">
                          <xs:annotation>
                            <xs:documentation>500--6--Von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_TO">
                          <xs:annotation>
                            <xs:documentation>500--7--Bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                          <xs:annotation>
                            <xs:documentation>500--8--Schrittweite</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
              <xs:annotation>
                <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="ITEM_DIMENSIONAL_DRAWING">
          <xs:annotation>
            <xs:documentation>400--32--Massbild</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:minLength value="1" />
                    <xs:maxLength value="240" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="DIMENSIONAL_PARAMETERS">
                <xs:annotation>
                  <xs:documentation>500--1--Satzart</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>500--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="DIMENSIONAL_NAME" use="required">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_FROM">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_TO">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
              <xs:annotation>
                <xs:documentation>400--32--Massbild</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:choice>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CARCASE_BASIC_SHAPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element : CARCASE_BASIC_SHAPE Element
Description
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation. If there are no parameter values for items with basic shape = 0, parameters must be filled with a value of 0.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
997 = items for which neither a basic shape nor a real visual presentation are delivered. This requires the elementsSUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO to be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.
This element must be filled if the BASIC_PROFILE_SHAPE is empty.
Namespace (none)
Diagram
BASIC_SHAPE_PARAMETERS Element BASIC_PROFILE_SHAPE Element Sequence CARCASE_BASIC_SHAPE Element
Overview
CARCASE_BASIC_SHAPE
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation. If there are no parameter values for items with basic shape = 0, parameters must be filled with a value of 0.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
997 = items for which neither a basic shape nor a real visual presentation are delivered. This requires the elementsSUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO to be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.
This element must be filled if the BASIC_PROFILE_SHAPE is empty.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
999 = items that are relevant for visual presentation, but for which no basic shape exists and that are visualised by a graphic model (also see elementMODELING_GRAPHIC_ID). The parameters for width, height and depth must also be specified when using real visual presentations. Additionally, the elementsSERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO can be used to store information for this item.
998 = items for which there is no basic shape or real visual presentation.
997 = items for which neither a basic shape nor a real visual presentation are delivered. For this, the SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO must be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.

This element must be filled if the BASIC_PROFILE_SHAPE is empty. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Here, a basic shape that describes the profile geometry is referenced. The dimensions of the profile must be specified in accordance with the parameters specified in the basic shape.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
This element is used to specify the number of the basic profile shape. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
The feature and option code for the profile shape option are specified here.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify a feature. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option that is to be assigned to a basic profile shape. D string
P
M [1:30]
BASIC_SHAPE_PARAMETERS
This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

For items with a basic shape number = 0 that do not have any dimensions, such as calculation positions (e.g. surcharge for feet shape), the parameters must be filled with 0.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.

If an item that is not relevant for visual presentation is created and the item does not have any parameters, then the superordinate node BASIC_PROFILE BASIC_PROFILE can be omitted instead of filling the parameters with 0.
BASIC_SHAPE_NAME required Restriction of xs:string
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
Attributes
Name Type Use Default Fixed Description
CARCASE_BASIC_SHAPE_NO Restriction of xs:nonNegativeInteger required
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
999 = items that are relevant for visual presentation, but for which no basic shape exists and that are visualised by a graphic model (also see elementMODELING_GRAPHIC_ID). The parameters for width, height and depth must also be specified when using real visual presentations. Additionally, the elementsSERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID andSUBCONTRACTOR_ITEM_NO can be used to store information for this item.
998 = items for which there is no basic shape or real visual presentation.
997 = items for which neither a basic shape nor a real visual presentation are delivered. For this, the SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO must be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.

This element must be filled if the BASIC_PROFILE_SHAPE is empty. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Source
<xs:element name="CARCASE_BASIC_SHAPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType mixed="true">
          <xs:sequence>
            <xs:element name="OPTION_REF">
              <xs:annotation>
                <xs:documentation>430--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>430--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>430--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,5}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="BASIC_SHAPE_PARAMETERS">
        <xs:annotation>
          <xs:documentation>500--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>500--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                  <xs:annotation>
                    <xs:documentation>500--0--Parameter</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                  <xs:annotation>
                    <xs:documentation>500--5--Nennwert</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_FROM">
                  <xs:annotation>
                    <xs:documentation>500--6--Von</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_TO">
                  <xs:annotation>
                    <xs:documentation>500--7--Bis</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                  <xs:annotation>
                    <xs:documentation>500--8--Schrittweite</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_PROFILE_SHAPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element : BASIC_PROFILE_SHAPE Element
Description
Here, a basic shape that describes the profile geometry is referenced. The dimensions of the profile must be specified in accordance with the parameters specified in the basic shape.
Namespace (none)
Diagram
OPTION_REF Element Sequence BASIC_PROFILE_SHAPE Element
Overview
BASIC_PROFILE_SHAPE optional
Here, a basic shape that describes the profile geometry is referenced. The dimensions of the profile must be specified in accordance with the parameters specified in the basic shape.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
This element is used to specify the number of the basic profile shape. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
The feature and option code for the profile shape option are specified here.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify a feature. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option that is to be assigned to a basic profile shape. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
BASIC_PROFILE_SHAPE_NO Restriction of xs:string required
This element is used to specify the number of the basic profile shape. D string
P [\S ]{1,5}
M [1:5]
Source
<xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType mixed="true">
    <xs:sequence>
      <xs:element name="OPTION_REF">
        <xs:annotation>
          <xs:documentation>430--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>430--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>430--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[\S ]{1,5}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element > BASIC_PROFILE_SHAPE Element : OPTION_REF Element
Description
The feature and option code for the profile shape option are specified here.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF
The feature and option code for the profile shape option are specified here.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify a feature. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option that is to be assigned to a basic profile shape. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify a feature. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY Restriction of xs:string required
This attribute is used to reference an option that is to be assigned to a basic profile shape. D string
P
M [1:30]
Source
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>430--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>430--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>430--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BASIC_PROFILE_SHAPE Element | CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_SHAPE_PARAMETERS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element : BASIC_SHAPE_PARAMETERS Element
Description
This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

For items with a basic shape number = 0 that do not have any dimensions, such as calculation positions (e.g. surcharge for feet shape), the parameters must be filled with 0.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Namespace (none)
Diagram
BASIC_SHAPE_PARAMETER Element Sequence BASIC_SHAPE_PARAMETERS Element
Overview
BASIC_SHAPE_PARAMETERS
This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

For items with a basic shape number = 0 that do not have any dimensions, such as calculation positions (e.g. surcharge for feet shape), the parameters must be filled with 0.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.

If an item that is not relevant for visual presentation is created and the item does not have any parameters, then the superordinate node BASIC_PROFILE BASIC_PROFILE can be omitted instead of filling the parameters with 0.
BASIC_SHAPE_NAME required Restriction of xs:string
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
Source
<xs:element name="BASIC_SHAPE_PARAMETERS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>500--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="BASIC_SHAPE_NAME" use="required">
            <xs:annotation>
              <xs:documentation>500--0--Parameter</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
            <xs:annotation>
              <xs:documentation>500--5--Nennwert</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_FROM">
            <xs:annotation>
              <xs:documentation>500--6--Von</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_TO">
            <xs:annotation>
              <xs:documentation>500--7--Bis</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
            <xs:annotation>
              <xs:documentation>500--8--Schrittweite</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_SHAPE_PARAMETER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element > BASIC_SHAPE_PARAMETERS Element : BASIC_SHAPE_PARAMETER Element
Description
This element is used to specify the values of the parameters describing a basic shape.

If an item that is not relevant for visual presentation is created and the item does not have any parameters, then the superordinate node BASIC_PROFILE BASIC_PROFILE can be omitted instead of filling the parameters with 0.
Namespace (none)
Diagram
BASIC_SHAPE_PARAMETER Element
Overview
BASIC_SHAPE_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.

If an item that is not relevant for visual presentation is created and the item does not have any parameters, then the superordinate node BASIC_PROFILE BASIC_PROFILE can be omitted instead of filling the parameters with 0.
BASIC_SHAPE_NAME required Restriction of xs:string
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
Attributes
Name Type Use Default Fixed Description
BASIC_SHAPE_NAME Restriction of xs:string required
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE Restriction of xs:decimal required
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM Restriction of xs:decimal optional
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO Restriction of xs:decimal optional
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE Restriction of xs:decimal optional
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
Source
<xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="BASIC_SHAPE_NAME" use="required">
      <xs:annotation>
        <xs:documentation>500--0--Parameter</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>500--5--Nennwert</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_FROM">
      <xs:annotation>
        <xs:documentation>500--6--Von</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_TO">
      <xs:annotation>
        <xs:documentation>500--7--Bis</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
      <xs:annotation>
        <xs:documentation>500--8--Schrittweite</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BASIC_SHAPE_PARAMETERS Element | CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_DIMENSIONAL_DRAWING Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element : ITEM_DIMENSIONAL_DRAWING Element
Description
This element is used to specify a dimensional drawing for which the parameters are specified in the DIMENSIONAL_PARAMETERS element. The dimensional drawing describes additional items.
The element must not be created if the BASIC_PROFILE_SHAPE already exists.
Namespace (none)
Diagram
DIMENSIONAL_PARAMETERS Element DOCUMENT_REFERENCE Element Sequence ITEM_DIMENSIONAL_DRAWING Element
Overview
ITEM_DIMENSIONAL_DRAWING
This element is used to specify a dimensional drawing for which the parameters are specified in the DIMENSIONAL_PARAMETERS element. The dimensional drawing describes additional items.
The element must not be created if the BASIC_PROFILE_SHAPE already exists.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
This element is used to specify a dimensional drawing for which the parameters are specified in the PARAMETERS element. The dimensional drawing describes additional items.
Even if this element is not specified, at least the dimensions of the bounding box (b, h, t) must be specified in the BASIC_PROFILES/PARAMETERS element.
The element must not be created if the BASIC_PROFILE_SHAPE already exists. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
The name of a document or a reference to a document is specified in this field.

The documents may e.g. contain additional technical information about the installation or templates for cutouts and drilling.
If only the document name is specified, the document must be delivered with the data. A document reference is specified for an URI/URL.

If a document reference is specified in this element, the NAME element must be set to 23. The value of 23 stands for document reference (see value tables). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS

This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements DIMENSIONAL_NOMINAL_VALUE (path 1), DIMENSIONAL_FROM (path 1) and DIMENSIONAL_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

If the created item is an electrical appliance, the dimensions B, H and T of that appliance must be specified.

Width, height and depth must also be specified, the planning systems use the term length (depending on the model key) for T=depth.

If absolutely necessary (e.g. for diagonal corner infill pieces), the values for basic shapes 21, 24 and 25 may be specified in 1/10 mm. Example: 27.33 mm => element volume: 0027,3

This element can only be omitted from an item if the item has basic shape number 0 assigned to it and no dimensions, such as for calculation positions (e.g. surcharge for handle).

Path1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Sequence
DIMENSIONAL_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.
DIMENSIONAL_NAME required Restriction of xs:string
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
Attributes
Name Type Use Default Fixed Description
ITEM_DIMENSIONAL_DRAWING_NO Restriction of xs:string required
This element is used to specify a dimensional drawing for which the parameters are specified in the PARAMETERS element. The dimensional drawing describes additional items.
Even if this element is not specified, at least the dimensions of the bounding box (b, h, t) must be specified in the BASIC_PROFILES/PARAMETERS element.
The element must not be created if the BASIC_PROFILE_SHAPE already exists. 		D string
P
M [1:20]
Source
<xs:element name="ITEM_DIMENSIONAL_DRAWING" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--32--Massbild</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="240" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DIMENSIONAL_PARAMETERS">
        <xs:annotation>
          <xs:documentation>500--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>500--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DIMENSIONAL_NAME" use="required">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_FROM">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_TO">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--32--Massbild</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="20" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DOCUMENT_REFERENCE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > ITEM_DIMENSIONAL_DRAWING Element : DOCUMENT_REFERENCE Element
Description
The name of a document or a reference to a document is specified in this field.

The documents may e.g. contain additional technical information about the installation or templates for cutouts and drilling.
If only the document name is specified, the document must be delivered with the data. A document reference is specified for an URI/URL.

If a document reference is specified in this element, the NAME element must be set to 23. The value of 23 stands for document reference (see value tables). 		D string
P
M [1:240]
Namespace (none)
Type
Restriction of xs:string
Diagram
DOCUMENT_REFERENCE Element
Overview
DOCUMENT_REFERENCE optional Restriction of xs:string
The name of a document or a reference to a document is specified in this field.

The documents may e.g. contain additional technical information about the installation or templates for cutouts and drilling.
If only the document name is specified, the document must be delivered with the data. A document reference is specified for an URI/URL.

If a document reference is specified in this element, the NAME element must be set to 23. The value of 23 stands for document reference (see value tables). 		D string
P
M [1:240]
Source
<xs:element name="DOCUMENT_REFERENCE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="240" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_DIMENSIONAL_DRAWING Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DIMENSIONAL_PARAMETERS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > ITEM_DIMENSIONAL_DRAWING Element : DIMENSIONAL_PARAMETERS Element
Description

This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements DIMENSIONAL_NOMINAL_VALUE (path 1), DIMENSIONAL_FROM (path 1) and DIMENSIONAL_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

If the created item is an electrical appliance, the dimensions B, H and T of that appliance must be specified.

Width, height and depth must also be specified, the planning systems use the term length (depending on the model key) for T=depth.

If absolutely necessary (e.g. for diagonal corner infill pieces), the values for basic shapes 21, 24 and 25 may be specified in 1/10 mm. Example: 27.33 mm => element volume: 0027,3

This element can only be omitted from an item if the item has basic shape number 0 assigned to it and no dimensions, such as for calculation positions (e.g. surcharge for handle).

Path1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Namespace (none)
Diagram
DIMENSIONAL_PARAMETER Element Sequence DIMENSIONAL_PARAMETERS Element
Overview
DIMENSIONAL_PARAMETERS

This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements DIMENSIONAL_NOMINAL_VALUE (path 1), DIMENSIONAL_FROM (path 1) and DIMENSIONAL_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

If the created item is an electrical appliance, the dimensions B, H and T of that appliance must be specified.

Width, height and depth must also be specified, the planning systems use the term length (depending on the model key) for T=depth.

If absolutely necessary (e.g. for diagonal corner infill pieces), the values for basic shapes 21, 24 and 25 may be specified in 1/10 mm. Example: 27.33 mm => element volume: 0027,3

This element can only be omitted from an item if the item has basic shape number 0 assigned to it and no dimensions, such as for calculation positions (e.g. surcharge for handle).

Path1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Sequence
DIMENSIONAL_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.
DIMENSIONAL_NAME required Restriction of xs:string
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
Source
<xs:element name="DIMENSIONAL_PARAMETERS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>500--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DIMENSIONAL_NAME" use="required">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_FROM">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_TO">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_STEP_SIZE">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM_DIMENSIONAL_DRAWING Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DIMENSIONAL_PARAMETER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > ITEM_DIMENSIONAL_DRAWING Element > DIMENSIONAL_PARAMETERS Element : DIMENSIONAL_PARAMETER Element
Description
This element is used to specify the values of the parameters describing a basic shape.
Namespace (none)
Diagram
DIMENSIONAL_PARAMETER Element
Overview
DIMENSIONAL_PARAMETER 1..∞
This element is used to specify the values of the parameters describing a basic shape.
DIMENSIONAL_NAME required Restriction of xs:string
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
Attributes
Name Type Use Default Fixed Description
DIMENSIONAL_NAME Restriction of xs:string required
This attribute is used to specify the parameter name. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE Restriction of xs:decimal required
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM Restriction of xs:decimal optional
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO Restriction of xs:decimal optional
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE Restriction of xs:decimal optional
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value. D decimal
P
M [0:999999]
Source
<xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DIMENSIONAL_NAME" use="required">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_FROM">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_TO">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_STEP_SIZE">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DIMENSIONAL_PARAMETERS Element | ITEM_DIMENSIONAL_DRAWING Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_TEXT Element
Description
This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. At least one item text must be specified for each item.

The following text combinations are permitted:
- Short text;
- Short text + recommended text;
- Short text + recommended text + long text;
- Short text + long text (only if no recommended text is been stored).

The short text may consist of three lines.
Namespace (none)
Diagram
LANGUAGE Element Sequence PLANNING_ADVICE Element LANGUAGE Element Sequence FULL_TEXT Element SHORT_TEXT Element Sequence ITEM_TEXT Element
Overview
ITEM_TEXT
This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. At least one item text must be specified for each item.

The following text combinations are permitted:
- Short text;
- Short text + recommended text;
- Short text + recommended text + long text;
- Short text + long text (only if no recommended text is been stored).

The short text may consist of three lines.
Sequence
SHORT_TEXT
This element contains short texts.
Sequence
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2
ISO_LANGUAGE_ID required Restriction of xs:language
410--0--NEW Version Beta 2.0 Build 2, K. Richter 26.03.2014
Sequence
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5
SEQUENCE_NO required Restriction of xs:positiveInteger
410--0--NEW Version Beta 2.0 Build 5
Sequence
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="ITEM_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SHORT_TEXT">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>410--6--Textzeile</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Za-z]{1,3}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SHORT_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : SHORT_TEXT Element
Description
This element contains short texts.
Namespace (none)
Diagram
LANGUAGE Element Sequence SHORT_TEXT Element
Overview
SHORT_TEXT
This element contains short texts.
Sequence
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2
ISO_LANGUAGE_ID required Restriction of xs:language
410--0--NEW Version Beta 2.0 Build 2, K. Richter 26.03.2014
Sequence
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5
SEQUENCE_NO required Restriction of xs:positiveInteger
410--0--NEW Version Beta 2.0 Build 5
Sequence
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
Source
<xs:element name="SHORT_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>410--6--Textzeile</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Za-z]{1,3}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element : LANGUAGE Element
Description
410--0--NEW Version Beta 2.0 Build 2
Namespace (none)
Diagram
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2
ISO_LANGUAGE_ID required Restriction of xs:language
410--0--NEW Version Beta 2.0 Build 2, K. Richter 26.03.2014
Sequence
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5
SEQUENCE_NO required Restriction of xs:positiveInteger
410--0--NEW Version Beta 2.0 Build 5
Sequence
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
Attributes
Name | Type | Use | Default | Fixed | Description
ISO_LANGUAGE_ID | Restriction of xs:language | required |  |  | 410--0--NEW Version Beta 2.0 Build 2, K. Richter 26.03.2014
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>410--6--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Za-z]{1,3}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT_LINE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element : TEXT_LINE Element
Description
410--0--NEW Version Beta 2.0 Build 5
Namespace (none)
Diagram
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5
SEQUENCE_NO required Restriction of xs:positiveInteger
410--0--NEW Version Beta 2.0 Build 5
Sequence
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
Attributes
Name | Type | Use | Default | Fixed | Description
SEQUENCE_NO | Restriction of xs:positiveInteger | required |  |  | 410--0--NEW Version Beta 2.0 Build 5
Source
<xs:element name="TEXT_LINE" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>410--6--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Description
410--6--Textzeile Version Beta 2.0 Build 5
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--6--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FULL_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : FULL_TEXT Element
Description
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence FULL_TEXT Element
Overview
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="FULL_TEXT" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PLANNING_ADVICE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : PLANNING_ADVICE Element
Description
This element contains planning advice.
Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence PLANNING_ADVICE Element
Overview
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TYPE_KEY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : TYPE_KEY Element
Description
This element is used to define the item's model code.

The values for model codes can be found in a table in the introduction, section Model code

The model code is specified precisely once for each item.
Namespace (none)
Diagram
TK_INFO Element TK_CLASS Element TK_TYPE Element Sequence TYPE_KEY Element
Overview
TYPE_KEY
This element is used to define the item's model code.

The values for model codes can be found in a table in the introduction, section Model code

The model code is specified precisely once for each item.
Sequence
TK_TYPE Restriction of xs:positiveInteger
A value from the column no. intable "model code" in the introduction is entered here. D poisitiveInteger
P
M [1000:2000]
TK_CLASS optional Restriction of xs:nonNegativeInteger
A value from colum type in table "model codes" is entered here. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
TK_INFO optional Restriction of xs:nonNegativeInteger
A value from colum no. in table " Variation code" is entered here. D nonNegativeInteger
P [0-8]0
M [00-80]
Source
<xs:element name="TYPE_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="2000" />
            <xs:minInclusive value="1000" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_CLASS" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_INFO" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:pattern value="[0-8]0" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TK_CLASS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_CLASS Element
Description
A value from colum type in table "model codes" is entered here. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
TK_CLASS Element
Overview
TK_CLASS optional Restriction of xs:nonNegativeInteger
A value from colum type in table "model codes" is entered here. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
Source
<xs:element name="TK_CLASS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TK_INFO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_INFO Element
Description
A value from colum no. in table " Variation code" is entered here. D nonNegativeInteger
P [0-8]0
M [00-80]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
TK_INFO Element
Overview
TK_INFO optional Restriction of xs:nonNegativeInteger
A value from colum no. in table " Variation code" is entered here. D nonNegativeInteger
P [0-8]0
M [00-80]
Source
<xs:element name="TK_INFO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:pattern value="[0-8]0" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CLASSIFICATIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CLASSIFICATIONS Element
Description
This element is used to store standardized classification numbers.
Namespace (none)
Diagram
ECLASS Element Sequence CLASSIFICATIONS Element
Overview
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
Source
<xs:element name="CLASSIFICATIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS_NO">
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:totalDigits value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ECLASS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element : ECLASS Element
Description
This element is used to specify the eCl@ss classification.
Namespace (none)
Diagram
ECLASS_NO Element Sequence ECLASS Element
Overview
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
Source
<xs:element name="ECLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS_NO">
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:totalDigits value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ECLASS_NO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element > ECLASS Element : ECLASS_NO Element
Description

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
ECLASS_NO Element
Overview
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
Source
<xs:element name="ECLASS_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:totalDigits value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ECLASS Element | CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFOS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : DETAIL_INFOS Element
Description
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) must be specified within a preparation rule, there must not be any simultaneous referencing to an assessment (no value for RESTRICTION_NO). 		D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DECISION_NO" use="optional">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

Namespace (none)
Diagram
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) must be specified within a preparation rule, there must not be any simultaneous referencing to an assessment (no value for RESTRICTION_NO). 		D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO Restriction of xs:positiveInteger optional
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) must be specified within a preparation rule, there must not be any simultaneous referencing to an assessment (no value for RESTRICTION_NO). 		D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DECISION_NO" use="optional">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SALES_NUMBER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : SALES_NUMBER Element
Description
If existing, the sale number of the item must be entered in this element. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
SALES_NUMBER Element
Overview
SALES_NUMBER optional Restriction of xs:string
If existing, the sale number of the item must be entered in this element. D string
P
M [1:30]
Source
<xs:element name="SALES_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PART_LIST_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PART_LIST_REF Element
Description

This element references a piece list contained in an item.

The item passes on its options (OPTIONS) to the sub positions if these have identical features (FEATURES) in the feature class associated with the respective sub-position.

The sub-positions can have rules that determine whether a sub-position is displayed. The sub-position is then specified with the corresponding piece quantity.

Items that are only permitted as sub-positions are marked separately (element PARTS_LIST_EXCLUSIVE).

If the item is a catalogue item (ITEM_IDENTIFICATION 'K'), prices may be assigned to the item.The total price of the catalogue item results from the price assigned to it and the prices of the components from the piece list.

The following applies for the planning proposal (ITEM_IDENTIFICATION '1'):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations (ITEM_IDENTIFICATION '2'):
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

Namespace (none)
Diagram
PART_LIST_REF Element
Overview
PART_LIST_REF optional

This element references a piece list contained in an item.

The item passes on its options (OPTIONS) to the sub positions if these have identical features (FEATURES) in the feature class associated with the respective sub-position.

The sub-positions can have rules that determine whether a sub-position is displayed. The sub-position is then specified with the corresponding piece quantity.

Items that are only permitted as sub-positions are marked separately (element PARTS_LIST_EXCLUSIVE).

If the item is a catalogue item (ITEM_IDENTIFICATION 'K'), prices may be assigned to the item.The total price of the catalogue item results from the price assigned to it and the prices of the components from the piece list.

The following applies for the planning proposal (ITEM_IDENTIFICATION '1'):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and options passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations (ITEM_IDENTIFICATION '2'):
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.

PART_LIST_KEY required Restriction of xs:string
This attribute is used to specify the piece list key. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
PART_LIST_KEY Restriction of xs:string required
This attribute is used to specify the piece list key. D string
P
M [1:30]
Source
<xs:element name="PART_LIST_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PART_LIST_KEY" use="required">
      <xs:annotation>
        <xs:documentation>--0--NEW</xs:documentation>
        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="30" />
          <xs:minLength value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PART_LIST_EXCLUSIVE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PART_LIST_EXCLUSIVE Element
Description
This element is used to identify whether the item is only permitted as a sub position within a piece list (value set to 1 (true)).
The value 0 (false) has the same meaning as no value at all. 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
PART_LIST_EXCLUSIVE Element
Overview
PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
This element is used to identify whether the item is only permitted as a sub position within a piece list (value set to 1 (true)).
The value 0 (false) has the same meaning as no value at all. 		D boolean
P
M
Source
<xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PROPERTIES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PROPERTIES Element
Description
This element is used to combine item-specific characteristic features/properties.
Namespace (none)
Diagram
PROPERTY_REF Element Sequence PROPERTIES Element
Overview
PROPERTIES optional
This element is used to combine item-specific characteristic features/properties.
Sequence
PROPERTY_REF 1..∞
This element is used to reference a characteristic feature defined under GLOBAL_DEFINITION/PROPERTIES
PROPERTY_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a characteristic feature. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

This attribute is used to specify the value of the characteristic feature.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Source
<xs:element name="PROPERTIES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PROPERTY_NO" use="required">
            <xs:annotation>
              <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="VALUE" use="required">
            <xs:annotation>
              <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PROPERTY_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PROPERTIES Element : PROPERTY_REF Element
Description
This element is used to reference a characteristic feature defined under GLOBAL_DEFINITION/PROPERTIES
Namespace (none)
Diagram
PROPERTY_REF Element
Overview
PROPERTY_REF 1..∞
This element is used to reference a characteristic feature defined under GLOBAL_DEFINITION/PROPERTIES
PROPERTY_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a characteristic feature. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

This attribute is used to specify the value of the characteristic feature.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Attributes
Name Type Use Default Fixed Description
PROPERTY_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a characteristic feature. D nonNegativeInteger
P
M [0:999]
VALUE Restriction of xs:string required

This attribute is used to specify the value of the characteristic feature.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Source
<xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PROPERTY_NO" use="required">
      <xs:annotation>
        <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="VALUE" use="required">
      <xs:annotation>
        <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PROPERTIES Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ECO_MOBILIER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ECO_MOBILIER Element
Description

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

D string P [0-9]{11} M [11:11]

Information can be found at the following link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

Namespace (none)
Type
Restriction of xs:string
Diagram
ECO_MOBILIER Element
Overview
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

D string P [0-9]{11} M [11:11]

Information can be found at the following link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

Source
<xs:element name="ECO_MOBILIER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9]{11}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PACKAGE_LIST Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PACKAGE_LIST Element
Description

This element is used to specify the packaged pieces per item. An optimisation of packaged items for purchases is not possible.

The width, depth and height must be specified for each packaged item in full mm figures. The weight is specified in decimal kg.

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

Namespace (none)
Diagram
PACKAGE_LIST_POS Element Sequence PACKAGE_LIST Element
Overview
PACKAGE_LIST optional

This element is used to specify the packaged pieces per item. An optimisation of packaged items for purchases is not possible.

The width, depth and height must be specified for each packaged item in full mm figures. The weight is specified in decimal kg.

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

Sequence
PACKAGE_LIST_POS 1..∞
The properties of a packaged item on the list are specified here.
SEQUENCE_NO required Restriction of xs:positiveInteger
This element serves the purpose of an assigning unique number within the list. D positiveInteger
P
M
Sequence
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
This element contains the names on the packaged items list.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
The description of the list of packaged items is entered here.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
WIDTH Restriction of xs:nonNegativeInteger

The width is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
DEPTH Restriction of xs:nonNegativeInteger

The depth is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
HEIGHT Restriction of xs:nonNegativeInteger

The height is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
WEIGHT xs:decimal

The weight is specified in this element.

 D decimal
P
M
EAN_NUMBER optional Restriction of xs:string

The EAN number is specified in this element.

 D string
P
M [1:15]
MATERIAL_NUMBER optional Restriction of xs:string

The material number is specified in this element.

 D string
P
M [1:15]
DECISIONS optional

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

This element is used to reference rules.

Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a list of packaged items.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="WIDTH">
              <xs:annotation>
                <xs:documentation>400--20--Gewicht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DEPTH">
              <xs:annotation>
                <xs:documentation>400--20--Gewicht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEIGHT">
              <xs:annotation>
                <xs:documentation>400--20--Gewicht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="WEIGHT" type="xs:decimal">
              <xs:annotation>
                <xs:documentation>400--20--Gewicht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="EAN_NUMBER" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MATERIAL_NUMBER" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DECISIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PACKAGE_LIST_POS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element : PACKAGE_LIST_POS Element
Description
The properties of a packaged item on the list are specified here.
Namespace (none)
Diagram
DECISIONS Element MATERIAL_NUMBER Element EAN_NUMBER Element WEIGHT Element HEIGHT Element DEPTH Element WIDTH Element LANGUAGE Element Sequence PACKAGE_LIST_COMMENT_TEXT Element LANGUAGE Element Sequence PACKAGE_LIST_TEXT Element Sequence PACKAGE_LIST_POS Element
Overview
PACKAGE_LIST_POS 1..∞
The properties of a packaged item on the list are specified here.
SEQUENCE_NO required Restriction of xs:positiveInteger
This element serves the purpose of an assigning unique number within the list. D positiveInteger
P
M
Sequence
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
This element contains the names on the packaged items list.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
The description of the list of packaged items is entered here.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
WIDTH Restriction of xs:nonNegativeInteger

The width is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
DEPTH Restriction of xs:nonNegativeInteger

The depth is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
HEIGHT Restriction of xs:nonNegativeInteger

The height is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
WEIGHT xs:decimal

The weight is specified in this element.

 D decimal
P
M
EAN_NUMBER optional Restriction of xs:string

The EAN number is specified in this element.

 D string
P
M [1:15]
MATERIAL_NUMBER optional Restriction of xs:string

The material number is specified in this element.

 D string
P
M [1:15]
DECISIONS optional

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

This element is used to reference rules.

Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a list of packaged items.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
SEQUENCE_NO Restriction of xs:positiveInteger required
This element serves the purpose of an assigning unique number within the list. D positiveInteger
P
M
Source
<xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="WIDTH">
        <xs:annotation>
          <xs:documentation>400--20--Gewicht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DEPTH">
        <xs:annotation>
          <xs:documentation>400--20--Gewicht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT">
        <xs:annotation>
          <xs:documentation>400--20--Gewicht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="WEIGHT" type="xs:decimal">
        <xs:annotation>
          <xs:documentation>400--20--Gewicht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="EAN_NUMBER" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--11--EAN_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MATERIAL_NUMBER" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--11--EAN_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DECISIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PACKAGE_LIST_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : PACKAGE_LIST_TEXT Element
Description
This element contains the names on the packaged items list.
Namespace (none)
Type
languagetext60 Complex Type
Diagram
LANGUAGE Element Sequence PACKAGE_LIST_TEXT Element
Overview
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
This element contains the names on the packaged items list.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PACKAGE_LIST_COMMENT_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : PACKAGE_LIST_COMMENT_TEXT Element
Description
The description of the list of packaged items is entered here.
Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence PACKAGE_LIST_COMMENT_TEXT Element
Overview
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
The description of the list of packaged items is entered here.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

WIDTH Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : WIDTH Element
Description

The width is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
WIDTH Element
Overview
WIDTH Restriction of xs:nonNegativeInteger

The width is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="WIDTH" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DEPTH Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : DEPTH Element
Description

The depth is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
DEPTH Element
Overview
DEPTH Restriction of xs:nonNegativeInteger

The depth is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="DEPTH" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

HEIGHT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : HEIGHT Element
Description

The height is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
HEIGHT Element
Overview
HEIGHT Restriction of xs:nonNegativeInteger

The height is specified in this element.

 D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="HEIGHT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

WEIGHT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : WEIGHT Element
Description

The weight is specified in this element.

 D decimal
P
M
Namespace (none)
Type
xs:decimal
Diagram
WEIGHT Element
Overview
WEIGHT xs:decimal

The weight is specified in this element.

 D decimal
P
M
Source
<xs:element name="WEIGHT" type="xs:decimal" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EAN_NUMBER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : EAN_NUMBER Element
Description

The EAN number is specified in this element.

 D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
EAN_NUMBER Element
Overview
EAN_NUMBER optional Restriction of xs:string

The EAN number is specified in this element.

 D string
P
M [1:15]
Source
<xs:element name="EAN_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--11--EAN_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MATERIAL_NUMBER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : MATERIAL_NUMBER Element
Description

The material number is specified in this element.

 D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
MATERIAL_NUMBER Element
Overview
MATERIAL_NUMBER optional Restriction of xs:string

The material number is specified in this element.

 D string
P
M [1:15]
Source
<xs:element name="MATERIAL_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--11--EAN_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : DECISIONS Element
Description

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

This element is used to reference rules.

Namespace (none)
Diagram
DECISION_REF Element Sequence DECISIONS Element
Overview
DECISIONS optional

Packaged items may be rule-based, i.e. depending on options, e.g. when drawers or mirrors are added as an option then this triggers a new packaged item. The option for a new packaged item should only be used in simple cases.This means that each element of the list of packaged items can also make reference to rules.

This element is used to reference rules.

Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a list of packaged items.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DECISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element > DECISIONS Element : DECISION_REF Element
Description
This element is used to reference a rule assigned to a list of packaged items.
Namespace (none)
Diagram
DECISION_REF Element
Overview
DECISION_REF 1..∞
This element is used to reference a rule assigned to a list of packaged items.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
DECISION_NO Restriction of xs:positiveInteger required
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DECISION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DECISIONS Element | PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : DECISIONS Element
Description
This element is used to combine product group-specific rules.
Namespace (none)
Diagram
DECISION_REF Element Sequence DECISIONS Element
Overview
DECISIONS optional
This element is used to combine product group-specific rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a rule assigned to a product group.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DECISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > DECISIONS Element : DECISION_REF Element
Description
This element is used to reference a rule assigned to a product group.
Namespace (none)
Diagram
DECISION_REF Element
Overview
DECISION_REF 1..∞
This element is used to reference a rule assigned to a product group.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
DECISION_NO Restriction of xs:positiveInteger required
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DECISION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DECISIONS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

COLOR_CONSULTANCIES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : COLOR_CONSULTANCIES Element
Description

This element is used to define colour consultancies.

Each colour consultancy COLOR_CONSULTANCY contains any number of references to combinations of detailed information and assessments FEATURE_DETAIL_INFO_REF, which are sorted by SEQUENCE_NO. The applied assessments must contain colour variations.

Namespace (none)
Diagram
COLOR_CONSULTANCY Element Sequence COLOR_CONSULTANCIES Element
Overview
COLOR_CONSULTANCIES optional

This element is used to define colour consultancies.

Each colour consultancy COLOR_CONSULTANCY contains any number of references to combinations of detailed information and assessments FEATURE_DETAIL_INFO_REF, which are sorted by SEQUENCE_NO. The applied assessments must contain colour variations.

Sequence
COLOR_CONSULTANCY 1..∞
This element is used to directly assign assessments to image layers.
The applied assessments must contain colour variations.
COLOR_CONSULTANCY_NO required Restriction of xs:nonNegativeInteger
This attribute defines the colour consultancy number. D nonNegativeInteger
P
M [0:9999]
Sequence
FEATURE_DETAIL_INFO_REF 1..∞
This element allows for the assignment of precisely one assessment or rule to the image layers.
The assessment and/or rule must contain a colour feature. The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO. Either an assessment (RESTRICTION) or rule (DECISION) can be assigned.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of the colour consultancy. D positiveInteger
P
M
DECISION_NO optional Restriction of xs:positiveInteger
This attribute references a rule. D positiveInteger
P
M [1:9999999999]
Remarks

Source
<xs:element name="COLOR_CONSULTANCIES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="COLOR_CONSULTANCY" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke
                              </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>255--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                          30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DECISION_NO" use="optional">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="COLOR_CONSULTANCY_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

COLOR_CONSULTANCY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > COLOR_CONSULTANCIES Element : COLOR_CONSULTANCY Element
Description
This element is used to directly assign assessments to image layers.
The applied assessments must contain colour variations.
Namespace (none)
Diagram
FEATURE_DETAIL_INFO_REF Element Sequence COLOR_CONSULTANCY Element
Overview
COLOR_CONSULTANCY 1..∞
This element is used to directly assign assessments to image layers.
The applied assessments must contain colour variations.
COLOR_CONSULTANCY_NO required Restriction of xs:nonNegativeInteger
This attribute defines the colour consultancy number. D nonNegativeInteger
P
M [0:9999]
Sequence
FEATURE_DETAIL_INFO_REF 1..∞
This element allows for the assignment of precisely one assessment or rule to the image layers.
The assessment and/or rule must contain a colour feature. The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO. Either an assessment (RESTRICTION) or rule (DECISION) can be assigned.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of the colour consultancy. D positiveInteger
P
M
DECISION_NO optional Restriction of xs:positiveInteger
This attribute references a rule. D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
COLOR_CONSULTANCY_NO Restriction of xs:nonNegativeInteger required
This attribute defines the colour consultancy number. D nonNegativeInteger
P
M [0:9999]
Remarks

Source
<xs:element name="COLOR_CONSULTANCY" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke
                              </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>255--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                          30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>270--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DECISION_NO" use="optional">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="COLOR_CONSULTANCY_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
COLOR_CONSULTANCIES Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_DETAIL_INFO_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > COLOR_CONSULTANCIES Element > COLOR_CONSULTANCY Element : FEATURE_DETAIL_INFO_REF Element
Description
This element allows for the assignment of precisely one assessment or rule to the image layers.
The assessment and/or rule must contain a colour feature. The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO. Either an assessment (RESTRICTION) or rule (DECISION) can be assigned.
Namespace (none)
Diagram
FEATURE_DETAIL_INFO_REF Element
Overview
FEATURE_DETAIL_INFO_REF 1..∞
This element allows for the assignment of precisely one assessment or rule to the image layers.
The assessment and/or rule must contain a colour feature. The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO. Either an assessment (RESTRICTION) or rule (DECISION) can be assigned.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of the colour consultancy. D positiveInteger
P
M
DECISION_NO optional Restriction of xs:positiveInteger
This attribute references a rule. D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO Restriction of xs:positiveInteger required
This attribute defines the order of the colour consultancy. D positiveInteger
P
M
DECISION_NO Restriction of xs:positiveInteger optional
This attribute references a rule. D positiveInteger
P
M [1:9999999999]
Remarks

Source
<xs:element name="FEATURE_DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                          30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>270--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DECISION_NO" use="optional">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
COLOR_CONSULTANCY Element | COLOR_CONSULTANCIES Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFOS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : DETAIL_INFOS Element
Description
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS 0..∞
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Remarks

Source
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description
This element is used to reference the detailed information.
Namespace (none)
Diagram
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Remarks

Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : VALID_FROM Element
Description
This element specifies the date on which the series becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the series becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
Source
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : VALID_UNTIL Element
Description
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Source
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element : DECISIONS Element
Description
This element is used to collect cross-series rules.
Namespace (none)
Diagram
DECISION_REF Element Sequence DECISIONS Element
Overview
DECISIONS optional
This element is used to collect cross-series rules.
Sequence
DECISION_REF 1..∞
This element is used to reference a cross-series rule.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DECISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > DECISIONS Element : DECISION_REF Element
Description
This element is used to reference a cross-series rule.
Namespace (none)
Diagram
DECISION_REF Element
Overview
DECISION_REF 1..∞
This element is used to reference a cross-series rule.
DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
DECISION_NO Restriction of xs:positiveInteger required
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DECISION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DECISIONS Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIE_GROUPS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element : SERIE_GROUPS Element
Description
This element can be used to combine different series in groups (model groups).
Namespace (none)
Diagram
SERIE_GROUP Element Sequence SERIE_GROUPS Element
Overview
SERIE_GROUPS optional
This element can be used to combine different series in groups (model groups).
Sequence
SERIE_GROUP 1..∞
A model group (combination of multiple series) is defined here.
SERIE_GROUP_KEY required Restriction of xs:string

This attribute assigns unique identifiers to series groups/model groups.

 D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger

This attribute allows for the specification of series groups with a freely-defined sorting order.

 D nonNegativeInteger
P
M
Sequence
SERIE_REF 1..∞
This element is used to reference series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a series. D nonNegativInteger
P
M [0:999999]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute defines the order of the series within a series group. D nonNegativeInteger
P
M
SERIE_GROUP_TEXT languagetext60 Complex Type
This element is used to specify the designation of the series group/model group.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS 0..∞
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="SERIE_GROUPS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5
Möglichkeit Serien zu gruppieren und auch ein Bild zu hinterlegen</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE_GROUP" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SERIE_GROUP_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_GROUP_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
              <xs:documentation>geändert auf SERIE_GROUP_KEY, K.Richter 23.11.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIE_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE_GROUPS Element : SERIE_GROUP Element
Description
A model group (combination of multiple series) is defined here.
Namespace (none)
Diagram
DETAIL_INFOS Element LANGUAGE Element Sequence SERIE_GROUP_TEXT Element SERIE_REF Element Sequence SERIE_GROUP Element
Overview
SERIE_GROUP 1..∞
A model group (combination of multiple series) is defined here.
SERIE_GROUP_KEY required Restriction of xs:string

This attribute assigns unique identifiers to series groups/model groups.

 D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger

This attribute allows for the specification of series groups with a freely-defined sorting order.

 D nonNegativeInteger
P
M
Sequence
SERIE_REF 1..∞
This element is used to reference series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a series. D nonNegativInteger
P
M [0:999999]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute defines the order of the series within a series group. D nonNegativeInteger
P
M
SERIE_GROUP_TEXT languagetext60 Complex Type
This element is used to specify the designation of the series group/model group.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS 0..∞
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
SERIE_GROUP_KEY Restriction of xs:string required

This attribute assigns unique identifiers to series groups/model groups.

 D string
P
M [1:30]
SEQUENCE_NO Restriction of xs:nonNegativeInteger optional

This attribute allows for the specification of series groups with a freely-defined sorting order.

 D nonNegativeInteger
P
M
Source
<xs:element name="SERIE_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIE_GROUP_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_GROUP_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
        <xs:documentation>geändert auf SERIE_GROUP_KEY, K.Richter 23.11.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SERIE_GROUPS Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE_GROUPS Element > SERIE_GROUP Element : SERIE_REF Element
Description
This element is used to reference series.
Namespace (none)
Diagram
SERIE_REF Element
Overview
SERIE_REF 1..∞
This element is used to reference series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a series. D nonNegativInteger
P
M [0:999999]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute defines the order of the series within a series group. D nonNegativeInteger
P
M
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a series. D nonNegativInteger
P
M [0:999999]
SEQUENCE_NO Restriction of xs:nonNegativeInteger optional
This attribute defines the order of the series within a series group. D nonNegativeInteger
P
M
Source
<xs:element name="SERIE_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SERIE_GROUP Element | SERIE_GROUPS Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIE_GROUP_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE_GROUPS Element > SERIE_GROUP Element : SERIE_GROUP_TEXT Element
Description
This element is used to specify the designation of the series group/model group.
Namespace (none)
Type
languagetext60 Complex Type
Diagram
LANGUAGE Element Sequence SERIE_GROUP_TEXT Element
Overview
SERIE_GROUP_TEXT languagetext60 Complex Type
This element is used to specify the designation of the series group/model group.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="SERIE_GROUP_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
SERIE_GROUP Element | SERIE_GROUPS Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFOS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE_GROUPS Element > SERIE_GROUP Element : DETAIL_INFOS Element
Description
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS 0..∞
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE_GROUP Element | SERIE_GROUPS Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE_GROUPS Element > SERIE_GROUP Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description
This element is used to reference the detailed information.
Namespace (none)
Diagram
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute references a detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | SERIE_GROUP Element | SERIE_GROUPS Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PART_LISTS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : PART_LISTS Element
Description

This element is used to assemble dynamic piece lists, with the sub-positions assigned to rules that determine depending on the option in which quantity the respective position exists in the piece list.

Only items in a corresponding series or items of series 0 are contained.

A contained item may however contain a piece list.

The item that contains a piece list passes on its options (OPTIONS) to the sub positions if these have identical features (FEATURES) in the feature class associated with the respective sub-position.

Namespace (none)
Diagram
PART_LIST Element Sequence PART_LISTS Element
Overview
PART_LISTS optional

This element is used to assemble dynamic piece lists, with the sub-positions assigned to rules that determine depending on the option in which quantity the respective position exists in the piece list.

Only items in a corresponding series or items of series 0 are contained.

A contained item may however contain a piece list.

The item that contains a piece list passes on its options (OPTIONS) to the sub positions if these have identical features (FEATURES) in the feature class associated with the respective sub-position.

Sequence
PART_LIST 1..∞
This version is used to define a piece list.
PART_LIST_KEY required Restriction of xs:string
This attribute is used to reference a piece list. D string
P
M [1:30]
Sequence
PART_LIST_POS 1..∞
This element is used to describe the piece list positions.
Sequence
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This attribute allows for the specification of piece lists with a freely-defined sorting order. D positiveInteger
P
M
ITEM_REF
This element is used to reference an item.
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:99999]
DECISIONS optional

The rules for the corresponding piece list position are collected in this element. It thereby influences the options and dimensions available for this position.

A rule with a quantity factor must not be specified here.Thisrule is referenced via DECISION_POS_COUNT.

Sequence
DECISION_REF 1..∞

This element references a rule corresponding to the piece list position and thereby influences the dimensions and options available for this position. A rule with a quantity factor must not be specified here.The rule is referenced via DECISION_POS_COUNT.

DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
This element is used to specify the quantity of the item in the piece list. D nonNegativeInteger
P
M [0:999999999]
DECISION_POS_COUNT optional

This element is used to specify a rule that sets the quantity factor.The maximum number is one for each position.This rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations.

Sequence
DECISION_REF

This element references a rulethat determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations.

DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule that determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations. D positiveInteger
P
M [1:9999999999]
POS_INVISIBILITY Restriction of xs:integer

This element is an identifier that the item must be contained in the order, the position should not be displayed in the configurator. The invisibility only applies to the specific position, not to a potentially existing sub-tree. This means that invisibility must in this case be specified at each sub-position.

0 = completely visible

1 = fully invisible

2 = only visible in EDI order if them is generated via a rule

D integer
P
M [0:2]
Source
<xs:element name="PART_LISTS" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PART_LIST" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PART_LIST_POS" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation />
                <xs:documentation />
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SEQUENCE_NO">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">IDM-2.5
laufende Nummer der Position
bei Planungsvorschlägen sollte diese von links nach rechts gemäß der Planungsvariante geordnet sein</xs:documentation>
                      <xs:documentation xml:lang="DE" />
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DECISIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DECISION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DECISION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="POS_COUNT_VALUE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Anzahl der Positionen gemäß der Einheit an den Stammdaten</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DECISION_POS_COUNT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">IDM 2.5
Entscheidungstabellen, die die Anzahl steuern.
Hier dürfen nur Decisions verwendet werden, die im Action_part die Anzahl steuern (set_pos_count).</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DECISION_REF">
                          <xs:annotation>
                            <xs:documentation />
                            <xs:documentation />
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DECISION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="POS_INVISIBILITY">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">IDM 2.5 neu
0 = sichtbar komplett
1 = gar nicht sichtbar
2= nur in EDI-Bestellung sichtbar, wenn über Decisions gezogen wird</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PART_LIST_KEY" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:maxLength value="30" />
                <xs:minLength value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PART_LIST Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element : PART_LIST Element
Description
This version is used to define a piece list.
Namespace (none)
Diagram
PART_LIST_POS Element Sequence PART_LIST Element
Overview
PART_LIST 1..∞
This version is used to define a piece list.
PART_LIST_KEY required Restriction of xs:string
This attribute is used to reference a piece list. D string
P
M [1:30]
Sequence
PART_LIST_POS 1..∞
This element is used to describe the piece list positions.
Sequence
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This attribute allows for the specification of piece lists with a freely-defined sorting order. D positiveInteger
P
M
ITEM_REF
This element is used to reference an item.
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:99999]
DECISIONS optional

The rules for the corresponding piece list position are collected in this element. It thereby influences the options and dimensions available for this position.

A rule with a quantity factor must not be specified here.Thisrule is referenced via DECISION_POS_COUNT.

Sequence
DECISION_REF 1..∞

This element references a rule corresponding to the piece list position and thereby influences the dimensions and options available for this position. A rule with a quantity factor must not be specified here.The rule is referenced via DECISION_POS_COUNT.

DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
This element is used to specify the quantity of the item in the piece list. D nonNegativeInteger
P
M [0:999999999]
DECISION_POS_COUNT optional

This element is used to specify a rule that sets the quantity factor.The maximum number is one for each position.This rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations.

Sequence
DECISION_REF

This element references a rulethat determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations.

DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule that determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations. D positiveInteger
P
M [1:9999999999]
POS_INVISIBILITY Restriction of xs:integer

This element is an identifier that the item must be contained in the order, the position should not be displayed in the configurator. The invisibility only applies to the specific position, not to a potentially existing sub-tree. This means that invisibility must in this case be specified at each sub-position.

0 = completely visible

1 = fully invisible

2 = only visible in EDI order if them is generated via a rule

D integer
P
M [0:2]
Attributes
Name Type Use Default Fixed Description
PART_LIST_KEY Restriction of xs:string required
This attribute is used to reference a piece list. D string
P
M [1:30]
Source
<xs:element name="PART_LIST" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PART_LIST_POS" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation />
          <xs:documentation />
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SEQUENCE_NO">
              <xs:annotation>
                <xs:documentation xml:lang="DE">IDM-2.5
laufende Nummer der Position
bei Planungsvorschlägen sollte diese von links nach rechts gemäß der Planungsvariante geordnet sein</xs:documentation>
                <xs:documentation xml:lang="DE" />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DECISIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="POS_COUNT_VALUE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Anzahl der Positionen gemäß der Einheit an den Stammdaten</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DECISION_POS_COUNT" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">IDM 2.5
Entscheidungstabellen, die die Anzahl steuern.
Hier dürfen nur Decisions verwendet werden, die im Action_part die Anzahl steuern (set_pos_count).</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_REF">
                    <xs:annotation>
                      <xs:documentation />
                      <xs:documentation />
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="POS_INVISIBILITY">
              <xs:annotation>
                <xs:documentation xml:lang="DE">IDM 2.5 neu
0 = sichtbar komplett
1 = gar nicht sichtbar
2= nur in EDI-Bestellung sichtbar, wenn über Decisions gezogen wird</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PART_LIST_KEY" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="30" />
          <xs:minLength value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PART_LIST_POS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element : PART_LIST_POS Element
Description
This element is used to describe the piece list positions.
Namespace (none)
Diagram
POS_INVISIBILITY Element DECISION_POS_COUNT Element POS_COUNT_VALUE Element DECISIONS Element ITEM_REF Element SEQUENCE_NO Element Sequence PART_LIST_POS Element
Overview
PART_LIST_POS 1..∞
This element is used to describe the piece list positions.
Sequence
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This attribute allows for the specification of piece lists with a freely-defined sorting order. D positiveInteger
P
M
ITEM_REF
This element is used to reference an item.
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:99999]
DECISIONS optional

The rules for the corresponding piece list position are collected in this element. It thereby influences the options and dimensions available for this position.

A rule with a quantity factor must not be specified here.Thisrule is referenced via DECISION_POS_COUNT.

Sequence
DECISION_REF 1..∞

This element references a rule corresponding to the piece list position and thereby influences the dimensions and options available for this position. A rule with a quantity factor must not be specified here.The rule is referenced via DECISION_POS_COUNT.

DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
This element is used to specify the quantity of the item in the piece list. D nonNegativeInteger
P
M [0:999999999]
DECISION_POS_COUNT optional

This element is used to specify a rule that sets the quantity factor.The maximum number is one for each position.This rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations.

Sequence
DECISION_REF

This element references a rulethat determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations.

DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule that determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations. D positiveInteger
P
M [1:9999999999]
POS_INVISIBILITY Restriction of xs:integer

This element is an identifier that the item must be contained in the order, the position should not be displayed in the configurator. The invisibility only applies to the specific position, not to a potentially existing sub-tree. This means that invisibility must in this case be specified at each sub-position.

0 = completely visible

1 = fully invisible

2 = only visible in EDI order if them is generated via a rule

D integer
P
M [0:2]
Source
<xs:element name="PART_LIST_POS" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation />
    <xs:documentation />
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SEQUENCE_NO">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM-2.5
laufende Nummer der Position
bei Planungsvorschlägen sollte diese von links nach rechts gemäß der Planungsvariante geordnet sein</xs:documentation>
          <xs:documentation xml:lang="DE" />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation> K. Richter 12.02.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation> K. Richter 12.02.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DECISIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="POS_COUNT_VALUE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Anzahl der Positionen gemäß der Einheit an den Stammdaten</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DECISION_POS_COUNT" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM 2.5
Entscheidungstabellen, die die Anzahl steuern.
Hier dürfen nur Decisions verwendet werden, die im Action_part die Anzahl steuern (set_pos_count).</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_REF">
              <xs:annotation>
                <xs:documentation />
                <xs:documentation />
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="POS_INVISIBILITY">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM 2.5 neu
0 = sichtbar komplett
1 = gar nicht sichtbar
2= nur in EDI-Bestellung sichtbar, wenn über Decisions gezogen wird</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SEQUENCE_NO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element : SEQUENCE_NO Element
Description
This attribute allows for the specification of piece lists with a freely-defined sorting order. D positiveInteger
P
M
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
SEQUENCE_NO Element
Overview
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This attribute allows for the specification of piece lists with a freely-defined sorting order. D positiveInteger
P
M
Source
<xs:element name="SEQUENCE_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM-2.5
laufende Nummer der Position
bei Planungsvorschlägen sollte diese von links nach rechts gemäß der Planungsvariante geordnet sein</xs:documentation>
    <xs:documentation xml:lang="DE" />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element : ITEM_REF Element
Description
This element is used to reference an item.
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF
This element is used to reference an item.
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:99999]
Attributes
Name Type Use Default Fixed Description
TYPE_NO Restriction of xs:string required
This attribute is used to reference an item with an item number. D string
P
M [1:30]
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:99999]
Source
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element : DECISIONS Element
Description

The rules for the corresponding piece list position are collected in this element. It thereby influences the options and dimensions available for this position.

A rule with a quantity factor must not be specified here.Thisrule is referenced via DECISION_POS_COUNT.

Namespace (none)
Diagram
DECISION_REF Element Sequence DECISIONS Element
Overview
DECISIONS optional

The rules for the corresponding piece list position are collected in this element. It thereby influences the options and dimensions available for this position.

A rule with a quantity factor must not be specified here.Thisrule is referenced via DECISION_POS_COUNT.

Sequence
DECISION_REF 1..∞

This element references a rule corresponding to the piece list position and thereby influences the dimensions and options available for this position. A rule with a quantity factor must not be specified here.The rule is referenced via DECISION_POS_COUNT.

DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DECISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element > DECISIONS Element : DECISION_REF Element
Description

This element references a rule corresponding to the piece list position and thereby influences the dimensions and options available for this position. A rule with a quantity factor must not be specified here.The rule is referenced via DECISION_POS_COUNT.

Namespace (none)
Diagram
DECISION_REF Element
Overview
DECISION_REF 1..∞

This element references a rule corresponding to the piece list position and thereby influences the dimensions and options available for this position. A rule with a quantity factor must not be specified here.The rule is referenced via DECISION_POS_COUNT.

DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
DECISION_NO Restriction of xs:positiveInteger required
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DECISION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DECISIONS Element | PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

POS_COUNT_VALUE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element : POS_COUNT_VALUE Element
Description
This element is used to specify the quantity of the item in the piece list. D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
POS_COUNT_VALUE Element
Overview
POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
This element is used to specify the quantity of the item in the piece list. D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="POS_COUNT_VALUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Anzahl der Positionen gemäß der Einheit an den Stammdaten</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_POS_COUNT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element : DECISION_POS_COUNT Element
Description

This element is used to specify a rule that sets the quantity factor.The maximum number is one for each position.This rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations.

Namespace (none)
Diagram
DECISION_REF Element Sequence DECISION_POS_COUNT Element
Overview
DECISION_POS_COUNT optional

This element is used to specify a rule that sets the quantity factor.The maximum number is one for each position.This rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations.

Sequence
DECISION_REF

This element references a rulethat determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations.

DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule that determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DECISION_POS_COUNT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5
Entscheidungstabellen, die die Anzahl steuern.
Hier dürfen nur Decisions verwendet werden, die im Action_part die Anzahl steuern (set_pos_count).</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF">
        <xs:annotation>
          <xs:documentation />
          <xs:documentation />
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element > DECISION_POS_COUNT Element : DECISION_REF Element
Description

This element references a rulethat determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations.

Namespace (none)
Diagram
DECISION_REF Element
Overview
DECISION_REF

This element references a rulethat determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations.

DECISION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a rule that determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations. D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
DECISION_NO Restriction of xs:positiveInteger required
This attribute is used to reference a rule that determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible feature combinations. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DECISION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation />
    <xs:documentation />
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DECISION_POS_COUNT Element | PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

POS_INVISIBILITY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element : POS_INVISIBILITY Element
Description

This element is an identifier that the item must be contained in the order, the position should not be displayed in the configurator. The invisibility only applies to the specific position, not to a potentially existing sub-tree. This means that invisibility must in this case be specified at each sub-position.

0 = completely visible

1 = fully invisible

2 = only visible in EDI order if them is generated via a rule

D integer
P
M [0:2]
Namespace (none)
Type
Restriction of xs:integer
Diagram
POS_INVISIBILITY Element
Overview
POS_INVISIBILITY Restriction of xs:integer

This element is an identifier that the item must be contained in the order, the position should not be displayed in the configurator. The invisibility only applies to the specific position, not to a potentially existing sub-tree. This means that invisibility must in this case be specified at each sub-position.

0 = completely visible

1 = fully invisible

2 = only visible in EDI order if them is generated via a rule

D integer
P
M [0:2]
Source
<xs:element name="POS_INVISIBILITY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5 neu
0 = sichtbar komplett
1 = gar nicht sichtbar
2= nur in EDI-Bestellung sichtbar, wenn über Decisions gezogen wird</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_DEFINITION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : FEATURE_DEFINITION Element
Description
This element is used to specify option-specific information.
Namespace (none)
Diagram
FORMULAS Element OPTION_GROUPS Element DECISIONS Element OPTION_DEFINITION Element FEATURES Element FEATURE_CLASSES Element Sequence FEATURE_DEFINITION Element
Overview
FEATURE_DEFINITION
This element is used to specify option-specific information.
Sequence
FEATURE_CLASSES

This element is used to combine features in families. These feature classes can be used to carry out plausibility and completeness checks with respect to the valid features.

The defined feature classes (path 1) can be assigned to series or product groups via FEATURE_CLASS_REF in SERIE and PRODUCT_GROUP. There is no relationship with respect to a priority between feature classes on series and item level. The number of features that are valid for an item results from the total number of features declared in the items product group.

All features that are referenced via the elements in PRICE_FEATURE_GROUP (path 3), PRICE_FEATURE_BASE_PRICE_GROUP_REF (path 4) and FINISH (path 5) must be contained in the feature class of the item.

The features used via the elements RESTRICTION_REF (path 6) and RESTRICTION_REF (path 8) must also be contained in the item's feature class.

Element paths
Path 1 : FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS
Path 2 : FEATURE_DEFINITION/FEATURES
Path 3 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 5 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Path 6: SERIES/RESTRICTIONS/RESTRICTION_REF
Path 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS

Sequence
FEATURE_CLASS 1..∞
This element is used to define a feature class.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute is used to identify a feature class. D positiveInteger
P
M [1:9999999999]
Sequence
FEATURE_REF 1..∞
This feature refers to the FEATURE (path 1) element.
Only helpful options must be referenced in the feature class of an item. Example: the feature class vacation must not contain any features for feet shapes.

Element paths
Path 1 : FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:9999]
INVISIBLE optional xs:boolean
If the value of this attribute is set to true (or 1), it specifies that the corresponding feature is invisible. D boolean
P
M
.
FEATURES

This element is used to define the features (FEATURE) and the associated options. Only the features needed for correctly mapping the catalogue are defined.

The combination of finish and colour is used for some features.

If this is the case, features must always be created in pairs. The corresponding colour feature exists for the respective finish option types; a corresponding finish feature exists for the colour feature.

Features declared as invisible features are not be referenced in a feature class.

All features in the FEATURES (path 3) element that are not declared as invisible head feature must be referenced in at least one feature class.

Further information about features can be found in the Introduction in section "features"
Element paths
Path 1 : FEATURE_DEFINITION/FEATURES
Path 2: FEATURE_DEFINITION/FEATURES/FEATURE
Path 3: FEATURE_DEFINITION

Sequence
FEATURE 1..∞
This element is used to define a feature.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a feature. D nonNegativeInteger
P
M [0:9999]
Sequence
OPTIONS optional
It is a container element in which the possible variations of a feature are stored.
The element is omitted for resulting features (HEADER_POS_VARIATION_TYPE=V).
Sequence
OPTION 1..∞
This element is used to define the options for feature.All options necessary in the data pool are stored here. If the option to be created is a feature (introduction: table features identified by type A), no colour values or texture must be specified. The gloss and opaqueness can optionally be assigned to a feature and have priority over corresponding colour variations.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute allows for the specification of a freely-defined sorting order. D nonNegativeInteger
P
M
Sequence
Choice optional
MATERIAL_REF
This element is used to reference a material.
MATERIAL_NO required Restriction of xs:string
This attribute is used to reference a material. D string
P
M [1:5]
FORM_REF
This element is used to reference a shape.

FORM_NO required Restriction of xs:string
This attribute is used to reference a profile shape. D string
P
M [1:5]
OPTION_MEASURE_REF
This attribute is used to reference a dimensional variation of a feature.
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
This attribute is used to reference a dimension variation. D positiveInteger
P
M [1:99999]
OPTION_TEXT languagetext60 Complex Type
This element is used to define an option text.
Sequence
LANGUAGE 1..∞
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements:
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.It is possible to assign a number of detail information to one option, and each image of the option can then be assigned to specific series or items. The respective image/media will then only be displayed for the corresponding series or item.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
This element contains texts for features.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element is used to specify a manufacturer-specific sorting for the features.
The order is a recommendation by the manufacturer. The dealership will, if necessary, work with a different sorting. The sorting is, for example, used for: display in on-screen forms, order of the options during the ordering process, or forms.
The sorting must be specified unequivocally for all data records.
The element is left blank for invisible head options (HEADER_POS_VARIATION_TYPE = U (path 1)).

Element paths
Path 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
This element is an identifier that specifies whether a feature is an
I = implicit feature,
K = head option, or
P = position feature.

It serves the purpose of controlling the processing method on head or position level, features designated with a "P" must, according to the manufacturer, not be processed on head level.

Features designated with an "I" are visible and result implicitly from other features. 		D string
P [IKP]
M [1:1]
FEATURE_TYPE
This element is used to identify the feature corresponding to the option. A feature can be assigned dimensional variations (value of FEATURE_T "M"), colour variations (value of FEATURE_T "C") or other features (value of FEATURE_T "O").
FEATURE_T optional Restriction of xs:string

This attribute is used to define the options assigned to the feature.

M = dimensional versions

C = colour versions

O = other options

 D string
P [MCO]
M [1:1]
Sequence
MEASURE optional

If the options assigned to the feature are dimensional versions, the dimensional information is entered in this element.

They consist of a dimensional parameter, the unit of measure and can then, for example, be used in the formulas of the rules (DECISIONS).

Sequence
MEASURE_UNIT xs:string
This element is used to specify the unit of measure. D string
P
M
MEASURE_PARAMETER optional Restriction of xs:string

This element is used to specify the parameters for defining a formula, e.g. planning width = 2 * st +sb, with st expressing the side part width and sb expressing the seat width.

 D string
P
M
OPTION_DEFINITION optional
This element is used to define the properties of colours, materials and dimensions.
Sequence
MATERIAL 0..∞
This element is used to define a material.

If the option to be created is a feature (identified by A), no colour values (COLOR) or texture (TEXTURE) must be specified.

Features are defined via T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION.
MATERIAL_NO required Restriction of xs:string
This attribute is used to identify a material. D string
P
M [1:5]
Sequence
COLOR
This element is used to define colours.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
OPTION_MEASURE 0..∞
This element is used to specify the values of options that are expressed in a dimension (e.g. backrest or cushion height).
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
This attribute identifies a dimensional variation. D positiveInteger
P
M [1:99999]
Sequence
MEASURE_VALUE Restriction of xs:nonNegativeInteger
This element is used to specify the dimensions. D nonNegativeInteger
P
M [0:999999999]
MEASURE_UNIT xs:string
This element is used to specify the unit of measure. D string
P
M
DECISIONS optional
This element is used to specify rules for options and features.
Sequence
DECISION 1..99999

This element is used to define and describe a rule that maps technically feasible configurations.
The rules are assigned to series or items by references from the corresponding elements. In total, all rules defined in this element must be referenced from either series or items.

Depending on the DECISION_TYPE attribute, different rules can be specified.

If the value in DECISION_TYPE is 0 or 1, the rule is a "preparation rule".

This allows for the definition of invalid and/or valid options in OPTION_COMBINATION. These are used to determine the valid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

The conditions are supplemented with operators. The special data type operator was defined for this purpose. It may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

The individual OPTION_COMBINATIONs must be considered as ELSE branches. This means that as soon as a condition line (OPTION_COMBINATION) receives a hit, the others will not be executed anymore.

If the value in DECISION_TYPE is 2, the rule is an action rule. It allows for the definition of actions depending on the conditions.

If all conditions within an „OPTION_COMBINATION“ are satisfied, all signed actions (ACTIONS) then can set values or make features (FEATURES) invisible depending on conditions. If an OPTION_COMBINATION is satisfied, the other conditions are not processed.

Actions (ACTIONS)

are instructions that are executed if a condition is met. The following actions can be executed:

    The setting of options ( SET_FEATURE_FIXED ) with the following options:

      - Direct, e.g. main fabric = "blue" (OPTION)

      - the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

      - the calculation of options (e.g. sitting height + 5 cm).
      This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
      This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
      The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

        The setting of standard versions ( SET_FEATURE_DEFAULT , SET_FEATURE_DEFAULT_NULL ):
        These can be filled if no value has been entered yet. The same options as above apply.

            The visibility of features ( SET_FEATURE_VISIBLE , SET_FEATURE_INVISIBLE ) and/or the deactivation of rules ( DISABLE_DECISION , ENABLE_DECISION ):
            Example: for wooden feet, a potentially existing feature for a shade can be displayed and made invisible if a metal foot is selected.

              Action rules are usually used in the configurator if an option value (an option) changes. If, for example, the foot option is changed from stainless steel to wood, a feature for the shade can be displayed.

              If the value in DECISION_TYPE is 3, the rule is an action rule for piece lists. Depending on the conditions, the quantity can be defined in the piece list here.

              DECISION_NO required Restriction of xs:positiveInteger
              This attribute is used to identify the rule. D positiveInteger
              P
              M [1:9999999999]
              DECISION_TYPE required Restriction of xs:int

              This attribute is used to specify the rule type.

              0 = excluding preparation rule

              This allows for the definition of invalid options in OPTION_COMBINATION/FEATURE_REF. These are used to determine the invalid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

              1 = Preparation rule

              This allows for the definition of valid options in OPTION_COMBINATION/FEATURE_REF. These are used to determine the valid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

              2 = Action rule
              It allows for the definition of actions in addition to the conditions.
              The rules are analysed before an option is entered for an item.
              Once a value has been selected, the action rules apply and then set values or make features invisible.
              For action rules, it is always the first line (OPTIONS_SET_REF) that applies. In this case, all associated ACTIONS are executed.

              3 = Action rule for quantity in piece lists (PositionCounter Rule)

              The quantity in the piece list can be defined here depending on the conditions via the action SET_POS_COUNT_VALUE.

                       D int
              P
              M [0-3]
              Sequence
              DECISION_NAME_TEXT languagetext60 Complex Type
              This element is used to specify the designation of a rule.
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              This attribute is used to specify the ISO code of the language in which the text is stored. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
              P [\S ]{1,60}
              M [1:60]
              OPTION_COMBINATION 1..∞

              This element is used to form a feature combination that is linked to certain conditions.

              If the value of DECISION_TYPE is 2 or 3, actions (ACTIONS) can also be assigned to the feature combination.

              SEQUENCE required Restriction of xs:nonNegativeInteger
              This element is used to specify the sequence in which the assigned assessment procedures will be executed. D nonNegativeInteger
              P
              M [1:99999]
              Sequence
              OPTIONS_SET_REF 0..∞

              This element is used to reference a feature and define a rule for its feature classes. The rules may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

              The simple data type operator was defined for this purpose and may contain the following values:

              eq (equal)

              ne (not equal)

              in (is contained in a quantity)

              nin (is not contained in a quantity)

              gt (greater)

              lt (less)

              ge (greater than or equal)

              le (less than or equal)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              REF_LEVEL optional Restriction of xs:nonNegativeInteger
              In piece lists, sub-positions can query features of the main position (PARENT), the uppermost position (ROOT) and the item itself (SELF) via the REF_LEVEL and depending on them trigger an action or integrate the action in a condition.

              1 = ROOT

              2 = PARENT

              3 = SELF (default is SELF if no REF level is specified)               		D nonNegativeInteger
              P
              M [1:3]
              Choice
              OPTION_INTERVAL
              This element is used to evaluate whether an option falls within or outside of an interval.
              OPERATOR required Restriction of operator Simple Type

              This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

              in (is contained in a quantity)

              nin (is not contained in a quantity)

                       D operator
              P in|nin
              M
              OPTION_KEY_MIN required Restriction of xs:string

              This attribute is used to specify the starting value of the interval.

                       D string
              P
              M [1:30]
              OPTION_KEY_MAX required Restriction of xs:string
              This attribute is used to specify the end value of the interval. D string
              P
              M [1:30]
              OPTION_LIST
              This element is used to evaluate whether an option corresponds to a value in a list.
              OPERATOR required Restriction of operator Simple Type

              This attribute is used to evaluate whether an option falls within or without a list of values.

              in (is contained in a quantity)

              nin (is not contained in a quantity)

                       D operator
              P in|nin
              M
              Sequence 1..∞
              OPTION_REF
              This element is used to reference the options in a comparison list.
              OPTION_GROUP_REF_OP
              This element is used to evaluate whether an option falls within a feature group.
              OPTION_GROUP_KEY required Restriction of xs:string
              This attribute is used to reference a feature group. D string
              P
              M [1:30]
              OPERATOR required Restriction of operator Simple Type

              This attribute is used to evaluate whether an option falls within a feature group.

              in (is contained in a quantity)

              nin (is not contained in a quantity)

                       D operator
              P in|nin
              M
              OPTION_REF_OP

              This element is used to define a comparison with an option.

              The comparison operator may contain the following values:

              eq (equal)

              ne (not equal)

              gt (greater)

              lt (less)

              ge (greater than or equal)

              le (less than or equal)

              OPTION_KEY required Restriction of xs:string
              This attribute is used to reference an option. D string
              P
              M [1:30]
              OPERATOR required Restriction of operator Simple Type
              This attribute is used to define a comparison with an option.

              The comparison operator may contain the following values:

              eq (equal)

              ne (not equal)

              gt (greater)

              lt (less)

              ge (greater than or equal)

              le (less than or equal)

                       D operator
              P eq|ne|gt|lt|ge|le
              M
              FEATURE_REF_OP

              This element is used to directly compare the feature.

              The comparison operator may contain the following values:

              eq (equal)

              ne (not equal)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              OPERATOR required Restriction of operator Simple Type
              This attribute is used to define a comparison with a feature.

              The comparison operator may contain the following values:

              eq (equal)

              ne (not equal)

                       D operator
              P eq|ne
              M
              MEASURE_VALUE_OP
              This element is used to check the dimension of an option using another dimension.
              MEASURE_VALUE required xs:nonNegativeInteger

              This attribute is used to specify the comparison dimension.

                       D nonNegativeInteger
              P
              M
              OPERATOR required Restriction of operator Simple Type
              This attribute is used to define a comparison with a dimension.

              The comparison operator may contain the following values:

              eq (equal)

              ne (not equal)

              gt (greater)

              lt (less)

              ge (greater than or equal)

              le (less than or equal)

                       D operator
              P eq|ne|gt|lt|ge|le
              M
              MEASURE_INTERVAL
              This element is used to evaluate whether an option's dimension falls within or outside of an interval.
              OPERATOR required Restriction of operator Simple Type

              This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

              in (is contained in a quantity)

              nin (is not contained in a quantity)

                       D operator
              P in|nin
              M
              MEASURE_MIN required xs:nonNegativeInteger

              This attribute is used to specify the starting value of the interval.

                       D nonNegativeInteger
              P
              M
              MEASURE_MAX required xs:nonNegativeInteger
              This attribute is used to specify the end value of the interval. D nonNegativeInteger
              P
              M
              ACTIONS optional

              This element is used to determine actions that are executed under certain conditions.

              Actions (ACTIONS) are instructions that are executed if a condition is met. The following actions can be executed:

              • The setting of options (SET_FEATURE_FIXED) with the following options:

              §Direct, e.g. main fabric = "blue" (OPTION)

              §the setting of feature values from another feature (FEATURE), e.g. ledge fabric = main fabric

              §the calculation of options (e.g. sitting height + 5 cm).
              This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
              This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
              The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

              • The setting of standard options (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
                These can be filled if no value has been entered yet. The same options as above apply.

              • The visibility of features (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) and disabling of rules (DISABLE_DECISION, ENABLE_DECISION):
                Example: for wooden feet, a potentially existing feature for a shade can be displayed and made invisible if a metal foot is selected.

              Choice 1..∞
              SET_FEATURE_DEFAULT

              This action is used to set standard options.

              These can be filled if no value has been entered yet.

              • The following options are available for the setting of options:

              - Direct , e.g. main fabric = "blue" (OPTION)

              - the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

              - the calculation of options. (e.g. seat height + 5 cm).
              This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
              This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
              The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              This element references another feature for the setting of option values.
              OPTION_REF
              This element is used to reference an option (OPTION) that is directly set as standard.
              FORMULA_REF
              This element is used to reference a formula for the calculation of standard values.
              SET_FEATURE_FIXED

              This action is used to set options.

              The following options are available for the setting of options:

              - Direct , e.g. main fabric = "blue" (OPTION)

              - the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

              - the calculation of options. (e.g. seat height + 5 cm).
              This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
              This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
              The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              This element references another feature for the setting of option values.
              OPTION_REF
              This element is used to reference an option (OPTION) that is set directly.
              FORMULA_REF
              This element is used to reference a formula for the calculation of options.
              ENABLE_DECISION

              This action activates rules.

              DECISION_NO optional Restriction of xs:positiveInteger
              This attribute is used to reference a rule. D positiveInteger
              P
              M [1:9999999999]
              DISABLE_DECISION

              This action deactivates rules.

              DECISION_NO optional Restriction of xs:positiveInteger
              This attribute is used to reference a rule. D positiveInteger
              P
              M [1:9999999999]
              SET_FEATURE_VISIBLE
              This action makes features visible.
              FEATURE_NO optional Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              SET_FEATURE_INVISIBLE
              This action makes features invisible.
              FEATURE_NO optional Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              SET_FEATURE
              This action sets a value for an option of a feature. Contrary to „SET_FEATURE FIXED“, this value can be modified if permitted by the conditions. This value rule also applies if the corresponding field was previously set to default or manual.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              This element references another feature for the setting of option values.
              OPTION_REF
              This element is used to reference an option (OPTION) that is set directly.
              FORMULA_REF
              This element is used to reference a formula for the calculation of options.
              SET_FEATURE_DEFAULT_NULL

              This action is used to set standard options.

              The default value only applies if the relevant feature field was previously blank.

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              This element references another feature for the setting of NULL.
              OPTION_REF
              This element is used to reference an option (OPTION) that is set to NULL.
              FORMULA_REF
              This element is used to reference a formula for the calculation of options.
              SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
              This version is used to set a quantity in the piece list.
              This action must only be specified for rules with DECISION_TYPE = 3.               		D nonNegativeInteger
              P
              M [0:9999]
              SET_MESSAGE
              This element is used to set a message for the purpose of triggering warnings or notices for certain feature combinations.
              MESSAGE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a message. D nonNegativeInteger
              P
              M [0:999999]
              VALID_FROM optional Restriction of xs:date
              This element is used to specify the date from which date onwards a rule is valid.
              Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date.               		D date
              P
              M
              VALID_UNTIL optional Restriction of xs:date
              This element specifies the date until which a rule is valid.
              Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.               		D date
              P
              M
              FEATURE_REF 0..∞
              This element is used to reference a feature.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              PRIO Restriction of xs:positiveInteger
              This element is used to specify a value for the priority of a rule.
              A low value means a high priority. This means that the rule takes a lower priority the higher this value is.               		D positiveInteger
              P
              M [1:999999999]
              OPTION_GROUPS optional
              This element is used to group quantities of options. They can be referenced in the assessment below OPTION_COMBINATION/FEATURE_REF in DECISIONS. These options are to be considered an independent pool and have no connection to any feature.
              Sequence
              OPTION_GROUP 1..∞

              This element is used to specify a feature group.

              It can be referenced in assessments below OPTION_COMBINATION/FEATURE_REF in the DECISIONS . These options are to be considered an independent pool and have no connection to any feature.

              OPTION_GROUP_KEY required Restriction of xs:string
              This attribute is used to identify a feature group. D string
              P
              M [1:30]
              Sequence
              OPTION 1..∞
              This element is used to reference an option.
              OPTION_KEY required Restriction of xs:string
              This attribute is used to reference an option. D string
              P
              M [1:30]
              SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
              This attribute defines the order of the options in a feature group. D nonNegativeInteger
              P
              M
              OPTION_GROUP_TEXT languagetext60 Complex Type
              This element contains texts for feature groups.
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              This attribute is used to specify the ISO code of the language in which the text is stored. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
              P [\S ]{1,60}
              M [1:60]
              FORMULAS optional
              This element is used for the calculation of options (e.g. sitting height + 5 cm). The function is however only permitted for dimensional versions with a feature that contains the value "M", the unit of measure can be entered in MEASURE_UNIT, the parameter (e.g. sh for sitting height) in MEASURE_PARAMETER. The calculation is carried out via a formula string that may contain parameters and values.
              Sequence
              FORMULA 1..∞
              The element serves the purpose of defining a formula.The attribute FORMULA_KEY contains the identifier, the FORMULA_STRING contains the actual formula.
              FORMULA_KEY required Restriction of xs:string
              This attribute is used to define the key for the formula. D string
              P
              M [1:30]
              Sequence
              FORMULA_STRING Restriction of xs:string
              This element is used to specify a formula. D string
              P [+\-*/()A-Za-z. ]{0,}
              M
              Remarks

              Source
              <xs:element name="FEATURE_DEFINITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_CLASSES">
        <xs:annotation>
          <xs:documentation>255--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_CLASS" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>255--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>255--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>255--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="INVISIBLE" type="xs:boolean">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">neu 2.4 BA/07.03.2014
unsichtbare Variantenart.
Wird nicht im Konfigurator angezeigt.
</xs:documentation>
                        </xs:annotation>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_CLASS_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>255--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                    <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURES">
        <xs:annotation>
          <xs:documentation>250--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:choice minOccurs="0">
                                <xs:element name="MATERIAL_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="MATERIAL_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="5" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="FORM_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="FORM_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="5" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_MEASURE_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_MEASURE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:choice>
                              <xs:element name="OPTION_TEXT" type="languagetext60">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_FREETEXT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:boolean" />
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FEATURE_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="SEQUENCE_NO">
                    <xs:annotation>
                      <xs:documentation>250--4--Sortierung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HEADER_POS_VARIATION_TYPE">
                    <xs:annotation>
                      <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[IKP]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FEATURE_TYPE">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MEASURE" minOccurs="0">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="MEASURE_UNIT" type="xs:string">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="MEASURE_PARAMETER" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:maxLength value="20" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_T">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:length value="1" />
                            <xs:pattern value="[MCO]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>250--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="COLOR">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RGB_RED">
                          <xs:annotation>
                            <xs:documentation>260--11--RGB_Rot</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="255" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="RGB_GREEN">
                          <xs:annotation>
                            <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="255" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="RGB_BLUE">
                          <xs:annotation>
                            <xs:documentation>260--13--RGB_Blau</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="255" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="MATERIAL_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MEASURE_VALUE">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MEASURE_UNIT" type="xs:string">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPTION_MEASURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DECISIONS" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>270/271--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>nicht zwingend anzugeben, K. Richter, 23.05.2014</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION" maxOccurs="99999">
              <xs:annotation>
                <xs:documentation>270/271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_NAME_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>270--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:complexType>
                            <xs:choice>
                              <xs:element name="OPTION_INTERVAL">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="in|nin" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY_MIN" use="required">
                                    <xs:annotation>
                                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY_MAX" use="required">
                                    <xs:annotation>
                                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_LIST">
                                <xs:complexType>
                                  <xs:sequence maxOccurs="unbounded">
                                    <xs:element name="OPTION_REF">
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="in|nin" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_GROUP_REF_OP">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="in|nin" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF_OP">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FEATURE_REF_OP">
                                <xs:annotation>
                                  <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
                                  <xs:documentation />
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="eq|ne" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="MEASURE_VALUE_OP">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                    </xs:annotation>
                                  </xs:attribute>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="MEASURE_INTERVAL">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="in|nin" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                    <xs:annotation>
                                      <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                    </xs:annotation>
                                  </xs:attribute>
                                  <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                    <xs:annotation>
                                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                    </xs:annotation>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="REF_LEVEL" use="optional">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">1 = ROOT
2 = PARENT
3 = SELF
Standardfall ist SELF, wenn kein REF-Level angegeben ist</xs:documentation>
                                <xs:documentation xml:lang="DE">12.02.2015 K. Richter</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:maxInclusive value="3" />
                                  <xs:minInclusive value="1" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ACTIONS" minOccurs="0">
                          <xs:complexType>
                            <xs:choice maxOccurs="unbounded">
                              <xs:element name="SET_FEATURE_DEFAULT">
                                <xs:complexType>
                                  <xs:choice>
                                    <xs:element name="FEATURE_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF">
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FORMULA_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FORMULA_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="SET_FEATURE_FIXED">
                                <xs:complexType>
                                  <xs:choice>
                                    <xs:element name="FEATURE_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF">
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FORMULA_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FORMULA_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ENABLE_DECISION">
                                <xs:complexType>
                                  <xs:attribute name="DECISION_NO">
                                    <xs:annotation>
                                      <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="DISABLE_DECISION">
                                <xs:complexType>
                                  <xs:attribute name="DECISION_NO">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="SET_FEATURE_VISIBLE">
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="SET_FEATURE_INVISIBLE">
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="SET_FEATURE">
                                <xs:complexType>
                                  <xs:choice>
                                    <xs:element name="FEATURE_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF">
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FORMULA_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FORMULA_KEY">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="SET_FEATURE_DEFAULT_NULL">
                                <xs:complexType>
                                  <xs:choice>
                                    <xs:element name="FEATURE_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF">
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_KEY">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FORMULA_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FORMULA_KEY">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="SET_POS_COUNT_VALUE">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                  <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                                  <xs:documentation>setzt Anzahl</xs:documentation>
                                  <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="SET_MESSAGE">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                  <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                                  <xs:documentation>setzt Anzahl</xs:documentation>
                                  <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="MESSAGE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                      <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                      <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FEATURE_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Entscheidungstabellen wieder entfernt, nur Angabe FEATURE_NO, 02.05.2014</xs:documentation>
                      <xs:documentation xml:lang="de">Version Beta 2.0 Build 12</xs:documentation>
                      <xs:documentation xml:lang="de">minimale Kardinalität auf 0 geändert K.Richter 18.07.2014</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRIO">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">neu IDM 2.4
Priorität von Prüfungen

Am Artikel können nur Decisions mit niedriger Priorität hinzu bzw. ausgeschaltet werden
Mehrere DECISIONS können auf einem gleichen Priolevel liegen

</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DECISION_TYPE" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">IDM 2.4 Build 14 H.Balke 05.2014
0 = ausschließende (nicht erlaubende) Preparation
1 = Preparation
2 = action Rules
3 = action Rule mit SET_POS_COUNT_VALUE (setzt die Anzahl in der die Position in der Stückliste erscheint)

Restriktions werden vor Eingabe einer Variante am Artikel ausgewertet.
Wenn dann ein Wert ausgewählt wurde, greifen die action Rules, welche dann Werte setzen oder Variantenarten ausblenden können.
Bei Action Rules greift immer die erste Zeile (option combination), die zutrifft. In dem Fall werden alle zugehörigen Actions ausgeführt.
</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:int">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="3" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_GROUPS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_GROUP" maxOccurs="unbounded">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_GROUP_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPTION_GROUP_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FORMULAS" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="de">Formeln dürfen nur angewendet werden auf Maßvarianten </xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FORMULA" maxOccurs="unbounded">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FORMULA_STRING">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Formeln dürfen nur Parameter enthalten, die an der Variantenart definiert wurden.</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[+\-*/()A-Za-z0-9. ]*" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FORMULA_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
              See Also
              T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_CLASSES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : FEATURE_CLASSES Element
Description

This element is used to combine features in families. These feature classes can be used to carry out plausibility and completeness checks with respect to the valid features.

The defined feature classes (path 1) can be assigned to series or product groups via FEATURE_CLASS_REF in SERIE and PRODUCT_GROUP. There is no relationship with respect to a priority between feature classes on series and item level. The number of features that are valid for an item results from the total number of features declared in the items product group.

All features that are referenced via the elements in PRICE_FEATURE_GROUP (path 3), PRICE_FEATURE_BASE_PRICE_GROUP_REF (path 4) and FINISH (path 5) must be contained in the feature class of the item.

The features used via the elements RESTRICTION_REF (path 6) and RESTRICTION_REF (path 8) must also be contained in the item's feature class.

Element paths
Path 1 : FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS
Path 2 : FEATURE_DEFINITION/FEATURES
Path 3 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 5 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Path 6: SERIES/RESTRICTIONS/RESTRICTION_REF
Path 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS

Namespace (none)
Diagram
FEATURE_CLASS Element Sequence FEATURE_CLASSES Element
Overview
FEATURE_CLASSES

This element is used to combine features in families. These feature classes can be used to carry out plausibility and completeness checks with respect to the valid features.

The defined feature classes (path 1) can be assigned to series or product groups via FEATURE_CLASS_REF in SERIE and PRODUCT_GROUP. There is no relationship with respect to a priority between feature classes on series and item level. The number of features that are valid for an item results from the total number of features declared in the items product group.

All features that are referenced via the elements in PRICE_FEATURE_GROUP (path 3), PRICE_FEATURE_BASE_PRICE_GROUP_REF (path 4) and FINISH (path 5) must be contained in the feature class of the item.

The features used via the elements RESTRICTION_REF (path 6) and RESTRICTION_REF (path 8) must also be contained in the item's feature class.

Element paths
Path 1 : FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS
Path 2 : FEATURE_DEFINITION/FEATURES
Path 3 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 5 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Path 6: SERIES/RESTRICTIONS/RESTRICTION_REF
Path 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS

Sequence
FEATURE_CLASS 1..∞
This element is used to define a feature class.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute is used to identify a feature class. D positiveInteger
P
M [1:9999999999]
Sequence
FEATURE_REF 1..∞
This feature refers to the FEATURE (path 1) element.
Only helpful options must be referenced in the feature class of an item. Example: the feature class vacation must not contain any features for feet shapes.

Element paths
Path 1 : FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:9999]
INVISIBLE optional xs:boolean
If the value of this attribute is set to true (or 1), it specifies that the corresponding feature is invisible. D boolean
P
M
.
Remarks

Source
<xs:element name="FEATURE_CLASSES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_CLASS" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>255--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>255--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>255--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="INVISIBLE" type="xs:boolean">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">neu 2.4 BA/07.03.2014
unsichtbare Variantenart.
Wird nicht im Konfigurator angezeigt.
</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_CLASS_NO" use="required">
            <xs:annotation>
              <xs:documentation>255--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
              <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_CLASS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURE_CLASSES Element : FEATURE_CLASS Element
Description
This element is used to define a feature class.
Namespace (none)
Diagram
FEATURE_REF Element Sequence FEATURE_CLASS Element
Overview
FEATURE_CLASS 1..∞
This element is used to define a feature class.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute is used to identify a feature class. D positiveInteger
P
M [1:9999999999]
Sequence
FEATURE_REF 1..∞
This feature refers to the FEATURE (path 1) element.
Only helpful options must be referenced in the feature class of an item. Example: the feature class vacation must not contain any features for feet shapes.

Element paths
Path 1 : FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:9999]
INVISIBLE optional xs:boolean
If the value of this attribute is set to true (or 1), it specifies that the corresponding feature is invisible. D boolean
P
M
.
Attributes
Name Type Use Default Fixed Description
FEATURE_CLASS_NO Restriction of xs:positiveInteger required
This attribute is used to identify a feature class. D positiveInteger
P
M [1:9999999999]
Remarks

Source
<xs:element name="FEATURE_CLASS" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>255--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>255--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="INVISIBLE" type="xs:boolean">
            <xs:annotation>
              <xs:documentation xml:lang="de">neu 2.4 BA/07.03.2014
unsichtbare Variantenart.
Wird nicht im Konfigurator angezeigt.
</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_CLASS_NO" use="required">
      <xs:annotation>
        <xs:documentation>255--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
        <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FEATURE_CLASSES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURE_CLASSES Element > FEATURE_CLASS Element : FEATURE_REF Element
Description
This feature refers to the FEATURE (path 1) element.
Only helpful options must be referenced in the feature class of an item. Example: the feature class vacation must not contain any features for feet shapes.

Element paths
Path 1 : FEATURE_DEFINITION/FEATURES
Namespace (none)
Diagram
FEATURE_REF Element
Overview
FEATURE_REF 1..∞
This feature refers to the FEATURE (path 1) element.
Only helpful options must be referenced in the feature class of an item. Example: the feature class vacation must not contain any features for feet shapes.

Element paths
Path 1 : FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:9999]
INVISIBLE optional xs:boolean
If the value of this attribute is set to true (or 1), it specifies that the corresponding feature is invisible. D boolean
P
M
.
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:9999]
INVISIBLE xs:boolean optional
If the value of this attribute is set to true (or 1), it specifies that the corresponding feature is invisible. D boolean
P
M
.
Remarks

Source
<xs:element name="FEATURE_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>255--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="INVISIBLE" type="xs:boolean">
      <xs:annotation>
        <xs:documentation xml:lang="de">neu 2.4 BA/07.03.2014
unsichtbare Variantenart.
Wird nicht im Konfigurator angezeigt.
</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FEATURE_CLASS Element | FEATURE_CLASSES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : FEATURES Element
Description

This element is used to define the features (FEATURE) and the associated options. Only the features needed for correctly mapping the catalogue are defined.

The combination of finish and colour is used for some features.

If this is the case, features must always be created in pairs. The corresponding colour feature exists for the respective finish option types; a corresponding finish feature exists for the colour feature.

Features declared as invisible features are not be referenced in a feature class.

All features in the FEATURES (path 3) element that are not declared as invisible head feature must be referenced in at least one feature class.

Further information about features can be found in the Introduction in section "features"
Element paths
Path 1 : FEATURE_DEFINITION/FEATURES
Path 2: FEATURE_DEFINITION/FEATURES/FEATURE
Path 3: FEATURE_DEFINITION

Namespace (none)
Diagram
FEATURE Element Sequence FEATURES Element
Overview
FEATURES

This element is used to define the features (FEATURE) and the associated options. Only the features needed for correctly mapping the catalogue are defined.

The combination of finish and colour is used for some features.

If this is the case, features must always be created in pairs. The corresponding colour feature exists for the respective finish option types; a corresponding finish feature exists for the colour feature.

Features declared as invisible features are not be referenced in a feature class.

All features in the FEATURES (path 3) element that are not declared as invisible head feature must be referenced in at least one feature class.

Further information about features can be found in the Introduction in section "features"
Element paths
Path 1 : FEATURE_DEFINITION/FEATURES
Path 2: FEATURE_DEFINITION/FEATURES/FEATURE
Path 3: FEATURE_DEFINITION

Sequence
FEATURE 1..∞
This element is used to define a feature.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a feature. D nonNegativeInteger
P
M [0:9999]
Sequence
OPTIONS optional
It is a container element in which the possible variations of a feature are stored.
The element is omitted for resulting features (HEADER_POS_VARIATION_TYPE=V).
Sequence
OPTION 1..∞
This element is used to define the options for feature.All options necessary in the data pool are stored here. If the option to be created is a feature (introduction: table features identified by type A), no colour values or texture must be specified. The gloss and opaqueness can optionally be assigned to a feature and have priority over corresponding colour variations.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute allows for the specification of a freely-defined sorting order. D nonNegativeInteger
P
M
Sequence
Choice optional
MATERIAL_REF
This element is used to reference a material.
MATERIAL_NO required Restriction of xs:string
This attribute is used to reference a material. D string
P
M [1:5]
FORM_REF
This element is used to reference a shape.

FORM_NO required Restriction of xs:string
This attribute is used to reference a profile shape. D string
P
M [1:5]
OPTION_MEASURE_REF
This attribute is used to reference a dimensional variation of a feature.
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
This attribute is used to reference a dimension variation. D positiveInteger
P
M [1:99999]
OPTION_TEXT languagetext60 Complex Type
This element is used to define an option text.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements:
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.It is possible to assign a number of detail information to one option, and each image of the option can then be assigned to specific series or items. The respective image/media will then only be displayed for the corresponding series or item.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
This element is used to reference the series.
ITEM_REF 0..∞
This element is used to reference an item.
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
This element contains texts for features.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element is used to specify a manufacturer-specific sorting for the features.
The order is a recommendation by the manufacturer. The dealership will, if necessary, work with a different sorting. The sorting is, for example, used for: display in on-screen forms, order of the options during the ordering process, or forms.
The sorting must be specified unequivocally for all data records.
The element is left blank for invisible head options (HEADER_POS_VARIATION_TYPE = U (path 1)).

Element paths
Path 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
This element is an identifier that specifies whether a feature is an
I = implicit feature,
K = head option, or
P = position feature.

It serves the purpose of controlling the processing method on head or position level, features designated with a "P" must, according to the manufacturer, not be processed on head level.

Features designated with an "I" are visible and result implicitly from other features. 		D string
P [IKP]
M [1:1]
FEATURE_TYPE
This element is used to identify the feature corresponding to the option. A feature can be assigned dimensional variations (value of FEATURE_T "M"), colour variations (value of FEATURE_T "C") or other features (value of FEATURE_T "O").
FEATURE_T optional Restriction of xs:string

This attribute is used to define the options assigned to the feature.

M = dimensional versions

C = colour versions

O = other options

 D string
P [MCO]
M [1:1]
Sequence
MEASURE optional

If the options assigned to the feature are dimensional versions, the dimensional information is entered in this element.

They consist of a dimensional parameter, the unit of measure and can then, for example, be used in the formulas of the rules (DECISIONS).

Sequence
MEASURE_UNIT xs:string
This element is used to specify the unit of measure. D string
P
M
MEASURE_PARAMETER optional Restriction of xs:string

This element is used to specify the parameters for defining a formula, e.g. planning width = 2 * st +sb, with st expressing the side part width and sb expressing the seat width.

 D string
P
M
Remarks

Source
<xs:element name="FEATURES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:choice minOccurs="0">
                          <xs:element name="MATERIAL_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="MATERIAL_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="5" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="FORM_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="FORM_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="5" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_MEASURE_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPTION_MEASURE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                        <xs:element name="OPTION_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_FREETEXT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURE_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="SEQUENCE_NO">
              <xs:annotation>
                <xs:documentation>250--4--Sortierung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEADER_POS_VARIATION_TYPE">
              <xs:annotation>
                <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[IKP]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FEATURE_TYPE">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MEASURE" minOccurs="0">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MEASURE_UNIT" type="xs:string">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="MEASURE_PARAMETER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:maxLength value="20" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_T">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:length value="1" />
                      <xs:pattern value="[MCO]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>250--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element : FEATURE Element
Description
This element is used to define a feature.
Namespace (none)
Diagram
FEATURE_TYPE Element HEADER_POS_VARIATION_TYPE Element SEQUENCE_NO Element LANGUAGE Element Sequence FEATURE_TEXT Element OPTIONS Element Sequence FEATURE Element
Overview
FEATURE 1..∞
This element is used to define a feature.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a feature. D nonNegativeInteger
P
M [0:9999]
Sequence
OPTIONS optional
It is a container element in which the possible variations of a feature are stored.
The element is omitted for resulting features (HEADER_POS_VARIATION_TYPE=V).
Sequence
OPTION 1..∞
This element is used to define the options for feature.All options necessary in the data pool are stored here. If the option to be created is a feature (introduction: table features identified by type A), no colour values or texture must be specified. The gloss and opaqueness can optionally be assigned to a feature and have priority over corresponding colour variations.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute allows for the specification of a freely-defined sorting order. D nonNegativeInteger
P
M
Sequence
Choice optional
MATERIAL_REF
This element is used to reference a material.
MATERIAL_NO required Restriction of xs:string
This attribute is used to reference a material. D string
P
M [1:5]
FORM_REF
This element is used to reference a shape.

FORM_NO required Restriction of xs:string
This attribute is used to reference a profile shape. D string
P
M [1:5]
OPTION_MEASURE_REF
This attribute is used to reference a dimensional variation of a feature.
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
This attribute is used to reference a dimension variation. D positiveInteger
P
M [1:99999]
OPTION_TEXT languagetext60 Complex Type
This element is used to define an option text.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements:
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.It is possible to assign a number of detail information to one option, and each image of the option can then be assigned to specific series or items. The respective image/media will then only be displayed for the corresponding series or item.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
This element is used to reference the series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
This element is used to reference an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the series of the referenced item. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
This element contains texts for features.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element is used to specify a manufacturer-specific sorting for the features.
The order is a recommendation by the manufacturer. The dealership will, if necessary, work with a different sorting. The sorting is, for example, used for: display in on-screen forms, order of the options during the ordering process, or forms.
The sorting must be specified unequivocally for all data records.
The element is left blank for invisible head options (HEADER_POS_VARIATION_TYPE = U (path 1)).

Element paths
Path 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
This element is an identifier that specifies whether a feature is an
I = implicit feature,
K = head option, or
P = position feature.

It serves the purpose of controlling the processing method on head or position level, features designated with a "P" must, according to the manufacturer, not be processed on head level.

Features designated with an "I" are visible and result implicitly from other features. 		D string
P [IKP]
M [1:1]
FEATURE_TYPE
This element is used to identify the feature corresponding to the option. A feature can be assigned dimensional variations (value of FEATURE_T "M"), colour variations (value of FEATURE_T "C") or other features (value of FEATURE_T "O").
FEATURE_T optional Restriction of xs:string

This attribute is used to define the options assigned to the feature.

M = dimensional versions

C = colour versions

O = other options

 D string
P [MCO]
M [1:1]
Sequence
MEASURE optional

If the options assigned to the feature are dimensional versions, the dimensional information is entered in this element.

They consist of a dimensional parameter, the unit of measure and can then, for example, be used in the formulas of the rules (DECISIONS).

Sequence
MEASURE_UNIT xs:string
This element is used to specify the unit of measure. D string
P
M
MEASURE_PARAMETER optional Restriction of xs:string

This element is used to specify the parameters for defining a formula, e.g. planning width = 2 * st +sb, with st expressing the side part width and sb expressing the seat width.

 D string
P
M
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to identify a feature. D nonNegativeInteger
P
M [0:9999]
Remarks

Source
<xs:element name="FEATURE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:choice minOccurs="0">
                    <xs:element name="MATERIAL_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="MATERIAL_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="FORM_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="FORM_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_MEASURE_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPTION_MEASURE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                  <xs:element name="OPTION_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_FREETEXT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="SEQUENCE_NO">
        <xs:annotation>
          <xs:documentation>250--4--Sortierung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEADER_POS_VARIATION_TYPE">
        <xs:annotation>
          <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[IKP]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FEATURE_TYPE">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MEASURE" minOccurs="0">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MEASURE_UNIT" type="xs:string">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="MEASURE_PARAMETER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_T">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:length value="1" />
                <xs:pattern value="[MCO]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>250--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : OPTIONS Element
Description
It is a container element in which the possible variations of a feature are stored.
The element is omitted for resulting features (HEADER_POS_VARIATION_TYPE=V).
Namespace (none)
Diagram
OPTION Element Sequence OPTIONS Element
Overview
OPTIONS optional
It is a container element in which the possible variations of a feature are stored.
The element is omitted for resulting features (HEADER_POS_VARIATION_TYPE=V).
Sequence
OPTION 1..∞
This element is used to define the options for feature.All options necessary in the data pool are stored here. If the option to be created is a feature (introduction: table features identified by type A), no colour values or texture must be specified. The gloss and opaqueness can optionally be assigned to a feature and have priority over corresponding colour variations.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute allows for the specification of a freely-defined sorting order. D nonNegativeInteger
P
M
Sequence
Choice optional
MATERIAL_REF
This element is used to reference a material.
MATERIAL_NO required Restriction of xs:string
This attribute is used to reference a material. D string
P
M [1:5]
FORM_REF
This element is used to reference a shape.

FORM_NO required Restriction of xs:string
This attribute is used to reference a profile shape. D string
P
M [1:5]
OPTION_MEASURE_REF
This attribute is used to reference a dimensional variation of a feature.
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
This attribute is used to reference a dimension variation. D positiveInteger
P
M [1:99999]
OPTION_TEXT languagetext60 Complex Type
This element is used to define an option text.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements:
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.It is possible to assign a number of detail information to one option, and each image of the option can then be assigned to specific series or items. The respective image/media will then only be displayed for the corresponding series or item.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
This element is used to reference the series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
This element is used to reference an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the series of the referenced item. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
Remarks

Source
<xs:element name="OPTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:choice minOccurs="0">
              <xs:element name="MATERIAL_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="MATERIAL_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="FORM_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="FORM_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="OPTION_MEASURE_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="OPTION_MEASURE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:choice>
            <xs:element name="OPTION_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_FREETEXT" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element : OPTION Element
Description
This element is used to define the options for feature.All options necessary in the data pool are stored here. If the option to be created is a feature (introduction: table features identified by type A), no colour values or texture must be specified. The gloss and opaqueness can optionally be assigned to a feature and have priority over corresponding colour variations.
Namespace (none)
Diagram
OPTION_FREETEXT Element DETAIL_INFOS Element VALID_UNTIL Element VALID_FROM Element LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element LANGUAGE Element Sequence OPTION_TEXT Element OPTION_MEASURE_REF Element FORM_REF Element MATERIAL_REF Element Choice Sequence OPTION Element
Overview
OPTION 1..∞
This element is used to define the options for feature.All options necessary in the data pool are stored here. If the option to be created is a feature (introduction: table features identified by type A), no colour values or texture must be specified. The gloss and opaqueness can optionally be assigned to a feature and have priority over corresponding colour variations.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute allows for the specification of a freely-defined sorting order. D nonNegativeInteger
P
M
Sequence
Choice optional
MATERIAL_REF
This element is used to reference a material.
MATERIAL_NO required Restriction of xs:string
This attribute is used to reference a material. D string
P
M [1:5]
FORM_REF
This element is used to reference a shape.

FORM_NO required Restriction of xs:string
This attribute is used to reference a profile shape. D string
P
M [1:5]
OPTION_MEASURE_REF
This attribute is used to reference a dimensional variation of a feature.
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
This attribute is used to reference a dimension variation. D positiveInteger
P
M [1:99999]
OPTION_TEXT languagetext60 Complex Type
This element is used to define an option text.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements:
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.It is possible to assign a number of detail information to one option, and each image of the option can then be assigned to specific series or items. The respective image/media will then only be displayed for the corresponding series or item.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
This element is used to reference the series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
This element is used to reference an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the series of the referenced item. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
Attributes
Name Type Use Default Fixed Description
OPTION_KEY Restriction of xs:string required
This attribute is used to reference an option. D string
P
M [1:30]
SEQUENCE_NO Restriction of xs:nonNegativeInteger optional
This attribute allows for the specification of a freely-defined sorting order. D nonNegativeInteger
P
M
Remarks

Source
<xs:element name="OPTION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:choice minOccurs="0">
        <xs:element name="MATERIAL_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="MATERIAL_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="5" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="FORM_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="FORM_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="5" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="OPTION_MEASURE_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="OPTION_MEASURE_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:choice>
      <xs:element name="OPTION_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_FREETEXT" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MATERIAL_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : MATERIAL_REF Element
Description
This element is used to reference a material.
Namespace (none)
Diagram
MATERIAL_REF Element
Overview
MATERIAL_REF
This element is used to reference a material.
MATERIAL_NO required Restriction of xs:string
This attribute is used to reference a material. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
MATERIAL_NO Restriction of xs:string required
This attribute is used to reference a material. D string
P
M [1:5]
Remarks

Source
<xs:element name="MATERIAL_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MATERIAL_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORM_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : FORM_REF Element
Description
This element is used to reference a shape.

Namespace (none)
Diagram
FORM_REF Element
Overview
FORM_REF
This element is used to reference a shape.

FORM_NO required Restriction of xs:string
This attribute is used to reference a profile shape. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FORM_NO Restriction of xs:string required
This attribute is used to reference a profile shape. D string
P
M [1:5]
Remarks

Source
<xs:element name="FORM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FORM_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_MEASURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_MEASURE_REF Element
Description
This attribute is used to reference a dimensional variation of a feature.
Namespace (none)
Diagram
OPTION_MEASURE_REF Element
Overview
OPTION_MEASURE_REF
This attribute is used to reference a dimensional variation of a feature.
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
This attribute is used to reference a dimension variation. D positiveInteger
P
M [1:99999]
Attributes
Name Type Use Default Fixed Description
OPTION_MEASURE_NO Restriction of xs:positiveInteger required
This attribute is used to reference a dimension variation. D positiveInteger
P
M [1:99999]
Remarks

Source
<xs:element name="OPTION_MEASURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_MEASURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_TEXT Element
Description
This element is used to define an option text.
Namespace (none)
Type
languagetext60 Complex Type
Diagram
LANGUAGE Element Sequence OPTION_TEXT Element
Overview
OPTION_TEXT languagetext60 Complex Type
This element is used to define an option text.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="OPTION_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_COMMENT_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_COMMENT_TEXT Element
Description
This element is used to reference a general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element
Overview
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_FROM Element
Description
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Remarks

Source
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_UNTIL Element
Description
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements:
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of options.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the option is continued for the planning. The following conditions apply for filling the elements:
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FROM element is filled: available from delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Remarks

Source
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFOS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : DETAIL_INFOS Element
Description
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.It is possible to assign a number of detail information to one option, and each image of the option can then be assigned to specific series or items. The respective image/media will then only be displayed for the corresponding series or item.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.It is possible to assign a number of detail information to one option, and each image of the option can then be assigned to specific series or items. The respective image/media will then only be displayed for the corresponding series or item.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
This element is used to reference the series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
This element is used to reference an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the series of the referenced item. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
Remarks

Source
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description
This element is used to reference the detailed information.
Namespace (none)
Diagram
ITEM_REF Element SERIE_REF Element Sequence DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
This element is used to reference the series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
This element is used to reference an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the series of the referenced item. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element > DETAIL_INFO_REF Element : SERIE_REF Element
Description
This element is used to reference the series.
Namespace (none)
Diagram
SERIE_REF Element
Overview
SERIE_REF 0..∞
This element is used to reference the series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFO_REF Element | DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element > DETAIL_INFO_REF Element : ITEM_REF Element
Description
This element is used to reference an item.
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF 0..∞
This element is used to reference an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the series of the referenced item. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify the identification number of the series of the referenced item. D nonNegativeInteger
P
M [0:999999]
TYPE_NO Restriction of xs:string required
This attribute is used to reference an item with an item number. D string
P
M [1:30]
Source
<xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFO_REF Element | DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_FREETEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_FREETEXT Element
Description
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
OPTION_FREETEXT Element
Overview
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
Source
<xs:element name="OPTION_FREETEXT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : FEATURE_TEXT Element
Description
This element contains texts for features.
Namespace (none)
Type
languagetext60 Complex Type
Diagram
LANGUAGE Element Sequence FEATURE_TEXT Element
Overview
FEATURE_TEXT languagetext60 Complex Type
This element contains texts for features.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="FEATURE_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SEQUENCE_NO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : SEQUENCE_NO Element
Description
This element is used to specify a manufacturer-specific sorting for the features.
The order is a recommendation by the manufacturer. The dealership will, if necessary, work with a different sorting. The sorting is, for example, used for: display in on-screen forms, order of the options during the ordering process, or forms.
The sorting must be specified unequivocally for all data records.
The element is left blank for invisible head options (HEADER_POS_VARIATION_TYPE = U (path 1)).

Element paths
Path 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
SEQUENCE_NO Element
Overview
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element is used to specify a manufacturer-specific sorting for the features.
The order is a recommendation by the manufacturer. The dealership will, if necessary, work with a different sorting. The sorting is, for example, used for: display in on-screen forms, order of the options during the ordering process, or forms.
The sorting must be specified unequivocally for all data records.
The element is left blank for invisible head options (HEADER_POS_VARIATION_TYPE = U (path 1)).

Element paths
Path 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
Remarks

Source
<xs:element name="SEQUENCE_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--4--Sortierung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

HEADER_POS_VARIATION_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : HEADER_POS_VARIATION_TYPE Element
Description
This element is an identifier that specifies whether a feature is an
I = implicit feature,
K = head option, or
P = position feature.

It serves the purpose of controlling the processing method on head or position level, features designated with a "P" must, according to the manufacturer, not be processed on head level.

Features designated with an "I" are visible and result implicitly from other features. 		D string
P [IKP]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
HEADER_POS_VARIATION_TYPE Element
Overview
HEADER_POS_VARIATION_TYPE Restriction of xs:string
This element is an identifier that specifies whether a feature is an
I = implicit feature,
K = head option, or
P = position feature.

It serves the purpose of controlling the processing method on head or position level, features designated with a "P" must, according to the manufacturer, not be processed on head level.

Features designated with an "I" are visible and result implicitly from other features. 		D string
P [IKP]
M [1:1]
Remarks

Source
<xs:element name="HEADER_POS_VARIATION_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[IKP]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : FEATURE_TYPE Element
Description
This element is used to identify the feature corresponding to the option. A feature can be assigned dimensional variations (value of FEATURE_T "M"), colour variations (value of FEATURE_T "C") or other features (value of FEATURE_T "O").
Namespace (none)
Diagram
MEASURE Element Sequence FEATURE_TYPE Element
Overview
FEATURE_TYPE
This element is used to identify the feature corresponding to the option. A feature can be assigned dimensional variations (value of FEATURE_T "M"), colour variations (value of FEATURE_T "C") or other features (value of FEATURE_T "O").
FEATURE_T optional Restriction of xs:string

This attribute is used to define the options assigned to the feature.

M = dimensional versions

C = colour versions

O = other options

 D string
P [MCO]
M [1:1]
Sequence
MEASURE optional

If the options assigned to the feature are dimensional versions, the dimensional information is entered in this element.

They consist of a dimensional parameter, the unit of measure and can then, for example, be used in the formulas of the rules (DECISIONS).

Sequence
MEASURE_UNIT xs:string
This element is used to specify the unit of measure. D string
P
M
MEASURE_PARAMETER optional Restriction of xs:string

This element is used to specify the parameters for defining a formula, e.g. planning width = 2 * st +sb, with st expressing the side part width and sb expressing the seat width.

 D string
P
M
Attributes
Name Type Use Default Fixed Description
FEATURE_T Restriction of xs:string optional

This attribute is used to define the options assigned to the feature.

M = dimensional versions

C = colour versions

O = other options

 D string
P [MCO]
M [1:1]
Source
<xs:element name="FEATURE_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MEASURE" minOccurs="0">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MEASURE_UNIT" type="xs:string">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="MEASURE_PARAMETER" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_T">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:length value="1" />
          <xs:pattern value="[MCO]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > FEATURE_TYPE Element : MEASURE Element
Description

If the options assigned to the feature are dimensional versions, the dimensional information is entered in this element.

They consist of a dimensional parameter, the unit of measure and can then, for example, be used in the formulas of the rules (DECISIONS).

Namespace (none)
Diagram
MEASURE_PARAMETER Element MEASURE_UNIT Element Sequence MEASURE Element
Overview
MEASURE optional

If the options assigned to the feature are dimensional versions, the dimensional information is entered in this element.

They consist of a dimensional parameter, the unit of measure and can then, for example, be used in the formulas of the rules (DECISIONS).

Sequence
MEASURE_UNIT xs:string
This element is used to specify the unit of measure. D string
P
M
MEASURE_PARAMETER optional Restriction of xs:string

This element is used to specify the parameters for defining a formula, e.g. planning width = 2 * st +sb, with st expressing the side part width and sb expressing the seat width.

 D string
P
M
Source
<xs:element name="MEASURE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MEASURE_UNIT" type="xs:string">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="MEASURE_PARAMETER" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_TYPE Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_UNIT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > FEATURE_TYPE Element > MEASURE Element : MEASURE_UNIT Element
Description
This element is used to specify the unit of measure. D string
P
M
Namespace (none)
Type
xs:string
Diagram
MEASURE_UNIT Element
Overview
MEASURE_UNIT xs:string
This element is used to specify the unit of measure. D string
P
M
Source
<xs:element name="MEASURE_UNIT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
MEASURE Element | FEATURE_TYPE Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_PARAMETER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > FEATURE_TYPE Element > MEASURE Element : MEASURE_PARAMETER Element
Description

This element is used to specify the parameters for defining a formula, e.g. planning width = 2 * st +sb, with st expressing the side part width and sb expressing the seat width.

 D string
P
M
Namespace (none)
Type
Restriction of xs:string
Diagram
MEASURE_PARAMETER Element
Overview
MEASURE_PARAMETER optional Restriction of xs:string

This element is used to specify the parameters for defining a formula, e.g. planning width = 2 * st +sb, with st expressing the side part width and sb expressing the seat width.

 D string
P
M
Source
<xs:element name="MEASURE_PARAMETER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MEASURE Element | FEATURE_TYPE Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_DEFINITION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : OPTION_DEFINITION Element
Description
This element is used to define the properties of colours, materials and dimensions.
Namespace (none)
Diagram
OPTION_MEASURE Element MATERIAL Element Sequence OPTION_DEFINITION Element
Overview
OPTION_DEFINITION optional
This element is used to define the properties of colours, materials and dimensions.
Sequence
MATERIAL 0..∞
This element is used to define a material.

If the option to be created is a feature (identified by A), no colour values (COLOR) or texture (TEXTURE) must be specified.

Features are defined via T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION.
MATERIAL_NO required Restriction of xs:string
This attribute is used to identify a material. D string
P
M [1:5]
Sequence
COLOR
This element is used to define colours.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
OPTION_MEASURE 0..∞
This element is used to specify the values of options that are expressed in a dimension (e.g. backrest or cushion height).
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
This attribute identifies a dimensional variation. D positiveInteger
P
M [1:99999]
Sequence
MEASURE_VALUE Restriction of xs:nonNegativeInteger
This element is used to specify the dimensions. D nonNegativeInteger
P
M [0:999999999]
MEASURE_UNIT xs:string
This element is used to specify the unit of measure. D string
P
M
Remarks

Source
<xs:element name="OPTION_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="COLOR">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RGB_RED">
                    <xs:annotation>
                      <xs:documentation>260--11--RGB_Rot</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="255" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="RGB_GREEN">
                    <xs:annotation>
                      <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="255" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="RGB_BLUE">
                    <xs:annotation>
                      <xs:documentation>260--13--RGB_Blau</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="255" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="MATERIAL_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MEASURE_VALUE">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MEASURE_UNIT" type="xs:string">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPTION_MEASURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MATERIAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : MATERIAL Element
Description
This element is used to define a material.

If the option to be created is a feature (identified by A), no colour values (COLOR) or texture (TEXTURE) must be specified.

Features are defined via T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION.
Namespace (none)
Diagram
COLOR Element Sequence MATERIAL Element
Overview
MATERIAL 0..∞
This element is used to define a material.

If the option to be created is a feature (identified by A), no colour values (COLOR) or texture (TEXTURE) must be specified.

Features are defined via T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION.
MATERIAL_NO required Restriction of xs:string
This attribute is used to identify a material. D string
P
M [1:5]
Sequence
COLOR
This element is used to define colours.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
Attributes
Name Type Use Default Fixed Description
MATERIAL_NO Restriction of xs:string required
This attribute is used to identify a material. D string
P
M [1:5]
Remarks

Source
<xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="COLOR">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RGB_RED">
              <xs:annotation>
                <xs:documentation>260--11--RGB_Rot</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="255" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="RGB_GREEN">
              <xs:annotation>
                <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="255" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="RGB_BLUE">
              <xs:annotation>
                <xs:documentation>260--13--RGB_Blau</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="255" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MATERIAL_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

COLOR Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element : COLOR Element
Description
This element is used to define colours.
Namespace (none)
Diagram
RGB_BLUE Element RGB_GREEN Element RGB_RED Element Sequence COLOR Element
Overview
COLOR
This element is used to define colours.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
Source
<xs:element name="COLOR" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RGB_RED">
        <xs:annotation>
          <xs:documentation>260--11--RGB_Rot</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="255" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="RGB_GREEN">
        <xs:annotation>
          <xs:documentation>260--12--RGB_Gruen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="255" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="RGB_BLUE">
        <xs:annotation>
          <xs:documentation>260--13--RGB_Blau</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="255" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

RGB_RED Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > COLOR Element : RGB_RED Element
Description
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
RGB_RED Element
Overview
RGB_RED Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
Source
<xs:element name="RGB_RED" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--11--RGB_Rot</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="255" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COLOR Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

RGB_GREEN Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > COLOR Element : RGB_GREEN Element
Description
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
RGB_GREEN Element
Overview
RGB_GREEN Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
Source
<xs:element name="RGB_GREEN" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--12--RGB_Gruen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="255" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COLOR Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

RGB_BLUE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > COLOR Element : RGB_BLUE Element
Description
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
RGB_BLUE Element
Overview
RGB_BLUE Restriction of xs:nonNegativeInteger
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity 		D nonNegativeInteger
P
M [0:255]
Source
<xs:element name="RGB_BLUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--13--RGB_Blau</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="255" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COLOR Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_MEASURE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : OPTION_MEASURE Element
Description
This element is used to specify the values of options that are expressed in a dimension (e.g. backrest or cushion height).
Namespace (none)
Diagram
MEASURE_UNIT Element MEASURE_VALUE Element Sequence OPTION_MEASURE Element
Overview
OPTION_MEASURE 0..∞
This element is used to specify the values of options that are expressed in a dimension (e.g. backrest or cushion height).
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
This attribute identifies a dimensional variation. D positiveInteger
P
M [1:99999]
Sequence
MEASURE_VALUE Restriction of xs:nonNegativeInteger
This element is used to specify the dimensions. D nonNegativeInteger
P
M [0:999999999]
MEASURE_UNIT xs:string
This element is used to specify the unit of measure. D string
P
M
Attributes
Name Type Use Default Fixed Description
OPTION_MEASURE_NO Restriction of xs:positiveInteger required
This attribute identifies a dimensional variation. D positiveInteger
P
M [1:99999]
Remarks

Source
<xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MEASURE_VALUE">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MEASURE_UNIT" type="xs:string">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPTION_MEASURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_VALUE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > OPTION_MEASURE Element : MEASURE_VALUE Element
Description
This element is used to specify the dimensions. D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MEASURE_VALUE Element
Overview
MEASURE_VALUE Restriction of xs:nonNegativeInteger
This element is used to specify the dimensions. D nonNegativeInteger
P
M [0:999999999]
Remarks

Source
<xs:element name="MEASURE_VALUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
OPTION_MEASURE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_UNIT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > OPTION_MEASURE Element : MEASURE_UNIT Element
Description
This element is used to specify the unit of measure. D string
P
M
Namespace (none)
Type
xs:string
Diagram
MEASURE_UNIT Element
Overview
MEASURE_UNIT xs:string
This element is used to specify the unit of measure. D string
P
M
Remarks

Source
<xs:element name="MEASURE_UNIT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPTION_MEASURE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : DECISIONS Element
Description
This element is used to specify rules for options and features.
Namespace (none)
Diagram
DECISION Element Sequence DECISIONS Element
Overview
DECISIONS optional
This element is used to specify rules for options and features.
Sequence
DECISION 1..99999

This element is used to define and describe a rule that maps technically feasible configurations.
The rules are assigned to series or items by references from the corresponding elements. In total, all rules defined in this element must be referenced from either series or items.

Depending on the DECISION_TYPE attribute, different rules can be specified.

If the value in DECISION_TYPE is 0 or 1, the rule is a "preparation rule".

This allows for the definition of invalid and/or valid options in OPTION_COMBINATION. These are used to determine the valid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

The conditions are supplemented with operators. The special data type operator was defined for this purpose. It may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

The individual OPTION_COMBINATIONs must be considered as ELSE branches. This means that as soon as a condition line (OPTION_COMBINATION) receives a hit, the others will not be executed anymore.

If the value in DECISION_TYPE is 2, the rule is an action rule. It allows for the definition of actions depending on the conditions.

If all conditions within an „OPTION_COMBINATION“ are satisfied, all signed actions (ACTIONS) then can set values or make features (FEATURES) invisible depending on conditions. If an OPTION_COMBINATION is satisfied, the other conditions are not processed.

Actions (ACTIONS)

are instructions that are executed if a condition is met. The following actions can be executed:

    The setting of options ( SET_FEATURE_FIXED ) with the following options:

      - Direct, e.g. main fabric = "blue" (OPTION)

      - the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

      - the calculation of options (e.g. sitting height + 5 cm).
      This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
      This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
      The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

        The setting of standard versions ( SET_FEATURE_DEFAULT , SET_FEATURE_DEFAULT_NULL ):
        These can be filled if no value has been entered yet. The same options as above apply.

            The visibility of features ( SET_FEATURE_VISIBLE , SET_FEATURE_INVISIBLE ) and/or the deactivation of rules ( DISABLE_DECISION , ENABLE_DECISION ):
            Example: for wooden feet, a potentially existing feature for a shade can be displayed and made invisible if a metal foot is selected.

              Action rules are usually used in the configurator if an option value (an option) changes. If, for example, the foot option is changed from stainless steel to wood, a feature for the shade can be displayed.

              If the value in DECISION_TYPE is 3, the rule is an action rule for piece lists. Depending on the conditions, the quantity can be defined in the piece list here.

              DECISION_NO required Restriction of xs:positiveInteger
              This attribute is used to identify the rule. D positiveInteger
              P
              M [1:9999999999]
              DECISION_TYPE required Restriction of xs:int

              This attribute is used to specify the rule type.

              0 = excluding preparation rule

              This allows for the definition of invalid options in OPTION_COMBINATION/FEATURE_REF. These are used to determine the invalid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

              1 = Preparation rule

              This allows for the definition of valid options in OPTION_COMBINATION/FEATURE_REF. These are used to determine the valid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

              2 = Action rule
              It allows for the definition of actions in addition to the conditions.
              The rules are analysed before an option is entered for an item.
              Once a value has been selected, the action rules apply and then set values or make features invisible.
              For action rules, it is always the first line (OPTIONS_SET_REF) that applies. In this case, all associated ACTIONS are executed.

              3 = Action rule for quantity in piece lists (PositionCounter Rule)

              The quantity in the piece list can be defined here depending on the conditions via the action SET_POS_COUNT_VALUE.

                       D int
              P
              M [0-3]
              Sequence
              DECISION_NAME_TEXT languagetext60 Complex Type
              This element is used to specify the designation of a rule.
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              This attribute is used to specify the ISO code of the language in which the text is stored. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
              P [\S ]{1,60}
              M [1:60]
              OPTION_COMBINATION 1..∞

              This element is used to form a feature combination that is linked to certain conditions.

              If the value of DECISION_TYPE is 2 or 3, actions (ACTIONS) can also be assigned to the feature combination.

              SEQUENCE required Restriction of xs:nonNegativeInteger
              This element is used to specify the sequence in which the assigned assessment procedures will be executed. D nonNegativeInteger
              P
              M [1:99999]
              Sequence
              OPTIONS_SET_REF 0..∞

              This element is used to reference a feature and define a rule for its feature classes. The rules may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

              The simple data type operator was defined for this purpose and may contain the following values:

              eq (equal)

              ne (not equal)

              in (is contained in a quantity)

              nin (is not contained in a quantity)

              gt (greater)

              lt (less)

              ge (greater than or equal)

              le (less than or equal)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              REF_LEVEL optional Restriction of xs:nonNegativeInteger
              In piece lists, sub-positions can query features of the main position (PARENT), the uppermost position (ROOT) and the item itself (SELF) via the REF_LEVEL and depending on them trigger an action or integrate the action in a condition.

              1 = ROOT

              2 = PARENT

              3 = SELF (default is SELF if no REF level is specified)               		D nonNegativeInteger
              P
              M [1:3]
              Choice
              OPTION_INTERVAL
              This element is used to evaluate whether an option falls within or outside of an interval.
              OPERATOR required Restriction of operator Simple Type

              This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

              in (is contained in a quantity)

              nin (is not contained in a quantity)

                       D operator
              P in|nin
              M
              OPTION_KEY_MIN required Restriction of xs:string

              This attribute is used to specify the starting value of the interval.

                       D string
              P
              M [1:30]
              OPTION_KEY_MAX required Restriction of xs:string
              This attribute is used to specify the end value of the interval. D string
              P
              M [1:30]
              OPTION_LIST
              This element is used to evaluate whether an option corresponds to a value in a list.
              OPERATOR required Restriction of operator Simple Type

              This attribute is used to evaluate whether an option falls within or without a list of values.

              in (is contained in a quantity)

              nin (is not contained in a quantity)

                       D operator
              P in|nin
              M
              Sequence 1..∞
              OPTION_REF
              This element is used to reference the options in a comparison list.
              OPTION_KEY required Restriction of xs:string
              This attribute is used to reference an option. D string
              P
              M [1:30]
              OPTION_GROUP_REF_OP
              This element is used to evaluate whether an option falls within a feature group.
              OPTION_GROUP_KEY required Restriction of xs:string
              This attribute is used to reference a feature group. D string
              P
              M [1:30]
              OPERATOR required Restriction of operator Simple Type

              This attribute is used to evaluate whether an option falls within a feature group.

              in (is contained in a quantity)

              nin (is not contained in a quantity)

                       D operator
              P in|nin
              M
              OPTION_REF_OP

              This element is used to define a comparison with an option.

              The comparison operator may contain the following values:

              eq (equal)

              ne (not equal)

              gt (greater)

              lt (less)

              ge (greater than or equal)

              le (less than or equal)

              OPTION_KEY required Restriction of xs:string
              This attribute is used to reference an option. D string
              P
              M [1:30]
              OPERATOR required Restriction of operator Simple Type
              This attribute is used to define a comparison with an option.

              The comparison operator may contain the following values:

              eq (equal)

              ne (not equal)

              gt (greater)

              lt (less)

              ge (greater than or equal)

              le (less than or equal)

                       D operator
              P eq|ne|gt|lt|ge|le
              M
              FEATURE_REF_OP

              This element is used to directly compare the feature.

              The comparison operator may contain the following values:

              eq (equal)

              ne (not equal)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              OPERATOR required Restriction of operator Simple Type
              This attribute is used to define a comparison with a feature.

              The comparison operator may contain the following values:

              eq (equal)

              ne (not equal)

                       D operator
              P eq|ne
              M
              MEASURE_VALUE_OP
              This element is used to check the dimension of an option using another dimension.
              MEASURE_VALUE required xs:nonNegativeInteger

              This attribute is used to specify the comparison dimension.

                       D nonNegativeInteger
              P
              M
              OPERATOR required Restriction of operator Simple Type
              This attribute is used to define a comparison with a dimension.

              The comparison operator may contain the following values:

              eq (equal)

              ne (not equal)

              gt (greater)

              lt (less)

              ge (greater than or equal)

              le (less than or equal)

                       D operator
              P eq|ne|gt|lt|ge|le
              M
              MEASURE_INTERVAL
              This element is used to evaluate whether an option's dimension falls within or outside of an interval.
              OPERATOR required Restriction of operator Simple Type

              This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

              in (is contained in a quantity)

              nin (is not contained in a quantity)

                       D operator
              P in|nin
              M
              MEASURE_MIN required xs:nonNegativeInteger

              This attribute is used to specify the starting value of the interval.

                       D nonNegativeInteger
              P
              M
              MEASURE_MAX required xs:nonNegativeInteger
              This attribute is used to specify the end value of the interval. D nonNegativeInteger
              P
              M
              ACTIONS optional

              This element is used to determine actions that are executed under certain conditions.

              Actions (ACTIONS) are instructions that are executed if a condition is met. The following actions can be executed:

              • The setting of options (SET_FEATURE_FIXED) with the following options:

              §Direct, e.g. main fabric = "blue" (OPTION)

              §the setting of feature values from another feature (FEATURE), e.g. ledge fabric = main fabric

              §the calculation of options (e.g. sitting height + 5 cm).
              This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
              This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
              The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

              • The setting of standard options (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
                These can be filled if no value has been entered yet. The same options as above apply.

              • The visibility of features (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) and disabling of rules (DISABLE_DECISION, ENABLE_DECISION):
                Example: for wooden feet, a potentially existing feature for a shade can be displayed and made invisible if a metal foot is selected.

              Choice 1..∞
              SET_FEATURE_DEFAULT

              This action is used to set standard options.

              These can be filled if no value has been entered yet.

              • The following options are available for the setting of options:

              - Direct , e.g. main fabric = "blue" (OPTION)

              - the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

              - the calculation of options. (e.g. seat height + 5 cm).
              This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
              This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
              The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              This element references another feature for the setting of option values.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              OPTION_REF
              This element is used to reference an option (OPTION) that is directly set as standard.
              OPTION_KEY required Restriction of xs:string
              This attribute is used to reference an option. D string
              P
              M [1:30]
              FORMULA_REF
              This element is used to reference a formula for the calculation of standard values.
              FORMULA_KEY required Restriction of xs:string
              This attribute is used to reference a formula. D string
              P
              M [1:30]
              SET_FEATURE_FIXED

              This action is used to set options.

              The following options are available for the setting of options:

              - Direct , e.g. main fabric = "blue" (OPTION)

              - the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

              - the calculation of options. (e.g. seat height + 5 cm).
              This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
              This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
              The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              This element references another feature for the setting of option values.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              OPTION_REF
              This element is used to reference an option (OPTION) that is set directly.
              OPTION_KEY required Restriction of xs:string
              This attribute is used to reference an option. D string
              P
              M [1:30]
              FORMULA_REF
              This element is used to reference a formula for the calculation of options.
              FORMULA_KEY required Restriction of xs:string
              This attribute is used to reference a formula. D string
              P
              M [1:30]
              ENABLE_DECISION

              This action activates rules.

              DECISION_NO optional Restriction of xs:positiveInteger
              This attribute is used to reference a rule. D positiveInteger
              P
              M [1:9999999999]
              DISABLE_DECISION

              This action deactivates rules.

              DECISION_NO optional Restriction of xs:positiveInteger
              This attribute is used to reference a rule. D positiveInteger
              P
              M [1:9999999999]
              SET_FEATURE_VISIBLE
              This action makes features visible.
              FEATURE_NO optional Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              SET_FEATURE_INVISIBLE
              This action makes features invisible.
              FEATURE_NO optional Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              SET_FEATURE
              This action sets a value for an option of a feature. Contrary to „SET_FEATURE FIXED“, this value can be modified if permitted by the conditions. This value rule also applies if the corresponding field was previously set to default or manual.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              This element references another feature for the setting of option values.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              OPTION_REF
              This element is used to reference an option (OPTION) that is set directly.
              OPTION_KEY required Restriction of xs:string
              This attribute is used to reference an option. D string
              P
              M [1:30]
              FORMULA_REF
              This element is used to reference a formula for the calculation of options.
              FORMULA_KEY optional Restriction of xs:string
              This attribute is used to reference a formula. D string
              P
              M [1:30]
              SET_FEATURE_DEFAULT_NULL

              This action is used to set standard options.

              The default value only applies if the relevant feature field was previously blank.

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              This element references another feature for the setting of NULL.
              FEATURE_NO optional Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              OPTION_REF
              This element is used to reference an option (OPTION) that is set to NULL.
              OPTION_KEY optional Restriction of xs:string
              This attribute is used to reference an option. D string
              P
              M [1:30]
              FORMULA_REF
              This element is used to reference a formula for the calculation of options.
              FORMULA_KEY optional Restriction of xs:string
              This attribute is used to reference a formula. D string
              P
              M [1:30]
              SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
              This version is used to set a quantity in the piece list.
              This action must only be specified for rules with DECISION_TYPE = 3.               		D nonNegativeInteger
              P
              M [0:9999]
              SET_MESSAGE
              This element is used to set a message for the purpose of triggering warnings or notices for certain feature combinations.
              MESSAGE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a message. D nonNegativeInteger
              P
              M [0:999999]
              VALID_FROM optional Restriction of xs:date
              This element is used to specify the date from which date onwards a rule is valid.
              Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date.               		D date
              P
              M
              VALID_UNTIL optional Restriction of xs:date
              This element specifies the date until which a rule is valid.
              Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.               		D date
              P
              M
              FEATURE_REF 0..∞
              This element is used to reference a feature.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              This attribute is used to reference a feature. D nonNegativeInteger
              P
              M [0:999]
              PRIO Restriction of xs:positiveInteger
              This element is used to specify a value for the priority of a rule.
              A low value means a high priority. This means that the rule takes a lower priority the higher this value is.               		D positiveInteger
              P
              M [1:999999999]
              Source
              <xs:element name="DECISIONS" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>nicht zwingend anzugeben, K. Richter, 23.05.2014</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION" maxOccurs="99999">
        <xs:annotation>
          <xs:documentation>270/271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_NAME_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>270--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:complexType>
                      <xs:choice>
                        <xs:element name="OPTION_INTERVAL">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="in|nin" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY_MIN" use="required">
                              <xs:annotation>
                                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY_MAX" use="required">
                              <xs:annotation>
                                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_LIST">
                          <xs:complexType>
                            <xs:sequence maxOccurs="unbounded">
                              <xs:element name="OPTION_REF">
                                <xs:complexType>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="in|nin" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_GROUP_REF_OP">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="OPTION_GROUP_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="in|nin" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF_OP">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FEATURE_REF_OP">
                          <xs:annotation>
                            <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
                            <xs:documentation />
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="eq|ne" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="MEASURE_VALUE_OP">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                              </xs:annotation>
                            </xs:attribute>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="MEASURE_INTERVAL">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="in|nin" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                              <xs:annotation>
                                <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                              </xs:annotation>
                            </xs:attribute>
                            <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                              <xs:annotation>
                                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                              </xs:annotation>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="REF_LEVEL" use="optional">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">1 = ROOT
2 = PARENT
3 = SELF
Standardfall ist SELF, wenn kein REF-Level angegeben ist</xs:documentation>
                          <xs:documentation xml:lang="DE">12.02.2015 K. Richter</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:maxInclusive value="3" />
                            <xs:minInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ACTIONS" minOccurs="0">
                    <xs:complexType>
                      <xs:choice maxOccurs="unbounded">
                        <xs:element name="SET_FEATURE_DEFAULT">
                          <xs:complexType>
                            <xs:choice>
                              <xs:element name="FEATURE_REF">
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF">
                                <xs:complexType>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FORMULA_REF">
                                <xs:complexType>
                                  <xs:attribute name="FORMULA_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SET_FEATURE_FIXED">
                          <xs:complexType>
                            <xs:choice>
                              <xs:element name="FEATURE_REF">
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF">
                                <xs:complexType>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FORMULA_REF">
                                <xs:complexType>
                                  <xs:attribute name="FORMULA_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ENABLE_DECISION">
                          <xs:complexType>
                            <xs:attribute name="DECISION_NO">
                              <xs:annotation>
                                <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DISABLE_DECISION">
                          <xs:complexType>
                            <xs:attribute name="DECISION_NO">
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SET_FEATURE_VISIBLE">
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SET_FEATURE_INVISIBLE">
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SET_FEATURE">
                          <xs:complexType>
                            <xs:choice>
                              <xs:element name="FEATURE_REF">
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF">
                                <xs:complexType>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FORMULA_REF">
                                <xs:complexType>
                                  <xs:attribute name="FORMULA_KEY">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SET_FEATURE_DEFAULT_NULL">
                          <xs:complexType>
                            <xs:choice>
                              <xs:element name="FEATURE_REF">
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF">
                                <xs:complexType>
                                  <xs:attribute name="OPTION_KEY">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FORMULA_REF">
                                <xs:complexType>
                                  <xs:attribute name="FORMULA_KEY">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SET_POS_COUNT_VALUE">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                            <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                            <xs:documentation>setzt Anzahl</xs:documentation>
                            <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="SET_MESSAGE">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                            <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                            <xs:documentation>setzt Anzahl</xs:documentation>
                            <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="MESSAGE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="FEATURE_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Entscheidungstabellen wieder entfernt, nur Angabe FEATURE_NO, 02.05.2014</xs:documentation>
                <xs:documentation xml:lang="de">Version Beta 2.0 Build 12</xs:documentation>
                <xs:documentation xml:lang="de">minimale Kardinalität auf 0 geändert K.Richter 18.07.2014</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRIO">
              <xs:annotation>
                <xs:documentation xml:lang="de">neu IDM 2.4
Priorität von Prüfungen

Am Artikel können nur Decisions mit niedriger Priorität hinzu bzw. ausgeschaltet werden
Mehrere DECISIONS können auf einem gleichen Priolevel liegen

</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DECISION_TYPE" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="de">IDM 2.4 Build 14 H.Balke 05.2014
0 = ausschließende (nicht erlaubende) Preparation
1 = Preparation
2 = action Rules
3 = action Rule mit SET_POS_COUNT_VALUE (setzt die Anzahl in der die Position in der Stückliste erscheint)

Restriktions werden vor Eingabe einer Variante am Artikel ausgewertet.
Wenn dann ein Wert ausgewählt wurde, greifen die action Rules, welche dann Werte setzen oder Variantenarten ausblenden können.
Bei Action Rules greift immer die erste Zeile (option combination), die zutrifft. In dem Fall werden alle zugehörigen Actions ausgeführt.
</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:int">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="3" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
              See Also
              FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element : DECISION Element
Description

This element is used to define and describe a rule that maps technically feasible configurations.
The rules are assigned to series or items by references from the corresponding elements. In total, all rules defined in this element must be referenced from either series or items.

Depending on the DECISION_TYPE attribute, different rules can be specified.

If the value in DECISION_TYPE is 0 or 1, the rule is a "preparation rule".

This allows for the definition of invalid and/or valid options in OPTION_COMBINATION. These are used to determine the valid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

The conditions are supplemented with operators. The special data type operator was defined for this purpose. It may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

The individual OPTION_COMBINATIONs must be considered as ELSE branches. This means that as soon as a condition line (OPTION_COMBINATION) receives a hit, the others will not be executed anymore.

If the value in DECISION_TYPE is 2, the rule is an action rule. It allows for the definition of actions depending on the conditions.

If all conditions within an „OPTION_COMBINATION“ are satisfied, all signed actions (ACTIONS) then can set values or make features (FEATURES) invisible depending on conditions. If an OPTION_COMBINATION is satisfied, the other conditions are not processed.

Actions (ACTIONS)

are instructions that are executed if a condition is met. The following actions can be executed:

    The setting of options ( SET_FEATURE_FIXED ) with the following options:

      - Direct, e.g. main fabric = "blue" (OPTION)

      - the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

      - the calculation of options (e.g. sitting height + 5 cm).
      This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
      This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
      The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

        The setting of standard versions ( SET_FEATURE_DEFAULT , SET_FEATURE_DEFAULT_NULL ):
        These can be filled if no value has been entered yet. The same options as above apply.

            The visibility of features ( SET_FEATURE_VISIBLE , SET_FEATURE_INVISIBLE ) and/or the deactivation of rules ( DISABLE_DECISION , ENABLE_DECISION ):
            Example: for wooden feet, a potentially existing feature for a shade can be displayed and made invisible if a metal foot is selected.

              Action rules are usually used in the configurator if an option value (an option) changes. If, for example, the foot option is changed from stainless steel to wood, a feature for the shade can be displayed.

              If the value in DECISION_TYPE is 3, the rule is an action rule for piece lists. Depending on the conditions, the quantity can be defined in the piece list here.

              Namespace (none)
              Diagram
              PRIO Element FEATURE_REF Element VALID_UNTIL Element VALID_FROM Element OPTION_COMBINATION Element LANGUAGE Element Sequence DECISION_NAME_TEXT Element Sequence DECISION Element
              Overview
              DECISION 1..99999

              This element is used to define and describe a rule that maps technically feasible configurations.
              The rules are assigned to series or items by references from the corresponding elements. In total, all rules defined in this element must be referenced from either series or items.

              Depending on the DECISION_TYPE attribute, different rules can be specified.

              If the value in DECISION_TYPE is 0 or 1, the rule is a "preparation rule".

              This allows for the definition of invalid and/or valid options in OPTION_COMBINATION. These are used to determine the valid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

              The conditions are supplemented with operators. The special data type operator was defined for this purpose. It may contain the following values:

              eq (equal)

              ne (not equal)

              in (is contained in a quantity)

              nin (is not contained in a quantity)

              gt (greater)

              lt (less)

              ge (greater than or equal)

              le (less than or equal)

              The individual OPTION_COMBINATIONs must be considered as ELSE branches. This means that as soon as a condition line (OPTION_COMBINATION) receives a hit, the others will not be executed anymore.

              If the value in DECISION_TYPE is 2, the rule is an action rule. It allows for the definition of actions depending on the conditions.

              If all conditions within an „OPTION_COMBINATION“ are satisfied, all signed actions (ACTIONS) then can set values or make features (FEATURES) invisible depending on conditions. If an OPTION_COMBINATION is satisfied, the other conditions are not processed.

              Actions (ACTIONS)

              are instructions that are executed if a condition is met. The following actions can be executed:

                The setting of options ( SET_FEATURE_FIXED ) with the following options:

                  - Direct, e.g. main fabric = "blue" (OPTION)

                  - the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

                  - the calculation of options (e.g. sitting height + 5 cm).
                  This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
                  This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
                  The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

                    The setting of standard versions ( SET_FEATURE_DEFAULT , SET_FEATURE_DEFAULT_NULL ):
                    These can be filled if no value has been entered yet. The same options as above apply.

                        The visibility of features ( SET_FEATURE_VISIBLE , SET_FEATURE_INVISIBLE ) and/or the deactivation of rules ( DISABLE_DECISION , ENABLE_DECISION ):
                        Example: for wooden feet, a potentially existing feature for a shade can be displayed and made invisible if a metal foot is selected.

                          Action rules are usually used in the configurator if an option value (an option) changes. If, for example, the foot option is changed from stainless steel to wood, a feature for the shade can be displayed.

                          If the value in DECISION_TYPE is 3, the rule is an action rule for piece lists. Depending on the conditions, the quantity can be defined in the piece list here.

                          DECISION_NO required Restriction of xs:positiveInteger
                          This attribute is used to identify the rule. D positiveInteger
                          P
                          M [1:9999999999]
                          DECISION_TYPE required Restriction of xs:int

                          This attribute is used to specify the rule type.

                          0 = excluding preparation rule

                          This allows for the definition of invalid options in OPTION_COMBINATION/FEATURE_REF. These are used to determine the invalid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

                          1 = Preparation rule

                          This allows for the definition of valid options in OPTION_COMBINATION/FEATURE_REF. These are used to determine the valid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

                          2 = Action rule
                          It allows for the definition of actions in addition to the conditions.
                          The rules are analysed before an option is entered for an item.
                          Once a value has been selected, the action rules apply and then set values or make features invisible.
                          For action rules, it is always the first line (OPTIONS_SET_REF) that applies. In this case, all associated ACTIONS are executed.

                          3 = Action rule for quantity in piece lists (PositionCounter Rule)

                          The quantity in the piece list can be defined here depending on the conditions via the action SET_POS_COUNT_VALUE.

                                   D int
                          P
                          M [0-3]
                          Sequence
                          DECISION_NAME_TEXT languagetext60 Complex Type
                          This element is used to specify the designation of a rule.
                          Sequence
                          LANGUAGE 1..∞
                          ISO_LANGUAGE_ID required Restriction of xs:language
                          This attribute is used to specify the ISO code of the language in which the text is stored. D language
                          P [A-Z]{2}
                          M [2:2]
                          Sequence
                          TEXT Restriction of xs:string
                          This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
                          P [\S ]{1,60}
                          M [1:60]
                          OPTION_COMBINATION 1..∞

                          This element is used to form a feature combination that is linked to certain conditions.

                          If the value of DECISION_TYPE is 2 or 3, actions (ACTIONS) can also be assigned to the feature combination.

                          SEQUENCE required Restriction of xs:nonNegativeInteger
                          This element is used to specify the sequence in which the assigned assessment procedures will be executed. D nonNegativeInteger
                          P
                          M [1:99999]
                          Sequence
                          OPTIONS_SET_REF 0..∞

                          This element is used to reference a feature and define a rule for its feature classes. The rules may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

                          The simple data type operator was defined for this purpose and may contain the following values:

                          eq (equal)

                          ne (not equal)

                          in (is contained in a quantity)

                          nin (is not contained in a quantity)

                          gt (greater)

                          lt (less)

                          ge (greater than or equal)

                          le (less than or equal)

                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a feature. D nonNegativeInteger
                          P
                          M [0:999]
                          REF_LEVEL optional Restriction of xs:nonNegativeInteger
                          In piece lists, sub-positions can query features of the main position (PARENT), the uppermost position (ROOT) and the item itself (SELF) via the REF_LEVEL and depending on them trigger an action or integrate the action in a condition.

                          1 = ROOT

                          2 = PARENT

                          3 = SELF (default is SELF if no REF level is specified)                           		D nonNegativeInteger
                          P
                          M [1:3]
                          Choice
                          OPTION_INTERVAL
                          This element is used to evaluate whether an option falls within or outside of an interval.
                          OPERATOR required Restriction of operator Simple Type

                          This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

                          in (is contained in a quantity)

                          nin (is not contained in a quantity)

                                   D operator
                          P in|nin
                          M
                          OPTION_KEY_MIN required Restriction of xs:string

                          This attribute is used to specify the starting value of the interval.

                                   D string
                          P
                          M [1:30]
                          OPTION_KEY_MAX required Restriction of xs:string
                          This attribute is used to specify the end value of the interval. D string
                          P
                          M [1:30]
                          OPTION_LIST
                          This element is used to evaluate whether an option corresponds to a value in a list.
                          OPERATOR required Restriction of operator Simple Type

                          This attribute is used to evaluate whether an option falls within or without a list of values.

                          in (is contained in a quantity)

                          nin (is not contained in a quantity)

                                   D operator
                          P in|nin
                          M
                          Sequence 1..∞
                          OPTION_REF
                          This element is used to reference the options in a comparison list.
                          OPTION_KEY required Restriction of xs:string
                          This attribute is used to reference an option. D string
                          P
                          M [1:30]
                          OPTION_GROUP_REF_OP
                          This element is used to evaluate whether an option falls within a feature group.
                          OPTION_GROUP_KEY required Restriction of xs:string
                          This attribute is used to reference a feature group. D string
                          P
                          M [1:30]
                          OPERATOR required Restriction of operator Simple Type

                          This attribute is used to evaluate whether an option falls within a feature group.

                          in (is contained in a quantity)

                          nin (is not contained in a quantity)

                                   D operator
                          P in|nin
                          M
                          OPTION_REF_OP

                          This element is used to define a comparison with an option.

                          The comparison operator may contain the following values:

                          eq (equal)

                          ne (not equal)

                          gt (greater)

                          lt (less)

                          ge (greater than or equal)

                          le (less than or equal)

                          OPTION_KEY required Restriction of xs:string
                          This attribute is used to reference an option. D string
                          P
                          M [1:30]
                          OPERATOR required Restriction of operator Simple Type
                          This attribute is used to define a comparison with an option.

                          The comparison operator may contain the following values:

                          eq (equal)

                          ne (not equal)

                          gt (greater)

                          lt (less)

                          ge (greater than or equal)

                          le (less than or equal)

                                   D operator
                          P eq|ne|gt|lt|ge|le
                          M
                          FEATURE_REF_OP

                          This element is used to directly compare the feature.

                          The comparison operator may contain the following values:

                          eq (equal)

                          ne (not equal)

                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a feature. D nonNegativeInteger
                          P
                          M [0:999]
                          OPERATOR required Restriction of operator Simple Type
                          This attribute is used to define a comparison with a feature.

                          The comparison operator may contain the following values:

                          eq (equal)

                          ne (not equal)

                                   D operator
                          P eq|ne
                          M
                          MEASURE_VALUE_OP
                          This element is used to check the dimension of an option using another dimension.
                          MEASURE_VALUE required xs:nonNegativeInteger

                          This attribute is used to specify the comparison dimension.

                                   D nonNegativeInteger
                          P
                          M
                          OPERATOR required Restriction of operator Simple Type
                          This attribute is used to define a comparison with a dimension.

                          The comparison operator may contain the following values:

                          eq (equal)

                          ne (not equal)

                          gt (greater)

                          lt (less)

                          ge (greater than or equal)

                          le (less than or equal)

                                   D operator
                          P eq|ne|gt|lt|ge|le
                          M
                          MEASURE_INTERVAL
                          This element is used to evaluate whether an option's dimension falls within or outside of an interval.
                          OPERATOR required Restriction of operator Simple Type

                          This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

                          in (is contained in a quantity)

                          nin (is not contained in a quantity)

                                   D operator
                          P in|nin
                          M
                          MEASURE_MIN required xs:nonNegativeInteger

                          This attribute is used to specify the starting value of the interval.

                                   D nonNegativeInteger
                          P
                          M
                          MEASURE_MAX required xs:nonNegativeInteger
                          This attribute is used to specify the end value of the interval. D nonNegativeInteger
                          P
                          M
                          ACTIONS optional

                          This element is used to determine actions that are executed under certain conditions.

                          Actions (ACTIONS) are instructions that are executed if a condition is met. The following actions can be executed:

                          • The setting of options (SET_FEATURE_FIXED) with the following options:

                          §Direct, e.g. main fabric = "blue" (OPTION)

                          §the setting of feature values from another feature (FEATURE), e.g. ledge fabric = main fabric

                          §the calculation of options (e.g. sitting height + 5 cm).
                          This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
                          This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
                          The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

                          • The setting of standard options (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
                            These can be filled if no value has been entered yet. The same options as above apply.

                          • The visibility of features (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) and disabling of rules (DISABLE_DECISION, ENABLE_DECISION):
                            Example: for wooden feet, a potentially existing feature for a shade can be displayed and made invisible if a metal foot is selected.

                          Choice 1..∞
                          SET_FEATURE_DEFAULT

                          This action is used to set standard options.

                          These can be filled if no value has been entered yet.

                          • The following options are available for the setting of options:

                          - Direct , e.g. main fabric = "blue" (OPTION)

                          - the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

                          - the calculation of options. (e.g. seat height + 5 cm).
                          This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
                          This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
                          The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a feature. D nonNegativeInteger
                          P
                          M [0:999]
                          Choice
                          FEATURE_REF
                          This element references another feature for the setting of option values.
                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a feature. D nonNegativeInteger
                          P
                          M [0:999]
                          OPTION_REF
                          This element is used to reference an option (OPTION) that is directly set as standard.
                          OPTION_KEY required Restriction of xs:string
                          This attribute is used to reference an option. D string
                          P
                          M [1:30]
                          FORMULA_REF
                          This element is used to reference a formula for the calculation of standard values.
                          FORMULA_KEY required Restriction of xs:string
                          This attribute is used to reference a formula. D string
                          P
                          M [1:30]
                          SET_FEATURE_FIXED

                          This action is used to set options.

                          The following options are available for the setting of options:

                          - Direct , e.g. main fabric = "blue" (OPTION)

                          - the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

                          - the calculation of options. (e.g. seat height + 5 cm).
                          This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
                          This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
                          The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a feature. D nonNegativeInteger
                          P
                          M [0:999]
                          Choice
                          FEATURE_REF
                          This element references another feature for the setting of option values.
                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a feature. D nonNegativeInteger
                          P
                          M [0:999]
                          OPTION_REF
                          This element is used to reference an option (OPTION) that is set directly.
                          OPTION_KEY required Restriction of xs:string
                          This attribute is used to reference an option. D string
                          P
                          M [1:30]
                          FORMULA_REF
                          This element is used to reference a formula for the calculation of options.
                          FORMULA_KEY required Restriction of xs:string
                          This attribute is used to reference a formula. D string
                          P
                          M [1:30]
                          ENABLE_DECISION

                          This action activates rules.

                          DECISION_NO optional Restriction of xs:positiveInteger
                          This attribute is used to reference a rule. D positiveInteger
                          P
                          M [1:9999999999]
                          DISABLE_DECISION

                          This action deactivates rules.

                          DECISION_NO optional Restriction of xs:positiveInteger
                          This attribute is used to reference a rule. D positiveInteger
                          P
                          M [1:9999999999]
                          SET_FEATURE_VISIBLE
                          This action makes features visible.
                          FEATURE_NO optional Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a feature. D nonNegativeInteger
                          P
                          M [0:999]
                          SET_FEATURE_INVISIBLE
                          This action makes features invisible.
                          FEATURE_NO optional Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a feature. D nonNegativeInteger
                          P
                          M [0:999]
                          SET_FEATURE
                          This action sets a value for an option of a feature. Contrary to „SET_FEATURE FIXED“, this value can be modified if permitted by the conditions. This value rule also applies if the corresponding field was previously set to default or manual.
                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a feature. D nonNegativeInteger
                          P
                          M [0:999]
                          Choice
                          FEATURE_REF
                          This element references another feature for the setting of option values.
                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a feature. D nonNegativeInteger
                          P
                          M [0:999]
                          OPTION_REF
                          This element is used to reference an option (OPTION) that is set directly.
                          OPTION_KEY required Restriction of xs:string
                          This attribute is used to reference an option. D string
                          P
                          M [1:30]
                          FORMULA_REF
                          This element is used to reference a formula for the calculation of options.
                          FORMULA_KEY optional Restriction of xs:string
                          This attribute is used to reference a formula. D string
                          P
                          M [1:30]
                          SET_FEATURE_DEFAULT_NULL

                          This action is used to set standard options.

                          The default value only applies if the relevant feature field was previously blank.

                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a feature. D nonNegativeInteger
                          P
                          M [0:999]
                          Choice
                          FEATURE_REF
                          This element references another feature for the setting of NULL.
                          FEATURE_NO optional Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a feature. D nonNegativeInteger
                          P
                          M [0:999]
                          OPTION_REF
                          This element is used to reference an option (OPTION) that is set to NULL.
                          OPTION_KEY optional Restriction of xs:string
                          This attribute is used to reference an option. D string
                          P
                          M [1:30]
                          FORMULA_REF
                          This element is used to reference a formula for the calculation of options.
                          FORMULA_KEY optional Restriction of xs:string
                          This attribute is used to reference a formula. D string
                          P
                          M [1:30]
                          SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
                          This version is used to set a quantity in the piece list.
                          This action must only be specified for rules with DECISION_TYPE = 3.                           		D nonNegativeInteger
                          P
                          M [0:9999]
                          SET_MESSAGE
                          This element is used to set a message for the purpose of triggering warnings or notices for certain feature combinations.
                          MESSAGE_NO required Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a message. D nonNegativeInteger
                          P
                          M [0:999999]
                          VALID_FROM optional Restriction of xs:date
                          This element is used to specify the date from which date onwards a rule is valid.
                          Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date.                           		D date
                          P
                          M
                          VALID_UNTIL optional Restriction of xs:date
                          This element specifies the date until which a rule is valid.
                          Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.                           		D date
                          P
                          M
                          FEATURE_REF 0..∞
                          This element is used to reference a feature.
                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          This attribute is used to reference a feature. D nonNegativeInteger
                          P
                          M [0:999]
                          PRIO Restriction of xs:positiveInteger
                          This element is used to specify a value for the priority of a rule.
                          A low value means a high priority. This means that the rule takes a lower priority the higher this value is.                           		D positiveInteger
                          P
                          M [1:999999999]
                          Attributes
                          Name Type Use Default Fixed Description
                          DECISION_NO Restriction of xs:positiveInteger required
                          This attribute is used to identify the rule. D positiveInteger
                          P
                          M [1:9999999999]
                          DECISION_TYPE Restriction of xs:int required

                          This attribute is used to specify the rule type.

                          0 = excluding preparation rule

                          This allows for the definition of invalid options in OPTION_COMBINATION/FEATURE_REF. These are used to determine the invalid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

                          1 = Preparation rule

                          This allows for the definition of valid options in OPTION_COMBINATION/FEATURE_REF. These are used to determine the valid options of a feature. These rules do not have an action part ("ACTIONS") and they define a quantity of feature combinations that are either true or false. This is a table with the features (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, feature groups that are linked by quantity operators.

                          2 = Action rule
                          It allows for the definition of actions in addition to the conditions.
                          The rules are analysed before an option is entered for an item.
                          Once a value has been selected, the action rules apply and then set values or make features invisible.
                          For action rules, it is always the first line (OPTIONS_SET_REF) that applies. In this case, all associated ACTIONS are executed.

                          3 = Action rule for quantity in piece lists (PositionCounter Rule)

                          The quantity in the piece list can be defined here depending on the conditions via the action SET_POS_COUNT_VALUE.

                                   D int
                          P
                          M [0-3]
                          Source
                          <xs:element name="DECISION" maxOccurs="99999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_NAME_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>270--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:complexType>
                <xs:choice>
                  <xs:element name="OPTION_INTERVAL">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="in|nin" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY_MIN" use="required">
                        <xs:annotation>
                          <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY_MAX" use="required">
                        <xs:annotation>
                          <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_LIST">
                    <xs:complexType>
                      <xs:sequence maxOccurs="unbounded">
                        <xs:element name="OPTION_REF">
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="in|nin" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_GROUP_REF_OP">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="OPTION_GROUP_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="in|nin" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF_OP">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="eq|ne|gt|lt|ge|le" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FEATURE_REF_OP">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
                      <xs:documentation />
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="eq|ne" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="MEASURE_VALUE_OP">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                      <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                        </xs:annotation>
                      </xs:attribute>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="eq|ne|gt|lt|ge|le" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="MEASURE_INTERVAL">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                      <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="in|nin" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                        <xs:annotation>
                          <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                        </xs:annotation>
                      </xs:attribute>
                      <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                        <xs:annotation>
                          <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                        </xs:annotation>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="REF_LEVEL" use="optional">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">1 = ROOT
2 = PARENT
3 = SELF
Standardfall ist SELF, wenn kein REF-Level angegeben ist</xs:documentation>
                    <xs:documentation xml:lang="DE">12.02.2015 K. Richter</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:maxInclusive value="3" />
                      <xs:minInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ACTIONS" minOccurs="0">
              <xs:complexType>
                <xs:choice maxOccurs="unbounded">
                  <xs:element name="SET_FEATURE_DEFAULT">
                    <xs:complexType>
                      <xs:choice>
                        <xs:element name="FEATURE_REF">
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF">
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FORMULA_REF">
                          <xs:complexType>
                            <xs:attribute name="FORMULA_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SET_FEATURE_FIXED">
                    <xs:complexType>
                      <xs:choice>
                        <xs:element name="FEATURE_REF">
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF">
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FORMULA_REF">
                          <xs:complexType>
                            <xs:attribute name="FORMULA_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ENABLE_DECISION">
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO">
                        <xs:annotation>
                          <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DISABLE_DECISION">
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO">
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SET_FEATURE_VISIBLE">
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SET_FEATURE_INVISIBLE">
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SET_FEATURE">
                    <xs:complexType>
                      <xs:choice>
                        <xs:element name="FEATURE_REF">
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF">
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FORMULA_REF">
                          <xs:complexType>
                            <xs:attribute name="FORMULA_KEY">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SET_FEATURE_DEFAULT_NULL">
                    <xs:complexType>
                      <xs:choice>
                        <xs:element name="FEATURE_REF">
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF">
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FORMULA_REF">
                          <xs:complexType>
                            <xs:attribute name="FORMULA_KEY">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SET_POS_COUNT_VALUE">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                      <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                      <xs:documentation>setzt Anzahl</xs:documentation>
                      <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="SET_MESSAGE">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                      <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                      <xs:documentation>setzt Anzahl</xs:documentation>
                      <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="MESSAGE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="FEATURE_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Entscheidungstabellen wieder entfernt, nur Angabe FEATURE_NO, 02.05.2014</xs:documentation>
          <xs:documentation xml:lang="de">Version Beta 2.0 Build 12</xs:documentation>
          <xs:documentation xml:lang="de">minimale Kardinalität auf 0 geändert K.Richter 18.07.2014</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRIO">
        <xs:annotation>
          <xs:documentation xml:lang="de">neu IDM 2.4
Priorität von Prüfungen

Am Artikel können nur Decisions mit niedriger Priorität hinzu bzw. ausgeschaltet werden
Mehrere DECISIONS können auf einem gleichen Priolevel liegen

</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DECISION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="de">IDM 2.4 Build 14 H.Balke 05.2014
0 = ausschließende (nicht erlaubende) Preparation
1 = Preparation
2 = action Rules
3 = action Rule mit SET_POS_COUNT_VALUE (setzt die Anzahl in der die Position in der Stückliste erscheint)

Restriktions werden vor Eingabe einer Variante am Artikel ausgewertet.
Wenn dann ein Wert ausgewählt wurde, greifen die action Rules, welche dann Werte setzen oder Variantenarten ausblenden können.
Bei Action Rules greift immer die erste Zeile (option combination), die zutrifft. In dem Fall werden alle zugehörigen Actions ausgeführt.
</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:int">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
                          See Also
                          DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_NAME_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element : DECISION_NAME_TEXT Element
Description
This element is used to specify the designation of a rule.
Namespace (none)
Type
languagetext60 Complex Type
Diagram
LANGUAGE Element Sequence DECISION_NAME_TEXT Element
Overview
DECISION_NAME_TEXT languagetext60 Complex Type
This element is used to specify the designation of a rule.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="DECISION_NAME_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_COMBINATION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element : OPTION_COMBINATION Element
Description

This element is used to form a feature combination that is linked to certain conditions.

If the value of DECISION_TYPE is 2 or 3, actions (ACTIONS) can also be assigned to the feature combination.

Namespace (none)
Diagram
ACTIONS Element OPTIONS_SET_REF Element Sequence OPTION_COMBINATION Element
Overview
OPTION_COMBINATION 1..∞

This element is used to form a feature combination that is linked to certain conditions.

If the value of DECISION_TYPE is 2 or 3, actions (ACTIONS) can also be assigned to the feature combination.

SEQUENCE required Restriction of xs:nonNegativeInteger
This element is used to specify the sequence in which the assigned assessment procedures will be executed. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

This element is used to reference a feature and define a rule for its feature classes. The rules may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
REF_LEVEL optional Restriction of xs:nonNegativeInteger
In piece lists, sub-positions can query features of the main position (PARENT), the uppermost position (ROOT) and the item itself (SELF) via the REF_LEVEL and depending on them trigger an action or integrate the action in a condition.

1 = ROOT

2 = PARENT

3 = SELF (default is SELF if no REF level is specified) 		D nonNegativeInteger
P
M [1:3]
Choice
OPTION_INTERVAL
This element is used to evaluate whether an option falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
FEATURE_REF_OP

This element is used to directly compare the feature.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a feature.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

 D operator
P eq|ne
M
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
ACTIONS optional

This element is used to determine actions that are executed under certain conditions.

Actions (ACTIONS) are instructions that are executed if a condition is met. The following actions can be executed:

  • The setting of options (SET_FEATURE_FIXED) with the following options:

§Direct, e.g. main fabric = "blue" (OPTION)

§the setting of feature values from another feature (FEATURE), e.g. ledge fabric = main fabric

§the calculation of options (e.g. sitting height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

  • The setting of standard options (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
    These can be filled if no value has been entered yet. The same options as above apply.

  • The visibility of features (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) and disabling of rules (DISABLE_DECISION, ENABLE_DECISION):
    Example: for wooden feet, a potentially existing feature for a shade can be displayed and made invisible if a metal foot is selected.

Choice 1..∞
SET_FEATURE_DEFAULT

This action is used to set standard options.

These can be filled if no value has been entered yet.

  • The following options are available for the setting of options:

- Direct , e.g. main fabric = "blue" (OPTION)

- the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

- the calculation of options. (e.g. seat height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
This element references another feature for the setting of option values.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPTION_REF
This element is used to reference an option (OPTION) that is directly set as standard.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
FORMULA_REF
This element is used to reference a formula for the calculation of standard values.
FORMULA_KEY required Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
SET_FEATURE_FIXED

This action is used to set options.

The following options are available for the setting of options:

- Direct , e.g. main fabric = "blue" (OPTION)

- the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

- the calculation of options. (e.g. seat height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
This element references another feature for the setting of option values.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPTION_REF
This element is used to reference an option (OPTION) that is set directly.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
FORMULA_REF
This element is used to reference a formula for the calculation of options.
FORMULA_KEY required Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
ENABLE_DECISION

This action activates rules.

DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
DISABLE_DECISION

This action deactivates rules.

DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
SET_FEATURE_VISIBLE
This action makes features visible.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
SET_FEATURE_INVISIBLE
This action makes features invisible.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
SET_FEATURE
This action sets a value for an option of a feature. Contrary to „SET_FEATURE FIXED“, this value can be modified if permitted by the conditions. This value rule also applies if the corresponding field was previously set to default or manual.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
This element references another feature for the setting of option values.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPTION_REF
This element is used to reference an option (OPTION) that is set directly.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
FORMULA_REF
This element is used to reference a formula for the calculation of options.
FORMULA_KEY optional Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
SET_FEATURE_DEFAULT_NULL

This action is used to set standard options.

The default value only applies if the relevant feature field was previously blank.

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
This element references another feature for the setting of NULL.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPTION_REF
This element is used to reference an option (OPTION) that is set to NULL.
OPTION_KEY optional Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
FORMULA_REF
This element is used to reference a formula for the calculation of options.
FORMULA_KEY optional Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
This version is used to set a quantity in the piece list.
This action must only be specified for rules with DECISION_TYPE = 3. 		D nonNegativeInteger
P
M [0:9999]
SET_MESSAGE
This element is used to set a message for the purpose of triggering warnings or notices for certain feature combinations.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a message. D nonNegativeInteger
P
M [0:999999]
Attributes
Name Type Use Default Fixed Description
SEQUENCE Restriction of xs:nonNegativeInteger required
This element is used to specify the sequence in which the assigned assessment procedures will be executed. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="OPTION_COMBINATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:complexType>
          <xs:choice>
            <xs:element name="OPTION_INTERVAL">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY_MIN" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY_MAX" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_LIST">
              <xs:complexType>
                <xs:sequence maxOccurs="unbounded">
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_GROUP_REF_OP">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_GROUP_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF_OP">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne|gt|lt|ge|le" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURE_REF_OP">
              <xs:annotation>
                <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MEASURE_VALUE_OP">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne|gt|lt|ge|le" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MEASURE_INTERVAL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
                <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="REF_LEVEL" use="optional">
            <xs:annotation>
              <xs:documentation xml:lang="DE">1 = ROOT
2 = PARENT
3 = SELF
Standardfall ist SELF, wenn kein REF-Level angegeben ist</xs:documentation>
              <xs:documentation xml:lang="DE">12.02.2015 K. Richter</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="3" />
                <xs:minInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ACTIONS" minOccurs="0">
        <xs:complexType>
          <xs:choice maxOccurs="unbounded">
            <xs:element name="SET_FEATURE_DEFAULT">
              <xs:complexType>
                <xs:choice>
                  <xs:element name="FEATURE_REF">
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FORMULA_REF">
                    <xs:complexType>
                      <xs:attribute name="FORMULA_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_FEATURE_FIXED">
              <xs:complexType>
                <xs:choice>
                  <xs:element name="FEATURE_REF">
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FORMULA_REF">
                    <xs:complexType>
                      <xs:attribute name="FORMULA_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ENABLE_DECISION">
              <xs:complexType>
                <xs:attribute name="DECISION_NO">
                  <xs:annotation>
                    <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DISABLE_DECISION">
              <xs:complexType>
                <xs:attribute name="DECISION_NO">
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_FEATURE_VISIBLE">
              <xs:complexType>
                <xs:attribute name="FEATURE_NO">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_FEATURE_INVISIBLE">
              <xs:complexType>
                <xs:attribute name="FEATURE_NO">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_FEATURE">
              <xs:complexType>
                <xs:choice>
                  <xs:element name="FEATURE_REF">
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FORMULA_REF">
                    <xs:complexType>
                      <xs:attribute name="FORMULA_KEY">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_FEATURE_DEFAULT_NULL">
              <xs:complexType>
                <xs:choice>
                  <xs:element name="FEATURE_REF">
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FORMULA_REF">
                    <xs:complexType>
                      <xs:attribute name="FORMULA_KEY">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_POS_COUNT_VALUE">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                <xs:documentation>setzt Anzahl</xs:documentation>
                <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="SET_MESSAGE">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                <xs:documentation>setzt Anzahl</xs:documentation>
                <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="MESSAGE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTIONS_SET_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element : OPTIONS_SET_REF Element
Description

This element is used to reference a feature and define a rule for its feature classes. The rules may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

Namespace (none)
Diagram
MEASURE_INTERVAL Element MEASURE_VALUE_OP Element FEATURE_REF_OP Element OPTION_REF_OP Element OPTION_GROUP_REF_OP Element OPTION_LIST Element OPTION_INTERVAL Element Choice OPTIONS_SET_REF Element
Overview
OPTIONS_SET_REF 0..∞

This element is used to reference a feature and define a rule for its feature classes. The rules may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
REF_LEVEL optional Restriction of xs:nonNegativeInteger
In piece lists, sub-positions can query features of the main position (PARENT), the uppermost position (ROOT) and the item itself (SELF) via the REF_LEVEL and depending on them trigger an action or integrate the action in a condition.

1 = ROOT

2 = PARENT

3 = SELF (default is SELF if no REF level is specified) 		D nonNegativeInteger
P
M [1:3]
Choice
OPTION_INTERVAL
This element is used to evaluate whether an option falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
FEATURE_REF_OP

This element is used to directly compare the feature.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a feature.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

 D operator
P eq|ne
M
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
REF_LEVEL Restriction of xs:nonNegativeInteger optional
In piece lists, sub-positions can query features of the main position (PARENT), the uppermost position (ROOT) and the item itself (SELF) via the REF_LEVEL and depending on them trigger an action or integrate the action in a condition.

1 = ROOT

2 = PARENT

3 = SELF (default is SELF if no REF level is specified) 		D nonNegativeInteger
P
M [1:3]
Source
<xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:choice>
      <xs:element name="OPTION_INTERVAL">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY_MIN" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY_MAX" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_LIST">
        <xs:complexType>
          <xs:sequence maxOccurs="unbounded">
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_GROUP_REF_OP">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_GROUP_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF_OP">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne|gt|lt|ge|le" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_REF_OP">
        <xs:annotation>
          <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MEASURE_VALUE_OP">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne|gt|lt|ge|le" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MEASURE_INTERVAL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
          <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="REF_LEVEL" use="optional">
      <xs:annotation>
        <xs:documentation xml:lang="DE">1 = ROOT
2 = PARENT
3 = SELF
Standardfall ist SELF, wenn kein REF-Level angegeben ist</xs:documentation>
        <xs:documentation xml:lang="DE">12.02.2015 K. Richter</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="3" />
          <xs:minInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_INTERVAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : OPTION_INTERVAL Element
Description
This element is used to evaluate whether an option falls within or outside of an interval.
Namespace (none)
Diagram
OPTION_INTERVAL Element
Overview
OPTION_INTERVAL
This element is used to evaluate whether an option falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
OPERATOR Restriction of operator Simple Type required

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN Restriction of xs:string required

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX Restriction of xs:string required
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
Source
<xs:element name="OPTION_INTERVAL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY_MIN" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY_MAX" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_LIST Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : OPTION_LIST Element
Description
This element is used to evaluate whether an option corresponds to a value in a list.
Namespace (none)
Diagram
OPTION_REF Element Sequence OPTION_LIST Element
Overview
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
OPERATOR Restriction of operator Simple Type required

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Source
<xs:element name="OPTION_LIST" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence maxOccurs="unbounded">
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element > OPTION_LIST Element : OPTION_REF Element
Description
This element is used to reference the options in a comparison list.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
OPTION_KEY Restriction of xs:string required
This attribute is used to reference an option. D string
P
M [1:30]
Source
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_LIST Element | OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_GROUP_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : OPTION_GROUP_REF_OP Element
Description
This element is used to evaluate whether an option falls within a feature group.
Namespace (none)
Diagram
OPTION_GROUP_REF_OP Element
Overview
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Attributes
Name Type Use Default Fixed Description
OPTION_GROUP_KEY Restriction of xs:string required
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR Restriction of operator Simple Type required

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Source
<xs:element name="OPTION_GROUP_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_GROUP_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : OPTION_REF_OP Element
Description

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

Namespace (none)
Diagram
OPTION_REF_OP Element
Overview
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
Attributes
Name Type Use Default Fixed Description
OPTION_KEY Restriction of xs:string required
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR Restriction of operator Simple Type required
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
Source
<xs:element name="OPTION_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne|gt|lt|ge|le" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : FEATURE_REF_OP Element
Description

This element is used to directly compare the feature.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

Namespace (none)
Diagram
FEATURE_REF_OP Element
Overview
FEATURE_REF_OP

This element is used to directly compare the feature.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a feature.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

 D operator
P eq|ne
M
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPERATOR Restriction of operator Simple Type required
This attribute is used to define a comparison with a feature.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

 D operator
P eq|ne
M
Source
<xs:element name="FEATURE_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_VALUE_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : MEASURE_VALUE_OP Element
Description
This element is used to check the dimension of an option using another dimension.
Namespace (none)
Diagram
MEASURE_VALUE_OP Element
Overview
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
Attributes
Name Type Use Default Fixed Description
MEASURE_VALUE xs:nonNegativeInteger required

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR Restriction of operator Simple Type required
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
Source
<xs:element name="MEASURE_VALUE_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne|gt|lt|ge|le" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_INTERVAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : MEASURE_INTERVAL Element
Description
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
Namespace (none)
Diagram
MEASURE_INTERVAL Element
Overview
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
Attributes
Name Type Use Default Fixed Description
OPERATOR Restriction of operator Simple Type required

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN xs:nonNegativeInteger required

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX xs:nonNegativeInteger required
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
Source
<xs:element name="MEASURE_INTERVAL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
    <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ACTIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element : ACTIONS Element
Description

This element is used to determine actions that are executed under certain conditions.

Actions (ACTIONS) are instructions that are executed if a condition is met. The following actions can be executed:

  • The setting of options (SET_FEATURE_FIXED) with the following options:

§Direct, e.g. main fabric = "blue" (OPTION)

§the setting of feature values from another feature (FEATURE), e.g. ledge fabric = main fabric

§the calculation of options (e.g. sitting height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

  • The setting of standard options (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
    These can be filled if no value has been entered yet. The same options as above apply.

  • The visibility of features (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) and disabling of rules (DISABLE_DECISION, ENABLE_DECISION):
    Example: for wooden feet, a potentially existing feature for a shade can be displayed and made invisible if a metal foot is selected.

Namespace (none)
Diagram
SET_MESSAGE Element SET_POS_COUNT_VALUE Element SET_FEATURE_DEFAULT_NULL Element SET_FEATURE Element SET_FEATURE_INVISIBLE Element SET_FEATURE_VISIBLE Element DISABLE_DECISION Element ENABLE_DECISION Element SET_FEATURE_FIXED Element SET_FEATURE_DEFAULT Element Choice ACTIONS Element
Overview
ACTIONS optional

This element is used to determine actions that are executed under certain conditions.

Actions (ACTIONS) are instructions that are executed if a condition is met. The following actions can be executed:

  • The setting of options (SET_FEATURE_FIXED) with the following options:

§Direct, e.g. main fabric = "blue" (OPTION)

§the setting of feature values from another feature (FEATURE), e.g. ledge fabric = main fabric

§the calculation of options (e.g. sitting height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

  • The setting of standard options (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
    These can be filled if no value has been entered yet. The same options as above apply.

  • The visibility of features (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) and disabling of rules (DISABLE_DECISION, ENABLE_DECISION):
    Example: for wooden feet, a potentially existing feature for a shade can be displayed and made invisible if a metal foot is selected.

Choice 1..∞
SET_FEATURE_DEFAULT

This action is used to set standard options.

These can be filled if no value has been entered yet.

  • The following options are available for the setting of options:

- Direct , e.g. main fabric = "blue" (OPTION)

- the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

- the calculation of options. (e.g. seat height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
This element references another feature for the setting of option values.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPTION_REF
This element is used to reference an option (OPTION) that is directly set as standard.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
FORMULA_REF
This element is used to reference a formula for the calculation of standard values.
FORMULA_KEY required Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
SET_FEATURE_FIXED

This action is used to set options.

The following options are available for the setting of options:

- Direct , e.g. main fabric = "blue" (OPTION)

- the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

- the calculation of options. (e.g. seat height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
This element references another feature for the setting of option values.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPTION_REF
This element is used to reference an option (OPTION) that is set directly.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
FORMULA_REF
This element is used to reference a formula for the calculation of options.
FORMULA_KEY required Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
ENABLE_DECISION

This action activates rules.

DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
DISABLE_DECISION

This action deactivates rules.

DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
SET_FEATURE_VISIBLE
This action makes features visible.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
SET_FEATURE_INVISIBLE
This action makes features invisible.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
SET_FEATURE
This action sets a value for an option of a feature. Contrary to „SET_FEATURE FIXED“, this value can be modified if permitted by the conditions. This value rule also applies if the corresponding field was previously set to default or manual.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
This element references another feature for the setting of option values.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPTION_REF
This element is used to reference an option (OPTION) that is set directly.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
FORMULA_REF
This element is used to reference a formula for the calculation of options.
FORMULA_KEY optional Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
SET_FEATURE_DEFAULT_NULL

This action is used to set standard options.

The default value only applies if the relevant feature field was previously blank.

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
This element references another feature for the setting of NULL.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPTION_REF
This element is used to reference an option (OPTION) that is set to NULL.
OPTION_KEY optional Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
FORMULA_REF
This element is used to reference a formula for the calculation of options.
FORMULA_KEY optional Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
This version is used to set a quantity in the piece list.
This action must only be specified for rules with DECISION_TYPE = 3. 		D nonNegativeInteger
P
M [0:9999]
SET_MESSAGE
This element is used to set a message for the purpose of triggering warnings or notices for certain feature combinations.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a message. D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="ACTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:choice maxOccurs="unbounded">
      <xs:element name="SET_FEATURE_DEFAULT">
        <xs:complexType>
          <xs:choice>
            <xs:element name="FEATURE_REF">
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FORMULA_REF">
              <xs:complexType>
                <xs:attribute name="FORMULA_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_FEATURE_FIXED">
        <xs:complexType>
          <xs:choice>
            <xs:element name="FEATURE_REF">
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FORMULA_REF">
              <xs:complexType>
                <xs:attribute name="FORMULA_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ENABLE_DECISION">
        <xs:complexType>
          <xs:attribute name="DECISION_NO">
            <xs:annotation>
              <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DISABLE_DECISION">
        <xs:complexType>
          <xs:attribute name="DECISION_NO">
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_FEATURE_VISIBLE">
        <xs:complexType>
          <xs:attribute name="FEATURE_NO">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_FEATURE_INVISIBLE">
        <xs:complexType>
          <xs:attribute name="FEATURE_NO">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_FEATURE">
        <xs:complexType>
          <xs:choice>
            <xs:element name="FEATURE_REF">
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FORMULA_REF">
              <xs:complexType>
                <xs:attribute name="FORMULA_KEY">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_FEATURE_DEFAULT_NULL">
        <xs:complexType>
          <xs:choice>
            <xs:element name="FEATURE_REF">
              <xs:complexType>
                <xs:attribute name="FEATURE_NO">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FORMULA_REF">
              <xs:complexType>
                <xs:attribute name="FORMULA_KEY">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_POS_COUNT_VALUE">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
          <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
          <xs:documentation>setzt Anzahl</xs:documentation>
          <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="SET_MESSAGE">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
          <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
          <xs:documentation>setzt Anzahl</xs:documentation>
          <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="MESSAGE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
  </xs:complexType>
</xs:element>
See Also
OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_FEATURE_DEFAULT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_FEATURE_DEFAULT Element
Description

This action is used to set standard options.

These can be filled if no value has been entered yet.

  • The following options are available for the setting of options:

- Direct , e.g. main fabric = "blue" (OPTION)

- the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

- the calculation of options. (e.g. seat height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

Namespace (none)
Diagram
FORMULA_REF Element OPTION_REF Element FEATURE_REF Element Choice SET_FEATURE_DEFAULT Element
Overview
SET_FEATURE_DEFAULT

This action is used to set standard options.

These can be filled if no value has been entered yet.

  • The following options are available for the setting of options:

- Direct , e.g. main fabric = "blue" (OPTION)

- the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

- the calculation of options. (e.g. seat height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
This element references another feature for the setting of option values.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPTION_REF
This element is used to reference an option (OPTION) that is directly set as standard.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
FORMULA_REF
This element is used to reference a formula for the calculation of standard values.
FORMULA_KEY required Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="SET_FEATURE_DEFAULT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:choice>
      <xs:element name="FEATURE_REF">
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FORMULA_REF">
        <xs:complexType>
          <xs:attribute name="FORMULA_KEY" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_DEFAULT Element : FEATURE_REF Element
Description
This element references another feature for the setting of option values.
Namespace (none)
Diagram
FEATURE_REF Element
Overview
FEATURE_REF
This element references another feature for the setting of option values.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="FEATURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_FEATURE_DEFAULT Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_DEFAULT Element : OPTION_REF Element
Description
This element is used to reference an option (OPTION) that is directly set as standard.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF
This element is used to reference an option (OPTION) that is directly set as standard.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
OPTION_KEY Restriction of xs:string required
This attribute is used to reference an option. D string
P
M [1:30]
Source
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_FEATURE_DEFAULT Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULA_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_DEFAULT Element : FORMULA_REF Element
Description
This element is used to reference a formula for the calculation of standard values.
Namespace (none)
Diagram
FORMULA_REF Element
Overview
FORMULA_REF
This element is used to reference a formula for the calculation of standard values.
FORMULA_KEY required Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
FORMULA_KEY Restriction of xs:string required
This attribute is used to reference a formula. D string
P
M [1:30]
Source
<xs:element name="FORMULA_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FORMULA_KEY" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_FEATURE_DEFAULT Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_FEATURE_FIXED Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_FEATURE_FIXED Element
Description

This action is used to set options.

The following options are available for the setting of options:

- Direct , e.g. main fabric = "blue" (OPTION)

- the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

- the calculation of options. (e.g. seat height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

Namespace (none)
Diagram
FORMULA_REF Element OPTION_REF Element FEATURE_REF Element Choice SET_FEATURE_FIXED Element
Overview
SET_FEATURE_FIXED

This action is used to set options.

The following options are available for the setting of options:

- Direct , e.g. main fabric = "blue" (OPTION)

- the setting of option values from another feature (FEATURE), e.g. ledge fabric = main fabric

- the calculation of options. (e.g. seat height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the feature (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
This element references another feature for the setting of option values.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPTION_REF
This element is used to reference an option (OPTION) that is set directly.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
FORMULA_REF
This element is used to reference a formula for the calculation of options.
FORMULA_KEY required Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="SET_FEATURE_FIXED" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:choice>
      <xs:element name="FEATURE_REF">
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FORMULA_REF">
        <xs:complexType>
          <xs:attribute name="FORMULA_KEY" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_FIXED Element : FEATURE_REF Element
Description
This element references another feature for the setting of option values.
Namespace (none)
Diagram
FEATURE_REF Element
Overview
FEATURE_REF
This element references another feature for the setting of option values.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="FEATURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_FEATURE_FIXED Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_FIXED Element : OPTION_REF Element
Description
This element is used to reference an option (OPTION) that is set directly.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF
This element is used to reference an option (OPTION) that is set directly.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
OPTION_KEY Restriction of xs:string required
This attribute is used to reference an option. D string
P
M [1:30]
Source
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_FEATURE_FIXED Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULA_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_FIXED Element : FORMULA_REF Element
Description
This element is used to reference a formula for the calculation of options.
Namespace (none)
Diagram
FORMULA_REF Element
Overview
FORMULA_REF
This element is used to reference a formula for the calculation of options.
FORMULA_KEY required Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
FORMULA_KEY Restriction of xs:string required
This attribute is used to reference a formula. D string
P
M [1:30]
Source
<xs:element name="FORMULA_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FORMULA_KEY" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_FEATURE_FIXED Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ENABLE_DECISION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : ENABLE_DECISION Element
Description

This action activates rules.

Namespace (none)
Diagram
ENABLE_DECISION Element
Overview
ENABLE_DECISION

This action activates rules.

DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
DECISION_NO Restriction of xs:positiveInteger optional
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="ENABLE_DECISION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="DECISION_NO">
      <xs:annotation>
        <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DISABLE_DECISION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : DISABLE_DECISION Element
Description

This action deactivates rules.

Namespace (none)
Diagram
DISABLE_DECISION Element
Overview
DISABLE_DECISION

This action deactivates rules.

DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
DECISION_NO Restriction of xs:positiveInteger optional
This attribute is used to reference a rule. D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DISABLE_DECISION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="DECISION_NO">
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_FEATURE_VISIBLE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_FEATURE_VISIBLE Element
Description
This action makes features visible.
Namespace (none)
Diagram
SET_FEATURE_VISIBLE Element
Overview
SET_FEATURE_VISIBLE
This action makes features visible.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger optional
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="SET_FEATURE_VISIBLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FEATURE_NO">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_FEATURE_INVISIBLE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_FEATURE_INVISIBLE Element
Description
This action makes features invisible.
Namespace (none)
Diagram
SET_FEATURE_INVISIBLE Element
Overview
SET_FEATURE_INVISIBLE
This action makes features invisible.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger optional
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="SET_FEATURE_INVISIBLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FEATURE_NO">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_FEATURE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_FEATURE Element
Description
This action sets a value for an option of a feature. Contrary to „SET_FEATURE FIXED“, this value can be modified if permitted by the conditions. This value rule also applies if the corresponding field was previously set to default or manual.
Namespace (none)
Diagram
FORMULA_REF Element OPTION_REF Element FEATURE_REF Element Choice SET_FEATURE Element
Overview
SET_FEATURE
This action sets a value for an option of a feature. Contrary to „SET_FEATURE FIXED“, this value can be modified if permitted by the conditions. This value rule also applies if the corresponding field was previously set to default or manual.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
This element references another feature for the setting of option values.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPTION_REF
This element is used to reference an option (OPTION) that is set directly.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
FORMULA_REF
This element is used to reference a formula for the calculation of options.
FORMULA_KEY optional Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="SET_FEATURE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:choice>
      <xs:element name="FEATURE_REF">
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FORMULA_REF">
        <xs:complexType>
          <xs:attribute name="FORMULA_KEY">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE Element : FEATURE_REF Element
Description
This element references another feature for the setting of option values.
Namespace (none)
Diagram
FEATURE_REF Element
Overview
FEATURE_REF
This element references another feature for the setting of option values.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="FEATURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_FEATURE Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE Element : OPTION_REF Element
Description
This element is used to reference an option (OPTION) that is set directly.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF
This element is used to reference an option (OPTION) that is set directly.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
OPTION_KEY Restriction of xs:string required
This attribute is used to reference an option. D string
P
M [1:30]
Source
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_FEATURE Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULA_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE Element : FORMULA_REF Element
Description
This element is used to reference a formula for the calculation of options.
Namespace (none)
Diagram
FORMULA_REF Element
Overview
FORMULA_REF
This element is used to reference a formula for the calculation of options.
FORMULA_KEY optional Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
FORMULA_KEY Restriction of xs:string optional
This attribute is used to reference a formula. D string
P
M [1:30]
Source
<xs:element name="FORMULA_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FORMULA_KEY">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_FEATURE Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_FEATURE_DEFAULT_NULL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_FEATURE_DEFAULT_NULL Element
Description

This action is used to set standard options.

The default value only applies if the relevant feature field was previously blank.

Namespace (none)
Diagram
FORMULA_REF Element OPTION_REF Element FEATURE_REF Element Choice SET_FEATURE_DEFAULT_NULL Element
Overview
SET_FEATURE_DEFAULT_NULL

This action is used to set standard options.

The default value only applies if the relevant feature field was previously blank.

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
This element references another feature for the setting of NULL.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
OPTION_REF
This element is used to reference an option (OPTION) that is set to NULL.
OPTION_KEY optional Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
FORMULA_REF
This element is used to reference a formula for the calculation of options.
FORMULA_KEY optional Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="SET_FEATURE_DEFAULT_NULL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:choice>
      <xs:element name="FEATURE_REF">
        <xs:complexType>
          <xs:attribute name="FEATURE_NO">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FORMULA_REF">
        <xs:complexType>
          <xs:attribute name="FORMULA_KEY">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_DEFAULT_NULL Element : FEATURE_REF Element
Description
This element references another feature for the setting of NULL.
Namespace (none)
Diagram
FEATURE_REF Element
Overview
FEATURE_REF
This element references another feature for the setting of NULL.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger optional
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="FEATURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FEATURE_NO">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_FEATURE_DEFAULT_NULL Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_DEFAULT_NULL Element : OPTION_REF Element
Description
This element is used to reference an option (OPTION) that is set to NULL.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF
This element is used to reference an option (OPTION) that is set to NULL.
OPTION_KEY optional Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
OPTION_KEY Restriction of xs:string optional
This attribute is used to reference an option. D string
P
M [1:30]
Source
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_FEATURE_DEFAULT_NULL Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULA_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_DEFAULT_NULL Element : FORMULA_REF Element
Description
This element is used to reference a formula for the calculation of options.
Namespace (none)
Diagram
FORMULA_REF Element
Overview
FORMULA_REF
This element is used to reference a formula for the calculation of options.
FORMULA_KEY optional Restriction of xs:string
This attribute is used to reference a formula. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
FORMULA_KEY Restriction of xs:string optional
This attribute is used to reference a formula. D string
P
M [1:30]
Source
<xs:element name="FORMULA_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FORMULA_KEY">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_FEATURE_DEFAULT_NULL Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_POS_COUNT_VALUE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_POS_COUNT_VALUE Element
Description
This version is used to set a quantity in the piece list.
This action must only be specified for rules with DECISION_TYPE = 3. 		D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
SET_POS_COUNT_VALUE Element
Overview
SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
This version is used to set a quantity in the piece list.
This action must only be specified for rules with DECISION_TYPE = 3. 		D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="SET_POS_COUNT_VALUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
    <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
    <xs:documentation>setzt Anzahl</xs:documentation>
    <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_MESSAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_MESSAGE Element
Description
This element is used to set a message for the purpose of triggering warnings or notices for certain feature combinations.
Namespace (none)
Diagram
SET_MESSAGE Element
Overview
SET_MESSAGE
This element is used to set a message for the purpose of triggering warnings or notices for certain feature combinations.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a message. D nonNegativeInteger
P
M [0:999999]
Attributes
Name Type Use Default Fixed Description
MESSAGE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a message. D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="SET_MESSAGE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
    <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
    <xs:documentation>setzt Anzahl</xs:documentation>
    <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MESSAGE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element : VALID_FROM Element
Description
This element is used to specify the date from which date onwards a rule is valid.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
This element is used to specify the date from which date onwards a rule is valid.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
Source
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element : VALID_UNTIL Element
Description
This element specifies the date until which a rule is valid.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which a rule is valid.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Source
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element : FEATURE_REF Element
Description
This element is used to reference a feature.
Namespace (none)
Diagram
FEATURE_REF Element
Overview
FEATURE_REF 0..∞
This element is used to reference a feature.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="FEATURE_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Entscheidungstabellen wieder entfernt, nur Angabe FEATURE_NO, 02.05.2014</xs:documentation>
    <xs:documentation xml:lang="de">Version Beta 2.0 Build 12</xs:documentation>
    <xs:documentation xml:lang="de">minimale Kardinalität auf 0 geändert K.Richter 18.07.2014</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRIO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element : PRIO Element
Description
This element is used to specify a value for the priority of a rule.
A low value means a high priority. This means that the rule takes a lower priority the higher this value is. 		D positiveInteger
P
M [1:999999999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRIO Element
Overview
PRIO Restriction of xs:positiveInteger
This element is used to specify a value for the priority of a rule.
A low value means a high priority. This means that the rule takes a lower priority the higher this value is. 		D positiveInteger
P
M [1:999999999]
Source
<xs:element name="PRIO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">neu IDM 2.4
Priorität von Prüfungen

Am Artikel können nur Decisions mit niedriger Priorität hinzu bzw. ausgeschaltet werden
Mehrere DECISIONS können auf einem gleichen Priolevel liegen

</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_GROUPS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : OPTION_GROUPS Element
Description
This element is used to group quantities of options. They can be referenced in the assessment below OPTION_COMBINATION/FEATURE_REF in DECISIONS. These options are to be considered an independent pool and have no connection to any feature.
Namespace (none)
Diagram
OPTION_GROUP Element Sequence OPTION_GROUPS Element
Overview
OPTION_GROUPS optional
This element is used to group quantities of options. They can be referenced in the assessment below OPTION_COMBINATION/FEATURE_REF in DECISIONS. These options are to be considered an independent pool and have no connection to any feature.
Sequence
OPTION_GROUP 1..∞

This element is used to specify a feature group.

It can be referenced in assessments below OPTION_COMBINATION/FEATURE_REF in the DECISIONS . These options are to be considered an independent pool and have no connection to any feature.

OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to identify a feature group. D string
P
M [1:30]
Sequence
OPTION 1..∞
This element is used to reference an option.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute defines the order of the options in a feature group. D nonNegativeInteger
P
M
OPTION_GROUP_TEXT languagetext60 Complex Type
This element contains texts for feature groups.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="OPTION_GROUPS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_GROUP" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_GROUP_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPTION_GROUP_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_GROUPS Element : OPTION_GROUP Element
Description

This element is used to specify a feature group.

It can be referenced in assessments below OPTION_COMBINATION/FEATURE_REF in the DECISIONS . These options are to be considered an independent pool and have no connection to any feature.

Namespace (none)
Diagram
LANGUAGE Element Sequence OPTION_GROUP_TEXT Element OPTION Element Sequence OPTION_GROUP Element
Overview
OPTION_GROUP 1..∞

This element is used to specify a feature group.

It can be referenced in assessments below OPTION_COMBINATION/FEATURE_REF in the DECISIONS . These options are to be considered an independent pool and have no connection to any feature.

OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to identify a feature group. D string
P
M [1:30]
Sequence
OPTION 1..∞
This element is used to reference an option.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute defines the order of the options in a feature group. D nonNegativeInteger
P
M
OPTION_GROUP_TEXT languagetext60 Complex Type
This element contains texts for feature groups.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
OPTION_GROUP_KEY Restriction of xs:string required
This attribute is used to identify a feature group. D string
P
M [1:30]
Source
<xs:element name="OPTION_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_GROUP_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPTION_GROUP_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_GROUPS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_GROUPS Element > OPTION_GROUP Element : OPTION Element
Description
This element is used to reference an option.
Namespace (none)
Diagram
OPTION Element
Overview
OPTION 1..∞
This element is used to reference an option.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute defines the order of the options in a feature group. D nonNegativeInteger
P
M
Attributes
Name Type Use Default Fixed Description
OPTION_KEY Restriction of xs:string required
This attribute is used to reference an option. D string
P
M [1:30]
SEQUENCE_NO Restriction of xs:nonNegativeInteger optional
This attribute defines the order of the options in a feature group. D nonNegativeInteger
P
M
Source
<xs:element name="OPTION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_GROUP Element | OPTION_GROUPS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_GROUP_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_GROUPS Element > OPTION_GROUP Element : OPTION_GROUP_TEXT Element
Description
This element contains texts for feature groups.
Namespace (none)
Type
languagetext60 Complex Type
Diagram
LANGUAGE Element Sequence OPTION_GROUP_TEXT Element
Overview
OPTION_GROUP_TEXT languagetext60 Complex Type
This element contains texts for feature groups.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="OPTION_GROUP_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPTION_GROUP Element | OPTION_GROUPS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULAS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : FORMULAS Element
Description
This element is used for the calculation of options (e.g. sitting height + 5 cm). The function is however only permitted for dimensional versions with a feature that contains the value "M", the unit of measure can be entered in MEASURE_UNIT, the parameter (e.g. sh for sitting height) in MEASURE_PARAMETER. The calculation is carried out via a formula string that may contain parameters and values.
Namespace (none)
Diagram
FORMULA Element Sequence FORMULAS Element
Overview
FORMULAS optional
This element is used for the calculation of options (e.g. sitting height + 5 cm). The function is however only permitted for dimensional versions with a feature that contains the value "M", the unit of measure can be entered in MEASURE_UNIT, the parameter (e.g. sh for sitting height) in MEASURE_PARAMETER. The calculation is carried out via a formula string that may contain parameters and values.
Sequence
FORMULA 1..∞
The element serves the purpose of defining a formula.The attribute FORMULA_KEY contains the identifier, the FORMULA_STRING contains the actual formula.
FORMULA_KEY required Restriction of xs:string
This attribute is used to define the key for the formula. D string
P
M [1:30]
Sequence
FORMULA_STRING Restriction of xs:string
This element is used to specify a formula. D string
P [+\-*/()A-Za-z. ]{0,}
M
Source
<xs:element name="FORMULAS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Formeln dürfen nur angewendet werden auf Maßvarianten </xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FORMULA" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FORMULA_STRING">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Formeln dürfen nur Parameter enthalten, die an der Variantenart definiert wurden.</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[+\-*/()A-Za-z0-9. ]*" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FORMULA_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULA Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FORMULAS Element : FORMULA Element
Description
The element serves the purpose of defining a formula.The attribute FORMULA_KEY contains the identifier, the FORMULA_STRING contains the actual formula.
Namespace (none)
Diagram
FORMULA_STRING Element Sequence FORMULA Element
Overview
FORMULA 1..∞
The element serves the purpose of defining a formula.The attribute FORMULA_KEY contains the identifier, the FORMULA_STRING contains the actual formula.
FORMULA_KEY required Restriction of xs:string
This attribute is used to define the key for the formula. D string
P
M [1:30]
Sequence
FORMULA_STRING Restriction of xs:string
This element is used to specify a formula. D string
P [+\-*/()A-Za-z. ]{0,}
M
Attributes
Name Type Use Default Fixed Description
FORMULA_KEY Restriction of xs:string required
This attribute is used to define the key for the formula. D string
P
M [1:30]
Source
<xs:element name="FORMULA" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FORMULA_STRING">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Formeln dürfen nur Parameter enthalten, die an der Variantenart definiert wurden.</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[+\-*/()A-Za-z0-9. ]*" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FORMULA_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FORMULAS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULA_STRING Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FORMULAS Element > FORMULA Element : FORMULA_STRING Element
Description
This element is used to specify a formula. D string
P [+\-*/()A-Za-z. ]{0,}
M
Namespace (none)
Type
Restriction of xs:string
Diagram
FORMULA_STRING Element
Overview
FORMULA_STRING Restriction of xs:string
This element is used to specify a formula. D string
P [+\-*/()A-Za-z. ]{0,}
M
Source
<xs:element name="FORMULA_STRING" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Formeln dürfen nur Parameter enthalten, die an der Variantenart definiert wurden.</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[+\-*/()A-Za-z0-9. ]*" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FORMULA Element | FORMULAS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_DEFINITION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : PRICE_DEFINITION Element
Description
This element is used to specify information for the catalogue modification that is necessary for the price calculation, such as price tables and design ranges.
Namespace (none)
Diagram
PRICE_TYPES Element PRICE_FEATURE_GROUPS Element Sequence PRICE_DEFINITION Element
Overview
PRICE_DEFINITION
This element is used to specify information for the catalogue modification that is necessary for the price calculation, such as price tables and design ranges.
Sequence
PRICE_FEATURE_GROUPS
This element is used to define feature groups (PRICE_FEATURE_GROUPS).
Sequence
PRICE_FEATURE_GROUP 1..∞

This element is used to specify price control information. The PRICE_FEATURE_GROUP is used to control the conditions under which a price (e.g. feature combinations) applies.

A PRICE_FEATURE_GROUP is referenced by the item. The specific prices are also specified in the item.

The following rules apply to PRICE_FEATURE_GROUP and/or items:
- Price group-neutral items can have options that are price-neutral. Their price must not be stated in price field 1, and they must only have one FINISHED element for the price field information. Price field-independent items for which only one FINISH element, in which the price is specified, exists in the PRICE_FEATURE_GROUP are only permitted to have one assigned price in accordance with the FINISH element specified in the price field.

- Variation-dependent items have one or a number of features.
- An item must reference precisely one base price group (ADDITIONAL_PRICE=0).

The creation of multiple PRICE_FEATURE_GROUPs with the same combination of features are permitted.

PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to unequivocally identify a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
ADDITIONAL_PRICE required Restriction of xs:boolean
Identifier whether the specified price is a base price or a surcharge. (0 = base price, 1 = additional price).
 D boolean
P
M
Sequence
PRICE_FEATURE_GROUP_TEXT languagetext60 Complex Type
This element contains texts for variation groups.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Choice
FINISH 0..∞
This element is used to assign price fields (PRICE_FIELD) and a manufacturer price group to valid feature combinations.
SEQUENCE required Restriction of xs:nonNegativeInteger
This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The price group is determined by the first matching feature combination. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

This element is used to reference a feature and define a price group for its feature classes. The price groups may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

This element is used to evaluate whether an option falls within or outside of an interval. 

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
PRICE_FIELD Restriction of xs:positiveInteger

These element specifies the price field in which the price of an item in this variation is specified. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1 or path 2).

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:9999]
SUPPLIER_PRICE_GROUP Restriction of xs:string
This catalogue is used to specify the manufacturer's price group.
 D string
P
M [1:10]
VALID_FROM optional Restriction of xs:date
This element is used to specify the date from which date onwards a price field is valid. D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element is used to specify the date until which a price field is valid. D date
P
M
PERCENTAGE_SURCHARGE 0..∞
To allow for percentage surcharges, the element FINISH supplemented below PRICE_FEATURE_GROUP by the element PERCENTAGE_SURCHARGE consisting of OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM and VALID_UNTIL.
This element must only be used for PRICE_FEATURE_GROUP's for which the attribute ADDITIONAL_PRICE is set to 1 (1=surcharge).
The percentage surcharge may refer to different PRICE_FEATURE_GROUPs:

Case 1

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge seat heating 10% of base price --> factor 0.1 * 500 = 50

Surcharge rapport base price 10% of base price + headrest --> factor 0.1 * (500+50) = 55

Surcharge XY 20% on everything --> factor 0.2 * (500+50+66+50+55) = 144.20

Position value = 865.20

Case 2

Base price 500.00

Surcharge seat heating 10% of base price --> factor 0.1 * 500 = 50

Position value = 550.00

Case 3

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge XY 20% of base price + headrest + function --> factor 0.2 * (500+50+66)=123.20

Position value = 739.20

Case 4

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge XY 20% of ( base price + headrest + function ) --> factor 0.2 * (500+50+66)=123.20

Surcharge ZZ -10% of ( base price + function ) --> factor 0.1 * (500+66)=56.60

Position value = 682.60

Case 5

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Condition value 616.00

Surcharge Global1 10% on everything --> factor 0.1 * 616 results in condition value = 61.60

Surcharge Global2 20% on everything --> factor 0.2 * 616 results in condition value = 123.20

Position value = 800.80

The factor value must be specified in the PRICE_FACTOR element.

The price groups to which the percentage surcharge relates are specified under PRICE_FEATURE_GROUP_REF.

The validity is specified in the VALID_FROM and VALID_UNTIL elements.

Position value = 800.80
SEQUENCE required Restriction of xs:nonNegativeInteger
This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The percentage surcharge is determined by the first matching feature combination. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

This element is used to reference a feature and defines a percentage surcharge for its feature classes. The percentage surcharges may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

This element is used to evaluate whether an option falls within or outside of an interval.

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
PRICE_FACTOR Restriction of xs:int

This element specifies a percentage surcharge. It is specified as a factor with five decimal places.

A value of 1050000 corresponds to a surcharge of 10.5%.

A value of -1000000 corresponds to a surcharge of -10%.

 D int
P
M [-9999999:99999999]
PRICE_FEATURE_GROUP_REF 0..∞
This element is used to reference a price group irrespective of the feature and/or calculation method (PRICE_FEATURE_GROUP).
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
VALID_FROM optional Restriction of xs:date
This element is used to specify the date from which date onwards a percentage surcharge is valid. D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element is used to specify the date until a percentage surcharge is valid. D date
P
M
PRICE_TYPES
This element is used to define the price types for piece or dimension-variable calculation of variation-neutral or variation-dependent items.
The child elements WIDTH_X, DEPTH_Y, HEIGHT_Z specify whether the price calculated for an item with this price type depends on the width, height, depth, surface area or volume.
If no dimension is specified as "1", the price does not depend on dimensions and is calculated on a per piece basis (e.g. for a sitting element). The values in BASIC_UNIT and ROUNDING_UNIT are then set to 0.
If "1" is set for a dimension, the price calculation will be based on this dimension (e.g. fabrics).
If exactly two dimensions are set to "1", the price is based on the surface area (e.g. carpets).
If exactly three dimensions are set to "1", the price is based on the volume (e.g. lounge sections).
Sequence 1..∞
PRICE_TYPE
This version is used to define a price type.
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute unequivocally identifies a defined price type. D positiveInteger
P
M [1:250]
Sequence
WIDTH_X Restriction of xs:boolean
If the price that is to be calculated depends on the dimension width, this element is set to 1, otherwise it is set to 0. D boolean
P
M
DEPTH_Y Restriction of xs:boolean
If the price that is to be calculated depends on the dimension depth, this element is set to 1, otherwise it is set to 0. D boolean
P
M
HEIGHT_Z Restriction of xs:boolean
If the price that is to be calculated depends on the dimension height , this element is set to 1, otherwise it is set to 0. D boolean
P
M
BASIC_UNIT Restriction of xs:nonNegativeInteger
The base unit (BASIC_UNIT) specifies on which dimension the prices in the ITEM_PRICE (P1) and ADDITIONAL_PRICE (P2) elements relate.
The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one meter, the value in this element must be entered as "1000". In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³]. If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0".

P1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
P2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
The rounding unit (ROUNDING_UNIT) is used to specify the upward rounding for the length, the surface area and/or the volume. The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one centimetre, the value in this element must be entered as "10". If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0". D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_TYPE Restriction of xs:positiveInteger

To specify the different types of the rounding, the ROUNDING_UNIT element is supplemented with the element ROUNDING_TYPE, with possible values being 1, 2 and 3, that identifies commercial rounding (up and down).

The values have the following meaning:

1 rounding up

2 rounding down

3 commercial rounding

 D positiveInteger
P
M [1:3]
BASIC_PRICE_DEPENDENT Restriction of xs:boolean

If the element is set to 1, the price will be calculated
on the basis of the base price and a base price unit. If the value is 0,
the price calculation is independent from a base price.

The element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC Izzy is to specify the
items base price applicable for the calculation and in .../ITEM/
PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT the
.../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT element. The base price unit is used
as a base value and/or starting point for the dimension-variable calculation.

The element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE
is used to specify the price that serves as a basis for the calculation of the filler price
that corresponds to the basic unit defined in the BASIC_UNIT element.
The base price is always a piece price. An item that is assigned a base price calculation
cannot be assigned a minimum price. The final price
of the item consists of the base price + the
calculated filler price in consideration of the logic defined in the element.
Base prices can only be assigned to items for which at least
one-dimensional is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions.
To calculate the price for the infill dimensions, the logic from the PRICE_TYPE element in conjunction with the
price from element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE is used.
If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

 D boolean
P
M
PRICE_TYPE_FORMULA optional Restriction of xs:string
Price calculation formulas can be specified when defining price types (PRICE_TYPE). Formulas must not be specified for standard price types, such as a calculation that relies squares or cubic metres.
The following rules apply for the definition of price type formulas:
- the parameters b, h and t can be used in formulas. Parameters b, h, t correspond to the parameters b, h and t of the carcase basic shape. Depending on the b, h, t parameters used, the corresponding element WIDTH_Y (P1) (b), DEPTH_Y (P1) (t) or HEIGHT_Z (P1) (h) must be set to "true".
- the basic calculation methods addition (+), subtraction (-), multiplication (*) and division (/) can be used;
- arithmetic brackets can be used;
- +/minus signs must not be used;
- only the final result is rounded;
- elements BASIC_UNIT (P1), ROUNDING_UNIT (P1) and BASIC_PRICE_DEPENDENT (P1) also apply in conjunction with the price type formula;

[SSS_elementpaths_SSS]element paths[EEE_elementpaths_EEE]
P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
PRICE_TYPE_NAME optional languagetext60 Complex Type
This element is used to specify a designation for the defined price type.
The designation simplifies data collection and communication. The designation is not analysed by the planning software.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PRICE_TYPE_RULES optional
This element is used to define rules for determining the price type.
Sequence
PRICE_TYPE_RULE 1..100
This element is used to define rules for determining the price type.
RULE_NO required Restriction of xs:nonNegativeInteger
This element is used to specify the rule number. D nonNegativeInteger
P
M [0:9999]
Sequence
RULE xs:string
This element is used to define the rule. D string
P
M
Remarks

Source
<xs:element name="PRICE_DEFINITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>300--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:choice>
                    <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                              <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:choice>
                                <xs:element name="OPTION_INTERVAL">
                                  <xs:annotation>
                                    <xs:documentation>271--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPTION_KEY_MIN" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPTION_KEY_MAX" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_LIST">
                                  <xs:complexType>
                                    <xs:sequence maxOccurs="unbounded">
                                      <xs:element name="OPTION_REF">
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_KEY" use="required">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_GROUP_REF_OP">
                                  <xs:annotation>
                                    <xs:documentation>271--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_REF_OP">
                                  <xs:annotation>
                                    <xs:documentation>271--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_KEY" use="required">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MEASURE_VALUE_OP">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MEASURE_INTERVAL">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                    <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:choice>
                              <xs:attribute name="FEATURE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="PRICE_FIELD">
                            <xs:annotation>
                              <xs:documentation>311--5--Preisfeld</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="SUPPLIER_PRICE_GROUP">
                            <xs:annotation>
                              <xs:documentation>311--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:minLength value="1" />
                                <xs:maxLength value="10" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="VALID_FROM" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                              <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:date" />
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="VALID_UNTIL" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                              <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:date" />
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="SEQUENCE" use="required">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="PERCENTAGE_SURCHARGE" minOccurs="0" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>geändert K.Richter 23.11.2015</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                              <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:choice>
                                <xs:element name="OPTION_INTERVAL">
                                  <xs:annotation>
                                    <xs:documentation>271--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPTION_KEY_MIN" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPTION_KEY_MAX" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_LIST">
                                  <xs:complexType>
                                    <xs:sequence maxOccurs="unbounded">
                                      <xs:element name="OPTION_REF">
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_KEY" use="required">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_GROUP_REF_OP">
                                  <xs:annotation>
                                    <xs:documentation>271--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_REF_OP">
                                  <xs:annotation>
                                    <xs:documentation>271--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_KEY" use="required">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MEASURE_VALUE_OP">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MEASURE_INTERVAL">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                    <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:choice>
                              <xs:attribute name="FEATURE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="PRICE_FACTOR">
                            <xs:annotation>
                              <xs:documentation>311--5--Preisfeld</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:int">
                                <xs:maxInclusive value="99999999" />
                                <xs:minInclusive value="-9999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="PRICE_FEATURE_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>311--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="VALID_FROM" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                              <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:date" />
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="VALID_UNTIL" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                              <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:date" />
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="SEQUENCE" use="required">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                </xs:sequence>
                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="ADDITIONAL_PRICE" use="required">
                  <xs:annotation>
                    <xs:documentation>300--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:boolean" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_TYPES">
        <xs:annotation>
          <xs:documentation>150--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence maxOccurs="unbounded">
            <xs:element name="PRICE_TYPE">
              <xs:annotation>
                <xs:documentation>150--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="WIDTH_X">
                    <xs:annotation>
                      <xs:documentation>150--3--Breite_X</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DEPTH_Y">
                    <xs:annotation>
                      <xs:documentation>150--4--Tiefe_Y</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HEIGHT_Z">
                    <xs:annotation>
                      <xs:documentation>150--5--Hoehe_Z</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_UNIT">
                    <xs:annotation>
                      <xs:documentation>150--6--Basis_Einheit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ROUNDING_UNIT">
                    <xs:annotation>
                      <xs:documentation>150--7--Rundungseinheit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ROUNDING_TYPE">
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_PRICE_DEPENDENT">
                    <xs:annotation>
                      <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>150--9--Preisart_Formel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="100" />
                        <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_NAME" type="languagetext60" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_RULES" minOccurs="0" maxOccurs="1">
                    <xs:annotation>
                      <xs:documentation>360--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_TYPE_RULE" maxOccurs="100">
                          <xs:annotation>
                            <xs:documentation>Polster
Regeln zur ermittelung der Preisart
z.B. if Preisgruppe A &gt; Preisgruppe B dann nimm Preisgruppe A </xs:documentation>
                            <xs:documentation xml:lang="DE">Version 2.1 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="RULE" type="xs:string">
                                <xs:annotation>
                                  <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
                                  <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="RULE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>360--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>150--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FEATURE_GROUPS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element : PRICE_FEATURE_GROUPS Element
Description
This element is used to define feature groups (PRICE_FEATURE_GROUPS).
Namespace (none)
Diagram
PRICE_FEATURE_GROUP Element Sequence PRICE_FEATURE_GROUPS Element
Overview
PRICE_FEATURE_GROUPS
This element is used to define feature groups (PRICE_FEATURE_GROUPS).
Sequence
PRICE_FEATURE_GROUP 1..∞

This element is used to specify price control information. The PRICE_FEATURE_GROUP is used to control the conditions under which a price (e.g. feature combinations) applies.

A PRICE_FEATURE_GROUP is referenced by the item. The specific prices are also specified in the item.

The following rules apply to PRICE_FEATURE_GROUP and/or items:
- Price group-neutral items can have options that are price-neutral. Their price must not be stated in price field 1, and they must only have one FINISHED element for the price field information. Price field-independent items for which only one FINISH element, in which the price is specified, exists in the PRICE_FEATURE_GROUP are only permitted to have one assigned price in accordance with the FINISH element specified in the price field.

- Variation-dependent items have one or a number of features.
- An item must reference precisely one base price group (ADDITIONAL_PRICE=0).

The creation of multiple PRICE_FEATURE_GROUPs with the same combination of features are permitted.

PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to unequivocally identify a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
ADDITIONAL_PRICE required Restriction of xs:boolean
Identifier whether the specified price is a base price or a surcharge. (0 = base price, 1 = additional price).
 D boolean
P
M
Sequence
PRICE_FEATURE_GROUP_TEXT languagetext60 Complex Type
This element contains texts for variation groups.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Choice
FINISH 0..∞
This element is used to assign price fields (PRICE_FIELD) and a manufacturer price group to valid feature combinations.
SEQUENCE required Restriction of xs:nonNegativeInteger
This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The price group is determined by the first matching feature combination. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

This element is used to reference a feature and define a price group for its feature classes. The price groups may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

This element is used to evaluate whether an option falls within or outside of an interval. 

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
PRICE_FIELD Restriction of xs:positiveInteger

These element specifies the price field in which the price of an item in this variation is specified. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1 or path 2).

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:9999]
SUPPLIER_PRICE_GROUP Restriction of xs:string
This catalogue is used to specify the manufacturer's price group.
 D string
P
M [1:10]
VALID_FROM optional Restriction of xs:date
This element is used to specify the date from which date onwards a price field is valid. D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element is used to specify the date until which a price field is valid. D date
P
M
PERCENTAGE_SURCHARGE 0..∞
To allow for percentage surcharges, the element FINISH supplemented below PRICE_FEATURE_GROUP by the element PERCENTAGE_SURCHARGE consisting of OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM and VALID_UNTIL.
This element must only be used for PRICE_FEATURE_GROUP's for which the attribute ADDITIONAL_PRICE is set to 1 (1=surcharge).
The percentage surcharge may refer to different PRICE_FEATURE_GROUPs:

Case 1

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge seat heating 10% of base price --> factor 0.1 * 500 = 50

Surcharge rapport base price 10% of base price + headrest --> factor 0.1 * (500+50) = 55

Surcharge XY 20% on everything --> factor 0.2 * (500+50+66+50+55) = 144.20

Position value = 865.20

Case 2

Base price 500.00

Surcharge seat heating 10% of base price --> factor 0.1 * 500 = 50

Position value = 550.00

Case 3

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge XY 20% of base price + headrest + function --> factor 0.2 * (500+50+66)=123.20

Position value = 739.20

Case 4

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge XY 20% of ( base price + headrest + function ) --> factor 0.2 * (500+50+66)=123.20

Surcharge ZZ -10% of ( base price + function ) --> factor 0.1 * (500+66)=56.60

Position value = 682.60

Case 5

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Condition value 616.00

Surcharge Global1 10% on everything --> factor 0.1 * 616 results in condition value = 61.60

Surcharge Global2 20% on everything --> factor 0.2 * 616 results in condition value = 123.20

Position value = 800.80

The factor value must be specified in the PRICE_FACTOR element.

The price groups to which the percentage surcharge relates are specified under PRICE_FEATURE_GROUP_REF.

The validity is specified in the VALID_FROM and VALID_UNTIL elements.

Position value = 800.80
SEQUENCE required Restriction of xs:nonNegativeInteger
This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The percentage surcharge is determined by the first matching feature combination. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

This element is used to reference a feature and defines a percentage surcharge for its feature classes. The percentage surcharges may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

This element is used to evaluate whether an option falls within or outside of an interval.

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
PRICE_FACTOR Restriction of xs:int

This element specifies a percentage surcharge. It is specified as a factor with five decimal places.

A value of 1050000 corresponds to a surcharge of 10.5%.

A value of -1000000 corresponds to a surcharge of -10%.

 D int
P
M [-9999999:99999999]
PRICE_FEATURE_GROUP_REF 0..∞
This element is used to reference a price group irrespective of the feature and/or calculation method (PRICE_FEATURE_GROUP).
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
VALID_FROM optional Restriction of xs:date
This element is used to specify the date from which date onwards a percentage surcharge is valid. D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element is used to specify the date until a percentage surcharge is valid. D date
P
M
Remarks

Source
<xs:element name="PRICE_FEATURE_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>300--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:choice>
              <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                        <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:choice>
                          <xs:element name="OPTION_INTERVAL">
                            <xs:annotation>
                              <xs:documentation>271--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPTION_KEY_MIN" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPTION_KEY_MAX" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_LIST">
                            <xs:complexType>
                              <xs:sequence maxOccurs="unbounded">
                                <xs:element name="OPTION_REF">
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_KEY" use="required">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_GROUP_REF_OP">
                            <xs:annotation>
                              <xs:documentation>271--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_REF_OP">
                            <xs:annotation>
                              <xs:documentation>271--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPTION_KEY" use="required">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MEASURE_VALUE_OP">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MEASURE_INTERVAL">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                              <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                        <xs:attribute name="FEATURE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="PRICE_FIELD">
                      <xs:annotation>
                        <xs:documentation>311--5--Preisfeld</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="9999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="SUPPLIER_PRICE_GROUP">
                      <xs:annotation>
                        <xs:documentation>311--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:minLength value="1" />
                          <xs:maxLength value="10" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="VALID_FROM" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                        <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:date" />
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="VALID_UNTIL" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                        <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:date" />
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="SEQUENCE" use="required">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="PERCENTAGE_SURCHARGE" minOccurs="0" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>geändert K.Richter 23.11.2015</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                        <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:choice>
                          <xs:element name="OPTION_INTERVAL">
                            <xs:annotation>
                              <xs:documentation>271--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPTION_KEY_MIN" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPTION_KEY_MAX" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_LIST">
                            <xs:complexType>
                              <xs:sequence maxOccurs="unbounded">
                                <xs:element name="OPTION_REF">
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_KEY" use="required">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_GROUP_REF_OP">
                            <xs:annotation>
                              <xs:documentation>271--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_REF_OP">
                            <xs:annotation>
                              <xs:documentation>271--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPTION_KEY" use="required">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MEASURE_VALUE_OP">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MEASURE_INTERVAL">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                              <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                        <xs:attribute name="FEATURE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="PRICE_FACTOR">
                      <xs:annotation>
                        <xs:documentation>311--5--Preisfeld</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:int">
                          <xs:maxInclusive value="99999999" />
                          <xs:minInclusive value="-9999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="PRICE_FEATURE_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>311--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="VALID_FROM" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                        <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:date" />
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="VALID_UNTIL" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                        <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:date" />
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="SEQUENCE" use="required">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:choice>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="ADDITIONAL_PRICE" use="required">
            <xs:annotation>
              <xs:documentation>300--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:boolean" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FEATURE_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element : PRICE_FEATURE_GROUP Element
Description

This element is used to specify price control information. The PRICE_FEATURE_GROUP is used to control the conditions under which a price (e.g. feature combinations) applies.

A PRICE_FEATURE_GROUP is referenced by the item. The specific prices are also specified in the item.

The following rules apply to PRICE_FEATURE_GROUP and/or items:
- Price group-neutral items can have options that are price-neutral. Their price must not be stated in price field 1, and they must only have one FINISHED element for the price field information. Price field-independent items for which only one FINISH element, in which the price is specified, exists in the PRICE_FEATURE_GROUP are only permitted to have one assigned price in accordance with the FINISH element specified in the price field.

- Variation-dependent items have one or a number of features.
- An item must reference precisely one base price group (ADDITIONAL_PRICE=0).

The creation of multiple PRICE_FEATURE_GROUPs with the same combination of features are permitted.

Namespace (none)
Diagram
PERCENTAGE_SURCHARGE Element FINISH Element Choice LANGUAGE Element Sequence PRICE_FEATURE_GROUP_TEXT Element Sequence PRICE_FEATURE_GROUP Element
Overview
PRICE_FEATURE_GROUP 1..∞

This element is used to specify price control information. The PRICE_FEATURE_GROUP is used to control the conditions under which a price (e.g. feature combinations) applies.

A PRICE_FEATURE_GROUP is referenced by the item. The specific prices are also specified in the item.

The following rules apply to PRICE_FEATURE_GROUP and/or items:
- Price group-neutral items can have options that are price-neutral. Their price must not be stated in price field 1, and they must only have one FINISHED element for the price field information. Price field-independent items for which only one FINISH element, in which the price is specified, exists in the PRICE_FEATURE_GROUP are only permitted to have one assigned price in accordance with the FINISH element specified in the price field.

- Variation-dependent items have one or a number of features.
- An item must reference precisely one base price group (ADDITIONAL_PRICE=0).

The creation of multiple PRICE_FEATURE_GROUPs with the same combination of features are permitted.

PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to unequivocally identify a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
ADDITIONAL_PRICE required Restriction of xs:boolean
Identifier whether the specified price is a base price or a surcharge. (0 = base price, 1 = additional price).
 D boolean
P
M
Sequence
PRICE_FEATURE_GROUP_TEXT languagetext60 Complex Type
This element contains texts for variation groups.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Choice
FINISH 0..∞
This element is used to assign price fields (PRICE_FIELD) and a manufacturer price group to valid feature combinations.
SEQUENCE required Restriction of xs:nonNegativeInteger
This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The price group is determined by the first matching feature combination. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

This element is used to reference a feature and define a price group for its feature classes. The price groups may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

This element is used to evaluate whether an option falls within or outside of an interval. 

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
PRICE_FIELD Restriction of xs:positiveInteger

These element specifies the price field in which the price of an item in this variation is specified. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1 or path 2).

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:9999]
SUPPLIER_PRICE_GROUP Restriction of xs:string
This catalogue is used to specify the manufacturer's price group.
 D string
P
M [1:10]
VALID_FROM optional Restriction of xs:date
This element is used to specify the date from which date onwards a price field is valid. D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element is used to specify the date until which a price field is valid. D date
P
M
PERCENTAGE_SURCHARGE 0..∞
To allow for percentage surcharges, the element FINISH supplemented below PRICE_FEATURE_GROUP by the element PERCENTAGE_SURCHARGE consisting of OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM and VALID_UNTIL.
This element must only be used for PRICE_FEATURE_GROUP's for which the attribute ADDITIONAL_PRICE is set to 1 (1=surcharge).
The percentage surcharge may refer to different PRICE_FEATURE_GROUPs:

Case 1

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge seat heating 10% of base price --> factor 0.1 * 500 = 50

Surcharge rapport base price 10% of base price + headrest --> factor 0.1 * (500+50) = 55

Surcharge XY 20% on everything --> factor 0.2 * (500+50+66+50+55) = 144.20

Position value = 865.20

Case 2

Base price 500.00

Surcharge seat heating 10% of base price --> factor 0.1 * 500 = 50

Position value = 550.00

Case 3

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge XY 20% of base price + headrest + function --> factor 0.2 * (500+50+66)=123.20

Position value = 739.20

Case 4

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge XY 20% of ( base price + headrest + function ) --> factor 0.2 * (500+50+66)=123.20

Surcharge ZZ -10% of ( base price + function ) --> factor 0.1 * (500+66)=56.60

Position value = 682.60

Case 5

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Condition value 616.00

Surcharge Global1 10% on everything --> factor 0.1 * 616 results in condition value = 61.60

Surcharge Global2 20% on everything --> factor 0.2 * 616 results in condition value = 123.20

Position value = 800.80

The factor value must be specified in the PRICE_FACTOR element.

The price groups to which the percentage surcharge relates are specified under PRICE_FEATURE_GROUP_REF.

The validity is specified in the VALID_FROM and VALID_UNTIL elements.

Position value = 800.80
SEQUENCE required Restriction of xs:nonNegativeInteger
This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The percentage surcharge is determined by the first matching feature combination. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

This element is used to reference a feature and defines a percentage surcharge for its feature classes. The percentage surcharges may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

This element is used to evaluate whether an option falls within or outside of an interval.

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
PRICE_FACTOR Restriction of xs:int

This element specifies a percentage surcharge. It is specified as a factor with five decimal places.

A value of 1050000 corresponds to a surcharge of 10.5%.

A value of -1000000 corresponds to a surcharge of -10%.

 D int
P
M [-9999999:99999999]
PRICE_FEATURE_GROUP_REF 0..∞
This element is used to reference a price group irrespective of the feature and/or calculation method (PRICE_FEATURE_GROUP).
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
VALID_FROM optional Restriction of xs:date
This element is used to specify the date from which date onwards a percentage surcharge is valid. D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element is used to specify the date until a percentage surcharge is valid. D date
P
M
Attributes
Name Type Use Default Fixed Description
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
This attribute is used to unequivocally identify a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
ADDITIONAL_PRICE Restriction of xs:boolean required
Identifier whether the specified price is a base price or a surcharge. (0 = base price, 1 = additional price).
 D boolean
P
M
Remarks

Source
<xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>300--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:choice>
        <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                  <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:choice>
                    <xs:element name="OPTION_INTERVAL">
                      <xs:annotation>
                        <xs:documentation>271--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPTION_KEY_MIN" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPTION_KEY_MAX" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_LIST">
                      <xs:complexType>
                        <xs:sequence maxOccurs="unbounded">
                          <xs:element name="OPTION_REF">
                            <xs:complexType>
                              <xs:attribute name="OPTION_KEY" use="required">
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_GROUP_REF_OP">
                      <xs:annotation>
                        <xs:documentation>271--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPTION_GROUP_KEY" use="required">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_REF_OP">
                      <xs:annotation>
                        <xs:documentation>271--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPTION_KEY" use="required">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="eq|ne|gt|lt|ge|le" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MEASURE_VALUE_OP">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="eq|ne|gt|lt|ge|le" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MEASURE_INTERVAL">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                        <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                  <xs:attribute name="FEATURE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="PRICE_FIELD">
                <xs:annotation>
                  <xs:documentation>311--5--Preisfeld</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="9999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="SUPPLIER_PRICE_GROUP">
                <xs:annotation>
                  <xs:documentation>311--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:minLength value="1" />
                    <xs:maxLength value="10" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="VALID_FROM" minOccurs="0">
                <xs:annotation>
                  <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                  <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:date" />
                </xs:simpleType>
              </xs:element>
              <xs:element name="VALID_UNTIL" minOccurs="0">
                <xs:annotation>
                  <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                  <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:date" />
                </xs:simpleType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="SEQUENCE" use="required">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="PERCENTAGE_SURCHARGE" minOccurs="0" maxOccurs="unbounded">
          <xs:annotation>
            <xs:documentation>geändert K.Richter 23.11.2015</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                  <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:choice>
                    <xs:element name="OPTION_INTERVAL">
                      <xs:annotation>
                        <xs:documentation>271--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPTION_KEY_MIN" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPTION_KEY_MAX" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_LIST">
                      <xs:complexType>
                        <xs:sequence maxOccurs="unbounded">
                          <xs:element name="OPTION_REF">
                            <xs:complexType>
                              <xs:attribute name="OPTION_KEY" use="required">
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_GROUP_REF_OP">
                      <xs:annotation>
                        <xs:documentation>271--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPTION_GROUP_KEY" use="required">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_REF_OP">
                      <xs:annotation>
                        <xs:documentation>271--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPTION_KEY" use="required">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="eq|ne|gt|lt|ge|le" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MEASURE_VALUE_OP">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="eq|ne|gt|lt|ge|le" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MEASURE_INTERVAL">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                        <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                  <xs:attribute name="FEATURE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="PRICE_FACTOR">
                <xs:annotation>
                  <xs:documentation>311--5--Preisfeld</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:int">
                    <xs:maxInclusive value="99999999" />
                    <xs:minInclusive value="-9999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="PRICE_FEATURE_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>311--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="VALID_FROM" minOccurs="0">
                <xs:annotation>
                  <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                  <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:date" />
                </xs:simpleType>
              </xs:element>
              <xs:element name="VALID_UNTIL" minOccurs="0">
                <xs:annotation>
                  <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                  <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:date" />
                </xs:simpleType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="SEQUENCE" use="required">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:choice>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="ADDITIONAL_PRICE" use="required">
      <xs:annotation>
        <xs:documentation>300--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:boolean" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element : PRICE_FEATURE_GROUP_TEXT Element
Description
This element contains texts for variation groups.
Namespace (none)
Type
languagetext60 Complex Type
Diagram
LANGUAGE Element Sequence PRICE_FEATURE_GROUP_TEXT Element
Overview
PRICE_FEATURE_GROUP_TEXT languagetext60 Complex Type
This element contains texts for variation groups.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FINISH Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element : FINISH Element
Description
This element is used to assign price fields (PRICE_FIELD) and a manufacturer price group to valid feature combinations.
Namespace (none)
Diagram
VALID_UNTIL Element VALID_FROM Element SUPPLIER_PRICE_GROUP Element PRICE_FIELD Element OPTIONS_SET_REF Element Sequence FINISH Element
Overview
FINISH 0..∞
This element is used to assign price fields (PRICE_FIELD) and a manufacturer price group to valid feature combinations.
SEQUENCE required Restriction of xs:nonNegativeInteger
This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The price group is determined by the first matching feature combination. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

This element is used to reference a feature and define a price group for its feature classes. The price groups may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

This element is used to evaluate whether an option falls within or outside of an interval. 

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
PRICE_FIELD Restriction of xs:positiveInteger

These element specifies the price field in which the price of an item in this variation is specified. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1 or path 2).

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:9999]
SUPPLIER_PRICE_GROUP Restriction of xs:string
This catalogue is used to specify the manufacturer's price group.
 D string
P
M [1:10]
VALID_FROM optional Restriction of xs:date
This element is used to specify the date from which date onwards a price field is valid. D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element is used to specify the date until which a price field is valid. D date
P
M
Attributes
Name Type Use Default Fixed Description
SEQUENCE Restriction of xs:nonNegativeInteger required
This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The price group is determined by the first matching feature combination. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
          <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:choice>
            <xs:element name="OPTION_INTERVAL">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY_MIN" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY_MAX" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_LIST">
              <xs:complexType>
                <xs:sequence maxOccurs="unbounded">
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_GROUP_REF_OP">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_GROUP_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF_OP">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne|gt|lt|ge|le" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MEASURE_VALUE_OP">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne|gt|lt|ge|le" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MEASURE_INTERVAL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
                <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>311--5--Preisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="SUPPLIER_PRICE_GROUP">
        <xs:annotation>
          <xs:documentation>311--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTIONS_SET_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : OPTIONS_SET_REF Element
Description

This element is used to reference a feature and define a price group for its feature classes. The price groups may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

Namespace (none)
Diagram
MEASURE_INTERVAL Element MEASURE_VALUE_OP Element OPTION_REF_OP Element OPTION_GROUP_REF_OP Element OPTION_LIST Element OPTION_INTERVAL Element Choice OPTIONS_SET_REF Element
Overview
OPTIONS_SET_REF 0..∞

This element is used to reference a feature and define a price group for its feature classes. The price groups may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

This element is used to evaluate whether an option falls within or outside of an interval. 

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
    <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:choice>
      <xs:element name="OPTION_INTERVAL">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY_MIN" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY_MAX" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_LIST">
        <xs:complexType>
          <xs:sequence maxOccurs="unbounded">
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_GROUP_REF_OP">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_GROUP_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF_OP">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne|gt|lt|ge|le" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MEASURE_VALUE_OP">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne|gt|lt|ge|le" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MEASURE_INTERVAL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
          <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_INTERVAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element : OPTION_INTERVAL Element
Description

This element is used to evaluate whether an option falls within or outside of an interval. 

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

Namespace (none)
Diagram
OPTION_INTERVAL Element
Overview
OPTION_INTERVAL

This element is used to evaluate whether an option falls within or outside of an interval. 

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
OPERATOR Restriction of operator Simple Type required

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN Restriction of xs:string required

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX Restriction of xs:string required
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
Source
<xs:element name="OPTION_INTERVAL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY_MIN" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY_MAX" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_LIST Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element : OPTION_LIST Element
Description
This element is used to evaluate whether an option corresponds to a value in a list.
Namespace (none)
Diagram
OPTION_REF Element Sequence OPTION_LIST Element
Overview
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
OPERATOR Restriction of operator Simple Type required

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Source
<xs:element name="OPTION_LIST" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence maxOccurs="unbounded">
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element > OPTION_LIST Element : OPTION_REF Element
Description
This element is used to reference the options in a comparison list.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
OPTION_KEY Restriction of xs:string required
This attribute is used to reference an option. D string
P
M [1:30]
Source
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_LIST Element | OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_GROUP_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element : OPTION_GROUP_REF_OP Element
Description
This element is used to evaluate whether an option falls within a feature group.
Namespace (none)
Diagram
OPTION_GROUP_REF_OP Element
Overview
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Attributes
Name Type Use Default Fixed Description
OPTION_GROUP_KEY Restriction of xs:string required
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR Restriction of operator Simple Type required

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Source
<xs:element name="OPTION_GROUP_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_GROUP_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element : OPTION_REF_OP Element
Description

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

Namespace (none)
Diagram
OPTION_REF_OP Element
Overview
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
Attributes
Name Type Use Default Fixed Description
OPTION_KEY Restriction of xs:string required
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR Restriction of operator Simple Type required
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
Source
<xs:element name="OPTION_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne|gt|lt|ge|le" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_VALUE_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element : MEASURE_VALUE_OP Element
Description
This element is used to check the dimension of an option using another dimension.
Namespace (none)
Diagram
MEASURE_VALUE_OP Element
Overview
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
Attributes
Name Type Use Default Fixed Description
MEASURE_VALUE xs:nonNegativeInteger required

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR Restriction of operator Simple Type required
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
Source
<xs:element name="MEASURE_VALUE_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne|gt|lt|ge|le" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_INTERVAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element : MEASURE_INTERVAL Element
Description
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
Namespace (none)
Diagram
MEASURE_INTERVAL Element
Overview
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
Attributes
Name Type Use Default Fixed Description
OPERATOR Restriction of operator Simple Type required

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN xs:nonNegativeInteger required

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX xs:nonNegativeInteger required
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
Source
<xs:element name="MEASURE_INTERVAL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
    <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FIELD Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : PRICE_FIELD Element
Description

These element specifies the price field in which the price of an item in this variation is specified. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1 or path 2).

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:9999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger

These element specifies the price field in which the price of an item in this variation is specified. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1 or path 2).

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:9999]
Source
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--5--Preisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SUPPLIER_PRICE_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : SUPPLIER_PRICE_GROUP Element
Description
This catalogue is used to specify the manufacturer's price group.
 D string
P
M [1:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
SUPPLIER_PRICE_GROUP Element
Overview
SUPPLIER_PRICE_GROUP Restriction of xs:string
This catalogue is used to specify the manufacturer's price group.
 D string
P
M [1:10]
Source
<xs:element name="SUPPLIER_PRICE_GROUP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : VALID_FROM Element
Description
This element is used to specify the date from which date onwards a price field is valid. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
This element is used to specify the date from which date onwards a price field is valid. D date
P
M
Source
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : VALID_UNTIL Element
Description
This element is used to specify the date until which a price field is valid. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
This element is used to specify the date until which a price field is valid. D date
P
M
Source
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PERCENTAGE_SURCHARGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element : PERCENTAGE_SURCHARGE Element
Description
To allow for percentage surcharges, the element FINISH supplemented below PRICE_FEATURE_GROUP by the element PERCENTAGE_SURCHARGE consisting of OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM and VALID_UNTIL.
This element must only be used for PRICE_FEATURE_GROUP's for which the attribute ADDITIONAL_PRICE is set to 1 (1=surcharge).
The percentage surcharge may refer to different PRICE_FEATURE_GROUPs:

Case 1

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge seat heating 10% of base price --> factor 0.1 * 500 = 50

Surcharge rapport base price 10% of base price + headrest --> factor 0.1 * (500+50) = 55

Surcharge XY 20% on everything --> factor 0.2 * (500+50+66+50+55) = 144.20

Position value = 865.20

Case 2

Base price 500.00

Surcharge seat heating 10% of base price --> factor 0.1 * 500 = 50

Position value = 550.00

Case 3

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge XY 20% of base price + headrest + function --> factor 0.2 * (500+50+66)=123.20

Position value = 739.20

Case 4

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge XY 20% of ( base price + headrest + function ) --> factor 0.2 * (500+50+66)=123.20

Surcharge ZZ -10% of ( base price + function ) --> factor 0.1 * (500+66)=56.60

Position value = 682.60

Case 5

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Condition value 616.00

Surcharge Global1 10% on everything --> factor 0.1 * 616 results in condition value = 61.60

Surcharge Global2 20% on everything --> factor 0.2 * 616 results in condition value = 123.20

Position value = 800.80

The factor value must be specified in the PRICE_FACTOR element.

The price groups to which the percentage surcharge relates are specified under PRICE_FEATURE_GROUP_REF.

The validity is specified in the VALID_FROM and VALID_UNTIL elements.

Position value = 800.80
Namespace (none)
Diagram
VALID_UNTIL Element VALID_FROM Element PRICE_FEATURE_GROUP_REF Element PRICE_FACTOR Element OPTIONS_SET_REF Element Sequence PERCENTAGE_SURCHARGE Element
Overview
PERCENTAGE_SURCHARGE 0..∞
To allow for percentage surcharges, the element FINISH supplemented below PRICE_FEATURE_GROUP by the element PERCENTAGE_SURCHARGE consisting of OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM and VALID_UNTIL.
This element must only be used for PRICE_FEATURE_GROUP's for which the attribute ADDITIONAL_PRICE is set to 1 (1=surcharge).
The percentage surcharge may refer to different PRICE_FEATURE_GROUPs:

Case 1

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge seat heating 10% of base price --> factor 0.1 * 500 = 50

Surcharge rapport base price 10% of base price + headrest --> factor 0.1 * (500+50) = 55

Surcharge XY 20% on everything --> factor 0.2 * (500+50+66+50+55) = 144.20

Position value = 865.20

Case 2

Base price 500.00

Surcharge seat heating 10% of base price --> factor 0.1 * 500 = 50

Position value = 550.00

Case 3

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge XY 20% of base price + headrest + function --> factor 0.2 * (500+50+66)=123.20

Position value = 739.20

Case 4

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Surcharge XY 20% of ( base price + headrest + function ) --> factor 0.2 * (500+50+66)=123.20

Surcharge ZZ -10% of ( base price + function ) --> factor 0.1 * (500+66)=56.60

Position value = 682.60

Case 5

Base price 500.00

Surcharge headrest 50.00

Surcharge function 66.00

Condition value 616.00

Surcharge Global1 10% on everything --> factor 0.1 * 616 results in condition value = 61.60

Surcharge Global2 20% on everything --> factor 0.2 * 616 results in condition value = 123.20

Position value = 800.80

The factor value must be specified in the PRICE_FACTOR element.

The price groups to which the percentage surcharge relates are specified under PRICE_FEATURE_GROUP_REF.

The validity is specified in the VALID_FROM and VALID_UNTIL elements.

Position value = 800.80
SEQUENCE required Restriction of xs:nonNegativeInteger
This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The percentage surcharge is determined by the first matching feature combination. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

This element is used to reference a feature and defines a percentage surcharge for its feature classes. The percentage surcharges may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

This element is used to evaluate whether an option falls within or outside of an interval.

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
PRICE_FACTOR Restriction of xs:int

This element specifies a percentage surcharge. It is specified as a factor with five decimal places.

A value of 1050000 corresponds to a surcharge of 10.5%.

A value of -1000000 corresponds to a surcharge of -10%.

 D int
P
M [-9999999:99999999]
PRICE_FEATURE_GROUP_REF 0..∞
This element is used to reference a price group irrespective of the feature and/or calculation method (PRICE_FEATURE_GROUP).
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
VALID_FROM optional Restriction of xs:date
This element is used to specify the date from which date onwards a percentage surcharge is valid. D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element is used to specify the date until a percentage surcharge is valid. D date
P
M
Attributes
Name Type Use Default Fixed Description
SEQUENCE Restriction of xs:nonNegativeInteger required
This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The percentage surcharge is determined by the first matching feature combination. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="PERCENTAGE_SURCHARGE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>geändert K.Richter 23.11.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
          <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:choice>
            <xs:element name="OPTION_INTERVAL">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY_MIN" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY_MAX" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_LIST">
              <xs:complexType>
                <xs:sequence maxOccurs="unbounded">
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_GROUP_REF_OP">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_GROUP_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF_OP">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne|gt|lt|ge|le" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MEASURE_VALUE_OP">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne|gt|lt|ge|le" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MEASURE_INTERVAL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
                <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_FACTOR">
        <xs:annotation>
          <xs:documentation>311--5--Preisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:int">
            <xs:maxInclusive value="99999999" />
            <xs:minInclusive value="-9999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_FEATURE_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>311--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTIONS_SET_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element : OPTIONS_SET_REF Element
Description

This element is used to reference a feature and defines a percentage surcharge for its feature classes. The percentage surcharges may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

Namespace (none)
Diagram
MEASURE_INTERVAL Element MEASURE_VALUE_OP Element OPTION_REF_OP Element OPTION_GROUP_REF_OP Element OPTION_LIST Element OPTION_INTERVAL Element Choice OPTIONS_SET_REF Element
Overview
OPTIONS_SET_REF 0..∞

This element is used to reference a feature and defines a percentage surcharge for its feature classes. The percentage surcharges may be defined via values, lists, intervals or feature groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

This element is used to evaluate whether an option falls within or outside of an interval.

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
    <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:choice>
      <xs:element name="OPTION_INTERVAL">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY_MIN" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY_MAX" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_LIST">
        <xs:complexType>
          <xs:sequence maxOccurs="unbounded">
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_GROUP_REF_OP">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_GROUP_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF_OP">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne|gt|lt|ge|le" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MEASURE_VALUE_OP">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne|gt|lt|ge|le" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MEASURE_INTERVAL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
          <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_INTERVAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element : OPTION_INTERVAL Element
Description

This element is used to evaluate whether an option falls within or outside of an interval.

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

Namespace (none)
Diagram
OPTION_INTERVAL Element
Overview
OPTION_INTERVAL

This element is used to evaluate whether an option falls within or outside of an interval.

Element OPTION_INTERVAL observes: OPTION_KEY_MIN <= assessed value <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
OPERATOR Restriction of operator Simple Type required

This attribute is used to evaluate whether an option is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
OPTION_KEY_MIN Restriction of xs:string required

This attribute is used to specify the starting value of the interval.

 D string
P
M [1:30]
OPTION_KEY_MAX Restriction of xs:string required
This attribute is used to specify the end value of the interval. D string
P
M [1:30]
Source
<xs:element name="OPTION_INTERVAL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY_MIN" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY_MAX" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_LIST Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element : OPTION_LIST Element
Description
This element is used to evaluate whether an option corresponds to a value in a list.
Namespace (none)
Diagram
OPTION_REF Element Sequence OPTION_LIST Element
Overview
OPTION_LIST
This element is used to evaluate whether an option corresponds to a value in a list.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
OPERATOR Restriction of operator Simple Type required

This attribute is used to evaluate whether an option falls within or without a list of values.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Source
<xs:element name="OPTION_LIST" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence maxOccurs="unbounded">
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element > OPTION_LIST Element : OPTION_REF Element
Description
This element is used to reference the options in a comparison list.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF
This element is used to reference the options in a comparison list.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
OPTION_KEY Restriction of xs:string required
This attribute is used to reference an option. D string
P
M [1:30]
Source
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_LIST Element | OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_GROUP_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element : OPTION_GROUP_REF_OP Element
Description
This element is used to evaluate whether an option falls within a feature group.
Namespace (none)
Diagram
OPTION_GROUP_REF_OP Element
Overview
OPTION_GROUP_REF_OP
This element is used to evaluate whether an option falls within a feature group.
OPTION_GROUP_KEY required Restriction of xs:string
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Attributes
Name Type Use Default Fixed Description
OPTION_GROUP_KEY Restriction of xs:string required
This attribute is used to reference a feature group. D string
P
M [1:30]
OPERATOR Restriction of operator Simple Type required

This attribute is used to evaluate whether an option falls within a feature group.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
Source
<xs:element name="OPTION_GROUP_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_GROUP_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element : OPTION_REF_OP Element
Description

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

Namespace (none)
Diagram
OPTION_REF_OP Element
Overview
OPTION_REF_OP

This element is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
Attributes
Name Type Use Default Fixed Description
OPTION_KEY Restriction of xs:string required
This attribute is used to reference an option. D string
P
M [1:30]
OPERATOR Restriction of operator Simple Type required
This attribute is used to define a comparison with an option.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
Source
<xs:element name="OPTION_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne|gt|lt|ge|le" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_VALUE_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element : MEASURE_VALUE_OP Element
Description
This element is used to check the dimension of an option using another dimension.
Namespace (none)
Diagram
MEASURE_VALUE_OP Element
Overview
MEASURE_VALUE_OP
This element is used to check the dimension of an option using another dimension.
MEASURE_VALUE required xs:nonNegativeInteger

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
Attributes
Name Type Use Default Fixed Description
MEASURE_VALUE xs:nonNegativeInteger required

This attribute is used to specify the comparison dimension.

 D nonNegativeInteger
P
M
OPERATOR Restriction of operator Simple Type required
This attribute is used to define a comparison with a dimension.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D operator
P eq|ne|gt|lt|ge|le
M
Source
<xs:element name="MEASURE_VALUE_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne|gt|lt|ge|le" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_INTERVAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element : MEASURE_INTERVAL Element
Description
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
Namespace (none)
Diagram
MEASURE_INTERVAL Element
Overview
MEASURE_INTERVAL
This element is used to evaluate whether an option's dimension falls within or outside of an interval.
OPERATOR required Restriction of operator Simple Type

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
Attributes
Name Type Use Default Fixed Description
OPERATOR Restriction of operator Simple Type required

This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.

in (is contained in a quantity)

nin (is not contained in a quantity)

 D operator
P in|nin
M
MEASURE_MIN xs:nonNegativeInteger required

This attribute is used to specify the starting value of the interval.

 D nonNegativeInteger
P
M
MEASURE_MAX xs:nonNegativeInteger required
This attribute is used to specify the end value of the interval. D nonNegativeInteger
P
M
Source
<xs:element name="MEASURE_INTERVAL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
    <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FACTOR Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element : PRICE_FACTOR Element
Description

This element specifies a percentage surcharge. It is specified as a factor with five decimal places.

A value of 1050000 corresponds to a surcharge of 10.5%.

A value of -1000000 corresponds to a surcharge of -10%.

 D int
P
M [-9999999:99999999]
Namespace (none)
Type
Restriction of xs:int
Diagram
PRICE_FACTOR Element
Overview
PRICE_FACTOR Restriction of xs:int

This element specifies a percentage surcharge. It is specified as a factor with five decimal places.

A value of 1050000 corresponds to a surcharge of 10.5%.

A value of -1000000 corresponds to a surcharge of -10%.

 D int
P
M [-9999999:99999999]
Source
<xs:element name="PRICE_FACTOR" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--5--Preisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:int">
      <xs:maxInclusive value="99999999" />
      <xs:minInclusive value="-9999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element : PRICE_FEATURE_GROUP_REF Element
Description
This element is used to reference a price group irrespective of the feature and/or calculation method (PRICE_FEATURE_GROUP).
Namespace (none)
Diagram
PRICE_FEATURE_GROUP_REF Element
Overview
PRICE_FEATURE_GROUP_REF 0..∞
This element is used to reference a price group irrespective of the feature and/or calculation method (PRICE_FEATURE_GROUP).
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
Attributes
Name Type Use Default Fixed Description
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
This attribute is used to reference a PRICE_FEATURE_GROUP. D postiveInteger
P
M [1:99999]
Source
<xs:element name="PRICE_FEATURE_GROUP_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element : VALID_FROM Element
Description
This element is used to specify the date from which date onwards a percentage surcharge is valid. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
This element is used to specify the date from which date onwards a percentage surcharge is valid. D date
P
M
Source
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element : VALID_UNTIL Element
Description
This element is used to specify the date until a percentage surcharge is valid. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
This element is used to specify the date until a percentage surcharge is valid. D date
P
M
Source
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element : PRICE_TYPES Element
Description
This element is used to define the price types for piece or dimension-variable calculation of variation-neutral or variation-dependent items.
The child elements WIDTH_X, DEPTH_Y, HEIGHT_Z specify whether the price calculated for an item with this price type depends on the width, height, depth, surface area or volume.
If no dimension is specified as "1", the price does not depend on dimensions and is calculated on a per piece basis (e.g. for a sitting element). The values in BASIC_UNIT and ROUNDING_UNIT are then set to 0.
If "1" is set for a dimension, the price calculation will be based on this dimension (e.g. fabrics).
If exactly two dimensions are set to "1", the price is based on the surface area (e.g. carpets).
If exactly three dimensions are set to "1", the price is based on the volume (e.g. lounge sections).
Namespace (none)
Diagram
PRICE_TYPE Element Sequence PRICE_TYPES Element
Overview
PRICE_TYPES
This element is used to define the price types for piece or dimension-variable calculation of variation-neutral or variation-dependent items.
The child elements WIDTH_X, DEPTH_Y, HEIGHT_Z specify whether the price calculated for an item with this price type depends on the width, height, depth, surface area or volume.
If no dimension is specified as "1", the price does not depend on dimensions and is calculated on a per piece basis (e.g. for a sitting element). The values in BASIC_UNIT and ROUNDING_UNIT are then set to 0.
If "1" is set for a dimension, the price calculation will be based on this dimension (e.g. fabrics).
If exactly two dimensions are set to "1", the price is based on the surface area (e.g. carpets).
If exactly three dimensions are set to "1", the price is based on the volume (e.g. lounge sections).
Sequence 1..∞
PRICE_TYPE
This version is used to define a price type.
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute unequivocally identifies a defined price type. D positiveInteger
P
M [1:250]
Sequence
WIDTH_X Restriction of xs:boolean
If the price that is to be calculated depends on the dimension width, this element is set to 1, otherwise it is set to 0. D boolean
P
M
DEPTH_Y Restriction of xs:boolean
If the price that is to be calculated depends on the dimension depth, this element is set to 1, otherwise it is set to 0. D boolean
P
M
HEIGHT_Z Restriction of xs:boolean
If the price that is to be calculated depends on the dimension height , this element is set to 1, otherwise it is set to 0. D boolean
P
M
BASIC_UNIT Restriction of xs:nonNegativeInteger
The base unit (BASIC_UNIT) specifies on which dimension the prices in the ITEM_PRICE (P1) and ADDITIONAL_PRICE (P2) elements relate.
The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one meter, the value in this element must be entered as "1000". In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³]. If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0".

P1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
P2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
The rounding unit (ROUNDING_UNIT) is used to specify the upward rounding for the length, the surface area and/or the volume. The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one centimetre, the value in this element must be entered as "10". If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0". D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_TYPE Restriction of xs:positiveInteger

To specify the different types of the rounding, the ROUNDING_UNIT element is supplemented with the element ROUNDING_TYPE, with possible values being 1, 2 and 3, that identifies commercial rounding (up and down).

The values have the following meaning:

1 rounding up

2 rounding down

3 commercial rounding

 D positiveInteger
P
M [1:3]
BASIC_PRICE_DEPENDENT Restriction of xs:boolean

If the element is set to 1, the price will be calculated
on the basis of the base price and a base price unit. If the value is 0,
the price calculation is independent from a base price.

The element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC Izzy is to specify the
items base price applicable for the calculation and in .../ITEM/
PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT the
.../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT element. The base price unit is used
as a base value and/or starting point for the dimension-variable calculation.

The element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE
is used to specify the price that serves as a basis for the calculation of the filler price
that corresponds to the basic unit defined in the BASIC_UNIT element.
The base price is always a piece price. An item that is assigned a base price calculation
cannot be assigned a minimum price. The final price
of the item consists of the base price + the
calculated filler price in consideration of the logic defined in the element.
Base prices can only be assigned to items for which at least
one-dimensional is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions.
To calculate the price for the infill dimensions, the logic from the PRICE_TYPE element in conjunction with the
price from element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE is used.
If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

 D boolean
P
M
PRICE_TYPE_FORMULA optional Restriction of xs:string
Price calculation formulas can be specified when defining price types (PRICE_TYPE). Formulas must not be specified for standard price types, such as a calculation that relies squares or cubic metres.
The following rules apply for the definition of price type formulas:
- the parameters b, h and t can be used in formulas. Parameters b, h, t correspond to the parameters b, h and t of the carcase basic shape. Depending on the b, h, t parameters used, the corresponding element WIDTH_Y (P1) (b), DEPTH_Y (P1) (t) or HEIGHT_Z (P1) (h) must be set to "true".
- the basic calculation methods addition (+), subtraction (-), multiplication (*) and division (/) can be used;
- arithmetic brackets can be used;
- +/minus signs must not be used;
- only the final result is rounded;
- elements BASIC_UNIT (P1), ROUNDING_UNIT (P1) and BASIC_PRICE_DEPENDENT (P1) also apply in conjunction with the price type formula;

[SSS_elementpaths_SSS]element paths[EEE_elementpaths_EEE]
P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
PRICE_TYPE_NAME optional languagetext60 Complex Type
This element is used to specify a designation for the defined price type.
The designation simplifies data collection and communication. The designation is not analysed by the planning software.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PRICE_TYPE_RULES optional
This element is used to define rules for determining the price type.
Sequence
PRICE_TYPE_RULE 1..100
This element is used to define rules for determining the price type.
RULE_NO required Restriction of xs:nonNegativeInteger
This element is used to specify the rule number. D nonNegativeInteger
P
M [0:9999]
Sequence
RULE xs:string
This element is used to define the rule. D string
P
M
Remarks

Source
<xs:element name="PRICE_TYPES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence maxOccurs="unbounded">
      <xs:element name="PRICE_TYPE">
        <xs:annotation>
          <xs:documentation>150--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="WIDTH_X">
              <xs:annotation>
                <xs:documentation>150--3--Breite_X</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="DEPTH_Y">
              <xs:annotation>
                <xs:documentation>150--4--Tiefe_Y</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEIGHT_Z">
              <xs:annotation>
                <xs:documentation>150--5--Hoehe_Z</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_UNIT">
              <xs:annotation>
                <xs:documentation>150--6--Basis_Einheit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ROUNDING_UNIT">
              <xs:annotation>
                <xs:documentation>150--7--Rundungseinheit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ROUNDING_TYPE">
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_PRICE_DEPENDENT">
              <xs:annotation>
                <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
              <xs:annotation>
                <xs:documentation>150--9--Preisart_Formel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="100" />
                  <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_TYPE_NAME" type="languagetext60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="PRICE_TYPE_RULES" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>360--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_TYPE_RULE" maxOccurs="100">
                    <xs:annotation>
                      <xs:documentation>Polster
Regeln zur ermittelung der Preisart
z.B. if Preisgruppe A &gt; Preisgruppe B dann nimm Preisgruppe A </xs:documentation>
                      <xs:documentation xml:lang="DE">Version 2.1 Build 7</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RULE" type="xs:string">
                          <xs:annotation>
                            <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
                            <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="RULE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>360--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element : PRICE_TYPE Element
Description
This version is used to define a price type.
Namespace (none)
Diagram
PRICE_TYPE_RULES Element LANGUAGE Element Sequence PRICE_TYPE_NAME Element PRICE_TYPE_FORMULA Element BASIC_PRICE_DEPENDENT Element ROUNDING_TYPE Element ROUNDING_UNIT Element BASIC_UNIT Element HEIGHT_Z Element DEPTH_Y Element WIDTH_X Element Sequence PRICE_TYPE Element
Overview
PRICE_TYPE
This version is used to define a price type.
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute unequivocally identifies a defined price type. D positiveInteger
P
M [1:250]
Sequence
WIDTH_X Restriction of xs:boolean
If the price that is to be calculated depends on the dimension width, this element is set to 1, otherwise it is set to 0. D boolean
P
M
DEPTH_Y Restriction of xs:boolean
If the price that is to be calculated depends on the dimension depth, this element is set to 1, otherwise it is set to 0. D boolean
P
M
HEIGHT_Z Restriction of xs:boolean
If the price that is to be calculated depends on the dimension height , this element is set to 1, otherwise it is set to 0. D boolean
P
M
BASIC_UNIT Restriction of xs:nonNegativeInteger
The base unit (BASIC_UNIT) specifies on which dimension the prices in the ITEM_PRICE (P1) and ADDITIONAL_PRICE (P2) elements relate.
The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one meter, the value in this element must be entered as "1000". In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³]. If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0".

P1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
P2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
The rounding unit (ROUNDING_UNIT) is used to specify the upward rounding for the length, the surface area and/or the volume. The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one centimetre, the value in this element must be entered as "10". If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0". D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_TYPE Restriction of xs:positiveInteger

To specify the different types of the rounding, the ROUNDING_UNIT element is supplemented with the element ROUNDING_TYPE, with possible values being 1, 2 and 3, that identifies commercial rounding (up and down).

The values have the following meaning:

1 rounding up

2 rounding down

3 commercial rounding

 D positiveInteger
P
M [1:3]
BASIC_PRICE_DEPENDENT Restriction of xs:boolean

If the element is set to 1, the price will be calculated
on the basis of the base price and a base price unit. If the value is 0,
the price calculation is independent from a base price.

The element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC Izzy is to specify the
items base price applicable for the calculation and in .../ITEM/
PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT the
.../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT element. The base price unit is used
as a base value and/or starting point for the dimension-variable calculation.

The element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE
is used to specify the price that serves as a basis for the calculation of the filler price
that corresponds to the basic unit defined in the BASIC_UNIT element.
The base price is always a piece price. An item that is assigned a base price calculation
cannot be assigned a minimum price. The final price
of the item consists of the base price + the
calculated filler price in consideration of the logic defined in the element.
Base prices can only be assigned to items for which at least
one-dimensional is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions.
To calculate the price for the infill dimensions, the logic from the PRICE_TYPE element in conjunction with the
price from element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE is used.
If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

 D boolean
P
M
PRICE_TYPE_FORMULA optional Restriction of xs:string
Price calculation formulas can be specified when defining price types (PRICE_TYPE). Formulas must not be specified for standard price types, such as a calculation that relies squares or cubic metres.
The following rules apply for the definition of price type formulas:
- the parameters b, h and t can be used in formulas. Parameters b, h, t correspond to the parameters b, h and t of the carcase basic shape. Depending on the b, h, t parameters used, the corresponding element WIDTH_Y (P1) (b), DEPTH_Y (P1) (t) or HEIGHT_Z (P1) (h) must be set to "true".
- the basic calculation methods addition (+), subtraction (-), multiplication (*) and division (/) can be used;
- arithmetic brackets can be used;
- +/minus signs must not be used;
- only the final result is rounded;
- elements BASIC_UNIT (P1), ROUNDING_UNIT (P1) and BASIC_PRICE_DEPENDENT (P1) also apply in conjunction with the price type formula;

[SSS_elementpaths_SSS]element paths[EEE_elementpaths_EEE]
P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
PRICE_TYPE_NAME optional languagetext60 Complex Type
This element is used to specify a designation for the defined price type.
The designation simplifies data collection and communication. The designation is not analysed by the planning software.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
PRICE_TYPE_RULES optional
This element is used to define rules for determining the price type.
Sequence
PRICE_TYPE_RULE 1..100
This element is used to define rules for determining the price type.
RULE_NO required Restriction of xs:nonNegativeInteger
This element is used to specify the rule number. D nonNegativeInteger
P
M [0:9999]
Sequence
RULE xs:string
This element is used to define the rule. D string
P
M
Attributes
Name Type Use Default Fixed Description
PRICE_TYPE_NO Restriction of xs:positiveInteger required
This attribute unequivocally identifies a defined price type. D positiveInteger
P
M [1:250]
Remarks

Source
<xs:element name="PRICE_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="WIDTH_X">
        <xs:annotation>
          <xs:documentation>150--3--Breite_X</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="DEPTH_Y">
        <xs:annotation>
          <xs:documentation>150--4--Tiefe_Y</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT_Z">
        <xs:annotation>
          <xs:documentation>150--5--Hoehe_Z</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_UNIT">
        <xs:annotation>
          <xs:documentation>150--6--Basis_Einheit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ROUNDING_UNIT">
        <xs:annotation>
          <xs:documentation>150--7--Rundungseinheit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ROUNDING_TYPE">
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_PRICE_DEPENDENT">
        <xs:annotation>
          <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
        <xs:annotation>
          <xs:documentation>150--9--Preisart_Formel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="100" />
            <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_TYPE_NAME" type="languagetext60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="PRICE_TYPE_RULES" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>360--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_TYPE_RULE" maxOccurs="100">
              <xs:annotation>
                <xs:documentation>Polster
Regeln zur ermittelung der Preisart
z.B. if Preisgruppe A &gt; Preisgruppe B dann nimm Preisgruppe A </xs:documentation>
                <xs:documentation xml:lang="DE">Version 2.1 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RULE" type="xs:string">
                    <xs:annotation>
                      <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
                      <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="RULE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>360--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

WIDTH_X Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : WIDTH_X Element
Description
If the price that is to be calculated depends on the dimension width, this element is set to 1, otherwise it is set to 0. D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
WIDTH_X Element
Overview
WIDTH_X Restriction of xs:boolean
If the price that is to be calculated depends on the dimension width, this element is set to 1, otherwise it is set to 0. D boolean
P
M
Remarks

Source
<xs:element name="WIDTH_X" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--3--Breite_X</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DEPTH_Y Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : DEPTH_Y Element
Description
If the price that is to be calculated depends on the dimension depth, this element is set to 1, otherwise it is set to 0. D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
DEPTH_Y Element
Overview
DEPTH_Y Restriction of xs:boolean
If the price that is to be calculated depends on the dimension depth, this element is set to 1, otherwise it is set to 0. D boolean
P
M
Remarks

Source
<xs:element name="DEPTH_Y" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--4--Tiefe_Y</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

HEIGHT_Z Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : HEIGHT_Z Element
Description
If the price that is to be calculated depends on the dimension height , this element is set to 1, otherwise it is set to 0. D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
HEIGHT_Z Element
Overview
HEIGHT_Z Restriction of xs:boolean
If the price that is to be calculated depends on the dimension height , this element is set to 1, otherwise it is set to 0. D boolean
P
M
Remarks

Source
<xs:element name="HEIGHT_Z" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--5--Hoehe_Z</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_UNIT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : BASIC_UNIT Element
Description
The base unit (BASIC_UNIT) specifies on which dimension the prices in the ITEM_PRICE (P1) and ADDITIONAL_PRICE (P2) elements relate.
The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one meter, the value in this element must be entered as "1000". In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³]. If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0".

P1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
P2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BASIC_UNIT Element
Overview
BASIC_UNIT Restriction of xs:nonNegativeInteger
The base unit (BASIC_UNIT) specifies on which dimension the prices in the ITEM_PRICE (P1) and ADDITIONAL_PRICE (P2) elements relate.
The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one meter, the value in this element must be entered as "1000". In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³]. If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0".

P1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
P2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
Remarks

Source
<xs:element name="BASIC_UNIT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--6--Basis_Einheit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ROUNDING_UNIT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : ROUNDING_UNIT Element
Description
The rounding unit (ROUNDING_UNIT) is used to specify the upward rounding for the length, the surface area and/or the volume. The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one centimetre, the value in this element must be entered as "10". If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0". D nonNegativeInteger
P
M [0:999999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
ROUNDING_UNIT Element
Overview
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
The rounding unit (ROUNDING_UNIT) is used to specify the upward rounding for the length, the surface area and/or the volume. The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one centimetre, the value in this element must be entered as "10". If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0". D nonNegativeInteger
P
M [0:999999999999]
Remarks

Source
<xs:element name="ROUNDING_UNIT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--7--Rundungseinheit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ROUNDING_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : ROUNDING_TYPE Element
Description

To specify the different types of the rounding, the ROUNDING_UNIT element is supplemented with the element ROUNDING_TYPE, with possible values being 1, 2 and 3, that identifies commercial rounding (up and down).

The values have the following meaning:

1 rounding up

2 rounding down

3 commercial rounding

 D positiveInteger
P
M [1:3]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
ROUNDING_TYPE Element
Overview
ROUNDING_TYPE Restriction of xs:positiveInteger

To specify the different types of the rounding, the ROUNDING_UNIT element is supplemented with the element ROUNDING_TYPE, with possible values being 1, 2 and 3, that identifies commercial rounding (up and down).

The values have the following meaning:

1 rounding up

2 rounding down

3 commercial rounding

 D positiveInteger
P
M [1:3]
Source
<xs:element name="ROUNDING_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_PRICE_DEPENDENT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : BASIC_PRICE_DEPENDENT Element
Description

If the element is set to 1, the price will be calculated
on the basis of the base price and a base price unit. If the value is 0,
the price calculation is independent from a base price.

The element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC Izzy is to specify the
items base price applicable for the calculation and in .../ITEM/
PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT the
.../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT element. The base price unit is used
as a base value and/or starting point for the dimension-variable calculation.

The element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE
is used to specify the price that serves as a basis for the calculation of the filler price
that corresponds to the basic unit defined in the BASIC_UNIT element.
The base price is always a piece price. An item that is assigned a base price calculation
cannot be assigned a minimum price. The final price
of the item consists of the base price + the
calculated filler price in consideration of the logic defined in the element.
Base prices can only be assigned to items for which at least
one-dimensional is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions.
To calculate the price for the infill dimensions, the logic from the PRICE_TYPE element in conjunction with the
price from element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE is used.
If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

 D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
BASIC_PRICE_DEPENDENT Element
Overview
BASIC_PRICE_DEPENDENT Restriction of xs:boolean

If the element is set to 1, the price will be calculated
on the basis of the base price and a base price unit. If the value is 0,
the price calculation is independent from a base price.

The element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC Izzy is to specify the
items base price applicable for the calculation and in .../ITEM/
PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT the
.../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT element. The base price unit is used
as a base value and/or starting point for the dimension-variable calculation.

The element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE
is used to specify the price that serves as a basis for the calculation of the filler price
that corresponds to the basic unit defined in the BASIC_UNIT element.
The base price is always a piece price. An item that is assigned a base price calculation
cannot be assigned a minimum price. The final price
of the item consists of the base price + the
calculated filler price in consideration of the logic defined in the element.
Base prices can only be assigned to items for which at least
one-dimensional is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions.
To calculate the price for the infill dimensions, the logic from the PRICE_TYPE element in conjunction with the
price from element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE is used.
If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

 D boolean
P
M
Remarks

Source
<xs:element name="BASIC_PRICE_DEPENDENT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE_FORMULA Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : PRICE_TYPE_FORMULA Element
Description
Price calculation formulas can be specified when defining price types (PRICE_TYPE). Formulas must not be specified for standard price types, such as a calculation that relies squares or cubic metres.
The following rules apply for the definition of price type formulas:
- the parameters b, h and t can be used in formulas. Parameters b, h, t correspond to the parameters b, h and t of the carcase basic shape. Depending on the b, h, t parameters used, the corresponding element WIDTH_Y (P1) (b), DEPTH_Y (P1) (t) or HEIGHT_Z (P1) (h) must be set to "true".
- the basic calculation methods addition (+), subtraction (-), multiplication (*) and division (/) can be used;
- arithmetic brackets can be used;
- +/minus signs must not be used;
- only the final result is rounded;
- elements BASIC_UNIT (P1), ROUNDING_UNIT (P1) and BASIC_PRICE_DEPENDENT (P1) also apply in conjunction with the price type formula;

[SSS_elementpaths_SSS]element paths[EEE_elementpaths_EEE]
P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
Namespace (none)
Type
Restriction of xs:string
Diagram
PRICE_TYPE_FORMULA Element
Overview
PRICE_TYPE_FORMULA optional Restriction of xs:string
Price calculation formulas can be specified when defining price types (PRICE_TYPE). Formulas must not be specified for standard price types, such as a calculation that relies squares or cubic metres.
The following rules apply for the definition of price type formulas:
- the parameters b, h and t can be used in formulas. Parameters b, h, t correspond to the parameters b, h and t of the carcase basic shape. Depending on the b, h, t parameters used, the corresponding element WIDTH_Y (P1) (b), DEPTH_Y (P1) (t) or HEIGHT_Z (P1) (h) must be set to "true".
- the basic calculation methods addition (+), subtraction (-), multiplication (*) and division (/) can be used;
- arithmetic brackets can be used;
- +/minus signs must not be used;
- only the final result is rounded;
- elements BASIC_UNIT (P1), ROUNDING_UNIT (P1) and BASIC_PRICE_DEPENDENT (P1) also apply in conjunction with the price type formula;

[SSS_elementpaths_SSS]element paths[EEE_elementpaths_EEE]
P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
Remarks

Source
<xs:element name="PRICE_TYPE_FORMULA" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--9--Preisart_Formel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="100" />
      <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : PRICE_TYPE_NAME Element
Description
This element is used to specify a designation for the defined price type.
The designation simplifies data collection and communication. The designation is not analysed by the planning software.
Namespace (none)
Type
languagetext60 Complex Type
Diagram
LANGUAGE Element Sequence PRICE_TYPE_NAME Element
Overview
PRICE_TYPE_NAME optional languagetext60 Complex Type
This element is used to specify a designation for the defined price type.
The designation simplifies data collection and communication. The designation is not analysed by the planning software.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="PRICE_TYPE_NAME" type="languagetext60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE_RULES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : PRICE_TYPE_RULES Element
Description
This element is used to define rules for determining the price type.
Namespace (none)
Diagram
PRICE_TYPE_RULE Element Sequence PRICE_TYPE_RULES Element
Overview
PRICE_TYPE_RULES optional
This element is used to define rules for determining the price type.
Sequence
PRICE_TYPE_RULE 1..100
This element is used to define rules for determining the price type.
RULE_NO required Restriction of xs:nonNegativeInteger
This element is used to specify the rule number. D nonNegativeInteger
P
M [0:9999]
Sequence
RULE xs:string
This element is used to define the rule. D string
P
M
Remarks

Source
<xs:element name="PRICE_TYPE_RULES" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>360--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_TYPE_RULE" maxOccurs="100">
        <xs:annotation>
          <xs:documentation>Polster
Regeln zur ermittelung der Preisart
z.B. if Preisgruppe A &gt; Preisgruppe B dann nimm Preisgruppe A </xs:documentation>
          <xs:documentation xml:lang="DE">Version 2.1 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RULE" type="xs:string">
              <xs:annotation>
                <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
                <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="RULE_NO" use="required">
            <xs:annotation>
              <xs:documentation>360--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE_RULE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element > PRICE_TYPE_RULES Element : PRICE_TYPE_RULE Element
Description
This element is used to define rules for determining the price type.
Namespace (none)
Diagram
RULE Element Sequence PRICE_TYPE_RULE Element
Overview
PRICE_TYPE_RULE 1..100
This element is used to define rules for determining the price type.
RULE_NO required Restriction of xs:nonNegativeInteger
This element is used to specify the rule number. D nonNegativeInteger
P
M [0:9999]
Sequence
RULE xs:string
This element is used to define the rule. D string
P
M
Attributes
Name Type Use Default Fixed Description
RULE_NO Restriction of xs:nonNegativeInteger required
This element is used to specify the rule number. D nonNegativeInteger
P
M [0:9999]
Remarks

Source
<xs:element name="PRICE_TYPE_RULE" maxOccurs="100" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Polster
Regeln zur ermittelung der Preisart
z.B. if Preisgruppe A &gt; Preisgruppe B dann nimm Preisgruppe A </xs:documentation>
    <xs:documentation xml:lang="DE">Version 2.1 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RULE" type="xs:string">
        <xs:annotation>
          <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
          <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="RULE_NO" use="required">
      <xs:annotation>
        <xs:documentation>360--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PRICE_TYPE_RULES Element | PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

RULE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element > PRICE_TYPE_RULES Element > PRICE_TYPE_RULE Element : RULE Element
Description
This element is used to define the rule. D string
P
M
Namespace (none)
Type
xs:string
Diagram
RULE Element
Overview
RULE xs:string
This element is used to define the rule. D string
P
M
Remarks

Source
<xs:element name="RULE" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
    <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PRICE_TYPE_RULE Element | PRICE_TYPE_RULES Element | PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Complex data types


%%LocalItemTitle%%

Description
This simple data type defines an operator for comparisons.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

Elements
Element | Description
T_NEW_CATALOG | This element is used to specify all information and data for the provisioning of a complete catalogue/data pool.
Complex Types
Complex Type | Description
languagetext | This data type is used to create multiple-language texts of any length.
languagetext30 | This data type is used to create multiple-language texts with a maximum length of 30 characters.
languagetext40 | This data type is used to create multiple-language texts with a maximum length of 40 characters.
languagetext60 | This data type is used to create multiple-language texts with a maximum length of 60 characters.
Simple Types
Simple Type Description
operator
This simple data type defines an operator for comparisons.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D string
P eq|ne|in|nin|gt|lt|ge|le
M [1:4]


%%LocalItemTitle%%

languagetext Complex Type
IDMW 2.0 XML-Schema Dokumentation : languagetext Complex Type
Description

This data type is used to create multiple-language texts of any length.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetext Complex Type
Overview
languagetext

This data type is used to create multiple-language texts of any length.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Used By
CATALOG_INFO Element
EXTERNAL_NAME Element
TOOL_TIP Element
MESSAGE_TEXT Element
PROPERTY_TEXT Element
FULL_TEXT Element
PLANNING_ADVICE Element
PACKAGE_LIST_COMMENT_TEXT Element
OPTION_COMMENT_TEXT Element
Source
<xs:complexType name="languagetext" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT" type="xs:string" />
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

languagetext30 Complex Type
IDMW 2.0 XML-Schema Dokumentation : languagetext30 Complex Type
Description
This data type is used to create multiple-language texts with a maximum length of 30 characters.
Namespace (none)
Diagram
LANGUAGE Element Sequence languagetext30 Complex Type
Overview
languagetext30
This data type is used to create multiple-language texts with a maximum length of 30 characters.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Used By
CATALOG_NAME Element
PROPERTY_UNIT Element
Source
<xs:complexType name="languagetext30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 30stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,30}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

languagetext40 Complex Type
IDMW 2.0 XML-Schema Dokumentation : languagetext40 Complex Type
Description

This data type is used to create multiple-language texts with a maximum length of 40 characters.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetext40 Complex Type
Overview
languagetext40

This data type is used to create multiple-language texts with a maximum length of 40 characters.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
Used By
INTERNAL_NAME Element
Source
<xs:complexType name="languagetext40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 40stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,40}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > languagetext40 Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,40}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetext40 Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > languagetext40 Complex Type > LANGUAGE Element : TEXT Element
Description
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,40}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetext40 Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

languagetext60 Complex Type
IDMW 2.0 XML-Schema Dokumentation : languagetext60 Complex Type
Description
This data type is used to create multiple-language texts with a maximum length of 60 characters.
Namespace (none)
Diagram
LANGUAGE Element Sequence languagetext60 Complex Type
Overview
languagetext60
This data type is used to create multiple-language texts with a maximum length of 60 characters.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Used By
PRODUCT_GROUP_TEXT Element
GROUP_TITLE Element
PACKAGE_LIST_TEXT Element
SERIE_GROUP_TEXT Element
OPTION_TEXT Element
FEATURE_TEXT Element
DECISION_NAME_TEXT Element
OPTION_GROUP_TEXT Element
PRICE_FEATURE_GROUP_TEXT Element
PRICE_TYPE_NAME Element
Source
<xs:complexType name="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,60}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDMW 2.0 XML-Schema Dokumentation


%%ItemTitle%%

IDMW 2.0 XML schema documentation
Simple data types

A separate data type operator was created for the definition of specific conditions

See Also
operator Simple Type


%%LocalItemTitle%%

operator Simple Type
IDMW 2.0 XML-Schema Dokumentation : operator Simple Type
Description
This simple data type defines an operator for comparisons.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D string
P eq|ne|in|nin|gt|lt|ge|le
M [1:4]
Namespace (none)
Type
Restriction of xs:string
Diagram
operator Simple Type
Overview
operator Restriction of xs:string
This simple data type defines an operator for comparisons.

The comparison operator may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

 D string
P eq|ne|in|nin|gt|lt|ge|le
M [1:4]
Facets
MaxLength | 4
Enumeration | eq
Enumeration | ne
Enumeration | in
Enumeration | nin
Enumeration | gt
Enumeration | lt
Enumeration | ge
Enumeration | le
Source
<xs:simpleType name="operator" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:appinfo source="de">eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)</xs:appinfo>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="4" />
    <xs:enumeration value="eq" />
    <xs:enumeration value="ne" />
    <xs:enumeration value="in" />
    <xs:enumeration value="nin" />
    <xs:enumeration value="gt" />
    <xs:enumeration value="lt" />
    <xs:enumeration value="ge" />
    <xs:enumeration value="le" />
  </xs:restriction>
</xs:simpleType>
See Also
IDMW 2.0 XML-Schema Dokumentation