%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Introduction
View with Navigation Tools

IDM 2.7.0 XML scheme

Documentation

release 01/05/2019

Documented XML scheme:

IDM_2_7_0.xsd

Contact

DCC e. V.
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telefon 0 52 21/12 65-37


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Basic structure of the IDM scheme
View with Navigation Tools
Introduction > Basic structure of the IDM scheme

Basic structure of the IDM scheme

The main element T_NEW_CATALOG defines that a complete, new catalogue database is supplied.

The IDM scheme is split up into different data areas represented by the following child elements (cf. pict.1) of T_NEW_CATALOG.

Picture 1 - Child elements of T_NEW_CATALOG

The different data areas are linked. Data which are initially created in some of the areas are used in other areas via references.

Description of the data areas.

CATALOG

The data area CATALOG contains all administrative information about the database, e.g. the version number of the file format, release date or the unique identification of the database.

SUPPLIER

The data area SUPPLIER contains all adiministrative information about the supplier, e.g. contact data, EDI-communication parameters or the manufacturer's country of origin.

GLOBAL_DEFINITION

The data area GLOBAL_DEFINITION is a pool of information which is used in other data areas, e.g. the definition of standard handle positions or information about series.

SERIES

The data area SERIES contains information which is used for describing the catalogue items. The items are assigned to different product groups, e.g. base cabinets, shelves etc.

FEATURE_DEFINITION

The data area FEATURE_DEFINITION provides information about the product variations, e.g. data variation families (FEATURE_CLASS),variation types (FEATURE), the corresponding options (OPTION_DEFINITION), or restrictions (RESTRICTION).

PRICE_DEFINITION

The data area PRICE_DEFINITION contains all relevant price information, e.g. data for price features (PRICE_FEATURE_GROUP), VAT (VALUE_ADDED_TAXES), merchandise groups (MERCHANDISE_GROUP) or price types PRICE_TYPE).

BLOCK_VALUE_CALCULATION

The data area BLOCK_VALUE_CALCULATON contains all information about the rules for block- and value clearing, e.g. data for block rules (SET_OF_BLOCK_RULES), block conditions (BLOCK_CONDITIONS) or grading tables (GRADING_TABLE).


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Elements of the catalogue structure
View with Navigation Tools
Introduction > Elements of the catalogue structure

Elements of the catalogue structure

Definition of series information

Series are defined in the following element:

T_NEW_CATALOG/SERIES/SERIE

For a complete description of a series all child elements are used. Programmes are assigned to series via restrictions (RESTRICTION_REF).

Definition of programme information

In the IDM format programmes are defined as variations. First the properties of a programme are defined as options of a variation, following the options are assigned to the variation type "programme". The definition of programme information is done in the following way:

Example: Definition of programme information

1. Definition of programme properties

The properties of a programme are defined in the following element:

FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

<STYLE STYLE_NO="A1">

<STYLE_NAME>Paris</STYLE_NAME>

</STYLE>

<STYLE STYLE_NO="A2">

<STYLE_NAME>New York</STYLE_NAME>

</STYLE>

</OPTION_DEFINITION>

The properties for the programmes "Paris" and "New York" are defined. For reasons of clarity the different available elements of STYLE are neglected in this context.

2. Definition of programme variations

The programme variations are described in the following element:

FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_NO="A1"FEATURE_NO="1">

<STYLE_REF STYLE_NO="A1"/>

</OPTION>

<OPTION OPTION_NO="A2"FEATURE_NO="1">

<STYLE_REF STYLE_NO="A2"/>

</OPTION>

</OPTIONS>

</FEATURE>

The example above contains the variations of the programmes "Paris" and "New York". Programme variations are defined with the feature No. 1 in the feature "programme". Each programme variation is uniquely and unambiguously identified by the combination of FEATURE_NO and OPTION_NO

Definition of item information

Item information is defined in the following element:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The element ITEM is described by a great number of different elements providing additional item information. The attribute TYPE_NO.

Depending on series the attributes of an item may vary. In this respect an item is identified unambiguously only by its attributes in connection with the series.

Series specific item information

Depending on series the attributes of an item may vary. As the element ITEM is a child element of SERIES, items are assigned to a series automatically.

Definition of features

Information about the features is provided in the IDM scheme as follows:

n Definition of the options for the feature

n Assignment of option and feature

Definition of options

The different options of a feature are defined as a data pool in the element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION.

Pict. 2 – The element OPTION_DEFINITION

The element OPTION_DEFINITION contains several elements for the definition of the different options:

STYLE | This element defines the attributes of a programme. Programmes are defined as a level in the catalogue structure but depicted via the features which are frequently used in the restrictions.
HANDLE_ORIENTATION | This element defines a standard handle orientation.
MATERIAL | This element defines the attributes of materials via colours and textures. These elements are referenced from the finish features (e.g. plinth finish) or colour features (e.g. plinth colour).
FORM | This element defines the different numbers for the form features (FORM_NO).The current version of the IDM-scheme supports only the feature FORM_NOThe options of this element may only be referenced by the features 750-756.
OPTION_MEASURE | This element contains measurement values for options which , require measurement information (e.g. plinth height (feature 402)).

Example: colour options

<OPTION_DEFINITION>

<COLOR COLOR_NO="1">

<RGB_RED>255</RGB_RED>

<RGB_GREEN>0</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="2">

<RGB_RED>133</RGB_RED>

<RGB_GREEN>273</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="3">

<RGB_RED>0</RGB_RED>

<RGB_GREEN>89</RGB_GREEN>

<RGB_BLUE>89</RGB_BLUE>

</COLOR>

</OPTION_DEFINITION>

The above mentioned elements define three different colours which are identified by numbers (COLOR_NO) 1-3.

Assignment of option and feature

To use the above mentioned colour examples, an assignment of features to these colours is required.

The assignment of features (FEATURE) and options (OPTION) is done in the element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE. A feature is defined an identified by the combination of FEATURE and OPTION The following XML elements define 2 colour features for plinths (feature 401).

Example: Definition of a feature via feature No. and option

<FEATURE FEATURE_NO="401">

<OPTIONS>

<OPTION OPTION_NO="1"FEATURE_NO="401">

<OPTION_TEXT_REF TEXT_NO="4"/>

</OPTION>

<OPTION OPTION_NO="3"FEATURE_NO="401">

<OPTION_TEXT_REF TEXT_NO="6"/>

</OPTION>

</OPTIONS>

<FEATURE_TEXT_REF TEXT_NO="12"/>

<CLASSIFICATION>1</CLASSIFICATION>

<HEADER_POS_VARIATION_TYPE>K</HEADER_POS_VARIATION_TYPE>

</FEATURE>

The child elements of FEATURE describe the attributes of the feature No. and the child elements of OPTION describe the attributes of the feature. This principle is essential for all elements in the IDM-scheme,e.g. the element OPTION_TEXT_REF references the text information about the option, the element FEATURE_TEXT_REF references text information concerning the feature.

To reference a feature the following combination is required: FEATURE_NO and OPTION_NO define the reference key.

Combination of features

If feature No. 1 (programme) is defined in combination with other features, feature No. 1 is always set in the first place.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Build of Catalogue structure
View with Navigation Tools
Introduction > Build of Catalogue structure

Build of Catalogue structure

Assignment of programmes to series

Programmes are assigned to series in the following element:

SERIES/SERIE/RESTRICTION_REF

The programme is assigned to that series in which a restriction is referenced that defines the programme as a legal combination of features and options.

The element for the description of programme features is:

FEATURE_DEFINITION/OPTION_DEFINITION/STYLE

Assignment of items to series and programmes

Item-series assignment

As the element ITEM is a child element of the element SERIES, all items are automatically assigned to a series:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Assignment of item to programmes

In general, items depending on programmes are available in all programmes which are assigned to a series. Item specific restrictions are used for excluding the availability of an item in one or more programmes:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

The following example defines a suitable restriction which excludes the availability of an item in a programme:

Example: restriction for the assignment of item and programme

element: FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="A1">

<FEATURE_REF FEATURE_NO="1"/>

<OPTION_REF OPTION_NO="A1"FEATURE_NO="1"/>

<TEST_ID>0</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

The above mentioned restriction defines an illegal combination of feature No. and option No. for the referenced features. The corresponding feature definition is:

The referenced programme feature:

element: FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_NO="A1"FEATURE_NO="1">

<STYLE_REF STYLE_NO="A1"/>

</OPTION>

</OPTIONS>

</FEATURE>

Used programme feature:

element: FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

<STYLE STYLE_NO="A1">

<STYLE_NAME>Paris</STYLE_NAME>

</STYLE>

</OPTION_DEFINITION>


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Catalogue structure
View with Navigation Tools
Introduction > Catalogue structure

Catalogue and element structure

The general catalogue structure of the database is built up as follows:

Pict.1 – Catalogue structure of databases

This catalogue structure is represented by the following element hierarchy in the IDM scheme:

Pict. 1 – Element hierarchy of the IDM scheme

The element SERIE is used for defining the properties of a series. The element RESTRICTION_REF assigns features to a series by means of restrictions. Within one series different produkt groups (PRODUCT_GROUPS) are defined which combine all items with similar features to one group. As items are child elements of the element SERIE they are automatically assigned to this series.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Referencing
View with Navigation Tools
Introduction > Referencing

Referencing of elements

The IDM scheme defines references between different elements. Information about these references is stored in a central data area. Multiple use of this information from different data areas is achieved via references. The type of reference which is used in the IDM scheme is described as follows:

Terminology

the following terms for references are used in the IDM scheme:

Key-element | a XML element which is referenced by other elements.
Ref-element | a XML element which references other elements.

Reference operation

A key element is identified unambiguously by its attributes. The Ref-element possesses at least the key-attributes of the key-element. A reference between the elements is defined by congruent attributes values of ref- and key-element.

Example: Referencing of a series from an item

The following example shows the way in which way an item (ITEM) references a series (SERIE). Only an abstract of the XML elements is shown here.

Key-element

T_NEW_CATALOG/SERIES/SERIE

<SERIES>

<SERIE SERIE_NO="1"/> … </SERIE>

<SERIE SERIE_NO="2"/> … </SERIE>

<SERIE SERIE_NO="3"/> … </SERIE>

. . .

<SERIE SERIE_NO="99"/> … </SERIE>

</SERIES>

Ref-element

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

ITEMS>

<ITEM SERIE_NO="1" . . . />

. . .

</ITEMS>

Example: Referencing of a feature

In the following example a feature is referenced by a restriction.

Key-element

T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="400"> <!-- plinth feature -->

<OPTIONS>

<OPTION OPTION_KEY="1"FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="2"FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="3"FEATURE_NO="400"> … </OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="401"> <!-- plinth colour -->

<OPTIONS>

<OPTION OPTION_KEY="1"FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="2"FEATURE_NO="401"> … </OPTION>

<OPTIONOPTION_KEY="3" FEATURE_NO="401"> … </OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

The XML elements define for feature type 400 (FEATURE) three options (OPTION) numbered 1-3 and for the feature type 401 three options with numbers 1-3. A feature is identified by the combination of FEATURE_NO and OPTION_KEY.

Ref-element

/T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_REF

<RESTRICTIONRESTRICTION_NO="1">

<OPTION_COMBINATION>

<OPTION_REFOPTION_KEY="1"FEATURE_NO="400"/>

<OPTION_REFOPTION_KEY="3" FEATURE_NO="401"/>

<OPTION_REFOPTION_KEY="3"FEATURE_NO="400"/>

<OPTION_REFOPTION_KEY="3"FEATURE_NO="401"/>

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

The XML elements define a restriction for legal combinations (TEST_ID = 1) for the plinth features ( FEATURE_NO=400 ) and plinth colours (FEATURE_NO=401) The ref-element OPTION_REF with the attributes highlighted in grey, reference the key-element OPTION.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Restrictions
View with Navigation Tools
Introduction > Restrictions

Definition and assignment of restrictions

The validity of restrictions may be series specific or comprehensive, programme specific or item specific. The priority of a restriction corresponds with the hierarchy level series -> programme -> item on which the restriction is defined. A restriction defined on item level overrides a restriction which is defined on programme level. Overriding restrictions may only define additional restrictions but not reverse previous restrictions. Example: the availability of an item in a programme is excluded by a restriction defined on item level. A restriction defined on item level may not reverse this exclusion.

First, the restrictions are defined and in a second step they are assigned to series, programmes and items. Definition

Definition of restrictions

Restrictions are defined in the following element:

FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

The element RESTRICTION references the feature combinations for which the restrictions have been defined. The element OPTION_REF references the feature combinations which are subject to control procedures. The element TEST_ID defines a feature combination as legal or illegal combination.

Example: definition of restrictions

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="523" FEATURE_1_NO="100" FEATURE2_NO="101">

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA"FEATURE_NO="100"/>#lacquered

<OPTION_REF OPTION_NO="RO"FEATURE_NO="101"/># red

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA"FEATURE_NO="100"/># lacquered

<OPTION_REF OPTION_NO="GR"FEATURE_NO="101"/># green

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="FU"FEATURE_NO="100"/># veneered

<OPTION_REF OPTION_NO="BU"FEATURE_NO="101"/># beech

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

The above mentioned example shows a restriction which defines a legal feature combination of „front finish" (No. 100) and "front colour" (No. 101). According to the above mentioned restriction the combinations lacquer-red, lacquer-green and beech veneer are permitted (TEST_ID = 1). The listing of permitted combinations (OPTION_REF) has to be in accordance with the sequence defined by the attributes in the element RESTRICTION (FEATURE_1_NO, FEATURE_2_NO)

For the purpose of unique and unambiguous identification of a restrictrion a RESTRICTION_NO) is assigned.

Assignment of restrictions

Series independent restriction

Series independent restrictions are assigned by the following elements:

SERIES/RESTRICTIONS/RESTRICTION_REF

As the element RESTRICTION_REF is a child element of SERIES/RESTRICTIONS, all restrictions referenced in the element RESTRICTION_REF are assigned to all series which are defined in SERIES/SERIE.

Example: Series independent assignment of restrictions

<SERIES>

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1"RESTRICTION_NO="523"/>

<RESTRICTION_REF SEQUENCE="2"RESTRICTION_NO="678"/>

</RESTRICTIONS>

</SERIES>

In the above mentioned example the restrictions 523 and 678 are referenced and assigned to all series.

Series specific assignment

The rules for a series specific assignment of restrictions correspond to that of series independent assignment. the following element is used for the series-specific assignment:

SERIES/SERIE/RESTRICTIONS/RESTRICTION_REF

The restrictions referenced in the element RESTRICTION_REF are assigned to that series in which the reference was made.

Restrictions which are assigned to programmes are one-level restrictions, containing only the feature No. 1( programme). These restrictions are mandatory if series > 0 and feature No. 1 is defined in the database.

Example: Series-specific assignment of restrictions

<SERIES>

<SERIE SERIE_NO="2">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1"RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2"RESTRICTION_NO="67"/>

</RESTRICTIONS>

</SERIE>

<SERIE SERIE_NO="7">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1"RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2"RESTRICTION_NO="123"/>

</RESTRICTIONS>

</SERIE>

</SERIES>

In the above mentioned example restrictions 45 and 67 are assigned to series "2" and restrictions 45 and 123 are assigned to series "7".

Item specific assignment

A programme specific assignment of restrictions is defined in the following element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

For item specific assignment the sames rules as for series or programme specific assignment apply.

If no restrictions are assigned to an item, this item is available without any restriction regarding series or programme.

Product group specific assignment

The product group specific assignment of restrictions is defined in the following element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/RESTRICTIONS/RESTRICTION_REF

The rules for a product group specific assignment of restrictions correspond with the rules for series and programme specific assignment.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Data types
View with Navigation Tools
Introduction > Data types

Data types and value ranges

The IDM schema used the data types defined in the standard XML schema 1.0 second edition (28 October 2004).

The following data types are used:

boolean | This data type maps the logical values "true" or "false". In accordance with the W3C recommendation for XML schemas, the values that can be used in the IDM are true/false or 1/0.
date | In the IDM, the data type date is used in conformity with the XML schemas as follows: YYYY-MM-DD YYYY = year, MM = month, DD = day
dateTime | In the IDM, the data type dateTime is used in conformity with the XML schemas as follows: YYYY-MM-DDThh:mm:ssZ YYYY = year, MM = month, DD = day T = Start of time information hh = hour, mm = minute, ss = second Z = UTC time
gYear | In the IDM, the data type dateTime is used in conformity with the XML schemas as follows: YYYY
integer | Numbers can be positive and negative integers.
nonNegativeInteger | Value is a positive integer, including 0
positiveInteger | Value is a positive integer, excluding 0
decimal | The data type is used in the IDM for floating-point values. Floating-point values for this data type are, as recommended by the W3C, stored as 126.56 or 45.98000 or +27.0.
string | A limited number of alphanumeric characters and special characters.
anyURI | The data type is used in the IDM for mapping URLs.anyURI represents a Uniform Resource Identifier (URI). The lexical part of anyURI is an indefinite sequence of characters that correspond to a legal URI. An anyURI value can be absolute or relative and may contain fragment codes (e.g. an URI reference).
language | The data type is used for the specification of valid language codes in the IDM.language represents codes for natural languages Tags for the Identification of Languagesas defined in the Thevaluerangeof language is the quantum of all character sequences that represent a valid code of a natural language. For ISO languages, the format consists of a sequence of 2-3 lower case letters optionally followed by a hyphen and a country code consisting of 2 upper case letters, e.g. en-US.

The value ranges of the above data types are usually restricted for the elements in the IDM. The "restrictions" in the data type definition contains restrictions for minimum and maximum values, permitted characters and value lists.

In the XML documentation of the IDM, the value ranges are specified by the information coming after M and P.

In addition to XML data types mentioned here, separate data types are defined for the texts.

They are explained at the end of the documentation.

See Also
languagetexte Complex Type
languagetexte30 Complex Type
languagetexte40 Complex Type
languagetexte60 Complex Type
languagetexte60999 Complex Type


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Explanations for the documentation
View with Navigation Tools
Introduction > Explanations for the documentation

Explanations for the documentation of the IDM

This paragraph contains explanations for the documentation of the IDM scheme.

Meaning of element properties

Each element is documented with a description and its properties. The following example shows an element description:

EXCHANGE_ID_NO Attribute

Description
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

The properties of the element are listed on the right side. The following abbreviations are used:

D | Documentation of the data type for the element. If no value is set here, the element does not contain user data but further child elements.
P | The values P and M are used to define the range of values. The regular term in P defines the number of legal values.
M | M defines the minium and maximum value in the range of legal values. In a string data type P defines the legal values and M defines the minimum and maximum length of the string. For numerical data types M defines the minimum and maximum value.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Variation types
View with Navigation Tools
Introduction > Variation types

Variation type | Variation text | Option type | Remark
1 | programm/ style | A | programm asvariation type
2 | serial number | A | assignment of a five-digit serial number
100 | Front finish | A |
101 | Front colour 1 | F | Front filling smooth = complete surface
102 | Front colour 2 | F | Frame
103 | Front colour 3 | F | Pilaster strips
104 | Edge colour front | F |
105 | Front combination | K | If only one key is used for different front information
106 | Front group | A | Overrides the FRONT_GROUP_NO in element FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
110 | Front finish contrast colour 1 | A |
111 | Front colour 1 contrast colour 1 | F | Front filling smooth = complete surface
112 | Front colour 2 contrast colour 1 | F | Frame
113 | Front colour 3 contrast colour 1 | F | Pilaster strips
114 | Edge colour front, contrast colour 1 | F |
115 | Front combination, contrast colour 1 | K | The variations 111 - 114 are permitted.
120 | Front finish contrast colour 2 | A |
121 | Front colour 1 contrast colour 2 | F | Front filling smooth = complete surface
122 | Front colour 2 contrast colour 2 | F | Frame
123 | Front colour 3 contrast colour 2 | F | Pilaster strips
124 | Edge colour front, contrast colour 2 | F |
125 | Front combination, contrast colour 2 | K | The variations 121 - 124 are permitted.
150 | Glass finish | A |
151 | Glass colour | F |
152 | Mullion type | A |
153 | Mullion colour | F |
154 | Type glass door frame | A |
155 | Colour glass door frame | F |
160 | Type roller shutter | A |
161 | Colour roller shutter | F |
170 | Type container | A |
171 | Colour container | F |
200 | Type carcase | A |
201 | Carcase combination | K | If only one key is used for several – interior /exterior - carcase colours
202 | Exterior carcase colour | F |
203 | Interior carcase colour | F |
204 | Edge carcase | A |
205 | Edge colour carcase | F |
206 | Type visible side | A |
207 | Colour visible side | F |
208 | Interior carcase colour for glass door cabinets | F | Glass door cabinets and open cabinets, which are not a shelf .
209 | Interior carcase for glass door cabinets | A | Glass door cabinets and open cabinets, which are not a shelf .
300 | Type handle | A |
301 | Handle colour 1 | F | Colour handle, knob or main colour
302 | Handle colour 2 | F | Colour bow, railing, or knob handles
303 | Combination of handles | K | If only one key is defined for several handle conditions
304 | Handle positions | NULL | cf. handle positions p. 5-23
400 | Type plinth | A |
401 | Plinth colour | F |
402 | Plinth height | A |
410 | Type plinth bottom | A |
411 | Colour plinth bottom | F |
500 | Type shelves | A |
501 | Colour shelves | F |
502 | Type cornice | A | Includes shape and material
503 | Colour cornice | F |
504 | Type light pelment | A | Includes shape and material
505 | Colour light pelmet | F |
506 | Type ceiling filler | A |
507 | Colour ceiling filler | F |
508 | Type filler | A | Bottom ledge
509 | Colour bottopm ledge | F | Bottom ledge
510 | Type gallery shelf | A |
511 | Colour gallery shelf | F |
512 | Type gallery shelf edge | A |
513 | Colour gallery shelf edge | F |
514 | Type board | A |
515 | Colour board | F |
516 | Type board edge | A |
517 | Colour board edge | F |
520 | Type side panels/ bars | A |
521 | Colour side panels/ bars | F |
522 | Type bar panel edge | A |
523 | Colour bar panel edge | F |
524 | Type bottom shelf | A |
525 | Colour bottom shelf | F |
526 | Type bottom shelf edge | A |
527 | Colour bottom shelf edge | F |
550 | Type recess | A |
551 | Colour recess | F |
560 | Type recess accessories | A |
561 | Colour recess accessories | F |
562 | Type pilaster | A |
563 | Colour pilaster | F |
564 | Type pilaster edge | A |
565 | Colour pilaster edge | F |
600 | Type worktop | A |
601 | Colour worktop | F |
602 | Type worktop edge | A |
603 | Colour worktop edge | F |
604 | Type countertop | A |
605 | Colour countertop | F |
606 | Type countertop edge | A |
607 | Colour countertop edge | F |
620 | Type cover shelf | A |
621 | Colour cover shelf | F |
622 | Type cover shelf edge | A |
623 | Colour cover shelf | F |
624 | Type attachment table | A |
625 | Colour attachment table | F |
626 | Type attachment table edge | A |
627 | Colour attachment table edge | F |
650 | Type worktop upstand | A | Worktop upstand profile
651 | Colour worktop upstand | F | Worktop upstand profile
700 | Type drawer | A | Interior equipment
701 | Colour drawer | F | Interior equipment
702 | Type pull-out | A | Interior equipment
703 | Colour pull-out | F | Interior equipment
750 | Shape worktop | S |
751 | Shape cornice | S |
752 | Shape light pelmet | S |
753 | Shape plinth | S |
754 | Shape worktop upstand | S |
755 | Shape cover shelf | S |
756 | Shape countertop | S |
800 | Type electrical appliance | A |
801 | Colour electrical appliance | F |
802 | Colour electr. appliances accessories | F |
850 | Type sink | A |
851 | Colour sink | F |
852 | Colour sink accessories | F |
853 | Colour mixer taps | F |
854 | Type mixer taps | A |
900 | Type general accessories | A |
901 | Colour general accessories | F |
930 | additional, graphical relevant information about type 1. | A | The software suppliers have to be informed separately about the meaning.
931 | additional, graphical relevant information about colour 1. | F | The software suppliers have to be informed separately about the meaning.
932 | additional, graphical relevant information about type 2. | A | The software suppliers have to be informed separately about the meaning.
933 | additional, graphical relevant information about colour 2. | F | The software suppliers have to be informed separately about the meaning.
934 | additional, graphical relevant information about type 3. | A | The software suppliers have to be informed separately about the meaning.
935 | additional, graphical relevant information about colour 3. | F | The software suppliers have to be informed separately about the meaning.
936 | additional, graphical relevant information about type 4. | A | The software suppliers have to be informed separately about the meaning.
937 | additional, graphical relevant information about colour 4. | F | The software suppliers have to be informed separately about the meaning.
938 | additional, graphical relevant information about type 5. | A | The software suppliers have to be informed separately about the meaning.
939 | additional, graphical relevant information about colour 5. | F | The software suppliers have to be informed separately about the meaning.
950 | Type miscellaneous 1 | A |
951 | Colour miscellaneous 1 | F |
952 | Type miscellaneous 2 | A |
953 | Colour miscellaneous 2 | F |
954 | Type miscellaneous 3 | A |
955 | Colour miscellaneous 3 | F |
956 | Type miscellaneous 4 | A |
957 | Colour miscellaneous 4 | F |
958 | Type miscellaneous 5 | A |
959 | Colour miscellaneous 5 | F |
960 | Type miscellaneous 6 | A |
961 | Colour miscellaneous 6 | F |
962 | Type miscellaneous 7 | A |
963 | Colour miscellaneous 7 | F |
964 | Type miscellaneous 8 | A |
965 | Colour miscellaneous 8 | F |
966 | Type miscellaneous 9 | A |
967 | Colour miscellaneous 9 | F |
968 | Type miscellaneous 10 | A |
969 | Colour miscellaneous 10 | F |
970 | Type miscellaneous 11 | A |
971 | Colour miscellaneous 11 | F |
972 | Type miscellaneous 12 | A |
973 | Colour miscellaneous 12 | F |
974 | Type miscellaneous 13 | A |
975 | Colour miscellaneous 13 | F |
976 | Type miscellaneous 14 | A |
977 | Colour miscellaneous 14 | F |
978 | Type miscellaneous 15 | A |
979 | Colour miscellaneous 15 | F |
980 | Type miscellaneous 16 | A |
981 | Colour miscellaneous 16 | F |
982 | Type miscellaneous 17 | A |
983 | Colour miscellaneous 17 | F |
984 | Type miscellaneous 18 | A |
985 | Colour miscellaneous 18 | F |
986 | Type miscellaneous 19 | A |
987 | Colour miscellaneous 19 | F |
988 | Type miscellaneous 20 | A |
989 | Colour miscellaneous 20 | F |
999 | Fixed material assignment | F |

Type: A = type

F = colour

K = Combination

S = shape


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Required version types
View with Navigation Tools
Introduction > Required version types

To assure that all necessary versions are available in the planning process, mandatory version types are defined and must be delivered in accordance with the model code of an item.

Model codes | required version types
Model code type 8 or 27 | 520,521
Model code type 26 | 562,563
Model code type 2 | 500,501
Model code type 29 | 514,515
Model code 5 | 550,551
Model code 20 or 21 | 510511
Model code 12 | 504,505
Model code 11 | 502,503
Model code 14 or 15 | 400,401,402
Model code 18 | 650,651
Model code 17 | 600,601
Front type code 4 | 151, 154, 208
Branch_ID=K | 101,202,203,205

All model codes can be found in the model code table.

The model code type can be found in the model code types table


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Type key
View with Navigation Tools
Introduction > Type key

Type-No. | Denotation
1 | Base cabinet
2 | Tall cabinet
3 | Wall cabinet
4 | Worktop top cabinet
5 | Recess elements
6 | Highboard
7 | Recess cabinet
8 | Solitaire furniture
9 | Front element
10 | Module element
11 | Cornice profile
12 | Light pelmet
13 | Ceiling filler
14 | Plinth blind
15 | Plinth board
17 | Worktop
18 | Worktop upstand profile
19 | Cover shelf
20 | Gallery shelf
21 | Gallery shelf
22 | Construction shelf
24 | Chimney
26 | Electrical appliance
27 | Gas appliance
28 | Small appliance
29 | Sink
30 | Fitting
35 | Lighting
37 | General Accesories
38 | Miscellaneous
41 | Block
42 | Additional equipment
43 | Value clearing
95 | Recycling fees.
98 | Information as subtext
99 | General text information/ order


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
EquipmentID
View with Navigation Tools
Introduction > EquipmentID

EquipmentID | Denotation
1 | Universal cutter
2 | Bread
3 | Rotating shelf
4 | Bottles
5 | Glass
6 | Towel
7 | Interior drawer/ pull-out
8 | Detergents/broom
9 | Waste sorter system
10 | Swivel mechanism
11 | Extractable table
12 | Larder
13 | Linen
14 | Spice
16 | Dryer
17 | Cooker
18 | Oven
19 | Hob
20 | Ceramic hob
21 | Extractor hood
22 | Extractor
23 | Extractor element
24 | Microwave
25 | Dishwasher
26 | Freezer
27 | Fridge
28 | Washing machine
29 | Control panel
30 | Double oven
31 | Sink
32 | Steam cooker
33 | Warming zone
34 | Grill
35 | Fryer Fryer
36 | Chopping board
37 | Coffee machine
41 | Fridge/ freezer combination
42 | Oven-Microwave combination
43 | Oven/ Warming
46 | Low pressure
47 | High pressure


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Installation information key
View with Navigation Tools
Introduction > Installation information key
Installation information no. | Designation (German) | Designation (English)
1 | For integrated fitting |
2 | Installation |
3 | Support base |
4 | Stand-alone appliance |
5 | Fully integrated |
7 | Integrated niche |
8 | Open niche |
11 | Flush with front |
12 | Flush with element |
13 | Flush with the surface |
14 | Surface-mounted | Lay-on
15 | Modules |
17 | Stand alone |
18 | Free-hanging |
19 | Wall-mounted |
21 | Visible side |
22 | Side plinth |
23 | Moulding |
24 | Return |
25 | Transition |
26 | Mitre profiling surcharge |
28 | Width reduction |
29 | Depth reduction |
30 | Height reduction |
32 | Cutout | Cut-out
33 | Angled cut |
34 | Rounding |
35 | Connection |
36 | Cutout | Release
37 | Processing |
46 | Row 60 cm |
47 | Corner | Edge
48 | Row 60 cm + corner |
49 | Special cabinet |


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Material key
View with Navigation Tools
Introduction > Material key
Material no. | Designation (German) | Designation (English)
1 | Kunststoff | Plastic
2 | Corian | Corean
3 | Echtholz | Wood
4 | Naturstein | Natural stone
5 | Metall | Metal
6 | Fliesen | Tiles
7 | Glas | Glass
8 | Verbundwerkstoff | Composite material
9 | Edelstahl | Stainless Steel
10 | Aluminium | Aluminium
11 | Stahl emailliert | Enameled steel
12 | Keramik | Ceramic


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Shape key
View with Navigation Tools
Introduction > Shape key
Shape no. | Designation (German) | Designation (English)
1 | Rechteckig | Square
2 | Diagonal | Diagonal
3 | Innenrund | Insidecurve
4 | Rund | Round
5 | Halbrund/Rundung | Half-round/rounding
6 | Schräg | Angled
7 | Z-Form / 3-D | Z-Form / 3-D
8 | Wellenform | Wavy
9 | 45-Grad | 45-degree
10 | 90-Grad | 90-degree
11 | 135-Grad | 135-degree
12 | N-Grad | N-degree


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Front appearance ID
View with Navigation Tools
Introduction > Front appearance ID
Front type no. | Designation (German) | Designation (English)
1 | Tür | Door
2 | Schubkasten | Drawer
3 | Auszug | Pull-out
4 | Glastür | Glass door
5 | Klappe | Lid/flap
6 | Schaltkastenblende | Switch cabinet bezel
7 | Jalousie | Blind
8 | Sliding door |
9 | Folding door |
10 | Rollershutter front |
11 | Tür/Schubkasten | Door/drawer
12 | Auszug/Schubkasten | Pull-out/drawer
13 | Schubkasten/Jalousie | Drawer/blind
14 | Auszug/Tür | Pull-out/door
15 | Auszug/Schubk./Tür | Pull-out/drawer/door
16 | Tür/Klappe | Door/flap
17 | Auszug/Schubk./Klappe | Pull-out/drawer/flap
18 | Drawer/rollershutter front |
20 | without front |
21 | 1 Becken o. Abtropfb. | 1 bowl without strainer bowl
22 | 1,5 Becken o. Abtropfb. | 1,5 bowls without strainer bowl
23 | 2 Becken o. Abtropfb. | 2 bowls without strainer bowl
24 | 1 Becken m. Abtropfb. | 1 bowl with strainer bowl
25 | 1,5 Becken m. Abtropfb. | 1,5 bowls with strainer bowl
26 | 2 Becken m. Abtropfb. | 2 bowls with strainer bowl
27 | Draining board | Strainer bowl
28 | 1 Becken m. Abfalls. | 1 bowl with rubbish container
29 | 1,5 Becken m. Abfalls. | 1,5 bowls with rubbish container
30 | 2 Becken m. Abfalls. | 2 bowls with rubbish container
31 | 1 Becken m. Abt.+Abf. | 1 bowl with strainer bowl and rubbish
32 | 1,5 Becken m. Abt.+Abf. | 1,5 bowls with strainer bowl and rubbish
33 | Abfall | Rubbish
36 | with spout |
37 | with spout repositioned/uninstalled |
38 | with hose spray head |
39 | with hose spray head repositioned/uninstalled |
41 | 1 Kochfläche | 1 ring
42 | 2 Kochflächen | 2 rings
43 | 3 Kochflächen | 3 rings
44 | 4 Kochflächen | 4 rings
45 | 5 Kochflächen | 5 rings
46 | 6 Kochflächen | 6 rings
47 | 7 Kochflächen | 7 rings
48 | 8 Kochflächen | 8 rings
49 | 9 Kochflächen | 9 rings


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Type key arts
View with Navigation Tools
Introduction > Type key arts
Item number | Bezeichnung (deutsch) | Designation (English)
1 | Normal | Normal
2 | Regal | Shelf
3 | Rahmen | Frame
4 | Seitenverkleidung | Side cladding
5 | Rückwandverkleidung | Rear cladding
6 | Frontblende | Front facing
7 | Dekorblende | Decorative facing
8 | Formwange | Shaped cheek
9 | Raumteiler | Room divider
10 | Unterbau | substructure
11 | Aufsatz | Cap
14 | Paßstück | Filler
15 | Blende | Baffle
16 | Umbau |
17 | Module housing |
19 | Einlegeboden | Shelf
21 | Barplatte | Bar top
22 | Table attachment | Fixed table
26 | Pilaster | Pilaster
27 | Stollen |
28 | Paneel | Panel
29 | Board/console | Board/table
30 | Reling | Rail
32 | Einhebelmischer |
33 | Zweigriffarmatur |
34 | Sonstige Armaturen |
36 | Umluft |
37 | Abluft |
40 | Zubehör | Accessory


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Information key
View with Navigation Tools
Introduction > Information key

Property no.

Designation

Description

Unit of measure

Value

Information for washing machines

100

RATED_CAPACITY

Nominal capacity in kg cotton for the standard program "Cotton 60°C" or the standard program.

"Cotton 40°C", respectively with full load, with the lower of the two values being authoritative

kg

numerical

101

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 1

A+++ … D

102

WEIGHTED_ANNUAL_ENERGY_CONSUMPTION

weighted annual energy consumption (AE C) in KWh/a, rounded to the next integer. This value must be specified as: Energy consumption of "X" kWh/a on the basis of 220 standard washing cycles at 60°C and 40°C cotton programs with full load and partial load, as well as consumption of operating modes with low power consumption. The actual energy consumption depends on the actual use of the appliance.

kWh per year

numerical

103

ENERGY_CONSUMPTION

Energy consumption (E t,60 , E t,60½ , E t,40½ ) of the standard program "Cotton 60°C" with full load and partial load, as well as the "Cotton 40°C" program with partial load.

kWh

numerical

104

WEIGHTED_POWER_CONSUMPTION_OFF

weighted power consumption when switched off

W

numerical

105

WEIGHTED_POWER_CONSUMPTION_ON

weighted power consumption when switched on

W

numerical

106

WEIGHTED_ANNUAL_WATER_CONSUMPTION

weighted annual water consumption (AW C) in liters/a, rounded to the next integer. This value must be specified as: Water consumption of "X" litres/a on the basis of 220 standard washing cycles at 60°C and 40°C cotton programs with full load and partial load. The actual water consumption depends on the actual use of the appliance.

litres per year

numerical

107

SPIN_DRYING_EFFICIENCY_CLASS

Spinning efficiency class, determined using table 2 and expressed as spinning efficiency class "X" on a scale from G (lowest efficiency) to A (highest efficiency). A different design can be used as long as it is made clear that the scale ranges from G (lowest efficiency) to A (highest efficiency).

A … G

108

MAX_SPIN_SPEED

maximum spinning speed for standard program "Cotton 60°C" with full load or for standard program "Cotton 40°C" with partial load, with the lower value being authoritative, as well as residual humidity for standard program "Cotton 60°C" with full load or for standard program "Cotton 40°C" with partial load, with the higher value being authoritative,.

revolutions per minute

numerical

109

INDICATION_STANDARD

Information about the fact that the standard programs "Cotton 60°C" and "Cotton 40°C" are the standard washing programs to which the information on the label and data sheet refer, that these programs are suitable for washing averagely dirty cotton fabrics and the most efficient ones with respect to the combined energy and water consumption.

Character sequence ST or blank

110

PROGRAMME_TIME

Program duration of the standard program "Cotton 60°C" with full load and partial load, as well as the "Cotton 40°C" program with partial load in minutes, rounded to the next minute.

min

numerical

111

DURATION_LEFT_ON_MODE

Time appliance is in switched on mode (T I ) if the household washing machine is equipped with power control.

min

numerical

112

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Airborne acoustical emissions in db(A) re 1 pW, rounded to the next integer, during washing and spinning in the standard program "Cotton 60°C" with full load.

dB

numerical

Information for dishwashers

120

RATED_CAPACITY

Nominal capacity in standard place settings for the standard cleaning mode

Quantity

numerical

121

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 3

A+++ … D

122

ANNUAL_ENERGY_CONSUMPTION

annual energy consumption (AE C ) in KWh/a, rounded to the next integer. This value must be stated as energy consumption "X" kWh/a on the basis of 280 standard cleaning cycles with cold water and the consumption incurred in the operating modes with the lowest power consumption. The actual energy consumption depends on the actual use of the appliance.

kWh per year

numerical

123

ENERGY_CONSUMPTION

Energy consumption (E t ) of the standard cleaning cycle

kWh

numerical

124

POWER_CONSUMPTION_OFF

weighted power consumption when switched off

W

numerical

125

POWER_CONSUMPTION_ON

weighted power consumption when switched on

W

numerical

126

WEIGHTED_ANNUAL_WATER_CONSUMPTION

weighted annual water consumption (AW C ) in liters/a, rounded to the next integer. This must be stated as: water consumption "X" litres/a based on 280 standard dishwashing cycles. The actual water consumption depends on the actual use of the appliance.

litres per year

numerical

127

DRYING_EFFICIENCY_CLASS

Drying efficiency class, determined in accordance with table 4 and expressed as the drying efficiency class "X" on a scale from G (lowest efficiency) to A (highest efficiency). A different design may be used if data is displayed in a table, provided it is made clear that the scale ranges from G (lowest efficiency) to A (highest efficiency).

A … G

128

INDICATION_STANDARD

Information about the fact that the "standard program" is the cleaning cycle to which the information on the label and data sheet refer, that this program is suitable for washing averagely dirty dishes and the most efficient one with respect to the combined energy and water consumption.

Character sequence ST or blank

129

PROGRAMME_TIME

Program duration of the standard cleaning cycle in minutes, rounded to the next integer.

min

numerical

130

DURATION_LEFT_ON_MODE

Time appliance is in switched on mode (T I ) if the household dishwasher is equipped with power control

min

numerical

131

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Airborne acoustical emissions in db(A) re 1 pW, rounded to the next integer.

dB

numerical

Information for tumble dryers

140

RATED_CAPACITY

Nominal capacity in kg cotton clothing for the standard cotton program with full load

kg

numerical

141

TUMBLE_KIND

whether the household tumble dryer is an exhaust air, condensation or gas-heated household tumble dryer

Code A, C or G

142

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 5

A+++ … D

143

WEIGHTED_ANNUAL_ENERGY_CONSUMPTION

for electrically heated household tumble dryers:

weighted annual energy consumption (AE c ) in KWh/a, rounded to one decimal space. This value must be specified as: Energy consumption of "X" kWh/a on the basis of 160 drying cycles for the standard cotton program with full load and partial load, as well as consumption of operating modes with low power consumption. The actual energy consumption per cycle depends on the actual use of the appliance.

for gas-heated household tumble dryers:

weighted annual energy consumption (AE c (gas) ) in KWh/a, rounded to one decimal space. This value must be specified as: Energy consumption of "X" gas kWh/a on the basis of 160 drying cycles for the standard cotton program with full load and partial load, as well as consumption of operating modes with low power consumption. The actual energy consumption per cycle depends on the actual use of the appliance.

and

weighted annual energy consumption (AE C (gas)el ), rounded to one decimal space. This value must be specified as: Energy consumption of "X" kWh/a on the basis of 160 drying cycles for the standard cotton program with full load and partial load, as well as consumption of operating modes with low power consumption. The actual energy consumption per cycle depends on the actual use of the appliance.

kWh per year

numerical

144

AUTOMATIC

whether the household tumble dryer is a tumble dryer with automatic controls or a tumble dryer without automatic controls

1=true
0=false

145

ENERGY_CONSUMPTION

Energy consumption (E dry , E dry½ , Eg dry , Eg dry½ , Eg dry,a , Eg dry½,a ) of the standard cotton program with full load and partial load.

kWh

numerical

146

POWER_CONSUMPTION_OFF

Power consumption when switched off (P o ) for the standard cotton program with full load

W

numerical

147

POWER_CONSUMPTION_ON

Power consumption when switched on (P I ) for the standard cotton program with full load

W

numerical

148

DURATION_LEFT_ON_MODE

Time appliance is in switched on mode if the household tumble dryer is equipped with power control.

min

numerical

149

INDICATION_STANDARD

Information about the fact that the "standard cotton program" with full and partial load is the standard drying program to which the information on the label and data sheet refers, that this program is suitable for drying normally wet cotton clothes and the most efficient one for cotton with respect to the energy consumption

Character sequence ST or blank

150

WEIGHTED_PROGRAMME_TIME

weighted program duration (T t ) of the "standard cotton program with full and partial load" in minutes, rounded to the next full minute.

min

numerical

151

WEIGHTED_PROGRAMME_TIME

Program duration of the "standard cotton program" with full load (T dry ) in minutes, rounded to the next full minute.

min

numerical

152

WEIGHTED_PROGRAMME_TIME

Program duration of the "standard cotton program" with partial load (T dry½ ) in minutes, rounded to the next full minute.

min

numerical

153

CONDENSATION_EFFICIENCY

if the household tumble dryer is a condensation dryer, the condensation efficiency class as stated in table 6 expressed as "condensation efficiency class 'X' on a scale from G (lowest efficiency) to A (highest efficiency); a different design can be used provided it is made clear that the scale ranges from G (lowest efficiency) to A (highest efficiency)

A … G

154

AVERAGE_CONDENSATION_EFFICIENCY

if the household tumble dryer is a condensation dryer, the average condensation efficiency C dry and C dry½ of the standard cotton program with full load and partial load and the weighted condensation efficiency (C t ) for the standard cotton program with full and partial load expressed as a percentage number rounded to the next full percent

%

numerical

155

SOUND_POWER_LEVEL

Sound power level (weighted average value - L WA ) in db, rounded to the next integer, for the standard cotton program with full load

dB

numerical

Information for combo washer dryers

160

ENERGY_EFFICIENCY_CLASS

Energy efficiency class of the model as per table 7, expressed as "energy efficiency class". . on a scale from A (low energy consumption) to G (high energy consumption)". A different design may be used if data is displayed in a table, provided it is made clear that the scale ranges from G (lowest efficiency) to A (highest efficiency).

A … G

161

ENERGY_CONSUMPTION

Energy consumption in kWh per completed operating cycle (washing, spinning, drying)

kWh

numerical

162

ENERGY_CONSUMPTION_W_D_ONLY

Energy consumption in kWh for the washing and spinning program only

kWh

numerical

163

WASHING_PERFORMANCE

Washing performance class as per table 8, expressed as "washing performance class . on a scale from A (better) to G (poor)". A different design can be used as long as it is made clear that the scale ranges from A (better) to G (poor).

A … G

164

WATER_EXTRACTION_EFFICIENCY

Spinning performance for the standard program "Cotton 60°C", expressed as "residual humidity after spinning ...% (percentage of the dry weight of the load)"

%

numerical

165

MAX_SPIN_SPEED

maximum spinning speed for the standard program "Cotton 60°C"

revolutions per minute

numerical

166

WASH_CAPACITY

Load capacity (washing) of the appliance for the standard program "Cotton 60°C"

kg

numerical

167

DRY_CAPACITY

Load capacity (drying) of the appliance for the standard program "Cotton shelf-dry"

kg

numerical

168

WATER_CONSUMPTION

Water consumption in l per completed operating cycle (washing, spinning and drying)

litres

numerical

169

WATER_CONSUMPTION_W_D_ONLY

Water consumption in 1 for washing and spinning only for the standard program "Cotton 60°C"

litres

numerical

170

WASHING_DRYING_TIME

Washing and drying time: duration until operating cycle (washing, spinning and drying) is completed in the standard program "Cotton 60°C" and the drying program "Cotton shelf-dry" with nominal capacity load

min

numerical

171

ENERGY_WATER_CONSUMPTION

Energy and water consumption based on 200 standard cycles, expressed as the estimated annual consumption of a 4-person household that always uses the combo washer dryer for drying (200 programs)

kWh

numerical

172

NOISE_EMISSION

Noise emissions during washing, spinning and drying in the standard program "Cotton 60°C" and "Cotton, shelf-dry",

dB

numerical

Information for refrigerators

180

CATEGORY

Household refrigerator category as per tables 9 and 10

numerical

1 … 10

181

ENERGY_EFFICIENCY_CLASS

Energy efficiency class of the model as per table 11

A+++ … G

182

ANNUAL_ENERGY_CONSUMPTION

annual energy consumption (AE C ) in KWh/a in accordance with no. 3 (2) of Annex VIII, rounded to the next integer. To be stated as: Energy consumption 'XYZ' kWh/a based on results of standard testing over 24 hours. The actual consumption depends on the use and location of the appliance.

kWh per year

numerical

183

STORAGE_VOLUMNE

Capacity of each compartment and, if applicable, star rating in accordance with the total capacity of all freezer compartments that have a star rating (i.e. with an operating temperature ≤ – 6 °C), rounded to the next integer, and star rating of the compartment with the highest share in the total; if the household refrigerator does not have freezer compartments, the supplier will specify "- L" instead of a value and leave the position for the star ranking blank

litres

numerical

184

DESIGN_TEMPERATURE

Design temperature "other compartments" in the meaning of Annex I letter n. For wine chilling compartments, the lowest chilling temperature that is preset for the compartment, or that can be set by the consumer in accordance with the manufacturer's instructions, and that can be maintained permanently

°C

numerical

185

FROST_FREE

Information "Frost-fee" for the relevant compartment(s) other than wine chilling compartments and intended for storage of certain foods with a temperature higher than + 14 °C

Compartment, counted from the bottom up

numerical

186

TEMPERATURE_RISE_TIME

"Storage time during malfunction 'X' h" defines the "temperature rise time"

h

numerical

187

FREEZING_CAPACITY

"Freezing capacity" in kg/24h

kg/24 h

numerical

188

CLIMATE_CLASS

"Climate class" as per table 12, expressed as: climate class: W [climate class]. This appliance is designed for operation in ambient temperatures between 'X' [lowest temperature] °C and 'X' [highest temperature] °C.

SN, N, ST or T

189

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Airborne acoustical emissions in db(A) re 1 pW, rounded to the next integer.

dB

numerical

190

WINE_ONLY

The following must be stated for wine chillers: "This appliance is intended for the storage of wine only." This does not apply to household refrigerators that are not specifically designed for wine chilling but can be used for this purpose and not to household refrigerators that have a wine chilling compartment that is combined with another type of compartment.

1=true

0=false

Information for ovens

200

NUMBER_CAVITY

number of cooking chambers

Quantity

numerical

201

ENERGY_EFFICIENCY_INDEX

the energy efficiency index (EEIcavity) for the first cooking chamber of the model, rounded to one decimal space

numerical

202

ENERGY_EFFICIENCY_CLASS

the energy efficiency class of the model for the first cooking chamber as per table 13

A+++ … D

203

ENERGY_CONSUMPTION

The energy consumption per cycle for the first cooking chamber in conventional cooking mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

204

ENERGY_CONSUMPTION

The energy consumption per cycle for the first cooking chamber in fan-forced mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

205

HEAT_SOURCE_CAVITY

the heat source for the first cooking chamber

E or G

206

VOLUMNE_ CAVITY

the volume of the first cooking chamber

litres

numerical

207

ENERGY_EFFICIENCY_INDEX

the energy efficiency index (EEIcavity) for the second cooking chamber of the model, rounded to one decimal space

208

ENERGY_EFFICIENCY_CLASS

the energy efficiency class of the model for the second cooking chamber as per table 13

A+++ … D

209

ENERGY_CONSUMPTION

The energy consumption per cycle for the second cooking chamber in conventional cooking mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

210

ENERGY_CONSUMPTION

The energy consumption per cycle for the second cooking chamber in fan-forced mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

211

HEAT_SOURCE_CAVITY

the heat source for the second cooking chamber

E or G

212

VOLUMNE_ CAVITY

the volume of the second cooking chamber

litres

numerical

213

ENERGY_EFFICIENCY_INDEX

the energy efficiency index (EEIcavity) for the third cooking chamber of the model, rounded to one decimal space

numerical

214

ENERGY_EFFICIENCY_CLASS

the energy efficiency class of the model for the third cooking chamber as per table 13

A+++ … D

215

ENERGY_CONSUMPTION

The energy consumption per cycle for the third cooking chamber in conventional cooking mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

216

ENERGY_CONSUMPTION

The energy consumption per cycle for the third cooking chamber in fan-forced mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

217

HEAT_SOURCE_CAVITY

the heat source for the third cooking chamber

E or G

218

VOLUMNE_ CAVITY

the volume of the third cooking chamber

litres

numerical

Information for cooker hoods

220

ANNUAL_ENERGY_CONSUMPTION

the annual energy consumption (AEC hood) in kWh/a, rounded to one decimal space

kWh per year

numerical

221

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 14

A+++ … G

222

FLUID_DYNAMIC_EFFICIENCY

The calculated fluid-dynamic efficiency (FDE hood), rounded to one decimal space

numerical

223

FLUID_DYNAMIC_EFFICIENCY_CLASS

The fluid-dynamic efficiency clause as per table 15

A … G

224

LIGHTING_EFFICIENCY

the calculated lighting efficiency (LE hood) in lx/W, rounded to one decimal space

numerical

225

LIGHTING _EFFICIENCY_CLASS

The lighting efficiency class as per table 16, the specified class must not be higher than the class stated in the technical documentation

A … G

226

GREASE_FILTERING_EFFICIENCY

the calculated grease filtering degree in percent, rounded to one decimal space. The stated value must not be higher than the value stated in the technical documentation.

%

numerical

227

GREASE_FILTERING _EFFICIENCY_CLASS

the class for level of grease separation as per table 17

A … G

228

AIR_FLOW

the air flow (in m 3 /h, rounded to the next integer) at maximum and minimum speed in normal mode, intensive mode and fast mode are excluded

m³/h

numerical

229

AIR_FLOW_INTENSIVE

if applicable, the air flow (in m 3 /h, rounded to the next integer) in intensive mode and fast mode

m³/h

numerical

230

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

the A-rated airborne critical noise emissions (in dB, rounded to the next integer) at minimum and maximum available speed in normal mode

dB

numerical

231

AIRBORNE_ACOUSTICAL_NOISE_EMISSION_INT

if applicable, the A-rated airborne acoustical noise emissions (in dB, rounded to the next integer) in intensive mode and fast mode

dB

numerical

232

POWER_CONSUMPTION_OFF

if applicable, the power consumption while switched off (P o ) in Watt, rounded to two decimal spaces

W

numerical

231

POWER_CONSUMPTION_ON

if applicable, the power consumption in standby mode (P o ) in Watt, rounded to two decimal spaces

W

numerical

Information for electrical lamps and lights

240

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 18

A++ … E

241

WEIGHTED_ENERGY_CONSUMPTION

weighted annual energy consumption (EC) in KWh/1000h, rounded to the next integer.

kWh per 1000 hours

numerical

242

ENERGY_EFFICIENCY_CLASS_COMPATIBILITY

The energy efficiency classes of lights that can be exchanged by the user and with which the light is compatible in accordance with state-of-the-art compatibility requirements

A++ … E

243

ENERGY_EFFICIENCY_CLASS_N_COMPATIBILITY

The energy efficiency classes of lights with which the lamp is incompatible in accordance with state-of-the-art compatibility requirements

A++ … E

244

ENERGY_EFFICIENCY_CLASS_LED

The energy efficiency classes for LED modules not intended for removal by the consumer

A++ … E

245

ENERGY_EFFICIENCY_CLASS_INCLUDED

The energy efficiency classes for lamps operated with the lights that can be exchanged by the consumer and that are included in the lamp's packaging

A++ … E

Information for TVs

260

ENERGY_EFFICIENCY_CLASS

Energy efficiency class of the model as per table 19

A+++ … G

261

SCREEN_DIAGONAL_CM

visible screen size in centimetres

cm

numerical

262

SCREEN_DIAGONAL_INCH

visible screen size in inches

inch

numerical

263

POWER_CONSUMPTION_ON

Power consumption while switched on

W

numerical

264

ANNUAL_ENERGY_CONSUMPTION

The calculated annual energy consumption in kWh/a, rounded to the next integer. This value is to be stated as: energy consumption XYZ kWh/a based on four hours of daily operation of the TV on 365 days. The actual energy consumption depends on the actual use of the TV.

kWh per year

numerical

265

POWER_CONSUMPTION_OFF

Power consumption while switched off

W

numerical

266

POWER_CONSUMPTION_STANDBY

Power consumption in standby mode

W

numerical

267

SCREEN_RESOLUTION_HORIZONTAL

Screen resolution, measured in the physical horizontal number of pixels.

pt

numerical

268

SCREEN_RESOLUTION_VERTICAL

Screen resolution, measured in the physical vertical number of pixels.

pt

numerical

Information for heating appliances: 280-300

Information for air-conditioners: 300-320

Information for single room heating appliances: 320-340

Information for vacuum cleaners: 340-360

Information for commercial refrigeration cabinets: 360-380

Information for residential ventilation appliances: 380-400

Information for solid fuel boilers and composite systems including solar installations: 400-420

The required numerical data must not be negative numbers. No decimal comma is used for numbers in the thousand range. Decimal spaces are preceded by a dot.

Properties can be freely assigned to the values 800-999.

1. ENERGY EFFICIENCY CLASSES for washing machines

The energy efficiency class of a household washing machine is determined on the basis of its energy efficiency index (EEI) as per table 1.

The energy efficiency index (EEI) of a household washing machine is determined as per table 1.

2. SPINNING EFFICIENCY CLASSES for washing machines

The spinning efficiency class of a household washing machine is determined on the basis of the residual humidity (D) as per table 2.

3. ENERGY EFFICIENCY CLASSES for dishwashers

The energy efficiency class of a household dishwasher is determined on the basis of its energy efficiency index (EEI)

as per table 3.

4. DRYING EFFICIENCY CLASSES for dishwasher

table 4

5. ENERGY EFFICIENCY CLASSES for tumble dryers

The energy efficiency class of a household tumble dryer is determined on the basis of its energy efficiency index (EEI) as per table 5.

table 5

6. CONDENSATION EFFICIENCY CLASSES

The condensation efficiency class of a household condensation tumble dryer is determined on the basis of the weighted condensation efficiency (C t ) as per table 6.

table 6

7. EFFICIENCY CLASSES for combo washer dryers

table 7: efficiency classes

Table 8: washing performance classes

8. CLASSIFICATION OF HOUSEHOLD REFRIGERATORS

The household refrigerators are classified in categories in accordance with table 9.

Each category is determined by a certain composition of compartments in accordance with table 10 and independent from the number of doors and/or drawers.

table 9

Household refrigerators that cannot be assigned to category 1 to 9 due to their compartment temperatures must be assigned to category 10.

Table 10

Household refrigerator classification and compartment composition

9. EFFICIENCY CLASSES for refrigeration appliances

The energy efficiency class of a household tumble dryer is determined on the basis of its energy efficiency index (EEI) as per table 5.

table 11

table 12

10. ENERGY EFFICIENCY CLASSES for ovens

The energy efficiency classes for household ovens are determined for each cooking chamber in accordance with the values in table 13.

11. EFFICIENCY CLASSES for a cooker hoods

The energy efficiency classes ofcooker hoodsare determined in accordance with the values in table 14.

The classes for the fluid-dynamic efficiency of a household cooker hood are determined on the basis of their fluid-dynamic efficiency (FDE hood) in accordance with the following table 15.

The classes for the illumination efficiency of a household cooker hood are determined on the basis of their illumination efficiency (LE hood) in accordance with the following table 16.

The classes for the level of grease separation of a household cooker hood are determined on the basis of their grease separation level (GFE hood) in accordance with the following table 17

12. ENERGY EFFICIENCY CLASSES for lamps

table 18: energy efficiency classes

13. ENERGY EFFICIENCY CLASSES for TVs

table 19: energy efficiency classes for TVs

The official EU journals pertaining to the relevant directives and regulations can be found at the following links:

http://www.newenergylabel.com/index.php/start/

http://ec.europa.eu/energy/sites/ener/files/documents/list_of_enegy_labelling_measures.pdf

Links to the individual product groups are available in multiple languages.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Standard handle orientations
View with Navigation Tools
Introduction > Standard handle orientations

Standard handle orientation | Denotation | Picture | Description
0 | Without drilling, with handle |  | valid for all types of front
1 | horizontally centred - vertical at outer edge |  | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). vertical orientation at outer edge for: doors; glass doors; roller shutters (vertical).
2 | horizontally centred - horizontal at outer edge |  | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontal orientation at outer edge for: doors; glass doors; roller shutters (vertical).
3 | vertically centred - vertical at outer edge |  | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). vertical orientation at outer edge for: doors; glass doors; roller shutters (vertical).
4 | vertically centred - horizontal at outer edge |  | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontal orientation at outer edge for: doors; glass doors; roller shutters (vertical).
5 | horizontally centred - vertically centred |  | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). vertically centred orientation for: doors; glass doors; roller shutters (vertical).
6 | horizontally centred - horizontally centred |  | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontally centred orientation for: doors; glass doors; roller shutters (vertical).
7 | vertically centred - vertically centred |  | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). vertically centred orientation for: doors; glass doors; roller shutters (vertical).
8 | vertically centred - horizontally centred |  | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontally centred orientation for: doors; glass doors; roller shutters (vertical).
9 | Horizontal at the top, full width - horizontal at the top, full width |  | orientation horizontal, full width, for: Drawers; pull-outs; shutters (horizontal). horizontal orientation full width for: doors; glass doors; flap doors; roller shutters (vertical).
10 | horizontal at the bottom of the element, full width - horizontal at the top of the element, full width |  | orientation at the bottom, full width, for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontal orientation full width for: doors; glass doors; roller shutters (vertical).
11 | horizontal at the top, full width - vertical at outer edge, full height |  | orientation horizontal, full width, for: Drawers; pull-outs; flap doors; shutters (horizontal). orientation at the outer edge, full height, for: doors; glass doors; roller shutters (vertical).
12 | horizontal at the bottom, full width - vertical at outer edge, full height |  | orientation at the bottom, full width, for: Drawers; pull-outs; flap doors; shutters (horizontal). orientation at the outer edge, full height, for: doors; glass doors; roller shutters (vertical).
90 | No standard handle orientation applicable. |  |
91 | No standard handle orientation applicable. |  |
92 | No standard handle orientation applicable. |  |
93 | No standard handle orientation applicable. |  |
94 | No standard handle orientation applicable. |  |
95 | No standard handle orientation applicable. |  |
96 | No standard handle orientation applicable. |  |
97 | No standard handle orientation applicable. |  |
98 | No standard handle orientation applicable. |  |
99 | Without drilling, without handle |  |


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Basic shapes
View with Navigation Tools
Introduction > Basic shapes

Introduction

This part of the IDM documentation describes the necessary basic forms for the data exchange.

The basic shapes are parametrized graphic illustrations. When data is exchanged, the parameters with the individual values are transmitted rather than the illustrations. A 3-D illustration is created in the processing systems on the basis of numbers unequivocally assigned to a basic shape and the parameter values. The IDM contains basic shapes for carcases, panels and tables, fronts, handles as well as for cornices and light pelmets.

General information on basic shapes

The basic shape is specified in the CARCASE_BASIC_SHAPE element. The basic shapes for carcases and table attachments are typified on the basis of top views on the relevant object. The illustrations of the objects are created by assigning values to the individual parameters. The measurements are assigned on the basis of milimeter data. For visualization purposes, almost all basic shapes have a perspective example and an example for the assignment of values to the parameters.

The represented basic shapes are only valid for cabinets/wooden parts and worktops, light pelmets, cornices etc., but not for accessories and electrical appliances. The basic shape no. 0 and no. 997 to no. 999 are used for accessories and electrical appliances. The basic shape no. 0 is available for items that are irrelevant for the illustration. Basic shape no. 997 is used for items for which neither a basic shape nor a real image or bitmap are available. It must be assured that the fields SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO in ITEM are filled and illustration information from the manufacturer are available. Basic shape no. 998 is used for items that are represented using a bitmap only. It must be assured that the fields FILE_NAME_TEXTURE_1/2 in ITEM are filled. Basic shape no. 999 is used if a real image is delivered rather than a basic shape. The values w, h and d must be specified in the BASIC_SHAPE_PARAMETERS for all basic shape numbers (0 and 997 - 999). The only exemptions are items without dimensions, e.g. width adjustments.

Basic shape no. 996 was introduced for filling levels below filling level 3. Basic shape no. 996 represents a visually relevant item for which further details analogous to basic shapes 997-999 are currently unavailable.

Values for width, height, depth and diameter without indices can be used as dimensions (boundingbox). For differentiation purposes, the "diameter" parameter is used for roundings that are relevant for the dimensions.

Because the "α" character cannot be used as a parameter, an "a" is used to specify the angle parameter.

Variable dimensions can be specified by values within the permitted range („from“(BASIC_SHAPE_FROM) „to“(BASIC_SHAPE_TO)) within the BASIC_SHAPE_PARAMETER in addition to the nominal dimensions (BASIC_SHAPE_NOMINAL_VALUE ). To allow for symmetric length adjustments, an object is overdetermined by the dimensions. The following definitions apply:

Rule 1:The overall dimension without index must correspond to the total of all component dimensions.

Rule 2:If a dimension variability is only specified for the overall dimension, all component dimensions are adjusted symmetrically.

Rule 3:The dimensions are fixed if there are no "from " and "to" values specified for the overall dimension (without indices). If values are specified for "from" and "to", the dimensions are flexible within this range.

Rule 4:If the option of dimension variability is only entered for component dimensions, the object will not be modified symmetrically, but the total of the component dimensions must result in the overall dimension.

Rule 5:By specifying equal values in the "from" and "to "fields, individual component dimensions (not w, h, d) can be exempt from the symmetric adjustment (see example).

Rule 6:The dimensions are adjusted (symmetrical distribution, addition to the overall dimension) for dimensions with indices (component dimensions) that have no "from" and "to" values specified. If values are specified for "from" and "to", the dimensions are flexible within this range.

The required dimensions relate to the carcase dimensions and not to front thickness. Guidance is provided by a double line on the sides and front surface of the carcases. This line represents both front panels as well as shelf openings.

For each basic shape, the alignment is defined by illustrating the wall. This is also the reason for the differentiator for basic shapes no. 5 and 8, which are primarily intended as elements for stand-alone and island solutions. This results from the only side available for planning facing the wall.

Special geometries cannot be mapped using the basic shapes. This is why basic shape numbers 997-999 are available for items that cannot be visualized using the available basic shapes. Basic shape no. 0 is used for items that are irrelevant for visualization purposes.

In this example, the carcase with a width of 700 mm for width 1 and width 3 is in each case shortened by 50 mm from the nominal dimensions.

The specified CONSTRUCTION_ID relates to the displayed illustrations. If CONSTRUCTION_ID = N, it is essential for the item to be symmetric. An item on the display may become asymmetric if the parameters are varied. The result is that CONSTRUCTION_ID = N must not be used for this item. It is now possible to create a separate item for each construction type ("L" or "R"), or an item with CONSTRUCTION_ID = J. If CONSTRUCTION_ID = J is used, the parameters for the left (CONSTRUCTION_ID "L") must be specified.

Changing the parameters must not result in changes to certain limiting conditions with regard to the parallelism of edges to other edges. If this case is theoretically possible, the corresponding basic shapes will contain an explicit notice.

Assigning a "leading" parameter aims at assuring a uniform cross-manufacturer allocation to a left or right CONSTRUCTION_ID. The leading parameter is specified for the relevant basic shape. For the left CONSTRUCTION_ID, the values of these parameters must be smaller on the left side of the illustration than the corresponding parameter on the right side. Also see the example below.

Example for an asymmetric item illustration for basic shape no. 4:

symmetric item asymmetric item asymmetric item

with CONSTRUCTION_ID=N with CONSTRUCTION_ID=R with CONSTRUCTION_ID=L

Parameters:

b1=b3 and t1=t2 b1<>b3 and t1<>t2 b1<>b3 and t1<>t2

In the case of asymmetric items with CONSTRUCTION_ID=J, a construction type right or left is created depending on the options in the dealer software system.

By setting the relevant parameters to equal values, basic shapes that are illustrated as construction type L and construction type R can be made symmetric. As an example, basic shape 19 can be specified with CONSTRUCTION_ID = N by setting identical values in parameters d = w and we= de.

Basic shapes that are only specified as CONSTRUCTION_ID = L and CONSTRUCTION_ID = R but that can also be specified as CONSTRUCTION_ID = N by setting identical values in certain parameters have a reference points that is identical to CONSTRUCTION_ID = L. A small circle highlights the reference point in the illustrations.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Basic carcase forms
View with Navigation Tools
Introduction > Basic shapes > Basic carcase forms

Basic shape 1

Parameters: b = width h = height t = depth value range for CONSTUCTION_ID: N L R

Example:

b=600mm, h=720mm, t=560mm, CONSTRUCTION_ID=N

Basic shape 2

Parameters: b=width h=height t=depth(carcase) t1=depth1 value range for CONSTRUCTION_ID: J,L,R

Example:

b=600mm, h=720mm, t=560mm, t1=401mm, CONSTRUCTION_ID=R

Basic shape 3

Parameters: b=width h=height t=depth(carcase) b1=width1 t1=depth1 value range for CONSTRUCTION_ID: N

Example 1:

b=365mm, h=590mm, t=560mm, t1=460mm, b1=365mm, CONSTRUCTION_ID=R

Example 2:

b=900mm, h=720mm, t=600mm, t1=560mm, b1=900mm, CONSTRUCTION_ID=R

Basic shape 4

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 t1=depth1 t2=depth2 value range for CONSTRUCTION_ID: N,L,R,J

Example:

b=600mm, h=720mm, t=365mm, b1=120mm, b2=360mm, b3=120mm, t1=120mm, t2=120mm, CONSTRUCTION_ID=N

Comments:

Widths 1-3 can be variably defined in the "from" and "to" fields. If a symmetric variability is to be specified, a value for the "from" and "to" fields must be specified for width w.

CONSTRUCTION_ID = N only if

b1 = b3, t1 = t2

b2 is always parallel to b and observe

b = b1 + b2+ b3

The leading parameters are b1 and b3.

Basic shape 5

Parameters: b=width(carcase) h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 t1=depth1 t2=depth2 value range for CONSTRUCTION_ID: N,L,R,J

Example:

b=600mm, h=720mm, t=365mm, b1=120mm, b2=360mm, b3=120mm, t1=120mm, t3=120mm, CONSTRUCTION_ID=N

Comments:

Primary use as a stand-alone element.

Widths 1-3 can be variably defined in the "from" and "to" fields. If a symmetric variability is to be specified, a value for the "from" and "to" fields must be specified for width w.

CONSTRUCTION_ID = N only if b1 = b3, t1 = t3

b2 is always parallel to b and observe

b = b1 + b2+ b3

The leading parameters are b1 and b3.

Basic shape 6

Parameters: b=width(carcase) h=height t=depth(carcase) b1=width1 b3=width3 t1=depth1 t2=depth2 t3=depth3 value range for CONSTRUCTION_ID: L,R,J

Example:

w=365mm, h=724mm, d=585mm, w1=120mm, w3=120mm, d1=120mm, d2=360mm, d3=120mm, CONSTRUCTION_ID=R

Comments:

Depths 1-3 can be variably defined in the "from" and "to" fields. If a

symmetric variability is to be specified, a value for the "from" and "to" fields for depth d

must be specified.

t = t1 + t2+ t3 applies.

Basic shape 7

Parameters: b=width(carcase) h=height t=depth(carcase) r1=radius1 r2=radius2 b1=width1 t1=depth1 t2=depth2 value range for CONSTUCTION_ID:N,L,R,J

Example:

b=500mm, h=720mm, t=300mm, b1=350mm, t1=225mm, t2=225mm, r1=75mm, r2=75mm, CONSTRUCTION_ID=N

Comments:

CONSTRUCTION_ID = N only if

t1 = t2, r1 = r2

b1 is always parallel to bàt1+r1 = t2+r2 and

b = r1 + b1+ r2, t = t1 + r1 and t = t2 + r2 applies.

The leading parameters are r1 and r2.

Basic shape 8

Parameters: b=width(carcase) h=height t=depth(carcase) r1=radius1 r2=radius2 b1=width1 t1=depth1 t2=depth2 value range for CONSTUCTION_ID:N,L,R,J

Example:

b=500mm, h=720mm, t=300mm, b1=350mm, t1=225mm, t2=225mm, r1=75mm, r2=75mm, CONSTRUCTION_ID=N

Comments:

Primary use as a stand-alone element.

The perspective examples are identical for basic carcase forms 8 and 9. The basic carcase forms only differ in their alignment to the wall. CONSTRUCTION_ID = N only if d1 = d2, r1 = r2

b1 is always parallel to bàt1+r1 = t2+r2 and

b = r1 + b1+ r2, t = t1 + r1 and t = t2 + r2 applies.

The leading parameters are r1 and r2.

Basic shape 9

Parameters: b=width(carcase) h=height t=depth(carcase) r1=radius1 r2=radius2 b1=width1 b2=width2 t1=depth1 value range for CONSTUCTION_ID:L,R,J

Example:

b=300mm, h=720mm, t=500mm, b1=225mm, b2=225mm, t1=350mm, r1=75mm, r2=75mm, CONSTRUCTION_ID=J

Comments:

The perspective examples are identical for basic carcase forms 8 and 9. The basic carcase forms

only differ in their alignment to the wall.

The formula

b= r1 + b1, b = b2 + r2 and t = t2 + r1 + r2 applies.

Basic shape 10

Parameters: b=width(carcase) h=height t=depth(carcase) b1=width1 t1=depth1 value range for CONSTRUCTION_ID: N,L,R,J

Example:

b=600mm, h=1900mm, t=560mm, b1=300mm, t1=460mm, CONSTRUCTION_ID=N

Comments:

CONSTRUCTION_ID = N only if

b1 = b2

The leading parameter is b1.

Basic shape 11

Parameters: b=width h=height t=depth(carcase) t1=depth1 value range for CONSTRUCTION_ID: L,R,J

b=365mm, h=590mm, t=560mm, t1=460mm, CONSTRUCTION_ID=R

Basic shape 12

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 t1=depth1 value range for CONSTRUCTION_ID: L,R,J

Example:

b=600mm, h=720mm, t=575mm, b1=150mm, b2=300mm, b3=150mm, t1=460mm CONSTRUCTION_ID=R

Comments:

Widths 1-3 can be variably defined in the "from" and "to" fields. If a

symmetric variability is to be specified, a value for the "from" and "to" fields for width w.

must be specified.

The formula b = b1 + b2 + b3 applies.

Basic shape 13

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 t1=depth1 value range for CONSTRUCTION_ID: L,R,J

Example:

b=900mm, h=720mm, t=575mm, b1=175mm, b2=550mm, b3=175mm, t1=175mm CONSTRUCTION_ID=L

Comments:

Widths 1-3 can be variably defined in the "from" and "to" fields. If a

symmetric variability is to be specified, a value for the "from" and "to" fields for width w.

must be specified.

The available options are CONSTRUCTION_ID = L, R, J

The formula b = b1 + b2 + b3 applies.

Basic shape 14

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 b4=width4 b5=width5 t1=depth1 t2=depth2 t3=depth3 value range for CONSTRUCTION_ID: N,L,R,J

Example:

b=900mm, h=720mm, t=575mm, b1=175mm, b2=175mm, b3=200mm, b4=175mm, b5=175mm, t1=175mm, t2=400mm, t3=400mm, CONSTRUCTION_ID=N

Comments:

Widths 1-5 can be variably defined in the "from" and "to" fields. If a

symmetric variability is to be specified, a value for the "from" and "to" fields for width w.

must be specified.

CONSTRUCTION_ID = N only if

b1 = b5, b2 = b4, t2 = t3

b1, b3 and b5 are always parallel to bàb1+b2 = b4 and b = b1 + b2 + b3 + b4 + b5 applies

The leading parameters are b1+b2 and b4+b5.

Basic shape 15

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 t1=depth1 t2=depth2 t3=depth3 value range for CONSTRUCTION_ID: N,L,R,J

Example:

b=600mm, h=590mm, t=465mm, b1=150mm, b2=300mm, b3=150mm, t1=50mm, t2=50mm, t3=365mm, CONSTRUCTION_ID=N

Comments:

Widths 1-3 can be variably defined in the "from" and "to" fields. If a

symmetric variability is to be specified, a value for the "from" and "to" fields for width b.

must be specified.

CONSTRUCTION_ID = N only if

b1 = b3

b1 and b3 are always parallel to w

The leading parameters are b1 and b3 and b = b1 + b2 + b3; t = t1 + t2 + t3 applies .

Basic shape 16

Parameters: b=width(carcase) h=height t=depth(carcase) be=corner width b1=width1 te=corner depth value range for CONSTRUCTION_ID: L,R,J

Example:

b=365mm, h=720mm, t=575mm, be=0mm, te=0mm, t1=195mm, b1=195mm, CONSTRUCTION_ID=R

Comments:

CONSTRUCTION_ID = N also if

b = t, b1 = t1, te = be

Basic shape 17

Parameters: b=width(carcase) h=height t=depth(carcase) be=corner width te=corner depth r=radius value range for CONSTRUCTION_ID: L,R,J

Example:

b=365mm, h=720mm, t=575mm, be=0mm, te=0mm, r=200mm, CONSTRUCTION_ID=R

Comments:

CONSTRUCTION_ID = N also if

b = t, be = te

Basic shape 18

Parameters: b=width(carcase) h=height t=depth(carcase) be=corner width b1=width1 te=corner depth t1=depth1 value range for CONSTRUCTION_ID: L,R,J

Example:

b=900mm, h=720mm, t=900mm, be=0mm, te=0mm, b1=300mm, t1=300mm, CONSTRUCTION_ID=N

Comments:

This basic shape is primarily intended for corner cabinets.

CONSTRUCTION_ID = N also if

b = t, be = te, b1 = t1

Basic shape 19

Parameters: b=width(carcase) h=height t=depth(carcase) be=corner width te=corner depth r=radius value range for CONSTRUCTION_ID: N,L,R,J

Example:

b=900mm, h=720mm, t=900mm, be=70mm, te=70mm, r=300mm, CONSTRUCTION_ID=N

Comments:

This basic shape is primarily intended for corner cabinets.

CONSTRUCTION_ID = N also if

b = t, be = te

Basic shape 20

Parameters: b=width(carcase) h=height t=depth(carcase) be=corner width te=corner depth b1=width1 t1=depth1 value range for CONSTRUCTION_ID: N,L,R,J

Example:

b=900mm, h=720mm, t=900mm, be=0mm, te=0mm, b1=600mm, t1=600mm, CONSTRUCTION_ID=N

Comments:

This basic shape is primarily intended for corner cabinets.

CONSTRUCTION_ID = N also if

b = t, be = te, b1 = t1

Basic shape 21

Parameters: b=width(carcase) h=height t=depth(carcase) be=corner width te=corner depth b1=width1 b2=width2 b3=width3 t1=depth1 t2=depth2 t3=depth3 value range for CONSTRUCTION_ID: N,L,R,J

Example:

b=900mm, h=720mm, t=900mm, te=0mm, be=0mm, b1=600mm, b2=150mm, b3=150mm, t1=150mm, t2=150mm, t3=600mm, CONSTRUCTION_ID=N

Comments:

This basic shape is primarily intended for corner cabinets.

CONSTRUCTION_ID = N also if

b = t, be = te, b1 = t3; b3 = t1, b2 = t2

b must equal b1+b2+b3 and t=t1+t2+t3

Basic shape 22

Parameters: b=width h=height t=depth be=corner width te=corner depth b1=width1 b2=width2 r=radius value range for CONSTRUCTION_ID: N,L,R,J

b=900mm, h=720mm, t=900mm, te=0mm, be=0mm, b1=600mm, b2=250mm, t1=250mm, t3=600mm, r=50mm, CONSTRUCTION_ID=N

Comments:

This basic shape is primarily intended for corner cabinets.

CONSTRUCTION_ID = N also if

b = t, be = te, b1 = t2, b2 = t1

b must equal b1+r+b2 and t=t1+t2+r

Basic shape 23

Parameters: b=width h=height d=depth wc=corner width dc=corner depth w1=width1 w2=width2 r=radius value range for CONSTRUCTION_ID: N,L,R,J

b=900mm, h=720mm, t=900mm, te=0mm, be=0mm, b1=600mm, b2=100mm, t1=100mm, t3=600mm, r=200mm, CONSTRUCTION_ID=N

Comments:

This basic shape is primarily intended for corner cabinets.

CONSTRUCTION_ID = N also if

b = t, be = te, b1= t2, b2 = t1

b must equal wb+r+b2 and t=t1+t2+r

Basic shape 24

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 a=angleα value range for CONSTRUCTION_ID: N,L,R,J

Filler [image] Filler profile

b=90mm, h=720mm, t=67mm, b1=14mm, b2=14mm, b3=57mm, b4=57mm, t1=380mm, t2=380mm, a=135°, CONSTRUCTION_ID=N

b=900mm, h=720mm, t=670mm, b1=140mm, b2=140mm, b3=570mm, b4=570mm, t1=380mm, t2=380mm, a=135mm, CONSTRUCTION_ID=N

Comments:

CONSTRUCTION_ID = N also if

b = t, t1 = t2, b1 = b2, b3 = b4 and a = 135°

Basic shape 25

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 a=angleα value range for CONSTRUCTION_ID: N,L,R,J

b=900mm, h=720mm, t=670mm, te=0mm, b1=140mm, b2=140mm, b3=570mm, b4=570mm, t1=380mm, t2=380mm, a=135mm, CONSTRUCTION_ID=N

Comments:

CONSTRUCTION_ID = N also if

b = t, t1 = t2, b1 = b2, b3 = b4 and a = 135°

Basic shape 26

Parameters: b=width h=height(total) t=depth b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 h1=cabinets height value range for CONSTRUCTION_ID: N

w=1100mm, h=560mm, d=1100mm, w1=1555mm, w2=400mm, w3=600mm, w4=400mm, d1=300mm, d2=400mm, h1=590mm, CONSTRUCTION_ID=N

Comments:

b must be equal to t.

Basic shape 27

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 t1=depth1 value range for CONSTRUCTION_ID: L,R,J

b=1300mm, h=720mm, t=700mm, b1=600mm, b2=600mm, b3=750mm, t1=600mm CONSTRUCTION_ID=R

Comments:

A front partition refers to the surface characterized by the parameter b2.

Basic shape 28

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 h1=height1 h2=height2 value range for CONSTRUCTION_ID: L,R,J

b=1100mm, h=720mm, t=700mm, b1=500mm, b2=600mm, h1=500mm, h2=220mm CONSTRUCTION_ID=L

Basic shape 29

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 h1=height1 h2=height2 value range for CONSTRUCTION_ID: N

b=900mm, h=715mm, t=450mm, b1=0mm, b2=450mm, h1=615mm, h2=100mm CONSTRUCTION_ID=N

b=900mm, h=715mm, t=450mm, b1=400mm, b2=250mm, h1=615mm, h2=100mm CONSTRUCTION_ID=N

Comments:

w2 must equal (w-w1)/2.

Basic shape 30

Parameters: b=width h=height t=depth(carcase) h1=height1 h2=height2 h3=height3 t1=depth1 t3=depth3 value range for CONSTRUCTION_ID: N

b=600mm, h=715mm, t=365mm, h1=0mm, h2=515mm, h3=200mm, t1=365mm , t3=150mm CONSTRUCTION_ID=N

Comments:

h must equal h1+h2+h3.

Basic shape 51

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 value range for CONSTRUCTION_ID: L,R

Example:

b=600mm, h=50mm, t=1200mm, b1=200mm, b2=400mm, b3=500mm CONSTRUCTION_ID=N

Comments:

is used if a filler is installed to close the gap to the wall.

A door (parameter 1) to the wall can be used instead of a filler.

Basic shape 52

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 value range for CONSTRUCTION_ID: L,R

Comments:

is used if a filler is not installed to close the gap to the wall.

Carcase material or, if suitable, a visible side (parameter 1) to the wall can be used instead of a filler.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Basic shapes for worktops and tables
View with Navigation Tools
Introduction > Basic shapes > Basic shapes for worktops and tables

Basic shape 31

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 t3=depth3 t4=depth4 value range for CONSTRUCTION_ID: N,L,R,J

b=1200mm, h=40mm, t=1200mm, b1=250mm, b2=250mm, b3=250mm, b4=250mm, t1=250mm, t2=250mm, t3=250mm, t4=250mm, CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

CONSTRUCTION_ID = N only if

b1 = b2, b3 = b4, t1 = t2, t3 = t4

Basic shape 32

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 t3=depth3 t4=depth4 value range for CONSTRUCTION_ID: N,L,R,J

b=1200mm, h=40mm, t=1200mm, b1=250mm, b2=250mm, b3=250mm, b4=250mm, t1=250mm, t2=250mm, t3=250mm, t4=250mm, CONSTRUCTION_ID=R

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 33

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 b4=width4 b5=width 5 t1=depth1 t2=depth2 t3=depth3 t4=depth4 t5=depth5 value range for CONSTRUCTION_ID: N,L,R,J

b=900mm, h=40mm, t=1500mm, b1=100mm, b2=100mm, b3=100mm, b4=100mm, b5=400mm, t1=100mm, t2=100mm, t3=100mm, t4=100mm, t5=500mm CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

CONSTRUCTION_ID = N only if

b1 = b2, b3 = b4, t1 = t2, t3 = t4

Basic shape 34

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 t3=depth3 t4=depth4 a=angleα value range for CONSTRUCTION_ID: L,R,J

b=900mm, h=50mm, t=1500mm, b1=600mm, b2=100mm, b3=100mm, b4=600mm, t1=700mm, t2=100mm, t3=100mm, t4=400mm, a=135° CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 35

Parameters: b=width h=height t=depth a=angleα value range for CONSTRUCTION_ID: N

b=1200mm, h=40mm, t=600mm, a=90° CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 36

Parameters: b=width h=height t=depth value range for CONSTRUCTION_ID: N

b=800mm, h=40mm, t=800mm, CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 37

Parameters: b=width h=height b1=width1 t1=depth1 d=diameter value range for CONSTRUCTION_ID: L,R,J

b=800mm, h=40mm, t=800mm, b1=550mm, t1=190mm, CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 38

Parameters: b=width h=height t=depth b1=width1 value range for CONSTRUCTION_ID: L,R,J

b=600mm, h=40mm, t=1200mm, b1=400mm, CONSTRUCTION_ID=R

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 39

Parameters: b=width h=height t=depth b1=width1 t1=depth1 t2=depth2 r=radius a=angleα value range for CONSTUCTION_ID:L,R,J

b=900mm, h=50mm, t=1500mm, b1=700mm, t1=400mm, t2=600mm, r=1500mm, a=135°, CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 40

Parameters: b=width h=height t=depth b1=width1 t1=depth1 r=radius value range for CONSTUCTION_ID:N,L,R,J

b=600mm, h=50mm, t=1200mm, b1=200mm, t1=30mm, r=200mm CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

CONSTRUCTION_ID = N also if

b1 = 0, t1 = 0, r=b/2

Basic shape 41

same as basic shape 31, but parameters w and d are reversed.

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 t3=depth3 t4=depth4 value range for CONSTRUCTION_ID: N,L,R,J

b=1200mm, h=40mm, t=1200mm, b1=250mm, b2=250mm, b3=250mm, b4=250mm, t1=250mm, t2=250mm, t3=250mm, t4=250mm, CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

CONSTRUCTION_ID = N only if

b1 = b2, b3 = b4, t1 = t2, t3 = t4

Basic shape 42

same as basic shape 32, but parameters w and d are reversed.

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 t3=depth3 t4=depth4 value range for CONSTRUCTION_ID: L,R,J

b=1500mm, h=40mm, t=900mm, b1=100mm, b2=100mm, b3=100mm, b4=500mm, t1=100mm, t2=100mm, t3=100mm, t4=600mm, CONSTRUCTION_ID=R

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 43
same as basic shape 33, but parameters w and d are reversed.

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 b4=width4 b5=width 5 t1=depth1 t2=depth2 t3=depth3 t4=depth4 t5=depth5 value range for CONSTRUCTION_ID: N,L,R,J

b=1500mm, h=40mm, t=900mm, b1=100mm, b2=100mm, b3=100mm, b4=100mm, b5=400mm, t1=100mm, t2=100mm, t3=100mm, t4=100mm, t5=500mm CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

CONSTRUCTION_ID = N only if

b1 = b2, b3 = b4, t1 = t2, t3 = t4

Basic shape 44
same as basic shape 34, but parameters w and d are reversed.

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 t3=depth3 t4=depth4 a=angleα value range for CONSTRUCTION_ID: L,R,J

b=1500mm, h=50mm, t=900mm, b1=700mm, b2=100mm, b3=100mm, b4=400mm, t1=600mm, t2=100mm, t3=100mm, t4=600mm, a=135°, CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 45
same as basic shape 35, but parameters w and d are reversed.

Parameters: b=width h=height t=depth a=angleα value range for CONSTRUCTION_ID: N

b=600mm, h=40mm, t=1200mm, a=90° CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 46
same as basic shape 36, but parameters w and d are reversed.

Parameters: b=width h=height t=depth value range for CONSTRUCTION_ID: N

b=800mm, h=40mm, t=800mm, CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 47
same as basic shape 37, but parameters w and d are reversed.

Parameters: b=width h=height d=diameter b1=width1 t1=depth1 value range for CONSTRUCTION_ID: L,R,J

b=800mm, h=40mm, t=800mm, b1=190mm, t1=550mm, CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 48
same as basic shape 38, but parameters w and d are reversed.

Parameters: b=width h=height t=depth t1=depth1 value range for CONSTRUCTION_ID: L,R,J

b=1200mm, h=40mm, t=600mm, t1=400mm, CONSTRUCTION_ID=R

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 49
same as basic shape 39, but parameters w and d are reversed.

Parameters: b=width h=height t=depth b1=width1 b2=width2 t1=depth1 r=radius a=angleα value range for CONSTUCTION_ID:L,R,J

b=1500mm, h=50mm, t=900mm, b1=400mm, b2=600mm, t1=700mm, r=1500mm, a=135°, CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 50
same as basic shape 40, but parameters w and d are reversed.

Parameters: b=width h=height t=depth b1=width1 t1=depth1 r=radius value range for CONSTUCTION_ID:N,L,R,J

b=1200mm, h=50mm, t=600mm, b1=30mm, t1=200mm, r=200mm CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

CONSTRUCTION_ID = N also if

b1 = 0, t1 = 0, r=t/2


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Language key
View with Navigation Tools
Introduction > Language key
Language key | Language name
AA | Afar
AB | Abkhasian
AE | Avestan
AF | Afrikaans
AM | Amharic
AN | Aragonese
AR | Arabic
AS | Assam
AY | Aymara
AZ | Azerbaijanian
BA | Baschkirian
BE | Byelorussian
BG | Bulgarian
BH | Biharic
BI | Bislamic
BM | Bambara
BN | Bengal
BO | Tibetan
BR | Breton
BS | Bosnian
CA | Catalan
CE | Circassian
CH | Chamorro
CO | Corsican
CS | Czech
CU | Old slavish
CV | Chuvash
CY | Welsh
DA | Danish
DE | German
DV | Dhivehi
DZ | Dzongkha
DV | Dhivehi
EE | Estonian
EL | Greek
EN | English
EO | Esperanto
ES | Spanish
ET | Estonian
EU | Basque
FA | Persian
FF | Fulfulde
FI | Finno-Ugric
FJ | Fiji
FO | Faroese
FR | French
FY | Frisian
GA | Irish
GD | Gaelic
GL | Galician
GN | Guarani
GU | Gujaratic
GV | Manx, Manx-Gaelic
HA | Hausa
HE | Hebrew
HI | Hindi
HO | Hiri Motu
HR | Croatian
HT | Haitian
HU | Hungarian
HY | Armenian
HZ | Herero
IA | Interlingua
ID | Indonesian
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiak
IN | former Indonesian
IO | Ido
IS | Icelandic
IT | Italian
IU | Inuit
JA | Japanese
JV | Javanese
KA | Georgian
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kazakh
KL | Kalaallisut (Greenland)
KM | Cambodian
KN | Canadian
KO | Korean
KR | Kanuri
KS | Kashmirian
KU | Kurdish
KV | Komi
KW | Cornish
KY | Kirghiz
LA | Latin
LB | Luxembourgish
LG | Luganda
LI | Limburg
LN | Lingala
LO | Laotian
LT | Lithuanian
LU | Kiluba
LV | Lett
MG | Malagasy
MH | Marshallese
MI | Maori
MK | Macedonian
ML | Malay
MN | Mongolian
MO | Moldovan
MR | Marathi
MS | Malayan
MT | Maltese
MY | Burmese
NA | Nauruan
NB | Norwegian Bokmål
ND | North Ndebele
NE | Nepalese
NG | Ndonga
NL | Dutch
NN | Norwegian Nynorsk
NO | Norwegian
NR | South Ndebele
NV | Navajo
NY | Chichewa
OC | Occitan
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Punjab
PI | Pali
PL | Polish
PS | Paschtu
PT | Portugese
QU | Quechua
RM | Rhaeto-Romanic
RN | Kirundisch
RO | Romanian
RU | Russian
RW | Kijarwanda
SA | Sanskrit
SC | Sardinian
SD | Sinto
SE | North Sami
SG | Sango
SI | Sinhalese
SK | Slovakian
SL | Slovenian
SM | Samoan
SN | Shonian
SO | Somali
SQ | Albanian
SR | Serbian
SS | Swazi
ST | Sesothisch
SU | Sudanese
SV | Swedish
SW | Swahili
TA | Tamil
TE | Tegulu
TG | Tajik
TH | Thai
TI | Tigrinja
TK | Turkmenian
TL | Tagalog
TN | Sezuan
TO | Tongan
TR | Turkish
TS | Tongan
TT | Tartary
TW | Twi
TY | Thai
UG | Uighur
UK | Ukranian
UR | Urdu
UZ | Uzbek
VI | Vietnamese
VO | Volapük
WA | Walloon
WO | Wolof
XH | Xhosa
YI | Yiddish
YO | Joruba
ZA | Zhuang
ZH | Chinese
ZU | Zulu


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Country code
View with Navigation Tools
Introduction > Country code

country code | country (German) | country (English)
AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Buying associations
View with Navigation Tools
Introduction > Buying associations

Buying association customer | Name buying association | Street | Postal Code | City | Phone | Fax
AMBRA | AMBRA Vertriebsgesellschaft mbH & Co. KG | Pfälzer Straße 10 | 33332 | Gütersloh | +49(5241)9246-0 | +49(5241)9246-49
AMM | Alliance Möbel-Marketing GmbH & Co.KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
ANT | ANTARES Einkaufs- und Marketinggesellschaft GmbH & Co. KG | Ramlinger Str. 50 | 31303 | Burgdorf-Ehlershausen | +49(5085)955887 | +49(5085)-955885
ASSIMA | ASSIMA Verbund GmbH & Co. KG | Bussardweg 18 | 41468 | Neuss | +49(2131)310400 | +49(2131)310469
ATLAS | Atlas-Einrichtungs-Einkauf GmbH | Brunshofstr. 2 | 45470 | Mülheim a. d. Ruhr | +49(208)992400 | +49(208)9924099
AWD | AWD Einkaufs- und Marketinggesellschaft für Wohnkomfort mbH | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
BAUR | Baur Friedrich GmbH Zentraleinkauf | Bahnhofstr. 10 | 96224 | Burgkunstadt | +49(9572)912739 o. 912746 | +49(9572)912006
BEGROS | Begros GmbH | Graf-Zeppelin-Str. 5 | 46149 | Oberhausen | +49(208)99493-0 | +49(208)99493-911
BETTENKREIS | BETTENKREIS GmbH & Co. | Pascalstr. 4 | 47506 | Neukirchen-Vluyn | +49(2845)9134-0 | +49(2845)9134-34
BETTENRING | BETTENRING eG | Echterdinger Str. 115 | 70794 | Filderstadt | +49(711)70958-0 | +49(711)70958-66
BRANION | BRANION GmbH | Soennecken-Platz | 51491 | Overath | +49(2206)607-0 | +49(2206)607-199
BÜRORING | BÜRORING eG | Siemensstr. 7 | 42781 | Haan | +49(2129)5571-0 | +49(2129)5571-93
CI | Createive Inneneinrichter | Spreestr. 3 | 64295 | Darmstadt | +49(6151)39128-0 | +49(6151)39128-28
CON | Concorde Möbel-Einkaufs-GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | 0211-47236-0 | 0211-4180034
CP | CREATIVE PARTNEr Service- und Einkaufs-Kooperation GmbH | Otto-Hahn-Str. 6 d | 21509 | Glinde | +49(40)728161-0 | +49(40)728161-21
DKR | Der Küchenring GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
DMV | DEUTSCHER MÖBEL-VERBUND Handels GmbH | Ampertal 8 | 85777 | Fahrenzhausen-Unterbruck | +49(8133)89-0 | +49(8133)-89-199
DSM | Drosser & Schaffer Marketing GmbH | Würmstr. 13A | 82166 | Gräfelfing | +49(89)89878434/-26 /-28 | +49(89)89878440
DU | DECOR UNION GmbH & Co. KG | Brüsseler Str. 3 | 30539 | Hannover | +49(511)8789-0 | +49(511)8789-299
EBUCH | ebuch eG | O'Brien-Str. 3 | 91126 | Schwabach | +49(9122)9386-0 | +49(9122)9386-68
EDE | Einkaufsbüro Deutscher Eisenhändler GmbH | Dieselstr. 33 | 42389 | Wuppertal | +49(202)6096-0 | +49(202)6096-331
EGEPACK | EGEPACK Einkaufs- und Vertriebsgesellschaft mbH | Bödekerstr. 7 | 30161 | Hannover | +49(511)38841-03 / -04 | +49(511)3884064
EIS | E.I. S. GmbH | Von-Hünefeld-Str. 41 | 50829 | Köln | +49(211)59797-44 / -45 | +49(211)59797-21
EK | Grosseinkauf eG | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-144
EKAFLOR | ekaflor GmbH & Co. KG | Watzmannstr. 3 | 90471 | Nürnberg | +49(911)981166-0 | +49(911)981166-5
ELTKONTOR | ELTKONTOR GmbH & Co. KG | Oldenburger Allee 21 | 30659 | Hannover | +49(511)61599-0 | +49(511)61599-77
EM | Europa Möbel | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EMV | Europa Möbel-Verbund (EMV) | Ampertal 8 | 85777 | Fahrenzhausen-Unterbrück | +49(8133)89-0 | +49(8133)89-199
ESG | ESG Einkaufs- und Service Gesellschaft mbH | Berliner Str. 26 | 33378 | Rheda-Wiedenbrück | +49(5242)9453-0 | +49(5242)9453-53
EUROKON | EUROPA-KONTOR GmbH & Co. KG | Amsterdamer Str 230 | 50735 | Köln | +49(221)971491-21 | +49(221)971491-60
EUROPA | GROSSEINKAUF EUROPA MÖBEL GmbH & Co. KG | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EVB | EVB BauPunkt Einkaufs- und Handelsgemeinschaft GmbH & Co. KG | Zillenhardtstr. 46 | 73037 | Göppingen | +49(7161)99931-70/ -71 | +49(7161)99931-72
EWEPA | E W E P A GmbH | Oberevinger Str. 5 | 44339 | Dortmund | +49(231)985127-0 | +49(231)-985127-17 / -18
FHG | FHG Fach-Handels-gesellschaft mbH & Co. KG | Brühler Str. 55/58 | 42657 | Solingen | +49(212)24809-0 | +49(212)24809-119
FHR | F H R Fachhandelsring GmbH | Am Pfaffensee 4 | 67376 | Harthausen | +49(6344)9533-0 | +49(6344)9533-90
FS | "FÜR SIE" Handelsgenossenschaft eg Food-Non Food | An der Münze 12-18 | 50668 | Köln | +49(221)16041-0 | +49(221)16041-821
GARANT | GARANT-MÖBEL-MARKETING LAUTEN GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
GEDK | Ge-dk Unternehmensbetreuungsgesellschaft mbH | Includes shape and material | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
GFM | G f M Möbeleinkaufsverbund GmbH & Co. Betriebs KG | Donaustr. 15 | 93333 | Neustadt a. d. D. | +49(9445)204-0 | +49(9445)204-155
HBO | H.B.O. Einkauf + Marketing GmbH & Co. | Dietrichsweg 64 | 26127 | Oldenburg | +49(441)96182-0 | +49(441)96182-55
HIS | Home in style Raumgsestaltung GmbH & Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-370 | +49(7231)915-259
HLH | HolzLand Holzhandels GmbH | Friedrich-Engels-Allee 432 | 42283 | Wuppertal | +49(202)55138-0 | +49(202)55138-10
HOLZRING | DER HOLZRING Handelsgesellschaft mbH | Universitätsallee 5 | 28359 | Bremen | +49(421)22315-0 | +49(421)22315-11
INKU | INKU GmbH + Co. | Nikolaus-Otto-Str. 6 | 70771 | Leinfelden-Echterdingen | +49(711)9492-438 | +49(711)9192-436
KA | K + A Küchen Aktuell GmbH | Senefelder Str. 2 a | 38124 | Braunschweig | +49(531)26134-0 | +49(531)26134-39
KAK | Küchen-Aktiv-Kreis | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KAREAL | Küchen Areal GmbH & Co. KG | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-163 | +49(5242)409-202
KARST | Karstadt Warenhaus AG | Theresienhöhe 5 | 80339 | München | +49(89)5105-0 | +49(89)5105-300
KATAG | KATAG International Partners GmbH | Stralsunder Str. 5 | 33605 | Bielefeld | +49(521)292-0 | +49(521)292-101/299
KAUFRING | KAUFRING AG | Kieshecker Weg 100 | 40468 | Düsseldorf | +49(211)4242-0 | +49(211)4242-444
KC | Küche & Co |  |  |  |  |
KER | Küchen-Einkaufs-Ring | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KGA | Koop Garant/Areal: EK-Grosseinkauf | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-559
KIG | Küchen-Interessen-Gesellschaft mbH | Strauberger Platz 19 | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
KL | Küchenliga | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
KOA | Koop Alliance FUTURA einkaufs-Gesellschaft mbH & Co. KG | Rolshoverstr. 227 | 51072 | Köln-Poll | +49(221)9836666 | +49(221)9836667
KP | Küchen Partner AG | Rüdesheimer Str. 34 | 65239 | Hochheim am Main | +49(6146)8340-0 | +49(6146)8340-40
KREIS | "DER KREIS" Einkaufsgesellschaft für Küche & Wohnen mbH & Co. KG | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)606700 | +49(7152)73017
KTEM | KTEM | Heemstr. 4 | 27793 | Wildeshausen | +49(4431)92067 | +49(4431)92069
LGF | MeisterTeam LGF GmbH | Rotenhäuser Str. 12 | 21109 | Hamburg | +49(40)7534091 | +49(40)7522019
LUTZ | LUTZ |  |  |  |  |
MBV | MBV Marketing Gesellschat mbH & Co. Lichthauspartner KG | Zeiloch 13 | 76643 | Bruchsal | +49(7251)7240890 | +49(7251)72408979
MDM | Küchenmarketing MDM GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
MHKD | musterhaus küchen Deutschland GmbH & Co. KG | Im Gefierth 9a | 36603 | Dreieich | +49(6103)391-0 | +49(6103)391-109
MIG | MIG Möbel-Interessen-Gemeinschaft GmbH & Co. KG | Industriestr. 41 | 53359 | Rheinbach | +49(2226)9221-0 | +49(2226)9221-22
MKK | Fachhändler Gemeinschaft "meister.Küchen-Konzepte" | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
MM | Möbel Mann GmbH | Durlacher Allee 109 | 76137 | Karlsruhe | +49(721)6096-298 | +49(721)6096-557
MON | Mondial GmbH | Eichsfelder Str. 17 | 40595 | Düsseldorf (Garath) | +49(211)702621-13 | +49(211)702621-30
MP | www.mig-power.de GmbH & Co.KG | Aktienstr. 2 | 45359 | Essen | +49(201)811710 | +49(201)2699838
MSI | Musterring International Josef Höner GmbH & Co. KG | Hauptstr. 134-140 | 33378 | Rheda-Wiedenbrück | +49(5242)592-01 | +49(5242)592-149
MV | Mega Verbund AG | St- Alban-Vorstadt 94 | CH-4052 | Basel | +41(61)2069070 | +41(61)-2069079
MZE | M Z E - Möbel-Zentral-Einkauf GmbH | Loheg 31 | 85375 | Neufarn b. Freising | +49(8165)9526-0 | +49(8165)9526-50
NB | Nürnberger Bund Grosseinkauf eG | Theodor-Althoff-Str. 39 | 45133 | Essen | +49(201)8709-0 |
NECK | Neckermann Versand AG | Hanauer Landstr. 360-400 | 60386 | Frankfurt/Main | +49(69)404-8697 | +49(69)404-8508
NOWEDA | NOWEDA eG | Heinrich-Strunk-Str. 77 | 45143 | Essen | +49(201)802-0 | +49(201)802-1314
NREM | nrc Nordring Einkauf- und Marketing-Cooperation GmbH | Am Redder 1 | 24558 | Henstedt-Ulzburg | +49(4193)9585-0 | +49(4193)9585-25
NWH | NORDWEST Handel AG | Berliner Str. 26-36 | 58135 | Hagen | +49(2331)461-0 | +49(2331)461-389
ÖkoPlus | ÖkoPlus AG Fachhandelsverbund für Ökologisches Bauen + Wohnen | Kasseler Str. 1 A | 60486 | Frankfurt | +49(69)70793013 | +49(69)70793016
OTTO | Otto Versand | Wandsbecker Str. 3-7 | 22179 | Hamburg | +49(40)64610 | +49(40)64618571
PARMA | parma-Aurel GmbH & Co. KG | Grosse-Kurfürsten-Str. 75 | 33615 | Bielefeld | +49(521)52077-0 | +49(521)52077-77
PRISMA | PRISMA Einkaufs- und Marketinggesellschaft mbH | Amsterdamer Str. 230 | 50735 | Köln | +49(221)971410-9 | +49(221)971410-84
ProÖko | Pro Öko Servicegesellschaft ökologischer Einrichtungshäuser mbH | Subbelrather Str. 24 | 50823 | Köln | +49(221)56968-0 | +49(221)56968-21
QUE | Grossversandhaus Quelle, Gustav Schickedanz KG | Thomas-Mann-Str. 50 | 90329 | Nürnberg 50 | +49(911)8152150 | +49(911)8152036
RED | Reddy Küchen und Elektro Vertriebs GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
REGENT | REGENT MÖBEL Grosseinkauf GmbH & Co. KG | Benzstr. 4 | 45891 | Gelsenkirchen | +49(209)9705-0 | +49(209)9705-188
SHK | S H K Einkaufs- und Vertriebsgesellschaft mbH & Co. KG | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
SOFATEX | sofatex Leistungsgemeinschaft GmbH | E.-C.-Baumann-Str. 12 | 95326 | Kulmbach | +49(9221)80064 | +49(9221)80066
SÜDRING | Südring GmbH & Co. KG | Nordstr. 71 | 63450 | Hanau | +49(6181)9104-0 | +49(6181)9104-44
TEV | Textil-Einkaufsverband "NORDWEST" eG | Nordweststr. | 59387 | Ascheberg | +49(2593)818 | +49(2593)7085
TREND | TReND Möbel-Handels-GmbH & Co. Einrichtungs KG | Im Lipperfeld 42 | 46047 | Oberhausen | +49(208)8205-0 | +49(208)8205-210
UNION | UNION Einkaufs GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | +49(211)47236-0 | +49(211)4180034
UNITEX | u n i t e x Einkaufsverband GmbH | Albrecht-Berblinger-Str. 11 | 89231 | Neu Ulm-Schwaighofen | +49(731)707940 | +49(731)7079446 / 7079424
VAR | Varia KE Franchise Warenvertriebsgesellschaft mbH | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)6097-25 | +49(7152)73017
VE | Vesta Küchenhandels GmbH | Industriestr. 9 | 96114 | Hirschaid | +49(9543)842330 | +49(9543)842340
VKG | V K G Vereinigter Küchenfachhandel GmbH + Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-0 | +49(7231)915-160
VME | V M E Vereinigte Möbeleinkaufs-GmbH & Co. KG | An der Wesebreede 2 | 33699 | Bielefeld | +49(521)20885-0 | +49(521)20885-60
WGMEM | Wohngruppe Möbeleinkauf + Marketing GmbH | Schleifweg 10 | 74257 | Untereisesheim | +49(7132)9988-0 | +49(7132)9988-44
WK | WK - WOHNEN Einrichtungs-GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +496103)391-109
WOTEX | Wotex Intercolor | Pappelweg 11 | 66578 | Schiffweiler | +49(6821)9614-0 | +49(6821)9614-60


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Types of detail information
View with Navigation Tools
Introduction > Types of detail information

The following info types can be used to describe the type of detail information:

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Filename
View with Navigation Tools
Introduction > Filename

The following is recommended for the file name associated with a data record:

· The name of the data record must not be limited to 8 characters.

· If possible, all components from the CATALOG_IDENTIFICATION should be used:

· The following components are suggested:

· Manufacturer number

· IDM version

· Customer number (value from the ASSOC_CTM_NO element)

· All languages

· Year

· Major number (MAJOR)

· File release timestamp (FILE_RELEASE_DATE)


%%LocalItemTitle%%

IDM 2.7.0 XML-Schema
Elements
Element | Description
T_NEW_CATALOG | This element is used for storing and providing all information and data for the issuing of a complete catalogue/ database.
Complex Types
Complex Type | Description
languagetexte | This data type is used for multilingual text information of any length.
languagetexte30 | This element is used for multilingual text information limited to 30 characters.
languagetexte40 | This element is used for multilingual text information limited to 40 characters.
languagetexte60 | This element is used for multilingual text information limited to 60 characters.
languagetexte60999 | This element is used for multilingual text information limited to 60 characters per line. The maximum length of the complete element is limited to 999 lines.

© 2020 All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Element reference
View with Navigation Tools


%%LocalItemTitle%%

T_NEW_CATALOG Element

Collapse All Expand All View with Navigation Tools

IDM 2.7.0 XML-Schema : T_NEW_CATALOG Element

Description

This element is used for storing and providing all information and data for the issuing of a complete catalogue/ database.

Namespace

(none)

Diagram

Overview

T_NEW_CATALOG
This element is used for storing and providing all information and data for the issuing of a complete catalogue/ database.

MAJOR required Restriction of xs:positiveInteger

The version number "MAJOR" indicates the format version of the database. This main version number is only changed if the format is changed completely.
The complete definition of a format version consists of the following elements: MAJOR, MINOR and REVISION.

D nonNegativeInteger
P
M [2]

MINOR required Restriction of xs:nonNegativeInteger

In general the number of the sub-version "MINOR" changes every year. In case the main version number MAJOR is changed, the sub-version number is reset to 0.

D nonNegativeInteger
P
M [0:99]

REVISION required Restriction of xs:nonNegativeInteger

The revision number "REVISION" highlights changes during the year resultant from individual working groups. The revisions are not published if they are not concerned with necessary corrections. Revision is reset to 0 with each new "MINOR" sub-version number.

D nonNegativeInteger
P
M [0:99]

Sequence

Signature optional

This element defines the type of encryption.

The root element of a digital signature via XML is represented by the element Signature.

Signature has two child elements in which the elements SignedInfo and SignatureValue are mandatory.

Sequence

SignedInfo

The first and most complex element of Signature is the element SignedInfo. This element contains the utilized algorithms for canonization and signature, one or more references to the signed data, and probable transformations as well as the hash values of these data. Moreover the element SignedInfo contains all relevant information about the resources which are signed and is therefore the part for which the digital signature is defined.

Digital signature of the algorithms is used for the purpose of data security. A secure algorithm cannot be exchanged by an insecure without cancellation of the signature.

Child elements of SignedInfo are the mandatory elements CanonizationMethod and SignatureMethod as well as one or more Reference elements.

Sequence

CanonicalizationMethod Extension of xs:string

The mandatory element CanonizationMethod contains an Algorithm attribute which identifies the canonization algorithm which is applied to the data with priority over signature evaluation in the element SignedInfo.

The canonization of an XML is split up into the following actions:

A document is encoded into UTF-8 format
Line breaks are normalised to #xA before parsing
The values of attributes are normalised (similar to validating parsers)
Character- and parsed-entity references are replaced
CDATA paragraphs are replaced by their contents
The XML declaration and a probably existing DTD are removed
Blank elements are converted to start-end-tag pairs
Whitespace outside of the document element and inside the start- and end-tags is normalised
Whitespace in text knots is kept (except signs which were removed by the normalisation of line breaks)
The values of attributes are given in double quotation marks
Special characters in attribute values and text knots are replaced by sign references
Redundant namespace declarations in front of each element are removed
Default attributes are added to the elements
The sort order of namespace declarations and attributes is alphanumeric

Algorithm optional xs:anyURI

This attribute is used to identify the canonization algorithm that is applied to the data in SignedInfo prior to the signature calculation. It is specified as an URI.

D anyURI
P
M

SignatureMethod Extension of xs:string
SignatureMethod is another mandatory, blank element with an algorithm attribute, which defines the algorithm used for the generation (and following the validation) of the signature. This algorithm is used for converting the canonical element SignedInfo into the element SignatureValue.

Algorithm optional xs:anyURI

This attribute is used to specify the algorithm for signature generation via an URI.

D anyURI
P
M

Reference

The element reference defines the random data (binary data permitted, too) which are included in the signature calculation. The element reference is therefore the core element of a signature.

XML-signatures never sign the resources directly. First a list of hash values is generated. This list is signed with the defined algorithm. In this way the process of the signature generation is accelerated and simplified as a number of resources is signed simultaneously.

The element reference is linked to the optional attribute URI.

URI optional xs:string

The URI attribute is also of the anyURI type and contains the address under which the data to be signed are available. The data that relates to the digital signature do not necessarily have to be contained in the Signature element itself, but can also be referenced via the local file system or an URL.

There are also other URIs that refer to the current document, e.g. URI="". This specific Uniform Resource Identifier represents all XML nodes of the current document, but without any potentially existing comments. The nodes associated with the signature are however included in the selection.

D anyURI
P
M

Sequence

Transforms

The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.

Sequence

Transform Extension of xs:string

The Transform element is used to specify the transformations to be performed. It consists of an Algorithm attribute together with the applicable transformation algorithm.

D string
P
M

Algorithm optional xs:anyURI

This attribute is used for defining a transformation algorithm by means of an URI.

D anyURI
P
M

DigestMethod Extension of xs:string
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.

Algorithm optional xs:anyURI

This attribute is used for defining the URI which identifies the message digest algorithm.

D anyURI
P
M

DigestValue xs:string

The algorithm specified in DigestMethod is used to calculate DigestValue, a unique hash value of the signed object and to store it in this element via Base-64 encoding. The hash value, also known as digital fingerprint, is usually shorter than the signed data and can therefore be signed faster in the step to follow. It is virtually impossible to reconstruct the original message from a hash value. It should also be impossible for two different messages to result in identical hash values (collision and birthday paradox).

D string
P
M

SignatureValue xs:string

The SignatureValue element contains the signature's hash value calculated for the entire SignedInfo element in binary format (always Base-64 encoding). This hash value is calculated by the algorithm specified in SignatureMethod using the canonized data and private key. This means that the signature is not affixed to the message itself, but rather to the - usually much shorter - hash value (hash-then-sign paradigm).

The signed data thus contain additional information about the signed references and their hash values. This makes it unnecessary for the data to be present in the document. The information about the applied algorithms is however used in the calculation of the signature. This prevents manipulations down the track.

Because all references are pooled and signed collectively prior to signing, there is precisely one SignatureValue element for the entire signature.

D string
P
M

CATALOG
All administrative information about the catalogue/ database is stored in this element.

Sequence

FILE_RELEASE_DATE xs:dateTime

The FILE_RELEASE_DATE element should be activated automatically when data is exported and contain the current date and time (UTC).

D dateTime
P
M

CATALOG_IDENTIFICATION
This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.

Sequence

MANUFACTURER_ID Restriction of xs:nonNegativeInteger

This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros.

D nonNegativeInteger
P
M [0:9999]

ISO_LANGUAGE_ID 1..∞ Restriction of xs:language

The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements.

D language
P [A-Z]{2}
M [2:2]

CURRENCY_KEY Restriction of xs:string

This element is used for the definition of the currency ID which applies to all prices given in a catalogue/ database. The rules and definitions of the ISO Currency-ID apply.
A change of currency keys within one database is not permitted. Updates during the year and also block prices haven to be given in the same currency unit as that of the basic file.

D string
P [A-Z]{1,3}
M [1:3]

COUNTRY_ID Restriction of xs:string

This element is used to specify the correct country allocation where a language is spoken in multiple countries and the identical currency is specified. This requires entry of the ISO country code.

D string
P [A-Z]{2}
M [2:2]

CATALOG_KIND Restriction of xs:positiveInteger

This element is a mandatory field for identifying the type of catalogue. CATALOG_KIND has the values
1 for a basic catalogue
2 for an association catalogue
3 for a customer-specific catalogue.

D positiveInteger
P
M [1:3]

ASSOC_CTM_NO optional Restriction of xs:string

If 2 or 3 is entered in the CATALOG_KIND field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations")

D string
P
M [1:15]

PRODUCT_BRANDNAME Restriction of xs:positiveInteger

This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year.

D positiveInteger
P
M [1:999]

PRICE_ID Restriction of xs:positiveInteger

This element is used for the definition of a price ID, i.e. the way in which the prices in a catalogue are given.

The following price IDs are possible:
1 = Price;
2 = Ident number;
3 = calculation point.

If the flags 1 (price) or 2 (ident number) are filled in, a currency has to be filled in the
field CURRENCY_KEY. If the flag 3 (calculation point) is set, values in the element CURRENCY_KEY are not permitted. If ident numbers are used instead of prices the corresponding information of the ident number purchase price sheet, provided by the manufacturer, has to be filled in in the element PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER. If calculation points are used the the conversion factor has to be defined.

D positiveInteger
P
M [1:3]

VAT Restriction of xs:boolean

This element is used for the definition of the VAT key which is applied to the prices given in a database.
The following values are used:
0/False = prices excluding VAT
1/True = prices including VAT

This element is of essential importance for the pricing.

D boolean
P
M

CATALOG_NUMBER Restriction of xs:string

This element defines a distinct number for the catalogue which is represented in the database. The catalogue number is manufacturer specific.

D string
P
M [1:10]

CATALOG_YEAR xs:gYear

This element refers to the calendar year of the catalogue data.

D gYear
P
M

MAJOR_NO Restriction of xs:positiveInteger

The major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged.

D positiveInteger
P
M 1:99

CATALOG_NAME languagetexte30 Complex Type
This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,30}
M [1:30]

DATA_VERSION Restriction of xs:date

The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database.

D date
P
M

VALID_FROM_DATE Restriction of xs:date

This element defines the period of validity for the catalogue and corresponding database.

D date
P
M

FILE_ID Restriction of xs:boolean

This element defines if the database is a test or a released version.

0/false = test data
1/true = released data

D boolean
P
M

CATALOG_MARK Restriction of xs:string

This element is used to differ between the possible data types

B = block data with prices
K = catalogue data
V = block data without prices (notional prices are required)

D string
P [BKV]
M [1:1]

FILLING_LEVEL Restriction of xs:string

The filling level (FILLING_LEVEL) defines the level of details which are provided in a database. In general, an increase in the filling level corresponds with an increase in data quality. The higher the degree of detail specification in the data, the more specific they are for a certain manufacturer.
The different filling levels are evaluated during the certification procedure: By checking the filling levels it is ascertained which information is required in the data, in order to achieve the filling level. In case the required information is missing in a filling level, the complete set of data is not certified.
The filling levels are defined as follows:
- Filling level 1: provides basic information except from elements for the description of texture information
- Filling level 2a: filling level 1 is supplemented with information regarding textures and material (colours RGB,transparency and brightness)
- Filling level 2b: filling level 1 is amended with information about front division and front finishes
- Filling level 2c: filling level 1 is supplemented with information about handles.
- Filling level 2d: filling level 1 is amended with information about item textures.

Combinations of filling levels 2a-2d are possible. Following itemized breakdowns of combinations are defined:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Filling level 3. To achieve filling level 3 information in the filling levels 1 and 2a - 2d supplemented by information about the modeling graphic is required. In filling level 3 all options of the data format for manufacturer specific illustrations are entirely applied.
A complete definition of the information required for the different filling levels is provided in the table "Filling levels".

D string
P [123]|2[a-n]
M [1:2]

PRICING_TERMS optional Restriction of xs:string

This element defines the pricing terms for the catalog prices.
A complete definition of the information required for the dThis element defines the pricing terms for the catalog prices. The information in this field is used for a correct data import in order to avoid overwriting of price information.

The following values are used:
0 = prices in the catalogue are purchase prices for dealers
1 = prices in the catalogue are recommended retail prices (UPE)

All price information in the catalogue has to correspond to the information in this element.

D string
P [01]
M [1:1]

CATALOG_INFO languagetexte60999 Complex Type
Information texts are stored in this element.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute specifies the ISO code of the stored text's language.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information

SEQUENCE_NO required Restriction of xs:positiveInteger

This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in.

D positiveInteger
P
M

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,60}
M [1:60]

FALL_BACK_LANGUAGE optional Restriction of xs:language

This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The two-digit ISO language code must be used.

D language
P [A-Z]{2}
M [2:2]

DETAIL_INFOS 0..∞
This element is used for images of the manufacturer catalogue.

Sequence

DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.

DETAIL_INFO_NO required Restriction of xs:positiveInteger

This attribute is used for defining the identification number of the referenced detail information.

D positiveInteger
P
M [1:999999999]

SUPPLIER
All relevant supplier data, e.g. communication and contact details, are stored in this element.

Sequence

EDI_INFO 0..∞
The different possibilities of EDI-communication are defined in this element. For each EDI message of an EDI format exactly one element is defined.

Sequence

EDI_FORMAT optional Restriction of xs:string

The supported EDI-format is indicated in this field(e.g. EDIDATA).

D string
P EANCOM|EAN 97|EAN 97 A|EDIDATA
M [1:20]

EDI_FORMAT_VERSION optional Restriction of xs:string

This field contains the version of the EDI format defined in the field EDI_FORMAT.

D string
P [1-9]\.[0-9]{2}
M [1:10]

EDI_MESSAGE optional Restriction of xs:string

All different EDI messages supported by a manufacturer are indicated here (e.g. order, order response).

D string
P
M [1:20]

EDI_COMMUNICATION optional Restriction of xs:string

This is used to specify the method for EDI communications (e.g. X400, Telebox, email).

D string
P
M [1:20]

EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string

The address for the EDI communication is filled in here (e. g. X.400 address, E-mail address or 'on consultation').

D string
P
M [1:40]

EDI_CONTACT optional Restriction of xs:string

The name of a contact person who is responsible for all questions concerning the EDI communication is filled in into this field. This field is not delimited so that all necessary information (i.e. name, phone number etc.) can be entered into one field.

D string
P
M [1:60]

BRANCH_ID Restriction of xs:string

The different branches of manufacturers are indicated by the entries in this element.The following branches are currently differentiated:

A = worktop manufacturer
B = bathroom furniture manufacturer
G = appliance manufacturer
K = kitchen furniture manufacturer
O = office furniture manufacturer
P = upholstery manufacturer
S = sanitary manufacturer
W = manufacturer of living room furniture
Z = manufacturer of accessories

D string
P [ABGKOPSWZ]
M [1:1]

ISO_COUNTRY_ID Restriction of xs:string

Based on the standards of ISO-norm the country of the manufacturer's headquarter is defined here.

D string
P [A-Z]{2}
M [2:2]

GLN_NO optional Restriction of xs:string

The unambiguous Global Location Number (GLN) of a supplier is defined in this element. This unique identification of companies resp. company units is used especially for the automated electronic data exchange.

D string
P [0-9]{13}
M [13:13]

WEEE_NO optional Restriction of xs:string

The WEEE registration number of the supplier is defined in this element. This registration number is required for all manufacturers and importers of electronic devices according to the rules of the German "Elektro- und Elektronikgerätegesetz" (ElektroG).
The German standard of the WEEE numbering is built up in the following way: "DE12345678".
The validity of a WEEE No. can be checked on the internet homepage of "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de.

D string
P
M

CONTACT_PERSON 1..2
All information concerning the contact person is defined in this element.

Sequence

CONTACT_PERSON_NO Restriction of xs:positiveInteger

Priorities in contacting the manufacturer's contact persons are defined in this element (1=1. contact, 2=2. contact).

D positiveInteger
P
M [1:2]

CONTACT_ROLE Restriction of xs:string

The different roles of the manufacturer's contact persons are defined in this element, e.g. EDI specialist, substitute.

D string
P
M [1:60]

CONTACT_NAME Restriction of xs:string

The family name of the direct contact person for the software suppliers is defined in this element.

D string
P
M [1:20]

FIRST_NAME Restriction of xs:string

The first name of the direct contact person is entered here.

D string
P
M [1:20]

FORM_OF_ADDRESS Restriction of xs:positiveInteger

The correct address of the contact person is defined by the following values.
1 = Mrs
2 = Mr

D positiveInteger
P
M [1:2]

DEPARTMENT optional Restriction of xs:string

If applicable, the department of the contact person is defined in this field.

D string
P
M [1:15]

TELEPHONE Restriction of xs:string

This element contains the phone number of the contact person including international dialing code and area code, e. g.: +49(1234)56-7890.

D string
P
M [1:18]

FAX optional Restriction of xs:string

This element contains the fax number of the contact person including international dialing code and area code. e.g.: +49(5251)60-3284.

D string
P
M [1:18]

EMAIL optional Restriction of xs:string

This element contains the E-Mail address of the contact person.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M

STREET optional Restriction of xs:string

The street address of the manufacturer is defined in this element.

D string
P
M [1:30]

ZIPCODE_STREET optional Restriction of xs:string

The ZIP code for the street address of the manufacturer is defined in this element.

D string
P
M [1:8]

CITY optional Restriction of xs:string

The city name of the manufacturer's address is entered here.

D string
P
M [1:30]

CONTACT_SUPPLIER
All contact information for the specific manufacturer is defined in this element.

Sequence

MANUFACTURER_NAME_1 Restriction of xs:string

This element contains the first line of the manufacturer's name.

D string
P
M [1:30]

MANUFACTURER_NAME_2 optional Restriction of xs:string

This element contains the second line of the manufacturer's name.

D string
P
M [1:30]

EMAIL optional Restriction of xs:string

The official E-Mail address of the manufacturer is defined in this element.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

INTERNET_ADDRESS optional Restriction of xs:string

If applicable, the official homepage of the manufacturer is defined in this element (e.g.: http://www.company.com).

D string
P
M

STREET Restriction of xs:string

The street address of the manufacturer is defined in this element.

D string
P
M [1:30]

ZIPCODE_STREET Restriction of xs:string

The ZIP code for the street address of the manufacturer is defined in this element.

D string
P
M [1:8]

CITY Restriction of xs:string

The city name of the manufacturer's address is entered here.

D string
P
M [1:30]

ZIPCODE_POSTBOX optional Restriction of xs:string

If applicable, the ZIP code of the manufacturer's postbox address is entered here.

D string
P
M [1:8]

POSTBOX optional Restriction of xs:string

If applicable, the postbox number of the manufacturer's address is defined in this element. The word "postbox" has to be omitted.

D string
P [0-9a-zA-Z]{0,10}
M [0:10]

TELEPHONE_SWITCHBOARD Restriction of xs:string

This element contains the manufacturer's switchboard telephone number including international dialing code and area code, e.g.: +49(1234)56-7890.

D string
P
M [1:18]

FAX_SWITCHBOARD Restriction of xs:string

This element contains the manufacturer's switchboard fax number including international dialing code and area code, e. g.: +49(1234)56-7890.

D string
P
M [1:18]

GLOBAL_DEFINITION optional
This element is used for defining global data which apply to the complete catalogue/ database (global information).

Sequence

CLEARING_GROUP 0..∞
This element is used for the definition of clearing groups. Different exchange_IDs are summarized and made up to a clearing group (element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID).

The clearing groups in the block conditions (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) and the grading tables (BLOCK_VALUE_CALCULATION/GRADING_TABLE) are used for the definition of a minimum value for a certain type range. The different type ranges can be identified by their corresponding exchange_ID.

The single amounts of all items which belong to a certain exchange_ID are summarized. A total amount is summed up for each clearing group. This amount is defined as reference value for further use in block calculation and for the value clearing grading table.

CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger

This attribute identifies a clearing group.

D nonNegativeInteger
P
M [0:999]

Sequence

EXCHANGE_ID_REF 1..∞
This element references an exchange-ID.

EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger

This element contains the exchange_IDs which are combined to a clearing group. Values 0, 98 and 99 are not permitted.

D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

CLEARING_GROUP_NAME languagetexte60 Complex Type
Name for a clearing group. This is used in order to simplify data acquisition.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,60}
M [1:60]

FRONTS_HANDLE_POSITIONS optional
This element is used for the definition of handle positions, either basic or specific positions. The validity of a basic handle position is global, whereas the validity of a specific handle position is subject to special conditions.

Sequence

SPECIFIC_HANDLE_POSITIONS optional
Specific handle positions, changes of handle positions or changes of handles can be defined in this element. For all these cases the denotation “specific handle positon” is used. User-defined combinations of the different child elements are permitted. The more child elements are filled in, the more precise is the description of the specific handle position. The PRIORITY field (P1) and at least one key field have to be filled in.

Element paths
Path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/

Sequence

SPECIFIC_HANDLE_ORIENTATION 1..∞
This element defines a specific handle orientation.

SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger

This attribute identifies a specific handle orientation.

D nonNegativeInteger
P
M [0:99999]

Sequence

STYLE_REF optional
References are used for assigning specific handle orientations to specific programmes. If this element is not defined, the handle orientation is applicable for all programmes.

STYLE_NO required Restriction of xs:string

This attribute defines the referenced programme. It references to the attribute STYLE_NO in the element STYLE (Path1).

element paths:
path1: FEATURE_DEFINITION/OPTION_DEFINITION/

D string
P
M [1:5]

FRONT_TYPE_GROUP_REF optional
This element defines the front type group to which a special handle orientation applies. If this element is not defined the handle orientation is available for all front type groups

FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger

This attribute references the front type group.

D nonNegativeInteger
P
M [1:99]

WIDTH_FROM optional Restriction of xs:positiveInteger

The given measurement in this element defines the minimum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field require corresponding settings in the field WIDTH_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item.

D nonNegativeInteger
P
M [1:9999]

WIDTH_TO optional Restriction of xs:positiveInteger

The given measurement defines the maximum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field are required when the field WIDTH_FROM was filled in. The width is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item.

D nonNegativeInteger
P
M [1:9999]

HEIGHT_FROM optional Restriction of xs:nonNegativeInteger

The given measurement defines the minimum height (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field require corresponding settings in the field HEIGHT_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item.

D nonNegativeInteger
P
M [1:9999]

HEIGHT_TO optional Restriction of xs:nonNegativeInteger

The given measurement defines the maximum height(nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field are required when the field HEIGHT_FROM was filled in. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item.

D nonNegativeInteger
P
M [1:9999]

OPTION_REF
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (FEATURE_NO = 154) is defined for it.

FEATURE_NO required Restriction of xs:nonNegativeInteger

This attribute is used for the definition of an option type. Only feature type 154 is permitted.

D nonNegativeInteger
P
M [154:154]

OPTION_KEY required Restriction of xs:string

This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door"" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (154) is defined for it.

D string
P
M [1:5]

HANDLE_EXCHANGE optional
Specific conditions for a handle exchange are defined in this element. Further conditions defined in the element SPECIFIC_HANDLE_ORIENTATION have to be fulfilled.

Sequence

FEATURE_REF
This element references a feature type which is defined in the element FEATURE_DEFINITION/FEATURES/FEATURE.

FROM_HANDLE
This element defines which handle is exchanged.

TO_HANDLE
This element defines the handle which is used as a replacement.

HANDLE_ORIENTATION_EXCHANGE optional
This element defines the exchange of handle orientations.

Sequence

FROM_HANDLE_ORIENTATION_REF
This element defines for which basic handle orientations the specific handle orientation is valid. If the element is not filled in the specific handle orientation is valid for all basic handle orientations.
The handle orientation has to be defined in the element BASIC_HANDLE_POSITIONS (Path1).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITION

TO_HANDLE_ORIENTATION_REF
This element defines the handle orientation which is used as a replacement.

PRIORITY Restriction of xs:nonNegativeInteger

A priority of a handle orientation is defined in this field.
Per definition in the element SPECIFIC_HANDLE_ORIENTATION (Path 1) it is possible that several handle orientations are defined as valid handle orientations which would cause confusing and contradicting situations.
To avoid any ambiguities, priorities can be assigned to handle orientations.
The priority increases with the increase of the numerical values which are used for the definition of priorities. Several handle orientations can be summarized under one priority. Handle orientations with the same priority value require settings in the same key fields.

Element paths:
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS

D nonNegativeInteger
P
M [1:999]

BASIC_HANDLE_POSITIONS

This element is used to describe the position and alignment of handles installed on certain front types. The basic handle positions defined in this element are valid universally.

The basic handle positions should be guided by the pre-defined standard handle positions in the section named standard handle positions. Please note that 0 must not be used as a value for basic handle positions.

Sequence

HANDLE_ORIENTATION 1..∞
This element is a container element for the definition of different basic handle positions.

HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger

This attribute identifies a basic handle orientation.

D positiveInteger
P
M [1:9999]

Sequence

FRONT_TYPE 1..7
This element defines the handle position and handle orientation for each front type. The front type itself is defined in the attribute FRONT_TYPE_CODE.

FRONT_TYPE_CODE required Restriction of xs:string

Different handle orientation are assigned to different front types. The different front types are listed below:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation)

D string
P [SAKJTR]|GT
M [1:2]

Sequence

ORIENTATION Restriction of xs:string

This element is used for the differentiation of orientations.
H = horizontal
V = vertical

D string
P [HV]
M [1:1]

POSITION Restriction of xs:string

This element is used for the differentiation of handle positions in accordance with the chosen front type.

M = middle (e.g. for grip ledges without hinge)
A = exterior (e.g. for grip ledge, dependent on the hinge)
D = double (two handles at the exterior sides)
G =without drilling, with handle (handle is delivered, drilling on site)
0 (zero) = without drilling, without handle (handle is not delivered, no drillings provided)

In case of position A = exterior, the definite position is indicated by the hinge information , i.e. left/ right, for the item.

D string
P [MADG0]
M [1:1]

FRONT_TYPES_GROUPS optional
For an efficient use of front types in the definition of specific handle orientations in the element SPECIFIC_HANDLE_ORIENTATION (Path1) different front types can be combined to one front type group.

element paths path1:
GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS

Sequence

FRONT_TYPES_GROUP 1..99
This element defines a front type group.

FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger

This attribute identifies a front type group.

D nonNegativeInteger
P
M [1:99]

Sequence

FRONT_TYPE 1..7
This element defines the handle position and handle orientation for each front type. The front type itself is defined by the attribute FRONT_TYPE_CODE.

FRONT_TYPE_CODE required Restriction of xs:string

This element contains the different front types which are combined to a front type group. The following front types are defined:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation)

D string
P [SAKJTR]|GT
M [1:2]

FRONT_APPEARANCES optional
The different front appearances of a programme, an option, or an item are defined in this element. These front appearances are referenced by programmes (FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_APPEARANCE_REF), options (FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/FRONT_APPEARANCE_REF), or by items (SERIES/.../ITEM/FRONT_APPEARANCE_REF).
The basic definition of a front appearance consists of a basic shape number, assigned to a front element,and geometrical measurement information.

Sequence

FRONT_APPEARANCE 1..999
This element is used for the definition of a front appearance.

FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger

This attribute defines a specific ID for a front appearance which is referenced by styles and items.

D positiveInteger
P
M [1:999]

Sequence

FRONT_TYPE 1..900
The definition of front type 0 is used when all front elements have the same appearance irrespective of the used front type. In this case the definition of divergent front types is not permitted. If a front type has been defined for a front appearance_ID, data sets for all other front types are required.

Sequence

FRONT_TYPE_NO Restriction of xs:positiveInteger

This attribute defines the front type key.

D positiveInteger
P
M [0:1000]

Sequence 1..∞

FRONT_CONSTRAINTS optional
For the elements WIDTH_FROM/TO and HEIGTH_FROM/TO the following rules apply:

- If the elements WIDTH_TO or HEIGHT_TO are not defined, this equals the value "infinite"
- If the elements WIDTH_FROM or HEIGHT_FROM are not defined, this equals the value 0.
- The value 0 is not permitted in the elements WIDTH_FROM/TO or HEIGTH_FROM/TO.
- The intervalls have to cover the complete range
from 0 to infinite. Gaps are not permitted either

Sequence

WIDTH_FROM optional Restriction of xs:positiveInteger

The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm).

D positiveInteger
P
M [1:999999]

WIDTH_TO optional Restriction of xs:positiveInteger

The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm).

D positiveInteger
P
M [1:999999]

HEIGHT_FROM optional Restriction of xs:positiveInteger

The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm).

D positiveInteger
P
M [1:999999]

HEIGHT_TO optional Restriction of xs:positiveInteger

The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm).

D positiveInteger
P
M [1:999999]

FRONT_SHAPE
This element is used for the geometrical description of a front element.

Sequence

GLASS Restriction of xs:boolean

Values in this field indicate whether the front type is a glass front (value 1/true) or a simple front (value 0/false). For one front type the values in this element may not vary. This rule makes sure that a glass front is always depicted as glass front even when the programme has been changed.

D boolean
P
M

Choice

MODELING_GRAPHIC_ID optional Restriction of xs:string

This element may be used for the definition of a modeling graphic.

Further format definitions are required.

D string
P
M [1:15]

BASIC_FRONT_SHAPE optional
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".

MODULE_RULE_SET_DEFINITIONS optional
This element is used for the definition of the rules which apply to module cabinets and their components.

Sequence

MODULE_RULE_SET_DEFINITION 1..∞
This element is used for the definition of specifig rules for module cabinets and the single module parts. The defined module rules are referenced by items (SERIES/.../ITEM/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) or (SERIES/.../ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO.

MODULE_RULE_SET_NO required xs:nonNegativeInteger

This attribute defines the number of the rule set which references an item to the corresponding rule set.

D nonNegativeInteger
P
M

Sequence

MODULE_RULE_SET_NAME languagetexte60 Complex Type
This element defines the name of the module rule set.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,60}
M [1:60]

DETAIL_INFOS optional
This element is used for saving hyperlinks with detail information.

Sequence

DETAIL_INFO 1..∞

This element is used to define a detail information.

DETAIL_INFO_NO required Restriction of xs:positiveInteger

This attribute identifies detail information.

D positiveInteger
P
M [1:999999999]

Sequence

CLASSIFICATION Restriction of xs:string

This element is used for the classification of detail information.

D string
P
M [1:8]

INFO_TYPE Restriction of xs:positiveInteger

This element describes the type of detail information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous

D positiveInteger
P [1-9]|1[01]|99
M [1:11],99

EXTERNAL_NAME optional languagetexte Complex Type
Name of the link (e.g. "magic corner in motion").

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

D string
P
M

INTERNAL_NAME languagetexte40 Complex Type
Element for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,40}
M [1:40]

GUID Restriction of xs:string

This element assigns a globally unambiguous, and unique figure (Globally Unique Identifier (GUID))

The format of the GUID is defined as follows XXX-XXXX-XXXX-XXXX- XX. Each 'X' represents a character of the hexadecimal system, i.e. figures 0-9 or characters A-F. Example:
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-characters).

D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]

TOOL_TIP optional languagetexte Complex Type
Text information for a tool tip with reference to the link.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

D string
P
M

URL
This element contains the URL for the detail information.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:anyURI

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D anyURI
P
M [1:1024]

HASH_VALUE optional Restriction of xs:string

This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not.

D string
P
M [1:64]

RESOLUTION optional Restriction of xs:positiveInteger

This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file .

D positiveInteger
P
M [1:4]

PROPERTIES optional

This element is used to include additional information and characteristics, e.g. energy label, efficiency classes and similar data. Only the characteristics needed for correctly mapping the catalogue are defined.

The keys can be found in the corresponding table (information keys).

Sequence

PROPERTY 1..∞

This element is used to define a feature.

The key, text and measurement unit can be found in the correspondingtable (information keys)(information keys).

PROPERTY_NO required Restriction of xs:nonNegativeInteger

This attribute is used to identify the feature.

Its number can be found in the table with the information keys.

D nonNegativeInteger
P
M [0:999]

Sequence

PROPERTY_TEXT languagetexte Complex Type

This element contains text information about the characteristics.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

D string
P
M

PROPERTY_UNIT optional languagetexte30 Complex Type
If applicable, this element contains the measurement unit of the characteristic.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,30}
M [1:30]

GROUP_TITLES optional
This is a central point to store all kinds of descriptions for groups of optional and mandatory accessories.

Sequence

GROUP_TITLE 1..∞
This element is used to specify a group title.

GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger

This attribute is used to specify a unique number for later referencing of the group title.

D nonNegativeInteger
P
M [0-999]

Sequence

GROUP_TITLE_NAME languagetexte60 Complex Type
This element contains the name for groups of accessories.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,60}
M [1:60]

SERIES
This element is used for defining all series of a catalogue/ database including properties and assigned elements, e.g. product groups or items.

Sequence

SERIE 1..100
This element is used for the definition of the series.
Items belonging to series 0 are valid for all series. Therefore items of series 0 must not occur with the same type number (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in other series. Items of other series (unequal 0) may be used with the same type name in different series.
Buying prices are always indicated as the dealer’s buying prices

SERIE_NO required Restriction of xs:nonNegativeInteger

This attribute defines the serial number of the series.

D nonNegativeInteger
P
M [0:99]

Sequence

FEATURE_CLASS_REF optional
This element references the feature class which is assigned to the series.
It is used for assigning all legal variations of a series to this specific series.
The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all programmes and items of a series. Therefore it is not obligatory to state the features of a series in the order. However, in an order it is indispensable to state the sum of features for an item in combination with those of the series.
All features which are assigned to one series can be chosen from a list box while entering the variation header.

FEATURE_CLASS_NO required Restriction of xs:positiveInteger

This attribute references a feature class. A feature class is defined in the element FEATURE_CLASS (path1).

path1: FEATURE_DEFINITION/FEATURE_CLASSES/

D positiveInteger
P
M [1:999]

SERIES_NAME
This element defines the name of the series.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT_LINE
This element defines a text line.
The element TEXT contains text information.

Sequence

TEXT Restriction of xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

D string
P [\S ]{1,30}
M [1:30]

FULL_TEXT optional xs:string

This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

D string
P
M

PURCHASE_RETAIL_ID Restriction of xs:boolean

This element is used for defining series specific purchase and retail prices
0 = purchase price
1 = retail price
Depending on the price_ID (element PRICE_ID (path1)) the price is defined as follows

price-ID = 1 (price),the value set in the element ITEM_PRICE (path2) is used

price_ID = 2 (ident number), the price is made up from the values set in element IDENT_NUMBER/PRICE (path3), element ITEM_PRICE/PRICE_MINIMUM_BASIC (path2) or in element ADDITIONAL_PRICE (path5).

price_ID = 3 (calculation point), the price made up from the settings in the elements ITEM_PRICE (path2) or PRICE_MINIMUM_BASIC multiplied with the calculation factor, defined in element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR.

According to the key, only one kind of price calculation (combination of elements VAT (path4) and PURCHASE_RETAIL_ID (path4)) may be used within one series.
If a database contains purchase prices as well as retail prices, items with purchase price may not be assigned to the same calculation group(PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP)as items with retail prices.
This element is of major significance for the correct price calculation! Purchase prices are always given as retailers' purchase prices not manufacturers' purchase prices.

element paths
path1: CATALOG/CATALOG_IDENTIFICATION/
path2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/
path3: PRICE_DEFINITION/IDENT_NUMBERS
path4: CATALOG/CATALOG_IDENTIFICATION
path5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

D boolean
P
M

RESTRICTIONS optional
This element references restrictions which are specific for one series (series specific restriction).

The number of features selected in a planning is only valid, if none of the feature combinations is excluded by any of the restrictions. The result of all restrictions represents an intersection of the feature combinations.

Sequence

RESTRICTION_REF 0..∞
This element references a restriction which is assigned to a series (series specific restrictions).

The number of features selected in a planning is only valid, if none of the feature combinations is excluded by any of the restrictions. The result of all restrictions represents an intersection of the feature combinations.

SEQUENCE required Restriction of xs:nonNegativeInteger

This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...)

D nonNegativeInteger
P
M [1:99999]

RESTRICTION_NO required Restriction of xs:nonNegativeInteger

This attribute references series specific restrictions.

D nonNegativeInteger
P
M [0:99999]

SUGGESTIONS optional
This element references default settings that are applied to the series.

If the series additionally contains a standard proposal (DEFAULT_OPTION_GROUPS), the standard proposal will take priority when the planning is recorded initially.

Sequence

SUGGESTION_REF 0..∞
This element references default settings that are applied to the series.

If the series additionally contains a standard proposal (DEFAULT_OPTION_GROUPS), the standard proposal will take priority when the planning is recorded initially.

SEQUENCE required Restriction of xs:nonNegativeInteger

This element is used to specify the sequence in which the assigned default values are suggested when a planning is recorded for the first time.

The numbering (SEQUENCE) determines the priorities

D nonNegativeInteger
P
M [1:99999]

SUGGESTION_NO required Restriction of xs:nonNegativeInteger

This attribute references a set of default values.

D nonNegativeInteger
P
M [0:99999]

PRODUCT_GROUPS
This element is used for the definition of product groups. Product groups are used for grouping items which have the same variation types (e.g. shelves).

Sequence

PRODUCT_GROUP 1..∞
This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.

Sequence

PRODUCT_GROUP_TEXT languagetexte60 Complex Type
This element is used for defining a name for a product group.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

FEATURE_CLASS_REF optional
This element is used for assigning a feature class to a product group. It references a feature class which is defined in the element FEATURE_DEFINITION/FEATURE_CLASSES.

FEATURE_CLASS_NO required Restriction of xs:positiveInteger

This attribute identifies the referenced feature class(FEATURE_CLASS).

D positiveInteger
P
M [1:999]

ITEMS
This element defines all items belonging to one product group.

Sequence

ITEM 1..∞
This element is used for the definition of items and blocks. An item is identified by the attributes SERIE_NO (path 1) and TYPE_NO (path 1)..

The elements OLD_SERIA_NO (path 1) and OLD_TYPE_NO (path 1) may only be used if the geometrical information for the referred item is exactly the same as for the current item.

If an electrical appliance is defined as an item, it is necessary to indicate the dimensions (B, H, T) of this item in the element PARAMETERS (path 3).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE

RESTRICTIONS optional
This element is used for combining all restrictions which apply to one product group.

Sequence

RESTRICTION_REF 1..∞
This element references a restriction which is assigned to a product group.

DEFAULT_OPTION_GROUPS optional
In this record type, default values for series variations are given as proposals resp. decision support for the user. The proposals made here have to be defined as legal combinations.

Sequence

DEFAULT_OPTION_GROUP 1..∞
This element defines a standard proposal.
Each feature type may be referenced only one time in the DEFAULT_OPTION_GROUP

DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger

This attribute defines a numerical counter for the default group.

D positiveInteger
P
M [1:999999999]

Sequence

DEFAULT_OPTION_GROUP_NAME languagetexte30 Complex Type
This element contains a freely defined name for the default option, e.g. defined by the user of the planning software.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

FILE_NAME optional Restriction of xs:string

This element contains the filename of a JPEG-file which is used as an example of the default option.

D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M

OPTION_REF 1..∞
This element references the features which are combined in the default option.

FEATURE_NO required Restriction of xs:nonNegativeInteger

This attribute defines the feature type of the referenced feature.

D noNegativeInteger
P
M [0:999]

OPTION_KEY required Restriction of xs:string

This attribute defines the reference between the feature and the default option.

D string
P
M [1:5]

DETAIL_INFOS optional
This element is used for defining pictures which are subordinated to the the standard proposal.

Sequence

DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.

DETAIL_INFOS 0..∞
This element is used for defining detailed media information, e.g. photographs, PDF files, video hyperlinks which refer to a series.

Sequence

DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.

DETAIL_INFO_NO required Restriction of xs:positiveInteger

This attribute is used to specify the identification number of the referenced detail information.

D positiveInteger
P
M [1:999999999]

RESTRICTIONS optional
This element is used for summarizing the global restrictions.

Sequence

RESTRICTION_REF 0..∞
This element references global restrictions.

SEQUENCE required Restriction of xs:nonNegativeInteger

This element defines the sequence in which the different restrictions are processed. Different values in the the field SEQUENCE_NO are required and an intersection of the different restrictions is made up.
The sequence has to be defined in ascending order which may have gaps (e.g. 1,3,10, ...).

D nonNegativeInteger
P
M [1:99999]

RESTRICTION_NO required Restriction of xs:nonNegativeInteger

This attribute references global (i.e. not depending on series) restrictions.

D nonNegativeInteger
P
M [0:99999]

FEATURE_DEFINITION optional
All information which is depending on the different variations is defined in this element.

Sequence

FEATURE_CLASSES
In this element features are grouped into feature classes. By using feature classes different checks concerning plausibility and completeness of the valid variation types can be processed.

Feature classes can be assigned to series, programmes, or product groups. There is no priority to any of these assigned levels. The total number of valid features for one item results from the sum of features which are defined for the feature class of the programme and the feature class of the item. Feature classes which are referenced from the element FEATURE_CLASS_REF(path 1), may only contain features which are defined as header features in the element FEATURES (path 2).

All features referenced by the elements PRICE_FEATURE_GROUP (path 3), PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 4) and FINISH (path 5) have to occur in the feature class of an item.

Also the features used from the elements RESTRICTION_REF (path 6), RESTRICTION_REF (path 1) and RESTRICTION_REF (path 8)have to be part of the feature class of an item.

Element paths:
1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
path 2: FEATURE_DEFINITION
path 3: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
path 6: SERIES/SERIE/RESTRICTIONS
path 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS

Sequence

FEATURE_CLASS 1..∞
This element defines the variations of a programme.

FEATURE_CLASS_NO required Restriction of xs:positiveInteger

This attribute identifies the variations of a programme as a feature class.

D nonNegativeInteger
P
M [1:999]

Sequence

FEATURE_REF 1..∞
The feature class refers to the element FEATURE (path 1) .
Only logical and meaningful variations may be referenced in the feature class of an item, e.g. a variation class for shelves must not contain feature types of handles.

Element paths
Pfad 1: FEATURE_DEFINITION/FEATURES

FEATURE_NO required Restriction of xs:nonNegativeInteger

This attribute is used for referencing a feature class.

D nonNegativeInteger
P
M [0:999]

FEATURES
This element defines the variation types (FEATURE) and the assigned variations. This element contains only those features which are necessary for the specific catalog.

Except for the combination features and the features 701 and 703 all features are defined by the combination of finish and colour.

Features have necessarily to be defined as pairs, i.e. each finish feature requires a corresponding colour feature and vice versa.

Only the features 701 and 703, which do not require a definition of colour features, are exceptions to this rule.

Features > 950 are only relevant for the modeling graphic and must not be defined as combination variations.

Feature combinations in the catalogue (e.g. veneer green) have to be defined in the element COMBINED_FEATURE (path 1).

All feature details used in the element COMBINED_FEATURE (path 1) have to be defined as invisible header features (HEADER_POS_VARIATION_TYPE (path 2) = U).

Features which are defined as invisible must not be referenced by any feature class.

All variation types which are not marked as invisible header features in the element FEATURES (path 3), have to be referenced by at least one feature class.

Certain MUST_FEATURES are defined which are basically required. In general these features are not sufficient for a complete description of the catalogue. The assignment of a type key and a MUST-feature is defined in the table "type key - MUST features".
Further information about features is provided in the chapter "Remarks for the correct use of features"

This element is mandatory for kitchen furniture manufacturers (SUPPLIER/BRANCH_ID = K).

Element paths
path 1: FEATURE_DEFINITION/FEATURES
path 2: FEATURE_DEFINITION/FEATURES/FEATURE
path 3: FEATURE_DEFINITIO

Sequence

COMBINED_FEATURE 0..∞
This element is used for grouping single features into feature combinations. In these combinations each feature is a detail feature.

If combined features are used, variation checks and assignments may only be applied to the defined combined features and not to the subordinated detail features.

Detail features have to be defined as invisible in the element HEADER_POS_VARIATION_TYPE (path 1). These may only be used in the element OPTION (path 2).

If a combined feature has been defined, it has to be used continuously. For example: if a combined feature with feature type 303 and and detail feature 301 and 302 has been defined, all further features for handles have to be defined as combined features with feature type 303, too.

Regarding the software processing of combined features the following conventions apply: for monocoloured fronts a combined feature with feature type front colour 1 (101) is defined. The colour of this feature is inherited to feature type front colour 2 (102).

If the combined feature is a handle combination (feature type 303), at least feature type 300 and feature type 301 or 302 have to be assigned to this combined feature.

Element paths
path 1: FEATURE_DEFINITION/FEATURES/FEATURE
path 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS

FEATURE_NO required Restriction of xs:nonNegativeInteger

This attribute is used for referencing a feature.

D nonNegativeInteger
P (105)|(115)|(125)|(201)|(303)
M [105:303]

OPTION_KEY required Restriction of xs:string

This attribute is used for referencing a option.

D string
P
M [1:5]

Sequence

OPTION_REF 2..5
This element references the features which are combined.

Feature types > 950 are only used for the modeling graphic and may not be defined as combined features.

FEATURE_NO required Restriction of xs:nonNegativeInteger

This attribute is used for referencing a feature.

D nonNegativeInteger
P 10[012346]|11[01234]|12[01234]|20[02345]|30[012]
M [100:312]

OPTION_KEY required Restriction of xs:string

This attribute is used for referencing a option.

D string
P
M [1:5]

FEATURE 1..∞
This element defines a feature.

FEATURE_NO required Restriction of xs:nonNegativeInteger

This attribute identifies a feature.

D nonNegativeInteger
P
M [0:999]

Sequence

OPTIONS optional
This element is used as a container for all possible options of a feature type.
For inheriting features types (HEADER_POS_VARIATION_TYPE=V) this element is not defined.

Sequence

OPTION 1..∞
This element defines the features of a feature class. All features of the complete database are defined in this element. In case of a finish option (cf. table standard variations, flag "A") neither texture (TEXTUR)nor colour values (COLOR) are permitted. The assignment of brightness and transparency is optional. In case they are defined they have priority over the colour variations.

FEATURE_NO required Restriction of xs:nonNegativeInteger

This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE.

D nonNegativeInteger
P
M [0:999]

OPTION_KEY required Restriction of xs:string

This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required.

D string
P
M [1:5]

SEQUENCE_NO optional Restriction of xs:nonNegativeInteger

This attribute defines a sort order for the features. This attribute does not have to be used continuously. The sort order criterion may be be applied to all features.

D nonNegativeInteger
P
M

Sequence

Choice optional

STYLE_REF
This element is used to reference a range.

MATERIAL_REF
This element references a material.

HANDLE_ORIENTATION_REF
This element references a handle orientation.

FORM_REF
This element references a shape.

OPTION_MEASURE_REF
This element references special dimensions of a feature class. Currently this element can only be used to indicate the different plinth heights (feature 402).

HANDLE_POSITION_REF
This element references a handle position.

OPTION_TEXT languagetexte60 Complex Type
This element is used for defining a text concerning a option.

OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element references a general comment which provides information about a option. It is only used for the purpose of user-friendliness and must not contain any order relevant information as this text information is not processed by the software.

VALID_FROM optional Restriction of xs:date

This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Fields named VALID_TO must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank.

D date
P
M

VALID_UNTIL optional Restriction of xs:date

This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
• both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Elements named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank.

D date
P
M

MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger

This element defines the minimum delivery time in weeks. This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.)

D nonNegativeInteger
P
M [0:999]

FRONT_APPEARANCE_REF optional
This element defines a reference between feature and front appearance. A front appearance referenced here has to be defined in the element path1/FRONT_APPEARANCE.

This element may be used when feature "glass frame door" (FEATURE_NO = 154) is defined in path2/FEATURE_NO.

For data processing the following rules apply:
If an item is available with glass door, i.e. feature 154 is an element of the feature class of this item, the FRONT_APPEARANCE_NO of this element is used. If the item has no glass door path3/FRONT_APPEARANCE_REF is used.

This element has to be filled in from filling level 2b on.

Element paths:
path1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
path2 = FEATURE_DEFINITION/FEATURES/FEATURE
path3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITE

DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.

FEATURE_TEXT languagetexte60 Complex Type
This element contains text information for the different features.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,60}
M [1:60]

SEQUENCE_NO Restriction of xs:nonNegativeInteger

This element defines a manufacturer specific classification for the feature types.
This classification is a recommendation of the manufacturer, the retailers may use different classifications. The classification is used for a better legibility and display of data on the screen or in print-outs.
In case a classification is defined here, this has to unambiguous and it has to be applied to all data sets.
The field classification must not be filled in if invisible header features (HEADER_POS_VARIATION_TYPE = U (path1)), are used

Element paths
path1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/

D nonNegativeInteger
P
M [0:999]

HEADER_POS_VARIATION_TYPE Restriction of xs:string

This element is used for distinguishing the different feature types
I = implicit variation,
K = header variation,
U = invisible header variation,
P = position variation type or
V = inheriting variation type.

These different types are used to control the software processing of variation types; Variation types marked with "P" may only occur on position level but not in the header.
Invisible header variations may only be used in the elements OPTION (path 1) and COMBINED_FEATURE (path 2).

For variation types that inherit information from another variation type the flag "V" is used. The process of inheritance is only applied within the same item, therefore this flag may only be used for variation types 202, 203, 205 and 208. If the flag "V" is set, the
element INHERIT_VARIATION_TYPE_REF (path 3) requires an entry. Legal entries to be used here are 202, 203, 205 or 208, marked with the flag "K" or "P" in the element HEADER_POS_VARIATION_TYPE (path 3).
Inheriting variation types must not be used in any other record type.
Variations marked with "I" are invisible variations which are used for control procedures. Currently the mark "I" is only used for variation type 305 = drilling pattern.

Element paths
path 1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
path 2: FEATURE_DEFINITION/FEATURES
path 3: FEATURE_DEFINITION/FEATURES/FEATURE

D nonNegativeInteger
P
M [0:999]

INHERIT_VARIATION_TYPE_REF optional
This element references the feature type from which information is inherited.
Feature types 202, 203, 205 and 208 may inherit information among each other.
Feature types used here must not contain the flag „invisible“

FEATURE_NO required Restriction of xs:nonNegativeInteger

This attribute defines the referenced feature.

D nonNegativeInteger
P (202)|(203)|(205)|(208)
M [0:999]

OPTION_DEFINITION
This element is used for defining the different variations of colours, materials, handles, shapes,and programmes.

Sequence

STYLE 0..∞
This element is used for the definition of programmes/ styles in a catalogue.
Styles are created as features in the element STYLE_REF (path1). A style is defined by feature type 1 (FEATURE_NO = 1).

The attributes of a style must not vary within one series. As a style is only defined in this element and referenced by the series, the aforementioned condition is represented by the structure.

This element is an optional one, if the element SUPPLIER/BRANCH_ID contains the values "G" or "Z".

P1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
P2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
P3: FEATURE_DEFINITION/FEATURES

STYLE_NO required Restriction of xs:string

This attribute defines a manufacturer specific key for a style. It is referenced by the attribute STYLE_NO in the element STYLE (path1).

P1: FEATURE_DEFINITION/OPTION_DEFINITION/

D string
P
M [1:5]

Sequence

FRONT_DEPTH optional Restriction of xs:nonNegativeInteger

This element defines the specific depth of a style in [mm]. The default value is 20 mm..
Values in this field are required when the element FRONT_APEREANCE_NO (path1) is filled in.

path1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/

D nonNegativeInteger
P
M [1:99]

FRONT_DISTANCE optional Restriction of xs:nonNegativeInteger

This element is used to define the range-specific door buffer [mm]. It represents the distance between the door and the carcase behind it.

D nonNegativeInteger
P
M [1:99]

FRONT_APPEARANCE_REF optional
This element assigns a front appearance to a style. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.

FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger

This attribute defines a specific ID for a front appearance which is referenced by styles and items.

D positiveInteger
P
M [1:999]

FRONT_GROUP_REF optional
This element is used for assigning a front group to a style.
Several styles which have the same front appearance can be grouped in one front group.
This element references the attribute SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_GROUP_NO.
For manufacturer catalogues in which the front divisions of the cabinets depend on the different styles a definition of front groups is required.
In some manufacturer catalogues the front divisions of cabinets do not vary in the different styles. In these cases no front group definition is required.
In many cases all traditional style fronts can be grouped into one front group. This is due to the fact that the front divisions of tall cabinet front doors have a similar pattern in traditional styles.
This rule is not applied to cabinets which have different front divisions depending on the varying sizes of appliances.
In case a front group has been defined for one style, front groups have to be assigned to all styles.

FRONT_GROUP_NO required Restriction of xs:positiveInteger

This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database.

D positiveInteger
P
M [1:99]

FEATURE_CLASS_REF optional
This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES.

FEATURE_CLASS_NO required Restriction of xs:positiveInteger

This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES/

D nonNegativeInteger
P
M [1:999]

DEFAULT_OPTION_GROUP_REF 0..∞
This element assigns default options to a style.

DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger

This attribute references a default option.

D nonNegativeInteger
P
M [1:999999999]

RESTRICTIONS optional
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.

Sequence

RESTRICTION_REF 1..∞
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.

RESTRICTION_NO required Restriction of xs:nonNegativeInteger

This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.

D nonNegativeInteger
P
M [1:99999]

SEQUENCE required Restriction of xs:positiveInteger

This element defines the sequence in which the different test procedures are performed. Several restriction can be grouped (set union), if the value filled in in the element SEQUENCE is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...)

D positiveInteger
P
M [1:99999]

HANDLE_ORIENTATION 0..∞
This element defines a handle orientation.

HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger

This attribute identifies a handle option.

D string
P
M [1:5]

Sequence

DEFAULT_HANDLE_ORIENTATION_REF optional

This element defines a variation of the basic handle position. It references a basic handle position defined in the element BASIC_HANDLE_POSITIONS (path 1).

The manufacturer specific name for this position is defined in the element OPTION_KEY (path 2).

The element default handle position has to be filled in if variation type 304 (handle position) is set in the element FEATURE (path 3).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS

path 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
path 3: FEATURE_DEFINITION/FEATURES

SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger

This attribute defines a standard handle position.

D nonNegativeInteger
P
M [1:99999]

MATERIAL 0..∞
This element defines a material.

In case of a finish option, (cf. table Standard variation types flag "A"), neither texture (TEXTURE) nor colour (COLOR) values are permitted.

Finish options are defined in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION.

MATERIAL_NO required Restriction of xs:string

This attribute identifies a material.

D string
P
M [1:5]

Sequence

Choice optional

COLOR
This element defines colours.

Sequence

RGB_RED Restriction of xs:nonNegativeInteger

This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined.

D nonNegativeInteger
P
M [0:255]

RGB_GREEN Restriction of xs:nonNegativeInteger

This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined.

D nonNegativeInteger
P
M [0:255]

RGB_BLUE Restriction of xs:nonNegativeInteger

This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined.

D nonNegativeInteger
P
M [0:255]

TEXTURE
This element defines information about the textures.

Sequence

FILE_NAME_TEXTURE Restriction of xs:string

This element defines references to material textures.

D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]

TEXTURE_REPEAT optional
This element defines if a texture is applied to a material only one time or repeatedly. If a texture repeat is required, this element is defined and the settings are applied to all child elements, too.
According to the basic texture size (DPI, number of pixels) the repeat factor is calculated automatically by the software programme.
If the element FILENAME_TEXTURE is filled in, this element is required, too.

TEXTURE_TILE optional Restriction of xs:int

This attribute defines if a texture is applied to a material only one time (0 = no repeat) or several times (1 = repeat).

D integer
P
M [0:1]

Sequence

REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger

This element defines the dimensions of the texture in X direction. The values are given in mm.

D nonNegativeInteger
P
M [1:9999]

REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger

This element defines the dimensions of the texture in Y direction. The values are given in mm.

D nonNegativeInteger
P
M [1:9999]

MASKING optional Restriction of xs:boolean

This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
If the element FILENAME_TEXTURE is filled in, this element is required, too.

D boolean
P
M

TEXTURE_DELIVERED_ORIENTATION Restriction of xs:string

This attribute identifies a default handle position.

D string
P |[HV]
M [0:1]

TRANSPARENCY optional Restriction of xs:nonNegativeInteger

This element defines the degree of transparency for a material RGB value or texture).
0 = opaque
9 = max. transparency
If this element is a colour variation settings in this field are required.

D nonNegativeInteger
P
M [0:9]

BRIGHTNESS optional Restriction of xs:nonNegativeInteger

This element defines the degree of brightness for a material (RGB value or texture).
0 = opaque
8 = high gloss
9 = reflection
If this element is a colour variation settings in this field are required.

D nonNegativeInteger
P
M [0:9]

FORM 0..∞
This element is used to define a variation of a shape.

FORM_NO required Restriction of xs:string

This attribute identifies the shape of a profile.

D string
P
M [1:5]

Sequence

PROFILE_KEY Restriction of xs:string

This element defines the manufacturer specific key for a profile shape. This element is used for building the variation types 750-756. Only these variation types 750-756 can use the element FORM. The different variations are referenced by the item (ITEM) which represents the profile.

D string
P
M [1:5]

OPTION_MEASURE 0..∞
This element defines measurement information for different features, e.g. plinth height (feature type 402).

OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger

This attribute identifies the dimensions of an appearance.

D nonNegativeInteger
P
M [1:99999]

Sequence

PLINTH_HEIGHT Restriction of xs:nonNegativeInteger

This element defines the plinth height in mm.

D nonNegativeInteger
P
M [0:999999999]

STANDARD_PLINTH optional xs:boolean

This element is used to specify whether the relevant plinth height is a standard value or if it is different from the standard. If the value is set to false(0), the plinth height is different from the standard height and may incur an additional price for the plinth feet.

A missing element corresponds to the value true(1).

This element must be specified if there are linked articles with allocation type CLASS = 21.

D boolean
P
M [0:1]

RESTRICTIONS optional
This element is used for the definition of restrictions.

Sequence

RESTRICTION 1..99999
This element is used for the definition and description of restrictions. These restrictions define rules for technically possible combinations but do not contain any planning advices. This is necessary to prevent the dealers from unnecessary restrictions in the course of kitchen planning.

Restrictions are assigned to series, styles or items by references. All test procedures defined in this element have to be referenced from series, styles or items.

Restrictions which are referenced from series or styles may not be referenced from items. Restrictions which are referenced from items have priority over restrictions referenced from series or styles

The element OPTION_REF can be set up in different ways. According to the filling levels in the elements FEATURE_1_NO, FEATURE_2_NO and FEATURE_3_NO test procedures can be defined as 0-level, 1-level or 2-level or 3-level.

Number of variations in case of undefined variations

On condition that the restriction is defined as a "permitting" test procedure (TEST_ID = 1), all features which are not listed in the test procedure are illegal feature combinations. If the restriction is defined as a "non-permitting" test procedure (TEST_ID = 0), all variations are legal feature combinations. If different feature combinations are combined this rule applies for the combination of the resulting features.

Number of variations for style specific restrictions:

In case a restriction is not referenced by all styles, the following rules apply:

If the restriction defines legal features and feature combinations, all variations of the feature combinations are illegal for those styles, which are not defined in the restriction.
If the restriction defines illegal features and feature combinations, all variations of the of the feature combinations are legal for those styles, which are not defined in the restriction.

Cyclical tests
Cyclical restrictions are not permitted. Such test procedures might result from the following constellations
Not permitted
1. restriction: feature 1 with feature 2
2. restriction: feature 2 with feature 3
3. restriction: feature 3 with feature 1

RESTRICTION_NO required Restriction of xs:nonNegativeInteger

This attribute identifies restrictions unambiguously.

D nonNegativeInteger
P
M [1:99999]

FEATURE_1_NO required Restriction of xs:nonNegativeInteger

The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction.

D nonNegativeInteger
P
M [0:999]

FEATURE_2_NO optional Restriction of xs:nonNegativeInteger

The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction.

D nonNegativeInteger
P
M [0:999]

FEATURE_3_NO optional Restriction of xs:nonNegativeInteger

The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction.

D nonNegativeInteger
P
M [0:999]

VALIDATION_TYPE required Restriction of xs:int

The attribute VALIDATION_TYPE defines a restriction as either colour-length or variation test procedure. In case of a colour-length test procedure the element MIN/MAX_DIMENSION under OPTION_COMBINATION has to be filled in.
0 = variation test procedure (formerly record type 270)
1 = colour-length test procedure (formerly record type 405)

D nonNegativeInteger
P
M [0:1]

Sequence

RESTRICTION_NAME_TEXT languagetexte60 Complex Type
This element is used for the definition of a name for a control procedure.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,60}
M [1:60]

OPTION_COMBINATION 1..∞
This element is used for the definition of a variation combination.

Sequence

OPTION_REF 1..3
This element is used for referencing the variation types which are used in the control procedures.

FEATURE_NO required Restriction of xs:nonNegativeInteger

This attribute is used for referencing a feature.

D nonNegativeInteger
P
M [0:999]

OPTION_KEY required Restriction of xs:string

This attribute is used for referencing a option.

D string
P
M [1:5]

Sequence optional

MAX_DIMENSION 0..3
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES

DIMENSION_TYPE required Restriction of xs:string

This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth

D string
P [WHD]
M [1:1]

DIMENSION_VALUE required Restriction of xs:nonNegativeInteger

This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES

D nonNegativeInteger
P
M [1:9999]

MIN_DIMENSION 0..3
This element defines the minimum dimension in which an option is available.

DIMENSION_TYPE required Restriction of xs:string

This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth

D string
P [WHD]
M [1:1]

DIMENSION_VALUE required Restriction of xs:nonNegativeInteger

This element defines the minimum dimension in which an option is available.

D nonNegativeInteger
P
M [1:9999]

TEST_ID Restriction of xs:boolean

The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted

D boolean
P
M

SUGGESTIONS optional
This element is used to specify default values.

Sequence

SUGGESTION 1..99999

This element is used to define and describe default values for version types with certain versions.

This option to set default values is only provided for head versions and becomes effective when a planning is recorded for the first time.

Similar to a standard proposal (DEFAULT_OPTION_GROUP), it is referenced below the series, with the standard proposal assigned a higher priority.

OPTION_COMBINATION can be used to make pairs of versions for version-specific default values available.

The version type specified at FEATURE_1_NO has the highest priority.

The default values must not conflict with the associated checks.

SUGGESTION_NO required Restriction of xs:nonNegativeInteger

This attribute assigns unique identifiers to sets of default values.

D nonNegativeInteger
P
M [1:99999]

FEATURE_1_NO required Restriction of xs:nonNegativeInteger

The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values.

D nonNegativeInteger
P
M [0:999]

FEATURE_2_NO optional Restriction of xs:nonNegativeInteger

The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values.

D nonNegativeInteger
P
M [0:999]

FEATURE_3_NO optional Restriction of xs:nonNegativeInteger

The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values.

D nonNegativeInteger
P
M [0:999]

Sequence

SUGGESTION_NAME_TEXT languagetexte60 Complex Type
This element is used to specify the description of a set of default values.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,60}
M [1:60]

OPTION_COMBINATION 1..∞
This element is used to form a version combination for default values.

Sequence

OPTION_REF 1..3
This element is used to reference variants that are specified in default settings.

FEATURE_NO required Restriction of xs:nonNegativeInteger

This attribute references the version type.

D nonNegativeInteger
P
M [0:999]

OPTION_KEY required Restriction of xs:string

This attribute references the variant type.

D string
P
M [1:5]

PRICE_DEFINITION
This element is used for providing all the information which is necessary for a correct calculation of prices, e.g. pricing tables and finish groups.

Sequence

PRICE_FEATURE_GROUPS
This element is used to defind the price feature groups.

Sequence

PRICE_FEATURE_GROUP 1..∞
This element contains all relevant pricing information. The settings in the element PRICE_FEATURE_GROUP define specific conditions (e.g. feature combinations) for the item price.

Each item references one PRICE_FEATURE_GROUP. The exact price information is defined on item level.

The following rules for price feature groups or items apply:
- Neutral items, not depending on a price feature group, cannot have features
- for items, depending on features, settings in the fields feature type 1 (style) and optionally the variation type 101 (front colour 1) or 105 (front combination)are required.
- items depending on features require one or two feature types
- each item has to reference exactly one basic price group (ADDITIONAL_PRICE=0)

Similar combinations of feature types for different price feature groups are not permitted, e.g. there should be only one PRICE_FEATURE_GROUP with feature type handle variation, which covers everything having to do with handle variations.

PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger

This attribute identifies a PRICE_FEATURE_GROUP.

D positiveInteger
P
M [1:99999]

ADDITIONAL_PRICE required Restriction of xs:boolean

This attribute is used for defining the different price types, e.g. basic price or additional price. (0 = basic price, 1= additional price):
If an additional price group is defined (ADDITIONAL_PRICE=1), the option "price on request" is not permitted. For items which refer to this additional price group the element PRICE_ON_REQUEST (path 1) is not permitted.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_ON_REQUEST

D boolean
P
M

PRICE_CALC_METHOD required Restriction of xs:nonNegativeInteger

This attribute is used for defining the basic price calculation method.

The following methods are defined:

0 = price on request;
1 = neutral item; price not depending on style or series
2 = price depending on style or series;
3 = price depending on finish.

A PRICE_FEATURE_GROUP which contains the value 0 (price on request) in the attribute PRICE_CALC_METHOD may occur only one time.

D nonNegativeInteger
P
M [0:3]

FEATURE_NO_1 optional Restriction of xs:nonNegativeInteger

This attribute identifies the feature type 1.
The combination which is defined in the attribute OPTION_REF/FEATURE_NO may not differ from the settings in the attribute FEATURE_NO_1.

D nonNegativeInteger
P
M [0:999]

FEATURE_NO_2 optional Restriction of xs:nonNegativeInteger

This attribute identifies the feature type 2.
The combination which is defined in the attribute OPTION_REF/FEATURE_NO may not differ from the settings in the attribute FEATURE_NO_2.

D nonNegativeInteger
P
M [1:99999]

Sequence

PRICE_FEATURE_GROUP_TEXT languagetexte60 Complex Type
This element provides text information for the finish groups.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,60}
M [1:60]

FINISH 0..∞
This element is used for assigning price fields (price field, block price field) and the manufacturer price group to legal feature classes.

If the attribute PRICE_CALC_METHOD is set to 0 (price on request), the element FINISH is not permitted.

Sequence

OPTION_REF 0..2
This element is used to reference a option.

FEATURE_NO required Restriction of xs:nonNegativeInteger

This attribute is used for referencing a feature.

D nonNegativeInteger
P
M [0:999]

OPTION_KEY required Restriction of xs:string

This attribute is used for referencing a option.

D string
P
M [1:5]

PRICE_FIELD Restriction of xs:positiveInteger

This element is used for defining the price field in which the item price is saved. The corresponding price field has to be defined in the element ITEM_PRICE (path 1 or path 2).

If the same catalogue is used for different customer groups the assignment of price groups must not be changed. The same applies to correction files within the same cycle.

Element paths
path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

D positiveInteger
P
M [1:250]

BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

This field is used to specify in which price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer dies not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

D nonNegativeInteger
P
M [1:250]

SUPPLIER_PRICE_GROUP Restriction of xs:string

This element contains the manufacturer's price group.

For prices which depend on series or finishes (PRICE_CALC_METHOD = 3) the value defined in the element PRICE_FIELD is copied to the element SUPPLIER_PRICE_GROUP.
For prices of neutral items (PRICE_CALC_METHOD = 1) values in this field are not taken into consideration.

D string
P
M [1:10]

SET_OF_EXCHANGE_IDS optional
This element defines the manufacturer specific ecxchange-IDs.

If blocks are available for one manufacturer, this element has to be defined in the catalogue file. This information is also required if the manufacturer is going to deliver blocks offside the general catalogue in the future. A block file must not contain this element.

Sequence

EXCHANGE_ID 1..∞
The element EXCHANGE_ID (exchange-ID) is used as a key for the exchange groups. Freely defined values in the range between 1 and 89 are permitted.
Special exchange_IDs are defined as follows:
0 = exchange of item not permitted
98 = exchange of item with itself only.
99 = exchange of item with all other exchange-IDs permitted.
All utilized exchange-ID have to be defined in the data as well as the predefined special exchange-IDs.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS.

EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger

This element is used as a key for the exchange groups. Freely defined values in the range between 1 and 89 are permitted.
Special exchange_IDs are defined as follows:
0 = exchange of item not permitted
98 = exchange of item with itself only
99 = exchange of item with all other exchange-IDs permitted.
All utilized exchange-ID have to be defined in the data as well as the predefined special exchange-IDs.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID.

D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

Sequence

EXCHANGE_ID_TEXT languagetexte40 Complex Type
Additional information about the exchange group is provided in the field, e.g.:
- furniture
- worktops
- light pelmet/ cornice
- accesories
- electrical appliances

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,40}
M [1:40]

VALUE_ADDED_TAXES
This element is used for defining the different rates of value added tax which are referenced by the items. The tax rates defined in this field have to correspond with the country defined in element COUNTRY_ID (path 1).

Element paths
path 1: CATALOG/CATALOG_IDENTIFICATIO

Sequence

VALUE_ADDED_TAX 1..100
This element defines a VAT rate.

VAT_NO required Restriction of xs:nonNegativeInteger

This attribute defines an ID for a VAT rate. The value 0 is reserved for those items which are not subject to VAT.

D nonNegativeInteger
P
M [0:99]

Sequence

VAT_RATE Restriction of xs:nonNegativeInteger

This element defines the VAT rate in percent. The value is given with two decimal places, e.g. 1600 for 16,00 % oder 10 für 0,1%).

D nonNegativeInteger
P
M [0:9999]

IDENT_NUMBERS optional
This element defines the ident numbers. All ident numbers used in a catalogue have to be defined here.

Sequence

IDENT_NUMBER 0..9999
This element defines the ident numbers. All ident numbers used in a catalogue have to be defined here.

IDENT_NO required Restriction of xs:positiveInteger

This attribute is used to define an identifier.

D positiveInteger
P
M [1:9999]

Sequence

SERIE_REF 1..99
This element references a series. If no series is referenced the ident numbers are valid globally.

SERIE_NO required Restriction of xs:nonNegativeInteger

This attribute is used for defining a serial No. of the referenced series.

D nonNegativeInteger
P
M [0:99]

PRICE Restriction of xs:integer

The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30,000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of EUR -9.00 is entered as -> -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_REF of the item does not contain an element for the corresponding price group.

D nonNegativeInteger
P
M [0:99]

MERCHANDISE_GROUP 1..∞
This element defines a merchandise group. The merchandise group and the assigned text information have to correspond with the calculation sheet of the manufacturer. For one merchandise group 1-n calculation groups can be defined.

MERCHANDISE_GROUP_NO required Restriction of xs:string

This attribute defines a merchandise group.

D string
P
M [1:5]

Sequence

MERCHANDISE_GROUP_TEXT languagetexte30 Complex Type
This element provides text information about the merchandise groups.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,30}
M [1:30]

Sequence

CALC_GROUP 1..∞

This element is used to define the possible calculation groups. It can be helpful when applying different discounts. This means that, depending on the number of discount scales, a corresponding number of calculation groups can be formed here. The element ITEM is used to allocate the items to a calculation group. Only calculation groups with referencing items must be defined. They key ist the CALC_GROUP_NO field.

If the same calculation group is used, the same price finding will also be used.

A calculation group can only be used once within all MERCHANDISE_GROUP elements. This means that a certain calculation group may only be used in a single MERCHANDISE_GROUP and not in multiple MERCHANDISE_GROUP elements.

The calculation group is specified via the CALC_GROUP_NO attribute.

CALC_GROUP_NO required Restriction of xs:positiveInteger

This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
8 = miscellaneous 1
9 = miscellaneous 2

Single-figure numbers (leading zeroes) are not allowed.
The calculation group does not correspond with the suppliers scales of conditions.

D positiveInteger
P
M [10:99]

Sequence

CALC_GROUP_TEXT languagetexte30 Complex Type
This element contains text information for a calculation group.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,30}
M [1:30]

CALCULATION_FACTOR optional Restriction of xs:nonNegativeInteger

The use of this element is only permitted if the value 3 is set in the element PRICE_ID (path 1).

If calculation points are used the corresponding calculation factor has to be defined in this element.
The factor is given as a decimal figure with max. 5 decimal places before the point and exactly three decimal places after the point (the point itself does not count). The calculation factor has to be > 0.

Element paths
path 1: CATALOG/CATALOG_IDENTIFICATION

D nonNegativeInteger
P
M [1:99999999]

PRICE_TYPES
This element is used for defining the different price types. Neutral as well as model specific items can be charged per piece or depending on certain measurements.
The child elements WIDTH_X, DEPTH_Y, HEIGHT_Z define that the price of an item depends on width, height, depth, surface or volume.
If the value "1" is not entered for any of the dimensions, the price is calculated per piece (e.g. base cabinet) and not depending on measurements. In this case the elements BASIC_UNIT and ROUNDING_UNIT have to be filled in with "0".
In case one dimension field is filled in with "1" , the price calculation is based on this dimension (e.g. light pelmets).
If the value "1" is filled in into two dimension fields, the price will be calculated depending on the surface of the item (e.g. cladding material).
The price calculation is based on volume, in case three dimension fields are filled with the value "1" (e.g. lacquer, stain).

Sequence 1..∞

PRICE_TYPE
This element defines a price type.

PRICE_TYPE_NO required Restriction of xs:positiveInteger

This attribute identifies a price type unambiguously.

D positiveInteger
P
M [1:250]

Sequence

WIDTH_X Restriction of xs:boolean

If the calculated price is depending on the width of an item, the value 1 has to be set in this field, otherwise the field is set to 0.

D boolean
P
M

DEPTH_Y Restriction of xs:boolean

If the calculated price is depending on the depth of an item, the value 1 has to be set in this field, otherwise the field is set to 0.

D boolean
P
M

HEIGHT_Z Restriction of xs:boolean

If the calculated price is depending on the height of an item, the value 1 has to be set in this field, otherwise the field is set to 0.

D boolean
P
M

BASIC_UNIT Restriction of xs:nonNegativeInteger

The field basic unit (BASIC_UNIT) indicatea the dimension to which the prices in the elements ITEM_PRICE (path1) and ADDITIONAL_PRICE (path2) refer.
The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm². If an item price depending on width is calculated per metre, the value "1000" has to be filled in into the field basic_unit, If the price calculation of an item is based on volume and the calculation unit is 1 m³, the value in the field basic_unit has to be "1000000000" [mm³]. If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0".

path1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/
path2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/

D nonNegativeInteger
P
M [0:999999999999]

ROUNDING_UNIT Restriction of xs:nonNegativeInteger

The element rounding unit (ROUNDING_UNIT) indicates the measurement to which length, surface or volume are rounded up. The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm³. If an item price depending on width is rounded up to full centimeters, the value filled in here has to be "10". If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0".

D nonNegativeInteger
P
M [0:999999999999]

BASIC_PRICE_DEPENDENT Restriction of xs:boolean

A basic price and a corresponding price unit can be defined for those items which are calculated depending on dimensions. No basic price is taken into account, if the value in this field is "0".

The element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC defines the current basic
price of an item. The element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT indicates the corresponding basic price unit.

The element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE defines the remaining measurement price, which refers to the element BASIC_UNIT.
In case the option BASIC_PRICE_DEPENDENT has been defined for an item, the definition of a minimum price is not permitted. The total price of an item is always calculated on the BASIC_PRICE and the additional REMAINDER_PRICE, taking into account the rules defined in this element.

The total item price is calculated according to the following scheme:
The basic price unit is subtracted from the total item price. The result of this operation is the remainder.
The calculation of the total item price is based on the rules defined in the element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE. In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0.

D boolean
P
M

PRICE_TYPE_FORMULA optional Restriction of xs:string

It is possible to define formulas for price calculation (PRICE_TYPE), but these formulas must not be defined for standard calculation price types, i.e. calculation per m² or m³.
The following rules for the definition of price formulas apply:
- Formula parameters b, h and t can be used. Parameters b, h, t correspond to the parameters b, h and t of the basic shapes. Depending on the used parameters b, h, t the corresponding Boolean field WIDTH_X (P1) (b), DEPTH_Y (P1) (t) or HEIGHT_Z (P1) (h) has to be set to true:
- Basic arithmetic operations addition (+), subtraction (-), multiplication (*) and division (/) can be applied;
- rules of parentheses may be applied;
- Algebraic signs must not be used;
- only the final result is rounded;
- All rules of the elements BASIC_UNIT (P1), ROUNDING_UNIT (P1), and BASIC_PRICE_DEPENDENT (P1) also apply in combination with the field PRICE_TYPE_FORMULA

P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/

D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]

PRICE_TYPE_NAME optional languagetexte60 Complex Type
This field contains a denotation for the defined price_type.
This denotation is used to simplify the data acquisition for communication purposes. This denotation is not evaluated in the processing software.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute define sthe ISO-Code for the chosen language in the text information.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,60}
M [1:60]

BLOCK_VALUE_CALCULATION optional
This element is used for defining the rules which apply to block calculation and value clearing.

Sequence

BLOCK_CONDITIONS optional
This element contains special conditions for the block calculation. Only if a block corresponds with these conditions it can be applied to a certain commission. Rules defined here apply to the value clearing system (value clearing block) as well as to block calculation (item block).

A block may only be applied to a commission,if all conditions for this special block are fulfilled. A tuple, consisting of the fields ITEM_REF (path 1) and OPERATION_ID (path 2), defines the conditions which refer to a certain block.

Basic condition for the correct application of block conditions is, that a block exists in one of the ranges which have been planned in one commission. In case different ranges have been planned in one commission, the first range which appears in the header data is considered as reference.

The settings and definitions of range- and variation controls apply to blocks in the same way as to “ordinary” items. The price information 0 in the element ITEM_PRICE (path 2) indicates that the value clearing block exists in a certain price group.

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

path 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence

BLOCK_CONDITION 1..∞
This element contains a condition which is used for validating a block, i.e. checking if a block price can be applied to a commission. This element is valid for clearing blocks and block calculation.

Sequence

ITEM_REF
This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.

TYPE_NO required Restriction of xs:string

This element is used for defining an item short code. (e.g. U60).

D string
P
M [1:15]

SERIE_NO required Restriction of xs:nonNegativeInteger

This attribute is used for defining a serial No. of the referenced series.

D nonNegativeInteger
P
M [0:99]

CONDITION_RULES
Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.

Sequence

CONDITION_RULE 1..∞
This element is used for defining block conditions.

Sequence

CLEARING_GROUP_REF 1..999
This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.

Choice

MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger

This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in.

D nonNegativeInteger
P
M [0:999999999]

MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger

This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.

D nonNegativeInteger
P
M [0:999999]

BLOCK_SALE_PRICES optional
This element is used for defining block sale prices.

Sequence

BLOCK_SALE_PRICE 1..∞
Block sale prices, which are only valid for various limited periods, are defined in this element. This element may be used only, if certain block prices are valid for more than one limited period within one catalogue period. Blocks, which are only available within one coherent period, are defined by the elements VALID_FROM (path 1) and /VALID_UNTIL (path 1).

A price defined in this element has precedence over the price defined in the general price field.
The variation combinations defined in this element have priority over the item specific control procedures.

Overlapping dates in the defined periods of block sale prices are not permitted.
Information provided in this element does not override information from other elements but abrogates it temporarily.
The combination of those pieces of information which are concerned, is defined in this element. All other combinations are still valid!

The validity dates of a block defined in this element have to differ from those defined in the elements VALID_FROM (path 1) and /VALID_UNTIL.
A block sale price is defined for a certain range within a certain period of time. The block sale price entered in this element must not override the “normal” block price in this pricegroup because other ranges may refer to that price, too.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Sequence

ITEM_REF
This element is used for referencing an item for which a block sale price has been defined.

TYPE_NO required Restriction of xs:string

This element is used for defining an item short code. (e.g. U60).

D string
P
M [1:15]

SERIE_NO required Restriction of xs:nonNegativeInteger

This attribute is used for defining a serial No. of the referenced series.

D nonNegativeInteger
P
M [0:99]

VARIATION_PRICE_DEFINITION 1..∞
This element is used for defining block sale conditions.

Sequence

VALID_FROM Restriction of xs:date

This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM.

D date
P
M

VALID_UNTIL Restriction of xs:date

This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM.

D date
P
M

OPTION_REF 0..4
This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.

FEATURE_NO required Restriction of xs:nonNegativeInteger

This attribute is used for referencing a feature.

D nonNegativeInteger
P
M [0:999]

OPTION_KEY required Restriction of xs:string

This attribute is used for referencing a option.

D string
P
M [1:5]

PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger

This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself).

D nonNegativeInteger
P
M [0:999999999]

GRADING_TABLE optional

This element is used for defining grading tables containing the surcharges or the credits which are used in the value clearing system.

A clearing block, which is valid for a certain commission, can be used as reference for the grading table. A reference amount is set up for each data record of this record type, to which the valid clearing block belongs CLEARING_GROUP (path 1). This amount is compared to the given amount of the clearing group. If the reference value corresponds with the given grading range (elements VALUE_FROM (path2) and VALUE_TO (path 2), the data record is applied. In this case the settings in the field TYPE_CREDIT (path 2) and/ or TYPE_DEBIT (path 2) are applied. The calculation is based on the amount of the calculation group, which is defined for type_credit or type_surcharge (element ITEM (path 3)).

Different grading ranges can be defined for one block. A freely defined operation_ID is assigned to each grading range COMPARING_RULES (path 4). Different grading ranges with the same operation_ID may appear within one grading range of a clearing block. In this case the conditions of all grading ranges with their corresponding clearing group have to be fulfilled, so that the value clearing system can be applied to the different items of the commission. Single data records are linked by an AND-operation (COMPARING_RULE).

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

In case several data records of a clearing block are applied in the GRADING_TABLE, the value of the block (ITEM (path 3)), ITEM_PRICE (path 5)) is calculated only one time.

path 1: GLOBAL_DEFINITION
path 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
path 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence

CREDIT_SURCHARGE_CLEARING 1..∞
This element defines value range for a grading table.

Sequence

ITEM_REF

This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string

This element is used for defining an item short code. (e.g. U60).

D string
P
M [1:15]

SERIE_NO required Restriction of xs:nonNegativeInteger

This attribute is used for defining a serial No. of the referenced series.

D nonNegativeInteger
P
M [0:99]

COMPARING_RULES 1..∞
Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.

Sequence

COMPARING_RULE 1..∞
This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.

Sequence

CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger

This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied.

D nonNegativeInteger
P
M [0:999]

VALUE_FROM Restriction of xs:nonNegativeInteger

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

D nonNegativeInteger
P
M [0:999999999]

VALUE_TO Restriction of xs:nonNegativeInteger

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

D nonNegativeInteger
P
M [0:999999999]

TYPE_CREDIT optional Restriction of xs:string

This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

D string
P
M [1:15]

TYPE_DEBIT optional Restriction of xs:string

The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

D nonNegativeInteger
P
M [1:250]

SET_OF_BLOCK_RULES
The manufacturer specific rules are defined in this element and the in the child elements.

Sequence

EXCHANGE_ID_GROUP 1..∞
This element is used for defining the exchange groups. If exchange-ID 1 (EXCHANGE_ID_1_REF) may be exchanged with exchange-ID 2 (EXCHANGE_ID_2_REF) and vice versa this has to be defined explicitly.
If items with the same exchange_ID can be exchanged 1 by 1 a special data record for this exchange has to be defined.

Sequence

EXCHANGE_ID_1_REF
The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS . The exchange-ID references the items of a commission or planning.

EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger

The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID.

D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

EXCHANGE_ID_2_REF
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS The exchange-ID references the items of a commission or planning.

EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger

The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID.

D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

RULE 1..99
This element defines a manufacturer specific set of rules.

RULE_NO required Restriction of xs:nonNegativeInteger

This attribute defines a counter from 1-99 for the manufacturer specific block rules.

D nonNegativeInteger
P
M [1:99]

Sequence

RULE_TEXT languagetexte60999 Complex Type
This element defines the criteria for exchanges in the block processing.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute specifies the ISO code of the stored text's language.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information

RULE_SET_TEXT languagetexte60999 Complex Type
This element contains text information and explanations for the set of rules.

Sequence

LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION

ISO_LANGUAGE_ID required Restriction of xs:language

This attribute specifies the ISO code of the stored text's language.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information

SEQUENCE_NO required Restriction of xs:positiveInteger

This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in.

D positiveInteger
P
M

Sequence

TEXT Restriction of xs:string

This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

D string
P [\S ]{1,60}
M [1:60]

Attributes

Name

Type

Use

Default

Fixed

Description

MAJOR

Restriction of xs:positiveInteger

required

The version number "MAJOR" indicates the format version of the database. This main version number is only changed if the format is changed completely.
The complete definition of a format version consists of the following elements: MAJOR, MINOR and REVISION.

D nonNegativeInteger
P
M [2]

MINOR

Restriction of xs:nonNegativeInteger

required

In general the number of the sub-version "MINOR" changes every year. In case the main version number MAJOR is changed, the sub-version number is reset to 0.

D nonNegativeInteger
P
M [0:99]

REVISION

Restriction of xs:nonNegativeInteger

required

The revision number "REVISION" highlights changes during the year resultant from individual working groups. The revisions are not published if they are not concerned with necessary corrections. Revision is reset to 0 with each new "MINOR" sub-version number.

D nonNegativeInteger
P
M [0:99]

Remarks

Source
<xs:element name="T_NEW_CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Signature" minOccurs="0" maxOccurs="1">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SignedInfo">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CanonicalizationMethod">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SignatureMethod">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="Reference">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="Transforms">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="Transform">
                                <xs:complexType>
                                  <xs:simpleContent>
                                    <xs:extension base="xs:string">
                                      <xs:attribute name="Algorithm" type="xs:anyURI" />
                                    </xs:extension>
                                  </xs:simpleContent>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DigestMethod">
                          <xs:complexType>
                            <xs:simpleContent>
                              <xs:extension base="xs:string">
                                <xs:attribute name="Algorithm" type="xs:anyURI" />
                              </xs:extension>
                            </xs:simpleContent>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DigestValue" type="xs:string" />
                      </xs:sequence>
                      <xs:attribute name="URI" type="xs:string" />
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SignatureValue" type="xs:string" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FILE_RELEASE_DATE" type="xs:dateTime">
              <xs:annotation>
                <xs:documentation>100--2--Dateifreigabe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_ID">
                    <xs:annotation>
                      <xs:documentation>100--5--Hersteller_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:language">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CURRENCY_KEY">
                    <xs:annotation>
                      <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{1,3}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>100--13--Laender_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CATALOG_KIND">
                    <xs:annotation>
                      <xs:documentation>Katalog-Art</xs:documentation>
                      <xs:documentation>1 für Basiskatalog</xs:documentation>
                      <xs:documentation>2 für Verbandskatalog</xs:documentation>
                      <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
                      <xs:documentation>geändert 17.04.2019</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ASSOC_CTM_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRODUCT_BRANDNAME">
                    <xs:annotation>
                      <xs:documentation>100--40--Produktmarke</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_ID">
                    <xs:annotation>
                      <xs:documentation>100--49--Preis_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VAT">
                    <xs:annotation>
                      <xs:documentation>200--4--MwSt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CATALOG_NUMBER">
              <xs:annotation>
                <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_YEAR" type="xs:gYear">
              <xs:annotation>
                <xs:documentation>Jahr der Neuerstellung</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="MAJOR_NO">
              <xs:annotation>
                <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_NAME" type="languagetexte30">
              <xs:annotation>
                <xs:documentation>100--10--Katalog_Name</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="DATA_VERSION">
              <xs:annotation>
                <xs:documentation>100--11--Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_FROM_DATE">
              <xs:annotation>
                <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILE_ID">
              <xs:annotation>
                <xs:documentation>100--14--Datei_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MARK">
              <xs:annotation>
                <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BKV]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILLING_LEVEL">
              <xs:annotation>
                <xs:documentation>100--44--Fuellstufe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[123]|2[a-n]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICING_TERMS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--48--Preisstellung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="1" />
                  <xs:pattern value="[01]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_INFO" type="languagetexte60999">
              <xs:annotation>
                <xs:documentation>110--3--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FALL_BACK_LANGUAGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
                <xs:documentation>K. Richter 29.06.2017</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
                <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW  </xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW </xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SUPPLIER">
        <xs:annotation>
          <xs:documentation>100--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EDI_INFO" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>105--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EDI_FORMAT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--2--EDI_Format</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                        <xs:pattern value="EANCOM|EAN 97|EAN 97 A|EDIDATA" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_FORMAT_VERSION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="10" />
                        <xs:pattern value="[1-9]\.[0-9]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_MESSAGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_COMMUNICATION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="40" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_CONTACT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="60" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="BRANCH_ID">
              <xs:annotation>
                <xs:documentation>100--8--Branchen_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[ABGKOPSWZ]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="GLN_NO" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>100--45--GLN_Nr 30.05.2012/Bur</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, verpflichtend, K. Richter 21.08.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9]{13}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="WEEE_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--47--WEEE_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_PERSON" maxOccurs="2">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CONTACT_PERSON_NO">
                    <xs:annotation>
                      <xs:documentation>100--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_ROLE">
                    <xs:annotation>
                      <xs:documentation>100--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="60" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_NAME">
                    <xs:annotation>
                      <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FIRST_NAME">
                    <xs:annotation>
                      <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FORM_OF_ADDRESS">
                    <xs:annotation>
                      <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DEPARTMENT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE">
                    <xs:annotation>
                      <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CONTACT_SUPPLIER">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_NAME_1">
                    <xs:annotation>
                      <xs:documentation>100--16--Herstellername_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--17--Herstellername_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INTERNET_ADDRESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--19--Internet_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET">
                    <xs:annotation>
                      <xs:documentation>100--20--Strasse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET">
                    <xs:annotation>
                      <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY">
                    <xs:annotation>
                      <xs:documentation>100--22--Ort</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--24--Postfach</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="GLOBAL_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLEARING_GROUP" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>120--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>120--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CLEARING_GROUP_NAME" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="CLEARING_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONTS_HANDLE_POSITIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SPECIFIC_HANDLE_POSITIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SPECIFIC_HANDLE_ORIENTATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="STYLE_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="STYLE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FRONT_TYPE_GROUP_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="WIDTH_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--4--Breite_von</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="WIDTH_TO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--5--Breite_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HEIGHT_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--6--Hoehe_von</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HEIGHT_TO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--7--Hoehe_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OPTION_REF">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="154" />
                                        <xs:maxInclusive value="154" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="HANDLE_EXCHANGE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="FEATURE_REF">
                                      <xs:annotation>
                                        <xs:documentation>232--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>232--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FROM_HANDLE">
                                      <xs:annotation>
                                        <xs:documentation>232--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="OPTION_REF">
                                            <xs:annotation>
                                              <xs:documentation>232--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>232--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="300" />
                                                    <xs:maxInclusive value="303" />
                                                    <xs:pattern value="300|303" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>232--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="5" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="TO_HANDLE">
                                      <xs:annotation>
                                        <xs:documentation>232--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="OPTION_REF">
                                            <xs:annotation>
                                              <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="300" />
                                                    <xs:maxInclusive value="303" />
                                                    <xs:pattern value="300|303" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="5" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="HANDLE_ORIENTATION_EXCHANGE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="FROM_HANDLE_ORIENTATION_REF">
                                      <xs:annotation>
                                        <xs:documentation>232--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>232--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="TO_HANDLE_ORIENTATION_REF">
                                      <xs:annotation>
                                        <xs:documentation>----</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>----</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRIORITY">
                                <xs:annotation>
                                  <xs:documentation>232--14--Prioritaet</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="BASIC_HANDLE_POSITIONS">
                    <xs:annotation>
                      <xs:documentation>230--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="HANDLE_ORIENTATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>230--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_TYPE" maxOccurs="7">
                                <xs:annotation>
                                  <xs:documentation>230--3--Fronttyp</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ORIENTATION">
                                      <xs:annotation>
                                        <xs:documentation>230--4--Lage</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[HV]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="POSITION">
                                      <xs:annotation>
                                        <xs:documentation>230--5--Position</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[MADG0]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="FRONT_TYPE_CODE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>230--3--Fronttyp</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[SAKJTR]|GT" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>230--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FRONT_TYPES_GROUPS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>231--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_TYPES_GROUP" maxOccurs="99">
                          <xs:annotation>
                            <xs:documentation>231--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_TYPE" maxOccurs="7">
                                <xs:annotation>
                                  <xs:documentation>231--3--Fronttyp</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FRONT_TYPE_CODE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>231--3--Fronttyp</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[SAKJTR]|GT" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>231--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONT_APPEARANCES" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_APPEARANCE" maxOccurs="999">
                    <xs:annotation>
                      <xs:documentation>520--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_TYPE" maxOccurs="900">
                          <xs:annotation>
                            <xs:documentation>520--3--Fronttyp</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_TYPE_NO">
                                <xs:annotation>
                                  <xs:documentation>520/570--3/3--Fronttyp</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="900" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:sequence maxOccurs="unbounded">
                                <xs:element name="FRONT_CONSTRAINTS" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="WIDTH_FROM" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>520/570--6--Breite_von</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="WIDTH_TO" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>520/570--7--Breite_von</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="HEIGHT_FROM" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="HEIGHT_TO" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="FRONT_SHAPE">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="GLASS">
                                        <xs:annotation>
                                          <xs:documentation>520--10--Glas</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:boolean" />
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:choice>
                                        <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="BASIC_FRONT_SHAPE" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="BASIC_FRONT_SHAPE_ID">
                                                <xs:annotation>
                                                  <xs:documentation>520--4--Front_Grundform</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="3" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PARAMETERS" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="VALUE">
                                                    <xs:annotation>
                                                      <xs:documentation>520--5--Wert</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:maxLength value="12" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="PARAMETER">
                                                    <xs:annotation>
                                                      <xs:documentation>570--4--Parameter</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:minLength value="1" />
                                                        <xs:maxLength value="5" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:choice>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>520--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="MODULE_RULE_SET_DEFINITIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MODULE_RULE_SET_DEFINITION" maxOccurs="unbounded">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MODULE_RULE_SET_NAME" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Um Mehrsprachenfaehigkeit erweitert AK 28.02.2012</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
13.06.2018/K.Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLASSIFICATION">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="8" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="INFO_TYPE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
                            <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
                            <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[01]|99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="INTERNAL_NAME" type="languagetexte40">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="GUID">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="URL">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:anyURI">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="1024" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="HASH_VALUE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="64" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="RESOLUTION" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="4" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PROPERTIES" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>Version 2.3 </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PROPERTY" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>Version 2.3</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PROPERTY_TEXT" type="languagetexte" minOccurs="1" maxOccurs="1" />
                        <xs:element name="PROPERTY_UNIT" type="languagetexte30" minOccurs="0" maxOccurs="1" />
                      </xs:sequence>
                      <xs:attribute name="PROPERTY_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="GROUP_TITLES" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>120--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="GROUP_TITLE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>120--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="GROUP_TITLE_NAME" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="GROUP_TITLE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIES">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE" maxOccurs="100">
              <xs:annotation>
                <xs:documentation>200--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_CLASS_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SERIES_NAME">
                    <xs:annotation>
                      <xs:documentation>200--3--Serienname</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>200--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>200--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PURCHASE_RETAIL_ID">
                    <xs:annotation>
                      <xs:documentation>200--5--EK_VK_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="RESTRICTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="RESTRICTION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SUGGESTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SUGGESTION_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SUGGESTION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRODUCT_GROUPS">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_CLASS_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEMS">
                                <xs:annotation>
                                  <xs:documentation>400--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECO_MOBILIER" minOccurs="0">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[0-9]{11}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="NET_WEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                            <xs:annotation>
                                              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence minOccurs="0">
                                                <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>450/470--1--Satzart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="PRICE_FIELD">
                                                        <xs:annotation>
                                                          <xs:documentation>450--4--Preisfeld</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="250" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PRICE">
                                                        <xs:annotation>
                                                          <xs:documentation>450--5--Preis</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:integer">
                                                            <xs:minInclusive value="-99999999" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:boolean" />
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>470--4--Preis</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:integer">
                                                            <xs:minInclusive value="-99999999" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="99999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="PRICE_TYPE_REF">
                                            <xs:annotation>
                                              <xs:documentation>400/407--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400/407--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CALC_GROUP_REF">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="CALC_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="10" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="PRICE_FEATURE_GROUP_REF">
                                                  <xs:annotation>
                                                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>460--1--Satzart</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="PRICE_FIELD">
                                                              <xs:annotation>
                                                                <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="250" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="PRICE">
                                                              <xs:annotation>
                                                                <xs:documentation>460--5--Preis</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:integer">
                                                                  <xs:minInclusive value="-99999999" />
                                                                  <xs:maxInclusive value="999999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="99999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="CALC_GROUP_REF" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="CALC_GROUP_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="10" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:pattern value="[0-9]|[1-8][0-9]" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="PRICE_TYPE_REF">
                                                  <xs:annotation>
                                                    <xs:documentation>407--5--Preisart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>407--5--Preisart</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="RESTRICTIONS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>409--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>409--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="RESTRICTION_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>409--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SEQUENCE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>409--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:maxInclusive value="99999" />
                                                          <xs:minInclusive value="1" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>406--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                                        <xs:annotation>
                                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                                          <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>120--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                            <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                              <xs:annotation>
                                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="SERIE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="99" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="TYPE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:minLength value="1" />
                                                                      <xs:maxLength value="15" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--7--Anzahl</xs:documentation>
                                                                    <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:positiveInteger">
                                                                      <xs:minInclusive value="1" />
                                                                      <xs:maxInclusive value="999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="SEQUENCE" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>Version 2.4.1</xs:documentation>
                                                                    <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:maxInclusive value="99999" />
                                                                      <xs:minInclusive value="1" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="SET_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="9" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                                        <xs:annotation>
                                                          <xs:documentation>406--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>120--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                            <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                              <xs:annotation>
                                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="SERIE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="99" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="TYPE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:minLength value="1" />
                                                                      <xs:maxLength value="15" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--7--Anzahl</xs:documentation>
                                                                    <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:positiveInteger">
                                                                      <xs:minInclusive value="1" />
                                                                      <xs:maxInclusive value="999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="SEQUENCE" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>Version 2.4.1</xs:documentation>
                                                                    <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:maxInclusive value="99999" />
                                                                      <xs:minInclusive value="1" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="SET_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="9" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="OPERATION_ITEM" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--1--Satzart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="SCOPE" maxOccurs="5">
                                                        <xs:annotation>
                                                          <xs:documentation>411--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                                                              <xs:annotation>
                                                                <xs:documentation>411--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="CLASS">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--7--Art</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="21" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="ITEM_REF" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:complexType>
                                                                      <xs:attribute name="SERIE_NO" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>411--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="99" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="TYPE_NO" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>411--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:string">
                                                                            <xs:minLength value="1" />
                                                                            <xs:maxLength value="15" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                    </xs:complexType>
                                                                  </xs:element>
                                                                  <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="[LNR]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="COVER" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--9--Abdeckung</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="3" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="VALUE" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--10--Wert</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="VALUE_MIN" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                                                      <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="VALUE_MAX" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                                                      <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="SCOPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>411--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="5" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="HINGE">
                                            <xs:annotation>
                                              <xs:documentation>400--4--Anschlag</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[BEJLMNR]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="EDP_NUMBER" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="EAN_NUMBER" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="9" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="ITEM_IDENTIFICATION">
                                            <xs:annotation>
                                              <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[BEKSMZVPNOG]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="CATALOG_PAGE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="40" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
                                              <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
                                              <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:maxInclusive value="999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VAT_ID_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="VAT_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="VALID_FROM" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:date" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VALID_UNTIL" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:date" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="WEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--20--Gewicht</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VOLUME" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--21--Volumen</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="CONSTRUCTION_ID">
                                            <xs:annotation>
                                              <xs:documentation>400--23--Bauweise_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[JLNRAE]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="OLD_SERIE_NO" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="99" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="OLD_TYPE_NO" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--27--Type_Alt</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="MASKING" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--30--Maskierung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:boolean" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="RANGE_DEPENDENT">
                                            <xs:annotation>
                                              <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:boolean" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="2" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BASIC_PROFILE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:choice>
                                                  <xs:element name="CARCASE_BASIC_SHAPE">
                                                    <xs:annotation>
                                                      <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                                          <xs:annotation>
                                                            <xs:documentation>400--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType mixed="true">
                                                            <xs:sequence>
                                                              <xs:element name="OPTION_REF">
                                                                <xs:annotation>
                                                                  <xs:documentation>430--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:complexType>
                                                                  <xs:attribute name="FEATURE_NO" use="required">
                                                                    <xs:annotation>
                                                                      <xs:documentation>430--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="OPTION_KEY" use="required">
                                                                    <xs:annotation>
                                                                      <xs:documentation>430--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:minLength value="1" />
                                                                        <xs:maxLength value="5" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                </xs:complexType>
                                                              </xs:element>
                                                            </xs:sequence>
                                                            <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>400--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[\S ]{1,5}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                          </xs:complexType>
                                                        </xs:element>
                                                        <xs:element name="BASIC_SHAPE_PARAMETERS">
                                                          <xs:annotation>
                                                            <xs:documentation>500--1--Satzart</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:sequence>
                                                              <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                                <xs:annotation>
                                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:complexType>
                                                                  <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--Parameter</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--5--Nennwert</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="BASIC_SHAPE_FROM">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--6--Von</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="BASIC_SHAPE_TO">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--7--Bis</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                </xs:complexType>
                                                              </xs:element>
                                                            </xs:sequence>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                      <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                  <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                                    <xs:annotation>
                                                      <xs:documentation>400--32--Massbild</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                                          <xs:annotation>
                                                            <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:string">
                                                              <xs:minLength value="1" />
                                                              <xs:maxLength value="240" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:element>
                                                        <xs:element name="DIMENSIONAL_PARAMETERS">
                                                          <xs:annotation>
                                                            <xs:documentation>500--1--Satzart</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:sequence>
                                                              <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                                <xs:annotation>
                                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:complexType>
                                                                  <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="DIMENSIONAL_FROM">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="DIMENSIONAL_TO">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                </xs:complexType>
                                                              </xs:element>
                                                            </xs:sequence>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                      <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>400--32--Massbild</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:minLength value="1" />
                                                            <xs:maxLength value="20" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:choice>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="BLOCK_PARTS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="BLOCK_SEQUENTIAL_NO">
                                                        <xs:annotation>
                                                          <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_REF">
                                                        <xs:annotation>
                                                          <xs:documentation>401--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="TYPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="SERIE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="99" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>401--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="FEATURE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="OPTION_KEY" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="5" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="HINGE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--6--Anschlag</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[BEJLMNR]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="EXCHANGE_CONDITION">
                                                        <xs:annotation>
                                                          <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="2" />
                                                            <xs:maxInclusive value="3" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="STATUS">
                                                        <xs:annotation>
                                                          <xs:documentation>401--8--Status</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[ABELSZ]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[JLNRAE]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="MODULE_PARTS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="MODULE_PART" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="PART_SEQUENTIAL_NO">
                                                        <xs:annotation>
                                                          <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:maxInclusive value="999" />
                                                            <xs:minInclusive value="0" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_REF">
                                                        <xs:annotation>
                                                          <xs:documentation>401--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="TYPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="SERIE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="99" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                      </xs:element>
                                                      <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="SHORT_TEXT">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>410--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TEXT_LINE" maxOccurs="3">
                                                              <xs:annotation>
                                                                <xs:documentation>410--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="TEXT">
                                                                    <xs:annotation>
                                                                      <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="[\S ]{1,30}" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                                <xs:attribute name="SEQUENCE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:positiveInteger" />
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:language">
                                                                <xs:pattern value="[A-Z]{2}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="TYPE_KEY">
                                            <xs:annotation>
                                              <xs:documentation>445--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TK_TYPE">
                                                  <xs:annotation>
                                                    <xs:documentation>445--4--TS_Typ</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_CLASS">
                                                  <xs:annotation>
                                                    <xs:documentation>445--5--TS_Art</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                                  <xs:annotation>
                                                    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>445--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                                <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="9999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SEQUENCE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger" />
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                                      <xs:annotation>
                                                        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="TK_MATERIAL" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--21--TS_Material</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-2]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_SHAPE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--22--TS_Form</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-2]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ECLASS">
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="ECLASS_NO">
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:totalDigits value="8" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FRONT_DIVISIONS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>510--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="FRONT_GROUP" maxOccurs="99">
                                                  <xs:annotation>
                                                    <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="FRONT_DIVISION_DEF">
                                                              <xs:annotation>
                                                                <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:minLength value="1" />
                                                                  <xs:maxLength value="250" />
                                                                  <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:minLength value="1" />
                                                                  <xs:maxLength value="15" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="FRONT_CELL_NO">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--6--Zellennummer</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="99" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="FRONT_TYPE" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--7--Fronttyp</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="900" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="4" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="4" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="PARAMETER_1" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--12--Parameter_1</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="99" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="PARAMETER_2" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--13--Parameter_2</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="99" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="9999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="9999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                  </xs:element>
                                                                  <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                  </xs:element>
                                                                  <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                  </xs:element>
                                                                  <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                  </xs:element>
                                                                  <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="4" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="UPPER_JOIN" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="|[VLSG]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="LOWER_JOIN" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="|[VLSG]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="LEFT_JOIN" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="|[VLSG]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="RIGHT_JOIN" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="|[VLSG]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="2" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="FRONT_GROUP_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:choice minOccurs="0">
                                            <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                            <xs:element name="MODULE_RULE_SETS" minOccurs="0">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="MODULE_RULES">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:sequence>
                                                              <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                                                                <xs:annotation>
                                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:complexType>
                                                                  <xs:sequence>
                                                                    <xs:element name="MODULE_POSITION">
                                                                      <xs:annotation>
                                                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:string">
                                                                          <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                                                          <xs:enumeration value="LINE_BOTTOM" />
                                                                          <xs:enumeration value="LINE_TOP" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:element>
                                                                    <xs:element name="MAX_VALUE" minOccurs="0">
                                                                      <xs:annotation>
                                                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                                          <xs:minInclusive value="0" />
                                                                          <xs:maxInclusive value="99999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:element>
                                                                    <xs:element name="MIN_VALUE" minOccurs="0">
                                                                      <xs:annotation>
                                                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                                          <xs:minInclusive value="0" />
                                                                          <xs:maxInclusive value="99999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:element>
                                                                  </xs:sequence>
                                                                </xs:complexType>
                                                              </xs:element>
                                                            </xs:sequence>
                                                          </xs:complexType>
                                                        </xs:element>
                                                        <xs:element name="MODULE_RULE_SET_REF">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                            </xs:attribute>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:choice>
                                          <xs:element name="DETAIL_INFOS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="PROPERTIES" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="PROPERTY_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="VALUE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="RESTRICTIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="RESTRICTION_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:maxInclusive value="99999" />
                                              <xs:minInclusive value="1" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DEFAULT_OPTION_GROUPS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>295--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DEFAULT_OPTION_GROUP" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DEFAULT_OPTION_GROUP_NAME" type="languagetexte30">
                                <xs:annotation>
                                  <xs:documentation>296--5--Name_Standard_Gruppe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="FILE_NAME" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>296--6--Dateiname</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OPTION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>295--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>295--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>295--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">Version 2.3 27.06.2014 K. Richter</xs:documentation>
                                  <xs:documentation>Bilder unterhalb des Standardvorschlages</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_CLASSES">
              <xs:annotation>
                <xs:documentation>255--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_CLASS" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>255--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FEATURE_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>255--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>255--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_CLASS_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>255--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURES">
              <xs:annotation>
                <xs:documentation>250--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="COMBINED_FEATURE" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>265--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF" minOccurs="2" maxOccurs="5">
                          <xs:annotation>
                            <xs:documentation>265--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>265--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="10[012346]|11[01234]|12[01234]|20[02345]|30[012]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>265--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>265--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="(105)|(115)|(125)|(201)|(303)" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>265--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FEATURE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:choice minOccurs="0">
                                      <xs:element name="STYLE_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="STYLE_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="5" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MATERIAL_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="MATERIAL_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="5" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="HANDLE_ORIENTATION_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="FORM_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="FORM_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="5" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_MEASURE_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_MEASURE_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="HANDLE_POSITION_REF">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="HANDLE_POSITION_NO" use="required">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999" />
                                                <xs:totalDigits value="3" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:choice>
                                    <xs:element name="OPTION_TEXT" type="languagetexte60">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="DETAIL_INFOS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE_NO">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FEATURE_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>250--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="SEQUENCE_NO">
                          <xs:annotation>
                            <xs:documentation>250--4--Sortierung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HEADER_POS_VARIATION_TYPE">
                          <xs:annotation>
                            <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[IKUPV]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="INHERIT_VARIATION_TYPE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>250--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>250--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="(202)|(203)|(205)|(208)" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_DEFINITION">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="STYLE" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>210--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_DEPTH" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>210--6--Front_Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FRONT_DISTANCE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>210--6--Türpuffer</xs:documentation>
                            <xs:documentation>K.Richter/13.06.2018</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FRONT_GROUP_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>210--12--Frontgruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FRONT_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>210--12--Frontgruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_CLASS_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>210--13--Var_Familien_Nr</xs:documentation>
                                <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DEFAULT_OPTION_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>295--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>295--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="RESTRICTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                            <xs:documentation>von minOcc 1 auf optional 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  <xs:documentation>von optional  auf  minOcc 1 2011-12-14</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="RESTRICTION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="STYLE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>210--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HANDLE_ORIENTATION" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DEFAULT_HANDLE_ORIENTATION_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:choice minOccurs="0">
                          <xs:annotation>
                            <xs:documentation />
                            <xs:documentation>AK 28.02.2012. Optional gesetzt um die alte 1.7 Logik zu erhalten.</xs:documentation>
                          </xs:annotation>
                          <xs:element name="COLOR">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="RGB_RED">
                                  <xs:annotation>
                                    <xs:documentation>260--11--RGB_Rot</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="255" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="RGB_GREEN">
                                  <xs:annotation>
                                    <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="255" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="RGB_BLUE">
                                  <xs:annotation>
                                    <xs:documentation>260--13--RGB_Blau</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="255" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="TEXTURE">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="FILE_NAME_TEXTURE">
                                  <xs:annotation>
                                    <xs:documentation>260--6--Dateiname_Textur</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="TEXTURE_REPEAT" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>260--9--Textur_Kachelung</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="REAL_MEASUREMENT_X">
                                        <xs:annotation>
                                          <xs:documentation>260--17--Realmass_X</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="REAL_MEASUREMENT_Y">
                                        <xs:annotation>
                                          <xs:documentation>260--18--Realmass_Y</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                    </xs:sequence>
                                    <xs:attribute name="TEXTURE_TILE">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:int">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="1" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MASKING" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>260--10--Maskierung</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:boolean" />
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="TEXTURE_DELIVERED_ORIENTATION">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:pattern value="|[HV]" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                        <xs:element name="TRANSPARENCY" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--14--Transparenz</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BRIGHTNESS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--15--Glanz</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="MATERIAL_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FORM" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PROFILE_KEY">
                          <xs:annotation>
                            <xs:documentation>430--4/5--Varianten_Art_Profilform/Var_Schluessel_</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FORM_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PLINTH_HEIGHT">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="STANDARD_PLINTH" type="xs:boolean" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Kennzeichnung zur Abweichung von Standardsockelhöhe</xs:documentation>
                            <xs:documentation>hinzugefügt K.Richter, 29.02.2016</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="OPTION_MEASURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>270/271--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION" maxOccurs="99999">
                    <xs:annotation>
                      <xs:documentation>270/271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>270--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF" maxOccurs="3">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:sequence minOccurs="0">
                                <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                                  <xs:annotation>
                                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="DIMENSION_TYPE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[WHD]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSION_VALUE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                                  <xs:annotation>
                                    <xs:documentation>405--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="DIMENSION_TYPE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[WHD]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSION_VALUE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TEST_ID">
                          <xs:annotation>
                            <xs:documentation>270--4--Pruef_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_1_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_2_NO">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_3_NO">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="VALIDATION_TYPE" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:int">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SUGGESTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>270/271--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SUGGESTION" maxOccurs="99999">
                    <xs:annotation>
                      <xs:documentation>270/271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SUGGESTION_NAME_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>270--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF" maxOccurs="3">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SUGGESTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_1_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_2_NO">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_3_NO">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_DEFINITION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>300--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
                                <xs:annotation>
                                  <xs:documentation>311--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>311--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>311--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_FIELD">
                                <xs:annotation>
                                  <xs:documentation>311--5--Preisfeld</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="SUPPLIER_PRICE_GROUP">
                                <xs:annotation>
                                  <xs:documentation>311--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="10" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="ADDITIONAL_PRICE" use="required">
                        <xs:annotation>
                          <xs:documentation>300--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:boolean" />
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="PRICE_CALC_METHOD" use="required">
                        <xs:annotation>
                          <xs:documentation>300--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="3" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_NO_1">
                        <xs:annotation>
                          <xs:documentation>300--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_NO_2">
                        <xs:annotation>
                          <xs:documentation>300--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_OF_EXCHANGE_IDS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>115--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>115--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="EXCHANGE_ID_TEXT" type="languagetexte40">
                          <xs:annotation>
                            <xs:documentation>115--3--Tausch_ID_Text</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>115--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="VALUE_ADDED_TAXES">
              <xs:annotation>
                <xs:documentation>360--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="VALUE_ADDED_TAX" maxOccurs="100">
                    <xs:annotation>
                      <xs:documentation>360--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="VAT_RATE">
                          <xs:annotation>
                            <xs:documentation>360--3--MwSt_Satz</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="VAT_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>360--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="IDENT_NUMBERS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>351--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="IDENT_NUMBER" minOccurs="0" maxOccurs="9999">
                    <xs:annotation>
                      <xs:documentation>351--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SERIE_REF" maxOccurs="99">
                          <xs:annotation>
                            <xs:documentation>351--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>351--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE">
                          <xs:annotation>
                            <xs:documentation>351--4--Preis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:integer">
                              <xs:minInclusive value="-99999999" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="IDENT_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>351--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="MERCHANDISE_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>350--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MERCHANDISE_GROUP_TEXT" type="languagetexte30">
                    <xs:annotation>
                      <xs:documentation>350--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      <xs:documentation>350--6--Warengruppentext</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:sequence>
                    <xs:element name="CALC_GROUP" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>350--1--Satzart</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="CALC_GROUP_TEXT" type="languagetexte30">
                            <xs:annotation>
                              <xs:documentation>350--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                          </xs:element>
                          <xs:element name="CALCULATION_FACTOR" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>350--4--Verrechnungsfaktor</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="99999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="CALC_GROUP_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>350--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="10" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:sequence>
                <xs:attribute name="MERCHANDISE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>350--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_TYPES">
              <xs:annotation>
                <xs:documentation>150--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence maxOccurs="unbounded">
                  <xs:element name="PRICE_TYPE">
                    <xs:annotation>
                      <xs:documentation>150--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="WIDTH_X">
                          <xs:annotation>
                            <xs:documentation>150--3--Breite_X</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DEPTH_Y">
                          <xs:annotation>
                            <xs:documentation>150--4--Tiefe_Y</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HEIGHT_Z">
                          <xs:annotation>
                            <xs:documentation>150--5--Hoehe_Z</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_UNIT">
                          <xs:annotation>
                            <xs:documentation>150--6--Basis_Einheit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ROUNDING_UNIT">
                          <xs:annotation>
                            <xs:documentation>150--7--Rundungseinheit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_PRICE_DEPENDENT">
                          <xs:annotation>
                            <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>150--9--Preisart_Formel</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="100" />
                              <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_NAME" type="languagetexte60" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>150--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="250" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BLOCK_VALUE_CALCULATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_CONDITIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>420--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_CONDITION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>420--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>420--3--Type_Block</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>420--3--Type_Block</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>420--3--Type_Block</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CONDITION_RULES">
                          <xs:annotation>
                            <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>420--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                                      <xs:annotation>
                                        <xs:documentation>420--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="CLEARING_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>420--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:choice>
                                      <xs:element name="MINIMUM_VALUE" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                    </xs:choice>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="BLOCK_SALE_PRICES" minOccurs="0">
              <xs:annotation>
                <xs:documentation>480--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>480--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>480--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>480--100--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="VALID_FROM">
                                <xs:annotation>
                                  <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL">
                                <xs:annotation>
                                  <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
                                <xs:annotation>
                                  <xs:documentation>480--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>480--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>480--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_OR_CALCULATION_POINT">
                                <xs:annotation>
                                  <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="GRADING_TABLE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>421--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>421--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>421--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>421--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>421--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>421--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="CLEARING_GROUP_ID">
                                      <xs:annotation>
                                        <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE_FROM">
                                      <xs:annotation>
                                        <xs:documentation>421--6--Wert_von</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE_TO">
                                      <xs:annotation>
                                        <xs:documentation>421--7--Wert_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TYPE_CREDIT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TYPE_DEBIT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>421--9--Type_Belastung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_OF_BLOCK_RULES">
              <xs:annotation>
                <xs:documentation>111--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>117--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="EXCHANGE_ID_1_REF">
                          <xs:annotation>
                            <xs:documentation>117--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>117--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="EXCHANGE_ID_2_REF">
                          <xs:annotation>
                            <xs:documentation>117--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>117--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RULE" maxOccurs="99">
                    <xs:annotation>
                      <xs:documentation>111--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RULE_TEXT" type="languagetexte60999">
                          <xs:annotation>
                            <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="RULE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>113--3--Regel_Nr</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RULE_SET_TEXT" type="languagetexte60999">
                    <xs:annotation>
                      <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MAJOR" use="required">
      <xs:annotation>
        <xs:documentation>100--3--Versionsnummer</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="2" />
          <xs:maxInclusive value="2" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MINOR" use="required">
      <xs:annotation>
        <xs:documentation>100--4--Sub_Versions_Nr</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="REVISION" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also

IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Signature Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : Signature Element
Description

This element defines the type of encryption.

The root element of a digital signature via XML is represented by the element Signature.

Signature has two child elements in which the elements SignedInfo and SignatureValue are mandatory.

Namespace (none)
Diagram
SignatureValue Element SignedInfo Element Sequence Signature Element
Overview
Signature optional

This element defines the type of encryption.

The root element of a digital signature via XML is represented by the element Signature.

Signature has two child elements in which the elements SignedInfo and SignatureValue are mandatory.

Sequence
SignedInfo

The first and most complex element of Signature is the element SignedInfo. This element contains the utilized algorithms for canonization and signature, one or more references to the signed data, and probable transformations as well as the hash values of these data. Moreover the element SignedInfo contains all relevant information about the resources which are signed and is therefore the part for which the digital signature is defined.

Digital signature of the algorithms is used for the purpose of data security. A secure algorithm cannot be exchanged by an insecure without cancellation of the signature.

Child elements of SignedInfo are the mandatory elements CanonizationMethod and SignatureMethod as well as one or more Reference elements.

Sequence
CanonicalizationMethod Extension of xs:string

The mandatory element CanonizationMethod contains an Algorithm attribute which identifies the canonization algorithm which is applied to the data with priority over signature evaluation in the element SignedInfo.

The canonization of an XML is split up into the following actions:

  • A document is encoded into UTF-8 format
  • Line breaks are normalised to #xA before parsing
  • The values of attributes are normalised (similar to validating parsers)
  • Character- and parsed-entity references are replaced
  • CDATA paragraphs are replaced by their contents
  • The XML declaration and a probably existing DTD are removed
  • Blank elements are converted to start-end-tag pairs
  • Whitespace outside of the document element and inside the start- and end-tags is normalised
  • Whitespace in text knots is kept (except signs which were removed by the normalisation of line breaks)
  • The values of attributes are given in double quotation marks
  • Special characters in attribute values and text knots are replaced by sign references
  • Redundant namespace declarations in front of each element are removed
  • Default attributes are added to the elements
  • The sort order of namespace declarations and attributes is alphanumeric
Algorithm optional xs:anyURI

This attribute is used to identify the canonization algorithm that is applied to the data in SignedInfo prior to the signature calculation. It is specified as an URI. D anyURI
P
M

SignatureMethod Extension of xs:string
SignatureMethod is another mandatory, blank element with an algorithm attribute, which defines the algorithm used for the generation (and following the validation) of the signature. This algorithm is used for converting the canonical element SignedInfo into the element SignatureValue.
Algorithm optional xs:anyURI

This attribute is used to specify the algorithm for signature generation via an URI.

 D anyURI
P
M
Reference

The element reference defines the random data (binary data permitted, too) which are included in the signature calculation. The element reference is therefore the core element of a signature.

XML-signatures never sign the resources directly. First a list of hash values is generated. This list is signed with the defined algorithm. In this way the process of the signature generation is accelerated and simplified as a number of resources is signed simultaneously.

The element reference is linked to the optional attribute URI.

URI optional xs:string

The URI attribute is also of the anyURI type and contains the address under which the data to be signed are available. The data that relates to the digital signature do not necessarily have to be contained in the Signature element itself, but can also be referenced via the local file system or an URL.

There are also other URIs that refer to the current document, e.g. URI="". This specific Uniform Resource Identifier represents all XML nodes of the current document, but without any potentially existing comments. The nodes associated with the signature are however included in the selection.

 D anyURI
P
M
Sequence
Transforms

The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.

Sequence
Transform Extension of xs:string

The Transform element is used to specify the transformations to be performed. It consists of an Algorithm attribute together with the applicable transformation algorithm.

 D string
P
M
Algorithm optional xs:anyURI

This attribute is used for defining a transformation algorithm by means of an URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.
Algorithm optional xs:anyURI

This attribute is used for defining the URI which identifies the message digest algorithm.

D anyURI
P
M
DigestValue xs:string
The algorithm specified in DigestMethod is used to calculate DigestValue, a unique hash value of the signed object and to store it in this element via Base-64 encoding. The hash value, also known as digital fingerprint, is usually shorter than the signed data and can therefore be signed faster in the step to follow. It is virtually impossible to reconstruct the original message from a hash value. It should also be impossible for two different messages to result in identical hash values (collision and birthday paradox). D string
P
M
SignatureValue xs:string

The SignatureValue element contains the signature's hash value calculated for the entire SignedInfo element in binary format (always Base-64 encoding). This hash value is calculated by the algorithm specified in SignatureMethod using the canonized data and private key. This means that the signature is not affixed to the message itself, but rather to the - usually much shorter - hash value (hash-then-sign paradigm).

The signed data thus contain additional information about the signed references and their hash values. This makes it unnecessary for the data to be present in the document. The information about the applied algorithms is however used in the calculation of the signature. This prevents manipulations down the track.

Because all references are pooled and signed collectively prior to signing, there is precisely one SignatureValue element for the entire signature.

 D string
P
M
Source
<xs:element name="Signature" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SignedInfo">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CanonicalizationMethod">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="SignatureMethod">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="Reference">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="Transforms">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="Transform">
                          <xs:complexType>
                            <xs:simpleContent>
                              <xs:extension base="xs:string">
                                <xs:attribute name="Algorithm" type="xs:anyURI" />
                              </xs:extension>
                            </xs:simpleContent>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DigestMethod">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DigestValue" type="xs:string" />
                </xs:sequence>
                <xs:attribute name="URI" type="xs:string" />
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SignatureValue" type="xs:string" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SignedInfo Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element : SignedInfo Element
Description

The first and most complex element of Signature is the element SignedInfo. This element contains the utilized algorithms for canonization and signature, one or more references to the signed data, and probable transformations as well as the hash values of these data. Moreover the element SignedInfo contains all relevant information about the resources which are signed and is therefore the part for which the digital signature is defined.

Digital signature of the algorithms is used for the purpose of data security. A secure algorithm cannot be exchanged by an insecure without cancellation of the signature.

Child elements of SignedInfo are the mandatory elements CanonizationMethod and SignatureMethod as well as one or more Reference elements.

Namespace (none)
Diagram
Reference Element SignatureMethod Element CanonicalizationMethod Element Sequence SignedInfo Element
Overview
SignedInfo

The first and most complex element of Signature is the element SignedInfo. This element contains the utilized algorithms for canonization and signature, one or more references to the signed data, and probable transformations as well as the hash values of these data. Moreover the element SignedInfo contains all relevant information about the resources which are signed and is therefore the part for which the digital signature is defined.

Digital signature of the algorithms is used for the purpose of data security. A secure algorithm cannot be exchanged by an insecure without cancellation of the signature.

Child elements of SignedInfo are the mandatory elements CanonizationMethod and SignatureMethod as well as one or more Reference elements.

Sequence
CanonicalizationMethod Extension of xs:string

The mandatory element CanonizationMethod contains an Algorithm attribute which identifies the canonization algorithm which is applied to the data with priority over signature evaluation in the element SignedInfo.

The canonization of an XML is split up into the following actions:

  • A document is encoded into UTF-8 format
  • Line breaks are normalised to #xA before parsing
  • The values of attributes are normalised (similar to validating parsers)
  • Character- and parsed-entity references are replaced
  • CDATA paragraphs are replaced by their contents
  • The XML declaration and a probably existing DTD are removed
  • Blank elements are converted to start-end-tag pairs
  • Whitespace outside of the document element and inside the start- and end-tags is normalised
  • Whitespace in text knots is kept (except signs which were removed by the normalisation of line breaks)
  • The values of attributes are given in double quotation marks
  • Special characters in attribute values and text knots are replaced by sign references
  • Redundant namespace declarations in front of each element are removed
  • Default attributes are added to the elements
  • The sort order of namespace declarations and attributes is alphanumeric
Algorithm optional xs:anyURI

This attribute is used to identify the canonization algorithm that is applied to the data in SignedInfo prior to the signature calculation. It is specified as an URI. D anyURI
P
M

SignatureMethod Extension of xs:string
SignatureMethod is another mandatory, blank element with an algorithm attribute, which defines the algorithm used for the generation (and following the validation) of the signature. This algorithm is used for converting the canonical element SignedInfo into the element SignatureValue.
Algorithm optional xs:anyURI

This attribute is used to specify the algorithm for signature generation via an URI.

 D anyURI
P
M
Reference

The element reference defines the random data (binary data permitted, too) which are included in the signature calculation. The element reference is therefore the core element of a signature.

XML-signatures never sign the resources directly. First a list of hash values is generated. This list is signed with the defined algorithm. In this way the process of the signature generation is accelerated and simplified as a number of resources is signed simultaneously.

The element reference is linked to the optional attribute URI.

URI optional xs:string

The URI attribute is also of the anyURI type and contains the address under which the data to be signed are available. The data that relates to the digital signature do not necessarily have to be contained in the Signature element itself, but can also be referenced via the local file system or an URL.

There are also other URIs that refer to the current document, e.g. URI="". This specific Uniform Resource Identifier represents all XML nodes of the current document, but without any potentially existing comments. The nodes associated with the signature are however included in the selection.

 D anyURI
P
M
Sequence
Transforms

The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.

Sequence
Transform Extension of xs:string

The Transform element is used to specify the transformations to be performed. It consists of an Algorithm attribute together with the applicable transformation algorithm.

 D string
P
M
Algorithm optional xs:anyURI

This attribute is used for defining a transformation algorithm by means of an URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.
Algorithm optional xs:anyURI

This attribute is used for defining the URI which identifies the message digest algorithm.

D anyURI
P
M
DigestValue xs:string
The algorithm specified in DigestMethod is used to calculate DigestValue, a unique hash value of the signed object and to store it in this element via Base-64 encoding. The hash value, also known as digital fingerprint, is usually shorter than the signed data and can therefore be signed faster in the step to follow. It is virtually impossible to reconstruct the original message from a hash value. It should also be impossible for two different messages to result in identical hash values (collision and birthday paradox). D string
P
M
Source
<xs:element name="SignedInfo" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CanonicalizationMethod">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="SignatureMethod">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="Reference">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="Transforms">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="Transform">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DigestMethod">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="DigestValue" type="xs:string" />
          </xs:sequence>
          <xs:attribute name="URI" type="xs:string" />
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CanonicalizationMethod Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element : CanonicalizationMethod Element
Description

The mandatory element CanonizationMethod contains an Algorithm attribute which identifies the canonization algorithm which is applied to the data with priority over signature evaluation in the element SignedInfo.

The canonization of an XML is split up into the following actions:

  • A document is encoded into UTF-8 format
  • Line breaks are normalised to #xA before parsing
  • The values of attributes are normalised (similar to validating parsers)
  • Character- and parsed-entity references are replaced
  • CDATA paragraphs are replaced by their contents
  • The XML declaration and a probably existing DTD are removed
  • Blank elements are converted to start-end-tag pairs
  • Whitespace outside of the document element and inside the start- and end-tags is normalised
  • Whitespace in text knots is kept (except signs which were removed by the normalisation of line breaks)
  • The values of attributes are given in double quotation marks
  • Special characters in attribute values and text knots are replaced by sign references
  • Redundant namespace declarations in front of each element are removed
  • Default attributes are added to the elements
  • The sort order of namespace declarations and attributes is alphanumeric
Namespace (none)
Type
Extension of xs:string
Diagram
CanonicalizationMethod Element
Overview
CanonicalizationMethod Extension of xs:string

The mandatory element CanonizationMethod contains an Algorithm attribute which identifies the canonization algorithm which is applied to the data with priority over signature evaluation in the element SignedInfo.

The canonization of an XML is split up into the following actions:

  • A document is encoded into UTF-8 format
  • Line breaks are normalised to #xA before parsing
  • The values of attributes are normalised (similar to validating parsers)
  • Character- and parsed-entity references are replaced
  • CDATA paragraphs are replaced by their contents
  • The XML declaration and a probably existing DTD are removed
  • Blank elements are converted to start-end-tag pairs
  • Whitespace outside of the document element and inside the start- and end-tags is normalised
  • Whitespace in text knots is kept (except signs which were removed by the normalisation of line breaks)
  • The values of attributes are given in double quotation marks
  • Special characters in attribute values and text knots are replaced by sign references
  • Redundant namespace declarations in front of each element are removed
  • Default attributes are added to the elements
  • The sort order of namespace declarations and attributes is alphanumeric
Algorithm optional xs:anyURI

This attribute is used to identify the canonization algorithm that is applied to the data in SignedInfo prior to the signature calculation. It is specified as an URI. D anyURI
P
M

Attributes
Name Type Use Default Fixed Description
Algorithm xs:anyURI optional

This attribute is used to identify the canonization algorithm that is applied to the data in SignedInfo prior to the signature calculation. It is specified as an URI. D anyURI
P
M

Source
<xs:element name="CanonicalizationMethod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
See Also
SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SignatureMethod Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element : SignatureMethod Element
Description
SignatureMethod is another mandatory, blank element with an algorithm attribute, which defines the algorithm used for the generation (and following the validation) of the signature. This algorithm is used for converting the canonical element SignedInfo into the element SignatureValue.
Namespace (none)
Type
Extension of xs:string
Diagram
SignatureMethod Element
Overview
SignatureMethod Extension of xs:string
SignatureMethod is another mandatory, blank element with an algorithm attribute, which defines the algorithm used for the generation (and following the validation) of the signature. This algorithm is used for converting the canonical element SignedInfo into the element SignatureValue.
Algorithm optional xs:anyURI

This attribute is used to specify the algorithm for signature generation via an URI.

 D anyURI
P
M
Attributes
Name Type Use Default Fixed Description
Algorithm xs:anyURI optional

This attribute is used to specify the algorithm for signature generation via an URI.

 D anyURI
P
M
Source
<xs:element name="SignatureMethod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
See Also
SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Reference Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element : Reference Element
Description

The element reference defines the random data (binary data permitted, too) which are included in the signature calculation. The element reference is therefore the core element of a signature.

XML-signatures never sign the resources directly. First a list of hash values is generated. This list is signed with the defined algorithm. In this way the process of the signature generation is accelerated and simplified as a number of resources is signed simultaneously.

The element reference is linked to the optional attribute URI.

Namespace (none)
Diagram
DigestValue Element DigestMethod Element Transforms Element Sequence Reference Element
Overview
Reference

The element reference defines the random data (binary data permitted, too) which are included in the signature calculation. The element reference is therefore the core element of a signature.

XML-signatures never sign the resources directly. First a list of hash values is generated. This list is signed with the defined algorithm. In this way the process of the signature generation is accelerated and simplified as a number of resources is signed simultaneously.

The element reference is linked to the optional attribute URI.

URI optional xs:string

The URI attribute is also of the anyURI type and contains the address under which the data to be signed are available. The data that relates to the digital signature do not necessarily have to be contained in the Signature element itself, but can also be referenced via the local file system or an URL.

There are also other URIs that refer to the current document, e.g. URI="". This specific Uniform Resource Identifier represents all XML nodes of the current document, but without any potentially existing comments. The nodes associated with the signature are however included in the selection.

 D anyURI
P
M
Sequence
Transforms

The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.

Sequence
Transform Extension of xs:string

The Transform element is used to specify the transformations to be performed. It consists of an Algorithm attribute together with the applicable transformation algorithm.

 D string
P
M
Algorithm optional xs:anyURI

This attribute is used for defining a transformation algorithm by means of an URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.
Algorithm optional xs:anyURI

This attribute is used for defining the URI which identifies the message digest algorithm.

D anyURI
P
M
DigestValue xs:string
The algorithm specified in DigestMethod is used to calculate DigestValue, a unique hash value of the signed object and to store it in this element via Base-64 encoding. The hash value, also known as digital fingerprint, is usually shorter than the signed data and can therefore be signed faster in the step to follow. It is virtually impossible to reconstruct the original message from a hash value. It should also be impossible for two different messages to result in identical hash values (collision and birthday paradox). D string
P
M
Attributes
Name Type Use Default Fixed Description
URI xs:string optional

The URI attribute is also of the anyURI type and contains the address under which the data to be signed are available. The data that relates to the digital signature do not necessarily have to be contained in the Signature element itself, but can also be referenced via the local file system or an URL.

There are also other URIs that refer to the current document, e.g. URI="". This specific Uniform Resource Identifier represents all XML nodes of the current document, but without any potentially existing comments. The nodes associated with the signature are however included in the selection.

 D anyURI
P
M
Source
<xs:element name="Reference" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Transforms">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="Transform">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DigestMethod">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="DigestValue" type="xs:string" />
    </xs:sequence>
    <xs:attribute name="URI" type="xs:string" />
  </xs:complexType>
</xs:element>
See Also
SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Transforms Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element > Reference Element : Transforms Element
Description

The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.

Namespace (none)
Diagram
Transform Element Sequence Transforms Element
Overview
Transforms

The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.

Sequence
Transform Extension of xs:string

The Transform element is used to specify the transformations to be performed. It consists of an Algorithm attribute together with the applicable transformation algorithm.

 D string
P
M
Algorithm optional xs:anyURI

This attribute is used for defining a transformation algorithm by means of an URI.

 D anyURI
P
M
Source
<xs:element name="Transforms" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Transform">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
Reference Element | SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Transform Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element > Reference Element > Transforms Element : Transform Element
Description

The Transform element is used to specify the transformations to be performed. It consists of an Algorithm attribute together with the applicable transformation algorithm.

 D string
P
M
Namespace (none)
Type
Extension of xs:string
Diagram
Transform Element
Overview
Transform Extension of xs:string

The Transform element is used to specify the transformations to be performed. It consists of an Algorithm attribute together with the applicable transformation algorithm.

 D string
P
M
Algorithm optional xs:anyURI

This attribute is used for defining a transformation algorithm by means of an URI.

 D anyURI
P
M
Attributes
Name Type Use Default Fixed Description
Algorithm xs:anyURI optional

This attribute is used for defining a transformation algorithm by means of an URI.

 D anyURI
P
M
Source
<xs:element name="Transform" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
See Also
Transforms Element | Reference Element | SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DigestMethod Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element > Reference Element : DigestMethod Element
Description
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.
Namespace (none)
Type
Extension of xs:string
Diagram
DigestMethod Element
Overview
DigestMethod Extension of xs:string
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.
Algorithm optional xs:anyURI

This attribute is used for defining the URI which identifies the message digest algorithm.

D anyURI
P
M
Attributes
Name Type Use Default Fixed Description
Algorithm xs:anyURI optional

This attribute is used for defining the URI which identifies the message digest algorithm.

D anyURI
P
M
Source
<xs:element name="DigestMethod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
See Also
Reference Element | SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DigestValue Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element > Reference Element : DigestValue Element
Description
The algorithm specified in DigestMethod is used to calculate DigestValue, a unique hash value of the signed object and to store it in this element via Base-64 encoding. The hash value, also known as digital fingerprint, is usually shorter than the signed data and can therefore be signed faster in the step to follow. It is virtually impossible to reconstruct the original message from a hash value. It should also be impossible for two different messages to result in identical hash values (collision and birthday paradox). D string
P
M
Namespace (none)
Type
xs:string
Diagram
DigestValue Element
Overview
DigestValue xs:string
The algorithm specified in DigestMethod is used to calculate DigestValue, a unique hash value of the signed object and to store it in this element via Base-64 encoding. The hash value, also known as digital fingerprint, is usually shorter than the signed data and can therefore be signed faster in the step to follow. It is virtually impossible to reconstruct the original message from a hash value. It should also be impossible for two different messages to result in identical hash values (collision and birthday paradox). D string
P
M
Source
<xs:element name="DigestValue" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Reference Element | SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SignatureValue Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element : SignatureValue Element
Description

The SignatureValue element contains the signature's hash value calculated for the entire SignedInfo element in binary format (always Base-64 encoding). This hash value is calculated by the algorithm specified in SignatureMethod using the canonized data and private key. This means that the signature is not affixed to the message itself, but rather to the - usually much shorter - hash value (hash-then-sign paradigm).

The signed data thus contain additional information about the signed references and their hash values. This makes it unnecessary for the data to be present in the document. The information about the applied algorithms is however used in the calculation of the signature. This prevents manipulations down the track.

Because all references are pooled and signed collectively prior to signing, there is precisely one SignatureValue element for the entire signature.

 D string
P
M
Namespace (none)
Type
xs:string
Diagram
SignatureValue Element
Overview
SignatureValue xs:string

The SignatureValue element contains the signature's hash value calculated for the entire SignedInfo element in binary format (always Base-64 encoding). This hash value is calculated by the algorithm specified in SignatureMethod using the canonized data and private key. This means that the signature is not affixed to the message itself, but rather to the - usually much shorter - hash value (hash-then-sign paradigm).

The signed data thus contain additional information about the signed references and their hash values. This makes it unnecessary for the data to be present in the document. The information about the applied algorithms is however used in the calculation of the signature. This prevents manipulations down the track.

Because all references are pooled and signed collectively prior to signing, there is precisely one SignatureValue element for the entire signature.

 D string
P
M
Source
<xs:element name="SignatureValue" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : CATALOG Element
Description
All administrative information about the catalogue/ database is stored in this element.
Namespace (none)
Diagram
DETAIL_INFOS Element FALL_BACK_LANGUAGE Element LANGUAGE Element Sequence CATALOG_INFO Element PRICING_TERMS Element FILLING_LEVEL Element CATALOG_MARK Element FILE_ID Element VALID_FROM_DATE Element DATA_VERSION Element LANGUAGE Element Sequence CATALOG_NAME Element MAJOR_NO Element CATALOG_YEAR Element CATALOG_NUMBER Element CATALOG_IDENTIFICATION Element FILE_RELEASE_DATE Element Sequence CATALOG Element
Overview
CATALOG
All administrative information about the catalogue/ database is stored in this element.
Sequence
FILE_RELEASE_DATE xs:dateTime
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contain the current date and time (UTC). D dateTime
P
M
CATALOG_IDENTIFICATION
This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
This element is used for the definition of the currency ID which applies to all prices given in a catalogue/ database. The rules and definitions of the ISO Currency-ID apply.
A change of currency keys within one database is not permitted. Updates during the year and also block prices haven to be given in the same currency unit as that of the basic file. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
This element is used to specify the correct country allocation where a language is spoken in multiple countries and the identical currency is specified. This requires entry of the ISO country code. D string
P [A-Z]{2}
M [2:2]
CATALOG_KIND Restriction of xs:positiveInteger
This element is a mandatory field for identifying the type of catalogue. CATALOG_KIND has the values
1 for a basic catalogue
2 for an association catalogue
3 for a customer-specific catalogue. 		D positiveInteger
P
M [1:3]
ASSOC_CTM_NO optional Restriction of xs:string
If 2 or 3 is entered in the CATALOG_KIND field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
This element is used for the definition of a price ID, i.e. the way in which the prices in a catalogue are given.

The following price IDs are possible:
1 = Price;
2 = Ident number;
3 = calculation point.

If the flags 1 (price) or 2 (ident number) are filled in, a currency has to be filled in the
field CURRENCY_KEY. If the flag 3 (calculation point) is set, values in the element CURRENCY_KEY are not permitted. If ident numbers are used instead of prices the corresponding information of the ident number purchase price sheet, provided by the manufacturer, has to be filled in in the element PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER. If calculation points are used the the conversion factor has to be defined. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
This element is used for the definition of the VAT key which is applied to the prices given in a database.
The following values are used:
0/False = prices excluding VAT
1/True = prices including VAT

This element is of essential importance for the pricing. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
This element defines a distinct number for the catalogue which is represented in the database. The catalogue number is manufacturer specific. D string
P
M [1:10]
CATALOG_YEAR xs:gYear
This element refers to the calendar year of the catalogue data. D gYear
P
M
MAJOR_NO Restriction of xs:positiveInteger
The major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged. D positiveInteger
P
M 1:99
CATALOG_NAME languagetexte30 Complex Type
This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database. D date
P
M
VALID_FROM_DATE Restriction of xs:date
This element defines the period of validity for the catalogue and corresponding database. D date
P
M
FILE_ID Restriction of xs:boolean
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
This element is used to differ between the possible data types

B = block data with prices
K = catalogue data
V = block data without prices (notional prices are required) 		D string
P [BKV]
M [1:1]
FILLING_LEVEL Restriction of xs:string
The filling level (FILLING_LEVEL) defines the level of details which are provided in a database. In general, an increase in the filling level corresponds with an increase in data quality. The higher the degree of detail specification in the data, the more specific they are for a certain manufacturer.
The different filling levels are evaluated during the certification procedure: By checking the filling levels it is ascertained which information is required in the data, in order to achieve the filling level. In case the required information is missing in a filling level, the complete set of data is not certified.
The filling levels are defined as follows:
- Filling level 1: provides basic information except from elements for the description of texture information
- Filling level 2a: filling level 1 is supplemented with information regarding textures and material (colours RGB,transparency and brightness)
- Filling level 2b: filling level 1 is amended with information about front division and front finishes
- Filling level 2c: filling level 1 is supplemented with information about handles.
- Filling level 2d: filling level 1 is amended with information about item textures.

Combinations of filling levels 2a-2d are possible. Following itemized breakdowns of combinations are defined:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Filling level 3. To achieve filling level 3 information in the filling levels 1 and 2a - 2d supplemented by information about the modeling graphic is required. In filling level 3 all options of the data format for manufacturer specific illustrations are entirely applied.
A complete definition of the information required for the different filling levels is provided in the table "Filling levels". 		D string
P [123]|2[a-n]
M [1:2]
PRICING_TERMS optional Restriction of xs:string
This element defines the pricing terms for the catalog prices.
A complete definition of the information required for the dThis element defines the pricing terms for the catalog prices. The information in this field is used for a correct data import in order to avoid overwriting of price information.

The following values are used:
0 = prices in the catalogue are purchase prices for dealers
1 = prices in the catalogue are recommended retail prices (UPE)

All price information in the catalogue has to correspond to the information in this element. 		D string
P [01]
M [1:1]
CATALOG_INFO languagetexte60999 Complex Type
Information texts are stored in this element.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
FALL_BACK_LANGUAGE optional Restriction of xs:language
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The two-digit ISO language code must be used. D language
P [A-Z]{2}
M [2:2]
DETAIL_INFOS 0..∞
This element is used for images of the manufacturer catalogue.
Sequence
DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Remarks

Source
<xs:element name="CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FILE_RELEASE_DATE" type="xs:dateTime">
        <xs:annotation>
          <xs:documentation>100--2--Dateifreigabe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_ID">
              <xs:annotation>
                <xs:documentation>100--5--Hersteller_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CURRENCY_KEY">
              <xs:annotation>
                <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{1,3}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--13--Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_KIND">
              <xs:annotation>
                <xs:documentation>Katalog-Art</xs:documentation>
                <xs:documentation>1 für Basiskatalog</xs:documentation>
                <xs:documentation>2 für Verbandskatalog</xs:documentation>
                <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
                <xs:documentation>geändert 17.04.2019</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ASSOC_CTM_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRODUCT_BRANDNAME">
              <xs:annotation>
                <xs:documentation>100--40--Produktmarke</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_ID">
              <xs:annotation>
                <xs:documentation>100--49--Preis_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VAT">
              <xs:annotation>
                <xs:documentation>200--4--MwSt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG_NUMBER">
        <xs:annotation>
          <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_YEAR" type="xs:gYear">
        <xs:annotation>
          <xs:documentation>Jahr der Neuerstellung</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="MAJOR_NO">
        <xs:annotation>
          <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_NAME" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>100--10--Katalog_Name</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="DATA_VERSION">
        <xs:annotation>
          <xs:documentation>100--11--Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_FROM_DATE">
        <xs:annotation>
          <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILE_ID">
        <xs:annotation>
          <xs:documentation>100--14--Datei_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MARK">
        <xs:annotation>
          <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BKV]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILLING_LEVEL">
        <xs:annotation>
          <xs:documentation>100--44--Fuellstufe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[123]|2[a-n]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICING_TERMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--48--Preisstellung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="1" />
            <xs:pattern value="[01]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_INFO" type="languagetexte60999">
        <xs:annotation>
          <xs:documentation>110--3--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FALL_BACK_LANGUAGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
          <xs:documentation>K. Richter 29.06.2017</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
          <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW  </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW </xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_RELEASE_DATE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : FILE_RELEASE_DATE Element
Description
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contain the current date and time (UTC). D dateTime
P
M
Namespace (none)
Type
xs:dateTime
Diagram
FILE_RELEASE_DATE Element
Overview
FILE_RELEASE_DATE xs:dateTime
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contain the current date and time (UTC). D dateTime
P
M
Remarks

Source
<xs:element name="FILE_RELEASE_DATE" type="xs:dateTime" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--2--Dateifreigabe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_IDENTIFICATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : CATALOG_IDENTIFICATION Element
Description
This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.
Namespace (none)
Diagram
VAT Element PRICE_ID Element PRODUCT_BRANDNAME Element ASSOC_CTM_NO Element CATALOG_KIND Element COUNTRY_ID Element CURRENCY_KEY Element ISO_LANGUAGE_ID Element MANUFACTURER_ID Element Sequence CATALOG_IDENTIFICATION Element
Overview
CATALOG_IDENTIFICATION
This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
This element is used for the definition of the currency ID which applies to all prices given in a catalogue/ database. The rules and definitions of the ISO Currency-ID apply.
A change of currency keys within one database is not permitted. Updates during the year and also block prices haven to be given in the same currency unit as that of the basic file. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
This element is used to specify the correct country allocation where a language is spoken in multiple countries and the identical currency is specified. This requires entry of the ISO country code. D string
P [A-Z]{2}
M [2:2]
CATALOG_KIND Restriction of xs:positiveInteger
This element is a mandatory field for identifying the type of catalogue. CATALOG_KIND has the values
1 for a basic catalogue
2 for an association catalogue
3 for a customer-specific catalogue. 		D positiveInteger
P
M [1:3]
ASSOC_CTM_NO optional Restriction of xs:string
If 2 or 3 is entered in the CATALOG_KIND field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
This element is used for the definition of a price ID, i.e. the way in which the prices in a catalogue are given.

The following price IDs are possible:
1 = Price;
2 = Ident number;
3 = calculation point.

If the flags 1 (price) or 2 (ident number) are filled in, a currency has to be filled in the
field CURRENCY_KEY. If the flag 3 (calculation point) is set, values in the element CURRENCY_KEY are not permitted. If ident numbers are used instead of prices the corresponding information of the ident number purchase price sheet, provided by the manufacturer, has to be filled in in the element PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER. If calculation points are used the the conversion factor has to be defined. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
This element is used for the definition of the VAT key which is applied to the prices given in a database.
The following values are used:
0/False = prices excluding VAT
1/True = prices including VAT

This element is of essential importance for the pricing. 		D boolean
P
M
Remarks

Source
<xs:element name="CATALOG_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_ID">
        <xs:annotation>
          <xs:documentation>100--5--Hersteller_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CURRENCY_KEY">
        <xs:annotation>
          <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{1,3}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--13--Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_KIND">
        <xs:annotation>
          <xs:documentation>Katalog-Art</xs:documentation>
          <xs:documentation>1 für Basiskatalog</xs:documentation>
          <xs:documentation>2 für Verbandskatalog</xs:documentation>
          <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
          <xs:documentation>geändert 17.04.2019</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ASSOC_CTM_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRODUCT_BRANDNAME">
        <xs:annotation>
          <xs:documentation>100--40--Produktmarke</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_ID">
        <xs:annotation>
          <xs:documentation>100--49--Preis_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VAT">
        <xs:annotation>
          <xs:documentation>200--4--MwSt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANUFACTURER_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : MANUFACTURER_ID Element
Description
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MANUFACTURER_ID Element
Overview
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
Remarks

Source
<xs:element name="MANUFACTURER_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--5--Hersteller_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ISO_LANGUAGE_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ISO_LANGUAGE_ID Element
Description
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:language
Diagram
ISO_LANGUAGE_ID Element
Overview
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
Remarks

Source
<xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CURRENCY_KEY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CURRENCY_KEY Element
Description
This element is used for the definition of the currency ID which applies to all prices given in a catalogue/ database. The rules and definitions of the ISO Currency-ID apply.
A change of currency keys within one database is not permitted. Updates during the year and also block prices haven to be given in the same currency unit as that of the basic file. 		D string
P [A-Z]{1,3}
M [1:3]
Namespace (none)
Type
Restriction of xs:string
Diagram
CURRENCY_KEY Element
Overview
CURRENCY_KEY Restriction of xs:string
This element is used for the definition of the currency ID which applies to all prices given in a catalogue/ database. The rules and definitions of the ISO Currency-ID apply.
A change of currency keys within one database is not permitted. Updates during the year and also block prices haven to be given in the same currency unit as that of the basic file. 		D string
P [A-Z]{1,3}
M [1:3]
Remarks

Source
<xs:element name="CURRENCY_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{1,3}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COUNTRY_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : COUNTRY_ID Element
Description
This element is used to specify the correct country allocation where a language is spoken in multiple countries and the identical currency is specified. This requires entry of the ISO country code. D string
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:string
Diagram
COUNTRY_ID Element
Overview
COUNTRY_ID Restriction of xs:string
This element is used to specify the correct country allocation where a language is spoken in multiple countries and the identical currency is specified. This requires entry of the ISO country code. D string
P [A-Z]{2}
M [2:2]
Remarks

Source
<xs:element name="COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--13--Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_KIND Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CATALOG_KIND Element
Description
This element is a mandatory field for identifying the type of catalogue. CATALOG_KIND has the values
1 for a basic catalogue
2 for an association catalogue
3 for a customer-specific catalogue. 		D positiveInteger
P
M [1:3]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
CATALOG_KIND Element
Overview
CATALOG_KIND Restriction of xs:positiveInteger
This element is a mandatory field for identifying the type of catalogue. CATALOG_KIND has the values
1 for a basic catalogue
2 for an association catalogue
3 for a customer-specific catalogue. 		D positiveInteger
P
M [1:3]
Source
<xs:element name="CATALOG_KIND" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Katalog-Art</xs:documentation>
    <xs:documentation>1 für Basiskatalog</xs:documentation>
    <xs:documentation>2 für Verbandskatalog</xs:documentation>
    <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
    <xs:documentation>geändert 17.04.2019</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ASSOC_CTM_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ASSOC_CTM_NO Element
Description
If 2 or 3 is entered in the CATALOG_KIND field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
ASSOC_CTM_NO Element
Overview
ASSOC_CTM_NO optional Restriction of xs:string
If 2 or 3 is entered in the CATALOG_KIND field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
Remarks

Source
<xs:element name="ASSOC_CTM_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_BRANDNAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : PRODUCT_BRANDNAME Element
Description
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRODUCT_BRANDNAME Element
Overview
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
Remarks

Source
<xs:element name="PRODUCT_BRANDNAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--40--Produktmarke</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : PRICE_ID Element
Description
This element is used for the definition of a price ID, i.e. the way in which the prices in a catalogue are given.

The following price IDs are possible:
1 = Price;
2 = Ident number;
3 = calculation point.

If the flags 1 (price) or 2 (ident number) are filled in, a currency has to be filled in the
field CURRENCY_KEY. If the flag 3 (calculation point) is set, values in the element CURRENCY_KEY are not permitted. If ident numbers are used instead of prices the corresponding information of the ident number purchase price sheet, provided by the manufacturer, has to be filled in in the element PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER. If calculation points are used the the conversion factor has to be defined. 		D positiveInteger
P
M [1:3]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRICE_ID Element
Overview
PRICE_ID Restriction of xs:positiveInteger
This element is used for the definition of a price ID, i.e. the way in which the prices in a catalogue are given.

The following price IDs are possible:
1 = Price;
2 = Ident number;
3 = calculation point.

If the flags 1 (price) or 2 (ident number) are filled in, a currency has to be filled in the
field CURRENCY_KEY. If the flag 3 (calculation point) is set, values in the element CURRENCY_KEY are not permitted. If ident numbers are used instead of prices the corresponding information of the ident number purchase price sheet, provided by the manufacturer, has to be filled in in the element PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER. If calculation points are used the the conversion factor has to be defined. 		D positiveInteger
P
M [1:3]
Remarks

Source
<xs:element name="PRICE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--49--Preis_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VAT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : VAT Element
Description
This element is used for the definition of the VAT key which is applied to the prices given in a database.
The following values are used:
0/False = prices excluding VAT
1/True = prices including VAT

This element is of essential importance for the pricing. 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
VAT Element
Overview
VAT Restriction of xs:boolean
This element is used for the definition of the VAT key which is applied to the prices given in a database.
The following values are used:
0/False = prices excluding VAT
1/True = prices including VAT

This element is of essential importance for the pricing. 		D boolean
P
M
Source
<xs:element name="VAT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--4--MwSt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_NUMBER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : CATALOG_NUMBER Element
Description
This element defines a distinct number for the catalogue which is represented in the database. The catalogue number is manufacturer specific. D string
P
M [1:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_NUMBER Element
Overview
CATALOG_NUMBER Restriction of xs:string
This element defines a distinct number for the catalogue which is represented in the database. The catalogue number is manufacturer specific. D string
P
M [1:10]
Remarks

Source
<xs:element name="CATALOG_NUMBER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_YEAR Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : CATALOG_YEAR Element
Description
This element refers to the calendar year of the catalogue data. D gYear
P
M
Namespace (none)
Type
xs:gYear
Diagram
CATALOG_YEAR Element
Overview
CATALOG_YEAR xs:gYear
This element refers to the calendar year of the catalogue data. D gYear
P
M
Source
<xs:element name="CATALOG_YEAR" type="xs:gYear" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Jahr der Neuerstellung</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MAJOR_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : MAJOR_NO Element
Description
The major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged. D positiveInteger
P
M 1:99
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
MAJOR_NO Element
Overview
MAJOR_NO Restriction of xs:positiveInteger
The major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged. D positiveInteger
P
M 1:99
Source
<xs:element name="MAJOR_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : CATALOG_NAME Element
Description
This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.
Namespace (none)
Type
languagetexte30 Complex Type
Diagram
LANGUAGE Element Sequence CATALOG_NAME Element
Overview
CATALOG_NAME languagetexte30 Complex Type
This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Remarks

Source
<xs:element name="CATALOG_NAME" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--10--Katalog_Name</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > languagetexte30 Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte30 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > languagetexte30 Complex Type > LANGUAGE Element : TEXT Element
Description
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetexte30 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DATA_VERSION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : DATA_VERSION Element
Description
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
DATA_VERSION Element
Overview
DATA_VERSION Restriction of xs:date
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database. D date
P
M
Remarks

Source
<xs:element name="DATA_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--11--Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_FROM_DATE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : VALID_FROM_DATE Element
Description
This element defines the period of validity for the catalogue and corresponding database. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM_DATE Element
Overview
VALID_FROM_DATE Restriction of xs:date
This element defines the period of validity for the catalogue and corresponding database. D date
P
M
Remarks

Source
<xs:element name="VALID_FROM_DATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : FILE_ID Element
Description
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
FILE_ID Element
Overview
FILE_ID Restriction of xs:boolean
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data 		D boolean
P
M
Remarks

Source
<xs:element name="FILE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--14--Datei_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_MARK Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : CATALOG_MARK Element
Description
This element is used to differ between the possible data types

B = block data with prices
K = catalogue data
V = block data without prices (notional prices are required) 		D string
P [BKV]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_MARK Element
Overview
CATALOG_MARK Restriction of xs:string
This element is used to differ between the possible data types

B = block data with prices
K = catalogue data
V = block data without prices (notional prices are required) 		D string
P [BKV]
M [1:1]
Remarks

Source
<xs:element name="CATALOG_MARK" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BKV]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILLING_LEVEL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : FILLING_LEVEL Element
Description
The filling level (FILLING_LEVEL) defines the level of details which are provided in a database. In general, an increase in the filling level corresponds with an increase in data quality. The higher the degree of detail specification in the data, the more specific they are for a certain manufacturer.
The different filling levels are evaluated during the certification procedure: By checking the filling levels it is ascertained which information is required in the data, in order to achieve the filling level. In case the required information is missing in a filling level, the complete set of data is not certified.
The filling levels are defined as follows:
- Filling level 1: provides basic information except from elements for the description of texture information
- Filling level 2a: filling level 1 is supplemented with information regarding textures and material (colours RGB,transparency and brightness)
- Filling level 2b: filling level 1 is amended with information about front division and front finishes
- Filling level 2c: filling level 1 is supplemented with information about handles.
- Filling level 2d: filling level 1 is amended with information about item textures.

Combinations of filling levels 2a-2d are possible. Following itemized breakdowns of combinations are defined:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Filling level 3. To achieve filling level 3 information in the filling levels 1 and 2a - 2d supplemented by information about the modeling graphic is required. In filling level 3 all options of the data format for manufacturer specific illustrations are entirely applied.
A complete definition of the information required for the different filling levels is provided in the table "Filling levels". 		D string
P [123]|2[a-n]
M [1:2]
Namespace (none)
Type
Restriction of xs:string
Diagram
FILLING_LEVEL Element
Overview
FILLING_LEVEL Restriction of xs:string
The filling level (FILLING_LEVEL) defines the level of details which are provided in a database. In general, an increase in the filling level corresponds with an increase in data quality. The higher the degree of detail specification in the data, the more specific they are for a certain manufacturer.
The different filling levels are evaluated during the certification procedure: By checking the filling levels it is ascertained which information is required in the data, in order to achieve the filling level. In case the required information is missing in a filling level, the complete set of data is not certified.
The filling levels are defined as follows:
- Filling level 1: provides basic information except from elements for the description of texture information
- Filling level 2a: filling level 1 is supplemented with information regarding textures and material (colours RGB,transparency and brightness)
- Filling level 2b: filling level 1 is amended with information about front division and front finishes
- Filling level 2c: filling level 1 is supplemented with information about handles.
- Filling level 2d: filling level 1 is amended with information about item textures.

Combinations of filling levels 2a-2d are possible. Following itemized breakdowns of combinations are defined:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Filling level 3. To achieve filling level 3 information in the filling levels 1 and 2a - 2d supplemented by information about the modeling graphic is required. In filling level 3 all options of the data format for manufacturer specific illustrations are entirely applied.
A complete definition of the information required for the different filling levels is provided in the table "Filling levels". 		D string
P [123]|2[a-n]
M [1:2]
Remarks

Source
<xs:element name="FILLING_LEVEL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--44--Fuellstufe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[123]|2[a-n]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICING_TERMS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : PRICING_TERMS Element
Description
This element defines the pricing terms for the catalog prices.
A complete definition of the information required for the dThis element defines the pricing terms for the catalog prices. The information in this field is used for a correct data import in order to avoid overwriting of price information.

The following values are used:
0 = prices in the catalogue are purchase prices for dealers
1 = prices in the catalogue are recommended retail prices (UPE)

All price information in the catalogue has to correspond to the information in this element. 		D string
P [01]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
PRICING_TERMS Element
Overview
PRICING_TERMS optional Restriction of xs:string
This element defines the pricing terms for the catalog prices.
A complete definition of the information required for the dThis element defines the pricing terms for the catalog prices. The information in this field is used for a correct data import in order to avoid overwriting of price information.

The following values are used:
0 = prices in the catalogue are purchase prices for dealers
1 = prices in the catalogue are recommended retail prices (UPE)

All price information in the catalogue has to correspond to the information in this element. 		D string
P [01]
M [1:1]
Remarks

Source
<xs:element name="PRICING_TERMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--48--Preisstellung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="1" />
      <xs:pattern value="[01]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_INFO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : CATALOG_INFO Element
Description
Information texts are stored in this element.
Namespace (none)
Type
languagetexte60999 Complex Type
Diagram
LANGUAGE Element Sequence CATALOG_INFO Element
Overview
CATALOG_INFO languagetexte60999 Complex Type
Information texts are stored in this element.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="CATALOG_INFO" type="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>110--3--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > languagetexte60999 Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
Namespace (none)
Diagram
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="999">
        <xs:annotation>
          <xs:documentation>150--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>265--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,60}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte60999 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
IDM 2.7.0 XML-Schema > languagetexte60999 Complex Type > LANGUAGE Element : TEXT_LINE Element
Description
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
Namespace (none)
Diagram
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
SEQUENCE_NO Restriction of xs:positiveInteger required
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Source
<xs:element name="TEXT_LINE" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
LANGUAGE Element | languagetexte60999 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > languagetexte60999 Complex Type > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Description
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | languagetexte60999 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FALL_BACK_LANGUAGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : FALL_BACK_LANGUAGE Element
Description
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The two-digit ISO language code must be used. D language
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:language
Diagram
FALL_BACK_LANGUAGE Element
Overview
FALL_BACK_LANGUAGE optional Restriction of xs:language
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The two-digit ISO language code must be used. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="FALL_BACK_LANGUAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
    <xs:documentation>K. Richter 29.06.2017</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : DETAIL_INFOS Element
Description
This element is used for images of the manufacturer catalogue.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS 0..∞
This element is used for images of the manufacturer catalogue.
Sequence
DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
    <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW </xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description
This element is used for referencing the detail information.
Namespace (none)
Diagram
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUPPLIER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : SUPPLIER Element
Description
All relevant supplier data, e.g. communication and contact details, are stored in this element.
Namespace (none)
Diagram
CONTACT_SUPPLIER Element CONTACT_PERSON Element WEEE_NO Element GLN_NO Element ISO_COUNTRY_ID Element BRANCH_ID Element EDI_INFO Element Sequence SUPPLIER Element
Overview
SUPPLIER
All relevant supplier data, e.g. communication and contact details, are stored in this element.
Sequence
EDI_INFO 0..∞
The different possibilities of EDI-communication are defined in this element. For each EDI message of an EDI format exactly one element is defined.
Sequence
EDI_FORMAT optional Restriction of xs:string
The supported EDI-format is indicated in this field(e.g. EDIDATA). D string
P EANCOM|EAN 97|EAN 97 A|EDIDATA
M [1:20]
EDI_FORMAT_VERSION optional Restriction of xs:string
This field contains the version of the EDI format defined in the field EDI_FORMAT. D string
P [1-9]\.[0-9]{2}
M [1:10]
EDI_MESSAGE optional Restriction of xs:string
All different EDI messages supported by a manufacturer are indicated here (e.g. order, order response). D string
P
M [1:20]
EDI_COMMUNICATION optional Restriction of xs:string
This is used to specify the method for EDI communications (e.g. X400, Telebox, email). D string
P
M [1:20]
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
The address for the EDI communication is filled in here (e. g. X.400 address, E-mail address or 'on consultation'). D string
P
M [1:40]
EDI_CONTACT optional Restriction of xs:string
The name of a contact person who is responsible for all questions concerning the EDI communication is filled in into this field. This field is not delimited so that all necessary information (i.e. name, phone number etc.) can be entered into one field. D string
P
M [1:60]
BRANCH_ID Restriction of xs:string
The different branches of manufacturers are indicated by the entries in this element.The following branches are currently differentiated:

A = worktop manufacturer
B = bathroom furniture manufacturer
G = appliance manufacturer
K = kitchen furniture manufacturer
O = office furniture manufacturer
P = upholstery manufacturer
S = sanitary manufacturer
W = manufacturer of living room furniture
Z = manufacturer of accessories 		D string
P [ABGKOPSWZ]
M [1:1]
ISO_COUNTRY_ID Restriction of xs:string
Based on the standards of ISO-norm the country of the manufacturer's headquarter is defined here. D string
P [A-Z]{2}
M [2:2]
GLN_NO optional Restriction of xs:string
The unambiguous Global Location Number (GLN) of a supplier is defined in this element. This unique identification of companies resp. company units is used especially for the automated electronic data exchange. D string
P [0-9]{13}
M [13:13]
WEEE_NO optional Restriction of xs:string
The WEEE registration number of the supplier is defined in this element. This registration number is required for all manufacturers and importers of electronic devices according to the rules of the German "Elektro- und Elektronikgerätegesetz" (ElektroG).
The German standard of the WEEE numbering is built up in the following way: "DE12345678".
The validity of a WEEE No. can be checked on the internet homepage of "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de. 		D string
P
M
CONTACT_PERSON 1..2
All information concerning the contact person is defined in this element.
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
Priorities in contacting the manufacturer's contact persons are defined in this element (1=1. contact, 2=2. contact). D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
The different roles of the manufacturer's contact persons are defined in this element, e.g. EDI specialist, substitute. D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
The family name of the direct contact person for the software suppliers is defined in this element. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
The first name of the direct contact person is entered here. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
The correct address of the contact person is defined by the following values.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
If applicable, the department of the contact person is defined in this field. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
This element contains the phone number of the contact person including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
This element contains the fax number of the contact person including international dialing code and area code. e.g.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
This element contains the E-Mail address of the contact person. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
STREET optional Restriction of xs:string
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
CITY optional Restriction of xs:string
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
CONTACT_SUPPLIER
All contact information for the specific manufacturer is defined in this element.
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
This element contains the first line of the manufacturer's name. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
This element contains the second line of the manufacturer's name. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
The official E-Mail address of the manufacturer is defined in this element.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

INTERNET_ADDRESS optional Restriction of xs:string
If applicable, the official homepage of the manufacturer is defined in this element (e.g.: http://www.company.com). D string
P
M
STREET Restriction of xs:string
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
CITY Restriction of xs:string
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
ZIPCODE_POSTBOX optional Restriction of xs:string
If applicable, the ZIP code of the manufacturer's postbox address is entered here. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
If applicable, the postbox number of the manufacturer's address is defined in this element. The word "postbox" has to be omitted. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
This element contains the manufacturer's switchboard telephone number including international dialing code and area code, e.g.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
This element contains the manufacturer's switchboard fax number including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
Remarks

Source
<xs:element name="SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EDI_INFO" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>105--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EDI_FORMAT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--2--EDI_Format</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                  <xs:pattern value="EANCOM|EAN 97|EAN 97 A|EDIDATA" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_FORMAT_VERSION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                  <xs:pattern value="[1-9]\.[0-9]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_MESSAGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_COMMUNICATION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="40" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_CONTACT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="60" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BRANCH_ID">
        <xs:annotation>
          <xs:documentation>100--8--Branchen_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[ABGKOPSWZ]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="GLN_NO" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>100--45--GLN_Nr 30.05.2012/Bur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, verpflichtend, K. Richter 21.08.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9]{13}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="WEEE_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--47--WEEE_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_PERSON" maxOccurs="2">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CONTACT_PERSON_NO">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_ROLE">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="60" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_NAME">
              <xs:annotation>
                <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FIRST_NAME">
              <xs:annotation>
                <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FORM_OF_ADDRESS">
              <xs:annotation>
                <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DEPARTMENT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE">
              <xs:annotation>
                <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CONTACT_SUPPLIER">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_NAME_1">
              <xs:annotation>
                <xs:documentation>100--16--Herstellername_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--17--Herstellername_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INTERNET_ADDRESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--19--Internet_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET">
              <xs:annotation>
                <xs:documentation>100--20--Strasse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET">
              <xs:annotation>
                <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY">
              <xs:annotation>
                <xs:documentation>100--22--Ort</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--24--Postfach</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_INFO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : EDI_INFO Element
Description
The different possibilities of EDI-communication are defined in this element. For each EDI message of an EDI format exactly one element is defined.
Namespace (none)
Diagram
EDI_CONTACT Element EDI_COMMUNICATION_ADDRESS Element EDI_COMMUNICATION Element EDI_MESSAGE Element EDI_FORMAT_VERSION Element EDI_FORMAT Element Sequence EDI_INFO Element
Overview
EDI_INFO 0..∞
The different possibilities of EDI-communication are defined in this element. For each EDI message of an EDI format exactly one element is defined.
Sequence
EDI_FORMAT optional Restriction of xs:string
The supported EDI-format is indicated in this field(e.g. EDIDATA). D string
P EANCOM|EAN 97|EAN 97 A|EDIDATA
M [1:20]
EDI_FORMAT_VERSION optional Restriction of xs:string
This field contains the version of the EDI format defined in the field EDI_FORMAT. D string
P [1-9]\.[0-9]{2}
M [1:10]
EDI_MESSAGE optional Restriction of xs:string
All different EDI messages supported by a manufacturer are indicated here (e.g. order, order response). D string
P
M [1:20]
EDI_COMMUNICATION optional Restriction of xs:string
This is used to specify the method for EDI communications (e.g. X400, Telebox, email). D string
P
M [1:20]
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
The address for the EDI communication is filled in here (e. g. X.400 address, E-mail address or 'on consultation'). D string
P
M [1:40]
EDI_CONTACT optional Restriction of xs:string
The name of a contact person who is responsible for all questions concerning the EDI communication is filled in into this field. This field is not delimited so that all necessary information (i.e. name, phone number etc.) can be entered into one field. D string
P
M [1:60]
Remarks

Source
<xs:element name="EDI_INFO" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EDI_FORMAT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--2--EDI_Format</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
            <xs:pattern value="EANCOM|EAN 97|EAN 97 A|EDIDATA" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_FORMAT_VERSION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
            <xs:pattern value="[1-9]\.[0-9]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_MESSAGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_COMMUNICATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="40" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_CONTACT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="60" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_FORMAT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_FORMAT Element
Description
The supported EDI-format is indicated in this field(e.g. EDIDATA). D string
P EANCOM|EAN 97|EAN 97 A|EDIDATA
M [1:20]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDI_FORMAT Element
Overview
EDI_FORMAT optional Restriction of xs:string
The supported EDI-format is indicated in this field(e.g. EDIDATA). D string
P EANCOM|EAN 97|EAN 97 A|EDIDATA
M [1:20]
Remarks

Source
<xs:element name="EDI_FORMAT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--2--EDI_Format</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
      <xs:pattern value="EANCOM|EAN 97|EAN 97 A|EDIDATA" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_FORMAT_VERSION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_FORMAT_VERSION Element
Description
This field contains the version of the EDI format defined in the field EDI_FORMAT. D string
P [1-9]\.[0-9]{2}
M [1:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDI_FORMAT_VERSION Element
Overview
EDI_FORMAT_VERSION optional Restriction of xs:string
This field contains the version of the EDI format defined in the field EDI_FORMAT. D string
P [1-9]\.[0-9]{2}
M [1:10]
Remarks

Source
<xs:element name="EDI_FORMAT_VERSION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
      <xs:pattern value="[1-9]\.[0-9]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_MESSAGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_MESSAGE Element
Description
All different EDI messages supported by a manufacturer are indicated here (e.g. order, order response). D string
P
M [1:20]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDI_MESSAGE Element
Overview
EDI_MESSAGE optional Restriction of xs:string
All different EDI messages supported by a manufacturer are indicated here (e.g. order, order response). D string
P
M [1:20]
Remarks

Source
<xs:element name="EDI_MESSAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_COMMUNICATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_COMMUNICATION Element
Description
This is used to specify the method for EDI communications (e.g. X400, Telebox, email). D string
P
M [1:20]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDI_COMMUNICATION Element
Overview
EDI_COMMUNICATION optional Restriction of xs:string
This is used to specify the method for EDI communications (e.g. X400, Telebox, email). D string
P
M [1:20]
Remarks

Source
<xs:element name="EDI_COMMUNICATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_COMMUNICATION_ADDRESS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_COMMUNICATION_ADDRESS Element
Description
The address for the EDI communication is filled in here (e. g. X.400 address, E-mail address or 'on consultation'). D string
P
M [1:40]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDI_COMMUNICATION_ADDRESS Element
Overview
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
The address for the EDI communication is filled in here (e. g. X.400 address, E-mail address or 'on consultation'). D string
P
M [1:40]
Remarks

Source
<xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="40" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_CONTACT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_CONTACT Element
Description
The name of a contact person who is responsible for all questions concerning the EDI communication is filled in into this field. This field is not delimited so that all necessary information (i.e. name, phone number etc.) can be entered into one field. D string
P
M [1:60]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDI_CONTACT Element
Overview
EDI_CONTACT optional Restriction of xs:string
The name of a contact person who is responsible for all questions concerning the EDI communication is filled in into this field. This field is not delimited so that all necessary information (i.e. name, phone number etc.) can be entered into one field. D string
P
M [1:60]
Remarks

Source
<xs:element name="EDI_CONTACT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="60" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BRANCH_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : BRANCH_ID Element
Description
The different branches of manufacturers are indicated by the entries in this element.The following branches are currently differentiated:

A = worktop manufacturer
B = bathroom furniture manufacturer
G = appliance manufacturer
K = kitchen furniture manufacturer
O = office furniture manufacturer
P = upholstery manufacturer
S = sanitary manufacturer
W = manufacturer of living room furniture
Z = manufacturer of accessories 		D string
P [ABGKOPSWZ]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
BRANCH_ID Element
Overview
BRANCH_ID Restriction of xs:string
The different branches of manufacturers are indicated by the entries in this element.The following branches are currently differentiated:

A = worktop manufacturer
B = bathroom furniture manufacturer
G = appliance manufacturer
K = kitchen furniture manufacturer
O = office furniture manufacturer
P = upholstery manufacturer
S = sanitary manufacturer
W = manufacturer of living room furniture
Z = manufacturer of accessories 		D string
P [ABGKOPSWZ]
M [1:1]
Remarks

Source
<xs:element name="BRANCH_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--8--Branchen_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[ABGKOPSWZ]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ISO_COUNTRY_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : ISO_COUNTRY_ID Element
Description
Based on the standards of ISO-norm the country of the manufacturer's headquarter is defined here. D string
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:string
Diagram
ISO_COUNTRY_ID Element
Overview
ISO_COUNTRY_ID Restriction of xs:string
Based on the standards of ISO-norm the country of the manufacturer's headquarter is defined here. D string
P [A-Z]{2}
M [2:2]
Remarks

Source
<xs:element name="ISO_COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GLN_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : GLN_NO Element
Description
The unambiguous Global Location Number (GLN) of a supplier is defined in this element. This unique identification of companies resp. company units is used especially for the automated electronic data exchange. D string
P [0-9]{13}
M [13:13]
Namespace (none)
Type
Restriction of xs:string
Diagram
GLN_NO Element
Overview
GLN_NO optional Restriction of xs:string
The unambiguous Global Location Number (GLN) of a supplier is defined in this element. This unique identification of companies resp. company units is used especially for the automated electronic data exchange. D string
P [0-9]{13}
M [13:13]
Remarks

Source
<xs:element name="GLN_NO" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--45--GLN_Nr 30.05.2012/Bur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, verpflichtend, K. Richter 21.08.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9]{13}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WEEE_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : WEEE_NO Element
Description
The WEEE registration number of the supplier is defined in this element. This registration number is required for all manufacturers and importers of electronic devices according to the rules of the German "Elektro- und Elektronikgerätegesetz" (ElektroG).
The German standard of the WEEE numbering is built up in the following way: "DE12345678".
The validity of a WEEE No. can be checked on the internet homepage of "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de. 		D string
P
M
Namespace (none)
Type
Restriction of xs:string
Diagram
WEEE_NO Element
Overview
WEEE_NO optional Restriction of xs:string
The WEEE registration number of the supplier is defined in this element. This registration number is required for all manufacturers and importers of electronic devices according to the rules of the German "Elektro- und Elektronikgerätegesetz" (ElektroG).
The German standard of the WEEE numbering is built up in the following way: "DE12345678".
The validity of a WEEE No. can be checked on the internet homepage of "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de. 		D string
P
M
Remarks

Source
<xs:element name="WEEE_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--47--WEEE_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONTACT_PERSON Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : CONTACT_PERSON Element
Description
All information concerning the contact person is defined in this element.
Namespace (none)
Diagram
CITY Element ZIPCODE_STREET Element STREET Element EMAIL Element FAX Element TELEPHONE Element DEPARTMENT Element FORM_OF_ADDRESS Element FIRST_NAME Element CONTACT_NAME Element CONTACT_ROLE Element CONTACT_PERSON_NO Element Sequence CONTACT_PERSON Element
Overview
CONTACT_PERSON 1..2
All information concerning the contact person is defined in this element.
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
Priorities in contacting the manufacturer's contact persons are defined in this element (1=1. contact, 2=2. contact). D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
The different roles of the manufacturer's contact persons are defined in this element, e.g. EDI specialist, substitute. D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
The family name of the direct contact person for the software suppliers is defined in this element. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
The first name of the direct contact person is entered here. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
The correct address of the contact person is defined by the following values.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
If applicable, the department of the contact person is defined in this field. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
This element contains the phone number of the contact person including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
This element contains the fax number of the contact person including international dialing code and area code. e.g.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
This element contains the E-Mail address of the contact person. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
STREET optional Restriction of xs:string
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
CITY optional Restriction of xs:string
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
Remarks

Source
<xs:element name="CONTACT_PERSON" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CONTACT_PERSON_NO">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_ROLE">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="60" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_NAME">
        <xs:annotation>
          <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FIRST_NAME">
        <xs:annotation>
          <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FORM_OF_ADDRESS">
        <xs:annotation>
          <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DEPARTMENT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE">
        <xs:annotation>
          <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONTACT_PERSON_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_PERSON_NO Element
Description
Priorities in contacting the manufacturer's contact persons are defined in this element (1=1. contact, 2=2. contact). D positiveInteger
P
M [1:2]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
CONTACT_PERSON_NO Element
Overview
CONTACT_PERSON_NO Restriction of xs:positiveInteger
Priorities in contacting the manufacturer's contact persons are defined in this element (1=1. contact, 2=2. contact). D positiveInteger
P
M [1:2]
Remarks

Source
<xs:element name="CONTACT_PERSON_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONTACT_ROLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_ROLE Element
Description
The different roles of the manufacturer's contact persons are defined in this element, e.g. EDI specialist, substitute. D string
P
M [1:60]
Namespace (none)
Type
Restriction of xs:string
Diagram
CONTACT_ROLE Element
Overview
CONTACT_ROLE Restriction of xs:string
The different roles of the manufacturer's contact persons are defined in this element, e.g. EDI specialist, substitute. D string
P
M [1:60]
Remarks

Source
<xs:element name="CONTACT_ROLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="60" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONTACT_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_NAME Element
Description
The family name of the direct contact person for the software suppliers is defined in this element. D string
P
M [1:20]
Namespace (none)
Type
Restriction of xs:string
Diagram
CONTACT_NAME Element
Overview
CONTACT_NAME Restriction of xs:string
The family name of the direct contact person for the software suppliers is defined in this element. D string
P
M [1:20]
Remarks

Source
<xs:element name="CONTACT_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FIRST_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : FIRST_NAME Element
Description
The first name of the direct contact person is entered here. D string
P
M [1:20]
Namespace (none)
Type
Restriction of xs:string
Diagram
FIRST_NAME Element
Overview
FIRST_NAME Restriction of xs:string
The first name of the direct contact person is entered here. D string
P
M [1:20]
Remarks

Source
<xs:element name="FIRST_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FORM_OF_ADDRESS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : FORM_OF_ADDRESS Element
Description
The correct address of the contact person is defined by the following values.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
FORM_OF_ADDRESS Element
Overview
FORM_OF_ADDRESS Restriction of xs:positiveInteger
The correct address of the contact person is defined by the following values.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
Remarks

Source
<xs:element name="FORM_OF_ADDRESS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEPARTMENT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : DEPARTMENT Element
Description
If applicable, the department of the contact person is defined in this field. D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
DEPARTMENT Element
Overview
DEPARTMENT optional Restriction of xs:string
If applicable, the department of the contact person is defined in this field. D string
P
M [1:15]
Remarks

Source
<xs:element name="DEPARTMENT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TELEPHONE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : TELEPHONE Element
Description
This element contains the phone number of the contact person including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
Namespace (none)
Type
Restriction of xs:string
Diagram
TELEPHONE Element
Overview
TELEPHONE Restriction of xs:string
This element contains the phone number of the contact person including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
Remarks

Source
<xs:element name="TELEPHONE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FAX Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : FAX Element
Description
This element contains the fax number of the contact person including international dialing code and area code. e.g.: +49(5251)60-3284. D string
P
M [1:18]
Namespace (none)
Type
Restriction of xs:string
Diagram
FAX Element
Overview
FAX optional Restriction of xs:string
This element contains the fax number of the contact person including international dialing code and area code. e.g.: +49(5251)60-3284. D string
P
M [1:18]
Remarks

Source
<xs:element name="FAX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EMAIL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : EMAIL Element
Description
This element contains the E-Mail address of the contact person. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
Namespace (none)
Type
Restriction of xs:string
Diagram
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
This element contains the E-Mail address of the contact person. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
Remarks

Source
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STREET Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : STREET Element
Description
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
STREET Element
Overview
STREET optional Restriction of xs:string
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
Remarks

Source
<xs:element name="STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ZIPCODE_STREET Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : ZIPCODE_STREET Element
Description
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
Namespace (none)
Type
Restriction of xs:string
Diagram
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET optional Restriction of xs:string
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
Remarks

Source
<xs:element name="ZIPCODE_STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CITY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CITY Element
Description
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
CITY Element
Overview
CITY optional Restriction of xs:string
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
Remarks

Source
<xs:element name="CITY" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONTACT_SUPPLIER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : CONTACT_SUPPLIER Element
Description
All contact information for the specific manufacturer is defined in this element.
Namespace (none)
Diagram
FAX_SWITCHBOARD Element TELEPHONE_SWITCHBOARD Element POSTBOX Element ZIPCODE_POSTBOX Element CITY Element ZIPCODE_STREET Element STREET Element INTERNET_ADDRESS Element EMAIL Element MANUFACTURER_NAME_2 Element MANUFACTURER_NAME_1 Element Sequence CONTACT_SUPPLIER Element
Overview
CONTACT_SUPPLIER
All contact information for the specific manufacturer is defined in this element.
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
This element contains the first line of the manufacturer's name. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
This element contains the second line of the manufacturer's name. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
The official E-Mail address of the manufacturer is defined in this element.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

INTERNET_ADDRESS optional Restriction of xs:string
If applicable, the official homepage of the manufacturer is defined in this element (e.g.: http://www.company.com). D string
P
M
STREET Restriction of xs:string
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
CITY Restriction of xs:string
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
ZIPCODE_POSTBOX optional Restriction of xs:string
If applicable, the ZIP code of the manufacturer's postbox address is entered here. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
If applicable, the postbox number of the manufacturer's address is defined in this element. The word "postbox" has to be omitted. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
This element contains the manufacturer's switchboard telephone number including international dialing code and area code, e.g.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
This element contains the manufacturer's switchboard fax number including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
Remarks

Source
<xs:element name="CONTACT_SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_NAME_1">
        <xs:annotation>
          <xs:documentation>100--16--Herstellername_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--17--Herstellername_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INTERNET_ADDRESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--19--Internet_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET">
        <xs:annotation>
          <xs:documentation>100--20--Strasse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET">
        <xs:annotation>
          <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY">
        <xs:annotation>
          <xs:documentation>100--22--Ort</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--24--Postfach</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9a-zA-Z]{0,10}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANUFACTURER_NAME_1 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_1 Element
Description
This element contains the first line of the manufacturer's name. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
MANUFACTURER_NAME_1 Element
Overview
MANUFACTURER_NAME_1 Restriction of xs:string
This element contains the first line of the manufacturer's name. D string
P
M [1:30]
Remarks

Source
<xs:element name="MANUFACTURER_NAME_1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--16--Herstellername_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANUFACTURER_NAME_2 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_2 Element
Description
This element contains the second line of the manufacturer's name. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
MANUFACTURER_NAME_2 Element
Overview
MANUFACTURER_NAME_2 optional Restriction of xs:string
This element contains the second line of the manufacturer's name. D string
P
M [1:30]
Remarks

Source
<xs:element name="MANUFACTURER_NAME_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--17--Herstellername_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EMAIL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : EMAIL Element
Description
The official E-Mail address of the manufacturer is defined in this element.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

Namespace (none)
Type
Restriction of xs:string
Diagram
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
The official E-Mail address of the manufacturer is defined in this element.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

Remarks

Source
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

INTERNET_ADDRESS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : INTERNET_ADDRESS Element
Description
If applicable, the official homepage of the manufacturer is defined in this element (e.g.: http://www.company.com). D string
P
M
Namespace (none)
Type
Restriction of xs:string
Diagram
INTERNET_ADDRESS Element
Overview
INTERNET_ADDRESS optional Restriction of xs:string
If applicable, the official homepage of the manufacturer is defined in this element (e.g.: http://www.company.com). D string
P
M
Remarks

Source
<xs:element name="INTERNET_ADDRESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--19--Internet_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STREET Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : STREET Element
Description
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
STREET Element
Overview
STREET Restriction of xs:string
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
Remarks

Source
<xs:element name="STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--20--Strasse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ZIPCODE_STREET Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_STREET Element
Description
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
Namespace (none)
Type
Restriction of xs:string
Diagram
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET Restriction of xs:string
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
Remarks

Source
<xs:element name="ZIPCODE_STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CITY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : CITY Element
Description
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
CITY Element
Overview
CITY Restriction of xs:string
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
Remarks

Source
<xs:element name="CITY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--22--Ort</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ZIPCODE_POSTBOX Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_POSTBOX Element
Description
If applicable, the ZIP code of the manufacturer's postbox address is entered here. D string
P
M [1:8]
Namespace (none)
Type
Restriction of xs:string
Diagram
ZIPCODE_POSTBOX Element
Overview
ZIPCODE_POSTBOX optional Restriction of xs:string
If applicable, the ZIP code of the manufacturer's postbox address is entered here. D string
P
M [1:8]
Remarks

Source
<xs:element name="ZIPCODE_POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

POSTBOX Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : POSTBOX Element
Description
If applicable, the postbox number of the manufacturer's address is defined in this element. The word "postbox" has to be omitted. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
POSTBOX Element
Overview
POSTBOX optional Restriction of xs:string
If applicable, the postbox number of the manufacturer's address is defined in this element. The word "postbox" has to be omitted. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
Remarks

Source
<xs:element name="POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--24--Postfach</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9a-zA-Z]{0,10}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TELEPHONE_SWITCHBOARD Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : TELEPHONE_SWITCHBOARD Element
Description
This element contains the manufacturer's switchboard telephone number including international dialing code and area code, e.g.: +49(1234)56-7890. D string
P
M [1:18]
Namespace (none)
Type
Restriction of xs:string
Diagram
TELEPHONE_SWITCHBOARD Element
Overview
TELEPHONE_SWITCHBOARD Restriction of xs:string
This element contains the manufacturer's switchboard telephone number including international dialing code and area code, e.g.: +49(1234)56-7890. D string
P
M [1:18]
Remarks

Source
<xs:element name="TELEPHONE_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FAX_SWITCHBOARD Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : FAX_SWITCHBOARD Element
Description
This element contains the manufacturer's switchboard fax number including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
Namespace (none)
Type
Restriction of xs:string
Diagram
FAX_SWITCHBOARD Element
Overview
FAX_SWITCHBOARD Restriction of xs:string
This element contains the manufacturer's switchboard fax number including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
Remarks

Source
<xs:element name="FAX_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GLOBAL_DEFINITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : GLOBAL_DEFINITION Element
Description
This element is used for defining global data which apply to the complete catalogue/ database (global information).
Namespace (none)
Diagram
GROUP_TITLES Element PROPERTIES Element DETAIL_INFOS Element MODULE_RULE_SET_DEFINITIONS Element FRONT_APPEARANCES Element FRONTS_HANDLE_POSITIONS Element CLEARING_GROUP Element Sequence GLOBAL_DEFINITION Element
Overview
GLOBAL_DEFINITION optional
This element is used for defining global data which apply to the complete catalogue/ database (global information).
Sequence
CLEARING_GROUP 0..∞
This element is used for the definition of clearing groups. Different exchange_IDs are summarized and made up to a clearing group (element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID).

The clearing groups in the block conditions (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) and the grading tables (BLOCK_VALUE_CALCULATION/GRADING_TABLE) are used for the definition of a minimum value for a certain type range. The different type ranges can be identified by their corresponding exchange_ID.

The single amounts of all items which belong to a certain exchange_ID are summarized. A total amount is summed up for each clearing group. This amount is defined as reference value for further use in block calculation and for the value clearing grading table.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a clearing group. D nonNegativeInteger
P
M [0:999]
Sequence
EXCHANGE_ID_REF 1..∞
This element references an exchange-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
This element contains the exchange_IDs which are combined to a clearing group. Values 0, 98 and 99 are not permitted. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
CLEARING_GROUP_NAME languagetexte60 Complex Type
Name for a clearing group. This is used in order to simplify data acquisition.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
FRONTS_HANDLE_POSITIONS optional
This element is used for the definition of handle positions, either basic or specific positions. The validity of a basic handle position is global, whereas the validity of a specific handle position is subject to special conditions.
Sequence
SPECIFIC_HANDLE_POSITIONS optional
Specific handle positions, changes of handle positions or changes of handles can be defined in this element. For all these cases the denotation “specific handle positon” is used. User-defined combinations of the different child elements are permitted. The more child elements are filled in, the more precise is the description of the specific handle position. The PRIORITY field (P1) and at least one key field have to be filled in.

Element paths
Path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/
Sequence
SPECIFIC_HANDLE_ORIENTATION 1..∞
This element defines a specific handle orientation.
SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a specific handle orientation. D nonNegativeInteger
P
M [0:99999]
Sequence
STYLE_REF optional
References are used for assigning specific handle orientations to specific programmes. If this element is not defined, the handle orientation is applicable for all programmes.
STYLE_NO required Restriction of xs:string
This attribute defines the referenced programme. It references to the attribute STYLE_NO in the element STYLE (Path1).

element paths:
path1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
FRONT_TYPE_GROUP_REF optional
This element defines the front type group to which a special handle orientation applies. If this element is not defined the handle orientation is available for all front type groups
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute references the front type group. D nonNegativeInteger
P
M [1:99]
WIDTH_FROM optional Restriction of xs:positiveInteger
The given measurement in this element defines the minimum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field require corresponding settings in the field WIDTH_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
WIDTH_TO optional Restriction of xs:positiveInteger
The given measurement defines the maximum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field are required when the field WIDTH_FROM was filled in. The width is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
The given measurement defines the minimum height (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field require corresponding settings in the field HEIGHT_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
HEIGHT_TO optional Restriction of xs:nonNegativeInteger
The given measurement defines the maximum height(nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field are required when the field HEIGHT_FROM was filled in. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
OPTION_REF
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (FEATURE_NO = 154) is defined for it.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. Only feature type 154 is permitted. D nonNegativeInteger
P
M [154:154]
OPTION_KEY required Restriction of xs:string
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door"" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (154) is defined for it. 		D string
P
M [1:5]
HANDLE_EXCHANGE optional
Specific conditions for a handle exchange are defined in this element. Further conditions defined in the element SPECIFIC_HANDLE_ORIENTATION have to be fulfilled.
Sequence
FEATURE_REF
This element references a feature type which is defined in the element FEATURE_DEFINITION/FEATURES/FEATURE.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
FROM_HANDLE
This element defines which handle is exchanged.
Sequence
OPTION_REF
This element references a handle option in the element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. This element defines the handle option which is used for the specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle options.
TO_HANDLE
This element defines the handle which is used as a replacement.
Sequence
OPTION_REF
This element defines the handle which is used as a replacement handle in certain situations.
HANDLE_ORIENTATION_EXCHANGE optional
This element defines the exchange of handle orientations.
Sequence
FROM_HANDLE_ORIENTATION_REF
This element defines for which basic handle orientations the specific handle orientation is valid. If the element is not filled in the specific handle orientation is valid for all basic handle orientations.
The handle orientation has to be defined in the element BASIC_HANDLE_POSITIONS (Path1).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITION
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
TO_HANDLE_ORIENTATION_REF
This element defines the handle orientation which is used as a replacement.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
PRIORITY Restriction of xs:nonNegativeInteger
A priority of a handle orientation is defined in this field.
Per definition in the element SPECIFIC_HANDLE_ORIENTATION (Path 1) it is possible that several handle orientations are defined as valid handle orientations which would cause confusing and contradicting situations.
To avoid any ambiguities, priorities can be assigned to handle orientations.
The priority increases with the increase of the numerical values which are used for the definition of priorities. Several handle orientations can be summarized under one priority. Handle orientations with the same priority value require settings in the same key fields.

Element paths:
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS 		D nonNegativeInteger
P
M [1:999]
BASIC_HANDLE_POSITIONS

This element is used to describe the position and alignment of handles installed on certain front types. The basic handle positions defined in this element are valid universally.

The basic handle positions should be guided by the pre-defined standard handle positions in the section named standard handle positions. Please note that 0 must not be used as a value for basic handle positions.

Sequence
HANDLE_ORIENTATION 1..∞
This element is a container element for the definition of different basic handle positions.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute identifies a basic handle orientation. D positiveInteger
P
M [1:9999]
Sequence
FRONT_TYPE 1..7
This element defines the handle position and handle orientation for each front type. The front type itself is defined in the attribute FRONT_TYPE_CODE.
FRONT_TYPE_CODE required Restriction of xs:string
Different handle orientation are assigned to different front types. The different front types are listed below:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation) 		D string
P [SAKJTR]|GT
M [1:2]
Sequence
ORIENTATION Restriction of xs:string
This element is used for the differentiation of orientations.
H = horizontal
V = vertical 		D string
P [HV]
M [1:1]
POSITION Restriction of xs:string
This element is used for the differentiation of handle positions in accordance with the chosen front type.

M = middle (e.g. for grip ledges without hinge)
A = exterior (e.g. for grip ledge, dependent on the hinge)
D = double (two handles at the exterior sides)
G =without drilling, with handle (handle is delivered, drilling on site)
0 (zero) = without drilling, without handle (handle is not delivered, no drillings provided)

In case of position A = exterior, the definite position is indicated by the hinge information , i.e. left/ right, for the item. 		D string
P [MADG0]
M [1:1]
FRONT_TYPES_GROUPS optional
For an efficient use of front types in the definition of specific handle orientations in the element SPECIFIC_HANDLE_ORIENTATION (Path1) different front types can be combined to one front type group.

element paths path1:
GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS
Sequence
FRONT_TYPES_GROUP 1..99
This element defines a front type group.
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a front type group. D nonNegativeInteger
P
M [1:99]
Sequence
FRONT_TYPE 1..7
This element defines the handle position and handle orientation for each front type. The front type itself is defined by the attribute FRONT_TYPE_CODE.
FRONT_TYPE_CODE required Restriction of xs:string
This element contains the different front types which are combined to a front type group. The following front types are defined:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation) 		D string
P [SAKJTR]|GT
M [1:2]

FRONT_APPEARANCES optional
The different front appearances of a programme, an option, or an item are defined in this element. These front appearances are referenced by programmes (FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_APPEARANCE_REF), options (FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/FRONT_APPEARANCE_REF), or by items (SERIES/.../ITEM/FRONT_APPEARANCE_REF).
The basic definition of a front appearance consists of a basic shape number, assigned to a front element,and geometrical measurement information.
Sequence
FRONT_APPEARANCE 1..999
This element is used for the definition of a front appearance.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID for a front appearance which is referenced by styles and items. D positiveInteger
P
M [1:999]
Sequence
FRONT_TYPE 1..900
The definition of front type 0 is used when all front elements have the same appearance irrespective of the used front type. In this case the definition of divergent front types is not permitted. If a front type has been defined for a front appearance_ID, data sets for all other front types are required.
Sequence
FRONT_TYPE_NO Restriction of xs:positiveInteger
This attribute defines the front type key. D positiveInteger
P
M [0:1000]
Sequence 1..∞
FRONT_CONSTRAINTS optional
For the elements WIDTH_FROM/TO and HEIGTH_FROM/TO the following rules apply:

- If the elements WIDTH_TO or HEIGHT_TO are not defined, this equals the value "infinite"
- If the elements WIDTH_FROM or HEIGHT_FROM are not defined, this equals the value 0.
- The value 0 is not permitted in the elements WIDTH_FROM/TO or HEIGTH_FROM/TO.
- The intervalls have to cover the complete range
from 0 to infinite. Gaps are not permitted either
Sequence
WIDTH_FROM optional Restriction of xs:positiveInteger
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
WIDTH_TO optional Restriction of xs:positiveInteger
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
HEIGHT_FROM optional Restriction of xs:positiveInteger
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
HEIGHT_TO optional Restriction of xs:positiveInteger
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
FRONT_SHAPE
This element is used for the geometrical description of a front element.
Sequence
GLASS Restriction of xs:boolean
Values in this field indicate whether the front type is a glass front (value 1/true) or a simple front (value 0/false). For one front type the values in this element may not vary. This rule makes sure that a glass front is always depicted as glass front even when the programme has been changed. D boolean
P
M
Choice
MODELING_GRAPHIC_ID optional Restriction of xs:string
This element may be used for the definition of a modeling graphic.

Further format definitions are required. 		D string
P
M [1:15]
BASIC_FRONT_SHAPE optional
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".
Sequence
BASIC_FRONT_SHAPE_ID Restriction of xs:string
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".

Value 999 is not permitted any longer. 		D string
P
M [1:3]
PARAMETERS 1..∞
This element is used for assigning values to the different front parameters.
MODULE_RULE_SET_DEFINITIONS optional
This element is used for the definition of the rules which apply to module cabinets and their components.
Sequence
MODULE_RULE_SET_DEFINITION 1..∞
This element is used for the definition of specifig rules for module cabinets and the single module parts. The defined module rules are referenced by items (SERIES/.../ITEM/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) or (SERIES/.../ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the number of the rule set which references an item to the corresponding rule set. D nonNegativeInteger
P
M
Sequence
MODULE_RULE_SET_NAME languagetexte60 Complex Type
This element defines the name of the module rule set.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS optional
This element is used for saving hyperlinks with detail information.
Sequence
DETAIL_INFO 1..∞

This element is used to define a detail information.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute identifies detail information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
This element is used for the classification of detail information.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
This element describes the type of detail information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
Name of the link (e.g. "magic corner in motion").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
Element for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
This element assigns a globally unambiguous, and unique figure (Globally Unique Identifier (GUID))

The format of the GUID is defined as follows XXX-XXXX-XXXX-XXXX- XX. Each 'X' represents a character of the hexadecimal system, i.e. figures 0-9 or characters A-F. Example:
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-characters). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
Text information for a tool tip with reference to the link.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
URL
This element contains the URL for the detail information.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file . 		D positiveInteger
P
M [1:4]
PROPERTIES optional

This element is used to include additional information and characteristics, e.g. energy label, efficiency classes and similar data. Only the characteristics needed for correctly mapping the catalogue are defined.

The keys can be found in the corresponding table (information keys).

Sequence
PROPERTY 1..∞

This element is used to define a feature.

The key, text and measurement unit can be found in the correspondingtable (information keys)(information keys).

PROPERTY_NO required Restriction of xs:nonNegativeInteger

This attribute is used to identify the feature.

Its number can be found in the table with the information keys.

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetexte Complex Type

This element contains text information about the characteristics.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
PROPERTY_UNIT optional languagetexte30 Complex Type
If applicable, this element contains the measurement unit of the characteristic.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
GROUP_TITLES optional
This is a central point to store all kinds of descriptions for groups of optional and mandatory accessories.
Sequence
GROUP_TITLE 1..∞
This element is used to specify a group title.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify a unique number for later referencing of the group title. D nonNegativeInteger
P
M [0-999]
Sequence
GROUP_TITLE_NAME languagetexte60 Complex Type
This element contains the name for groups of accessories.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="GLOBAL_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLEARING_GROUP" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>120--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>120--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CLEARING_GROUP_NAME" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="CLEARING_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONTS_HANDLE_POSITIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SPECIFIC_HANDLE_POSITIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SPECIFIC_HANDLE_ORIENTATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="STYLE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="STYLE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FRONT_TYPE_GROUP_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="WIDTH_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--4--Breite_von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="WIDTH_TO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--5--Breite_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HEIGHT_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--6--Hoehe_von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HEIGHT_TO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--7--Hoehe_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OPTION_REF">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="154" />
                                  <xs:maxInclusive value="154" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="HANDLE_EXCHANGE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FEATURE_REF">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FROM_HANDLE">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="OPTION_REF">
                                      <xs:annotation>
                                        <xs:documentation>232--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>232--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="300" />
                                              <xs:maxInclusive value="303" />
                                              <xs:pattern value="300|303" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>232--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="5" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="TO_HANDLE">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="OPTION_REF">
                                      <xs:annotation>
                                        <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="300" />
                                              <xs:maxInclusive value="303" />
                                              <xs:pattern value="300|303" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="5" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="HANDLE_ORIENTATION_EXCHANGE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FROM_HANDLE_ORIENTATION_REF">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="TO_HANDLE_ORIENTATION_REF">
                                <xs:annotation>
                                  <xs:documentation>----</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>----</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRIORITY">
                          <xs:annotation>
                            <xs:documentation>232--14--Prioritaet</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="BASIC_HANDLE_POSITIONS">
              <xs:annotation>
                <xs:documentation>230--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="HANDLE_ORIENTATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>230--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_TYPE" maxOccurs="7">
                          <xs:annotation>
                            <xs:documentation>230--3--Fronttyp</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ORIENTATION">
                                <xs:annotation>
                                  <xs:documentation>230--4--Lage</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[HV]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="POSITION">
                                <xs:annotation>
                                  <xs:documentation>230--5--Position</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[MADG0]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="FRONT_TYPE_CODE" use="required">
                              <xs:annotation>
                                <xs:documentation>230--3--Fronttyp</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:pattern value="[SAKJTR]|GT" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>230--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONT_TYPES_GROUPS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>231--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_TYPES_GROUP" maxOccurs="99">
                    <xs:annotation>
                      <xs:documentation>231--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_TYPE" maxOccurs="7">
                          <xs:annotation>
                            <xs:documentation>231--3--Fronttyp</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FRONT_TYPE_CODE" use="required">
                              <xs:annotation>
                                <xs:documentation>231--3--Fronttyp</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:pattern value="[SAKJTR]|GT" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>231--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONT_APPEARANCES" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_APPEARANCE" maxOccurs="999">
              <xs:annotation>
                <xs:documentation>520--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_TYPE" maxOccurs="900">
                    <xs:annotation>
                      <xs:documentation>520--3--Fronttyp</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_TYPE_NO">
                          <xs:annotation>
                            <xs:documentation>520/570--3/3--Fronttyp</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="900" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:sequence maxOccurs="unbounded">
                          <xs:element name="FRONT_CONSTRAINTS" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="WIDTH_FROM" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>520/570--6--Breite_von</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="WIDTH_TO" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>520/570--7--Breite_von</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="HEIGHT_FROM" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="HEIGHT_TO" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="FRONT_SHAPE">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="GLASS">
                                  <xs:annotation>
                                    <xs:documentation>520--10--Glas</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:boolean" />
                                  </xs:simpleType>
                                </xs:element>
                                <xs:choice>
                                  <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="BASIC_FRONT_SHAPE" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="BASIC_FRONT_SHAPE_ID">
                                          <xs:annotation>
                                            <xs:documentation>520--4--Front_Grundform</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="3" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PARAMETERS" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="VALUE">
                                              <xs:annotation>
                                                <xs:documentation>520--5--Wert</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:maxLength value="12" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="PARAMETER">
                                              <xs:annotation>
                                                <xs:documentation>570--4--Parameter</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:minLength value="1" />
                                                  <xs:maxLength value="5" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:choice>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>520--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MODULE_RULE_SET_DEFINITIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MODULE_RULE_SET_DEFINITION" maxOccurs="unbounded">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MODULE_RULE_SET_NAME" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Um Mehrsprachenfaehigkeit erweitert AK 28.02.2012</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
13.06.2018/K.Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLASSIFICATION">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INFO_TYPE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
                      <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
                      <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[01]|99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="INTERNAL_NAME" type="languagetexte40">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="GUID">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="URL">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:anyURI">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="1024" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HASH_VALUE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="64" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RESOLUTION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="4" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PROPERTIES" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>Version 2.3 </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PROPERTY" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>Version 2.3</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PROPERTY_TEXT" type="languagetexte" minOccurs="1" maxOccurs="1" />
                  <xs:element name="PROPERTY_UNIT" type="languagetexte30" minOccurs="0" maxOccurs="1" />
                </xs:sequence>
                <xs:attribute name="PROPERTY_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="GROUP_TITLES" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>120--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="GROUP_TITLE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>120--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="GROUP_TITLE_NAME" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="GROUP_TITLE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : CLEARING_GROUP Element
Description
This element is used for the definition of clearing groups. Different exchange_IDs are summarized and made up to a clearing group (element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID).

The clearing groups in the block conditions (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) and the grading tables (BLOCK_VALUE_CALCULATION/GRADING_TABLE) are used for the definition of a minimum value for a certain type range. The different type ranges can be identified by their corresponding exchange_ID.

The single amounts of all items which belong to a certain exchange_ID are summarized. A total amount is summed up for each clearing group. This amount is defined as reference value for further use in block calculation and for the value clearing grading table.
Namespace (none)
Diagram
LANGUAGE Element Sequence CLEARING_GROUP_NAME Element EXCHANGE_ID_REF Element Sequence CLEARING_GROUP Element
Overview
CLEARING_GROUP 0..∞
This element is used for the definition of clearing groups. Different exchange_IDs are summarized and made up to a clearing group (element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID).

The clearing groups in the block conditions (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) and the grading tables (BLOCK_VALUE_CALCULATION/GRADING_TABLE) are used for the definition of a minimum value for a certain type range. The different type ranges can be identified by their corresponding exchange_ID.

The single amounts of all items which belong to a certain exchange_ID are summarized. A total amount is summed up for each clearing group. This amount is defined as reference value for further use in block calculation and for the value clearing grading table.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a clearing group. D nonNegativeInteger
P
M [0:999]
Sequence
EXCHANGE_ID_REF 1..∞
This element references an exchange-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
This element contains the exchange_IDs which are combined to a clearing group. Values 0, 98 and 99 are not permitted. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
CLEARING_GROUP_NAME languagetexte60 Complex Type
Name for a clearing group. This is used in order to simplify data acquisition.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
CLEARING_GROUP_NO Restriction of xs:nonNegativeInteger required
This attribute identifies a clearing group. D nonNegativeInteger
P
M [0:999]
Remarks

Source
<xs:element name="CLEARING_GROUP" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>120--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CLEARING_GROUP_NAME" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="CLEARING_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > CLEARING_GROUP Element : EXCHANGE_ID_REF Element
Description
This element references an exchange-ID.
Namespace (none)
Diagram
EXCHANGE_ID_REF Element
Overview
EXCHANGE_ID_REF 1..∞
This element references an exchange-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
This element contains the exchange_IDs which are combined to a clearing group. Values 0, 98 and 99 are not permitted. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attributes
Name Type Use Default Fixed Description
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
This element contains the exchange_IDs which are combined to a clearing group. Values 0, 98 and 99 are not permitted. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Remarks

Source
<xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
CLEARING_GROUP Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > CLEARING_GROUP Element : CLEARING_GROUP_NAME Element
Description
Name for a clearing group. This is used in order to simplify data acquisition.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence CLEARING_GROUP_NAME Element
Overview
CLEARING_GROUP_NAME languagetexte60 Complex Type
Name for a clearing group. This is used in order to simplify data acquisition.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="CLEARING_GROUP_NAME" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CLEARING_GROUP Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > languagetexte60 Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte60 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > languagetexte60 Complex Type > LANGUAGE Element : TEXT Element
Description
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetexte60 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONTS_HANDLE_POSITIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : FRONTS_HANDLE_POSITIONS Element
Description
This element is used for the definition of handle positions, either basic or specific positions. The validity of a basic handle position is global, whereas the validity of a specific handle position is subject to special conditions.
Namespace (none)
Diagram
FRONT_TYPES_GROUPS Element BASIC_HANDLE_POSITIONS Element SPECIFIC_HANDLE_POSITIONS Element Sequence FRONTS_HANDLE_POSITIONS Element
Overview
FRONTS_HANDLE_POSITIONS optional
This element is used for the definition of handle positions, either basic or specific positions. The validity of a basic handle position is global, whereas the validity of a specific handle position is subject to special conditions.
Sequence
SPECIFIC_HANDLE_POSITIONS optional
Specific handle positions, changes of handle positions or changes of handles can be defined in this element. For all these cases the denotation “specific handle positon” is used. User-defined combinations of the different child elements are permitted. The more child elements are filled in, the more precise is the description of the specific handle position. The PRIORITY field (P1) and at least one key field have to be filled in.

Element paths
Path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/
Sequence
SPECIFIC_HANDLE_ORIENTATION 1..∞
This element defines a specific handle orientation.
SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a specific handle orientation. D nonNegativeInteger
P
M [0:99999]
Sequence
STYLE_REF optional
References are used for assigning specific handle orientations to specific programmes. If this element is not defined, the handle orientation is applicable for all programmes.
STYLE_NO required Restriction of xs:string
This attribute defines the referenced programme. It references to the attribute STYLE_NO in the element STYLE (Path1).

element paths:
path1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
FRONT_TYPE_GROUP_REF optional
This element defines the front type group to which a special handle orientation applies. If this element is not defined the handle orientation is available for all front type groups
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute references the front type group. D nonNegativeInteger
P
M [1:99]
WIDTH_FROM optional Restriction of xs:positiveInteger
The given measurement in this element defines the minimum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field require corresponding settings in the field WIDTH_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
WIDTH_TO optional Restriction of xs:positiveInteger
The given measurement defines the maximum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field are required when the field WIDTH_FROM was filled in. The width is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
The given measurement defines the minimum height (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field require corresponding settings in the field HEIGHT_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
HEIGHT_TO optional Restriction of xs:nonNegativeInteger
The given measurement defines the maximum height(nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field are required when the field HEIGHT_FROM was filled in. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
OPTION_REF
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (FEATURE_NO = 154) is defined for it.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. Only feature type 154 is permitted. D nonNegativeInteger
P
M [154:154]
OPTION_KEY required Restriction of xs:string
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door"" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (154) is defined for it. 		D string
P
M [1:5]
HANDLE_EXCHANGE optional
Specific conditions for a handle exchange are defined in this element. Further conditions defined in the element SPECIFIC_HANDLE_ORIENTATION have to be fulfilled.
Sequence
FEATURE_REF
This element references a feature type which is defined in the element FEATURE_DEFINITION/FEATURES/FEATURE.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
FROM_HANDLE
This element defines which handle is exchanged.
Sequence
OPTION_REF
This element references a handle option in the element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. This element defines the handle option which is used for the specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle options.
FEATURE_NO required Restriction of xs:positiveInteger
This attribute defines the variation type of the handle which is changed, options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
This attribute assigns a handle variation to a specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle variations. D string
P
M [1:5]
TO_HANDLE
This element defines the handle which is used as a replacement.
Sequence
OPTION_REF
This element defines the handle which is used as a replacement handle in certain situations.
FEATURE_NO required Restriction of xs:positiveInteger
This attribute defines the variation type of the referenced handle variation. Options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
This element defines the handle variation which is used as a replacement. D string
P
M [1:5]
HANDLE_ORIENTATION_EXCHANGE optional
This element defines the exchange of handle orientations.
Sequence
FROM_HANDLE_ORIENTATION_REF
This element defines for which basic handle orientations the specific handle orientation is valid. If the element is not filled in the specific handle orientation is valid for all basic handle orientations.
The handle orientation has to be defined in the element BASIC_HANDLE_POSITIONS (Path1).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITION
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
TO_HANDLE_ORIENTATION_REF
This element defines the handle orientation which is used as a replacement.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
PRIORITY Restriction of xs:nonNegativeInteger
A priority of a handle orientation is defined in this field.
Per definition in the element SPECIFIC_HANDLE_ORIENTATION (Path 1) it is possible that several handle orientations are defined as valid handle orientations which would cause confusing and contradicting situations.
To avoid any ambiguities, priorities can be assigned to handle orientations.
The priority increases with the increase of the numerical values which are used for the definition of priorities. Several handle orientations can be summarized under one priority. Handle orientations with the same priority value require settings in the same key fields.

Element paths:
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS 		D nonNegativeInteger
P
M [1:999]
BASIC_HANDLE_POSITIONS

This element is used to describe the position and alignment of handles installed on certain front types. The basic handle positions defined in this element are valid universally.

The basic handle positions should be guided by the pre-defined standard handle positions in the section named standard handle positions. Please note that 0 must not be used as a value for basic handle positions.

Sequence
HANDLE_ORIENTATION 1..∞
This element is a container element for the definition of different basic handle positions.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute identifies a basic handle orientation. D positiveInteger
P
M [1:9999]
Sequence
FRONT_TYPE 1..7
This element defines the handle position and handle orientation for each front type. The front type itself is defined in the attribute FRONT_TYPE_CODE.
FRONT_TYPE_CODE required Restriction of xs:string
Different handle orientation are assigned to different front types. The different front types are listed below:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation) 		D string
P [SAKJTR]|GT
M [1:2]
Sequence
ORIENTATION Restriction of xs:string
This element is used for the differentiation of orientations.
H = horizontal
V = vertical 		D string
P [HV]
M [1:1]
POSITION Restriction of xs:string
This element is used for the differentiation of handle positions in accordance with the chosen front type.

M = middle (e.g. for grip ledges without hinge)
A = exterior (e.g. for grip ledge, dependent on the hinge)
D = double (two handles at the exterior sides)
G =without drilling, with handle (handle is delivered, drilling on site)
0 (zero) = without drilling, without handle (handle is not delivered, no drillings provided)

In case of position A = exterior, the definite position is indicated by the hinge information , i.e. left/ right, for the item. 		D string
P [MADG0]
M [1:1]
FRONT_TYPES_GROUPS optional
For an efficient use of front types in the definition of specific handle orientations in the element SPECIFIC_HANDLE_ORIENTATION (Path1) different front types can be combined to one front type group.

element paths path1:
GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS
Sequence
FRONT_TYPES_GROUP 1..99
This element defines a front type group.
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a front type group. D nonNegativeInteger
P
M [1:99]
Sequence
FRONT_TYPE 1..7
This element defines the handle position and handle orientation for each front type. The front type itself is defined by the attribute FRONT_TYPE_CODE.
FRONT_TYPE_CODE required Restriction of xs:string
This element contains the different front types which are combined to a front type group. The following front types are defined:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation) 		D string
P [SAKJTR]|GT
M [1:2]

Remarks

Source
<xs:element name="FRONTS_HANDLE_POSITIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SPECIFIC_HANDLE_POSITIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SPECIFIC_HANDLE_ORIENTATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="STYLE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="STYLE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FRONT_TYPE_GROUP_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="WIDTH_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--4--Breite_von</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="WIDTH_TO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--5--Breite_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HEIGHT_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--6--Hoehe_von</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HEIGHT_TO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--7--Hoehe_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OPTION_REF">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="154" />
                            <xs:maxInclusive value="154" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HANDLE_EXCHANGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FEATURE_REF">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FROM_HANDLE">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="300" />
                                        <xs:maxInclusive value="303" />
                                        <xs:pattern value="300|303" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TO_HANDLE">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF">
                                <xs:annotation>
                                  <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="300" />
                                        <xs:maxInclusive value="303" />
                                        <xs:pattern value="300|303" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HANDLE_ORIENTATION_EXCHANGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FROM_HANDLE_ORIENTATION_REF">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TO_HANDLE_ORIENTATION_REF">
                          <xs:annotation>
                            <xs:documentation>----</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>----</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRIORITY">
                    <xs:annotation>
                      <xs:documentation>232--14--Prioritaet</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BASIC_HANDLE_POSITIONS">
        <xs:annotation>
          <xs:documentation>230--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="HANDLE_ORIENTATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>230--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_TYPE" maxOccurs="7">
                    <xs:annotation>
                      <xs:documentation>230--3--Fronttyp</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ORIENTATION">
                          <xs:annotation>
                            <xs:documentation>230--4--Lage</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[HV]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="POSITION">
                          <xs:annotation>
                            <xs:documentation>230--5--Position</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[MADG0]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FRONT_TYPE_CODE" use="required">
                        <xs:annotation>
                          <xs:documentation>230--3--Fronttyp</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:pattern value="[SAKJTR]|GT" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>230--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONT_TYPES_GROUPS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>231--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_TYPES_GROUP" maxOccurs="99">
              <xs:annotation>
                <xs:documentation>231--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_TYPE" maxOccurs="7">
                    <xs:annotation>
                      <xs:documentation>231--3--Fronttyp</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FRONT_TYPE_CODE" use="required">
                        <xs:annotation>
                          <xs:documentation>231--3--Fronttyp</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:pattern value="[SAKJTR]|GT" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>231--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SPECIFIC_HANDLE_POSITIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element : SPECIFIC_HANDLE_POSITIONS Element
Description
Specific handle positions, changes of handle positions or changes of handles can be defined in this element. For all these cases the denotation “specific handle positon” is used. User-defined combinations of the different child elements are permitted. The more child elements are filled in, the more precise is the description of the specific handle position. The PRIORITY field (P1) and at least one key field have to be filled in.

Element paths
Path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/
Namespace (none)
Diagram
SPECIFIC_HANDLE_ORIENTATION Element Sequence SPECIFIC_HANDLE_POSITIONS Element
Overview
SPECIFIC_HANDLE_POSITIONS optional
Specific handle positions, changes of handle positions or changes of handles can be defined in this element. For all these cases the denotation “specific handle positon” is used. User-defined combinations of the different child elements are permitted. The more child elements are filled in, the more precise is the description of the specific handle position. The PRIORITY field (P1) and at least one key field have to be filled in.

Element paths
Path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/
Sequence
SPECIFIC_HANDLE_ORIENTATION 1..∞
This element defines a specific handle orientation.
SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a specific handle orientation. D nonNegativeInteger
P
M [0:99999]
Sequence
STYLE_REF optional
References are used for assigning specific handle orientations to specific programmes. If this element is not defined, the handle orientation is applicable for all programmes.
STYLE_NO required Restriction of xs:string
This attribute defines the referenced programme. It references to the attribute STYLE_NO in the element STYLE (Path1).

element paths:
path1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
FRONT_TYPE_GROUP_REF optional
This element defines the front type group to which a special handle orientation applies. If this element is not defined the handle orientation is available for all front type groups
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute references the front type group. D nonNegativeInteger
P
M [1:99]
WIDTH_FROM optional Restriction of xs:positiveInteger
The given measurement in this element defines the minimum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field require corresponding settings in the field WIDTH_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
WIDTH_TO optional Restriction of xs:positiveInteger
The given measurement defines the maximum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field are required when the field WIDTH_FROM was filled in. The width is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
The given measurement defines the minimum height (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field require corresponding settings in the field HEIGHT_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
HEIGHT_TO optional Restriction of xs:nonNegativeInteger
The given measurement defines the maximum height(nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field are required when the field HEIGHT_FROM was filled in. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
OPTION_REF
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (FEATURE_NO = 154) is defined for it.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. Only feature type 154 is permitted. D nonNegativeInteger
P
M [154:154]
OPTION_KEY required Restriction of xs:string
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door"" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (154) is defined for it. 		D string
P
M [1:5]
HANDLE_EXCHANGE optional
Specific conditions for a handle exchange are defined in this element. Further conditions defined in the element SPECIFIC_HANDLE_ORIENTATION have to be fulfilled.
Sequence
FEATURE_REF
This element references a feature type which is defined in the element FEATURE_DEFINITION/FEATURES/FEATURE.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
FROM_HANDLE
This element defines which handle is exchanged.
Sequence
OPTION_REF
This element references a handle option in the element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. This element defines the handle option which is used for the specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle options.
FEATURE_NO required Restriction of xs:positiveInteger
This attribute defines the variation type of the handle which is changed, options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
This attribute assigns a handle variation to a specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle variations. D string
P
M [1:5]
TO_HANDLE
This element defines the handle which is used as a replacement.
Sequence
OPTION_REF
This element defines the handle which is used as a replacement handle in certain situations.
FEATURE_NO required Restriction of xs:positiveInteger
This attribute defines the variation type of the referenced handle variation. Options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
This element defines the handle variation which is used as a replacement. D string
P
M [1:5]
HANDLE_ORIENTATION_EXCHANGE optional
This element defines the exchange of handle orientations.
Sequence
FROM_HANDLE_ORIENTATION_REF
This element defines for which basic handle orientations the specific handle orientation is valid. If the element is not filled in the specific handle orientation is valid for all basic handle orientations.
The handle orientation has to be defined in the element BASIC_HANDLE_POSITIONS (Path1).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITION
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
TO_HANDLE_ORIENTATION_REF
This element defines the handle orientation which is used as a replacement.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
PRIORITY Restriction of xs:nonNegativeInteger
A priority of a handle orientation is defined in this field.
Per definition in the element SPECIFIC_HANDLE_ORIENTATION (Path 1) it is possible that several handle orientations are defined as valid handle orientations which would cause confusing and contradicting situations.
To avoid any ambiguities, priorities can be assigned to handle orientations.
The priority increases with the increase of the numerical values which are used for the definition of priorities. Several handle orientations can be summarized under one priority. Handle orientations with the same priority value require settings in the same key fields.

Element paths:
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS 		D nonNegativeInteger
P
M [1:999]
Remarks

Source
<xs:element name="SPECIFIC_HANDLE_POSITIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SPECIFIC_HANDLE_ORIENTATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="STYLE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="STYLE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONT_TYPE_GROUP_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="WIDTH_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--4--Breite_von</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="WIDTH_TO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--5--Breite_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEIGHT_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--6--Hoehe_von</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEIGHT_TO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--7--Hoehe_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="OPTION_REF">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="154" />
                      <xs:maxInclusive value="154" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="HANDLE_EXCHANGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_REF">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FROM_HANDLE">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="300" />
                                  <xs:maxInclusive value="303" />
                                  <xs:pattern value="300|303" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TO_HANDLE">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF">
                          <xs:annotation>
                            <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="300" />
                                  <xs:maxInclusive value="303" />
                                  <xs:pattern value="300|303" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="HANDLE_ORIENTATION_EXCHANGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FROM_HANDLE_ORIENTATION_REF">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TO_HANDLE_ORIENTATION_REF">
                    <xs:annotation>
                      <xs:documentation>----</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>----</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRIORITY">
              <xs:annotation>
                <xs:documentation>232--14--Prioritaet</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SPECIFIC_HANDLE_ORIENTATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element : SPECIFIC_HANDLE_ORIENTATION Element
Description
This element defines a specific handle orientation.
Namespace (none)
Diagram
PRIORITY Element HANDLE_ORIENTATION_EXCHANGE Element HANDLE_EXCHANGE Element OPTION_REF Element HEIGHT_TO Element HEIGHT_FROM Element WIDTH_TO Element WIDTH_FROM Element FRONT_TYPE_GROUP_REF Element STYLE_REF Element Sequence SPECIFIC_HANDLE_ORIENTATION Element
Overview
SPECIFIC_HANDLE_ORIENTATION 1..∞
This element defines a specific handle orientation.
SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a specific handle orientation. D nonNegativeInteger
P
M [0:99999]
Sequence
STYLE_REF optional
References are used for assigning specific handle orientations to specific programmes. If this element is not defined, the handle orientation is applicable for all programmes.
STYLE_NO required Restriction of xs:string
This attribute defines the referenced programme. It references to the attribute STYLE_NO in the element STYLE (Path1).

element paths:
path1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
FRONT_TYPE_GROUP_REF optional
This element defines the front type group to which a special handle orientation applies. If this element is not defined the handle orientation is available for all front type groups
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute references the front type group. D nonNegativeInteger
P
M [1:99]
WIDTH_FROM optional Restriction of xs:positiveInteger
The given measurement in this element defines the minimum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field require corresponding settings in the field WIDTH_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
WIDTH_TO optional Restriction of xs:positiveInteger
The given measurement defines the maximum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field are required when the field WIDTH_FROM was filled in. The width is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
The given measurement defines the minimum height (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field require corresponding settings in the field HEIGHT_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
HEIGHT_TO optional Restriction of xs:nonNegativeInteger
The given measurement defines the maximum height(nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field are required when the field HEIGHT_FROM was filled in. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
OPTION_REF
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (FEATURE_NO = 154) is defined for it.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. Only feature type 154 is permitted. D nonNegativeInteger
P
M [154:154]
OPTION_KEY required Restriction of xs:string
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door"" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (154) is defined for it. 		D string
P
M [1:5]
HANDLE_EXCHANGE optional
Specific conditions for a handle exchange are defined in this element. Further conditions defined in the element SPECIFIC_HANDLE_ORIENTATION have to be fulfilled.
Sequence
FEATURE_REF
This element references a feature type which is defined in the element FEATURE_DEFINITION/FEATURES/FEATURE.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
FROM_HANDLE
This element defines which handle is exchanged.
Sequence
OPTION_REF
This element references a handle option in the element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. This element defines the handle option which is used for the specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle options.
FEATURE_NO required Restriction of xs:positiveInteger
This attribute defines the variation type of the handle which is changed, options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
This attribute assigns a handle variation to a specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle variations. D string
P
M [1:5]
TO_HANDLE
This element defines the handle which is used as a replacement.
Sequence
OPTION_REF
This element defines the handle which is used as a replacement handle in certain situations.
FEATURE_NO required Restriction of xs:positiveInteger
This attribute defines the variation type of the referenced handle variation. Options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
This element defines the handle variation which is used as a replacement. D string
P
M [1:5]
HANDLE_ORIENTATION_EXCHANGE optional
This element defines the exchange of handle orientations.
Sequence
FROM_HANDLE_ORIENTATION_REF
This element defines for which basic handle orientations the specific handle orientation is valid. If the element is not filled in the specific handle orientation is valid for all basic handle orientations.
The handle orientation has to be defined in the element BASIC_HANDLE_POSITIONS (Path1).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITION
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
TO_HANDLE_ORIENTATION_REF
This element defines the handle orientation which is used as a replacement.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
PRIORITY Restriction of xs:nonNegativeInteger
A priority of a handle orientation is defined in this field.
Per definition in the element SPECIFIC_HANDLE_ORIENTATION (Path 1) it is possible that several handle orientations are defined as valid handle orientations which would cause confusing and contradicting situations.
To avoid any ambiguities, priorities can be assigned to handle orientations.
The priority increases with the increase of the numerical values which are used for the definition of priorities. Several handle orientations can be summarized under one priority. Handle orientations with the same priority value require settings in the same key fields.

Element paths:
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS 		D nonNegativeInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
SPECIFIC_HANDLE_ORIENTATION_NO Restriction of xs:nonNegativeInteger required
This attribute identifies a specific handle orientation. D nonNegativeInteger
P
M [0:99999]
Remarks

Source
<xs:element name="SPECIFIC_HANDLE_ORIENTATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="STYLE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="STYLE_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONT_TYPE_GROUP_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="WIDTH_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--4--Breite_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="WIDTH_TO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--5--Breite_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--6--Hoehe_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT_TO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--7--Hoehe_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="OPTION_REF">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="154" />
                <xs:maxInclusive value="154" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="HANDLE_EXCHANGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_REF">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FROM_HANDLE">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="300" />
                            <xs:maxInclusive value="303" />
                            <xs:pattern value="300|303" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="TO_HANDLE">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF">
                    <xs:annotation>
                      <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="300" />
                            <xs:maxInclusive value="303" />
                            <xs:pattern value="300|303" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="HANDLE_ORIENTATION_EXCHANGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FROM_HANDLE_ORIENTATION_REF">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="TO_HANDLE_ORIENTATION_REF">
              <xs:annotation>
                <xs:documentation>----</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>----</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRIORITY">
        <xs:annotation>
          <xs:documentation>232--14--Prioritaet</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STYLE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : STYLE_REF Element
Description
References are used for assigning specific handle orientations to specific programmes. If this element is not defined, the handle orientation is applicable for all programmes.
Namespace (none)
Diagram
STYLE_REF Element
Overview
STYLE_REF optional
References are used for assigning specific handle orientations to specific programmes. If this element is not defined, the handle orientation is applicable for all programmes.
STYLE_NO required Restriction of xs:string
This attribute defines the referenced programme. It references to the attribute STYLE_NO in the element STYLE (Path1).

element paths:
path1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
STYLE_NO Restriction of xs:string required
This attribute defines the referenced programme. It references to the attribute STYLE_NO in the element STYLE (Path1).

element paths:
path1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Remarks

Source
<xs:element name="STYLE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="STYLE_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPE_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : FRONT_TYPE_GROUP_REF Element
Description
This element defines the front type group to which a special handle orientation applies. If this element is not defined the handle orientation is available for all front type groups
Namespace (none)
Diagram
FRONT_TYPE_GROUP_REF Element
Overview
FRONT_TYPE_GROUP_REF optional
This element defines the front type group to which a special handle orientation applies. If this element is not defined the handle orientation is available for all front type groups
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute references the front type group. D nonNegativeInteger
P
M [1:99]
Attributes
Name Type Use Default Fixed Description
FRONT_TYPE_GROUP_NO Restriction of xs:nonNegativeInteger required
This attribute references the front type group. D nonNegativeInteger
P
M [1:99]
Remarks

Source
<xs:element name="FRONT_TYPE_GROUP_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WIDTH_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : WIDTH_FROM Element
Description
The given measurement in this element defines the minimum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field require corresponding settings in the field WIDTH_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
WIDTH_FROM Element
Overview
WIDTH_FROM optional Restriction of xs:positiveInteger
The given measurement in this element defines the minimum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field require corresponding settings in the field WIDTH_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
Remarks

Source
<xs:element name="WIDTH_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--4--Breite_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WIDTH_TO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : WIDTH_TO Element
Description
The given measurement defines the maximum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field are required when the field WIDTH_FROM was filled in. The width is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
WIDTH_TO Element
Overview
WIDTH_TO optional Restriction of xs:positiveInteger
The given measurement defines the maximum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field are required when the field WIDTH_FROM was filled in. The width is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
Remarks

Source
<xs:element name="WIDTH_TO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--5--Breite_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEIGHT_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : HEIGHT_FROM Element
Description
The given measurement defines the minimum height (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field require corresponding settings in the field HEIGHT_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
HEIGHT_FROM Element
Overview
HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
The given measurement defines the minimum height (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field require corresponding settings in the field HEIGHT_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
Remarks

Source
<xs:element name="HEIGHT_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--6--Hoehe_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEIGHT_TO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : HEIGHT_TO Element
Description
The given measurement defines the maximum height(nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field are required when the field HEIGHT_FROM was filled in. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
HEIGHT_TO Element
Overview
HEIGHT_TO optional Restriction of xs:nonNegativeInteger
The given measurement defines the maximum height(nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field are required when the field HEIGHT_FROM was filled in. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item. D nonNegativeInteger
P
M [1:9999]
Remarks

Source
<xs:element name="HEIGHT_TO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--7--Hoehe_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : OPTION_REF Element
Description
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (FEATURE_NO = 154) is defined for it.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (FEATURE_NO = 154) is defined for it.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. Only feature type 154 is permitted. D nonNegativeInteger
P
M [154:154]
OPTION_KEY required Restriction of xs:string
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door"" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (154) is defined for it. 		D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for the definition of an option type. Only feature type 154 is permitted. D nonNegativeInteger
P
M [154:154]
OPTION_KEY Restriction of xs:string required
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door"" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (154) is defined for it. 		D string
P
M [1:5]
Remarks

Source
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="154" />
          <xs:maxInclusive value="154" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_EXCHANGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : HANDLE_EXCHANGE Element
Description
Specific conditions for a handle exchange are defined in this element. Further conditions defined in the element SPECIFIC_HANDLE_ORIENTATION have to be fulfilled.
Namespace (none)
Diagram
TO_HANDLE Element FROM_HANDLE Element FEATURE_REF Element Sequence HANDLE_EXCHANGE Element
Overview
HANDLE_EXCHANGE optional
Specific conditions for a handle exchange are defined in this element. Further conditions defined in the element SPECIFIC_HANDLE_ORIENTATION have to be fulfilled.
Sequence
FEATURE_REF
This element references a feature type which is defined in the element FEATURE_DEFINITION/FEATURES/FEATURE.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
FROM_HANDLE
This element defines which handle is exchanged.
Sequence
OPTION_REF
This element references a handle option in the element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. This element defines the handle option which is used for the specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle options.
FEATURE_NO required Restriction of xs:positiveInteger
This attribute defines the variation type of the handle which is changed, options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
This attribute assigns a handle variation to a specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle variations. D string
P
M [1:5]
TO_HANDLE
This element defines the handle which is used as a replacement.
Sequence
OPTION_REF
This element defines the handle which is used as a replacement handle in certain situations.
FEATURE_NO required Restriction of xs:positiveInteger
This attribute defines the variation type of the referenced handle variation. Options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
This element defines the handle variation which is used as a replacement. D string
P
M [1:5]
Remarks

Source
<xs:element name="HANDLE_EXCHANGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_REF">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FROM_HANDLE">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="300" />
                      <xs:maxInclusive value="303" />
                      <xs:pattern value="300|303" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="TO_HANDLE">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF">
              <xs:annotation>
                <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="300" />
                      <xs:maxInclusive value="303" />
                      <xs:pattern value="300|303" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_EXCHANGE Element : FEATURE_REF Element
Description
This element references a feature type which is defined in the element FEATURE_DEFINITION/FEATURES/FEATURE.
Namespace (none)
Diagram
FEATURE_REF Element
Overview
FEATURE_REF
This element references a feature type which is defined in the element FEATURE_DEFINITION/FEATURES/FEATURE.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
Remarks

Source
<xs:element name="FEATURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
HANDLE_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FROM_HANDLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_EXCHANGE Element : FROM_HANDLE Element
Description
This element defines which handle is exchanged.
Namespace (none)
Diagram
OPTION_REF Element Sequence FROM_HANDLE Element
Overview
FROM_HANDLE
This element defines which handle is exchanged.
Sequence
OPTION_REF
This element references a handle option in the element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. This element defines the handle option which is used for the specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle options.
FEATURE_NO required Restriction of xs:positiveInteger
This attribute defines the variation type of the handle which is changed, options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
This attribute assigns a handle variation to a specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle variations. D string
P
M [1:5]
Remarks

Source
<xs:element name="FROM_HANDLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="300" />
                <xs:maxInclusive value="303" />
                <xs:pattern value="300|303" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
HANDLE_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_EXCHANGE Element > FROM_HANDLE Element : OPTION_REF Element
Description
This element references a handle option in the element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. This element defines the handle option which is used for the specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle options.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF
This element references a handle option in the element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. This element defines the handle option which is used for the specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle options.
FEATURE_NO required Restriction of xs:positiveInteger
This attribute defines the variation type of the handle which is changed, options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
This attribute assigns a handle variation to a specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle variations. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:positiveInteger required
This attribute defines the variation type of the handle which is changed, options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY Restriction of xs:string required
This attribute assigns a handle variation to a specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle variations. D string
P
M [1:5]
Remarks

Source
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="300" />
          <xs:maxInclusive value="303" />
          <xs:pattern value="300|303" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FROM_HANDLE Element | HANDLE_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TO_HANDLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_EXCHANGE Element : TO_HANDLE Element
Description
This element defines the handle which is used as a replacement.
Namespace (none)
Diagram
OPTION_REF Element Sequence TO_HANDLE Element
Overview
TO_HANDLE
This element defines the handle which is used as a replacement.
Sequence
OPTION_REF
This element defines the handle which is used as a replacement handle in certain situations.
FEATURE_NO required Restriction of xs:positiveInteger
This attribute defines the variation type of the referenced handle variation. Options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
This element defines the handle variation which is used as a replacement. D string
P
M [1:5]
Remarks

Source
<xs:element name="TO_HANDLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF">
        <xs:annotation>
          <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="300" />
                <xs:maxInclusive value="303" />
                <xs:pattern value="300|303" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
HANDLE_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_EXCHANGE Element > TO_HANDLE Element : OPTION_REF Element
Description
This element defines the handle which is used as a replacement handle in certain situations.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF
This element defines the handle which is used as a replacement handle in certain situations.
FEATURE_NO required Restriction of xs:positiveInteger
This attribute defines the variation type of the referenced handle variation. Options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
This element defines the handle variation which is used as a replacement. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:positiveInteger required
This attribute defines the variation type of the referenced handle variation. Options 300 and 303 are permitted. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY Restriction of xs:string required
This element defines the handle variation which is used as a replacement. D string
P
M [1:5]
Remarks

Source
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="300" />
          <xs:maxInclusive value="303" />
          <xs:pattern value="300|303" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
TO_HANDLE Element | HANDLE_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_ORIENTATION_EXCHANGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : HANDLE_ORIENTATION_EXCHANGE Element
Description
This element defines the exchange of handle orientations.
Namespace (none)
Diagram
TO_HANDLE_ORIENTATION_REF Element FROM_HANDLE_ORIENTATION_REF Element Sequence HANDLE_ORIENTATION_EXCHANGE Element
Overview
HANDLE_ORIENTATION_EXCHANGE optional
This element defines the exchange of handle orientations.
Sequence
FROM_HANDLE_ORIENTATION_REF
This element defines for which basic handle orientations the specific handle orientation is valid. If the element is not filled in the specific handle orientation is valid for all basic handle orientations.
The handle orientation has to be defined in the element BASIC_HANDLE_POSITIONS (Path1).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITION
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
TO_HANDLE_ORIENTATION_REF
This element defines the handle orientation which is used as a replacement.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
Remarks

Source
<xs:element name="HANDLE_ORIENTATION_EXCHANGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FROM_HANDLE_ORIENTATION_REF">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="TO_HANDLE_ORIENTATION_REF">
        <xs:annotation>
          <xs:documentation>----</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
            <xs:annotation>
              <xs:documentation>----</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FROM_HANDLE_ORIENTATION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_ORIENTATION_EXCHANGE Element : FROM_HANDLE_ORIENTATION_REF Element
Description
This element defines for which basic handle orientations the specific handle orientation is valid. If the element is not filled in the specific handle orientation is valid for all basic handle orientations.
The handle orientation has to be defined in the element BASIC_HANDLE_POSITIONS (Path1).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITION
Namespace (none)
Diagram
FROM_HANDLE_ORIENTATION_REF Element
Overview
FROM_HANDLE_ORIENTATION_REF
This element defines for which basic handle orientations the specific handle orientation is valid. If the element is not filled in the specific handle orientation is valid for all basic handle orientations.
The handle orientation has to be defined in the element BASIC_HANDLE_POSITIONS (Path1).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITION
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
Attributes
Name Type Use Default Fixed Description
HANDLE_ORIENTATION_NO Restriction of xs:positiveInteger required
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
Remarks

Source
<xs:element name="FROM_HANDLE_ORIENTATION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
HANDLE_ORIENTATION_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TO_HANDLE_ORIENTATION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_ORIENTATION_EXCHANGE Element : TO_HANDLE_ORIENTATION_REF Element
Description
This element defines the handle orientation which is used as a replacement.
Namespace (none)
Diagram
TO_HANDLE_ORIENTATION_REF Element
Overview
TO_HANDLE_ORIENTATION_REF
This element defines the handle orientation which is used as a replacement.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
Attributes
Name Type Use Default Fixed Description
HANDLE_ORIENTATION_NO Restriction of xs:positiveInteger required
This attribute is used to reference a specific handle position. D positiveInteger
P
M [1:9999]
Remarks

Source
<xs:element name="TO_HANDLE_ORIENTATION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>----</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>----</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
HANDLE_ORIENTATION_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRIORITY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : PRIORITY Element
Description
A priority of a handle orientation is defined in this field.
Per definition in the element SPECIFIC_HANDLE_ORIENTATION (Path 1) it is possible that several handle orientations are defined as valid handle orientations which would cause confusing and contradicting situations.
To avoid any ambiguities, priorities can be assigned to handle orientations.
The priority increases with the increase of the numerical values which are used for the definition of priorities. Several handle orientations can be summarized under one priority. Handle orientations with the same priority value require settings in the same key fields.

Element paths:
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS 		D nonNegativeInteger
P
M [1:999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
PRIORITY Element
Overview
PRIORITY Restriction of xs:nonNegativeInteger
A priority of a handle orientation is defined in this field.
Per definition in the element SPECIFIC_HANDLE_ORIENTATION (Path 1) it is possible that several handle orientations are defined as valid handle orientations which would cause confusing and contradicting situations.
To avoid any ambiguities, priorities can be assigned to handle orientations.
The priority increases with the increase of the numerical values which are used for the definition of priorities. Several handle orientations can be summarized under one priority. Handle orientations with the same priority value require settings in the same key fields.

Element paths:
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS 		D nonNegativeInteger
P
M [1:999]
Remarks

Source
<xs:element name="PRIORITY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--14--Prioritaet</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_HANDLE_POSITIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element : BASIC_HANDLE_POSITIONS Element
Description

This element is used to describe the position and alignment of handles installed on certain front types. The basic handle positions defined in this element are valid universally.

The basic handle positions should be guided by the pre-defined standard handle positions in the section named standard handle positions. Please note that 0 must not be used as a value for basic handle positions.

Namespace (none)
Diagram
HANDLE_ORIENTATION Element Sequence BASIC_HANDLE_POSITIONS Element
Overview
BASIC_HANDLE_POSITIONS

This element is used to describe the position and alignment of handles installed on certain front types. The basic handle positions defined in this element are valid universally.

The basic handle positions should be guided by the pre-defined standard handle positions in the section named standard handle positions. Please note that 0 must not be used as a value for basic handle positions.

Sequence
HANDLE_ORIENTATION 1..∞
This element is a container element for the definition of different basic handle positions.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute identifies a basic handle orientation. D positiveInteger
P
M [1:9999]
Sequence
FRONT_TYPE 1..7
This element defines the handle position and handle orientation for each front type. The front type itself is defined in the attribute FRONT_TYPE_CODE.
FRONT_TYPE_CODE required Restriction of xs:string
Different handle orientation are assigned to different front types. The different front types are listed below:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation) 		D string
P [SAKJTR]|GT
M [1:2]
Sequence
ORIENTATION Restriction of xs:string
This element is used for the differentiation of orientations.
H = horizontal
V = vertical 		D string
P [HV]
M [1:1]
POSITION Restriction of xs:string
This element is used for the differentiation of handle positions in accordance with the chosen front type.

M = middle (e.g. for grip ledges without hinge)
A = exterior (e.g. for grip ledge, dependent on the hinge)
D = double (two handles at the exterior sides)
G =without drilling, with handle (handle is delivered, drilling on site)
0 (zero) = without drilling, without handle (handle is not delivered, no drillings provided)

In case of position A = exterior, the definite position is indicated by the hinge information , i.e. left/ right, for the item. 		D string
P [MADG0]
M [1:1]
Remarks

Source
<xs:element name="BASIC_HANDLE_POSITIONS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>230--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="HANDLE_ORIENTATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>230--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_TYPE" maxOccurs="7">
              <xs:annotation>
                <xs:documentation>230--3--Fronttyp</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ORIENTATION">
                    <xs:annotation>
                      <xs:documentation>230--4--Lage</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[HV]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="POSITION">
                    <xs:annotation>
                      <xs:documentation>230--5--Position</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[MADG0]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FRONT_TYPE_CODE" use="required">
                  <xs:annotation>
                    <xs:documentation>230--3--Fronttyp</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[SAKJTR]|GT" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
            <xs:annotation>
              <xs:documentation>230--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_ORIENTATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > BASIC_HANDLE_POSITIONS Element : HANDLE_ORIENTATION Element
Description
This element is a container element for the definition of different basic handle positions.
Namespace (none)
Diagram
FRONT_TYPE Element Sequence HANDLE_ORIENTATION Element
Overview
HANDLE_ORIENTATION 1..∞
This element is a container element for the definition of different basic handle positions.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute identifies a basic handle orientation. D positiveInteger
P
M [1:9999]
Sequence
FRONT_TYPE 1..7
This element defines the handle position and handle orientation for each front type. The front type itself is defined in the attribute FRONT_TYPE_CODE.
FRONT_TYPE_CODE required Restriction of xs:string
Different handle orientation are assigned to different front types. The different front types are listed below:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation) 		D string
P [SAKJTR]|GT
M [1:2]
Sequence
ORIENTATION Restriction of xs:string
This element is used for the differentiation of orientations.
H = horizontal
V = vertical 		D string
P [HV]
M [1:1]
POSITION Restriction of xs:string
This element is used for the differentiation of handle positions in accordance with the chosen front type.

M = middle (e.g. for grip ledges without hinge)
A = exterior (e.g. for grip ledge, dependent on the hinge)
D = double (two handles at the exterior sides)
G =without drilling, with handle (handle is delivered, drilling on site)
0 (zero) = without drilling, without handle (handle is not delivered, no drillings provided)

In case of position A = exterior, the definite position is indicated by the hinge information , i.e. left/ right, for the item. 		D string
P [MADG0]
M [1:1]
Attributes
Name Type Use Default Fixed Description
HANDLE_ORIENTATION_NO Restriction of xs:positiveInteger required
This attribute identifies a basic handle orientation. D positiveInteger
P
M [1:9999]
Remarks

Source
<xs:element name="HANDLE_ORIENTATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>230--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_TYPE" maxOccurs="7">
        <xs:annotation>
          <xs:documentation>230--3--Fronttyp</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ORIENTATION">
              <xs:annotation>
                <xs:documentation>230--4--Lage</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[HV]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="POSITION">
              <xs:annotation>
                <xs:documentation>230--5--Position</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[MADG0]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FRONT_TYPE_CODE" use="required">
            <xs:annotation>
              <xs:documentation>230--3--Fronttyp</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[SAKJTR]|GT" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>230--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BASIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > BASIC_HANDLE_POSITIONS Element > HANDLE_ORIENTATION Element : FRONT_TYPE Element
Description
This element defines the handle position and handle orientation for each front type. The front type itself is defined in the attribute FRONT_TYPE_CODE.
Namespace (none)
Diagram
POSITION Element ORIENTATION Element Sequence FRONT_TYPE Element
Overview
FRONT_TYPE 1..7
This element defines the handle position and handle orientation for each front type. The front type itself is defined in the attribute FRONT_TYPE_CODE.
FRONT_TYPE_CODE required Restriction of xs:string
Different handle orientation are assigned to different front types. The different front types are listed below:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation) 		D string
P [SAKJTR]|GT
M [1:2]
Sequence
ORIENTATION Restriction of xs:string
This element is used for the differentiation of orientations.
H = horizontal
V = vertical 		D string
P [HV]
M [1:1]
POSITION Restriction of xs:string
This element is used for the differentiation of handle positions in accordance with the chosen front type.

M = middle (e.g. for grip ledges without hinge)
A = exterior (e.g. for grip ledge, dependent on the hinge)
D = double (two handles at the exterior sides)
G =without drilling, with handle (handle is delivered, drilling on site)
0 (zero) = without drilling, without handle (handle is not delivered, no drillings provided)

In case of position A = exterior, the definite position is indicated by the hinge information , i.e. left/ right, for the item. 		D string
P [MADG0]
M [1:1]
Attributes
Name Type Use Default Fixed Description
FRONT_TYPE_CODE Restriction of xs:string required
Different handle orientation are assigned to different front types. The different front types are listed below:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation) 		D string
P [SAKJTR]|GT
M [1:2]
Remarks

Source
<xs:element name="FRONT_TYPE" maxOccurs="7" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>230--3--Fronttyp</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ORIENTATION">
        <xs:annotation>
          <xs:documentation>230--4--Lage</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[HV]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="POSITION">
        <xs:annotation>
          <xs:documentation>230--5--Position</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[MADG0]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FRONT_TYPE_CODE" use="required">
      <xs:annotation>
        <xs:documentation>230--3--Fronttyp</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[SAKJTR]|GT" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
HANDLE_ORIENTATION Element | BASIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ORIENTATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > BASIC_HANDLE_POSITIONS Element > HANDLE_ORIENTATION Element > FRONT_TYPE Element : ORIENTATION Element
Description
This element is used for the differentiation of orientations.
H = horizontal
V = vertical 		D string
P [HV]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
ORIENTATION Element
Overview
ORIENTATION Restriction of xs:string
This element is used for the differentiation of orientations.
H = horizontal
V = vertical 		D string
P [HV]
M [1:1]
Remarks

Source
<xs:element name="ORIENTATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>230--4--Lage</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[HV]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_TYPE Element | HANDLE_ORIENTATION Element | BASIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

POSITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > BASIC_HANDLE_POSITIONS Element > HANDLE_ORIENTATION Element > FRONT_TYPE Element : POSITION Element
Description
This element is used for the differentiation of handle positions in accordance with the chosen front type.

M = middle (e.g. for grip ledges without hinge)
A = exterior (e.g. for grip ledge, dependent on the hinge)
D = double (two handles at the exterior sides)
G =without drilling, with handle (handle is delivered, drilling on site)
0 (zero) = without drilling, without handle (handle is not delivered, no drillings provided)

In case of position A = exterior, the definite position is indicated by the hinge information , i.e. left/ right, for the item. 		D string
P [MADG0]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
POSITION Element
Overview
POSITION Restriction of xs:string
This element is used for the differentiation of handle positions in accordance with the chosen front type.

M = middle (e.g. for grip ledges without hinge)
A = exterior (e.g. for grip ledge, dependent on the hinge)
D = double (two handles at the exterior sides)
G =without drilling, with handle (handle is delivered, drilling on site)
0 (zero) = without drilling, without handle (handle is not delivered, no drillings provided)

In case of position A = exterior, the definite position is indicated by the hinge information , i.e. left/ right, for the item. 		D string
P [MADG0]
M [1:1]
Remarks

Source
<xs:element name="POSITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>230--5--Position</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[MADG0]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_TYPE Element | HANDLE_ORIENTATION Element | BASIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPES_GROUPS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element : FRONT_TYPES_GROUPS Element
Description
For an efficient use of front types in the definition of specific handle orientations in the element SPECIFIC_HANDLE_ORIENTATION (Path1) different front types can be combined to one front type group.

element paths path1:
GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS
Namespace (none)
Diagram
FRONT_TYPES_GROUP Element Sequence FRONT_TYPES_GROUPS Element
Overview
FRONT_TYPES_GROUPS optional
For an efficient use of front types in the definition of specific handle orientations in the element SPECIFIC_HANDLE_ORIENTATION (Path1) different front types can be combined to one front type group.

element paths path1:
GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS
Sequence
FRONT_TYPES_GROUP 1..99
This element defines a front type group.
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a front type group. D nonNegativeInteger
P
M [1:99]
Sequence
FRONT_TYPE 1..7
This element defines the handle position and handle orientation for each front type. The front type itself is defined by the attribute FRONT_TYPE_CODE.
FRONT_TYPE_CODE required Restriction of xs:string
This element contains the different front types which are combined to a front type group. The following front types are defined:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation) 		D string
P [SAKJTR]|GT
M [1:2]

Remarks

Source
<xs:element name="FRONT_TYPES_GROUPS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>231--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_TYPES_GROUP" maxOccurs="99">
        <xs:annotation>
          <xs:documentation>231--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_TYPE" maxOccurs="7">
              <xs:annotation>
                <xs:documentation>231--3--Fronttyp</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FRONT_TYPE_CODE" use="required">
                  <xs:annotation>
                    <xs:documentation>231--3--Fronttyp</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[SAKJTR]|GT" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>231--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPES_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > FRONT_TYPES_GROUPS Element : FRONT_TYPES_GROUP Element
Description
This element defines a front type group.
Namespace (none)
Diagram
FRONT_TYPE Element Sequence FRONT_TYPES_GROUP Element
Overview
FRONT_TYPES_GROUP 1..99
This element defines a front type group.
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a front type group. D nonNegativeInteger
P
M [1:99]
Sequence
FRONT_TYPE 1..7
This element defines the handle position and handle orientation for each front type. The front type itself is defined by the attribute FRONT_TYPE_CODE.
FRONT_TYPE_CODE required Restriction of xs:string
This element contains the different front types which are combined to a front type group. The following front types are defined:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation) 		D string
P [SAKJTR]|GT
M [1:2]

Attributes
Name Type Use Default Fixed Description
FRONT_TYPE_GROUP_NO Restriction of xs:nonNegativeInteger required
This attribute identifies a front type group. D nonNegativeInteger
P
M [1:99]
Remarks

Source
<xs:element name="FRONT_TYPES_GROUP" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>231--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_TYPE" maxOccurs="7">
        <xs:annotation>
          <xs:documentation>231--3--Fronttyp</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FRONT_TYPE_CODE" use="required">
            <xs:annotation>
              <xs:documentation>231--3--Fronttyp</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[SAKJTR]|GT" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>231--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FRONT_TYPES_GROUPS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > FRONT_TYPES_GROUPS Element > FRONT_TYPES_GROUP Element : FRONT_TYPE Element
Description
This element defines the handle position and handle orientation for each front type. The front type itself is defined by the attribute FRONT_TYPE_CODE.
Namespace (none)
Diagram
FRONT_TYPE Element
Overview
FRONT_TYPE 1..7
This element defines the handle position and handle orientation for each front type. The front type itself is defined by the attribute FRONT_TYPE_CODE.
FRONT_TYPE_CODE required Restriction of xs:string
This element contains the different front types which are combined to a front type group. The following front types are defined:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation) 		D string
P [SAKJTR]|GT
M [1:2]

Attributes
Name Type Use Default Fixed Description
FRONT_TYPE_CODE Restriction of xs:string required
This element contains the different front types which are combined to a front type group. The following front types are defined:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation) 		D string
P [SAKJTR]|GT
M [1:2]

Remarks

Source
<xs:element name="FRONT_TYPE" maxOccurs="7" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>231--3--Fronttyp</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FRONT_TYPE_CODE" use="required">
      <xs:annotation>
        <xs:documentation>231--3--Fronttyp</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[SAKJTR]|GT" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FRONT_TYPES_GROUP Element | FRONT_TYPES_GROUPS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_APPEARANCES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : FRONT_APPEARANCES Element
Description
The different front appearances of a programme, an option, or an item are defined in this element. These front appearances are referenced by programmes (FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_APPEARANCE_REF), options (FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/FRONT_APPEARANCE_REF), or by items (SERIES/.../ITEM/FRONT_APPEARANCE_REF).
The basic definition of a front appearance consists of a basic shape number, assigned to a front element,and geometrical measurement information.
Namespace (none)
Diagram
FRONT_APPEARANCE Element Sequence FRONT_APPEARANCES Element
Overview
FRONT_APPEARANCES optional
The different front appearances of a programme, an option, or an item are defined in this element. These front appearances are referenced by programmes (FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_APPEARANCE_REF), options (FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/FRONT_APPEARANCE_REF), or by items (SERIES/.../ITEM/FRONT_APPEARANCE_REF).
The basic definition of a front appearance consists of a basic shape number, assigned to a front element,and geometrical measurement information.
Sequence
FRONT_APPEARANCE 1..999
This element is used for the definition of a front appearance.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID for a front appearance which is referenced by styles and items. D positiveInteger
P
M [1:999]
Sequence
FRONT_TYPE 1..900
The definition of front type 0 is used when all front elements have the same appearance irrespective of the used front type. In this case the definition of divergent front types is not permitted. If a front type has been defined for a front appearance_ID, data sets for all other front types are required.
Sequence
FRONT_TYPE_NO Restriction of xs:positiveInteger
This attribute defines the front type key. D positiveInteger
P
M [0:1000]
Sequence 1..∞
FRONT_CONSTRAINTS optional
For the elements WIDTH_FROM/TO and HEIGTH_FROM/TO the following rules apply:

- If the elements WIDTH_TO or HEIGHT_TO are not defined, this equals the value "infinite"
- If the elements WIDTH_FROM or HEIGHT_FROM are not defined, this equals the value 0.
- The value 0 is not permitted in the elements WIDTH_FROM/TO or HEIGTH_FROM/TO.
- The intervalls have to cover the complete range
from 0 to infinite. Gaps are not permitted either
Sequence
WIDTH_FROM optional Restriction of xs:positiveInteger
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
WIDTH_TO optional Restriction of xs:positiveInteger
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
HEIGHT_FROM optional Restriction of xs:positiveInteger
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
HEIGHT_TO optional Restriction of xs:positiveInteger
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
FRONT_SHAPE
This element is used for the geometrical description of a front element.
Sequence
GLASS Restriction of xs:boolean
Values in this field indicate whether the front type is a glass front (value 1/true) or a simple front (value 0/false). For one front type the values in this element may not vary. This rule makes sure that a glass front is always depicted as glass front even when the programme has been changed. D boolean
P
M
Choice
MODELING_GRAPHIC_ID optional Restriction of xs:string
This element may be used for the definition of a modeling graphic.

Further format definitions are required. 		D string
P
M [1:15]
BASIC_FRONT_SHAPE optional
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".
Sequence
BASIC_FRONT_SHAPE_ID Restriction of xs:string
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".

Value 999 is not permitted any longer. 		D string
P
M [1:3]
PARAMETERS 1..∞
This element is used for assigning values to the different front parameters.
VALUE optional Restriction of xs:string
This attribute is used to assign a measurement to the parameter for the basic front shape. D decimal
P
M
PARAMETER optional Restriction of xs:string
This element contains the parameter which indicates the basic shape. A dimension value is filled in in the element VALUE. D string
P
M [1:5]
Remarks

Source
<xs:element name="FRONT_APPEARANCES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_APPEARANCE" maxOccurs="999">
        <xs:annotation>
          <xs:documentation>520--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_TYPE" maxOccurs="900">
              <xs:annotation>
                <xs:documentation>520--3--Fronttyp</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_TYPE_NO">
                    <xs:annotation>
                      <xs:documentation>520/570--3/3--Fronttyp</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="900" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:sequence maxOccurs="unbounded">
                    <xs:element name="FRONT_CONSTRAINTS" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="WIDTH_FROM" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>520/570--6--Breite_von</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="WIDTH_TO" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>520/570--7--Breite_von</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="HEIGHT_FROM" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="HEIGHT_TO" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="FRONT_SHAPE">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="GLASS">
                            <xs:annotation>
                              <xs:documentation>520--10--Glas</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:boolean" />
                            </xs:simpleType>
                          </xs:element>
                          <xs:choice>
                            <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="BASIC_FRONT_SHAPE" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="BASIC_FRONT_SHAPE_ID">
                                    <xs:annotation>
                                      <xs:documentation>520--4--Front_Grundform</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="3" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PARAMETERS" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="VALUE">
                                        <xs:annotation>
                                          <xs:documentation>520--5--Wert</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:maxLength value="12" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="PARAMETER">
                                        <xs:annotation>
                                          <xs:documentation>570--4--Parameter</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:minLength value="1" />
                                            <xs:maxLength value="5" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:choice>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>520--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_APPEARANCE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element : FRONT_APPEARANCE Element
Description
This element is used for the definition of a front appearance.
Namespace (none)
Diagram
FRONT_TYPE Element Sequence FRONT_APPEARANCE Element
Overview
FRONT_APPEARANCE 1..999
This element is used for the definition of a front appearance.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID for a front appearance which is referenced by styles and items. D positiveInteger
P
M [1:999]
Sequence
FRONT_TYPE 1..900
The definition of front type 0 is used when all front elements have the same appearance irrespective of the used front type. In this case the definition of divergent front types is not permitted. If a front type has been defined for a front appearance_ID, data sets for all other front types are required.
Sequence
FRONT_TYPE_NO Restriction of xs:positiveInteger
This attribute defines the front type key. D positiveInteger
P
M [0:1000]
Sequence 1..∞
FRONT_CONSTRAINTS optional
For the elements WIDTH_FROM/TO and HEIGTH_FROM/TO the following rules apply:

- If the elements WIDTH_TO or HEIGHT_TO are not defined, this equals the value "infinite"
- If the elements WIDTH_FROM or HEIGHT_FROM are not defined, this equals the value 0.
- The value 0 is not permitted in the elements WIDTH_FROM/TO or HEIGTH_FROM/TO.
- The intervalls have to cover the complete range
from 0 to infinite. Gaps are not permitted either
Sequence
WIDTH_FROM optional Restriction of xs:positiveInteger
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
WIDTH_TO optional Restriction of xs:positiveInteger
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
HEIGHT_FROM optional Restriction of xs:positiveInteger
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
HEIGHT_TO optional Restriction of xs:positiveInteger
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
FRONT_SHAPE
This element is used for the geometrical description of a front element.
Sequence
GLASS Restriction of xs:boolean
Values in this field indicate whether the front type is a glass front (value 1/true) or a simple front (value 0/false). For one front type the values in this element may not vary. This rule makes sure that a glass front is always depicted as glass front even when the programme has been changed. D boolean
P
M
Choice
MODELING_GRAPHIC_ID optional Restriction of xs:string
This element may be used for the definition of a modeling graphic.

Further format definitions are required. 		D string
P
M [1:15]
BASIC_FRONT_SHAPE optional
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".
Sequence
BASIC_FRONT_SHAPE_ID Restriction of xs:string
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".

Value 999 is not permitted any longer. 		D string
P
M [1:3]
PARAMETERS 1..∞
This element is used for assigning values to the different front parameters.
VALUE optional Restriction of xs:string
This attribute is used to assign a measurement to the parameter for the basic front shape. D decimal
P
M
PARAMETER optional Restriction of xs:string
This element contains the parameter which indicates the basic shape. A dimension value is filled in in the element VALUE. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FRONT_APPEARANCE_NO Restriction of xs:positiveInteger required
This attribute defines a specific ID for a front appearance which is referenced by styles and items. D positiveInteger
P
M [1:999]
Remarks

Source
<xs:element name="FRONT_APPEARANCE" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_TYPE" maxOccurs="900">
        <xs:annotation>
          <xs:documentation>520--3--Fronttyp</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_TYPE_NO">
              <xs:annotation>
                <xs:documentation>520/570--3/3--Fronttyp</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="900" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:sequence maxOccurs="unbounded">
              <xs:element name="FRONT_CONSTRAINTS" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="WIDTH_FROM" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>520/570--6--Breite_von</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="WIDTH_TO" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>520/570--7--Breite_von</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="HEIGHT_FROM" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="HEIGHT_TO" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
              <xs:element name="FRONT_SHAPE">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="GLASS">
                      <xs:annotation>
                        <xs:documentation>520--10--Glas</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:boolean" />
                      </xs:simpleType>
                    </xs:element>
                    <xs:choice>
                      <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="BASIC_FRONT_SHAPE" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="BASIC_FRONT_SHAPE_ID">
                              <xs:annotation>
                                <xs:documentation>520--4--Front_Grundform</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="3" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PARAMETERS" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="VALUE">
                                  <xs:annotation>
                                    <xs:documentation>520--5--Wert</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:maxLength value="12" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="PARAMETER">
                                  <xs:annotation>
                                    <xs:documentation>570--4--Parameter</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:minLength value="1" />
                                      <xs:maxLength value="5" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:choice>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>520--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element : FRONT_TYPE Element
Description
The definition of front type 0 is used when all front elements have the same appearance irrespective of the used front type. In this case the definition of divergent front types is not permitted. If a front type has been defined for a front appearance_ID, data sets for all other front types are required.
Namespace (none)
Diagram
FRONT_SHAPE Element FRONT_CONSTRAINTS Element Sequence FRONT_TYPE_NO Element Sequence FRONT_TYPE Element
Overview
FRONT_TYPE 1..900
The definition of front type 0 is used when all front elements have the same appearance irrespective of the used front type. In this case the definition of divergent front types is not permitted. If a front type has been defined for a front appearance_ID, data sets for all other front types are required.
Sequence
FRONT_TYPE_NO Restriction of xs:positiveInteger
This attribute defines the front type key. D positiveInteger
P
M [0:1000]
Sequence 1..∞
FRONT_CONSTRAINTS optional
For the elements WIDTH_FROM/TO and HEIGTH_FROM/TO the following rules apply:

- If the elements WIDTH_TO or HEIGHT_TO are not defined, this equals the value "infinite"
- If the elements WIDTH_FROM or HEIGHT_FROM are not defined, this equals the value 0.
- The value 0 is not permitted in the elements WIDTH_FROM/TO or HEIGTH_FROM/TO.
- The intervalls have to cover the complete range
from 0 to infinite. Gaps are not permitted either
Sequence
WIDTH_FROM optional Restriction of xs:positiveInteger
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
WIDTH_TO optional Restriction of xs:positiveInteger
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
HEIGHT_FROM optional Restriction of xs:positiveInteger
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
HEIGHT_TO optional Restriction of xs:positiveInteger
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
FRONT_SHAPE
This element is used for the geometrical description of a front element.
Sequence
GLASS Restriction of xs:boolean
Values in this field indicate whether the front type is a glass front (value 1/true) or a simple front (value 0/false). For one front type the values in this element may not vary. This rule makes sure that a glass front is always depicted as glass front even when the programme has been changed. D boolean
P
M
Choice
MODELING_GRAPHIC_ID optional Restriction of xs:string
This element may be used for the definition of a modeling graphic.

Further format definitions are required. 		D string
P
M [1:15]
BASIC_FRONT_SHAPE optional
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".
Sequence
BASIC_FRONT_SHAPE_ID Restriction of xs:string
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".

Value 999 is not permitted any longer. 		D string
P
M [1:3]
PARAMETERS 1..∞
This element is used for assigning values to the different front parameters.
VALUE optional Restriction of xs:string
This attribute is used to assign a measurement to the parameter for the basic front shape. D decimal
P
M
PARAMETER optional Restriction of xs:string
This element contains the parameter which indicates the basic shape. A dimension value is filled in in the element VALUE. D string
P
M [1:5]
Remarks

Source
<xs:element name="FRONT_TYPE" maxOccurs="900" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520--3--Fronttyp</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_TYPE_NO">
        <xs:annotation>
          <xs:documentation>520/570--3/3--Fronttyp</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="900" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:sequence maxOccurs="unbounded">
        <xs:element name="FRONT_CONSTRAINTS" minOccurs="0">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="WIDTH_FROM" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>520/570--6--Breite_von</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="WIDTH_TO" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>520/570--7--Breite_von</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="HEIGHT_FROM" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="HEIGHT_TO" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
        <xs:element name="FRONT_SHAPE">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="GLASS">
                <xs:annotation>
                  <xs:documentation>520--10--Glas</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:boolean" />
                </xs:simpleType>
              </xs:element>
              <xs:choice>
                <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="BASIC_FRONT_SHAPE" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="BASIC_FRONT_SHAPE_ID">
                        <xs:annotation>
                          <xs:documentation>520--4--Front_Grundform</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="3" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="PARAMETERS" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="VALUE">
                            <xs:annotation>
                              <xs:documentation>520--5--Wert</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:maxLength value="12" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                          <xs:attribute name="PARAMETER">
                            <xs:annotation>
                              <xs:documentation>570--4--Parameter</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:minLength value="1" />
                                <xs:maxLength value="5" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
              </xs:choice>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPE_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element : FRONT_TYPE_NO Element
Description
This attribute defines the front type key. D positiveInteger
P
M [0:1000]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
FRONT_TYPE_NO Element
Overview
FRONT_TYPE_NO Restriction of xs:positiveInteger
This attribute defines the front type key. D positiveInteger
P
M [0:1000]
Remarks

Source
<xs:element name="FRONT_TYPE_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520/570--3/3--Fronttyp</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="900" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_CONSTRAINTS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element : FRONT_CONSTRAINTS Element
Description
For the elements WIDTH_FROM/TO and HEIGTH_FROM/TO the following rules apply:

- If the elements WIDTH_TO or HEIGHT_TO are not defined, this equals the value "infinite"
- If the elements WIDTH_FROM or HEIGHT_FROM are not defined, this equals the value 0.
- The value 0 is not permitted in the elements WIDTH_FROM/TO or HEIGTH_FROM/TO.
- The intervalls have to cover the complete range
from 0 to infinite. Gaps are not permitted either
Namespace (none)
Diagram
HEIGHT_TO Element HEIGHT_FROM Element WIDTH_TO Element WIDTH_FROM Element Sequence FRONT_CONSTRAINTS Element
Overview
FRONT_CONSTRAINTS optional
For the elements WIDTH_FROM/TO and HEIGTH_FROM/TO the following rules apply:

- If the elements WIDTH_TO or HEIGHT_TO are not defined, this equals the value "infinite"
- If the elements WIDTH_FROM or HEIGHT_FROM are not defined, this equals the value 0.
- The value 0 is not permitted in the elements WIDTH_FROM/TO or HEIGTH_FROM/TO.
- The intervalls have to cover the complete range
from 0 to infinite. Gaps are not permitted either
Sequence
WIDTH_FROM optional Restriction of xs:positiveInteger
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
WIDTH_TO optional Restriction of xs:positiveInteger
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
HEIGHT_FROM optional Restriction of xs:positiveInteger
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
HEIGHT_TO optional Restriction of xs:positiveInteger
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
Remarks

Source
<xs:element name="FRONT_CONSTRAINTS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="WIDTH_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>520/570--6--Breite_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="WIDTH_TO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>520/570--7--Breite_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT_TO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WIDTH_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_CONSTRAINTS Element : WIDTH_FROM Element
Description
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
WIDTH_FROM Element
Overview
WIDTH_FROM optional Restriction of xs:positiveInteger
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
Remarks

Source
<xs:element name="WIDTH_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520/570--6--Breite_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CONSTRAINTS Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WIDTH_TO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_CONSTRAINTS Element : WIDTH_TO Element
Description
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
WIDTH_TO Element
Overview
WIDTH_TO optional Restriction of xs:positiveInteger
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm). D positiveInteger
P
M [1:999999]
Remarks

Source
<xs:element name="WIDTH_TO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520/570--7--Breite_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CONSTRAINTS Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEIGHT_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_CONSTRAINTS Element : HEIGHT_FROM Element
Description
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
HEIGHT_FROM Element
Overview
HEIGHT_FROM optional Restriction of xs:positiveInteger
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
Remarks

Source
<xs:element name="HEIGHT_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CONSTRAINTS Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEIGHT_TO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_CONSTRAINTS Element : HEIGHT_TO Element
Description
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
HEIGHT_TO Element
Overview
HEIGHT_TO optional Restriction of xs:positiveInteger
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm). D positiveInteger
P
M [1:999999]
Remarks

Source
<xs:element name="HEIGHT_TO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CONSTRAINTS Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_SHAPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element : FRONT_SHAPE Element
Description
This element is used for the geometrical description of a front element.
Namespace (none)
Diagram
BASIC_FRONT_SHAPE Element MODELING_GRAPHIC_ID Element Choice GLASS Element Sequence FRONT_SHAPE Element
Overview
FRONT_SHAPE
This element is used for the geometrical description of a front element.
Sequence
GLASS Restriction of xs:boolean
Values in this field indicate whether the front type is a glass front (value 1/true) or a simple front (value 0/false). For one front type the values in this element may not vary. This rule makes sure that a glass front is always depicted as glass front even when the programme has been changed. D boolean
P
M
Choice
MODELING_GRAPHIC_ID optional Restriction of xs:string
This element may be used for the definition of a modeling graphic.

Further format definitions are required. 		D string
P
M [1:15]
BASIC_FRONT_SHAPE optional
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".
Sequence
BASIC_FRONT_SHAPE_ID Restriction of xs:string
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".

Value 999 is not permitted any longer. 		D string
P
M [1:3]
PARAMETERS 1..∞
This element is used for assigning values to the different front parameters.
VALUE optional Restriction of xs:string
This attribute is used to assign a measurement to the parameter for the basic front shape. D decimal
P
M
PARAMETER optional Restriction of xs:string
This element contains the parameter which indicates the basic shape. A dimension value is filled in in the element VALUE. D string
P
M [1:5]
Remarks

Source
<xs:element name="FRONT_SHAPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="GLASS">
        <xs:annotation>
          <xs:documentation>520--10--Glas</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:choice>
        <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
          <xs:annotation>
            <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:string">
              <xs:minLength value="1" />
              <xs:maxLength value="15" />
            </xs:restriction>
          </xs:simpleType>
        </xs:element>
        <xs:element name="BASIC_FRONT_SHAPE" minOccurs="0">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="BASIC_FRONT_SHAPE_ID">
                <xs:annotation>
                  <xs:documentation>520--4--Front_Grundform</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:minLength value="1" />
                    <xs:maxLength value="3" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="PARAMETERS" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="VALUE">
                    <xs:annotation>
                      <xs:documentation>520--5--Wert</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:maxLength value="12" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                  <xs:attribute name="PARAMETER">
                    <xs:annotation>
                      <xs:documentation>570--4--Parameter</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
      </xs:choice>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GLASS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_SHAPE Element : GLASS Element
Description
Values in this field indicate whether the front type is a glass front (value 1/true) or a simple front (value 0/false). For one front type the values in this element may not vary. This rule makes sure that a glass front is always depicted as glass front even when the programme has been changed. D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
GLASS Element
Overview
GLASS Restriction of xs:boolean
Values in this field indicate whether the front type is a glass front (value 1/true) or a simple front (value 0/false). For one front type the values in this element may not vary. This rule makes sure that a glass front is always depicted as glass front even when the programme has been changed. D boolean
P
M
Remarks

Source
<xs:element name="GLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520--10--Glas</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
FRONT_SHAPE Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODELING_GRAPHIC_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_SHAPE Element : MODELING_GRAPHIC_ID Element
Description
This element may be used for the definition of a modeling graphic.

Further format definitions are required. 		D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
MODELING_GRAPHIC_ID Element
Overview
MODELING_GRAPHIC_ID optional Restriction of xs:string
This element may be used for the definition of a modeling graphic.

Further format definitions are required. 		D string
P
M [1:15]
Remarks

Source
<xs:element name="MODELING_GRAPHIC_ID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_SHAPE Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_FRONT_SHAPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_SHAPE Element : BASIC_FRONT_SHAPE Element
Description
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".
Namespace (none)
Diagram
PARAMETERS Element BASIC_FRONT_SHAPE_ID Element Sequence BASIC_FRONT_SHAPE Element
Overview
BASIC_FRONT_SHAPE optional
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".
Sequence
BASIC_FRONT_SHAPE_ID Restriction of xs:string
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".

Value 999 is not permitted any longer. 		D string
P
M [1:3]
PARAMETERS 1..∞
This element is used for assigning values to the different front parameters.
VALUE optional Restriction of xs:string
This attribute is used to assign a measurement to the parameter for the basic front shape. D decimal
P
M
PARAMETER optional Restriction of xs:string
This element contains the parameter which indicates the basic shape. A dimension value is filled in in the element VALUE. D string
P
M [1:5]
Remarks

Source
<xs:element name="BASIC_FRONT_SHAPE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BASIC_FRONT_SHAPE_ID">
        <xs:annotation>
          <xs:documentation>520--4--Front_Grundform</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PARAMETERS" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="VALUE">
            <xs:annotation>
              <xs:documentation>520--5--Wert</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:maxLength value="12" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="PARAMETER">
            <xs:annotation>
              <xs:documentation>570--4--Parameter</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FRONT_SHAPE Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_FRONT_SHAPE_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_SHAPE Element > BASIC_FRONT_SHAPE Element : BASIC_FRONT_SHAPE_ID Element
Description
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".

Value 999 is not permitted any longer. 		D string
P
M [1:3]
Namespace (none)
Type
Restriction of xs:string
Diagram
BASIC_FRONT_SHAPE_ID Element
Overview
BASIC_FRONT_SHAPE_ID Restriction of xs:string
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".

Value 999 is not permitted any longer. 		D string
P
M [1:3]
Remarks

Source
<xs:element name="BASIC_FRONT_SHAPE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520--4--Front_Grundform</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BASIC_FRONT_SHAPE Element | FRONT_SHAPE Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PARAMETERS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_SHAPE Element > BASIC_FRONT_SHAPE Element : PARAMETERS Element
Description
This element is used for assigning values to the different front parameters.
Namespace (none)
Diagram
PARAMETERS Element
Overview
PARAMETERS 1..∞
This element is used for assigning values to the different front parameters.
VALUE optional Restriction of xs:string
This attribute is used to assign a measurement to the parameter for the basic front shape. D decimal
P
M
PARAMETER optional Restriction of xs:string
This element contains the parameter which indicates the basic shape. A dimension value is filled in in the element VALUE. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
VALUE Restriction of xs:string optional
This attribute is used to assign a measurement to the parameter for the basic front shape. D decimal
P
M
PARAMETER Restriction of xs:string optional
This element contains the parameter which indicates the basic shape. A dimension value is filled in in the element VALUE. D string
P
M [1:5]
Remarks

Source
<xs:element name="PARAMETERS" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="VALUE">
      <xs:annotation>
        <xs:documentation>520--5--Wert</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="12" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="PARAMETER">
      <xs:annotation>
        <xs:documentation>570--4--Parameter</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BASIC_FRONT_SHAPE Element | FRONT_SHAPE Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SET_DEFINITIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : MODULE_RULE_SET_DEFINITIONS Element
Description
This element is used for the definition of the rules which apply to module cabinets and their components.
Namespace (none)
Diagram
MODULE_RULE_SET_DEFINITION Element Sequence MODULE_RULE_SET_DEFINITIONS Element
Overview
MODULE_RULE_SET_DEFINITIONS optional
This element is used for the definition of the rules which apply to module cabinets and their components.
Sequence
MODULE_RULE_SET_DEFINITION 1..∞
This element is used for the definition of specifig rules for module cabinets and the single module parts. The defined module rules are referenced by items (SERIES/.../ITEM/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) or (SERIES/.../ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the number of the rule set which references an item to the corresponding rule set. D nonNegativeInteger
P
M
Sequence
MODULE_RULE_SET_NAME languagetexte60 Complex Type
This element defines the name of the module rule set.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="MODULE_RULE_SET_DEFINITIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_RULE_SET_DEFINITION" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MODULE_RULE_SET_NAME" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Um Mehrsprachenfaehigkeit erweitert AK 28.02.2012</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SET_DEFINITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > MODULE_RULE_SET_DEFINITIONS Element : MODULE_RULE_SET_DEFINITION Element
Description
This element is used for the definition of specifig rules for module cabinets and the single module parts. The defined module rules are referenced by items (SERIES/.../ITEM/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) or (SERIES/.../ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO.
Namespace (none)
Diagram
LANGUAGE Element Sequence MODULE_RULE_SET_NAME Element Sequence MODULE_RULE_SET_DEFINITION Element
Overview
MODULE_RULE_SET_DEFINITION 1..∞
This element is used for the definition of specifig rules for module cabinets and the single module parts. The defined module rules are referenced by items (SERIES/.../ITEM/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) or (SERIES/.../ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the number of the rule set which references an item to the corresponding rule set. D nonNegativeInteger
P
M
Sequence
MODULE_RULE_SET_NAME languagetexte60 Complex Type
This element defines the name of the module rule set.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
MODULE_RULE_SET_NO xs:nonNegativeInteger required
This attribute defines the number of the rule set which references an item to the corresponding rule set. D nonNegativeInteger
P
M
Remarks

Source
<xs:element name="MODULE_RULE_SET_DEFINITION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_RULE_SET_NAME" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Um Mehrsprachenfaehigkeit erweitert AK 28.02.2012</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
MODULE_RULE_SET_DEFINITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SET_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > MODULE_RULE_SET_DEFINITIONS Element > MODULE_RULE_SET_DEFINITION Element : MODULE_RULE_SET_NAME Element
Description
This element defines the name of the module rule set.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence MODULE_RULE_SET_NAME Element
Overview
MODULE_RULE_SET_NAME languagetexte60 Complex Type
This element defines the name of the module rule set.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="MODULE_RULE_SET_NAME" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Um Mehrsprachenfaehigkeit erweitert AK 28.02.2012</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
MODULE_RULE_SET_DEFINITION Element | MODULE_RULE_SET_DEFINITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : DETAIL_INFOS Element
Description
This element is used for saving hyperlinks with detail information.
Namespace (none)
Diagram
DETAIL_INFO Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
This element is used for saving hyperlinks with detail information.
Sequence
DETAIL_INFO 1..∞

This element is used to define a detail information.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute identifies detail information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
This element is used for the classification of detail information.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
This element describes the type of detail information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
Name of the link (e.g. "magic corner in motion").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
Element for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
This element assigns a globally unambiguous, and unique figure (Globally Unique Identifier (GUID))

The format of the GUID is defined as follows XXX-XXXX-XXXX-XXXX- XX. Each 'X' represents a character of the hexadecimal system, i.e. figures 0-9 or characters A-F. Example:
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-characters). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
Text information for a tool tip with reference to the link.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
URL
This element contains the URL for the detail information.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file . 		D positiveInteger
P
M [1:4]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
13.06.2018/K.Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLASSIFICATION">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INFO_TYPE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
                <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
                <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[01]|99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="INTERNAL_NAME" type="languagetexte40">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="GUID">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="URL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:anyURI">
                              <xs:minLength value="1" />
                              <xs:maxLength value="1024" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HASH_VALUE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="64" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESOLUTION" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="4" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element : DETAIL_INFO Element
Description

This element is used to define a detail information.

Namespace (none)
Diagram
RESOLUTION Element URL Element LANGUAGE Element Sequence TOOL_TIP Element GUID Element LANGUAGE Element Sequence INTERNAL_NAME Element LANGUAGE Element Sequence EXTERNAL_NAME Element INFO_TYPE Element CLASSIFICATION Element Sequence DETAIL_INFO Element
Overview
DETAIL_INFO 1..∞

This element is used to define a detail information.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute identifies detail information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
This element is used for the classification of detail information.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
This element describes the type of detail information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
Name of the link (e.g. "magic corner in motion").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
Element for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
This element assigns a globally unambiguous, and unique figure (Globally Unique Identifier (GUID))

The format of the GUID is defined as follows XXX-XXXX-XXXX-XXXX- XX. Each 'X' represents a character of the hexadecimal system, i.e. figures 0-9 or characters A-F. Example:
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-characters). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
Text information for a tool tip with reference to the link.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
URL
This element contains the URL for the detail information.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file . 		D positiveInteger
P
M [1:4]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute identifies detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLASSIFICATION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INFO_TYPE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
          <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
          <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[01]|99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="INTERNAL_NAME" type="languagetexte40">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="GUID">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="URL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:anyURI">
                        <xs:minLength value="1" />
                        <xs:maxLength value="1024" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HASH_VALUE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="64" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESOLUTION" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="4" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLASSIFICATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : CLASSIFICATION Element
Description
This element is used for the classification of detail information.
 D string
P
M [1:8]
Namespace (none)
Type
Restriction of xs:string
Diagram
CLASSIFICATION Element
Overview
CLASSIFICATION Restriction of xs:string
This element is used for the classification of detail information.
 D string
P
M [1:8]
Source
<xs:element name="CLASSIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

INFO_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INFO_TYPE Element
Description
This element describes the type of detail information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
INFO_TYPE Element
Overview
INFO_TYPE Restriction of xs:positiveInteger
This element describes the type of detail information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
Source
<xs:element name="INFO_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
    <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
    <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[01]|99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXTERNAL_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : EXTERNAL_NAME Element
Description
Name of the link (e.g. "magic corner in motion").
Namespace (none)
Type
languagetexte Complex Type
Diagram
LANGUAGE Element Sequence EXTERNAL_NAME Element
Overview
EXTERNAL_NAME optional languagetexte Complex Type
Name of the link (e.g. "magic corner in motion").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > languagetexte Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:string">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

INTERNAL_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INTERNAL_NAME Element
Description
Element for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.
Namespace (none)
Type
languagetexte40 Complex Type
Diagram
LANGUAGE Element Sequence INTERNAL_NAME Element
Overview
INTERNAL_NAME languagetexte40 Complex Type
Element for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Source
<xs:element name="INTERNAL_NAME" type="languagetexte40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > languagetexte40 Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,40}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte40 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GUID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : GUID Element
Description
This element assigns a globally unambiguous, and unique figure (Globally Unique Identifier (GUID))

The format of the GUID is defined as follows XXX-XXXX-XXXX-XXXX- XX. Each 'X' represents a character of the hexadecimal system, i.e. figures 0-9 or characters A-F. Example:
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-characters). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
Namespace (none)
Type
Restriction of xs:string
Diagram
GUID Element
Overview
GUID Restriction of xs:string
This element assigns a globally unambiguous, and unique figure (Globally Unique Identifier (GUID))

The format of the GUID is defined as follows XXX-XXXX-XXXX-XXXX- XX. Each 'X' represents a character of the hexadecimal system, i.e. figures 0-9 or characters A-F. Example:
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-characters). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
Source
<xs:element name="GUID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TOOL_TIP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : TOOL_TIP Element
Description
Text information for a tool tip with reference to the link.
Namespace (none)
Type
languagetexte Complex Type
Diagram
LANGUAGE Element Sequence TOOL_TIP Element
Overview
TOOL_TIP optional languagetexte Complex Type
Text information for a tool tip with reference to the link.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

URL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : URL Element
Description
This element contains the URL for the detail information.
Namespace (none)
Diagram
LANGUAGE Element Sequence URL Element
Overview
URL
This element contains the URL for the detail information.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
Source
<xs:element name="URL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:anyURI">
                  <xs:minLength value="1" />
                  <xs:maxLength value="1024" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HASH_VALUE" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="64" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element : LANGUAGE Element
Description
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
Namespace (none)
Diagram
HASH_VALUE Element TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:anyURI">
            <xs:minLength value="1" />
            <xs:maxLength value="1024" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HASH_VALUE" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="64" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : TEXT Element
Description
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
Namespace (none)
Type
Restriction of xs:anyURI
Diagram
TEXT Element
Overview
TEXT Restriction of xs:anyURI
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:anyURI">
      <xs:minLength value="1" />
      <xs:maxLength value="1024" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HASH_VALUE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : HASH_VALUE Element
Description
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
Namespace (none)
Type
Restriction of xs:string
Diagram
HASH_VALUE Element
Overview
HASH_VALUE optional Restriction of xs:string
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
Source
<xs:element name="HASH_VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="64" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESOLUTION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : RESOLUTION Element
Description
This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file . 		D positiveInteger
P
M [1:4]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
RESOLUTION Element
Overview
RESOLUTION optional Restriction of xs:positiveInteger
This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file . 		D positiveInteger
P
M [1:4]
Source
<xs:element name="RESOLUTION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="4" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROPERTIES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : PROPERTIES Element
Description

This element is used to include additional information and characteristics, e.g. energy label, efficiency classes and similar data. Only the characteristics needed for correctly mapping the catalogue are defined.

The keys can be found in the corresponding table (information keys).

Namespace (none)
Diagram
PROPERTY Element Sequence PROPERTIES Element
Overview
PROPERTIES optional

This element is used to include additional information and characteristics, e.g. energy label, efficiency classes and similar data. Only the characteristics needed for correctly mapping the catalogue are defined.

The keys can be found in the corresponding table (information keys).

Sequence
PROPERTY 1..∞

This element is used to define a feature.

The key, text and measurement unit can be found in the correspondingtable (information keys)(information keys).

PROPERTY_NO required Restriction of xs:nonNegativeInteger

This attribute is used to identify the feature.

Its number can be found in the table with the information keys.

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetexte Complex Type

This element contains text information about the characteristics.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
PROPERTY_UNIT optional languagetexte30 Complex Type
If applicable, this element contains the measurement unit of the characteristic.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="PROPERTIES" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Version 2.3 </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROPERTY" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>Version 2.3</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PROPERTY_TEXT" type="languagetexte" minOccurs="1" maxOccurs="1" />
            <xs:element name="PROPERTY_UNIT" type="languagetexte30" minOccurs="0" maxOccurs="1" />
          </xs:sequence>
          <xs:attribute name="PROPERTY_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROPERTY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > PROPERTIES Element : PROPERTY Element
Description

This element is used to define a feature.

The key, text and measurement unit can be found in the correspondingtable (information keys)(information keys).

Namespace (none)
Diagram
LANGUAGE Element Sequence PROPERTY_UNIT Element LANGUAGE Element Sequence PROPERTY_TEXT Element Sequence PROPERTY Element
Overview
PROPERTY 1..∞

This element is used to define a feature.

The key, text and measurement unit can be found in the correspondingtable (information keys)(information keys).

PROPERTY_NO required Restriction of xs:nonNegativeInteger

This attribute is used to identify the feature.

Its number can be found in the table with the information keys.

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetexte Complex Type

This element contains text information about the characteristics.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
PROPERTY_UNIT optional languagetexte30 Complex Type
If applicable, this element contains the measurement unit of the characteristic.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Attributes
Name Type Use Default Fixed Description
PROPERTY_NO Restriction of xs:nonNegativeInteger required

This attribute is used to identify the feature.

Its number can be found in the table with the information keys.

 D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="PROPERTY" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Version 2.3</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROPERTY_TEXT" type="languagetexte" minOccurs="1" maxOccurs="1" />
      <xs:element name="PROPERTY_UNIT" type="languagetexte30" minOccurs="0" maxOccurs="1" />
    </xs:sequence>
    <xs:attribute name="PROPERTY_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PROPERTIES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROPERTY_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > PROPERTIES Element > PROPERTY Element : PROPERTY_TEXT Element
Description

This element contains text information about the characteristics.

Namespace (none)
Type
languagetexte Complex Type
Diagram
LANGUAGE Element Sequence PROPERTY_TEXT Element
Overview
PROPERTY_TEXT languagetexte Complex Type

This element contains text information about the characteristics.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="PROPERTY_TEXT" type="languagetexte" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PROPERTY Element | PROPERTIES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROPERTY_UNIT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > PROPERTIES Element > PROPERTY Element : PROPERTY_UNIT Element
Description
If applicable, this element contains the measurement unit of the characteristic.
Namespace (none)
Type
languagetexte30 Complex Type
Diagram
LANGUAGE Element Sequence PROPERTY_UNIT Element
Overview
PROPERTY_UNIT optional languagetexte30 Complex Type
If applicable, this element contains the measurement unit of the characteristic.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="PROPERTY_UNIT" type="languagetexte30" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
PROPERTY Element | PROPERTIES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GROUP_TITLES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : GROUP_TITLES Element
Description
This is a central point to store all kinds of descriptions for groups of optional and mandatory accessories.
Namespace (none)
Diagram
GROUP_TITLE Element Sequence GROUP_TITLES Element
Overview
GROUP_TITLES optional
This is a central point to store all kinds of descriptions for groups of optional and mandatory accessories.
Sequence
GROUP_TITLE 1..∞
This element is used to specify a group title.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify a unique number for later referencing of the group title. D nonNegativeInteger
P
M [0-999]
Sequence
GROUP_TITLE_NAME languagetexte60 Complex Type
This element contains the name for groups of accessories.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="GROUP_TITLES" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="GROUP_TITLE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>120--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="GROUP_TITLE_NAME" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="GROUP_TITLE_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GROUP_TITLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > GROUP_TITLES Element : GROUP_TITLE Element
Description
This element is used to specify a group title.
Namespace (none)
Diagram
LANGUAGE Element Sequence GROUP_TITLE_NAME Element Sequence GROUP_TITLE Element
Overview
GROUP_TITLE 1..∞
This element is used to specify a group title.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify a unique number for later referencing of the group title. D nonNegativeInteger
P
M [0-999]
Sequence
GROUP_TITLE_NAME languagetexte60 Complex Type
This element contains the name for groups of accessories.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
GROUP_TITLE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify a unique number for later referencing of the group title. D nonNegativeInteger
P
M [0-999]
Source
<xs:element name="GROUP_TITLE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="GROUP_TITLE_NAME" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="GROUP_TITLE_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
GROUP_TITLES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GROUP_TITLE_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > GROUP_TITLES Element > GROUP_TITLE Element : GROUP_TITLE_NAME Element
Description
This element contains the name for groups of accessories.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence GROUP_TITLE_NAME Element
Overview
GROUP_TITLE_NAME languagetexte60 Complex Type
This element contains the name for groups of accessories.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="GROUP_TITLE_NAME" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
GROUP_TITLE Element | GROUP_TITLES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : SERIES Element
Description
This element is used for defining all series of a catalogue/ database including properties and assigned elements, e.g. product groups or items.
Namespace (none)
Diagram
RESTRICTIONS Element SERIE Element Sequence SERIES Element
Overview
SERIES
This element is used for defining all series of a catalogue/ database including properties and assigned elements, e.g. product groups or items.
Sequence
SERIE 1..100
This element is used for the definition of the series.
Items belonging to series 0 are valid for all series. Therefore items of series 0 must not occur with the same type number (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in other series. Items of other series (unequal 0) may be used with the same type name in different series.
Buying prices are always indicated as the dealer’s buying prices
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the serial number of the series. D nonNegativeInteger
P
M [0:99]
Sequence
FEATURE_CLASS_REF optional
This element references the feature class which is assigned to the series.
It is used for assigning all legal variations of a series to this specific series.
The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all programmes and items of a series. Therefore it is not obligatory to state the features of a series in the order. However, in an order it is indispensable to state the sum of features for an item in combination with those of the series.
All features which are assigned to one series can be chosen from a list box while entering the variation header.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute references a feature class. A feature class is defined in the element FEATURE_CLASS (path1).

path1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D positiveInteger
P
M [1:999]
SERIES_NAME
This element defines the name of the series.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element defines a text line.
The element TEXT contains text information.
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
PURCHASE_RETAIL_ID Restriction of xs:boolean
This element is used for defining series specific purchase and retail prices
0 = purchase price
1 = retail price
Depending on the price_ID (element PRICE_ID (path1)) the price is defined as follows

price-ID = 1 (price),the value set in the element ITEM_PRICE (path2) is used

price_ID = 2 (ident number), the price is made up from the values set in element IDENT_NUMBER/PRICE (path3), element ITEM_PRICE/PRICE_MINIMUM_BASIC (path2) or in element ADDITIONAL_PRICE (path5).

price_ID = 3 (calculation point), the price made up from the settings in the elements ITEM_PRICE (path2) or PRICE_MINIMUM_BASIC multiplied with the calculation factor, defined in element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR.

According to the key, only one kind of price calculation (combination of elements VAT (path4) and PURCHASE_RETAIL_ID (path4)) may be used within one series.
If a database contains purchase prices as well as retail prices, items with purchase price may not be assigned to the same calculation group(PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP)as items with retail prices.
This element is of major significance for the correct price calculation! Purchase prices are always given as retailers' purchase prices not manufacturers' purchase prices.

element paths
path1: CATALOG/CATALOG_IDENTIFICATION/
path2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/
path3: PRICE_DEFINITION/IDENT_NUMBERS
path4: CATALOG/CATALOG_IDENTIFICATION
path5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP 		D boolean
P
M
RESTRICTIONS optional
This element references restrictions which are specific for one series (series specific restriction).

The number of features selected in a planning is only valid, if none of the feature combinations is excluded by any of the restrictions. The result of all restrictions represents an intersection of the feature combinations.
Sequence
RESTRICTION_REF 0..∞
This element references a restriction which is assigned to a series (series specific restrictions).

The number of features selected in a planning is only valid, if none of the feature combinations is excluded by any of the restrictions. The result of all restrictions represents an intersection of the feature combinations.
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...) 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references series specific restrictions. D nonNegativeInteger
P
M [0:99999]
SUGGESTIONS optional
This element references default settings that are applied to the series.

If the series additionally contains a standard proposal (DEFAULT_OPTION_GROUPS), the standard proposal will take priority when the planning is recorded initially.
Sequence
SUGGESTION_REF 0..∞
This element references default settings that are applied to the series.

If the series additionally contains a standard proposal (DEFAULT_OPTION_GROUPS), the standard proposal will take priority when the planning is recorded initially.
SEQUENCE required Restriction of xs:nonNegativeInteger

This element is used to specify the sequence in which the assigned default values are suggested when a planning is recorded for the first time.

The numbering (SEQUENCE) determines the priorities

 D nonNegativeInteger
P
M [1:99999]
SUGGESTION_NO required Restriction of xs:nonNegativeInteger
This attribute references a set of default values. D nonNegativeInteger
P
M [0:99999]
PRODUCT_GROUPS
This element is used for the definition of product groups. Product groups are used for grouping items which have the same variation types (e.g. shelves).
Sequence
PRODUCT_GROUP 1..∞
This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
This element is used for defining a name for a product group.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
This element is used for assigning a feature class to a product group. It references a feature class which is defined in the element FEATURE_DEFINITION/FEATURE_CLASSES.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute identifies the referenced feature class(FEATURE_CLASS). D positiveInteger
P
M [1:999]
ITEMS
This element defines all items belonging to one product group.
Sequence
ITEM 1..∞
This element is used for the definition of items and blocks. An item is identified by the attributes SERIE_NO (path 1) and TYPE_NO (path 1)..

The elements OLD_SERIA_NO (path 1) and OLD_TYPE_NO (path 1) may only be used if the geometrical information for the referred item is exactly the same as for the current item.

If an electrical appliance is defined as an item, it is necessary to indicate the dimensions (B, H, T) of this item in the element PARAMETERS (path 3).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Sequence
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

Information can be found at:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

The code, inter alia, expresses the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D string
P [0-9]{11}
M [11:11]

NET_WEIGHT optional Restriction of xs:nonNegativeInteger

This attribute is used to specify the net weight.

The code in the previous element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]

PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) with the value 0 in the element ADDITIONAL_PRICE.

Exactly one basic price feature group has to be assigned to an item. Further price groups can be assigned in the element ADDITIONAL_PRICE_GROUP.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 1/PRICE_TYPE.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPE
CALC_GROUP_REF
This element references calculation groups. Calculation groups are defined in the merchandise groups (PRICE_DEFINITION/MERCHANDISE_GROUP).
EXCHANGE_ID_REF optional
This element references an exchange-ID which is defined in the element path 1/EXCHANGE_ID.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_I
ADDITIONAL_PRICE_GROUP 0..∞
This element references PRICE_FEATURE_GROUPS with additional price groups. The basic price feature groups which is referenced excatly one time by an item is defined in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF .

All items which reference the same PRICE_FEATURE_GROUP have also to reference the same calculation group (CALC_GROUP_REF) and exchange-ID (EXCHANGE_ID_REF).

If different price types (item prices/ surcharge prices) are assigned to an item, the following combinations are permitted:

Item | Surcharge
Price per piece | Price per piece
Price depending on length | Price depending on length
Price depending on length | Price per piece

The following combinations are NOT permitted:

Item | Surcharge
Price per piece | Price depending on length
RESTRICTIONS optional
This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
ADDITIONAL_ITEMS optional
This element is used for assigning additional items. A number of optional and/or mandatory additional items is defined which the user may select from in the planning process.
HINGE Restriction of xs:string

This element provides information about the orientation of the door hinges. No geometrical information is filled in here. All geometrical information is provided in the element CONSTRUCTION_ID.

The following codes can be used to define the door closing:
J = request for door closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = no hinge or hinges on the exterior edges (double door);
R = hinge right ;
B = corresponding with construction ID i.e. construction-ID left : hinge left;
E = opposite to construction-ID, i.e. construction-ID left : hinge right;

In case of double doors, L and R apply to both doors.

For the item identifier B (block) the placement of the items in a block corresponds to the construction_ID => value "N" is required in the field HINGE.

Values B and E are only permitted if the value "J" is filled in in the element CONSTRUCTION_ID (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
EDP_NUMBER optional Restriction of xs:string
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
EAN_NUMBER optional Restriction of xs:string
If available the EAN-code of an item is defined in this element. D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article.
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal.

 D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

This element can be used to specify the item's catalogue page in the catalogue saved as a .pdf file. This information helps to quickly find an item within the stored catalogue.

The URL of the .pdf file is stored in the DETAIL_INFO element (on catalogue level). Because some items feature on multiple pages within the catalogue, it must be assured that the information for the .pdf file is identical to the 40-digit catalogue page CATALOG_PAGE, meaning they both refer to the same page.

 D positiveInteger
P
M [1:999]
VAT_ID_REF optional
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VALID_FROM optional Restriction of xs:date
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
WEIGHT optional Restriction of xs:nonNegativeInteger

This element is used to specify the item weight (100 g) including packaging material. (e.g. 50 = 5000 g).
The code in the element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.
Contiguous parts are calculated in the basis of the gross weight per price unit.

Example:
An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
This element defines the volume of an item including packaging material. The basic unit of the volume is [dm³], e.g. a volume of 50 dm³ is entered as 50. D nonNegativeInteger
P
M [0:9999]
CONSTRUCTION_ID Restriction of xs:string
This element defines the basic carcase shape of an item.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the construction_ID. 		D string
P [JLNRAE]
M [1:1]
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
In case the item is provided by a subcontractor, the corresponding supplier number is entered in this element.

If this subcontractor item is a visible part either the elements SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO or the elements FILE_NAME_TEXTURE_1/2 have to be defined.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D nonNegativeInteger
P
M [0:9999]
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
In case the item is provided by a subcontractor (SUBCONTRACTOR_ID filled in) the corresponding supplier number is entered in this element.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D string
P
M [1:15]
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D nonNegativeInteger
P
M [0:99]
OLD_TYPE_NO optional Restriction of xs:string
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D string
P
M [1:15]
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
These elements are used to enter the file names of bitmaps for accessory textures. The files are JPEG files. Because JPEGs do not allow for an alpha channel, the RGB colour code 0,0,255 is used for masking in this case.
The elements are used depending on the value in the „CONSTRUCTION_ID“ element. The FILE_NAME_TEXTURE_1 element contains the left side illustration of the accessories, the FILE_NAME_TEXTURE_2 the right side illustration of the accessories.
CONSTRUCTION_ID = N: The texture in the „filename_texture_1" is used.
CONSTRUCTION_ID = J: There are two different options:
1. The image is mirrored along the central axle. Depending on the item, this can be the Y-axis or the Z-axis (e.g. inset sinks, cooking elements = Y and refrigerators, microwave = Z): The image showing the left side is entered in the FILE_NAME_TEXTURE_1 element.
2. The item cannot be mirrored along the central axle. The image of the left side is entered in the FILE_NAME_TEXTURE_1, while the image of the right side is entered in the FILE_NAME_TEXTURE_2 element.
CONSTRUCTION_ID = L: The value is only entered in the FILE_NAME_TEXTURE_1 element
CONSTRUCTION_ID = R: The value is only entered in the FILE_NAME_TEXTURE_2 element
The values are specified in [cccccccc.jpg] format. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
This element is used for defining a name for the texture bitmaps of accessories. JPEG is the standard file format. Since the alpha channel is not available in the JPEG-format, the RGB value 0,0,255 is used for masking.
The elements are used depending on the settings in the element "CONSTRUCTION_ID". The element FILE_NAME_TEXTURE_1 implies left-hand depiction of the accessory item and the element FILE_NAME_TEXTURE_2 is used to indicate a right-hand depiction.
CONSTRUCTION_ID = N: the texture defined in the element "FILE_NAME_TEXTURE_1" is used
CONSTRUCTION_ID = J: there are two possibilities:
1. A symmetrical item is mirrored on the centre line, which can be either y or z axis (e.g. sinks, cooking elements = Y and refrigerators, microwave ovens = Z): The left-hand depiction is entered into the element FILE_NAME_TEXTURE_1.
2. The item is not symmetrical and therefore cannot be mirrored: The depiction of the left-hand part is entered into element FILE_NAME_TEXTURE_1 and the depiction of the right-hand part is filled in into element FILE_NAME_TEXTURE_2
CONSTRUCTION_ID = L: only settings in element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: only settings in element FILE_NAME_TEXTURE_2
The general format for all settings is [cccccccc.jpg]. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
MASKING optional Restriction of xs:boolean
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
This field is of optional use, unless at least one of the elements FILE_NAME_TEXTURE_1/2is filled in. 		D boolean
P
M
MODELING_GRAPHIC_ID optional Restriction of xs:string
This element references a modeling graphic. D string
P
M [1:15]
RANGE_DEPENDENT Restriction of xs:boolean
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element defines the minimum delivery time in weeks.
This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.) 		D nonNegativeInteger
P
M [0:999]
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

This element provides information about possible alterations of an item provided by the manufacturer. Any changes of an item depend on the definitions of the basic shape in the element PARAMETERS (path 1).

0 = all measurement parameters (PARAMETERS (path 1)) are locked, changes of measurements are not possible;

1 = the measurement parameters (PARAMETERS (path 1)) may be changed according to the settings in SA500. The measurement that shall be changed is upon request;

2 = all measurement parameters (PARAMETERS (path 1)) may be changed, locked parameters require identical values in the attribute NOMINAL_VALUE (path 1), FROM (path 1) and TO (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
BASIC_PROFILE optional
This element definea the basic shape of an item.
BLOCK_PARTS optional
This element is used as a container element for the block parts lists in the catalogue.
MODULE_PARTS optional

If the relevant item is a 3-D unit, this element contains a list of parts for module elements, with the first element being a base unit with position 0 followed by the module elements from the bottom upwards. This element must be left blank if the associated item is not a 3-D unit.

The 3-D unit has a fixed price. If the 3-D unit is changed, the new price will result from the price for the base unit + the price for the modules. The 3-D unit is deleted, the base unit becomes the main position and contains all other module elements as sub-positions from the bottom upwards.

The module elements can be range or version-specific.

Rules concerning the height of module elements within the base unit can be specified via MODUL_RULE_SETS. The universally defined module rule is referenced in this case.

The base unit can be assigned this kind of rule via MODULE_RULE_SET_REF.

ITEM_TEXT
This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
TYPE_KEY
This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item.
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
FRONT_DIVISIONS optional
This element is used for defining the possible front divisions of an item.
Different front divisions may be related to the chosen range or built-in appliances.

Similar front divisions in different programmes may be defined in front groups. These front groups are referenced by the programmes.

All front divisions are based on the left-hand construction method. If an item is also available in right-hand construction mode, it is mirrored.If an item is also available in right-hand construction mode, it is mirrored.
FRONT_APPEARANCE_REF optional
This element is used for assigning a front appearance to an item. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Front appearances which are assigned to this element are not dependent on a programme.
Choice optional
MODULE_RULE_SET_REF optional
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
MODULE_RULE_SETS optional
This element is used for defining a set of rules for module elements. If an item is defined as a module element (type key = 10) the rules for planning this item are defined in this element. It is only possible to define either the element MODULE_RULE_SET_REF or the element MODULE_RULE_SETS.
DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.
PROPERTIES optional
This element is used for summarizing the item specific characteristics.
RESTRICTIONS optional
This element is used for combining all restrictions which apply to one product group.
Sequence
RESTRICTION_REF 1..∞
This element references a restriction which is assigned to a product group.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references item specific restrictions. D positiveInteger
P [0:99999]
M
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...). 		D positiveInteger
P
M [1:99999]

DEFAULT_OPTION_GROUPS optional
In this record type, default values for series variations are given as proposals resp. decision support for the user. The proposals made here have to be defined as legal combinations.
Sequence
DEFAULT_OPTION_GROUP 1..∞
This element defines a standard proposal.
Each feature type may be referenced only one time in the DEFAULT_OPTION_GROUP
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
This attribute defines a numerical counter for the default group. D positiveInteger
P
M [1:999999999]
Sequence
DEFAULT_OPTION_GROUP_NAME languagetexte30 Complex Type
This element contains a freely defined name for the default option, e.g. defined by the user of the planning software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FILE_NAME optional Restriction of xs:string
This element contains the filename of a JPEG-file which is used as an example of the default option. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M
OPTION_REF 1..∞
This element references the features which are combined in the default option.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the feature type of the referenced feature. D noNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines the reference between the feature and the default option. D string
P
M [1:5]
DETAIL_INFOS optional
This element is used for defining pictures which are subordinated to the the standard proposal.
Sequence
DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
DETAIL_INFOS 0..∞
This element is used for defining detailed media information, e.g. photographs, PDF files, video hyperlinks which refer to a series.
Sequence
DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
RESTRICTIONS optional
This element is used for summarizing the global restrictions.
Sequence
RESTRICTION_REF 0..∞
This element references global restrictions.
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different restrictions are processed. Different values in the the field SEQUENCE_NO are required and an intersection of the different restrictions is made up.
The sequence has to be defined in ascending order which may have gaps (e.g. 1,3,10, ...). 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references global (i.e. not depending on series) restrictions. D nonNegativeInteger
P
M [0:99999]
Remarks

Source
<xs:element name="SERIES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE" maxOccurs="100">
        <xs:annotation>
          <xs:documentation>200--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_CLASS_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SERIES_NAME">
              <xs:annotation>
                <xs:documentation>200--3--Serienname</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>200--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PURCHASE_RETAIL_ID">
              <xs:annotation>
                <xs:documentation>200--5--EK_VK_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SUGGESTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SUGGESTION_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SUGGESTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRODUCT_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_CLASS_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEMS">
                          <xs:annotation>
                            <xs:documentation>400--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECO_MOBILIER" minOccurs="0">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[0-9]{11}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="NET_WEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                      <xs:annotation>
                                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence minOccurs="0">
                                          <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>450/470--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="PRICE_FIELD">
                                                  <xs:annotation>
                                                    <xs:documentation>450--4--Preisfeld</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="250" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PRICE">
                                                  <xs:annotation>
                                                    <xs:documentation>450--5--Preis</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:integer">
                                                      <xs:minInclusive value="-99999999" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:boolean" />
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>470--4--Preis</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:integer">
                                                      <xs:minInclusive value="-99999999" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="99999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="PRICE_TYPE_REF">
                                      <xs:annotation>
                                        <xs:documentation>400/407--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="PRICE_TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400/407--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CALC_GROUP_REF">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="CALC_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="10" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PRICE_FEATURE_GROUP_REF">
                                            <xs:annotation>
                                              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>460--1--Satzart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="PRICE_FIELD">
                                                        <xs:annotation>
                                                          <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="250" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PRICE">
                                                        <xs:annotation>
                                                          <xs:documentation>460--5--Preis</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:integer">
                                                            <xs:minInclusive value="-99999999" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="99999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CALC_GROUP_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="CALC_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="10" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[0-9]|[1-8][0-9]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="PRICE_TYPE_REF">
                                            <xs:annotation>
                                              <xs:documentation>407--5--Preisart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>407--5--Preisart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="RESTRICTIONS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>409--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>409--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="RESTRICTION_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>409--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SEQUENCE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>409--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:maxInclusive value="99999" />
                                                    <xs:minInclusive value="1" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>406--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                                    <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>120--0--NEW</xs:documentation>
                                                              <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>406--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="SERIE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="99" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="TYPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                            <xs:annotation>
                                                              <xs:documentation>406--7--Anzahl</xs:documentation>
                                                              <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="SEQUENCE" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>Version 2.4.1</xs:documentation>
                                                              <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:maxInclusive value="99999" />
                                                                <xs:minInclusive value="1" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SET_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="9" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>120--0--NEW</xs:documentation>
                                                              <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>406--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="SERIE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="99" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="TYPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                            <xs:annotation>
                                                              <xs:documentation>406--7--Anzahl</xs:documentation>
                                                              <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="SEQUENCE" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>Version 2.4.1</xs:documentation>
                                                              <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:maxInclusive value="99999" />
                                                                <xs:minInclusive value="1" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SET_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="9" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPERATION_ITEM" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="SCOPE" maxOccurs="5">
                                                  <xs:annotation>
                                                    <xs:documentation>411--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>411--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="CLASS">
                                                              <xs:annotation>
                                                                <xs:documentation>411--7--Art</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="21" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="ITEM_REF" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="SERIE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>411--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="99" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="TYPE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>411--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:minLength value="1" />
                                                                      <xs:maxLength value="15" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                            <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[LNR]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="COVER" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--9--Abdeckung</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="3" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="VALUE" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--10--Wert</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="VALUE_MIN" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                                                <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="VALUE_MAX" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                                                <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SCOPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>411--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="5" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="HINGE">
                                      <xs:annotation>
                                        <xs:documentation>400--4--Anschlag</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[BEJLMNR]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="EDP_NUMBER" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="EAN_NUMBER" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="ITEM_IDENTIFICATION">
                                      <xs:annotation>
                                        <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[BEKSMZVPNOG]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="CATALOG_PAGE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="40" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
                                        <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
                                        <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VAT_ID_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="VAT_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="WEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--20--Gewicht</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VOLUME" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--21--Volumen</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="CONSTRUCTION_ID">
                                      <xs:annotation>
                                        <xs:documentation>400--23--Bauweise_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[JLNRAE]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="OLD_SERIE_NO" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="99" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="OLD_TYPE_NO" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--27--Type_Alt</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="MASKING" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--30--Maskierung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:boolean" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="RANGE_DEPENDENT">
                                      <xs:annotation>
                                        <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:boolean" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="2" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BASIC_PROFILE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:choice>
                                            <xs:element name="CARCASE_BASIC_SHAPE">
                                              <xs:annotation>
                                                <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                                    <xs:annotation>
                                                      <xs:documentation>400--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType mixed="true">
                                                      <xs:sequence>
                                                        <xs:element name="OPTION_REF">
                                                          <xs:annotation>
                                                            <xs:documentation>430--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:attribute name="FEATURE_NO" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>430--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="OPTION_KEY" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>430--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:minLength value="1" />
                                                                  <xs:maxLength value="5" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                      <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>400--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[\S ]{1,5}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                  <xs:element name="BASIC_SHAPE_PARAMETERS">
                                                    <xs:annotation>
                                                      <xs:documentation>500--1--Satzart</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                          <xs:annotation>
                                                            <xs:documentation>500--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--Parameter</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>500--5--Nennwert</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="BASIC_SHAPE_FROM">
                                                              <xs:annotation>
                                                                <xs:documentation>500--6--Von</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="BASIC_SHAPE_TO">
                                                              <xs:annotation>
                                                                <xs:documentation>500--7--Bis</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                              <xs:annotation>
                                                                <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                                <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                            <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                              <xs:annotation>
                                                <xs:documentation>400--32--Massbild</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                                    <xs:annotation>
                                                      <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:minLength value="1" />
                                                        <xs:maxLength value="240" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:element>
                                                  <xs:element name="DIMENSIONAL_PARAMETERS">
                                                    <xs:annotation>
                                                      <xs:documentation>500--1--Satzart</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                          <xs:annotation>
                                                            <xs:documentation>500--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="DIMENSIONAL_FROM">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="DIMENSIONAL_TO">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                                <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>400--32--Massbild</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="20" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:choice>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="BLOCK_PARTS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="BLOCK_SEQUENTIAL_NO">
                                                  <xs:annotation>
                                                    <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="FEATURE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="OPTION_KEY" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="5" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="HINGE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--6--Anschlag</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[BEJLMNR]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="EXCHANGE_CONDITION">
                                                  <xs:annotation>
                                                    <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="2" />
                                                      <xs:maxInclusive value="3" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="STATUS">
                                                  <xs:annotation>
                                                    <xs:documentation>401--8--Status</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[ABELSZ]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[JLNRAE]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="MODULE_PARTS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="MODULE_PART" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="PART_SEQUENTIAL_NO">
                                                  <xs:annotation>
                                                    <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:maxInclusive value="999" />
                                                      <xs:minInclusive value="0" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="SHORT_TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TEXT_LINE" maxOccurs="3">
                                                        <xs:annotation>
                                                          <xs:documentation>410--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TEXT">
                                                              <xs:annotation>
                                                                <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[\S ]{1,30}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="SEQUENCE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger" />
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:language">
                                                          <xs:pattern value="[A-Z]{2}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="TYPE_KEY">
                                      <xs:annotation>
                                        <xs:documentation>445--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TK_TYPE">
                                            <xs:annotation>
                                              <xs:documentation>445--4--TS_Typ</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_CLASS">
                                            <xs:annotation>
                                              <xs:documentation>445--5--TS_Art</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                            <xs:annotation>
                                              <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                          <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="9999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SEQUENCE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger" />
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                                <xs:annotation>
                                                  <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="TK_MATERIAL" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--21--TS_Material</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-2]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_SHAPE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--22--TS_Form</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-2]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECLASS">
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ECLASS_NO">
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:totalDigits value="8" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FRONT_DIVISIONS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>510--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="FRONT_GROUP" maxOccurs="99">
                                            <xs:annotation>
                                              <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="FRONT_DIVISION_DEF">
                                                        <xs:annotation>
                                                          <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:minLength value="1" />
                                                            <xs:maxLength value="250" />
                                                            <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:minLength value="1" />
                                                            <xs:maxLength value="15" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="FRONT_CELL_NO">
                                                              <xs:annotation>
                                                                <xs:documentation>540--6--Zellennummer</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="99" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="FRONT_TYPE" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--7--Fronttyp</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="900" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="4" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="4" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="PARAMETER_1" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--12--Parameter_1</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="99" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="PARAMETER_2" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--13--Parameter_2</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="99" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="9999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="9999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                            </xs:element>
                                                            <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                            </xs:element>
                                                            <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                            </xs:element>
                                                            <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                            </xs:element>
                                                            <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="4" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="UPPER_JOIN" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="|[VLSG]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="LOWER_JOIN" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="|[VLSG]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="LEFT_JOIN" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="|[VLSG]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="RIGHT_JOIN" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="|[VLSG]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="2" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="FRONT_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:choice minOccurs="0">
                                      <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MODULE_RULE_SETS" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="MODULE_RULES">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:sequence>
                                                              <xs:element name="MODULE_POSITION">
                                                                <xs:annotation>
                                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:string">
                                                                    <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                                                    <xs:enumeration value="LINE_BOTTOM" />
                                                                    <xs:enumeration value="LINE_TOP" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:element>
                                                              <xs:element name="MAX_VALUE" minOccurs="0">
                                                                <xs:annotation>
                                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                                    <xs:minInclusive value="0" />
                                                                    <xs:maxInclusive value="99999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:element>
                                                              <xs:element name="MIN_VALUE" minOccurs="0">
                                                                <xs:annotation>
                                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                                    <xs:minInclusive value="0" />
                                                                    <xs:maxInclusive value="99999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:element>
                                                            </xs:sequence>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                    </xs:complexType>
                                                  </xs:element>
                                                  <xs:element name="MODULE_RULE_SET_REF">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:choice>
                                    <xs:element name="DETAIL_INFOS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="PROPERTIES" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="PROPERTY_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="VALUE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="RESTRICTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="RESTRICTION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:maxInclusive value="99999" />
                                        <xs:minInclusive value="1" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DEFAULT_OPTION_GROUPS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>295--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DEFAULT_OPTION_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DEFAULT_OPTION_GROUP_NAME" type="languagetexte30">
                          <xs:annotation>
                            <xs:documentation>296--5--Name_Standard_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="FILE_NAME" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>296--6--Dateiname</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OPTION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>295--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>295--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>295--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Version 2.3 27.06.2014 K. Richter</xs:documentation>
                            <xs:documentation>Bilder unterhalb des Standardvorschlages</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element : SERIE Element
Description
This element is used for the definition of the series.
Items belonging to series 0 are valid for all series. Therefore items of series 0 must not occur with the same type number (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in other series. Items of other series (unequal 0) may be used with the same type name in different series.
Buying prices are always indicated as the dealer’s buying prices
Namespace (none)
Diagram
DETAIL_INFOS Element DEFAULT_OPTION_GROUPS Element PRODUCT_GROUPS Element SUGGESTIONS Element RESTRICTIONS Element PURCHASE_RETAIL_ID Element SERIES_NAME Element FEATURE_CLASS_REF Element Sequence SERIE Element
Overview
SERIE 1..100
This element is used for the definition of the series.
Items belonging to series 0 are valid for all series. Therefore items of series 0 must not occur with the same type number (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in other series. Items of other series (unequal 0) may be used with the same type name in different series.
Buying prices are always indicated as the dealer’s buying prices
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the serial number of the series. D nonNegativeInteger
P
M [0:99]
Sequence
FEATURE_CLASS_REF optional
This element references the feature class which is assigned to the series.
It is used for assigning all legal variations of a series to this specific series.
The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all programmes and items of a series. Therefore it is not obligatory to state the features of a series in the order. However, in an order it is indispensable to state the sum of features for an item in combination with those of the series.
All features which are assigned to one series can be chosen from a list box while entering the variation header.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute references a feature class. A feature class is defined in the element FEATURE_CLASS (path1).

path1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D positiveInteger
P
M [1:999]
SERIES_NAME
This element defines the name of the series.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element defines a text line.
The element TEXT contains text information.
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
PURCHASE_RETAIL_ID Restriction of xs:boolean
This element is used for defining series specific purchase and retail prices
0 = purchase price
1 = retail price
Depending on the price_ID (element PRICE_ID (path1)) the price is defined as follows

price-ID = 1 (price),the value set in the element ITEM_PRICE (path2) is used

price_ID = 2 (ident number), the price is made up from the values set in element IDENT_NUMBER/PRICE (path3), element ITEM_PRICE/PRICE_MINIMUM_BASIC (path2) or in element ADDITIONAL_PRICE (path5).

price_ID = 3 (calculation point), the price made up from the settings in the elements ITEM_PRICE (path2) or PRICE_MINIMUM_BASIC multiplied with the calculation factor, defined in element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR.

According to the key, only one kind of price calculation (combination of elements VAT (path4) and PURCHASE_RETAIL_ID (path4)) may be used within one series.
If a database contains purchase prices as well as retail prices, items with purchase price may not be assigned to the same calculation group(PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP)as items with retail prices.
This element is of major significance for the correct price calculation! Purchase prices are always given as retailers' purchase prices not manufacturers' purchase prices.

element paths
path1: CATALOG/CATALOG_IDENTIFICATION/
path2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/
path3: PRICE_DEFINITION/IDENT_NUMBERS
path4: CATALOG/CATALOG_IDENTIFICATION
path5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP 		D boolean
P
M
RESTRICTIONS optional
This element references restrictions which are specific for one series (series specific restriction).

The number of features selected in a planning is only valid, if none of the feature combinations is excluded by any of the restrictions. The result of all restrictions represents an intersection of the feature combinations.
Sequence
RESTRICTION_REF 0..∞
This element references a restriction which is assigned to a series (series specific restrictions).

The number of features selected in a planning is only valid, if none of the feature combinations is excluded by any of the restrictions. The result of all restrictions represents an intersection of the feature combinations.
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...) 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references series specific restrictions. D nonNegativeInteger
P
M [0:99999]
SUGGESTIONS optional
This element references default settings that are applied to the series.

If the series additionally contains a standard proposal (DEFAULT_OPTION_GROUPS), the standard proposal will take priority when the planning is recorded initially.
Sequence
SUGGESTION_REF 0..∞
This element references default settings that are applied to the series.

If the series additionally contains a standard proposal (DEFAULT_OPTION_GROUPS), the standard proposal will take priority when the planning is recorded initially.
SEQUENCE required Restriction of xs:nonNegativeInteger

This element is used to specify the sequence in which the assigned default values are suggested when a planning is recorded for the first time.

The numbering (SEQUENCE) determines the priorities

 D nonNegativeInteger
P
M [1:99999]
SUGGESTION_NO required Restriction of xs:nonNegativeInteger
This attribute references a set of default values. D nonNegativeInteger
P
M [0:99999]
PRODUCT_GROUPS
This element is used for the definition of product groups. Product groups are used for grouping items which have the same variation types (e.g. shelves).
Sequence
PRODUCT_GROUP 1..∞
This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
This element is used for defining a name for a product group.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
This element is used for assigning a feature class to a product group. It references a feature class which is defined in the element FEATURE_DEFINITION/FEATURE_CLASSES.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute identifies the referenced feature class(FEATURE_CLASS). D positiveInteger
P
M [1:999]
ITEMS
This element defines all items belonging to one product group.
Sequence
ITEM 1..∞
This element is used for the definition of items and blocks. An item is identified by the attributes SERIE_NO (path 1) and TYPE_NO (path 1)..

The elements OLD_SERIA_NO (path 1) and OLD_TYPE_NO (path 1) may only be used if the geometrical information for the referred item is exactly the same as for the current item.

If an electrical appliance is defined as an item, it is necessary to indicate the dimensions (B, H, T) of this item in the element PARAMETERS (path 3).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Sequence
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

Information can be found at:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

The code, inter alia, expresses the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D string
P [0-9]{11}
M [11:11]

NET_WEIGHT optional Restriction of xs:nonNegativeInteger

This attribute is used to specify the net weight.

The code in the previous element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]

PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) with the value 0 in the element ADDITIONAL_PRICE.

Exactly one basic price feature group has to be assigned to an item. Further price groups can be assigned in the element ADDITIONAL_PRICE_GROUP.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
This element is used for the item price and additional price information.
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 1/PRICE_TYPE.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPE
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
This element references calculation groups. Calculation groups are defined in the merchandise groups (PRICE_DEFINITION/MERCHANDISE_GROUP).
CALC_GROUP_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
This element references an exchange-ID which is defined in the element path 1/EXCHANGE_ID.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_I
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
ADDITIONAL_PRICE_GROUP 0..∞
This element references PRICE_FEATURE_GROUPS with additional price groups. The basic price feature groups which is referenced excatly one time by an item is defined in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF .

All items which reference the same PRICE_FEATURE_GROUP have also to reference the same calculation group (CALC_GROUP_REF) and exchange-ID (EXCHANGE_ID_REF).

If different price types (item prices/ surcharge prices) are assigned to an item, the following combinations are permitted:

Item | Surcharge
Price per piece | Price per piece
Price depending on length | Price depending on length
Price depending on length | Price per piece

The following combinations are NOT permitted:

Item | Surcharge
Price per piece | Price depending on length
Sequence
PRICE_FEATURE_GROUP_REF
This element references a surcharge group. Surcharge groups which are referenced here may not be used as feature groups.
CALC_GROUP_REF optional
This element references calculation groups. The calculation groups are defined within the merchandise groups(PRICE_DEFINITION/MERCHANDISE_GROUP).
EXCHANGE_ID_REF optional
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS. The exchange-ID references block items.
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 11/PRICE_TYPE.

Element paths:
path1: PRICE_DEFINITION/PRICE_TYPES
RESTRICTIONS optional
This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Sequence
RESTRICTION_REF 1..∞
This element references an item to an assigned restriction.
ADDITIONAL_ITEMS optional
This element is used for assigning additional items. A number of optional and/or mandatory additional items is defined which the user may select from in the planning process.
Sequence
OPTIONAL_ITEMS optional
This element references optional additional items. The number of optional items is not restricted. Items which are defined as linked items may not be used as additional items.
MANDATORY_ITEMS optional
This element is used for assigning mandatory additional items to a main item. For each main item the number of mandatory additional items is restricted to 1 but different groups of mandatory items may be assigned to one main item.
If only 1 additional item is assigned to a group this additional item is automatically transferred into the planning
OPERATION_ITEM optional
This element is used for assigning items to special models, surcharges for mitres, visible sides, or cut outs. The different ways of combination are defined by the elements ITEM_REF/SCOPE (path 1) and CLASS (path 1).

Linked items may not be used as additional items.
Linked items may not be used as additional items.

The following examples illustrate the different possibilities of combination:
- Assignment of surcharges for mitres for cornices, light pelmets,plinths
- Assignment of visible sides for items (range dependent/ range independent)
- Assignment of formed pieces, returns etc. for cornices, light pelmets, plinths
- Assignment of lateral plinth to straight plinth boards
- Assignment of cut outs, tongue and groove for worktops
- Assignment of legal measurement changes, i.e. width-, height-, depth reductions.

In case special models/ items are assigned to an item in this element, only these specially defined models/ items are legal, if no assignments are explicitly defined, all special models are permitted.
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
HINGE Restriction of xs:string

This element provides information about the orientation of the door hinges. No geometrical information is filled in here. All geometrical information is provided in the element CONSTRUCTION_ID.

The following codes can be used to define the door closing:
J = request for door closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = no hinge or hinges on the exterior edges (double door);
R = hinge right ;
B = corresponding with construction ID i.e. construction-ID left : hinge left;
E = opposite to construction-ID, i.e. construction-ID left : hinge right;

In case of double doors, L and R apply to both doors.

For the item identifier B (block) the placement of the items in a block corresponds to the construction_ID => value "N" is required in the field HINGE.

Values B and E are only permitted if the value "J" is filled in in the element CONSTRUCTION_ID (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
EDP_NUMBER optional Restriction of xs:string
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
EAN_NUMBER optional Restriction of xs:string
If available the EAN-code of an item is defined in this element. D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article.
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal.

 D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

This element can be used to specify the item's catalogue page in the catalogue saved as a .pdf file. This information helps to quickly find an item within the stored catalogue.

The URL of the .pdf file is stored in the DETAIL_INFO element (on catalogue level). Because some items feature on multiple pages within the catalogue, it must be assured that the information for the .pdf file is identical to the 40-digit catalogue page CATALOG_PAGE, meaning they both refer to the same page.

 D positiveInteger
P
M [1:999]
VAT_ID_REF optional
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
WEIGHT optional Restriction of xs:nonNegativeInteger

This element is used to specify the item weight (100 g) including packaging material. (e.g. 50 = 5000 g).
The code in the element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.
Contiguous parts are calculated in the basis of the gross weight per price unit.

Example:
An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
This element defines the volume of an item including packaging material. The basic unit of the volume is [dm³], e.g. a volume of 50 dm³ is entered as 50. D nonNegativeInteger
P
M [0:9999]
CONSTRUCTION_ID Restriction of xs:string
This element defines the basic carcase shape of an item.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the construction_ID. 		D string
P [JLNRAE]
M [1:1]
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
In case the item is provided by a subcontractor, the corresponding supplier number is entered in this element.

If this subcontractor item is a visible part either the elements SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO or the elements FILE_NAME_TEXTURE_1/2 have to be defined.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D nonNegativeInteger
P
M [0:9999]
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
In case the item is provided by a subcontractor (SUBCONTRACTOR_ID filled in) the corresponding supplier number is entered in this element.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D string
P
M [1:15]
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D nonNegativeInteger
P
M [0:99]
OLD_TYPE_NO optional Restriction of xs:string
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D string
P
M [1:15]
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
These elements are used to enter the file names of bitmaps for accessory textures. The files are JPEG files. Because JPEGs do not allow for an alpha channel, the RGB colour code 0,0,255 is used for masking in this case.
The elements are used depending on the value in the „CONSTRUCTION_ID“ element. The FILE_NAME_TEXTURE_1 element contains the left side illustration of the accessories, the FILE_NAME_TEXTURE_2 the right side illustration of the accessories.
CONSTRUCTION_ID = N: The texture in the „filename_texture_1" is used.
CONSTRUCTION_ID = J: There are two different options:
1. The image is mirrored along the central axle. Depending on the item, this can be the Y-axis or the Z-axis (e.g. inset sinks, cooking elements = Y and refrigerators, microwave = Z): The image showing the left side is entered in the FILE_NAME_TEXTURE_1 element.
2. The item cannot be mirrored along the central axle. The image of the left side is entered in the FILE_NAME_TEXTURE_1, while the image of the right side is entered in the FILE_NAME_TEXTURE_2 element.
CONSTRUCTION_ID = L: The value is only entered in the FILE_NAME_TEXTURE_1 element
CONSTRUCTION_ID = R: The value is only entered in the FILE_NAME_TEXTURE_2 element
The values are specified in [cccccccc.jpg] format. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
This element is used for defining a name for the texture bitmaps of accessories. JPEG is the standard file format. Since the alpha channel is not available in the JPEG-format, the RGB value 0,0,255 is used for masking.
The elements are used depending on the settings in the element "CONSTRUCTION_ID". The element FILE_NAME_TEXTURE_1 implies left-hand depiction of the accessory item and the element FILE_NAME_TEXTURE_2 is used to indicate a right-hand depiction.
CONSTRUCTION_ID = N: the texture defined in the element "FILE_NAME_TEXTURE_1" is used
CONSTRUCTION_ID = J: there are two possibilities:
1. A symmetrical item is mirrored on the centre line, which can be either y or z axis (e.g. sinks, cooking elements = Y and refrigerators, microwave ovens = Z): The left-hand depiction is entered into the element FILE_NAME_TEXTURE_1.
2. The item is not symmetrical and therefore cannot be mirrored: The depiction of the left-hand part is entered into element FILE_NAME_TEXTURE_1 and the depiction of the right-hand part is filled in into element FILE_NAME_TEXTURE_2
CONSTRUCTION_ID = L: only settings in element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: only settings in element FILE_NAME_TEXTURE_2
The general format for all settings is [cccccccc.jpg]. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
MASKING optional Restriction of xs:boolean
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
This field is of optional use, unless at least one of the elements FILE_NAME_TEXTURE_1/2is filled in. 		D boolean
P
M
MODELING_GRAPHIC_ID optional Restriction of xs:string
This element references a modeling graphic. D string
P
M [1:15]
RANGE_DEPENDENT Restriction of xs:boolean
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element defines the minimum delivery time in weeks.
This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.) 		D nonNegativeInteger
P
M [0:999]
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

This element provides information about possible alterations of an item provided by the manufacturer. Any changes of an item depend on the definitions of the basic shape in the element PARAMETERS (path 1).

0 = all measurement parameters (PARAMETERS (path 1)) are locked, changes of measurements are not possible;

1 = the measurement parameters (PARAMETERS (path 1)) may be changed according to the settings in SA500. The measurement that shall be changed is upon request;

2 = all measurement parameters (PARAMETERS (path 1)) may be changed, locked parameters require identical values in the attribute NOMINAL_VALUE (path 1), FROM (path 1) and TO (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
BASIC_PROFILE optional
This element definea the basic shape of an item.
Sequence
Choice
CARCASE_BASIC_SHAPE
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information. If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank.
ITEM_DIMENSIONAL_DRAWING
This element is used for the definition of dimensional drawings. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

This element is not permitted if the element BASIC_PROFILE_SHAPE is defined. Dimensional drawings for furniture elements are not permitted.
BLOCK_PARTS optional
This element is used as a container element for the block parts lists in the catalogue.
Sequence
BLOCK_PART 1..∞

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2)), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

MODULE_PARTS optional

If the relevant item is a 3-D unit, this element contains a list of parts for module elements, with the first element being a base unit with position 0 followed by the module elements from the bottom upwards. This element must be left blank if the associated item is not a 3-D unit.

The 3-D unit has a fixed price. If the 3-D unit is changed, the new price will result from the price for the base unit + the price for the modules. The 3-D unit is deleted, the base unit becomes the main position and contains all other module elements as sub-positions from the bottom upwards.

The module elements can be range or version-specific.

Rules concerning the height of module elements within the base unit can be specified via MODUL_RULE_SETS. The universally defined module rule is referenced in this case.

The base unit can be assigned this kind of rule via MODULE_RULE_SET_REF.

Sequence
MODULE_PART 1..∞

This element corresponds to a partial list of parts for module elements of a 3-D unit. The elements must be specified in their order from bottom to top. Position 0 (PART_SEQUENTIAL_NO) is the empty base unit (cabinet type code 17) It is followed by the module elements from bottom to top (cabinet type key 10). The base unit hinges are identical to the hinges of the 3-D unit.

ITEM_TEXT
This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Sequence
SHORT_TEXT
This element contains short text information.
FULL_TEXT optional languagetexte Complex Type

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

PLANNING_ADVICE optional languagetexte60999 Complex Type
This element contains planning advices.
TYPE_KEY
This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item.
Sequence
TK_TYPE Restriction of xs:positiveInteger
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
A value from the column item No., as listed in the Table "Type keys", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

This element is used for assigning a type key to the installation information and recess height.

TK_MATERIAL optional Restriction of xs:positiveInteger
A value from the column type, as listed in table "Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
A value from the column shape No., as listed in the table "Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
A value from the column front appearance No., as listed in the table "Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
FRONT_DIVISIONS optional
This element is used for defining the possible front divisions of an item.
Different front divisions may be related to the chosen range or built-in appliances.

Similar front divisions in different programmes may be defined in front groups. These front groups are referenced by the programmes.

All front divisions are based on the left-hand construction method. If an item is also available in right-hand construction mode, it is mirrored.If an item is also available in right-hand construction mode, it is mirrored.
Sequence
FRONT_GROUP 1..99
This element defines different front divisions and combines them in one front group.
FRONT_APPEARANCE_REF optional
This element is used for assigning a front appearance to an item. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Front appearances which are assigned to this element are not dependent on a programme.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This element is used to define the relationship between the version defined in the data record and a front type. D positiveInteger
P
M
Choice optional
MODULE_RULE_SET_REF optional
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the number of the rule set which references an item to the corresponding rule set. D positiveInteger
P
M
MODULE_RULE_SETS optional
This element is used for defining a set of rules for module elements. If an item is defined as a module element (type key = 10) the rules for planning this item are defined in this element. It is only possible to define either the element MODULE_RULE_SET_REF or the element MODULE_RULE_SETS.
Sequence
MODULE_RULE_SET 1..∞
This element assigns a set of rules to a module element. The element MODULE_RULE_SET_NO references each set of rules to the related module housing element. Therefore it is possible to define different set of rules for one item depending on the selected module housing element.
DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
PROPERTIES optional
This element is used for summarizing the item specific characteristics.
Sequence
PROPERTY_REF 1..∞
This element references a characteristic which is defined under GLOBAL_DEFINITION/PROPERTIES.
RESTRICTIONS optional
This element is used for combining all restrictions which apply to one product group.
Sequence
RESTRICTION_REF 1..∞
This element references a restriction which is assigned to a product group.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references item specific restrictions. D positiveInteger
P [0:99999]
M
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...). 		D positiveInteger
P
M [1:99999]

DEFAULT_OPTION_GROUPS optional
In this record type, default values for series variations are given as proposals resp. decision support for the user. The proposals made here have to be defined as legal combinations.
Sequence
DEFAULT_OPTION_GROUP 1..∞
This element defines a standard proposal.
Each feature type may be referenced only one time in the DEFAULT_OPTION_GROUP
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
This attribute defines a numerical counter for the default group. D positiveInteger
P
M [1:999999999]
Sequence
DEFAULT_OPTION_GROUP_NAME languagetexte30 Complex Type
This element contains a freely defined name for the default option, e.g. defined by the user of the planning software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FILE_NAME optional Restriction of xs:string
This element contains the filename of a JPEG-file which is used as an example of the default option. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M
OPTION_REF 1..∞
This element references the features which are combined in the default option.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the feature type of the referenced feature. D noNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines the reference between the feature and the default option. D string
P
M [1:5]
DETAIL_INFOS optional
This element is used for defining pictures which are subordinated to the the standard proposal.
Sequence
DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
DETAIL_INFOS 0..∞
This element is used for defining detailed media information, e.g. photographs, PDF files, video hyperlinks which refer to a series.
Sequence
DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute defines the serial number of the series. D nonNegativeInteger
P
M [0:99]
Remarks

Source
<xs:element name="SERIE" maxOccurs="100" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_CLASS_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIES_NAME">
        <xs:annotation>
          <xs:documentation>200--3--Serienname</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>200--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PURCHASE_RETAIL_ID">
        <xs:annotation>
          <xs:documentation>200--5--EK_VK_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SUGGESTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SUGGESTION_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SUGGESTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRODUCT_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_CLASS_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEMS">
                    <xs:annotation>
                      <xs:documentation>400--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECO_MOBILIER" minOccurs="0">
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[0-9]{11}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="NET_WEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                <xs:annotation>
                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence minOccurs="0">
                                    <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>450/470--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PRICE_FIELD">
                                            <xs:annotation>
                                              <xs:documentation>450--4--Preisfeld</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="250" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PRICE">
                                            <xs:annotation>
                                              <xs:documentation>450--5--Preis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:integer">
                                                <xs:minInclusive value="-99999999" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:boolean" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>470--4--Preis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:integer">
                                                <xs:minInclusive value="-99999999" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_TYPE_REF">
                                <xs:annotation>
                                  <xs:documentation>400/407--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="PRICE_TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400/407--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CALC_GROUP_REF">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="CALC_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="10" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PRICE_FEATURE_GROUP_REF">
                                      <xs:annotation>
                                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>460--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="PRICE_FIELD">
                                                  <xs:annotation>
                                                    <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="250" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PRICE">
                                                  <xs:annotation>
                                                    <xs:documentation>460--5--Preis</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:integer">
                                                      <xs:minInclusive value="-99999999" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="99999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CALC_GROUP_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="CALC_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="10" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[0-9]|[1-8][0-9]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="PRICE_TYPE_REF">
                                      <xs:annotation>
                                        <xs:documentation>407--5--Preisart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="PRICE_TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>407--5--Preisart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="RESTRICTIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>409--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>409--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="RESTRICTION_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>409--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>409--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:maxInclusive value="99999" />
                                              <xs:minInclusive value="1" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>406--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                              <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>120--0--NEW</xs:documentation>
                                                        <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                      <xs:annotation>
                                                        <xs:documentation>406--7--Anzahl</xs:documentation>
                                                        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SEQUENCE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>Version 2.4.1</xs:documentation>
                                                        <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:maxInclusive value="99999" />
                                                          <xs:minInclusive value="1" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SET_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="9" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>120--0--NEW</xs:documentation>
                                                        <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                      <xs:annotation>
                                                        <xs:documentation>406--7--Anzahl</xs:documentation>
                                                        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SEQUENCE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>Version 2.4.1</xs:documentation>
                                                        <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:maxInclusive value="99999" />
                                                          <xs:minInclusive value="1" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SET_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="9" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPERATION_ITEM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="SCOPE" maxOccurs="5">
                                            <xs:annotation>
                                              <xs:documentation>411--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>411--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="CLASS">
                                                        <xs:annotation>
                                                          <xs:documentation>411--7--Art</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="21" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_REF" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="SERIE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>411--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="99" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="TYPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>411--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[LNR]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="COVER" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--9--Abdeckung</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="3" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="VALUE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--10--Wert</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="VALUE_MIN" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                                          <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="VALUE_MAX" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                                          <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SCOPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>411--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="5" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="HINGE">
                                <xs:annotation>
                                  <xs:documentation>400--4--Anschlag</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[BEJLMNR]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="EDP_NUMBER" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="EAN_NUMBER" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="ITEM_IDENTIFICATION">
                                <xs:annotation>
                                  <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[BEKSMZVPNOG]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="CATALOG_PAGE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="40" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
                                  <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
                                  <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VAT_ID_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="VAT_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="WEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VOLUME" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--21--Volumen</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="CONSTRUCTION_ID">
                                <xs:annotation>
                                  <xs:documentation>400--23--Bauweise_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[JLNRAE]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OLD_SERIE_NO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="99" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OLD_TYPE_NO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--27--Type_Alt</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="MASKING" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--30--Maskierung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:boolean" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="RANGE_DEPENDENT">
                                <xs:annotation>
                                  <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:boolean" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="2" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BASIC_PROFILE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:choice>
                                      <xs:element name="CARCASE_BASIC_SHAPE">
                                        <xs:annotation>
                                          <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                              <xs:annotation>
                                                <xs:documentation>400--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType mixed="true">
                                                <xs:sequence>
                                                  <xs:element name="OPTION_REF">
                                                    <xs:annotation>
                                                      <xs:documentation>430--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:attribute name="FEATURE_NO" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>430--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="OPTION_KEY" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>430--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:minLength value="1" />
                                                            <xs:maxLength value="5" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                                <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>400--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[\S ]{1,5}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                            <xs:element name="BASIC_SHAPE_PARAMETERS">
                                              <xs:annotation>
                                                <xs:documentation>500--1--Satzart</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                    <xs:annotation>
                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--Parameter</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>500--5--Nennwert</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="BASIC_SHAPE_FROM">
                                                        <xs:annotation>
                                                          <xs:documentation>500--6--Von</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="BASIC_SHAPE_TO">
                                                        <xs:annotation>
                                                          <xs:documentation>500--7--Bis</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                        <xs:annotation>
                                                          <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                          <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                        <xs:annotation>
                                          <xs:documentation>400--32--Massbild</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                              <xs:annotation>
                                                <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:minLength value="1" />
                                                  <xs:maxLength value="240" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:element>
                                            <xs:element name="DIMENSIONAL_PARAMETERS">
                                              <xs:annotation>
                                                <xs:documentation>500--1--Satzart</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                    <xs:annotation>
                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="DIMENSIONAL_FROM">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="DIMENSIONAL_TO">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                          <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>400--32--Massbild</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="20" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:choice>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="BLOCK_PARTS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="BLOCK_SEQUENTIAL_NO">
                                            <xs:annotation>
                                              <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="5" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="HINGE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--6--Anschlag</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[BEJLMNR]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="EXCHANGE_CONDITION">
                                            <xs:annotation>
                                              <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="2" />
                                                <xs:maxInclusive value="3" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="STATUS">
                                            <xs:annotation>
                                              <xs:documentation>401--8--Status</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[ABELSZ]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[JLNRAE]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="MODULE_PARTS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="MODULE_PART" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PART_SEQUENTIAL_NO">
                                            <xs:annotation>
                                              <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:maxInclusive value="999" />
                                                <xs:minInclusive value="0" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="SHORT_TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>410--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TEXT_LINE" maxOccurs="3">
                                                  <xs:annotation>
                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TEXT">
                                                        <xs:annotation>
                                                          <xs:documentation>410--6--Textzeile</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[\S ]{1,30}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SEQUENCE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger" />
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:language">
                                                    <xs:pattern value="[A-Z]{2}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="TYPE_KEY">
                                <xs:annotation>
                                  <xs:documentation>445--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TK_TYPE">
                                      <xs:annotation>
                                        <xs:documentation>445--4--TS_Typ</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_CLASS">
                                      <xs:annotation>
                                        <xs:documentation>445--5--TS_Art</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                      <xs:annotation>
                                        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                    <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="9999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                          <xs:annotation>
                                            <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="TK_MATERIAL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--21--TS_Material</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-2]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_SHAPE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--22--TS_Form</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-2]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECLASS">
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECLASS_NO">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:totalDigits value="8" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FRONT_DIVISIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>510--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="FRONT_GROUP" maxOccurs="99">
                                      <xs:annotation>
                                        <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="FRONT_DIVISION_DEF">
                                                  <xs:annotation>
                                                    <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="250" />
                                                      <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="15" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="FRONT_CELL_NO">
                                                        <xs:annotation>
                                                          <xs:documentation>540--6--Zellennummer</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="FRONT_TYPE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--7--Fronttyp</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="900" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="4" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="4" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PARAMETER_1" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--12--Parameter_1</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PARAMETER_2" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--13--Parameter_2</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="9999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="9999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                      </xs:element>
                                                      <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                      </xs:element>
                                                      <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                      </xs:element>
                                                      <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                      </xs:element>
                                                      <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="4" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="UPPER_JOIN" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[VLSG]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="LOWER_JOIN" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[VLSG]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="LEFT_JOIN" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[VLSG]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="RIGHT_JOIN" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[VLSG]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="2" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="FRONT_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:choice minOccurs="0">
                                <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MODULE_RULE_SETS" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="MODULE_RULES">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="MODULE_POSITION">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:string">
                                                              <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                                              <xs:enumeration value="LINE_BOTTOM" />
                                                              <xs:enumeration value="LINE_TOP" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:element>
                                                        <xs:element name="MAX_VALUE" minOccurs="0">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="0" />
                                                              <xs:maxInclusive value="99999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:element>
                                                        <xs:element name="MIN_VALUE" minOccurs="0">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="0" />
                                                              <xs:maxInclusive value="99999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                              </xs:complexType>
                                            </xs:element>
                                            <xs:element name="MODULE_RULE_SET_REF">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                              </xs:choice>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PROPERTIES" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="PROPERTY_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="VALUE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RESTRICTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="RESTRICTION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:maxInclusive value="99999" />
                                  <xs:minInclusive value="1" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DEFAULT_OPTION_GROUPS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>295--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DEFAULT_OPTION_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DEFAULT_OPTION_GROUP_NAME" type="languagetexte30">
                    <xs:annotation>
                      <xs:documentation>296--5--Name_Standard_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="FILE_NAME" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>296--6--Dateiname</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OPTION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>295--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>295--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>295--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Version 2.3 27.06.2014 K. Richter</xs:documentation>
                      <xs:documentation>Bilder unterhalb des Standardvorschlages</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_CLASS_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : FEATURE_CLASS_REF Element
Description
This element references the feature class which is assigned to the series.
It is used for assigning all legal variations of a series to this specific series.
The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all programmes and items of a series. Therefore it is not obligatory to state the features of a series in the order. However, in an order it is indispensable to state the sum of features for an item in combination with those of the series.
All features which are assigned to one series can be chosen from a list box while entering the variation header.
Namespace (none)
Diagram
FEATURE_CLASS_REF Element
Overview
FEATURE_CLASS_REF optional
This element references the feature class which is assigned to the series.
It is used for assigning all legal variations of a series to this specific series.
The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all programmes and items of a series. Therefore it is not obligatory to state the features of a series in the order. However, in an order it is indispensable to state the sum of features for an item in combination with those of the series.
All features which are assigned to one series can be chosen from a list box while entering the variation header.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute references a feature class. A feature class is defined in the element FEATURE_CLASS (path1).

path1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D positiveInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_CLASS_NO Restriction of xs:positiveInteger required
This attribute references a feature class. A feature class is defined in the element FEATURE_CLASS (path1).

path1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D positiveInteger
P
M [1:999]
Remarks

Source
<xs:element name="FEATURE_CLASS_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_CLASS_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIES_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : SERIES_NAME Element
Description
This element defines the name of the series.
Namespace (none)
Diagram
LANGUAGE Element Sequence SERIES_NAME Element
Overview
SERIES_NAME
This element defines the name of the series.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element defines a text line.
The element TEXT contains text information.
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Remarks

Source
<xs:element name="SERIES_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--3--Serienname</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>200--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element : LANGUAGE Element
Description
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
Namespace (none)
Diagram
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element defines a text line.
The element TEXT contains text information.
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Remarks

Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>200--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element : TEXT_LINE Element
Description
This element defines a text line.
The element TEXT contains text information.
Namespace (none)
Diagram
FULL_TEXT Element TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE
This element defines a text line.
The element TEXT contains text information.
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Remarks

Source
<xs:element name="TEXT_LINE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Description
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Remarks

Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FULL_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : FULL_TEXT Element
Description
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Namespace (none)
Type
xs:string
Diagram
FULL_TEXT Element
Overview
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Source
<xs:element name="FULL_TEXT" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PURCHASE_RETAIL_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : PURCHASE_RETAIL_ID Element
Description
This element is used for defining series specific purchase and retail prices
0 = purchase price
1 = retail price
Depending on the price_ID (element PRICE_ID (path1)) the price is defined as follows

price-ID = 1 (price),the value set in the element ITEM_PRICE (path2) is used

price_ID = 2 (ident number), the price is made up from the values set in element IDENT_NUMBER/PRICE (path3), element ITEM_PRICE/PRICE_MINIMUM_BASIC (path2) or in element ADDITIONAL_PRICE (path5).

price_ID = 3 (calculation point), the price made up from the settings in the elements ITEM_PRICE (path2) or PRICE_MINIMUM_BASIC multiplied with the calculation factor, defined in element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR.

According to the key, only one kind of price calculation (combination of elements VAT (path4) and PURCHASE_RETAIL_ID (path4)) may be used within one series.
If a database contains purchase prices as well as retail prices, items with purchase price may not be assigned to the same calculation group(PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP)as items with retail prices.
This element is of major significance for the correct price calculation! Purchase prices are always given as retailers' purchase prices not manufacturers' purchase prices.

element paths
path1: CATALOG/CATALOG_IDENTIFICATION/
path2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/
path3: PRICE_DEFINITION/IDENT_NUMBERS
path4: CATALOG/CATALOG_IDENTIFICATION
path5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
PURCHASE_RETAIL_ID Element
Overview
PURCHASE_RETAIL_ID Restriction of xs:boolean
This element is used for defining series specific purchase and retail prices
0 = purchase price
1 = retail price
Depending on the price_ID (element PRICE_ID (path1)) the price is defined as follows

price-ID = 1 (price),the value set in the element ITEM_PRICE (path2) is used

price_ID = 2 (ident number), the price is made up from the values set in element IDENT_NUMBER/PRICE (path3), element ITEM_PRICE/PRICE_MINIMUM_BASIC (path2) or in element ADDITIONAL_PRICE (path5).

price_ID = 3 (calculation point), the price made up from the settings in the elements ITEM_PRICE (path2) or PRICE_MINIMUM_BASIC multiplied with the calculation factor, defined in element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR.

According to the key, only one kind of price calculation (combination of elements VAT (path4) and PURCHASE_RETAIL_ID (path4)) may be used within one series.
If a database contains purchase prices as well as retail prices, items with purchase price may not be assigned to the same calculation group(PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP)as items with retail prices.
This element is of major significance for the correct price calculation! Purchase prices are always given as retailers' purchase prices not manufacturers' purchase prices.

element paths
path1: CATALOG/CATALOG_IDENTIFICATION/
path2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/
path3: PRICE_DEFINITION/IDENT_NUMBERS
path4: CATALOG/CATALOG_IDENTIFICATION
path5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP 		D boolean
P
M
Remarks

Source
<xs:element name="PURCHASE_RETAIL_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--5--EK_VK_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : RESTRICTIONS Element
Description
This element references restrictions which are specific for one series (series specific restriction).

The number of features selected in a planning is only valid, if none of the feature combinations is excluded by any of the restrictions. The result of all restrictions represents an intersection of the feature combinations.
Namespace (none)
Diagram
RESTRICTION_REF Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional
This element references restrictions which are specific for one series (series specific restriction).

The number of features selected in a planning is only valid, if none of the feature combinations is excluded by any of the restrictions. The result of all restrictions represents an intersection of the feature combinations.
Sequence
RESTRICTION_REF 0..∞
This element references a restriction which is assigned to a series (series specific restrictions).

The number of features selected in a planning is only valid, if none of the feature combinations is excluded by any of the restrictions. The result of all restrictions represents an intersection of the feature combinations.
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...) 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references series specific restrictions. D nonNegativeInteger
P
M [0:99999]
Remarks

Source
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > RESTRICTIONS Element : RESTRICTION_REF Element
Description
This element references a restriction which is assigned to a series (series specific restrictions).

The number of features selected in a planning is only valid, if none of the feature combinations is excluded by any of the restrictions. The result of all restrictions represents an intersection of the feature combinations.
Namespace (none)
Diagram
RESTRICTION_REF Element
Overview
RESTRICTION_REF 0..∞
This element references a restriction which is assigned to a series (series specific restrictions).

The number of features selected in a planning is only valid, if none of the feature combinations is excluded by any of the restrictions. The result of all restrictions represents an intersection of the feature combinations.
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...) 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references series specific restrictions. D nonNegativeInteger
P
M [0:99999]
Attributes
Name Type Use Default Fixed Description
SEQUENCE Restriction of xs:nonNegativeInteger required
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...) 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
This attribute references series specific restrictions. D nonNegativeInteger
P
M [0:99999]
Remarks

Source
<xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
RESTRICTIONS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUGGESTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : SUGGESTIONS Element
Description
This element references default settings that are applied to the series.

If the series additionally contains a standard proposal (DEFAULT_OPTION_GROUPS), the standard proposal will take priority when the planning is recorded initially.
Namespace (none)
Diagram
SUGGESTION_REF Element Sequence SUGGESTIONS Element
Overview
SUGGESTIONS optional
This element references default settings that are applied to the series.

If the series additionally contains a standard proposal (DEFAULT_OPTION_GROUPS), the standard proposal will take priority when the planning is recorded initially.
Sequence
SUGGESTION_REF 0..∞
This element references default settings that are applied to the series.

If the series additionally contains a standard proposal (DEFAULT_OPTION_GROUPS), the standard proposal will take priority when the planning is recorded initially.
SEQUENCE required Restriction of xs:nonNegativeInteger

This element is used to specify the sequence in which the assigned default values are suggested when a planning is recorded for the first time.

The numbering (SEQUENCE) determines the priorities

 D nonNegativeInteger
P
M [1:99999]
SUGGESTION_NO required Restriction of xs:nonNegativeInteger
This attribute references a set of default values. D nonNegativeInteger
P
M [0:99999]
Source
<xs:element name="SUGGESTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SUGGESTION_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SUGGESTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUGGESTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SUGGESTIONS Element : SUGGESTION_REF Element
Description
This element references default settings that are applied to the series.

If the series additionally contains a standard proposal (DEFAULT_OPTION_GROUPS), the standard proposal will take priority when the planning is recorded initially.
Namespace (none)
Diagram
SUGGESTION_REF Element
Overview
SUGGESTION_REF 0..∞
This element references default settings that are applied to the series.

If the series additionally contains a standard proposal (DEFAULT_OPTION_GROUPS), the standard proposal will take priority when the planning is recorded initially.
SEQUENCE required Restriction of xs:nonNegativeInteger

This element is used to specify the sequence in which the assigned default values are suggested when a planning is recorded for the first time.

The numbering (SEQUENCE) determines the priorities

 D nonNegativeInteger
P
M [1:99999]
SUGGESTION_NO required Restriction of xs:nonNegativeInteger
This attribute references a set of default values. D nonNegativeInteger
P
M [0:99999]
Attributes
Name Type Use Default Fixed Description
SEQUENCE Restriction of xs:nonNegativeInteger required

This element is used to specify the sequence in which the assigned default values are suggested when a planning is recorded for the first time.

The numbering (SEQUENCE) determines the priorities

 D nonNegativeInteger
P
M [1:99999]
SUGGESTION_NO Restriction of xs:nonNegativeInteger required
This attribute references a set of default values. D nonNegativeInteger
P
M [0:99999]
Source
<xs:element name="SUGGESTION_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SUGGESTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SUGGESTIONS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUPS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : PRODUCT_GROUPS Element
Description
This element is used for the definition of product groups. Product groups are used for grouping items which have the same variation types (e.g. shelves).
Namespace (none)
Diagram
PRODUCT_GROUP Element Sequence PRODUCT_GROUPS Element
Overview
PRODUCT_GROUPS
This element is used for the definition of product groups. Product groups are used for grouping items which have the same variation types (e.g. shelves).
Sequence
PRODUCT_GROUP 1..∞
This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
This element is used for defining a name for a product group.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
This element is used for assigning a feature class to a product group. It references a feature class which is defined in the element FEATURE_DEFINITION/FEATURE_CLASSES.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute identifies the referenced feature class(FEATURE_CLASS). D positiveInteger
P
M [1:999]
ITEMS
This element defines all items belonging to one product group.
Sequence
ITEM 1..∞
This element is used for the definition of items and blocks. An item is identified by the attributes SERIE_NO (path 1) and TYPE_NO (path 1)..

The elements OLD_SERIA_NO (path 1) and OLD_TYPE_NO (path 1) may only be used if the geometrical information for the referred item is exactly the same as for the current item.

If an electrical appliance is defined as an item, it is necessary to indicate the dimensions (B, H, T) of this item in the element PARAMETERS (path 3).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Sequence
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

Information can be found at:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

The code, inter alia, expresses the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D string
P [0-9]{11}
M [11:11]

NET_WEIGHT optional Restriction of xs:nonNegativeInteger

This attribute is used to specify the net weight.

The code in the previous element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]

PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) with the value 0 in the element ADDITIONAL_PRICE.

Exactly one basic price feature group has to be assigned to an item. Further price groups can be assigned in the element ADDITIONAL_PRICE_GROUP.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
This element is used for the item price and additional price information.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element references to the price field. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
PRICE_ON_REQUEST optional Restriction of xs:boolean
The use of this element indicates that the price for an item is not fixed but available upon request
. This element is used in combination with the element PRICE_CALC_METHOD.

The following values are defined:
1/true = price on request.

If this element is defined, only the value true is permitted.

This element may only be used if the item is available in different price groups.

Definition of a "price on request" for a price group of item:
The element ITEM_PRICE is defined with a corresponding price group. The value "true" is set in the element
PRICE_ON_REQUEST. The following values can be used in the element PRICE:
- value 0: information without relevance,
- a value unequal 0: reference value for the price. The exact value
has to be requested from the manufacturer.

Definition of a "price on request" for a complete item:
Element ITEM_PRICE is not defined. The attribute PRICE_CALC_METHOD (P1) in the element PRICE_FEATURE_GROUP defines, that all prices for the item have to be requested from the manufacturer. 		D boolean
P
M
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used for the definition of minimum or basic prices of an item. The prices are filled in according to their price groups (price field, PRICE_FIELD).

If the referenced price type is not depending on a basic price, a minimum price is filled in here. In all other cases a basic price is defined. If the value 0 is filled in, the item has no minimum or basic price. The value 0 does not imply that this item is free of charge.

Prices haven to be given in the smallest currency unit (e.g. 300.00 € = 30000 cent). Ident numbers are entered without decimal places. Calculation points are given with exactly two decimal places (without the comma).

If an item is not available in one price group, no data record is defined for this price group.

The basic price is always defined as a price per piece. If the flag basic price has been set, it is not permitted to assign a minimum price to that item.
According to the price calculation rules the total price of an item is made up from the given basic price and the calculated remainder price, taking into account the logic defined in the price type (P3/PRICE_TYPE_REF). Basic prices can only be defined for those items which depend at least on one dimension for the price calculation.

The total item price is calculated according to the following scheme:
The basic price unit (P5/BASIC_PRICE_UNIT) is subtracted from the total item price calculated depending on one or more dimensions. The result of this operation is the remainder. The calculation of the total item price is based on the price calculation rules in combination with the defined item price (P5/PRICE). In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0.

This element has to be defined if the price type (P3/PRICE_TYPE_REF) of the item has been defined as basic price depending.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (P1/PRICE_TYPE_REF) has been defined as basic price dependent this element is used for defining the unit for this basic price. The basic price unit depends on the number of dimensions which are set to "1" or "true".

If the price of an item depends on width and the price calculation is based on a unit of one and a half metres, the value "1500" has to be filled in here. If an item depends on volume and the basic unit is "1 m²", the value "1000000000" [mm²] is filled in.
If the price calculation of an item is a price per piece and does not depend on any dimension, the field has to be set to "0".

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 1/PRICE_TYPE.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPE
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
This element references calculation groups. Calculation groups are defined in the merchandise groups (PRICE_DEFINITION/MERCHANDISE_GROUP).
CALC_GROUP_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
This element references an exchange-ID which is defined in the element path 1/EXCHANGE_ID.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_I
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
ADDITIONAL_PRICE_GROUP 0..∞
This element references PRICE_FEATURE_GROUPS with additional price groups. The basic price feature groups which is referenced excatly one time by an item is defined in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF .

All items which reference the same PRICE_FEATURE_GROUP have also to reference the same calculation group (CALC_GROUP_REF) and exchange-ID (EXCHANGE_ID_REF).

If different price types (item prices/ surcharge prices) are assigned to an item, the following combinations are permitted:

Item | Surcharge
Price per piece | Price per piece
Price depending on length | Price depending on length
Price depending on length | Price per piece

The following combinations are NOT permitted:

Item | Surcharge
Price per piece | Price depending on length
Sequence
PRICE_FEATURE_GROUP_REF
This element references a surcharge group. Surcharge groups which are referenced here may not be used as feature groups.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a surcharge group. D positiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
This element is used for the definition of an item price.
CALC_GROUP_REF optional
This element references calculation groups. The calculation groups are defined within the merchandise groups(PRICE_DEFINITION/MERCHANDISE_GROUP).
CALC_GROUP_NO required Restriction of xs:positiveInteger
This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
The calculation group does not correspond with the suppliers scales of conditions. 		D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS. The exchange-ID references block items.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
All exchange-IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The value 0 may only be used in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 11/PRICE_TYPE.

Element paths:
path1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
RESTRICTIONS optional
This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Sequence
RESTRICTION_REF 1..∞
This element references an item to an assigned restriction.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
ADDITIONAL_ITEMS optional
This element is used for assigning additional items. A number of optional and/or mandatory additional items is defined which the user may select from in the planning process.
Sequence
OPTIONAL_ITEMS optional
This element references optional additional items. The number of optional items is not restricted. Items which are defined as linked items may not be used as additional items.
Sequence
OPTIONAL_ITEM_GROUP 1..9
This element is used for defining a group of optional additional items.
MANDATORY_ITEMS optional
This element is used for assigning mandatory additional items to a main item. For each main item the number of mandatory additional items is restricted to 1 but different groups of mandatory items may be assigned to one main item.
If only 1 additional item is assigned to a group this additional item is automatically transferred into the planning
Sequence
MANDATORY_ITEM_GROUP 1..9
This element is used for defining a group of mandatory additional items. Exactly one of these mandatory additional items has to be chosen in the course of the planning.
OPERATION_ITEM optional
This element is used for assigning items to special models, surcharges for mitres, visible sides, or cut outs. The different ways of combination are defined by the elements ITEM_REF/SCOPE (path 1) and CLASS (path 1).

Linked items may not be used as additional items.
Linked items may not be used as additional items.

The following examples illustrate the different possibilities of combination:
- Assignment of surcharges for mitres for cornices, light pelmets,plinths
- Assignment of visible sides for items (range dependent/ range independent)
- Assignment of formed pieces, returns etc. for cornices, light pelmets, plinths
- Assignment of lateral plinth to straight plinth boards
- Assignment of cut outs, tongue and groove for worktops
- Assignment of legal measurement changes, i.e. width-, height-, depth reductions.

In case special models/ items are assigned to an item in this element, only these specially defined models/ items are legal, if no assignments are explicitly defined, all special models are permitted.
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
Sequence
SCOPE 1..5
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required.
HINGE Restriction of xs:string

This element provides information about the orientation of the door hinges. No geometrical information is filled in here. All geometrical information is provided in the element CONSTRUCTION_ID.

The following codes can be used to define the door closing:
J = request for door closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = no hinge or hinges on the exterior edges (double door);
R = hinge right ;
B = corresponding with construction ID i.e. construction-ID left : hinge left;
E = opposite to construction-ID, i.e. construction-ID left : hinge right;

In case of double doors, L and R apply to both doors.

For the item identifier B (block) the placement of the items in a block corresponds to the construction_ID => value "N" is required in the field HINGE.

Values B and E are only permitted if the value "J" is filled in in the element CONSTRUCTION_ID (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
EDP_NUMBER optional Restriction of xs:string
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
EAN_NUMBER optional Restriction of xs:string
If available the EAN-code of an item is defined in this element. D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article.
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal.

 D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

This element can be used to specify the item's catalogue page in the catalogue saved as a .pdf file. This information helps to quickly find an item within the stored catalogue.

The URL of the .pdf file is stored in the DETAIL_INFO element (on catalogue level). Because some items feature on multiple pages within the catalogue, it must be assured that the information for the .pdf file is identical to the 40-digit catalogue page CATALOG_PAGE, meaning they both refer to the same page.

 D positiveInteger
P
M [1:999]
VAT_ID_REF optional
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
WEIGHT optional Restriction of xs:nonNegativeInteger

This element is used to specify the item weight (100 g) including packaging material. (e.g. 50 = 5000 g).
The code in the element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.
Contiguous parts are calculated in the basis of the gross weight per price unit.

Example:
An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
This element defines the volume of an item including packaging material. The basic unit of the volume is [dm³], e.g. a volume of 50 dm³ is entered as 50. D nonNegativeInteger
P
M [0:9999]
CONSTRUCTION_ID Restriction of xs:string
This element defines the basic carcase shape of an item.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the construction_ID. 		D string
P [JLNRAE]
M [1:1]
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
In case the item is provided by a subcontractor, the corresponding supplier number is entered in this element.

If this subcontractor item is a visible part either the elements SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO or the elements FILE_NAME_TEXTURE_1/2 have to be defined.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D nonNegativeInteger
P
M [0:9999]
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
In case the item is provided by a subcontractor (SUBCONTRACTOR_ID filled in) the corresponding supplier number is entered in this element.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D string
P
M [1:15]
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D nonNegativeInteger
P
M [0:99]
OLD_TYPE_NO optional Restriction of xs:string
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D string
P
M [1:15]
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
These elements are used to enter the file names of bitmaps for accessory textures. The files are JPEG files. Because JPEGs do not allow for an alpha channel, the RGB colour code 0,0,255 is used for masking in this case.
The elements are used depending on the value in the „CONSTRUCTION_ID“ element. The FILE_NAME_TEXTURE_1 element contains the left side illustration of the accessories, the FILE_NAME_TEXTURE_2 the right side illustration of the accessories.
CONSTRUCTION_ID = N: The texture in the „filename_texture_1" is used.
CONSTRUCTION_ID = J: There are two different options:
1. The image is mirrored along the central axle. Depending on the item, this can be the Y-axis or the Z-axis (e.g. inset sinks, cooking elements = Y and refrigerators, microwave = Z): The image showing the left side is entered in the FILE_NAME_TEXTURE_1 element.
2. The item cannot be mirrored along the central axle. The image of the left side is entered in the FILE_NAME_TEXTURE_1, while the image of the right side is entered in the FILE_NAME_TEXTURE_2 element.
CONSTRUCTION_ID = L: The value is only entered in the FILE_NAME_TEXTURE_1 element
CONSTRUCTION_ID = R: The value is only entered in the FILE_NAME_TEXTURE_2 element
The values are specified in [cccccccc.jpg] format. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
This element is used for defining a name for the texture bitmaps of accessories. JPEG is the standard file format. Since the alpha channel is not available in the JPEG-format, the RGB value 0,0,255 is used for masking.
The elements are used depending on the settings in the element "CONSTRUCTION_ID". The element FILE_NAME_TEXTURE_1 implies left-hand depiction of the accessory item and the element FILE_NAME_TEXTURE_2 is used to indicate a right-hand depiction.
CONSTRUCTION_ID = N: the texture defined in the element "FILE_NAME_TEXTURE_1" is used
CONSTRUCTION_ID = J: there are two possibilities:
1. A symmetrical item is mirrored on the centre line, which can be either y or z axis (e.g. sinks, cooking elements = Y and refrigerators, microwave ovens = Z): The left-hand depiction is entered into the element FILE_NAME_TEXTURE_1.
2. The item is not symmetrical and therefore cannot be mirrored: The depiction of the left-hand part is entered into element FILE_NAME_TEXTURE_1 and the depiction of the right-hand part is filled in into element FILE_NAME_TEXTURE_2
CONSTRUCTION_ID = L: only settings in element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: only settings in element FILE_NAME_TEXTURE_2
The general format for all settings is [cccccccc.jpg]. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
MASKING optional Restriction of xs:boolean
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
This field is of optional use, unless at least one of the elements FILE_NAME_TEXTURE_1/2is filled in. 		D boolean
P
M
MODELING_GRAPHIC_ID optional Restriction of xs:string
This element references a modeling graphic. D string
P
M [1:15]
RANGE_DEPENDENT Restriction of xs:boolean
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element defines the minimum delivery time in weeks.
This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.) 		D nonNegativeInteger
P
M [0:999]
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

This element provides information about possible alterations of an item provided by the manufacturer. Any changes of an item depend on the definitions of the basic shape in the element PARAMETERS (path 1).

0 = all measurement parameters (PARAMETERS (path 1)) are locked, changes of measurements are not possible;

1 = the measurement parameters (PARAMETERS (path 1)) may be changed according to the settings in SA500. The measurement that shall be changed is upon request;

2 = all measurement parameters (PARAMETERS (path 1)) may be changed, locked parameters require identical values in the attribute NOMINAL_VALUE (path 1), FROM (path 1) and TO (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
BASIC_PROFILE optional
This element definea the basic shape of an item.
Sequence
Choice
CARCASE_BASIC_SHAPE
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information. If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information.
If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
This element defines a basic geometrical shape for a profile. The given measurements for a profile have to correspond with the parameters of the basic profile shape.
Attributes FROM (value from) and TO (value to) are only permitted for parameter B.
This element is only permitted for the following items: cornice, light pelmet, plinth, worktop, cover board, table top, upstand.
BASIC_SHAPE_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
ITEM_DIMENSIONAL_DRAWING
This element is used for the definition of dimensional drawings. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

This element is not permitted if the element BASIC_PROFILE_SHAPE is defined. Dimensional drawings for furniture elements are not permitted.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
This element is used for the definition of a dimensional drawing. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

Even if this element is not defined at least the measurements of the bounding box (w, h, d) have to be defined in the element BASIC_PROFILES/PARAMETERS.

This element is not permitted if the element BASIC_PROFILE_SHAPE exists. This element is not permitted for furniture items, too. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
This element is used for defining a document name or reference.

Documents may contain additional technical information e.g. assembly instructions, or cut-out / drilling patterns.
If only the name of the document is given, this document has to be delivered together with the catalogue data. A document reference is given by an URI/URL.

If a document reference is defined in this element, the element NAME requires the value "23" (= document reference, cf. tables). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
BLOCK_PARTS optional
This element is used as a container element for the block parts lists in the catalogue.
Sequence
BLOCK_PART 1..∞

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2)), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
ITEM_REF

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

OPTION_REF 0..∞
This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
HINGE optional Restriction of xs:string
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
MODULE_PARTS optional

If the relevant item is a 3-D unit, this element contains a list of parts for module elements, with the first element being a base unit with position 0 followed by the module elements from the bottom upwards. This element must be left blank if the associated item is not a 3-D unit.

The 3-D unit has a fixed price. If the 3-D unit is changed, the new price will result from the price for the base unit + the price for the modules. The 3-D unit is deleted, the base unit becomes the main position and contains all other module elements as sub-positions from the bottom upwards.

The module elements can be range or version-specific.

Rules concerning the height of module elements within the base unit can be specified via MODUL_RULE_SETS. The universally defined module rule is referenced in this case.

The base unit can be assigned this kind of rule via MODULE_RULE_SET_REF.

Sequence
MODULE_PART 1..∞

This element corresponds to a partial list of parts for module elements of a 3-D unit. The elements must be specified in their order from bottom to top. Position 0 (PART_SEQUENTIAL_NO) is the empty base unit (cabinet type code 17) It is followed by the module elements from bottom to top (cabinet type key 10). The base unit hinges are identical to the hinges of the 3-D unit.

Sequence
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element is used to specify the item's position within the 3-D unit. The base unit (item type code 17) must include the position value of 0. The module elements (type code 10) contain additional position numbers sorted from bottom to top. D nonNegativeInteger
P
M [0:999]
ITEM_REF
This element is used to refer to the base unit (type code 17) and the individual module elements (type code 10).
The base unit must be assigned position (PART_SEQUENTIAL_NO) 0. The remaining module elements must be referenced in the order from the bottom to the top and in line with the PART_SEQUENTIAL_NO attribute.
HEIGHT_VARIABLE optional xs:boolean
If this flag is set to true(1), this means that the corresponding module element will contain changes relating to changes of other elements within the list. This means that if another module element becomes smaller or larger, the module element designated as true in HEIGHT_VARIABLE will adjust itself so that the total height of all module elements within the base unit is restored. D boolean
P
M
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
A module element can be variable, but the list contains a fixed height that has to be specified for variable measurements within this element. D nonNegativeInteger
P
M [1:99999]
ITEM_TEXT
This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Sequence
SHORT_TEXT
This element contains short text information.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
FULL_TEXT optional languagetexte Complex Type

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
PLANNING_ADVICE optional languagetexte60999 Complex Type
This element contains planning advices.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
TYPE_KEY
This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item.
Sequence
TK_TYPE Restriction of xs:positiveInteger
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
A value from the column item No., as listed in the Table "Type keys", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

This element is used for assigning a type key to the installation information and recess height.

SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key ", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
This element defines the combination of installation information (cf. table Installation information-key) and recess height.
TK_MATERIAL optional Restriction of xs:positiveInteger
A value from the column type, as listed in table "Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
A value from the column shape No., as listed in the table "Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
A value from the column front appearance No., as listed in the table "Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.
The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
FRONT_DIVISIONS optional
This element is used for defining the possible front divisions of an item.
Different front divisions may be related to the chosen range or built-in appliances.

Similar front divisions in different programmes may be defined in front groups. These front groups are referenced by the programmes.

All front divisions are based on the left-hand construction method. If an item is also available in right-hand construction mode, it is mirrored.If an item is also available in right-hand construction mode, it is mirrored.
Sequence
FRONT_GROUP 1..99
This element defines different front divisions and combines them in one front group.
FRONT_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database.

If one FRONT_GROUP is valid for all programmes, the value 0 has to be set. 		D positiveInteger
P
M [0:99]
Sequence
FRONT_DIVISION 1..∞
This element defines a front division and describes the single cells of the front division.
FRONT_APPEARANCE_REF optional
This element is used for assigning a front appearance to an item. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Front appearances which are assigned to this element are not dependent on a programme.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This element is used to define the relationship between the version defined in the data record and a front type. D positiveInteger
P
M
Choice optional
MODULE_RULE_SET_REF optional
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the number of the rule set which references an item to the corresponding rule set. D positiveInteger
P
M
MODULE_RULE_SETS optional
This element is used for defining a set of rules for module elements. If an item is defined as a module element (type key = 10) the rules for planning this item are defined in this element. It is only possible to define either the element MODULE_RULE_SET_REF or the element MODULE_RULE_SETS.
Sequence
MODULE_RULE_SET 1..∞
This element assigns a set of rules to a module element. The element MODULE_RULE_SET_NO references each set of rules to the related module housing element. Therefore it is possible to define different set of rules for one item depending on the selected module housing element.
Sequence
MODULE_RULES
This element defines a set of rules for the installation of single modules into a module cabinet.
MODULE_RULE_SET_REF
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
PROPERTIES optional
This element is used for summarizing the item specific characteristics.
Sequence
PROPERTY_REF 1..∞
This element references a characteristic which is defined under GLOBAL_DEFINITION/PROPERTIES.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
This attribute references a characteristic. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

This attribute defines a value for the characteristic.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
RESTRICTIONS optional
This element is used for combining all restrictions which apply to one product group.
Sequence
RESTRICTION_REF 1..∞
This element references a restriction which is assigned to a product group.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references item specific restrictions. D positiveInteger
P [0:99999]
M
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...). 		D positiveInteger
P
M [1:99999]

Remarks

Source
<xs:element name="PRODUCT_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_CLASS_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEMS">
              <xs:annotation>
                <xs:documentation>400--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECO_MOBILIER" minOccurs="0">
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[0-9]{11}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="NET_WEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                          <xs:annotation>
                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence minOccurs="0">
                              <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>450/470--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PRICE_FIELD">
                                      <xs:annotation>
                                        <xs:documentation>450--4--Preisfeld</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="250" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PRICE">
                                      <xs:annotation>
                                        <xs:documentation>450--5--Preis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:integer">
                                          <xs:minInclusive value="-99999999" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:boolean" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>470--4--Preis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:integer">
                                          <xs:minInclusive value="-99999999" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_REF">
                          <xs:annotation>
                            <xs:documentation>400/407--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="PRICE_TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400/407--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CALC_GROUP_REF">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="CALC_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="10" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRICE_FEATURE_GROUP_REF">
                                <xs:annotation>
                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>460--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PRICE_FIELD">
                                            <xs:annotation>
                                              <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="250" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PRICE">
                                            <xs:annotation>
                                              <xs:documentation>460--5--Preis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:integer">
                                                <xs:minInclusive value="-99999999" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CALC_GROUP_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="CALC_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="10" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[0-9]|[1-8][0-9]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_TYPE_REF">
                                <xs:annotation>
                                  <xs:documentation>407--5--Preisart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="PRICE_TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>407--5--Preisart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="RESTRICTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>409--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>409--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="RESTRICTION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>409--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>409--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:maxInclusive value="99999" />
                                        <xs:minInclusive value="1" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>406--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>120--0--NEW</xs:documentation>
                                                  <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                <xs:annotation>
                                                  <xs:documentation>406--7--Anzahl</xs:documentation>
                                                  <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SEQUENCE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>Version 2.4.1</xs:documentation>
                                                  <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:maxInclusive value="99999" />
                                                    <xs:minInclusive value="1" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SET_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>120--0--NEW</xs:documentation>
                                                  <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                <xs:annotation>
                                                  <xs:documentation>406--7--Anzahl</xs:documentation>
                                                  <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SEQUENCE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>Version 2.4.1</xs:documentation>
                                                  <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:maxInclusive value="99999" />
                                                    <xs:minInclusive value="1" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SET_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPERATION_ITEM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="SCOPE" maxOccurs="5">
                                      <xs:annotation>
                                        <xs:documentation>411--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>411--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="CLASS">
                                                  <xs:annotation>
                                                    <xs:documentation>411--7--Art</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="21" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>411--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>411--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[LNR]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="COVER" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--9--Abdeckung</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="3" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="VALUE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--10--Wert</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="VALUE_MIN" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                                    <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="VALUE_MAX" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                                    <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SCOPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>411--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="5" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="HINGE">
                          <xs:annotation>
                            <xs:documentation>400--4--Anschlag</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[BEJLMNR]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EDP_NUMBER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EAN_NUMBER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_IDENTIFICATION">
                          <xs:annotation>
                            <xs:documentation>400--14--Artikelkennung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[BEKSMZVPNOG]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="CATALOG_PAGE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="40" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
                            <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
                            <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VAT_ID_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="VAT_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="WEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--20--Gewicht</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VOLUME" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--21--Volumen</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="CONSTRUCTION_ID">
                          <xs:annotation>
                            <xs:documentation>400--23--Bauweise_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[JLNRAE]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OLD_SERIE_NO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OLD_TYPE_NO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--27--Type_Alt</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MASKING" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--30--Maskierung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="RANGE_DEPENDENT">
                          <xs:annotation>
                            <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="2" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_PROFILE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:choice>
                                <xs:element name="CARCASE_BASIC_SHAPE">
                                  <xs:annotation>
                                    <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>400--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType mixed="true">
                                          <xs:sequence>
                                            <xs:element name="OPTION_REF">
                                              <xs:annotation>
                                                <xs:documentation>430--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:attribute name="FEATURE_NO" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>430--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="OPTION_KEY" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>430--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="5" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                          <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[\S ]{1,5}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="BASIC_SHAPE_PARAMETERS">
                                        <xs:annotation>
                                          <xs:documentation>500--1--Satzart</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                              <xs:annotation>
                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--Parameter</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>500--5--Nennwert</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="BASIC_SHAPE_FROM">
                                                  <xs:annotation>
                                                    <xs:documentation>500--6--Von</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="BASIC_SHAPE_TO">
                                                  <xs:annotation>
                                                    <xs:documentation>500--7--Bis</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                  <xs:annotation>
                                                    <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                    <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                  <xs:annotation>
                                    <xs:documentation>400--32--Massbild</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:minLength value="1" />
                                            <xs:maxLength value="240" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="DIMENSIONAL_PARAMETERS">
                                        <xs:annotation>
                                          <xs:documentation>500--1--Satzart</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                              <xs:annotation>
                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="DIMENSIONAL_FROM">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="DIMENSIONAL_TO">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                    <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>400--32--Massbild</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="20" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:choice>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="BLOCK_PARTS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="BLOCK_SEQUENTIAL_NO">
                                      <xs:annotation>
                                        <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="5" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="HINGE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--6--Anschlag</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[BEJLMNR]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="EXCHANGE_CONDITION">
                                      <xs:annotation>
                                        <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="2" />
                                          <xs:maxInclusive value="3" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="STATUS">
                                      <xs:annotation>
                                        <xs:documentation>401--8--Status</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[ABELSZ]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[JLNRAE]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="MODULE_PARTS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="MODULE_PART" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PART_SEQUENTIAL_NO">
                                      <xs:annotation>
                                        <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:maxInclusive value="999" />
                                          <xs:minInclusive value="0" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_TEXT">
                          <xs:annotation>
                            <xs:documentation>410--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="SHORT_TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TEXT_LINE" maxOccurs="3">
                                            <xs:annotation>
                                              <xs:documentation>410--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TEXT">
                                                  <xs:annotation>
                                                    <xs:documentation>410--6--Textzeile</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[\S ]{1,30}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SEQUENCE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger" />
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:language">
                                              <xs:pattern value="[A-Z]{2}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TYPE_KEY">
                          <xs:annotation>
                            <xs:documentation>445--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TK_TYPE">
                                <xs:annotation>
                                  <xs:documentation>445--4--TS_Typ</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_CLASS">
                                <xs:annotation>
                                  <xs:documentation>445--5--TS_Art</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                <xs:annotation>
                                  <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                    <xs:annotation>
                                      <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="TK_MATERIAL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--21--TS_Material</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-2]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_SHAPE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--22--TS_Form</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-2]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CLASSIFICATIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECLASS">
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECLASS_NO">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:totalDigits value="8" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FRONT_DIVISIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>510--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_GROUP" maxOccurs="99">
                                <xs:annotation>
                                  <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="FRONT_DIVISION_DEF">
                                            <xs:annotation>
                                              <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="250" />
                                                <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="FRONT_CELL_NO">
                                                  <xs:annotation>
                                                    <xs:documentation>540--6--Zellennummer</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="FRONT_TYPE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--7--Fronttyp</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="900" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="4" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="4" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PARAMETER_1" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--12--Parameter_1</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PARAMETER_2" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--13--Parameter_2</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="9999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="9999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="4" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="UPPER_JOIN" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[VLSG]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="LOWER_JOIN" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[VLSG]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="LEFT_JOIN" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[VLSG]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="RIGHT_JOIN" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[VLSG]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="2" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="FRONT_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:choice minOccurs="0">
                          <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MODULE_RULE_SETS" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="MODULE_RULES">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="MODULE_POSITION">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                                        <xs:enumeration value="LINE_BOTTOM" />
                                                        <xs:enumeration value="LINE_TOP" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:element>
                                                  <xs:element name="MAX_VALUE" minOccurs="0">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="0" />
                                                        <xs:maxInclusive value="99999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:element>
                                                  <xs:element name="MIN_VALUE" minOccurs="0">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="0" />
                                                        <xs:maxInclusive value="99999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:element>
                                                </xs:sequence>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MODULE_RULE_SET_REF">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PROPERTIES" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="PROPERTY_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="VALUE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:maxInclusive value="99999" />
                            <xs:minInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element : PRODUCT_GROUP Element
Description
This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.
Namespace (none)
Diagram
RESTRICTIONS Element ITEMS Element FEATURE_CLASS_REF Element LANGUAGE Element Sequence PRODUCT_GROUP_TEXT Element Sequence PRODUCT_GROUP Element
Overview
PRODUCT_GROUP 1..∞
This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
This element is used for defining a name for a product group.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
This element is used for assigning a feature class to a product group. It references a feature class which is defined in the element FEATURE_DEFINITION/FEATURE_CLASSES.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute identifies the referenced feature class(FEATURE_CLASS). D positiveInteger
P
M [1:999]
ITEMS
This element defines all items belonging to one product group.
Sequence
ITEM 1..∞
This element is used for the definition of items and blocks. An item is identified by the attributes SERIE_NO (path 1) and TYPE_NO (path 1)..

The elements OLD_SERIA_NO (path 1) and OLD_TYPE_NO (path 1) may only be used if the geometrical information for the referred item is exactly the same as for the current item.

If an electrical appliance is defined as an item, it is necessary to indicate the dimensions (B, H, T) of this item in the element PARAMETERS (path 3).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Sequence
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

Information can be found at:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

The code, inter alia, expresses the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D string
P [0-9]{11}
M [11:11]

NET_WEIGHT optional Restriction of xs:nonNegativeInteger

This attribute is used to specify the net weight.

The code in the previous element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]

PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) with the value 0 in the element ADDITIONAL_PRICE.

Exactly one basic price feature group has to be assigned to an item. Further price groups can be assigned in the element ADDITIONAL_PRICE_GROUP.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
This element is used for the item price and additional price information.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element references to the price field. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
PRICE_ON_REQUEST optional Restriction of xs:boolean
The use of this element indicates that the price for an item is not fixed but available upon request
. This element is used in combination with the element PRICE_CALC_METHOD.

The following values are defined:
1/true = price on request.

If this element is defined, only the value true is permitted.

This element may only be used if the item is available in different price groups.

Definition of a "price on request" for a price group of item:
The element ITEM_PRICE is defined with a corresponding price group. The value "true" is set in the element
PRICE_ON_REQUEST. The following values can be used in the element PRICE:
- value 0: information without relevance,
- a value unequal 0: reference value for the price. The exact value
has to be requested from the manufacturer.

Definition of a "price on request" for a complete item:
Element ITEM_PRICE is not defined. The attribute PRICE_CALC_METHOD (P1) in the element PRICE_FEATURE_GROUP defines, that all prices for the item have to be requested from the manufacturer. 		D boolean
P
M
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used for the definition of minimum or basic prices of an item. The prices are filled in according to their price groups (price field, PRICE_FIELD).

If the referenced price type is not depending on a basic price, a minimum price is filled in here. In all other cases a basic price is defined. If the value 0 is filled in, the item has no minimum or basic price. The value 0 does not imply that this item is free of charge.

Prices haven to be given in the smallest currency unit (e.g. 300.00 € = 30000 cent). Ident numbers are entered without decimal places. Calculation points are given with exactly two decimal places (without the comma).

If an item is not available in one price group, no data record is defined for this price group.

The basic price is always defined as a price per piece. If the flag basic price has been set, it is not permitted to assign a minimum price to that item.
According to the price calculation rules the total price of an item is made up from the given basic price and the calculated remainder price, taking into account the logic defined in the price type (P3/PRICE_TYPE_REF). Basic prices can only be defined for those items which depend at least on one dimension for the price calculation.

The total item price is calculated according to the following scheme:
The basic price unit (P5/BASIC_PRICE_UNIT) is subtracted from the total item price calculated depending on one or more dimensions. The result of this operation is the remainder. The calculation of the total item price is based on the price calculation rules in combination with the defined item price (P5/PRICE). In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0.

This element has to be defined if the price type (P3/PRICE_TYPE_REF) of the item has been defined as basic price depending.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (P1/PRICE_TYPE_REF) has been defined as basic price dependent this element is used for defining the unit for this basic price. The basic price unit depends on the number of dimensions which are set to "1" or "true".

If the price of an item depends on width and the price calculation is based on a unit of one and a half metres, the value "1500" has to be filled in here. If an item depends on volume and the basic unit is "1 m²", the value "1000000000" [mm²] is filled in.
If the price calculation of an item is a price per piece and does not depend on any dimension, the field has to be set to "0".

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 1/PRICE_TYPE.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPE
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
This element references calculation groups. Calculation groups are defined in the merchandise groups (PRICE_DEFINITION/MERCHANDISE_GROUP).
CALC_GROUP_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
This element references an exchange-ID which is defined in the element path 1/EXCHANGE_ID.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_I
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
ADDITIONAL_PRICE_GROUP 0..∞
This element references PRICE_FEATURE_GROUPS with additional price groups. The basic price feature groups which is referenced excatly one time by an item is defined in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF .

All items which reference the same PRICE_FEATURE_GROUP have also to reference the same calculation group (CALC_GROUP_REF) and exchange-ID (EXCHANGE_ID_REF).

If different price types (item prices/ surcharge prices) are assigned to an item, the following combinations are permitted:

Item | Surcharge
Price per piece | Price per piece
Price depending on length | Price depending on length
Price depending on length | Price per piece

The following combinations are NOT permitted:

Item | Surcharge
Price per piece | Price depending on length
Sequence
PRICE_FEATURE_GROUP_REF
This element references a surcharge group. Surcharge groups which are referenced here may not be used as feature groups.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a surcharge group. D positiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
This element is used for the definition of an item price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element references a price group. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
The prices are filled in according to the price groups of an item (price field). Prices have to be defined in the smallest currency unit (e.g. instead of 300,00 [€], 30000 [Cent]). Fields may also contain negative prices. These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(Example: field with 9 digits; the figure minus 9,00 € shall be filled in : -900) 		D integer
P
M [-99999999:999999999]
CALC_GROUP_REF optional
This element references calculation groups. The calculation groups are defined within the merchandise groups(PRICE_DEFINITION/MERCHANDISE_GROUP).
CALC_GROUP_NO required Restriction of xs:positiveInteger
This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
The calculation group does not correspond with the suppliers scales of conditions. 		D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS. The exchange-ID references block items.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
All exchange-IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The value 0 may only be used in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 11/PRICE_TYPE.

Element paths:
path1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
RESTRICTIONS optional
This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Sequence
RESTRICTION_REF 1..∞
This element references an item to an assigned restriction.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
ADDITIONAL_ITEMS optional
This element is used for assigning additional items. A number of optional and/or mandatory additional items is defined which the user may select from in the planning process.
Sequence
OPTIONAL_ITEMS optional
This element references optional additional items. The number of optional items is not restricted. Items which are defined as linked items may not be used as additional items.
Sequence
OPTIONAL_ITEM_GROUP 1..9
This element is used for defining a group of optional additional items.
SET_NO required Restriction of xs:positiveInteger
A certain number of optional items is available for the main item. In case the field MULTIPLE_CHOICE is set to "true", different optional items can be selected from the total number of available options. If the number of optional items is limited to one, this optional item is selected automatically.
1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
This attribute defines if mulitple optional items are available for a main item.

true = multiple selection permitted 		D boolean
P
M
Sequence
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
ITEM_REF 1..∞
This element references an optional additional item.
MANDATORY_ITEMS optional
This element is used for assigning mandatory additional items to a main item. For each main item the number of mandatory additional items is restricted to 1 but different groups of mandatory items may be assigned to one main item.
If only 1 additional item is assigned to a group this additional item is automatically transferred into the planning
Sequence
MANDATORY_ITEM_GROUP 1..9
This element is used for defining a group of mandatory additional items. Exactly one of these mandatory additional items has to be chosen in the course of the planning.
SET_NO required Restriction of xs:positiveInteger
A number of mandatory additional items can be defined for one main item. Exactly one item has to be selected from this group of mandatory additional items. If only 1 mandatory additional item is assigned to a group this additional item is automatically selected in the planning.

1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
Sequence
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
ITEM_REF 1..∞
This element references an item
OPERATION_ITEM optional
This element is used for assigning items to special models, surcharges for mitres, visible sides, or cut outs. The different ways of combination are defined by the elements ITEM_REF/SCOPE (path 1) and CLASS (path 1).

Linked items may not be used as additional items.
Linked items may not be used as additional items.

The following examples illustrate the different possibilities of combination:
- Assignment of surcharges for mitres for cornices, light pelmets,plinths
- Assignment of visible sides for items (range dependent/ range independent)
- Assignment of formed pieces, returns etc. for cornices, light pelmets, plinths
- Assignment of lateral plinth to straight plinth boards
- Assignment of cut outs, tongue and groove for worktops
- Assignment of legal measurement changes, i.e. width-, height-, depth reductions.

In case special models/ items are assigned to an item in this element, only these specially defined models/ items are legal, if no assignments are explicitly defined, all special models are permitted.
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
Sequence
SCOPE 1..5
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required.
SCOPE_NO required Restriction of xs:positiveInteger
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required. 		D positiveInteger
P
M [1:5]
Sequence
ITEM_INFORMATION 1..∞
This element contains all information referring to the scope of an item (e.g. type, plinth, cornice, light pelmet, worktop).
HINGE Restriction of xs:string

This element provides information about the orientation of the door hinges. No geometrical information is filled in here. All geometrical information is provided in the element CONSTRUCTION_ID.

The following codes can be used to define the door closing:
J = request for door closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = no hinge or hinges on the exterior edges (double door);
R = hinge right ;
B = corresponding with construction ID i.e. construction-ID left : hinge left;
E = opposite to construction-ID, i.e. construction-ID left : hinge right;

In case of double doors, L and R apply to both doors.

For the item identifier B (block) the placement of the items in a block corresponds to the construction_ID => value "N" is required in the field HINGE.

Values B and E are only permitted if the value "J" is filled in in the element CONSTRUCTION_ID (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
EDP_NUMBER optional Restriction of xs:string
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
EAN_NUMBER optional Restriction of xs:string
If available the EAN-code of an item is defined in this element. D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article.
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal.

 D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

This element can be used to specify the item's catalogue page in the catalogue saved as a .pdf file. This information helps to quickly find an item within the stored catalogue.

The URL of the .pdf file is stored in the DETAIL_INFO element (on catalogue level). Because some items feature on multiple pages within the catalogue, it must be assured that the information for the .pdf file is identical to the 40-digit catalogue page CATALOG_PAGE, meaning they both refer to the same page.

 D positiveInteger
P
M [1:999]
VAT_ID_REF optional
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
WEIGHT optional Restriction of xs:nonNegativeInteger

This element is used to specify the item weight (100 g) including packaging material. (e.g. 50 = 5000 g).
The code in the element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.
Contiguous parts are calculated in the basis of the gross weight per price unit.

Example:
An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
This element defines the volume of an item including packaging material. The basic unit of the volume is [dm³], e.g. a volume of 50 dm³ is entered as 50. D nonNegativeInteger
P
M [0:9999]
CONSTRUCTION_ID Restriction of xs:string
This element defines the basic carcase shape of an item.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the construction_ID. 		D string
P [JLNRAE]
M [1:1]
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
In case the item is provided by a subcontractor, the corresponding supplier number is entered in this element.

If this subcontractor item is a visible part either the elements SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO or the elements FILE_NAME_TEXTURE_1/2 have to be defined.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D nonNegativeInteger
P
M [0:9999]
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
In case the item is provided by a subcontractor (SUBCONTRACTOR_ID filled in) the corresponding supplier number is entered in this element.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D string
P
M [1:15]
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D nonNegativeInteger
P
M [0:99]
OLD_TYPE_NO optional Restriction of xs:string
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D string
P
M [1:15]
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
These elements are used to enter the file names of bitmaps for accessory textures. The files are JPEG files. Because JPEGs do not allow for an alpha channel, the RGB colour code 0,0,255 is used for masking in this case.
The elements are used depending on the value in the „CONSTRUCTION_ID“ element. The FILE_NAME_TEXTURE_1 element contains the left side illustration of the accessories, the FILE_NAME_TEXTURE_2 the right side illustration of the accessories.
CONSTRUCTION_ID = N: The texture in the „filename_texture_1" is used.
CONSTRUCTION_ID = J: There are two different options:
1. The image is mirrored along the central axle. Depending on the item, this can be the Y-axis or the Z-axis (e.g. inset sinks, cooking elements = Y and refrigerators, microwave = Z): The image showing the left side is entered in the FILE_NAME_TEXTURE_1 element.
2. The item cannot be mirrored along the central axle. The image of the left side is entered in the FILE_NAME_TEXTURE_1, while the image of the right side is entered in the FILE_NAME_TEXTURE_2 element.
CONSTRUCTION_ID = L: The value is only entered in the FILE_NAME_TEXTURE_1 element
CONSTRUCTION_ID = R: The value is only entered in the FILE_NAME_TEXTURE_2 element
The values are specified in [cccccccc.jpg] format. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
This element is used for defining a name for the texture bitmaps of accessories. JPEG is the standard file format. Since the alpha channel is not available in the JPEG-format, the RGB value 0,0,255 is used for masking.
The elements are used depending on the settings in the element "CONSTRUCTION_ID". The element FILE_NAME_TEXTURE_1 implies left-hand depiction of the accessory item and the element FILE_NAME_TEXTURE_2 is used to indicate a right-hand depiction.
CONSTRUCTION_ID = N: the texture defined in the element "FILE_NAME_TEXTURE_1" is used
CONSTRUCTION_ID = J: there are two possibilities:
1. A symmetrical item is mirrored on the centre line, which can be either y or z axis (e.g. sinks, cooking elements = Y and refrigerators, microwave ovens = Z): The left-hand depiction is entered into the element FILE_NAME_TEXTURE_1.
2. The item is not symmetrical and therefore cannot be mirrored: The depiction of the left-hand part is entered into element FILE_NAME_TEXTURE_1 and the depiction of the right-hand part is filled in into element FILE_NAME_TEXTURE_2
CONSTRUCTION_ID = L: only settings in element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: only settings in element FILE_NAME_TEXTURE_2
The general format for all settings is [cccccccc.jpg]. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
MASKING optional Restriction of xs:boolean
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
This field is of optional use, unless at least one of the elements FILE_NAME_TEXTURE_1/2is filled in. 		D boolean
P
M
MODELING_GRAPHIC_ID optional Restriction of xs:string
This element references a modeling graphic. D string
P
M [1:15]
RANGE_DEPENDENT Restriction of xs:boolean
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element defines the minimum delivery time in weeks.
This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.) 		D nonNegativeInteger
P
M [0:999]
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

This element provides information about possible alterations of an item provided by the manufacturer. Any changes of an item depend on the definitions of the basic shape in the element PARAMETERS (path 1).

0 = all measurement parameters (PARAMETERS (path 1)) are locked, changes of measurements are not possible;

1 = the measurement parameters (PARAMETERS (path 1)) may be changed according to the settings in SA500. The measurement that shall be changed is upon request;

2 = all measurement parameters (PARAMETERS (path 1)) may be changed, locked parameters require identical values in the attribute NOMINAL_VALUE (path 1), FROM (path 1) and TO (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
BASIC_PROFILE optional
This element definea the basic shape of an item.
Sequence
Choice
CARCASE_BASIC_SHAPE
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information. If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information.
If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
This element defines a basic geometrical shape for a profile. The given measurements for a profile have to correspond with the parameters of the basic profile shape.
Attributes FROM (value from) and TO (value to) are only permitted for parameter B.
This element is only permitted for the following items: cornice, light pelmet, plinth, worktop, cover board, table top, upstand.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
This element defines the number of the basic shape for a profile. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
This element defines the option type and the option key of a profile shape.
The manufacturer specific key for the profile shape as indicated in the printed sales manual is used as OPTION_KEY.
Only the options types 750-756 are permitted in the element BASIC_PROFILE_SHAPE/OPTION_REF.
BASIC_SHAPE_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.

Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
ITEM_DIMENSIONAL_DRAWING
This element is used for the definition of dimensional drawings. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

This element is not permitted if the element BASIC_PROFILE_SHAPE is defined. Dimensional drawings for furniture elements are not permitted.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
This element is used for the definition of a dimensional drawing. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

Even if this element is not defined at least the measurements of the bounding box (w, h, d) have to be defined in the element BASIC_PROFILES/PARAMETERS.

This element is not permitted if the element BASIC_PROFILE_SHAPE exists. This element is not permitted for furniture items, too. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
This element is used for defining a document name or reference.

Documents may contain additional technical information e.g. assembly instructions, or cut-out / drilling patterns.
If only the name of the document is given, this document has to be delivered together with the catalogue data. A document reference is given by an URI/URL.

If a document reference is defined in this element, the element NAME requires the value "23" (= document reference, cf. tables). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Sequence
DIMENSIONAL_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.
BLOCK_PARTS optional
This element is used as a container element for the block parts lists in the catalogue.
Sequence
BLOCK_PART 1..∞

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2)), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
ITEM_REF

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞
This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the feature which is referenced by a option.
Each FEATURE_NO may exist only one time in the database. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references a option. D string
P
M [1:5]
HINGE optional Restriction of xs:string
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
MODULE_PARTS optional

If the relevant item is a 3-D unit, this element contains a list of parts for module elements, with the first element being a base unit with position 0 followed by the module elements from the bottom upwards. This element must be left blank if the associated item is not a 3-D unit.

The 3-D unit has a fixed price. If the 3-D unit is changed, the new price will result from the price for the base unit + the price for the modules. The 3-D unit is deleted, the base unit becomes the main position and contains all other module elements as sub-positions from the bottom upwards.

The module elements can be range or version-specific.

Rules concerning the height of module elements within the base unit can be specified via MODUL_RULE_SETS. The universally defined module rule is referenced in this case.

The base unit can be assigned this kind of rule via MODULE_RULE_SET_REF.

Sequence
MODULE_PART 1..∞

This element corresponds to a partial list of parts for module elements of a 3-D unit. The elements must be specified in their order from bottom to top. Position 0 (PART_SEQUENTIAL_NO) is the empty base unit (cabinet type code 17) It is followed by the module elements from bottom to top (cabinet type key 10). The base unit hinges are identical to the hinges of the 3-D unit.

Sequence
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element is used to specify the item's position within the 3-D unit. The base unit (item type code 17) must include the position value of 0. The module elements (type code 10) contain additional position numbers sorted from bottom to top. D nonNegativeInteger
P
M [0:999]
ITEM_REF
This element is used to refer to the base unit (type code 17) and the individual module elements (type code 10).
The base unit must be assigned position (PART_SEQUENTIAL_NO) 0. The remaining module elements must be referenced in the order from the bottom to the top and in line with the PART_SEQUENTIAL_NO attribute.
TYPE_NO required Restriction of xs:string
This element is used to specify the item type. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
HEIGHT_VARIABLE optional xs:boolean
If this flag is set to true(1), this means that the corresponding module element will contain changes relating to changes of other elements within the list. This means that if another module element becomes smaller or larger, the module element designated as true in HEIGHT_VARIABLE will adjust itself so that the total height of all module elements within the base unit is restored. D boolean
P
M
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
A module element can be variable, but the list contains a fixed height that has to be specified for variable measurements within this element. D nonNegativeInteger
P
M [1:99999]
ITEM_TEXT
This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Sequence
SHORT_TEXT
This element contains short text information.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
FULL_TEXT optional languagetexte Complex Type

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
This element contains planning advices.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
TYPE_KEY
This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item.
Sequence
TK_TYPE Restriction of xs:positiveInteger
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
A value from the column item No., as listed in the Table "Type keys", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

This element is used for assigning a type key to the installation information and recess height.

SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key ", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
This element defines the combination of installation information (cf. table Installation information-key) and recess height.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
A value from the column installation information, as listed in table "Installation information-key", is required in this field. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
A value from the column type, as listed in table "Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
A value from the column shape No., as listed in the table "Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
A value from the column front appearance No., as listed in the table "Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.
The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
FRONT_DIVISIONS optional
This element is used for defining the possible front divisions of an item.
Different front divisions may be related to the chosen range or built-in appliances.

Similar front divisions in different programmes may be defined in front groups. These front groups are referenced by the programmes.

All front divisions are based on the left-hand construction method. If an item is also available in right-hand construction mode, it is mirrored.If an item is also available in right-hand construction mode, it is mirrored.
Sequence
FRONT_GROUP 1..99
This element defines different front divisions and combines them in one front group.
FRONT_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database.

If one FRONT_GROUP is valid for all programmes, the value 0 has to be set. 		D positiveInteger
P
M [0:99]
Sequence
FRONT_DIVISION 1..∞
This element defines a front division and describes the single cells of the front division.
Sequence
FRONT_DIVISION_DEF Restriction of xs:string
For the definition of the front division the syntax rules provided in the attachment apply. These syntax rules are not used for the description of front divisions for shelves. Shelves are defined as a separate front cell (cf. FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
INTERNAL_ORDER_NO optional Restriction of xs:string
For items which have different front divisions and only one order number in the catalogue, internal order numbers for the different front divisions are entered in this field. D string
P
M [1:15]
FRONT_CELL 1..∞
This element defines the single cells of a front division.
FRONT_APPEARANCE_REF optional
This element is used for assigning a front appearance to an item. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Front appearances which are assigned to this element are not dependent on a programme.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This element is used to define the relationship between the version defined in the data record and a front type. D positiveInteger
P
M
Choice optional
MODULE_RULE_SET_REF optional
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the number of the rule set which references an item to the corresponding rule set. D positiveInteger
P
M
MODULE_RULE_SETS optional
This element is used for defining a set of rules for module elements. If an item is defined as a module element (type key = 10) the rules for planning this item are defined in this element. It is only possible to define either the element MODULE_RULE_SET_REF or the element MODULE_RULE_SETS.
Sequence
MODULE_RULE_SET 1..∞
This element assigns a set of rules to a module element. The element MODULE_RULE_SET_NO references each set of rules to the related module housing element. Therefore it is possible to define different set of rules for one item depending on the selected module housing element.
Sequence
MODULE_RULES
This element defines a set of rules for the installation of single modules into a module cabinet.
Sequence
MODULE_RULE 1..∞
A rule for the installation of a module into a module cabinet.
This rule defines whether the installation of a module element into the selected module housing element is permitted or not.

Type key 10 is required for module elements.
MODULE_RULE_SET_REF
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the reference between the rule set and the MODULE_RULE_SET_DEFINITION and the related module housing units. D nonNegativeInteger
P
M
DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
PROPERTIES optional
This element is used for summarizing the item specific characteristics.
Sequence
PROPERTY_REF 1..∞
This element references a characteristic which is defined under GLOBAL_DEFINITION/PROPERTIES.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
This attribute references a characteristic. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

This attribute defines a value for the characteristic.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
RESTRICTIONS optional
This element is used for combining all restrictions which apply to one product group.
Sequence
RESTRICTION_REF 1..∞
This element references a restriction which is assigned to a product group.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references item specific restrictions. D positiveInteger
P [0:99999]
M
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...). 		D positiveInteger
P
M [1:99999]

Remarks

Source
<xs:element name="PRODUCT_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_CLASS_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEMS">
        <xs:annotation>
          <xs:documentation>400--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECO_MOBILIER" minOccurs="0">
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[0-9]{11}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="NET_WEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                    <xs:annotation>
                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence minOccurs="0">
                        <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>450/470--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRICE_FIELD">
                                <xs:annotation>
                                  <xs:documentation>450--4--Preisfeld</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PRICE">
                                <xs:annotation>
                                  <xs:documentation>450--5--Preis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:integer">
                                    <xs:minInclusive value="-99999999" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:boolean" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>470--4--Preis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:integer">
                                    <xs:minInclusive value="-99999999" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_REF">
                    <xs:annotation>
                      <xs:documentation>400/407--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400/407--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CALC_GROUP_REF">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="CALC_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="10" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FEATURE_GROUP_REF">
                          <xs:annotation>
                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>460--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PRICE_FIELD">
                                      <xs:annotation>
                                        <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="250" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PRICE">
                                      <xs:annotation>
                                        <xs:documentation>460--5--Preis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:integer">
                                          <xs:minInclusive value="-99999999" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CALC_GROUP_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="CALC_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="10" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>407--7--Tausch_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_REF">
                          <xs:annotation>
                            <xs:documentation>407--5--Preisart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="PRICE_TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>407--5--Preisart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RESTRICTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>409--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>409--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="RESTRICTION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>409--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>409--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:maxInclusive value="99999" />
                                  <xs:minInclusive value="1" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>406--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="GROUP_TITLE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>120--0--NEW</xs:documentation>
                                            <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                          <xs:annotation>
                                            <xs:documentation>406--7--Anzahl</xs:documentation>
                                            <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>Version 2.4.1</xs:documentation>
                                            <xs:documentation>geändert 13.09.2016</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:maxInclusive value="99999" />
                                              <xs:minInclusive value="1" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SET_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="GROUP_TITLE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>120--0--NEW</xs:documentation>
                                            <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                          <xs:annotation>
                                            <xs:documentation>406--7--Anzahl</xs:documentation>
                                            <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>Version 2.4.1</xs:documentation>
                                            <xs:documentation>geändert 13.09.2016</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:maxInclusive value="99999" />
                                              <xs:minInclusive value="1" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SET_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPERATION_ITEM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="SCOPE" maxOccurs="5">
                                <xs:annotation>
                                  <xs:documentation>411--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>411--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="CLASS">
                                            <xs:annotation>
                                              <xs:documentation>411--7--Art</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="21" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>411--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>411--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[LNR]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="COVER" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--9--Abdeckung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="3" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VALUE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--10--Wert</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VALUE_MIN" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                              <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VALUE_MAX" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                              <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SCOPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>411--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HINGE">
                    <xs:annotation>
                      <xs:documentation>400--4--Anschlag</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[BEJLMNR]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDP_NUMBER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EAN_NUMBER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_IDENTIFICATION">
                    <xs:annotation>
                      <xs:documentation>400--14--Artikelkennung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[BEKSMZVPNOG]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CATALOG_PAGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="40" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
                      <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
                      <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VAT_ID_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="VAT_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="WEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--20--Gewicht</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VOLUME" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--21--Volumen</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONSTRUCTION_ID">
                    <xs:annotation>
                      <xs:documentation>400--23--Bauweise_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[JLNRAE]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OLD_SERIE_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OLD_TYPE_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--27--Type_Alt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MASKING" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--30--Maskierung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="RANGE_DEPENDENT">
                    <xs:annotation>
                      <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_PROFILE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:choice>
                          <xs:element name="CARCASE_BASIC_SHAPE">
                            <xs:annotation>
                              <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>400--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType mixed="true">
                                    <xs:sequence>
                                      <xs:element name="OPTION_REF">
                                        <xs:annotation>
                                          <xs:documentation>430--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="FEATURE_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>430--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPTION_KEY" use="required">
                                            <xs:annotation>
                                              <xs:documentation>430--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="5" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                    <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,5}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="BASIC_SHAPE_PARAMETERS">
                                  <xs:annotation>
                                    <xs:documentation>500--1--Satzart</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                        <xs:annotation>
                                          <xs:documentation>500--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                            <xs:annotation>
                                              <xs:documentation>500--0--Parameter</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                            <xs:annotation>
                                              <xs:documentation>500--5--Nennwert</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="BASIC_SHAPE_FROM">
                                            <xs:annotation>
                                              <xs:documentation>500--6--Von</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="BASIC_SHAPE_TO">
                                            <xs:annotation>
                                              <xs:documentation>500--7--Bis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                            <xs:annotation>
                                              <xs:documentation>500--8--Schrittweite</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                            <xs:annotation>
                              <xs:documentation>400--32--Massbild</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:minLength value="1" />
                                      <xs:maxLength value="240" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="DIMENSIONAL_PARAMETERS">
                                  <xs:annotation>
                                    <xs:documentation>500--1--Satzart</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                        <xs:annotation>
                                          <xs:documentation>500--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="DIMENSIONAL_FROM">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="DIMENSIONAL_TO">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>400--32--Massbild</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="20" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="BLOCK_PARTS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="BLOCK_SEQUENTIAL_NO">
                                <xs:annotation>
                                  <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="ITEM_REF">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="HINGE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--6--Anschlag</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[BEJLMNR]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="EXCHANGE_CONDITION">
                                <xs:annotation>
                                  <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="2" />
                                    <xs:maxInclusive value="3" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="STATUS">
                                <xs:annotation>
                                  <xs:documentation>401--8--Status</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[ABELSZ]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[JLNRAE]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="MODULE_PARTS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MODULE_PART" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PART_SEQUENTIAL_NO">
                                <xs:annotation>
                                  <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:maxInclusive value="999" />
                                    <xs:minInclusive value="0" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="ITEM_REF">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_TEXT">
                    <xs:annotation>
                      <xs:documentation>410--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SHORT_TEXT">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT_LINE" maxOccurs="3">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--6--Textzeile</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[\S ]{1,30}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TYPE_KEY">
                    <xs:annotation>
                      <xs:documentation>445--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TK_TYPE">
                          <xs:annotation>
                            <xs:documentation>445--4--TS_Typ</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_CLASS">
                          <xs:annotation>
                            <xs:documentation>445--5--TS_Art</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                          <xs:annotation>
                            <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SEQUENCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                              <xs:annotation>
                                <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TK_MATERIAL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--21--TS_Material</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-2]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_SHAPE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--22--TS_Form</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-2]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CLASSIFICATIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECLASS">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECLASS_NO">
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:totalDigits value="8" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FRONT_DIVISIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>510--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_GROUP" maxOccurs="99">
                          <xs:annotation>
                            <xs:documentation>510/540--0/0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="FRONT_DIVISION_DEF">
                                      <xs:annotation>
                                        <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="250" />
                                          <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="FRONT_CELL_NO">
                                            <xs:annotation>
                                              <xs:documentation>540--6--Zellennummer</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="FRONT_TYPE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--7--Fronttyp</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="900" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="4" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="4" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PARAMETER_1" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--12--Parameter_1</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PARAMETER_2" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--13--Parameter_2</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="4" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="UPPER_JOIN" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[VLSG]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="LOWER_JOIN" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[VLSG]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="LEFT_JOIN" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[VLSG]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="RIGHT_JOIN" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[VLSG]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="2" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="FRONT_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:choice minOccurs="0">
                    <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MODULE_RULE_SETS" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="MODULE_RULES">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="MODULE_POSITION">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                                  <xs:enumeration value="LINE_BOTTOM" />
                                                  <xs:enumeration value="LINE_TOP" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:element>
                                            <xs:element name="MAX_VALUE" minOccurs="0">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="0" />
                                                  <xs:maxInclusive value="99999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:element>
                                            <xs:element name="MIN_VALUE" minOccurs="0">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="0" />
                                                  <xs:maxInclusive value="99999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:element>
                                          </xs:sequence>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MODULE_RULE_SET_REF">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PROPERTIES" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="PROPERTY_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="VALUE" use="required">
                              <xs:annotation>
                                <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:maxInclusive value="99999" />
                      <xs:minInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUP_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : PRODUCT_GROUP_TEXT Element
Description
This element is used for defining a name for a product group.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence PRODUCT_GROUP_TEXT Element
Overview
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
This element is used for defining a name for a product group.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_CLASS_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : FEATURE_CLASS_REF Element
Description
This element is used for assigning a feature class to a product group. It references a feature class which is defined in the element FEATURE_DEFINITION/FEATURE_CLASSES.
Namespace (none)
Diagram
FEATURE_CLASS_REF Element
Overview
FEATURE_CLASS_REF optional
This element is used for assigning a feature class to a product group. It references a feature class which is defined in the element FEATURE_DEFINITION/FEATURE_CLASSES.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute identifies the referenced feature class(FEATURE_CLASS). D positiveInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_CLASS_NO Restriction of xs:positiveInteger required
This attribute identifies the referenced feature class(FEATURE_CLASS). D positiveInteger
P
M [1:999]
Remarks

Source
<xs:element name="FEATURE_CLASS_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_CLASS_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEMS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : ITEMS Element
Description
This element defines all items belonging to one product group.
Namespace (none)
Diagram
ITEM Element Sequence ITEMS Element
Overview
ITEMS
This element defines all items belonging to one product group.
Sequence
ITEM 1..∞
This element is used for the definition of items and blocks. An item is identified by the attributes SERIE_NO (path 1) and TYPE_NO (path 1)..

The elements OLD_SERIA_NO (path 1) and OLD_TYPE_NO (path 1) may only be used if the geometrical information for the referred item is exactly the same as for the current item.

If an electrical appliance is defined as an item, it is necessary to indicate the dimensions (B, H, T) of this item in the element PARAMETERS (path 3).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Sequence
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

Information can be found at:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

The code, inter alia, expresses the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D string
P [0-9]{11}
M [11:11]

NET_WEIGHT optional Restriction of xs:nonNegativeInteger

This attribute is used to specify the net weight.

The code in the previous element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]

PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) with the value 0 in the element ADDITIONAL_PRICE.

Exactly one basic price feature group has to be assigned to an item. Further price groups can be assigned in the element ADDITIONAL_PRICE_GROUP.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
This element is used for the item price and additional price information.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element references to the price field. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
PRICE_ON_REQUEST optional Restriction of xs:boolean
The use of this element indicates that the price for an item is not fixed but available upon request
. This element is used in combination with the element PRICE_CALC_METHOD.

The following values are defined:
1/true = price on request.

If this element is defined, only the value true is permitted.

This element may only be used if the item is available in different price groups.

Definition of a "price on request" for a price group of item:
The element ITEM_PRICE is defined with a corresponding price group. The value "true" is set in the element
PRICE_ON_REQUEST. The following values can be used in the element PRICE:
- value 0: information without relevance,
- a value unequal 0: reference value for the price. The exact value
has to be requested from the manufacturer.

Definition of a "price on request" for a complete item:
Element ITEM_PRICE is not defined. The attribute PRICE_CALC_METHOD (P1) in the element PRICE_FEATURE_GROUP defines, that all prices for the item have to be requested from the manufacturer. 		D boolean
P
M
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used for the definition of minimum or basic prices of an item. The prices are filled in according to their price groups (price field, PRICE_FIELD).

If the referenced price type is not depending on a basic price, a minimum price is filled in here. In all other cases a basic price is defined. If the value 0 is filled in, the item has no minimum or basic price. The value 0 does not imply that this item is free of charge.

Prices haven to be given in the smallest currency unit (e.g. 300.00 € = 30000 cent). Ident numbers are entered without decimal places. Calculation points are given with exactly two decimal places (without the comma).

If an item is not available in one price group, no data record is defined for this price group.

The basic price is always defined as a price per piece. If the flag basic price has been set, it is not permitted to assign a minimum price to that item.
According to the price calculation rules the total price of an item is made up from the given basic price and the calculated remainder price, taking into account the logic defined in the price type (P3/PRICE_TYPE_REF). Basic prices can only be defined for those items which depend at least on one dimension for the price calculation.

The total item price is calculated according to the following scheme:
The basic price unit (P5/BASIC_PRICE_UNIT) is subtracted from the total item price calculated depending on one or more dimensions. The result of this operation is the remainder. The calculation of the total item price is based on the price calculation rules in combination with the defined item price (P5/PRICE). In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0.

This element has to be defined if the price type (P3/PRICE_TYPE_REF) of the item has been defined as basic price depending.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (P1/PRICE_TYPE_REF) has been defined as basic price dependent this element is used for defining the unit for this basic price. The basic price unit depends on the number of dimensions which are set to "1" or "true".

If the price of an item depends on width and the price calculation is based on a unit of one and a half metres, the value "1500" has to be filled in here. If an item depends on volume and the basic unit is "1 m²", the value "1000000000" [mm²] is filled in.
If the price calculation of an item is a price per piece and does not depend on any dimension, the field has to be set to "0".

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 1/PRICE_TYPE.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPE
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
This element references calculation groups. Calculation groups are defined in the merchandise groups (PRICE_DEFINITION/MERCHANDISE_GROUP).
CALC_GROUP_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
This element references an exchange-ID which is defined in the element path 1/EXCHANGE_ID.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_I
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
ADDITIONAL_PRICE_GROUP 0..∞
This element references PRICE_FEATURE_GROUPS with additional price groups. The basic price feature groups which is referenced excatly one time by an item is defined in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF .

All items which reference the same PRICE_FEATURE_GROUP have also to reference the same calculation group (CALC_GROUP_REF) and exchange-ID (EXCHANGE_ID_REF).

If different price types (item prices/ surcharge prices) are assigned to an item, the following combinations are permitted:

Item | Surcharge
Price per piece | Price per piece
Price depending on length | Price depending on length
Price depending on length | Price per piece

The following combinations are NOT permitted:

Item | Surcharge
Price per piece | Price depending on length
Sequence
PRICE_FEATURE_GROUP_REF
This element references a surcharge group. Surcharge groups which are referenced here may not be used as feature groups.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a surcharge group. D positiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
This element is used for the definition of an item price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element references a price group. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
The prices are filled in according to the price groups of an item (price field). Prices have to be defined in the smallest currency unit (e.g. instead of 300,00 [€], 30000 [Cent]). Fields may also contain negative prices. These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(Example: field with 9 digits; the figure minus 9,00 € shall be filled in : -900) 		D integer
P
M [-99999999:999999999]
CALC_GROUP_REF optional
This element references calculation groups. The calculation groups are defined within the merchandise groups(PRICE_DEFINITION/MERCHANDISE_GROUP).
CALC_GROUP_NO required Restriction of xs:positiveInteger
This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
The calculation group does not correspond with the suppliers scales of conditions. 		D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS. The exchange-ID references block items.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
All exchange-IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The value 0 may only be used in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 11/PRICE_TYPE.

Element paths:
path1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
RESTRICTIONS optional
This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Sequence
RESTRICTION_REF 1..∞
This element references an item to an assigned restriction.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
ADDITIONAL_ITEMS optional
This element is used for assigning additional items. A number of optional and/or mandatory additional items is defined which the user may select from in the planning process.
Sequence
OPTIONAL_ITEMS optional
This element references optional additional items. The number of optional items is not restricted. Items which are defined as linked items may not be used as additional items.
Sequence
OPTIONAL_ITEM_GROUP 1..9
This element is used for defining a group of optional additional items.
SET_NO required Restriction of xs:positiveInteger
A certain number of optional items is available for the main item. In case the field MULTIPLE_CHOICE is set to "true", different optional items can be selected from the total number of available options. If the number of optional items is limited to one, this optional item is selected automatically.
1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
This attribute defines if mulitple optional items are available for a main item.

true = multiple selection permitted 		D boolean
P
M
Sequence
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
This element references an optional additional item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY optional Restriction of xs:positiveInteger
Number of additional items. Default value for planning software systems. In case of optional additional items this default value is a non-binding proposal. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
MANDATORY_ITEMS optional
This element is used for assigning mandatory additional items to a main item. For each main item the number of mandatory additional items is restricted to 1 but different groups of mandatory items may be assigned to one main item.
If only 1 additional item is assigned to a group this additional item is automatically transferred into the planning
Sequence
MANDATORY_ITEM_GROUP 1..9
This element is used for defining a group of mandatory additional items. Exactly one of these mandatory additional items has to be chosen in the course of the planning.
SET_NO required Restriction of xs:positiveInteger
A number of mandatory additional items can be defined for one main item. Exactly one item has to be selected from this group of mandatory additional items. If only 1 mandatory additional item is assigned to a group this additional item is automatically selected in the planning.

1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
Sequence
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
This element references an item
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
MANDATORY_QUANTITY optional Restriction of xs:positiveInteger
Number of additional items. Default value for planning software systems. For mandatory additional items this default value is binding. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
OPERATION_ITEM optional
This element is used for assigning items to special models, surcharges for mitres, visible sides, or cut outs. The different ways of combination are defined by the elements ITEM_REF/SCOPE (path 1) and CLASS (path 1).

Linked items may not be used as additional items.
Linked items may not be used as additional items.

The following examples illustrate the different possibilities of combination:
- Assignment of surcharges for mitres for cornices, light pelmets,plinths
- Assignment of visible sides for items (range dependent/ range independent)
- Assignment of formed pieces, returns etc. for cornices, light pelmets, plinths
- Assignment of lateral plinth to straight plinth boards
- Assignment of cut outs, tongue and groove for worktops
- Assignment of legal measurement changes, i.e. width-, height-, depth reductions.

In case special models/ items are assigned to an item in this element, only these specially defined models/ items are legal, if no assignments are explicitly defined, all special models are permitted.
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
Sequence
SCOPE 1..5
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required.
SCOPE_NO required Restriction of xs:positiveInteger
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required. 		D positiveInteger
P
M [1:5]
Sequence
ITEM_INFORMATION 1..∞
This element contains all information referring to the scope of an item (e.g. type, plinth, cornice, light pelmet, worktop).
Sequence
CLASS Restriction of xs:positiveInteger

This element defines the type of assignment. The following types are defined:
1 = visible side
2 = lateral plinth
3 = form piece
4 = return
5 = transitions
6 = surcharge mitre
7 = width reduction
8 = depth reduction
9 = height reduction
10 = cut-out
11 = rectangular cut-out
12 = round cut-out
13 = jog
14 = chamfer
15 = rounding
16 = tongue and groove
17 = edge for VALUE 5
18 = width extension for VALUE 1
19 = depth extension for VALUE 1
20 = height extension to value 1
21 = deviation from default plinth

Values defined in this element refer to the values set in the element SCOPE. The following rules apply:

element SCOPE value 1 => element CLASS values 1, 2, 3, 7, 8, 9, 18 - 20
element SCOPE value 2 => element CLASS values 2 to 6, value 21
element SCOPE values 3 or 4 => element CLASS values 3 and 6
element SCOPE value 5 => element CLASS values 10 - 17

 D positiveInteger
P
M [1:21]
ITEM_REF optional
Settings in this field indicate the type (operation_item) which is assigned to the target-type. The operation item either requires the same series number as the target-type or it has to be assigned to series 0.

This element has to be defined if the element CLASS (path 1) contains values for form piece (3), return (4), or transition (5).

If this element is not defined the element VALUE (path 1) is required.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM
CONSTRUCTION_ID optional Restriction of xs:string
This element refers to the method of construction for an item, depending on the basic carcase shape.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical. 		D string
P |[LNR]
M [1:1]
COVER optional Restriction of xs:positiveInteger
The value 3 (form piece) in the field CLASS requires settings in this element. In all other cases this field has to be left blank. Different types of covers are defined: basic cover, part cover, total cover. The different types of cover for form pieces depend on the defined basic shape.The assignment of cover types is listed in table "Assignment of cover types".

With respect to the chosen cover type the following values are permitted:
1 = basic cover
2 = part cover
3 = total cover 		D nonNegativeInteger
P
M [1:3]
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
If assignments for plinth, cornices, light pelmets (scope 2-4) are defined, the assignment to a basic shape has to be defined in this element. Settings in this field are required if values 2 - 4 are entered in the field SCOPE. If the values 1 and 5 are set, this element has to be left blank. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
VALUE optional Restriction of xs:nonNegativeInteger
The additional measurement for a mitre (given in mm) is defined in this element. D nonNegativeInteger
P
M [0:999999999]
VALUE_MIN optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the minimum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element. D nonNegativeInteger
P
M [0:999999999]
VALUE_MAX optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the maximum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element.CLASS D nonNegativeInteger
P
M [0:999999999]
HINGE Restriction of xs:string

This element provides information about the orientation of the door hinges. No geometrical information is filled in here. All geometrical information is provided in the element CONSTRUCTION_ID.

The following codes can be used to define the door closing:
J = request for door closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = no hinge or hinges on the exterior edges (double door);
R = hinge right ;
B = corresponding with construction ID i.e. construction-ID left : hinge left;
E = opposite to construction-ID, i.e. construction-ID left : hinge right;

In case of double doors, L and R apply to both doors.

For the item identifier B (block) the placement of the items in a block corresponds to the construction_ID => value "N" is required in the field HINGE.

Values B and E are only permitted if the value "J" is filled in in the element CONSTRUCTION_ID (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
EDP_NUMBER optional Restriction of xs:string
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
EAN_NUMBER optional Restriction of xs:string
If available the EAN-code of an item is defined in this element. D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article.
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal.

 D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

This element can be used to specify the item's catalogue page in the catalogue saved as a .pdf file. This information helps to quickly find an item within the stored catalogue.

The URL of the .pdf file is stored in the DETAIL_INFO element (on catalogue level). Because some items feature on multiple pages within the catalogue, it must be assured that the information for the .pdf file is identical to the 40-digit catalogue page CATALOG_PAGE, meaning they both refer to the same page.

 D positiveInteger
P
M [1:999]
VAT_ID_REF optional
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
WEIGHT optional Restriction of xs:nonNegativeInteger

This element is used to specify the item weight (100 g) including packaging material. (e.g. 50 = 5000 g).
The code in the element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.
Contiguous parts are calculated in the basis of the gross weight per price unit.

Example:
An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
This element defines the volume of an item including packaging material. The basic unit of the volume is [dm³], e.g. a volume of 50 dm³ is entered as 50. D nonNegativeInteger
P
M [0:9999]
CONSTRUCTION_ID Restriction of xs:string
This element defines the basic carcase shape of an item.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the construction_ID. 		D string
P [JLNRAE]
M [1:1]
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
In case the item is provided by a subcontractor, the corresponding supplier number is entered in this element.

If this subcontractor item is a visible part either the elements SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO or the elements FILE_NAME_TEXTURE_1/2 have to be defined.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D nonNegativeInteger
P
M [0:9999]
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
In case the item is provided by a subcontractor (SUBCONTRACTOR_ID filled in) the corresponding supplier number is entered in this element.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D string
P
M [1:15]
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D nonNegativeInteger
P
M [0:99]
OLD_TYPE_NO optional Restriction of xs:string
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D string
P
M [1:15]
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
These elements are used to enter the file names of bitmaps for accessory textures. The files are JPEG files. Because JPEGs do not allow for an alpha channel, the RGB colour code 0,0,255 is used for masking in this case.
The elements are used depending on the value in the „CONSTRUCTION_ID“ element. The FILE_NAME_TEXTURE_1 element contains the left side illustration of the accessories, the FILE_NAME_TEXTURE_2 the right side illustration of the accessories.
CONSTRUCTION_ID = N: The texture in the „filename_texture_1" is used.
CONSTRUCTION_ID = J: There are two different options:
1. The image is mirrored along the central axle. Depending on the item, this can be the Y-axis or the Z-axis (e.g. inset sinks, cooking elements = Y and refrigerators, microwave = Z): The image showing the left side is entered in the FILE_NAME_TEXTURE_1 element.
2. The item cannot be mirrored along the central axle. The image of the left side is entered in the FILE_NAME_TEXTURE_1, while the image of the right side is entered in the FILE_NAME_TEXTURE_2 element.
CONSTRUCTION_ID = L: The value is only entered in the FILE_NAME_TEXTURE_1 element
CONSTRUCTION_ID = R: The value is only entered in the FILE_NAME_TEXTURE_2 element
The values are specified in [cccccccc.jpg] format. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
This element is used for defining a name for the texture bitmaps of accessories. JPEG is the standard file format. Since the alpha channel is not available in the JPEG-format, the RGB value 0,0,255 is used for masking.
The elements are used depending on the settings in the element "CONSTRUCTION_ID". The element FILE_NAME_TEXTURE_1 implies left-hand depiction of the accessory item and the element FILE_NAME_TEXTURE_2 is used to indicate a right-hand depiction.
CONSTRUCTION_ID = N: the texture defined in the element "FILE_NAME_TEXTURE_1" is used
CONSTRUCTION_ID = J: there are two possibilities:
1. A symmetrical item is mirrored on the centre line, which can be either y or z axis (e.g. sinks, cooking elements = Y and refrigerators, microwave ovens = Z): The left-hand depiction is entered into the element FILE_NAME_TEXTURE_1.
2. The item is not symmetrical and therefore cannot be mirrored: The depiction of the left-hand part is entered into element FILE_NAME_TEXTURE_1 and the depiction of the right-hand part is filled in into element FILE_NAME_TEXTURE_2
CONSTRUCTION_ID = L: only settings in element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: only settings in element FILE_NAME_TEXTURE_2
The general format for all settings is [cccccccc.jpg]. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
MASKING optional Restriction of xs:boolean
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
This field is of optional use, unless at least one of the elements FILE_NAME_TEXTURE_1/2is filled in. 		D boolean
P
M
MODELING_GRAPHIC_ID optional Restriction of xs:string
This element references a modeling graphic. D string
P
M [1:15]
RANGE_DEPENDENT Restriction of xs:boolean
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element defines the minimum delivery time in weeks.
This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.) 		D nonNegativeInteger
P
M [0:999]
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

This element provides information about possible alterations of an item provided by the manufacturer. Any changes of an item depend on the definitions of the basic shape in the element PARAMETERS (path 1).

0 = all measurement parameters (PARAMETERS (path 1)) are locked, changes of measurements are not possible;

1 = the measurement parameters (PARAMETERS (path 1)) may be changed according to the settings in SA500. The measurement that shall be changed is upon request;

2 = all measurement parameters (PARAMETERS (path 1)) may be changed, locked parameters require identical values in the attribute NOMINAL_VALUE (path 1), FROM (path 1) and TO (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
BASIC_PROFILE optional
This element definea the basic shape of an item.
Sequence
Choice
CARCASE_BASIC_SHAPE
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information. If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information.
If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
This element defines a basic geometrical shape for a profile. The given measurements for a profile have to correspond with the parameters of the basic profile shape.
Attributes FROM (value from) and TO (value to) are only permitted for parameter B.
This element is only permitted for the following items: cornice, light pelmet, plinth, worktop, cover board, table top, upstand.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
This element defines the number of the basic shape for a profile. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
This element defines the option type and the option key of a profile shape.
The manufacturer specific key for the profile shape as indicated in the printed sales manual is used as OPTION_KEY.
Only the options types 750-756 are permitted in the element BASIC_PROFILE_SHAPE/OPTION_REF.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references an option which shall be used as basic shape for a profile. D string
P
M [1:5]
BASIC_SHAPE_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.

Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
BASIC_SHAPE_NAME required Restriction of xs:string
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
ITEM_DIMENSIONAL_DRAWING
This element is used for the definition of dimensional drawings. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

This element is not permitted if the element BASIC_PROFILE_SHAPE is defined. Dimensional drawings for furniture elements are not permitted.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
This element is used for the definition of a dimensional drawing. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

Even if this element is not defined at least the measurements of the bounding box (w, h, d) have to be defined in the element BASIC_PROFILES/PARAMETERS.

This element is not permitted if the element BASIC_PROFILE_SHAPE exists. This element is not permitted for furniture items, too. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
This element is used for defining a document name or reference.

Documents may contain additional technical information e.g. assembly instructions, or cut-out / drilling patterns.
If only the name of the document is given, this document has to be delivered together with the catalogue data. A document reference is given by an URI/URL.

If a document reference is defined in this element, the element NAME requires the value "23" (= document reference, cf. tables). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Sequence
DIMENSIONAL_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.
DIMENSIONAL_NAME required Restriction of xs:string
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
BLOCK_PARTS optional
This element is used as a container element for the block parts lists in the catalogue.
Sequence
BLOCK_PART 1..∞

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2)), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
ITEM_REF

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞
This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the feature which is referenced by a option.
Each FEATURE_NO may exist only one time in the database. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references a option. D string
P
M [1:5]
HINGE optional Restriction of xs:string
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
MODULE_PARTS optional

If the relevant item is a 3-D unit, this element contains a list of parts for module elements, with the first element being a base unit with position 0 followed by the module elements from the bottom upwards. This element must be left blank if the associated item is not a 3-D unit.

The 3-D unit has a fixed price. If the 3-D unit is changed, the new price will result from the price for the base unit + the price for the modules. The 3-D unit is deleted, the base unit becomes the main position and contains all other module elements as sub-positions from the bottom upwards.

The module elements can be range or version-specific.

Rules concerning the height of module elements within the base unit can be specified via MODUL_RULE_SETS. The universally defined module rule is referenced in this case.

The base unit can be assigned this kind of rule via MODULE_RULE_SET_REF.

Sequence
MODULE_PART 1..∞

This element corresponds to a partial list of parts for module elements of a 3-D unit. The elements must be specified in their order from bottom to top. Position 0 (PART_SEQUENTIAL_NO) is the empty base unit (cabinet type code 17) It is followed by the module elements from bottom to top (cabinet type key 10). The base unit hinges are identical to the hinges of the 3-D unit.

Sequence
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element is used to specify the item's position within the 3-D unit. The base unit (item type code 17) must include the position value of 0. The module elements (type code 10) contain additional position numbers sorted from bottom to top. D nonNegativeInteger
P
M [0:999]
ITEM_REF
This element is used to refer to the base unit (type code 17) and the individual module elements (type code 10).
The base unit must be assigned position (PART_SEQUENTIAL_NO) 0. The remaining module elements must be referenced in the order from the bottom to the top and in line with the PART_SEQUENTIAL_NO attribute.
TYPE_NO required Restriction of xs:string
This element is used to specify the item type. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
HEIGHT_VARIABLE optional xs:boolean
If this flag is set to true(1), this means that the corresponding module element will contain changes relating to changes of other elements within the list. This means that if another module element becomes smaller or larger, the module element designated as true in HEIGHT_VARIABLE will adjust itself so that the total height of all module elements within the base unit is restored. D boolean
P
M
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
A module element can be variable, but the list contains a fixed height that has to be specified for variable measurements within this element. D nonNegativeInteger
P
M [1:99999]
ITEM_TEXT
This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Sequence
SHORT_TEXT
This element contains short text information.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetexte Complex Type

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
This element contains planning advices.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item.
Sequence
TK_TYPE Restriction of xs:positiveInteger
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
A value from the column item No., as listed in the Table "Type keys", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

This element is used for assigning a type key to the installation information and recess height.

SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key ", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
This element defines the combination of installation information (cf. table Installation information-key) and recess height.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
A value from the column installation information, as listed in table "Installation information-key", is required in this field. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
A value from the column type, as listed in table "Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
A value from the column shape No., as listed in the table "Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
A value from the column front appearance No., as listed in the table "Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.
The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
FRONT_DIVISIONS optional
This element is used for defining the possible front divisions of an item.
Different front divisions may be related to the chosen range or built-in appliances.

Similar front divisions in different programmes may be defined in front groups. These front groups are referenced by the programmes.

All front divisions are based on the left-hand construction method. If an item is also available in right-hand construction mode, it is mirrored.If an item is also available in right-hand construction mode, it is mirrored.
Sequence
FRONT_GROUP 1..99
This element defines different front divisions and combines them in one front group.
FRONT_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database.

If one FRONT_GROUP is valid for all programmes, the value 0 has to be set. 		D positiveInteger
P
M [0:99]
Sequence
FRONT_DIVISION 1..∞
This element defines a front division and describes the single cells of the front division.
Sequence
FRONT_DIVISION_DEF Restriction of xs:string
For the definition of the front division the syntax rules provided in the attachment apply. These syntax rules are not used for the description of front divisions for shelves. Shelves are defined as a separate front cell (cf. FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
INTERNAL_ORDER_NO optional Restriction of xs:string
For items which have different front divisions and only one order number in the catalogue, internal order numbers for the different front divisions are entered in this field. D string
P
M [1:15]
FRONT_CELL 1..∞
This element defines the single cells of a front division.
Sequence
FRONT_CELL_NO Restriction of xs:positiveInteger
This attribute defines the No. of the cell which has to be described. The cell No. is defined in the front division (FRONT_DIVISION_DEF). D positiveInteger
P
M [1:99]
FRONT_TYPE optional Restriction of xs:positiveInteger
This element defines the front type of the cell. A front element is assigned by the front type (cf. element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

The following front types can be assigned:

1 - 100 = doors
101 - 200 = drawers
201 - 300 = pull-outs
301 - 400 = flap doors
401 - 450 = recess with blind
451 - 500 = recess without blind
501 - 550 = open compartment/compartment recess
551 - 600 = shelves
601 - 650 = fixed blinds
651 - 700 = control panel blinds
701 - 750 = shutters
751 - 800 = roller shutter fronts
801 - 900 = miscellaneous 		D positiveInteger
P
M [1:900]
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
PARAMETER_1 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
PARAMETER_2 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
OFFSET_ABOVE optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
OFFSET_BELOW optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
OFFSET_LEFT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
OFFSET_RIGHT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell
3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) no mirroring
1) mirroring only when the hinge is changed
2) mirroring only when the construction ID is changed
3) mirroring when either hinge OR construction ID is changed
4) mirroring when hinge AND construction ID are changed.

The rules are defined in the header and examples are given.

 D nonNegativeInteger
P
M [0:4]
UPPER_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
LOWER_JOIN optional Restriction of xs:string

This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre

 D string
P |[VLSG]
M [0:1]
LEFT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
RIGHT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

This element defines the position of the doucine

1) = horizontal
2) = vertical

 D nonNegativeInteger
P
M [1:2]
FRONT_APPEARANCE_REF optional
This element is used for assigning a front appearance to an item. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Front appearances which are assigned to this element are not dependent on a programme.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This element is used to define the relationship between the version defined in the data record and a front type. D positiveInteger
P
M
Choice optional
MODULE_RULE_SET_REF optional
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the number of the rule set which references an item to the corresponding rule set. D positiveInteger
P
M
MODULE_RULE_SETS optional
This element is used for defining a set of rules for module elements. If an item is defined as a module element (type key = 10) the rules for planning this item are defined in this element. It is only possible to define either the element MODULE_RULE_SET_REF or the element MODULE_RULE_SETS.
Sequence
MODULE_RULE_SET 1..∞
This element assigns a set of rules to a module element. The element MODULE_RULE_SET_NO references each set of rules to the related module housing element. Therefore it is possible to define different set of rules for one item depending on the selected module housing element.
Sequence
MODULE_RULES
This element defines a set of rules for the installation of single modules into a module cabinet.
Sequence
MODULE_RULE 1..∞
A rule for the installation of a module into a module cabinet.
This rule defines whether the installation of a module element into the selected module housing element is permitted or not.

Type key 10 is required for module elements.
Sequence
MODULE_POSITION Restriction of xs:string
This element defines the values which have to be checked.

LINE_BOTTOM | Bottom line of the module element in mm
LINE_TOP | Top line of the module element

The control process requires settings MIN_VALUE or MAX_VALUES .
D string
P LINE_BOTTOM|LINE_TOP
M
MAX_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the maximum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
MIN_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the minimum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
MODULE_RULE_SET_REF
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the reference between the rule set and the MODULE_RULE_SET_DEFINITION and the related module housing units. D nonNegativeInteger
P
M
DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
PROPERTIES optional
This element is used for summarizing the item specific characteristics.
Sequence
PROPERTY_REF 1..∞
This element references a characteristic which is defined under GLOBAL_DEFINITION/PROPERTIES.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
This attribute references a characteristic. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

This attribute defines a value for the characteristic.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Remarks

Source
<xs:element name="ITEMS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECO_MOBILIER" minOccurs="0">
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9]{11}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="NET_WEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
              <xs:annotation>
                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence minOccurs="0">
                  <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>450/470--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FIELD">
                          <xs:annotation>
                            <xs:documentation>450--4--Preisfeld</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE">
                          <xs:annotation>
                            <xs:documentation>450--5--Preis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:integer">
                              <xs:minInclusive value="-99999999" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>470--4--Preis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:integer">
                              <xs:minInclusive value="-99999999" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_TYPE_REF">
              <xs:annotation>
                <xs:documentation>400/407--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="PRICE_TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400/407--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CALC_GROUP_REF">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="CALC_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="10" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP_REF">
                    <xs:annotation>
                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>460--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRICE_FIELD">
                                <xs:annotation>
                                  <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PRICE">
                                <xs:annotation>
                                  <xs:documentation>460--5--Preis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:integer">
                                    <xs:minInclusive value="-99999999" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CALC_GROUP_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="CALC_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="10" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>407--7--Tausch_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>407--7--Tausch_ID</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_REF">
                    <xs:annotation>
                      <xs:documentation>407--5--Preisart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>407--5--Preisart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>409--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>409--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>409--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>409--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:maxInclusive value="99999" />
                            <xs:minInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>406--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="GROUP_TITLE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>120--0--NEW</xs:documentation>
                                      <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                    <xs:annotation>
                                      <xs:documentation>406--7--Anzahl</xs:documentation>
                                      <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>Version 2.4.1</xs:documentation>
                                      <xs:documentation>geändert 13.09.2016</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:maxInclusive value="99999" />
                                        <xs:minInclusive value="1" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SET_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="GROUP_TITLE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>120--0--NEW</xs:documentation>
                                      <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                    <xs:annotation>
                                      <xs:documentation>406--7--Anzahl</xs:documentation>
                                      <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>Version 2.4.1</xs:documentation>
                                      <xs:documentation>geändert 13.09.2016</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:maxInclusive value="99999" />
                                        <xs:minInclusive value="1" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SET_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPERATION_ITEM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SCOPE" maxOccurs="5">
                          <xs:annotation>
                            <xs:documentation>411--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>411--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="CLASS">
                                      <xs:annotation>
                                        <xs:documentation>411--7--Art</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="21" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>411--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>411--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[LNR]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="COVER" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--9--Abdeckung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="3" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--10--Wert</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE_MIN" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                        <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE_MAX" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                        <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SCOPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>411--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="HINGE">
              <xs:annotation>
                <xs:documentation>400--4--Anschlag</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BEJLMNR]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDP_NUMBER" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EAN_NUMBER" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>400--14--Artikelkennung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BEKSMZVPNOG]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_PAGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="40" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
                <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
                <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VAT_ID_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="VAT_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="WEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--20--Gewicht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VOLUME" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--21--Volumen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONSTRUCTION_ID">
              <xs:annotation>
                <xs:documentation>400--23--Bauweise_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[JLNRAE]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="OLD_SERIE_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="OLD_TYPE_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--27--Type_Alt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MASKING" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--30--Maskierung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="RANGE_DEPENDENT">
              <xs:annotation>
                <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_PROFILE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:choice>
                    <xs:element name="CARCASE_BASIC_SHAPE">
                      <xs:annotation>
                        <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>400--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType mixed="true">
                              <xs:sequence>
                                <xs:element name="OPTION_REF">
                                  <xs:annotation>
                                    <xs:documentation>430--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="FEATURE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>430--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPTION_KEY" use="required">
                                      <xs:annotation>
                                        <xs:documentation>430--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="5" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,5}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="BASIC_SHAPE_PARAMETERS">
                            <xs:annotation>
                              <xs:documentation>500--1--Satzart</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>500--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                      <xs:annotation>
                                        <xs:documentation>500--0--Parameter</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>500--5--Nennwert</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="BASIC_SHAPE_FROM">
                                      <xs:annotation>
                                        <xs:documentation>500--6--Von</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="BASIC_SHAPE_TO">
                                      <xs:annotation>
                                        <xs:documentation>500--7--Bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                      <xs:annotation>
                                        <xs:documentation>500--8--Schrittweite</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                      <xs:annotation>
                        <xs:documentation>400--32--Massbild</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:minLength value="1" />
                                <xs:maxLength value="240" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="DIMENSIONAL_PARAMETERS">
                            <xs:annotation>
                              <xs:documentation>500--1--Satzart</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>500--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSIONAL_FROM">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSIONAL_TO">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>400--32--Massbild</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="20" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="BLOCK_PARTS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="BLOCK_SEQUENTIAL_NO">
                          <xs:annotation>
                            <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="HINGE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--6--Anschlag</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[BEJLMNR]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EXCHANGE_CONDITION">
                          <xs:annotation>
                            <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="2" />
                              <xs:maxInclusive value="3" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="STATUS">
                          <xs:annotation>
                            <xs:documentation>401--8--Status</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[ABELSZ]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[JLNRAE]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="MODULE_PARTS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MODULE_PART" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PART_SEQUENTIAL_NO">
                          <xs:annotation>
                            <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:maxInclusive value="999" />
                              <xs:minInclusive value="0" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEM_TEXT">
              <xs:annotation>
                <xs:documentation>410--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SHORT_TEXT">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE" maxOccurs="3">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--6--Textzeile</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="TYPE_KEY">
              <xs:annotation>
                <xs:documentation>445--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TK_TYPE">
                    <xs:annotation>
                      <xs:documentation>445--4--TS_Typ</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_CLASS">
                    <xs:annotation>
                      <xs:documentation>445--5--TS_Art</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                    <xs:annotation>
                      <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                        <xs:annotation>
                          <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TK_MATERIAL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--21--TS_Material</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-2]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_SHAPE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--22--TS_Form</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-2]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CLASSIFICATIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECLASS">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECLASS_NO">
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:totalDigits value="8" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONT_DIVISIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>510--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_GROUP" maxOccurs="99">
                    <xs:annotation>
                      <xs:documentation>510/540--0/0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>510/540--0/0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_DIVISION_DEF">
                                <xs:annotation>
                                  <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="250" />
                                    <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="FRONT_CELL_NO">
                                      <xs:annotation>
                                        <xs:documentation>540--6--Zellennummer</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FRONT_TYPE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--7--Fronttyp</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="900" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="4" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="4" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PARAMETER_1" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--12--Parameter_1</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PARAMETER_2" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--13--Parameter_2</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="4" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="UPPER_JOIN" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[VLSG]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="LOWER_JOIN" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[VLSG]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="LEFT_JOIN" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[VLSG]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="RIGHT_JOIN" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[VLSG]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="2" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FRONT_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>510/540--0/0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:choice minOccurs="0">
              <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="MODULE_RULE_SETS" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="MODULE_RULES">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="MODULE_POSITION">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                            <xs:enumeration value="LINE_BOTTOM" />
                                            <xs:enumeration value="LINE_TOP" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="MAX_VALUE" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="99999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="MIN_VALUE" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="99999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MODULE_RULE_SET_REF">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:choice>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PROPERTIES" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="PROPERTY_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="VALUE" use="required">
                        <xs:annotation>
                          <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element : ITEM Element
Description
This element is used for the definition of items and blocks. An item is identified by the attributes SERIE_NO (path 1) and TYPE_NO (path 1)..

The elements OLD_SERIA_NO (path 1) and OLD_TYPE_NO (path 1) may only be used if the geometrical information for the referred item is exactly the same as for the current item.

If an electrical appliance is defined as an item, it is necessary to indicate the dimensions (B, H, T) of this item in the element PARAMETERS (path 3).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE
Namespace (none)
Diagram
PROPERTIES Element DETAIL_INFOS Element MODULE_RULE_SETS Element MODULE_RULE_SET_REF Element Choice FRONT_APPEARANCE_REF Element FRONT_DIVISIONS Element CLASSIFICATIONS Element TYPE_KEY Element ITEM_TEXT Element MODULE_PARTS Element BLOCK_PARTS Element BASIC_PROFILE Element EX_FACTORY_MODIFICATION Element MINIMUM_DELIVERY_TIME Element RANGE_DEPENDENT Element MODELING_GRAPHIC_ID Element MASKING Element FILE_NAME_TEXTURE_2 Element FILE_NAME_TEXTURE_1 Element OLD_TYPE_NO Element OLD_SERIE_NO Element SUBCONTRACTOR_ITEM_NO Element SUBCONTRACTOR_ID Element CONSTRUCTION_ID Element VOLUME Element WEIGHT Element VALID_UNTIL Element VALID_FROM Element VAT_ID_REF Element CATALOG_PAGE_PDF Element CATALOG_PAGE Element ITEM_IDENTIFICATION Element BLOCK_PRICE_STATUS Element EAN_NUMBER Element EDP_NUMBER Element HINGE Element ADDITIONAL_ITEMS Element RESTRICTIONS Element ADDITIONAL_PRICE_GROUP Element EXCHANGE_ID_REF Element CALC_GROUP_REF Element PRICE_TYPE_REF Element PRICE_FEATURE_GROUP_BASE_PRICE_REF Element NET_WEIGHT Element ECO_MOBILIER Element Sequence ITEM Element
Overview
ITEM 1..∞
This element is used for the definition of items and blocks. An item is identified by the attributes SERIE_NO (path 1) and TYPE_NO (path 1)..

The elements OLD_SERIA_NO (path 1) and OLD_TYPE_NO (path 1) may only be used if the geometrical information for the referred item is exactly the same as for the current item.

If an electrical appliance is defined as an item, it is necessary to indicate the dimensions (B, H, T) of this item in the element PARAMETERS (path 3).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Sequence
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

Information can be found at:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

The code, inter alia, expresses the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D string
P [0-9]{11}
M [11:11]

NET_WEIGHT optional Restriction of xs:nonNegativeInteger

This attribute is used to specify the net weight.

The code in the previous element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]

PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) with the value 0 in the element ADDITIONAL_PRICE.

Exactly one basic price feature group has to be assigned to an item. Further price groups can be assigned in the element ADDITIONAL_PRICE_GROUP.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
This element is used for the item price and additional price information.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element references to the price field. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
PRICE_ON_REQUEST optional Restriction of xs:boolean
The use of this element indicates that the price for an item is not fixed but available upon request
. This element is used in combination with the element PRICE_CALC_METHOD.

The following values are defined:
1/true = price on request.

If this element is defined, only the value true is permitted.

This element may only be used if the item is available in different price groups.

Definition of a "price on request" for a price group of item:
The element ITEM_PRICE is defined with a corresponding price group. The value "true" is set in the element
PRICE_ON_REQUEST. The following values can be used in the element PRICE:
- value 0: information without relevance,
- a value unequal 0: reference value for the price. The exact value
has to be requested from the manufacturer.

Definition of a "price on request" for a complete item:
Element ITEM_PRICE is not defined. The attribute PRICE_CALC_METHOD (P1) in the element PRICE_FEATURE_GROUP defines, that all prices for the item have to be requested from the manufacturer. 		D boolean
P
M
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used for the definition of minimum or basic prices of an item. The prices are filled in according to their price groups (price field, PRICE_FIELD).

If the referenced price type is not depending on a basic price, a minimum price is filled in here. In all other cases a basic price is defined. If the value 0 is filled in, the item has no minimum or basic price. The value 0 does not imply that this item is free of charge.

Prices haven to be given in the smallest currency unit (e.g. 300.00 € = 30000 cent). Ident numbers are entered without decimal places. Calculation points are given with exactly two decimal places (without the comma).

If an item is not available in one price group, no data record is defined for this price group.

The basic price is always defined as a price per piece. If the flag basic price has been set, it is not permitted to assign a minimum price to that item.
According to the price calculation rules the total price of an item is made up from the given basic price and the calculated remainder price, taking into account the logic defined in the price type (P3/PRICE_TYPE_REF). Basic prices can only be defined for those items which depend at least on one dimension for the price calculation.

The total item price is calculated according to the following scheme:
The basic price unit (P5/BASIC_PRICE_UNIT) is subtracted from the total item price calculated depending on one or more dimensions. The result of this operation is the remainder. The calculation of the total item price is based on the price calculation rules in combination with the defined item price (P5/PRICE). In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0.

This element has to be defined if the price type (P3/PRICE_TYPE_REF) of the item has been defined as basic price depending.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (P1/PRICE_TYPE_REF) has been defined as basic price dependent this element is used for defining the unit for this basic price. The basic price unit depends on the number of dimensions which are set to "1" or "true".

If the price of an item depends on width and the price calculation is based on a unit of one and a half metres, the value "1500" has to be filled in here. If an item depends on volume and the basic unit is "1 m²", the value "1000000000" [mm²] is filled in.
If the price calculation of an item is a price per piece and does not depend on any dimension, the field has to be set to "0".

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 1/PRICE_TYPE.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPE
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
This element references calculation groups. Calculation groups are defined in the merchandise groups (PRICE_DEFINITION/MERCHANDISE_GROUP).
CALC_GROUP_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
This element references an exchange-ID which is defined in the element path 1/EXCHANGE_ID.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_I
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
ADDITIONAL_PRICE_GROUP 0..∞
This element references PRICE_FEATURE_GROUPS with additional price groups. The basic price feature groups which is referenced excatly one time by an item is defined in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF .

All items which reference the same PRICE_FEATURE_GROUP have also to reference the same calculation group (CALC_GROUP_REF) and exchange-ID (EXCHANGE_ID_REF).

If different price types (item prices/ surcharge prices) are assigned to an item, the following combinations are permitted:

Item | Surcharge
Price per piece | Price per piece
Price depending on length | Price depending on length
Price depending on length | Price per piece

The following combinations are NOT permitted:

Item | Surcharge
Price per piece | Price depending on length
Sequence
PRICE_FEATURE_GROUP_REF
This element references a surcharge group. Surcharge groups which are referenced here may not be used as feature groups.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a surcharge group. D positiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
This element is used for the definition of an item price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element references a price group. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
The prices are filled in according to the price groups of an item (price field). Prices have to be defined in the smallest currency unit (e.g. instead of 300,00 [€], 30000 [Cent]). Fields may also contain negative prices. These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(Example: field with 9 digits; the figure minus 9,00 € shall be filled in : -900) 		D integer
P
M [-99999999:999999999]
CALC_GROUP_REF optional
This element references calculation groups. The calculation groups are defined within the merchandise groups(PRICE_DEFINITION/MERCHANDISE_GROUP).
CALC_GROUP_NO required Restriction of xs:positiveInteger
This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
The calculation group does not correspond with the suppliers scales of conditions. 		D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS. The exchange-ID references block items.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
All exchange-IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The value 0 may only be used in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 11/PRICE_TYPE.

Element paths:
path1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
RESTRICTIONS optional
This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Sequence
RESTRICTION_REF 1..∞
This element references an item to an assigned restriction.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
ADDITIONAL_ITEMS optional
This element is used for assigning additional items. A number of optional and/or mandatory additional items is defined which the user may select from in the planning process.
Sequence
OPTIONAL_ITEMS optional
This element references optional additional items. The number of optional items is not restricted. Items which are defined as linked items may not be used as additional items.
Sequence
OPTIONAL_ITEM_GROUP 1..9
This element is used for defining a group of optional additional items.
SET_NO required Restriction of xs:positiveInteger
A certain number of optional items is available for the main item. In case the field MULTIPLE_CHOICE is set to "true", different optional items can be selected from the total number of available options. If the number of optional items is limited to one, this optional item is selected automatically.
1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
This attribute defines if mulitple optional items are available for a main item.

true = multiple selection permitted 		D boolean
P
M
Sequence
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
This element references an optional additional item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY optional Restriction of xs:positiveInteger
Number of additional items. Default value for planning software systems. In case of optional additional items this default value is a non-binding proposal. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
MANDATORY_ITEMS optional
This element is used for assigning mandatory additional items to a main item. For each main item the number of mandatory additional items is restricted to 1 but different groups of mandatory items may be assigned to one main item.
If only 1 additional item is assigned to a group this additional item is automatically transferred into the planning
Sequence
MANDATORY_ITEM_GROUP 1..9
This element is used for defining a group of mandatory additional items. Exactly one of these mandatory additional items has to be chosen in the course of the planning.
SET_NO required Restriction of xs:positiveInteger
A number of mandatory additional items can be defined for one main item. Exactly one item has to be selected from this group of mandatory additional items. If only 1 mandatory additional item is assigned to a group this additional item is automatically selected in the planning.

1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
Sequence
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
This element references an item
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
MANDATORY_QUANTITY optional Restriction of xs:positiveInteger
Number of additional items. Default value for planning software systems. For mandatory additional items this default value is binding. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
OPERATION_ITEM optional
This element is used for assigning items to special models, surcharges for mitres, visible sides, or cut outs. The different ways of combination are defined by the elements ITEM_REF/SCOPE (path 1) and CLASS (path 1).

Linked items may not be used as additional items.
Linked items may not be used as additional items.

The following examples illustrate the different possibilities of combination:
- Assignment of surcharges for mitres for cornices, light pelmets,plinths
- Assignment of visible sides for items (range dependent/ range independent)
- Assignment of formed pieces, returns etc. for cornices, light pelmets, plinths
- Assignment of lateral plinth to straight plinth boards
- Assignment of cut outs, tongue and groove for worktops
- Assignment of legal measurement changes, i.e. width-, height-, depth reductions.

In case special models/ items are assigned to an item in this element, only these specially defined models/ items are legal, if no assignments are explicitly defined, all special models are permitted.
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
Sequence
SCOPE 1..5
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required.
SCOPE_NO required Restriction of xs:positiveInteger
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required. 		D positiveInteger
P
M [1:5]
Sequence
ITEM_INFORMATION 1..∞
This element contains all information referring to the scope of an item (e.g. type, plinth, cornice, light pelmet, worktop).
Sequence
CLASS Restriction of xs:positiveInteger

This element defines the type of assignment. The following types are defined:
1 = visible side
2 = lateral plinth
3 = form piece
4 = return
5 = transitions
6 = surcharge mitre
7 = width reduction
8 = depth reduction
9 = height reduction
10 = cut-out
11 = rectangular cut-out
12 = round cut-out
13 = jog
14 = chamfer
15 = rounding
16 = tongue and groove
17 = edge for VALUE 5
18 = width extension for VALUE 1
19 = depth extension for VALUE 1
20 = height extension to value 1
21 = deviation from default plinth

Values defined in this element refer to the values set in the element SCOPE. The following rules apply:

element SCOPE value 1 => element CLASS values 1, 2, 3, 7, 8, 9, 18 - 20
element SCOPE value 2 => element CLASS values 2 to 6, value 21
element SCOPE values 3 or 4 => element CLASS values 3 and 6
element SCOPE value 5 => element CLASS values 10 - 17

 D positiveInteger
P
M [1:21]
ITEM_REF optional
Settings in this field indicate the type (operation_item) which is assigned to the target-type. The operation item either requires the same series number as the target-type or it has to be assigned to series 0.

This element has to be defined if the element CLASS (path 1) contains values for form piece (3), return (4), or transition (5).

If this element is not defined the element VALUE (path 1) is required.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
CONSTRUCTION_ID optional Restriction of xs:string
This element refers to the method of construction for an item, depending on the basic carcase shape.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical. 		D string
P |[LNR]
M [1:1]
COVER optional Restriction of xs:positiveInteger
The value 3 (form piece) in the field CLASS requires settings in this element. In all other cases this field has to be left blank. Different types of covers are defined: basic cover, part cover, total cover. The different types of cover for form pieces depend on the defined basic shape.The assignment of cover types is listed in table "Assignment of cover types".

With respect to the chosen cover type the following values are permitted:
1 = basic cover
2 = part cover
3 = total cover 		D nonNegativeInteger
P
M [1:3]
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
If assignments for plinth, cornices, light pelmets (scope 2-4) are defined, the assignment to a basic shape has to be defined in this element. Settings in this field are required if values 2 - 4 are entered in the field SCOPE. If the values 1 and 5 are set, this element has to be left blank. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
VALUE optional Restriction of xs:nonNegativeInteger
The additional measurement for a mitre (given in mm) is defined in this element. D nonNegativeInteger
P
M [0:999999999]
VALUE_MIN optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the minimum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element. D nonNegativeInteger
P
M [0:999999999]
VALUE_MAX optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the maximum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element.CLASS D nonNegativeInteger
P
M [0:999999999]
HINGE Restriction of xs:string

This element provides information about the orientation of the door hinges. No geometrical information is filled in here. All geometrical information is provided in the element CONSTRUCTION_ID.

The following codes can be used to define the door closing:
J = request for door closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = no hinge or hinges on the exterior edges (double door);
R = hinge right ;
B = corresponding with construction ID i.e. construction-ID left : hinge left;
E = opposite to construction-ID, i.e. construction-ID left : hinge right;

In case of double doors, L and R apply to both doors.

For the item identifier B (block) the placement of the items in a block corresponds to the construction_ID => value "N" is required in the field HINGE.

Values B and E are only permitted if the value "J" is filled in in the element CONSTRUCTION_ID (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
EDP_NUMBER optional Restriction of xs:string
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
EAN_NUMBER optional Restriction of xs:string
If available the EAN-code of an item is defined in this element. D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article.
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal.

 D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

This element can be used to specify the item's catalogue page in the catalogue saved as a .pdf file. This information helps to quickly find an item within the stored catalogue.

The URL of the .pdf file is stored in the DETAIL_INFO element (on catalogue level). Because some items feature on multiple pages within the catalogue, it must be assured that the information for the .pdf file is identical to the 40-digit catalogue page CATALOG_PAGE, meaning they both refer to the same page.

 D positiveInteger
P
M [1:999]
VAT_ID_REF optional
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
WEIGHT optional Restriction of xs:nonNegativeInteger

This element is used to specify the item weight (100 g) including packaging material. (e.g. 50 = 5000 g).
The code in the element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.
Contiguous parts are calculated in the basis of the gross weight per price unit.

Example:
An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
This element defines the volume of an item including packaging material. The basic unit of the volume is [dm³], e.g. a volume of 50 dm³ is entered as 50. D nonNegativeInteger
P
M [0:9999]
CONSTRUCTION_ID Restriction of xs:string
This element defines the basic carcase shape of an item.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the construction_ID. 		D string
P [JLNRAE]
M [1:1]
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
In case the item is provided by a subcontractor, the corresponding supplier number is entered in this element.

If this subcontractor item is a visible part either the elements SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO or the elements FILE_NAME_TEXTURE_1/2 have to be defined.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D nonNegativeInteger
P
M [0:9999]
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
In case the item is provided by a subcontractor (SUBCONTRACTOR_ID filled in) the corresponding supplier number is entered in this element.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D string
P
M [1:15]
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D nonNegativeInteger
P
M [0:99]
OLD_TYPE_NO optional Restriction of xs:string
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D string
P
M [1:15]
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
These elements are used to enter the file names of bitmaps for accessory textures. The files are JPEG files. Because JPEGs do not allow for an alpha channel, the RGB colour code 0,0,255 is used for masking in this case.
The elements are used depending on the value in the „CONSTRUCTION_ID“ element. The FILE_NAME_TEXTURE_1 element contains the left side illustration of the accessories, the FILE_NAME_TEXTURE_2 the right side illustration of the accessories.
CONSTRUCTION_ID = N: The texture in the „filename_texture_1" is used.
CONSTRUCTION_ID = J: There are two different options:
1. The image is mirrored along the central axle. Depending on the item, this can be the Y-axis or the Z-axis (e.g. inset sinks, cooking elements = Y and refrigerators, microwave = Z): The image showing the left side is entered in the FILE_NAME_TEXTURE_1 element.
2. The item cannot be mirrored along the central axle. The image of the left side is entered in the FILE_NAME_TEXTURE_1, while the image of the right side is entered in the FILE_NAME_TEXTURE_2 element.
CONSTRUCTION_ID = L: The value is only entered in the FILE_NAME_TEXTURE_1 element
CONSTRUCTION_ID = R: The value is only entered in the FILE_NAME_TEXTURE_2 element
The values are specified in [cccccccc.jpg] format. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
This element is used for defining a name for the texture bitmaps of accessories. JPEG is the standard file format. Since the alpha channel is not available in the JPEG-format, the RGB value 0,0,255 is used for masking.
The elements are used depending on the settings in the element "CONSTRUCTION_ID". The element FILE_NAME_TEXTURE_1 implies left-hand depiction of the accessory item and the element FILE_NAME_TEXTURE_2 is used to indicate a right-hand depiction.
CONSTRUCTION_ID = N: the texture defined in the element "FILE_NAME_TEXTURE_1" is used
CONSTRUCTION_ID = J: there are two possibilities:
1. A symmetrical item is mirrored on the centre line, which can be either y or z axis (e.g. sinks, cooking elements = Y and refrigerators, microwave ovens = Z): The left-hand depiction is entered into the element FILE_NAME_TEXTURE_1.
2. The item is not symmetrical and therefore cannot be mirrored: The depiction of the left-hand part is entered into element FILE_NAME_TEXTURE_1 and the depiction of the right-hand part is filled in into element FILE_NAME_TEXTURE_2
CONSTRUCTION_ID = L: only settings in element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: only settings in element FILE_NAME_TEXTURE_2
The general format for all settings is [cccccccc.jpg]. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
MASKING optional Restriction of xs:boolean
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
This field is of optional use, unless at least one of the elements FILE_NAME_TEXTURE_1/2is filled in. 		D boolean
P
M
MODELING_GRAPHIC_ID optional Restriction of xs:string
This element references a modeling graphic. D string
P
M [1:15]
RANGE_DEPENDENT Restriction of xs:boolean
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element defines the minimum delivery time in weeks.
This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.) 		D nonNegativeInteger
P
M [0:999]
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

This element provides information about possible alterations of an item provided by the manufacturer. Any changes of an item depend on the definitions of the basic shape in the element PARAMETERS (path 1).

0 = all measurement parameters (PARAMETERS (path 1)) are locked, changes of measurements are not possible;

1 = the measurement parameters (PARAMETERS (path 1)) may be changed according to the settings in SA500. The measurement that shall be changed is upon request;

2 = all measurement parameters (PARAMETERS (path 1)) may be changed, locked parameters require identical values in the attribute NOMINAL_VALUE (path 1), FROM (path 1) and TO (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
BASIC_PROFILE optional
This element definea the basic shape of an item.
Sequence
Choice
CARCASE_BASIC_SHAPE
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information. If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information.
If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
This element defines a basic geometrical shape for a profile. The given measurements for a profile have to correspond with the parameters of the basic profile shape.
Attributes FROM (value from) and TO (value to) are only permitted for parameter B.
This element is only permitted for the following items: cornice, light pelmet, plinth, worktop, cover board, table top, upstand.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
This element defines the number of the basic shape for a profile. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
This element defines the option type and the option key of a profile shape.
The manufacturer specific key for the profile shape as indicated in the printed sales manual is used as OPTION_KEY.
Only the options types 750-756 are permitted in the element BASIC_PROFILE_SHAPE/OPTION_REF.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references an option which shall be used as basic shape for a profile. D string
P
M [1:5]
BASIC_SHAPE_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.

Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
BASIC_SHAPE_NAME required Restriction of xs:string
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
ITEM_DIMENSIONAL_DRAWING
This element is used for the definition of dimensional drawings. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

This element is not permitted if the element BASIC_PROFILE_SHAPE is defined. Dimensional drawings for furniture elements are not permitted.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
This element is used for the definition of a dimensional drawing. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

Even if this element is not defined at least the measurements of the bounding box (w, h, d) have to be defined in the element BASIC_PROFILES/PARAMETERS.

This element is not permitted if the element BASIC_PROFILE_SHAPE exists. This element is not permitted for furniture items, too. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
This element is used for defining a document name or reference.

Documents may contain additional technical information e.g. assembly instructions, or cut-out / drilling patterns.
If only the name of the document is given, this document has to be delivered together with the catalogue data. A document reference is given by an URI/URL.

If a document reference is defined in this element, the element NAME requires the value "23" (= document reference, cf. tables). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Sequence
DIMENSIONAL_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.
DIMENSIONAL_NAME required Restriction of xs:string
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
BLOCK_PARTS optional
This element is used as a container element for the block parts lists in the catalogue.
Sequence
BLOCK_PART 1..∞

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2)), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
ITEM_REF

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞
This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the feature which is referenced by a option.
Each FEATURE_NO may exist only one time in the database. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references a option. D string
P
M [1:5]
HINGE optional Restriction of xs:string
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
MODULE_PARTS optional

If the relevant item is a 3-D unit, this element contains a list of parts for module elements, with the first element being a base unit with position 0 followed by the module elements from the bottom upwards. This element must be left blank if the associated item is not a 3-D unit.

The 3-D unit has a fixed price. If the 3-D unit is changed, the new price will result from the price for the base unit + the price for the modules. The 3-D unit is deleted, the base unit becomes the main position and contains all other module elements as sub-positions from the bottom upwards.

The module elements can be range or version-specific.

Rules concerning the height of module elements within the base unit can be specified via MODUL_RULE_SETS. The universally defined module rule is referenced in this case.

The base unit can be assigned this kind of rule via MODULE_RULE_SET_REF.

Sequence
MODULE_PART 1..∞

This element corresponds to a partial list of parts for module elements of a 3-D unit. The elements must be specified in their order from bottom to top. Position 0 (PART_SEQUENTIAL_NO) is the empty base unit (cabinet type code 17) It is followed by the module elements from bottom to top (cabinet type key 10). The base unit hinges are identical to the hinges of the 3-D unit.

Sequence
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element is used to specify the item's position within the 3-D unit. The base unit (item type code 17) must include the position value of 0. The module elements (type code 10) contain additional position numbers sorted from bottom to top. D nonNegativeInteger
P
M [0:999]
ITEM_REF
This element is used to refer to the base unit (type code 17) and the individual module elements (type code 10).
The base unit must be assigned position (PART_SEQUENTIAL_NO) 0. The remaining module elements must be referenced in the order from the bottom to the top and in line with the PART_SEQUENTIAL_NO attribute.
TYPE_NO required Restriction of xs:string
This element is used to specify the item type. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
HEIGHT_VARIABLE optional xs:boolean
If this flag is set to true(1), this means that the corresponding module element will contain changes relating to changes of other elements within the list. This means that if another module element becomes smaller or larger, the module element designated as true in HEIGHT_VARIABLE will adjust itself so that the total height of all module elements within the base unit is restored. D boolean
P
M
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
A module element can be variable, but the list contains a fixed height that has to be specified for variable measurements within this element. D nonNegativeInteger
P
M [1:99999]
ITEM_TEXT
This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Sequence
SHORT_TEXT
This element contains short text information.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetexte Complex Type

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
This element contains planning advices.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item.
Sequence
TK_TYPE Restriction of xs:positiveInteger
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
A value from the column item No., as listed in the Table "Type keys", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

This element is used for assigning a type key to the installation information and recess height.

SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key ", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
This element defines the combination of installation information (cf. table Installation information-key) and recess height.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
A value from the column installation information, as listed in table "Installation information-key", is required in this field. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
A value from the column type, as listed in table "Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
A value from the column shape No., as listed in the table "Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
A value from the column front appearance No., as listed in the table "Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.
The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
FRONT_DIVISIONS optional
This element is used for defining the possible front divisions of an item.
Different front divisions may be related to the chosen range or built-in appliances.

Similar front divisions in different programmes may be defined in front groups. These front groups are referenced by the programmes.

All front divisions are based on the left-hand construction method. If an item is also available in right-hand construction mode, it is mirrored.If an item is also available in right-hand construction mode, it is mirrored.
Sequence
FRONT_GROUP 1..99
This element defines different front divisions and combines them in one front group.
FRONT_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database.

If one FRONT_GROUP is valid for all programmes, the value 0 has to be set. 		D positiveInteger
P
M [0:99]
Sequence
FRONT_DIVISION 1..∞
This element defines a front division and describes the single cells of the front division.
Sequence
FRONT_DIVISION_DEF Restriction of xs:string
For the definition of the front division the syntax rules provided in the attachment apply. These syntax rules are not used for the description of front divisions for shelves. Shelves are defined as a separate front cell (cf. FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
INTERNAL_ORDER_NO optional Restriction of xs:string
For items which have different front divisions and only one order number in the catalogue, internal order numbers for the different front divisions are entered in this field. D string
P
M [1:15]
FRONT_CELL 1..∞
This element defines the single cells of a front division.
Sequence
FRONT_CELL_NO Restriction of xs:positiveInteger
This attribute defines the No. of the cell which has to be described. The cell No. is defined in the front division (FRONT_DIVISION_DEF). D positiveInteger
P
M [1:99]
FRONT_TYPE optional Restriction of xs:positiveInteger
This element defines the front type of the cell. A front element is assigned by the front type (cf. element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

The following front types can be assigned:

1 - 100 = doors
101 - 200 = drawers
201 - 300 = pull-outs
301 - 400 = flap doors
401 - 450 = recess with blind
451 - 500 = recess without blind
501 - 550 = open compartment/compartment recess
551 - 600 = shelves
601 - 650 = fixed blinds
651 - 700 = control panel blinds
701 - 750 = shutters
751 - 800 = roller shutter fronts
801 - 900 = miscellaneous 		D positiveInteger
P
M [1:900]
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
PARAMETER_1 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
PARAMETER_2 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
OFFSET_ABOVE optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
OFFSET_BELOW optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
OFFSET_LEFT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
OFFSET_RIGHT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell
3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) no mirroring
1) mirroring only when the hinge is changed
2) mirroring only when the construction ID is changed
3) mirroring when either hinge OR construction ID is changed
4) mirroring when hinge AND construction ID are changed.

The rules are defined in the header and examples are given.

 D nonNegativeInteger
P
M [0:4]
UPPER_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
LOWER_JOIN optional Restriction of xs:string

This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre

 D string
P |[VLSG]
M [0:1]
LEFT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
RIGHT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

This element defines the position of the doucine

1) = horizontal
2) = vertical

 D nonNegativeInteger
P
M [1:2]
FRONT_APPEARANCE_REF optional
This element is used for assigning a front appearance to an item. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Front appearances which are assigned to this element are not dependent on a programme.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This element is used to define the relationship between the version defined in the data record and a front type. D positiveInteger
P
M
Choice optional
MODULE_RULE_SET_REF optional
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the number of the rule set which references an item to the corresponding rule set. D positiveInteger
P
M
MODULE_RULE_SETS optional
This element is used for defining a set of rules for module elements. If an item is defined as a module element (type key = 10) the rules for planning this item are defined in this element. It is only possible to define either the element MODULE_RULE_SET_REF or the element MODULE_RULE_SETS.
Sequence
MODULE_RULE_SET 1..∞
This element assigns a set of rules to a module element. The element MODULE_RULE_SET_NO references each set of rules to the related module housing element. Therefore it is possible to define different set of rules for one item depending on the selected module housing element.
Sequence
MODULE_RULES
This element defines a set of rules for the installation of single modules into a module cabinet.
Sequence
MODULE_RULE 1..∞
A rule for the installation of a module into a module cabinet.
This rule defines whether the installation of a module element into the selected module housing element is permitted or not.

Type key 10 is required for module elements.
Sequence
MODULE_POSITION Restriction of xs:string
This element defines the values which have to be checked.

LINE_BOTTOM | Bottom line of the module element in mm
LINE_TOP | Top line of the module element

The control process requires settings MIN_VALUE or MAX_VALUES .
D string
P LINE_BOTTOM|LINE_TOP
M
MAX_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the maximum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
MIN_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the minimum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
MODULE_RULE_SET_REF
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the reference between the rule set and the MODULE_RULE_SET_DEFINITION and the related module housing units. D nonNegativeInteger
P
M
DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
PROPERTIES optional
This element is used for summarizing the item specific characteristics.
Sequence
PROPERTY_REF 1..∞
This element references a characteristic which is defined under GLOBAL_DEFINITION/PROPERTIES.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
This attribute references a characteristic. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

This attribute defines a value for the characteristic.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO Restriction of xs:string required
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Remarks

Source
<xs:element name="ITEM" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECO_MOBILIER" minOccurs="0">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9]{11}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="NET_WEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
        <xs:annotation>
          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence minOccurs="0">
            <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>450/470--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FIELD">
                    <xs:annotation>
                      <xs:documentation>450--4--Preisfeld</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE">
                    <xs:annotation>
                      <xs:documentation>450--5--Preis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="-99999999" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>470--4--Preis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="-99999999" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_TYPE_REF">
        <xs:annotation>
          <xs:documentation>400/407--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PRICE_TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400/407--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CALC_GROUP_REF">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="CALC_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="10" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP_REF">
              <xs:annotation>
                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>460--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FIELD">
                          <xs:annotation>
                            <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE">
                          <xs:annotation>
                            <xs:documentation>460--5--Preis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:integer">
                              <xs:minInclusive value="-99999999" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CALC_GROUP_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="CALC_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="10" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>407--7--Tausch_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>407--7--Tausch_ID</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_TYPE_REF">
              <xs:annotation>
                <xs:documentation>407--5--Preisart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="PRICE_TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>407--5--Preisart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>409--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>409--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>409--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>409--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:maxInclusive value="99999" />
                      <xs:minInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>406--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="GROUP_TITLE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>120--0--NEW</xs:documentation>
                                <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                              <xs:annotation>
                                <xs:documentation>406--7--Anzahl</xs:documentation>
                                <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>Version 2.4.1</xs:documentation>
                                <xs:documentation>geändert 13.09.2016</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:maxInclusive value="99999" />
                                  <xs:minInclusive value="1" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SET_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="MANDATORY_ITEMS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="GROUP_TITLE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>120--0--NEW</xs:documentation>
                                <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                              <xs:annotation>
                                <xs:documentation>406--7--Anzahl</xs:documentation>
                                <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>Version 2.4.1</xs:documentation>
                                <xs:documentation>geändert 13.09.2016</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:maxInclusive value="99999" />
                                  <xs:minInclusive value="1" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SET_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPERATION_ITEM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SCOPE" maxOccurs="5">
                    <xs:annotation>
                      <xs:documentation>411--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>411--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CLASS">
                                <xs:annotation>
                                  <xs:documentation>411--7--Art</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="21" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="ITEM_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>411--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>411--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[LNR]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="COVER" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--9--Abdeckung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="3" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--10--Wert</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE_MIN" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                  <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE_MAX" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                  <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SCOPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>411--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="HINGE">
        <xs:annotation>
          <xs:documentation>400--4--Anschlag</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BEJLMNR]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDP_NUMBER" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--10--EDV_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EAN_NUMBER" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--11--EAN_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>400--14--Artikelkennung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BEKSMZVPNOG]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_PAGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--15--Katalog_Seite</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="40" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
          <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
          <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VAT_ID_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="VAT_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="WEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--20--Gewicht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VOLUME" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--21--Volumen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONSTRUCTION_ID">
        <xs:annotation>
          <xs:documentation>400--23--Bauweise_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[JLNRAE]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="OLD_SERIE_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="OLD_TYPE_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--27--Type_Alt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MASKING" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--30--Maskierung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="RANGE_DEPENDENT">
        <xs:annotation>
          <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_PROFILE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:choice>
              <xs:element name="CARCASE_BASIC_SHAPE">
                <xs:annotation>
                  <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>400--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType mixed="true">
                        <xs:sequence>
                          <xs:element name="OPTION_REF">
                            <xs:annotation>
                              <xs:documentation>430--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="FEATURE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>430--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPTION_KEY" use="required">
                                <xs:annotation>
                                  <xs:documentation>430--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="5" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,5}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="BASIC_SHAPE_PARAMETERS">
                      <xs:annotation>
                        <xs:documentation>500--1--Satzart</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>500--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                <xs:annotation>
                                  <xs:documentation>500--0--Parameter</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                <xs:annotation>
                                  <xs:documentation>500--5--Nennwert</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="BASIC_SHAPE_FROM">
                                <xs:annotation>
                                  <xs:documentation>500--6--Von</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="BASIC_SHAPE_TO">
                                <xs:annotation>
                                  <xs:documentation>500--7--Bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                <xs:annotation>
                                  <xs:documentation>500--8--Schrittweite</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                <xs:annotation>
                  <xs:documentation>400--32--Massbild</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:minLength value="1" />
                          <xs:maxLength value="240" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="DIMENSIONAL_PARAMETERS">
                      <xs:annotation>
                        <xs:documentation>500--1--Satzart</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>500--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSIONAL_FROM">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSIONAL_TO">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>400--32--Massbild</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:choice>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BLOCK_PARTS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_PART" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_SEQUENTIAL_NO">
                    <xs:annotation>
                      <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HINGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--6--Anschlag</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[BEJLMNR]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EXCHANGE_CONDITION">
                    <xs:annotation>
                      <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="2" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STATUS">
                    <xs:annotation>
                      <xs:documentation>401--8--Status</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[ABELSZ]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[JLNRAE]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MODULE_PARTS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MODULE_PART" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PART_SEQUENTIAL_NO">
                    <xs:annotation>
                      <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:maxInclusive value="999" />
                        <xs:minInclusive value="0" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEM_TEXT">
        <xs:annotation>
          <xs:documentation>410--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SHORT_TEXT">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE" maxOccurs="3">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--6--Textzeile</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SEQUENCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="TYPE_KEY">
        <xs:annotation>
          <xs:documentation>445--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TK_TYPE">
              <xs:annotation>
                <xs:documentation>445--4--TS_Typ</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_CLASS">
              <xs:annotation>
                <xs:documentation>445--5--TS_Art</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
              <xs:annotation>
                <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                  <xs:annotation>
                    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="TK_MATERIAL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--21--TS_Material</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-2]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_SHAPE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--22--TS_Form</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-2]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CLASSIFICATIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECLASS_NO">
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:totalDigits value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONT_DIVISIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>510--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_GROUP" maxOccurs="99">
              <xs:annotation>
                <xs:documentation>510/540--0/0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>510/540--0/0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_DIVISION_DEF">
                          <xs:annotation>
                            <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="250" />
                              <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_CELL_NO">
                                <xs:annotation>
                                  <xs:documentation>540--6--Zellennummer</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FRONT_TYPE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--7--Fronttyp</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="900" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="4" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="4" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PARAMETER_1" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--12--Parameter_1</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PARAMETER_2" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--13--Parameter_2</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="4" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="UPPER_JOIN" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[VLSG]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="LOWER_JOIN" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[VLSG]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="LEFT_JOIN" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[VLSG]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="RIGHT_JOIN" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[VLSG]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="2" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FRONT_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>510/540--0/0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:choice minOccurs="0">
        <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="MODULE_RULE_SETS" minOccurs="0">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="MODULE_RULES">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="MODULE_POSITION">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                      <xs:enumeration value="LINE_BOTTOM" />
                                      <xs:enumeration value="LINE_TOP" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="MAX_VALUE" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="99999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="MIN_VALUE" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="99999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MODULE_RULE_SET_REF">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
      </xs:choice>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PROPERTIES" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="PROPERTY_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="VALUE" use="required">
                  <xs:annotation>
                    <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ECO_MOBILIER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ECO_MOBILIER Element
Description

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

Information can be found at:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

The code, inter alia, expresses the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D string
P [0-9]{11}
M [11:11]

Namespace (none)
Type
Restriction of xs:string
Diagram
ECO_MOBILIER Element
Overview
ECO_MOBILIER optional Restriction of xs:string

This 11-digit code is a nomenclature created by Eco mobilier for classifying the furniture pieces by certain characteristics that are mandatory information required by the French Agency for the Environment and Energy (ADEME) and Eco mobilier.

The simulator available on the Eco mobilier website must be used to determine the product codes required in the information notice. The following illustration shows the composition of the product code.

Information can be found at:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

and/or

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

The code, inter alia, expresses the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D string
P [0-9]{11}
M [11:11]

Remarks

Source
<xs:element name="ECO_MOBILIER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9]{11}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

NET_WEIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : NET_WEIGHT Element
Description

This attribute is used to specify the net weight.

The code in the previous element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]

Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
NET_WEIGHT Element
Overview
NET_WEIGHT optional Restriction of xs:nonNegativeInteger

This attribute is used to specify the net weight.

The code in the previous element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]

Remarks

Source
<xs:element name="NET_WEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
Description
This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) with the value 0 in the element ADDITIONAL_PRICE.

Exactly one basic price feature group has to be assigned to an item. Further price groups can be assigned in the element ADDITIONAL_PRICE_GROUP.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Namespace (none)
Diagram
ITEM_PRICE Element Sequence PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
Overview
PRICE_FEATURE_GROUP_BASE_PRICE_REF
This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) with the value 0 in the element ADDITIONAL_PRICE.

Exactly one basic price feature group has to be assigned to an item. Further price groups can be assigned in the element ADDITIONAL_PRICE_GROUP.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
This element is used for the item price and additional price information.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element references to the price field. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
PRICE_ON_REQUEST optional Restriction of xs:boolean
The use of this element indicates that the price for an item is not fixed but available upon request
. This element is used in combination with the element PRICE_CALC_METHOD.

The following values are defined:
1/true = price on request.

If this element is defined, only the value true is permitted.

This element may only be used if the item is available in different price groups.

Definition of a "price on request" for a price group of item:
The element ITEM_PRICE is defined with a corresponding price group. The value "true" is set in the element
PRICE_ON_REQUEST. The following values can be used in the element PRICE:
- value 0: information without relevance,
- a value unequal 0: reference value for the price. The exact value
has to be requested from the manufacturer.

Definition of a "price on request" for a complete item:
Element ITEM_PRICE is not defined. The attribute PRICE_CALC_METHOD (P1) in the element PRICE_FEATURE_GROUP defines, that all prices for the item have to be requested from the manufacturer. 		D boolean
P
M
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used for the definition of minimum or basic prices of an item. The prices are filled in according to their price groups (price field, PRICE_FIELD).

If the referenced price type is not depending on a basic price, a minimum price is filled in here. In all other cases a basic price is defined. If the value 0 is filled in, the item has no minimum or basic price. The value 0 does not imply that this item is free of charge.

Prices haven to be given in the smallest currency unit (e.g. 300.00 € = 30000 cent). Ident numbers are entered without decimal places. Calculation points are given with exactly two decimal places (without the comma).

If an item is not available in one price group, no data record is defined for this price group.

The basic price is always defined as a price per piece. If the flag basic price has been set, it is not permitted to assign a minimum price to that item.
According to the price calculation rules the total price of an item is made up from the given basic price and the calculated remainder price, taking into account the logic defined in the price type (P3/PRICE_TYPE_REF). Basic prices can only be defined for those items which depend at least on one dimension for the price calculation.

The total item price is calculated according to the following scheme:
The basic price unit (P5/BASIC_PRICE_UNIT) is subtracted from the total item price calculated depending on one or more dimensions. The result of this operation is the remainder. The calculation of the total item price is based on the price calculation rules in combination with the defined item price (P5/PRICE). In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0.

This element has to be defined if the price type (P3/PRICE_TYPE_REF) of the item has been defined as basic price depending.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (P1/PRICE_TYPE_REF) has been defined as basic price dependent this element is used for defining the unit for this basic price. The basic price unit depends on the number of dimensions which are set to "1" or "true".

If the price of an item depends on width and the price calculation is based on a unit of one and a half metres, the value "1500" has to be filled in here. If an item depends on volume and the basic unit is "1 m²", the value "1000000000" [mm²] is filled in.
If the price calculation of an item is a price per piece and does not depend on any dimension, the field has to be set to "0".

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
Attributes
Name Type Use Default Fixed Description
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Remarks

Source
<xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence minOccurs="0">
      <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>450/470--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>450--4--Preisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE">
              <xs:annotation>
                <xs:documentation>450--5--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
              <xs:annotation>
                <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
              <xs:annotation>
                <xs:documentation>470--4--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_PRICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element : ITEM_PRICE Element
Description
This element is used for the item price and additional price information.
Namespace (none)
Diagram
BASIC_PRICE_UNIT Element PRICE_MINIMUM_BASIC Element PRICE_ON_REQUEST Element PRICE Element PRICE_FIELD Element Sequence ITEM_PRICE Element
Overview
ITEM_PRICE 0..∞
This element is used for the item price and additional price information.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element references to the price field. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
PRICE_ON_REQUEST optional Restriction of xs:boolean
The use of this element indicates that the price for an item is not fixed but available upon request
. This element is used in combination with the element PRICE_CALC_METHOD.

The following values are defined:
1/true = price on request.

If this element is defined, only the value true is permitted.

This element may only be used if the item is available in different price groups.

Definition of a "price on request" for a price group of item:
The element ITEM_PRICE is defined with a corresponding price group. The value "true" is set in the element
PRICE_ON_REQUEST. The following values can be used in the element PRICE:
- value 0: information without relevance,
- a value unequal 0: reference value for the price. The exact value
has to be requested from the manufacturer.

Definition of a "price on request" for a complete item:
Element ITEM_PRICE is not defined. The attribute PRICE_CALC_METHOD (P1) in the element PRICE_FEATURE_GROUP defines, that all prices for the item have to be requested from the manufacturer. 		D boolean
P
M
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used for the definition of minimum or basic prices of an item. The prices are filled in according to their price groups (price field, PRICE_FIELD).

If the referenced price type is not depending on a basic price, a minimum price is filled in here. In all other cases a basic price is defined. If the value 0 is filled in, the item has no minimum or basic price. The value 0 does not imply that this item is free of charge.

Prices haven to be given in the smallest currency unit (e.g. 300.00 € = 30000 cent). Ident numbers are entered without decimal places. Calculation points are given with exactly two decimal places (without the comma).

If an item is not available in one price group, no data record is defined for this price group.

The basic price is always defined as a price per piece. If the flag basic price has been set, it is not permitted to assign a minimum price to that item.
According to the price calculation rules the total price of an item is made up from the given basic price and the calculated remainder price, taking into account the logic defined in the price type (P3/PRICE_TYPE_REF). Basic prices can only be defined for those items which depend at least on one dimension for the price calculation.

The total item price is calculated according to the following scheme:
The basic price unit (P5/BASIC_PRICE_UNIT) is subtracted from the total item price calculated depending on one or more dimensions. The result of this operation is the remainder. The calculation of the total item price is based on the price calculation rules in combination with the defined item price (P5/PRICE). In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0.

This element has to be defined if the price type (P3/PRICE_TYPE_REF) of the item has been defined as basic price depending.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (P1/PRICE_TYPE_REF) has been defined as basic price dependent this element is used for defining the unit for this basic price. The basic price unit depends on the number of dimensions which are set to "1" or "true".

If the price of an item depends on width and the price calculation is based on a unit of one and a half metres, the value "1500" has to be filled in here. If an item depends on volume and the basic unit is "1 m²", the value "1000000000" [mm²] is filled in.
If the price calculation of an item is a price per piece and does not depend on any dimension, the field has to be set to "0".

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
Source
<xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450/470--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>450--4--Preisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE">
        <xs:annotation>
          <xs:documentation>450--5--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
        <xs:annotation>
          <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
        <xs:annotation>
          <xs:documentation>470--4--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FIELD Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE_FIELD Element
Description
This element references to the price field. D positiveInteger
P
M [1:250]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger
This element references to the price field. D positiveInteger
P
M [1:250]
Source
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--4--Preisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE Element
Description
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
Namespace (none)
Type
Restriction of xs:integer
Diagram
PRICE Element
Overview
PRICE Restriction of xs:integer
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
Source
<xs:element name="PRICE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--5--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_ON_REQUEST Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE_ON_REQUEST Element
Description
The use of this element indicates that the price for an item is not fixed but available upon request
. This element is used in combination with the element PRICE_CALC_METHOD.

The following values are defined:
1/true = price on request.

If this element is defined, only the value true is permitted.

This element may only be used if the item is available in different price groups.

Definition of a "price on request" for a price group of item:
The element ITEM_PRICE is defined with a corresponding price group. The value "true" is set in the element
PRICE_ON_REQUEST. The following values can be used in the element PRICE:
- value 0: information without relevance,
- a value unequal 0: reference value for the price. The exact value
has to be requested from the manufacturer.

Definition of a "price on request" for a complete item:
Element ITEM_PRICE is not defined. The attribute PRICE_CALC_METHOD (P1) in the element PRICE_FEATURE_GROUP defines, that all prices for the item have to be requested from the manufacturer. 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
PRICE_ON_REQUEST Element
Overview
PRICE_ON_REQUEST optional Restriction of xs:boolean
The use of this element indicates that the price for an item is not fixed but available upon request
. This element is used in combination with the element PRICE_CALC_METHOD.

The following values are defined:
1/true = price on request.

If this element is defined, only the value true is permitted.

This element may only be used if the item is available in different price groups.

Definition of a "price on request" for a price group of item:
The element ITEM_PRICE is defined with a corresponding price group. The value "true" is set in the element
PRICE_ON_REQUEST. The following values can be used in the element PRICE:
- value 0: information without relevance,
- a value unequal 0: reference value for the price. The exact value
has to be requested from the manufacturer.

Definition of a "price on request" for a complete item:
Element ITEM_PRICE is not defined. The attribute PRICE_CALC_METHOD (P1) in the element PRICE_FEATURE_GROUP defines, that all prices for the item have to be requested from the manufacturer. 		D boolean
P
M
Source
<xs:element name="PRICE_ON_REQUEST" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_MINIMUM_BASIC Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE_MINIMUM_BASIC Element
Description
This element is used for the definition of minimum or basic prices of an item. The prices are filled in according to their price groups (price field, PRICE_FIELD).

If the referenced price type is not depending on a basic price, a minimum price is filled in here. In all other cases a basic price is defined. If the value 0 is filled in, the item has no minimum or basic price. The value 0 does not imply that this item is free of charge.

Prices haven to be given in the smallest currency unit (e.g. 300.00 € = 30000 cent). Ident numbers are entered without decimal places. Calculation points are given with exactly two decimal places (without the comma).

If an item is not available in one price group, no data record is defined for this price group.

The basic price is always defined as a price per piece. If the flag basic price has been set, it is not permitted to assign a minimum price to that item.
According to the price calculation rules the total price of an item is made up from the given basic price and the calculated remainder price, taking into account the logic defined in the price type (P3/PRICE_TYPE_REF). Basic prices can only be defined for those items which depend at least on one dimension for the price calculation.

The total item price is calculated according to the following scheme:
The basic price unit (P5/BASIC_PRICE_UNIT) is subtracted from the total item price calculated depending on one or more dimensions. The result of this operation is the remainder. The calculation of the total item price is based on the price calculation rules in combination with the defined item price (P5/PRICE). In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0.

This element has to be defined if the price type (P3/PRICE_TYPE_REF) of the item has been defined as basic price depending.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
Namespace (none)
Type
Restriction of xs:integer
Diagram
PRICE_MINIMUM_BASIC Element
Overview
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
This element is used for the definition of minimum or basic prices of an item. The prices are filled in according to their price groups (price field, PRICE_FIELD).

If the referenced price type is not depending on a basic price, a minimum price is filled in here. In all other cases a basic price is defined. If the value 0 is filled in, the item has no minimum or basic price. The value 0 does not imply that this item is free of charge.

Prices haven to be given in the smallest currency unit (e.g. 300.00 € = 30000 cent). Ident numbers are entered without decimal places. Calculation points are given with exactly two decimal places (without the comma).

If an item is not available in one price group, no data record is defined for this price group.

The basic price is always defined as a price per piece. If the flag basic price has been set, it is not permitted to assign a minimum price to that item.
According to the price calculation rules the total price of an item is made up from the given basic price and the calculated remainder price, taking into account the logic defined in the price type (P3/PRICE_TYPE_REF). Basic prices can only be defined for those items which depend at least on one dimension for the price calculation.

The total item price is calculated according to the following scheme:
The basic price unit (P5/BASIC_PRICE_UNIT) is subtracted from the total item price calculated depending on one or more dimensions. The result of this operation is the remainder. The calculation of the total item price is based on the price calculation rules in combination with the defined item price (P5/PRICE). In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0.

This element has to be defined if the price type (P3/PRICE_TYPE_REF) of the item has been defined as basic price depending.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
Source
<xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>470--4--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_PRICE_UNIT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : BASIC_PRICE_UNIT Element
Description
If a price type (P1/PRICE_TYPE_REF) has been defined as basic price dependent this element is used for defining the unit for this basic price. The basic price unit depends on the number of dimensions which are set to "1" or "true".

If the price of an item depends on width and the price calculation is based on a unit of one and a half metres, the value "1500" has to be filled in here. If an item depends on volume and the basic unit is "1 m²", the value "1000000000" [mm²] is filled in.
If the price calculation of an item is a price per piece and does not depend on any dimension, the field has to be set to "0".

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BASIC_PRICE_UNIT Element
Overview
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
If a price type (P1/PRICE_TYPE_REF) has been defined as basic price dependent this element is used for defining the unit for this basic price. The basic price unit depends on the number of dimensions which are set to "1" or "true".

If the price of an item depends on width and the price calculation is based on a unit of one and a half metres, the value "1500" has to be filled in here. If an item depends on volume and the basic unit is "1 m²", the value "1000000000" [mm²] is filled in.
If the price calculation of an item is a price per piece and does not depend on any dimension, the field has to be set to "0".

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
Source
<xs:element name="BASIC_PRICE_UNIT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_TYPE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PRICE_TYPE_REF Element
Description
This element references a price type. Price types are defined by the element path 1/PRICE_TYPE.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPE
Namespace (none)
Diagram
PRICE_TYPE_REF Element
Overview
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 1/PRICE_TYPE.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPE
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
PRICE_TYPE_NO Restriction of xs:positiveInteger required
This attribute identifies a price type. D positiveInteger
P
M [1:999]
Remarks

Source
<xs:element name="PRICE_TYPE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400/407--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400/407--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CALC_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CALC_GROUP_REF Element
Description
This element references calculation groups. Calculation groups are defined in the merchandise groups (PRICE_DEFINITION/MERCHANDISE_GROUP).
Namespace (none)
Diagram
CALC_GROUP_REF Element
Overview
CALC_GROUP_REF
This element references calculation groups. Calculation groups are defined in the merchandise groups (PRICE_DEFINITION/MERCHANDISE_GROUP).
CALC_GROUP_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [10:99]
Attributes
Name Type Use Default Fixed Description
CALC_GROUP_NO Restriction of xs:positiveInteger required
This attribute identifies a price type. D positiveInteger
P
M [10:99]
Remarks

Source
<xs:element name="CALC_GROUP_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="CALC_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="10" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EXCHANGE_ID_REF Element
Description
This element references an exchange-ID which is defined in the element path 1/EXCHANGE_ID.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_I
Namespace (none)
Diagram
EXCHANGE_ID_REF Element
Overview
EXCHANGE_ID_REF optional
This element references an exchange-ID which is defined in the element path 1/EXCHANGE_ID.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_I
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attributes
Name Type Use Default Fixed Description
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Remarks

Source
<xs:element name="EXCHANGE_ID_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ADDITIONAL_PRICE_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ADDITIONAL_PRICE_GROUP Element
Description
This element references PRICE_FEATURE_GROUPS with additional price groups. The basic price feature groups which is referenced excatly one time by an item is defined in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF .

All items which reference the same PRICE_FEATURE_GROUP have also to reference the same calculation group (CALC_GROUP_REF) and exchange-ID (EXCHANGE_ID_REF).

If different price types (item prices/ surcharge prices) are assigned to an item, the following combinations are permitted:

Item | Surcharge
Price per piece | Price per piece
Price depending on length | Price depending on length
Price depending on length | Price per piece

The following combinations are NOT permitted:

Item | Surcharge
Price per piece | Price depending on length
Namespace (none)
Diagram
PRICE_TYPE_REF Element EXCHANGE_ID_REF Element CALC_GROUP_REF Element PRICE_FEATURE_GROUP_REF Element Sequence ADDITIONAL_PRICE_GROUP Element
Overview
ADDITIONAL_PRICE_GROUP 0..∞
This element references PRICE_FEATURE_GROUPS with additional price groups. The basic price feature groups which is referenced excatly one time by an item is defined in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF .

All items which reference the same PRICE_FEATURE_GROUP have also to reference the same calculation group (CALC_GROUP_REF) and exchange-ID (EXCHANGE_ID_REF).

If different price types (item prices/ surcharge prices) are assigned to an item, the following combinations are permitted:

Item | Surcharge
Price per piece | Price per piece
Price depending on length | Price depending on length
Price depending on length | Price per piece

The following combinations are NOT permitted:

Item | Surcharge
Price per piece | Price depending on length
Sequence
PRICE_FEATURE_GROUP_REF
This element references a surcharge group. Surcharge groups which are referenced here may not be used as feature groups.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a surcharge group. D positiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
This element is used for the definition of an item price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element references a price group. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
The prices are filled in according to the price groups of an item (price field). Prices have to be defined in the smallest currency unit (e.g. instead of 300,00 [€], 30000 [Cent]). Fields may also contain negative prices. These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(Example: field with 9 digits; the figure minus 9,00 € shall be filled in : -900) 		D integer
P
M [-99999999:999999999]
CALC_GROUP_REF optional
This element references calculation groups. The calculation groups are defined within the merchandise groups(PRICE_DEFINITION/MERCHANDISE_GROUP).
CALC_GROUP_NO required Restriction of xs:positiveInteger
This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
The calculation group does not correspond with the suppliers scales of conditions. 		D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS. The exchange-ID references block items.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
All exchange-IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The value 0 may only be used in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 11/PRICE_TYPE.

Element paths:
path1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
Remarks

Source
<xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP_REF">
        <xs:annotation>
          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>460--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FIELD">
                    <xs:annotation>
                      <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE">
                    <xs:annotation>
                      <xs:documentation>460--5--Preis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="-99999999" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CALC_GROUP_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="CALC_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="10" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>407--7--Tausch_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>407--7--Tausch_ID</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_TYPE_REF">
        <xs:annotation>
          <xs:documentation>407--5--Preisart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PRICE_TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>407--5--Preisart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element : PRICE_FEATURE_GROUP_REF Element
Description
This element references a surcharge group. Surcharge groups which are referenced here may not be used as feature groups.
Namespace (none)
Diagram
ITEM_PRICE Element Sequence PRICE_FEATURE_GROUP_REF Element
Overview
PRICE_FEATURE_GROUP_REF
This element references a surcharge group. Surcharge groups which are referenced here may not be used as feature groups.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a surcharge group. D positiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
This element is used for the definition of an item price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element references a price group. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
The prices are filled in according to the price groups of an item (price field). Prices have to be defined in the smallest currency unit (e.g. instead of 300,00 [€], 30000 [Cent]). Fields may also contain negative prices. These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(Example: field with 9 digits; the figure minus 9,00 € shall be filled in : -900) 		D integer
P
M [-99999999:999999999]
Attributes
Name Type Use Default Fixed Description
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
This attribute references a surcharge group. D positiveInteger
P
M [1:99999]
Source
<xs:element name="PRICE_FEATURE_GROUP_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>460--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE">
              <xs:annotation>
                <xs:documentation>460--5--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_PRICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element > PRICE_FEATURE_GROUP_REF Element : ITEM_PRICE Element
Description
This element is used for the definition of an item price.
Namespace (none)
Diagram
PRICE Element PRICE_FIELD Element Sequence ITEM_PRICE Element
Overview
ITEM_PRICE 1..∞
This element is used for the definition of an item price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
This element references a price group. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
The prices are filled in according to the price groups of an item (price field). Prices have to be defined in the smallest currency unit (e.g. instead of 300,00 [€], 30000 [Cent]). Fields may also contain negative prices. These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(Example: field with 9 digits; the figure minus 9,00 € shall be filled in : -900) 		D integer
P
M [-99999999:999999999]
Source
<xs:element name="ITEM_PRICE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>460--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE">
        <xs:annotation>
          <xs:documentation>460--5--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_FEATURE_GROUP_REF Element | ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FIELD Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element > PRICE_FEATURE_GROUP_REF Element > ITEM_PRICE Element : PRICE_FIELD Element
Description
This element references a price group. D positiveInteger
P
M [1:250]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger
This element references a price group. D positiveInteger
P
M [1:250]
Source
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_REF Element | ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element > PRICE_FEATURE_GROUP_REF Element > ITEM_PRICE Element : PRICE Element
Description
The prices are filled in according to the price groups of an item (price field). Prices have to be defined in the smallest currency unit (e.g. instead of 300,00 [€], 30000 [Cent]). Fields may also contain negative prices. These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(Example: field with 9 digits; the figure minus 9,00 € shall be filled in : -900) 		D integer
P
M [-99999999:999999999]
Namespace (none)
Type
Restriction of xs:integer
Diagram
PRICE Element
Overview
PRICE Restriction of xs:integer
The prices are filled in according to the price groups of an item (price field). Prices have to be defined in the smallest currency unit (e.g. instead of 300,00 [€], 30000 [Cent]). Fields may also contain negative prices. These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(Example: field with 9 digits; the figure minus 9,00 € shall be filled in : -900) 		D integer
P
M [-99999999:999999999]
Source
<xs:element name="PRICE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>460--5--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_REF Element | ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CALC_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element : CALC_GROUP_REF Element
Description
This element references calculation groups. The calculation groups are defined within the merchandise groups(PRICE_DEFINITION/MERCHANDISE_GROUP).
Namespace (none)
Diagram
CALC_GROUP_REF Element
Overview
CALC_GROUP_REF optional
This element references calculation groups. The calculation groups are defined within the merchandise groups(PRICE_DEFINITION/MERCHANDISE_GROUP).
CALC_GROUP_NO required Restriction of xs:positiveInteger
This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
The calculation group does not correspond with the suppliers scales of conditions. 		D positiveInteger
P
M [10:99]
Attributes
Name Type Use Default Fixed Description
CALC_GROUP_NO Restriction of xs:positiveInteger required
This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
The calculation group does not correspond with the suppliers scales of conditions. 		D positiveInteger
P
M [10:99]
Source
<xs:element name="CALC_GROUP_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="CALC_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="10" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element : EXCHANGE_ID_REF Element
Description
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS. The exchange-ID references block items.
Namespace (none)
Diagram
EXCHANGE_ID_REF Element
Overview
EXCHANGE_ID_REF optional
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS. The exchange-ID references block items.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
All exchange-IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The value 0 may only be used in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
Attributes
Name Type Use Default Fixed Description
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
All exchange-IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The value 0 may only be used in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
Source
<xs:element name="EXCHANGE_ID_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>407--7--Tausch_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>407--7--Tausch_ID</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_TYPE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element : PRICE_TYPE_REF Element
Description
This element references a price type. Price types are defined by the element path 11/PRICE_TYPE.

Element paths:
path1: PRICE_DEFINITION/PRICE_TYPES
Namespace (none)
Diagram
PRICE_TYPE_REF Element
Overview
PRICE_TYPE_REF
This element references a price type. Price types are defined by the element path 11/PRICE_TYPE.

Element paths:
path1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type. D positiveInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
PRICE_TYPE_NO Restriction of xs:positiveInteger required
This attribute identifies a price type. D positiveInteger
P
M [1:999]
Source
<xs:element name="PRICE_TYPE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>407--5--Preisart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>407--5--Preisart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : RESTRICTIONS Element
Description
This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Namespace (none)
Diagram
RESTRICTION_REF Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional
This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Sequence
RESTRICTION_REF 1..∞
This element references an item to an assigned restriction.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
Source
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>409--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>409--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>409--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>409--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="99999" />
                <xs:minInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > RESTRICTIONS Element : RESTRICTION_REF Element
Description
This element references an item to an assigned restriction.
Namespace (none)
Diagram
RESTRICTION_REF Element
Overview
RESTRICTION_REF 1..∞
This element references an item to an assigned restriction.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
Attributes
Name Type Use Default Fixed Description
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE Restriction of xs:nonNegativeInteger required
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
Source
<xs:element name="RESTRICTION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>409--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>409--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>409--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="99999" />
          <xs:minInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
RESTRICTIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ADDITIONAL_ITEMS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ADDITIONAL_ITEMS Element
Description
This element is used for assigning additional items. A number of optional and/or mandatory additional items is defined which the user may select from in the planning process.
Namespace (none)
Diagram
OPERATION_ITEM Element MANDATORY_ITEMS Element OPTIONAL_ITEMS Element Sequence ADDITIONAL_ITEMS Element
Overview
ADDITIONAL_ITEMS optional
This element is used for assigning additional items. A number of optional and/or mandatory additional items is defined which the user may select from in the planning process.
Sequence
OPTIONAL_ITEMS optional
This element references optional additional items. The number of optional items is not restricted. Items which are defined as linked items may not be used as additional items.
Sequence
OPTIONAL_ITEM_GROUP 1..9
This element is used for defining a group of optional additional items.
SET_NO required Restriction of xs:positiveInteger
A certain number of optional items is available for the main item. In case the field MULTIPLE_CHOICE is set to "true", different optional items can be selected from the total number of available options. If the number of optional items is limited to one, this optional item is selected automatically.
1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
This attribute defines if mulitple optional items are available for a main item.

true = multiple selection permitted 		D boolean
P
M
Sequence
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
This element references an optional additional item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY optional Restriction of xs:positiveInteger
Number of additional items. Default value for planning software systems. In case of optional additional items this default value is a non-binding proposal. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
MANDATORY_ITEMS optional
This element is used for assigning mandatory additional items to a main item. For each main item the number of mandatory additional items is restricted to 1 but different groups of mandatory items may be assigned to one main item.
If only 1 additional item is assigned to a group this additional item is automatically transferred into the planning
Sequence
MANDATORY_ITEM_GROUP 1..9
This element is used for defining a group of mandatory additional items. Exactly one of these mandatory additional items has to be chosen in the course of the planning.
SET_NO required Restriction of xs:positiveInteger
A number of mandatory additional items can be defined for one main item. Exactly one item has to be selected from this group of mandatory additional items. If only 1 mandatory additional item is assigned to a group this additional item is automatically selected in the planning.

1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
Sequence
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
This element references an item
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
MANDATORY_QUANTITY optional Restriction of xs:positiveInteger
Number of additional items. Default value for planning software systems. For mandatory additional items this default value is binding. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
OPERATION_ITEM optional
This element is used for assigning items to special models, surcharges for mitres, visible sides, or cut outs. The different ways of combination are defined by the elements ITEM_REF/SCOPE (path 1) and CLASS (path 1).

Linked items may not be used as additional items.
Linked items may not be used as additional items.

The following examples illustrate the different possibilities of combination:
- Assignment of surcharges for mitres for cornices, light pelmets,plinths
- Assignment of visible sides for items (range dependent/ range independent)
- Assignment of formed pieces, returns etc. for cornices, light pelmets, plinths
- Assignment of lateral plinth to straight plinth boards
- Assignment of cut outs, tongue and groove for worktops
- Assignment of legal measurement changes, i.e. width-, height-, depth reductions.

In case special models/ items are assigned to an item in this element, only these specially defined models/ items are legal, if no assignments are explicitly defined, all special models are permitted.
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
Sequence
SCOPE 1..5
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required.
SCOPE_NO required Restriction of xs:positiveInteger
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required. 		D positiveInteger
P
M [1:5]
Sequence
ITEM_INFORMATION 1..∞
This element contains all information referring to the scope of an item (e.g. type, plinth, cornice, light pelmet, worktop).
Sequence
CLASS Restriction of xs:positiveInteger

This element defines the type of assignment. The following types are defined:
1 = visible side
2 = lateral plinth
3 = form piece
4 = return
5 = transitions
6 = surcharge mitre
7 = width reduction
8 = depth reduction
9 = height reduction
10 = cut-out
11 = rectangular cut-out
12 = round cut-out
13 = jog
14 = chamfer
15 = rounding
16 = tongue and groove
17 = edge for VALUE 5
18 = width extension for VALUE 1
19 = depth extension for VALUE 1
20 = height extension to value 1
21 = deviation from default plinth

Values defined in this element refer to the values set in the element SCOPE. The following rules apply:

element SCOPE value 1 => element CLASS values 1, 2, 3, 7, 8, 9, 18 - 20
element SCOPE value 2 => element CLASS values 2 to 6, value 21
element SCOPE values 3 or 4 => element CLASS values 3 and 6
element SCOPE value 5 => element CLASS values 10 - 17

 D positiveInteger
P
M [1:21]
ITEM_REF optional
Settings in this field indicate the type (operation_item) which is assigned to the target-type. The operation item either requires the same series number as the target-type or it has to be assigned to series 0.

This element has to be defined if the element CLASS (path 1) contains values for form piece (3), return (4), or transition (5).

If this element is not defined the element VALUE (path 1) is required.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
CONSTRUCTION_ID optional Restriction of xs:string
This element refers to the method of construction for an item, depending on the basic carcase shape.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical. 		D string
P |[LNR]
M [1:1]
COVER optional Restriction of xs:positiveInteger
The value 3 (form piece) in the field CLASS requires settings in this element. In all other cases this field has to be left blank. Different types of covers are defined: basic cover, part cover, total cover. The different types of cover for form pieces depend on the defined basic shape.The assignment of cover types is listed in table "Assignment of cover types".

With respect to the chosen cover type the following values are permitted:
1 = basic cover
2 = part cover
3 = total cover 		D nonNegativeInteger
P
M [1:3]
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
If assignments for plinth, cornices, light pelmets (scope 2-4) are defined, the assignment to a basic shape has to be defined in this element. Settings in this field are required if values 2 - 4 are entered in the field SCOPE. If the values 1 and 5 are set, this element has to be left blank. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
VALUE optional Restriction of xs:nonNegativeInteger
The additional measurement for a mitre (given in mm) is defined in this element. D nonNegativeInteger
P
M [0:999999999]
VALUE_MIN optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the minimum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element. D nonNegativeInteger
P
M [0:999999999]
VALUE_MAX optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the maximum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element.CLASS D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="ADDITIONAL_ITEMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="GROUP_TITLE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                        <xs:annotation>
                          <xs:documentation>406--7--Anzahl</xs:documentation>
                          <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>Version 2.4.1</xs:documentation>
                          <xs:documentation>geändert 13.09.2016</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:maxInclusive value="99999" />
                            <xs:minInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SET_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MANDATORY_ITEMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="GROUP_TITLE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                        <xs:annotation>
                          <xs:documentation>406--7--Anzahl</xs:documentation>
                          <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>Version 2.4.1</xs:documentation>
                          <xs:documentation>geändert 13.09.2016</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:maxInclusive value="99999" />
                            <xs:minInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SET_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPERATION_ITEM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SCOPE" maxOccurs="5">
              <xs:annotation>
                <xs:documentation>411--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>411--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLASS">
                          <xs:annotation>
                            <xs:documentation>411--7--Art</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="21" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>411--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>411--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[LNR]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="COVER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--9--Abdeckung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="3" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--10--Wert</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE_MIN" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--10--minimaler Wert</xs:documentation>
                            <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE_MAX" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--10--maximaler Wert</xs:documentation>
                            <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SCOPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>411--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTIONAL_ITEMS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element : OPTIONAL_ITEMS Element
Description
This element references optional additional items. The number of optional items is not restricted. Items which are defined as linked items may not be used as additional items.
Namespace (none)
Diagram
OPTIONAL_ITEM_GROUP Element Sequence OPTIONAL_ITEMS Element
Overview
OPTIONAL_ITEMS optional
This element references optional additional items. The number of optional items is not restricted. Items which are defined as linked items may not be used as additional items.
Sequence
OPTIONAL_ITEM_GROUP 1..9
This element is used for defining a group of optional additional items.
SET_NO required Restriction of xs:positiveInteger
A certain number of optional items is available for the main item. In case the field MULTIPLE_CHOICE is set to "true", different optional items can be selected from the total number of available options. If the number of optional items is limited to one, this optional item is selected automatically.
1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
This attribute defines if mulitple optional items are available for a main item.

true = multiple selection permitted 		D boolean
P
M
Sequence
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
This element references an optional additional item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY optional Restriction of xs:positiveInteger
Number of additional items. Default value for planning software systems. In case of optional additional items this default value is a non-binding proposal. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="OPTIONAL_ITEMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="GROUP_TITLE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="GROUP_TITLE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEM_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                  <xs:annotation>
                    <xs:documentation>406--7--Anzahl</xs:documentation>
                    <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>Version 2.4.1</xs:documentation>
                    <xs:documentation>geändert 13.09.2016</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:maxInclusive value="99999" />
                      <xs:minInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SET_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTIONAL_ITEM_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPTIONAL_ITEMS Element : OPTIONAL_ITEM_GROUP Element
Description
This element is used for defining a group of optional additional items.
Namespace (none)
Diagram
ITEM_REF Element GROUP_TITLE_REF Element Sequence OPTIONAL_ITEM_GROUP Element
Overview
OPTIONAL_ITEM_GROUP 1..9
This element is used for defining a group of optional additional items.
SET_NO required Restriction of xs:positiveInteger
A certain number of optional items is available for the main item. In case the field MULTIPLE_CHOICE is set to "true", different optional items can be selected from the total number of available options. If the number of optional items is limited to one, this optional item is selected automatically.
1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
This attribute defines if mulitple optional items are available for a main item.

true = multiple selection permitted 		D boolean
P
M
Sequence
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
This element references an optional additional item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY optional Restriction of xs:positiveInteger
Number of additional items. Default value for planning software systems. In case of optional additional items this default value is a non-binding proposal. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
Attributes
Name Type Use Default Fixed Description
SET_NO Restriction of xs:positiveInteger required
A certain number of optional items is available for the main item. In case the field MULTIPLE_CHOICE is set to "true", different optional items can be selected from the total number of available options. If the number of optional items is limited to one, this optional item is selected automatically.
1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE xs:boolean required
This attribute defines if mulitple optional items are available for a main item.

true = multiple selection permitted 		D boolean
P
M
Source
<xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="GROUP_TITLE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="GROUP_TITLE_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEM_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
            <xs:annotation>
              <xs:documentation>406--7--Anzahl</xs:documentation>
              <xs:documentation>K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>Version 2.4.1</xs:documentation>
              <xs:documentation>geändert 13.09.2016</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="99999" />
                <xs:minInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SET_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
  </xs:complexType>
</xs:element>
See Also
OPTIONAL_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GROUP_TITLE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPTIONAL_ITEMS Element > OPTIONAL_ITEM_GROUP Element : GROUP_TITLE_REF Element
Description
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
Namespace (none)
Diagram
GROUP_TITLE_REF Element
Overview
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
GROUP_TITLE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
Source
<xs:element name="GROUP_TITLE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="GROUP_TITLE_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONAL_ITEM_GROUP Element | OPTIONAL_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPTIONAL_ITEMS Element > OPTIONAL_ITEM_GROUP Element : ITEM_REF Element
Description
This element references an optional additional item.
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF 1..∞
This element references an optional additional item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY optional Restriction of xs:positiveInteger
Number of additional items. Default value for planning software systems. In case of optional additional items this default value is a non-binding proposal. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO Restriction of xs:string required
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY Restriction of xs:positiveInteger optional
Number of additional items. Default value for planning software systems. In case of optional additional items this default value is a non-binding proposal. D nonNegativeInteger
P
M [1:999]
SEQUENCE Restriction of xs:nonNegativeInteger required
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="ITEM_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
      <xs:annotation>
        <xs:documentation>406--7--Anzahl</xs:documentation>
        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>Version 2.4.1</xs:documentation>
        <xs:documentation>geändert 13.09.2016</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="99999" />
          <xs:minInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONAL_ITEM_GROUP Element | OPTIONAL_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANDATORY_ITEMS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element : MANDATORY_ITEMS Element
Description
This element is used for assigning mandatory additional items to a main item. For each main item the number of mandatory additional items is restricted to 1 but different groups of mandatory items may be assigned to one main item.
If only 1 additional item is assigned to a group this additional item is automatically transferred into the planning
Namespace (none)
Diagram
MANDATORY_ITEM_GROUP Element Sequence MANDATORY_ITEMS Element
Overview
MANDATORY_ITEMS optional
This element is used for assigning mandatory additional items to a main item. For each main item the number of mandatory additional items is restricted to 1 but different groups of mandatory items may be assigned to one main item.
If only 1 additional item is assigned to a group this additional item is automatically transferred into the planning
Sequence
MANDATORY_ITEM_GROUP 1..9
This element is used for defining a group of mandatory additional items. Exactly one of these mandatory additional items has to be chosen in the course of the planning.
SET_NO required Restriction of xs:positiveInteger
A number of mandatory additional items can be defined for one main item. Exactly one item has to be selected from this group of mandatory additional items. If only 1 mandatory additional item is assigned to a group this additional item is automatically selected in the planning.

1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
Sequence
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
This element references an item
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
MANDATORY_QUANTITY optional Restriction of xs:positiveInteger
Number of additional items. Default value for planning software systems. For mandatory additional items this default value is binding. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="MANDATORY_ITEMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="GROUP_TITLE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="GROUP_TITLE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEM_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                  <xs:annotation>
                    <xs:documentation>406--7--Anzahl</xs:documentation>
                    <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>Version 2.4.1</xs:documentation>
                    <xs:documentation>geändert 13.09.2016</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:maxInclusive value="99999" />
                      <xs:minInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SET_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANDATORY_ITEM_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > MANDATORY_ITEMS Element : MANDATORY_ITEM_GROUP Element
Description
This element is used for defining a group of mandatory additional items. Exactly one of these mandatory additional items has to be chosen in the course of the planning.
Namespace (none)
Diagram
ITEM_REF Element GROUP_TITLE_REF Element Sequence MANDATORY_ITEM_GROUP Element
Overview
MANDATORY_ITEM_GROUP 1..9
This element is used for defining a group of mandatory additional items. Exactly one of these mandatory additional items has to be chosen in the course of the planning.
SET_NO required Restriction of xs:positiveInteger
A number of mandatory additional items can be defined for one main item. Exactly one item has to be selected from this group of mandatory additional items. If only 1 mandatory additional item is assigned to a group this additional item is automatically selected in the planning.

1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
Sequence
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
This element references an item
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
MANDATORY_QUANTITY optional Restriction of xs:positiveInteger
Number of additional items. Default value for planning software systems. For mandatory additional items this default value is binding. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
Attributes
Name Type Use Default Fixed Description
SET_NO Restriction of xs:positiveInteger required
A number of mandatory additional items can be defined for one main item. Exactly one item has to be selected from this group of mandatory additional items. If only 1 mandatory additional item is assigned to a group this additional item is automatically selected in the planning.

1-9 = status for the definition of optional additional item groups. 		D positiveInteger
P
M [1:9]
Source
<xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="GROUP_TITLE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="GROUP_TITLE_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEM_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MANDATORY_QUANTITY" use="optional">
            <xs:annotation>
              <xs:documentation>406--7--Anzahl</xs:documentation>
              <xs:documentation>K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>Version 2.4.1</xs:documentation>
              <xs:documentation>geändert 13.09.2016</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="99999" />
                <xs:minInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SET_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
MANDATORY_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GROUP_TITLE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > MANDATORY_ITEMS Element > MANDATORY_ITEM_GROUP Element : GROUP_TITLE_REF Element
Description
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
Namespace (none)
Diagram
GROUP_TITLE_REF Element
Overview
GROUP_TITLE_REF optional
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
GROUP_TITLE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to identify a group title. D positiveInteger
P
M [0:999]
Source
<xs:element name="GROUP_TITLE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="GROUP_TITLE_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
MANDATORY_ITEM_GROUP Element | MANDATORY_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > MANDATORY_ITEMS Element > MANDATORY_ITEM_GROUP Element : ITEM_REF Element
Description
This element references an item
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF 1..∞
This element references an item
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
MANDATORY_QUANTITY optional Restriction of xs:positiveInteger
Number of additional items. Default value for planning software systems. For mandatory additional items this default value is binding. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO Restriction of xs:string required
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
MANDATORY_QUANTITY Restriction of xs:positiveInteger optional
Number of additional items. Default value for planning software systems. For mandatory additional items this default value is binding. D nonNegativeInteger
P
M [1:999]
SEQUENCE Restriction of xs:nonNegativeInteger required
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="ITEM_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MANDATORY_QUANTITY" use="optional">
      <xs:annotation>
        <xs:documentation>406--7--Anzahl</xs:documentation>
        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>Version 2.4.1</xs:documentation>
        <xs:documentation>geändert 13.09.2016</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="99999" />
          <xs:minInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
MANDATORY_ITEM_GROUP Element | MANDATORY_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPERATION_ITEM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element : OPERATION_ITEM Element
Description
This element is used for assigning items to special models, surcharges for mitres, visible sides, or cut outs. The different ways of combination are defined by the elements ITEM_REF/SCOPE (path 1) and CLASS (path 1).

Linked items may not be used as additional items.
Linked items may not be used as additional items.

The following examples illustrate the different possibilities of combination:
- Assignment of surcharges for mitres for cornices, light pelmets,plinths
- Assignment of visible sides for items (range dependent/ range independent)
- Assignment of formed pieces, returns etc. for cornices, light pelmets, plinths
- Assignment of lateral plinth to straight plinth boards
- Assignment of cut outs, tongue and groove for worktops
- Assignment of legal measurement changes, i.e. width-, height-, depth reductions.

In case special models/ items are assigned to an item in this element, only these specially defined models/ items are legal, if no assignments are explicitly defined, all special models are permitted.
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
Namespace (none)
Diagram
SCOPE Element Sequence OPERATION_ITEM Element
Overview
OPERATION_ITEM optional
This element is used for assigning items to special models, surcharges for mitres, visible sides, or cut outs. The different ways of combination are defined by the elements ITEM_REF/SCOPE (path 1) and CLASS (path 1).

Linked items may not be used as additional items.
Linked items may not be used as additional items.

The following examples illustrate the different possibilities of combination:
- Assignment of surcharges for mitres for cornices, light pelmets,plinths
- Assignment of visible sides for items (range dependent/ range independent)
- Assignment of formed pieces, returns etc. for cornices, light pelmets, plinths
- Assignment of lateral plinth to straight plinth boards
- Assignment of cut outs, tongue and groove for worktops
- Assignment of legal measurement changes, i.e. width-, height-, depth reductions.

In case special models/ items are assigned to an item in this element, only these specially defined models/ items are legal, if no assignments are explicitly defined, all special models are permitted.
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
Sequence
SCOPE 1..5
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required.
SCOPE_NO required Restriction of xs:positiveInteger
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required. 		D positiveInteger
P
M [1:5]
Sequence
ITEM_INFORMATION 1..∞
This element contains all information referring to the scope of an item (e.g. type, plinth, cornice, light pelmet, worktop).
Sequence
CLASS Restriction of xs:positiveInteger

This element defines the type of assignment. The following types are defined:
1 = visible side
2 = lateral plinth
3 = form piece
4 = return
5 = transitions
6 = surcharge mitre
7 = width reduction
8 = depth reduction
9 = height reduction
10 = cut-out
11 = rectangular cut-out
12 = round cut-out
13 = jog
14 = chamfer
15 = rounding
16 = tongue and groove
17 = edge for VALUE 5
18 = width extension for VALUE 1
19 = depth extension for VALUE 1
20 = height extension to value 1
21 = deviation from default plinth

Values defined in this element refer to the values set in the element SCOPE. The following rules apply:

element SCOPE value 1 => element CLASS values 1, 2, 3, 7, 8, 9, 18 - 20
element SCOPE value 2 => element CLASS values 2 to 6, value 21
element SCOPE values 3 or 4 => element CLASS values 3 and 6
element SCOPE value 5 => element CLASS values 10 - 17

 D positiveInteger
P
M [1:21]
ITEM_REF optional
Settings in this field indicate the type (operation_item) which is assigned to the target-type. The operation item either requires the same series number as the target-type or it has to be assigned to series 0.

This element has to be defined if the element CLASS (path 1) contains values for form piece (3), return (4), or transition (5).

If this element is not defined the element VALUE (path 1) is required.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
CONSTRUCTION_ID optional Restriction of xs:string
This element refers to the method of construction for an item, depending on the basic carcase shape.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical. 		D string
P |[LNR]
M [1:1]
COVER optional Restriction of xs:positiveInteger
The value 3 (form piece) in the field CLASS requires settings in this element. In all other cases this field has to be left blank. Different types of covers are defined: basic cover, part cover, total cover. The different types of cover for form pieces depend on the defined basic shape.The assignment of cover types is listed in table "Assignment of cover types".

With respect to the chosen cover type the following values are permitted:
1 = basic cover
2 = part cover
3 = total cover 		D nonNegativeInteger
P
M [1:3]
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
If assignments for plinth, cornices, light pelmets (scope 2-4) are defined, the assignment to a basic shape has to be defined in this element. Settings in this field are required if values 2 - 4 are entered in the field SCOPE. If the values 1 and 5 are set, this element has to be left blank. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
VALUE optional Restriction of xs:nonNegativeInteger
The additional measurement for a mitre (given in mm) is defined in this element. D nonNegativeInteger
P
M [0:999999999]
VALUE_MIN optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the minimum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element. D nonNegativeInteger
P
M [0:999999999]
VALUE_MAX optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the maximum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element.CLASS D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="OPERATION_ITEM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SCOPE" maxOccurs="5">
        <xs:annotation>
          <xs:documentation>411--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>411--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLASS">
                    <xs:annotation>
                      <xs:documentation>411--7--Art</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="21" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>411--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>411--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[LNR]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="COVER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--9--Abdeckung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--10--Wert</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE_MIN" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--10--minimaler Wert</xs:documentation>
                      <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE_MAX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--10--maximaler Wert</xs:documentation>
                      <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SCOPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>411--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SCOPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element : SCOPE Element
Description
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required.
Namespace (none)
Diagram
ITEM_INFORMATION Element Sequence SCOPE Element
Overview
SCOPE 1..5
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required.
SCOPE_NO required Restriction of xs:positiveInteger
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required. 		D positiveInteger
P
M [1:5]
Sequence
ITEM_INFORMATION 1..∞
This element contains all information referring to the scope of an item (e.g. type, plinth, cornice, light pelmet, worktop).
Sequence
CLASS Restriction of xs:positiveInteger

This element defines the type of assignment. The following types are defined:
1 = visible side
2 = lateral plinth
3 = form piece
4 = return
5 = transitions
6 = surcharge mitre
7 = width reduction
8 = depth reduction
9 = height reduction
10 = cut-out
11 = rectangular cut-out
12 = round cut-out
13 = jog
14 = chamfer
15 = rounding
16 = tongue and groove
17 = edge for VALUE 5
18 = width extension for VALUE 1
19 = depth extension for VALUE 1
20 = height extension to value 1
21 = deviation from default plinth

Values defined in this element refer to the values set in the element SCOPE. The following rules apply:

element SCOPE value 1 => element CLASS values 1, 2, 3, 7, 8, 9, 18 - 20
element SCOPE value 2 => element CLASS values 2 to 6, value 21
element SCOPE values 3 or 4 => element CLASS values 3 and 6
element SCOPE value 5 => element CLASS values 10 - 17

 D positiveInteger
P
M [1:21]
ITEM_REF optional
Settings in this field indicate the type (operation_item) which is assigned to the target-type. The operation item either requires the same series number as the target-type or it has to be assigned to series 0.

This element has to be defined if the element CLASS (path 1) contains values for form piece (3), return (4), or transition (5).

If this element is not defined the element VALUE (path 1) is required.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
CONSTRUCTION_ID optional Restriction of xs:string
This element refers to the method of construction for an item, depending on the basic carcase shape.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical. 		D string
P |[LNR]
M [1:1]
COVER optional Restriction of xs:positiveInteger
The value 3 (form piece) in the field CLASS requires settings in this element. In all other cases this field has to be left blank. Different types of covers are defined: basic cover, part cover, total cover. The different types of cover for form pieces depend on the defined basic shape.The assignment of cover types is listed in table "Assignment of cover types".

With respect to the chosen cover type the following values are permitted:
1 = basic cover
2 = part cover
3 = total cover 		D nonNegativeInteger
P
M [1:3]
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
If assignments for plinth, cornices, light pelmets (scope 2-4) are defined, the assignment to a basic shape has to be defined in this element. Settings in this field are required if values 2 - 4 are entered in the field SCOPE. If the values 1 and 5 are set, this element has to be left blank. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
VALUE optional Restriction of xs:nonNegativeInteger
The additional measurement for a mitre (given in mm) is defined in this element. D nonNegativeInteger
P
M [0:999999999]
VALUE_MIN optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the minimum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element. D nonNegativeInteger
P
M [0:999999999]
VALUE_MAX optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the maximum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element.CLASS D nonNegativeInteger
P
M [0:999999999]
Attributes
Name Type Use Default Fixed Description
SCOPE_NO Restriction of xs:positiveInteger required
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required. 		D positiveInteger
P
M [1:5]
Source
<xs:element name="SCOPE" maxOccurs="5" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>411--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLASS">
              <xs:annotation>
                <xs:documentation>411--7--Art</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="21" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>411--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>411--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CONSTRUCTION_ID" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[LNR]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="COVER" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--9--Abdeckung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--10--Wert</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE_MIN" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--10--minimaler Wert</xs:documentation>
                <xs:documentation>13.06.2018/K.Richter</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE_MAX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--10--maximaler Wert</xs:documentation>
                <xs:documentation>13.06.2018/K.Richter</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SCOPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>411--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_INFORMATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element : ITEM_INFORMATION Element
Description
This element contains all information referring to the scope of an item (e.g. type, plinth, cornice, light pelmet, worktop).
Namespace (none)
Diagram
VALUE_MAX Element VALUE_MIN Element VALUE Element BASIC_SHAPE_REFERENCE Element COVER Element CONSTRUCTION_ID Element ITEM_REF Element CLASS Element Sequence ITEM_INFORMATION Element
Overview
ITEM_INFORMATION 1..∞
This element contains all information referring to the scope of an item (e.g. type, plinth, cornice, light pelmet, worktop).
Sequence
CLASS Restriction of xs:positiveInteger

This element defines the type of assignment. The following types are defined:
1 = visible side
2 = lateral plinth
3 = form piece
4 = return
5 = transitions
6 = surcharge mitre
7 = width reduction
8 = depth reduction
9 = height reduction
10 = cut-out
11 = rectangular cut-out
12 = round cut-out
13 = jog
14 = chamfer
15 = rounding
16 = tongue and groove
17 = edge for VALUE 5
18 = width extension for VALUE 1
19 = depth extension for VALUE 1
20 = height extension to value 1
21 = deviation from default plinth

Values defined in this element refer to the values set in the element SCOPE. The following rules apply:

element SCOPE value 1 => element CLASS values 1, 2, 3, 7, 8, 9, 18 - 20
element SCOPE value 2 => element CLASS values 2 to 6, value 21
element SCOPE values 3 or 4 => element CLASS values 3 and 6
element SCOPE value 5 => element CLASS values 10 - 17

 D positiveInteger
P
M [1:21]
ITEM_REF optional
Settings in this field indicate the type (operation_item) which is assigned to the target-type. The operation item either requires the same series number as the target-type or it has to be assigned to series 0.

This element has to be defined if the element CLASS (path 1) contains values for form piece (3), return (4), or transition (5).

If this element is not defined the element VALUE (path 1) is required.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
CONSTRUCTION_ID optional Restriction of xs:string
This element refers to the method of construction for an item, depending on the basic carcase shape.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical. 		D string
P |[LNR]
M [1:1]
COVER optional Restriction of xs:positiveInteger
The value 3 (form piece) in the field CLASS requires settings in this element. In all other cases this field has to be left blank. Different types of covers are defined: basic cover, part cover, total cover. The different types of cover for form pieces depend on the defined basic shape.The assignment of cover types is listed in table "Assignment of cover types".

With respect to the chosen cover type the following values are permitted:
1 = basic cover
2 = part cover
3 = total cover 		D nonNegativeInteger
P
M [1:3]
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
If assignments for plinth, cornices, light pelmets (scope 2-4) are defined, the assignment to a basic shape has to be defined in this element. Settings in this field are required if values 2 - 4 are entered in the field SCOPE. If the values 1 and 5 are set, this element has to be left blank. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
VALUE optional Restriction of xs:nonNegativeInteger
The additional measurement for a mitre (given in mm) is defined in this element. D nonNegativeInteger
P
M [0:999999999]
VALUE_MIN optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the minimum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element. D nonNegativeInteger
P
M [0:999999999]
VALUE_MAX optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the maximum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element.CLASS D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="ITEM_INFORMATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLASS">
        <xs:annotation>
          <xs:documentation>411--7--Art</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="21" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>411--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>411--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CONSTRUCTION_ID" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--4--Bauweise_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[LNR]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="COVER" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--9--Abdeckung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--10--Wert</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE_MIN" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--10--minimaler Wert</xs:documentation>
          <xs:documentation>13.06.2018/K.Richter</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE_MAX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--10--maximaler Wert</xs:documentation>
          <xs:documentation>13.06.2018/K.Richter</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLASS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : CLASS Element
Description

This element defines the type of assignment. The following types are defined:
1 = visible side
2 = lateral plinth
3 = form piece
4 = return
5 = transitions
6 = surcharge mitre
7 = width reduction
8 = depth reduction
9 = height reduction
10 = cut-out
11 = rectangular cut-out
12 = round cut-out
13 = jog
14 = chamfer
15 = rounding
16 = tongue and groove
17 = edge for VALUE 5
18 = width extension for VALUE 1
19 = depth extension for VALUE 1
20 = height extension to value 1
21 = deviation from default plinth

Values defined in this element refer to the values set in the element SCOPE. The following rules apply:

element SCOPE value 1 => element CLASS values 1, 2, 3, 7, 8, 9, 18 - 20
element SCOPE value 2 => element CLASS values 2 to 6, value 21
element SCOPE values 3 or 4 => element CLASS values 3 and 6
element SCOPE value 5 => element CLASS values 10 - 17

 D positiveInteger
P
M [1:21]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
CLASS Element
Overview
CLASS Restriction of xs:positiveInteger

This element defines the type of assignment. The following types are defined:
1 = visible side
2 = lateral plinth
3 = form piece
4 = return
5 = transitions
6 = surcharge mitre
7 = width reduction
8 = depth reduction
9 = height reduction
10 = cut-out
11 = rectangular cut-out
12 = round cut-out
13 = jog
14 = chamfer
15 = rounding
16 = tongue and groove
17 = edge for VALUE 5
18 = width extension for VALUE 1
19 = depth extension for VALUE 1
20 = height extension to value 1
21 = deviation from default plinth

Values defined in this element refer to the values set in the element SCOPE. The following rules apply:

element SCOPE value 1 => element CLASS values 1, 2, 3, 7, 8, 9, 18 - 20
element SCOPE value 2 => element CLASS values 2 to 6, value 21
element SCOPE values 3 or 4 => element CLASS values 3 and 6
element SCOPE value 5 => element CLASS values 10 - 17

 D positiveInteger
P
M [1:21]
Source
<xs:element name="CLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--7--Art</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="21" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : ITEM_REF Element
Description
Settings in this field indicate the type (operation_item) which is assigned to the target-type. The operation item either requires the same series number as the target-type or it has to be assigned to series 0.

This element has to be defined if the element CLASS (path 1) contains values for form piece (3), return (4), or transition (5).

If this element is not defined the element VALUE (path 1) is required.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF optional
Settings in this field indicate the type (operation_item) which is assigned to the target-type. The operation item either requires the same series number as the target-type or it has to be assigned to series 0.

This element has to be defined if the element CLASS (path 1) contains values for form piece (3), return (4), or transition (5).

If this element is not defined the element VALUE (path 1) is required.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO Restriction of xs:string required
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Source
<xs:element name="ITEM_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>411--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>411--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONSTRUCTION_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : CONSTRUCTION_ID Element
Description
This element refers to the method of construction for an item, depending on the basic carcase shape.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical. 		D string
P |[LNR]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
CONSTRUCTION_ID Element
Overview
CONSTRUCTION_ID optional Restriction of xs:string
This element refers to the method of construction for an item, depending on the basic carcase shape.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical. 		D string
P |[LNR]
M [1:1]
Source
<xs:element name="CONSTRUCTION_ID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--4--Bauweise_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[LNR]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COVER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : COVER Element
Description
The value 3 (form piece) in the field CLASS requires settings in this element. In all other cases this field has to be left blank. Different types of covers are defined: basic cover, part cover, total cover. The different types of cover for form pieces depend on the defined basic shape.The assignment of cover types is listed in table "Assignment of cover types".

With respect to the chosen cover type the following values are permitted:
1 = basic cover
2 = part cover
3 = total cover 		D nonNegativeInteger
P
M [1:3]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
COVER Element
Overview
COVER optional Restriction of xs:positiveInteger
The value 3 (form piece) in the field CLASS requires settings in this element. In all other cases this field has to be left blank. Different types of covers are defined: basic cover, part cover, total cover. The different types of cover for form pieces depend on the defined basic shape.The assignment of cover types is listed in table "Assignment of cover types".

With respect to the chosen cover type the following values are permitted:
1 = basic cover
2 = part cover
3 = total cover 		D nonNegativeInteger
P
M [1:3]
Source
<xs:element name="COVER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--9--Abdeckung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_SHAPE_REFERENCE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : BASIC_SHAPE_REFERENCE Element
Description
If assignments for plinth, cornices, light pelmets (scope 2-4) are defined, the assignment to a basic shape has to be defined in this element. Settings in this field are required if values 2 - 4 are entered in the field SCOPE. If the values 1 and 5 are set, this element has to be left blank. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BASIC_SHAPE_REFERENCE Element
Overview
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
If assignments for plinth, cornices, light pelmets (scope 2-4) are defined, the assignment to a basic shape has to be defined in this element. Settings in this field are required if values 2 - 4 are entered in the field SCOPE. If the values 1 and 5 are set, this element has to be left blank. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
Source
<xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : VALUE Element
Description
The additional measurement for a mitre (given in mm) is defined in this element. D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
VALUE Element
Overview
VALUE optional Restriction of xs:nonNegativeInteger
The additional measurement for a mitre (given in mm) is defined in this element. D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--10--Wert</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE_MIN Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : VALUE_MIN Element
Description
This element is used to specify the measurement in mm for the minimum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element. D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
VALUE_MIN Element
Overview
VALUE_MIN optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the minimum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element. D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="VALUE_MIN" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--10--minimaler Wert</xs:documentation>
    <xs:documentation>13.06.2018/K.Richter</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE_MAX Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : VALUE_MAX Element
Description
This element is used to specify the measurement in mm for the maximum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element.CLASS D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
VALUE_MAX Element
Overview
VALUE_MAX optional Restriction of xs:nonNegativeInteger
This element is used to specify the measurement in mm for the maximum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element.CLASS D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="VALUE_MAX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--10--maximaler Wert</xs:documentation>
    <xs:documentation>13.06.2018/K.Richter</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HINGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : HINGE Element
Description

This element provides information about the orientation of the door hinges. No geometrical information is filled in here. All geometrical information is provided in the element CONSTRUCTION_ID.

The following codes can be used to define the door closing:
J = request for door closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = no hinge or hinges on the exterior edges (double door);
R = hinge right ;
B = corresponding with construction ID i.e. construction-ID left : hinge left;
E = opposite to construction-ID, i.e. construction-ID left : hinge right;

In case of double doors, L and R apply to both doors.

For the item identifier B (block) the placement of the items in a block corresponds to the construction_ID => value "N" is required in the field HINGE.

Values B and E are only permitted if the value "J" is filled in in the element CONSTRUCTION_ID (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
HINGE Element
Overview
HINGE Restriction of xs:string

This element provides information about the orientation of the door hinges. No geometrical information is filled in here. All geometrical information is provided in the element CONSTRUCTION_ID.

The following codes can be used to define the door closing:
J = request for door closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = no hinge or hinges on the exterior edges (double door);
R = hinge right ;
B = corresponding with construction ID i.e. construction-ID left : hinge left;
E = opposite to construction-ID, i.e. construction-ID left : hinge right;

In case of double doors, L and R apply to both doors.

For the item identifier B (block) the placement of the items in a block corresponds to the construction_ID => value "N" is required in the field HINGE.

Values B and E are only permitted if the value "J" is filled in in the element CONSTRUCTION_ID (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
Source
<xs:element name="HINGE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--4--Anschlag</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BEJLMNR]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDP_NUMBER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EDP_NUMBER Element
Description
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDP_NUMBER Element
Overview
EDP_NUMBER optional Restriction of xs:string
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
Source
<xs:element name="EDP_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--10--EDV_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EAN_NUMBER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EAN_NUMBER Element
Description
If available the EAN-code of an item is defined in this element. D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
EAN_NUMBER Element
Overview
EAN_NUMBER optional Restriction of xs:string
If available the EAN-code of an item is defined in this element. D string
P
M [1:15]
Source
<xs:element name="EAN_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--11--EAN_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_PRICE_STATUS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : BLOCK_PRICE_STATUS Element
Description
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BLOCK_PRICE_STATUS Element
Overview
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
Source
<xs:element name="BLOCK_PRICE_STATUS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_IDENTIFICATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_IDENTIFICATION Element
Description

This element is used to assign an identifier to the article.
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal.

 D string
P [BEKSMZVPNOG]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
ITEM_IDENTIFICATION Element
Overview
ITEM_IDENTIFICATION Restriction of xs:string

This element is used to assign an identifier to the article.
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal.

 D string
P [BEKSMZVPNOG]
M [1:1]
Source
<xs:element name="ITEM_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--14--Artikelkennung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BEKSMZVPNOG]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_PAGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CATALOG_PAGE Element
Description
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_PAGE Element
Overview
CATALOG_PAGE optional Restriction of xs:string
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
Source
<xs:element name="CATALOG_PAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--15--Katalog_Seite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="40" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_PAGE_PDF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CATALOG_PAGE_PDF Element
Description

This element can be used to specify the item's catalogue page in the catalogue saved as a .pdf file. This information helps to quickly find an item within the stored catalogue.

The URL of the .pdf file is stored in the DETAIL_INFO element (on catalogue level). Because some items feature on multiple pages within the catalogue, it must be assured that the information for the .pdf file is identical to the 40-digit catalogue page CATALOG_PAGE, meaning they both refer to the same page.

 D positiveInteger
P
M [1:999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
CATALOG_PAGE_PDF Element
Overview
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

This element can be used to specify the item's catalogue page in the catalogue saved as a .pdf file. This information helps to quickly find an item within the stored catalogue.

The URL of the .pdf file is stored in the DETAIL_INFO element (on catalogue level). Because some items feature on multiple pages within the catalogue, it must be assured that the information for the .pdf file is identical to the 40-digit catalogue page CATALOG_PAGE, meaning they both refer to the same page.

 D positiveInteger
P
M [1:999]
Source
<xs:element name="CATALOG_PAGE_PDF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
    <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
    <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VAT_ID_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VAT_ID_REF Element
Description
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
Namespace (none)
Diagram
VAT_ID_REF Element
Overview
VAT_ID_REF optional
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
Attributes
Name Type Use Default Fixed Description
VAT_NO Restriction of xs:nonNegativeInteger required
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="VAT_ID_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="VAT_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_FROM Element
Description
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
Source
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_UNTIL Element
Description
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
Source
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WEIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : WEIGHT Element
Description

This element is used to specify the item weight (100 g) including packaging material. (e.g. 50 = 5000 g).
The code in the element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.
Contiguous parts are calculated in the basis of the gross weight per price unit.

Example:
An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
WEIGHT Element
Overview
WEIGHT optional Restriction of xs:nonNegativeInteger

This element is used to specify the item weight (100 g) including packaging material. (e.g. 50 = 5000 g).
The code in the element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.
Contiguous parts are calculated in the basis of the gross weight per price unit.

Example:
An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.

 D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="WEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VOLUME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VOLUME Element
Description
This element defines the volume of an item including packaging material. The basic unit of the volume is [dm³], e.g. a volume of 50 dm³ is entered as 50. D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
VOLUME Element
Overview
VOLUME optional Restriction of xs:nonNegativeInteger
This element defines the volume of an item including packaging material. The basic unit of the volume is [dm³], e.g. a volume of 50 dm³ is entered as 50. D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="VOLUME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--21--Volumen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONSTRUCTION_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CONSTRUCTION_ID Element
Description
This element defines the basic carcase shape of an item.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the construction_ID. 		D string
P [JLNRAE]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
CONSTRUCTION_ID Element
Overview
CONSTRUCTION_ID Restriction of xs:string
This element defines the basic carcase shape of an item.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the construction_ID. 		D string
P [JLNRAE]
M [1:1]
Source
<xs:element name="CONSTRUCTION_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--23--Bauweise_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[JLNRAE]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUBCONTRACTOR_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : SUBCONTRACTOR_ID Element
Description
In case the item is provided by a subcontractor, the corresponding supplier number is entered in this element.

If this subcontractor item is a visible part either the elements SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO or the elements FILE_NAME_TEXTURE_1/2 have to be defined.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
SUBCONTRACTOR_ID Element
Overview
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
In case the item is provided by a subcontractor, the corresponding supplier number is entered in this element.

If this subcontractor item is a visible part either the elements SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO or the elements FILE_NAME_TEXTURE_1/2 have to be defined.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="SUBCONTRACTOR_ID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUBCONTRACTOR_ITEM_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : SUBCONTRACTOR_ITEM_NO Element
Description
In case the item is provided by a subcontractor (SUBCONTRACTOR_ID filled in) the corresponding supplier number is entered in this element.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
SUBCONTRACTOR_ITEM_NO Element
Overview
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
In case the item is provided by a subcontractor (SUBCONTRACTOR_ID filled in) the corresponding supplier number is entered in this element.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification. 		D string
P
M [1:15]
Source
<xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OLD_SERIE_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : OLD_SERIE_NO Element
Description
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D nonNegativeInteger
P
M [0:99]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
OLD_SERIE_NO Element
Overview
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="OLD_SERIE_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OLD_TYPE_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : OLD_TYPE_NO Element
Description
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
OLD_TYPE_NO Element
Overview
OLD_TYPE_NO optional Restriction of xs:string
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old. D string
P
M [1:15]
Source
<xs:element name="OLD_TYPE_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--27--Type_Alt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_NAME_TEXTURE_1 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : FILE_NAME_TEXTURE_1 Element
Description
These elements are used to enter the file names of bitmaps for accessory textures. The files are JPEG files. Because JPEGs do not allow for an alpha channel, the RGB colour code 0,0,255 is used for masking in this case.
The elements are used depending on the value in the „CONSTRUCTION_ID“ element. The FILE_NAME_TEXTURE_1 element contains the left side illustration of the accessories, the FILE_NAME_TEXTURE_2 the right side illustration of the accessories.
CONSTRUCTION_ID = N: The texture in the „filename_texture_1" is used.
CONSTRUCTION_ID = J: There are two different options:
1. The image is mirrored along the central axle. Depending on the item, this can be the Y-axis or the Z-axis (e.g. inset sinks, cooking elements = Y and refrigerators, microwave = Z): The image showing the left side is entered in the FILE_NAME_TEXTURE_1 element.
2. The item cannot be mirrored along the central axle. The image of the left side is entered in the FILE_NAME_TEXTURE_1, while the image of the right side is entered in the FILE_NAME_TEXTURE_2 element.
CONSTRUCTION_ID = L: The value is only entered in the FILE_NAME_TEXTURE_1 element
CONSTRUCTION_ID = R: The value is only entered in the FILE_NAME_TEXTURE_2 element
The values are specified in [cccccccc.jpg] format. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
FILE_NAME_TEXTURE_1 Element
Overview
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
These elements are used to enter the file names of bitmaps for accessory textures. The files are JPEG files. Because JPEGs do not allow for an alpha channel, the RGB colour code 0,0,255 is used for masking in this case.
The elements are used depending on the value in the „CONSTRUCTION_ID“ element. The FILE_NAME_TEXTURE_1 element contains the left side illustration of the accessories, the FILE_NAME_TEXTURE_2 the right side illustration of the accessories.
CONSTRUCTION_ID = N: The texture in the „filename_texture_1" is used.
CONSTRUCTION_ID = J: There are two different options:
1. The image is mirrored along the central axle. Depending on the item, this can be the Y-axis or the Z-axis (e.g. inset sinks, cooking elements = Y and refrigerators, microwave = Z): The image showing the left side is entered in the FILE_NAME_TEXTURE_1 element.
2. The item cannot be mirrored along the central axle. The image of the left side is entered in the FILE_NAME_TEXTURE_1, while the image of the right side is entered in the FILE_NAME_TEXTURE_2 element.
CONSTRUCTION_ID = L: The value is only entered in the FILE_NAME_TEXTURE_1 element
CONSTRUCTION_ID = R: The value is only entered in the FILE_NAME_TEXTURE_2 element
The values are specified in [cccccccc.jpg] format. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
Source
<xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_NAME_TEXTURE_2 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : FILE_NAME_TEXTURE_2 Element
Description
This element is used for defining a name for the texture bitmaps of accessories. JPEG is the standard file format. Since the alpha channel is not available in the JPEG-format, the RGB value 0,0,255 is used for masking.
The elements are used depending on the settings in the element "CONSTRUCTION_ID". The element FILE_NAME_TEXTURE_1 implies left-hand depiction of the accessory item and the element FILE_NAME_TEXTURE_2 is used to indicate a right-hand depiction.
CONSTRUCTION_ID = N: the texture defined in the element "FILE_NAME_TEXTURE_1" is used
CONSTRUCTION_ID = J: there are two possibilities:
1. A symmetrical item is mirrored on the centre line, which can be either y or z axis (e.g. sinks, cooking elements = Y and refrigerators, microwave ovens = Z): The left-hand depiction is entered into the element FILE_NAME_TEXTURE_1.
2. The item is not symmetrical and therefore cannot be mirrored: The depiction of the left-hand part is entered into element FILE_NAME_TEXTURE_1 and the depiction of the right-hand part is filled in into element FILE_NAME_TEXTURE_2
CONSTRUCTION_ID = L: only settings in element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: only settings in element FILE_NAME_TEXTURE_2
The general format for all settings is [cccccccc.jpg]. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
FILE_NAME_TEXTURE_2 Element
Overview
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
This element is used for defining a name for the texture bitmaps of accessories. JPEG is the standard file format. Since the alpha channel is not available in the JPEG-format, the RGB value 0,0,255 is used for masking.
The elements are used depending on the settings in the element "CONSTRUCTION_ID". The element FILE_NAME_TEXTURE_1 implies left-hand depiction of the accessory item and the element FILE_NAME_TEXTURE_2 is used to indicate a right-hand depiction.
CONSTRUCTION_ID = N: the texture defined in the element "FILE_NAME_TEXTURE_1" is used
CONSTRUCTION_ID = J: there are two possibilities:
1. A symmetrical item is mirrored on the centre line, which can be either y or z axis (e.g. sinks, cooking elements = Y and refrigerators, microwave ovens = Z): The left-hand depiction is entered into the element FILE_NAME_TEXTURE_1.
2. The item is not symmetrical and therefore cannot be mirrored: The depiction of the left-hand part is entered into element FILE_NAME_TEXTURE_1 and the depiction of the right-hand part is filled in into element FILE_NAME_TEXTURE_2
CONSTRUCTION_ID = L: only settings in element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: only settings in element FILE_NAME_TEXTURE_2
The general format for all settings is [cccccccc.jpg]. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
Source
<xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MASKING Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MASKING Element
Description
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
This field is of optional use, unless at least one of the elements FILE_NAME_TEXTURE_1/2is filled in. 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
MASKING Element
Overview
MASKING optional Restriction of xs:boolean
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
This field is of optional use, unless at least one of the elements FILE_NAME_TEXTURE_1/2is filled in. 		D boolean
P
M
Source
<xs:element name="MASKING" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--30--Maskierung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODELING_GRAPHIC_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MODELING_GRAPHIC_ID Element
Description
This element references a modeling graphic. D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
MODELING_GRAPHIC_ID Element
Overview
MODELING_GRAPHIC_ID optional Restriction of xs:string
This element references a modeling graphic. D string
P
M [1:15]
Source
<xs:element name="MODELING_GRAPHIC_ID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RANGE_DEPENDENT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : RANGE_DEPENDENT Element
Description
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
RANGE_DEPENDENT Element
Overview
RANGE_DEPENDENT Restriction of xs:boolean
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
Source
<xs:element name="RANGE_DEPENDENT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MINIMUM_DELIVERY_TIME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MINIMUM_DELIVERY_TIME Element
Description
This element defines the minimum delivery time in weeks.
This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.) 		D nonNegativeInteger
P
M [0:999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MINIMUM_DELIVERY_TIME Element
Overview
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element defines the minimum delivery time in weeks.
This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.) 		D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EX_FACTORY_MODIFICATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EX_FACTORY_MODIFICATION Element
Description

This element provides information about possible alterations of an item provided by the manufacturer. Any changes of an item depend on the definitions of the basic shape in the element PARAMETERS (path 1).

0 = all measurement parameters (PARAMETERS (path 1)) are locked, changes of measurements are not possible;

1 = the measurement parameters (PARAMETERS (path 1)) may be changed according to the settings in SA500. The measurement that shall be changed is upon request;

2 = all measurement parameters (PARAMETERS (path 1)) may be changed, locked parameters require identical values in the attribute NOMINAL_VALUE (path 1), FROM (path 1) and TO (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
EX_FACTORY_MODIFICATION Element
Overview
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

This element provides information about possible alterations of an item provided by the manufacturer. Any changes of an item depend on the definitions of the basic shape in the element PARAMETERS (path 1).

0 = all measurement parameters (PARAMETERS (path 1)) are locked, changes of measurements are not possible;

1 = the measurement parameters (PARAMETERS (path 1)) may be changed according to the settings in SA500. The measurement that shall be changed is upon request;

2 = all measurement parameters (PARAMETERS (path 1)) may be changed, locked parameters require identical values in the attribute NOMINAL_VALUE (path 1), FROM (path 1) and TO (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
Source
<xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_PROFILE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : BASIC_PROFILE Element
Description
This element definea the basic shape of an item.
Namespace (none)
Diagram
ITEM_DIMENSIONAL_DRAWING Element CARCASE_BASIC_SHAPE Element Choice Sequence BASIC_PROFILE Element
Overview
BASIC_PROFILE optional
This element definea the basic shape of an item.
Sequence
Choice
CARCASE_BASIC_SHAPE
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information. If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information.
If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
This element defines a basic geometrical shape for a profile. The given measurements for a profile have to correspond with the parameters of the basic profile shape.
Attributes FROM (value from) and TO (value to) are only permitted for parameter B.
This element is only permitted for the following items: cornice, light pelmet, plinth, worktop, cover board, table top, upstand.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
This element defines the number of the basic shape for a profile. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
This element defines the option type and the option key of a profile shape.
The manufacturer specific key for the profile shape as indicated in the printed sales manual is used as OPTION_KEY.
Only the options types 750-756 are permitted in the element BASIC_PROFILE_SHAPE/OPTION_REF.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references an option which shall be used as basic shape for a profile. D string
P
M [1:5]
BASIC_SHAPE_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.

Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
BASIC_SHAPE_NAME required Restriction of xs:string
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
ITEM_DIMENSIONAL_DRAWING
This element is used for the definition of dimensional drawings. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

This element is not permitted if the element BASIC_PROFILE_SHAPE is defined. Dimensional drawings for furniture elements are not permitted.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
This element is used for the definition of a dimensional drawing. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

Even if this element is not defined at least the measurements of the bounding box (w, h, d) have to be defined in the element BASIC_PROFILES/PARAMETERS.

This element is not permitted if the element BASIC_PROFILE_SHAPE exists. This element is not permitted for furniture items, too. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
This element is used for defining a document name or reference.

Documents may contain additional technical information e.g. assembly instructions, or cut-out / drilling patterns.
If only the name of the document is given, this document has to be delivered together with the catalogue data. A document reference is given by an URI/URL.

If a document reference is defined in this element, the element NAME requires the value "23" (= document reference, cf. tables). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Sequence
DIMENSIONAL_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.
DIMENSIONAL_NAME required Restriction of xs:string
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
Source
<xs:element name="BASIC_PROFILE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:choice>
        <xs:element name="CARCASE_BASIC_SHAPE">
          <xs:annotation>
            <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>400--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                </xs:annotation>
                <xs:complexType mixed="true">
                  <xs:sequence>
                    <xs:element name="OPTION_REF">
                      <xs:annotation>
                        <xs:documentation>430--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="FEATURE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>430--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPTION_KEY" use="required">
                          <xs:annotation>
                            <xs:documentation>430--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,5}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="BASIC_SHAPE_PARAMETERS">
                <xs:annotation>
                  <xs:documentation>500--1--Satzart</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>500--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                          <xs:annotation>
                            <xs:documentation>500--0--Parameter</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>500--5--Nennwert</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_FROM">
                          <xs:annotation>
                            <xs:documentation>500--6--Von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_TO">
                          <xs:annotation>
                            <xs:documentation>500--7--Bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                          <xs:annotation>
                            <xs:documentation>500--8--Schrittweite</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
              <xs:annotation>
                <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="ITEM_DIMENSIONAL_DRAWING">
          <xs:annotation>
            <xs:documentation>400--32--Massbild</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:minLength value="1" />
                    <xs:maxLength value="240" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="DIMENSIONAL_PARAMETERS">
                <xs:annotation>
                  <xs:documentation>500--1--Satzart</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>500--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="DIMENSIONAL_NAME" use="required">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_FROM">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_TO">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
              <xs:annotation>
                <xs:documentation>400--32--Massbild</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:choice>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CARCASE_BASIC_SHAPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element : CARCASE_BASIC_SHAPE Element
Description
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information. If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank.
Namespace (none)
Diagram
BASIC_SHAPE_PARAMETERS Element BASIC_PROFILE_SHAPE Element Sequence CARCASE_BASIC_SHAPE Element
Overview
CARCASE_BASIC_SHAPE
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information. If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information.
If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
This element defines a basic geometrical shape for a profile. The given measurements for a profile have to correspond with the parameters of the basic profile shape.
Attributes FROM (value from) and TO (value to) are only permitted for parameter B.
This element is only permitted for the following items: cornice, light pelmet, plinth, worktop, cover board, table top, upstand.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
This element defines the number of the basic shape for a profile. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
This element defines the option type and the option key of a profile shape.
The manufacturer specific key for the profile shape as indicated in the printed sales manual is used as OPTION_KEY.
Only the options types 750-756 are permitted in the element BASIC_PROFILE_SHAPE/OPTION_REF.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references an option which shall be used as basic shape for a profile. D string
P
M [1:5]
BASIC_SHAPE_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.

Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
BASIC_SHAPE_NAME required Restriction of xs:string
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
Attributes
Name Type Use Default Fixed Description
CARCASE_BASIC_SHAPE_NO Restriction of xs:nonNegativeInteger required
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information.
If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels < 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Source
<xs:element name="CARCASE_BASIC_SHAPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType mixed="true">
          <xs:sequence>
            <xs:element name="OPTION_REF">
              <xs:annotation>
                <xs:documentation>430--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>430--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>430--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,5}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="BASIC_SHAPE_PARAMETERS">
        <xs:annotation>
          <xs:documentation>500--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>500--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                  <xs:annotation>
                    <xs:documentation>500--0--Parameter</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                  <xs:annotation>
                    <xs:documentation>500--5--Nennwert</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_FROM">
                  <xs:annotation>
                    <xs:documentation>500--6--Von</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_TO">
                  <xs:annotation>
                    <xs:documentation>500--7--Bis</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                  <xs:annotation>
                    <xs:documentation>500--8--Schrittweite</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_PROFILE_SHAPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element : BASIC_PROFILE_SHAPE Element
Description
This element defines a basic geometrical shape for a profile. The given measurements for a profile have to correspond with the parameters of the basic profile shape.
Attributes FROM (value from) and TO (value to) are only permitted for parameter B.
This element is only permitted for the following items: cornice, light pelmet, plinth, worktop, cover board, table top, upstand.
Namespace (none)
Diagram
OPTION_REF Element Sequence BASIC_PROFILE_SHAPE Element
Overview
BASIC_PROFILE_SHAPE optional
This element defines a basic geometrical shape for a profile. The given measurements for a profile have to correspond with the parameters of the basic profile shape.
Attributes FROM (value from) and TO (value to) are only permitted for parameter B.
This element is only permitted for the following items: cornice, light pelmet, plinth, worktop, cover board, table top, upstand.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
This element defines the number of the basic shape for a profile. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
This element defines the option type and the option key of a profile shape.
The manufacturer specific key for the profile shape as indicated in the printed sales manual is used as OPTION_KEY.
Only the options types 750-756 are permitted in the element BASIC_PROFILE_SHAPE/OPTION_REF.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references an option which shall be used as basic shape for a profile. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
BASIC_PROFILE_SHAPE_NO Restriction of xs:string required
This element defines the number of the basic shape for a profile. D string
P [\S ]{1,5}
M [1:5]
Source
<xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType mixed="true">
    <xs:sequence>
      <xs:element name="OPTION_REF">
        <xs:annotation>
          <xs:documentation>430--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>430--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>430--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[\S ]{1,5}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element > BASIC_PROFILE_SHAPE Element : OPTION_REF Element
Description
This element defines the option type and the option key of a profile shape.
The manufacturer specific key for the profile shape as indicated in the printed sales manual is used as OPTION_KEY.
Only the options types 750-756 are permitted in the element BASIC_PROFILE_SHAPE/OPTION_REF.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF
This element defines the option type and the option key of a profile shape.
The manufacturer specific key for the profile shape as indicated in the printed sales manual is used as OPTION_KEY.
Only the options types 750-756 are permitted in the element BASIC_PROFILE_SHAPE/OPTION_REF.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references an option which shall be used as basic shape for a profile. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for the definition of an option type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
This attribute references an option which shall be used as basic shape for a profile. D string
P
M [1:5]
Source
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>430--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>430--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>430--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BASIC_PROFILE_SHAPE Element | CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_SHAPE_PARAMETERS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element : BASIC_SHAPE_PARAMETERS Element
Description
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Namespace (none)
Diagram
BASIC_SHAPE_PARAMETER Element Sequence BASIC_SHAPE_PARAMETERS Element
Overview
BASIC_SHAPE_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.

Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
BASIC_SHAPE_NAME required Restriction of xs:string
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
Source
<xs:element name="BASIC_SHAPE_PARAMETERS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>500--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="BASIC_SHAPE_NAME" use="required">
            <xs:annotation>
              <xs:documentation>500--0--Parameter</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
            <xs:annotation>
              <xs:documentation>500--5--Nennwert</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_FROM">
            <xs:annotation>
              <xs:documentation>500--6--Von</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_TO">
            <xs:annotation>
              <xs:documentation>500--7--Bis</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
            <xs:annotation>
              <xs:documentation>500--8--Schrittweite</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_SHAPE_PARAMETER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element > BASIC_SHAPE_PARAMETERS Element : BASIC_SHAPE_PARAMETER Element
Description
This element defines the values for the parameters that describe a basic shape.

Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
Namespace (none)
Diagram
BASIC_SHAPE_PARAMETER Element
Overview
BASIC_SHAPE_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.

Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
BASIC_SHAPE_NAME required Restriction of xs:string
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
Attributes
Name Type Use Default Fixed Description
BASIC_SHAPE_NAME Restriction of xs:string required
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE Restriction of xs:decimal required
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM Restriction of xs:decimal optional
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_TO Restriction of xs:decimal optional
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE Restriction of xs:decimal optional
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
Source
<xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="BASIC_SHAPE_NAME" use="required">
      <xs:annotation>
        <xs:documentation>500--0--Parameter</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>500--5--Nennwert</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_FROM">
      <xs:annotation>
        <xs:documentation>500--6--Von</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_TO">
      <xs:annotation>
        <xs:documentation>500--7--Bis</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
      <xs:annotation>
        <xs:documentation>500--8--Schrittweite</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BASIC_SHAPE_PARAMETERS Element | CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_DIMENSIONAL_DRAWING Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element : ITEM_DIMENSIONAL_DRAWING Element
Description
This element is used for the definition of dimensional drawings. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

This element is not permitted if the element BASIC_PROFILE_SHAPE is defined. Dimensional drawings for furniture elements are not permitted.
Namespace (none)
Diagram
DIMENSIONAL_PARAMETERS Element DOCUMENT_REFERENCE Element Sequence ITEM_DIMENSIONAL_DRAWING Element
Overview
ITEM_DIMENSIONAL_DRAWING
This element is used for the definition of dimensional drawings. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

This element is not permitted if the element BASIC_PROFILE_SHAPE is defined. Dimensional drawings for furniture elements are not permitted.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
This element is used for the definition of a dimensional drawing. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

Even if this element is not defined at least the measurements of the bounding box (w, h, d) have to be defined in the element BASIC_PROFILES/PARAMETERS.

This element is not permitted if the element BASIC_PROFILE_SHAPE exists. This element is not permitted for furniture items, too. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
This element is used for defining a document name or reference.

Documents may contain additional technical information e.g. assembly instructions, or cut-out / drilling patterns.
If only the name of the document is given, this document has to be delivered together with the catalogue data. A document reference is given by an URI/URL.

If a document reference is defined in this element, the element NAME requires the value "23" (= document reference, cf. tables). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Sequence
DIMENSIONAL_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.
DIMENSIONAL_NAME required Restriction of xs:string
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
Attributes
Name Type Use Default Fixed Description
ITEM_DIMENSIONAL_DRAWING_NO Restriction of xs:string required
This element is used for the definition of a dimensional drawing. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

Even if this element is not defined at least the measurements of the bounding box (w, h, d) have to be defined in the element BASIC_PROFILES/PARAMETERS.

This element is not permitted if the element BASIC_PROFILE_SHAPE exists. This element is not permitted for furniture items, too. 		D string
P
M [1:20]
Source
<xs:element name="ITEM_DIMENSIONAL_DRAWING" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--32--Massbild</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="240" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DIMENSIONAL_PARAMETERS">
        <xs:annotation>
          <xs:documentation>500--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>500--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DIMENSIONAL_NAME" use="required">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_FROM">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_TO">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--32--Massbild</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="20" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DOCUMENT_REFERENCE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > ITEM_DIMENSIONAL_DRAWING Element : DOCUMENT_REFERENCE Element
Description
This element is used for defining a document name or reference.

Documents may contain additional technical information e.g. assembly instructions, or cut-out / drilling patterns.
If only the name of the document is given, this document has to be delivered together with the catalogue data. A document reference is given by an URI/URL.

If a document reference is defined in this element, the element NAME requires the value "23" (= document reference, cf. tables). 		D string
P
M [1:240]
Namespace (none)
Type
Restriction of xs:string
Diagram
DOCUMENT_REFERENCE Element
Overview
DOCUMENT_REFERENCE optional Restriction of xs:string
This element is used for defining a document name or reference.

Documents may contain additional technical information e.g. assembly instructions, or cut-out / drilling patterns.
If only the name of the document is given, this document has to be delivered together with the catalogue data. A document reference is given by an URI/URL.

If a document reference is defined in this element, the element NAME requires the value "23" (= document reference, cf. tables). 		D string
P
M [1:240]
Source
<xs:element name="DOCUMENT_REFERENCE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="240" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_DIMENSIONAL_DRAWING Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DIMENSIONAL_PARAMETERS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > ITEM_DIMENSIONAL_DRAWING Element : DIMENSIONAL_PARAMETERS Element
Description
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Namespace (none)
Diagram
DIMENSIONAL_PARAMETER Element Sequence DIMENSIONAL_PARAMETERS Element
Overview
DIMENSIONAL_PARAMETERS
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm => value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Sequence
DIMENSIONAL_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.
DIMENSIONAL_NAME required Restriction of xs:string
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
Source
<xs:element name="DIMENSIONAL_PARAMETERS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>500--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DIMENSIONAL_NAME" use="required">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_FROM">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_TO">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_STEP_SIZE">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM_DIMENSIONAL_DRAWING Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DIMENSIONAL_PARAMETER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > ITEM_DIMENSIONAL_DRAWING Element > DIMENSIONAL_PARAMETERS Element : DIMENSIONAL_PARAMETER Element
Description
This element defines the values for the parameters that describe a basic shape.
Namespace (none)
Diagram
DIMENSIONAL_PARAMETER Element
Overview
DIMENSIONAL_PARAMETER 1..∞
This element defines the values for the parameters that describe a basic shape.
DIMENSIONAL_NAME required Restriction of xs:string
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
Attributes
Name Type Use Default Fixed Description
DIMENSIONAL_NAME Restriction of xs:string required
This attribute is used for defining a name for the parameter. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE Restriction of xs:decimal required
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM Restriction of xs:decimal optional
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_TO Restriction of xs:decimal optional
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE Restriction of xs:decimal optional
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to. D decimal
P
M [0:999999]
Source
<xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DIMENSIONAL_NAME" use="required">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_FROM">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_TO">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_STEP_SIZE">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DIMENSIONAL_PARAMETERS Element | ITEM_DIMENSIONAL_DRAWING Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_PARTS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : BLOCK_PARTS Element
Description
This element is used as a container element for the block parts lists in the catalogue.
Namespace (none)
Diagram
BLOCK_PART Element Sequence BLOCK_PARTS Element
Overview
BLOCK_PARTS optional
This element is used as a container element for the block parts lists in the catalogue.
Sequence
BLOCK_PART 1..∞

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2)), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
ITEM_REF

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞
This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the feature which is referenced by a option.
Each FEATURE_NO may exist only one time in the database. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references a option. D string
P
M [1:5]
HINGE optional Restriction of xs:string
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Source
<xs:element name="BLOCK_PARTS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_PART" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_SEQUENTIAL_NO">
              <xs:annotation>
                <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="HINGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--6--Anschlag</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[BEJLMNR]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EXCHANGE_CONDITION">
              <xs:annotation>
                <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="2" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="STATUS">
              <xs:annotation>
                <xs:documentation>401--8--Status</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[ABELSZ]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONSTRUCTION_ID" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[JLNRAE]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_PART Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element : BLOCK_PART Element
Description

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2)), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Namespace (none)
Diagram
CONSTRUCTION_ID Element BLOCK_ITEM_DIMENSION_DEPTH Element BLOCK_ITEM_DIMENSION_HEIGHT Element BLOCK_ITEM_DIMENSION_WIDTH Element STATUS Element EXCHANGE_CONDITION Element HINGE Element OPTION_REF Element ITEM_REF Element BLOCK_SEQUENTIAL_NO Element Sequence BLOCK_PART Element
Overview
BLOCK_PART 1..∞

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2)), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
ITEM_REF

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞
This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the feature which is referenced by a option.
Each FEATURE_NO may exist only one time in the database. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references a option. D string
P
M [1:5]
HINGE optional Restriction of xs:string
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Source
<xs:element name="BLOCK_PART" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_SEQUENTIAL_NO">
        <xs:annotation>
          <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="HINGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--6--Anschlag</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[BEJLMNR]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EXCHANGE_CONDITION">
        <xs:annotation>
          <xs:documentation>401--7--Tauschbedingung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="2" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="STATUS">
        <xs:annotation>
          <xs:documentation>401--8--Status</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[ABELSZ]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONSTRUCTION_ID" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--13--Bauweise_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[JLNRAE]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_SEQUENTIAL_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_SEQUENTIAL_NO Element
Description
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BLOCK_SEQUENTIAL_NO Element
Overview
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
Source
<xs:element name="BLOCK_SEQUENTIAL_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : ITEM_REF Element
Description

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Attributes
Name Type Use Default Fixed Description
TYPE_NO Restriction of xs:string required
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : OPTION_REF Element
Description
This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF 0..∞
This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the feature which is referenced by a option.
Each FEATURE_NO may exist only one time in the database. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references a option. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute defines the feature which is referenced by a option.
Each FEATURE_NO may exist only one time in the database. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
This attribute references a option. D string
P
M [1:5]
Source
<xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HINGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : HINGE Element
Description
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
HINGE Element
Overview
HINGE optional Restriction of xs:string
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
Source
<xs:element name="HINGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--6--Anschlag</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[BEJLMNR]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_CONDITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : EXCHANGE_CONDITION Element
Description

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
EXCHANGE_CONDITION Element
Overview
EXCHANGE_CONDITION Restriction of xs:positiveInteger

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
Source
<xs:element name="EXCHANGE_CONDITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--7--Tauschbedingung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="2" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STATUS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : STATUS Element
Description
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
STATUS Element
Overview
STATUS Restriction of xs:string
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
Source
<xs:element name="STATUS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--8--Status</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[ABELSZ]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_ITEM_DIMENSION_WIDTH Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_ITEM_DIMENSION_WIDTH Element
Description
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BLOCK_ITEM_DIMENSION_WIDTH Element
Overview
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_ITEM_DIMENSION_HEIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_ITEM_DIMENSION_HEIGHT Element
Description
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BLOCK_ITEM_DIMENSION_HEIGHT Element
Overview
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_ITEM_DIMENSION_DEPTH Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_ITEM_DIMENSION_DEPTH Element
Description
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BLOCK_ITEM_DIMENSION_DEPTH Element
Overview
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONSTRUCTION_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : CONSTRUCTION_ID Element
Description
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
CONSTRUCTION_ID Element
Overview
CONSTRUCTION_ID optional Restriction of xs:string
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Source
<xs:element name="CONSTRUCTION_ID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--13--Bauweise_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[JLNRAE]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_PARTS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MODULE_PARTS Element
Description

If the relevant item is a 3-D unit, this element contains a list of parts for module elements, with the first element being a base unit with position 0 followed by the module elements from the bottom upwards. This element must be left blank if the associated item is not a 3-D unit.

The 3-D unit has a fixed price. If the 3-D unit is changed, the new price will result from the price for the base unit + the price for the modules. The 3-D unit is deleted, the base unit becomes the main position and contains all other module elements as sub-positions from the bottom upwards.

The module elements can be range or version-specific.

Rules concerning the height of module elements within the base unit can be specified via MODUL_RULE_SETS. The universally defined module rule is referenced in this case.

The base unit can be assigned this kind of rule via MODULE_RULE_SET_REF.

Namespace (none)
Diagram
MODULE_PART Element Sequence MODULE_PARTS Element
Overview
MODULE_PARTS optional

If the relevant item is a 3-D unit, this element contains a list of parts for module elements, with the first element being a base unit with position 0 followed by the module elements from the bottom upwards. This element must be left blank if the associated item is not a 3-D unit.

The 3-D unit has a fixed price. If the 3-D unit is changed, the new price will result from the price for the base unit + the price for the modules. The 3-D unit is deleted, the base unit becomes the main position and contains all other module elements as sub-positions from the bottom upwards.

The module elements can be range or version-specific.

Rules concerning the height of module elements within the base unit can be specified via MODUL_RULE_SETS. The universally defined module rule is referenced in this case.

The base unit can be assigned this kind of rule via MODULE_RULE_SET_REF.

Sequence
MODULE_PART 1..∞

This element corresponds to a partial list of parts for module elements of a 3-D unit. The elements must be specified in their order from bottom to top. Position 0 (PART_SEQUENTIAL_NO) is the empty base unit (cabinet type code 17) It is followed by the module elements from bottom to top (cabinet type key 10). The base unit hinges are identical to the hinges of the 3-D unit.

Sequence
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element is used to specify the item's position within the 3-D unit. The base unit (item type code 17) must include the position value of 0. The module elements (type code 10) contain additional position numbers sorted from bottom to top. D nonNegativeInteger
P
M [0:999]
ITEM_REF
This element is used to refer to the base unit (type code 17) and the individual module elements (type code 10).
The base unit must be assigned position (PART_SEQUENTIAL_NO) 0. The remaining module elements must be referenced in the order from the bottom to the top and in line with the PART_SEQUENTIAL_NO attribute.
TYPE_NO required Restriction of xs:string
This element is used to specify the item type. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
HEIGHT_VARIABLE optional xs:boolean
If this flag is set to true(1), this means that the corresponding module element will contain changes relating to changes of other elements within the list. This means that if another module element becomes smaller or larger, the module element designated as true in HEIGHT_VARIABLE will adjust itself so that the total height of all module elements within the base unit is restored. D boolean
P
M
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
A module element can be variable, but the list contains a fixed height that has to be specified for variable measurements within this element. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="MODULE_PARTS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_PART" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PART_SEQUENTIAL_NO">
              <xs:annotation>
                <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:maxInclusive value="999" />
                  <xs:minInclusive value="0" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_PART Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_PARTS Element : MODULE_PART Element
Description

This element corresponds to a partial list of parts for module elements of a 3-D unit. The elements must be specified in their order from bottom to top. Position 0 (PART_SEQUENTIAL_NO) is the empty base unit (cabinet type code 17) It is followed by the module elements from bottom to top (cabinet type key 10). The base unit hinges are identical to the hinges of the 3-D unit.

Namespace (none)
Diagram
MODULE_ITEM_DIMENSION_HEIGHT Element HEIGHT_VARIABLE Element ITEM_REF Element PART_SEQUENTIAL_NO Element Sequence MODULE_PART Element
Overview
MODULE_PART 1..∞

This element corresponds to a partial list of parts for module elements of a 3-D unit. The elements must be specified in their order from bottom to top. Position 0 (PART_SEQUENTIAL_NO) is the empty base unit (cabinet type code 17) It is followed by the module elements from bottom to top (cabinet type key 10). The base unit hinges are identical to the hinges of the 3-D unit.

Sequence
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element is used to specify the item's position within the 3-D unit. The base unit (item type code 17) must include the position value of 0. The module elements (type code 10) contain additional position numbers sorted from bottom to top. D nonNegativeInteger
P
M [0:999]
ITEM_REF
This element is used to refer to the base unit (type code 17) and the individual module elements (type code 10).
The base unit must be assigned position (PART_SEQUENTIAL_NO) 0. The remaining module elements must be referenced in the order from the bottom to the top and in line with the PART_SEQUENTIAL_NO attribute.
TYPE_NO required Restriction of xs:string
This element is used to specify the item type. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
HEIGHT_VARIABLE optional xs:boolean
If this flag is set to true(1), this means that the corresponding module element will contain changes relating to changes of other elements within the list. This means that if another module element becomes smaller or larger, the module element designated as true in HEIGHT_VARIABLE will adjust itself so that the total height of all module elements within the base unit is restored. D boolean
P
M
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
A module element can be variable, but the list contains a fixed height that has to be specified for variable measurements within this element. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="MODULE_PART" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PART_SEQUENTIAL_NO">
        <xs:annotation>
          <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:maxInclusive value="999" />
            <xs:minInclusive value="0" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
MODULE_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PART_SEQUENTIAL_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_PARTS Element > MODULE_PART Element : PART_SEQUENTIAL_NO Element
Description
This element is used to specify the item's position within the 3-D unit. The base unit (item type code 17) must include the position value of 0. The module elements (type code 10) contain additional position numbers sorted from bottom to top. D nonNegativeInteger
P
M [0:999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
PART_SEQUENTIAL_NO Element
Overview
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
This element is used to specify the item's position within the 3-D unit. The base unit (item type code 17) must include the position value of 0. The module elements (type code 10) contain additional position numbers sorted from bottom to top. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="PART_SEQUENTIAL_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:maxInclusive value="999" />
      <xs:minInclusive value="0" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MODULE_PART Element | MODULE_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_PARTS Element > MODULE_PART Element : ITEM_REF Element
Description
This element is used to refer to the base unit (type code 17) and the individual module elements (type code 10).
The base unit must be assigned position (PART_SEQUENTIAL_NO) 0. The remaining module elements must be referenced in the order from the bottom to the top and in line with the PART_SEQUENTIAL_NO attribute.
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF
This element is used to refer to the base unit (type code 17) and the individual module elements (type code 10).
The base unit must be assigned position (PART_SEQUENTIAL_NO) 0. The remaining module elements must be referenced in the order from the bottom to the top and in line with the PART_SEQUENTIAL_NO attribute.
TYPE_NO required Restriction of xs:string
This element is used to specify the item type. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
Attributes
Name Type Use Default Fixed Description
TYPE_NO Restriction of xs:string required
This element is used to specify the item type. (e.g. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
MODULE_PART Element | MODULE_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEIGHT_VARIABLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_PARTS Element > MODULE_PART Element : HEIGHT_VARIABLE Element
Description
If this flag is set to true(1), this means that the corresponding module element will contain changes relating to changes of other elements within the list. This means that if another module element becomes smaller or larger, the module element designated as true in HEIGHT_VARIABLE will adjust itself so that the total height of all module elements within the base unit is restored. D boolean
P
M
Namespace (none)
Type
xs:boolean
Diagram
HEIGHT_VARIABLE Element
Overview
HEIGHT_VARIABLE optional xs:boolean
If this flag is set to true(1), this means that the corresponding module element will contain changes relating to changes of other elements within the list. This means that if another module element becomes smaller or larger, the module element designated as true in HEIGHT_VARIABLE will adjust itself so that the total height of all module elements within the base unit is restored. D boolean
P
M
Source
<xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
MODULE_PART Element | MODULE_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_ITEM_DIMENSION_HEIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_PARTS Element > MODULE_PART Element : MODULE_ITEM_DIMENSION_HEIGHT Element
Description
A module element can be variable, but the list contains a fixed height that has to be specified for variable measurements within this element. D nonNegativeInteger
P
M [1:99999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MODULE_ITEM_DIMENSION_HEIGHT Element
Overview
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
A module element can be variable, but the list contains a fixed height that has to be specified for variable measurements within this element. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MODULE_PART Element | MODULE_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_TEXT Element
Description
This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Namespace (none)
Diagram
LANGUAGE Element Sequence PLANNING_ADVICE Element LANGUAGE Element Sequence FULL_TEXT Element SHORT_TEXT Element Sequence ITEM_TEXT Element
Overview
ITEM_TEXT
This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Sequence
SHORT_TEXT
This element contains short text information.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetexte Complex Type

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
This element contains planning advices.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="ITEM_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SHORT_TEXT">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>410--6--Textzeile</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SHORT_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : SHORT_TEXT Element
Description
This element contains short text information.
Namespace (none)
Diagram
LANGUAGE Element Sequence SHORT_TEXT Element
Overview
SHORT_TEXT
This element contains short text information.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="SHORT_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>410--6--Textzeile</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element : LANGUAGE Element
Description
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
Namespace (none)
Diagram
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>410--6--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element : TEXT_LINE Element
Description
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
Namespace (none)
Diagram
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..3
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Attributes
Name Type Use Default Fixed Description
SEQUENCE_NO Restriction of xs:positiveInteger required
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Source
<xs:element name="TEXT_LINE" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>410--6--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Description
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--6--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FULL_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : FULL_TEXT Element
Description

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Namespace (none)
Type
languagetexte Complex Type
Diagram
LANGUAGE Element Sequence FULL_TEXT Element
Overview
FULL_TEXT optional languagetexte Complex Type

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte Complex Type
IDM 2.7.0 XML-Schema : languagetexte Complex Type
Description

This data type is used for multilingual text information of any length.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte Complex Type
Overview
languagetexte

This data type is used for multilingual text information of any length.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Used By
EXTERNAL_NAME Element
TOOL_TIP Element
PROPERTY_TEXT Element
FULL_TEXT Element
Source
<xs:complexType name="languagetexte" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT" type="xs:string">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PLANNING_ADVICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : PLANNING_ADVICE Element
Description
This element contains planning advices.
Namespace (none)
Type
languagetexte60999 Complex Type
Diagram
LANGUAGE Element Sequence PLANNING_ADVICE Element
Overview
PLANNING_ADVICE optional languagetexte60999 Complex Type
This element contains planning advices.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TYPE_KEY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : TYPE_KEY Element
Description
This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item.
Namespace (none)
Diagram
TK_FRONT_APPEARANCE Element TK_SHAPE Element TK_MATERIAL Element TK_EQUIPMENT Element TK_CLASS Element TK_TYPE Element Sequence TYPE_KEY Element
Overview
TYPE_KEY
This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item.
Sequence
TK_TYPE Restriction of xs:positiveInteger
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
A value from the column item No., as listed in the Table "Type keys", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

This element is used for assigning a type key to the installation information and recess height.

SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key ", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
This element defines the combination of installation information (cf. table Installation information-key) and recess height.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
A value from the column installation information, as listed in table "Installation information-key", is required in this field. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
A value from the column type, as listed in table "Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
A value from the column shape No., as listed in the table "Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
A value from the column front appearance No., as listed in the table "Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
Source
<xs:element name="TYPE_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_TYPE">
        <xs:annotation>
          <xs:documentation>445--4--TS_Typ</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_CLASS">
        <xs:annotation>
          <xs:documentation>445--5--TS_Art</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
        <xs:annotation>
          <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
            <xs:annotation>
              <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="TK_MATERIAL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--21--TS_Material</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-2]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_SHAPE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--22--TS_Form</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-2]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_TYPE Element
Description
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
TK_TYPE Element
Overview
TK_TYPE Restriction of xs:positiveInteger
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
Source
<xs:element name="TK_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--4--TS_Typ</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_CLASS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_CLASS Element
Description
A value from the column item No., as listed in the Table "Type keys", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
TK_CLASS Element
Overview
TK_CLASS Restriction of xs:positiveInteger
A value from the column item No., as listed in the Table "Type keys", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
Source
<xs:element name="TK_CLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--5--TS_Art</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_EQUIPMENT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_EQUIPMENT Element
Description

This element is used for assigning a type key to the installation information and recess height.

Namespace (none)
Diagram
TK_INSTALLATION_RECESS Element Sequence TK_EQUIPMENT Element
Overview
TK_EQUIPMENT 0..5

This element is used for assigning a type key to the installation information and recess height.

SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key ", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
This element defines the combination of installation information (cf. table Installation information-key) and recess height.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
A value from the column installation information, as listed in table "Installation information-key", is required in this field. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
Attributes
Name Type Use Default Fixed Description
SEQUENCE_NO Restriction of xs:positiveInteger required
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO Restriction of xs:nonNegativeInteger optional

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key ", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Source
<xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
      <xs:annotation>
        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_INSTALLATION_RECESS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element > TK_EQUIPMENT Element : TK_INSTALLATION_RECESS Element
Description
This element defines the combination of installation information (cf. table Installation information-key) and recess height.
Namespace (none)
Diagram
TK_RECESS_HEIGHT Element TK_INSTALLATION_INFORMATION Element Sequence TK_INSTALLATION_RECESS Element
Overview
TK_INSTALLATION_RECESS optional
This element defines the combination of installation information (cf. table Installation information-key) and recess height.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
A value from the column installation information, as listed in table "Installation information-key", is required in this field. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="TK_INSTALLATION_RECESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
          <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
TK_EQUIPMENT Element | TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_INSTALLATION_INFORMATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element > TK_EQUIPMENT Element > TK_INSTALLATION_RECESS Element : TK_INSTALLATION_INFORMATION Element
Description
A value from the column installation information, as listed in table "Installation information-key", is required in this field. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
TK_INSTALLATION_INFORMATION Element
Overview
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
A value from the column installation information, as listed in table "Installation information-key", is required in this field. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
Source
<xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TK_INSTALLATION_RECESS Element | TK_EQUIPMENT Element | TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_RECESS_HEIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element > TK_EQUIPMENT Element > TK_INSTALLATION_RECESS Element : TK_RECESS_HEIGHT Element
Description
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
TK_RECESS_HEIGHT Element
Overview
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="TK_RECESS_HEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
    <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TK_INSTALLATION_RECESS Element | TK_EQUIPMENT Element | TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_MATERIAL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_MATERIAL Element
Description
A value from the column type, as listed in table "Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
TK_MATERIAL Element
Overview
TK_MATERIAL optional Restriction of xs:positiveInteger
A value from the column type, as listed in table "Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Source
<xs:element name="TK_MATERIAL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--21--TS_Material</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-2]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_SHAPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_SHAPE Element
Description
A value from the column shape No., as listed in the table "Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
TK_SHAPE Element
Overview
TK_SHAPE optional Restriction of xs:positiveInteger
A value from the column shape No., as listed in the table "Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Source
<xs:element name="TK_SHAPE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--22--TS_Form</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-2]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_FRONT_APPEARANCE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_FRONT_APPEARANCE Element
Description
A value from the column front appearance No., as listed in the table "Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
TK_FRONT_APPEARANCE Element
Overview
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
A value from the column front appearance No., as listed in the table "Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
Source
<xs:element name="TK_FRONT_APPEARANCE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLASSIFICATIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CLASSIFICATIONS Element
Description
This element is used to store standardized classification numbers.
Namespace (none)
Diagram
ECLASS Element Sequence CLASSIFICATIONS Element
Overview
CLASSIFICATIONS optional
This element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.
The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Source
<xs:element name="CLASSIFICATIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS_NO">
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:totalDigits value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ECLASS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element : ECLASS Element
Description
This element is used to specify the eCl@ss classification.
Namespace (none)
Diagram
ECLASS_NO Element Sequence ECLASS Element
Overview
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.
The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Source
<xs:element name="ECLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS_NO">
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:totalDigits value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ECLASS_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element > ECLASS Element : ECLASS_NO Element
Description

The 8-digit eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.
The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
ECLASS_NO Element
Overview
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.
The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Source
<xs:element name="ECLASS_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:totalDigits value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ECLASS Element | CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_DIVISIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : FRONT_DIVISIONS Element
Description
This element is used for defining the possible front divisions of an item.
Different front divisions may be related to the chosen range or built-in appliances.

Similar front divisions in different programmes may be defined in front groups. These front groups are referenced by the programmes.

All front divisions are based on the left-hand construction method. If an item is also available in right-hand construction mode, it is mirrored.If an item is also available in right-hand construction mode, it is mirrored.
Namespace (none)
Diagram
FRONT_GROUP Element Sequence FRONT_DIVISIONS Element
Overview
FRONT_DIVISIONS optional
This element is used for defining the possible front divisions of an item.
Different front divisions may be related to the chosen range or built-in appliances.

Similar front divisions in different programmes may be defined in front groups. These front groups are referenced by the programmes.

All front divisions are based on the left-hand construction method. If an item is also available in right-hand construction mode, it is mirrored.If an item is also available in right-hand construction mode, it is mirrored.
Sequence
FRONT_GROUP 1..99
This element defines different front divisions and combines them in one front group.
FRONT_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database.

If one FRONT_GROUP is valid for all programmes, the value 0 has to be set. 		D positiveInteger
P
M [0:99]
Sequence
FRONT_DIVISION 1..∞
This element defines a front division and describes the single cells of the front division.
Sequence
FRONT_DIVISION_DEF Restriction of xs:string
For the definition of the front division the syntax rules provided in the attachment apply. These syntax rules are not used for the description of front divisions for shelves. Shelves are defined as a separate front cell (cf. FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
INTERNAL_ORDER_NO optional Restriction of xs:string
For items which have different front divisions and only one order number in the catalogue, internal order numbers for the different front divisions are entered in this field. D string
P
M [1:15]
FRONT_CELL 1..∞
This element defines the single cells of a front division.
Sequence
FRONT_CELL_NO Restriction of xs:positiveInteger
This attribute defines the No. of the cell which has to be described. The cell No. is defined in the front division (FRONT_DIVISION_DEF). D positiveInteger
P
M [1:99]
FRONT_TYPE optional Restriction of xs:positiveInteger
This element defines the front type of the cell. A front element is assigned by the front type (cf. element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

The following front types can be assigned:

1 - 100 = doors
101 - 200 = drawers
201 - 300 = pull-outs
301 - 400 = flap doors
401 - 450 = recess with blind
451 - 500 = recess without blind
501 - 550 = open compartment/compartment recess
551 - 600 = shelves
601 - 650 = fixed blinds
651 - 700 = control panel blinds
701 - 750 = shutters
751 - 800 = roller shutter fronts
801 - 900 = miscellaneous 		D positiveInteger
P
M [1:900]
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
PARAMETER_1 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
PARAMETER_2 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
OFFSET_ABOVE optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
OFFSET_BELOW optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
OFFSET_LEFT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
OFFSET_RIGHT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell
3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) no mirroring
1) mirroring only when the hinge is changed
2) mirroring only when the construction ID is changed
3) mirroring when either hinge OR construction ID is changed
4) mirroring when hinge AND construction ID are changed.

The rules are defined in the header and examples are given.

 D nonNegativeInteger
P
M [0:4]
UPPER_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
LOWER_JOIN optional Restriction of xs:string

This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre

 D string
P |[VLSG]
M [0:1]
LEFT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
RIGHT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

This element defines the position of the doucine

1) = horizontal
2) = vertical

 D nonNegativeInteger
P
M [1:2]
Source
<xs:element name="FRONT_DIVISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>510--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_GROUP" maxOccurs="99">
        <xs:annotation>
          <xs:documentation>510/540--0/0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>510/540--0/0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_DIVISION_DEF">
                    <xs:annotation>
                      <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="250" />
                        <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_CELL_NO">
                          <xs:annotation>
                            <xs:documentation>540--6--Zellennummer</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FRONT_TYPE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--7--Fronttyp</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="900" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--8--Griffposition_1</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--9--Griffposition_2</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--10--Grifflage_1</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="4" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--11--Grifflage_2</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="4" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PARAMETER_1" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--12--Parameter_1</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PARAMETER_2" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--13--Parameter_2</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="4" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="UPPER_JOIN" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[VLSG]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="LOWER_JOIN" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[VLSG]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="LEFT_JOIN" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[VLSG]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="RIGHT_JOIN" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[VLSG]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DOUCINE_POSITION" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="2" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FRONT_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>510/540--0/0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element : FRONT_GROUP Element
Description
This element defines different front divisions and combines them in one front group.
Namespace (none)
Diagram
FRONT_DIVISION Element Sequence FRONT_GROUP Element
Overview
FRONT_GROUP 1..99
This element defines different front divisions and combines them in one front group.
FRONT_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database.

If one FRONT_GROUP is valid for all programmes, the value 0 has to be set. 		D positiveInteger
P
M [0:99]
Sequence
FRONT_DIVISION 1..∞
This element defines a front division and describes the single cells of the front division.
Sequence
FRONT_DIVISION_DEF Restriction of xs:string
For the definition of the front division the syntax rules provided in the attachment apply. These syntax rules are not used for the description of front divisions for shelves. Shelves are defined as a separate front cell (cf. FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
INTERNAL_ORDER_NO optional Restriction of xs:string
For items which have different front divisions and only one order number in the catalogue, internal order numbers for the different front divisions are entered in this field. D string
P
M [1:15]
FRONT_CELL 1..∞
This element defines the single cells of a front division.
Sequence
FRONT_CELL_NO Restriction of xs:positiveInteger
This attribute defines the No. of the cell which has to be described. The cell No. is defined in the front division (FRONT_DIVISION_DEF). D positiveInteger
P
M [1:99]
FRONT_TYPE optional Restriction of xs:positiveInteger
This element defines the front type of the cell. A front element is assigned by the front type (cf. element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

The following front types can be assigned:

1 - 100 = doors
101 - 200 = drawers
201 - 300 = pull-outs
301 - 400 = flap doors
401 - 450 = recess with blind
451 - 500 = recess without blind
501 - 550 = open compartment/compartment recess
551 - 600 = shelves
601 - 650 = fixed blinds
651 - 700 = control panel blinds
701 - 750 = shutters
751 - 800 = roller shutter fronts
801 - 900 = miscellaneous 		D positiveInteger
P
M [1:900]
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
PARAMETER_1 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
PARAMETER_2 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
OFFSET_ABOVE optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
OFFSET_BELOW optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
OFFSET_LEFT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
OFFSET_RIGHT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell
3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) no mirroring
1) mirroring only when the hinge is changed
2) mirroring only when the construction ID is changed
3) mirroring when either hinge OR construction ID is changed
4) mirroring when hinge AND construction ID are changed.

The rules are defined in the header and examples are given.

 D nonNegativeInteger
P
M [0:4]
UPPER_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
LOWER_JOIN optional Restriction of xs:string

This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre

 D string
P |[VLSG]
M [0:1]
LEFT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
RIGHT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

This element defines the position of the doucine

1) = horizontal
2) = vertical

 D nonNegativeInteger
P
M [1:2]
Attributes
Name Type Use Default Fixed Description
FRONT_GROUP_NO Restriction of xs:nonNegativeInteger required
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database.

If one FRONT_GROUP is valid for all programmes, the value 0 has to be set. 		D positiveInteger
P
M [0:99]
Source
<xs:element name="FRONT_GROUP" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>510/540--0/0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>510/540--0/0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_DIVISION_DEF">
              <xs:annotation>
                <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="250" />
                  <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FRONT_CELL" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_CELL_NO">
                    <xs:annotation>
                      <xs:documentation>540--6--Zellennummer</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FRONT_TYPE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--7--Fronttyp</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="900" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--8--Griffposition_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--9--Griffposition_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--10--Grifflage_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="4" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--11--Grifflage_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="4" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PARAMETER_1" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--12--Parameter_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PARAMETER_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--13--Parameter_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="4" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="UPPER_JOIN" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[VLSG]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="LOWER_JOIN" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[VLSG]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="LEFT_JOIN" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[VLSG]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="RIGHT_JOIN" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[VLSG]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DOUCINE_POSITION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FRONT_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>510/540--0/0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_DIVISION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element : FRONT_DIVISION Element
Description
This element defines a front division and describes the single cells of the front division.
Namespace (none)
Diagram
FRONT_CELL Element INTERNAL_ORDER_NO Element FRONT_DIVISION_DEF Element Sequence FRONT_DIVISION Element
Overview
FRONT_DIVISION 1..∞
This element defines a front division and describes the single cells of the front division.
Sequence
FRONT_DIVISION_DEF Restriction of xs:string
For the definition of the front division the syntax rules provided in the attachment apply. These syntax rules are not used for the description of front divisions for shelves. Shelves are defined as a separate front cell (cf. FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
INTERNAL_ORDER_NO optional Restriction of xs:string
For items which have different front divisions and only one order number in the catalogue, internal order numbers for the different front divisions are entered in this field. D string
P
M [1:15]
FRONT_CELL 1..∞
This element defines the single cells of a front division.
Sequence
FRONT_CELL_NO Restriction of xs:positiveInteger
This attribute defines the No. of the cell which has to be described. The cell No. is defined in the front division (FRONT_DIVISION_DEF). D positiveInteger
P
M [1:99]
FRONT_TYPE optional Restriction of xs:positiveInteger
This element defines the front type of the cell. A front element is assigned by the front type (cf. element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

The following front types can be assigned:

1 - 100 = doors
101 - 200 = drawers
201 - 300 = pull-outs
301 - 400 = flap doors
401 - 450 = recess with blind
451 - 500 = recess without blind
501 - 550 = open compartment/compartment recess
551 - 600 = shelves
601 - 650 = fixed blinds
651 - 700 = control panel blinds
701 - 750 = shutters
751 - 800 = roller shutter fronts
801 - 900 = miscellaneous 		D positiveInteger
P
M [1:900]
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
PARAMETER_1 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
PARAMETER_2 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
OFFSET_ABOVE optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
OFFSET_BELOW optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
OFFSET_LEFT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
OFFSET_RIGHT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell
3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) no mirroring
1) mirroring only when the hinge is changed
2) mirroring only when the construction ID is changed
3) mirroring when either hinge OR construction ID is changed
4) mirroring when hinge AND construction ID are changed.

The rules are defined in the header and examples are given.

 D nonNegativeInteger
P
M [0:4]
UPPER_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
LOWER_JOIN optional Restriction of xs:string

This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre

 D string
P |[VLSG]
M [0:1]
LEFT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
RIGHT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

This element defines the position of the doucine

1) = horizontal
2) = vertical

 D nonNegativeInteger
P
M [1:2]
Source
<xs:element name="FRONT_DIVISION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>510/540--0/0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_DIVISION_DEF">
        <xs:annotation>
          <xs:documentation>510--7--Frontaufteilung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="250" />
            <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FRONT_CELL" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_CELL_NO">
              <xs:annotation>
                <xs:documentation>540--6--Zellennummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FRONT_TYPE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--7--Fronttyp</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="900" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HANDLE_POSITION_1" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--8--Griffposition_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HANDLE_POSITION_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--9--Griffposition_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--10--Grifflage_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="4" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--11--Grifflage_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="4" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PARAMETER_1" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--12--Parameter_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PARAMETER_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--13--Parameter_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="4" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="UPPER_JOIN" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[VLSG]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="LOWER_JOIN" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[VLSG]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="LEFT_JOIN" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[VLSG]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="RIGHT_JOIN" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[VLSG]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DOUCINE_POSITION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_DIVISION_DEF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element : FRONT_DIVISION_DEF Element
Description
For the definition of the front division the syntax rules provided in the attachment apply. These syntax rules are not used for the description of front divisions for shelves. Shelves are defined as a separate front cell (cf. FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
Namespace (none)
Type
Restriction of xs:string
Diagram
FRONT_DIVISION_DEF Element
Overview
FRONT_DIVISION_DEF Restriction of xs:string
For the definition of the front division the syntax rules provided in the attachment apply. These syntax rules are not used for the description of front divisions for shelves. Shelves are defined as a separate front cell (cf. FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
Source
<xs:element name="FRONT_DIVISION_DEF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>510--7--Frontaufteilung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="250" />
      <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

INTERNAL_ORDER_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element : INTERNAL_ORDER_NO Element
Description
For items which have different front divisions and only one order number in the catalogue, internal order numbers for the different front divisions are entered in this field. D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
INTERNAL_ORDER_NO Element
Overview
INTERNAL_ORDER_NO optional Restriction of xs:string
For items which have different front divisions and only one order number in the catalogue, internal order numbers for the different front divisions are entered in this field. D string
P
M [1:15]
Source
<xs:element name="INTERNAL_ORDER_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_CELL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element : FRONT_CELL Element
Description
This element defines the single cells of a front division.
Namespace (none)
Diagram
DOUCINE_POSITION Element RIGHT_JOIN Element LEFT_JOIN Element LOWER_JOIN Element UPPER_JOIN Element HINGE_BEHAVIOR Element OFFSET_RIGHT Element OFFSET_LEFT Element OFFSET_BELOW Element OFFSET_ABOVE Element MOUNTING_HEIGHT_TO Element MOUNTING_HEIGHT_FROM Element PARAMETER_2 Element PARAMETER_1 Element HANDLE_ORIENTATION_2 Element HANDLE_ORIENTATION_1 Element HANDLE_POSITION_2 Element HANDLE_POSITION_1 Element FRONT_TYPE Element FRONT_CELL_NO Element Sequence FRONT_CELL Element
Overview
FRONT_CELL 1..∞
This element defines the single cells of a front division.
Sequence
FRONT_CELL_NO Restriction of xs:positiveInteger
This attribute defines the No. of the cell which has to be described. The cell No. is defined in the front division (FRONT_DIVISION_DEF). D positiveInteger
P
M [1:99]
FRONT_TYPE optional Restriction of xs:positiveInteger
This element defines the front type of the cell. A front element is assigned by the front type (cf. element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

The following front types can be assigned:

1 - 100 = doors
101 - 200 = drawers
201 - 300 = pull-outs
301 - 400 = flap doors
401 - 450 = recess with blind
451 - 500 = recess without blind
501 - 550 = open compartment/compartment recess
551 - 600 = shelves
601 - 650 = fixed blinds
651 - 700 = control panel blinds
701 - 750 = shutters
751 - 800 = roller shutter fronts
801 - 900 = miscellaneous 		D positiveInteger
P
M [1:900]
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
PARAMETER_1 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
PARAMETER_2 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
OFFSET_ABOVE optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
OFFSET_BELOW optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
OFFSET_LEFT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
OFFSET_RIGHT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell
3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) no mirroring
1) mirroring only when the hinge is changed
2) mirroring only when the construction ID is changed
3) mirroring when either hinge OR construction ID is changed
4) mirroring when hinge AND construction ID are changed.

The rules are defined in the header and examples are given.

 D nonNegativeInteger
P
M [0:4]
UPPER_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
LOWER_JOIN optional Restriction of xs:string

This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre

 D string
P |[VLSG]
M [0:1]
LEFT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
RIGHT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

This element defines the position of the doucine

1) = horizontal
2) = vertical

 D nonNegativeInteger
P
M [1:2]
Source
<xs:element name="FRONT_CELL" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_CELL_NO">
        <xs:annotation>
          <xs:documentation>540--6--Zellennummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FRONT_TYPE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--7--Fronttyp</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="900" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HANDLE_POSITION_1" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--8--Griffposition_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HANDLE_POSITION_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--9--Griffposition_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--10--Grifflage_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="4" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--11--Grifflage_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="4" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PARAMETER_1" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--12--Parameter_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PARAMETER_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--13--Parameter_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="4" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="UPPER_JOIN" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[VLSG]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="LOWER_JOIN" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[VLSG]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="LEFT_JOIN" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[VLSG]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="RIGHT_JOIN" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[VLSG]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DOUCINE_POSITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_CELL_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : FRONT_CELL_NO Element
Description
This attribute defines the No. of the cell which has to be described. The cell No. is defined in the front division (FRONT_DIVISION_DEF). D positiveInteger
P
M [1:99]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
FRONT_CELL_NO Element
Overview
FRONT_CELL_NO Restriction of xs:positiveInteger
This attribute defines the No. of the cell which has to be described. The cell No. is defined in the front division (FRONT_DIVISION_DEF). D positiveInteger
P
M [1:99]
Source
<xs:element name="FRONT_CELL_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--6--Zellennummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : FRONT_TYPE Element
Description
This element defines the front type of the cell. A front element is assigned by the front type (cf. element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

The following front types can be assigned:

1 - 100 = doors
101 - 200 = drawers
201 - 300 = pull-outs
301 - 400 = flap doors
401 - 450 = recess with blind
451 - 500 = recess without blind
501 - 550 = open compartment/compartment recess
551 - 600 = shelves
601 - 650 = fixed blinds
651 - 700 = control panel blinds
701 - 750 = shutters
751 - 800 = roller shutter fronts
801 - 900 = miscellaneous 		D positiveInteger
P
M [1:900]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
FRONT_TYPE Element
Overview
FRONT_TYPE optional Restriction of xs:positiveInteger
This element defines the front type of the cell. A front element is assigned by the front type (cf. element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

The following front types can be assigned:

1 - 100 = doors
101 - 200 = drawers
201 - 300 = pull-outs
301 - 400 = flap doors
401 - 450 = recess with blind
451 - 500 = recess without blind
501 - 550 = open compartment/compartment recess
551 - 600 = shelves
601 - 650 = fixed blinds
651 - 700 = control panel blinds
701 - 750 = shutters
751 - 800 = roller shutter fronts
801 - 900 = miscellaneous 		D positiveInteger
P
M [1:900]
Source
<xs:element name="FRONT_TYPE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--7--Fronttyp</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="900" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_POSITION_1 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : HANDLE_POSITION_1 Element
Description
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
HANDLE_POSITION_1 Element
Overview
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
Remarks

Source
<xs:element name="HANDLE_POSITION_1" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--8--Griffposition_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_POSITION_2 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : HANDLE_POSITION_2 Element
Description
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
HANDLE_POSITION_2 Element
Overview
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L". 		D positiveInteger
P
M [1:99]
Source
<xs:element name="HANDLE_POSITION_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--9--Griffposition_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_ORIENTATION_1 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : HANDLE_ORIENTATION_1 Element
Description
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
HANDLE_ORIENTATION_1 Element
Overview
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
Source
<xs:element name="HANDLE_ORIENTATION_1" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--10--Grifflage_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="4" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_ORIENTATION_2 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : HANDLE_ORIENTATION_2 Element
Description
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
HANDLE_ORIENTATION_2 Element
Overview
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304. 		D positiveInteger
P
M [1:4]
Source
<xs:element name="HANDLE_ORIENTATION_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--11--Grifflage_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="4" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PARAMETER_1 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : PARAMETER_1 Element
Description
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PARAMETER_1 Element
Overview
PARAMETER_1 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
Source
<xs:element name="PARAMETER_1" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--12--Parameter_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PARAMETER_2 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : PARAMETER_2 Element
Description
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PARAMETER_2 Element
Overview
PARAMETER_2 optional Restriction of xs:positiveInteger
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves. 		D positiveInteger
P
M [1-99]
Source
<xs:element name="PARAMETER_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--13--Parameter_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MOUNTING_HEIGHT_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : MOUNTING_HEIGHT_FROM Element
Description
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MOUNTING_HEIGHT_FROM Element
Overview
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
Source
<xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MOUNTING_HEIGHT_TO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : MOUNTING_HEIGHT_TO Element
Description
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MOUNTING_HEIGHT_TO Element
Overview
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance. D nonNegativeInteger
P
M [0-9999]
Source
<xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OFFSET_ABOVE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : OFFSET_ABOVE Element
Description
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
Namespace (none)
Type
xs:integer
Diagram
OFFSET_ABOVE Element
Overview
OFFSET_ABOVE optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
Source
<xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OFFSET_BELOW Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : OFFSET_BELOW Element
Description
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
Namespace (none)
Type
xs:integer
Diagram
OFFSET_BELOW Element
Overview
OFFSET_BELOW optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 		D integer
P
M
Source
<xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OFFSET_LEFT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : OFFSET_LEFT Element
Description
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
Namespace (none)
Type
xs:integer
Diagram
OFFSET_LEFT Element
Overview
OFFSET_LEFT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
Source
<xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OFFSET_RIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : OFFSET_RIGHT Element
Description
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell
3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
Namespace (none)
Type
xs:integer
Diagram
OFFSET_RIGHT Element
Overview
OFFSET_RIGHT optional xs:integer
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell
3) clearance depends on the hinge (cf. field hinge behaviour) 		D integer
P
M
Source
<xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HINGE_BEHAVIOR Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : HINGE_BEHAVIOR Element
Description

0) no mirroring
1) mirroring only when the hinge is changed
2) mirroring only when the construction ID is changed
3) mirroring when either hinge OR construction ID is changed
4) mirroring when hinge AND construction ID are changed.

The rules are defined in the header and examples are given.

 D nonNegativeInteger
P
M [0:4]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
HINGE_BEHAVIOR Element
Overview
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) no mirroring
1) mirroring only when the hinge is changed
2) mirroring only when the construction ID is changed
3) mirroring when either hinge OR construction ID is changed
4) mirroring when hinge AND construction ID are changed.

The rules are defined in the header and examples are given.

 D nonNegativeInteger
P
M [0:4]
Source
<xs:element name="HINGE_BEHAVIOR" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="4" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

UPPER_JOIN Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : UPPER_JOIN Element
Description
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
UPPER_JOIN Element
Overview
UPPER_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
Source
<xs:element name="UPPER_JOIN" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[VLSG]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LOWER_JOIN Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : LOWER_JOIN Element
Description

This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre

 D string
P |[VLSG]
M [0:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
LOWER_JOIN Element
Overview
LOWER_JOIN optional Restriction of xs:string

This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre

 D string
P |[VLSG]
M [0:1]
Source
<xs:element name="LOWER_JOIN" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[VLSG]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LEFT_JOIN Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : LEFT_JOIN Element
Description
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
LEFT_JOIN Element
Overview
LEFT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
Source
<xs:element name="LEFT_JOIN" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[VLSG]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RIGHT_JOIN Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : RIGHT_JOIN Element
Description
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
RIGHT_JOIN Element
Overview
RIGHT_JOIN optional Restriction of xs:string
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre 		D string
P |[VLSG]
M [0:1]
Source
<xs:element name="RIGHT_JOIN" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[VLSG]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DOUCINE_POSITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : DOUCINE_POSITION Element
Description

This element defines the position of the doucine

1) = horizontal
2) = vertical

 D nonNegativeInteger
P
M [1:2]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
DOUCINE_POSITION Element
Overview
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

This element defines the position of the doucine

1) = horizontal
2) = vertical

 D nonNegativeInteger
P
M [1:2]
Source
<xs:element name="DOUCINE_POSITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_APPEARANCE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : FRONT_APPEARANCE_REF Element
Description
This element is used for assigning a front appearance to an item. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Front appearances which are assigned to this element are not dependent on a programme.
Namespace (none)
Diagram
FRONT_APPEARANCE_REF Element
Overview
FRONT_APPEARANCE_REF optional
This element is used for assigning a front appearance to an item. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Front appearances which are assigned to this element are not dependent on a programme.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This element is used to define the relationship between the version defined in the data record and a front type. D positiveInteger
P
M
Attributes
Name Type Use Default Fixed Description
FRONT_APPEARANCE_NO Restriction of xs:positiveInteger required
This element is used to define the relationship between the version defined in the data record and a front type. D positiveInteger
P
M
Source
<xs:element name="FRONT_APPEARANCE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SET_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MODULE_RULE_SET_REF Element
Description
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
Namespace (none)
Diagram
MODULE_RULE_SET_REF Element
Overview
MODULE_RULE_SET_REF optional
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the number of the rule set which references an item to the corresponding rule set. D positiveInteger
P
M
Attributes
Name Type Use Default Fixed Description
MODULE_RULE_SET_NO xs:nonNegativeInteger required
This attribute defines the number of the rule set which references an item to the corresponding rule set. D positiveInteger
P
M
Source
<xs:element name="MODULE_RULE_SET_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SETS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MODULE_RULE_SETS Element
Description
This element is used for defining a set of rules for module elements. If an item is defined as a module element (type key = 10) the rules for planning this item are defined in this element. It is only possible to define either the element MODULE_RULE_SET_REF or the element MODULE_RULE_SETS.
Namespace (none)
Diagram
MODULE_RULE_SET Element Sequence MODULE_RULE_SETS Element
Overview
MODULE_RULE_SETS optional
This element is used for defining a set of rules for module elements. If an item is defined as a module element (type key = 10) the rules for planning this item are defined in this element. It is only possible to define either the element MODULE_RULE_SET_REF or the element MODULE_RULE_SETS.
Sequence
MODULE_RULE_SET 1..∞
This element assigns a set of rules to a module element. The element MODULE_RULE_SET_NO references each set of rules to the related module housing element. Therefore it is possible to define different set of rules for one item depending on the selected module housing element.
Sequence
MODULE_RULES
This element defines a set of rules for the installation of single modules into a module cabinet.
Sequence
MODULE_RULE 1..∞
A rule for the installation of a module into a module cabinet.
This rule defines whether the installation of a module element into the selected module housing element is permitted or not.

Type key 10 is required for module elements.
Sequence
MODULE_POSITION Restriction of xs:string
This element defines the values which have to be checked.

LINE_BOTTOM | Bottom line of the module element in mm
LINE_TOP | Top line of the module element

The control process requires settings MIN_VALUE or MAX_VALUES .
D string
P LINE_BOTTOM|LINE_TOP
M
MAX_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the maximum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
MIN_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the minimum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
MODULE_RULE_SET_REF
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the reference between the rule set and the MODULE_RULE_SET_DEFINITION and the related module housing units. D nonNegativeInteger
P
M
Source
<xs:element name="MODULE_RULE_SETS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MODULE_RULES">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MODULE_POSITION">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                              <xs:enumeration value="LINE_BOTTOM" />
                              <xs:enumeration value="LINE_TOP" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MAX_VALUE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MIN_VALUE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="MODULE_RULE_SET_REF">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SET Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element : MODULE_RULE_SET Element
Description
This element assigns a set of rules to a module element. The element MODULE_RULE_SET_NO references each set of rules to the related module housing element. Therefore it is possible to define different set of rules for one item depending on the selected module housing element.
Namespace (none)
Diagram
MODULE_RULE_SET_REF Element MODULE_RULES Element Sequence MODULE_RULE_SET Element
Overview
MODULE_RULE_SET 1..∞
This element assigns a set of rules to a module element. The element MODULE_RULE_SET_NO references each set of rules to the related module housing element. Therefore it is possible to define different set of rules for one item depending on the selected module housing element.
Sequence
MODULE_RULES
This element defines a set of rules for the installation of single modules into a module cabinet.
Sequence
MODULE_RULE 1..∞
A rule for the installation of a module into a module cabinet.
This rule defines whether the installation of a module element into the selected module housing element is permitted or not.

Type key 10 is required for module elements.
Sequence
MODULE_POSITION Restriction of xs:string
This element defines the values which have to be checked.

LINE_BOTTOM | Bottom line of the module element in mm
LINE_TOP | Top line of the module element

The control process requires settings MIN_VALUE or MAX_VALUES .
D string
P LINE_BOTTOM|LINE_TOP
M
MAX_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the maximum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
MIN_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the minimum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
MODULE_RULE_SET_REF
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the reference between the rule set and the MODULE_RULE_SET_DEFINITION and the related module housing units. D nonNegativeInteger
P
M
Source
<xs:element name="MODULE_RULE_SET" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_RULES">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MODULE_RULE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MODULE_POSITION">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                        <xs:enumeration value="LINE_BOTTOM" />
                        <xs:enumeration value="LINE_TOP" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MAX_VALUE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MIN_VALUE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MODULE_RULE_SET_REF">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element > MODULE_RULE_SET Element : MODULE_RULES Element
Description
This element defines a set of rules for the installation of single modules into a module cabinet.
Namespace (none)
Diagram
MODULE_RULE Element Sequence MODULE_RULES Element
Overview
MODULE_RULES
This element defines a set of rules for the installation of single modules into a module cabinet.
Sequence
MODULE_RULE 1..∞
A rule for the installation of a module into a module cabinet.
This rule defines whether the installation of a module element into the selected module housing element is permitted or not.

Type key 10 is required for module elements.
Sequence
MODULE_POSITION Restriction of xs:string
This element defines the values which have to be checked.

LINE_BOTTOM | Bottom line of the module element in mm
LINE_TOP | Top line of the module element

The control process requires settings MIN_VALUE or MAX_VALUES .
D string
P LINE_BOTTOM|LINE_TOP
M
MAX_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the maximum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
MIN_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the minimum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
Source
<xs:element name="MODULE_RULES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_RULE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MODULE_POSITION">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                  <xs:enumeration value="LINE_BOTTOM" />
                  <xs:enumeration value="LINE_TOP" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MAX_VALUE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MIN_VALUE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
MODULE_RULE_SET Element | MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element > MODULE_RULE_SET Element > MODULE_RULES Element : MODULE_RULE Element
Description
A rule for the installation of a module into a module cabinet.
This rule defines whether the installation of a module element into the selected module housing element is permitted or not.

Type key 10 is required for module elements.
Namespace (none)
Diagram
MIN_VALUE Element MAX_VALUE Element MODULE_POSITION Element Sequence MODULE_RULE Element
Overview
MODULE_RULE 1..∞
A rule for the installation of a module into a module cabinet.
This rule defines whether the installation of a module element into the selected module housing element is permitted or not.

Type key 10 is required for module elements.
Sequence
MODULE_POSITION Restriction of xs:string
This element defines the values which have to be checked.

LINE_BOTTOM | Bottom line of the module element in mm
LINE_TOP | Top line of the module element

The control process requires settings MIN_VALUE or MAX_VALUES .
D string
P LINE_BOTTOM|LINE_TOP
M
MAX_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the maximum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
MIN_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the minimum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
Source
<xs:element name="MODULE_RULE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_POSITION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
            <xs:enumeration value="LINE_BOTTOM" />
            <xs:enumeration value="LINE_TOP" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MAX_VALUE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MIN_VALUE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
MODULE_RULES Element | MODULE_RULE_SET Element | MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_POSITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element > MODULE_RULE_SET Element > MODULE_RULES Element > MODULE_RULE Element : MODULE_POSITION Element
Description
This element defines the values which have to be checked.

LINE_BOTTOM | Bottom line of the module element in mm
LINE_TOP | Top line of the module element

The control process requires settings MIN_VALUE or MAX_VALUES .
D string
P LINE_BOTTOM|LINE_TOP
M
Namespace (none)
Type
Restriction of xs:string
Diagram
MODULE_POSITION Element
Overview
MODULE_POSITION Restriction of xs:string
This element defines the values which have to be checked.

LINE_BOTTOM | Bottom line of the module element in mm
LINE_TOP | Top line of the module element

The control process requires settings MIN_VALUE or MAX_VALUES .
D string
P LINE_BOTTOM|LINE_TOP
M
Source
<xs:element name="MODULE_POSITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
      <xs:enumeration value="LINE_BOTTOM" />
      <xs:enumeration value="LINE_TOP" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MODULE_RULE Element | MODULE_RULES Element | MODULE_RULE_SET Element | MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MAX_VALUE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element > MODULE_RULE_SET Element > MODULE_RULES Element > MODULE_RULE Element : MAX_VALUE Element
Description

This serves to define the maximum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MAX_VALUE Element
Overview
MAX_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the maximum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
Source
<xs:element name="MAX_VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MODULE_RULE Element | MODULE_RULES Element | MODULE_RULE_SET Element | MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MIN_VALUE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element > MODULE_RULE_SET Element > MODULE_RULES Element > MODULE_RULE Element : MIN_VALUE Element
Description

This serves to define the minimum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MIN_VALUE Element
Overview
MIN_VALUE optional Restriction of xs:nonNegativeInteger

This serves to define the minimum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.

 D nonNegativeInteger
P
M [0-99999]
Source
<xs:element name="MIN_VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MODULE_RULE Element | MODULE_RULES Element | MODULE_RULE_SET Element | MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SET_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element > MODULE_RULE_SET Element : MODULE_RULE_SET_REF Element
Description
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
Namespace (none)
Diagram
MODULE_RULE_SET_REF Element
Overview
MODULE_RULE_SET_REF
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
This attribute defines the reference between the rule set and the MODULE_RULE_SET_DEFINITION and the related module housing units. D nonNegativeInteger
P
M
Attributes
Name Type Use Default Fixed Description
MODULE_RULE_SET_NO xs:nonNegativeInteger required
This attribute defines the reference between the rule set and the MODULE_RULE_SET_DEFINITION and the related module housing units. D nonNegativeInteger
P
M
Source
<xs:element name="MODULE_RULE_SET_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
MODULE_RULE_SET Element | MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : DETAIL_INFOS Element
Description
This element summarizes all hyperlinks providing detail information for an item.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description
This element references hyperlinks to detail information.
Namespace (none)
Diagram
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROPERTIES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PROPERTIES Element
Description
This element is used for summarizing the item specific characteristics.
Namespace (none)
Diagram
PROPERTY_REF Element Sequence PROPERTIES Element
Overview
PROPERTIES optional
This element is used for summarizing the item specific characteristics.
Sequence
PROPERTY_REF 1..∞
This element references a characteristic which is defined under GLOBAL_DEFINITION/PROPERTIES.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
This attribute references a characteristic. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

This attribute defines a value for the characteristic.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Source
<xs:element name="PROPERTIES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PROPERTY_NO" use="required">
            <xs:annotation>
              <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="VALUE" use="required">
            <xs:annotation>
              <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROPERTY_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PROPERTIES Element : PROPERTY_REF Element
Description
This element references a characteristic which is defined under GLOBAL_DEFINITION/PROPERTIES.
Namespace (none)
Diagram
PROPERTY_REF Element
Overview
PROPERTY_REF 1..∞
This element references a characteristic which is defined under GLOBAL_DEFINITION/PROPERTIES.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
This attribute references a characteristic. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

This attribute defines a value for the characteristic.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Attributes
Name Type Use Default Fixed Description
PROPERTY_NO Restriction of xs:nonNegativeInteger required
This attribute references a characteristic. D nonNegativeInteger
P
M [0:999]
VALUE Restriction of xs:string required

This attribute defines a value for the characteristic.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Source
<xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PROPERTY_NO" use="required">
      <xs:annotation>
        <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="VALUE" use="required">
      <xs:annotation>
        <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PROPERTIES Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : RESTRICTIONS Element
Description
This element is used for combining all restrictions which apply to one product group.
Namespace (none)
Diagram
RESTRICTION_REF Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional
This element is used for combining all restrictions which apply to one product group.
Sequence
RESTRICTION_REF 1..∞
This element references a restriction which is assigned to a product group.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references item specific restrictions. D positiveInteger
P [0:99999]
M
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...). 		D positiveInteger
P
M [1:99999]

Remarks

Source
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="99999" />
                <xs:minInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > RESTRICTIONS Element : RESTRICTION_REF Element
Description
This element references a restriction which is assigned to a product group.
Namespace (none)
Diagram
RESTRICTION_REF Element
Overview
RESTRICTION_REF 1..∞
This element references a restriction which is assigned to a product group.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references item specific restrictions. D positiveInteger
P [0:99999]
M
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...). 		D positiveInteger
P
M [1:99999]

Attributes
Name Type Use Default Fixed Description
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
This attribute references item specific restrictions. D positiveInteger
P [0:99999]
M
SEQUENCE Restriction of xs:nonNegativeInteger required
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...). 		D positiveInteger
P
M [1:99999]

Remarks

Source
<xs:element name="RESTRICTION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="99999" />
          <xs:minInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
RESTRICTIONS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEFAULT_OPTION_GROUPS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : DEFAULT_OPTION_GROUPS Element
Description
In this record type, default values for series variations are given as proposals resp. decision support for the user. The proposals made here have to be defined as legal combinations.
Namespace (none)
Diagram
DEFAULT_OPTION_GROUP Element Sequence DEFAULT_OPTION_GROUPS Element
Overview
DEFAULT_OPTION_GROUPS optional
In this record type, default values for series variations are given as proposals resp. decision support for the user. The proposals made here have to be defined as legal combinations.
Sequence
DEFAULT_OPTION_GROUP 1..∞
This element defines a standard proposal.
Each feature type may be referenced only one time in the DEFAULT_OPTION_GROUP
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
This attribute defines a numerical counter for the default group. D positiveInteger
P
M [1:999999999]
Sequence
DEFAULT_OPTION_GROUP_NAME languagetexte30 Complex Type
This element contains a freely defined name for the default option, e.g. defined by the user of the planning software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FILE_NAME optional Restriction of xs:string
This element contains the filename of a JPEG-file which is used as an example of the default option. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M
OPTION_REF 1..∞
This element references the features which are combined in the default option.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the feature type of the referenced feature. D noNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines the reference between the feature and the default option. D string
P
M [1:5]
DETAIL_INFOS optional
This element is used for defining pictures which are subordinated to the the standard proposal.
Sequence
DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Remarks

Source
<xs:element name="DEFAULT_OPTION_GROUPS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>295--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DEFAULT_OPTION_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DEFAULT_OPTION_GROUP_NAME" type="languagetexte30">
              <xs:annotation>
                <xs:documentation>296--5--Name_Standard_Gruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FILE_NAME" minOccurs="0">
              <xs:annotation>
                <xs:documentation>296--6--Dateiname</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="OPTION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>295--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>295--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>295--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Version 2.3 27.06.2014 K. Richter</xs:documentation>
                <xs:documentation>Bilder unterhalb des Standardvorschlages</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEFAULT_OPTION_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DEFAULT_OPTION_GROUPS Element : DEFAULT_OPTION_GROUP Element
Description
This element defines a standard proposal.
Each feature type may be referenced only one time in the DEFAULT_OPTION_GROUP
Namespace (none)
Diagram
DETAIL_INFOS Element OPTION_REF Element FILE_NAME Element LANGUAGE Element Sequence DEFAULT_OPTION_GROUP_NAME Element Sequence DEFAULT_OPTION_GROUP Element
Overview
DEFAULT_OPTION_GROUP 1..∞
This element defines a standard proposal.
Each feature type may be referenced only one time in the DEFAULT_OPTION_GROUP
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
This attribute defines a numerical counter for the default group. D positiveInteger
P
M [1:999999999]
Sequence
DEFAULT_OPTION_GROUP_NAME languagetexte30 Complex Type
This element contains a freely defined name for the default option, e.g. defined by the user of the planning software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FILE_NAME optional Restriction of xs:string
This element contains the filename of a JPEG-file which is used as an example of the default option. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M
OPTION_REF 1..∞
This element references the features which are combined in the default option.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the feature type of the referenced feature. D noNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines the reference between the feature and the default option. D string
P
M [1:5]
DETAIL_INFOS optional
This element is used for defining pictures which are subordinated to the the standard proposal.
Sequence
DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
DEFAULT_OPTION_GROUP_NO Restriction of xs:positiveInteger required
This attribute defines a numerical counter for the default group. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DEFAULT_OPTION_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DEFAULT_OPTION_GROUP_NAME" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>296--5--Name_Standard_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FILE_NAME" minOccurs="0">
        <xs:annotation>
          <xs:documentation>296--6--Dateiname</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="OPTION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>295--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>295--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>295--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Version 2.3 27.06.2014 K. Richter</xs:documentation>
          <xs:documentation>Bilder unterhalb des Standardvorschlages</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DEFAULT_OPTION_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEFAULT_OPTION_GROUP_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DEFAULT_OPTION_GROUPS Element > DEFAULT_OPTION_GROUP Element : DEFAULT_OPTION_GROUP_NAME Element
Description
This element contains a freely defined name for the default option, e.g. defined by the user of the planning software.
Namespace (none)
Type
languagetexte30 Complex Type
Diagram
LANGUAGE Element Sequence DEFAULT_OPTION_GROUP_NAME Element
Overview
DEFAULT_OPTION_GROUP_NAME languagetexte30 Complex Type
This element contains a freely defined name for the default option, e.g. defined by the user of the planning software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="DEFAULT_OPTION_GROUP_NAME" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>296--5--Name_Standard_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DEFAULT_OPTION_GROUP Element | DEFAULT_OPTION_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DEFAULT_OPTION_GROUPS Element > DEFAULT_OPTION_GROUP Element : FILE_NAME Element
Description
This element contains the filename of a JPEG-file which is used as an example of the default option. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M
Namespace (none)
Type
Restriction of xs:string
Diagram
FILE_NAME Element
Overview
FILE_NAME optional Restriction of xs:string
This element contains the filename of a JPEG-file which is used as an example of the default option. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M
Source
<xs:element name="FILE_NAME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>296--6--Dateiname</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DEFAULT_OPTION_GROUP Element | DEFAULT_OPTION_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DEFAULT_OPTION_GROUPS Element > DEFAULT_OPTION_GROUP Element : OPTION_REF Element
Description
This element references the features which are combined in the default option.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF 1..∞
This element references the features which are combined in the default option.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the feature type of the referenced feature. D noNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines the reference between the feature and the default option. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute defines the feature type of the referenced feature. D noNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
This attribute defines the reference between the feature and the default option. D string
P
M [1:5]
Source
<xs:element name="OPTION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>295--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>295--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>295--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DEFAULT_OPTION_GROUP Element | DEFAULT_OPTION_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DEFAULT_OPTION_GROUPS Element > DEFAULT_OPTION_GROUP Element : DETAIL_INFOS Element
Description
This element is used for defining pictures which are subordinated to the the standard proposal.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
This element is used for defining pictures which are subordinated to the the standard proposal.
Sequence
DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Version 2.3 27.06.2014 K. Richter</xs:documentation>
    <xs:documentation>Bilder unterhalb des Standardvorschlages</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
DEFAULT_OPTION_GROUP Element | DEFAULT_OPTION_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DEFAULT_OPTION_GROUPS Element > DEFAULT_OPTION_GROUP Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description
This element is used for referencing the detail information.
Namespace (none)
Diagram
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | DEFAULT_OPTION_GROUP Element | DEFAULT_OPTION_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : DETAIL_INFOS Element
Description
This element is used for defining detailed media information, e.g. photographs, PDF files, video hyperlinks which refer to a series.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS 0..∞
This element is used for defining detailed media information, e.g. photographs, PDF files, video hyperlinks which refer to a series.
Sequence
DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description
This element is used for referencing the detail information.
Namespace (none)
Diagram
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
This element is used for referencing the detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute is used to specify the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element : RESTRICTIONS Element
Description
This element is used for summarizing the global restrictions.
Namespace (none)
Diagram
RESTRICTION_REF Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional
This element is used for summarizing the global restrictions.
Sequence
RESTRICTION_REF 0..∞
This element references global restrictions.
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different restrictions are processed. Different values in the the field SEQUENCE_NO are required and an intersection of the different restrictions is made up.
The sequence has to be defined in ascending order which may have gaps (e.g. 1,3,10, ...). 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references global (i.e. not depending on series) restrictions. D nonNegativeInteger
P
M [0:99999]
Source
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > RESTRICTIONS Element : RESTRICTION_REF Element
Description
This element references global restrictions.
Namespace (none)
Diagram
RESTRICTION_REF Element
Overview
RESTRICTION_REF 0..∞
This element references global restrictions.
SEQUENCE required Restriction of xs:nonNegativeInteger
This element defines the sequence in which the different restrictions are processed. Different values in the the field SEQUENCE_NO are required and an intersection of the different restrictions is made up.
The sequence has to be defined in ascending order which may have gaps (e.g. 1,3,10, ...). 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute references global (i.e. not depending on series) restrictions. D nonNegativeInteger
P
M [0:99999]
Attributes
Name Type Use Default Fixed Description
SEQUENCE Restriction of xs:nonNegativeInteger required
This element defines the sequence in which the different restrictions are processed. Different values in the the field SEQUENCE_NO are required and an intersection of the different restrictions is made up.
The sequence has to be defined in ascending order which may have gaps (e.g. 1,3,10, ...). 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
This attribute references global (i.e. not depending on series) restrictions. D nonNegativeInteger
P
M [0:99999]
Source
<xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
RESTRICTIONS Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_DEFINITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : FEATURE_DEFINITION Element
Description
All information which is depending on the different variations is defined in this element.
Namespace (none)
Diagram
SUGGESTIONS Element RESTRICTIONS Element OPTION_DEFINITION Element FEATURES Element FEATURE_CLASSES Element Sequence FEATURE_DEFINITION Element
Overview
FEATURE_DEFINITION optional
All information which is depending on the different variations is defined in this element.
Sequence
FEATURE_CLASSES
In this element features are grouped into feature classes. By using feature classes different checks concerning plausibility and completeness of the valid variation types can be processed.

Feature classes can be assigned to series, programmes, or product groups. There is no priority to any of these assigned levels. The total number of valid features for one item results from the sum of features which are defined for the feature class of the programme and the feature class of the item. Feature classes which are referenced from the element FEATURE_CLASS_REF(path 1), may only contain features which are defined as header features in the element FEATURES (path 2).

All features referenced by the elements PRICE_FEATURE_GROUP (path 3), PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 4) and FINISH (path 5) have to occur in the feature class of an item.

Also the features used from the elements RESTRICTION_REF (path 6), RESTRICTION_REF (path 1) and RESTRICTION_REF (path 8)have to be part of the feature class of an item.

Element paths:
1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
path 2: FEATURE_DEFINITION
path 3: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
path 6: SERIES/SERIE/RESTRICTIONS
path 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS
Sequence
FEATURE_CLASS 1..∞
This element defines the variations of a programme.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute identifies the variations of a programme as a feature class. D nonNegativeInteger
P
M [1:999]
Sequence
FEATURE_REF 1..∞
The feature class refers to the element FEATURE (path 1) .
Only logical and meaningful variations may be referenced in the feature class of an item, e.g. a variation class for shelves must not contain feature types of handles.

Element paths
Pfad 1: FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature class. D nonNegativeInteger
P
M [0:999]
FEATURES
This element defines the variation types (FEATURE) and the assigned variations. This element contains only those features which are necessary for the specific catalog.

Except for the combination features and the features 701 and 703 all features are defined by the combination of finish and colour.

Features have necessarily to be defined as pairs, i.e. each finish feature requires a corresponding colour feature and vice versa.

Only the features 701 and 703, which do not require a definition of colour features, are exceptions to this rule.

Features > 950 are only relevant for the modeling graphic and must not be defined as combination variations.

Feature combinations in the catalogue (e.g. veneer green) have to be defined in the element COMBINED_FEATURE (path 1).

All feature details used in the element COMBINED_FEATURE (path 1) have to be defined as invisible header features (HEADER_POS_VARIATION_TYPE (path 2) = U).

Features which are defined as invisible must not be referenced by any feature class.

All variation types which are not marked as invisible header features in the element FEATURES (path 3), have to be referenced by at least one feature class.

Certain MUST_FEATURES are defined which are basically required. In general these features are not sufficient for a complete description of the catalogue. The assignment of a type key and a MUST-feature is defined in the table "type key - MUST features".
Further information about features is provided in the chapter "Remarks for the correct use of features"

This element is mandatory for kitchen furniture manufacturers (SUPPLIER/BRANCH_ID = K).

Element paths
path 1: FEATURE_DEFINITION/FEATURES
path 2: FEATURE_DEFINITION/FEATURES/FEATURE
path 3: FEATURE_DEFINITIO
Sequence
COMBINED_FEATURE 0..∞
This element is used for grouping single features into feature combinations. In these combinations each feature is a detail feature.

If combined features are used, variation checks and assignments may only be applied to the defined combined features and not to the subordinated detail features.

Detail features have to be defined as invisible in the element HEADER_POS_VARIATION_TYPE (path 1). These may only be used in the element OPTION (path 2).

If a combined feature has been defined, it has to be used continuously. For example: if a combined feature with feature type 303 and and detail feature 301 and 302 has been defined, all further features for handles have to be defined as combined features with feature type 303, too.

Regarding the software processing of combined features the following conventions apply: for monocoloured fronts a combined feature with feature type front colour 1 (101) is defined. The colour of this feature is inherited to feature type front colour 2 (102).

If the combined feature is a handle combination (feature type 303), at least feature type 300 and feature type 301 or 302 have to be assigned to this combined feature.

Element paths
path 1: FEATURE_DEFINITION/FEATURES/FEATURE
path 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P (105)|(115)|(125)|(201)|(303)
M [105:303]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
Sequence
OPTION_REF 2..5
This element references the features which are combined.

Feature types > 950 are only used for the modeling graphic and may not be defined as combined features.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P 10[012346]|11[01234]|12[01234]|20[02345]|30[012]
M [100:312]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
FEATURE 1..∞
This element defines a feature.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a feature. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
This element is used as a container for all possible options of a feature type.
For inheriting features types (HEADER_POS_VARIATION_TYPE=V) this element is not defined.
Sequence
OPTION 1..∞
This element defines the features of a feature class. All features of the complete database are defined in this element. In case of a finish option (cf. table standard variations, flag "A") neither texture (TEXTUR)nor colour values (COLOR) are permitted. The assignment of brightness and transparency is optional. In case they are defined they have priority over the colour variations.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required. D string
P
M [1:5]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute defines a sort order for the features. This attribute does not have to be used continuously. The sort order criterion may be be applied to all features. D nonNegativeInteger
P
M
Sequence
Choice optional
STYLE_REF
This element is used to reference a range.
STYLE_NO required Restriction of xs:string
This attribute defines the referenced programme. The attribute STYLE_NO refences to the element STYLE (path 1).

Path1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
MATERIAL_REF
This element references a material.
MATERIAL_NO required Restriction of xs:string
This attribute references a material. D string
P
M [1:5]
HANDLE_ORIENTATION_REF
This element references a handle orientation.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute defines a handle option.
 D positiveInteger
P
M [1:9999]
FORM_REF
This element references a shape.
FORM_NO required Restriction of xs:string
This attribute references a basic profile shape.
 D string
P
M [1:5]
OPTION_MEASURE_REF
This element references special dimensions of a feature class. Currently this element can only be used to indicate the different plinth heights (feature 402).
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies the referenced dimension option
 D nonNegativeInteger
P
M [1:99999]
HANDLE_POSITION_REF
This element references a handle position.
HANDLE_POSITION_NO required Restriction of xs:nonNegativeInteger
This attribute references a handle position.
 D nonNegativeInteger
P
M [0:999]
OPTION_TEXT languagetexte60 Complex Type
This element is used for defining a text concerning a option.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element references a general comment which provides information about a option. It is only used for the purpose of user-friendliness and must not contain any order relevant information as this text information is not processed by the software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
VALID_FROM optional Restriction of xs:date
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Fields named VALID_TO must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
• both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Elements named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element defines the minimum delivery time in weeks. This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.)
 D nonNegativeInteger
P
M [0:999]
FRONT_APPEARANCE_REF optional
This element defines a reference between feature and front appearance. A front appearance referenced here has to be defined in the element path1/FRONT_APPEARANCE.

This element may be used when feature "glass frame door" (FEATURE_NO = 154) is defined in path2/FEATURE_NO.

For data processing the following rules apply:
If an item is available with glass door, i.e. feature 154 is an element of the feature class of this item, the FRONT_APPEARANCE_NO of this element is used. If the item has no glass door path3/FRONT_APPEARANCE_REF is used.

This element has to be filled in from filling level 2b on.

Element paths:
path1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
path2 = FEATURE_DEFINITION/FEATURES/FEATURE
path3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITE
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID for a front appearance which is referenced by styles and items.
 D positiveInteger
P
M [1:999]
DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
FEATURE_TEXT languagetexte60 Complex Type
This element contains text information for the different features.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element defines a manufacturer specific classification for the feature types.
This classification is a recommendation of the manufacturer, the retailers may use different classifications. The classification is used for a better legibility and display of data on the screen or in print-outs.
In case a classification is defined here, this has to unambiguous and it has to be applied to all data sets.
The field classification must not be filled in if invisible header features (HEADER_POS_VARIATION_TYPE = U (path1)), are used

Element paths
path1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
This element is used for distinguishing the different feature types
I = implicit variation,
K = header variation,
U = invisible header variation,
P = position variation type or
V = inheriting variation type.

These different types are used to control the software processing of variation types; Variation types marked with "P" may only occur on position level but not in the header.
Invisible header variations may only be used in the elements OPTION (path 1) and COMBINED_FEATURE (path 2).

For variation types that inherit information from another variation type the flag "V" is used. The process of inheritance is only applied within the same item, therefore this flag may only be used for variation types 202, 203, 205 and 208. If the flag "V" is set, the
element INHERIT_VARIATION_TYPE_REF (path 3) requires an entry. Legal entries to be used here are 202, 203, 205 or 208, marked with the flag "K" or "P" in the element HEADER_POS_VARIATION_TYPE (path 3).
Inheriting variation types must not be used in any other record type.
Variations marked with "I" are invisible variations which are used for control procedures. Currently the mark "I" is only used for variation type 305 = drilling pattern.

Element paths
path 1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
path 2: FEATURE_DEFINITION/FEATURES
path 3: FEATURE_DEFINITION/FEATURES/FEATURE 		D nonNegativeInteger
P
M [0:999]
INHERIT_VARIATION_TYPE_REF optional
This element references the feature type from which information is inherited.
Feature types 202, 203, 205 and 208 may inherit information among each other.
Feature types used here must not contain the flag „invisible“
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the referenced feature. D nonNegativeInteger
P (202)|(203)|(205)|(208)
M [0:999]
OPTION_DEFINITION
This element is used for defining the different variations of colours, materials, handles, shapes,and programmes.
Sequence
STYLE 0..∞
This element is used for the definition of programmes/ styles in a catalogue.
Styles are created as features in the element STYLE_REF (path1). A style is defined by feature type 1 (FEATURE_NO = 1).

The attributes of a style must not vary within one series. As a style is only defined in this element and referenced by the series, the aforementioned condition is represented by the structure.

This element is an optional one, if the element SUPPLIER/BRANCH_ID contains the values "G" or "Z".

P1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
P2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
P3: FEATURE_DEFINITION/FEATURES
STYLE_NO required Restriction of xs:string
This attribute defines a manufacturer specific key for a style. It is referenced by the attribute STYLE_NO in the element STYLE (path1).

P1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Sequence
FRONT_DEPTH optional Restriction of xs:nonNegativeInteger
This element defines the specific depth of a style in [mm]. The default value is 20 mm..
Values in this field are required when the element FRONT_APEREANCE_NO (path1) is filled in.

path1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/ 		D nonNegativeInteger
P
M [1:99]
FRONT_DISTANCE optional Restriction of xs:nonNegativeInteger
This element is used to define the range-specific door buffer [mm]. It represents the distance between the door and the carcase behind it. D nonNegativeInteger
P
M [1:99]
FRONT_APPEARANCE_REF optional
This element assigns a front appearance to a style. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID for a front appearance which is referenced by styles and items. D positiveInteger
P
M [1:999]
FRONT_GROUP_REF optional
This element is used for assigning a front group to a style.
Several styles which have the same front appearance can be grouped in one front group.
This element references the attribute SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_GROUP_NO.
For manufacturer catalogues in which the front divisions of the cabinets depend on the different styles a definition of front groups is required.
In some manufacturer catalogues the front divisions of cabinets do not vary in the different styles. In these cases no front group definition is required.
In many cases all traditional style fronts can be grouped into one front group. This is due to the fact that the front divisions of tall cabinet front doors have a similar pattern in traditional styles.
This rule is not applied to cabinets which have different front divisions depending on the varying sizes of appliances.
In case a front group has been defined for one style, front groups have to be assigned to all styles.
FRONT_GROUP_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database. D positiveInteger
P
M [1:99]
FEATURE_CLASS_REF optional
This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D nonNegativeInteger
P
M [1:999]
DEFAULT_OPTION_GROUP_REF 0..∞
This element assigns default options to a style.
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a default option. D nonNegativeInteger
P
M [1:999999999]
RESTRICTIONS optional
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.
Sequence
RESTRICTION_REF 1..∞
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations. 		D nonNegativeInteger
P
M [1:99999]
SEQUENCE required Restriction of xs:positiveInteger
This element defines the sequence in which the different test procedures are performed. Several restriction can be grouped (set union), if the value filled in in the element SEQUENCE is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...) 		D positiveInteger
P
M [1:99999]
HANDLE_ORIENTATION 0..∞
This element defines a handle orientation.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute identifies a handle option. D string
P
M [1:5]
Sequence
DEFAULT_HANDLE_ORIENTATION_REF optional

This element defines a variation of the basic handle position. It references a basic handle position defined in the element BASIC_HANDLE_POSITIONS (path 1).

The manufacturer specific name for this position is defined in the element OPTION_KEY (path 2).

The element default handle position has to be filled in if variation type 304 (handle position) is set in the element FEATURE (path 3).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS

path 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
path 3: FEATURE_DEFINITION/FEATURES

SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
This attribute defines a standard handle position. D nonNegativeInteger
P
M [1:99999]
MATERIAL 0..∞
This element defines a material.

In case of a finish option, (cf. table Standard variation types flag "A"), neither texture (TEXTURE) nor colour (COLOR) values are permitted.

Finish options are defined in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION.
MATERIAL_NO required Restriction of xs:string
This attribute identifies a material. D string
P
M [1:5]
Sequence
Choice optional
COLOR
This element defines colours.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
TEXTURE
This element defines information about the textures.
Sequence
FILE_NAME_TEXTURE Restriction of xs:string
This element defines references to material textures. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]
TEXTURE_REPEAT optional
This element defines if a texture is applied to a material only one time or repeatedly. If a texture repeat is required, this element is defined and the settings are applied to all child elements, too.
According to the basic texture size (DPI, number of pixels) the repeat factor is calculated automatically by the software programme.
If the element FILENAME_TEXTURE is filled in, this element is required, too.
TEXTURE_TILE optional Restriction of xs:int
This attribute defines if a texture is applied to a material only one time (0 = no repeat) or several times (1 = repeat). D integer
P
M [0:1]
Sequence
REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger
This element defines the dimensions of the texture in X direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger
This element defines the dimensions of the texture in Y direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
MASKING optional Restriction of xs:boolean
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
If the element FILENAME_TEXTURE is filled in, this element is required, too. 		D boolean
P
M
TEXTURE_DELIVERED_ORIENTATION Restriction of xs:string
This attribute identifies a default handle position. D string
P |[HV]
M [0:1]
TRANSPARENCY optional Restriction of xs:nonNegativeInteger
This element defines the degree of transparency for a material RGB value or texture).
0 = opaque
9 = max. transparency
If this element is a colour variation settings in this field are required. 		D nonNegativeInteger
P
M [0:9]
BRIGHTNESS optional Restriction of xs:nonNegativeInteger
This element defines the degree of brightness for a material (RGB value or texture).
0 = opaque
8 = high gloss
9 = reflection
If this element is a colour variation settings in this field are required. 		D nonNegativeInteger
P
M [0:9]
FORM 0..∞
This element is used to define a variation of a shape.
FORM_NO required Restriction of xs:string
This attribute identifies the shape of a profile. D string
P
M [1:5]
Sequence
PROFILE_KEY Restriction of xs:string
This element defines the manufacturer specific key for a profile shape. This element is used for building the variation types 750-756. Only these variation types 750-756 can use the element FORM. The different variations are referenced by the item (ITEM) which represents the profile. D string
P
M [1:5]
OPTION_MEASURE 0..∞
This element defines measurement information for different features, e.g. plinth height (feature type 402).
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies the dimensions of an appearance. D nonNegativeInteger
P
M [1:99999]
Sequence
PLINTH_HEIGHT Restriction of xs:nonNegativeInteger
This element defines the plinth height in mm. D nonNegativeInteger
P
M [0:999999999]
STANDARD_PLINTH optional xs:boolean

This element is used to specify whether the relevant plinth height is a standard value or if it is different from the standard. If the value is set to false(0), the plinth height is different from the standard height and may incur an additional price for the plinth feet.

A missing element corresponds to the value true(1).

This element must be specified if there are linked articles with allocation type CLASS = 21.

D boolean
P
M [0:1]
RESTRICTIONS optional
This element is used for the definition of restrictions.
Sequence
RESTRICTION 1..99999
This element is used for the definition and description of restrictions. These restrictions define rules for technically possible combinations but do not contain any planning advices. This is necessary to prevent the dealers from unnecessary restrictions in the course of kitchen planning.

Restrictions are assigned to series, styles or items by references. All test procedures defined in this element have to be referenced from series, styles or items.

Restrictions which are referenced from series or styles may not be referenced from items. Restrictions which are referenced from items have priority over restrictions referenced from series or styles

The element OPTION_REF can be set up in different ways. According to the filling levels in the elements FEATURE_1_NO, FEATURE_2_NO and FEATURE_3_NO test procedures can be defined as 0-level, 1-level or 2-level or 3-level.

Number of variations in case of undefined variations

On condition that the restriction is defined as a "permitting" test procedure (TEST_ID = 1), all features which are not listed in the test procedure are illegal feature combinations. If the restriction is defined as a "non-permitting" test procedure (TEST_ID = 0), all variations are legal feature combinations. If different feature combinations are combined this rule applies for the combination of the resulting features.

Number of variations for style specific restrictions:

In case a restriction is not referenced by all styles, the following rules apply:

If the restriction defines legal features and feature combinations, all variations of the feature combinations are illegal for those styles, which are not defined in the restriction.
If the restriction defines illegal features and feature combinations, all variations of the of the feature combinations are legal for those styles, which are not defined in the restriction.

Cyclical tests
Cyclical restrictions are not permitted. Such test procedures might result from the following constellations
Not permitted
1. restriction: feature 1 with feature 2
2. restriction: feature 2 with feature 3
3. restriction: feature 3 with feature 1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute identifies restrictions unambiguously. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger

The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]

VALIDATION_TYPE required Restriction of xs:int
The attribute VALIDATION_TYPE defines a restriction as either colour-length or variation test procedure. In case of a colour-length test procedure the element MIN/MAX_DIMENSION under OPTION_COMBINATION has to be filled in.
0 = variation test procedure (formerly record type 270)
1 = colour-length test procedure (formerly record type 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
This element is used for the definition of a name for a control procedure.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
This element is used for the definition of a variation combination.
Sequence
OPTION_REF 1..3
This element is used for referencing the variation types which are used in the control procedures.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
This element defines the minimum dimension in which an option is available.
DIMENSION_TYPE required Restriction of xs:string
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
This element defines the minimum dimension in which an option is available. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted 		D boolean
P
M
SUGGESTIONS optional
This element is used to specify default values.
Sequence
SUGGESTION 1..99999

This element is used to define and describe default values for version types with certain versions.

This option to set default values is only provided for head versions and becomes effective when a planning is recorded for the first time.

Similar to a standard proposal (DEFAULT_OPTION_GROUP), it is referenced below the series, with the standard proposal assigned a higher priority.

OPTION_COMBINATION can be used to make pairs of versions for version-specific default values available.

The version type specified at FEATURE_1_NO has the highest priority.

The default values must not conflict with the associated checks.

SUGGESTION_NO required Restriction of xs:nonNegativeInteger
This attribute assigns unique identifiers to sets of default values. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values. D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values. D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values. D nonNegativeInteger
P
M [0:999]
Sequence
SUGGESTION_NAME_TEXT languagetexte60 Complex Type
This element is used to specify the description of a set of default values.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
This element is used to form a version combination for default values.
Sequence
OPTION_REF 1..3
This element is used to reference variants that are specified in default settings.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references the version type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references the variant type. D string
P
M [1:5]
Remarks

Source
<xs:element name="FEATURE_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_CLASSES">
        <xs:annotation>
          <xs:documentation>255--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_CLASS" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>255--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>255--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>255--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_CLASS_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>255--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURES">
        <xs:annotation>
          <xs:documentation>250--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="COMBINED_FEATURE" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>265--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF" minOccurs="2" maxOccurs="5">
                    <xs:annotation>
                      <xs:documentation>265--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>265--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="10[012346]|11[01234]|12[01234]|20[02345]|30[012]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>265--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>265--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="(105)|(115)|(125)|(201)|(303)" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>265--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:choice minOccurs="0">
                                <xs:element name="STYLE_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="STYLE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="5" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MATERIAL_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="MATERIAL_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="5" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="HANDLE_ORIENTATION_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="FORM_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="FORM_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="5" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_MEASURE_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_MEASURE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="HANDLE_POSITION_REF">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="HANDLE_POSITION_NO" use="required">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                          <xs:totalDigits value="3" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:choice>
                              <xs:element name="OPTION_TEXT" type="languagetexte60">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FEATURE_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="SEQUENCE_NO">
                    <xs:annotation>
                      <xs:documentation>250--4--Sortierung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HEADER_POS_VARIATION_TYPE">
                    <xs:annotation>
                      <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[IKUPV]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INHERIT_VARIATION_TYPE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="(202)|(203)|(205)|(208)" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>250--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_DEFINITION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="STYLE" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>210--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_DEPTH" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>210--6--Front_Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FRONT_DISTANCE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>210--6--Türpuffer</xs:documentation>
                      <xs:documentation>K.Richter/13.06.2018</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FRONT_GROUP_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>210--12--Frontgruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FRONT_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>210--12--Frontgruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_CLASS_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>210--13--Var_Familien_Nr</xs:documentation>
                          <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DEFAULT_OPTION_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>295--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>295--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RESTRICTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                      <xs:documentation>von minOcc 1 auf optional 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            <xs:documentation>von optional  auf  minOcc 1 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="RESTRICTION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="STYLE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>210--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="HANDLE_ORIENTATION" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DEFAULT_HANDLE_ORIENTATION_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:choice minOccurs="0">
                    <xs:annotation>
                      <xs:documentation />
                      <xs:documentation>AK 28.02.2012. Optional gesetzt um die alte 1.7 Logik zu erhalten.</xs:documentation>
                    </xs:annotation>
                    <xs:element name="COLOR">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="RGB_RED">
                            <xs:annotation>
                              <xs:documentation>260--11--RGB_Rot</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="255" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="RGB_GREEN">
                            <xs:annotation>
                              <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="255" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="RGB_BLUE">
                            <xs:annotation>
                              <xs:documentation>260--13--RGB_Blau</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="255" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="TEXTURE">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="FILE_NAME_TEXTURE">
                            <xs:annotation>
                              <xs:documentation>260--6--Dateiname_Textur</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="TEXTURE_REPEAT" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>260--9--Textur_Kachelung</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="REAL_MEASUREMENT_X">
                                  <xs:annotation>
                                    <xs:documentation>260--17--Realmass_X</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="REAL_MEASUREMENT_Y">
                                  <xs:annotation>
                                    <xs:documentation>260--18--Realmass_Y</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="TEXTURE_TILE">
                                <xs:simpleType>
                                  <xs:restriction base="xs:int">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="1" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MASKING" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>260--10--Maskierung</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:boolean" />
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="TEXTURE_DELIVERED_ORIENTATION">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:pattern value="|[HV]" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                  <xs:element name="TRANSPARENCY" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--14--Transparenz</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BRIGHTNESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--15--Glanz</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="MATERIAL_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FORM" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PROFILE_KEY">
                    <xs:annotation>
                      <xs:documentation>430--4/5--Varianten_Art_Profilform/Var_Schluessel_</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FORM_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PLINTH_HEIGHT">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STANDARD_PLINTH" type="xs:boolean" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Kennzeichnung zur Abweichung von Standardsockelhöhe</xs:documentation>
                      <xs:documentation>hinzugefügt K.Richter, 29.02.2016</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPTION_MEASURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>270/271--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION" maxOccurs="99999">
              <xs:annotation>
                <xs:documentation>270/271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>270--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF" maxOccurs="3">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:sequence minOccurs="0">
                          <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                            <xs:annotation>
                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                              <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="DIMENSION_TYPE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[WHD]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSION_VALUE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                            <xs:annotation>
                              <xs:documentation>405--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                              <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="DIMENSION_TYPE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[WHD]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSION_VALUE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TEST_ID">
                    <xs:annotation>
                      <xs:documentation>270--4--Pruef_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_1_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_2_NO">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_3_NO">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="VALIDATION_TYPE" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:int">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SUGGESTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>270/271--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SUGGESTION" maxOccurs="99999">
              <xs:annotation>
                <xs:documentation>270/271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SUGGESTION_NAME_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>270--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF" maxOccurs="3">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SUGGESTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_1_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_2_NO">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_3_NO">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_CLASSES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : FEATURE_CLASSES Element
Description
In this element features are grouped into feature classes. By using feature classes different checks concerning plausibility and completeness of the valid variation types can be processed.

Feature classes can be assigned to series, programmes, or product groups. There is no priority to any of these assigned levels. The total number of valid features for one item results from the sum of features which are defined for the feature class of the programme and the feature class of the item. Feature classes which are referenced from the element FEATURE_CLASS_REF(path 1), may only contain features which are defined as header features in the element FEATURES (path 2).

All features referenced by the elements PRICE_FEATURE_GROUP (path 3), PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 4) and FINISH (path 5) have to occur in the feature class of an item.

Also the features used from the elements RESTRICTION_REF (path 6), RESTRICTION_REF (path 1) and RESTRICTION_REF (path 8)have to be part of the feature class of an item.

Element paths:
1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
path 2: FEATURE_DEFINITION
path 3: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
path 6: SERIES/SERIE/RESTRICTIONS
path 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS
Namespace (none)
Diagram
FEATURE_CLASS Element Sequence FEATURE_CLASSES Element
Overview
FEATURE_CLASSES
In this element features are grouped into feature classes. By using feature classes different checks concerning plausibility and completeness of the valid variation types can be processed.

Feature classes can be assigned to series, programmes, or product groups. There is no priority to any of these assigned levels. The total number of valid features for one item results from the sum of features which are defined for the feature class of the programme and the feature class of the item. Feature classes which are referenced from the element FEATURE_CLASS_REF(path 1), may only contain features which are defined as header features in the element FEATURES (path 2).

All features referenced by the elements PRICE_FEATURE_GROUP (path 3), PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 4) and FINISH (path 5) have to occur in the feature class of an item.

Also the features used from the elements RESTRICTION_REF (path 6), RESTRICTION_REF (path 1) and RESTRICTION_REF (path 8)have to be part of the feature class of an item.

Element paths:
1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
path 2: FEATURE_DEFINITION
path 3: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
path 6: SERIES/SERIE/RESTRICTIONS
path 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS
Sequence
FEATURE_CLASS 1..∞
This element defines the variations of a programme.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute identifies the variations of a programme as a feature class. D nonNegativeInteger
P
M [1:999]
Sequence
FEATURE_REF 1..∞
The feature class refers to the element FEATURE (path 1) .
Only logical and meaningful variations may be referenced in the feature class of an item, e.g. a variation class for shelves must not contain feature types of handles.

Element paths
Pfad 1: FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature class. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="FEATURE_CLASSES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_CLASS" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>255--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>255--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>255--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_CLASS_NO" use="required">
            <xs:annotation>
              <xs:documentation>255--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_CLASS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURE_CLASSES Element : FEATURE_CLASS Element
Description
This element defines the variations of a programme.
Namespace (none)
Diagram
FEATURE_REF Element Sequence FEATURE_CLASS Element
Overview
FEATURE_CLASS 1..∞
This element defines the variations of a programme.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This attribute identifies the variations of a programme as a feature class. D nonNegativeInteger
P
M [1:999]
Sequence
FEATURE_REF 1..∞
The feature class refers to the element FEATURE (path 1) .
Only logical and meaningful variations may be referenced in the feature class of an item, e.g. a variation class for shelves must not contain feature types of handles.

Element paths
Pfad 1: FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature class. D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_CLASS_NO Restriction of xs:positiveInteger required
This attribute identifies the variations of a programme as a feature class. D nonNegativeInteger
P
M [1:999]
Source
<xs:element name="FEATURE_CLASS" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>255--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>255--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_CLASS_NO" use="required">
      <xs:annotation>
        <xs:documentation>255--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FEATURE_CLASSES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURE_CLASSES Element > FEATURE_CLASS Element : FEATURE_REF Element
Description
The feature class refers to the element FEATURE (path 1) .
Only logical and meaningful variations may be referenced in the feature class of an item, e.g. a variation class for shelves must not contain feature types of handles.

Element paths
Pfad 1: FEATURE_DEFINITION/FEATURES
Namespace (none)
Diagram
FEATURE_REF Element
Overview
FEATURE_REF 1..∞
The feature class refers to the element FEATURE (path 1) .
Only logical and meaningful variations may be referenced in the feature class of an item, e.g. a variation class for shelves must not contain feature types of handles.

Element paths
Pfad 1: FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature class. D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for referencing a feature class. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="FEATURE_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>255--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FEATURE_CLASS Element | FEATURE_CLASSES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : FEATURES Element
Description
This element defines the variation types (FEATURE) and the assigned variations. This element contains only those features which are necessary for the specific catalog.

Except for the combination features and the features 701 and 703 all features are defined by the combination of finish and colour.

Features have necessarily to be defined as pairs, i.e. each finish feature requires a corresponding colour feature and vice versa.

Only the features 701 and 703, which do not require a definition of colour features, are exceptions to this rule.

Features > 950 are only relevant for the modeling graphic and must not be defined as combination variations.

Feature combinations in the catalogue (e.g. veneer green) have to be defined in the element COMBINED_FEATURE (path 1).

All feature details used in the element COMBINED_FEATURE (path 1) have to be defined as invisible header features (HEADER_POS_VARIATION_TYPE (path 2) = U).

Features which are defined as invisible must not be referenced by any feature class.

All variation types which are not marked as invisible header features in the element FEATURES (path 3), have to be referenced by at least one feature class.

Certain MUST_FEATURES are defined which are basically required. In general these features are not sufficient for a complete description of the catalogue. The assignment of a type key and a MUST-feature is defined in the table "type key - MUST features".
Further information about features is provided in the chapter "Remarks for the correct use of features"

This element is mandatory for kitchen furniture manufacturers (SUPPLIER/BRANCH_ID = K).

Element paths
path 1: FEATURE_DEFINITION/FEATURES
path 2: FEATURE_DEFINITION/FEATURES/FEATURE
path 3: FEATURE_DEFINITIO
Namespace (none)
Diagram
FEATURE Element COMBINED_FEATURE Element Sequence FEATURES Element
Overview
FEATURES
This element defines the variation types (FEATURE) and the assigned variations. This element contains only those features which are necessary for the specific catalog.

Except for the combination features and the features 701 and 703 all features are defined by the combination of finish and colour.

Features have necessarily to be defined as pairs, i.e. each finish feature requires a corresponding colour feature and vice versa.

Only the features 701 and 703, which do not require a definition of colour features, are exceptions to this rule.

Features > 950 are only relevant for the modeling graphic and must not be defined as combination variations.

Feature combinations in the catalogue (e.g. veneer green) have to be defined in the element COMBINED_FEATURE (path 1).

All feature details used in the element COMBINED_FEATURE (path 1) have to be defined as invisible header features (HEADER_POS_VARIATION_TYPE (path 2) = U).

Features which are defined as invisible must not be referenced by any feature class.

All variation types which are not marked as invisible header features in the element FEATURES (path 3), have to be referenced by at least one feature class.

Certain MUST_FEATURES are defined which are basically required. In general these features are not sufficient for a complete description of the catalogue. The assignment of a type key and a MUST-feature is defined in the table "type key - MUST features".
Further information about features is provided in the chapter "Remarks for the correct use of features"

This element is mandatory for kitchen furniture manufacturers (SUPPLIER/BRANCH_ID = K).

Element paths
path 1: FEATURE_DEFINITION/FEATURES
path 2: FEATURE_DEFINITION/FEATURES/FEATURE
path 3: FEATURE_DEFINITIO
Sequence
COMBINED_FEATURE 0..∞
This element is used for grouping single features into feature combinations. In these combinations each feature is a detail feature.

If combined features are used, variation checks and assignments may only be applied to the defined combined features and not to the subordinated detail features.

Detail features have to be defined as invisible in the element HEADER_POS_VARIATION_TYPE (path 1). These may only be used in the element OPTION (path 2).

If a combined feature has been defined, it has to be used continuously. For example: if a combined feature with feature type 303 and and detail feature 301 and 302 has been defined, all further features for handles have to be defined as combined features with feature type 303, too.

Regarding the software processing of combined features the following conventions apply: for monocoloured fronts a combined feature with feature type front colour 1 (101) is defined. The colour of this feature is inherited to feature type front colour 2 (102).

If the combined feature is a handle combination (feature type 303), at least feature type 300 and feature type 301 or 302 have to be assigned to this combined feature.

Element paths
path 1: FEATURE_DEFINITION/FEATURES/FEATURE
path 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P (105)|(115)|(125)|(201)|(303)
M [105:303]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
Sequence
OPTION_REF 2..5
This element references the features which are combined.

Feature types > 950 are only used for the modeling graphic and may not be defined as combined features.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P 10[012346]|11[01234]|12[01234]|20[02345]|30[012]
M [100:312]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
FEATURE 1..∞
This element defines a feature.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a feature. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
This element is used as a container for all possible options of a feature type.
For inheriting features types (HEADER_POS_VARIATION_TYPE=V) this element is not defined.
Sequence
OPTION 1..∞
This element defines the features of a feature class. All features of the complete database are defined in this element. In case of a finish option (cf. table standard variations, flag "A") neither texture (TEXTUR)nor colour values (COLOR) are permitted. The assignment of brightness and transparency is optional. In case they are defined they have priority over the colour variations.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required. D string
P
M [1:5]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute defines a sort order for the features. This attribute does not have to be used continuously. The sort order criterion may be be applied to all features. D nonNegativeInteger
P
M
Sequence
Choice optional
STYLE_REF
This element is used to reference a range.
STYLE_NO required Restriction of xs:string
This attribute defines the referenced programme. The attribute STYLE_NO refences to the element STYLE (path 1).

Path1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
MATERIAL_REF
This element references a material.
MATERIAL_NO required Restriction of xs:string
This attribute references a material. D string
P
M [1:5]
HANDLE_ORIENTATION_REF
This element references a handle orientation.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute defines a handle option.
 D positiveInteger
P
M [1:9999]
FORM_REF
This element references a shape.
FORM_NO required Restriction of xs:string
This attribute references a basic profile shape.
 D string
P
M [1:5]
OPTION_MEASURE_REF
This element references special dimensions of a feature class. Currently this element can only be used to indicate the different plinth heights (feature 402).
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies the referenced dimension option
 D nonNegativeInteger
P
M [1:99999]
HANDLE_POSITION_REF
This element references a handle position.
HANDLE_POSITION_NO required Restriction of xs:nonNegativeInteger
This attribute references a handle position.
 D nonNegativeInteger
P
M [0:999]
OPTION_TEXT languagetexte60 Complex Type
This element is used for defining a text concerning a option.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element references a general comment which provides information about a option. It is only used for the purpose of user-friendliness and must not contain any order relevant information as this text information is not processed by the software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Fields named VALID_TO must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
• both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Elements named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element defines the minimum delivery time in weeks. This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.)
 D nonNegativeInteger
P
M [0:999]
FRONT_APPEARANCE_REF optional
This element defines a reference between feature and front appearance. A front appearance referenced here has to be defined in the element path1/FRONT_APPEARANCE.

This element may be used when feature "glass frame door" (FEATURE_NO = 154) is defined in path2/FEATURE_NO.

For data processing the following rules apply:
If an item is available with glass door, i.e. feature 154 is an element of the feature class of this item, the FRONT_APPEARANCE_NO of this element is used. If the item has no glass door path3/FRONT_APPEARANCE_REF is used.

This element has to be filled in from filling level 2b on.

Element paths:
path1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
path2 = FEATURE_DEFINITION/FEATURES/FEATURE
path3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITE
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID for a front appearance which is referenced by styles and items.
 D positiveInteger
P
M [1:999]
DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This element references hyperlinks to detail information.
 D positiveInteger
P
M [1:999999999]
FEATURE_TEXT languagetexte60 Complex Type
This element contains text information for the different features.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element defines a manufacturer specific classification for the feature types.
This classification is a recommendation of the manufacturer, the retailers may use different classifications. The classification is used for a better legibility and display of data on the screen or in print-outs.
In case a classification is defined here, this has to unambiguous and it has to be applied to all data sets.
The field classification must not be filled in if invisible header features (HEADER_POS_VARIATION_TYPE = U (path1)), are used

Element paths
path1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
This element is used for distinguishing the different feature types
I = implicit variation,
K = header variation,
U = invisible header variation,
P = position variation type or
V = inheriting variation type.

These different types are used to control the software processing of variation types; Variation types marked with "P" may only occur on position level but not in the header.
Invisible header variations may only be used in the elements OPTION (path 1) and COMBINED_FEATURE (path 2).

For variation types that inherit information from another variation type the flag "V" is used. The process of inheritance is only applied within the same item, therefore this flag may only be used for variation types 202, 203, 205 and 208. If the flag "V" is set, the
element INHERIT_VARIATION_TYPE_REF (path 3) requires an entry. Legal entries to be used here are 202, 203, 205 or 208, marked with the flag "K" or "P" in the element HEADER_POS_VARIATION_TYPE (path 3).
Inheriting variation types must not be used in any other record type.
Variations marked with "I" are invisible variations which are used for control procedures. Currently the mark "I" is only used for variation type 305 = drilling pattern.

Element paths
path 1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
path 2: FEATURE_DEFINITION/FEATURES
path 3: FEATURE_DEFINITION/FEATURES/FEATURE 		D nonNegativeInteger
P
M [0:999]
INHERIT_VARIATION_TYPE_REF optional
This element references the feature type from which information is inherited.
Feature types 202, 203, 205 and 208 may inherit information among each other.
Feature types used here must not contain the flag „invisible“
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the referenced feature. D nonNegativeInteger
P (202)|(203)|(205)|(208)
M [0:999]
Source
<xs:element name="FEATURES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="COMBINED_FEATURE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>265--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF" minOccurs="2" maxOccurs="5">
              <xs:annotation>
                <xs:documentation>265--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>265--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="10[012346]|11[01234]|12[01234]|20[02345]|30[012]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>265--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>265--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="(105)|(115)|(125)|(201)|(303)" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>265--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:choice minOccurs="0">
                          <xs:element name="STYLE_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="STYLE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="5" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MATERIAL_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="MATERIAL_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="5" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="HANDLE_ORIENTATION_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="FORM_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="FORM_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="5" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_MEASURE_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPTION_MEASURE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="HANDLE_POSITION_REF">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="HANDLE_POSITION_NO" use="required">
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                    <xs:totalDigits value="3" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                        <xs:element name="OPTION_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURE_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="SEQUENCE_NO">
              <xs:annotation>
                <xs:documentation>250--4--Sortierung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEADER_POS_VARIATION_TYPE">
              <xs:annotation>
                <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[IKUPV]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INHERIT_VARIATION_TYPE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>250--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="(202)|(203)|(205)|(208)" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>250--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COMBINED_FEATURE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element : COMBINED_FEATURE Element
Description
This element is used for grouping single features into feature combinations. In these combinations each feature is a detail feature.

If combined features are used, variation checks and assignments may only be applied to the defined combined features and not to the subordinated detail features.

Detail features have to be defined as invisible in the element HEADER_POS_VARIATION_TYPE (path 1). These may only be used in the element OPTION (path 2).

If a combined feature has been defined, it has to be used continuously. For example: if a combined feature with feature type 303 and and detail feature 301 and 302 has been defined, all further features for handles have to be defined as combined features with feature type 303, too.

Regarding the software processing of combined features the following conventions apply: for monocoloured fronts a combined feature with feature type front colour 1 (101) is defined. The colour of this feature is inherited to feature type front colour 2 (102).

If the combined feature is a handle combination (feature type 303), at least feature type 300 and feature type 301 or 302 have to be assigned to this combined feature.

Element paths
path 1: FEATURE_DEFINITION/FEATURES/FEATURE
path 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
Namespace (none)
Diagram
OPTION_REF Element Sequence COMBINED_FEATURE Element
Overview
COMBINED_FEATURE 0..∞
This element is used for grouping single features into feature combinations. In these combinations each feature is a detail feature.

If combined features are used, variation checks and assignments may only be applied to the defined combined features and not to the subordinated detail features.

Detail features have to be defined as invisible in the element HEADER_POS_VARIATION_TYPE (path 1). These may only be used in the element OPTION (path 2).

If a combined feature has been defined, it has to be used continuously. For example: if a combined feature with feature type 303 and and detail feature 301 and 302 has been defined, all further features for handles have to be defined as combined features with feature type 303, too.

Regarding the software processing of combined features the following conventions apply: for monocoloured fronts a combined feature with feature type front colour 1 (101) is defined. The colour of this feature is inherited to feature type front colour 2 (102).

If the combined feature is a handle combination (feature type 303), at least feature type 300 and feature type 301 or 302 have to be assigned to this combined feature.

Element paths
path 1: FEATURE_DEFINITION/FEATURES/FEATURE
path 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P (105)|(115)|(125)|(201)|(303)
M [105:303]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
Sequence
OPTION_REF 2..5
This element references the features which are combined.

Feature types > 950 are only used for the modeling graphic and may not be defined as combined features.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P 10[012346]|11[01234]|12[01234]|20[02345]|30[012]
M [100:312]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for referencing a feature. D nonNegativeInteger
P (105)|(115)|(125)|(201)|(303)
M [105:303]
OPTION_KEY Restriction of xs:string required
This attribute is used for referencing a option. D string
P
M [1:5]
Source
<xs:element name="COMBINED_FEATURE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF" minOccurs="2" maxOccurs="5">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>265--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="10[012346]|11[01234]|12[01234]|20[02345]|30[012]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>265--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>265--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="(105)|(115)|(125)|(201)|(303)" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>265--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > COMBINED_FEATURE Element : OPTION_REF Element
Description
This element references the features which are combined.

Feature types > 950 are only used for the modeling graphic and may not be defined as combined features.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF 2..5
This element references the features which are combined.

Feature types > 950 are only used for the modeling graphic and may not be defined as combined features.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P 10[012346]|11[01234]|12[01234]|20[02345]|30[012]
M [100:312]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for referencing a feature. D nonNegativeInteger
P 10[012346]|11[01234]|12[01234]|20[02345]|30[012]
M [100:312]
OPTION_KEY Restriction of xs:string required
This attribute is used for referencing a option. D string
P
M [1:5]
Source
<xs:element name="OPTION_REF" minOccurs="2" maxOccurs="5" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>265--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="10[012346]|11[01234]|12[01234]|20[02345]|30[012]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>265--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
COMBINED_FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element : FEATURE Element
Description
This element defines a feature.
Namespace (none)
Diagram
INHERIT_VARIATION_TYPE_REF Element HEADER_POS_VARIATION_TYPE Element SEQUENCE_NO Element LANGUAGE Element Sequence FEATURE_TEXT Element OPTIONS Element Sequence FEATURE Element
Overview
FEATURE 1..∞
This element defines a feature.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a feature. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
This element is used as a container for all possible options of a feature type.
For inheriting features types (HEADER_POS_VARIATION_TYPE=V) this element is not defined.
Sequence
OPTION 1..∞
This element defines the features of a feature class. All features of the complete database are defined in this element. In case of a finish option (cf. table standard variations, flag "A") neither texture (TEXTUR)nor colour values (COLOR) are permitted. The assignment of brightness and transparency is optional. In case they are defined they have priority over the colour variations.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required. D string
P
M [1:5]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute defines a sort order for the features. This attribute does not have to be used continuously. The sort order criterion may be be applied to all features. D nonNegativeInteger
P
M
Sequence
Choice optional
STYLE_REF
This element is used to reference a range.
STYLE_NO required Restriction of xs:string
This attribute defines the referenced programme. The attribute STYLE_NO refences to the element STYLE (path 1).

Path1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
MATERIAL_REF
This element references a material.
MATERIAL_NO required Restriction of xs:string
This attribute references a material. D string
P
M [1:5]
HANDLE_ORIENTATION_REF
This element references a handle orientation.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute defines a handle option.
 D positiveInteger
P
M [1:9999]
FORM_REF
This element references a shape.
FORM_NO required Restriction of xs:string
This attribute references a basic profile shape.
 D string
P
M [1:5]
OPTION_MEASURE_REF
This element references special dimensions of a feature class. Currently this element can only be used to indicate the different plinth heights (feature 402).
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies the referenced dimension option
 D nonNegativeInteger
P
M [1:99999]
HANDLE_POSITION_REF
This element references a handle position.
HANDLE_POSITION_NO required Restriction of xs:nonNegativeInteger
This attribute references a handle position.
 D nonNegativeInteger
P
M [0:999]
OPTION_TEXT languagetexte60 Complex Type
This element is used for defining a text concerning a option.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element references a general comment which provides information about a option. It is only used for the purpose of user-friendliness and must not contain any order relevant information as this text information is not processed by the software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Fields named VALID_TO must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
• both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Elements named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element defines the minimum delivery time in weeks. This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.)
 D nonNegativeInteger
P
M [0:999]
FRONT_APPEARANCE_REF optional
This element defines a reference between feature and front appearance. A front appearance referenced here has to be defined in the element path1/FRONT_APPEARANCE.

This element may be used when feature "glass frame door" (FEATURE_NO = 154) is defined in path2/FEATURE_NO.

For data processing the following rules apply:
If an item is available with glass door, i.e. feature 154 is an element of the feature class of this item, the FRONT_APPEARANCE_NO of this element is used. If the item has no glass door path3/FRONT_APPEARANCE_REF is used.

This element has to be filled in from filling level 2b on.

Element paths:
path1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
path2 = FEATURE_DEFINITION/FEATURES/FEATURE
path3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITE
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID for a front appearance which is referenced by styles and items.
 D positiveInteger
P
M [1:999]
DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This element references hyperlinks to detail information.
 D positiveInteger
P
M [1:999999999]
FEATURE_TEXT languagetexte60 Complex Type
This element contains text information for the different features.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element defines a manufacturer specific classification for the feature types.
This classification is a recommendation of the manufacturer, the retailers may use different classifications. The classification is used for a better legibility and display of data on the screen or in print-outs.
In case a classification is defined here, this has to unambiguous and it has to be applied to all data sets.
The field classification must not be filled in if invisible header features (HEADER_POS_VARIATION_TYPE = U (path1)), are used

Element paths
path1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
This element is used for distinguishing the different feature types
I = implicit variation,
K = header variation,
U = invisible header variation,
P = position variation type or
V = inheriting variation type.

These different types are used to control the software processing of variation types; Variation types marked with "P" may only occur on position level but not in the header.
Invisible header variations may only be used in the elements OPTION (path 1) and COMBINED_FEATURE (path 2).

For variation types that inherit information from another variation type the flag "V" is used. The process of inheritance is only applied within the same item, therefore this flag may only be used for variation types 202, 203, 205 and 208. If the flag "V" is set, the
element INHERIT_VARIATION_TYPE_REF (path 3) requires an entry. Legal entries to be used here are 202, 203, 205 or 208, marked with the flag "K" or "P" in the element HEADER_POS_VARIATION_TYPE (path 3).
Inheriting variation types must not be used in any other record type.
Variations marked with "I" are invisible variations which are used for control procedures. Currently the mark "I" is only used for variation type 305 = drilling pattern.

Element paths
path 1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
path 2: FEATURE_DEFINITION/FEATURES
path 3: FEATURE_DEFINITION/FEATURES/FEATURE 		D nonNegativeInteger
P
M [0:999]
INHERIT_VARIATION_TYPE_REF optional
This element references the feature type from which information is inherited.
Feature types 202, 203, 205 and 208 may inherit information among each other.
Feature types used here must not contain the flag „invisible“
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the referenced feature. D nonNegativeInteger
P (202)|(203)|(205)|(208)
M [0:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute identifies a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="FEATURE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:choice minOccurs="0">
                    <xs:element name="STYLE_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="STYLE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MATERIAL_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="MATERIAL_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="HANDLE_ORIENTATION_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="FORM_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="FORM_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_MEASURE_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPTION_MEASURE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="HANDLE_POSITION_REF">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="HANDLE_POSITION_NO" use="required">
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                              <xs:totalDigits value="3" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                  <xs:element name="OPTION_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="SEQUENCE_NO">
        <xs:annotation>
          <xs:documentation>250--4--Sortierung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEADER_POS_VARIATION_TYPE">
        <xs:annotation>
          <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[IKUPV]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INHERIT_VARIATION_TYPE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>250--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="(202)|(203)|(205)|(208)" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>250--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : OPTIONS Element
Description
This element is used as a container for all possible options of a feature type.
For inheriting features types (HEADER_POS_VARIATION_TYPE=V) this element is not defined.
Namespace (none)
Diagram
OPTION Element Sequence OPTIONS Element
Overview
OPTIONS optional
This element is used as a container for all possible options of a feature type.
For inheriting features types (HEADER_POS_VARIATION_TYPE=V) this element is not defined.
Sequence
OPTION 1..∞
This element defines the features of a feature class. All features of the complete database are defined in this element. In case of a finish option (cf. table standard variations, flag "A") neither texture (TEXTUR)nor colour values (COLOR) are permitted. The assignment of brightness and transparency is optional. In case they are defined they have priority over the colour variations.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required. D string
P
M [1:5]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute defines a sort order for the features. This attribute does not have to be used continuously. The sort order criterion may be be applied to all features. D nonNegativeInteger
P
M
Sequence
Choice optional
STYLE_REF
This element is used to reference a range.
STYLE_NO required Restriction of xs:string
This attribute defines the referenced programme. The attribute STYLE_NO refences to the element STYLE (path 1).

Path1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
MATERIAL_REF
This element references a material.
MATERIAL_NO required Restriction of xs:string
This attribute references a material. D string
P
M [1:5]
HANDLE_ORIENTATION_REF
This element references a handle orientation.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute defines a handle option.
 D positiveInteger
P
M [1:9999]
FORM_REF
This element references a shape.
FORM_NO required Restriction of xs:string
This attribute references a basic profile shape.
 D string
P
M [1:5]
OPTION_MEASURE_REF
This element references special dimensions of a feature class. Currently this element can only be used to indicate the different plinth heights (feature 402).
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies the referenced dimension option
 D nonNegativeInteger
P
M [1:99999]
HANDLE_POSITION_REF
This element references a handle position.
HANDLE_POSITION_NO required Restriction of xs:nonNegativeInteger
This attribute references a handle position.
 D nonNegativeInteger
P
M [0:999]
OPTION_TEXT languagetexte60 Complex Type
This element is used for defining a text concerning a option.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element references a general comment which provides information about a option. It is only used for the purpose of user-friendliness and must not contain any order relevant information as this text information is not processed by the software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Fields named VALID_TO must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
• both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Elements named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element defines the minimum delivery time in weeks. This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.)
 D nonNegativeInteger
P
M [0:999]
FRONT_APPEARANCE_REF optional
This element defines a reference between feature and front appearance. A front appearance referenced here has to be defined in the element path1/FRONT_APPEARANCE.

This element may be used when feature "glass frame door" (FEATURE_NO = 154) is defined in path2/FEATURE_NO.

For data processing the following rules apply:
If an item is available with glass door, i.e. feature 154 is an element of the feature class of this item, the FRONT_APPEARANCE_NO of this element is used. If the item has no glass door path3/FRONT_APPEARANCE_REF is used.

This element has to be filled in from filling level 2b on.

Element paths:
path1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
path2 = FEATURE_DEFINITION/FEATURES/FEATURE
path3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITE
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID for a front appearance which is referenced by styles and items.
 D positiveInteger
P
M [1:999]
DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This element references hyperlinks to detail information.
 D positiveInteger
P
M [1:999999999]
Source
<xs:element name="OPTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:choice minOccurs="0">
              <xs:element name="STYLE_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="STYLE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="MATERIAL_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="MATERIAL_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="HANDLE_ORIENTATION_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="FORM_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="FORM_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="OPTION_MEASURE_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="OPTION_MEASURE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="HANDLE_POSITION_REF">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="HANDLE_POSITION_NO" use="required">
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                        <xs:totalDigits value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:choice>
            <xs:element name="OPTION_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element : OPTION Element
Description
This element defines the features of a feature class. All features of the complete database are defined in this element. In case of a finish option (cf. table standard variations, flag "A") neither texture (TEXTUR)nor colour values (COLOR) are permitted. The assignment of brightness and transparency is optional. In case they are defined they have priority over the colour variations.
Namespace (none)
Diagram
DETAIL_INFOS Element FRONT_APPEARANCE_REF Element MINIMUM_DELIVERY_TIME Element VALID_UNTIL Element VALID_FROM Element LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element LANGUAGE Element Sequence OPTION_TEXT Element HANDLE_POSITION_REF Element OPTION_MEASURE_REF Element FORM_REF Element HANDLE_ORIENTATION_REF Element MATERIAL_REF Element STYLE_REF Element Choice Sequence OPTION Element
Overview
OPTION 1..∞
This element defines the features of a feature class. All features of the complete database are defined in this element. In case of a finish option (cf. table standard variations, flag "A") neither texture (TEXTUR)nor colour values (COLOR) are permitted. The assignment of brightness and transparency is optional. In case they are defined they have priority over the colour variations.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required. D string
P
M [1:5]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute defines a sort order for the features. This attribute does not have to be used continuously. The sort order criterion may be be applied to all features. D nonNegativeInteger
P
M
Sequence
Choice optional
STYLE_REF
This element is used to reference a range.
STYLE_NO required Restriction of xs:string
This attribute defines the referenced programme. The attribute STYLE_NO refences to the element STYLE (path 1).

Path1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
MATERIAL_REF
This element references a material.
MATERIAL_NO required Restriction of xs:string
This attribute references a material. D string
P
M [1:5]
HANDLE_ORIENTATION_REF
This element references a handle orientation.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute defines a handle option.
 D positiveInteger
P
M [1:9999]
FORM_REF
This element references a shape.
FORM_NO required Restriction of xs:string
This attribute references a basic profile shape.
 D string
P
M [1:5]
OPTION_MEASURE_REF
This element references special dimensions of a feature class. Currently this element can only be used to indicate the different plinth heights (feature 402).
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies the referenced dimension option
 D nonNegativeInteger
P
M [1:99999]
HANDLE_POSITION_REF
This element references a handle position.
HANDLE_POSITION_NO required Restriction of xs:nonNegativeInteger
This attribute references a handle position.
 D nonNegativeInteger
P
M [0:999]
OPTION_TEXT languagetexte60 Complex Type
This element is used for defining a text concerning a option.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element references a general comment which provides information about a option. It is only used for the purpose of user-friendliness and must not contain any order relevant information as this text information is not processed by the software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Fields named VALID_TO must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
• both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Elements named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element defines the minimum delivery time in weeks. This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.)
 D nonNegativeInteger
P
M [0:999]
FRONT_APPEARANCE_REF optional
This element defines a reference between feature and front appearance. A front appearance referenced here has to be defined in the element path1/FRONT_APPEARANCE.

This element may be used when feature "glass frame door" (FEATURE_NO = 154) is defined in path2/FEATURE_NO.

For data processing the following rules apply:
If an item is available with glass door, i.e. feature 154 is an element of the feature class of this item, the FRONT_APPEARANCE_NO of this element is used. If the item has no glass door path3/FRONT_APPEARANCE_REF is used.

This element has to be filled in from filling level 2b on.

Element paths:
path1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
path2 = FEATURE_DEFINITION/FEATURES/FEATURE
path3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITE
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID for a front appearance which is referenced by styles and items.
 D positiveInteger
P
M [1:999]
DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This element references hyperlinks to detail information.
 D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required. D string
P
M [1:5]
SEQUENCE_NO Restriction of xs:nonNegativeInteger optional
This attribute defines a sort order for the features. This attribute does not have to be used continuously. The sort order criterion may be be applied to all features. D nonNegativeInteger
P
M
Source
<xs:element name="OPTION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:choice minOccurs="0">
        <xs:element name="STYLE_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="STYLE_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="5" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="MATERIAL_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="MATERIAL_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="5" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="HANDLE_ORIENTATION_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="FORM_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="FORM_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="5" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="OPTION_MEASURE_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="OPTION_MEASURE_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="HANDLE_POSITION_REF">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="HANDLE_POSITION_NO" use="required">
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                  <xs:totalDigits value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:choice>
      <xs:element name="OPTION_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STYLE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : STYLE_REF Element
Description
This element is used to reference a range.
Namespace (none)
Diagram
STYLE_REF Element
Overview
STYLE_REF
This element is used to reference a range.
STYLE_NO required Restriction of xs:string
This attribute defines the referenced programme. The attribute STYLE_NO refences to the element STYLE (path 1).

Path1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
STYLE_NO Restriction of xs:string required
This attribute defines the referenced programme. The attribute STYLE_NO refences to the element STYLE (path 1).

Path1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Source
<xs:element name="STYLE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="STYLE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MATERIAL_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : MATERIAL_REF Element
Description
This element references a material.
Namespace (none)
Diagram
MATERIAL_REF Element
Overview
MATERIAL_REF
This element references a material.
MATERIAL_NO required Restriction of xs:string
This attribute references a material. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
MATERIAL_NO Restriction of xs:string required
This attribute references a material. D string
P
M [1:5]
Source
<xs:element name="MATERIAL_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MATERIAL_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_ORIENTATION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : HANDLE_ORIENTATION_REF Element
Description
This element references a handle orientation.
Namespace (none)
Diagram
HANDLE_ORIENTATION_REF Element
Overview
HANDLE_ORIENTATION_REF
This element references a handle orientation.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute defines a handle option.
 D positiveInteger
P
M [1:9999]
Attributes
Name Type Use Default Fixed Description
HANDLE_ORIENTATION_NO Restriction of xs:positiveInteger required
This attribute defines a handle option.
 D positiveInteger
P
M [1:9999]
Source
<xs:element name="HANDLE_ORIENTATION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FORM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : FORM_REF Element
Description
This element references a shape.
Namespace (none)
Diagram
FORM_REF Element
Overview
FORM_REF
This element references a shape.
FORM_NO required Restriction of xs:string
This attribute references a basic profile shape.
 D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FORM_NO Restriction of xs:string required
This attribute references a basic profile shape.
 D string
P
M [1:5]
Source
<xs:element name="FORM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FORM_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_MEASURE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_MEASURE_REF Element
Description
This element references special dimensions of a feature class. Currently this element can only be used to indicate the different plinth heights (feature 402).
Namespace (none)
Diagram
OPTION_MEASURE_REF Element
Overview
OPTION_MEASURE_REF
This element references special dimensions of a feature class. Currently this element can only be used to indicate the different plinth heights (feature 402).
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies the referenced dimension option
 D nonNegativeInteger
P
M [1:99999]
Attributes
Name Type Use Default Fixed Description
OPTION_MEASURE_NO Restriction of xs:nonNegativeInteger required
This attribute identifies the referenced dimension option
 D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="OPTION_MEASURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_MEASURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_POSITION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : HANDLE_POSITION_REF Element
Description
This element references a handle position.
Namespace (none)
Diagram
HANDLE_POSITION_REF Element
Overview
HANDLE_POSITION_REF
This element references a handle position.
HANDLE_POSITION_NO required Restriction of xs:nonNegativeInteger
This attribute references a handle position.
 D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
HANDLE_POSITION_NO Restriction of xs:nonNegativeInteger required
This attribute references a handle position.
 D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="HANDLE_POSITION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="HANDLE_POSITION_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
          <xs:totalDigits value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_TEXT Element
Description
This element is used for defining a text concerning a option.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence OPTION_TEXT Element
Overview
OPTION_TEXT languagetexte60 Complex Type
This element is used for defining a text concerning a option.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="OPTION_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_COMMENT_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_COMMENT_TEXT Element
Description
This element references a general comment which provides information about a option. It is only used for the purpose of user-friendliness and must not contain any order relevant information as this text information is not processed by the software.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element
Overview
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element references a general comment which provides information about a option. It is only used for the purpose of user-friendliness and must not contain any order relevant information as this text information is not processed by the software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_FROM Element
Description
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Fields named VALID_TO must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Fields named VALID_TO must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
Source
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_UNTIL Element
Description
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
• both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Elements named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
• both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Elements named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
Source
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MINIMUM_DELIVERY_TIME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : MINIMUM_DELIVERY_TIME Element
Description
This element defines the minimum delivery time in weeks. This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.)
 D nonNegativeInteger
P
M [0:999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MINIMUM_DELIVERY_TIME Element
Overview
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
This element defines the minimum delivery time in weeks. This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.)
 D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_APPEARANCE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : FRONT_APPEARANCE_REF Element
Description
This element defines a reference between feature and front appearance. A front appearance referenced here has to be defined in the element path1/FRONT_APPEARANCE.

This element may be used when feature "glass frame door" (FEATURE_NO = 154) is defined in path2/FEATURE_NO.

For data processing the following rules apply:
If an item is available with glass door, i.e. feature 154 is an element of the feature class of this item, the FRONT_APPEARANCE_NO of this element is used. If the item has no glass door path3/FRONT_APPEARANCE_REF is used.

This element has to be filled in from filling level 2b on.

Element paths:
path1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
path2 = FEATURE_DEFINITION/FEATURES/FEATURE
path3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITE
Namespace (none)
Diagram
FRONT_APPEARANCE_REF Element
Overview
FRONT_APPEARANCE_REF optional
This element defines a reference between feature and front appearance. A front appearance referenced here has to be defined in the element path1/FRONT_APPEARANCE.

This element may be used when feature "glass frame door" (FEATURE_NO = 154) is defined in path2/FEATURE_NO.

For data processing the following rules apply:
If an item is available with glass door, i.e. feature 154 is an element of the feature class of this item, the FRONT_APPEARANCE_NO of this element is used. If the item has no glass door path3/FRONT_APPEARANCE_REF is used.

This element has to be filled in from filling level 2b on.

Element paths:
path1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
path2 = FEATURE_DEFINITION/FEATURES/FEATURE
path3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITE
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID for a front appearance which is referenced by styles and items.
 D positiveInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
FRONT_APPEARANCE_NO Restriction of xs:positiveInteger required
This attribute defines a specific ID for a front appearance which is referenced by styles and items.
 D positiveInteger
P
M [1:999]
Source
<xs:element name="FRONT_APPEARANCE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : DETAIL_INFOS Element
Description
This element summarizes all hyperlinks providing detail information for an item.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
This element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This element references hyperlinks to detail information.
 D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description
This element references hyperlinks to detail information.
Namespace (none)
Diagram
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
This element references hyperlinks to detail information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This element references hyperlinks to detail information.
 D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This element references hyperlinks to detail information.
 D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : FEATURE_TEXT Element
Description
This element contains text information for the different features.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence FEATURE_TEXT Element
Overview
FEATURE_TEXT languagetexte60 Complex Type
This element contains text information for the different features.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="FEATURE_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SEQUENCE_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : SEQUENCE_NO Element
Description
This element defines a manufacturer specific classification for the feature types.
This classification is a recommendation of the manufacturer, the retailers may use different classifications. The classification is used for a better legibility and display of data on the screen or in print-outs.
In case a classification is defined here, this has to unambiguous and it has to be applied to all data sets.
The field classification must not be filled in if invisible header features (HEADER_POS_VARIATION_TYPE = U (path1)), are used

Element paths
path1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
SEQUENCE_NO Element
Overview
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element defines a manufacturer specific classification for the feature types.
This classification is a recommendation of the manufacturer, the retailers may use different classifications. The classification is used for a better legibility and display of data on the screen or in print-outs.
In case a classification is defined here, this has to unambiguous and it has to be applied to all data sets.
The field classification must not be filled in if invisible header features (HEADER_POS_VARIATION_TYPE = U (path1)), are used

Element paths
path1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="SEQUENCE_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--4--Sortierung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEADER_POS_VARIATION_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : HEADER_POS_VARIATION_TYPE Element
Description
This element is used for distinguishing the different feature types
I = implicit variation,
K = header variation,
U = invisible header variation,
P = position variation type or
V = inheriting variation type.

These different types are used to control the software processing of variation types; Variation types marked with "P" may only occur on position level but not in the header.
Invisible header variations may only be used in the elements OPTION (path 1) and COMBINED_FEATURE (path 2).

For variation types that inherit information from another variation type the flag "V" is used. The process of inheritance is only applied within the same item, therefore this flag may only be used for variation types 202, 203, 205 and 208. If the flag "V" is set, the
element INHERIT_VARIATION_TYPE_REF (path 3) requires an entry. Legal entries to be used here are 202, 203, 205 or 208, marked with the flag "K" or "P" in the element HEADER_POS_VARIATION_TYPE (path 3).
Inheriting variation types must not be used in any other record type.
Variations marked with "I" are invisible variations which are used for control procedures. Currently the mark "I" is only used for variation type 305 = drilling pattern.

Element paths
path 1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
path 2: FEATURE_DEFINITION/FEATURES
path 3: FEATURE_DEFINITION/FEATURES/FEATURE 		D nonNegativeInteger
P
M [0:999]
Namespace (none)
Type
Restriction of xs:string
Diagram
HEADER_POS_VARIATION_TYPE Element
Overview
HEADER_POS_VARIATION_TYPE Restriction of xs:string
This element is used for distinguishing the different feature types
I = implicit variation,
K = header variation,
U = invisible header variation,
P = position variation type or
V = inheriting variation type.

These different types are used to control the software processing of variation types; Variation types marked with "P" may only occur on position level but not in the header.
Invisible header variations may only be used in the elements OPTION (path 1) and COMBINED_FEATURE (path 2).

For variation types that inherit information from another variation type the flag "V" is used. The process of inheritance is only applied within the same item, therefore this flag may only be used for variation types 202, 203, 205 and 208. If the flag "V" is set, the
element INHERIT_VARIATION_TYPE_REF (path 3) requires an entry. Legal entries to be used here are 202, 203, 205 or 208, marked with the flag "K" or "P" in the element HEADER_POS_VARIATION_TYPE (path 3).
Inheriting variation types must not be used in any other record type.
Variations marked with "I" are invisible variations which are used for control procedures. Currently the mark "I" is only used for variation type 305 = drilling pattern.

Element paths
path 1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
path 2: FEATURE_DEFINITION/FEATURES
path 3: FEATURE_DEFINITION/FEATURES/FEATURE 		D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="HEADER_POS_VARIATION_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[IKUPV]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

INHERIT_VARIATION_TYPE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : INHERIT_VARIATION_TYPE_REF Element
Description
This element references the feature type from which information is inherited.
Feature types 202, 203, 205 and 208 may inherit information among each other.
Feature types used here must not contain the flag „invisible“
Namespace (none)
Diagram
INHERIT_VARIATION_TYPE_REF Element
Overview
INHERIT_VARIATION_TYPE_REF optional
This element references the feature type from which information is inherited.
Feature types 202, 203, 205 and 208 may inherit information among each other.
Feature types used here must not contain the flag „invisible“
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the referenced feature. D nonNegativeInteger
P (202)|(203)|(205)|(208)
M [0:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute defines the referenced feature. D nonNegativeInteger
P (202)|(203)|(205)|(208)
M [0:999]
Source
<xs:element name="INHERIT_VARIATION_TYPE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>250--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="(202)|(203)|(205)|(208)" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_DEFINITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : OPTION_DEFINITION Element
Description
This element is used for defining the different variations of colours, materials, handles, shapes,and programmes.
Namespace (none)
Diagram
OPTION_MEASURE Element FORM Element MATERIAL Element HANDLE_ORIENTATION Element STYLE Element Sequence OPTION_DEFINITION Element
Overview
OPTION_DEFINITION
This element is used for defining the different variations of colours, materials, handles, shapes,and programmes.
Sequence
STYLE 0..∞
This element is used for the definition of programmes/ styles in a catalogue.
Styles are created as features in the element STYLE_REF (path1). A style is defined by feature type 1 (FEATURE_NO = 1).

The attributes of a style must not vary within one series. As a style is only defined in this element and referenced by the series, the aforementioned condition is represented by the structure.

This element is an optional one, if the element SUPPLIER/BRANCH_ID contains the values "G" or "Z".

P1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
P2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
P3: FEATURE_DEFINITION/FEATURES
STYLE_NO required Restriction of xs:string
This attribute defines a manufacturer specific key for a style. It is referenced by the attribute STYLE_NO in the element STYLE (path1).

P1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Sequence
FRONT_DEPTH optional Restriction of xs:nonNegativeInteger
This element defines the specific depth of a style in [mm]. The default value is 20 mm..
Values in this field are required when the element FRONT_APEREANCE_NO (path1) is filled in.

path1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/ 		D nonNegativeInteger
P
M [1:99]
FRONT_DISTANCE optional Restriction of xs:nonNegativeInteger
This element is used to define the range-specific door buffer [mm]. It represents the distance between the door and the carcase behind it. D nonNegativeInteger
P
M [1:99]
FRONT_APPEARANCE_REF optional
This element assigns a front appearance to a style. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID for a front appearance which is referenced by styles and items. D positiveInteger
P
M [1:999]
FRONT_GROUP_REF optional
This element is used for assigning a front group to a style.
Several styles which have the same front appearance can be grouped in one front group.
This element references the attribute SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_GROUP_NO.
For manufacturer catalogues in which the front divisions of the cabinets depend on the different styles a definition of front groups is required.
In some manufacturer catalogues the front divisions of cabinets do not vary in the different styles. In these cases no front group definition is required.
In many cases all traditional style fronts can be grouped into one front group. This is due to the fact that the front divisions of tall cabinet front doors have a similar pattern in traditional styles.
This rule is not applied to cabinets which have different front divisions depending on the varying sizes of appliances.
In case a front group has been defined for one style, front groups have to be assigned to all styles.
FRONT_GROUP_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database. D positiveInteger
P
M [1:99]
FEATURE_CLASS_REF optional
This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D nonNegativeInteger
P
M [1:999]
DEFAULT_OPTION_GROUP_REF 0..∞
This element assigns default options to a style.
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a default option. D nonNegativeInteger
P
M [1:999999999]
RESTRICTIONS optional
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.
Sequence
RESTRICTION_REF 1..∞
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations. 		D nonNegativeInteger
P
M [1:99999]
SEQUENCE required Restriction of xs:positiveInteger
This element defines the sequence in which the different test procedures are performed. Several restriction can be grouped (set union), if the value filled in in the element SEQUENCE is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...) 		D positiveInteger
P
M [1:99999]
HANDLE_ORIENTATION 0..∞
This element defines a handle orientation.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute identifies a handle option. D string
P
M [1:5]
Sequence
DEFAULT_HANDLE_ORIENTATION_REF optional

This element defines a variation of the basic handle position. It references a basic handle position defined in the element BASIC_HANDLE_POSITIONS (path 1).

The manufacturer specific name for this position is defined in the element OPTION_KEY (path 2).

The element default handle position has to be filled in if variation type 304 (handle position) is set in the element FEATURE (path 3).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS

path 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
path 3: FEATURE_DEFINITION/FEATURES

SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
This attribute defines a standard handle position. D nonNegativeInteger
P
M [1:99999]
MATERIAL 0..∞
This element defines a material.

In case of a finish option, (cf. table Standard variation types flag "A"), neither texture (TEXTURE) nor colour (COLOR) values are permitted.

Finish options are defined in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION.
MATERIAL_NO required Restriction of xs:string
This attribute identifies a material. D string
P
M [1:5]
Sequence
Choice optional
COLOR
This element defines colours.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
TEXTURE
This element defines information about the textures.
Sequence
FILE_NAME_TEXTURE Restriction of xs:string
This element defines references to material textures. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]
TEXTURE_REPEAT optional
This element defines if a texture is applied to a material only one time or repeatedly. If a texture repeat is required, this element is defined and the settings are applied to all child elements, too.
According to the basic texture size (DPI, number of pixels) the repeat factor is calculated automatically by the software programme.
If the element FILENAME_TEXTURE is filled in, this element is required, too.
TEXTURE_TILE optional Restriction of xs:int
This attribute defines if a texture is applied to a material only one time (0 = no repeat) or several times (1 = repeat). D integer
P
M [0:1]
Sequence
REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger
This element defines the dimensions of the texture in X direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger
This element defines the dimensions of the texture in Y direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
MASKING optional Restriction of xs:boolean
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
If the element FILENAME_TEXTURE is filled in, this element is required, too. 		D boolean
P
M
TEXTURE_DELIVERED_ORIENTATION Restriction of xs:string
This attribute identifies a default handle position. D string
P |[HV]
M [0:1]
TRANSPARENCY optional Restriction of xs:nonNegativeInteger
This element defines the degree of transparency for a material RGB value or texture).
0 = opaque
9 = max. transparency
If this element is a colour variation settings in this field are required. 		D nonNegativeInteger
P
M [0:9]
BRIGHTNESS optional Restriction of xs:nonNegativeInteger
This element defines the degree of brightness for a material (RGB value or texture).
0 = opaque
8 = high gloss
9 = reflection
If this element is a colour variation settings in this field are required. 		D nonNegativeInteger
P
M [0:9]
FORM 0..∞
This element is used to define a variation of a shape.
FORM_NO required Restriction of xs:string
This attribute identifies the shape of a profile. D string
P
M [1:5]
Sequence
PROFILE_KEY Restriction of xs:string
This element defines the manufacturer specific key for a profile shape. This element is used for building the variation types 750-756. Only these variation types 750-756 can use the element FORM. The different variations are referenced by the item (ITEM) which represents the profile. D string
P
M [1:5]
OPTION_MEASURE 0..∞
This element defines measurement information for different features, e.g. plinth height (feature type 402).
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies the dimensions of an appearance. D nonNegativeInteger
P
M [1:99999]
Sequence
PLINTH_HEIGHT Restriction of xs:nonNegativeInteger
This element defines the plinth height in mm. D nonNegativeInteger
P
M [0:999999999]
STANDARD_PLINTH optional xs:boolean

This element is used to specify whether the relevant plinth height is a standard value or if it is different from the standard. If the value is set to false(0), the plinth height is different from the standard height and may incur an additional price for the plinth feet.

A missing element corresponds to the value true(1).

This element must be specified if there are linked articles with allocation type CLASS = 21.

D boolean
P
M [0:1]
Remarks

Source
<xs:element name="OPTION_DEFINITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="STYLE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>210--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_DEPTH" minOccurs="0">
              <xs:annotation>
                <xs:documentation>210--6--Front_Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FRONT_DISTANCE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>210--6--Türpuffer</xs:documentation>
                <xs:documentation>K.Richter/13.06.2018</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONT_GROUP_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>210--12--Frontgruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FRONT_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>210--12--Frontgruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_CLASS_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>210--13--Var_Familien_Nr</xs:documentation>
                    <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DEFAULT_OPTION_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>295--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>295--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                <xs:documentation>von minOcc 1 auf optional 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      <xs:documentation>von optional  auf  minOcc 1 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="STYLE_NO" use="required">
            <xs:annotation>
              <xs:documentation>210--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="HANDLE_ORIENTATION" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DEFAULT_HANDLE_ORIENTATION_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:choice minOccurs="0">
              <xs:annotation>
                <xs:documentation />
                <xs:documentation>AK 28.02.2012. Optional gesetzt um die alte 1.7 Logik zu erhalten.</xs:documentation>
              </xs:annotation>
              <xs:element name="COLOR">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="RGB_RED">
                      <xs:annotation>
                        <xs:documentation>260--11--RGB_Rot</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="255" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="RGB_GREEN">
                      <xs:annotation>
                        <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="255" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="RGB_BLUE">
                      <xs:annotation>
                        <xs:documentation>260--13--RGB_Blau</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="255" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
              <xs:element name="TEXTURE">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="FILE_NAME_TEXTURE">
                      <xs:annotation>
                        <xs:documentation>260--6--Dateiname_Textur</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="TEXTURE_REPEAT" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>260--9--Textur_Kachelung</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="REAL_MEASUREMENT_X">
                            <xs:annotation>
                              <xs:documentation>260--17--Realmass_X</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="REAL_MEASUREMENT_Y">
                            <xs:annotation>
                              <xs:documentation>260--18--Realmass_Y</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="TEXTURE_TILE">
                          <xs:simpleType>
                            <xs:restriction base="xs:int">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="1" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MASKING" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>260--10--Maskierung</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:boolean" />
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="TEXTURE_DELIVERED_ORIENTATION">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:pattern value="|[HV]" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:choice>
            <xs:element name="TRANSPARENCY" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--14--Transparenz</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BRIGHTNESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--15--Glanz</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="MATERIAL_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FORM" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PROFILE_KEY">
              <xs:annotation>
                <xs:documentation>430--4/5--Varianten_Art_Profilform/Var_Schluessel_</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="5" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FORM_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PLINTH_HEIGHT">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="STANDARD_PLINTH" type="xs:boolean" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Kennzeichnung zur Abweichung von Standardsockelhöhe</xs:documentation>
                <xs:documentation>hinzugefügt K.Richter, 29.02.2016</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPTION_MEASURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STYLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : STYLE Element
Description
This element is used for the definition of programmes/ styles in a catalogue.
Styles are created as features in the element STYLE_REF (path1). A style is defined by feature type 1 (FEATURE_NO = 1).

The attributes of a style must not vary within one series. As a style is only defined in this element and referenced by the series, the aforementioned condition is represented by the structure.

This element is an optional one, if the element SUPPLIER/BRANCH_ID contains the values "G" or "Z".

P1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
P2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
P3: FEATURE_DEFINITION/FEATURES
Namespace (none)
Diagram
RESTRICTIONS Element DEFAULT_OPTION_GROUP_REF Element FEATURE_CLASS_REF Element FRONT_GROUP_REF Element FRONT_APPEARANCE_REF Element FRONT_DISTANCE Element FRONT_DEPTH Element Sequence STYLE Element
Overview
STYLE 0..∞
This element is used for the definition of programmes/ styles in a catalogue.
Styles are created as features in the element STYLE_REF (path1). A style is defined by feature type 1 (FEATURE_NO = 1).

The attributes of a style must not vary within one series. As a style is only defined in this element and referenced by the series, the aforementioned condition is represented by the structure.

This element is an optional one, if the element SUPPLIER/BRANCH_ID contains the values "G" or "Z".

P1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
P2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
P3: FEATURE_DEFINITION/FEATURES
STYLE_NO required Restriction of xs:string
This attribute defines a manufacturer specific key for a style. It is referenced by the attribute STYLE_NO in the element STYLE (path1).

P1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Sequence
FRONT_DEPTH optional Restriction of xs:nonNegativeInteger
This element defines the specific depth of a style in [mm]. The default value is 20 mm..
Values in this field are required when the element FRONT_APEREANCE_NO (path1) is filled in.

path1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/ 		D nonNegativeInteger
P
M [1:99]
FRONT_DISTANCE optional Restriction of xs:nonNegativeInteger
This element is used to define the range-specific door buffer [mm]. It represents the distance between the door and the carcase behind it. D nonNegativeInteger
P
M [1:99]
FRONT_APPEARANCE_REF optional
This element assigns a front appearance to a style. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID for a front appearance which is referenced by styles and items. D positiveInteger
P
M [1:999]
FRONT_GROUP_REF optional
This element is used for assigning a front group to a style.
Several styles which have the same front appearance can be grouped in one front group.
This element references the attribute SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_GROUP_NO.
For manufacturer catalogues in which the front divisions of the cabinets depend on the different styles a definition of front groups is required.
In some manufacturer catalogues the front divisions of cabinets do not vary in the different styles. In these cases no front group definition is required.
In many cases all traditional style fronts can be grouped into one front group. This is due to the fact that the front divisions of tall cabinet front doors have a similar pattern in traditional styles.
This rule is not applied to cabinets which have different front divisions depending on the varying sizes of appliances.
In case a front group has been defined for one style, front groups have to be assigned to all styles.
FRONT_GROUP_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database. D positiveInteger
P
M [1:99]
FEATURE_CLASS_REF optional
This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D nonNegativeInteger
P
M [1:999]
DEFAULT_OPTION_GROUP_REF 0..∞
This element assigns default options to a style.
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a default option. D nonNegativeInteger
P
M [1:999999999]
RESTRICTIONS optional
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.
Sequence
RESTRICTION_REF 1..∞
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations. 		D nonNegativeInteger
P
M [1:99999]
SEQUENCE required Restriction of xs:positiveInteger
This element defines the sequence in which the different test procedures are performed. Several restriction can be grouped (set union), if the value filled in in the element SEQUENCE is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...) 		D positiveInteger
P
M [1:99999]
Attributes
Name Type Use Default Fixed Description
STYLE_NO Restriction of xs:string required
This attribute defines a manufacturer specific key for a style. It is referenced by the attribute STYLE_NO in the element STYLE (path1).

P1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Source
<xs:element name="STYLE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>210--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_DEPTH" minOccurs="0">
        <xs:annotation>
          <xs:documentation>210--6--Front_Tiefe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FRONT_DISTANCE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>210--6--Türpuffer</xs:documentation>
          <xs:documentation>K.Richter/13.06.2018</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONT_GROUP_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>210--12--Frontgruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FRONT_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>210--12--Frontgruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_CLASS_NO" use="required">
            <xs:annotation>
              <xs:documentation>210--13--Var_Familien_Nr</xs:documentation>
              <xs:documentation>K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DEFAULT_OPTION_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>295--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>295--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
          <xs:documentation>von minOcc 1 auf optional 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>von optional  auf  minOcc 1 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="STYLE_NO" use="required">
      <xs:annotation>
        <xs:documentation>210--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_DEPTH Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : FRONT_DEPTH Element
Description
This element defines the specific depth of a style in [mm]. The default value is 20 mm..
Values in this field are required when the element FRONT_APEREANCE_NO (path1) is filled in.

path1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/ 		D nonNegativeInteger
P
M [1:99]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
FRONT_DEPTH Element
Overview
FRONT_DEPTH optional Restriction of xs:nonNegativeInteger
This element defines the specific depth of a style in [mm]. The default value is 20 mm..
Values in this field are required when the element FRONT_APEREANCE_NO (path1) is filled in.

path1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/ 		D nonNegativeInteger
P
M [1:99]
Source
<xs:element name="FRONT_DEPTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>210--6--Front_Tiefe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_DISTANCE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : FRONT_DISTANCE Element
Description
This element is used to define the range-specific door buffer [mm]. It represents the distance between the door and the carcase behind it. D nonNegativeInteger
P
M [1:99]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
FRONT_DISTANCE Element
Overview
FRONT_DISTANCE optional Restriction of xs:nonNegativeInteger
This element is used to define the range-specific door buffer [mm]. It represents the distance between the door and the carcase behind it. D nonNegativeInteger
P
M [1:99]
Source
<xs:element name="FRONT_DISTANCE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>210--6--Türpuffer</xs:documentation>
    <xs:documentation>K.Richter/13.06.2018</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_APPEARANCE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : FRONT_APPEARANCE_REF Element
Description
This element assigns a front appearance to a style. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Namespace (none)
Diagram
FRONT_APPEARANCE_REF Element
Overview
FRONT_APPEARANCE_REF optional
This element assigns a front appearance to a style. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID for a front appearance which is referenced by styles and items. D positiveInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
FRONT_APPEARANCE_NO Restriction of xs:positiveInteger required
This attribute defines a specific ID for a front appearance which is referenced by styles and items. D positiveInteger
P
M [1:999]
Source
<xs:element name="FRONT_APPEARANCE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : FRONT_GROUP_REF Element
Description
This element is used for assigning a front group to a style.
Several styles which have the same front appearance can be grouped in one front group.
This element references the attribute SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_GROUP_NO.
For manufacturer catalogues in which the front divisions of the cabinets depend on the different styles a definition of front groups is required.
In some manufacturer catalogues the front divisions of cabinets do not vary in the different styles. In these cases no front group definition is required.
In many cases all traditional style fronts can be grouped into one front group. This is due to the fact that the front divisions of tall cabinet front doors have a similar pattern in traditional styles.
This rule is not applied to cabinets which have different front divisions depending on the varying sizes of appliances.
In case a front group has been defined for one style, front groups have to be assigned to all styles.
Namespace (none)
Diagram
FRONT_GROUP_REF Element
Overview
FRONT_GROUP_REF optional
This element is used for assigning a front group to a style.
Several styles which have the same front appearance can be grouped in one front group.
This element references the attribute SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_GROUP_NO.
For manufacturer catalogues in which the front divisions of the cabinets depend on the different styles a definition of front groups is required.
In some manufacturer catalogues the front divisions of cabinets do not vary in the different styles. In these cases no front group definition is required.
In many cases all traditional style fronts can be grouped into one front group. This is due to the fact that the front divisions of tall cabinet front doors have a similar pattern in traditional styles.
This rule is not applied to cabinets which have different front divisions depending on the varying sizes of appliances.
In case a front group has been defined for one style, front groups have to be assigned to all styles.
FRONT_GROUP_NO required Restriction of xs:positiveInteger
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database. D positiveInteger
P
M [1:99]
Attributes
Name Type Use Default Fixed Description
FRONT_GROUP_NO Restriction of xs:positiveInteger required
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database. D positiveInteger
P
M [1:99]
Source
<xs:element name="FRONT_GROUP_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>210--12--Frontgruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FRONT_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>210--12--Frontgruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_CLASS_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : FEATURE_CLASS_REF Element
Description
This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES.
Namespace (none)
Diagram
FEATURE_CLASS_REF Element
Overview
FEATURE_CLASS_REF optional
This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D nonNegativeInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_CLASS_NO Restriction of xs:positiveInteger required
This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D nonNegativeInteger
P
M [1:999]
Source
<xs:element name="FEATURE_CLASS_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_CLASS_NO" use="required">
      <xs:annotation>
        <xs:documentation>210--13--Var_Familien_Nr</xs:documentation>
        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEFAULT_OPTION_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : DEFAULT_OPTION_GROUP_REF Element
Description
This element assigns default options to a style.
Namespace (none)
Diagram
DEFAULT_OPTION_GROUP_REF Element
Overview
DEFAULT_OPTION_GROUP_REF 0..∞
This element assigns default options to a style.
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
This attribute references a default option. D nonNegativeInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
DEFAULT_OPTION_GROUP_NO Restriction of xs:positiveInteger required
This attribute references a default option. D nonNegativeInteger
P
M [1:999999999]
Source
<xs:element name="DEFAULT_OPTION_GROUP_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>295--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>295--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : RESTRICTIONS Element
Description
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.
Namespace (none)
Diagram
RESTRICTION_REF Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.
Sequence
RESTRICTION_REF 1..∞
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations. 		D nonNegativeInteger
P
M [1:99999]
SEQUENCE required Restriction of xs:positiveInteger
This element defines the sequence in which the different test procedures are performed. Several restriction can be grouped (set union), if the value filled in in the element SEQUENCE is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...) 		D positiveInteger
P
M [1:99999]
Source
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
    <xs:documentation>von minOcc 1 auf optional 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>von optional  auf  minOcc 1 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element > RESTRICTIONS Element : RESTRICTION_REF Element
Description
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.
Namespace (none)
Diagram
RESTRICTION_REF Element
Overview
RESTRICTION_REF 1..∞
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations. 		D nonNegativeInteger
P
M [1:99999]
SEQUENCE required Restriction of xs:positiveInteger
This element defines the sequence in which the different test procedures are performed. Several restriction can be grouped (set union), if the value filled in in the element SEQUENCE is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...) 		D positiveInteger
P
M [1:99999]
Attributes
Name Type Use Default Fixed Description
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations. 		D nonNegativeInteger
P
M [1:99999]
SEQUENCE Restriction of xs:positiveInteger required
This element defines the sequence in which the different test procedures are performed. Several restriction can be grouped (set union), if the value filled in in the element SEQUENCE is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...) 		D positiveInteger
P
M [1:99999]
Source
<xs:element name="RESTRICTION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>von optional  auf  minOcc 1 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
RESTRICTIONS Element | STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_ORIENTATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : HANDLE_ORIENTATION Element
Description
This element defines a handle orientation.
Namespace (none)
Diagram
DEFAULT_HANDLE_ORIENTATION_REF Element Sequence HANDLE_ORIENTATION Element
Overview
HANDLE_ORIENTATION 0..∞
This element defines a handle orientation.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
This attribute identifies a handle option. D string
P
M [1:5]
Sequence
DEFAULT_HANDLE_ORIENTATION_REF optional

This element defines a variation of the basic handle position. It references a basic handle position defined in the element BASIC_HANDLE_POSITIONS (path 1).

The manufacturer specific name for this position is defined in the element OPTION_KEY (path 2).

The element default handle position has to be filled in if variation type 304 (handle position) is set in the element FEATURE (path 3).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS

path 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
path 3: FEATURE_DEFINITION/FEATURES

SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
This attribute defines a standard handle position. D nonNegativeInteger
P
M [1:99999]
Attributes
Name Type Use Default Fixed Description
HANDLE_ORIENTATION_NO Restriction of xs:positiveInteger required
This attribute identifies a handle option. D string
P
M [1:5]
Source
<xs:element name="HANDLE_ORIENTATION" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DEFAULT_HANDLE_ORIENTATION_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEFAULT_HANDLE_ORIENTATION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > HANDLE_ORIENTATION Element : DEFAULT_HANDLE_ORIENTATION_REF Element
Description

This element defines a variation of the basic handle position. It references a basic handle position defined in the element BASIC_HANDLE_POSITIONS (path 1).

The manufacturer specific name for this position is defined in the element OPTION_KEY (path 2).

The element default handle position has to be filled in if variation type 304 (handle position) is set in the element FEATURE (path 3).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS

path 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
path 3: FEATURE_DEFINITION/FEATURES

Namespace (none)
Diagram
DEFAULT_HANDLE_ORIENTATION_REF Element
Overview
DEFAULT_HANDLE_ORIENTATION_REF optional

This element defines a variation of the basic handle position. It references a basic handle position defined in the element BASIC_HANDLE_POSITIONS (path 1).

The manufacturer specific name for this position is defined in the element OPTION_KEY (path 2).

The element default handle position has to be filled in if variation type 304 (handle position) is set in the element FEATURE (path 3).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS

path 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
path 3: FEATURE_DEFINITION/FEATURES

SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
This attribute defines a standard handle position. D nonNegativeInteger
P
M [1:99999]
Attributes
Name Type Use Default Fixed Description
SPECIFIC_HANDLE_ORIENTATION_NO Restriction of xs:nonNegativeInteger required
This attribute defines a standard handle position. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="DEFAULT_HANDLE_ORIENTATION_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
HANDLE_ORIENTATION Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MATERIAL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : MATERIAL Element
Description
This element defines a material.

In case of a finish option, (cf. table Standard variation types flag "A"), neither texture (TEXTURE) nor colour (COLOR) values are permitted.

Finish options are defined in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION.
Namespace (none)
Diagram
BRIGHTNESS Element TRANSPARENCY Element TEXTURE Element COLOR Element Choice Sequence MATERIAL Element
Overview
MATERIAL 0..∞
This element defines a material.

In case of a finish option, (cf. table Standard variation types flag "A"), neither texture (TEXTURE) nor colour (COLOR) values are permitted.

Finish options are defined in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION.
MATERIAL_NO required Restriction of xs:string
This attribute identifies a material. D string
P
M [1:5]
Sequence
Choice optional
COLOR
This element defines colours.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
TEXTURE
This element defines information about the textures.
Sequence
FILE_NAME_TEXTURE Restriction of xs:string
This element defines references to material textures. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]
TEXTURE_REPEAT optional
This element defines if a texture is applied to a material only one time or repeatedly. If a texture repeat is required, this element is defined and the settings are applied to all child elements, too.
According to the basic texture size (DPI, number of pixels) the repeat factor is calculated automatically by the software programme.
If the element FILENAME_TEXTURE is filled in, this element is required, too.
TEXTURE_TILE optional Restriction of xs:int
This attribute defines if a texture is applied to a material only one time (0 = no repeat) or several times (1 = repeat). D integer
P
M [0:1]
Sequence
REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger
This element defines the dimensions of the texture in X direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger
This element defines the dimensions of the texture in Y direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
MASKING optional Restriction of xs:boolean
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
If the element FILENAME_TEXTURE is filled in, this element is required, too. 		D boolean
P
M
TEXTURE_DELIVERED_ORIENTATION Restriction of xs:string
This attribute identifies a default handle position. D string
P |[HV]
M [0:1]
TRANSPARENCY optional Restriction of xs:nonNegativeInteger
This element defines the degree of transparency for a material RGB value or texture).
0 = opaque
9 = max. transparency
If this element is a colour variation settings in this field are required. 		D nonNegativeInteger
P
M [0:9]
BRIGHTNESS optional Restriction of xs:nonNegativeInteger
This element defines the degree of brightness for a material (RGB value or texture).
0 = opaque
8 = high gloss
9 = reflection
If this element is a colour variation settings in this field are required. 		D nonNegativeInteger
P
M [0:9]
Attributes
Name Type Use Default Fixed Description
MATERIAL_NO Restriction of xs:string required
This attribute identifies a material. D string
P
M [1:5]
Source
<xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:choice minOccurs="0">
        <xs:annotation>
          <xs:documentation />
          <xs:documentation>AK 28.02.2012. Optional gesetzt um die alte 1.7 Logik zu erhalten.</xs:documentation>
        </xs:annotation>
        <xs:element name="COLOR">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="RGB_RED">
                <xs:annotation>
                  <xs:documentation>260--11--RGB_Rot</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="255" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="RGB_GREEN">
                <xs:annotation>
                  <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="255" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="RGB_BLUE">
                <xs:annotation>
                  <xs:documentation>260--13--RGB_Blau</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="255" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
        <xs:element name="TEXTURE">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="FILE_NAME_TEXTURE">
                <xs:annotation>
                  <xs:documentation>260--6--Dateiname_Textur</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="TEXTURE_REPEAT" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>260--9--Textur_Kachelung</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="REAL_MEASUREMENT_X">
                      <xs:annotation>
                        <xs:documentation>260--17--Realmass_X</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="9999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="REAL_MEASUREMENT_Y">
                      <xs:annotation>
                        <xs:documentation>260--18--Realmass_Y</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="9999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="TEXTURE_TILE">
                    <xs:simpleType>
                      <xs:restriction base="xs:int">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="1" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="MASKING" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>260--10--Maskierung</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:boolean" />
                </xs:simpleType>
              </xs:element>
              <xs:element name="TEXTURE_DELIVERED_ORIENTATION">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:pattern value="|[HV]" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
      </xs:choice>
      <xs:element name="TRANSPARENCY" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--14--Transparenz</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BRIGHTNESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--15--Glanz</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MATERIAL_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COLOR Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element : COLOR Element
Description
This element defines colours.
Namespace (none)
Diagram
RGB_BLUE Element RGB_GREEN Element RGB_RED Element Sequence COLOR Element
Overview
COLOR
This element defines colours.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
Source
<xs:element name="COLOR" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RGB_RED">
        <xs:annotation>
          <xs:documentation>260--11--RGB_Rot</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="255" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="RGB_GREEN">
        <xs:annotation>
          <xs:documentation>260--12--RGB_Gruen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="255" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="RGB_BLUE">
        <xs:annotation>
          <xs:documentation>260--13--RGB_Blau</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="255" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RGB_RED Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > COLOR Element : RGB_RED Element
Description
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
RGB_RED Element
Overview
RGB_RED Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
Source
<xs:element name="RGB_RED" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--11--RGB_Rot</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="255" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COLOR Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RGB_GREEN Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > COLOR Element : RGB_GREEN Element
Description
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
RGB_GREEN Element
Overview
RGB_GREEN Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
Source
<xs:element name="RGB_GREEN" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--12--RGB_Gruen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="255" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COLOR Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RGB_BLUE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > COLOR Element : RGB_BLUE Element
Description
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
RGB_BLUE Element
Overview
RGB_BLUE Restriction of xs:nonNegativeInteger
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined. 		D nonNegativeInteger
P
M [0:255]
Source
<xs:element name="RGB_BLUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--13--RGB_Blau</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="255" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COLOR Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXTURE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element : TEXTURE Element
Description
This element defines information about the textures.
Namespace (none)
Diagram
TEXTURE_DELIVERED_ORIENTATION Element MASKING Element TEXTURE_REPEAT Element FILE_NAME_TEXTURE Element Sequence TEXTURE Element
Overview
TEXTURE
This element defines information about the textures.
Sequence
FILE_NAME_TEXTURE Restriction of xs:string
This element defines references to material textures. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]
TEXTURE_REPEAT optional
This element defines if a texture is applied to a material only one time or repeatedly. If a texture repeat is required, this element is defined and the settings are applied to all child elements, too.
According to the basic texture size (DPI, number of pixels) the repeat factor is calculated automatically by the software programme.
If the element FILENAME_TEXTURE is filled in, this element is required, too.
TEXTURE_TILE optional Restriction of xs:int
This attribute defines if a texture is applied to a material only one time (0 = no repeat) or several times (1 = repeat). D integer
P
M [0:1]
Sequence
REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger
This element defines the dimensions of the texture in X direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger
This element defines the dimensions of the texture in Y direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
MASKING optional Restriction of xs:boolean
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
If the element FILENAME_TEXTURE is filled in, this element is required, too. 		D boolean
P
M
TEXTURE_DELIVERED_ORIENTATION Restriction of xs:string
This attribute identifies a default handle position. D string
P |[HV]
M [0:1]
Source
<xs:element name="TEXTURE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FILE_NAME_TEXTURE">
        <xs:annotation>
          <xs:documentation>260--6--Dateiname_Textur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TEXTURE_REPEAT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--9--Textur_Kachelung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="REAL_MEASUREMENT_X">
              <xs:annotation>
                <xs:documentation>260--17--Realmass_X</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="REAL_MEASUREMENT_Y">
              <xs:annotation>
                <xs:documentation>260--18--Realmass_Y</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="TEXTURE_TILE">
            <xs:simpleType>
              <xs:restriction base="xs:int">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MASKING" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--10--Maskierung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="TEXTURE_DELIVERED_ORIENTATION">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[HV]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_NAME_TEXTURE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > TEXTURE Element : FILE_NAME_TEXTURE Element
Description
This element defines references to material textures. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]
Namespace (none)
Type
Restriction of xs:string
Diagram
FILE_NAME_TEXTURE Element
Overview
FILE_NAME_TEXTURE Restriction of xs:string
This element defines references to material textures. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]
Source
<xs:element name="FILE_NAME_TEXTURE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--6--Dateiname_Textur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXTURE Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXTURE_REPEAT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > TEXTURE Element : TEXTURE_REPEAT Element
Description
This element defines if a texture is applied to a material only one time or repeatedly. If a texture repeat is required, this element is defined and the settings are applied to all child elements, too.
According to the basic texture size (DPI, number of pixels) the repeat factor is calculated automatically by the software programme.
If the element FILENAME_TEXTURE is filled in, this element is required, too.
Namespace (none)
Diagram
REAL_MEASUREMENT_Y Element REAL_MEASUREMENT_X Element Sequence TEXTURE_REPEAT Element
Overview
TEXTURE_REPEAT optional
This element defines if a texture is applied to a material only one time or repeatedly. If a texture repeat is required, this element is defined and the settings are applied to all child elements, too.
According to the basic texture size (DPI, number of pixels) the repeat factor is calculated automatically by the software programme.
If the element FILENAME_TEXTURE is filled in, this element is required, too.
TEXTURE_TILE optional Restriction of xs:int
This attribute defines if a texture is applied to a material only one time (0 = no repeat) or several times (1 = repeat). D integer
P
M [0:1]
Sequence
REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger
This element defines the dimensions of the texture in X direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger
This element defines the dimensions of the texture in Y direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
Attributes
Name Type Use Default Fixed Description
TEXTURE_TILE Restriction of xs:int optional
This attribute defines if a texture is applied to a material only one time (0 = no repeat) or several times (1 = repeat). D integer
P
M [0:1]
Source
<xs:element name="TEXTURE_REPEAT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--9--Textur_Kachelung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="REAL_MEASUREMENT_X">
        <xs:annotation>
          <xs:documentation>260--17--Realmass_X</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="REAL_MEASUREMENT_Y">
        <xs:annotation>
          <xs:documentation>260--18--Realmass_Y</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="TEXTURE_TILE">
      <xs:simpleType>
        <xs:restriction base="xs:int">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
TEXTURE Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

REAL_MEASUREMENT_X Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > TEXTURE Element > TEXTURE_REPEAT Element : REAL_MEASUREMENT_X Element
Description
This element defines the dimensions of the texture in X direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
REAL_MEASUREMENT_X Element
Overview
REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger
This element defines the dimensions of the texture in X direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
Source
<xs:element name="REAL_MEASUREMENT_X" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--17--Realmass_X</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXTURE_REPEAT Element | TEXTURE Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

REAL_MEASUREMENT_Y Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > TEXTURE Element > TEXTURE_REPEAT Element : REAL_MEASUREMENT_Y Element
Description
This element defines the dimensions of the texture in Y direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
REAL_MEASUREMENT_Y Element
Overview
REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger
This element defines the dimensions of the texture in Y direction. The values are given in mm. D nonNegativeInteger
P
M [1:9999]
Source
<xs:element name="REAL_MEASUREMENT_Y" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--18--Realmass_Y</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXTURE_REPEAT Element | TEXTURE Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MASKING Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > TEXTURE Element : MASKING Element
Description
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
If the element FILENAME_TEXTURE is filled in, this element is required, too. 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
MASKING Element
Overview
MASKING optional Restriction of xs:boolean
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
If the element FILENAME_TEXTURE is filled in, this element is required, too. 		D boolean
P
M
Source
<xs:element name="MASKING" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--10--Maskierung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
TEXTURE Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXTURE_DELIVERED_ORIENTATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > TEXTURE Element : TEXTURE_DELIVERED_ORIENTATION Element
Description
This attribute identifies a default handle position. D string
P |[HV]
M [0:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXTURE_DELIVERED_ORIENTATION Element
Overview
TEXTURE_DELIVERED_ORIENTATION Restriction of xs:string
This attribute identifies a default handle position. D string
P |[HV]
M [0:1]
Source
<xs:element name="TEXTURE_DELIVERED_ORIENTATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[HV]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXTURE Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TRANSPARENCY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element : TRANSPARENCY Element
Description
This element defines the degree of transparency for a material RGB value or texture).
0 = opaque
9 = max. transparency
If this element is a colour variation settings in this field are required. 		D nonNegativeInteger
P
M [0:9]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
TRANSPARENCY Element
Overview
TRANSPARENCY optional Restriction of xs:nonNegativeInteger
This element defines the degree of transparency for a material RGB value or texture).
0 = opaque
9 = max. transparency
If this element is a colour variation settings in this field are required. 		D nonNegativeInteger
P
M [0:9]
Source
<xs:element name="TRANSPARENCY" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--14--Transparenz</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BRIGHTNESS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element : BRIGHTNESS Element
Description
This element defines the degree of brightness for a material (RGB value or texture).
0 = opaque
8 = high gloss
9 = reflection
If this element is a colour variation settings in this field are required. 		D nonNegativeInteger
P
M [0:9]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BRIGHTNESS Element
Overview
BRIGHTNESS optional Restriction of xs:nonNegativeInteger
This element defines the degree of brightness for a material (RGB value or texture).
0 = opaque
8 = high gloss
9 = reflection
If this element is a colour variation settings in this field are required. 		D nonNegativeInteger
P
M [0:9]
Source
<xs:element name="BRIGHTNESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--15--Glanz</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FORM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : FORM Element
Description
This element is used to define a variation of a shape.
Namespace (none)
Diagram
PROFILE_KEY Element Sequence FORM Element
Overview
FORM 0..∞
This element is used to define a variation of a shape.
FORM_NO required Restriction of xs:string
This attribute identifies the shape of a profile. D string
P
M [1:5]
Sequence
PROFILE_KEY Restriction of xs:string
This element defines the manufacturer specific key for a profile shape. This element is used for building the variation types 750-756. Only these variation types 750-756 can use the element FORM. The different variations are referenced by the item (ITEM) which represents the profile. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FORM_NO Restriction of xs:string required
This attribute identifies the shape of a profile. D string
P
M [1:5]
Source
<xs:element name="FORM" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROFILE_KEY">
        <xs:annotation>
          <xs:documentation>430--4/5--Varianten_Art_Profilform/Var_Schluessel_</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="5" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FORM_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROFILE_KEY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > FORM Element : PROFILE_KEY Element
Description
This element defines the manufacturer specific key for a profile shape. This element is used for building the variation types 750-756. Only these variation types 750-756 can use the element FORM. The different variations are referenced by the item (ITEM) which represents the profile. D string
P
M [1:5]
Namespace (none)
Type
Restriction of xs:string
Diagram
PROFILE_KEY Element
Overview
PROFILE_KEY Restriction of xs:string
This element defines the manufacturer specific key for a profile shape. This element is used for building the variation types 750-756. Only these variation types 750-756 can use the element FORM. The different variations are referenced by the item (ITEM) which represents the profile. D string
P
M [1:5]
Source
<xs:element name="PROFILE_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>430--4/5--Varianten_Art_Profilform/Var_Schluessel_</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="5" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FORM Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_MEASURE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : OPTION_MEASURE Element
Description
This element defines measurement information for different features, e.g. plinth height (feature type 402).
Namespace (none)
Diagram
STANDARD_PLINTH Element PLINTH_HEIGHT Element Sequence OPTION_MEASURE Element
Overview
OPTION_MEASURE 0..∞
This element defines measurement information for different features, e.g. plinth height (feature type 402).
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies the dimensions of an appearance. D nonNegativeInteger
P
M [1:99999]
Sequence
PLINTH_HEIGHT Restriction of xs:nonNegativeInteger
This element defines the plinth height in mm. D nonNegativeInteger
P
M [0:999999999]
STANDARD_PLINTH optional xs:boolean

This element is used to specify whether the relevant plinth height is a standard value or if it is different from the standard. If the value is set to false(0), the plinth height is different from the standard height and may incur an additional price for the plinth feet.

A missing element corresponds to the value true(1).

This element must be specified if there are linked articles with allocation type CLASS = 21.

D boolean
P
M [0:1]
Attributes
Name Type Use Default Fixed Description
OPTION_MEASURE_NO Restriction of xs:nonNegativeInteger required
This attribute identifies the dimensions of an appearance. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PLINTH_HEIGHT">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="STANDARD_PLINTH" type="xs:boolean" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Kennzeichnung zur Abweichung von Standardsockelhöhe</xs:documentation>
          <xs:documentation>hinzugefügt K.Richter, 29.02.2016</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPTION_MEASURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PLINTH_HEIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > OPTION_MEASURE Element : PLINTH_HEIGHT Element
Description
This element defines the plinth height in mm. D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
PLINTH_HEIGHT Element
Overview
PLINTH_HEIGHT Restriction of xs:nonNegativeInteger
This element defines the plinth height in mm. D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="PLINTH_HEIGHT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
OPTION_MEASURE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STANDARD_PLINTH Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > OPTION_MEASURE Element : STANDARD_PLINTH Element
Description

This element is used to specify whether the relevant plinth height is a standard value or if it is different from the standard. If the value is set to false(0), the plinth height is different from the standard height and may incur an additional price for the plinth feet.

A missing element corresponds to the value true(1).

This element must be specified if there are linked articles with allocation type CLASS = 21.

D boolean
P
M [0:1]
Namespace (none)
Type
xs:boolean
Diagram
STANDARD_PLINTH Element
Overview
STANDARD_PLINTH optional xs:boolean

This element is used to specify whether the relevant plinth height is a standard value or if it is different from the standard. If the value is set to false(0), the plinth height is different from the standard height and may incur an additional price for the plinth feet.

A missing element corresponds to the value true(1).

This element must be specified if there are linked articles with allocation type CLASS = 21.

D boolean
P
M [0:1]
Source
<xs:element name="STANDARD_PLINTH" type="xs:boolean" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Kennzeichnung zur Abweichung von Standardsockelhöhe</xs:documentation>
    <xs:documentation>hinzugefügt K.Richter, 29.02.2016</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPTION_MEASURE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : RESTRICTIONS Element
Description
This element is used for the definition of restrictions.
Namespace (none)
Diagram
RESTRICTION Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional
This element is used for the definition of restrictions.
Sequence
RESTRICTION 1..99999
This element is used for the definition and description of restrictions. These restrictions define rules for technically possible combinations but do not contain any planning advices. This is necessary to prevent the dealers from unnecessary restrictions in the course of kitchen planning.

Restrictions are assigned to series, styles or items by references. All test procedures defined in this element have to be referenced from series, styles or items.

Restrictions which are referenced from series or styles may not be referenced from items. Restrictions which are referenced from items have priority over restrictions referenced from series or styles

The element OPTION_REF can be set up in different ways. According to the filling levels in the elements FEATURE_1_NO, FEATURE_2_NO and FEATURE_3_NO test procedures can be defined as 0-level, 1-level or 2-level or 3-level.

Number of variations in case of undefined variations

On condition that the restriction is defined as a "permitting" test procedure (TEST_ID = 1), all features which are not listed in the test procedure are illegal feature combinations. If the restriction is defined as a "non-permitting" test procedure (TEST_ID = 0), all variations are legal feature combinations. If different feature combinations are combined this rule applies for the combination of the resulting features.

Number of variations for style specific restrictions:

In case a restriction is not referenced by all styles, the following rules apply:

If the restriction defines legal features and feature combinations, all variations of the feature combinations are illegal for those styles, which are not defined in the restriction.
If the restriction defines illegal features and feature combinations, all variations of the of the feature combinations are legal for those styles, which are not defined in the restriction.

Cyclical tests
Cyclical restrictions are not permitted. Such test procedures might result from the following constellations
Not permitted
1. restriction: feature 1 with feature 2
2. restriction: feature 2 with feature 3
3. restriction: feature 3 with feature 1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute identifies restrictions unambiguously. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger

The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]

VALIDATION_TYPE required Restriction of xs:int
The attribute VALIDATION_TYPE defines a restriction as either colour-length or variation test procedure. In case of a colour-length test procedure the element MIN/MAX_DIMENSION under OPTION_COMBINATION has to be filled in.
0 = variation test procedure (formerly record type 270)
1 = colour-length test procedure (formerly record type 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
This element is used for the definition of a name for a control procedure.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
This element is used for the definition of a variation combination.
Sequence
OPTION_REF 1..3
This element is used for referencing the variation types which are used in the control procedures.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
This element defines the minimum dimension in which an option is available.
DIMENSION_TYPE required Restriction of xs:string
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
This element defines the minimum dimension in which an option is available. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted 		D boolean
P
M
Source
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION" maxOccurs="99999">
        <xs:annotation>
          <xs:documentation>270/271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>270--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:sequence minOccurs="0">
                    <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                      <xs:annotation>
                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                        <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="DIMENSION_TYPE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[WHD]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSION_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                      <xs:annotation>
                        <xs:documentation>405--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                        <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="DIMENSION_TYPE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[WHD]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSION_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="TEST_ID">
              <xs:annotation>
                <xs:documentation>270--4--Pruef_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_1_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_2_NO">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_3_NO">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="VALIDATION_TYPE" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:int">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element : RESTRICTION Element
Description
This element is used for the definition and description of restrictions. These restrictions define rules for technically possible combinations but do not contain any planning advices. This is necessary to prevent the dealers from unnecessary restrictions in the course of kitchen planning.

Restrictions are assigned to series, styles or items by references. All test procedures defined in this element have to be referenced from series, styles or items.

Restrictions which are referenced from series or styles may not be referenced from items. Restrictions which are referenced from items have priority over restrictions referenced from series or styles

The element OPTION_REF can be set up in different ways. According to the filling levels in the elements FEATURE_1_NO, FEATURE_2_NO and FEATURE_3_NO test procedures can be defined as 0-level, 1-level or 2-level or 3-level.

Number of variations in case of undefined variations

On condition that the restriction is defined as a "permitting" test procedure (TEST_ID = 1), all features which are not listed in the test procedure are illegal feature combinations. If the restriction is defined as a "non-permitting" test procedure (TEST_ID = 0), all variations are legal feature combinations. If different feature combinations are combined this rule applies for the combination of the resulting features.

Number of variations for style specific restrictions:

In case a restriction is not referenced by all styles, the following rules apply:

If the restriction defines legal features and feature combinations, all variations of the feature combinations are illegal for those styles, which are not defined in the restriction.
If the restriction defines illegal features and feature combinations, all variations of the of the feature combinations are legal for those styles, which are not defined in the restriction.

Cyclical tests
Cyclical restrictions are not permitted. Such test procedures might result from the following constellations
Not permitted
1. restriction: feature 1 with feature 2
2. restriction: feature 2 with feature 3
3. restriction: feature 3 with feature 1
Namespace (none)
Diagram
TEST_ID Element OPTION_COMBINATION Element LANGUAGE Element Sequence RESTRICTION_NAME_TEXT Element Sequence RESTRICTION Element
Overview
RESTRICTION 1..99999
This element is used for the definition and description of restrictions. These restrictions define rules for technically possible combinations but do not contain any planning advices. This is necessary to prevent the dealers from unnecessary restrictions in the course of kitchen planning.

Restrictions are assigned to series, styles or items by references. All test procedures defined in this element have to be referenced from series, styles or items.

Restrictions which are referenced from series or styles may not be referenced from items. Restrictions which are referenced from items have priority over restrictions referenced from series or styles

The element OPTION_REF can be set up in different ways. According to the filling levels in the elements FEATURE_1_NO, FEATURE_2_NO and FEATURE_3_NO test procedures can be defined as 0-level, 1-level or 2-level or 3-level.

Number of variations in case of undefined variations

On condition that the restriction is defined as a "permitting" test procedure (TEST_ID = 1), all features which are not listed in the test procedure are illegal feature combinations. If the restriction is defined as a "non-permitting" test procedure (TEST_ID = 0), all variations are legal feature combinations. If different feature combinations are combined this rule applies for the combination of the resulting features.

Number of variations for style specific restrictions:

In case a restriction is not referenced by all styles, the following rules apply:

If the restriction defines legal features and feature combinations, all variations of the feature combinations are illegal for those styles, which are not defined in the restriction.
If the restriction defines illegal features and feature combinations, all variations of the of the feature combinations are legal for those styles, which are not defined in the restriction.

Cyclical tests
Cyclical restrictions are not permitted. Such test procedures might result from the following constellations
Not permitted
1. restriction: feature 1 with feature 2
2. restriction: feature 2 with feature 3
3. restriction: feature 3 with feature 1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
This attribute identifies restrictions unambiguously. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger

The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]

VALIDATION_TYPE required Restriction of xs:int
The attribute VALIDATION_TYPE defines a restriction as either colour-length or variation test procedure. In case of a colour-length test procedure the element MIN/MAX_DIMENSION under OPTION_COMBINATION has to be filled in.
0 = variation test procedure (formerly record type 270)
1 = colour-length test procedure (formerly record type 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
This element is used for the definition of a name for a control procedure.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
This element is used for the definition of a variation combination.
Sequence
OPTION_REF 1..3
This element is used for referencing the variation types which are used in the control procedures.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
This element defines the minimum dimension in which an option is available.
DIMENSION_TYPE required Restriction of xs:string
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
This element defines the minimum dimension in which an option is available. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted 		D boolean
P
M
Attributes
Name Type Use Default Fixed Description
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
This attribute identifies restrictions unambiguously. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO Restriction of xs:nonNegativeInteger required
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO Restriction of xs:nonNegativeInteger optional
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO Restriction of xs:nonNegativeInteger optional

The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]

VALIDATION_TYPE Restriction of xs:int required
The attribute VALIDATION_TYPE defines a restriction as either colour-length or variation test procedure. In case of a colour-length test procedure the element MIN/MAX_DIMENSION under OPTION_COMBINATION has to be filled in.
0 = variation test procedure (formerly record type 270)
1 = colour-length test procedure (formerly record type 405) 		D nonNegativeInteger
P
M [0:1]
Source
<xs:element name="RESTRICTION" maxOccurs="99999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>270--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:sequence minOccurs="0">
              <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                <xs:annotation>
                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="DIMENSION_TYPE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[WHD]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                  <xs:attribute name="DIMENSION_VALUE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                <xs:annotation>
                  <xs:documentation>405--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="DIMENSION_TYPE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[WHD]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                  <xs:attribute name="DIMENSION_VALUE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="TEST_ID">
        <xs:annotation>
          <xs:documentation>270--4--Pruef_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_1_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_2_NO">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_3_NO">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="VALIDATION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:int">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION_NAME_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element : RESTRICTION_NAME_TEXT Element
Description
This element is used for the definition of a name for a control procedure.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence RESTRICTION_NAME_TEXT Element
Overview
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
This element is used for the definition of a name for a control procedure.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_COMBINATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element : OPTION_COMBINATION Element
Description
This element is used for the definition of a variation combination.
Namespace (none)
Diagram
MIN_DIMENSION Element MAX_DIMENSION Element Sequence OPTION_REF Element Sequence OPTION_COMBINATION Element
Overview
OPTION_COMBINATION 1..∞
This element is used for the definition of a variation combination.
Sequence
OPTION_REF 1..3
This element is used for referencing the variation types which are used in the control procedures.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
This element defines the minimum dimension in which an option is available.
DIMENSION_TYPE required Restriction of xs:string
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
This element defines the minimum dimension in which an option is available. D nonNegativeInteger
P
M [1:9999]
Remarks

Source
<xs:element name="OPTION_COMBINATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:sequence minOccurs="0">
        <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
          <xs:annotation>
            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="DIMENSION_TYPE" use="required">
              <xs:annotation>
                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[WHD]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
            <xs:attribute name="DIMENSION_VALUE" use="required">
              <xs:annotation>
                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
          <xs:annotation>
            <xs:documentation>405--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="DIMENSION_TYPE" use="required">
              <xs:annotation>
                <xs:documentation>405--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[WHD]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
            <xs:attribute name="DIMENSION_VALUE" use="required">
              <xs:annotation>
                <xs:documentation>405--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element > OPTION_COMBINATION Element : OPTION_REF Element
Description
This element is used for referencing the variation types which are used in the control procedures.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF 1..3
This element is used for referencing the variation types which are used in the control procedures.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
This attribute is used for referencing a option. D string
P
M [1:5]
Remarks

Source
<xs:element name="OPTION_REF" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_COMBINATION Element | RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MAX_DIMENSION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element > OPTION_COMBINATION Element : MAX_DIMENSION Element
Description
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
Namespace (none)
Diagram
MAX_DIMENSION Element
Overview
MAX_DIMENSION 0..3
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
Attributes
Name Type Use Default Fixed Description
DIMENSION_TYPE Restriction of xs:string required
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE Restriction of xs:nonNegativeInteger required
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
Source
<xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DIMENSION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[WHD]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSION_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_COMBINATION Element | RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MIN_DIMENSION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element > OPTION_COMBINATION Element : MIN_DIMENSION Element
Description
This element defines the minimum dimension in which an option is available.
Namespace (none)
Diagram
MIN_DIMENSION Element
Overview
MIN_DIMENSION 0..3
This element defines the minimum dimension in which an option is available.
DIMENSION_TYPE required Restriction of xs:string
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
This element defines the minimum dimension in which an option is available. D nonNegativeInteger
P
M [1:9999]
Attributes
Name Type Use Default Fixed Description
DIMENSION_TYPE Restriction of xs:string required
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE Restriction of xs:nonNegativeInteger required
This element defines the minimum dimension in which an option is available. D nonNegativeInteger
P
M [1:9999]
Source
<xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>405--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DIMENSION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation>405--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[WHD]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSION_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>405--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_COMBINATION Element | RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEST_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element : TEST_ID Element
Description
The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
TEST_ID Element
Overview
TEST_ID Restriction of xs:boolean
The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted 		D boolean
P
M
Source
<xs:element name="TEST_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270--4--Pruef_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUGGESTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : SUGGESTIONS Element
Description
This element is used to specify default values.
Namespace (none)
Diagram
SUGGESTION Element Sequence SUGGESTIONS Element
Overview
SUGGESTIONS optional
This element is used to specify default values.
Sequence
SUGGESTION 1..99999

This element is used to define and describe default values for version types with certain versions.

This option to set default values is only provided for head versions and becomes effective when a planning is recorded for the first time.

Similar to a standard proposal (DEFAULT_OPTION_GROUP), it is referenced below the series, with the standard proposal assigned a higher priority.

OPTION_COMBINATION can be used to make pairs of versions for version-specific default values available.

The version type specified at FEATURE_1_NO has the highest priority.

The default values must not conflict with the associated checks.

SUGGESTION_NO required Restriction of xs:nonNegativeInteger
This attribute assigns unique identifiers to sets of default values. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values. D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values. D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values. D nonNegativeInteger
P
M [0:999]
Sequence
SUGGESTION_NAME_TEXT languagetexte60 Complex Type
This element is used to specify the description of a set of default values.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
This element is used to form a version combination for default values.
Sequence
OPTION_REF 1..3
This element is used to reference variants that are specified in default settings.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references the version type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references the variant type. D string
P
M [1:5]
Source
<xs:element name="SUGGESTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SUGGESTION" maxOccurs="99999">
        <xs:annotation>
          <xs:documentation>270/271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SUGGESTION_NAME_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>270--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SUGGESTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_1_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_2_NO">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_3_NO">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUGGESTION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > SUGGESTIONS Element : SUGGESTION Element
Description

This element is used to define and describe default values for version types with certain versions.

This option to set default values is only provided for head versions and becomes effective when a planning is recorded for the first time.

Similar to a standard proposal (DEFAULT_OPTION_GROUP), it is referenced below the series, with the standard proposal assigned a higher priority.

OPTION_COMBINATION can be used to make pairs of versions for version-specific default values available.

The version type specified at FEATURE_1_NO has the highest priority.

The default values must not conflict with the associated checks.

Namespace (none)
Diagram
OPTION_COMBINATION Element LANGUAGE Element Sequence SUGGESTION_NAME_TEXT Element Sequence SUGGESTION Element
Overview
SUGGESTION 1..99999

This element is used to define and describe default values for version types with certain versions.

This option to set default values is only provided for head versions and becomes effective when a planning is recorded for the first time.

Similar to a standard proposal (DEFAULT_OPTION_GROUP), it is referenced below the series, with the standard proposal assigned a higher priority.

OPTION_COMBINATION can be used to make pairs of versions for version-specific default values available.

The version type specified at FEATURE_1_NO has the highest priority.

The default values must not conflict with the associated checks.

SUGGESTION_NO required Restriction of xs:nonNegativeInteger
This attribute assigns unique identifiers to sets of default values. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values. D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values. D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values. D nonNegativeInteger
P
M [0:999]
Sequence
SUGGESTION_NAME_TEXT languagetexte60 Complex Type
This element is used to specify the description of a set of default values.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
This element is used to form a version combination for default values.
Sequence
OPTION_REF 1..3
This element is used to reference variants that are specified in default settings.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references the version type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references the variant type. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
SUGGESTION_NO Restriction of xs:nonNegativeInteger required
This attribute assigns unique identifiers to sets of default values. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO Restriction of xs:nonNegativeInteger required
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values. D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO Restriction of xs:nonNegativeInteger optional
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values. D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO Restriction of xs:nonNegativeInteger optional
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="SUGGESTION" maxOccurs="99999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SUGGESTION_NAME_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>270--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SUGGESTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_1_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_2_NO">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_3_NO">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SUGGESTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUGGESTION_NAME_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > SUGGESTIONS Element > SUGGESTION Element : SUGGESTION_NAME_TEXT Element
Description
This element is used to specify the description of a set of default values.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence SUGGESTION_NAME_TEXT Element
Overview
SUGGESTION_NAME_TEXT languagetexte60 Complex Type
This element is used to specify the description of a set of default values.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="SUGGESTION_NAME_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
SUGGESTION Element | SUGGESTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_COMBINATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > SUGGESTIONS Element > SUGGESTION Element : OPTION_COMBINATION Element
Description
This element is used to form a version combination for default values.
Namespace (none)
Diagram
OPTION_REF Element Sequence OPTION_COMBINATION Element
Overview
OPTION_COMBINATION 1..∞
This element is used to form a version combination for default values.
Sequence
OPTION_REF 1..3
This element is used to reference variants that are specified in default settings.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references the version type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references the variant type. D string
P
M [1:5]
Source
<xs:element name="OPTION_COMBINATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SUGGESTION Element | SUGGESTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > SUGGESTIONS Element > SUGGESTION Element > OPTION_COMBINATION Element : OPTION_REF Element
Description
This element is used to reference variants that are specified in default settings.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF 1..3
This element is used to reference variants that are specified in default settings.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references the version type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute references the variant type. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute references the version type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
This attribute references the variant type. D string
P
M [1:5]
Source
<xs:element name="OPTION_REF" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_COMBINATION Element | SUGGESTION Element | SUGGESTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_DEFINITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : PRICE_DEFINITION Element
Description
This element is used for providing all the information which is necessary for a correct calculation of prices, e.g. pricing tables and finish groups.
Namespace (none)
Diagram
PRICE_TYPES Element MERCHANDISE_GROUP Element IDENT_NUMBERS Element VALUE_ADDED_TAXES Element SET_OF_EXCHANGE_IDS Element PRICE_FEATURE_GROUPS Element Sequence PRICE_DEFINITION Element
Overview
PRICE_DEFINITION
This element is used for providing all the information which is necessary for a correct calculation of prices, e.g. pricing tables and finish groups.
Sequence
PRICE_FEATURE_GROUPS
This element is used to defind the price feature groups.
Sequence
PRICE_FEATURE_GROUP 1..∞
This element contains all relevant pricing information. The settings in the element PRICE_FEATURE_GROUP define specific conditions (e.g. feature combinations) for the item price.

Each item references one PRICE_FEATURE_GROUP. The exact price information is defined on item level.

The following rules for price feature groups or items apply:
- Neutral items, not depending on a price feature group, cannot have features
- for items, depending on features, settings in the fields feature type 1 (style) and optionally the variation type 101 (front colour 1) or 105 (front combination)are required.
- items depending on features require one or two feature types
- each item has to reference exactly one basic price group (ADDITIONAL_PRICE=0)

Similar combinations of feature types for different price feature groups are not permitted, e.g. there should be only one PRICE_FEATURE_GROUP with feature type handle variation, which covers everything having to do with handle variations.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute identifies a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
ADDITIONAL_PRICE required Restriction of xs:boolean
This attribute is used for defining the different price types, e.g. basic price or additional price. (0 = basic price, 1= additional price):
If an additional price group is defined (ADDITIONAL_PRICE=1), the option "price on request" is not permitted. For items which refer to this additional price group the element PRICE_ON_REQUEST (path 1) is not permitted.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_ON_REQUEST 		D boolean
P
M
PRICE_CALC_METHOD required Restriction of xs:nonNegativeInteger
This attribute is used for defining the basic price calculation method.

The following methods are defined:

0 = price on request;
1 = neutral item; price not depending on style or series
2 = price depending on style or series;
3 = price depending on finish.

A PRICE_FEATURE_GROUP which contains the value 0 (price on request) in the attribute PRICE_CALC_METHOD may occur only one time. 		D nonNegativeInteger
P
M [0:3]
FEATURE_NO_1 optional Restriction of xs:nonNegativeInteger
This attribute identifies the feature type 1.
The combination which is defined in the attribute OPTION_REF/FEATURE_NO may not differ from the settings in the attribute FEATURE_NO_1. 		D nonNegativeInteger
P
M [0:999]
FEATURE_NO_2 optional Restriction of xs:nonNegativeInteger
This attribute identifies the feature type 2.
The combination which is defined in the attribute OPTION_REF/FEATURE_NO may not differ from the settings in the attribute FEATURE_NO_2. 		D nonNegativeInteger
P
M [1:99999]
Sequence
PRICE_FEATURE_GROUP_TEXT languagetexte60 Complex Type
This element provides text information for the finish groups.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
FINISH 0..∞
This element is used for assigning price fields (price field, block price field) and the manufacturer price group to legal feature classes.

If the attribute PRICE_CALC_METHOD is set to 0 (price on request), the element FINISH is not permitted.
Sequence
OPTION_REF 0..2
This element is used to reference a option.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

This element is used for defining the price field in which the item price is saved. The corresponding price field has to be defined in the element ITEM_PRICE (path 1 or path 2).

If the same catalogue is used for different customer groups the assignment of price groups must not be changed. The same applies to correction files within the same cycle.

Element paths
path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

This field is used to specify in which price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer dies not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
This element contains the manufacturer's price group.

For prices which depend on series or finishes (PRICE_CALC_METHOD = 3) the value defined in the element PRICE_FIELD is copied to the element SUPPLIER_PRICE_GROUP.
For prices of neutral items (PRICE_CALC_METHOD = 1) values in this field are not taken into consideration. 		D string
P
M [1:10]
SET_OF_EXCHANGE_IDS optional
This element defines the manufacturer specific ecxchange-IDs.

If blocks are available for one manufacturer, this element has to be defined in the catalogue file. This information is also required if the manufacturer is going to deliver blocks offside the general catalogue in the future. A block file must not contain this element.
Sequence
EXCHANGE_ID 1..∞
The element EXCHANGE_ID (exchange-ID) is used as a key for the exchange groups. Freely defined values in the range between 1 and 89 are permitted.
Special exchange_IDs are defined as follows:
0 = exchange of item not permitted
98 = exchange of item with itself only.
99 = exchange of item with all other exchange-IDs permitted.
All utilized exchange-ID have to be defined in the data as well as the predefined special exchange-IDs.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
This element is used as a key for the exchange groups. Freely defined values in the range between 1 and 89 are permitted.
Special exchange_IDs are defined as follows:
0 = exchange of item not permitted
98 = exchange of item with itself only
99 = exchange of item with all other exchange-IDs permitted.
All utilized exchange-ID have to be defined in the data as well as the predefined special exchange-IDs.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Sequence
EXCHANGE_ID_TEXT languagetexte40 Complex Type
Additional information about the exchange group is provided in the field, e.g.:
- furniture
- worktops
- light pelmet/ cornice
- accesories
- electrical appliances
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
VALUE_ADDED_TAXES
This element is used for defining the different rates of value added tax which are referenced by the items. The tax rates defined in this field have to correspond with the country defined in element COUNTRY_ID (path 1).

Element paths
path 1: CATALOG/CATALOG_IDENTIFICATIO
Sequence
VALUE_ADDED_TAX 1..100
This element defines a VAT rate.
VAT_NO required Restriction of xs:nonNegativeInteger
This attribute defines an ID for a VAT rate. The value 0 is reserved for those items which are not subject to VAT. D nonNegativeInteger
P
M [0:99]
Sequence
VAT_RATE Restriction of xs:nonNegativeInteger
This element defines the VAT rate in percent. The value is given with two decimal places, e.g. 1600 for 16,00 % oder 10 für 0,1%). D nonNegativeInteger
P
M [0:9999]
IDENT_NUMBERS optional
This element defines the ident numbers. All ident numbers used in a catalogue have to be defined here.
Sequence
IDENT_NUMBER 0..9999
This element defines the ident numbers. All ident numbers used in a catalogue have to be defined here.
IDENT_NO required Restriction of xs:positiveInteger
This attribute is used to define an identifier. D positiveInteger
P
M [1:9999]
Sequence
SERIE_REF 1..99
This element references a series. If no series is referenced the ident numbers are valid globally.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
PRICE Restriction of xs:integer
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30,000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of EUR -9.00 is entered as -> -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_REF of the item does not contain an element for the corresponding price group. 		D nonNegativeInteger
P
M [0:99]
MERCHANDISE_GROUP 1..∞
This element defines a merchandise group. The merchandise group and the assigned text information have to correspond with the calculation sheet of the manufacturer. For one merchandise group 1-n calculation groups can be defined.
MERCHANDISE_GROUP_NO required Restriction of xs:string
This attribute defines a merchandise group. D string
P
M [1:5]
Sequence
MERCHANDISE_GROUP_TEXT languagetexte30 Complex Type
This element provides text information about the merchandise groups.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Sequence
CALC_GROUP 1..∞

This element is used to define the possible calculation groups. It can be helpful when applying different discounts. This means that, depending on the number of discount scales, a corresponding number of calculation groups can be formed here. The element ITEM is used to allocate the items to a calculation group. Only calculation groups with referencing items must be defined. They key ist the CALC_GROUP_NO field.

If the same calculation group is used, the same price finding will also be used.

A calculation group can only be used once within all MERCHANDISE_GROUP elements. This means that a certain calculation group may only be used in a single MERCHANDISE_GROUP and not in multiple MERCHANDISE_GROUP elements.

The calculation group is specified via the CALC_GROUP_NO attribute.

CALC_GROUP_NO required Restriction of xs:positiveInteger

This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
8 = miscellaneous 1
9 = miscellaneous 2

Single-figure numbers (leading zeroes) are not allowed.
The calculation group does not correspond with the suppliers scales of conditions.

 D positiveInteger
P
M [10:99]
Sequence
CALC_GROUP_TEXT languagetexte30 Complex Type
This element contains text information for a calculation group.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
CALCULATION_FACTOR optional Restriction of xs:nonNegativeInteger
The use of this element is only permitted if the value 3 is set in the element PRICE_ID (path 1).

If calculation points are used the corresponding calculation factor has to be defined in this element.
The factor is given as a decimal figure with max. 5 decimal places before the point and exactly three decimal places after the point (the point itself does not count). The calculation factor has to be > 0.

Element paths
path 1: CATALOG/CATALOG_IDENTIFICATION 		D nonNegativeInteger
P
M [1:99999999]
PRICE_TYPES
This element is used for defining the different price types. Neutral as well as model specific items can be charged per piece or depending on certain measurements.
The child elements WIDTH_X, DEPTH_Y, HEIGHT_Z define that the price of an item depends on width, height, depth, surface or volume.
If the value "1" is not entered for any of the dimensions, the price is calculated per piece (e.g. base cabinet) and not depending on measurements. In this case the elements BASIC_UNIT and ROUNDING_UNIT have to be filled in with "0".
In case one dimension field is filled in with "1" , the price calculation is based on this dimension (e.g. light pelmets).
If the value "1" is filled in into two dimension fields, the price will be calculated depending on the surface of the item (e.g. cladding material).
The price calculation is based on volume, in case three dimension fields are filled with the value "1" (e.g. lacquer, stain).
Sequence 1..∞
PRICE_TYPE
This element defines a price type.
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type unambiguously. D positiveInteger
P
M [1:250]
Sequence
WIDTH_X Restriction of xs:boolean
If the calculated price is depending on the width of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
DEPTH_Y Restriction of xs:boolean
If the calculated price is depending on the depth of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
HEIGHT_Z Restriction of xs:boolean
If the calculated price is depending on the height of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
BASIC_UNIT Restriction of xs:nonNegativeInteger
The field basic unit (BASIC_UNIT) indicatea the dimension to which the prices in the elements ITEM_PRICE (path1) and ADDITIONAL_PRICE (path2) refer.
The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm². If an item price depending on width is calculated per metre, the value "1000" has to be filled in into the field basic_unit, If the price calculation of an item is based on volume and the calculation unit is 1 m³, the value in the field basic_unit has to be "1000000000" [mm³]. If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0".

path1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/
path2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
The element rounding unit (ROUNDING_UNIT) indicates the measurement to which length, surface or volume are rounded up. The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm³. If an item price depending on width is rounded up to full centimeters, the value filled in here has to be "10". If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0". D nonNegativeInteger
P
M [0:999999999999]
BASIC_PRICE_DEPENDENT Restriction of xs:boolean
A basic price and a corresponding price unit can be defined for those items which are calculated depending on dimensions. No basic price is taken into account, if the value in this field is "0".

The element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC defines the current basic
price of an item. The element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT indicates the corresponding basic price unit.

The element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE defines the remaining measurement price, which refers to the element BASIC_UNIT.
In case the option BASIC_PRICE_DEPENDENT has been defined for an item, the definition of a minimum price is not permitted. The total price of an item is always calculated on the BASIC_PRICE and the additional REMAINDER_PRICE, taking into account the rules defined in this element.

The total item price is calculated according to the following scheme:
The basic price unit is subtracted from the total item price. The result of this operation is the remainder.
The calculation of the total item price is based on the rules defined in the element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE. In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0. 		D boolean
P
M
PRICE_TYPE_FORMULA optional Restriction of xs:string
It is possible to define formulas for price calculation (PRICE_TYPE), but these formulas must not be defined for standard calculation price types, i.e. calculation per m² or m³.
The following rules for the definition of price formulas apply:
- Formula parameters b, h and t can be used. Parameters b, h, t correspond to the parameters b, h and t of the basic shapes. Depending on the used parameters b, h, t the corresponding Boolean field WIDTH_X (P1) (b), DEPTH_Y (P1) (t) or HEIGHT_Z (P1) (h) has to be set to true:
- Basic arithmetic operations addition (+), subtraction (-), multiplication (*) and division (/) can be applied;
- rules of parentheses may be applied;
- Algebraic signs must not be used;
- only the final result is rounded;
- All rules of the elements BASIC_UNIT (P1), ROUNDING_UNIT (P1), and BASIC_PRICE_DEPENDENT (P1) also apply in combination with the field PRICE_TYPE_FORMULA

P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
PRICE_TYPE_NAME optional languagetexte60 Complex Type
This field contains a denotation for the defined price_type.
This denotation is used to simplify the data acquisition for communication purposes. This denotation is not evaluated in the processing software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="PRICE_DEFINITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>300--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
                          <xs:annotation>
                            <xs:documentation>311--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>311--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>311--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_FIELD">
                          <xs:annotation>
                            <xs:documentation>311--5--Preisfeld</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="SUPPLIER_PRICE_GROUP">
                          <xs:annotation>
                            <xs:documentation>311--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="10" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="ADDITIONAL_PRICE" use="required">
                  <xs:annotation>
                    <xs:documentation>300--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:boolean" />
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="PRICE_CALC_METHOD" use="required">
                  <xs:annotation>
                    <xs:documentation>300--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="3" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_NO_1">
                  <xs:annotation>
                    <xs:documentation>300--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_NO_2">
                  <xs:annotation>
                    <xs:documentation>300--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_OF_EXCHANGE_IDS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>115--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>115--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_TEXT" type="languagetexte40">
                    <xs:annotation>
                      <xs:documentation>115--3--Tausch_ID_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>115--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="VALUE_ADDED_TAXES">
        <xs:annotation>
          <xs:documentation>360--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="VALUE_ADDED_TAX" maxOccurs="100">
              <xs:annotation>
                <xs:documentation>360--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="VAT_RATE">
                    <xs:annotation>
                      <xs:documentation>360--3--MwSt_Satz</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="VAT_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>360--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="IDENT_NUMBERS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>351--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="IDENT_NUMBER" minOccurs="0" maxOccurs="9999">
              <xs:annotation>
                <xs:documentation>351--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIE_REF" maxOccurs="99">
                    <xs:annotation>
                      <xs:documentation>351--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>351--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE">
                    <xs:annotation>
                      <xs:documentation>351--4--Preis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="-99999999" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="IDENT_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>351--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MERCHANDISE_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>350--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MERCHANDISE_GROUP_TEXT" type="languagetexte30">
              <xs:annotation>
                <xs:documentation>350--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>350--6--Warengruppentext</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:sequence>
              <xs:element name="CALC_GROUP" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>350--1--Satzart</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="CALC_GROUP_TEXT" type="languagetexte30">
                      <xs:annotation>
                        <xs:documentation>350--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                    </xs:element>
                    <xs:element name="CALCULATION_FACTOR" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>350--4--Verrechnungsfaktor</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="99999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="CALC_GROUP_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>350--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="10" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
          </xs:sequence>
          <xs:attribute name="MERCHANDISE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>350--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_TYPES">
        <xs:annotation>
          <xs:documentation>150--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence maxOccurs="unbounded">
            <xs:element name="PRICE_TYPE">
              <xs:annotation>
                <xs:documentation>150--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="WIDTH_X">
                    <xs:annotation>
                      <xs:documentation>150--3--Breite_X</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DEPTH_Y">
                    <xs:annotation>
                      <xs:documentation>150--4--Tiefe_Y</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HEIGHT_Z">
                    <xs:annotation>
                      <xs:documentation>150--5--Hoehe_Z</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_UNIT">
                    <xs:annotation>
                      <xs:documentation>150--6--Basis_Einheit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ROUNDING_UNIT">
                    <xs:annotation>
                      <xs:documentation>150--7--Rundungseinheit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_PRICE_DEPENDENT">
                    <xs:annotation>
                      <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>150--9--Preisart_Formel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="100" />
                        <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_NAME" type="languagetexte60" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>150--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="250" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUPS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element : PRICE_FEATURE_GROUPS Element
Description
This element is used to defind the price feature groups.
Namespace (none)
Diagram
PRICE_FEATURE_GROUP Element Sequence PRICE_FEATURE_GROUPS Element
Overview
PRICE_FEATURE_GROUPS
This element is used to defind the price feature groups.
Sequence
PRICE_FEATURE_GROUP 1..∞
This element contains all relevant pricing information. The settings in the element PRICE_FEATURE_GROUP define specific conditions (e.g. feature combinations) for the item price.

Each item references one PRICE_FEATURE_GROUP. The exact price information is defined on item level.

The following rules for price feature groups or items apply:
- Neutral items, not depending on a price feature group, cannot have features
- for items, depending on features, settings in the fields feature type 1 (style) and optionally the variation type 101 (front colour 1) or 105 (front combination)are required.
- items depending on features require one or two feature types
- each item has to reference exactly one basic price group (ADDITIONAL_PRICE=0)

Similar combinations of feature types for different price feature groups are not permitted, e.g. there should be only one PRICE_FEATURE_GROUP with feature type handle variation, which covers everything having to do with handle variations.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute identifies a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
ADDITIONAL_PRICE required Restriction of xs:boolean
This attribute is used for defining the different price types, e.g. basic price or additional price. (0 = basic price, 1= additional price):
If an additional price group is defined (ADDITIONAL_PRICE=1), the option "price on request" is not permitted. For items which refer to this additional price group the element PRICE_ON_REQUEST (path 1) is not permitted.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_ON_REQUEST 		D boolean
P
M
PRICE_CALC_METHOD required Restriction of xs:nonNegativeInteger
This attribute is used for defining the basic price calculation method.

The following methods are defined:

0 = price on request;
1 = neutral item; price not depending on style or series
2 = price depending on style or series;
3 = price depending on finish.

A PRICE_FEATURE_GROUP which contains the value 0 (price on request) in the attribute PRICE_CALC_METHOD may occur only one time. 		D nonNegativeInteger
P
M [0:3]
FEATURE_NO_1 optional Restriction of xs:nonNegativeInteger
This attribute identifies the feature type 1.
The combination which is defined in the attribute OPTION_REF/FEATURE_NO may not differ from the settings in the attribute FEATURE_NO_1. 		D nonNegativeInteger
P
M [0:999]
FEATURE_NO_2 optional Restriction of xs:nonNegativeInteger
This attribute identifies the feature type 2.
The combination which is defined in the attribute OPTION_REF/FEATURE_NO may not differ from the settings in the attribute FEATURE_NO_2. 		D nonNegativeInteger
P
M [1:99999]
Sequence
PRICE_FEATURE_GROUP_TEXT languagetexte60 Complex Type
This element provides text information for the finish groups.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
FINISH 0..∞
This element is used for assigning price fields (price field, block price field) and the manufacturer price group to legal feature classes.

If the attribute PRICE_CALC_METHOD is set to 0 (price on request), the element FINISH is not permitted.
Sequence
OPTION_REF 0..2
This element is used to reference a option.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

This element is used for defining the price field in which the item price is saved. The corresponding price field has to be defined in the element ITEM_PRICE (path 1 or path 2).

If the same catalogue is used for different customer groups the assignment of price groups must not be changed. The same applies to correction files within the same cycle.

Element paths
path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

This field is used to specify in which price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer dies not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
This element contains the manufacturer's price group.

For prices which depend on series or finishes (PRICE_CALC_METHOD = 3) the value defined in the element PRICE_FIELD is copied to the element SUPPLIER_PRICE_GROUP.
For prices of neutral items (PRICE_CALC_METHOD = 1) values in this field are not taken into consideration. 		D string
P
M [1:10]
Source
<xs:element name="PRICE_FEATURE_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>300--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
                    <xs:annotation>
                      <xs:documentation>311--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>311--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>311--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_FIELD">
                    <xs:annotation>
                      <xs:documentation>311--5--Preisfeld</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="SUPPLIER_PRICE_GROUP">
                    <xs:annotation>
                      <xs:documentation>311--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="10" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="ADDITIONAL_PRICE" use="required">
            <xs:annotation>
              <xs:documentation>300--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:boolean" />
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="PRICE_CALC_METHOD" use="required">
            <xs:annotation>
              <xs:documentation>300--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="3" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_NO_1">
            <xs:annotation>
              <xs:documentation>300--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_NO_2">
            <xs:annotation>
              <xs:documentation>300--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element : PRICE_FEATURE_GROUP Element
Description
This element contains all relevant pricing information. The settings in the element PRICE_FEATURE_GROUP define specific conditions (e.g. feature combinations) for the item price.

Each item references one PRICE_FEATURE_GROUP. The exact price information is defined on item level.

The following rules for price feature groups or items apply:
- Neutral items, not depending on a price feature group, cannot have features
- for items, depending on features, settings in the fields feature type 1 (style) and optionally the variation type 101 (front colour 1) or 105 (front combination)are required.
- items depending on features require one or two feature types
- each item has to reference exactly one basic price group (ADDITIONAL_PRICE=0)

Similar combinations of feature types for different price feature groups are not permitted, e.g. there should be only one PRICE_FEATURE_GROUP with feature type handle variation, which covers everything having to do with handle variations.
Namespace (none)
Diagram
FINISH Element LANGUAGE Element Sequence PRICE_FEATURE_GROUP_TEXT Element Sequence PRICE_FEATURE_GROUP Element
Overview
PRICE_FEATURE_GROUP 1..∞
This element contains all relevant pricing information. The settings in the element PRICE_FEATURE_GROUP define specific conditions (e.g. feature combinations) for the item price.

Each item references one PRICE_FEATURE_GROUP. The exact price information is defined on item level.

The following rules for price feature groups or items apply:
- Neutral items, not depending on a price feature group, cannot have features
- for items, depending on features, settings in the fields feature type 1 (style) and optionally the variation type 101 (front colour 1) or 105 (front combination)are required.
- items depending on features require one or two feature types
- each item has to reference exactly one basic price group (ADDITIONAL_PRICE=0)

Similar combinations of feature types for different price feature groups are not permitted, e.g. there should be only one PRICE_FEATURE_GROUP with feature type handle variation, which covers everything having to do with handle variations.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
This attribute identifies a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
ADDITIONAL_PRICE required Restriction of xs:boolean
This attribute is used for defining the different price types, e.g. basic price or additional price. (0 = basic price, 1= additional price):
If an additional price group is defined (ADDITIONAL_PRICE=1), the option "price on request" is not permitted. For items which refer to this additional price group the element PRICE_ON_REQUEST (path 1) is not permitted.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_ON_REQUEST 		D boolean
P
M
PRICE_CALC_METHOD required Restriction of xs:nonNegativeInteger
This attribute is used for defining the basic price calculation method.

The following methods are defined:

0 = price on request;
1 = neutral item; price not depending on style or series
2 = price depending on style or series;
3 = price depending on finish.

A PRICE_FEATURE_GROUP which contains the value 0 (price on request) in the attribute PRICE_CALC_METHOD may occur only one time. 		D nonNegativeInteger
P
M [0:3]
FEATURE_NO_1 optional Restriction of xs:nonNegativeInteger
This attribute identifies the feature type 1.
The combination which is defined in the attribute OPTION_REF/FEATURE_NO may not differ from the settings in the attribute FEATURE_NO_1. 		D nonNegativeInteger
P
M [0:999]
FEATURE_NO_2 optional Restriction of xs:nonNegativeInteger
This attribute identifies the feature type 2.
The combination which is defined in the attribute OPTION_REF/FEATURE_NO may not differ from the settings in the attribute FEATURE_NO_2. 		D nonNegativeInteger
P
M [1:99999]
Sequence
PRICE_FEATURE_GROUP_TEXT languagetexte60 Complex Type
This element provides text information for the finish groups.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
FINISH 0..∞
This element is used for assigning price fields (price field, block price field) and the manufacturer price group to legal feature classes.

If the attribute PRICE_CALC_METHOD is set to 0 (price on request), the element FINISH is not permitted.
Sequence
OPTION_REF 0..2
This element is used to reference a option.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

This element is used for defining the price field in which the item price is saved. The corresponding price field has to be defined in the element ITEM_PRICE (path 1 or path 2).

If the same catalogue is used for different customer groups the assignment of price groups must not be changed. The same applies to correction files within the same cycle.

Element paths
path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

This field is used to specify in which price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer dies not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
This element contains the manufacturer's price group.

For prices which depend on series or finishes (PRICE_CALC_METHOD = 3) the value defined in the element PRICE_FIELD is copied to the element SUPPLIER_PRICE_GROUP.
For prices of neutral items (PRICE_CALC_METHOD = 1) values in this field are not taken into consideration. 		D string
P
M [1:10]
Attributes
Name Type Use Default Fixed Description
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
This attribute identifies a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
ADDITIONAL_PRICE Restriction of xs:boolean required
This attribute is used for defining the different price types, e.g. basic price or additional price. (0 = basic price, 1= additional price):
If an additional price group is defined (ADDITIONAL_PRICE=1), the option "price on request" is not permitted. For items which refer to this additional price group the element PRICE_ON_REQUEST (path 1) is not permitted.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_ON_REQUEST 		D boolean
P
M
PRICE_CALC_METHOD Restriction of xs:nonNegativeInteger required
This attribute is used for defining the basic price calculation method.

The following methods are defined:

0 = price on request;
1 = neutral item; price not depending on style or series
2 = price depending on style or series;
3 = price depending on finish.

A PRICE_FEATURE_GROUP which contains the value 0 (price on request) in the attribute PRICE_CALC_METHOD may occur only one time. 		D nonNegativeInteger
P
M [0:3]
FEATURE_NO_1 Restriction of xs:nonNegativeInteger optional
This attribute identifies the feature type 1.
The combination which is defined in the attribute OPTION_REF/FEATURE_NO may not differ from the settings in the attribute FEATURE_NO_1. 		D nonNegativeInteger
P
M [0:999]
FEATURE_NO_2 Restriction of xs:nonNegativeInteger optional
This attribute identifies the feature type 2.
The combination which is defined in the attribute OPTION_REF/FEATURE_NO may not differ from the settings in the attribute FEATURE_NO_2. 		D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>300--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
              <xs:annotation>
                <xs:documentation>311--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>311--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>311--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>311--5--Preisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="SUPPLIER_PRICE_GROUP">
              <xs:annotation>
                <xs:documentation>311--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="ADDITIONAL_PRICE" use="required">
      <xs:annotation>
        <xs:documentation>300--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:boolean" />
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="PRICE_CALC_METHOD" use="required">
      <xs:annotation>
        <xs:documentation>300--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_NO_1">
      <xs:annotation>
        <xs:documentation>300--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_NO_2">
      <xs:annotation>
        <xs:documentation>300--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element : PRICE_FEATURE_GROUP_TEXT Element
Description
This element provides text information for the finish groups.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence PRICE_FEATURE_GROUP_TEXT Element
Overview
PRICE_FEATURE_GROUP_TEXT languagetexte60 Complex Type
This element provides text information for the finish groups.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FINISH Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element : FINISH Element
Description
This element is used for assigning price fields (price field, block price field) and the manufacturer price group to legal feature classes.

If the attribute PRICE_CALC_METHOD is set to 0 (price on request), the element FINISH is not permitted.
Namespace (none)
Diagram
SUPPLIER_PRICE_GROUP Element BLOCK_PRICE_FIELD Element PRICE_FIELD Element OPTION_REF Element Sequence FINISH Element
Overview
FINISH 0..∞
This element is used for assigning price fields (price field, block price field) and the manufacturer price group to legal feature classes.

If the attribute PRICE_CALC_METHOD is set to 0 (price on request), the element FINISH is not permitted.
Sequence
OPTION_REF 0..2
This element is used to reference a option.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

This element is used for defining the price field in which the item price is saved. The corresponding price field has to be defined in the element ITEM_PRICE (path 1 or path 2).

If the same catalogue is used for different customer groups the assignment of price groups must not be changed. The same applies to correction files within the same cycle.

Element paths
path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

This field is used to specify in which price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer dies not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
This element contains the manufacturer's price group.

For prices which depend on series or finishes (PRICE_CALC_METHOD = 3) the value defined in the element PRICE_FIELD is copied to the element SUPPLIER_PRICE_GROUP.
For prices of neutral items (PRICE_CALC_METHOD = 1) values in this field are not taken into consideration. 		D string
P
M [1:10]
Source
<xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
        <xs:annotation>
          <xs:documentation>311--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>311--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>311--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>311--5--Preisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="SUPPLIER_PRICE_GROUP">
        <xs:annotation>
          <xs:documentation>311--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : OPTION_REF Element
Description
This element is used to reference a option.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF 0..2
This element is used to reference a option.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
This attribute is used for referencing a option. D string
P
M [1:5]
Source
<xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>311--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>311--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FIELD Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : PRICE_FIELD Element
Description

This element is used for defining the price field in which the item price is saved. The corresponding price field has to be defined in the element ITEM_PRICE (path 1 or path 2).

If the same catalogue is used for different customer groups the assignment of price groups must not be changed. The same applies to correction files within the same cycle.

Element paths
path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger

This element is used for defining the price field in which the item price is saved. The corresponding price field has to be defined in the element ITEM_PRICE (path 1 or path 2).

If the same catalogue is used for different customer groups the assignment of price groups must not be changed. The same applies to correction files within the same cycle.

Element paths
path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
Source
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--5--Preisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_PRICE_FIELD Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : BLOCK_PRICE_FIELD Element
Description

This field is used to specify in which price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer dies not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

 D nonNegativeInteger
P
M [1:250]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BLOCK_PRICE_FIELD Element
Overview
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

This field is used to specify in which price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer dies not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

 D nonNegativeInteger
P
M [1:250]
Source
<xs:element name="BLOCK_PRICE_FIELD" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUPPLIER_PRICE_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : SUPPLIER_PRICE_GROUP Element
Description
This element contains the manufacturer's price group.

For prices which depend on series or finishes (PRICE_CALC_METHOD = 3) the value defined in the element PRICE_FIELD is copied to the element SUPPLIER_PRICE_GROUP.
For prices of neutral items (PRICE_CALC_METHOD = 1) values in this field are not taken into consideration. 		D string
P
M [1:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
SUPPLIER_PRICE_GROUP Element
Overview
SUPPLIER_PRICE_GROUP Restriction of xs:string
This element contains the manufacturer's price group.

For prices which depend on series or finishes (PRICE_CALC_METHOD = 3) the value defined in the element PRICE_FIELD is copied to the element SUPPLIER_PRICE_GROUP.
For prices of neutral items (PRICE_CALC_METHOD = 1) values in this field are not taken into consideration. 		D string
P
M [1:10]
Source
<xs:element name="SUPPLIER_PRICE_GROUP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SET_OF_EXCHANGE_IDS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element : SET_OF_EXCHANGE_IDS Element
Description
This element defines the manufacturer specific ecxchange-IDs.

If blocks are available for one manufacturer, this element has to be defined in the catalogue file. This information is also required if the manufacturer is going to deliver blocks offside the general catalogue in the future. A block file must not contain this element.
Namespace (none)
Diagram
EXCHANGE_ID Element Sequence SET_OF_EXCHANGE_IDS Element
Overview
SET_OF_EXCHANGE_IDS optional
This element defines the manufacturer specific ecxchange-IDs.

If blocks are available for one manufacturer, this element has to be defined in the catalogue file. This information is also required if the manufacturer is going to deliver blocks offside the general catalogue in the future. A block file must not contain this element.
Sequence
EXCHANGE_ID 1..∞
The element EXCHANGE_ID (exchange-ID) is used as a key for the exchange groups. Freely defined values in the range between 1 and 89 are permitted.
Special exchange_IDs are defined as follows:
0 = exchange of item not permitted
98 = exchange of item with itself only.
99 = exchange of item with all other exchange-IDs permitted.
All utilized exchange-ID have to be defined in the data as well as the predefined special exchange-IDs.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
This element is used as a key for the exchange groups. Freely defined values in the range between 1 and 89 are permitted.
Special exchange_IDs are defined as follows:
0 = exchange of item not permitted
98 = exchange of item with itself only
99 = exchange of item with all other exchange-IDs permitted.
All utilized exchange-ID have to be defined in the data as well as the predefined special exchange-IDs.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Sequence
EXCHANGE_ID_TEXT languagetexte40 Complex Type
Additional information about the exchange group is provided in the field, e.g.:
- furniture
- worktops
- light pelmet/ cornice
- accesories
- electrical appliances
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Source
<xs:element name="SET_OF_EXCHANGE_IDS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>115--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>115--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_TEXT" type="languagetexte40">
              <xs:annotation>
                <xs:documentation>115--3--Tausch_ID_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>115--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > SET_OF_EXCHANGE_IDS Element : EXCHANGE_ID Element
Description
The element EXCHANGE_ID (exchange-ID) is used as a key for the exchange groups. Freely defined values in the range between 1 and 89 are permitted.
Special exchange_IDs are defined as follows:
0 = exchange of item not permitted
98 = exchange of item with itself only.
99 = exchange of item with all other exchange-IDs permitted.
All utilized exchange-ID have to be defined in the data as well as the predefined special exchange-IDs.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS.
Namespace (none)
Diagram
LANGUAGE Element Sequence EXCHANGE_ID_TEXT Element Sequence EXCHANGE_ID Element
Overview
EXCHANGE_ID 1..∞
The element EXCHANGE_ID (exchange-ID) is used as a key for the exchange groups. Freely defined values in the range between 1 and 89 are permitted.
Special exchange_IDs are defined as follows:
0 = exchange of item not permitted
98 = exchange of item with itself only.
99 = exchange of item with all other exchange-IDs permitted.
All utilized exchange-ID have to be defined in the data as well as the predefined special exchange-IDs.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
This element is used as a key for the exchange groups. Freely defined values in the range between 1 and 89 are permitted.
Special exchange_IDs are defined as follows:
0 = exchange of item not permitted
98 = exchange of item with itself only
99 = exchange of item with all other exchange-IDs permitted.
All utilized exchange-ID have to be defined in the data as well as the predefined special exchange-IDs.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Sequence
EXCHANGE_ID_TEXT languagetexte40 Complex Type
Additional information about the exchange group is provided in the field, e.g.:
- furniture
- worktops
- light pelmet/ cornice
- accesories
- electrical appliances
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Attributes
Name Type Use Default Fixed Description
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
This element is used as a key for the exchange groups. Freely defined values in the range between 1 and 89 are permitted.
Special exchange_IDs are defined as follows:
0 = exchange of item not permitted
98 = exchange of item with itself only
99 = exchange of item with all other exchange-IDs permitted.
All utilized exchange-ID have to be defined in the data as well as the predefined special exchange-IDs.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Source
<xs:element name="EXCHANGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>115--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_TEXT" type="languagetexte40">
        <xs:annotation>
          <xs:documentation>115--3--Tausch_ID_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>115--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_OF_EXCHANGE_IDS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > SET_OF_EXCHANGE_IDS Element > EXCHANGE_ID Element : EXCHANGE_ID_TEXT Element
Description
Additional information about the exchange group is provided in the field, e.g.:
- furniture
- worktops
- light pelmet/ cornice
- accesories
- electrical appliances
Namespace (none)
Type
languagetexte40 Complex Type
Diagram
LANGUAGE Element Sequence EXCHANGE_ID_TEXT Element
Overview
EXCHANGE_ID_TEXT languagetexte40 Complex Type
Additional information about the exchange group is provided in the field, e.g.:
- furniture
- worktops
- light pelmet/ cornice
- accesories
- electrical appliances
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Source
<xs:element name="EXCHANGE_ID_TEXT" type="languagetexte40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>115--3--Tausch_ID_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
EXCHANGE_ID Element | SET_OF_EXCHANGE_IDS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE_ADDED_TAXES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element : VALUE_ADDED_TAXES Element
Description
This element is used for defining the different rates of value added tax which are referenced by the items. The tax rates defined in this field have to correspond with the country defined in element COUNTRY_ID (path 1).

Element paths
path 1: CATALOG/CATALOG_IDENTIFICATIO
Namespace (none)
Diagram
VALUE_ADDED_TAX Element Sequence VALUE_ADDED_TAXES Element
Overview
VALUE_ADDED_TAXES
This element is used for defining the different rates of value added tax which are referenced by the items. The tax rates defined in this field have to correspond with the country defined in element COUNTRY_ID (path 1).

Element paths
path 1: CATALOG/CATALOG_IDENTIFICATIO
Sequence
VALUE_ADDED_TAX 1..100
This element defines a VAT rate.
VAT_NO required Restriction of xs:nonNegativeInteger
This attribute defines an ID for a VAT rate. The value 0 is reserved for those items which are not subject to VAT. D nonNegativeInteger
P
M [0:99]
Sequence
VAT_RATE Restriction of xs:nonNegativeInteger
This element defines the VAT rate in percent. The value is given with two decimal places, e.g. 1600 for 16,00 % oder 10 für 0,1%). D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="VALUE_ADDED_TAXES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>360--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="VALUE_ADDED_TAX" maxOccurs="100">
        <xs:annotation>
          <xs:documentation>360--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="VAT_RATE">
              <xs:annotation>
                <xs:documentation>360--3--MwSt_Satz</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="VAT_NO" use="required">
            <xs:annotation>
              <xs:documentation>360--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE_ADDED_TAX Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > VALUE_ADDED_TAXES Element : VALUE_ADDED_TAX Element
Description
This element defines a VAT rate.
Namespace (none)
Diagram
VAT_RATE Element Sequence VALUE_ADDED_TAX Element
Overview
VALUE_ADDED_TAX 1..100
This element defines a VAT rate.
VAT_NO required Restriction of xs:nonNegativeInteger
This attribute defines an ID for a VAT rate. The value 0 is reserved for those items which are not subject to VAT. D nonNegativeInteger
P
M [0:99]
Sequence
VAT_RATE Restriction of xs:nonNegativeInteger
This element defines the VAT rate in percent. The value is given with two decimal places, e.g. 1600 for 16,00 % oder 10 für 0,1%). D nonNegativeInteger
P
M [0:9999]
Attributes
Name Type Use Default Fixed Description
VAT_NO Restriction of xs:nonNegativeInteger required
This attribute defines an ID for a VAT rate. The value 0 is reserved for those items which are not subject to VAT. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="VALUE_ADDED_TAX" maxOccurs="100" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>360--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="VAT_RATE">
        <xs:annotation>
          <xs:documentation>360--3--MwSt_Satz</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="VAT_NO" use="required">
      <xs:annotation>
        <xs:documentation>360--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
VALUE_ADDED_TAXES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VAT_RATE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > VALUE_ADDED_TAXES Element > VALUE_ADDED_TAX Element : VAT_RATE Element
Description
This element defines the VAT rate in percent. The value is given with two decimal places, e.g. 1600 for 16,00 % oder 10 für 0,1%). D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
VAT_RATE Element
Overview
VAT_RATE Restriction of xs:nonNegativeInteger
This element defines the VAT rate in percent. The value is given with two decimal places, e.g. 1600 for 16,00 % oder 10 für 0,1%). D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="VAT_RATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>360--3--MwSt_Satz</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
VALUE_ADDED_TAX Element | VALUE_ADDED_TAXES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

IDENT_NUMBERS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element : IDENT_NUMBERS Element
Description
This element defines the ident numbers. All ident numbers used in a catalogue have to be defined here.
Namespace (none)
Diagram
IDENT_NUMBER Element Sequence IDENT_NUMBERS Element
Overview
IDENT_NUMBERS optional
This element defines the ident numbers. All ident numbers used in a catalogue have to be defined here.
Sequence
IDENT_NUMBER 0..9999
This element defines the ident numbers. All ident numbers used in a catalogue have to be defined here.
IDENT_NO required Restriction of xs:positiveInteger
This attribute is used to define an identifier. D positiveInteger
P
M [1:9999]
Sequence
SERIE_REF 1..99
This element references a series. If no series is referenced the ident numbers are valid globally.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
PRICE Restriction of xs:integer
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30,000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of EUR -9.00 is entered as -> -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_REF of the item does not contain an element for the corresponding price group. 		D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="IDENT_NUMBERS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>351--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="IDENT_NUMBER" minOccurs="0" maxOccurs="9999">
        <xs:annotation>
          <xs:documentation>351--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE_REF" maxOccurs="99">
              <xs:annotation>
                <xs:documentation>351--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>351--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE">
              <xs:annotation>
                <xs:documentation>351--4--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="IDENT_NO" use="required">
            <xs:annotation>
              <xs:documentation>351--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

IDENT_NUMBER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > IDENT_NUMBERS Element : IDENT_NUMBER Element
Description
This element defines the ident numbers. All ident numbers used in a catalogue have to be defined here.
Namespace (none)
Diagram
PRICE Element SERIE_REF Element Sequence IDENT_NUMBER Element
Overview
IDENT_NUMBER 0..9999
This element defines the ident numbers. All ident numbers used in a catalogue have to be defined here.
IDENT_NO required Restriction of xs:positiveInteger
This attribute is used to define an identifier. D positiveInteger
P
M [1:9999]
Sequence
SERIE_REF 1..99
This element references a series. If no series is referenced the ident numbers are valid globally.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
PRICE Restriction of xs:integer
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30,000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of EUR -9.00 is entered as -> -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_REF of the item does not contain an element for the corresponding price group. 		D nonNegativeInteger
P
M [0:99]
Attributes
Name Type Use Default Fixed Description
IDENT_NO Restriction of xs:positiveInteger required
This attribute is used to define an identifier. D positiveInteger
P
M [1:9999]
Source
<xs:element name="IDENT_NUMBER" minOccurs="0" maxOccurs="9999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>351--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE_REF" maxOccurs="99">
        <xs:annotation>
          <xs:documentation>351--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>351--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE">
        <xs:annotation>
          <xs:documentation>351--4--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="IDENT_NO" use="required">
      <xs:annotation>
        <xs:documentation>351--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
IDENT_NUMBERS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > IDENT_NUMBERS Element > IDENT_NUMBER Element : SERIE_REF Element
Description
This element references a series. If no series is referenced the ident numbers are valid globally.
Namespace (none)
Diagram
SERIE_REF Element
Overview
SERIE_REF 1..99
This element references a series. If no series is referenced the ident numbers are valid globally.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="SERIE_REF" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>351--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>351--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
IDENT_NUMBER Element | IDENT_NUMBERS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > IDENT_NUMBERS Element > IDENT_NUMBER Element : PRICE Element
Description
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30,000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of EUR -9.00 is entered as -> -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_REF of the item does not contain an element for the corresponding price group. 		D nonNegativeInteger
P
M [0:99]
Namespace (none)
Type
Restriction of xs:integer
Diagram
PRICE Element
Overview
PRICE Restriction of xs:integer
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30,000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of EUR -9.00 is entered as -> -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_REF of the item does not contain an element for the corresponding price group. 		D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="PRICE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>351--4--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
IDENT_NUMBER Element | IDENT_NUMBERS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MERCHANDISE_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element : MERCHANDISE_GROUP Element
Description
This element defines a merchandise group. The merchandise group and the assigned text information have to correspond with the calculation sheet of the manufacturer. For one merchandise group 1-n calculation groups can be defined.
Namespace (none)
Diagram
CALC_GROUP Element Sequence LANGUAGE Element Sequence MERCHANDISE_GROUP_TEXT Element Sequence MERCHANDISE_GROUP Element
Overview
MERCHANDISE_GROUP 1..∞
This element defines a merchandise group. The merchandise group and the assigned text information have to correspond with the calculation sheet of the manufacturer. For one merchandise group 1-n calculation groups can be defined.
MERCHANDISE_GROUP_NO required Restriction of xs:string
This attribute defines a merchandise group. D string
P
M [1:5]
Sequence
MERCHANDISE_GROUP_TEXT languagetexte30 Complex Type
This element provides text information about the merchandise groups.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Sequence
CALC_GROUP 1..∞

This element is used to define the possible calculation groups. It can be helpful when applying different discounts. This means that, depending on the number of discount scales, a corresponding number of calculation groups can be formed here. The element ITEM is used to allocate the items to a calculation group. Only calculation groups with referencing items must be defined. They key ist the CALC_GROUP_NO field.

If the same calculation group is used, the same price finding will also be used.

A calculation group can only be used once within all MERCHANDISE_GROUP elements. This means that a certain calculation group may only be used in a single MERCHANDISE_GROUP and not in multiple MERCHANDISE_GROUP elements.

The calculation group is specified via the CALC_GROUP_NO attribute.

CALC_GROUP_NO required Restriction of xs:positiveInteger

This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
8 = miscellaneous 1
9 = miscellaneous 2

Single-figure numbers (leading zeroes) are not allowed.
The calculation group does not correspond with the suppliers scales of conditions.

 D positiveInteger
P
M [10:99]
Sequence
CALC_GROUP_TEXT languagetexte30 Complex Type
This element contains text information for a calculation group.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
CALCULATION_FACTOR optional Restriction of xs:nonNegativeInteger
The use of this element is only permitted if the value 3 is set in the element PRICE_ID (path 1).

If calculation points are used the corresponding calculation factor has to be defined in this element.
The factor is given as a decimal figure with max. 5 decimal places before the point and exactly three decimal places after the point (the point itself does not count). The calculation factor has to be > 0.

Element paths
path 1: CATALOG/CATALOG_IDENTIFICATION 		D nonNegativeInteger
P
M [1:99999999]
Attributes
Name Type Use Default Fixed Description
MERCHANDISE_GROUP_NO Restriction of xs:string required
This attribute defines a merchandise group. D string
P
M [1:5]
Source
<xs:element name="MERCHANDISE_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>350--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MERCHANDISE_GROUP_TEXT" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>350--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>350--6--Warengruppentext</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:sequence>
        <xs:element name="CALC_GROUP" maxOccurs="unbounded">
          <xs:annotation>
            <xs:documentation>350--1--Satzart</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="CALC_GROUP_TEXT" type="languagetexte30">
                <xs:annotation>
                  <xs:documentation>350--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
              </xs:element>
              <xs:element name="CALCULATION_FACTOR" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>350--4--Verrechnungsfaktor</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="99999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="CALC_GROUP_NO" use="required">
              <xs:annotation>
                <xs:documentation>350--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="10" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:sequence>
    <xs:attribute name="MERCHANDISE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>350--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MERCHANDISE_GROUP_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > MERCHANDISE_GROUP Element : MERCHANDISE_GROUP_TEXT Element
Description
This element provides text information about the merchandise groups.
Namespace (none)
Type
languagetexte30 Complex Type
Diagram
LANGUAGE Element Sequence MERCHANDISE_GROUP_TEXT Element
Overview
MERCHANDISE_GROUP_TEXT languagetexte30 Complex Type
This element provides text information about the merchandise groups.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="MERCHANDISE_GROUP_TEXT" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>350--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>350--6--Warengruppentext</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
MERCHANDISE_GROUP Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CALC_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > MERCHANDISE_GROUP Element : CALC_GROUP Element
Description

This element is used to define the possible calculation groups. It can be helpful when applying different discounts. This means that, depending on the number of discount scales, a corresponding number of calculation groups can be formed here. The element ITEM is used to allocate the items to a calculation group. Only calculation groups with referencing items must be defined. They key ist the CALC_GROUP_NO field.

If the same calculation group is used, the same price finding will also be used.

A calculation group can only be used once within all MERCHANDISE_GROUP elements. This means that a certain calculation group may only be used in a single MERCHANDISE_GROUP and not in multiple MERCHANDISE_GROUP elements.

The calculation group is specified via the CALC_GROUP_NO attribute.

Namespace (none)
Diagram
CALCULATION_FACTOR Element LANGUAGE Element Sequence CALC_GROUP_TEXT Element Sequence CALC_GROUP Element
Overview
CALC_GROUP 1..∞

This element is used to define the possible calculation groups. It can be helpful when applying different discounts. This means that, depending on the number of discount scales, a corresponding number of calculation groups can be formed here. The element ITEM is used to allocate the items to a calculation group. Only calculation groups with referencing items must be defined. They key ist the CALC_GROUP_NO field.

If the same calculation group is used, the same price finding will also be used.

A calculation group can only be used once within all MERCHANDISE_GROUP elements. This means that a certain calculation group may only be used in a single MERCHANDISE_GROUP and not in multiple MERCHANDISE_GROUP elements.

The calculation group is specified via the CALC_GROUP_NO attribute.

CALC_GROUP_NO required Restriction of xs:positiveInteger

This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
8 = miscellaneous 1
9 = miscellaneous 2

Single-figure numbers (leading zeroes) are not allowed.
The calculation group does not correspond with the suppliers scales of conditions.

 D positiveInteger
P
M [10:99]
Sequence
CALC_GROUP_TEXT languagetexte30 Complex Type
This element contains text information for a calculation group.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
CALCULATION_FACTOR optional Restriction of xs:nonNegativeInteger
The use of this element is only permitted if the value 3 is set in the element PRICE_ID (path 1).

If calculation points are used the corresponding calculation factor has to be defined in this element.
The factor is given as a decimal figure with max. 5 decimal places before the point and exactly three decimal places after the point (the point itself does not count). The calculation factor has to be > 0.

Element paths
path 1: CATALOG/CATALOG_IDENTIFICATION 		D nonNegativeInteger
P
M [1:99999999]
Attributes
Name Type Use Default Fixed Description
CALC_GROUP_NO Restriction of xs:positiveInteger required

This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
8 = miscellaneous 1
9 = miscellaneous 2

Single-figure numbers (leading zeroes) are not allowed.
The calculation group does not correspond with the suppliers scales of conditions.

 D positiveInteger
P
M [10:99]
Source
<xs:element name="CALC_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>350--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CALC_GROUP_TEXT" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>350--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CALCULATION_FACTOR" minOccurs="0">
        <xs:annotation>
          <xs:documentation>350--4--Verrechnungsfaktor</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="CALC_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>350--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="10" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
MERCHANDISE_GROUP Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CALC_GROUP_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > MERCHANDISE_GROUP Element > CALC_GROUP Element : CALC_GROUP_TEXT Element
Description
This element contains text information for a calculation group.
Namespace (none)
Type
languagetexte30 Complex Type
Diagram
LANGUAGE Element Sequence CALC_GROUP_TEXT Element
Overview
CALC_GROUP_TEXT languagetexte30 Complex Type
This element contains text information for a calculation group.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="CALC_GROUP_TEXT" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>350--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CALC_GROUP Element | MERCHANDISE_GROUP Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CALCULATION_FACTOR Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > MERCHANDISE_GROUP Element > CALC_GROUP Element : CALCULATION_FACTOR Element
Description
The use of this element is only permitted if the value 3 is set in the element PRICE_ID (path 1).

If calculation points are used the corresponding calculation factor has to be defined in this element.
The factor is given as a decimal figure with max. 5 decimal places before the point and exactly three decimal places after the point (the point itself does not count). The calculation factor has to be > 0.

Element paths
path 1: CATALOG/CATALOG_IDENTIFICATION 		D nonNegativeInteger
P
M [1:99999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
CALCULATION_FACTOR Element
Overview
CALCULATION_FACTOR optional Restriction of xs:nonNegativeInteger
The use of this element is only permitted if the value 3 is set in the element PRICE_ID (path 1).

If calculation points are used the corresponding calculation factor has to be defined in this element.
The factor is given as a decimal figure with max. 5 decimal places before the point and exactly three decimal places after the point (the point itself does not count). The calculation factor has to be > 0.

Element paths
path 1: CATALOG/CATALOG_IDENTIFICATION 		D nonNegativeInteger
P
M [1:99999999]
Source
<xs:element name="CALCULATION_FACTOR" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>350--4--Verrechnungsfaktor</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CALC_GROUP Element | MERCHANDISE_GROUP Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_TYPES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element : PRICE_TYPES Element
Description
This element is used for defining the different price types. Neutral as well as model specific items can be charged per piece or depending on certain measurements.
The child elements WIDTH_X, DEPTH_Y, HEIGHT_Z define that the price of an item depends on width, height, depth, surface or volume.
If the value "1" is not entered for any of the dimensions, the price is calculated per piece (e.g. base cabinet) and not depending on measurements. In this case the elements BASIC_UNIT and ROUNDING_UNIT have to be filled in with "0".
In case one dimension field is filled in with "1" , the price calculation is based on this dimension (e.g. light pelmets).
If the value "1" is filled in into two dimension fields, the price will be calculated depending on the surface of the item (e.g. cladding material).
The price calculation is based on volume, in case three dimension fields are filled with the value "1" (e.g. lacquer, stain).
Namespace (none)
Diagram
PRICE_TYPE Element Sequence PRICE_TYPES Element
Overview
PRICE_TYPES
This element is used for defining the different price types. Neutral as well as model specific items can be charged per piece or depending on certain measurements.
The child elements WIDTH_X, DEPTH_Y, HEIGHT_Z define that the price of an item depends on width, height, depth, surface or volume.
If the value "1" is not entered for any of the dimensions, the price is calculated per piece (e.g. base cabinet) and not depending on measurements. In this case the elements BASIC_UNIT and ROUNDING_UNIT have to be filled in with "0".
In case one dimension field is filled in with "1" , the price calculation is based on this dimension (e.g. light pelmets).
If the value "1" is filled in into two dimension fields, the price will be calculated depending on the surface of the item (e.g. cladding material).
The price calculation is based on volume, in case three dimension fields are filled with the value "1" (e.g. lacquer, stain).
Sequence 1..∞
PRICE_TYPE
This element defines a price type.
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type unambiguously. D positiveInteger
P
M [1:250]
Sequence
WIDTH_X Restriction of xs:boolean
If the calculated price is depending on the width of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
DEPTH_Y Restriction of xs:boolean
If the calculated price is depending on the depth of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
HEIGHT_Z Restriction of xs:boolean
If the calculated price is depending on the height of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
BASIC_UNIT Restriction of xs:nonNegativeInteger
The field basic unit (BASIC_UNIT) indicatea the dimension to which the prices in the elements ITEM_PRICE (path1) and ADDITIONAL_PRICE (path2) refer.
The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm². If an item price depending on width is calculated per metre, the value "1000" has to be filled in into the field basic_unit, If the price calculation of an item is based on volume and the calculation unit is 1 m³, the value in the field basic_unit has to be "1000000000" [mm³]. If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0".

path1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/
path2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
The element rounding unit (ROUNDING_UNIT) indicates the measurement to which length, surface or volume are rounded up. The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm³. If an item price depending on width is rounded up to full centimeters, the value filled in here has to be "10". If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0". D nonNegativeInteger
P
M [0:999999999999]
BASIC_PRICE_DEPENDENT Restriction of xs:boolean
A basic price and a corresponding price unit can be defined for those items which are calculated depending on dimensions. No basic price is taken into account, if the value in this field is "0".

The element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC defines the current basic
price of an item. The element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT indicates the corresponding basic price unit.

The element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE defines the remaining measurement price, which refers to the element BASIC_UNIT.
In case the option BASIC_PRICE_DEPENDENT has been defined for an item, the definition of a minimum price is not permitted. The total price of an item is always calculated on the BASIC_PRICE and the additional REMAINDER_PRICE, taking into account the rules defined in this element.

The total item price is calculated according to the following scheme:
The basic price unit is subtracted from the total item price. The result of this operation is the remainder.
The calculation of the total item price is based on the rules defined in the element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE. In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0. 		D boolean
P
M
PRICE_TYPE_FORMULA optional Restriction of xs:string
It is possible to define formulas for price calculation (PRICE_TYPE), but these formulas must not be defined for standard calculation price types, i.e. calculation per m² or m³.
The following rules for the definition of price formulas apply:
- Formula parameters b, h and t can be used. Parameters b, h, t correspond to the parameters b, h and t of the basic shapes. Depending on the used parameters b, h, t the corresponding Boolean field WIDTH_X (P1) (b), DEPTH_Y (P1) (t) or HEIGHT_Z (P1) (h) has to be set to true:
- Basic arithmetic operations addition (+), subtraction (-), multiplication (*) and division (/) can be applied;
- rules of parentheses may be applied;
- Algebraic signs must not be used;
- only the final result is rounded;
- All rules of the elements BASIC_UNIT (P1), ROUNDING_UNIT (P1), and BASIC_PRICE_DEPENDENT (P1) also apply in combination with the field PRICE_TYPE_FORMULA

P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
PRICE_TYPE_NAME optional languagetexte60 Complex Type
This field contains a denotation for the defined price_type.
This denotation is used to simplify the data acquisition for communication purposes. This denotation is not evaluated in the processing software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="PRICE_TYPES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence maxOccurs="unbounded">
      <xs:element name="PRICE_TYPE">
        <xs:annotation>
          <xs:documentation>150--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="WIDTH_X">
              <xs:annotation>
                <xs:documentation>150--3--Breite_X</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="DEPTH_Y">
              <xs:annotation>
                <xs:documentation>150--4--Tiefe_Y</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEIGHT_Z">
              <xs:annotation>
                <xs:documentation>150--5--Hoehe_Z</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_UNIT">
              <xs:annotation>
                <xs:documentation>150--6--Basis_Einheit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ROUNDING_UNIT">
              <xs:annotation>
                <xs:documentation>150--7--Rundungseinheit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_PRICE_DEPENDENT">
              <xs:annotation>
                <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
              <xs:annotation>
                <xs:documentation>150--9--Preisart_Formel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="100" />
                  <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_TYPE_NAME" type="languagetexte60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="250" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element : PRICE_TYPE Element
Description
This element defines a price type.
Namespace (none)
Diagram
LANGUAGE Element Sequence PRICE_TYPE_NAME Element PRICE_TYPE_FORMULA Element BASIC_PRICE_DEPENDENT Element ROUNDING_UNIT Element BASIC_UNIT Element HEIGHT_Z Element DEPTH_Y Element WIDTH_X Element Sequence PRICE_TYPE Element
Overview
PRICE_TYPE
This element defines a price type.
PRICE_TYPE_NO required Restriction of xs:positiveInteger
This attribute identifies a price type unambiguously. D positiveInteger
P
M [1:250]
Sequence
WIDTH_X Restriction of xs:boolean
If the calculated price is depending on the width of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
DEPTH_Y Restriction of xs:boolean
If the calculated price is depending on the depth of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
HEIGHT_Z Restriction of xs:boolean
If the calculated price is depending on the height of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
BASIC_UNIT Restriction of xs:nonNegativeInteger
The field basic unit (BASIC_UNIT) indicatea the dimension to which the prices in the elements ITEM_PRICE (path1) and ADDITIONAL_PRICE (path2) refer.
The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm². If an item price depending on width is calculated per metre, the value "1000" has to be filled in into the field basic_unit, If the price calculation of an item is based on volume and the calculation unit is 1 m³, the value in the field basic_unit has to be "1000000000" [mm³]. If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0".

path1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/
path2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
The element rounding unit (ROUNDING_UNIT) indicates the measurement to which length, surface or volume are rounded up. The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm³. If an item price depending on width is rounded up to full centimeters, the value filled in here has to be "10". If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0". D nonNegativeInteger
P
M [0:999999999999]
BASIC_PRICE_DEPENDENT Restriction of xs:boolean
A basic price and a corresponding price unit can be defined for those items which are calculated depending on dimensions. No basic price is taken into account, if the value in this field is "0".

The element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC defines the current basic
price of an item. The element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT indicates the corresponding basic price unit.

The element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE defines the remaining measurement price, which refers to the element BASIC_UNIT.
In case the option BASIC_PRICE_DEPENDENT has been defined for an item, the definition of a minimum price is not permitted. The total price of an item is always calculated on the BASIC_PRICE and the additional REMAINDER_PRICE, taking into account the rules defined in this element.

The total item price is calculated according to the following scheme:
The basic price unit is subtracted from the total item price. The result of this operation is the remainder.
The calculation of the total item price is based on the rules defined in the element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE. In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0. 		D boolean
P
M
PRICE_TYPE_FORMULA optional Restriction of xs:string
It is possible to define formulas for price calculation (PRICE_TYPE), but these formulas must not be defined for standard calculation price types, i.e. calculation per m² or m³.
The following rules for the definition of price formulas apply:
- Formula parameters b, h and t can be used. Parameters b, h, t correspond to the parameters b, h and t of the basic shapes. Depending on the used parameters b, h, t the corresponding Boolean field WIDTH_X (P1) (b), DEPTH_Y (P1) (t) or HEIGHT_Z (P1) (h) has to be set to true:
- Basic arithmetic operations addition (+), subtraction (-), multiplication (*) and division (/) can be applied;
- rules of parentheses may be applied;
- Algebraic signs must not be used;
- only the final result is rounded;
- All rules of the elements BASIC_UNIT (P1), ROUNDING_UNIT (P1), and BASIC_PRICE_DEPENDENT (P1) also apply in combination with the field PRICE_TYPE_FORMULA

P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
PRICE_TYPE_NAME optional languagetexte60 Complex Type
This field contains a denotation for the defined price_type.
This denotation is used to simplify the data acquisition for communication purposes. This denotation is not evaluated in the processing software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
PRICE_TYPE_NO Restriction of xs:positiveInteger required
This attribute identifies a price type unambiguously. D positiveInteger
P
M [1:250]
Source
<xs:element name="PRICE_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="WIDTH_X">
        <xs:annotation>
          <xs:documentation>150--3--Breite_X</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="DEPTH_Y">
        <xs:annotation>
          <xs:documentation>150--4--Tiefe_Y</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT_Z">
        <xs:annotation>
          <xs:documentation>150--5--Hoehe_Z</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_UNIT">
        <xs:annotation>
          <xs:documentation>150--6--Basis_Einheit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ROUNDING_UNIT">
        <xs:annotation>
          <xs:documentation>150--7--Rundungseinheit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_PRICE_DEPENDENT">
        <xs:annotation>
          <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
        <xs:annotation>
          <xs:documentation>150--9--Preisart_Formel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="100" />
            <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_TYPE_NAME" type="languagetexte60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="250" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WIDTH_X Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : WIDTH_X Element
Description
If the calculated price is depending on the width of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
WIDTH_X Element
Overview
WIDTH_X Restriction of xs:boolean
If the calculated price is depending on the width of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
Source
<xs:element name="WIDTH_X" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--3--Breite_X</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEPTH_Y Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : DEPTH_Y Element
Description
If the calculated price is depending on the depth of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
DEPTH_Y Element
Overview
DEPTH_Y Restriction of xs:boolean
If the calculated price is depending on the depth of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
Source
<xs:element name="DEPTH_Y" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--4--Tiefe_Y</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEIGHT_Z Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : HEIGHT_Z Element
Description
If the calculated price is depending on the height of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
HEIGHT_Z Element
Overview
HEIGHT_Z Restriction of xs:boolean
If the calculated price is depending on the height of an item, the value 1 has to be set in this field, otherwise the field is set to 0. D boolean
P
M
Source
<xs:element name="HEIGHT_Z" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--5--Hoehe_Z</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_UNIT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : BASIC_UNIT Element
Description
The field basic unit (BASIC_UNIT) indicatea the dimension to which the prices in the elements ITEM_PRICE (path1) and ADDITIONAL_PRICE (path2) refer.
The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm². If an item price depending on width is calculated per metre, the value "1000" has to be filled in into the field basic_unit, If the price calculation of an item is based on volume and the calculation unit is 1 m³, the value in the field basic_unit has to be "1000000000" [mm³]. If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0".

path1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/
path2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BASIC_UNIT Element
Overview
BASIC_UNIT Restriction of xs:nonNegativeInteger
The field basic unit (BASIC_UNIT) indicatea the dimension to which the prices in the elements ITEM_PRICE (path1) and ADDITIONAL_PRICE (path2) refer.
The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm². If an item price depending on width is calculated per metre, the value "1000" has to be filled in into the field basic_unit, If the price calculation of an item is based on volume and the calculation unit is 1 m³, the value in the field basic_unit has to be "1000000000" [mm³]. If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0".

path1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/
path2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
Source
<xs:element name="BASIC_UNIT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--6--Basis_Einheit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ROUNDING_UNIT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : ROUNDING_UNIT Element
Description
The element rounding unit (ROUNDING_UNIT) indicates the measurement to which length, surface or volume are rounded up. The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm³. If an item price depending on width is rounded up to full centimeters, the value filled in here has to be "10". If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0". D nonNegativeInteger
P
M [0:999999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
ROUNDING_UNIT Element
Overview
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
The element rounding unit (ROUNDING_UNIT) indicates the measurement to which length, surface or volume are rounded up. The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm³. If an item price depending on width is rounded up to full centimeters, the value filled in here has to be "10". If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0". D nonNegativeInteger
P
M [0:999999999999]
Source
<xs:element name="ROUNDING_UNIT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--7--Rundungseinheit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_PRICE_DEPENDENT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : BASIC_PRICE_DEPENDENT Element
Description
A basic price and a corresponding price unit can be defined for those items which are calculated depending on dimensions. No basic price is taken into account, if the value in this field is "0".

The element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC defines the current basic
price of an item. The element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT indicates the corresponding basic price unit.

The element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE defines the remaining measurement price, which refers to the element BASIC_UNIT.
In case the option BASIC_PRICE_DEPENDENT has been defined for an item, the definition of a minimum price is not permitted. The total price of an item is always calculated on the BASIC_PRICE and the additional REMAINDER_PRICE, taking into account the rules defined in this element.

The total item price is calculated according to the following scheme:
The basic price unit is subtracted from the total item price. The result of this operation is the remainder.
The calculation of the total item price is based on the rules defined in the element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE. In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0. 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
BASIC_PRICE_DEPENDENT Element
Overview
BASIC_PRICE_DEPENDENT Restriction of xs:boolean
A basic price and a corresponding price unit can be defined for those items which are calculated depending on dimensions. No basic price is taken into account, if the value in this field is "0".

The element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC defines the current basic
price of an item. The element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT indicates the corresponding basic price unit.

The element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE defines the remaining measurement price, which refers to the element BASIC_UNIT.
In case the option BASIC_PRICE_DEPENDENT has been defined for an item, the definition of a minimum price is not permitted. The total price of an item is always calculated on the BASIC_PRICE and the additional REMAINDER_PRICE, taking into account the rules defined in this element.

The total item price is calculated according to the following scheme:
The basic price unit is subtracted from the total item price. The result of this operation is the remainder.
The calculation of the total item price is based on the rules defined in the element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE. In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0. 		D boolean
P
M
Source
<xs:element name="BASIC_PRICE_DEPENDENT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_TYPE_FORMULA Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : PRICE_TYPE_FORMULA Element
Description
It is possible to define formulas for price calculation (PRICE_TYPE), but these formulas must not be defined for standard calculation price types, i.e. calculation per m² or m³.
The following rules for the definition of price formulas apply:
- Formula parameters b, h and t can be used. Parameters b, h, t correspond to the parameters b, h and t of the basic shapes. Depending on the used parameters b, h, t the corresponding Boolean field WIDTH_X (P1) (b), DEPTH_Y (P1) (t) or HEIGHT_Z (P1) (h) has to be set to true:
- Basic arithmetic operations addition (+), subtraction (-), multiplication (*) and division (/) can be applied;
- rules of parentheses may be applied;
- Algebraic signs must not be used;
- only the final result is rounded;
- All rules of the elements BASIC_UNIT (P1), ROUNDING_UNIT (P1), and BASIC_PRICE_DEPENDENT (P1) also apply in combination with the field PRICE_TYPE_FORMULA

P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
Namespace (none)
Type
Restriction of xs:string
Diagram
PRICE_TYPE_FORMULA Element
Overview
PRICE_TYPE_FORMULA optional Restriction of xs:string
It is possible to define formulas for price calculation (PRICE_TYPE), but these formulas must not be defined for standard calculation price types, i.e. calculation per m² or m³.
The following rules for the definition of price formulas apply:
- Formula parameters b, h and t can be used. Parameters b, h, t correspond to the parameters b, h and t of the basic shapes. Depending on the used parameters b, h, t the corresponding Boolean field WIDTH_X (P1) (b), DEPTH_Y (P1) (t) or HEIGHT_Z (P1) (h) has to be set to true:
- Basic arithmetic operations addition (+), subtraction (-), multiplication (*) and division (/) can be applied;
- rules of parentheses may be applied;
- Algebraic signs must not be used;
- only the final result is rounded;
- All rules of the elements BASIC_UNIT (P1), ROUNDING_UNIT (P1), and BASIC_PRICE_DEPENDENT (P1) also apply in combination with the field PRICE_TYPE_FORMULA

P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
Source
<xs:element name="PRICE_TYPE_FORMULA" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--9--Preisart_Formel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="100" />
      <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_TYPE_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : PRICE_TYPE_NAME Element
Description
This field contains a denotation for the defined price_type.
This denotation is used to simplify the data acquisition for communication purposes. This denotation is not evaluated in the processing software.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence PRICE_TYPE_NAME Element
Overview
PRICE_TYPE_NAME optional languagetexte60 Complex Type
This field contains a denotation for the defined price_type.
This denotation is used to simplify the data acquisition for communication purposes. This denotation is not evaluated in the processing software.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="PRICE_TYPE_NAME" type="languagetexte60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_VALUE_CALCULATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : BLOCK_VALUE_CALCULATION Element
Description
This element is used for defining the rules which apply to block calculation and value clearing.
Namespace (none)
Diagram
SET_OF_BLOCK_RULES Element GRADING_TABLE Element BLOCK_SALE_PRICES Element BLOCK_CONDITIONS Element Sequence BLOCK_VALUE_CALCULATION Element
Overview
BLOCK_VALUE_CALCULATION optional
This element is used for defining the rules which apply to block calculation and value clearing.
Sequence
BLOCK_CONDITIONS optional
This element contains special conditions for the block calculation. Only if a block corresponds with these conditions it can be applied to a certain commission. Rules defined here apply to the value clearing system (value clearing block) as well as to block calculation (item block).

A block may only be applied to a commission,if all conditions for this special block are fulfilled. A tuple, consisting of the fields ITEM_REF (path 1) and OPERATION_ID (path 2), defines the conditions which refer to a certain block.

Basic condition for the correct application of block conditions is, that a block exists in one of the ranges which have been planned in one commission. In case different ranges have been planned in one commission, the first range which appears in the header data is considered as reference.

The settings and definitions of range- and variation controls apply to blocks in the same way as to “ordinary” items. The price information 0 in the element ITEM_PRICE (path 2) indicates that the value clearing block exists in a certain price group.

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

path 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE
Sequence
BLOCK_CONDITION 1..∞
This element contains a condition which is used for validating a block, i.e. checking if a block price can be applied to a commission. This element is valid for clearing blocks and block calculation.
Sequence
ITEM_REF
This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.
Sequence
CONDITION_RULE 1..∞
This element is used for defining block conditions.
Sequence
CLEARING_GROUP_REF 1..999
This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
BLOCK_SALE_PRICES optional
This element is used for defining block sale prices.
Sequence
BLOCK_SALE_PRICE 1..∞
Block sale prices, which are only valid for various limited periods, are defined in this element. This element may be used only, if certain block prices are valid for more than one limited period within one catalogue period. Blocks, which are only available within one coherent period, are defined by the elements VALID_FROM (path 1) and /VALID_UNTIL (path 1).

A price defined in this element has precedence over the price defined in the general price field.
The variation combinations defined in this element have priority over the item specific control procedures.

Overlapping dates in the defined periods of block sale prices are not permitted.
Information provided in this element does not override information from other elements but abrogates it temporarily.
The combination of those pieces of information which are concerned, is defined in this element. All other combinations are still valid!

The validity dates of a block defined in this element have to differ from those defined in the elements VALID_FROM (path 1) and /VALID_UNTIL.
A block sale price is defined for a certain range within a certain period of time. The block sale price entered in this element must not override the “normal” block price in this pricegroup because other ranges may refer to that price, too.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Sequence
ITEM_REF
This element is used for referencing an item for which a block sale price has been defined.
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
This element is used for defining block sale conditions.
Sequence
VALID_FROM Restriction of xs:date
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM. D date
P
M
VALID_UNTIL Restriction of xs:date
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM. D date
P
M
OPTION_REF 0..4
This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself). D nonNegativeInteger
P
M [0:999999999]
GRADING_TABLE optional

This element is used for defining grading tables containing the surcharges or the credits which are used in the value clearing system.

A clearing block, which is valid for a certain commission, can be used as reference for the grading table. A reference amount is set up for each data record of this record type, to which the valid clearing block belongs CLEARING_GROUP (path 1). This amount is compared to the given amount of the clearing group. If the reference value corresponds with the given grading range (elements VALUE_FROM (path2) and VALUE_TO (path 2), the data record is applied. In this case the settings in the field TYPE_CREDIT (path 2) and/ or TYPE_DEBIT (path 2) are applied. The calculation is based on the amount of the calculation group, which is defined for type_credit or type_surcharge (element ITEM (path 3)).

Different grading ranges can be defined for one block. A freely defined operation_ID is assigned to each grading range COMPARING_RULES (path 4). Different grading ranges with the same operation_ID may appear within one grading range of a clearing block. In this case the conditions of all grading ranges with their corresponding clearing group have to be fulfilled, so that the value clearing system can be applied to the different items of the commission. Single data records are linked by an AND-operation (COMPARING_RULE).

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

In case several data records of a clearing block are applied in the GRADING_TABLE, the value of the block (ITEM (path 3)), ITEM_PRICE (path 5)) is calculated only one time.

path 1: GLOBAL_DEFINITION
path 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
path 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence
CREDIT_SURCHARGE_CLEARING 1..∞
This element defines value range for a grading table.
Sequence
ITEM_REF

This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.
Sequence
COMPARING_RULE 1..∞
This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
SET_OF_BLOCK_RULES
The manufacturer specific rules are defined in this element and the in the child elements.
Sequence
EXCHANGE_ID_GROUP 1..∞
This element is used for defining the exchange groups. If exchange-ID 1 (EXCHANGE_ID_1_REF) may be exchanged with exchange-ID 2 (EXCHANGE_ID_2_REF) and vice versa this has to be defined explicitly.
If items with the same exchange_ID can be exchanged 1 by 1 a special data record for this exchange has to be defined.
Sequence
EXCHANGE_ID_1_REF
The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS . The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RULE 1..99
This element defines a manufacturer specific set of rules.
RULE_NO required Restriction of xs:nonNegativeInteger
This attribute defines a counter from 1-99 for the manufacturer specific block rules. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
This element defines the criteria for exchanges in the block processing.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
RULE_SET_TEXT languagetexte60999 Complex Type
This element contains text information and explanations for the set of rules.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Remarks

Source
<xs:element name="BLOCK_VALUE_CALCULATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_CONDITIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>420--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_CONDITION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>420--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>420--3--Type_Block</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>420--3--Type_Block</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>420--3--Type_Block</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CONDITION_RULES">
                    <xs:annotation>
                      <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>420--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                                <xs:annotation>
                                  <xs:documentation>420--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="CLEARING_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>420--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:choice>
                                <xs:element name="MINIMUM_VALUE" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:choice>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BLOCK_SALE_PRICES" minOccurs="0">
        <xs:annotation>
          <xs:documentation>480--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>480--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>480--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>480--100--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="VALID_FROM">
                          <xs:annotation>
                            <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL">
                          <xs:annotation>
                            <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
                          <xs:annotation>
                            <xs:documentation>480--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_OR_CALCULATION_POINT">
                          <xs:annotation>
                            <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="GRADING_TABLE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>421--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>421--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>421--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>421--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>421--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>421--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CLEARING_GROUP_ID">
                                <xs:annotation>
                                  <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE_FROM">
                                <xs:annotation>
                                  <xs:documentation>421--6--Wert_von</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE_TO">
                                <xs:annotation>
                                  <xs:documentation>421--7--Wert_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TYPE_CREDIT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TYPE_DEBIT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>421--9--Type_Belastung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_OF_BLOCK_RULES">
        <xs:annotation>
          <xs:documentation>111--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>117--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_1_REF">
                    <xs:annotation>
                      <xs:documentation>117--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>117--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="EXCHANGE_ID_2_REF">
                    <xs:annotation>
                      <xs:documentation>117--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>117--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RULE" maxOccurs="99">
              <xs:annotation>
                <xs:documentation>111--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RULE_TEXT" type="languagetexte60999">
                    <xs:annotation>
                      <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="RULE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>113--3--Regel_Nr</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="RULE_SET_TEXT" type="languagetexte60999">
              <xs:annotation>
                <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_CONDITIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element : BLOCK_CONDITIONS Element
Description
This element contains special conditions for the block calculation. Only if a block corresponds with these conditions it can be applied to a certain commission. Rules defined here apply to the value clearing system (value clearing block) as well as to block calculation (item block).

A block may only be applied to a commission,if all conditions for this special block are fulfilled. A tuple, consisting of the fields ITEM_REF (path 1) and OPERATION_ID (path 2), defines the conditions which refer to a certain block.

Basic condition for the correct application of block conditions is, that a block exists in one of the ranges which have been planned in one commission. In case different ranges have been planned in one commission, the first range which appears in the header data is considered as reference.

The settings and definitions of range- and variation controls apply to blocks in the same way as to “ordinary” items. The price information 0 in the element ITEM_PRICE (path 2) indicates that the value clearing block exists in a certain price group.

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

path 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE
Namespace (none)
Diagram
BLOCK_CONDITION Element Sequence BLOCK_CONDITIONS Element
Overview
BLOCK_CONDITIONS optional
This element contains special conditions for the block calculation. Only if a block corresponds with these conditions it can be applied to a certain commission. Rules defined here apply to the value clearing system (value clearing block) as well as to block calculation (item block).

A block may only be applied to a commission,if all conditions for this special block are fulfilled. A tuple, consisting of the fields ITEM_REF (path 1) and OPERATION_ID (path 2), defines the conditions which refer to a certain block.

Basic condition for the correct application of block conditions is, that a block exists in one of the ranges which have been planned in one commission. In case different ranges have been planned in one commission, the first range which appears in the header data is considered as reference.

The settings and definitions of range- and variation controls apply to blocks in the same way as to “ordinary” items. The price information 0 in the element ITEM_PRICE (path 2) indicates that the value clearing block exists in a certain price group.

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

path 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE
Sequence
BLOCK_CONDITION 1..∞
This element contains a condition which is used for validating a block, i.e. checking if a block price can be applied to a commission. This element is valid for clearing blocks and block calculation.
Sequence
ITEM_REF
This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.
Sequence
CONDITION_RULE 1..∞
This element is used for defining block conditions.
Sequence
CLEARING_GROUP_REF 1..999
This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="BLOCK_CONDITIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_CONDITION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>420--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>420--3--Type_Block</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>420--3--Type_Block</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>420--3--Type_Block</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CONDITION_RULES">
              <xs:annotation>
                <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>420--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                          <xs:annotation>
                            <xs:documentation>420--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="CLEARING_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>420--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:choice>
                          <xs:element name="MINIMUM_VALUE" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="999999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:choice>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_CONDITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element : BLOCK_CONDITION Element
Description
This element contains a condition which is used for validating a block, i.e. checking if a block price can be applied to a commission. This element is valid for clearing blocks and block calculation.
Namespace (none)
Diagram
CONDITION_RULES Element ITEM_REF Element Sequence BLOCK_CONDITION Element
Overview
BLOCK_CONDITION 1..∞
This element contains a condition which is used for validating a block, i.e. checking if a block price can be applied to a commission. This element is valid for clearing blocks and block calculation.
Sequence
ITEM_REF
This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.
Sequence
CONDITION_RULE 1..∞
This element is used for defining block conditions.
Sequence
CLEARING_GROUP_REF 1..999
This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="BLOCK_CONDITION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>420--3--Type_Block</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>420--3--Type_Block</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>420--3--Type_Block</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CONDITION_RULES">
        <xs:annotation>
          <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>420--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                    <xs:annotation>
                      <xs:documentation>420--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="CLEARING_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>420--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:choice>
                    <xs:element name="MINIMUM_VALUE" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="999999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:choice>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element : ITEM_REF Element
Description
This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF
This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Attributes
Name Type Use Default Fixed Description
TYPE_NO Restriction of xs:string required
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--3--Type_Block</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>420--3--Type_Block</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>420--3--Type_Block</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONDITION_RULES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element : CONDITION_RULES Element
Description
Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.
Namespace (none)
Diagram
CONDITION_RULE Element Sequence CONDITION_RULES Element
Overview
CONDITION_RULES
Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.
Sequence
CONDITION_RULE 1..∞
This element is used for defining block conditions.
Sequence
CLEARING_GROUP_REF 1..999
This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="CONDITION_RULES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>420--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
              <xs:annotation>
                <xs:documentation>420--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="CLEARING_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>420--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:choice>
              <xs:element name="MINIMUM_VALUE" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="999999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
            </xs:choice>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONDITION_RULE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element : CONDITION_RULE Element
Description
This element is used for defining block conditions.
Namespace (none)
Diagram
MINIMUM_WIDTH Element MINIMUM_VALUE Element Choice CLEARING_GROUP_REF Element Sequence CONDITION_RULE Element
Overview
CONDITION_RULE 1..∞
This element is used for defining block conditions.
Sequence
CLEARING_GROUP_REF 1..999
This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="CONDITION_RULE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
        <xs:annotation>
          <xs:documentation>420--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="CLEARING_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>420--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:choice>
        <xs:element name="MINIMUM_VALUE" minOccurs="0">
          <xs:annotation>
            <xs:documentation>420--6--Mindest_Wert</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:nonNegativeInteger">
              <xs:minInclusive value="0" />
              <xs:maxInclusive value="999999999" />
            </xs:restriction>
          </xs:simpleType>
        </xs:element>
        <xs:element name="MINIMUM_WIDTH" minOccurs="0">
          <xs:annotation>
            <xs:documentation>420--7--Mindest_Breite</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:nonNegativeInteger">
              <xs:minInclusive value="0" />
              <xs:maxInclusive value="999999" />
            </xs:restriction>
          </xs:simpleType>
        </xs:element>
      </xs:choice>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element > CONDITION_RULE Element : CLEARING_GROUP_REF Element
Description
This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
Namespace (none)
Diagram
CLEARING_GROUP_REF Element
Overview
CLEARING_GROUP_REF 1..999
This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
CLEARING_GROUP_NO Restriction of xs:nonNegativeInteger required
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="CLEARING_GROUP_REF" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="CLEARING_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>420--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
CONDITION_RULE Element | CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MINIMUM_VALUE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element > CONDITION_RULE Element : MINIMUM_VALUE Element
Description
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MINIMUM_VALUE Element
Overview
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="MINIMUM_VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--6--Mindest_Wert</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONDITION_RULE Element | CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MINIMUM_WIDTH Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element > CONDITION_RULE Element : MINIMUM_WIDTH Element
Description
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MINIMUM_WIDTH Element
Overview
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="MINIMUM_WIDTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--7--Mindest_Breite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONDITION_RULE Element | CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_SALE_PRICES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element : BLOCK_SALE_PRICES Element
Description
This element is used for defining block sale prices.
Namespace (none)
Diagram
BLOCK_SALE_PRICE Element Sequence BLOCK_SALE_PRICES Element
Overview
BLOCK_SALE_PRICES optional
This element is used for defining block sale prices.
Sequence
BLOCK_SALE_PRICE 1..∞
Block sale prices, which are only valid for various limited periods, are defined in this element. This element may be used only, if certain block prices are valid for more than one limited period within one catalogue period. Blocks, which are only available within one coherent period, are defined by the elements VALID_FROM (path 1) and /VALID_UNTIL (path 1).

A price defined in this element has precedence over the price defined in the general price field.
The variation combinations defined in this element have priority over the item specific control procedures.

Overlapping dates in the defined periods of block sale prices are not permitted.
Information provided in this element does not override information from other elements but abrogates it temporarily.
The combination of those pieces of information which are concerned, is defined in this element. All other combinations are still valid!

The validity dates of a block defined in this element have to differ from those defined in the elements VALID_FROM (path 1) and /VALID_UNTIL.
A block sale price is defined for a certain range within a certain period of time. The block sale price entered in this element must not override the “normal” block price in this pricegroup because other ranges may refer to that price, too.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Sequence
ITEM_REF
This element is used for referencing an item for which a block sale price has been defined.
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
This element is used for defining block sale conditions.
Sequence
VALID_FROM Restriction of xs:date
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM. D date
P
M
VALID_UNTIL Restriction of xs:date
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM. D date
P
M
OPTION_REF 0..4
This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself). D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="BLOCK_SALE_PRICES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>480--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>480--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>480--100--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="VALID_FROM">
                    <xs:annotation>
                      <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL">
                    <xs:annotation>
                      <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
                    <xs:annotation>
                      <xs:documentation>480--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_OR_CALCULATION_POINT">
                    <xs:annotation>
                      <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_SALE_PRICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element : BLOCK_SALE_PRICE Element
Description
Block sale prices, which are only valid for various limited periods, are defined in this element. This element may be used only, if certain block prices are valid for more than one limited period within one catalogue period. Blocks, which are only available within one coherent period, are defined by the elements VALID_FROM (path 1) and /VALID_UNTIL (path 1).

A price defined in this element has precedence over the price defined in the general price field.
The variation combinations defined in this element have priority over the item specific control procedures.

Overlapping dates in the defined periods of block sale prices are not permitted.
Information provided in this element does not override information from other elements but abrogates it temporarily.
The combination of those pieces of information which are concerned, is defined in this element. All other combinations are still valid!

The validity dates of a block defined in this element have to differ from those defined in the elements VALID_FROM (path 1) and /VALID_UNTIL.
A block sale price is defined for a certain range within a certain period of time. The block sale price entered in this element must not override the “normal” block price in this pricegroup because other ranges may refer to that price, too.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Namespace (none)
Diagram
VARIATION_PRICE_DEFINITION Element ITEM_REF Element Sequence BLOCK_SALE_PRICE Element
Overview
BLOCK_SALE_PRICE 1..∞
Block sale prices, which are only valid for various limited periods, are defined in this element. This element may be used only, if certain block prices are valid for more than one limited period within one catalogue period. Blocks, which are only available within one coherent period, are defined by the elements VALID_FROM (path 1) and /VALID_UNTIL (path 1).

A price defined in this element has precedence over the price defined in the general price field.
The variation combinations defined in this element have priority over the item specific control procedures.

Overlapping dates in the defined periods of block sale prices are not permitted.
Information provided in this element does not override information from other elements but abrogates it temporarily.
The combination of those pieces of information which are concerned, is defined in this element. All other combinations are still valid!

The validity dates of a block defined in this element have to differ from those defined in the elements VALID_FROM (path 1) and /VALID_UNTIL.
A block sale price is defined for a certain range within a certain period of time. The block sale price entered in this element must not override the “normal” block price in this pricegroup because other ranges may refer to that price, too.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Sequence
ITEM_REF
This element is used for referencing an item for which a block sale price has been defined.
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
This element is used for defining block sale conditions.
Sequence
VALID_FROM Restriction of xs:date
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM. D date
P
M
VALID_UNTIL Restriction of xs:date
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM. D date
P
M
OPTION_REF 0..4
This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself). D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>480--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>480--100--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="VALID_FROM">
              <xs:annotation>
                <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL">
              <xs:annotation>
                <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
              <xs:annotation>
                <xs:documentation>480--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_OR_CALCULATION_POINT">
              <xs:annotation>
                <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element : ITEM_REF Element
Description
This element is used for referencing an item for which a block sale price has been defined.
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF
This element is used for referencing an item for which a block sale price has been defined.
TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Attributes
Name Type Use Default Fixed Description
TYPE_NO Restriction of xs:string required
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VARIATION_PRICE_DEFINITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element : VARIATION_PRICE_DEFINITION Element
Description
This element is used for defining block sale conditions.
Namespace (none)
Diagram
PRICE_OR_CALCULATION_POINT Element OPTION_REF Element VALID_UNTIL Element VALID_FROM Element Sequence VARIATION_PRICE_DEFINITION Element
Overview
VARIATION_PRICE_DEFINITION 1..∞
This element is used for defining block sale conditions.
Sequence
VALID_FROM Restriction of xs:date
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM. D date
P
M
VALID_UNTIL Restriction of xs:date
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM. D date
P
M
OPTION_REF 0..4
This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself). D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--100--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="VALID_FROM">
        <xs:annotation>
          <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL">
        <xs:annotation>
          <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
        <xs:annotation>
          <xs:documentation>480--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_OR_CALCULATION_POINT">
        <xs:annotation>
          <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : VALID_FROM Element
Description
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM Restriction of xs:date
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM. D date
P
M
Source
<xs:element name="VALID_FROM" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : VALID_UNTIL Element
Description
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL Restriction of xs:date
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM. D date
P
M
Source
<xs:element name="VALID_UNTIL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : OPTION_REF Element
Description
This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF 0..4
This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used for referencing a option. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
This attribute is used for referencing a option. D string
P
M [1:5]
Source
<xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_OR_CALCULATION_POINT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : PRICE_OR_CALCULATION_POINT Element
Description
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself). D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
PRICE_OR_CALCULATION_POINT Element
Overview
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself). D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="PRICE_OR_CALCULATION_POINT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GRADING_TABLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element : GRADING_TABLE Element
Description

This element is used for defining grading tables containing the surcharges or the credits which are used in the value clearing system.

A clearing block, which is valid for a certain commission, can be used as reference for the grading table. A reference amount is set up for each data record of this record type, to which the valid clearing block belongs CLEARING_GROUP (path 1). This amount is compared to the given amount of the clearing group. If the reference value corresponds with the given grading range (elements VALUE_FROM (path2) and VALUE_TO (path 2), the data record is applied. In this case the settings in the field TYPE_CREDIT (path 2) and/ or TYPE_DEBIT (path 2) are applied. The calculation is based on the amount of the calculation group, which is defined for type_credit or type_surcharge (element ITEM (path 3)).

Different grading ranges can be defined for one block. A freely defined operation_ID is assigned to each grading range COMPARING_RULES (path 4). Different grading ranges with the same operation_ID may appear within one grading range of a clearing block. In this case the conditions of all grading ranges with their corresponding clearing group have to be fulfilled, so that the value clearing system can be applied to the different items of the commission. Single data records are linked by an AND-operation (COMPARING_RULE).

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

In case several data records of a clearing block are applied in the GRADING_TABLE, the value of the block (ITEM (path 3)), ITEM_PRICE (path 5)) is calculated only one time.

path 1: GLOBAL_DEFINITION
path 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
path 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Namespace (none)
Diagram
CREDIT_SURCHARGE_CLEARING Element Sequence GRADING_TABLE Element
Overview
GRADING_TABLE optional

This element is used for defining grading tables containing the surcharges or the credits which are used in the value clearing system.

A clearing block, which is valid for a certain commission, can be used as reference for the grading table. A reference amount is set up for each data record of this record type, to which the valid clearing block belongs CLEARING_GROUP (path 1). This amount is compared to the given amount of the clearing group. If the reference value corresponds with the given grading range (elements VALUE_FROM (path2) and VALUE_TO (path 2), the data record is applied. In this case the settings in the field TYPE_CREDIT (path 2) and/ or TYPE_DEBIT (path 2) are applied. The calculation is based on the amount of the calculation group, which is defined for type_credit or type_surcharge (element ITEM (path 3)).

Different grading ranges can be defined for one block. A freely defined operation_ID is assigned to each grading range COMPARING_RULES (path 4). Different grading ranges with the same operation_ID may appear within one grading range of a clearing block. In this case the conditions of all grading ranges with their corresponding clearing group have to be fulfilled, so that the value clearing system can be applied to the different items of the commission. Single data records are linked by an AND-operation (COMPARING_RULE).

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

In case several data records of a clearing block are applied in the GRADING_TABLE, the value of the block (ITEM (path 3)), ITEM_PRICE (path 5)) is calculated only one time.

path 1: GLOBAL_DEFINITION
path 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
path 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence
CREDIT_SURCHARGE_CLEARING 1..∞
This element defines value range for a grading table.
Sequence
ITEM_REF

This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.
Sequence
COMPARING_RULE 1..∞
This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Source
<xs:element name="GRADING_TABLE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>421--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>421--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>421--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>421--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>421--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLEARING_GROUP_ID">
                          <xs:annotation>
                            <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE_FROM">
                          <xs:annotation>
                            <xs:documentation>421--6--Wert_von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE_TO">
                          <xs:annotation>
                            <xs:documentation>421--7--Wert_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TYPE_CREDIT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TYPE_DEBIT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>421--9--Type_Belastung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CREDIT_SURCHARGE_CLEARING Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element : CREDIT_SURCHARGE_CLEARING Element
Description
This element defines value range for a grading table.
Namespace (none)
Diagram
COMPARING_RULES Element ITEM_REF Element Sequence CREDIT_SURCHARGE_CLEARING Element
Overview
CREDIT_SURCHARGE_CLEARING 1..∞
This element defines value range for a grading table.
Sequence
ITEM_REF

This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.
Sequence
COMPARING_RULE 1..∞
This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Source
<xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>421--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>421--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>421--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>421--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLEARING_GROUP_ID">
                    <xs:annotation>
                      <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE_FROM">
                    <xs:annotation>
                      <xs:documentation>421--6--Wert_von</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE_TO">
                    <xs:annotation>
                      <xs:documentation>421--7--Wert_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TYPE_CREDIT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TYPE_DEBIT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>421--9--Type_Belastung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element : ITEM_REF Element
Description

This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF

This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Attributes
Name Type Use Default Fixed Description
TYPE_NO Restriction of xs:string required
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>421--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>421--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COMPARING_RULES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element : COMPARING_RULES Element
Description
Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.
Namespace (none)
Diagram
COMPARING_RULE Element Sequence COMPARING_RULES Element
Overview
COMPARING_RULES 1..∞
Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.
Sequence
COMPARING_RULE 1..∞
This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Source
<xs:element name="COMPARING_RULES" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>421--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLEARING_GROUP_ID">
              <xs:annotation>
                <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE_FROM">
              <xs:annotation>
                <xs:documentation>421--6--Wert_von</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE_TO">
              <xs:annotation>
                <xs:documentation>421--7--Wert_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TYPE_CREDIT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TYPE_DEBIT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>421--9--Type_Belastung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COMPARING_RULE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element : COMPARING_RULE Element
Description
This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.
Namespace (none)
Diagram
TYPE_DEBIT Element TYPE_CREDIT Element VALUE_TO Element VALUE_FROM Element CLEARING_GROUP_ID Element Sequence COMPARING_RULE Element
Overview
COMPARING_RULE 1..∞
This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Source
<xs:element name="COMPARING_RULE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLEARING_GROUP_ID">
        <xs:annotation>
          <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE_FROM">
        <xs:annotation>
          <xs:documentation>421--6--Wert_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE_TO">
        <xs:annotation>
          <xs:documentation>421--7--Wert_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TYPE_CREDIT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TYPE_DEBIT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>421--9--Type_Belastung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : CLEARING_GROUP_ID Element
Description
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
CLEARING_GROUP_ID Element
Overview
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="CLEARING_GROUP_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : VALUE_FROM Element
Description
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
VALUE_FROM Element
Overview
VALUE_FROM Restriction of xs:nonNegativeInteger
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="VALUE_FROM" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--6--Wert_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE_TO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : VALUE_TO Element
Description

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
VALUE_TO Element
Overview
VALUE_TO Restriction of xs:nonNegativeInteger

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="VALUE_TO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--7--Wert_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TYPE_CREDIT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : TYPE_CREDIT Element
Description
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
TYPE_CREDIT Element
Overview
TYPE_CREDIT optional Restriction of xs:string
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
Source
<xs:element name="TYPE_CREDIT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TYPE_DEBIT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : TYPE_DEBIT Element
Description
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Namespace (none)
Type
Restriction of xs:string
Diagram
TYPE_DEBIT Element
Overview
TYPE_DEBIT optional Restriction of xs:string
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Source
<xs:element name="TYPE_DEBIT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--9--Type_Belastung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SET_OF_BLOCK_RULES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element : SET_OF_BLOCK_RULES Element
Description
The manufacturer specific rules are defined in this element and the in the child elements.
Namespace (none)
Diagram
LANGUAGE Element Sequence RULE_SET_TEXT Element RULE Element EXCHANGE_ID_GROUP Element Sequence SET_OF_BLOCK_RULES Element
Overview
SET_OF_BLOCK_RULES
The manufacturer specific rules are defined in this element and the in the child elements.
Sequence
EXCHANGE_ID_GROUP 1..∞
This element is used for defining the exchange groups. If exchange-ID 1 (EXCHANGE_ID_1_REF) may be exchanged with exchange-ID 2 (EXCHANGE_ID_2_REF) and vice versa this has to be defined explicitly.
If items with the same exchange_ID can be exchanged 1 by 1 a special data record for this exchange has to be defined.
Sequence
EXCHANGE_ID_1_REF
The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS . The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RULE 1..99
This element defines a manufacturer specific set of rules.
RULE_NO required Restriction of xs:nonNegativeInteger
This attribute defines a counter from 1-99 for the manufacturer specific block rules. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
This element defines the criteria for exchanges in the block processing.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
RULE_SET_TEXT languagetexte60999 Complex Type
This element contains text information and explanations for the set of rules.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="SET_OF_BLOCK_RULES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>111--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>117--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_1_REF">
              <xs:annotation>
                <xs:documentation>117--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>117--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="EXCHANGE_ID_2_REF">
              <xs:annotation>
                <xs:documentation>117--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>117--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RULE" maxOccurs="99">
        <xs:annotation>
          <xs:documentation>111--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RULE_TEXT" type="languagetexte60999">
              <xs:annotation>
                <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="RULE_NO" use="required">
            <xs:annotation>
              <xs:documentation>113--3--Regel_Nr</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="RULE_SET_TEXT" type="languagetexte60999">
        <xs:annotation>
          <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element : EXCHANGE_ID_GROUP Element
Description
This element is used for defining the exchange groups. If exchange-ID 1 (EXCHANGE_ID_1_REF) may be exchanged with exchange-ID 2 (EXCHANGE_ID_2_REF) and vice versa this has to be defined explicitly.
If items with the same exchange_ID can be exchanged 1 by 1 a special data record for this exchange has to be defined.
Namespace (none)
Diagram
EXCHANGE_ID_2_REF Element EXCHANGE_ID_1_REF Element Sequence EXCHANGE_ID_GROUP Element
Overview
EXCHANGE_ID_GROUP 1..∞
This element is used for defining the exchange groups. If exchange-ID 1 (EXCHANGE_ID_1_REF) may be exchanged with exchange-ID 2 (EXCHANGE_ID_2_REF) and vice versa this has to be defined explicitly.
If items with the same exchange_ID can be exchanged 1 by 1 a special data record for this exchange has to be defined.
Sequence
EXCHANGE_ID_1_REF
The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS . The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Source
<xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>117--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_1_REF">
        <xs:annotation>
          <xs:documentation>117--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>117--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="EXCHANGE_ID_2_REF">
        <xs:annotation>
          <xs:documentation>117--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>117--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_1_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element > EXCHANGE_ID_GROUP Element : EXCHANGE_ID_1_REF Element
Description
The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS . The exchange-ID references the items of a commission or planning.
Namespace (none)
Diagram
EXCHANGE_ID_1_REF Element
Overview
EXCHANGE_ID_1_REF
The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS . The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attributes
Name Type Use Default Fixed Description
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Source
<xs:element name="EXCHANGE_ID_1_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>117--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>117--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
EXCHANGE_ID_GROUP Element | SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_2_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element > EXCHANGE_ID_GROUP Element : EXCHANGE_ID_2_REF Element
Description
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS The exchange-ID references the items of a commission or planning.
Namespace (none)
Diagram
EXCHANGE_ID_2_REF Element
Overview
EXCHANGE_ID_2_REF
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attributes
Name Type Use Default Fixed Description
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Source
<xs:element name="EXCHANGE_ID_2_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>117--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>117--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
EXCHANGE_ID_GROUP Element | SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RULE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element : RULE Element
Description
This element defines a manufacturer specific set of rules.
Namespace (none)
Diagram
LANGUAGE Element Sequence RULE_TEXT Element Sequence RULE Element
Overview
RULE 1..99
This element defines a manufacturer specific set of rules.
RULE_NO required Restriction of xs:nonNegativeInteger
This attribute defines a counter from 1-99 for the manufacturer specific block rules. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
This element defines the criteria for exchanges in the block processing.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
RULE_NO Restriction of xs:nonNegativeInteger required
This attribute defines a counter from 1-99 for the manufacturer specific block rules. D nonNegativeInteger
P
M [1:99]
Source
<xs:element name="RULE" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>111--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RULE_TEXT" type="languagetexte60999">
        <xs:annotation>
          <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="RULE_NO" use="required">
      <xs:annotation>
        <xs:documentation>113--3--Regel_Nr</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RULE_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element > RULE Element : RULE_TEXT Element
Description
This element defines the criteria for exchanges in the block processing.
Namespace (none)
Type
languagetexte60999 Complex Type
Diagram
LANGUAGE Element Sequence RULE_TEXT Element
Overview
RULE_TEXT languagetexte60999 Complex Type
This element defines the criteria for exchanges in the block processing.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="RULE_TEXT" type="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RULE Element | SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RULE_SET_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element : RULE_SET_TEXT Element
Description
This element contains text information and explanations for the set of rules.
Namespace (none)
Type
languagetexte60999 Complex Type
Diagram
LANGUAGE Element Sequence RULE_SET_TEXT Element
Overview
RULE_SET_TEXT languagetexte60999 Complex Type
This element contains text information and explanations for the set of rules.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="RULE_SET_TEXT" type="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%ItemTitle%%

IDM 2.7.0 XML-Schema Documentation
Type of data
View with Navigation Tools

Special types of data have been defined for element references depending on language.


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > languagetexte Complex Type > LANGUAGE Element : TEXT Element
Description

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Namespace (none)
Type
xs:string
Diagram
TEXT Element
Overview
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="TEXT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
LANGUAGE Element | languagetexte Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte30 Complex Type
IDM 2.7.0 XML-Schema : languagetexte30 Complex Type
Description

This element is used for multilingual text information limited to 30 characters.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte30 Complex Type
Overview
languagetexte30

This element is used for multilingual text information limited to 30 characters.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Used By
CATALOG_NAME Element
PROPERTY_UNIT Element
DEFAULT_OPTION_GROUP_NAME Element
MERCHANDISE_GROUP_TEXT Element
CALC_GROUP_TEXT Element
Source
<xs:complexType name="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 30stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,30}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte40 Complex Type
IDM 2.7.0 XML-Schema : languagetexte40 Complex Type
Description

This element is used for multilingual text information limited to 40 characters.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte40 Complex Type
Overview
languagetexte40

This element is used for multilingual text information limited to 40 characters.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Used By
INTERNAL_NAME Element
EXCHANGE_ID_TEXT Element
Source
<xs:complexType name="languagetexte40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 40stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,40}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > languagetexte40 Complex Type > LANGUAGE Element : TEXT Element
Description
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,40}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetexte40 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte60 Complex Type
IDM 2.7.0 XML-Schema : languagetexte60 Complex Type
Description

This element is used for multilingual text information limited to 60 characters.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte60 Complex Type
Overview
languagetexte60

This element is used for multilingual text information limited to 60 characters.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Used By
CLEARING_GROUP_NAME Element
MODULE_RULE_SET_NAME Element
GROUP_TITLE_NAME Element
PRODUCT_GROUP_TEXT Element
OPTION_TEXT Element
OPTION_COMMENT_TEXT Element
FEATURE_TEXT Element
RESTRICTION_NAME_TEXT Element
SUGGESTION_NAME_TEXT Element
PRICE_FEATURE_GROUP_TEXT Element
PRICE_TYPE_NAME Element
Source
<xs:complexType name="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>265--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,60}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte60999 Complex Type
IDM 2.7.0 XML-Schema : languagetexte60999 Complex Type
Description

This element is used for multilingual text information limited to 60 characters per line. The maximum length of the complete element is limited to 999 lines.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte60999 Complex Type
Overview
languagetexte60999

This element is used for multilingual text information limited to 60 characters per line. The maximum length of the complete element is limited to 999 lines.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Used By
CATALOG_INFO Element
PLANNING_ADVICE Element
RULE_TEXT Element
RULE_SET_TEXT Element
Source
<xs:complexType name="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelligen Zeilen</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT_LINE" maxOccurs="999">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="TEXT">
                  <xs:annotation>
                    <xs:documentation>265--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[\S ]{1,60}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
              </xs:sequence>
              <xs:attribute name="SEQUENCE_NO" use="required">
                <xs:annotation>
                  <xs:documentation>150--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger" />
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDM 2.7.0 XML-Schema