%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Introduction
View with Navigation Tools

Modification IDM 2.7.0 XML schema

Documentation

Last revised 01/05/2019

Documented XML schema:

MODIFY_IDM_2_7_0.xsd

Contact

DCC e. V.
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telephone 0 52 21/12 65-37


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
The basic structure of the IDM schema
View with Navigation Tools
Introduction > The basic structure of the IDM schema

The basic structure of the IDM schema

The main element T_MODIFY_CATALOG defines that a modification file for a complete catalogue data pool is made available.

XML files must be UTF-8 encrypted.

The IDM schema is subdivided in data ranges that are specified in the subsequent child-elements (see figure 1) in T_MODIFY_CATALOG.

Figure 1 - child elements in T_NEW_CATALOG

The data ranges are not used in isolation from each other. In some data ranges, data is initially created and used from other data ranges via referencing.

Description of the data ranges

CATALOG

Administrative information about the data pool is specified in CATALOG. E.g. the version of the data format, release date or the unique identification of the data pool.

REF_CATALOG

Information about the main catalogue is stored in REF_CATAG.

SERIES

SERIES is used to store the data for the description of the items. Items are combined into product groups, such as base units or shelf units.

FEATURE_DEFINITION

The version information is specified in FEATURE_DEFINITION The specified data are the modifications from the main catalogue.

PRICE_DEFINITION

The price information is specified in PRICE_DEFINITION. The information relates on e.g. modified price fields from the main catalogue.


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Catalogue structure
View with Navigation Tools
Introduction > Catalogue structure

Catalogue and element structure

The general catalogue structure of the database is built up as follows:

Pict.1 – Catalogue structure of databases

This catalogue structure is represented by the following element hierarchy in the IDM scheme:

Pict. 1 – Element hierarchy of the IDM scheme

The element SERIE is used for defining the properties of a series. The element RESTRICTION_REF assigns features to a series by means of restrictions. Within one series different produkt groups (PRODUCT_GROUPS) are defined which combine all items with similar features to one group. As items are child elements of the element SERIE they are automatically assigned to this series.


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Referencing
View with Navigation Tools
Introduction > Referencing

Referencing of elements

The IDM schema establishes relationships between elements and defines information at a central point which are used on multiple occasions in another position. The reuse of the information and the structure of element relationships takes place via referencing. The type of referencing used in the IDM schema is described in the following.

Definition of terms

The IDM schema uses the following terms for the referencing of elements:

Key element | An XML element referenced by other elements.
Ref element | An XML element referencing other elements

Referencing procedure

The key element has attributes that allow for its unequivocal identification. The ref element has at least the key attributes of the key element. The reference in which the attribute values of the ref element are identical to those of the key element is established between the elements.

Example: referencing of a version

The following example shows how to newly reference a version from a design range.

Key element

T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="400"> <!-- Plinth finish-->

<OPTIONS>

<OPTION OPTION_KEY="1"FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="2"FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="3"FEATURE_NO="400"> … </OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="401"> <!-- Plinth colour-->

<OPTIONS>

<OPTION OPTION_KEY="1"FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="2"FEATURE_NO="401"> … </OPTION>

<OPTIONOPTION_KEY="3" FEATURE_NO="401"> … </OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

For version type 400 (FEATURE),FEATUREthe XML elements define three versions (OPTION) numbered 1-3, as well as three versions numbered 1-3 for version type 401. A version is identified via the combination FEATURE_NO and OPTION_KEY.

Ref element

/T_MODIFY_CATALOG/PRICE_DEFINITION/PICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTION_REF


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Data types
View with Navigation Tools
Introduction > Data types

Data types and value ranges

The IDM schema uses the data types defined in the standard XML schema 1.0 second edition (28 October 2004).

The following data types are used:

boolean | This data type maps the logical values "true" or "false". In accordance with the W3C recommendation for XML schemas, the values that can be used in the IDM are true/false or 1/0.
date | In the IDM, the data type date is used in conformity with the XML schemas as follows: YYYY-MM-DD YYYY = year, MM = month, DD = day
dateTime | In the IDM, the data type dateTime is used in conformity with the XML schemas as follows: YYYY-MM-DDThh:mm:ssZ YYYY = year, MM = month, DD = day T = Start of time information hh = hour, mm = minute, ss = second Z = UTC time
gYear | In the IDM, the data type dateTime is used in conformity with the XML schemas as follows: YYYY
integer | Numbers can be positive and negative integers.
nonNegativeInteger | Value is a positive integer, including 0
positiveInteger | Value is a positive integer, excluding 0
decimal | The data type is used in the IDM for floating-point values. Floating-point values for this data type are, as recommended by the W3C, stored as 126.56 ir 45.98000 or +27.0.
string | A limited number of alphanumeric characters and special characters.
anyURI | The data type is used in the IDM for mapping URLs.anyURI represents a Uniform Resource Identifier (URI). The lexical part of anyURI is an indefinite sequence of characters that correspond to a legal URI. An anyURI value can be absolute or relative and may contain fragment codes (e.g. an URI reference).
language | The data type is used for the specification of valid language codes in the IDM.language represents codes for natural languages Tags for the Identification of Languagesas defined in the Thevaluerangeof language is the quantum of all character sequences that represent a valid code of a natural language. For ISO languages, the format consists of a sequence of 2-3 lower case letters optionally followed by a hyphen and a country code consisting of 2 upper case letters, e.g. en-US.

The value ranges of the above data types are usually restricted for the elements in the IDM. The "restrictions" in the data type definition contains restrictions for minimum and maximum values, permitted characters and value lists.

In the XML documentation of the IDM, the value ranges are specified by the information coming after M and P.

In addition to XML data types mentioned here, separate data types are defined for the texts.

They are explained at the end of the documentation.

See Also
languagetexte Complex Type
languagetexte30 Complex Type
languagetexte40 Complex Type
languagetexte60 Complex Type
languagetexte60999 Complex Type


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Explanations for the documentation
View with Navigation Tools
Introduction > Explanations for the documentation

Explanations for the documentation of the IDM

This paragraph contains explanations for the documentation of the IDM scheme.

Meaning of element properties

Each element is documented with a description and its properties. The following example shows an element description:

EXCHANGE_ID_NO Attribute

Description
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

The properties of the element are listed on the right side. The following abbreviations are used:

D | Documentation of the data type for the element. If no value is set here, the element does not contain user data but further child elements.
P | The values P and M are used to define the range of values. The regular term in P defines the number of legal values.
M | M defines the minium and maximum value in the range of legal values. In a string data type P defines the legal values and M defines the minimum and maximum length of the string. For numerical data types M defines the minimum and maximum value.


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Variation types
View with Navigation Tools
Introduction > Variation types

Variation type | Variation text | Option type | Remark
1 | programm/ style | A | programm asvariation type
2 | serial number | A | assignment of a five-digit serial number
100 | Front finish | A |
101 | Front colour 1 | F | Front filling smooth = complete surface
102 | Front colour 2 | F | Frame
103 | Front colour 3 | F | Pilaster strips
104 | Edge colour front | F |
105 | Front combination | K | If only one key is used for different front information
106 | Front group | A | Overrides the FRONT_GROUP_NO in element FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
110 | Front finish contrast colour 1 | A |
111 | Front colour 1 contrast colour 1 | F | Front filling smooth = complete surface
112 | Front colour 2 contrast colour 1 | F | Frame
113 | Front colour 3 contrast colour 1 | F | Pilaster strips
114 | Edge colour front, contrast colour 1 | F |
115 | Front combination, contrast colour 1 | K | The variations 111 - 114 are permitted.
120 | Front finish contrast colour 2 | A |
121 | Front colour 1 contrast colour 2 | F | Front filling smooth = complete surface
122 | Front colour 2 contrast colour 2 | F | Frame
123 | Front colour 3 contrast colour 2 | F | Pilaster strips
124 | Edge colour front, contrast colour 2 | F |
125 | Front combination, contrast colour 2 | K | The variations 121 - 124 are permitted.
150 | Glass finish | A |
151 | Glass colour | F |
152 | Mullion type | A |
153 | Mullion colour | F |
154 | Type glass door frame | A |
155 | Colour glass door frame | F |
160 | Type roller shutter | A |
161 | Colour roller shutter | F |
170 | Type container | A |
171 | Colour container | F |
200 | Type carcase | A |
201 | Carcase combination | K | If only one key is used for several – interior /exterior - carcase colours
202 | Exterior carcase colour | F |
203 | Interior carcase colour | F |
204 | Edge carcase | A |
205 | Edge colour carcase | F |
206 | Type visible side | A |
207 | Colour visible side | F |
208 | Interior carcase colour for glass door cabinets | F | Glass door cabinets and open cabinets, which are not a shelf .
209 | Interior carcase for glass door cabinets | A | Glass door cabinets and open cabinets, which are not a shelf .
300 | Type handle | A |
301 | Handle colour 1 | F | Colour handle, knob or main colour
302 | Handle colour 2 | F | Colour bow, railing, or knob handles
303 | Combination of handles | K | If only one key is defined for several handle conditions
304 | Handle positions | NULL | cf. handle positions p. 5-23
400 | Type plinth | A |
401 | Plinth colour | F |
402 | Plinth height | A |
410 | Type plinth bottom | A |
411 | Colour plinth bottom | F |
500 | Type shelves | A |
501 | Colour shelves | F |
502 | Type cornice | A | Includes shape and material
503 | Colour cornice | F |
504 | Type light pelment | A | Includes shape and material
505 | Colour light pelmet | F |
506 | Type ceiling filler | A |
507 | Colour ceiling filler | F |
508 | Type filler | A | Bottom ledge
509 | Colour bottopm ledge | F | Bottom ledge
510 | Type gallery shelf | A |
511 | Colour gallery shelf | F |
512 | Type gallery shelf edge | A |
513 | Colour gallery shelf edge | F |
514 | Type board | A |
515 | Colour board | F |
516 | Type board edge | A |
517 | Colour board edge | F |
520 | Type side panels/ bars | A |
521 | Colour side panels/ bars | F |
522 | Type bar panel edge | A |
523 | Colour bar panel edge | F |
524 | Type bottom shelf | A |
525 | Colour bottom shelf | F |
526 | Type bottom shelf edge | A |
527 | Colour bottom shelf edge | F |
550 | Type recess | A |
551 | Colour recess | F |
560 | Type recess accessories | A |
561 | Colour recess accessories | F |
562 | Type pilaster | A |
563 | Colour pilaster | F |
564 | Type pilaster edge | A |
565 | Colour pilaster edge | F |
600 | Type worktop | A |
601 | Colour worktop | F |
602 | Type worktop edge | A |
603 | Colour worktop edge | F |
604 | Type countertop | A |
605 | Colour countertop | F |
606 | Type countertop edge | A |
607 | Colour countertop edge | F |
620 | Type cover shelf | A |
621 | Colour cover shelf | F |
622 | Type cover shelf edge | A |
623 | Colour cover shelf | F |
624 | Type attachment table | A |
625 | Colour attachment table | F |
626 | Type attachment table edge | A |
627 | Colour attachment table edge | F |
650 | Type worktop upstand | A | Worktop upstand profile
651 | Colour worktop upstand | F | Worktop upstand profile
700 | Type drawer | A | Interior equipment
701 | Colour drawer | F | Interior equipment
702 | Type pull-out | A | Interior equipment
703 | Colour pull-out | F | Interior equipment
750 | Shape worktop | S |
751 | Shape cornice | S |
752 | Shape light pelmet | S |
753 | Shape plinth | S |
754 | Shape worktop upstand | S |
755 | Shape cover shelf | S |
756 | Shape countertop | S |
800 | Type electrical appliance | A |
801 | Colour electrical appliance | F |
802 | Colour electr. appliances accessories | F |
850 | Type sink | A |
851 | Colour sink | F |
852 | Colour sink accessories | F |
853 | Colour mixer taps | F |
854 | Type mixer taps | A |
900 | Type general accessories | A |
901 | Colour general accessories | F |
930 | additional, graphical relevant information about type 1. | A | The software suppliers have to be informed separately about the meaning.
931 | additional, graphical relevant information about colour 1. | F | The software suppliers have to be informed separately about the meaning.
932 | additional, graphical relevant information about type 2. | A | The software suppliers have to be informed separately about the meaning.
933 | additional, graphical relevant information about colour 2. | F | The software suppliers have to be informed separately about the meaning.
934 | additional, graphical relevant information about type 3. | A | The software suppliers have to be informed separately about the meaning.
935 | additional, graphical relevant information about colour 3. | F | The software suppliers have to be informed separately about the meaning.
936 | additional, graphical relevant information about type 4. | A | The software suppliers have to be informed separately about the meaning.
937 | additional, graphical relevant information about colour 4. | F | The software suppliers have to be informed separately about the meaning.
938 | additional, graphical relevant information about type 5. | A | The software suppliers have to be informed separately about the meaning.
939 | additional, graphical relevant information about colour 5. | F | The software suppliers have to be informed separately about the meaning.
950 | Type miscellaneous 1 | A |
951 | Colour miscellaneous 1 | F |
952 | Type miscellaneous 2 | A |
953 | Colour miscellaneous 2 | F |
954 | Type miscellaneous 3 | A |
955 | Colour miscellaneous 3 | F |
956 | Type miscellaneous 4 | A |
957 | Colour miscellaneous 4 | F |
958 | Type miscellaneous 5 | A |
959 | Colour miscellaneous 5 | F |
960 | Type miscellaneous 6 | A |
961 | Colour miscellaneous 6 | F |
962 | Type miscellaneous 7 | A |
963 | Colour miscellaneous 7 | F |
964 | Type miscellaneous 8 | A |
965 | Colour miscellaneous 8 | F |
966 | Type miscellaneous 9 | A |
967 | Colour miscellaneous 9 | F |
968 | Type miscellaneous 10 | A |
969 | Colour miscellaneous 10 | F |
970 | Type miscellaneous 11 | A |
971 | Colour miscellaneous 11 | F |
972 | Type miscellaneous 12 | A |
973 | Colour miscellaneous 12 | F |
974 | Type miscellaneous 13 | A |
975 | Colour miscellaneous 13 | F |
976 | Type miscellaneous 14 | A |
977 | Colour miscellaneous 14 | F |
978 | Type miscellaneous 15 | A |
979 | Colour miscellaneous 15 | F |
980 | Type miscellaneous 16 | A |
981 | Colour miscellaneous 16 | F |
982 | Type miscellaneous 17 | A |
983 | Colour miscellaneous 17 | F |
984 | Type miscellaneous 18 | A |
985 | Colour miscellaneous 18 | F |
986 | Type miscellaneous 19 | A |
987 | Colour miscellaneous 19 | F |
988 | Type miscellaneous 20 | A |
989 | Colour miscellaneous 20 | F |
999 | Fixed material assignment | F |

Type: A = type

F = colour

K = Combination

S = shape

</


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Language key
View with Navigation Tools
Introduction > Language key
Language key | Language name
AA | Afar
AB | Abkhasian
AE | Avestan
AF | Afrikaans
AM | Amharic
AN | Aragonese
AR | Arabic
AS | Assam
AY | Aymara
AZ | Azerbaijanian
BA | Baschkirian
BE | Byelorussian
BG | Bulgarian
BH | Biharic
BI | Bislamic
BM | Bambara
BN | Bengal
BO | Tibetan
BR | Breton
BS | Bosnian
CA | Catalan
CE | Circassian
CH | Chamorro
CO | Corsican
CS | Czech
CU | Old slavish
CV | Chuvash
CY | Welsh
DA | Danish
DE | German
DV | Dhivehi
DZ | Dzongkha
DV | Dhivehi
EE | Estonian
EL | Greek
EN | English
EO | Esperanto
ES | Spanish
ET | Estonian
EU | Basque
FA | Persian
FF | Fulfulde
FI | Finno-Ugric
FJ | Fiji
FO | Faroese
FR | French
FY | Frisian
GA | Irish
GD | Gaelic
GL | Galician
GN | Guarani
GU | Gujaratic
GV | Manx, Manx-Gaelic
HA | Hausa
HE | Hebrew
HI | Hindi
HO | Hiri Motu
HR | Croatian
HT | Haitian
HU | Hungarian
HY | Armenian
HZ | Herero
IA | Interlingua
ID | Indonesian
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiak
IN | former Indonesian
IO | Ido
IS | Icelandic
IT | Italian
IU | Inuit
JA | Japanese
JV | Javanese
KA | Georgian
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kazakh
KL | Kalaallisut (Greenland)
KM | Cambodian
KN | Canadian
KO | Korean
KR | Kanuri
KS | Kashmirian
KU | Kurdish
KV | Komi
KW | Cornish
KY | Kirghiz
LA | Latin
LB | Luxembourgish
LG | Luganda
LI | Limburg
LN | Lingala
LO | Laotian
LT | Lithuanian
LU | Kiluba
LV | Lett
MG | Malagasy
MH | Marshallese
MI | Maori
MK | Macedonian
ML | Malay
MN | Mongolian
MO | Moldovan
MR | Marathi
MS | Malayan
MT | Maltese
MY | Burmese
NA | Nauruan
NB | Norwegian Bokmål
ND | North Ndebele
NE | Nepalese
NG | Ndonga
NL | Dutch
NN | Norwegian Nynorsk
NO | Norwegian
NR | South Ndebele
NV | Navajo
NY | Chichewa
OC | Occitan
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Punjab
PI | Pali
PL | Polish
PS | Paschtu
PT | Portugese
QU | Quechua
RM | Rhaeto-Romanic
RN | Kirundisch
RO | Romanian
RU | Russian
RW | Kijarwanda
SA | Sanskrit
SC | Sardinian
SD | Sinto
SE | North Sami
SG | Sango
SI | Sinhalese
SK | Slovakian
SL | Slovenian
SM | Samoan
SN | Shonian
SO | Somali
SQ | Albanian
SR | Serbian
SS | Swazi
ST | Sesothisch
SU | Sudanese
SV | Swedish
SW | Swahili
TA | Tamil
TE | Tegulu
TG | Tajik
TH | Thai
TI | Tigrinja
TK | Turkmenian
TL | Tagalog
TN | Sezuan
TO | Tongan
TR | Turkish
TS | Tongan
TT | Tartary
TW | Twi
TY | Thai
UG | Uighur
UK | Ukranian
UR | Urdu
UZ | Uzbek
VI | Vietnamese
VO | Volapük
WA | Walloon
WO | Wolof
XH | Xhosa
YI | Yiddish
YO | Joruba
ZA | Zhuang
ZH | Chinese
ZU | Zulu

</


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Country code
View with Navigation Tools
Introduction > Country code

country code | country (German) | country (English)
AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe

</


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Buying associations
View with Navigation Tools
Introduction > Buying associations

Buying association customer | Name buying association | Street | Postal Code | City | Phone | Fax
AMBRA | AMBRA Vertriebsgesellschaft mbH & Co. KG | Pfälzer Straße 10 | 33332 | Gütersloh | +49(5241)9246-0 | +49(5241)9246-49
AMM | Alliance Möbel-Marketing GmbH & Co.KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
ANT | ANTARES Einkaufs- und Marketinggesellschaft GmbH & Co. KG | Ramlinger Str. 50 | 31303 | Burgdorf-Ehlershausen | +49(5085)955887 | +49(5085)-955885
ASSIMA | ASSIMA Verbund GmbH & Co. KG | Bussardweg 18 | 41468 | Neuss | +49(2131)310400 | +49(2131)310469
ATLAS | Atlas-Einrichtungs-Einkauf GmbH | Brunshofstr. 2 | 45470 | Mülheim a. d. Ruhr | +49(208)992400 | +49(208)9924099
AWD | AWD Einkaufs- und Marketinggesellschaft für Wohnkomfort mbH | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
BAUR | Baur Friedrich GmbH Zentraleinkauf | Bahnhofstr. 10 | 96224 | Burgkunstadt | +49(9572)912739 o. 912746 | +49(9572)912006
BEGROS | Begros GmbH | Graf-Zeppelin-Str. 5 | 46149 | Oberhausen | +49(208)99493-0 | +49(208)99493-911
BETTENKREIS | BETTENKREIS GmbH & Co. | Pascalstr. 4 | 47506 | Neukirchen-Vluyn | +49(2845)9134-0 | +49(2845)9134-34
BETTENRING | BETTENRING eG | Echterdinger Str. 115 | 70794 | Filderstadt | +49(711)70958-0 | +49(711)70958-66
BRANION | BRANION GmbH | Soennecken-Platz | 51491 | Overath | +49(2206)607-0 | +49(2206)607-199
BÜRORING | BÜRORING eG | Siemensstr. 7 | 42781 | Haan | +49(2129)5571-0 | +49(2129)5571-93
CI | Createive Inneneinrichter | Spreestr. 3 | 64295 | Darmstadt | +49(6151)39128-0 | +49(6151)39128-28
CON | Concorde Möbel-Einkaufs-GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | 0211-47236-0 | 0211-4180034
CP | CREATIVE PARTNEr Service- und Einkaufs-Kooperation GmbH | Otto-Hahn-Str. 6 d | 21509 | Glinde | +49(40)728161-0 | +49(40)728161-21
DKR | Der Küchenring GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
DMV | DEUTSCHER MÖBEL-VERBUND Handels GmbH | Ampertal 8 | 85777 | Fahrenzhausen-Unterbruck | +49(8133)89-0 | +49(8133)-89-199
DSM | Drosser & Schaffer Marketing GmbH | Würmstr. 13A | 82166 | Gräfelfing | +49(89)89878434/-26 /-28 | +49(89)89878440
DU | DECOR UNION GmbH & Co. KG | Brüsseler Str. 3 | 30539 | Hannover | +49(511)8789-0 | +49(511)8789-299
EBUCH | ebuch eG | O'Brien-Str. 3 | 91126 | Schwabach | +49(9122)9386-0 | +49(9122)9386-68
EDE | Einkaufsbüro Deutscher Eisenhändler GmbH | Dieselstr. 33 | 42389 | Wuppertal | +49(202)6096-0 | +49(202)6096-331
EGEPACK | EGEPACK Einkaufs- und Vertriebsgesellschaft mbH | Bödekerstr. 7 | 30161 | Hannover | +49(511)38841-03 / -04 | +49(511)3884064
EIS | E.I. S. GmbH | Von-Hünefeld-Str. 41 | 50829 | Köln | +49(211)59797-44 / -45 | +49(211)59797-21
EK | Grosseinkauf eG | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-144
EKAFLOR | ekaflor GmbH & Co. KG | Watzmannstr. 3 | 90471 | Nürnberg | +49(911)981166-0 | +49(911)981166-5
ELTKONTOR | ELTKONTOR GmbH & Co. KG | Oldenburger Allee 21 | 30659 | Hannover | +49(511)61599-0 | +49(511)61599-77
EM | Europa Möbel | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EMV | Europa Möbel-Verbund (EMV) | Ampertal 8 | 85777 | Fahrenzhausen-Unterbrück | +49(8133)89-0 | +49(8133)89-199
ESG | ESG Einkaufs- und Service Gesellschaft mbH | Berliner Str. 26 | 33378 | Rheda-Wiedenbrück | +49(5242)9453-0 | +49(5242)9453-53
EUROKON | EUROPA-KONTOR GmbH & Co. KG | Amsterdamer Str 230 | 50735 | Köln | +49(221)971491-21 | +49(221)971491-60
EUROPA | GROSSEINKAUF EUROPA MÖBEL GmbH & Co. KG | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EVB | EVB BauPunkt Einkaufs- und Handelsgemeinschaft GmbH & Co. KG | Zillenhardtstr. 46 | 73037 | Göppingen | +49(7161)99931-70/ -71 | +49(7161)99931-72
EWEPA | E W E P A GmbH | Oberevinger Str. 5 | 44339 | Dortmund | +49(231)985127-0 | +49(231)-985127-17 / -18
FHG | FHG Fach-Handels-gesellschaft mbH & Co. KG | Brühler Str. 55/58 | 42657 | Solingen | +49(212)24809-0 | +49(212)24809-119
FHR | F H R Fachhandelsring GmbH | Am Pfaffensee 4 | 67376 | Harthausen | +49(6344)9533-0 | +49(6344)9533-90
FS | "FÜR SIE" Handelsgenossenschaft eg Food-Non Food | An der Münze 12-18 | 50668 | Köln | +49(221)16041-0 | +49(221)16041-821
GARANT | GARANT-MÖBEL-MARKETING LAUTEN GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
GEDK | Ge-dk Unternehmensbetreuungsgesellschaft mbH | Includes shape and material | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
GFM | G f M Möbeleinkaufsverbund GmbH & Co. Betriebs KG | Donaustr. 15 | 93333 | Neustadt a. d. D. | +49(9445)204-0 | +49(9445)204-155
HBO | H.B.O. Einkauf + Marketing GmbH & Co. | Dietrichsweg 64 | 26127 | Oldenburg | +49(441)96182-0 | +49(441)96182-55
HIS | Home in style Raumgsestaltung GmbH & Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-370 | +49(7231)915-259
HLH | HolzLand Holzhandels GmbH | Friedrich-Engels-Allee 432 | 42283 | Wuppertal | +49(202)55138-0 | +49(202)55138-10
HOLZRING | DER HOLZRING Handelsgesellschaft mbH | Universitätsallee 5 | 28359 | Bremen | +49(421)22315-0 | +49(421)22315-11
INKU | INKU GmbH + Co. | Nikolaus-Otto-Str. 6 | 70771 | Leinfelden-Echterdingen | +49(711)9492-438 | +49(711)9192-436
KA | K + A Küchen Aktuell GmbH | Senefelder Str. 2 a | 38124 | Braunschweig | +49(531)26134-0 | +49(531)26134-39
KAK | Küchen-Aktiv-Kreis | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KAREAL | Küchen Areal GmbH & Co. KG | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-163 | +49(5242)409-202
KARST | Karstadt Warenhaus AG | Theresienhöhe 5 | 80339 | München | +49(89)5105-0 | +49(89)5105-300
KATAG | KATAG International Partners GmbH | Stralsunder Str. 5 | 33605 | Bielefeld | +49(521)292-0 | +49(521)292-101/299
KAUFRING | KAUFRING AG | Kieshecker Weg 100 | 40468 | Düsseldorf | +49(211)4242-0 | +49(211)4242-444
KC | Küche & Co |  |  |  |  |
KER | Küchen-Einkaufs-Ring | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KGA | Koop Garant/Areal: EK-Grosseinkauf | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-559
KIG | Küchen-Interessen-Gesellschaft mbH | Strauberger Platz 19 | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
KL | Küchenliga | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
KOA | Koop Alliance FUTURA einkaufs-Gesellschaft mbH & Co. KG | Rolshoverstr. 227 | 51072 | Köln-Poll | +49(221)9836666 | +49(221)9836667
KP | Küchen Partner AG | Rüdesheimer Str. 34 | 65239 | Hochheim am Main | +49(6146)8340-0 | +49(6146)8340-40
KREIS | "DER KREIS" Einkaufsgesellschaft für Küche & Wohnen mbH & Co. KG | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)606700 | +49(7152)73017
KTEM | KTEM | Heemstr. 4 | 27793 | Wildeshausen | +49(4431)92067 | +49(4431)92069
LGF | MeisterTeam LGF GmbH | Rotenhäuser Str. 12 | 21109 | Hamburg | +49(40)7534091 | +49(40)7522019
LUTZ | LUTZ |  |  |  |  |
MBV | MBV Marketing Gesellschat mbH & Co. Lichthauspartner KG | Zeiloch 13 | 76643 | Bruchsal | +49(7251)7240890 | +49(7251)72408979
MDM | Küchenmarketing MDM GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
MHKD | musterhaus küchen Deutschland GmbH & Co. KG | Im Gefierth 9a | 36603 | Dreieich | +49(6103)391-0 | +49(6103)391-109
MIG | MIG Möbel-Interessen-Gemeinschaft GmbH & Co. KG | Industriestr. 41 | 53359 | Rheinbach | +49(2226)9221-0 | +49(2226)9221-22
MKK | Fachhändler Gemeinschaft "meister.Küchen-Konzepte" | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
MM | Möbel Mann GmbH | Durlacher Allee 109 | 76137 | Karlsruhe | +49(721)6096-298 | +49(721)6096-557
MON | Mondial GmbH | Eichsfelder Str. 17 | 40595 | Düsseldorf (Garath) | +49(211)702621-13 | +49(211)702621-30
MP | www.mig-power.de GmbH & Co.KG | Aktienstr. 2 | 45359 | Essen | +49(201)811710 | +49(201)2699838
MSI | Musterring International Josef Höner GmbH & Co. KG | Hauptstr. 134-140 | 33378 | Rheda-Wiedenbrück | +49(5242)592-01 | +49(5242)592-149
MV | Mega Verbund AG | St- Alban-Vorstadt 94 | CH-4052 | Basel | +41(61)2069070 | +41(61)-2069079
MZE | M Z E - Möbel-Zentral-Einkauf GmbH | Loheg 31 | 85375 | Neufarn b. Freising | +49(8165)9526-0 | +49(8165)9526-50
NB | Nürnberger Bund Grosseinkauf eG | Theodor-Althoff-Str. 39 | 45133 | Essen | +49(201)8709-0 |
NECK | Neckermann Versand AG | Hanauer Landstr. 360-400 | 60386 | Frankfurt/Main | +49(69)404-8697 | +49(69)404-8508
NOWEDA | NOWEDA eG | Heinrich-Strunk-Str. 77 | 45143 | Essen | +49(201)802-0 | +49(201)802-1314
NREM | nrc Nordring Einkauf- und Marketing-Cooperation GmbH | Am Redder 1 | 24558 | Henstedt-Ulzburg | +49(4193)9585-0 | +49(4193)9585-25
NWH | NORDWEST Handel AG | Berliner Str. 26-36 | 58135 | Hagen | +49(2331)461-0 | +49(2331)461-389
ÖkoPlus | ÖkoPlus AG Fachhandelsverbund für Ökologisches Bauen + Wohnen | Kasseler Str. 1 A | 60486 | Frankfurt | +49(69)70793013 | +49(69)70793016
OTTO | Otto Versand | Wandsbecker Str. 3-7 | 22179 | Hamburg | +49(40)64610 | +49(40)64618571
PARMA | parma-Aurel GmbH & Co. KG | Grosse-Kurfürsten-Str. 75 | 33615 | Bielefeld | +49(521)52077-0 | +49(521)52077-77
PRISMA | PRISMA Einkaufs- und Marketinggesellschaft mbH | Amsterdamer Str. 230 | 50735 | Köln | +49(221)971410-9 | +49(221)971410-84
ProÖko | Pro Öko Servicegesellschaft ökologischer Einrichtungshäuser mbH | Subbelrather Str. 24 | 50823 | Köln | +49(221)56968-0 | +49(221)56968-21
QUE | Grossversandhaus Quelle, Gustav Schickedanz KG | Thomas-Mann-Str. 50 | 90329 | Nürnberg 50 | +49(911)8152150 | +49(911)8152036
RED | Reddy Küchen und Elektro Vertriebs GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
REGENT | REGENT MÖBEL Grosseinkauf GmbH & Co. KG | Benzstr. 4 | 45891 | Gelsenkirchen | +49(209)9705-0 | +49(209)9705-188
SHK | S H K Einkaufs- und Vertriebsgesellschaft mbH & Co. KG | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
SOFATEX | sofatex Leistungsgemeinschaft GmbH | E.-C.-Baumann-Str. 12 | 95326 | Kulmbach | +49(9221)80064 | +49(9221)80066
SÜDRING | Südring GmbH & Co. KG | Nordstr. 71 | 63450 | Hanau | +49(6181)9104-0 | +49(6181)9104-44
TEV | Textil-Einkaufsverband "NORDWEST" eG | Nordweststr. | 59387 | Ascheberg | +49(2593)818 | +49(2593)7085
TREND | TReND Möbel-Handels-GmbH & Co. Einrichtungs KG | Im Lipperfeld 42 | 46047 | Oberhausen | +49(208)8205-0 | +49(208)8205-210
UNION | UNION Einkaufs GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | +49(211)47236-0 | +49(211)4180034
UNITEX | u n i t e x Einkaufsverband GmbH | Albrecht-Berblinger-Str. 11 | 89231 | Neu Ulm-Schwaighofen | +49(731)707940 | +49(731)7079446 / 7079424
VAR | Varia KE Franchise Warenvertriebsgesellschaft mbH | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)6097-25 | +49(7152)73017
VE | Vesta Küchenhandels GmbH | Industriestr. 9 | 96114 | Hirschaid | +49(9543)842330 | +49(9543)842340
VKG | V K G Vereinigter Küchenfachhandel GmbH + Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-0 | +49(7231)915-160
VME | V M E Vereinigte Möbeleinkaufs-GmbH & Co. KG | An der Wesebreede 2 | 33699 | Bielefeld | +49(521)20885-0 | +49(521)20885-60
WGMEM | Wohngruppe Möbeleinkauf + Marketing GmbH | Schleifweg 10 | 74257 | Untereisesheim | +49(7132)9988-0 | +49(7132)9988-44
WK | WK - WOHNEN Einrichtungs-GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +496103)391-109
WOTEX | Wotex Intercolor | Pappelweg 11 | 66578 | Schiffweiler | +49(6821)9614-0 | +49(6821)9614-60

</


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Standard handle orientations
View with Navigation Tools

Standard handle orientation | Denotation | Picture | Description
0 | Without drilling, with handle |  | valid for all types of front
1 | horizontally centred - vertical at outer edge |  | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). vertical orientation at outer edge for: doors; glass doors; roller shutters (vertical).
2 | horizontally centred - horizontal at outer edge |  | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontal orientation at outer edge for: doors; glass doors; roller shutters (vertical).
3 | vertically centred - vertical at outer edge |  | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). vertical orientation at outer edge for: doors; glass doors; roller shutters (vertical).
4 | vertically centred - horizontal at outer edge |  | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontal orientation at outer edge for: doors; glass doors; roller shutters (vertical).
5 | horizontally centred - vertically centred |  | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). vertically centred orientation for: doors; glass doors; roller shutters (vertical).
6 | horizontally centred - horizontally centred |  | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontally centred orientation for: doors; glass doors; roller shutters (vertical).
7 | vertically centred - vertically centred |  | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). vertically centred orientation for: doors; glass doors; roller shutters (vertical).
8 | vertically centred - horizontally centred |  | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontally centred orientation for: doors; glass doors; roller shutters (vertical).
9 | Horizontal at the top, full width - horizontal at the top, full width |  | orientation horizontal, full width, for: Drawers; pull-outs; shutters (horizontal). horizontal orientation full width for: doors; glass doors; flap doors; roller shutters (vertical).
10 | horizontal at the bottom of the element, full width - horizontal at the top of the element, full width |  | orientation at the bottom, full width, for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontal orientation full width for: doors; glass doors; roller shutters (vertical).
11 | horizontal at the top, full width - vertical at outer edge, full height |  | orientation horizontal, full width, for: Drawers; pull-outs; flap doors; shutters (horizontal). orientation at the outer edge, full height, for: doors; glass doors; roller shutters (vertical).
12 | horizontal at the bottom, full width - vertical at outer edge, full height |  | orientation at the bottom, full width, for: Drawers; pull-outs; flap doors; shutters (horizontal). orientation at the outer edge, full height, for: doors; glass doors; roller shutters (vertical).
90 | No standard handle orientation applicable. |  |
91 | No standard handle orientation applicable. |  |
92 | No standard handle orientation applicable. |  |
93 | No standard handle orientation applicable. |  |
94 | No standard handle orientation applicable. |  |
95 | No standard handle orientation applicable. |  |
96 | No standard handle orientation applicable. |  |
97 | No standard handle orientation applicable. |  |
98 | No standard handle orientation applicable. |  |
99 | Without drilling, without handle |  |


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Required version types
View with Navigation Tools

To assure that all necessary versions are available in the planning process, mandatory version types are defined and must be delivered in accordance with the model code of an item.

Model codes | required version types
Model code type 8 or 27 | 520,521
Model code type 26 | 562,563
Model code type 2 | 500,501
Model code type 29 | 514,515
Model code 5 | 550,551
Model code 20 or 21 | 510,511
Model code 12 | 504,505
Model code 11 | 502,503
Model code 14 or 15 | 400,401,402
Model code 18 | 650,651
Model code 17 | 600,601
Front type code 4 | 151, 154, 208
Branch_ID=K | 101,202,203,205

All model codes can be found in the model code table.

The model code type can be found in the model code types table


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Filename
View with Navigation Tools
Introduction > Filename

The following is recommended for the file name associated with a data record:

· The name of the data record must not be limited to 8 characters.

· If possible, all components from the CATALOG_IDENTIFICATION should be used:

· The following components are suggested:

· Manufacturer number

· IDM version

· Customer number (value from the ASSOC_CTM_NO element)

· All languages

· Year

· Major number (MAJOR)

· File release timestamp (FILE_RELEASE_DATE)


%%LocalItemTitle%%

Modifikation IDM 2.7.0 XML-Schema
Elements
Element | Description
T_MODIFY_CATALOG | This element is used to specify all information and data for the modification of an existing catalogue/data pool.
Complex Types
Complex Type | Description
languagetexte | This data type is used for multilingual text information of any length.
languagetexte30 | This element is used for multilingual text information limited to 30 characters.
languagetexte40 | This element is used for multilingual text information limited to 40 characters.
languagetexte60 | This element is used for multilingual text information limited to 60 characters.
languagetexte60999 | This element is used for multilingual text information limited to 60 characters per line. The maximum length of the complete element is limited to 999 lines.

© 2020 All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Element reference
View with Navigation Tools


%%LocalItemTitle%%

T_MODIFY_CATALOG Element
Modifikation IDM 2.7.0 XML-Schema : T_MODIFY_CATALOG Element
Description
This element is used to specify all information and data for the modification of an existing catalogue/data pool.
Namespace (none)
Diagram
PRICE_DEFINITION Element FEATURE_DEFINITION Element SERIES Element REF_CATALOG Element CATALOG Element Signature Element Sequence T_MODIFY_CATALOG Element
Overview
T_MODIFY_CATALOG
This element is used to specify all information and data for the modification of an existing catalogue/data pool.
MAJOR required Restriction of xs:positiveInteger
The version number "MAJOR" indicates the format version of the database. This main version number is only changed if the format is changed completely.
The complete definition of a format version consists of the following elements: MAJOR, MINOR and REVISION. 		D nonNegativeInteger
P
M [2]
MINOR required Restriction of xs:nonNegativeInteger
In general the number of the sub-version "MINOR" changes every year. In case the main version number MAJOR is changed, the sub-version number is reset to 0.
 D nonNegativeInteger
P
M [0:99]
REVISION required Restriction of xs:nonNegativeInteger
During the year the field revision number "REVISION" indicates changes of the format, as agreed upon in the regular sessions of the committee. The different revisions are not issued unless they are necessary corrections. The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. D nonNegativeInteger
P
M [0:99]
Sequence
Signature optional

This element defines the type of encryption.

The root element of a digital signature via XML is represented by the element Signature.

Signature has two child elements in which the elements SignedInfo and SignatureValue are mandatory.

Sequence
SignedInfo

The first and most complex element of Signature is the element SignedInfo. This element contains the utilized algorithms for canonization and signature, one or more references to the signed data, and probable transformations as well as the hash values of these data. Moreover the element SignedInfo contains all relevant information about the resources which are signed and is therefore the part for which the digital signature is defined.

Digital signature of the algorithms is used for the purpose of data security. A secure algorithm cannot be exchanged by an insecure without cancellation of the signature.

Child elements of SignedInfo are the mandatory elements CanonizationMethod and SignatureMethod as well as one or more Reference elements.

Sequence
CanonicalizationMethod Extension of xs:string

The mandatory element CanonizationMethod contains an Algorithm attribute which identifies the canonization algorithm which is applied to the data with priority over signature evaluation in the element SignedInfo.

The canonization of an XML is split up into the following actions:

  • A document is encoded into UTF-8 format
  • Line breaks are normalised to #xA before parsing
  • The values of attributes are normalised (similar to validating parsers)
  • Character- and parsed-entity references are replaced
  • CDATA paragraphs are replaced by their contents
  • The XML declaration and a probably existing DTD are removed
  • Blank elements are converted to start-end-tag pairs
  • Whitespace outside of the document element and inside the start- and end-tags is normalised
  • Whitespace in text knots is kept (except signs which were removed by the normalisation of line breaks)
  • The values of attributes are given in double quotation marks
  • Special characters in attribute values and text knots are replaced by sign references
  • Redundant namespace declarations in front of each element are removed
  • Default attributes are added to the elements
  • The sort order of namespace declarations and attributes is alphanumeric
Algorithm optional xs:anyURI
This attribute identifies the Canonization-algorithm, which is applied to data with priority over the signature calculation in the element SignedInfo. The specification is given by an URI. D anyURI
P
M
SignatureMethod Extension of xs:string
SignatureMethod is another mandatory, blank element with an algorithm attribute, which defines the algorithm used for the generation (and following the validation) of the signature. This algorithm is used for converting the canonical element SignedInfo into the element SignatureValue.
Algorithm optional xs:anyURI

This attribute is used for defining an algorithm for the generation of a signature which is defined by an URI.

 D anyURI
P
M
Reference

The element reference defines the random data (binary data permitted, too) which are included in the signature calculation. The element reference is therefore the core element of a signature.

XML-signatures never sign the resources directly. First a list of hash values is generated. This list is signed with the defined algorithm. In this way the process of the signature generation is accelerated and simplified as a number of resources is signed simultaneously.

The element reference is linked to the optional attribute URI.

URI optional xs:string

The type of the attribute URI is that of anyURI and contains the address of the data which have to be signed. It is not necessary that the data which the digital signature refers to are part of the element signature. The data can be referenced by a local file system or an hyperlink.

Moreover there are URI which refer to the current document ,e.g. URI="". This special type of Uniform Resource Identifier represents all XML knots of the current XML document but without probable comments. The knots which belong to a signature are part of repertory.

 D anyURI
P
M
Sequence
Transforms

The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.

Sequence
Transform Extension of xs:string

The element transform defines the type of transformation. It consists of an Algorithm Attribute with the applicable transformation algorithm.

 D string
P
M
Algorithm optional xs:anyURI

This attribute is used for defining a transformation algorithm by means of an URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.
Algorithm optional xs:anyURI

This attribute is used for defining the URI which identifies the message digest algorithm.

D anyURI
P
M
DigestValue xs:string
The algorithm defined in the element DigestMethod is used for calculating the DigestValue, which is a unique hash value of the signed object and saved in base-64 encoding format. The hash value is a kind of digital finger print, in general it is shorter than the data which were signed. In this way the following steps of digital signature are accelerated. It is almost impossible to infer the original message from the given hash value. D string
P
M
SignatureValue xs:string

The element SignatureValue contains the binary hash value of the signature (always Base-64 encoded) calculated over the complete element SignedInfo . This hash value is given according to the algorithm defined in the element SignatureMethod and calculated from the canonized data and the private key. In this way it is not the message itself which is signed but only its (normally shorter) hash value ( Hash-Then-Sign Paradigma).

The signed data contain all information about the signed references and their hash values. Therefore it is not necessary that the data themselves are available in the document. All information about the utilized algorithms are part of the signature generation and subsequent manipulations are avoided.

As all references are summarized before the signature generation the complete signature has always exactly one SignatureValue element.

D string
P
M
CATALOG
All administrative information about the catalogue/ database is stored in this element.
Sequence
FILE_RELEASE_DATE xs:dateTime
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contains the current date and time (UTC). D dateTime
P
M
CATALOG_IDENTIFICATION
This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
This element is used for the definition of the currency ID which applies to all prices given in a catalogue/ database. The rules and definitions of the ISO Currency-ID apply.
A change of currency keys within one database is not permitted. Updates during the year and also block prices haven to be given in the same currency unit as that of the basic file. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
For transnational catalogues with an identical currency key this element is used for assigning a database to one country by the different ISO country codes. D string
P [A-Z]{2}
M [2:2]
CATALOG_KIND Restriction of xs:positiveInteger

This field is used to identify association catalogues.
The following values can be used:
2 = association catalogue
3 = customer-specific catalogue

If 2 or 3 is entered in the field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

 D positiveInteger
P
M [2:3]
ASSOC_CTM_NO Restriction of xs:string
This element is used to specify the customer number of the Association or customer for which the data pool is available.
The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
This element is used for the definition of a price ID, i.e. the way in which the prices in a catalogue are given.

The following price IDs are possible:
1 = Price;
2 = Ident number;
3 = calculation point.

If the flags 1 (price) or 2 (ident number) are filled in, a currency has to be filled in the field CURRENCY_KEY. If the flag 3 (calculation point) is set, values in the element CURRENCY_KEY are not permitted. If calculation points are used the the conversion factor has to be defined. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
This element is used for the definition of the VAT key which is applied to the prices given in a database.
The following values are used:
0/False = prices excluding VAT
1/True = prices including VAT

This element is of essential importance for the pricing. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
This element defines a distinct number for the catalogue which is represented in the database. The catalogue number is manufacturer specific. D string
P
M [1:10]
CATALOG_YEAR xs:gYear
This element refers to the calendar year of the catalogue data in the main catalogue. D gYear
P
M
MIN_MAJOR_NO Restriction of xs:positiveInteger
The main catalogue's major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged. Element MIN_MAJOR_NO contains the minimum value of the main catalogues's MAJOR_NO. D positiveInteger
P
M 1:99
CATALOG_NAME languagetexte30 Complex Type
This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database. D date
P
M
FILE_ID Restriction of xs:boolean
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
This element is used to highlight the provision M data = data that has been modified from the main catalogue. D string
P [M]
M [1:1]
CATALOG_INFO languagetexte60999 Complex Type
Information texts are stored in this element.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
REF_CATALOG
This element is used to specify the catalogue to which the modification file relates.
Sequence
CATALOG_IDENTIFICATION
This element is used to identify the catalogue to which this modification file relates. A catalogue is identified unequivocally by the combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data, the corresponding block data or the value settlement must be identical.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
This element is used to enter the manufacturer ID valid for the manufacturer. The manufacturer IDs are defined in the table "Manufacturer ID". Leading zeros are omitted in the manufacturer ID. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISOLanguage code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
This element is used to specify the correct country allocation where a language is spoken in multiple countries and the identical currency is specified. The ISO country code must be entered. D string
P [A-Z]{2}
M [2:2]
ASSOC_CTM_NO optional Restriction of xs:string
This element is used to specify the customer number of the Association or customer for which the data pool is available.
The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "codes for purchasing associations") Purchasing associations 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

The product brand assists in the unequivocal definition of a catalogue. It should be kept up-to-date in this element as required.

This is done by specifying a freely-definable number, which must remain identical for the validity of a product by across multiple catalogue rounds. This allows the software houses to allocate a catalogue to the previous year's catalogue, which in turn allows for a more efficient implementation of catalogues.

 D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
This element is used to specify a price ID used to define the types of prices in the data pool.

The following price IDs can be used:
1 = price;
2 = identification number;
3 = settlement point.

If 1 (price) or 2 (identification number) is entered in this field, a currency must be specified in the CURRENCY_KEY element. If 3 is entered in this element (settlement point), the CURRENCY_KEY element must be left blank. In the case of settlement points, the corresponding settlement factor must be specified. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
This element is used to specify the VAT ID used for pricing in the data pool.
The following values can be used:
0/False = exclusive of VAT
1/True = inclusive of VAT
This element is very important for pricing. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
CATALOG_NAME languagetexte30 Complex Type
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names with years are permitted as the unequivocal identification of the catalogue takes place via the PRODUCT_BRANDNAME element.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
SERIES optional
This element is used to specify all series of the catalogue/data pool that were modified from the base catalogue including their assigned elements, such as product groups or articles.
Sequence
SERIE 1..100
This element is used to define the series that were modified from the base catalogue.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the serial number of the series. D nonNegativeInteger
P
M [0:99]
Sequence
SERIES_NAME optional
This element defines the name of the series.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element defines a text line.
The element TEXT contains text information.
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
PRODUCT_GROUPS
This element is used to reference to the product groups that were modified from the base catalogue.Articles with the same version types e.g. shelf units are grouped into product groups.
Sequence
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups in the base catalogue. "Identical" product groups must therefore not be captured.
Sequence
ITEMS
This element is used to reference all articles within a product group that are to be modified.
Sequence
ITEM 1..∞
This element is used to specify items and blocks with a different validity than in the base catalogue. An item is identified via the SERIE_NO and TYPE_NO attributes of the main catalogue.
FEATURE_DEFINITION optional
This element is used to specify version-specific information that is to be modified.
Sequence
FEATURES
This element is used to define the version types (FEATURE) and the associated versions to be modified. Only version types that are required for modifying the catalogue are specified.
Sequence
FEATURE 1..∞
This element is used to define a version type.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a feature. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
This element is used as a container for all possible options of a feature type.
Sequence
OPTION 1..∞
This element is used to define the versions for version type. This element is used to store all versions to be modified in the data pool.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required. D string
P
M [1:5]
Sequence
OPTION_TEXT optional languagetexte60 Complex Type
This element is used to define a modified version text.
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element is used to modify a general comment as a notice of special properties of a version. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
VALID_FROM optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FRONT element is filled: available from delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
VALID_UNTIL optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FROM element is filled: on available for delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
PRICE_DEFINITION optional
This element is used to specify information for the catalogue modification that is necessary for the price calculation, such as price tables and design ranges.
Sequence
PRICE_FEATURE_GROUPS
This element is used to reference price version groups that are modified from the base catalogue.
Sequence
PRICE_FEATURE_GROUP 1..∞
This element is used to reference a price version group that contains information on modifications from the base catalogue.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine zu modifizierende PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
Sequence
FINISH 0..∞
This element is used to assign version combinations to modified price fields (price field, block price field) and a manufacturer price group.
Sequence
OPTION_REF 0..2
This element is used to reference a version.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a version type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used to reference a version type. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1or path 2 in the base catalogue).
Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

This field is used to specify in which modified price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2 in the base catalogue).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer does not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
This catalogue is used to specify the manufacturer's modified price group.

In the case of type-specific prices (PRICE_CALC_METHOD = 3), the value of the PRICE_FIELD element is "copied" into field SUPPLIER_PRICE_GROUP.
For universal prices (PRICE_CALC_METHOD = 1), any content can be used and will not be analysed. 		D string
P
M [1:10]
Attributes
Name Type Use Default Fixed Description
MAJOR Restriction of xs:positiveInteger required
The version number "MAJOR" indicates the format version of the database. This main version number is only changed if the format is changed completely.
The complete definition of a format version consists of the following elements: MAJOR, MINOR and REVISION. 		D nonNegativeInteger
P
M [2]
MINOR Restriction of xs:nonNegativeInteger required
In general the number of the sub-version "MINOR" changes every year. In case the main version number MAJOR is changed, the sub-version number is reset to 0.
 D nonNegativeInteger
P
M [0:99]
REVISION Restriction of xs:nonNegativeInteger required
During the year the field revision number "REVISION" indicates changes of the format, as agreed upon in the regular sessions of the committee. The different revisions are not issued unless they are necessary corrections. The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="T_MODIFY_CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Signature" minOccurs="0" maxOccurs="1">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SignedInfo">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CanonicalizationMethod">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SignatureMethod">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="Reference">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="Transforms">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="Transform">
                                <xs:complexType>
                                  <xs:simpleContent>
                                    <xs:extension base="xs:string">
                                      <xs:attribute name="Algorithm" type="xs:anyURI" />
                                    </xs:extension>
                                  </xs:simpleContent>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DigestMethod">
                          <xs:complexType>
                            <xs:simpleContent>
                              <xs:extension base="xs:string">
                                <xs:attribute name="Algorithm" type="xs:anyURI" />
                              </xs:extension>
                            </xs:simpleContent>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DigestValue" type="xs:string" />
                      </xs:sequence>
                      <xs:attribute name="URI" type="xs:string" />
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SignatureValue" type="xs:string" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FILE_RELEASE_DATE" type="xs:dateTime">
              <xs:annotation>
                <xs:documentation>100--2--Dateifreigabe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_ID">
                    <xs:annotation>
                      <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                      <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:language">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CURRENCY_KEY">
                    <xs:annotation>
                      <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                      <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{1,3}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>100--13--Laender_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CATALOG_KIND">
                    <xs:annotation>
                      <xs:documentation>Katalog-Art</xs:documentation>
                      <xs:documentation>2 für Verbandskatalog</xs:documentation>
                      <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
                      <xs:documentation>geändert 17.04.2019</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="3" />
                        <xs:minInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ASSOC_CTM_NO">
                    <xs:annotation>
                      <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRODUCT_BRANDNAME">
                    <xs:annotation>
                      <xs:documentation>100--40--Produktmarke</xs:documentation>
                      <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_ID">
                    <xs:annotation>
                      <xs:documentation>100--49--Preis_ID</xs:documentation>
                      <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VAT">
                    <xs:annotation>
                      <xs:documentation>200--4--MwSt</xs:documentation>
                      <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CATALOG_NUMBER">
              <xs:annotation>
                <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_YEAR" type="xs:gYear">
              <xs:annotation>
                <xs:documentation>Jahr der Neuerstellung</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="MIN_MAJOR_NO">
              <xs:annotation>
                <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_NAME" type="languagetexte30">
              <xs:annotation>
                <xs:documentation>100--10--Katalog_Name</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="DATA_VERSION">
              <xs:annotation>
                <xs:documentation>100--11--Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILE_ID">
              <xs:annotation>
                <xs:documentation>100--14--Datei_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MARK">
              <xs:annotation>
                <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
                <xs:documentation>M = Modifikation</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[M]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_INFO" type="languagetexte60999">
              <xs:annotation>
                <xs:documentation>110--3--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="REF_CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CATALOG_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_ID">
                    <xs:annotation>
                      <xs:documentation>100--5--Hersteller_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:language">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CURRENCY_KEY">
                    <xs:annotation>
                      <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{1,3}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>100--13--Laender_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ASSOC_CTM_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRODUCT_BRANDNAME">
                    <xs:annotation>
                      <xs:documentation>100--40--Produktmarke</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_ID">
                    <xs:annotation>
                      <xs:documentation>100--49--Preis_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VAT">
                    <xs:annotation>
                      <xs:documentation>200--4--MwSt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CATALOG_NUMBER">
              <xs:annotation>
                <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_NAME" type="languagetexte30">
              <xs:annotation>
                <xs:documentation>100--10--Katalog_Name</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIES" minOccurs="0">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE" maxOccurs="100">
              <xs:annotation>
                <xs:documentation>200--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIES_NAME" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>200--3--Serienname</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>200--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>200--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRODUCT_GROUPS">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEMS">
                                <xs:annotation>
                                  <xs:documentation>400--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="VALID_FROM" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:date" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VALID_UNTIL" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:date" />
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURES">
              <xs:annotation>
                <xs:documentation>250--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>300--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
                                <xs:annotation>
                                  <xs:documentation>311--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>311--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>311--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_FIELD">
                                <xs:annotation>
                                  <xs:documentation>311--5--Preisfeld</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="SUPPLIER_PRICE_GROUP">
                                <xs:annotation>
                                  <xs:documentation>311--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="10" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MAJOR" use="required">
      <xs:annotation>
        <xs:documentation>100--3--Versionsnummer</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="2" />
          <xs:maxInclusive value="2" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MINOR" use="required">
      <xs:annotation>
        <xs:documentation>100--4--Sub_Versions_Nr</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="REVISION" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Signature Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element : Signature Element
Description

This element defines the type of encryption.

The root element of a digital signature via XML is represented by the element Signature.

Signature has two child elements in which the elements SignedInfo and SignatureValue are mandatory.

Namespace (none)
Diagram
SignatureValue Element SignedInfo Element Sequence Signature Element
Overview
Signature optional

This element defines the type of encryption.

The root element of a digital signature via XML is represented by the element Signature.

Signature has two child elements in which the elements SignedInfo and SignatureValue are mandatory.

Sequence
SignedInfo

The first and most complex element of Signature is the element SignedInfo. This element contains the utilized algorithms for canonization and signature, one or more references to the signed data, and probable transformations as well as the hash values of these data. Moreover the element SignedInfo contains all relevant information about the resources which are signed and is therefore the part for which the digital signature is defined.

Digital signature of the algorithms is used for the purpose of data security. A secure algorithm cannot be exchanged by an insecure without cancellation of the signature.

Child elements of SignedInfo are the mandatory elements CanonizationMethod and SignatureMethod as well as one or more Reference elements.

Sequence
CanonicalizationMethod Extension of xs:string

The mandatory element CanonizationMethod contains an Algorithm attribute which identifies the canonization algorithm which is applied to the data with priority over signature evaluation in the element SignedInfo.

The canonization of an XML is split up into the following actions:

  • A document is encoded into UTF-8 format
  • Line breaks are normalised to #xA before parsing
  • The values of attributes are normalised (similar to validating parsers)
  • Character- and parsed-entity references are replaced
  • CDATA paragraphs are replaced by their contents
  • The XML declaration and a probably existing DTD are removed
  • Blank elements are converted to start-end-tag pairs
  • Whitespace outside of the document element and inside the start- and end-tags is normalised
  • Whitespace in text knots is kept (except signs which were removed by the normalisation of line breaks)
  • The values of attributes are given in double quotation marks
  • Special characters in attribute values and text knots are replaced by sign references
  • Redundant namespace declarations in front of each element are removed
  • Default attributes are added to the elements
  • The sort order of namespace declarations and attributes is alphanumeric
Algorithm optional xs:anyURI
This attribute identifies the Canonization-algorithm, which is applied to data with priority over the signature calculation in the element SignedInfo. The specification is given by an URI. D anyURI
P
M
SignatureMethod Extension of xs:string
SignatureMethod is another mandatory, blank element with an algorithm attribute, which defines the algorithm used for the generation (and following the validation) of the signature. This algorithm is used for converting the canonical element SignedInfo into the element SignatureValue.
Algorithm optional xs:anyURI

This attribute is used for defining an algorithm for the generation of a signature which is defined by an URI.

 D anyURI
P
M
Reference

The element reference defines the random data (binary data permitted, too) which are included in the signature calculation. The element reference is therefore the core element of a signature.

XML-signatures never sign the resources directly. First a list of hash values is generated. This list is signed with the defined algorithm. In this way the process of the signature generation is accelerated and simplified as a number of resources is signed simultaneously.

The element reference is linked to the optional attribute URI.

URI optional xs:string

The type of the attribute URI is that of anyURI and contains the address of the data which have to be signed. It is not necessary that the data which the digital signature refers to are part of the element signature. The data can be referenced by a local file system or an hyperlink.

Moreover there are URI which refer to the current document ,e.g. URI="". This special type of Uniform Resource Identifier represents all XML knots of the current XML document but without probable comments. The knots which belong to a signature are part of repertory.

 D anyURI
P
M
Sequence
Transforms

The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.

Sequence
Transform Extension of xs:string

The element transform defines the type of transformation. It consists of an Algorithm Attribute with the applicable transformation algorithm.

 D string
P
M
Algorithm optional xs:anyURI

This attribute is used for defining a transformation algorithm by means of an URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.
Algorithm optional xs:anyURI

This attribute is used for defining the URI which identifies the message digest algorithm.

D anyURI
P
M
DigestValue xs:string
The algorithm defined in the element DigestMethod is used for calculating the DigestValue, which is a unique hash value of the signed object and saved in base-64 encoding format. The hash value is a kind of digital finger print, in general it is shorter than the data which were signed. In this way the following steps of digital signature are accelerated. It is almost impossible to infer the original message from the given hash value. D string
P
M
SignatureValue xs:string

The element SignatureValue contains the binary hash value of the signature (always Base-64 encoded) calculated over the complete element SignedInfo . This hash value is given according to the algorithm defined in the element SignatureMethod and calculated from the canonized data and the private key. In this way it is not the message itself which is signed but only its (normally shorter) hash value ( Hash-Then-Sign Paradigma).

The signed data contain all information about the signed references and their hash values. Therefore it is not necessary that the data themselves are available in the document. All information about the utilized algorithms are part of the signature generation and subsequent manipulations are avoided.

As all references are summarized before the signature generation the complete signature has always exactly one SignatureValue element.

D string
P
M
Source
<xs:element name="Signature" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SignedInfo">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CanonicalizationMethod">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="SignatureMethod">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="Reference">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="Transforms">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="Transform">
                          <xs:complexType>
                            <xs:simpleContent>
                              <xs:extension base="xs:string">
                                <xs:attribute name="Algorithm" type="xs:anyURI" />
                              </xs:extension>
                            </xs:simpleContent>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DigestMethod">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DigestValue" type="xs:string" />
                </xs:sequence>
                <xs:attribute name="URI" type="xs:string" />
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SignatureValue" type="xs:string" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SignedInfo Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element : SignedInfo Element
Description

The first and most complex element of Signature is the element SignedInfo. This element contains the utilized algorithms for canonization and signature, one or more references to the signed data, and probable transformations as well as the hash values of these data. Moreover the element SignedInfo contains all relevant information about the resources which are signed and is therefore the part for which the digital signature is defined.

Digital signature of the algorithms is used for the purpose of data security. A secure algorithm cannot be exchanged by an insecure without cancellation of the signature.

Child elements of SignedInfo are the mandatory elements CanonizationMethod and SignatureMethod as well as one or more Reference elements.

Namespace (none)
Diagram
Reference Element SignatureMethod Element CanonicalizationMethod Element Sequence SignedInfo Element
Overview
SignedInfo

The first and most complex element of Signature is the element SignedInfo. This element contains the utilized algorithms for canonization and signature, one or more references to the signed data, and probable transformations as well as the hash values of these data. Moreover the element SignedInfo contains all relevant information about the resources which are signed and is therefore the part for which the digital signature is defined.

Digital signature of the algorithms is used for the purpose of data security. A secure algorithm cannot be exchanged by an insecure without cancellation of the signature.

Child elements of SignedInfo are the mandatory elements CanonizationMethod and SignatureMethod as well as one or more Reference elements.

Sequence
CanonicalizationMethod Extension of xs:string

The mandatory element CanonizationMethod contains an Algorithm attribute which identifies the canonization algorithm which is applied to the data with priority over signature evaluation in the element SignedInfo.

The canonization of an XML is split up into the following actions:

  • A document is encoded into UTF-8 format
  • Line breaks are normalised to #xA before parsing
  • The values of attributes are normalised (similar to validating parsers)
  • Character- and parsed-entity references are replaced
  • CDATA paragraphs are replaced by their contents
  • The XML declaration and a probably existing DTD are removed
  • Blank elements are converted to start-end-tag pairs
  • Whitespace outside of the document element and inside the start- and end-tags is normalised
  • Whitespace in text knots is kept (except signs which were removed by the normalisation of line breaks)
  • The values of attributes are given in double quotation marks
  • Special characters in attribute values and text knots are replaced by sign references
  • Redundant namespace declarations in front of each element are removed
  • Default attributes are added to the elements
  • The sort order of namespace declarations and attributes is alphanumeric
Algorithm optional xs:anyURI
This attribute identifies the Canonization-algorithm, which is applied to data with priority over the signature calculation in the element SignedInfo. The specification is given by an URI. D anyURI
P
M
SignatureMethod Extension of xs:string
SignatureMethod is another mandatory, blank element with an algorithm attribute, which defines the algorithm used for the generation (and following the validation) of the signature. This algorithm is used for converting the canonical element SignedInfo into the element SignatureValue.
Algorithm optional xs:anyURI

This attribute is used for defining an algorithm for the generation of a signature which is defined by an URI.

 D anyURI
P
M
Reference

The element reference defines the random data (binary data permitted, too) which are included in the signature calculation. The element reference is therefore the core element of a signature.

XML-signatures never sign the resources directly. First a list of hash values is generated. This list is signed with the defined algorithm. In this way the process of the signature generation is accelerated and simplified as a number of resources is signed simultaneously.

The element reference is linked to the optional attribute URI.

URI optional xs:string

The type of the attribute URI is that of anyURI and contains the address of the data which have to be signed. It is not necessary that the data which the digital signature refers to are part of the element signature. The data can be referenced by a local file system or an hyperlink.

Moreover there are URI which refer to the current document ,e.g. URI="". This special type of Uniform Resource Identifier represents all XML knots of the current XML document but without probable comments. The knots which belong to a signature are part of repertory.

 D anyURI
P
M
Sequence
Transforms

The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.

Sequence
Transform Extension of xs:string

The element transform defines the type of transformation. It consists of an Algorithm Attribute with the applicable transformation algorithm.

 D string
P
M
Algorithm optional xs:anyURI

This attribute is used for defining a transformation algorithm by means of an URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.
Algorithm optional xs:anyURI

This attribute is used for defining the URI which identifies the message digest algorithm.

D anyURI
P
M
DigestValue xs:string
The algorithm defined in the element DigestMethod is used for calculating the DigestValue, which is a unique hash value of the signed object and saved in base-64 encoding format. The hash value is a kind of digital finger print, in general it is shorter than the data which were signed. In this way the following steps of digital signature are accelerated. It is almost impossible to infer the original message from the given hash value. D string
P
M
Source
<xs:element name="SignedInfo" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CanonicalizationMethod">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="SignatureMethod">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="Reference">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="Transforms">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="Transform">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DigestMethod">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="DigestValue" type="xs:string" />
          </xs:sequence>
          <xs:attribute name="URI" type="xs:string" />
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CanonicalizationMethod Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element : CanonicalizationMethod Element
Description

The mandatory element CanonizationMethod contains an Algorithm attribute which identifies the canonization algorithm which is applied to the data with priority over signature evaluation in the element SignedInfo.

The canonization of an XML is split up into the following actions:

  • A document is encoded into UTF-8 format
  • Line breaks are normalised to #xA before parsing
  • The values of attributes are normalised (similar to validating parsers)
  • Character- and parsed-entity references are replaced
  • CDATA paragraphs are replaced by their contents
  • The XML declaration and a probably existing DTD are removed
  • Blank elements are converted to start-end-tag pairs
  • Whitespace outside of the document element and inside the start- and end-tags is normalised
  • Whitespace in text knots is kept (except signs which were removed by the normalisation of line breaks)
  • The values of attributes are given in double quotation marks
  • Special characters in attribute values and text knots are replaced by sign references
  • Redundant namespace declarations in front of each element are removed
  • Default attributes are added to the elements
  • The sort order of namespace declarations and attributes is alphanumeric
Namespace (none)
Type
Extension of xs:string
Diagram
CanonicalizationMethod Element
Overview
CanonicalizationMethod Extension of xs:string

The mandatory element CanonizationMethod contains an Algorithm attribute which identifies the canonization algorithm which is applied to the data with priority over signature evaluation in the element SignedInfo.

The canonization of an XML is split up into the following actions:

  • A document is encoded into UTF-8 format
  • Line breaks are normalised to #xA before parsing
  • The values of attributes are normalised (similar to validating parsers)
  • Character- and parsed-entity references are replaced
  • CDATA paragraphs are replaced by their contents
  • The XML declaration and a probably existing DTD are removed
  • Blank elements are converted to start-end-tag pairs
  • Whitespace outside of the document element and inside the start- and end-tags is normalised
  • Whitespace in text knots is kept (except signs which were removed by the normalisation of line breaks)
  • The values of attributes are given in double quotation marks
  • Special characters in attribute values and text knots are replaced by sign references
  • Redundant namespace declarations in front of each element are removed
  • Default attributes are added to the elements
  • The sort order of namespace declarations and attributes is alphanumeric
Algorithm optional xs:anyURI
This attribute identifies the Canonization-algorithm, which is applied to data with priority over the signature calculation in the element SignedInfo. The specification is given by an URI. D anyURI
P
M
Attributes
Name Type Use Default Fixed Description
Algorithm xs:anyURI optional
This attribute identifies the Canonization-algorithm, which is applied to data with priority over the signature calculation in the element SignedInfo. The specification is given by an URI. D anyURI
P
M
Source
<xs:element name="CanonicalizationMethod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
See Also
SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SignatureMethod Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element : SignatureMethod Element
Description
SignatureMethod is another mandatory, blank element with an algorithm attribute, which defines the algorithm used for the generation (and following the validation) of the signature. This algorithm is used for converting the canonical element SignedInfo into the element SignatureValue.
Namespace (none)
Type
Extension of xs:string
Diagram
SignatureMethod Element
Overview
SignatureMethod Extension of xs:string
SignatureMethod is another mandatory, blank element with an algorithm attribute, which defines the algorithm used for the generation (and following the validation) of the signature. This algorithm is used for converting the canonical element SignedInfo into the element SignatureValue.
Algorithm optional xs:anyURI

This attribute is used for defining an algorithm for the generation of a signature which is defined by an URI.

 D anyURI
P
M
Attributes
Name Type Use Default Fixed Description
Algorithm xs:anyURI optional

This attribute is used for defining an algorithm for the generation of a signature which is defined by an URI.

 D anyURI
P
M
Source
<xs:element name="SignatureMethod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
See Also
SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Reference Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element : Reference Element
Description

The element reference defines the random data (binary data permitted, too) which are included in the signature calculation. The element reference is therefore the core element of a signature.

XML-signatures never sign the resources directly. First a list of hash values is generated. This list is signed with the defined algorithm. In this way the process of the signature generation is accelerated and simplified as a number of resources is signed simultaneously.

The element reference is linked to the optional attribute URI.

Namespace (none)
Diagram
DigestValue Element DigestMethod Element Transforms Element Sequence Reference Element
Overview
Reference

The element reference defines the random data (binary data permitted, too) which are included in the signature calculation. The element reference is therefore the core element of a signature.

XML-signatures never sign the resources directly. First a list of hash values is generated. This list is signed with the defined algorithm. In this way the process of the signature generation is accelerated and simplified as a number of resources is signed simultaneously.

The element reference is linked to the optional attribute URI.

URI optional xs:string

The type of the attribute URI is that of anyURI and contains the address of the data which have to be signed. It is not necessary that the data which the digital signature refers to are part of the element signature. The data can be referenced by a local file system or an hyperlink.

Moreover there are URI which refer to the current document ,e.g. URI="". This special type of Uniform Resource Identifier represents all XML knots of the current XML document but without probable comments. The knots which belong to a signature are part of repertory.

 D anyURI
P
M
Sequence
Transforms

The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.

Sequence
Transform Extension of xs:string

The element transform defines the type of transformation. It consists of an Algorithm Attribute with the applicable transformation algorithm.

 D string
P
M
Algorithm optional xs:anyURI

This attribute is used for defining a transformation algorithm by means of an URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.
Algorithm optional xs:anyURI

This attribute is used for defining the URI which identifies the message digest algorithm.

D anyURI
P
M
DigestValue xs:string
The algorithm defined in the element DigestMethod is used for calculating the DigestValue, which is a unique hash value of the signed object and saved in base-64 encoding format. The hash value is a kind of digital finger print, in general it is shorter than the data which were signed. In this way the following steps of digital signature are accelerated. It is almost impossible to infer the original message from the given hash value. D string
P
M
Attributes
Name Type Use Default Fixed Description
URI xs:string optional

The type of the attribute URI is that of anyURI and contains the address of the data which have to be signed. It is not necessary that the data which the digital signature refers to are part of the element signature. The data can be referenced by a local file system or an hyperlink.

Moreover there are URI which refer to the current document ,e.g. URI="". This special type of Uniform Resource Identifier represents all XML knots of the current XML document but without probable comments. The knots which belong to a signature are part of repertory.

 D anyURI
P
M
Source
<xs:element name="Reference" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Transforms">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="Transform">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DigestMethod">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="DigestValue" type="xs:string" />
    </xs:sequence>
    <xs:attribute name="URI" type="xs:string" />
  </xs:complexType>
</xs:element>
See Also
SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Transforms Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element > Reference Element : Transforms Element
Description

The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.

Namespace (none)
Diagram
Transform Element Sequence Transforms Element
Overview
Transforms

The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.

Sequence
Transform Extension of xs:string

The element transform defines the type of transformation. It consists of an Algorithm Attribute with the applicable transformation algorithm.

 D string
P
M
Algorithm optional xs:anyURI

This attribute is used for defining a transformation algorithm by means of an URI.

 D anyURI
P
M
Source
<xs:element name="Transforms" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Transform">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
Reference Element | SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Transform Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element > Reference Element > Transforms Element : Transform Element
Description

The element transform defines the type of transformation. It consists of an Algorithm Attribute with the applicable transformation algorithm.

 D string
P
M
Namespace (none)
Type
Extension of xs:string
Diagram
Transform Element
Overview
Transform Extension of xs:string

The element transform defines the type of transformation. It consists of an Algorithm Attribute with the applicable transformation algorithm.

 D string
P
M
Algorithm optional xs:anyURI

This attribute is used for defining a transformation algorithm by means of an URI.

 D anyURI
P
M
Attributes
Name Type Use Default Fixed Description
Algorithm xs:anyURI optional

This attribute is used for defining a transformation algorithm by means of an URI.

 D anyURI
P
M
Source
<xs:element name="Transform" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
See Also
Transforms Element | Reference Element | SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DigestMethod Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element > Reference Element : DigestMethod Element
Description
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.
Namespace (none)
Type
Extension of xs:string
Diagram
DigestMethod Element
Overview
DigestMethod Extension of xs:string
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.
Algorithm optional xs:anyURI

This attribute is used for defining the URI which identifies the message digest algorithm.

D anyURI
P
M
Attributes
Name Type Use Default Fixed Description
Algorithm xs:anyURI optional

This attribute is used for defining the URI which identifies the message digest algorithm.

D anyURI
P
M
Source
<xs:element name="DigestMethod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
See Also
Reference Element | SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DigestValue Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element > Reference Element : DigestValue Element
Description
The algorithm defined in the element DigestMethod is used for calculating the DigestValue, which is a unique hash value of the signed object and saved in base-64 encoding format. The hash value is a kind of digital finger print, in general it is shorter than the data which were signed. In this way the following steps of digital signature are accelerated. It is almost impossible to infer the original message from the given hash value. D string
P
M
Namespace (none)
Type
xs:string
Diagram
DigestValue Element
Overview
DigestValue xs:string
The algorithm defined in the element DigestMethod is used for calculating the DigestValue, which is a unique hash value of the signed object and saved in base-64 encoding format. The hash value is a kind of digital finger print, in general it is shorter than the data which were signed. In this way the following steps of digital signature are accelerated. It is almost impossible to infer the original message from the given hash value. D string
P
M
Source
<xs:element name="DigestValue" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Reference Element | SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SignatureValue Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element : SignatureValue Element
Description

The element SignatureValue contains the binary hash value of the signature (always Base-64 encoded) calculated over the complete element SignedInfo . This hash value is given according to the algorithm defined in the element SignatureMethod and calculated from the canonized data and the private key. In this way it is not the message itself which is signed but only its (normally shorter) hash value ( Hash-Then-Sign Paradigma).

The signed data contain all information about the signed references and their hash values. Therefore it is not necessary that the data themselves are available in the document. All information about the utilized algorithms are part of the signature generation and subsequent manipulations are avoided.

As all references are summarized before the signature generation the complete signature has always exactly one SignatureValue element.

D string
P
M
Namespace (none)
Type
xs:string
Diagram
SignatureValue Element
Overview
SignatureValue xs:string

The element SignatureValue contains the binary hash value of the signature (always Base-64 encoded) calculated over the complete element SignedInfo . This hash value is given according to the algorithm defined in the element SignatureMethod and calculated from the canonized data and the private key. In this way it is not the message itself which is signed but only its (normally shorter) hash value ( Hash-Then-Sign Paradigma).

The signed data contain all information about the signed references and their hash values. Therefore it is not necessary that the data themselves are available in the document. All information about the utilized algorithms are part of the signature generation and subsequent manipulations are avoided.

As all references are summarized before the signature generation the complete signature has always exactly one SignatureValue element.

D string
P
M
Source
<xs:element name="SignatureValue" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element : CATALOG Element
Description
All administrative information about the catalogue/ database is stored in this element.
Namespace (none)
Diagram
LANGUAGE Element Sequence CATALOG_INFO Element CATALOG_MARK Element FILE_ID Element DATA_VERSION Element LANGUAGE Element Sequence CATALOG_NAME Element MIN_MAJOR_NO Element CATALOG_YEAR Element CATALOG_NUMBER Element CATALOG_IDENTIFICATION Element FILE_RELEASE_DATE Element Sequence CATALOG Element
Overview
CATALOG
All administrative information about the catalogue/ database is stored in this element.
Sequence
FILE_RELEASE_DATE xs:dateTime
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contains the current date and time (UTC). D dateTime
P
M
CATALOG_IDENTIFICATION
This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
This element is used for the definition of the currency ID which applies to all prices given in a catalogue/ database. The rules and definitions of the ISO Currency-ID apply.
A change of currency keys within one database is not permitted. Updates during the year and also block prices haven to be given in the same currency unit as that of the basic file. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
For transnational catalogues with an identical currency key this element is used for assigning a database to one country by the different ISO country codes. D string
P [A-Z]{2}
M [2:2]
CATALOG_KIND Restriction of xs:positiveInteger

This field is used to identify association catalogues.
The following values can be used:
2 = association catalogue
3 = customer-specific catalogue

If 2 or 3 is entered in the field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

 D positiveInteger
P
M [2:3]
ASSOC_CTM_NO Restriction of xs:string
This element is used to specify the customer number of the Association or customer for which the data pool is available.
The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
This element is used for the definition of a price ID, i.e. the way in which the prices in a catalogue are given.

The following price IDs are possible:
1 = Price;
2 = Ident number;
3 = calculation point.

If the flags 1 (price) or 2 (ident number) are filled in, a currency has to be filled in the field CURRENCY_KEY. If the flag 3 (calculation point) is set, values in the element CURRENCY_KEY are not permitted. If calculation points are used the the conversion factor has to be defined. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
This element is used for the definition of the VAT key which is applied to the prices given in a database.
The following values are used:
0/False = prices excluding VAT
1/True = prices including VAT

This element is of essential importance for the pricing. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
This element defines a distinct number for the catalogue which is represented in the database. The catalogue number is manufacturer specific. D string
P
M [1:10]
CATALOG_YEAR xs:gYear
This element refers to the calendar year of the catalogue data in the main catalogue. D gYear
P
M
MIN_MAJOR_NO Restriction of xs:positiveInteger
The main catalogue's major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged. Element MIN_MAJOR_NO contains the minimum value of the main catalogues's MAJOR_NO. D positiveInteger
P
M 1:99
CATALOG_NAME languagetexte30 Complex Type
This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database. D date
P
M
FILE_ID Restriction of xs:boolean
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
This element is used to highlight the provision M data = data that has been modified from the main catalogue. D string
P [M]
M [1:1]
CATALOG_INFO languagetexte60999 Complex Type
Information texts are stored in this element.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FILE_RELEASE_DATE" type="xs:dateTime">
        <xs:annotation>
          <xs:documentation>100--2--Dateifreigabe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_ID">
              <xs:annotation>
                <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CURRENCY_KEY">
              <xs:annotation>
                <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{1,3}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--13--Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_KIND">
              <xs:annotation>
                <xs:documentation>Katalog-Art</xs:documentation>
                <xs:documentation>2 für Verbandskatalog</xs:documentation>
                <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
                <xs:documentation>geändert 17.04.2019</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="3" />
                  <xs:minInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ASSOC_CTM_NO">
              <xs:annotation>
                <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRODUCT_BRANDNAME">
              <xs:annotation>
                <xs:documentation>100--40--Produktmarke</xs:documentation>
                <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_ID">
              <xs:annotation>
                <xs:documentation>100--49--Preis_ID</xs:documentation>
                <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VAT">
              <xs:annotation>
                <xs:documentation>200--4--MwSt</xs:documentation>
                <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG_NUMBER">
        <xs:annotation>
          <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_YEAR" type="xs:gYear">
        <xs:annotation>
          <xs:documentation>Jahr der Neuerstellung</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="MIN_MAJOR_NO">
        <xs:annotation>
          <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_NAME" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>100--10--Katalog_Name</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="DATA_VERSION">
        <xs:annotation>
          <xs:documentation>100--11--Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILE_ID">
        <xs:annotation>
          <xs:documentation>100--14--Datei_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MARK">
        <xs:annotation>
          <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
          <xs:documentation>M = Modifikation</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[M]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_INFO" type="languagetexte60999">
        <xs:annotation>
          <xs:documentation>110--3--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_RELEASE_DATE Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : FILE_RELEASE_DATE Element
Description
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contains the current date and time (UTC). D dateTime
P
M
Namespace (none)
Type
xs:dateTime
Diagram
FILE_RELEASE_DATE Element
Overview
FILE_RELEASE_DATE xs:dateTime
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contains the current date and time (UTC). D dateTime
P
M
Source
<xs:element name="FILE_RELEASE_DATE" type="xs:dateTime" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--2--Dateifreigabe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_IDENTIFICATION Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : CATALOG_IDENTIFICATION Element
Description
This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.
Namespace (none)
Diagram
VAT Element PRICE_ID Element PRODUCT_BRANDNAME Element ASSOC_CTM_NO Element CATALOG_KIND Element COUNTRY_ID Element CURRENCY_KEY Element ISO_LANGUAGE_ID Element MANUFACTURER_ID Element Sequence CATALOG_IDENTIFICATION Element
Overview
CATALOG_IDENTIFICATION
This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
This element is used for the definition of the currency ID which applies to all prices given in a catalogue/ database. The rules and definitions of the ISO Currency-ID apply.
A change of currency keys within one database is not permitted. Updates during the year and also block prices haven to be given in the same currency unit as that of the basic file. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
For transnational catalogues with an identical currency key this element is used for assigning a database to one country by the different ISO country codes. D string
P [A-Z]{2}
M [2:2]
CATALOG_KIND Restriction of xs:positiveInteger

This field is used to identify association catalogues.
The following values can be used:
2 = association catalogue
3 = customer-specific catalogue

If 2 or 3 is entered in the field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

 D positiveInteger
P
M [2:3]
ASSOC_CTM_NO Restriction of xs:string
This element is used to specify the customer number of the Association or customer for which the data pool is available.
The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
This element is used for the definition of a price ID, i.e. the way in which the prices in a catalogue are given.

The following price IDs are possible:
1 = Price;
2 = Ident number;
3 = calculation point.

If the flags 1 (price) or 2 (ident number) are filled in, a currency has to be filled in the field CURRENCY_KEY. If the flag 3 (calculation point) is set, values in the element CURRENCY_KEY are not permitted. If calculation points are used the the conversion factor has to be defined. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
This element is used for the definition of the VAT key which is applied to the prices given in a database.
The following values are used:
0/False = prices excluding VAT
1/True = prices including VAT

This element is of essential importance for the pricing. 		D boolean
P
M
Source
<xs:element name="CATALOG_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_ID">
        <xs:annotation>
          <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
          <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CURRENCY_KEY">
        <xs:annotation>
          <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
          <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{1,3}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--13--Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_KIND">
        <xs:annotation>
          <xs:documentation>Katalog-Art</xs:documentation>
          <xs:documentation>2 für Verbandskatalog</xs:documentation>
          <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
          <xs:documentation>geändert 17.04.2019</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="3" />
            <xs:minInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ASSOC_CTM_NO">
        <xs:annotation>
          <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRODUCT_BRANDNAME">
        <xs:annotation>
          <xs:documentation>100--40--Produktmarke</xs:documentation>
          <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_ID">
        <xs:annotation>
          <xs:documentation>100--49--Preis_ID</xs:documentation>
          <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VAT">
        <xs:annotation>
          <xs:documentation>200--4--MwSt</xs:documentation>
          <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANUFACTURER_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : MANUFACTURER_ID Element
Description
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MANUFACTURER_ID Element
Overview
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="MANUFACTURER_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ISO_LANGUAGE_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ISO_LANGUAGE_ID Element
Description
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:language
Diagram
ISO_LANGUAGE_ID Element
Overview
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
    <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CURRENCY_KEY Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CURRENCY_KEY Element
Description
This element is used for the definition of the currency ID which applies to all prices given in a catalogue/ database. The rules and definitions of the ISO Currency-ID apply.
A change of currency keys within one database is not permitted. Updates during the year and also block prices haven to be given in the same currency unit as that of the basic file. 		D string
P [A-Z]{1,3}
M [1:3]
Namespace (none)
Type
Restriction of xs:string
Diagram
CURRENCY_KEY Element
Overview
CURRENCY_KEY Restriction of xs:string
This element is used for the definition of the currency ID which applies to all prices given in a catalogue/ database. The rules and definitions of the ISO Currency-ID apply.
A change of currency keys within one database is not permitted. Updates during the year and also block prices haven to be given in the same currency unit as that of the basic file. 		D string
P [A-Z]{1,3}
M [1:3]
Source
<xs:element name="CURRENCY_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
    <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{1,3}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COUNTRY_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : COUNTRY_ID Element
Description
For transnational catalogues with an identical currency key this element is used for assigning a database to one country by the different ISO country codes. D string
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:string
Diagram
COUNTRY_ID Element
Overview
COUNTRY_ID Restriction of xs:string
For transnational catalogues with an identical currency key this element is used for assigning a database to one country by the different ISO country codes. D string
P [A-Z]{2}
M [2:2]
Source
<xs:element name="COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--13--Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_KIND Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CATALOG_KIND Element
Description

This field is used to identify association catalogues.
The following values can be used:
2 = association catalogue
3 = customer-specific catalogue

If 2 or 3 is entered in the field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

 D positiveInteger
P
M [2:3]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
CATALOG_KIND Element
Overview
CATALOG_KIND Restriction of xs:positiveInteger

This field is used to identify association catalogues.
The following values can be used:
2 = association catalogue
3 = customer-specific catalogue

If 2 or 3 is entered in the field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

 D positiveInteger
P
M [2:3]
Source
<xs:element name="CATALOG_KIND" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Katalog-Art</xs:documentation>
    <xs:documentation>2 für Verbandskatalog</xs:documentation>
    <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
    <xs:documentation>geändert 17.04.2019</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="3" />
      <xs:minInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ASSOC_CTM_NO Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ASSOC_CTM_NO Element
Description
This element is used to specify the customer number of the Association or customer for which the data pool is available.
The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
ASSOC_CTM_NO Element
Overview
ASSOC_CTM_NO Restriction of xs:string
This element is used to specify the customer number of the Association or customer for which the data pool is available.
The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
Source
<xs:element name="ASSOC_CTM_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_BRANDNAME Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : PRODUCT_BRANDNAME Element
Description
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRODUCT_BRANDNAME Element
Overview
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
Source
<xs:element name="PRODUCT_BRANDNAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--40--Produktmarke</xs:documentation>
    <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : PRICE_ID Element
Description
This element is used for the definition of a price ID, i.e. the way in which the prices in a catalogue are given.

The following price IDs are possible:
1 = Price;
2 = Ident number;
3 = calculation point.

If the flags 1 (price) or 2 (ident number) are filled in, a currency has to be filled in the field CURRENCY_KEY. If the flag 3 (calculation point) is set, values in the element CURRENCY_KEY are not permitted. If calculation points are used the the conversion factor has to be defined. 		D positiveInteger
P
M [1:3]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRICE_ID Element
Overview
PRICE_ID Restriction of xs:positiveInteger
This element is used for the definition of a price ID, i.e. the way in which the prices in a catalogue are given.

The following price IDs are possible:
1 = Price;
2 = Ident number;
3 = calculation point.

If the flags 1 (price) or 2 (ident number) are filled in, a currency has to be filled in the field CURRENCY_KEY. If the flag 3 (calculation point) is set, values in the element CURRENCY_KEY are not permitted. If calculation points are used the the conversion factor has to be defined. 		D positiveInteger
P
M [1:3]
Source
<xs:element name="PRICE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--49--Preis_ID</xs:documentation>
    <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VAT Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : VAT Element
Description
This element is used for the definition of the VAT key which is applied to the prices given in a database.
The following values are used:
0/False = prices excluding VAT
1/True = prices including VAT

This element is of essential importance for the pricing. 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
VAT Element
Overview
VAT Restriction of xs:boolean
This element is used for the definition of the VAT key which is applied to the prices given in a database.
The following values are used:
0/False = prices excluding VAT
1/True = prices including VAT

This element is of essential importance for the pricing. 		D boolean
P
M
Source
<xs:element name="VAT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--4--MwSt</xs:documentation>
    <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_NUMBER Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : CATALOG_NUMBER Element
Description
This element defines a distinct number for the catalogue which is represented in the database. The catalogue number is manufacturer specific. D string
P
M [1:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_NUMBER Element
Overview
CATALOG_NUMBER Restriction of xs:string
This element defines a distinct number for the catalogue which is represented in the database. The catalogue number is manufacturer specific. D string
P
M [1:10]
Source
<xs:element name="CATALOG_NUMBER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_YEAR Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : CATALOG_YEAR Element
Description
This element refers to the calendar year of the catalogue data in the main catalogue. D gYear
P
M
Namespace (none)
Type
xs:gYear
Diagram
CATALOG_YEAR Element
Overview
CATALOG_YEAR xs:gYear
This element refers to the calendar year of the catalogue data in the main catalogue. D gYear
P
M
Source
<xs:element name="CATALOG_YEAR" type="xs:gYear" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Jahr der Neuerstellung</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MIN_MAJOR_NO Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : MIN_MAJOR_NO Element
Description
The main catalogue's major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged. Element MIN_MAJOR_NO contains the minimum value of the main catalogues's MAJOR_NO. D positiveInteger
P
M 1:99
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
MIN_MAJOR_NO Element
Overview
MIN_MAJOR_NO Restriction of xs:positiveInteger
The main catalogue's major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged. Element MIN_MAJOR_NO contains the minimum value of the main catalogues's MAJOR_NO. D positiveInteger
P
M 1:99
Source
<xs:element name="MIN_MAJOR_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_NAME Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : CATALOG_NAME Element
Description
This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.
Namespace (none)
Type
languagetexte30 Complex Type
Diagram
LANGUAGE Element Sequence CATALOG_NAME Element
Overview
CATALOG_NAME languagetexte30 Complex Type
This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="CATALOG_NAME" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--10--Katalog_Name</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte30 Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte30 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte30 Complex Type > LANGUAGE Element : TEXT Element
Description
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetexte30 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DATA_VERSION Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : DATA_VERSION Element
Description
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
DATA_VERSION Element
Overview
DATA_VERSION Restriction of xs:date
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database. D date
P
M
Source
<xs:element name="DATA_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--11--Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : FILE_ID Element
Description
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
FILE_ID Element
Overview
FILE_ID Restriction of xs:boolean
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data 		D boolean
P
M
Source
<xs:element name="FILE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--14--Datei_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_MARK Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : CATALOG_MARK Element
Description
This element is used to highlight the provision M data = data that has been modified from the main catalogue. D string
P [M]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_MARK Element
Overview
CATALOG_MARK Restriction of xs:string
This element is used to highlight the provision M data = data that has been modified from the main catalogue. D string
P [M]
M [1:1]
Source
<xs:element name="CATALOG_MARK" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
    <xs:documentation>M = Modifikation</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[M]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_INFO Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : CATALOG_INFO Element
Description
Information texts are stored in this element.
Namespace (none)
Type
languagetexte60999 Complex Type
Diagram
LANGUAGE Element Sequence CATALOG_INFO Element
Overview
CATALOG_INFO languagetexte60999 Complex Type
Information texts are stored in this element.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="CATALOG_INFO" type="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>110--3--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

REF_CATALOG Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element : REF_CATALOG Element
Description
This element is used to specify the catalogue to which the modification file relates.
Namespace (none)
Diagram
LANGUAGE Element Sequence CATALOG_NAME Element CATALOG_NUMBER Element CATALOG_IDENTIFICATION Element Sequence REF_CATALOG Element
Overview
REF_CATALOG
This element is used to specify the catalogue to which the modification file relates.
Sequence
CATALOG_IDENTIFICATION
This element is used to identify the catalogue to which this modification file relates. A catalogue is identified unequivocally by the combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data, the corresponding block data or the value settlement must be identical.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
This element is used to enter the manufacturer ID valid for the manufacturer. The manufacturer IDs are defined in the table "Manufacturer ID". Leading zeros are omitted in the manufacturer ID. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISOLanguage code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
This element is used to specify the correct country allocation where a language is spoken in multiple countries and the identical currency is specified. The ISO country code must be entered. D string
P [A-Z]{2}
M [2:2]
ASSOC_CTM_NO optional Restriction of xs:string
This element is used to specify the customer number of the Association or customer for which the data pool is available.
The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "codes for purchasing associations") Purchasing associations 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

The product brand assists in the unequivocal definition of a catalogue. It should be kept up-to-date in this element as required.

This is done by specifying a freely-definable number, which must remain identical for the validity of a product by across multiple catalogue rounds. This allows the software houses to allocate a catalogue to the previous year's catalogue, which in turn allows for a more efficient implementation of catalogues.

 D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
This element is used to specify a price ID used to define the types of prices in the data pool.

The following price IDs can be used:
1 = price;
2 = identification number;
3 = settlement point.

If 1 (price) or 2 (identification number) is entered in this field, a currency must be specified in the CURRENCY_KEY element. If 3 is entered in this element (settlement point), the CURRENCY_KEY element must be left blank. In the case of settlement points, the corresponding settlement factor must be specified. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
This element is used to specify the VAT ID used for pricing in the data pool.
The following values can be used:
0/False = exclusive of VAT
1/True = inclusive of VAT
This element is very important for pricing. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
CATALOG_NAME languagetexte30 Complex Type
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names with years are permitted as the unequivocal identification of the catalogue takes place via the PRODUCT_BRANDNAME element.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="REF_CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_ID">
              <xs:annotation>
                <xs:documentation>100--5--Hersteller_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CURRENCY_KEY">
              <xs:annotation>
                <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{1,3}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--13--Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ASSOC_CTM_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRODUCT_BRANDNAME">
              <xs:annotation>
                <xs:documentation>100--40--Produktmarke</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_ID">
              <xs:annotation>
                <xs:documentation>100--49--Preis_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VAT">
              <xs:annotation>
                <xs:documentation>200--4--MwSt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG_NUMBER">
        <xs:annotation>
          <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_NAME" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>100--10--Katalog_Name</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_IDENTIFICATION Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element : CATALOG_IDENTIFICATION Element
Description
This element is used to identify the catalogue to which this modification file relates. A catalogue is identified unequivocally by the combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data, the corresponding block data or the value settlement must be identical.
Namespace (none)
Diagram
VAT Element PRICE_ID Element PRODUCT_BRANDNAME Element ASSOC_CTM_NO Element COUNTRY_ID Element CURRENCY_KEY Element ISO_LANGUAGE_ID Element MANUFACTURER_ID Element Sequence CATALOG_IDENTIFICATION Element
Overview
CATALOG_IDENTIFICATION
This element is used to identify the catalogue to which this modification file relates. A catalogue is identified unequivocally by the combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data, the corresponding block data or the value settlement must be identical.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
This element is used to enter the manufacturer ID valid for the manufacturer. The manufacturer IDs are defined in the table "Manufacturer ID". Leading zeros are omitted in the manufacturer ID. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISOLanguage code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
This element is used to specify the correct country allocation where a language is spoken in multiple countries and the identical currency is specified. The ISO country code must be entered. D string
P [A-Z]{2}
M [2:2]
ASSOC_CTM_NO optional Restriction of xs:string
This element is used to specify the customer number of the Association or customer for which the data pool is available.
The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "codes for purchasing associations") Purchasing associations 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

The product brand assists in the unequivocal definition of a catalogue. It should be kept up-to-date in this element as required.

This is done by specifying a freely-definable number, which must remain identical for the validity of a product by across multiple catalogue rounds. This allows the software houses to allocate a catalogue to the previous year's catalogue, which in turn allows for a more efficient implementation of catalogues.

 D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
This element is used to specify a price ID used to define the types of prices in the data pool.

The following price IDs can be used:
1 = price;
2 = identification number;
3 = settlement point.

If 1 (price) or 2 (identification number) is entered in this field, a currency must be specified in the CURRENCY_KEY element. If 3 is entered in this element (settlement point), the CURRENCY_KEY element must be left blank. In the case of settlement points, the corresponding settlement factor must be specified. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
This element is used to specify the VAT ID used for pricing in the data pool.
The following values can be used:
0/False = exclusive of VAT
1/True = inclusive of VAT
This element is very important for pricing. 		D boolean
P
M
Source
<xs:element name="CATALOG_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_ID">
        <xs:annotation>
          <xs:documentation>100--5--Hersteller_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CURRENCY_KEY">
        <xs:annotation>
          <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{1,3}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--13--Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ASSOC_CTM_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRODUCT_BRANDNAME">
        <xs:annotation>
          <xs:documentation>100--40--Produktmarke</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_ID">
        <xs:annotation>
          <xs:documentation>100--49--Preis_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VAT">
        <xs:annotation>
          <xs:documentation>200--4--MwSt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANUFACTURER_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : MANUFACTURER_ID Element
Description
This element is used to enter the manufacturer ID valid for the manufacturer. The manufacturer IDs are defined in the table "Manufacturer ID". Leading zeros are omitted in the manufacturer ID. D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MANUFACTURER_ID Element
Overview
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
This element is used to enter the manufacturer ID valid for the manufacturer. The manufacturer IDs are defined in the table "Manufacturer ID". Leading zeros are omitted in the manufacturer ID. D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="MANUFACTURER_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--5--Hersteller_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ISO_LANGUAGE_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : ISO_LANGUAGE_ID Element
Description
The language code defines the language in which the texts in the data pool were created. The ISOLanguage code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:language
Diagram
ISO_LANGUAGE_ID Element
Overview
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISOLanguage code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CURRENCY_KEY Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : CURRENCY_KEY Element
Description
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
Namespace (none)
Type
Restriction of xs:string
Diagram
CURRENCY_KEY Element
Overview
CURRENCY_KEY Restriction of xs:string
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
Source
<xs:element name="CURRENCY_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{1,3}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COUNTRY_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : COUNTRY_ID Element
Description
This element is used to specify the correct country allocation where a language is spoken in multiple countries and the identical currency is specified. The ISO country code must be entered. D string
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:string
Diagram
COUNTRY_ID Element
Overview
COUNTRY_ID Restriction of xs:string
This element is used to specify the correct country allocation where a language is spoken in multiple countries and the identical currency is specified. The ISO country code must be entered. D string
P [A-Z]{2}
M [2:2]
Source
<xs:element name="COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--13--Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ASSOC_CTM_NO Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : ASSOC_CTM_NO Element
Description
This element is used to specify the customer number of the Association or customer for which the data pool is available.
The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "codes for purchasing associations") Purchasing associations 		D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
ASSOC_CTM_NO Element
Overview
ASSOC_CTM_NO optional Restriction of xs:string
This element is used to specify the customer number of the Association or customer for which the data pool is available.
The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "codes for purchasing associations") Purchasing associations 		D string
P
M [1:15]
Source
<xs:element name="ASSOC_CTM_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_BRANDNAME Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : PRODUCT_BRANDNAME Element
Description

The product brand assists in the unequivocal definition of a catalogue. It should be kept up-to-date in this element as required.

This is done by specifying a freely-definable number, which must remain identical for the validity of a product by across multiple catalogue rounds. This allows the software houses to allocate a catalogue to the previous year's catalogue, which in turn allows for a more efficient implementation of catalogues.

 D positiveInteger
P
M [1:999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRODUCT_BRANDNAME Element
Overview
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

The product brand assists in the unequivocal definition of a catalogue. It should be kept up-to-date in this element as required.

This is done by specifying a freely-definable number, which must remain identical for the validity of a product by across multiple catalogue rounds. This allows the software houses to allocate a catalogue to the previous year's catalogue, which in turn allows for a more efficient implementation of catalogues.

 D positiveInteger
P
M [1:999]
Source
<xs:element name="PRODUCT_BRANDNAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--40--Produktmarke</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : PRICE_ID Element
Description
This element is used to specify a price ID used to define the types of prices in the data pool.

The following price IDs can be used:
1 = price;
2 = identification number;
3 = settlement point.

If 1 (price) or 2 (identification number) is entered in this field, a currency must be specified in the CURRENCY_KEY element. If 3 is entered in this element (settlement point), the CURRENCY_KEY element must be left blank. In the case of settlement points, the corresponding settlement factor must be specified. 		D positiveInteger
P
M [1:3]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRICE_ID Element
Overview
PRICE_ID Restriction of xs:positiveInteger
This element is used to specify a price ID used to define the types of prices in the data pool.

The following price IDs can be used:
1 = price;
2 = identification number;
3 = settlement point.

If 1 (price) or 2 (identification number) is entered in this field, a currency must be specified in the CURRENCY_KEY element. If 3 is entered in this element (settlement point), the CURRENCY_KEY element must be left blank. In the case of settlement points, the corresponding settlement factor must be specified. 		D positiveInteger
P
M [1:3]
Source
<xs:element name="PRICE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--49--Preis_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VAT Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : VAT Element
Description
This element is used to specify the VAT ID used for pricing in the data pool.
The following values can be used:
0/False = exclusive of VAT
1/True = inclusive of VAT
This element is very important for pricing. 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
VAT Element
Overview
VAT Restriction of xs:boolean
This element is used to specify the VAT ID used for pricing in the data pool.
The following values can be used:
0/False = exclusive of VAT
1/True = inclusive of VAT
This element is very important for pricing. 		D boolean
P
M
Source
<xs:element name="VAT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--4--MwSt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_NUMBER Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element : CATALOG_NUMBER Element
Description
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_NUMBER Element
Overview
CATALOG_NUMBER Restriction of xs:string
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
Source
<xs:element name="CATALOG_NUMBER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_NAME Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element : CATALOG_NAME Element
Description
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names with years are permitted as the unequivocal identification of the catalogue takes place via the PRODUCT_BRANDNAME element.
Namespace (none)
Type
languagetexte30 Complex Type
Diagram
LANGUAGE Element Sequence CATALOG_NAME Element
Overview
CATALOG_NAME languagetexte30 Complex Type
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names with years are permitted as the unequivocal identification of the catalogue takes place via the PRODUCT_BRANDNAME element.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="CATALOG_NAME" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--10--Katalog_Name</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIES Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element : SERIES Element
Description
This element is used to specify all series of the catalogue/data pool that were modified from the base catalogue including their assigned elements, such as product groups or articles.
Namespace (none)
Diagram
SERIE Element Sequence SERIES Element
Overview
SERIES optional
This element is used to specify all series of the catalogue/data pool that were modified from the base catalogue including their assigned elements, such as product groups or articles.
Sequence
SERIE 1..100
This element is used to define the series that were modified from the base catalogue.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the serial number of the series. D nonNegativeInteger
P
M [0:99]
Sequence
SERIES_NAME optional
This element defines the name of the series.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element defines a text line.
The element TEXT contains text information.
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
PRODUCT_GROUPS
This element is used to reference to the product groups that were modified from the base catalogue.Articles with the same version types e.g. shelf units are grouped into product groups.
Sequence
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups in the base catalogue. "Identical" product groups must therefore not be captured.
Sequence
ITEMS
This element is used to reference all articles within a product group that are to be modified.
Sequence
ITEM 1..∞
This element is used to specify items and blocks with a different validity than in the base catalogue. An item is identified via the SERIE_NO and TYPE_NO attributes of the main catalogue.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. (e.g. U60). D string
P
M [1:15]
Sequence
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Source
<xs:element name="SERIES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE" maxOccurs="100">
        <xs:annotation>
          <xs:documentation>200--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIES_NAME" minOccurs="0">
              <xs:annotation>
                <xs:documentation>200--3--Serienname</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>200--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRODUCT_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEMS">
                          <xs:annotation>
                            <xs:documentation>400--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIE Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element : SERIE Element
Description
This element is used to define the series that were modified from the base catalogue.
Namespace (none)
Diagram
PRODUCT_GROUPS Element SERIES_NAME Element Sequence SERIE Element
Overview
SERIE 1..100
This element is used to define the series that were modified from the base catalogue.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute defines the serial number of the series. D nonNegativeInteger
P
M [0:99]
Sequence
SERIES_NAME optional
This element defines the name of the series.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element defines a text line.
The element TEXT contains text information.
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
PRODUCT_GROUPS
This element is used to reference to the product groups that were modified from the base catalogue.Articles with the same version types e.g. shelf units are grouped into product groups.
Sequence
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups in the base catalogue. "Identical" product groups must therefore not be captured.
Sequence
ITEMS
This element is used to reference all articles within a product group that are to be modified.
Sequence
ITEM 1..∞
This element is used to specify items and blocks with a different validity than in the base catalogue. An item is identified via the SERIE_NO and TYPE_NO attributes of the main catalogue.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. (e.g. U60). D string
P
M [1:15]
Sequence
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute defines the serial number of the series. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="SERIE" maxOccurs="100" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIES_NAME" minOccurs="0">
        <xs:annotation>
          <xs:documentation>200--3--Serienname</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>200--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRODUCT_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEMS">
                    <xs:annotation>
                      <xs:documentation>400--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIES_NAME Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element : SERIES_NAME Element
Description
This element defines the name of the series.
Namespace (none)
Diagram
LANGUAGE Element Sequence SERIES_NAME Element
Overview
SERIES_NAME optional
This element defines the name of the series.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element defines a text line.
The element TEXT contains text information.
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Source
<xs:element name="SERIES_NAME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--3--Serienname</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>200--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element : LANGUAGE Element
Description
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
Namespace (none)
Diagram
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element defines a text line.
The element TEXT contains text information.
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>200--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element : TEXT_LINE Element
Description
This element defines a text line.
The element TEXT contains text information.
Namespace (none)
Diagram
FULL_TEXT Element TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE
This element defines a text line.
The element TEXT contains text information.
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Source
<xs:element name="TEXT_LINE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Description
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FULL_TEXT Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : FULL_TEXT Element
Description
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Namespace (none)
Type
xs:string
Diagram
FULL_TEXT Element
Overview
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Source
<xs:element name="FULL_TEXT" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUPS Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element : PRODUCT_GROUPS Element
Description
This element is used to reference to the product groups that were modified from the base catalogue.Articles with the same version types e.g. shelf units are grouped into product groups.
Namespace (none)
Diagram
PRODUCT_GROUP Element Sequence PRODUCT_GROUPS Element
Overview
PRODUCT_GROUPS
This element is used to reference to the product groups that were modified from the base catalogue.Articles with the same version types e.g. shelf units are grouped into product groups.
Sequence
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups in the base catalogue. "Identical" product groups must therefore not be captured.
Sequence
ITEMS
This element is used to reference all articles within a product group that are to be modified.
Sequence
ITEM 1..∞
This element is used to specify items and blocks with a different validity than in the base catalogue. An item is identified via the SERIE_NO and TYPE_NO attributes of the main catalogue.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. (e.g. U60). D string
P
M [1:15]
Sequence
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Source
<xs:element name="PRODUCT_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEMS">
              <xs:annotation>
                <xs:documentation>400--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUP Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element : PRODUCT_GROUP Element
Description
This element is used to create modified items that are combined in product groups in the base catalogue. "Identical" product groups must therefore not be captured.
Namespace (none)
Diagram
ITEMS Element Sequence PRODUCT_GROUP Element
Overview
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups in the base catalogue. "Identical" product groups must therefore not be captured.
Sequence
ITEMS
This element is used to reference all articles within a product group that are to be modified.
Sequence
ITEM 1..∞
This element is used to specify items and blocks with a different validity than in the base catalogue. An item is identified via the SERIE_NO and TYPE_NO attributes of the main catalogue.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. (e.g. U60). D string
P
M [1:15]
Sequence
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Source
<xs:element name="PRODUCT_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEMS">
        <xs:annotation>
          <xs:documentation>400--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEMS Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : ITEMS Element
Description
This element is used to reference all articles within a product group that are to be modified.
Namespace (none)
Diagram
ITEM Element Sequence ITEMS Element
Overview
ITEMS
This element is used to reference all articles within a product group that are to be modified.
Sequence
ITEM 1..∞
This element is used to specify items and blocks with a different validity than in the base catalogue. An item is identified via the SERIE_NO and TYPE_NO attributes of the main catalogue.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. (e.g. U60). D string
P
M [1:15]
Sequence
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Source
<xs:element name="ITEMS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element : ITEM Element
Description
This element is used to specify items and blocks with a different validity than in the base catalogue. An item is identified via the SERIE_NO and TYPE_NO attributes of the main catalogue.
Namespace (none)
Diagram
VALID_UNTIL Element VALID_FROM Element Sequence ITEM Element
Overview
ITEM 1..∞
This element is used to specify items and blocks with a different validity than in the base catalogue. An item is identified via the SERIE_NO and TYPE_NO attributes of the main catalogue.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
This element is used to enter the item code. (e.g. U60). D string
P
M [1:15]
Sequence
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify the serial number of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO Restriction of xs:string required
This element is used to enter the item code. (e.g. U60). D string
P
M [1:15]
Source
<xs:element name="ITEM" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_FROM Element
Description
This element specifies the date on which the item becomes available for delivery.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
This element specifies the date on which the item becomes available for delivery.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. 		D date
P
M
Source
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_UNTIL Element
Description
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Source
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_DEFINITION Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element : FEATURE_DEFINITION Element
Description
This element is used to specify version-specific information that is to be modified.
Namespace (none)
Diagram
FEATURES Element Sequence FEATURE_DEFINITION Element
Overview
FEATURE_DEFINITION optional
This element is used to specify version-specific information that is to be modified.
Sequence
FEATURES
This element is used to define the version types (FEATURE) and the associated versions to be modified. Only version types that are required for modifying the catalogue are specified.
Sequence
FEATURE 1..∞
This element is used to define a version type.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a feature. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
This element is used as a container for all possible options of a feature type.
Sequence
OPTION 1..∞
This element is used to define the versions for version type. This element is used to store all versions to be modified in the data pool.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required. D string
P
M [1:5]
Sequence
OPTION_TEXT optional languagetexte60 Complex Type
This element is used to define a modified version text.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element is used to modify a general comment as a notice of special properties of a version. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
VALID_FROM optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FRONT element is filled: available from delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
VALID_UNTIL optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FROM element is filled: on available for delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
Source
<xs:element name="FEATURE_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURES">
        <xs:annotation>
          <xs:documentation>250--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>250--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURES Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element : FEATURES Element
Description
This element is used to define the version types (FEATURE) and the associated versions to be modified. Only version types that are required for modifying the catalogue are specified.
Namespace (none)
Diagram
FEATURE Element Sequence FEATURES Element
Overview
FEATURES
This element is used to define the version types (FEATURE) and the associated versions to be modified. Only version types that are required for modifying the catalogue are specified.
Sequence
FEATURE 1..∞
This element is used to define a version type.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a feature. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
This element is used as a container for all possible options of a feature type.
Sequence
OPTION 1..∞
This element is used to define the versions for version type. This element is used to store all versions to be modified in the data pool.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required. D string
P
M [1:5]
Sequence
OPTION_TEXT optional languagetexte60 Complex Type
This element is used to define a modified version text.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element is used to modify a general comment as a notice of special properties of a version. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FRONT element is filled: available from delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
VALID_UNTIL optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FROM element is filled: on available for delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
Source
<xs:element name="FEATURES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>250--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element : FEATURE Element
Description
This element is used to define a version type.
Namespace (none)
Diagram
OPTIONS Element Sequence FEATURE Element
Overview
FEATURE 1..∞
This element is used to define a version type.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute identifies a feature. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
This element is used as a container for all possible options of a feature type.
Sequence
OPTION 1..∞
This element is used to define the versions for version type. This element is used to store all versions to be modified in the data pool.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required. D string
P
M [1:5]
Sequence
OPTION_TEXT optional languagetexte60 Complex Type
This element is used to define a modified version text.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element is used to modify a general comment as a notice of special properties of a version. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FRONT element is filled: available from delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
VALID_UNTIL optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FROM element is filled: on available for delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute identifies a feature. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="FEATURE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>250--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTIONS Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : OPTIONS Element
Description
This element is used as a container for all possible options of a feature type.
Namespace (none)
Diagram
OPTION Element Sequence OPTIONS Element
Overview
OPTIONS optional
This element is used as a container for all possible options of a feature type.
Sequence
OPTION 1..∞
This element is used to define the versions for version type. This element is used to store all versions to be modified in the data pool.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required. D string
P
M [1:5]
Sequence
OPTION_TEXT optional languagetexte60 Complex Type
This element is used to define a modified version text.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element is used to modify a general comment as a notice of special properties of a version. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FRONT element is filled: available from delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
VALID_UNTIL optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FROM element is filled: on available for delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
Source
<xs:element name="OPTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element : OPTION Element
Description
This element is used to define the versions for version type. This element is used to store all versions to be modified in the data pool.
Namespace (none)
Diagram
VALID_UNTIL Element VALID_FROM Element LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element LANGUAGE Element Sequence OPTION_TEXT Element Sequence OPTION Element
Overview
OPTION 1..∞
This element is used to define the versions for version type. This element is used to store all versions to be modified in the data pool.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required. D string
P
M [1:5]
Sequence
OPTION_TEXT optional languagetexte60 Complex Type
This element is used to define a modified version text.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element is used to modify a general comment as a notice of special properties of a version. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FRONT element is filled: available from delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
VALID_UNTIL optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FROM element is filled: on available for delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required. D string
P
M [1:5]
Source
<xs:element name="OPTION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_TEXT Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_TEXT Element
Description
This element is used to define a modified version text.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence OPTION_TEXT Element
Overview
OPTION_TEXT optional languagetexte60 Complex Type
This element is used to define a modified version text.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_COMMENT_TEXT Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_COMMENT_TEXT Element
Description
This element is used to modify a general comment as a notice of special properties of a version. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element
Overview
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
This element is used to modify a general comment as a notice of special properties of a version. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_FROM Element
Description

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FRONT element is filled: available from delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FRONT element is filled: available from delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
Source
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_UNTIL Element
Description

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FROM element is filled: on available for delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date

These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

  • Both elements filled: available for delivery in the resulting period.
    Both elements left blank: always available for delivery.
  • Only the VALID_FROM element is filled: on available for delivery from this date onwards.
  • Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.

 D date
P
M
Source
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_DEFINITION Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element : PRICE_DEFINITION Element
Description
This element is used to specify information for the catalogue modification that is necessary for the price calculation, such as price tables and design ranges.
Namespace (none)
Diagram
PRICE_FEATURE_GROUPS Element Sequence PRICE_DEFINITION Element
Overview
PRICE_DEFINITION optional
This element is used to specify information for the catalogue modification that is necessary for the price calculation, such as price tables and design ranges.
Sequence
PRICE_FEATURE_GROUPS
This element is used to reference price version groups that are modified from the base catalogue.
Sequence
PRICE_FEATURE_GROUP 1..∞
This element is used to reference a price version group that contains information on modifications from the base catalogue.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine zu modifizierende PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
Sequence
FINISH 0..∞
This element is used to assign version combinations to modified price fields (price field, block price field) and a manufacturer price group.
Sequence
OPTION_REF 0..2
This element is used to reference a version.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a version type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used to reference a version type. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1or path 2 in the base catalogue).
Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

This field is used to specify in which modified price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2 in the base catalogue).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer does not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
This catalogue is used to specify the manufacturer's modified price group.

In the case of type-specific prices (PRICE_CALC_METHOD = 3), the value of the PRICE_FIELD element is "copied" into field SUPPLIER_PRICE_GROUP.
For universal prices (PRICE_CALC_METHOD = 1), any content can be used and will not be analysed. 		D string
P
M [1:10]
Source
<xs:element name="PRICE_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>300--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
                          <xs:annotation>
                            <xs:documentation>311--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>311--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>311--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_FIELD">
                          <xs:annotation>
                            <xs:documentation>311--5--Preisfeld</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="SUPPLIER_PRICE_GROUP">
                          <xs:annotation>
                            <xs:documentation>311--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="10" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUPS Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element : PRICE_FEATURE_GROUPS Element
Description
This element is used to reference price version groups that are modified from the base catalogue.
Namespace (none)
Diagram
PRICE_FEATURE_GROUP Element Sequence PRICE_FEATURE_GROUPS Element
Overview
PRICE_FEATURE_GROUPS
This element is used to reference price version groups that are modified from the base catalogue.
Sequence
PRICE_FEATURE_GROUP 1..∞
This element is used to reference a price version group that contains information on modifications from the base catalogue.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine zu modifizierende PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
Sequence
FINISH 0..∞
This element is used to assign version combinations to modified price fields (price field, block price field) and a manufacturer price group.
Sequence
OPTION_REF 0..2
This element is used to reference a version.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a version type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used to reference a version type. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1or path 2 in the base catalogue).
Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

This field is used to specify in which modified price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2 in the base catalogue).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer does not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
This catalogue is used to specify the manufacturer's modified price group.

In the case of type-specific prices (PRICE_CALC_METHOD = 3), the value of the PRICE_FIELD element is "copied" into field SUPPLIER_PRICE_GROUP.
For universal prices (PRICE_CALC_METHOD = 1), any content can be used and will not be analysed. 		D string
P
M [1:10]
Source
<xs:element name="PRICE_FEATURE_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>300--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
                    <xs:annotation>
                      <xs:documentation>311--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>311--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>311--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_FIELD">
                    <xs:annotation>
                      <xs:documentation>311--5--Preisfeld</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="SUPPLIER_PRICE_GROUP">
                    <xs:annotation>
                      <xs:documentation>311--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="10" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUP Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element : PRICE_FEATURE_GROUP Element
Description
This element is used to reference a price version group that contains information on modifications from the base catalogue.
Namespace (none)
Diagram
FINISH Element Sequence PRICE_FEATURE_GROUP Element
Overview
PRICE_FEATURE_GROUP 1..∞
This element is used to reference a price version group that contains information on modifications from the base catalogue.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine zu modifizierende PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
Sequence
FINISH 0..∞
This element is used to assign version combinations to modified price fields (price field, block price field) and a manufacturer price group.
Sequence
OPTION_REF 0..2
This element is used to reference a version.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a version type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used to reference a version type. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1or path 2 in the base catalogue).
Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

This field is used to specify in which modified price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2 in the base catalogue).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer does not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
This catalogue is used to specify the manufacturer's modified price group.

In the case of type-specific prices (PRICE_CALC_METHOD = 3), the value of the PRICE_FIELD element is "copied" into field SUPPLIER_PRICE_GROUP.
For universal prices (PRICE_CALC_METHOD = 1), any content can be used and will not be analysed. 		D string
P
M [1:10]
Attributes
Name Type Use Default Fixed Description
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine zu modifizierende PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
Source
<xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>300--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
              <xs:annotation>
                <xs:documentation>311--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>311--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>311--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>311--5--Preisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="SUPPLIER_PRICE_GROUP">
              <xs:annotation>
                <xs:documentation>311--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FINISH Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element : FINISH Element
Description
This element is used to assign version combinations to modified price fields (price field, block price field) and a manufacturer price group.
Namespace (none)
Diagram
SUPPLIER_PRICE_GROUP Element BLOCK_PRICE_FIELD Element PRICE_FIELD Element OPTION_REF Element Sequence FINISH Element
Overview
FINISH 0..∞
This element is used to assign version combinations to modified price fields (price field, block price field) and a manufacturer price group.
Sequence
OPTION_REF 0..2
This element is used to reference a version.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a version type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used to reference a version type. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1or path 2 in the base catalogue).
Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

This field is used to specify in which modified price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2 in the base catalogue).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer does not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
This catalogue is used to specify the manufacturer's modified price group.

In the case of type-specific prices (PRICE_CALC_METHOD = 3), the value of the PRICE_FIELD element is "copied" into field SUPPLIER_PRICE_GROUP.
For universal prices (PRICE_CALC_METHOD = 1), any content can be used and will not be analysed. 		D string
P
M [1:10]
Source
<xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
        <xs:annotation>
          <xs:documentation>311--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>311--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>311--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>311--5--Preisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="SUPPLIER_PRICE_GROUP">
        <xs:annotation>
          <xs:documentation>311--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : OPTION_REF Element
Description
This element is used to reference a version.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF 0..2
This element is used to reference a version.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to reference a version type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
This attribute is used to reference a version type. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to reference a version type. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
This attribute is used to reference a version type. D string
P
M [1:5]
Source
<xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>311--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>311--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FIELD Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : PRICE_FIELD Element
Description

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1or path 2 in the base catalogue).
Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1or path 2 in the base catalogue).
Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
Source
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--5--Preisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_PRICE_FIELD Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : BLOCK_PRICE_FIELD Element
Description

This field is used to specify in which modified price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2 in the base catalogue).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer does not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

 D nonNegativeInteger
P
M [1:250]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BLOCK_PRICE_FIELD Element
Overview
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

This field is used to specify in which modified price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2 in the base catalogue).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer does not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

 D nonNegativeInteger
P
M [1:250]
Source
<xs:element name="BLOCK_PRICE_FIELD" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUPPLIER_PRICE_GROUP Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : SUPPLIER_PRICE_GROUP Element
Description
This catalogue is used to specify the manufacturer's modified price group.

In the case of type-specific prices (PRICE_CALC_METHOD = 3), the value of the PRICE_FIELD element is "copied" into field SUPPLIER_PRICE_GROUP.
For universal prices (PRICE_CALC_METHOD = 1), any content can be used and will not be analysed. 		D string
P
M [1:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
SUPPLIER_PRICE_GROUP Element
Overview
SUPPLIER_PRICE_GROUP Restriction of xs:string
This catalogue is used to specify the manufacturer's modified price group.

In the case of type-specific prices (PRICE_CALC_METHOD = 3), the value of the PRICE_FIELD element is "copied" into field SUPPLIER_PRICE_GROUP.
For universal prices (PRICE_CALC_METHOD = 1), any content can be used and will not be analysed. 		D string
P
M [1:10]
Source
<xs:element name="SUPPLIER_PRICE_GROUP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%ItemTitle%%

Modification IDM 2.7.0 XML schema documentation
Type of data
View with Navigation Tools

Special types of data have been defined for element references depending on language.


%%LocalItemTitle%%

languagetexte Complex Type
Modifikation IDM 2.7.0 XML-Schema : languagetexte Complex Type
Description

This data type is used for multilingual text information of any length.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte Complex Type
Overview
languagetexte

This data type is used for multilingual text information of any length.

Sequence
LANGUAGE 1..∞
This element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:complexType name="languagetexte" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT" type="xs:string">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte Complex Type : LANGUAGE Element
Description
This element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:string">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte Complex Type > LANGUAGE Element : TEXT Element
Description

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Namespace (none)
Type
xs:string
Diagram
TEXT Element
Overview
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="TEXT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
LANGUAGE Element | languagetexte Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte30 Complex Type
Modifikation IDM 2.7.0 XML-Schema : languagetexte30 Complex Type
Description

This element is used for multilingual text information limited to 30 characters.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte30 Complex Type
Overview
languagetexte30

This element is used for multilingual text information limited to 30 characters.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Used By
CATALOG_NAME Element
CATALOG_NAME Element
Source
<xs:complexType name="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 30stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,30}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte40 Complex Type
Modifikation IDM 2.7.0 XML-Schema : languagetexte40 Complex Type
Description

This element is used for multilingual text information limited to 40 characters.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte40 Complex Type
Overview
languagetexte40

This element is used for multilingual text information limited to 40 characters.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Source
<xs:complexType name="languagetexte40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 40stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,40}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte40 Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,40}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte40 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte40 Complex Type > LANGUAGE Element : TEXT Element
Description
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,40}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetexte40 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte60 Complex Type
Modifikation IDM 2.7.0 XML-Schema : languagetexte60 Complex Type
Description

This element is used for multilingual text information limited to 60 characters.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte60 Complex Type
Overview
languagetexte60

This element is used for multilingual text information limited to 60 characters.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Used By
OPTION_TEXT Element
OPTION_COMMENT_TEXT Element
Source
<xs:complexType name="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>265--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,60}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte60 Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte60 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte60 Complex Type > LANGUAGE Element : TEXT Element
Description
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetexte60 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte60999 Complex Type
Modifikation IDM 2.7.0 XML-Schema : languagetexte60999 Complex Type
Description

This element is used for multilingual text information limited to 60 characters per line. The maximum length of the complete element is limited to 999 lines.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte60999 Complex Type
Overview
languagetexte60999

This element is used for multilingual text information limited to 60 characters per line. The maximum length of the complete element is limited to 999 lines.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Used By
CATALOG_INFO Element
Source
<xs:complexType name="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelligen Zeilen</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT_LINE" maxOccurs="999">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="TEXT">
                  <xs:annotation>
                    <xs:documentation>265--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[\S ]{1,60}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
              </xs:sequence>
              <xs:attribute name="SEQUENCE_NO" use="required">
                <xs:annotation>
                  <xs:documentation>150--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger" />
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte60999 Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
Namespace (none)
Diagram
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="999">
        <xs:annotation>
          <xs:documentation>150--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>265--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,60}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte60999 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte60999 Complex Type > LANGUAGE Element : TEXT_LINE Element
Description
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
Namespace (none)
Diagram
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..999
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
SEQUENCE_NO Restriction of xs:positiveInteger required
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Source
<xs:element name="TEXT_LINE" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
LANGUAGE Element | languagetexte60999 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte60999 Complex Type > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Description
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | languagetexte60999 Complex Type | Modifikation IDM 2.7.0 XML-Schema